Cisco Nexus 5000 Series NX-OS レイヤ 2 インターフェイス コマンド リファレンス Cisco NX-OS Release 4.x、5.x
S コマンド
S コマンド
発行日;2012/06/17 | 英語版ドキュメント(2012/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

S コマンド

shut(ERSPAN)

shutdown

shutdown(VLAN コンフィギュレーション)

slot

snmp-server enable traps vtp

source(SPAN、ERSPAN)

spanning-tree bridge assurance

spanning-tree bpdufilter

spanning-tree bpduguard

spanning-tree cost

spanning-tree domain

spanning-tree guard

spanning-tree link-type

spanning-tree loopguard default

spanning-tree mode

spanning-tree mst configuration

spanning-tree mst cost

spanning-tree mst forward-time

spanning-tree mst hello-time

spanning-tree mst max-age

spanning-tree mst max-hops

spanning-tree mst port-priority

spanning-tree mst pre-standard

spanning-tree mst priority

spanning-tree mst root

spanning-tree mst simulate pvst

spanning-tree mst simulate pvst global

spanning-tree pathcost method

spanning-tree port-priority

spanning-tree port type edge

spanning-tree port type edge bpdufilter default

spanning-tree port type edge bpduguard default

spanning-tree port type edge default

spanning-tree port type network

spanning-tree port type network default

spanning-tree port type normal

spanning-tree pseudo-information

spanning-tree vlan

spanning-tree vlan cost

spanning-tree vlan port-priority

speed(インターフェイス)

state

svi enable

svs connection

svs veth auto-delete

svs veth auto-setup

switchport access vlan

switchport backup interface

switchport block

switchport host

switchport mode

switchport mode private-vlan host

switchport mode private-vlan promiscuous

switchport mode private-vlan trunk

switchport monitor rate-limit

switchport port-security

switchport port-security aging

switchport port-security mac-address

switchport port-security maximum

switchport port-security violation

switchport priority extend

switchport private-vlan association trunk

switchport private-vlan host-association

switchport private-vlan mapping

switchport private-vlan trunk allowed vlan

switchport private-vlan trunk native

switchport trunk allowed vlan

switchport trunk native vlan

switchport voice vlan

system private-vlan fex trunk

S コマンド

この章では、S で始まる Cisco NX-OS イーサネット コマンドおよび仮想イーサネット コマンドについて説明します。

shut(ERSPAN)

Encapsulated Remote Switched Port Analyzer(ERSPAN)セッションをシャット ダウンするには、 shut コマンドを使用します。ERSPAN セッションをイネーブルにするには、このコマンドの no 形式を使用します。

shut

no shut

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

ERSPAN セッション コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、ERSPAN セッションをシャットダウンする例を示します。

switch# configure terminal
switch(config)# monitor session 1 type erspan-source
switch(config-erspan-src)# shut
switch(config-erspan-src)#
 

次に、ERSPAN セッションをイネーブルにする例を示します。

switch# configure terminal
switch(config)# monitor session 1 type erspan-source
switch(config-erspan-src)# no shut
switch(config-erspan-src)#
 

 
関連コマンド

コマンド
説明

monitor session

モニタ コンフィギュレーション モードを開始します。

show monitor session

仮想 SPAN または ERSPAN のコンフィギュレーションを表示します。

 

shutdown

インターフェイス上のローカル トラフィックをシャット ダウンするには、 shutdown コマンドを使用します。インターフェイスをデフォルトの動作ステートに戻すには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

シャットダウンしません。

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスおよびサブインターフェイスのサポートが追加されました。

5.1(3)N1(1)

仮想イーサネット インターフェイスのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、次のインターフェイスで使用できます。

レイヤ 2 インターフェイス(イーサネット インターフェイス、EtherChannel インターフェイス、サブインターフェイス)

レイヤ 3 インターフェイス


) インターフェイスをレイヤ 3 インターフェイスとして設定するには、no switchport コマンドを使用します。


レイヤ 3 サブインターフェイス

管理インターフェイス

仮想イーサネット インターフェイス

次に、レイヤ 2 インターフェイスをシャットダウン(ディセーブル)する例を示します。

switch(config)# interface ethernet 1/10
switch(config-if)# shutdown
switch(config-if)#
 

次に、レイヤ 3 イーサネット サブインターフェイスをシャットダウンする例を示します。

switch(config)# interface ethernet 1/5.1
switch(config-subif)# shutdown
switch(config-subif)#
 

次に、仮想イーサネット インターフェイスをシャット ダウンする例を示します。

switch(config)# interface vethernet 10
switch(config-if)# shutdown
switch(config-if)#
 

 
関連コマンド

コマンド
説明

no switchport

インターフェイスをレイヤ 3 ルーテッド インターフェイスに変換します。

show interface ethernet

イーサネット インターフェイス コンフィギュレーション情報を表示します。

show interface port-channel

指定の EtherChannel インターフェイスのトラフィックに関する情報を表示します。

show interface vethernet

仮想イーサネット インターフェイスのコンフィギュレーション情報を表示します。

 

shutdown(VLAN コンフィギュレーション)

VLAN 上のローカル トラフィックをシャットダウンするには、 shutdown コマンドを使用します。VLAN をデフォルトの動作ステートに戻すには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

シャットダウンしません。

 
コマンド モード

VLAN コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

VLAN 1 または VLAN 1006 ~ 4094 は、シャットダウンしたりディセーブルにしたりできません。

VLAN をシャットダウンすると、その VLAN 上でのトラフィック フローが終了します。その VLAN 上のアクセス ポートもダウンします。トランク ポートは、そのポートで許可されている他の VLAN へのトラフィック伝送を継続します。ただし、指定の VLAN のインターフェイス関連付けは保持されます。その指定の VLAN を再度イネーブルにするか再作成すると、スイッチによってその VLAN の元のポートがすべて自動的に復元されます。

VLAN が内部的にシャットダウンされているかどうかを調べるには、 show vlan コマンド出力の Status フィールドを確認します。VLAN が内部的にシャットダウンされている場合は、Status フィールドに次の値のいずれか 1 つが表示されます。

act/lshut:VLAN ステータスはアクティブで、内部的にシャットダウンされています。

sus/lshut:VLAN ステータスは一時停止で、内部的にシャットダウンされています。


) VLAN が一時停止およびシャットダウンされている場合は、no shutdown および state active コマンドの両方を使用して VLAN をアクティブ ステートに戻します。


次に、VLAN をシャットダウンまたはディセーブルにした後、VLAN 2 上のローカル トラフィックを復元する例を示します。

switch(config)# vlan 2
switch(config-vlan)# no shutdown
 

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

slot

シャーシのスロットの事前プロビジョニングをイネーブルにするには、 slot コマンドを使用します。スロットの事前プロビジョニングをディセーブルにするには、このコマンドの no 形式を使用します。

slot slot-number

no slot slot-number

 
構文の説明

slot-number

シャーシのスロット番号。有効な範囲は 2 ~ 199 です。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード
コンフィギュレーション同期モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、シャーシのスロットでモジュールの機能またはインターフェイスの事前プロビジョニングをイネーブルにするために使用します。事前プロビジョニングにより、モジュールをスイッチのシャーシに挿入する前に、モジュールの機能またはインターフェイス(イーサネット、ファイバ チャネル)を設定できます。

次に、シャーシのスロットでモジュールの事前プロビジョニングをイネーブルにする例を示します。

switch(config)# slot 2
switch(config-slot)#
 

次に、シャーシのスロットでモジュールの事前プロビジョニングがイネーブルになるようにスイッチ プロファイルを設定する例を示します。

switch# config sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile sp
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# slot 2
switch(config-sync-sp-slot)#
 

次に、シャーシのスロットでモジュールの事前プロビジョニングをディセーブルにする例を示します。

switch(config)# no slot 2
switch(config)#
 

 
関連コマンド

コマンド
説明

port

ポートをイーサネット、ネイティブ ファイバ チャネル、または Fibre Channel over Ethernet(FCoE)ポートとして設定します。

provision

スロット内のモジュールの事前プロビジョニングを行います。

show running-config exclude-provision

事前プロビジョニングされた機能を除く実行コンフィギュレーションを表示します。

snmp-server enable traps vtp

VLAN トランキング プロトコル(VTP)ドメインで簡易ネットワーク管理プロトコル(SNMP)通知をイネーブルにするには、 snmp-server enable traps vtp コマンドを使用します。VTP ドメインで SNMP 通知をディセーブルにするには、このコマンドの no 形式を使用します。

snmp-server enable traps vtp

no snmp-server enable traps vtp

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

snmp-server enable traps コマンドは、設定されている通知ホスト レシーバに応じて、トラップとインフォームの両方をイネーブルにします。

次に、VTP ドメインで SNMP 通知をイネーブルにする例を示します。

switch(config)# snmp-server enable traps vtp
switch(config)#
 

次に、VTP ドメインですべての SNMP 通知をディセーブルにする例を示します。

switch(config)# no snmp-server enable traps vtp
switch(config)#
 

 
関連コマンド

コマンド
説明

show snmp trap

イネーブルまたはディセーブルである SNMP 通知を表示します。

show vtp status

VTP 情報を表示します。

source(SPAN、ERSPAN)

イーサネット スイッチド ポート アナライザ(SPAN)または Encapsulated Remote Switched Port Analyzer(ERSPAN)の送信元ポートを追加するには、 source コマンドを使用します。SPAN または ERSPAN の送信元ポートを削除するには、このコマンドの no 形式を使用します。

source { interface { ethernet slot / port | port-channel channel-num | vethernet veth-num } [{ both | rx | tx }] | vlan vlan-num | vsan vsan-num }

no source { interface { ethernet slot / port | port-channel channel-num | vethernet veth-num } | vlan vlan-num | vsan vsan-num }

 
構文の説明

interface

インターフェイス タイプを送信元 SPAN ポートとして使用するように指定します。

ethernet slot / port

イーサネット インターフェイスを送信元 SPAN ポートとして使用するように指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

port-channel channel-num

EtherChannel インターフェイスを送信元 SPAN ポートとして使用するように指定します。EtherChannel 番号の範囲は 1 ~ 4096 です。

vethernet veth-num

SPAN または ERSPAN の送信元ポートとして使用する仮想イーサネット インターフェイスを指定します。仮想イーサネット インターフェイスの番号は 1~1048575 です。

both

(任意)送信元ポートに入力トラフィックと出力トラフィックの両方を指定します。

(注) このキーワードは、ERSPAN 送信元ポートに適用されます。

rx

(任意)送信元ポートに入力トラフィックのみを指定します。

(注) このキーワードは、ERSPAN 送信元ポートに適用されます。

tx

(任意)送信元ポートに出力トラフィックのみを指定します。

(注) このキーワードは、ERSPAN 送信元ポートに適用されます。

vlan vlan-num

VLAN インターフェイスを送信元 SPAN ポートとして使用するように指定します。有効な範囲は 1 ~ 3967 および 4048 ~ 4093 です。

vsan vsan-num

仮想ストレージ エリア ネットワーク(VSAN)を送信元 SPAN ポートとして使用するように指定します。有効な範囲は 1 ~ 4093 です。

 
コマンド デフォルト

なし

 
コマンド モード

SPAN セッション コンフィギュレーション モード
ERSPAN セッション コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(2)N1(1)

ポート チャネルおよび SAN ポート チャネル インターフェイスは入力または出力送信元ポートとして設定できます。

モニタ セッションの出力(TX)送信元の数に対する制限がなくなりました。

5.1(3)N1(1)

仮想イーサネット インターフェイスおよび ERSPAN のサポートが追加されました。

 
使用上のガイドライン

送信元ポート(別名 モニタ対象ポート )は、ネットワーク トラフィック分析のためにモニタリングするスイッチド ポートです。単一のローカル SPAN セッションで、受信(Rx)、送信(Tx)、または双方向(both)の送信元ポート トラフィックをモニタできます。

送信元ポートには、イーサネット ポート、ポート チャネル、SAN ポート チャネル、VLAN、または VSAN ポートを使用できます。宛先ポートにすることはできません。


) Cisco NX-OS Release 4.2(1)N2(1) およびそれ以前のリリースの場合、Cisco Nexus 5010 スイッチと Cisco Nexus 5020 スイッチは最大 2 つの出力 SPAN 送信元ポートをサポートします。


Cisco NX-OS Release 5.0(2)N2(1) 以降:

出力 SPAN 送信元ポートの数に対する制限がなくなりました。

SAN ポート チャネル インターフェイスは、入力または出力送信元ポートとして設定できます。

モニタ セッションの出力(TX)送信元の数に対する制限がなくなりました。

ポート チャネル インターフェイスを出力送信元として設定できます。

both rx tx のいずれも指定していない場合、ERSPAN に対しては両方向の送信元トラフィックが分析されます。

次に、イーサネット SPAN 送信元ポートを設定する例を示します。

switch# configure terminal
switch(config)# monitor session 9 type local
switch(config-monitor)# description A Local SPAN session
switch(config-monitor)# source interface ethernet 1/1
switch(config-monitor)#
 

次に、ポート チャネル SPAN 送信元を設定する例を示します。

switch# configure terminal
switch(config)# monitor session 2
switch(config-monitor)# source interface port-channel 5
switch(config-monitor)#
 

次に、トラフィックを受信するように ERSPAN 送信元ポートを設定する例を示します。

switch# configure terminal
switch(config)# monitor session 1 type erspan-source
switch(config-erspan-src)# source interface ethernet 1/5 rx
switch(config-erspan-src)#
 

 
関連コマンド

コマンド
説明

destination(SPAN、ERSPAN)

宛先 SPAN ポートを設定します。

monitor session

新規 SPAN セッション設定を作成します。

show monitor session

SPAN セッションのコンフィギュレーション情報を表示します。

show running-config monitor

SPAN セッションの実行コンフィギュレーション情報を表示します。

 

spanning-tree bridge assurance

スイッチ上のすべてのネットワーク ポートでスパニング ツリー プロトコル(STP)の Bridge Assurance をイネーブルにするには、 spanning-tree bridge assurance コマンドを使用します。ブリッジ保証をディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree bridge assurance

no spanning-tree bridge assurance

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)

このコマンドが追加されました。

 
使用上のガイドライン

Bridge Assurance を使用すると、ネットワーク内でブリッジング ループの原因となる問題の発生を防ぐことができます。


) Bridge Assurance は、Rapid Per VLAN Spanning Tree Plus(Rapid PVST+)とマルチ スパニング ツリー(MST)でのみサポートされています。従来の 802.1D スパニング ツリーではサポートされていません。


Bridge Assurance はデフォルトでイネーブルになっており、グローバル単位でだけディセーブルにできます。

Bridge Assurance は、デフォルトでグローバルにイネーブルですが、インターフェイスに対してはデフォルトでディセーブルです。 spanning-tree port type network コマンドを使用すると、インターフェイスに対して Bridge Assurance をイネーブルにできます。

Bridge Assurance の詳細は、『 Cisco Nexus 5000 シリーズ NX-OS Layer 2 Switching Configuration Guide 』を参照してください。

このコマンドには、ライセンスは必要ありません。

次に、スイッチ上で Bridge Assurance をグローバルにイネーブルにする例を示します。

switch# configure terminal
switch(config)# spanning-tree bridge assurance
switch(config)#
 

 
関連コマンド

コマンド
説明

show spanning-tree bridge

ローカルのスパニング ツリー プロトコル(STP)ブリッジのステータスおよびコンフィギュレーションを表示します。

spanning-tree port type network

ネットワークのスパニング ツリー ポートとしてインターフェイスを設定します。

 

spanning-tree bpdufilter

インターフェイス上で Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)フィルタリングをイネーブルにするには、 spanning-tree bpdufilter コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree bpdufilter { enable | disable }

no spanning-tree bpdufilter

 
構文の説明

enable

このインターフェイスで BPDU フィルタリングをイネーブルにします。

disable

このインターフェイスで BPDU フィルタリングをディセーブルにします。

 
コマンド デフォルト

spanning-tree port type edge bpdufilter default コマンド を入力したときに、すでに設定されていた設定。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

spanning-tree bpdufilter enable コマンドを入力して BPDU フィルタリングをイネーブルにすると、スパニング ツリー エッジ ポート設定が上書きされます。そのポートは、標準スパニング ツリーポート タイプに戻り、標準スパニング ツリーの移行が行われます。


注意 指定インターフェイスで spanning-tree bpdufilter enable コマンドを入力するときは注意してください。ホストに接続されていないポート上で BPDU フィルタリングを明示的に設定すると、そのポートはすべての受信 BPDU を無視することになるため、ブリッジング ループが生じ、ポートが STP フォワーディング ステートに移行する可能性があります。

すべてのスパニング ツリー エッジ ポートで BPDU フィルタリングをイネーブルにするには、 spanning-tree port type edge bpdufilter default コマンドを使用します。

次に、スパニング ツリー エッジ ポート Ethernet 1/4 で BPDU フィルタリングを明示的にイネーブルにする例を示します。

switch (config)# interface ethernet 1/4
switch(config-if)# spanning-tree bpdufilter enable
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree bpduguard

インターフェイス上で Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)ガードをイネーブルにするには、 spanning-tree bpduguard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree bpduguard { enable | disable }

no spanning-tree bpduguard

 
構文の説明

enable

このインターフェイスで BPDU ガードをイネーブルにします。

disable

このインターフェイスで BPDU ガードをディセーブルにします。

 
コマンド デフォルト

spanning-tree port type edge bpdufilter default コマンド を入力したときに、すでに設定されていた設定。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

BPDU ガードにより、ポートは BPDU を受信しなくなります。ポートが引き続き BPDU を受信する場合は、保護対策としてポートが errdisable ステートになります。


注意 このコマンドは、慎重に使用してください。このコマンドは、端末に接続するインターフェイスに限って使用する必要があります。そうしないと、偶発的なトポロジ ループが原因でデータ パケット ループが発生し、スイッチおよびネットワークの動作が中断する可能性があります。

この BPDU ガード コマンドをグローバルにイネーブルにすると、スパニング ツリー エッジ ポートだけにこのコマンドが適用されます。BPDU ガードのグローバル コマンドの詳細については spanning-tree port type edge bpdufilter default コマンドを参照してください。一方、インターフェイス上でこの機能をイネーブルにすると、スパニング ツリー ポート タイプにかかわらず、そのインターフェイスに機能が適用されます。

このコマンドには次の 3 つの状態があります。

spanning-tree bpduguard enable 指定インターフェイスで BPDU ガードを無条件にイネーブルにします。

spanning-tree bpduguard disable 指定インターフェイスで BPDU ガードを無条件にディセーブルにします。

no spanning-tree bpduguard 動作中のスパニング ツリー エッジ ポート インターフェイスに spanning-tree port type edge bpdufilter default コマンドが設定されている場合、そのインターフェイスで BPDU ガードをイネーブルにします。

通常、この機能は、アクセス ポートがスパニング ツリーに参加しないようにネットワーク管理者によって設定されるサービス プロバイダーの環境で使用されます。

次に、このインターフェイス上で BPDU ソース ガードをイネーブルにする例を示します。

switch(config-if)# spanning-tree bpduguard enable
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree cost

Spanning Tree Protocol(STP; スパニング ツリー プロトコル)計算用にインターフェイスのパス コストを設定するには、 spanning-tree cost コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree [ vlan vlan-id ] cost { value | auto }

no spanning-tree [ vlan vlan-id ] cost

 
構文の説明

vlan vlan-id

(任意)パス コストを割り当てるこのトランク インターフェイス上の VLAN のリストを示します。このパラメータは、アクセス ポートでは使用しません。有効な範囲は 1 ~ 4094 です。

value

ポート コストの値。使用可能なコスト範囲は、次のようにパス コスト計算方式によって異なります。

short:有効な範囲は 1 ~ 65536 です。

long:有効な範囲は 1 ~ 200,000,000 です。

auto

インターフェイスのメディア速度によってポート コストの値を設定します(値については、 表 1 を参照してください)。

 
コマンド デフォルト

メディア速度によってポート コストが設定されます。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

STP ポートのパス コストのデフォルト値は、LAN インターフェイスのメディア速度およびパス コスト計算方式で決まります( 表 1 を参照)。Rapid per VLAN Spanning Tree Plus(Rapid PVST+)のパス コスト計算方式の設定については、 spanning-tree pathcost method コマンドを参照してください。

 

表 1 デフォルトのポート コスト

帯域幅
ショート パス コスト方式のポート コスト
ロング パス コスト方式のポート コスト

10 Mbps

100

2,000,000

100 Mbps

19

200,000

1 ギガビット イーサネット

4

20,000

10 ギガビット イーサネット

2

2,000

value を設定するときは、高い値ほどコストが高くなります。

アクセス ポートでは、ポート コストをポートごとに割り当てます。トランク ポートでは、ポート コストを VLAN ごとに割り当てます。トランク ポートのすべての VLAN を同じポート コストに設定できます。

EtherChannel バンドルは、単一ポートと見なされます。ポート コストは、そのチャネルに割り当てられている設定済みのすべてのポート コストの合計です。


) このコマンドを使用して Rapid PVST+ のポート コストを設定します。MST のポート コストを設定するには、spanning-tree mst cost コマンドを使用します。


次に、インターフェイスにアクセスして、そのインターフェイスに関連付けられているスパニング ツリー VLAN にパス コスト値 250 を設定する例を示します。

switch(config)# interface ethernet 1/4
switch(config-if)# spanning-tree cost 250
 

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー設定に関する情報を表示します。

 

spanning-tree domain

スパニング ツリー プロトコル(STP)ドメインを設定するには、 spanning-tree domain コマンドを使用します。STP ドメインを削除するには、このコマンドの no 形式を使用します。

spanning-tree domain domain-num

no spanning-tree domain domain-num

 
構文の説明

domain-num

STP ドメイン番号。指定できる範囲は 1 ~ 1023 です。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、スパニング ツリー ドメインを設定する例を示します。

switch# configure terminal
switch(config)# spanning-tree domain 1
switch(config)#
 

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー プロトコル(STP)のコンフィギュレーション情報を表示します。

 

spanning-tree guard

ループ ガードまたはルート ガードをイネーブルまたはディセーブルにするには、 spanning-tree guard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree guard { loop | none | root }

no spanning-tree guard

 
構文の説明

loop

インターフェイス上でループ ガードをイネーブルにします。

none

ガード モードを None に設定します。

root

インターフェイス上でルート ガードをイネーブルにします。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

スパニング ツリー エッジ ポート上でループ ガードをイネーブルにするコマンドはスイッチによって受け入れられますが、ルート ガードがイネーブルになっている場合はループ ガードをイネーブルにできません。

次に、ルート ガードをイネーブルにする例を示します。

switch(config-if)# spanning-tree guard root
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

spanning-tree link-type

ポートのリンク タイプを設定するには、 spanning-tree link-type コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree link-type { auto | point-to-point | shared }

no spanning-tree link-type

 
構文の説明

auto

インターフェイスのデュプレックス設定に基づいてリンク タイプを設定します。

point-to-point

インターフェイスがポイントツーポイント リンクになるように指定します。

shared

インターフェイスが共有メディアになるように指定します。

 
コマンド デフォルト

デュプレックス設定に基づいて自動的に設定されるリンク タイプ。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

高速移行(IEEE 802.1w で指定)は、2 つのブリッジ間のポイントツーポイント リンク上だけで機能します。

デフォルトでは、スイッチはデュプレックス モードからポートのリンク タイプを取得します。全二重ポートはポイントツーポイント リンクと見なされ、半二重設定は共有リンク上にあると見なされます。


) Cisco Nexus 5000 シリーズ スイッチでは、ポート デュプレックスを設定できません。


次に、ポートを共有リンクとして設定する例を示します。

switch(config-if)# spanning-tree link-type shared
 

 
関連コマンド

コマンド
説明

show spanning-tree interface

スパニング ツリー ステートに関する情報を表示します。

spanning-tree loopguard default

ループ ガードを、すべてのスパニング ツリー標準およびネットワーク ポート上でデフォルトとしてイネーブルにするには、 spanning-tree loopguard default コマンドを使用します。ループ ガードをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree loopguard default

no spanning-tree loopguard default

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

ループ ガードを使用すると、ブリッジ ネットワークのセキュリティを高めることができます。ループ ガードは、単方向リンクを引き起こす可能性のある障害が原因で、代替ポートまたはルート ポートが指定ポートになるのを防ぎます。

ループ ガードは、スパニング ツリーによってポイントツーポイント リンクと見なされるポートだけで動作し、スパニング ツリー エッジ ポート上では稼動しません。

指定のインターフェイスで spanning-tree guard loop コマンドを入力すると、このグローバル ループ ガード コマンドが上書きされます。

次に、ループ ガードをイネーブルにする例を示します。

switch(config)# spanning-tree loopguard default
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

spanning-tree mode

Rapid per VLAN Spanning Tree Plus(Rapid PVST+)と Multiple Spanning Tree(MST; 多重スパニング ツリー)Spanning Tree Protocol(STP; スパニング ツリー プロトコル)モードを切り替えるには、 spanning-tree mode コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mode { rapid-pvst | mst }

no spanning-tree mode

 
構文の説明

rapid-pvst

STP モードを Rapid PVST+ に設定します。

mst

STP モードを MST に設定します。

 
コマンド デフォルト

Rapid PVST+

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

スイッチ上で MST と Rapid PVST+ との同時実行はできません。


注意 spanning-tree mode コマンドを使用して、Rapid PVST+ モードと MST モードを切り替えるときには注意してください。コマンドを入力すると、以前のモードのすべての STP インスタンスが停止して、新しいモードで再開されます。このコマンドの使用により、ユーザ トラフィックが中断される可能性があります。

次に、MST モードに切り替える例を示します。

switch(config)# spanning-tree mode mst
switch(config-mst)#
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree mst configuration

Multiple Spanning Tree(MST; 多重スパニング ツリー)コンフィギュレーション モードを開始するには、 spanning-tree mst configuration コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst configuration

no spanning-tree mst configuration

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

MST 設定のデフォルト値は、MST 設定のすべてのパラメータのデフォルト値となります。

いずれの MST インスタンスにも VLAN はマップされません。すべての VLAN は、Common and Internal Spanning Tree(CIST)インスタンスにマップされます。

領域名は空の文字列になります。

リビジョン番号は 0 です。

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

MST 設定は、3 つの主要パラメータで構成されています。

インスタンス VLAN マッピング: instance vlan コマンドを参照してください。

領域名: name(MST コンフィギュレーション) コマンドを参照してください。

コンフィギュレーション リビジョン番号: revision コマンドを参照してください。

abort および exit コマンドで、MST コンフィギュレーション モードを終了できます。この 2 つのコマンドは、変更を保存するかどうかで異なります。

exit コマンドでは、MST コンフィギュレーション モードを終了する前にすべての変更がコミットされます。

abort コマンドでは、変更はコミットされないで MST コンフィギュレーション モードが終了します。

関連付けられたプライマリ VLAN と同じインスタンスにセカンダリ VLAN をマッピングしていない場合は、MST コンフィギュレーション モードの終了時に次の警告メッセージが表示されます。

These secondary vlans are not mapped to the same instance as their primary:
-> 3
 

この問題を解決する方法については、 switchport mode private-vlan host コマンドを参照してください。

MST コンフィギュレーション モード パラメータを変更すると、接続が切断される可能性があります。サービスの中断を減らすには、MST コンフィギュレーション モードを開始したら、現在の MST 設定のコピーを変更します。設定の編集が終了したら、exit キーワードを使用して、すべての変更を一度に適用できます。

万一、2 人の管理者がまったく同時に新しいコンフィギュレーションをコミットした場合は、次の警告メッセージが表示されます。

% MST CFG:Configuration change lost because of concurrent access
 

次に、MST コンフィギュレーション モードを開始する例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)#
 

次に、MST 設定(名前、インスタンス マッピング、およびリビジョン番号)をデフォルト設定にリセットする例を示します。

switch(config)# no spanning-tree mst configuration
 

 
関連コマンド

コマンド
説明

instance vlan

VLAN または VLAN セットを MST インスタンスにマッピングします。

name(MST コンフィギュレーション)

MST 領域の名前を設定します。

revision

MST 設定のリビジョン番号を設定します。

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst cost

Multiple Spanning Tree(MST; 多重スパニング ツリー)インスタンス(インスタンス ID が 0 の Common and Internal Spanning Tree(CIST)も含む)のパス コスト パラメータを設定するには、 spanning-tree mst cost コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id cost { cost | auto }

no spanning-tree mst instance-id cost

 
構文の説明

instance-id

インスタンス ID 番号。有効な範囲は 0 ~ 4094 です。

cost

1 つのインスタンスのポート コスト。有効な範囲は 1 ~ 200,000,000 です。

auto

インターフェイスのメディア速度によってポート コストの値を設定します。

 
コマンド デフォルト

ポート コスト値を自動的に設定します。

10 Mbps:2,000,000

100 Mbps:200,000

1 ギガビット イーサネット:20,000

10 ギガビット イーサネット:2,000

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

ポート コストは、ポート速度によって異なります。インターフェイス速度が速いほど、コストは小さくなります。MST は、常にロング パス コストを使用します。

コスト値が大きいほど、コストが高くなります。コストを入力する際はカンマをエントリに含めないでください。たとえば、1,000 ではなく 1000 と入力します。

EtherChannel バンドルは、単一ポートと見なされます。ポート コストは、そのチャネルに割り当てられている設定済みのすべてのポート コストの合計です。

次に、インターフェイス パス コストを設定する例を示します。

switch(config-if)# spanning-tree mst 0 cost 17031970
 

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst forward-time

スイッチ上のすべてのインスタンスの転送遅延タイマーを設定するには、 spanning-tree mst forward-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst forward-time seconds

no spanning-tree mst forward-time

 
構文の説明

seconds

スイッチ上のすべてのインスタンスに設定される転送遅延タイマーの秒数。有効な範囲は 4 ~ 30 秒です。

 
コマンド デフォルト

15 秒

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、転送遅延タイマーを設定する例を示します。

switch(config)# spanning-tree mst forward-time 20
 

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst hello-time

スイッチ上のすべてのインスタンスの hello タイム遅延タイマーを設定するには、 spanning-tree mst hello-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst hello-time seconds

no spanning-tree mst hello-time

 
構文の説明

seconds

スイッチ上のすべてのインスタンスに設定される hello タイム遅延タイマーの秒数。有効な範囲は 1 ~ 10 秒です。

 
コマンド デフォルト

2 秒

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

hello-time 値を指定しない場合は、ネットワークの直径から値が計算されます。

次に、hello タイム遅延タイマーを設定する例を示します。

switch(config)# spanning-tree mst hello-time 3
 

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst max-age

スイッチ上のすべてのインスタンスの最大エージング タイマーを設定するには、 spanning-tree mst max-age コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst max-age seconds

no spanning-tree mst max-age

 
構文の説明

seconds

スイッチ上のすべてのインスタンスに設定される最大エージング タイマーの秒数。有効な範囲は 6 ~ 40 秒です。

 
コマンド デフォルト

20 秒

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

このパラメータは、インスタンス 0 または IST だけが使用します。

次に、最大エージング タイマーを設定する例を示します。

switch(config)# spanning-tree mst max-age 40
 

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst max-hops

Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)が廃棄される前に領域で許容されるホップ数を指定するには、 spanning-tree mst max-hops コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst max-hops hop-count

no spanning-tree mst max-hops

 
構文の説明

hop-count

BPDU が廃棄される前に領域内で可能なホップ数。有効な範囲は 1 ~ 255 ホップです。

 
コマンド デフォルト

20 ホップ

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、許容されるホップ数を設定する例を示します。

switch(config)# spanning-tree mst max-hops 25
 

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst port-priority

Multiple Spanning Tree(MST; 多重スパニング ツリー)インスタンス(インスタンス ID が 0 の Common and Internal Spanning Tree(CIST)も含む)のポート プライオリティ パラメータを設定するには、 spanning-tree mst port-priority コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id port-priority priority

no spanning-tree mst instance-id port-priority

 
構文の説明

instance-id

インスタンス ID 番号。 有効な範囲は 0 ~ 4094 です。

priority

1 つのインスタンスのポート プライオリティ。指定できる範囲は 0 ~ 224 で、刻み幅は 32 です。

 
コマンド デフォルト

ポート プライオリティ値は 128 です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

port-priority priority 値が大きいほど、プライオリティは低くなります。

プライオリティ値は、0、32、64、96、128、160、192、224 です。その他すべての値は拒否されます。

次に、インターフェイス プライオリティを設定する例を示します。

switch(config-if)# spanning-tree mst 0 port-priority 64
 

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree port-priority

デフォルト STP のポート プライオリティを設定します。デフォルト STP は Rapid PVST+ です。

 

spanning-tree mst pre-standard

インターフェイス ポート上で先行標準のマルチ スパニング ツリー(MST)のブリッジ プロトコル データ ユニット(BPDU)伝送を強制するには、 spanning-tree mst pre-standard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst pre-standard

no spanning-tree mst pre-standard

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、ポート上で先行標準の MST BPDU 伝送を強制する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# spanning-tree mst pre-standard
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst priority

ブリッジ プライオリティを設定するには、 spanning-tree mst priority コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id priority priority-value

no spanning-tree mst instance-id priority

 
構文の説明

instance-id

インスタンス ID 番号。有効な範囲は 0 ~ 4094 です。

priority-value

ブリッジ プライオリティ。有効値および追加情報については、「使用上のガイドライン」の項を参照してください。

 
コマンド デフォルト

ブリッジ プライオリティのデフォルト値は 32768 です。

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

ブリッジ プライオリティには、4096 単位で増加する値だけを設定できます。プライオリティを設定する場合、有効な値は、0、4096、8192、12288、16384、20480、24576、28672、32768、36864、40960、45056、49152、53248、57344、および 61440 です。

priority-value 引数に 0 を設定することで、スイッチをルートにできます。

instance-id 引数には、1 つのインスタンスまたはインスタンス範囲を入力できます。たとえば、0-3、5、7-9 と入力できます。

次に、ブリッジ プライオリティを設定する例を示します。

switch(config)# spanning-tree mst 0 priority 4096
 

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst root

プライマリ ルートおよびセカンダリ ルートを指定して、インスタンスのタイマー値を設定するには、 spanning-tree mst root コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id root { primary | secondary } [ diameter dia [ hello-time hello-time ]]

no spanning-tree mst instance-id root

 
構文の説明

instance-id

インスタンス ID 番号。有効な範囲は 0 ~ 4094 です。

primary

スパニング ツリー インスタンスのブリッジ ルートを作成するのに十分な高プライオリティ(小さな値)を指定します。

secondary

プライマリ ルートに障害が発生した場合に、セカンダリ ルートとなるようにスイッチを指定します。

diameter dia

(任意)ネットワークの直径に基づく、ブリッジのタイマー値を指定します。

hello-time hello-time

(任意)ルート スイッチが設定メッセージを生成する間隔を指定します。有効な範囲は 1 ~ 10 秒で、デフォルトは 2 秒です。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

instance-id 引数には、1 つのインスタンスまたはインスタンス範囲を入力できます。たとえば、0-3、5、7-9 と入力できます。

hello-time 引数を指定しない場合は、ネットワークの直径から引数が計算されます。 hello-time hello-time キーワードと引数を指定するには、まず diameter dia キーワードと引数を指定する必要があります。

次に、プライマリ ルートを指定する例を示します。

switch(config)# spanning-tree mst 0 root primary
 

次に、ブリッジのプライオリティ値およびタイマー値を設定する例を示します。

switch(config)# spanning-tree mst 0 root primary diameter 7 hello-time 2
 

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst simulate pvst

特定のインターフェイスを再度イネーブルにして、Multiple Spanning Tree(MST; 多重スパニング ツリー)と Rapid per VLAN Spanning Tree Plus(Rapid PVST+)間で自動的に相互運用するには、 spanning-tree mst simulate pvst コマンドを使用します。特定の MST インターフェイスと Rapid PVST+ を実行している接続先デバイスとの自動的な相互運用を回避するには、 spanning-tree mst simulate pvst disable コマンドを使用します。特定のインターフェイスをスイッチにグローバルに設定されているデフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst simulate pvst

spanning-tree mst simulate pvst disable

no spanning-tree mst simulate pvst

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

イネーブル。デフォルトでは、スイッチのすべてのインターフェイスは、MST と Rapid PVST+ との間でシームレスに相互運用します。この設定をグローバルに変更する方法については、 spanning-tree mst simulate pvst global コマンドを参照してください。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

MST は、ユーザが設定しなくても、Rapid PVST+ と相互運用できます。PVST+ シミュレーション機能により、このシームレスな相互運用が可能になっています。ただし、MST と Rapid PVST+ との接続を制御し、MST 対応ポートを Rapid PVST+ 対応ポートに誤って接続するのを防止することが必要な場合もあります。

spanning-tree mst simulate pvst disable コマンドを使用すると、Rapid PVST+(SSTP)Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)を受信した指定の MST インターフェイスが STP ブロッキング ステートに移行します。これらのインターフェイスは、ポートでの Rapid PVST+ BPDU の受信が停止するまで不整合な状態で保持され、ポートで BPDU の受信を停止すると、通常の STP 移行プロセスを再開します。


) スイッチ全体で MST と Rapid PVST+ の自動的な相互運用をブロックするには、no spanning-tree mst simulate pvst global コマンドを使用します。


このコマンドは、Rapid PVST+ を実行するデバイスに誤って接続することを回避するうえで役立ちます。

特定のインターフェイス上で MST と Rapid PVST+ 間のシームレスな運用を再度イネーブルにするには、 spanning-tree mst simulate pvst コマンドを使用します。

次に、指定のポートと Rapid PVST+ を実行する接続先デバイスとの自動的な相互運用を回避する例を示します。

switch(config-if)# spanning-tree mst simulate pvst disable
 

 
関連コマンド

コマンド
説明

spanning-tree mst simulate pvst global

MST と Rapid PVST+ 間のシームレスな相互運用をグローバルにイネーブルにします。

spanning-tree mst simulate pvst global

多重スパニング ツリー(MST)スイッチと Rapid per VLAN Spanning Tree Plus(Rapid PVST+)を実行する接続先デバイスとの自動的な相互運用を回避するには、 spanning-tree mst simulate pvst global コマンドを使用します。デフォルト設定(スイッチ上で MST と Rapid PVST+ 間のシームレスな運用が行われる)に戻すには、 no spanning-tree mst simulate pvst global コマンドを使用します。

spanning-tree mst simulate pvst global

no spanning-tree mst simulate pvst global

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

イネーブル。デフォルトでは、スイッチが MST と Rapid PVST+ 間でシームレスに相互運用します。

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

MST では、Rapid PVST+ と相互運用するためのユーザ設定は必要ありません。PVST+ シミュレーション機能により、このシームレスな相互運用が可能になっています。ただし、MST と Rapid PVST+ との接続を制御し、MST 対応ポートを Rapid PVST+ 対応ポートに誤って接続するのを防止することが必要な場合もあります。

no spanning-tree mst simulate pvst global コマンドを使用すると、MST モードで稼動するスイッチにより、Rapid PVST+(SSTP)Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)を受信するすべてのインターフェイスが、Spanning Tree Protocol(STP; スパニング ツリー プロトコル)ブロッキング ステートに移行されます。これらのインターフェイスは、ポートでの Rapid PVST+ BPDU の受信が停止するまで不整合な状態で保持され、ポートで BPDU の受信を停止すると、通常の STP 移行プロセスを再開します。

インターフェイス モードからもこのコマンドを使用でき、設定はスイッチ全体に適用されます。


) MST と Rapid PVST+ の自動的な相互運用をブロックする方法については、spanning-tree mst simulate pvst コマンドの説明を参照してください。


このコマンドは、MST を実行していないデバイスに誤って接続することを回避するうえで役立ちます。

スイッチを MST と Rapid PVST+ 間のシームレスな運用に戻すには、 spanning-tree mst simulate pvst global コマンドを使用します。

次に、スイッチのすべてのポートと Rapid PVST+ を実行する接続先デバイスとの自動的な相互運用を回避する例を示します。

switch(config)# no spanning-tree mst simulate pvst global
 

 
関連コマンド

コマンド
説明

spanning-tree mst simulate pvst

MST と Rapid PVST+ 間のシームレスな相互運用をインターフェイス単位でイネーブルにします。

spanning-tree pathcost method

デフォルト パス コスト計算方式を設定するには、 spanning-tree pathcost method コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree pathcost method { long | short }

no spanning-tree pathcost method

 
構文の説明

long

ポートのパス コストに 32 ビット ベース値を指定します。

short

ポートのパス コストに 16 ビット ベース値を指定します。

 
コマンド デフォルト

short

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

long パス コスト計算方式では、パス コスト計算に 32 ビットをすべて使用して、2 ~ 2,00,000,000 の値を生成します。

short パス コスト計算方式(16 ビット)では、1 ~ 65535 の値を生成します。


) このコマンドは、デフォルト モードである Rapid per VLAN Spanning Tree Plus(Rapid PVST+)スパニング ツリー モードだけに適用されます。Multiple Spanning Tree(MST; 多重スパニング ツリー)スパニング ツリー モードを使用している場合、スイッチはパス コストの計算に long 方式だけを使用します。これは MST についてはユーザ設定可能ではありません。


次に、デフォルト パス コスト方式に long を設定する例を示します。

switch(config)# spanning-tree pathcost method long
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

spanning-tree port-priority

2 台のブリッジがルート ブリッジとして位置競合している場合に、インターフェイス プライオリティを設定するには、 spanning-tree port-priority コマンドを使用します。設定するプライオリティによって、優劣が決まります。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree [ vlan vlan-id ] port-priority value

no spanning-tree [ vlan vlan-id ] port-priority

 
構文の説明

vlan vlan-id

(任意)VLAN ID 番号を指定します。有効な範囲は 0 ~ 4094 です

value

ポート プライオリティ。 指定できる範囲は 1 ~ 224 で、刻み幅は 32 です。

 
コマンド デフォルト

ポート プライオリティのデフォルト値は 128 です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

アクセス ポート上では、 vlan vlan-id パラメータを使用しないでください。ソフトウェアは、アクセス ポートにはポート プライオリティ値、トランク ポートには VLAN ポート プライオリティ値を使用します。

プライオリティ値は、0、32、64、96、128、160、192、224 です。その他すべての値は拒否されます。


) デフォルト STP モードである Rapid per VLAN Spanning Tree Plus(Rapid PVST+)スパニング ツリー モードのポート プライオリティを設定するには、このコマンドを使用します。Multiple Spanning Tree(MST; 多重スパニング ツリー)スパニング ツリー モードのポート プライオリティを設定するには、spacing-tree mst port-priority コマンドを使用します。


次に、ポート プライオリティを 32 に変更して、アクセス ポート インターフェイス 2/0 上のスパニング ツリー インスタンスがルート ブリッジとして選択される確率を高くする例を示します。

switch(config-if)# spanning-tree port-priority 32
 

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

spanning-tree interface priority

インターフェイスのスパニング ツリー ポート プライオリティに関する情報を表示します。

spanning-tree port type edge

ホストに接続されているインターフェイスをエッジ ポートとして設定するには、 spanning-tree port type edge コマンドを使用します。この設定により、ポートはブロッキング ステートまたはラーニング ステートを通過することなく自動的にスパニング ツリー フォワーディング ステートに移行します。ポートを標準のスパニング ツリー ポートに戻すには、 no spanning-tree port type コマンドを使用します。

spanning-tree port type edge [ trunk ]

no spanning-tree port type

 
構文の説明

trunk

(任意)トランク ポートをスパニング ツリー エッジ ポートして設定します。

 
コマンド デフォルト

デフォルトは spanning-tree port type edge default コマンドを入力したときに設定されるデフォルト ポート タイプ エッジのグローバル設定です。グローバル設定を設定しなかった場合、デフォルトのスパニング ツリー ポート タイプは標準です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドを使用して、ポートをスパニング ツリー エッジ ポートとしてトランク モードに設定することもできます。


注意 このコマンドは、端末に接続するインターフェイスに限って使用する必要があります。そうしないと、偶発的なトポロジ ループが原因でデータ パケット ループが発生し、スイッチおよびネットワークの動作が中断する可能性があります。

リンクがアップすると、スパニング ツリー エッジ ポートは、標準の転送遅延時間の経過を待たずに、ただちにスパニング ツリー フォワーディング ステートに移行します。


) これは、以前にシスコ独自の PortFast 機能が提供していた機能と同じです。


このコマンドを使用すると、システムによって次のようなメッセージが返されます。

Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 

trunk キーワードを指定せずにこのコマンドを使用すると、システムから次のような追加メッセージが返されます。

%Portfast has been configured on Ethernet1/40 but will only
have effect when the interface is in a non-trunking mode.
 

トランク インターフェイスをスパニング ツリー エッジ ポートとして設定するには、 spanning-tree port type trunk コマンドを使用します。スパニング ツリー エッジ ポート タイプ設定を削除するには、 no spanning-tree port type コマンドを使用します。

デフォルトのスパニング ツリー ポート タイプは「標準」です。

次に、ホストに接続されたインターフェイスをエッジ ポートとして設定する例を示します。この設定により、インターフェイスは、リンクがアップしたときに自動的にフォワーディング ステートに移行されます。

switch(config-if)# spanning-tree port type edge
 

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree port type edge bpdufilter default

すべてのスパニング ツリー エッジ ポート上でデフォルトで Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)フィルタリングをイネーブルにするには、 spanning-tree port type edge bpdufilter default コマンドを使用します。すべてのエッジポート上でデフォルトで BPDU フィルタリングをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree port type edge bpdufilter default

no spanning-tree port type edge bpdufilter default

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

デフォルトで BPDU フィルタリングをイネーブルにするには、次を実行する必要があります。

spanning-tree port type edge または spanning-tree port type edge default コマンドを使用して、インターフェイスをスパニング ツリー エッジ ポートとして設定します。

BPDU フィルタリングをイネーブルにします。

すべてのスパニング ツリー エッジ ポート上で BPDU フィルタリングをグローバルにイネーブルにするには、このコマンドを使用します。BPDU フィルタリングにより、ポートは BPDU を送受信しなくなります。


注意 このコマンドを使用するときには注意してください。誤って使用すると、ブリッジング ループが発生するおそれがあります。

インターフェイス レベルで BPDU フィルタリングを設定することにより、この spanning-tree port type edge bpdufilter default コマンドのグローバルな影響を無効にできます。この機能をインターフェイス レベルで使用する方法の詳細については、 spanning-tree bpdufilter コマンドを参照してください。


) BPDU フィルタリングは、ポート単位でイネーブルにしたときとグローバルにイネーブルにしたときでは、その機能が異なります。グローバルにイネーブルにされた BPDU フィルタリングは、動作中のスパニング ツリー エッジ ポートにだけ適用されます。ポートは数個の BPDU をリンクアップ時に送出してから、実際に、発信 BPDU のフィルタリングを開始します。BPDU を受信したエッジ ポートはただちに標準スパニング ツリー ポートになり、通常の移行が起こり、BPDU フィルタリングがディセーブルになります。ポートでローカルに BPDU フィルタリングをイネーブルにすると、スイッチはこのポートで BPDU の送受信を行わなくなります。


次に、動作中のすべてのスパニング ツリー エッジ ポート上で、デフォルトで BPDU フィルタリングをグローバルにイネーブルにする例を示します。

switch(config)# spanning-tree port type edge bpdufilter default
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree bpdufilter

インターフェイス上で BPDU フィルタリングをイネーブルにします。

spanning-tree port type edge

インターフェイスをスパニング ツリー エッジ ポートとして設定します。

spanning-tree port type edge bpduguard default

すべてのスパニング ツリー エッジ ポート上でデフォルトで Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)ガードをイネーブルにするには、 spanning-tree port type edge bpduguard default コマンドを使用します。デフォルトですべてのエッジ ポートの BPDU ガードをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree port type edge bpduguard default

no spanning-tree port type edge bpduguard default

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

デフォルトで BPDU ガードをイネーブルにするには、次を実行する必要があります。

spanning-tree port type edge または spanning-tree port type edge default コマンドを入力して、インターフェイスをスパニング ツリー エッジ ポートとして設定します。

BPDU ガードをイネーブルにします。

すべてのスパニング ツリー エッジ ポート上で BPDU ガードをグローバルにイネーブルにするには、このコマンドを使用します。BPDU を受信したポートは、BPDU ガードによってディセーブルになります。

グローバル BPDU ガードは、スパニング ツリー エッジ ポート上だけに適用されます。

インターフェイスごとに BPDU ガードをイネーブルにすることもできます。詳細については spanning-tree bpduguard コマンドを参照してください。


) すべてのスパニング ツリー エッジ ポートで BPDU ガードをイネーブルにすることを推奨します。


次に、すべてのスパニング ツリー エッジ ポートで、デフォルトで BPDU ガードをイネーブルにする例を示します。

switch(config)# spanning-tree port type edge bpduguard default
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree bpduguard

インターフェイス上で BPDU ガードをイネーブルにします。

spanning-tree port type edge

インターフェイスをスパニング ツリー エッジ ポートとして設定します。

spanning-tree port type edge default

ホストに接続されているすべてのアクセス ポートをデフォルトでエッジ ポートとして設定するには、 spanning-tree port type edge default コマンドを使用します。ホストに接続されているすべてのポートをデフォルトで標準スパニング ツリー ポートに戻すには、このコマンドの no 形式を使用します。

spanning-tree port type edge default

no spanning-tree port type edge default

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

すべてのインターフェイスをデフォルトでスパニング ツリー エッジ ポートとして自動的に設定するには、このコマンドを使用します。このコマンドは、トランク ポート上では機能しません。


注意 このコマンドは、慎重に使用してください。このコマンドは、端末に接続するインターフェイスに限って使用する必要があります。そうしないと、偶発的なトポロジ ループが原因でデータ パケット ループが発生し、スイッチおよびネットワークの動作が中断する可能性があります。

リンクがアップすると、エッジ ポートとして設定されているインターフェイスは、標準の転送遅延時間の経過を待たずに、ただちにスパニング ツリー フォワーディング ステートに移行します (この移行は、以前は、シスコ独自の PortFast 機能として設定していました)。

このコマンドを使用すると、システムによって次のようなメッセージが返されます。

Warning: this command enables portfast by default on all interfaces. You
should now disable portfast explicitly on switched ports leading to hubs,
switches and bridges as they may create temporary bridging loops.
 

spanning-tree port type edge コマンド を使用して、個々のインターフェイスをエッジ ポートとして設定できます。

デフォルトのスパニング ツリー ポート タイプは「標準」です。

次に、ホストに接続されたすべてのポートをスパニング ツリー エッジ ポートとしてグローバルに設定する例を示します。

switch(config)# spanning-tree port type edge default
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree port type edge

インターフェイスをスパニング ツリー エッジ ポートとして設定します。

spanning-tree port type network

グローバル設定に関係なく、スイッチに接続されているインターフェイスをネットワーク スパニング ツリー ポートとして設定するには、 spanning-tree port type network コマンドを使用します。ポートを標準のスパニング ツリー ポートに戻すには、このコマンドの no 形式を使用します。

spanning-tree port type network

no spanning-tree port type

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

デフォルトは spanning-tree port type network default コマンドを入力したときに設定されるデフォルト ポート タイプ ネットワークのグローバル設定です。グローバル設定を設定しなかった場合、デフォルトのスパニング ツリー ポート タイプは標準です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

スイッチに接続されているインターフェイスをスパニング ツリー ネットワーク ポートとして設定するには、このコマンドを使用します。Bridge Assurance は、Spanning Tree Protocol(STP; スパニング ツリー プロトコル)ネットワーク ポート上だけで実行されます。


) ホストに接続されているポートを誤って STP ネットワーク ポートとして設定し、Bridge Assurance をイネーブルにすると、それらのポートは自動的にブロッキング ステートに移行します。



) Bridge Assurance はデフォルトでイネーブルとなり、スパニング ツリー ネットワーク ポートとして設定されているすべてのインターフェイスの Bridge Assurance がイネーブルになります。


ポートをスパニング ツリー ネットワーク ポートとして設定するには、 spanning-tree port type network コマンドを使用します。この設定を削除するには、 no spanning-tree port type コマンドを使用します。 no spanning-tree port type コマンドを使用すると、ソフトウェアによってポートがネットワーク ポート タイプのグローバルなデフォルト設定に戻されます。

spanning-tree port type network default コマンドを入力すると、スイッチに接続されているすべてのポートをデフォルトでスパニング ツリー ネットワーク ポートとして設定できます。

デフォルトのスパニング ツリー ポート タイプは「標準」です。

次に、スイッチまたはブリッジに接続されているインターフェイスをスパニング ツリー ネットワーク ポートとして設定する例を示します。

switch(config-if)# spanning-tree port type network
 

 
関連コマンド

コマンド
説明

show spanning-tree interface

指定のインターフェイス単位でスパニング ツリー設定に関する情報を表示します。

 

spanning-tree port type network default

すべてのポートをデフォルトでスパニング ツリー ネットワーク ポートとして設定するには、 spanning-tree port type network default コマンドを使用します。すべてのポートをデフォルトで標準スパニング ツリー ポートに戻すには、このコマンドの no 形式を使用します。

spanning-tree port type network default

no spanning-tree port type network default

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

スイッチに接続されているすべてのインターフェイスをデフォルトでスパニング ツリー ネットワーク ポートとして自動的に設定するには、このコマンドを使用します。次に、 spanning-tree port type edge コマンドを使用して、ホストにスパニング ツリー エッジ ポートとして接続された特定のポートを設定できます。


) ホストに接続されているポートを誤って Spanning Tree Protocol(STP; スパニング ツリー プロトコル)ネットワーク ポートとして設定し、Bridge Assurance をイネーブルにすると、それらのポートは自動的にブロッキング ステートに移行します。


Bridge Assurance 機能により、ホストに接続されているネットワーク ポートはスパニング ツリー ブロッキング ステートに移行するため、他のスイッチに接続されているポートだけをネットワークポートとして設定してください。

spanning-tree port type network コマンド を使用して、個々のインターフェイスをネットワーク ポートとして識別できます。

デフォルトのスパニング ツリー ポート タイプは「標準」です。

次に、スイッチに接続されたすべてのポートをスパニング ツリー ネットワーク ポートとしてグローバルに設定する例を示します。

switch(config)# spanning-tree port type network default
 

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

 

spanning-tree port type normal

標準のスパニング ツリー ポートとしてインターフェイスを設定するには、 spanning-tree port type normal コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree port type normal

no spanning-tree port type normal

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

デフォルトのスパニング ツリー ポート タイプは「標準」です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、インターフェイスを標準のポートとして設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# spanning-tree port type normal
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree pseudo-information

2 つのレイヤ 2 ゲートウェイ スイッチのスパニング ツリー疑似情報パラメータを設定するには、 spanning-tree pseudo-information コマンドを使用します。

spanning-tree pseudo-information

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ハイブリッド スイッチを備えたトポロジ(たとえば、仮想ポート チャネル(vPC)ではないスイッチに接続した vPC)で VLAN ベースのロード バランシングを設定するには、このコマンドを使用します。

VLAN ベースのロードバランシング基準を満たすには、スパニング ツリー プロトコル(STP)のブリッジ プライオリティに、ルート ブリッジと指定ブリッジでそれぞれ別々の値を設定する必要があります。

このコマンドには、ライセンスは必要ありません。

次に、スイッチ上で Bridge Assurance をグローバルにイネーブルにする例を示します。

switch# configure terminal
switch(config)# spanning-tree pseudo-information
switch(config-pseudo)#
 

 
関連コマンド

コマンド
説明

mst(STP)

マルチ スパニング ツリー(MST)の指定ブリッジとルート ブリッジのブリッジ プライオリティを設定します。

show running-config spanning-tree

スパニング ツリーの実行コンフィギュレーション情報を表示します。

show spanning-tree summary

STP の要約情報を表示します。

vlan(STP)

VLAN の指定ブリッジとルート ブリッジのプライオリティを設定します。

 

spanning-tree vlan

VLAN 単位で Spanning Tree Protocol(STP; スパニング ツリー プロトコル)パラメータを設定するには、 spanning-tree vlan コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree vlan vlan-id [ forward-time value | hello-time value | max-age value | priority value | [ root { primary | secondary } [ diameter dia [ hello-time value ]]]]

no spanning-tree vlan vlan-id [ forward-time | hello-time | max-age | priority | root ]

 
構文の説明

vlan-id

VLAN ID 番号。VLAN ID の範囲は 0 ~ 4094 です。

forward-time value

(任意) STP 転送遅延時間を指定します。有効な範囲は 4 ~ 30 秒です。

hello-time value

(任意)ルート スイッチが 設定メッセージを生成する秒数 を指定します 。有効な範囲は 1 ~ 10 秒です。

max-age value

(任意) Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)で情報が有効な最大秒数を指定します。有効な範囲は 6 ~ 40 秒です。

priority value

(任意)STP ブリッジ プライオリティを指定します。有効な値は、0、4096、8192、12288、16384、20480、24576、28672、32768、36864、40960、45056、49152、53248、57344、または 61440 です。 その他すべての値は拒否されます。

root primary

(任意)このスイッチを強制的にルート ブリッジに設定します。

root secondary

(任意)プライマリ ルートに障害が発生した場合には、このスイッチを強制的にルート スイッチにします。

diameter dia

(任意)端末間の 2 つの接続ポイントの間に存在するブリッジの最大数を指定します。

 
コマンド デフォルト

デフォルトの設定は次のとおりです。

forward-time :15

hello-time :2

max-age :20

priority :32768

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン


注意 no spanning-tree vlan vlan-id コマンドを使用して、VLAN 上のスパニング ツリーをディセーブルにするときは、VLAN のすべてのスイッチおよびブリッジのスパニング ツリーがディセーブルになっていることを確認してください。VLAN 内の一部のスイッチおよびブリッジのスパニング ツリーをディセーブルにし、同じ VLAN 内の別のスイッチおよびブリッジのスパニング ツリーをイネーブルのままにしておくことはできません。スパニング ツリーがイネーブルになっているスイッチおよびブリッジは、ネットワークの物理トポロジについて不完全な情報しか持たないからです。


注意 物理的なループがないトポロジであっても、スパニング ツリーをディセーブルにしないことを推奨します。スパニング ツリーは、設定の誤りおよび配線の誤りに対する保護手段です。VLAN に物理的なループが存在しないことを確認せずに、VLAN でスパニング ツリーをディセーブルにしないでください。

max-age seconds の設定時に、ルート ブリッジからの BPDU が指定のインターバル内にブリッジで見えない場合、ブリッジはネットワークが変更されたものと見なし、スパニング ツリー トポロジを再計算します。

spanning-tree root primary を実行すると、このスイッチのブリッジ プライオリティが 24576 に変更されます。spanning-tree root primary コマンドを入力してもスイッチがルートにならない場合、ブリッジ プライオリティは現在のブリッジのブリッジ プライオリティより 4096 だけ小さい値に変更されます。ルート ブリッジになるために必要な値が 1 より小さい場合は、このコマンドは失敗します。スイッチがルートにならない場合は、エラーが発生します。

ネットワーク デバイスのデフォルト ブリッジ プライオリティが 32768 に設定されている場合に、spanning-tree root secondary コマンドを入力すると、ソフトウェアによって現在のブリッジのブリッジ プライオリティが 28762 に変更されます。ルート スイッチに障害が発生すると、このスイッチが次のルート スイッチになります。

spanning-tree root コマンドは、バックボーン スイッチ上だけで使用してください。

次に、VLAN 200 上でスパニング ツリーをイネーブルにする例を示します。

switch(config)# spanning-tree vlan 200
 

次の例では、スイッチを VLAN 10 のルート スイッチとして設定し、ネットワーク直径を 4 に設定する方法を示します。

switch(config)# spanning-tree vlan 10 root primary diameter 4
 

次の例では、スイッチを VLAN 10 のセカンダリ ルート スイッチとして設定し、ネットワーク直径を 4 に設定する方法を示します。

switch(config)# spanning-tree vlan 10 root secondary diameter 4
 

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree vlan cost

インターフェイスのスパニング ツリー ポートのパス コストを変更するには、 spanning-tree vlan cost コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree vlan vlan-id cost { port_path_cost | auto }

no spanning-tree vlan vlan-id cost { port_path_cost | auto }

 
構文の説明

vlan-id

VLAN ID 番号。VLAN ID の範囲は 0 ~ 4094 です。

port_path_cost

ポートのパス コスト。有効な範囲は 1 ~ 200,000,000 です。

auto

このインターフェイスのメディア速度に基づいてコストを決定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、インターフェイスのスパニング ツリー ポートのパス コストを変更する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# spanning-tree vlan 5 cost 200
switch(config-if)#
 

次に、インターフェイスをデフォルトのコンフィギュレーションに戻す例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no spanning-tree vlan 5 cost 200
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

 

spanning-tree vlan port-priority

インターフェイスのスパニング ツリー ポート プライオリティを変更するには、 spanning-tree vlan port-priority コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree vlan vlan-id port-priority port_priority_value

no spanning-tree vlan vlan-id port-priority port_priority_value

 
構文の説明

vlan-id

VLAN ID 番号。VLAN ID の範囲は 0 ~ 4094 です。

port_priority_value

ポート プライオリティ。指定できる範囲は 0 ~ 224 で、刻み幅は 32 です。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、インターフェイスのスパニング ツリー ポート プライオリティを 20 に変更する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# spanning-tree vlan 5 port-priority 20
switch(config-if)#
 

次に、インターフェイスをデフォルトのコンフィギュレーションに戻す例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no spanning-tree vlan 5 port-priority 20
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

 

speed(インターフェイス)

インターフェイスの送受信速度を設定するには、 speed コマンドを使用します。デフォルトの速度にリセットするには、このコマンドの no 形式を使用します。

speed { 100 | 1000 | 10000 | auto }

no speed

 
構文の説明

100

インターフェイスの速度を 100 Mbps に設定します。

(注) このキーワードは、管理インターフェイス上でサポートされません。

1000

インターフェイス速度を 1 Gbps に設定します。

10000

インターフェイス速度を 10 Gbps に設定します。これがデフォルト速度です。

(注) このキーワードは、管理インターフェイス上でサポートされません。

auto

インターフェイスの速度を自動的にネゴシエートすることを指定します。

 
コマンド デフォルト

デフォルト速度は 10000(10 ギガビット)です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(1a)N1(1)

このコマンドが追加されました。

5.1(3)N1(1)

100 Mbps のインターフェイス速度および auto キーワードが導入されました。

 
使用上のガイドライン

Cisco Nexus 5010 スイッチの最初の 8 個のポートと、Cisco Nexus 5020 スイッチの最初の 16 個のポートは、スイッチ可能な 1 ギガビット ポートと 10 ギガビット ポートです。デフォルトのインターフェイス速度は 10 ギガビットです。これらのポートを 1 ギガビット イーサネットに設定するには、1 ギガビット イーサネット SFP トランシーバを該当するポートに挿入してから、その速度を speed コマンドで設定します。


) インターフェイスとトランシーバの速度が一致しない場合、show interface ethernet slot/port コマンドを入力すると、SFP 検証失敗メッセージが表示されます。たとえば、speed 1000 コマンドを設定しないで 1 ギガビット SFP トランシーバをポートに挿入すると、このエラーが発生します。

デフォルトでは、Cisco Nexus 5000 シリーズ スイッチ上のすべてのポートは 10 ギガビットです。


次に、1 ギガビット イーサネット ポートの速度を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# speed 1000
 

次に、自動的に速度をネゴシエートするようにインターフェイス ポートを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# speed auto
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface

インターフェイス コンフィギュレーション情報を表示します。

 

state

VLAN の動作ステートを設定するには、 state コマンドを使用します。VLAN をデフォルトの動作ステートに戻すには、このコマンドの no 形式を使用します。

state { active | suspend }

no state

 
構文の説明

active

VLAN がアクティブにトラフィックを受け渡すように指定します。

suspend

VLAN がパケットを受け渡さないように指定します。

 
コマンド デフォルト

VLAN がアクティブにトラフィックを受け渡します。

 
コマンド モード

VLAN コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

VLAN 1 および VLAN 1006 ~ 4094 のステートは一時停止できません。

一時停止ステートの VLAN は、パケットを受け渡しません。

次に、VLAN 2 を一時停止する例を示します。

switch(config)# vlan 2
switch(config-vlan)# state suspend
 

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

svi enable

VLAN インターフェイスの作成をイネーブルにするには、 svi enable コマンドを使用します。VLAN インターフェイス機能をディセーブルにするには、このコマンドの no 形式を使用します。

svi enable

no svi enable

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

VLAN インターフェイスはディセーブルです。

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.0(1a)N1(1)

このコマンドは廃止予定で、 feature interface-vlan コマンドに置き換えられます。このコマンドは、下位互換性のためにいくつかのリリースにわたって保持されます。

 
使用上のガイドライン

feature interface-vlan コマンドは、VLAN インターフェイスを作成する前に使用する必要があります。

次に、スイッチでインターフェイス上の VLAN 機能をイネーブルにする例を示します。

switch(config)# svi enable
 

 
関連コマンド

コマンド
説明

interface vlan

VLAN インターフェイスを作成します。

 

svs connection

SVS 接続で Cisco Nexus 5000 シリーズ スイッチに vCenter サーバを接続できるようにするには、 svs connection コマンドを使用します。SVS 接続をディセーブルにするには、このコマンドの no 形式を使用します。

svs connection svs-name

no svs connection svs-name

 
構文の説明

svs-name

SVS 接続の名前。この名前には最大 64 文字までの英数字を指定できます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

イネーブルにできる SVS 接続は、セッションごとに 1 つだけです。

このコマンドには、ライセンスは必要ありません。

次に、SVS 接続をイネーブルにする例を示します。

switch# configure terminal
switch(config)# svs connection SVSConn
switch(config-svs-conn)#
 

次に、SVS 接続をディセーブルにする例を示します。

switch# configure terminal
switch(config)# no svs connection SVSConn
switch(config)#
 

 
関連コマンド

コマンド
説明

connect

vCenter Server との接続を開始します。

protocol vmware-vim

VMware VI SDK をイネーブルにします。

show svs connections

SVS 接続の情報を表示します。

remote

リモート マシンに接続します。

vmware dvs

VMware 仮想スイッチを作成します。

 

svs veth auto-delete

仮想 NIC(vNIC)でもハイパーバイザ ポートでも使用しなくなった分散仮想ポート(dvPort)を仮想スーパーバイザ モジュール(VSM)で自動的に削除できるようにするには、 svs veth auto-delete コマンドを使用します。このコントロールをディセーブルにするには、このコマンドの no 形式を使用します。

svs veth auto-delete

no svs veth auto-delete

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

イネーブルの場合(デフォルト)、管理的にダウンしている仮想イーサネット インターフェイスは、対応する vNIC でそのインターフェイスが使用されていないことを vCenter Server で確認したうえで、すべて削除されます。

このコマンドには、ライセンスは必要ありません。

次に、vNIC でもハイパーバイザ ポートでも使用しなくなった dvPort を仮想スーパーバイザ モジュール(VSM)で自動的に削除できるようにする例を示します。

switch# configure terminal
switch(config)# svs veth auto-delete
switch(config)#
 

次に、vNIC でもハイパーバイザ ポートでも使用しなくなった dvPort の自動削除をディセーブルにする例を示します。

switch# configure terminal
switch(config)# no svs veth auto-delete
switch(config)#
 

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを作成します。

show svs connections

SVS 接続の情報を表示します。

svs veth auto-setup

ホストで新しいポートがアクティブになったときに VSM で自動的に仮想イーサネット インターフェイスを作成できるようにします。

 

svs veth auto-setup

ホストで新しいポートがアクティブになると仮想スーパーバイザ モジュール(VSM)で自動的に仮想イーサネット インターフェイスを作成できるようにするには、 svs veth auto-setup コマンドを使用します。このコントロールを削除するには、このコマンドの no 形式を使用します。

svs veth auto-setup

no svs veth auto-setup

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、仮想イーサネット インターフェイスの自動的な作成と設定をイネーブルにする例を示します。

switch# configure terminal
switch(config)# svs veth auto-setup
switch(config)#
 

次に、仮想イーサネット インターフェイスの自動的な作成と設定をディセーブルにする例を示します。

switch# configure terminal
switch(config)# no svs veth auto-setup
switch(config)#
 

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを作成します。

show svs connections

SVS 接続の情報を表示します。

svs veth auto-delete

vNIC でもハイパーバイザ ポートでも使用しなくなった dvPort を VSM で自動的に削除できるようにします。

 

switchport access vlan

インターフェイスがアクセス モードのときにアクセス VLAN を設定するには、 switchport access vlan コマンドを使用します。アクセス モード VLAN をスイッチの適切なデフォルト VLAN にリセットするには、このコマンドの no 形式を使用します。

switchport access vlan vlan-id

no switchport access vlan

 
構文の説明

vlan-id

インターフェイスがアクセス モードのときに設定する VLAN。内部使用に予約されている VLAN を除き、有効な範囲は 1 ~ 4094 秒です。

 
コマンド デフォルト

VLAN 1

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.1(3)N1(1)

仮想イーサネット インターフェイスのサポートが追加されました。

 
使用上のガイドライン

アクセス モード VLAN をスイッチの適切なデフォルト VLAN にリセットするには、 switchport access vlan コマンドの no 形式を使用します。このアクションにより、ポートが接続されているデバイスに関するメッセージが生成される場合があります。

次に、VLAN 2 に参加するようにイーサネット インターフェイスを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/7
switch(config-if)# switchport access vlan 2
switch(config-if)#
 

次に、VLAN 5 に参加するように仮想イーサネット インターフェイスを設定する例を示します。

switch# configure terminal
switch(config)# interface vethernet 1
switch(config-if)# switchport access vlan 5
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface switchport

ポートの管理ステータスおよび動作ステータスを表示します。

show interface vethernet

仮想イーサネット インターフェイスの情報を表示します。

 

switchport backup interface

レイヤ 2 インターフェイスに、相互にバックアップする 2 個のインターフェイスである Flex Link を設定するには、 switchport backup interface コマンドを使用します。Flex Link の設定を削除するには、このコマンドの no 形式を使用します。

switchport backup interface { ethernet slot / port | port-channel channel-no } [ multicast fast-convergence | preemption { delay delay-time | mode [ bandwidth | forced | off ]}]

no switchport backup interface { ethernet slot / port | port-channel channel-no } [ multicast fast-convergence | preemption { delay delay-time | mode [ bandwidth | forced | off ]}]

 
構文の説明

ethernet slot / port

バックアップ イーサネット インターフェイスを指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

port-channel channel-no

ポート チャネル インターフェイスを指定します。インターフェイス番号は 1~4096 です。

multicast

(任意)マルチキャスト パラメータを設定するように指定します。

fast-convergence

(任意)バックアップ インターフェイスの高速コンバージェンスを設定します。

preemption

(任意)バックアップ インターフェイス ペアのプリエンプション スキームを設定するように指定します。

delay delay-time

(任意)プリエンプション遅延を指定します。範囲は 1 ~ 300 秒です。

mode

(任意)プリエンプション モードを指定します。

bandwidth

(任意)より多くの帯域幅を使用できるインターフェイスが常にバックアップに優先することを指定します。

forced

(任意)常にバックアップをプリエンプトするインターフェイスを指定します。

off

(任意)バックアップからアクティブへのプリエンプションが発生しないことを指定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N2(1)

このコマンドが追加されました。

 
使用上のガイドライン


) このコマンドは、Cisco Nexus 5548 シリーズ スイッチと Cisco Nexus 5596 シリーズ スイッチに適用されます。


このコマンドを使用する前に、 feature flexlink コマンドを使用してスイッチの Flex Link を確実にイネーブルにする必要があります。


) 仮想ポート チャネル(vPC)がスイッチでディセーブルになっていることを確認します。


Flex Link ポートは物理イーサネット ポートでもポート チャネルでもかまいません。

次のタイプのインターフェイスの Flex Link ポートは設定できません。

ファブリック エクステンダ(FEX)ファブリック ポートおよび FEX ホスト ポート

仮想ファイバ チャネル インターフェイス

仮想ネットワーク タグ(VNTag)

ポート セキュリティがイネーブルであるインターフェイス

レイヤ 3 インターフェイス

スイッチド ポート アナライザ(SPAN)宛先

ポート チャネル メンバー

プライベート VLAN で設定されたインターフェイス

Endnode モード

ファブリック パス コア インターフェイス(レイヤ 2 マルチパス)

次に、イーサネット 1/1 およびイーサネット 1/12 を Flex Link として設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport backup interface ethernet 1/12
switch(config-if)#
 

次に、EtherChannel 100 および EtherChannel 101 を Flex Link として設定する例を示します。

switch# configure terminal
switch(config)# interface port-channel 100
switch(config-if)# switchport backup interface port-channel 101
switch(config-if)#
 

次に、常にバックアップをプリエンプトするようにイーサネット インターフェイスを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet1/10
switch(config-if)# switchport backup interface ethernet1/2 preemption mode forced
switch(config-if)#
 

次に、イーサネット インターフェイスのプリエンプション遅延時間を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet1/1
switch(config-if)# switchport backup interface ethernet1/12 preemption delay 150
switch(config-if)#
 

次に、バックアップ インターフェイスの高速コンバージェンスを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet1/1
switch(config-if)# switchport backup interface ethernet1/12 multicast fast-convergence
switch(config-if)#

 
関連コマンド

コマンド
説明

feature flexlink

レイヤ 2 インターフェイスの Flex Link をイネーブルにします。

show interface switchport backup

バックアップ インターフェイスを表示します。

switchport block

不明のマルチキャストまたはユニキャスト パケットが転送されないようにするには、 switchport block コマンドを使用します。不明のマルチキャストまたはユニキャスト パケットの転送を許可するには、このコマンドの no 形式を使用します。

switchport block { multicast | unicast }

no switchport block { multicast | unicast }

 
構文の説明

multicast

不明のマルチキャスト トラフィックがブロックされるように指定します。

unicast

不明のユニキャスト トラフィックがブロックされるように指定します。

 
コマンド デフォルト

未知のマルチキャストおよびユニキャスト トラフィックはブロックされません。未知の MAC アドレスを持ったすべてのトラフィックがすべてのポートに送信されます。

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.1(3)N1(1)

仮想イーサネット インターフェイスのサポートが追加されました。

 
使用上のガイドライン

スイッチ ポート上の不明なマルチキャストまたはユニキャスト トラフィックをブロックできます。

不明なマルチキャストまたはユニキャスト トラフィックのブロックは、スイッチ ポート上で自動的にイネーブルにはなりません。明示的に設定する必要があります。

次に、インターフェイス上で不明なマルチキャスト トラフィックをブロックする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport block multicast
switch(config-if)#
 

次に、仮想イーサネット インターフェイス上で不明なユニキャスト トラフィックをブロックする例を示します。

switch# configure terminal
switch(config)# interface vethernet 1
switch(config-if)# switchport block uniicast
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface switchport

指定のインターフェイスまたはすべてのインターフェイスのスイッチ ポート情報を表示します。

show interface vethernet

仮想イーサネット インターフェイスのコンフィギュレーション情報を表示します。

 

switchport host

インターフェイスをアクセス ホスト ポートに設定するには、 switchport host コマンドを使用します。ホスト ポートを削除するには、このコマンドの no 形式を使用します。

switchport host

no switchport host

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

適切なインターフェイスを設定していることを確認します。エンド ステーションに接続されているインターフェイスを設定する必要があります。

アクセス ホスト ポートは、エッジ ポートと同じように STP を処理して、ブロッキング ステートおよびラーニング ステートを経由せずに、フォワーディング ステートに直接移行します。インターフェイスをアクセス ホスト ポートとして設定すると、そのインターフェイス上で EtherChannel 動作がディセーブルになります。

次に、EtherChannel がディセーブルにされたイーサネット アクセス ホスト ポートとしてインターフェイスを設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# switchport host
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface brief

インターフェイス設定情報のサマリーを表示します。

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport mode

非トランキングでタグなしの単一 VLAN イーサネット インターフェイスまたは仮想イーサネット インターフェイスとしてインターフェイスを設定するには、 switchport mode コマンドを使用します。設定を削除してデフォルトに戻すには、このコマンドの no 形式を使用します。

switchport mode { access | trunk | vntag }

no switchport mode { access | trunk | vntag }

no switchport mode

 
構文の説明

access

インターフェイスがアクセス モードになるように指定します。

trunk

インターフェイスがトランク モードになるように指定します。

vntag

インターフェイスがポート モードであることを指定します。

(注) このキーワードは、仮想イーサネット インターフェイスには適用されません。

 
コマンド デフォルト

アクセス ポートは VLAN 1 のトラフィックを送受信します。

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.1(3)N1(1)

仮想イーサネット インターフェイスのサポートが追加されました。

 
使用上のガイドライン

アクセス ポートは、1 つの VLAN のトラフィックだけを伝送できます。アクセス ポートは、デフォルトで、VLAN 1 のトラフィックを送受信します。異なる VLAN のトラフィックを送受信するようアクセス ポートを設定するには、 switchport access vlan コマンドを使用します。

VLAN をアクセス VLAN として指定するには、その VLAN が存在しなければなりません。システムは、存在しないアクセス VLAN に割り当てられたアクセス ポートをシャット ダウンします。

仮想ネットワーク タグ(VNTag)ポートは、その物理ポートの仮想インターフェイスの識別に役立ちます。

仮想イーサネット インターフェイスの場合は、キーワードを指定せずにこのコマンドの no 形式を使用します。

次に、指定された VLAN のみのトラフィックを送受信するイーサネット アクセス ポートとしてインターフェイスを設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan 5
switch(config-if)#
 

次に、VNTag ポートとしてインターフェイスを設定する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# switchport mode vntag
switch(config-if)#
 

次に、トランク ポート モードで仮想イーサネット インターフェイスを設定する例を示します。

switch# configure terminal
switch(config)# interface vethernet 1
switch(config-if)# switchport mode trunk
switch(config-if)#
 

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを設定します。

show interface ethernet

指定されたイーサネット インターフェイスに関する情報を表示します。

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport access vlan

インターフェイスがアクセス モードの場合にアクセス VLAN を設定します。

 

switchport mode private-vlan host

インターフェイス タイプをプライベート VLAN のホスト ポートとして設定するには、 switchport mode private-vlan host コマンドを使用します。設定を削除するには、このコマンドの no 形式を使用します。

switchport mode private-vlan host

no switchport mode

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.1(3)N1(1)

仮想イーサネット インターフェイスのサポートが追加されました。

 
使用上のガイドライン

ポートをプライベート VLAN ホスト ポートとして設定し、次のいずれか 1 つがあてはまる場合にはポートが非アクティブになります。

ポートに有効なプライベート VLAN 関連付けが設定されていない。

ポートが Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)宛先である。

プライベート VLAN 関連付けが一時停止されている。

プライベート VLAN ポート関連付けを削除するか、プライベート ポートを SPAN 宛先として設定した場合、削除されたプライベート VLAN ポート関連付けまたは SPAN 宛先として設定されたプライベート ポートは非アクティブになります。


) スパニング ツリー BPDU ガードをすべてのプライベート VLAN ホスト ポートでイネーブルにすることを推奨します。


次に、ポートをプライベート VLAN のホスト モードに設定する例を示します。

switch(config-if)# switchport mode private-vlan host
 

次に、仮想イーサネット インターフェイス ポートをプライベート VLAN に対してホスト モードに設定する例を示します。

switch# configure terminal
switch(config)# interface vethernet 1
switch(config-if)# switchport mode private-vlan host
switch(config-if)#
 

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを設定します。

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

show vlan private-vlan

プライベート VLAN のステータスを表示します。

 

switchport mode private-vlan promiscuous

インターフェイス タイプをプライベート VLAN 無差別ポートに設定するには、 switchport mode private-vlan promiscuous コマンドを使用します。

switchport mode private-vlan promiscuous

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

ポートをプライベート VLAN 無差別モード ポートとして設定し、次のいずれか 1 つがあてはまる場合はポートが非アクティブになります。

ポートに有効なプライベート VLAN マッピングが設定されていない。

ポートが Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)宛先である。

プライベート VLAN ポート マッピングを削除するか、プライベート ポートを SPAN 宛先として設定した場合、削除されたプライベート VLAN ポート マッピングまたは SPAN 宛先として設定されたプライベート ポートは非アクティブになります。

無差別モード ポートの詳細については private-vlan コマンドを参照してください。

次に、ポートをプライベート VLAN の無差別モードに設定する例を示します。

switch(config-if)# switchport mode private-vlan promiscuous
 

 
関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

show vlan private-vlan

プライベート VLAN のステータスを表示します。

switchport mode private-vlan trunk

プライベート VLAN でセカンダリ トランク ポートとしてポートを設定するには、 switchport mode private-vlan trunk コマンドを使用します。独立トランク ポートを削除するには、このコマンドの no 形式を使用します。

switchport mode private-vlan trunk [ promiscous | secondary ]

no switchport mode private-vlan trunk [ promiscous | secondary ]

 
構文の説明

promiscous

(任意)無差別モード ポートを指定します。

secondary

(任意)セカンダリ ポートを指定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

プライベート VLAN ドメインで、独立トランクは、セカンダリ VLAN の一部です。独立トランク ポートは、複数の独立 VLAN を送受信できます。

次に、プライベート VLAN で、イーサネット インターフェイス 1/1 を無差別トランク ポートとして設定する例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# switchport mode private-vlan trunk promiscous
switch(config-if)#
 

次に、プライベート VLAN で、イーサネット インターフェイス 1/5 をセカンダリ トランク ポートとして設定する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# switchport mode private-vlan trunk secondary
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport private-vlan association trunk

プライベート VLAN のプライマリ VLAN およびセカンダリ VLAN に、独立トランク ポートを関連付けます。

switchport monitor rate-limit

インターフェイス上のトラフィックをモニタするときのレート制限を設定するには、 switchport monitor rate-limit コマンドを使用します。レート制限を削除するには、このコマンドの no 形式を使用します。

switchport monitor rate-limit 1G

no switchport monitor rate-limit [ 1G ]

 
構文の説明

1G

(任意)レート制限が 1 GB であることを指定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、次の Cisco Nexus 5000 シリーズ スイッチに適用されます。

Cisco Nexus 5010 シリーズ

Cisco Nexus 5020 シリーズ

このコマンドには、ライセンスは必要ありません。

次に、イーサネット インターフェイス 1/2 の帯域幅を 1 GB に制限する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# switchport monitor rate-limit 1G
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport private-vlan association trunk

プライベート VLAN のプライマリ VLAN およびセカンダリ VLAN に、独立トランク ポートを関連付けます。

 

switchport port-security

インターフェイス上でポート セキュリティをイネーブルにするには、 switchport port-security コマンドを使用します。ポートのポート セキュリティをディセーブルにするには、このコマンドの no 形式を使用します。

switchport port-security

no switchport port-security

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、レイヤ 2 インターフェイスのポート セキュリティをイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# switchport port-security
switch(config-if)#
 

次に、インターフェイスのポート セキュリティをディセーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport port-security
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show port-security

ポート セキュリティのコンフィギュレーション情報を表示します。

 

switchport port-security aging

レイヤ 2 ポートでポート セキュリティ エージングをイネーブルにするには、 switchport port-security aging コマンドを使用します。ポートのポート セキュリティをディセーブルにするには、このコマンドの no 形式を使用します。

switchport port-security aging { time aging-time | type { absolute | inactivity }}

no switchport port-security aging { time aging-time | type { absolute | inactivity }}

 
構文の説明

time aging-time

すべてのアドレスが保護される期間を設定します。有効値は 1 ~ 1440 分です。

type

エージングのタイプを指定します。

absolute

absolute エージングを指定します。

inactivity

トラフィックがないときにのみタイマーの実行を開始することを指定します。

 
コマンド デフォルト

エージング時間は 0

エージング タイプは absolute

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、ポートでセキュア MAC アドレスのエージング タイプを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# switchport port-security aging type absolute
switch(config-if)#
 

次に、セキュア MAC アドレスのエージング時間を 2 分に設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# switchport port-security aging time 2
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show port-security

ポート セキュリティのコンフィギュレーション情報を表示します。

switchport port-security

ポート セキュリティを確立するようにスイッチポート パラメータを設定します。

 

switchport port-security mac-address

レイヤ 2 インターフェイスにスタティック セキュア MAC アドレスを追加する場合や、インターフェイスのスティッキ MAC アドレス ラーニングをイネーブルにする場合は、 switchport port-security mac-address コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchport port-security mac-address { MAC-addr [ vlan vlan-ID ] | sticky }

no switchport port-security mac-address { MAC-addr [ vlan vlan-ID ] | sticky }

 
構文の説明

mac-addr

形式 E . E . E . の MAC アドレス。

vlan vlan-ID

(任意)MAC アドレスを保護する VLAN を指定します。有効な範囲は 1 ~ 4094 です。

sticky

インターフェイス上でダイナミック MAC アドレスをスティッキとして設定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、ポートにスタティック セキュア MAC アドレスを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# switchport port-security mac-address 0050.3e8d.6400
switch(config-if)#
 

次に、スティッキ MAC アドレスによるポート セキュリティをポート上でイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# switchport port-security mac-address sticky
switch(config-if)#
 

次に、セキュア MAC アドレス リストから MAC アドレスを削除する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport port-security mac-address 0050.3e8d.6400
switch(config-if)#

 
関連コマンド

コマンド
説明

show port-security

ポート セキュリティのコンフィギュレーション情報を表示します。

 

switchport port-security maximum

ポート上のセキュア MAC アドレスの最大数を設定するには、 switchport port-security maximum コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchport port-security maximum max-addr [ vlan vlan-ID ]

no switchport port-security maximum max-addr [ vlan vlan-ID ]

 
構文の説明

max-addr

インターフェイスのセキュア MAC アドレスの最大数を指定します。有効値は 1~1025 です。

vlan vlan-ID

(任意)MAC アドレスを保護する VLAN を指定します。有効な範囲は 1 ~ 4094 です。

 
コマンド デフォルト

1

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、ポートのセキュア MAC アドレスの最大数を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# switchport port-security maximum 5
switch(config-if)#
 

次に、特定の VLAN で設定されているセキュア MAC アドレスの最大数を上書きする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# switchport port-security maximum 3 vlan 10
switch(config-if)#
 

次に、ポートのセキュア MAC アドレスの最大数をデフォルト値に設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport port-security maximum 5
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show port-security

ポート セキュリティのコンフィギュレーション情報を表示します。

 

switchport port-security violation

セキュリティ違反が検出された場合に実行するアクションを設定するには、 switchport port-security violation コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchport port-security violation { protect | restrict | shutdown }

no switchport port-security violation { protect | restrict | shutdown }

 
構文の説明

protect

ポート セキュリティ プロセス レベルの非セキュア ホストからのすべてのパケットを廃棄しますが、セキュリティ違反数は増加させません。

restrict

ポート セキュリティ プロセス レベルの非セキュア ホストからのすべてのパケットを廃棄して、セキュリティ違反数を増加させます。

shutdown

セキュリティ違反がある場合、ポートをシャットダウンします。

 
コマンド デフォルト

shutdown

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、ポートのポート セキュリティ違反モードを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# switchport port-security violation protect
switch(config-if)#
 

次に、ポートのポート セキュリティ違反モードをデフォルト値に設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport port-security violation protect
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show port-security

ポート セキュリティのコンフィギュレーション情報を表示します。

 

switchport priority extend

接続先デバイスから Cisco IP Phone のポートに着信するフレームのプライオリティを上書きするようにスイッチを設定するには、 switchport priority extende コマンドを使用します。ポートをそのデフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchport priority extend { cos cos-value | trust }

no switchport priority extend

 
構文の説明

cos

データ トラフィックをサービス クラス(CoS)値でマーク付けするように Cisco IP Phone に指示する CDP パケットをスイッチが送信するように指定します。

cos-value

CoS 値 有効な範囲は 0 ~ 7 です。

trust

Cisco IP Phone にタグ付きデータ トラフィックを信頼するように指示する CDP パケットをスイッチが送信するように指定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N2(1)

このコマンドが追加されました。

次に、タグ付きデータ トラフィックを信頼するように Cisco IP Phone ポートを設定する例を示します。

switch(config)# interface ethernet 1/28
switch(config-if)# switchport priority extend trust
switch(config-if)#
 

次に、CoS 値でデータ トラフィックをマーク付けするように Cisco IP Phone ポートを設定する例を示します。

switch(config)# interface ethernet 1/28
switch(config-if)# switchport priority extend cos 3
switch(config-if)#
 

次に、デフォルト設定に戻す例を示します。

switch(config)# interface ethernet 1/28
switch(config-if)# no switchport priority extend
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport private-vlan association trunk

独立トランク ポートをプライベート VLAN のプライマリ VLAN およびセカンダリ VLAN に関連付けるには、 switchport private-vlan association trunk コマンドを使用します。独立トランク ポートの関連付けを削除するには、このコマンドの no 形式を使用します。

switchport private-vlan association trunk primary-id secondary-id

no switchport private-vlan association trunk

 
構文の説明

primary-id

プライマリ VLAN ID。有効な範囲は 1 ~ 3967 および 4048 ~ 4093 です。

secondary-id

セカンダリ VLAN ID。有効な範囲は 1 ~ 3967 および 4048 ~ 4093 です。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

セカンダリ VLAN は独立 VLAN である必要があります。指定されたプライマリ VLAN の 1 つの独立 VLAN のみを、独立トランク ポートに関連付けることができます。

次に、セカンダリ VLAN をプライマリ VLAN にマップする例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# switchport mode private-vlan trunk secondary
switch(config-if)# switchport private-vlan association trunk 5 100
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport mode private-vlan trunk

プライベート VLAN のセカンダリ トランク ポートとしてポートを設定します。

show vlan private-vlan

プライベート VLAN のステータスを表示します。

switchport private-vlan host-association

独立ポートまたはコミュニティ ポートのプライベート VLAN 関連付けを定義するには、switchport private-vlan host-association コマンドを使用します。ポートからプライベート VLAN 関連付けを削除するには、このコマンドの no 形式を使用します。

switchport private-vlan host-association { primary-vlan-id } { secondary-vlan-id }

no switchport private-vlan host-association

 
構文の説明

primary-vlan-id

プライベート VLAN 関係のプライマリ VLAN の番号。有効な範囲は 1 ~ 3967 および 4048 ~ 4093 です。

secondary-vlan-id

プライベート VLAN 関係のセカンダリ VLAN の番号。有効な範囲は 1 ~ 3967 および 4048 ~ 4093 です。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.1(3)N1(1)

仮想イーサネット インターフェイスのサポートが追加されました。

 
使用上のガイドライン

ポートがプライベート VLAN のホスト モードでない限り、ポート上でランタイムの効果はありません。ポートがプライベート VLAN ホスト モードであっても、VLAN がどちらも存在しない場合は、コマンドは許可されますが、ポートは非アクティブになります。プライベート VLAN 間の関連付けが一時停止されている場合も、ポートが非アクティブになる可能性があります。

セカンダリ VLAN は、独立 VLAN またはコミュニティ VLAN である可能性があります。

プライマリ VLAN、セカンダリ VLAN、 および独立ポートまたはコミュニティ ポートの詳細については、 private-vlan コマンドを参照してください。


) 現行リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチのプライベート VLAN 独立ポートは、IEEE 802.1Q のカプセル化をサポートしておらず、トランク ポートとして使用できません。


次に、プライマリ VLAN(VLAN 18)およびセカンダリ VLAN(VLAN 20)とのレイヤ 2 プライベート VLAN ホスト ポートを設定する例を示します。

switch(config-if)# switchport private-vlan host-association 18 20
 

次に、ポートからプライベート VLAN 関連付けを削除する例を示します。

switch(config-if)# no switchport private-vlan host-association
 

次に、仮想イーサネット インターフェイスのホストのプライベート VLAN ポートにプライマリ VLAN(VLAN 5)とセカンダリ VLAN(VLAN 23)を設定する例を示します。

switch# configure terminal
switch(config)# interface vethernet 1
switch(config-if)# switchport private-vlan host-association 5 23
switch(config-if)#
 

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを設定します。

show vlan private-vlan

プライベート VLAN に関する情報を表示します。

 

switchport private-vlan mapping

無差別ポートのプライベート VLAN 関連付けを定義するには、 switchport private-vlan mapping コマンドを使用します。プライマリ VLAN からすべてのマッピングをクリアするには、このコマンドの no 形式を使用します。

switchport private-vlan mapping { primary-vlan-id | trunk primary-vlan-id } { secondary-vlan-id | { add | remove } secondary-vlan-id }

no switchport private-vlan mapping [ { primary-vlan-id | trunk primary-vlan-id } secondary-vlan-id ]

 
構文の説明

primary-vlan-id

プライベート VLAN 関係のプライマリ VLAN の番号。

trunk

プライベート VLAN 無差別トランク ポートを指定します。

(注) このキーワードは、レイヤ 2 インターフェイスにのみ適用されます。

add

(任意)セカンダリ VLAN をプライマリ VLAN に関連付けます。

secondary-vlan-id

プライベート VLAN 関係のセカンダリ VLAN の番号。

remove

セカンダリ VLAN とプライマリ VLAN 間の関連付けを消去します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(2)N2(1)

セカンダリ VLAN の最大数は 16 です。

5.1(3)N1(1)

仮想イーサネット インターフェイスのサポートが追加されました。

 
使用上のガイドライン

ポートがプライベート VLAN の無差別モードでない限り、ポート上でランタイムの効果はありません。ポートがプライベート VLAN 無差別モードであっても、プライマリ VLAN が存在しない場合は、コマンドは許可されますが、ポートは非アクティブになります。

セカンダリ VLAN は、独立 VLAN またはコミュニティ VLAN である可能性があります。

プライマリ VLAN、セカンダリ VLAN、 および独立ポートまたはコミュニティ ポートの詳細については、 private-vlan コマンドを参照してください。


) 現行リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチのプライベート VLAN 独立ポートは、IEEE 802.1Q のカプセル化をサポートしておらず、トランク ポートとして使用できません。



) Cisco NX-OS Release 5.0(2)N2(1) 以降、プライベート VLAN トランク ポートでのマッピング数は 16 に制限されています。


次に、プライベート VLAN 無差別ポートでセカンダリ独立 VLAN 20 にプライマリ VLAN 18 を関連付けるように設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport mode private-vlan promiscous
switch(config-if)# switchport private-vlan mapping 18 20
 

次に、無差別ポート上の関連付けに VLAN を追加する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/2
switch(config-if)# switchport mode private-vlan promiscous
switch(config-if)# switchport private-vlan mapping 18 add 21
 

次に、プライベート VLAN 無差別トランク ポートでセカンダリ独立 VLAN 20 ~ 32 にプライマリ VLAN 30 を関連付けるように設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/21
switch(config-if)# switchport mode private-vlan promiscous trunk
switch(config-if)# switchport private-vlan mapping trunk 30 20-32
switch(config-if)#
 

次に、プライベート VLAN 無差別トランク ポートで、(合計で 16 個のセカンダリ VLAN という許容限度を上回る)セカンダリ独立 VLAN 50 ~ 100 にプライマリ VLAN 30 を関連付けるように設定するときに表示されるエラー メッセージを表示します。

switch# configure terminal
switch(config)# interface ethernet 1/12
switch(config-if)# switchport mode private-vlan promiscous trunk
switch(config-if)# switchport private-vlan mapping trunk 30 50-100
ERROR: secondary VLAN list contains primary VLAN id in trunk promiscuous port mapping.
switch(config-if)#
 

次に、ポートからすべてのプライベート VLAN 関連付けを削除する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport private-vlan mapping
switch(config-if)#
 

次に、仮想イーサネット インターフェイスのホストでプライマリ VLAN 12 をセカンダリ独立 VLAN 20 に設定する例を示します。

switch# configure terminal
switch(config)# interface vethernet 1
switch(config-if)# switchport private-vlan mapping 12 20
switch(config-if)#
 

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを設定します。

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

show interface private-vlan mapping

VLAN インターフェイスのプライベート VLAN マッピングまたは SVI に関する情報を表示します。

 

switchport private-vlan trunk allowed vlan

プライベート トランク インターフェイスの許容 VLAN を設定するには、 switchport private-vlan trunk allowed vlan コマンドを使用します。許容 VLAN を削除するには、このコマンドの no 形式を使用します。

switchport private-vlan trunk allowed vlan { vlan-list | { add | except | remove } vlan-list | all | none }

no switchport private-vlan trunk allowed vlan vlan-list

 
構文の説明

vlan-list

インターフェイスがプライベート VLAN トランキング モードのときの、許容 VLAN の VLAN ID。内部使用に予約されている VLAN を除き、有効な範囲は 1 ~ 4094 秒です。

ハイフン(-)を使用して、VLAN ID の範囲の開始 ID と終了 ID を区別します(たとえば、70-100)。

カンマ(,)を使用して、各 VLAN ID および VLAN ID の範囲を区別します(たとえば、20,70-100,142)。

add

現在のリストに追加する VLAN を指定します。

except

現在のリストに追加するすべての VLAN を指定します。ただし、指定された VLAN は除きます。

remove

現在のリストから削除する VLAN を指定します。

all

現在のリストに追加するすべての VLAN を指定します。

none

現在のリストに追加する VLAN がないことを指定します。

 
コマンド デフォルト

プライベート VLAN トランク インターフェイス上で関連付けられている VLAN のみが許容されます。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

プライマリ VLAN は、許容 VLAN リストに明示的に追加する必要はありません。プライマリ VLAN とセカンダリ VLAN との間で 1 回マッピングされると、自動的に追加されます。

次に、イーサネット プライベート VLAN トランク ポートで、許容 VLAN のリストに VLAN を追加する例を示します。

switch(config)# interface ethernet 1/3
switch(config-if)# switchport private-vlan trunk allowed vlan 15-20
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport mode private-vlan trunk

プライベート VLAN のセカンダリ トランク ポートとしてポートを設定します。

show vlan private-vlan

プライベート VLAN のステータスを表示します。

switchport private-vlan trunk native

プライベート VLAN トランクのネイティブ VLAN ID を設定するには、 switchport private-vlan trunk native コマンドを使用します。プライベート VLAN トランクからネイティブ VLAN ID を削除するには、このコマンドの no 形式を使用します。

switchport private-vlan trunk native vlan vlan-list

no switchport private-vlan trunk native vlan vlan-list

 
構文の説明

vlan vlan-list

VLAN ID を指定します。有効な範囲は 1 ~ 3967 および 4048 ~ 4093 です。

 
コマンド デフォルト

VLAN 1

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

セカンダリ VLAN は、無差別トランク ポートではネイティブ VLAN ID で設定できません。プライマリ VLAN は、独立トランク ポートではネイティブ VLAN ID で設定できません。

次に、セカンダリ VLAN をプライマリ VLAN にマップする例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# switchport private-vlan trunk native vlan 5
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface switchport

スイッチポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport mode private-vlan trunk

プライベート VLAN のセカンダリ トランク ポートとしてポートを設定します。

show vlan private-vlan

プライベート VLAN のステータスを表示します。

 

switchport trunk allowed vlan

仮想イーサネット インターフェイスの許可 VLAN を設定するには、 switchport trunk allowed vlan コマンドを使用します。設定を削除するには、このコマンドの no 形式を使用します。

switchport trunk allowed vlan {{ add | except | remove } vlan_list | all | none }

no switchport trunk allowed vlan

 
構文の説明

add

現在のリストに追加する VLAN を指定します。

except

現在のリストに追加するすべての VLAN を指定します。ただし、指定された VLAN は除きます。

remove

現在のリストから削除する VLAN を指定します。

vlan_list

インターフェイスがトランキング モードの場合の許可 VLAN の VLAN ID。内部使用に予約されている VLAN を除き、有効な範囲は 1 ~ 4094 秒です。

ハイフン(-)を使用して、VLAN ID の範囲の開始 ID と終了 ID を区別します(たとえば、70-100)。

カンマ(,)を使用して、各 VLAN ID および VLAN ID の範囲を区別します(たとえば、20,70-100,142)。

all

現在のリストに追加するすべての VLAN を指定します。

none

現在のリストに追加する VLAN がないことを指定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、仮想イーサネット インターフェイスのトランク ポートで許可 VLAN のリストに VLAN を追加する例を示します。

switch# configure terminal
switch(config)# interface vethernet 1
switch(config-if)# switchport trunk allowed vlan 5-15
switch(config-if)#
 

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを設定します。

show running-config

実行システム コンフィギュレーション情報を表示します。

 

switchport trunk native vlan

仮想イーサネット インターフェイスのネイティブ VLAN ID を設定するには、 switchport trunk native vlan コマンドを使用します。仮想イーサネット インターフェイスからネイティブ VLAN ID を削除するには、このコマンドの no 形式を使用します。

switchport trunk native vlan vlan_ID

no switchport trunk native vlan

 
構文の説明

vlan_ID

このポートがトランキング モードの場合のネイティブ VLAN の VLAN ID。有効な範囲は 1 ~ 4094 です。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、VLAN 3 をネイティブ トランク ポートとして設定する例を示します。

switch# configure terminal
switch(config)# interface vethernet 1
switch(config-if)# switchport trunk native vlan 3
switch(config-if)#
 

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを設定します。

show running-config

実行システム コンフィギュレーション情報を表示します。

 

switchport voice vlan

ポートに音声 VLAN を設定するには、 switchport voice vlan コマンドを使用します。音声 VLAN を削除するには、このコマンドの no 形式を使用します。

switchport voice vlan { vlan-list | dot1p | untagged }

no switchport voice vlan

 
構文の説明

vlan-list

VLAN ID です。有効な範囲は 1 ~ 3967 および 4048 ~ 4093 です。

dot1p

Cisco IP Phone がプライオリティ タギングを使用し、音声トラフィックの場合は 0 の 802.1p VLAN ID を使用するように指定します。

untagged

Cisco IP Phone が音声トラフィックのフレームにタグを付けないように指定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N2(1)

このコマンドが追加されました。

次に、音声 VLAN として VLAN 3 を設定する例を示します。

switch(config)# interface ethernet 1/28
switch(config-if)# switchport voice vlan 3
switch(config-if)#
 

次に、802.1p フレームで音声トラフィックを伝送するように Cisco IP Phone を設定する CDP パケットを送信するように、イーサネット ポートを設定する例を示します。

switch(config)# interface ethernet 1/28
switch(config-if)# switchport voice vlan dot1p
switch(config-if)#
 

次に、タグなし音声トラフィックを伝送するように Cisco IP Phone を設定する CDP パケットを送信するように、イーサネット ポートを設定する例を示します。

switch(config)# interface ethernet 1/28
switch(config-if)# switchport voice vlan untagged
switch(config-if)#
 

次に、イーサネット ポート上で音声トラフィックを停止する例を示します。

switch(config)# interface ethernet 1/28
switch(config-if)# no switchport voice vlan
switch(config-if)#

system private-vlan fex trunk

ポートで PVLAN FEX トランクを設定するには、 system private-vlan fex trunk コマンドを使用します。PVLAN FEX トランク ポートを削除するには、このコマンドの no 形式を使用します。

system private-vlan fex trunk

no system private-vlan fex trunk


注意 FEX トランク ポートで PVLAN を設定する前に、すべての FEX 隔離トランク ポートをディセーブルにする必要があります。FEX 隔離トランク ポートと FEX トランク ポートの両方をイネーブルにすると、不要なトラフィックが発生することがあります。

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N2(1)

このコマンドが追加されました。

次に、FEX トランク ポート上で PVLAN を設定する例を示します。

switch# configure terminal
switch(config-if)# System private-vlan fex trunk
switch(config-if)# copy running-config startup-config

 
関連コマンド

コマンド
説明

feature private-vlan

プライベート VLAN をイネーブルにします。