Cisco Nexus 5000 Series NX-OS レイヤ 2 インターフェイス コマンド リファレンス Cisco NX-OS Release 4.x、5.x
M コマンド
M コマンド
発行日;2012/06/17 | 英語版ドキュメント(2012/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

M コマンド

mac address-table aging-time

mac address-table notification

mac address-table static

management

monitor erspan origin ip-address

monitor session

mst(STP)

mvr group

mvr type

mvr vlan

M コマンド

この章では、M で始まる Cisco NX-OS イーサネット コマンドおよび仮想イーサネット コマンドについて説明します。

mac address-table aging-time

MAC アドレス テーブルのエントリのエージング タイムを設定するには、 mac address-table aging-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

mac address-table aging-time seconds [ vlan vlan-id ]

no mac address-table aging-time [ vlan vlan-id ]

 
構文の説明

seconds

MAC アドレス テーブル エントリのエージング タイム。有効な範囲は 0 ~ 1000000 秒です。デフォルト値は 300 秒です。0 を入力すると、MAC アドレス エージングはディセーブルになります。

vlan vlan-id

(任意)変更されたエージング タイムを適用する VLAN を指定します。

 
コマンド デフォルト

300 秒

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.2(1)N1(1)

コマンド構文が mac address-table aging-time に変更されました。

 
使用上のガイドライン

エージング プロセスをディセーブルにするには、0 秒を入力します。

エージング値は、5 秒の倍数に最も近い値に丸められます。システムによって丸められた値が、ユーザが指定した(丸め処理による)値と異なる場合、システムから情報メッセージが返されます。

このコマンドを EXEC モードで使用すると、設定を指定していないすべての VLAN のエージング値が変更され、個別にエージング タイムを変更した VLAN は変更されません。VLAN パラメータなしでこのコマンドの no 形式を使用すると、個別にエージング タイムが設定されていない VLAN だけがデフォルト値にリセットされます。個別にエージング タイムが変更されている VLAN は変更されません。

このコマンドを使用して VLAN を指定すると、指定した VLAN のエージング タイムだけが変更されます。このコマンドの no 形式を使用して VLAN を指定すると、VLAN のエージング タイムが現在のエージング タイムのグローバル設定に戻ります。デフォルト値の 300 秒に戻るかどうかは、スイッチのエージング タイムのグローバル設定の変更の有無に応じて異なります。

エージング タイムは、スイッチが最後に MAC アドレスを検出した時点からカウントされます。

次に、スイッチ全体でエントリが MAC アドレス テーブルにとどまる時間を 500 秒に変更する例を示します。

switch(config)# mac address-table aging-time 500

 
関連コマンド

コマンド
説明

show mac address-table

MAC アドレス テーブルに関する情報を表示します。

show mac address-table aging-time

MAC アドレスのエージング タイムに関する情報を表示します。

mac address-table notification

MAC アドレス テーブル イベントのログ メッセージ通知を設定するには、 mac address-table notification コマンドを使用します。ログ メッセージ通知をディセーブルにするには、このコマンドの no 形式を使用します。

mac address-table notification { mac-move | threshold [ limit percentage interval seconds ]}

no mac address-table notification { mac-move | threshold }

 
構文の説明

mac-move

MAC アドレスが移動された場合に、通知メッセージを送信します。

threshold

MAC アドレス テーブルのしきい値を超えた場合に、通知メッセージを送信します。

limit percentage

(任意)割合の限界(1 ~ 100)を指定します。この割合を超えた時点でしきい値の通知がイネーブルになります。

interval seconds

(任意)2 つの通知間の最小時間を秒単位で指定します(10 ~ 10000 秒)。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.2(1)N1(1)

コマンド構文が mac address-table notification に変更されました。

次に、しきい値が 45% を超えたときにログ メッセージ通知が送信され、アップデート間隔が 1024 秒に 1 回に制限されるように設定する例を示します。

switch(config)# mac address-table notification threshold limit 45 interval 1024
 

 
関連コマンド

コマンド
説明

show mac address-table

MAC アドレス テーブルに関する情報を表示します。

mac address-table static

MAC アドレス テーブルのスタティック エントリを設定するには、 mac address-table static コマンドを使用します。スタティック エントリを削除するには、このコマンドの no 形式を使用します。

mac address-table static mac-address vlan vlan-id { drop | interface { ethernet slot / port | port-channel number [ . subinterface-number ]} [ auto-learn ]

no mac address-table static mac-address { vlan vlan-id }

 
構文の説明

mac-address

テーブルに追加する MAC アドレス。EEEE.EEEE.EEEE の形式を使用します。

vlan vlan-id

スタティック MAC アドレスを適用する VLAN を指定します。VLAN ID の範囲は 1 ~ 4094 です。

drop

指定された VLAN 内の設定済みの MAC アドレスとの間で送受信されるすべてのトラフィックをドロップします。

interface

インターフェイスを指定します。タイプは、イーサネットまたは Ethernet のいずれかです。

ethernet slot/port

イーサネット インターフェイス、およびスロット番号とポート番号を指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

port-channel number

EtherChannel インターフェイスおよび EtherChannel 番号を指定します。指定できる範囲は 1 ~ 4096 です。

. subinterface-number

(任意)EtherChannel 番号とその後ろに続くドット(.)インジケータ、およびサブインターフェイス番号。

auto-learn

(任意)スイッチによりこの MAC アドレスが自動的にアップデートされるようにします。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.2(1)N1(1)

コマンド構文が mac address-table static に変更されました。

 
使用上のガイドライン

マルチキャスト MAC アドレスには、 mac address-table static mac-address vlan vlan-id drop コマンドは適用できません。

スタティック MAC アドレスをインストールすると、スタティック MAC アドレスはポートに関連付けられます。別のポートに同じ MAC アドレスが表示される場合には、 auto-learn キーワードを入力すると、エントリが新しいポートによってアップデートされます。

次に、MAC アドレス テーブルにスタティック エントリを追加する例を示します。

switch(config)# mac address-table static 0050.3e8d.6400 vlan 3 interface ethernet 1/4
 

 
関連コマンド

コマンド
説明

show mac address-table

MAC アドレス テーブルに関する情報を表示します。

 

management

インバンド管理に使用するスイッチ仮想インターフェイス(SVI)を設定するには、 management コマンドを使用します。VLAN インターフェイスの IP アドレスへのインバンド管理アクセスを削除するには、このコマンドの no 形式を使用します。

management

no management

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

VLAN インターフェイスでこのコマンドを使用できます。

次に、インバンド管理アクセスを許可するように VLAN インターフェイスを設定する例を示します。

switch# configure terminal
switch(config)# interface vlan 5
switch(config-if)# management
switch(config-if)#
 

次に、VLAN インターフェイスへのインバンド管理アクセスを削除する例を示します。

switch# configure terminal
switch(config)# interface vlan 5
switch(config-if)# no management
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show running-config interface

インターフェイスの実行コンフィギュレーション情報を表示します。

 

monitor erspan origin ip-address

Encapsulated Remote Switched Port Analyzer(ERSPAN)起点 IP アドレスを設定するには、 monitor espan origin ip-address コマンドを使用します。ERSPAN の起点 IP アドレスの設定を削除するには、このコマンドの no 形式を使用します。

monitor erspan origin ip-address ip-address [ global ]

no monitor erspan origin ip-address ip-address [ global ]

 
構文の説明

ip-address

IP アドレス。

global

(任意)すべての VDC のデフォルトの仮想デバイス コンテキスト(VDC)設定を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

デフォルトの VDC で起点 IP アドレスを変更すると、すべてのセッションに影響を与えます。

このコマンドには、ライセンスは必要ありません。

次に、ERSPAN の起点 IP アドレスを設定する例を示します。

switch# configure terminal
switch(config)# monitor erspan origin ip-address 10.1.1.1 global
switch(config)#
 

次に、ERSPAN IP アドレスを削除する例を示します。

switch# configure terminal
switch(config)# no monitor erspan origin ip-address 10.1.1.1 global
switch(config)#

 
関連コマンド

コマンド
説明

monitor session

SPAN セッションまたは ERSPAN セッションを設定します。

monitor session

ポート間のトラフィック分析のために、イーサネット スイッチド ポート アナライザ(SPAN)セッションまたは Encapsulated Remote Switched Port Analyzer(ERSPAN)セッションのコンフィギュレーションを新規作成するか、既存のセッションのコンフィギュレーションに追加するには、 monitor session コマンドを使用します。SPAN セッションまたは ERSPAN セッションをクリアするには、このコマンドの no 形式を使用します。

monitor session { session-number [ shut | type { local | erspan-source } | all shut }

no monitor session { session-number | all } [ shut ]

 
構文の説明

session-number

作成または設定する SPAN セッション。有効な範囲は 1 ~ 18 です。

all

コンフィギュレーション情報をすべての SPAN セッションに適用するように指定します。

shut

(任意)選択されたセッションがモニタリングのためにシャットダウンされるように指定します。

type

(任意)設定するセッションのタイプを指定します。

local

セッション タイプをローカルに指定します。

erspan-source

ERSPAN 送信元セッションを作成します。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.2(1)N1(1)

monitor session { session-number | all } suspend コマンドが廃止されました。

monitor session { session-number | all } shut コマンドおよび monitor session { session-number | all } type コマンドが追加されました。

5.0(2)N2(1)

モニタ セッションの出力(TX)送信元の数に対する制限が緩和されました。

5.1(3)N1(1)

ERSPAN のサポートが追加されました。

 
使用上のガイドライン

完全に新しいセッションを処理していることを確認するために、任意のセッション番号またはすべての SPAN セッションをクリアできます。


) Cisco Nexus 5000 シリーズ スイッチは、2 つのアクティブな SPAN セッションをサポートしています。Cisco Nexus 5548 スイッチは、4 つのアクティブな SPAN セッションをサポートします。2 つを超える SPAN セッションを設定すると、最初の 2 つのセッションがアクティブになります。起動中にアクティブなセッションの順序が逆になり、最後の 2 つのセッションがアクティブになります。たとえば、セッション 1 ~ 10 を設定して、1 と 2 がアクティブな場合、リブート後はセッション 9 と 10 がアクティブになります。確定した動作を可能にするには、monitor session session-number shut コマンドを使用して、セッション 3 ~ 10 を明示的に一時停止します。



) Cisco NX-OS Release 5.0(2)N2(1) より、モニタ セッションの出力(TX)送信元の数に対する制限が緩和されました。ポート チャネル インターフェイスを出力送信元として設定できます。


ERSPAN セッションを作成した後でセッションを記述し、送信元および宛先としてインターフェイスおよび VLAN を追加できます。

次に、SPAN セッションを作成する例を示します。

switch# configure terminal
switch(config)# monitor session 2
switch(config)#
 

次に、モニタ コンフィギュレーション モードを開始し、ポート間のトラフィック分析のために SPAN セッション番号 9 を設定する例を示します。

switch(config)# monitor session 9 type local
switch(config-monitor)# description A Local SPAN session
switch(config-monitor)# source interface ethernet 1/1
switch(config-monitor)# destination interface ethernet 1/2
switch(config-monitor)# no shutdown
 

次に、SPAN セッションを起動する前に、任意の SPAN 宛先インターフェイスをレイヤ 2 SPAN モニタとして設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# switchport
switch(config-if)# switchport monitor
switch(config-if)# no shutdown
 

次に、通常の SPAN 宛先トランク インターフェイスを設定する例を示します。

switch(config)# interface Ethernet1/2
switch(config-if)# switchport
switch(config-if)# switchport mode trunk
switch(config-if)# switchport monitor
switch(config-if)# switchport trunk allowed vlan 10-12
switch(config-if)# no shutdown
 

次に、ERSPAN セッションを作成する例を示します。

switch# configure terminal
switch(config)# monitor session 1 type erspan-source
switch(config-erspan-src)#
 

 
関連コマンド

コマンド
説明

description(SPAN、ERSPAN)

説明を SPAN セッションを識別するために追加します。

destination(ERSPAN)

ERSPAN パケットの宛先 IP ポートを設定します。

erspan-id(ERSPAN)

ERSPAN セッションのフロー ID を設定します。

ip dscp(ERSPAN)

ERSPAN パケットの DSCP 値を設定します。

ip prec(ERSPAN)

ERSPAN パケットの IP precedence 値を設定します。

ip ttl(ERSPAN)

ERSPAN パケットの存続可能時間(TTL)値を設定します。

mtu(ERSPAN)

ERSPAN パケットの最大伝送値(MTU)を設定します。

show monitor session

SPAN セッションのコンフィギュレーション情報を表示します。

source(SPAN、ERSPAN)

SPAN 送信元ポートを追加します。

 

mst(STP)

多重スパニング ツリー(MST)の指定ブリッジとルート ブリッジのプライオリティを設定するには、 mst コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

mst instance-id [{ designated | root } priority priority-value ]

no mst instance-id [{ designated | root } priority priority-value ]

 
構文の説明

instance-id

MST インスタンス。有効な範囲は 0 ~ 4094 です。

designated

(任意)スパニング ツリーの指定ブリッジのプライオリティを設定します。

root

(任意)スパニング ツリーのルート ブリッジのプライオリティを設定します。

priority priority-value

(任意)STP ブリッジのプライオリティを指定します。有効な値は 0、4096、8192、12288、16384、20480、24576、28672、32768、36864、40960、45056、49152、53248、57344、61440 です。その他すべての値は拒否されます。

 
コマンド デフォルト

なし

 
コマンド モード

スパニングツリー疑似コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

instance-id 引数には、1 つのインスタンスまたはインスタンス範囲を入力できます。たとえば、0-3、5、7-9 と入力できます。

このコマンドには、ライセンスは必要ありません。

次に、スパニング ツリー ドメインを設定する例を示します。

switch# configure terminal
switch(config)# spanning-tree pseudo-information
switch(config-pseudo)# mst 2 designated priority 8192
switch(config-pseudo)# mst 2 root priority 4096
switch(config-pseudo)#
 

 
関連コマンド

コマンド
説明

show running-config spanning-tree

スパニング ツリー プロトコル(STP)の実行コンフィギュレーション情報を表示します。

show spanning-tree

STP のコンフィギュレーション情報を表示します。

spanning-tree pseudo-information

スパニング ツリー疑似情報パラメータを設定します。

 

mvr group

インターフェイスのマルチキャスト VLAN レジストレーション(MVR)グループを設定するには、 mvr group コマンドを使用します。インターフェイスから MVR グループを削除するには、このコマンドの no 形式を使用します。

mvr group { group_IP_address | IP_prefix / length } [ count count_value ] [ vlan vlan_ID [... vlan vlan_ID ]]

no mvr group { group_IP_address | IP_prefix / length } [ count count_value ] [ vlan vlan_ID [... vlan vlan_ID ]]

 
構文の説明

group_IP_address

A . B . C . D 形式のグループ IP アドレス。

IP_prefix / length

x . x . x . x / m の形式の IP プレフィックスおよびネットワーク マスクの長さです。

count count_value

カウント数を指定します。有効な範囲は 1 ~ 64 です。

vlan vlan_ID

グローバルなデフォルト MVR VLAN を指定します。有効な範囲は 1 ~ 4094 です。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、次のインターフェイスで使用できます。

イーサネット インターフェイス

仮想イーサネット インターフェイス

仮想イーサネット インターフェイスを使用する前に、 feature vmfex コマンドを使用して、スイッチ上で Cisco 仮想マシン ファブリック エクステンダ(VM-FEX)をイネーブルにする必要があります。

このコマンドには、ライセンスは必要ありません。

次に、インターフェイスの MVR VLAN グループを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# mvr group 192.0.2.1/12 vlan 1
switch(config-if)#
 

 
関連コマンド

コマンド
説明

feature vmfex

スイッチ上で VM-FEX をイネーブルにします。

interface vethernet

スイッチ上で仮想イーサネット インターフェイスを設定します。

show mvr

MVR に関する情報を表示します。

show running-config

実行システム コンフィギュレーション情報を表示します。

 

mvr type

インターフェイスのマルチキャスト VLAN レジストレーション(MVR)のポート タイプを設定するには、 mvr type コマンドを使用します。インターフェイスの MVR ポート タイプを削除するには、このコマンドの no 形式を使用します。

mvr type { source | receiver }

no mvr type { source | receiver }

 
構文の説明

source

MVR 送信元ポートを指定します。

receiver

MVR 受信ポートを指定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、次のインターフェイスで使用できます。

イーサネット インターフェイス

仮想イーサネット インターフェイス

仮想イーサネット インターフェイスを使用する前に、 feature vmfex コマンドを使用して、スイッチ上で Cisco 仮想マシン ファブリック エクステンダ(VM-FEX)をイネーブルにする必要があります。

このコマンドには、ライセンスは必要ありません。

次に、インターフェイスの MVR 送信元ポートを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# mvr type source
switch(config-if)#
 

 
関連コマンド

コマンド
説明

feature vmfex

スイッチ上で VM-FEX をイネーブルにします。

interface vethernet

スイッチ上で仮想イーサネット インターフェイスを設定します。

show mvr

MVR に関する情報を表示します。

show running-config

実行システム コンフィギュレーション情報を表示します。

 

mvr vlan

インターフェイスのマルチキャスト VLAN レジストレーション(MVR)VLAN を設定するには、 mvr vlan コマンドを使用します。インターフェイスから MVR VLAN 値を削除するには、このコマンドの no 形式を使用します。

mvr vlan vlan_ID

no mvr vlan vlan_ID

 
構文の説明

vlan_ID

MVR VLAN ID。有効な範囲は 1 ~ 4094 です。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
仮想イーサネット インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、次のインターフェイスで使用できます。

イーサネット インターフェイス

仮想イーサネット インターフェイス

仮想イーサネット インターフェイスを使用する前に、 feature vmfex コマンドを使用して、スイッチ上で Cisco 仮想マシン ファブリック エクステンダ(VM-FEX)をイネーブルにする必要があります。

このコマンドには、ライセンスは必要ありません。

次に、インターフェイスの MVR VLAN を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# mvr vlan 1
switch(config-if)#
 

 
関連コマンド

コマンド
説明

feature vmfex

スイッチ上で VM-FEX をイネーブルにします。

interface vethernet

スイッチ上で仮想イーサネット インターフェイスを設定します。

show mvr

MVR に関する情報を表示します。

show running-config

実行システム コンフィギュレーション情報を表示します。