Cisco Nexus 5000 Series NX-OS レイヤ 2 インターフェイス コマンド リファレンス Cisco NX-OS Release 4.x、5.x
I コマンド
I コマンド
発行日;2012/06/17 | 英語版ドキュメント(2012/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

I コマンド

install certificate

install feature-set virtualization

instance vlan

interface ethernet

interface ethernet(レイヤ 3)

interface loopback

interface mgmt

interface port-channel

interface vethernet

interface vlan

ip igmp snooping(EXEC)

ip igmp snooping(VLAN)

I コマンド

この章では、I で始まる Cisco NX-OS イーサネット コマンドおよび仮想イーサネット コマンドについて説明します。

install certificate

vCenter Server への接続に使用する証明書をインストールするには、 install certificate コマンドを使用します。証明書を削除するには、このコマンドの no 形式を使用します。

install certificate { bootflash: [// server /] | default }

no install certificate

構文の説明

bootflash: [// server /]

証明書をインストールするブート フラッシュ メモリの送信元 URL または宛先 URL を指定します。 server 引数の値は、 module-1 sup-1 sup-active または sup-local です。

default

デフォルト パスを指定します。

コマンド デフォルト

なし

コマンド モード

SVS 接続コンフィギュレーション モード

コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次の例では、ブート フラッシュ メモリに証明書をインストールする例を示します。

switch# configure terminal
switch(config)# svs connection SVSConn
switch(config-svs-conn)# install certificate bootflash:///
switch(config-svs-conn)#
 

次に、証明書を削除する例を示します。

switch# configure terminal
switch(config)# svs connection SVSConn
switch(config-svs-conn)# no install certificate
switch(config-svs-conn)#
 

関連コマンド

コマンド
説明

show svs connections

SVS 接続の情報を表示します。

svs connection

SVS 接続をイネーブルにします。

 

install feature-set virtualization

スイッチ上でシスコ仮想マシンのフィーチャ セットをインストールするには、 install feature-set virtualization コマンドを使用します。シスコ仮想マシンのフィーチャ セットを削除するには、このコマンドの no 形式を使用します。

install feature-set virtualization

no install feature-set virtualization

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

ディセーブル

コマンド モード

グローバル コンフィギュレーション モード

コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

使用上のガイドライン


) シスコ仮想マシン機能は、Cisco Nexus 5500 シリーズ スイッチでだけサポートされます。


このコマンドには、Enhanced Layer 2 ライセンスが必要です。

次に、スイッチ上でシスコ仮想マシンのフィーチャ セットをインストールする例を示します。

switch# configure terminal
switch(config)# install feature-set virtualization
switch(config)#
 

関連コマンド

コマンド
説明

feature vmfex

スイッチ上で Cisco 仮想マシン ファブリック エクステンダ(VM-FEX)をイネーブルまたはディセーブルにします。

feature-set virtualization

スイッチ上でシスコ仮想マシンのフィーチャ セットをイネーブルにします。

show feature-set

仮想化フィーチャ セットのステータスを表示します。

show running-config

実行システム コンフィギュレーション情報を表示します。

 

instance vlan

VLAN または VLAN セットを Multiple Spanning Tree Instance(MSTI)にマッピングするには、 instance vlan コマンドを使用します。インスタンスを削除して、VLAN をデフォルト インスタンス(Common and Internal Spanning Tree(CIST))に戻すには、このコマンドの no 形式を使用します。

instance instance-id vlan vlan-id

no instance instance-id [ vlan vlan-id ]

構文の説明

instance-id

指定された VLAN がマップされるインスタンス。有効な範囲は 0 ~ 4094 です。

vlan vlan-id

指定の MSTI にマッピングする VLAN の番号を指定します。VLAN ID の範囲は 1 ~ 4094 です。

コマンド デフォルト

VLAN は MSTI にマッピングされません(すべての VLAN は CIST インスタンスにマッピングされます)。

コマンド モード

MST コンフィギュレーション モード

コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

VLAN 識別番号は、単一の値または範囲として入力します。

マッピングは、絶対的ではなく差分的に行われます。VLAN の範囲を入力すると、その範囲が既存のインスタンスに追加されるか、既存のインスタンスから削除されます。

マッピングされていない VLAN は、CIST インスタンスにマッピングされます。


注意 VLAN/MSTI マッピングを変更すると、MST は再起動されます。

次に、VLAN 範囲を MSTI 4 にマッピングする例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)# instance 4 vlan 100-200
 

関連コマンド

コマンド
説明

show spanning-tree mst configuration

MST プロトコルに関する情報を表示します。

spanning-tree mst configuration

MST コンフィギュレーション モードを開始します。

interface ethernet

イーサネット IEEE 802.3 インターフェイスのインターフェイス コンフィギュレーション モードを開始するには、 interface ethernet コマンドを使用します。

interface ethernet [ chassis_ID /] slot / port

構文の説明

chassis_ID

(任意)ファブリック エクステンダ シャーシ ID を指定します。シャーシ ID の範囲は、100 ~ 199 です。

(注) Cisco Nexus 2000 シリーズ ファブリック エクステンダ のホスト インターフェイスをアドレッシングする場合は、この引数は任意ではありません。

slot

1 ~ 3 のスロット。次のリストに使用可能なスロットを定義します。

スロット 1 にはすべての固定ポートが含まれます。ファブリック エクステンダにのみ、1 つのスロットが含まれます。

スロット 2 には上位拡張モジュールのポートが含まれます(実装されている場合)。

スロット 3 には下位拡張モジュールのポートが含まれます(実装されている場合)。

port

特定のスロット内のポート番号を指定します。指定できるポート番号は 1 ~ 128 です。

コマンド デフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.0(1a)N2(1)

このコマンドは、シャーシ ID 引数を提供するように変更されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

次に、イーサネット インターフェイス 1/4 でコンフィギュレーション モードを開始する例を示します。

switch(config)# interface ethernet 1/4
switch(config-if)#
 

次に、ファブリック エクステンダのホスト インターフェイスでコンフィギュレーション モードを開始する例を示します。

switch(config)# interface ethernet 101/1/1
switch(config-if)#
 

関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを設定します。

show fex

スイッチに接続されている、すべての設定済みのファブリック エクステンダ シャーシを表示します。

show interface ethernet

イーサネット IEEE 802.3 インターフェイスの各種パラメータを表示します。

speed

インターフェイスの速度を設定します。

vtp(インターフェイス)

インターフェイスの VLAN トランキング プロトコル(VTP)をイネーブルにします。

interface ethernet(レイヤ 3)

レイヤ 3 イーサネット IEEE 802.3 ルーテッド インターフェイスを設定するには、 interface ethernet コマンドを使用します。

interface ethernet [ chassis_ID /] slot / port [ . subintf-port-no ]

構文の説明

chassis_ID

(任意)ファブリック エクステンダ シャーシ ID を指定します。シャーシ ID の範囲は、100 ~ 199 です。

(注) Cisco Nexus 2000 シリーズ ファブリック エクステンダのホスト インターフェイスをアドレッシングする場合は、この引数は任意ではありません。

slot

1 ~ 3 のスロット。次のリストに使用可能なスロットを定義します。

スロット 1 にはすべての固定ポートが含まれます。ファブリック エクステンダにのみ、1 つのスロットが含まれます。

スロット 2 には上位拡張モジュールのポートが含まれます(実装されている場合)。

スロット 3 には下位拡張モジュールのポートが含まれます(実装されている場合)。

port

特定のスロット内のポート番号を指定します。指定できるポート番号は 1 ~ 128 です。

.

(任意)サブインターフェイスの区切り文字を指定します。

subintf-port-no

(任意)サブインターフェイスのポート番号。有効な範囲は 1 ~ 48 です。

コマンド デフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード
インターフェイス コンフィギュレーション モード

コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

使用上のガイドライン

インターフェイスをレイヤ 3 ルーテッド インターフェイスとして設定するためには、 no switchport コマンドをインターフェイス コンフィギュレーション モードで使用する必要があります。インターフェイスをレイヤ 3 インターフェイスとして設定すると、そのインターフェイスのすべてのレイヤ 2 固有のコンフィギュレーションが削除されます。

レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変換するには、 switchport コマンドを使用します。インターフェイスをレイヤ 2 インターフェイスとして設定すると、このインターフェイスのすべてのレイヤ 3 固有のコンフィギュレーションが削除されます。

次に、レイヤ 3 イーサネット インターフェイス 1/5 のコンフィギュレーション モードを開始する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)#
 

次に、ファブリック エクステンダのホスト インターフェイスでコンフィギュレーション モードを開始する例を示します。

switch(config)# interface ethernet 101/1/1
switch(config-if)# no switchport
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)#
 

次に、グローバル コンフィギュレーション モードでイーサネット インターフェイス 1/5 のレイヤ 3 サブインターフェイスを設定する例を示します。

switch(config)# interface ethernet 1/5.2
switch(config-if)# no switchport
switch(config-subif)# ip address 10.1.1.1/24
switch(config-subif)#
 

次に、インターフェイス コンフィギュレーション モードでレイヤ 3 サブインターフェイスを設定する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# interface ethernet 1/5.1
switch(config-subif)# ip address 10.1.1.1/24
switch(config-subif)#
 

次に、レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変換する例を示します。

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)# switchport
switch(config-if)#
 

関連コマンド

コマンド
説明

bandwidth

インターフェイスの帯域幅パラメータを設定します。

delay

インターフェイス スループ ット遅延値を設定します。

encapsulation

インターフェイスのカプセル化タイプを設定します。

ip address

インターフェイスのプライマリまたはセカンダリ IP アドレスを設定します。

inherit

インターフェイスにポート プロファイルを割り当てます。

interface vethernet

仮想イーサネット インターフェイスを設定します。

no switchport

インターフェイスをレイヤ 3 インターフェイスとして設定します。

service-policy

インターフェイスのサービス ポリシーを設定します。

show fex

スイッチに接続されている、すべての設定済みのファブリック エクステンダ シャーシを表示します。

show interface ethernet

イーサネット IEEE 802.3 インターフェイスの各種パラメータを表示します。

interface loopback

ループバック インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface loopback コマンドを使用します。ループバック インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface loopback number

no interface loopback number

構文の説明

number

インターフェイス番号。有効な値は 0 ~ 1023 です。

コマンド デフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

使用上のガイドライン

interface loopback コマンドは、ループバック インターフェイスを作成または変更するために使用します。

ループバック インターフェイス コンフィギュレーション モードからは、次のパラメータを使用できます。

description :インターフェイスの目的を説明します。

ip :インターフェイスの IP アドレス、アドレス解決プロトコル(ARP)属性、ロード バランシング、ユニキャスト リバース パス転送(RPF)、IP ソース ガードなどの IP 機能を設定します。

logging :イベントのロギングを設定します。

shutdown :インターフェイスでトラフィックをシャットダウンします。

このコマンドには、ライセンスは必要ありません。

次に、ループバック インターフェイスを作成する例を示します。

switch(config)# interface loopback 50
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)#
 

関連コマンド

コマンド
説明

show interface loopback

指定されたループバック インターフェイスのトラフィックに関する情報を表示します。

 

interface mgmt

管理インターフェイス コンフィギュレーション モードを開始するには、 interface mgmt コマンドを使用します。

interface mgmt mgmt-intf-num

構文の説明

mgmt-intf-num

管理インターフェイス番号。インターフェイス番号は 0 です。

コマンド デフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、管理インターフェイス コンフィギュレーション モードを開始する例を示します。

switch# configure terminal
switch(config)# interface mgmt 0
switch(config-if)#
 

関連コマンド

コマンド
説明

show interface mgmt

管理インターフェイスに関する情報を表示します。

cdp enable

インターフェイスの Cisco Discovery Protocol(CDP)をイネーブルにします。

description(インターフェイス)

インターフェイスのコンフィギュレーションに説明を追加します。

duplex

インターフェイスのデュプレックス モードを設定します。

lldp(インターフェイス)

インターフェイス上でリンク層検出プロトコル(LLDP)パケットの受信または送信をイネーブルにします。

rate-limit cpu direction

インターフェイスの Packet Per Second(PPS)のレート制限を設定します。

snmp trap link-status

インターフェイスでの簡易ネットワーク管理プロトコル(SNMP)のリンク トラップ生成をイネーブルにします。

speed

インターフェイスの送信速度と受信速度を設定します。

vrf member

仮想ルーティングおよび転送(VRF)のインスタンスにインターフェイスを追加します。

 

interface port-channel

EtherChannel インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface port-channel コマンドを使用します。EtherChannel インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface port-channel channel-number [. subintf-channel-no ]

no interface port-channel channel-number [. subintf-channel-no ]

構文の説明

channel-number

この EtherChannel 論理インターフェイスに割り当てられているチャネル番号。指定できる範囲は 1 ~ 4096 です。

.

(任意)サブインターフェイスの区切り文字を指定します。

(注) レイヤ 3 インターフェイスが対象となります。

subintf-channel-no

(任意)EtherChannel サブインターフェイスのポート番号。有効な範囲は 1 ~ 4093 です。

(注) レイヤ 3 インターフェイスが対象となります。

コマンド デフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード
インターフェイス コンフィギュレーション モード

コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスおよびサブインターフェイスのサポートが追加されました。

使用上のガイドライン

ポートは、1 つのチャネル グループだけに属すことができます。

レイヤ 2 インターフェイスに interface port-channel コマンドを使用する場合は、次のガイドラインに従ってください。

CDP を使用する場合は、EtherChannel インターフェイス上ではなく物理インターフェイス上だけで CDP を設定します。

EtherChannel インターフェイス上にスタティック MAC アドレスを割り当てない場合は、MAC アドレスが自動的に割り当てられます。スタティック MAC アドレスを割り当て、後で削除した場合は、MAC アドレスが自動的に割り当てられます。

EtherChannel の MAC アドレスは、チャネル グループに追加される最初の動作ポートのアドレスです。この最初に追加されたポートがチャネルから削除されると、次に追加された動作ポート(存在する場合)の MAC アドレスになります。

EtherChannel インターフェイスをレイヤ 3 インターフェイスとして設定するには、インターフェイス コンフィギュレーション モードで no switchport コマンドを使用する必要があります。インターフェイスをレイヤ 3 インターフェイスとして設定すると、そのインターフェイスのすべてのレイヤ 2 固有のコンフィギュレーションが削除されます。

レイヤ 3 EtherChannel インターフェイスをレイヤ 2 インターフェイスに変換するには、 switchport コマンドを使用します。インターフェイスをレイヤ 2 インターフェイスとして設定すると、このインターフェイスのすべてのレイヤ 3 固有のコンフィギュレーションが削除されます。

ルーテッド インターフェイスで構成されるポート チャネルに 1 つまたは複数のサブインターフェイスを設定できます。

次に、チャネル グループ番号 50 を持つ EtherChannel グループ インターフェイスを作成する例を示します。

switch(config)# interface port-channel 50
switch(config-if)#
 

次に、チャネル グループ番号 10 のレイヤ 3 EtherChannel グループ インターフェイスを作成する例を示します。

switch(config)# interface port-channel 10
switch(config-if)# no switchport
switch(config-if)# ip address 192.0.2.1/24
switch(config-if)#
 

次に、インターフェイス コンフィギュレーション モードでチャネル グループ番号 1 のレイヤ 3 EtherChannel サブインターフェイスを設定する例を示します。

switch(config)# interface port-channel 10
switch(config-if)# no switchport
switch(config-if)# interface port-channel 10.1
switch(config-subif)# ip address 192.0.2.2/24
switch(config-subif)#
 

次に、グローバル コンフィギュレーション モードでチャネル グループ番号 20.1 のレイヤ 3 EtherChannel サブインターフェイスを設定する例を示します。

switch(config)# interface port-channel 20.1
switch(config-subif)# ip address 192.0.2.3/24
switch(config-subif)#
 

関連コマンド

コマンド
説明

encapsulation

(レイヤ 3 インターフェイス)インターフェイスのカプセル化タイプを設定します。

ip address

(レイヤ 3 インターフェイス)インターフェイスのプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

no switchport

(レイヤ 3 インターフェイス)レイヤ 3 インターフェイスとしてインターフェイスを設定します。

show interface

インターフェイスに関する設定情報を表示します。

show lacp

LACP 情報を表示します。

show port-channel summary

EtherChannel に関する情報を表示します。

vtp(インターフェイス)

インターフェイスの VLAN トランキング プロトコル(VTP)をイネーブルにします。

interface vethernet

仮想イーサネット(vEth)インターフェイスのインターフェイス コンフィギュレーション モードを開始するには、 interface vethernet コマンドを使用します。仮想イーサネット インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface vethernet veth-id [, vethernet veth-id , ...]

no interface vethernet veth-id [, vethernet veth-id , ...]

構文の説明

veth-id

仮想イーサネット インターフェイス番号。有効な範囲は 1~1,048,575 です。

複数の仮想イーサネット インターフェイスを指定できます。必ずカンマ(,)区切り文字を使用します。

コマンド デフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

使用上のガイドライン

仮想イーサネット インターフェイスを使用する前に、 feature vmfex コマンドを使用して、スイッチ上で Cisco 仮想マシン ファブリック エクステンダ(VM-FEX)をイネーブルにする必要があります。

各スイッチの仮想イーサネット インターフェイスを設定する必要があります。セカンダリ スイッチのコンフィギュレーションは、プライマリ スイッチのコンフィギュレーションと同じにする必要があります。

Cisco Nexus 5548 スイッチでは、最大で 1000 個の仮想イーサネット インターフェイスを作成できます。スイッチ上で Adapter-FEX をディセーブルにする前に、必ずこれらのインターフェイスを削除します。仮想イーサネット インターフェイスを削除した後、スイッチの実行コンフィギュレーションを必ずスタートアップ コンフィギュレーション ファイルに保存します。

次に、仮想イーサネット インターフェイス 10 のコンフィギュレーション モードを開始する例を示します。

switch# configure terminal
switch(config)# interface vethernet 10
switch(config-if)#
 

次に、複数の仮想イーサネット インターフェイスのコンフィギュレーション モードを開始する例を示します。

switch# configure terminal
switch(config)# interface vethernet 10, vethernet 2
switch(config-if-range)#
 

次に示す例では、インターフェイスをバインドして、vEthernet アクセス インターフェイスを設定し、このインターフェイスにアクセス VLAN を割り当て、次に仮想イーサネット インターフェイスに ppVEth というポート プロファイルとサービス クラス(CoS)値 3 を割り当てます。

switch# configure terminal
switch(config)# port-profile type vethernet ppVEth
switch(config-port-prof)# switchport mode access
switch(config-port-prof)# service-policy type qos input my_policy1
switch(config-port-prof)# exit
switch(config)# interface vethernet 10
switch(config-if)# bind interface ethernet 1/5 channel 10
switch(config-if)# inherit port-profile ppVEth
switch(config-if)# untagged cos 3
switch(config-if)#
 

次に、仮想イーサネット インターフェイスを削除する例を示します。

switch# configure terminal
switch(config)# no interface vethernet 2
switch(config)#
 

関連コマンド

コマンド
説明

bind

仮想イーサネット インターフェイスにインターフェイスをバインドします。

feature vmfex

スイッチ上で VM-FEX をイネーブルにします。

port-profile

ポート プロファイルを設定します。

show interface ethernet

イーサネット インターフェイスに関する情報を表示します。

show interface vethernet

仮想イーサネット インターフェイスの各種パラメータを表示します。

show running-config interface

インターフェイスの実行コンフィギュレーションを表示します。

vethernet auto-create

仮想イーサネット インターフェイスの自動作成をイネーブルにするデフォルト ポリシーを設定します。

 

interface vlan

VLAN インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface vlan コマンドを使用します。VLAN インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface vlan vlan-id

no interface vlan vlan-id

構文の説明

vlan-id

インターフェイスがアクセス モードのときに設定する VLAN。有効な値は 1 ~ 4094 です。内部スイッチ用に予約されている VLAN は除きます。

コマンド デフォルト

なし

コマンド モード

グローバル コンフィギュレーション モード

コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

使用上のガイドライン

このコマンドを使用する前に、 feature interface-vlan コマンドを使用してインターフェイス VLAN 機能をイネーブルにします。

VLAN インターフェイスの作成または変更を行うには、 interface vlan コマンドを使用します。

VLAN インターフェイスは、特定の VLAN に対して初めて interface vlan コマンドを入力したときに作成されます。 vlan-id 引数は、IEEE 802.1Q カプセル化トランク上のデータ フレームに関連付けられた VLAN タグ、またはアクセス ポートに設定された VLAN ID に対応します。

このコマンドには、ライセンスは必要ありません。

次に、VLAN 50 の VLAN インターフェイスを作成する例を示します。

switch(config)# interface vlan 50
switch(config-if)#
 

関連コマンド

コマンド
説明

feature interface-vlan

VLAN インターフェイスを作成する機能をイネーブルにします。

show interface vlan

指定された VLAN インターフェイスのトラフィックに関する情報を表示します。

ip igmp snooping(EXEC)

インターネット グループ管理プロトコル(IGMP)をイネーブルにするには、 ip igmp snooping コマンドを使用します。IGMP スヌーピングをディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp snooping

no ip igmp snooping

構文の説明

このコマンドには、引数またはキーワードはありません。

コマンド デフォルト

IGMP スヌーピングはイネーブルです。


) グローバルな設定がディセーブルになっている場合は、すべての VLAN が、イネーブルかどうかに関係なくディセーブルと見なされます。


コマンド モード

EXEC モード

コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、IGMP スヌーピングをイネーブルにする例を示します。

switch# ip igmp snooping
 

関連コマンド

コマンド
説明

show ip igmp snooping

IGMP スヌーピング情報および設定を表示します。

ip igmp snooping(VLAN)

VLAN でインターネット グループ管理プロトコル(IGMP)を設定するには、 ip igmp snooping コマンドを使用します。コマンドを無効にするか、デフォルト設定に戻すには、このコマンドの no 形式を使用します。

ip igmp snooping parameter

no ip igmp snooping parameter

構文の説明

parameter

設定するパラメータ。詳細情報については、「使用上のガイドライン」の項を参照してください。

コマンド デフォルト

デフォルト設定は、次のとおりです。

explicit-tracking :イネーブル

fast-leave :すべての VLAN についてディセーブル

last-member-query-interval seconds :1

querier IP-address :ディセーブル

report-suppression :イネーブル

コマンド モード

VLAN コンフィギュレーション モード

コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.1(3)N1(1)

Cisco Adapter ファブリック エクステンダ(Adapter-FEX)でこのコマンドのサポートが追加されました。

使用上のガイドライン

表 1 に、 parameter の有効値を示します。

 

表 1 IGMP スヌーピング パラメータ

キーワードおよび引数
説明

explicit-tracking

VLAN ベースで各ポートの IGMPv3 メンバーシップ レポートのトラッキングをイネーブルにします。デフォルトは、すべての VLAN でイネーブルです。

fast-leave

IGMPv3 スヌーピングの高速脱退処理をイネーブルにします。デフォルトは、すべての VLAN でディセーブルです。

last-member-query-interval seconds

すべてのホストが IGMP クエリー メッセージに応答しない場合は、グループを削除します。有効値は 1 ~ 25 秒です。デフォルトは 1 秒です。

mrouter interface interface

マルチキャスト ルータへのスタティックな接続を設定します。指定のインターフェイスは、イーサネットまたは EtherChannel です。

querier IP-address

スヌーピング クエリアを設定します。IP アドレスは、メッセージの送信元として使用します。デフォルトではディセーブルです。

report-suppression

マルチキャスト対応ルータに送信されるメンバーシップ レポート トラフィックを制限します。レポート抑制をディセーブルにすると、すべての IGMP レポートがそのままマルチキャスト対応ルータに送信されます。デフォルトではイネーブルです。

static-group group-ip-addr [ source source-ip-addr ] interface interface

VLAN に属するインターフェイスを、マルチキャスト グループのスタティック メンバとして設定します。指定のインターフェイスは、イーサネットまたは EtherChannel、または仮想イーサネットです。

次に、VLAN 5 の IGMP スヌーピング パラメータを設定する例を示します。

switch# configure terminal
switch(config)# vlan 5
switch(config-vlan)# ip igmp snooping last-member-query-interval 3
switch(config-vlan)# ip igmp snooping querier 192.168.2.106
switch(config-vlan)# ip igmp snooping explicit-tracking
switch(config-vlan)# ip igmp snooping fast-leave
switch(config-vlan)# ip igmp snooping report-suppression
switch(config-vlan)# ip igmp snooping mrouter interface ethernet 1/10
switch(config-vlan)# ip igmp snooping static-group 192.0.2.1 interface ethernet 1/10
switch(config-vlan)# ip igmp snooping static-group 192.0.2.12 interface vethernet 4/1
switch(config-vlan)#
 

関連コマンド

コマンド
説明

show ip igmp snooping

IGMP スヌーピング情報および設定を表示します。