Cisco Nexus 5000 シリーズ NX-OS QoS コマンド リファレンス Cisco NX-OS Release 4.x、5.x
show コマンド
show コマンド
発行日;2012/06/17 | 英語版ドキュメント(2012/03/15 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 728KB) | フィードバック

目次

show コマンド

show class-map type control-plane

show class-map type network-qos

show class-map type qos

show class-map type queuing

show copp status

show interface flowcontrol

show hardware profile tcam feature qos

show interface priority-flow-control

show interface untagged-cos

show policy-map

show policy-map interface

show policy-map interface brief

show policy-map interface control-plane

show policy-map system

show policy-map type control-plane

show policy-map vlan

show queuing interface

show running-config copp

show running-config ipqos

show startup-config copp

show startup-config ipqos

show wrr-queue cos-map

show コマンド

この章では、Cisco NX-OS の Quality of Service(QoS)の show コマンドについて説明します。

show class-map type control-plane

コントロール プレーン クラス マップ情報を表示するには、 show class-map type control-plane コマンドを使用します。

show class-map type control-plane [ class-map-name ]

 
構文の説明

class-map-name

(任意)コントロール プレーン クラス マップの名前 名前は英数字で、大文字と小文字が区別されます。最大で 64 文字の長さまで指定可能です。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、コントロール プレーン クラス マップ情報を表示する例を示します。

switch# show class-map type control-plane
 
class-map type control-plane match-any copp-system-class-arp
match protocol arp
 
class-map type control-plane match-any copp-system-class-bgp
match protocol bgp
 
class-map type control-plane match-any copp-system-class-bridging
match protocol bridging
 
class-map type control-plane match-any copp-system-class-cdp
match protocol cdp
 
class-map type control-plane match-any copp-system-class-default
match protocol default
 
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

class-map type control-plane

コントロール プレーン クラス マップを作成または設定します。

show class-map type network-qos

ネットワーク QoS タイプのクラス マップを表示するには、 show class-map type network-qos コマンドを使用します。

show class-map type network-qos [ class-map-name ]

 
構文の説明

class-map-name

クラス マップ名です。最大 40 の英数字を使用できます。

 
コマンド デフォルト

クラス マップ名が指定されていない場合、ネットワーク QoS タイプのすべてのクラス マップが表示されます。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

タイプを指定しない場合、システムで設定されているすべてのクラス マップが表示されます。

次に、ネットワーク QoS タイプのすべてのクラス マップを表示する例を示します。

switch(config)# show class-map type network-qos
 
 
Type network-qos class-maps
==============================
 
class-map type network-qos s1
match qos-group 2
 
class-map type network-qos s2
match qos-group 3
 
class-map type network-qos s3
match qos-group 4
 
class-map type network-qos s4
match qos-group 5
 
class-map type network-qos cu1
match qos-group 2
 
class-map type network-qos cu2
match qos-group 3
 
class-map type network-qos cu3
match qos-group 4
 
class-map type network-qos cu4
match qos-group 5
 
class-map type network-qos new
match qos-group 2
 
class-map type network-qos class7
match qos-group 5
 
class-map type network-qos class-0
match qos-group 2
 
class-map type network-qos ip-based
match qos-group 5
 
class-map type network-qos class-1-2
match qos-group 3
 
class-map type network-qos class-4-7
match qos-group 4
 
class-map type network-qos cos-based
match qos-group 2
 
class-map type network-qos class-fcoe
match qos-group 1
 
class-map type network-qos class-flood
match qos-group 2
 
class-map type network-qos cos-based-3
match qos-group 3
 
class-map type network-qos cos-based-4
match qos-group 4
 
class-map type network-qos class-default
match qos-group 0
 
class-map type network-qos class-multicast
 
class-map type network-qos class-ip-multicast
match qos-group 5
 
 
switch(config)#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

show class-map type qos

QoS タイプのクラス マップを表示するには、 show class-map type qos コマンドを使用します。

show class-map type qos [ class-map-name ]

 
構文の説明

class-map-name

クラス マップの名前。 class-default という名前は予約されています。最大 40 の英数字を使用できます。

 
コマンド デフォルト

クラス マップ名が指定されていない場合、QoS タイプのすべてのクラス マップが表示されます。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、Cisco NX-OS Release 4.1(3)N1(1) を実行しているスイッチ上のすべての QoS タイプのクラス マップを表示する例を示します。

switch(config)# show class-map type qos
 
 
Type qos class-maps
===================
 
class-map type qos s1
match cos 0
 
class-map type qos s2
match protocol ldp
match ip rtp 2000
match protocol dhcp
match protocol arp
 
class-map type qos s3
match access-group name mac
 
class-map type qos s4
match access-group name ipv4
 
class-map type qos cp1
match precedence 4-5
match cos 0,4
match dscp 4
match protocol ldp
match protocol arp
 
class-map type qos cp2
match ip rtp 2000
match cos 0
 
class-map type qos cp3
match access-group name mac
 
class-map type qos cp5
 
class-map type qos cq1
match protocol ldp
match precedence 7
match cos 0
 
class-map type qos cq2
match protocol ldp
match cos 1-2
 
class-map type qos cq3
match access-group name mac
 
class-map type qos cq4
match access-group name ipv4-1
 
class-map type qos cq5
match access-group name ipv6-based
 
class-map type qos p1.1
match cos 7
 
class-map type qos p1.2
match protocol ldp
match ip rtp 2000-6001,10000-20000,60000-65535
match dscp 1
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p1.3
match access-group name mac
 
class-map type qos p1.4
match access-group name ipv4
 
class-map type qos p2.1
match cos 0,7
 
class-map type qos p2.2
match protocol ldp
match ip rtp 2000-6000,6002,10000-20000,60000-65535
match dscp 2
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p2.3
match access-group name mac
 
class-map type qos p2.4
match access-group name ipv4
 
class-map type qos p3.1
match cos 0,7
 
class-map type qos p3.2
match protocol ldp
match ip rtp 2000-6000,6003,10000-20000,60000-65535
match dscp 3
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p3.3
match access-group name mac
 
class-map type qos p3.4
match access-group name ipv4
 
class-map type qos p4.1
match cos 0,7
 
class-map type qos p4.2
match protocol ldp
match ip rtp 2000-6000,6004,10000-20000,60000-65535
match dscp 4
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p4.3
match access-group name mac
 
class-map type qos p4.4
match access-group name ipv4
 
class-map type qos p5.1
match cos 0,7
 
class-map type qos p5.2
match protocol ldp
match ip rtp 2000-6000,6005,10000-20000,60000-65535
match dscp 5
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p5.3
match access-group name mac
 
class-map type qos p5.4
match access-group name ipv4
 
class-map type qos p6.1
match cos 0,7
 
class-map type qos p6.2
match protocol ldp
match ip rtp 2000-6000,6006,10000-20000,60000-65535
match dscp 6
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p6.3
match access-group name mac
 
class-map type qos p6.4
match access-group name ipv4
 
class-map type qos p7.1
match cos 0,7
 
class-map type qos p7.2
match protocol ldp
match ip rtp 2000-6000,6007,10000-20000,60000-65535
match dscp 7
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p7.3
match access-group name mac
 
class-map type qos p7.4
match access-group name ipv4
 
class-map type qos p8.1
match cos 0,7
 
class-map type qos p8.2
match protocol ldp
match ip rtp 2000-6000,6008,10000-20000,60000-65535
match dscp 8
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p8.3
match access-group name mac
 
class-map type qos p8.4
match access-group name ipv4
 
class-map type qos p9.1
match cos 0,7
 
class-map type qos p9.2
match protocol ldp
match ip rtp 2000-6000,6009,10000-20000,60000-65535
match dscp 9
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p9.3
match access-group name mac
 
class-map type qos p9.4
match access-group name ipv4
 
class-map type qos class-0
match cos 0
 
class-map type qos class-6
match cos 6
 
class-map type qos class-7
match cos 7
 
class-map type qos clsas-0
 
class-map type qos cos-6-7
match cos 7
 
class-map type qos ip-based
match access-group name ip-based
 
class-map type qos acl-based
match access-group name ipPacl
 
class-map type qos class-1-2
match cos 1-2
 
class-map type qos class-4-5
match cos 4-5
 
class-map type qos class-4-6
match cos 5
 
class-map type qos class-4-7
match cos 5,7
 
class-map type qos class-405
 
class-map type qos cos-based
 
class-map type qos mac-based
match access-group name foo
 
class-map type qos udp-based
match access-group name ip-based
 
class-map type qos class-fcoe
match cos 3
 
class-map type qos class-flood
 
class-map type qos class-default
match any
 
class-map type qos class-all-flood
match all flood
 
class-map type qos class-ip-multicast
match ip multicast
 
switch(config)#
 

次に、特定のクラス マップを表示する例を示します。

switch# show class-map type qos class-4-6
 
 
Type qos class-maps
===================
 
class-map type qos class-4-6
match cos 5
 
switch#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチ上のすべての QoS タイプのクラス マップを表示する例を示します。

switch# show class-map type qos
 
 
Type qos class-maps
===================
 
class-map type qos match-any class-fcoe
match cos 3
 
class-map type qos match-any class-default
match any
 
class-map type qos match-any class-all-flood
match all flood
 
class-map type qos match-any class-ip-multicast
match ip multicast
 
switch#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

show class-map type queuing

キューイング タイプのクラス マップを表示するには、 show class-map type queuing コマンドを使用します。

show class-map type queuing [ class-map-name ]

 
構文の説明

class-map-name

クラス マップの名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

クラス マップ名が指定されていない場合、キューイング タイプのすべてのクラス マップが表示されます。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、Cisco NX-OS Release 4.1(3)N1(1) を実行しているスイッチ上のすべてのタイプのキューイング クラス マップを表示する例を示します。

switch(config)# show class-map type queuing
 
 
Type queuing class-maps
=======================
 
class-map type queuing s1
match qos-group 2
 
class-map type queuing s2
match qos-group 3
 
class-map type queuing s3
match qos-group 4
 
class-map type queuing s4
match qos-group 5
 
class-map type queuing cq1
match qos-group 2
 
class-map type queuing cq2
match qos-group 3
 
class-map type queuing cq3
match qos-group 4
 
class-map type queuing cq4
match qos-group 5
 
class-map type queuing pq1
 
class-map type queuing cqe1
match qos-group 2
 
class-map type queuing cqe2
match qos-group 3
 
class-map type queuing cqe3
match qos-group 4
 
class-map type queuing cqe4
match qos-group 5
 
class-map type queuing p1.1
match qos-group 2
 
class-map type queuing p1.2
match qos-group 3
 
class-map type queuing p1.3
match qos-group 4
 
class-map type queuing p1.4
match qos-group 5
 
class-map type queuing p2.1
match qos-group 2
 
class-map type queuing p2.2
match qos-group 3
 
class-map type queuing p2.3
match qos-group 4
 
class-map type queuing p2.4
match qos-group 5
 
class-map type queuing p3.1
match qos-group 2
 
class-map type queuing p3.2
match qos-group 3
 
<--Output truncated-->
switch(config)#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチ上のすべてのタイプのキューイング クラス マップを表示する例を示します。

switch# show class-map type queuing
 
 
Type queuing class-maps
=======================
 
class-map type queuing class-fcoe
match qos-group 1
 
class-map type queuing class-default
match qos-group 0
 
class-map type queuing class-all-flood
match qos-group 2
 
class-map type queuing class-ip-multicast
match qos-group 2
 
switch#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

 

show copp status

コントロール プレーン ポリシング(CoPP)の設定ステータスを表示するには、 show copp status コマンドを使用します。

show copp status

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、CoPP 設定ステータス情報を表示する例を示します。

switch# show copp status
Last Config Operation: class class-default
Last Config Operation Timestamp: 05:06:14 UTC Jan 1 2009
Last Config Operation Status: Success
Policy-map attached to the control-plane: copp-system-policy-default
 
switch#
 

 
関連コマンド

コマンド
説明

clear copp statistics

CoPP 統計情報をクリアします。

show running-config copp

実行コンフィギュレーションの CoPP コンフィギュレーション情報を表示します。

 

show interface flowcontrol

すべてのインターフェイスにおけるフロー制御の詳細なリストを表示するには、 show interface flowcontrol コマンドを使用します。

show interface flowcontrol [ module number ]

 
構文の説明

module number

(任意)指定したモジュールのすべてのインターフェイスにおけるフロー制御設定を表示します。有効なモジュール 番号 の範囲は 1 ~ 3 です。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

 
使用上のガイドライン

このコマンドを使用して、次のインターフェイスのフロー制御情報を表示できます。

レイヤ 2 インターフェイス

レイヤ 3 インターフェイス


no switchport コマンドを使用してインターフェイスをレイヤ 3 インターフェイスとして設定してから、flowcontrol コマンドを使用してインターフェイスのフロー制御を設定します。


次に、スイッチ上のすべてのインターフェイスにおけるフロー制御設定を表示する例を示します。

switch# show interface flowcontrol
 
--------------------------------------------------------------------------------
Port Send FlowControl Receive FlowControl RxPause TxPause
admin oper admin oper
--------------------------------------------------------------------------------
Eth1/1 off off off off 0 0
 
Eth1/2 off off off off 0 0
 
Eth1/3 off off off off 0 0
 
Eth1/4 off off off off 0 0
 
Eth1/5 off off off off 0 0
 
Eth1/6 off off off off 0 0
 
Eth1/7 off off off off 0 0
 
Eth1/8 off off off off 0 0
 
Eth1/9 off off off off 0 0
 
Eth1/10 off off off off 0 0
 
Eth1/11 off off off off 0 0
 
--More--
switch#

show hardware profile tcam feature qos

QoS TCAM の制限を表示するには、 show hardware profile tcam feature-qos コマンドを使用します。

show hardware profile tcam feature qos tcam-size

 
構文の説明

tcam-size

インターフェイス QoS TCAM の制限。tcam-size は 7 ~ 446 エントリの範囲で指定できます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.1(3)N2(1)

このコマンドが追加されました。

 
使用上のガイドライン

TCAM の QoS リージョンの interface_qos 制限の後には、インターフェイス ポリシーのエントリを配置しないようにします。

次に、インターフェイス QoS TCAM 制限を 20 エントリに設定する例を示します。

switch(config)# configue terminal
switch(config)# hardware profile tcam feature interface-qos limit 20
switch(config)# show hardware profile tcam feature qos
Feature Limit
--------------------------------------------------------------------------------
Interface 20
vlan-qos + global-qos 428
 
switch(config)# copy running-config startup-config

 
関連コマンド

コマンド
説明

hardware profile tcam feature interface-qos limit

QoS TCAM 制限を設定します

show interface priority-flow-control

指定したインターフェイスのプライオリティ フロー制御の詳細を表示するには、 show interface priority-flow-control コマンドを使用します。

show interface [ ethernet slot / port ] priority-flow-control

 
構文の説明

ethernet slot / port

(任意)イーサネット インターフェイス、およびそのスロット番号とポート番号を指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

 
使用上のガイドライン

このコマンドを使用して、次のインターフェイスのプライオリティ フロー制御情報を表示できます。

レイヤ 2 インターフェイス

レイヤ 3 インターフェイス


no switchport コマンドを使用してインターフェイスをレイヤ 3 インターフェイスとして設定してから、flowcontrol コマンドを使用してインターフェイスのフロー制御を設定します。


インターフェイスを指定しない場合 show interface priority-flow-control コマンドはすべてのインターフェイス(レイヤ 2、レイヤ 3)のプライオリティ フロー制御情報を表示します。

次に、指定したインターフェイスのプライオリティ フロー制御の詳細を表示する例を示します。

switch# show interface ethernet 1/2 priority-flow-control
============================================================
Port Mode Oper(VL bmap) RxPPP TxPPP
============================================================
 
Ethernet1/2 Auto On (9) 4088353 1890
switch#
 

イーサネット 1/2 がインターフェイスとして指定され、PFC モードは PFC 機能をネゴシエートするように設定されていて、動作がオンになっており、転送パケットは 1890 です。

次に、指定されたレイヤ 3 インターフェイスのプライオリティ フロー制御情報を表示する例を示します。

switch# show interface ethernet 1/5 priority-flow-control
============================================================
Port Mode Oper(VL bmap) RxPPP TxPPP
============================================================
 
Ethernet1/5 On On (0) 0 0
switch#
 

次に、すべてのインターフェイスのプライオリティ フロー制御情報を表示する例を示します。

switch# show interface priority-flow-control
============================================================
Port Mode Oper(VL bmap) RxPPP TxPPP
============================================================
 
Ethernet1/1 Auto Off 0 0
Ethernet1/2 Auto Off 0 0
Ethernet1/3 Auto Off 0 0
Ethernet1/4 Auto Off 0 0
Ethernet1/5 On On (0) 0 0
Ethernet1/6 Auto Off 0 0
Ethernet1/7 Auto Off 0 0
Ethernet1/8 Auto Off 0 0
Ethernet1/9 Auto Off 0 0
Ethernet1/10 Auto Off 0 0
Ethernet1/11 Auto Off 0 0
Ethernet1/12 Auto Off 0 0
Ethernet1/13 Auto Off 0 0
Ethernet1/14 Auto Off 0 0
Ethernet1/15 Auto Off 0 0
Ethernet1/16 Auto Off 0 0
Ethernet1/17 Auto Off 0 0
Ethernet1/18 Auto Off 0 0
Ethernet1/19 Auto Off 0 0
Ethernet1/20 Auto Off 0 0
Ethernet1/21 Auto Off 0 0
Ethernet1/22 Auto Off 0 0
Ethernet1/23 Auto Off 0 0
Ethernet1/24 Auto Off 0 0
Ethernet1/25 Auto Off 0 0
Ethernet1/26 Auto Off 0 0
Ethernet1/27 Auto Off 0 0
Ethernet1/28 Auto Off 0 0
Ethernet1/29 Auto Off 0 0
Ethernet1/30 Auto Off 0 0
Ethernet1/31 Auto Off 0 0
Ethernet1/32 Auto Off 0 0
Ethernet3/1 Auto Off 0 0
Ethernet3/2 Auto Off 0 0
Ethernet3/3 Auto Off 0 0
Ethernet3/4 Auto Off 0 0
Ethernet3/5 Auto Off 0 0
Ethernet3/6 Auto Off 0 0
Ethernet3/7 Auto Off 0 0
Ethernet3/8 Auto Off 0 0
Ethernet3/9 Auto Off 0 0
Ethernet3/10 Auto Off 0 0
Ethernet3/11 Auto Off 0 0
Ethernet3/12 Auto Off 0 0
Ethernet3/13 Auto Off 0 0
Ethernet3/14 Auto Off 0 0
Ethernet3/15 Auto Off 0 0
Ethernet3/16 Auto Off 0 0
Ethernet3/17 Auto Off 0 0
Ethernet3/18 Auto Off 0 0
Ethernet3/19 Auto Off 0 0
Ethernet3/20 Auto Off 0 0
Ethernet3/21 Auto Off 0 0
Ethernet3/22 Auto Off 0 0
Ethernet3/23 Auto Off 0 0
Ethernet3/24 Auto Off 0 0
Ethernet3/25 Auto Off 0 0
Ethernet3/26 Auto Off 0 0
Ethernet3/27 Auto Off 0 0
Ethernet3/28 Auto Off 0 0
Ethernet3/29 Auto Off 0 0
Ethernet3/30 Auto Off 0 0
Ethernet3/31 Auto Off 0 0
Ethernet3/32 Auto Off 0 0
Ethernet100/1/1 Auto Off 0 0
Ethernet100/1/2 Auto Off 0 0
Ethernet100/1/3 Auto Off 0 0
Ethernet100/1/4 Auto Off 0 0
Ethernet100/1/5 Auto Off 0 0
Ethernet100/1/6 Auto Off 0 0
Ethernet100/1/7 Auto Off 0 0
Ethernet100/1/8 Auto Off 0 0
Ethernet100/1/9 Auto Off 0 0
Ethernet100/1/10 Auto Off 0 0
Ethernet100/1/11 Auto Off 0 0
Ethernet100/1/12 Auto Off 0 0
Ethernet100/1/13 Auto Off 0 0
Ethernet100/1/14 Auto Off 0 0
Ethernet100/1/15 Auto Off 0 0
Ethernet100/1/16 Auto Off 0 0
switch#
 

 
関連コマンド

コマンド
説明

no switchport

レイヤ 3 ルーテッド インターフェイスとして設定します。

priority-flow-control

選択したインターフェイスの PFC モードを設定します。

show interface untagged-cos

指定したインターフェイスのタグなしサービス クラス(CoS)値を表示するには、 show interface untagged-cos コマンドを使用します。

show interface untagged-cos [ module module_no ]

 
構文の説明

module

(任意)スイッチ シャーシのこのモジュールのインターフェイスを表示します。

module_no

スイッチ シャーシのモジュール番号。有効な範囲は 1 ~ 18 です。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスを表示するサポートが追加されました。

次に、インターフェイスのタグなし CoS 値を表示する例を示します。

switch# show interface untagged-cos
=================================
 
Interface Untagged-CoS
=================================
 
port-channel1
port-channel3 2
port-channel5 5
port-channel6
port-channel12
port-channel15
port-channel20
port-channel24
port-channel25
port-channel33
port-channel41
port-channel44
--More--
switch#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチ上のすべてのインターフェイス(レイヤ 2、レイヤ 3)のタグなし CoS 値を表示する例を示します。

switch# show interface untagged-cos
S3(config-if)# show int untagged-cos
=================================
 
Interface Untagged-CoS
=================================
 
port-channel100
port-channel127
port-channel128
Ethernet1/1
Ethernet1/2
Ethernet1/3
Ethernet1/4
Ethernet1/5 3
Ethernet1/6
Ethernet1/7
Ethernet1/8
Ethernet1/9
Ethernet1/10
Ethernet1/11
Ethernet1/12
:
<--snip-->
Ethernet3/31
Ethernet3/32
Ethernet100/1/1
Ethernet100/1/2
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

untagged cos

タグなしイーサネット フレームの CoS 値を設定します。

show policy-map

ポリシー マップを表示するには、 show policy-map コマンドを使用します。

show policy-map [ type { network-qos | qos | queuing }] [ policy-map-name ]

 
構文の説明

type

(任意)表示するコンポーネント タイプを指定します。

network-qos

ネットワーク QoS タイプのポリシー マップを表示します。

qos

QoS タイプのポリシー マップだけを表示します。

queuing

キューイング タイプのポリシー マップだけを表示します。

policy-map-name

(任意)ポリシー マップの名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

引数やキーワードを指定せずに show policy-map コマンドを入力すると、コントロール プレーン ポリシング(CoPP)情報も表示されます。

次に、指定したネットワーク QoS タイプのポリシー マップを表示する例を示します。

switch# show policy-map type network-qos my_pnq
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos my_pnq
class type network-qos cl_nq
multicast-optimize
queue-limit 20480 bytes
mtu 1500
class type network-qos class-fcoe
pause no-drop
mtu 2158
class type network-qos class-default
mtu 1500
switch#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

show policy-map interface

各インターフェイスに設定されているサービス ポリシー マップを表示するには、 show policy-map interface コマンドを使用します。

show policy-map interface [ ethernet slot / port | port-channel channel-number ] [ input | output ] [ type { qos | queuing }]

 
構文の説明

ethernet

(任意)イーサネット インターフェイスに割り当てられているポリシー マップを表示します。

slot/port

イーサネット インターフェイスのスロット番号とポート番号を指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

port-channel

(任意)EtherChannel に割り当てられているポリシー マップを表示します。

channel-number

EtherChannel 番号。範囲は 1 ~ 4096 です。

input

(任意)入力トラフィックに割り当てられているポリシー マップだけを表示します。

output

(任意)出力トラフィックに割り当てられているポリシー マップだけを表示します。

type

(任意)表示するコンポーネント タイプを指定します。

qos

QoS タイプのポリシー マップだけを表示します。

queuing

キューイング タイプのポリシー マップだけを表示します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 サブインターフェイスのサポートが追加されました。

 
使用上のガイドライン

デフォルトでは統計情報が表示されます。

次に、指定したインターフェイスに割り当てられているポリシー マップを表示する例を示します。

switch(config)# show policy-map interface ethernet 2/10
 

次に、指定したインターフェイスに割り当てられている QoS ポリシー マップを表示する例を示します。

switch# show policy-map interface ethernet 3/1 type qos
 
 
Global statistics status : disabled
 
Ethernet3/1
 
Service-policy (qos) input: s
policy statistics status: disabled
 
Class-map (qos): s1 (match-any)
Match: cos 0
set qos-group 2
 
Class-map (qos): class-1-2 (match-any)
Match: cos 1-2
set qos-group 3
 
Class-map (qos): class-4-5 (match-any)
Match: cos 4-5
set qos-group 4
 
Class-map (qos): class-6 (match-any)
Match: cos 6
set qos-group 5
 
Class-map (qos): class-fcoe (match-any)
Match: cos 3
set qos-group 1
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
switch#
 

次に、指定したインターフェイスの出力トラフィックに割り当てられたポリシー マップを表示する例を示します。

switch# show policy-map interface ethernet 3/1 output
 
 
Global statistics status : disabled
 
Ethernet3/1
 
Service-policy (queuing) output: pqe1
policy statistics status: disabled
 
Class-map (queuing): cqe1 (match-any)
Match: qos-group 2
bandwidth percent 20
 
Class-map (queuing): cqe2 (match-any)
Match: qos-group 3
priority
 
Class-map (queuing): cqe3 (match-any)
Match: qos-group 4
bandwidth percent 20
 
Class-map (queuing): cqe4 (match-any)
Match: qos-group 5
bandwidth percent 40
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 5
 
switch#
 

次に、仮想イーサネット インターフェイスの入力トラフィックに割り当てられているポリシー マップを表示する例を示します。

switch# show policy-map interface vethernet 10 input type queuing
 
 
Global statistics status : disabled
 
Vethernet10
 
Service-policy (queuing) input: p2
policy statistics status: disabled
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 50
shape 30 kbps
 
switch#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

service-policy(仮想イーサネット インターフェイス)

ポリシー マップを仮想イーサネット インターフェイスに関連付けます。

show policy-map interface brief

インターフェイスに適用されるポリシー マップの概要を表示するには、 show policy-map interface brief コマンドを使用します。

show policy-map interface brief

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスを表示するサポートが追加されました。

次に、割り当てられているポリシー マップの概要を表示する例を示します。

switch(config)# show policy-map interface brief
 
 
Interface [Status]:INP QOS INP QUE OUT QUE
===================================================================
port-channel1 [Active]:p1 pqe1 pqe1
port-channel3 [Active]:s pqe1 pqe1
port-channel5 [Active]:s pqe1 pqe1
port-channel6 [Active]:s pqe1 pqe1
port-channel12 [Active]:p12 p12-in p12-out
port-channel15 [Active]:s pqe1 pqe1
port-channel20 [Active]:s pqe1 pqe1
port-channel24 [Active]:p4 pqe1 pqe1
port-channel25 [Active]:p4 pqe1 pqe1
port-channel33 [Active]:s pqe1 pqe1
port-channel41 [Active]:s pqe1 pqe1
port-channel44 [Active]:s pqe1 pqe1
port-channel48 [Active]:s pqe1 pqe1
port-channel101 [Active]:s pqe1 pqe1
port-channel102 [Active]:p4
port-channel103 [Active]:p4
port-channel104 [Active]:p4
port-channel105 [Active]:p4
port-channel106 [Active]:p4
port-channel107 [Active]:p4
--More--
switch(config)#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチで割り当てられているポリシー マップの概要を表示する例を示します。

switch# show policy-map interface brief
S3(config-if)# show policy-map interface brief
 
 
Interface/VLAN [Status]:INP QOS OUT QOS INP QUE OUT QUE
================================================================================
port-channel100 [Active]:default-in-po default-in-po default-out-p
 
port-channel127 [Active]:default-in-po default-in-po default-out-p
 
port-channel128 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/1 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/2 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/3 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/4 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/5 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/6 [Active]:default-in-po default-in-po default-out-p
 
:
<Snip>
:
Ethernet3/31 [Active]:default-in-po default-in-po default-out-p
 
Ethernet3/32 [Active]:default-in-po default-in-po default-out-p
 
Ethernet100/1/1 [Active]:default-in-po default-in-po default-out-p
 
Ethernet100/1/2 [Active]:default-in-po default-in-po default-out-p
 
Ethernet100/1/3 [Active]:default-in-po default-in-po default-out-p
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

show policy-map

ポリシー マップを表示します。

 

show policy-map interface control-plane

インターフェイスに適用されているコントロール プレーン ポリシー マップを表示するには、 show policy-map interface control-plane コマンドを使用します。

show policy-map interface control-plane

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

次に、割り当てられたコントロール プレーン ポリシー マップを表示する例を示します。

switch# show policy-map interface control-plane
control Plane
 
service-policy input: copp-system-policy-default
 
class-map copp-system-class-igmp (match-any)
match protocol igmp
police cir 1024 kbps , bc 65535 bytes
conformed 0 bytes; action: transmit
violated 0 bytes; action: drop
 
class-map copp-system-class-pim-hello (match-any)
match protocol pim
police cir 1024 kbps , bc 4800000 bytes
conformed 0 bytes; action: transmit
violated 0 bytes; action: drop
 
class-map copp-system-class-bridging (match-any)
match protocol bridging
police cir 20000 kbps , bc 4800000 bytes
conformed 0 bytes; action: transmit
violated 0 bytes; action: drop
 
class-map copp-system-class-arp (match-any)
match protocol arp
<--Output truncated-->
switch(config)#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

show policy-map

ポリシー マップを表示します。

 

show policy-map system

システムのすべてのアクティブ ポリシー マップを表示するには、 show policy-map system コマンドを使用します。

show policy-map system [ type { network-qos | qos [ input ] | queuing [ input | output ]}]

 
構文の説明

type

(任意)表示するコンポーネント タイプを指定します。

network-qos

ネットワーク QoS タイプのポリシー マップだけを表示します。

qos

QoS タイプのポリシー マップだけを表示します。

input

(任意)入力トラフィックに割り当てられているポリシー マップを表示します。

queuing

キューイング タイプのポリシー マップだけを表示します。

output

(任意)出力トラフィックに割り当てられているポリシー マップを表示します。

 
コマンド デフォルト

すべてのポリシー マップ

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポリシー マップのタイプと名前を指定しない場合、システムのすべてのアクティブ ポリシー マップが表示されます。

次に、システムのすべてのアクティブ ポリシー マップを表示する例を示します。

switch# show policy-map system
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos s
class type network-qos s2 match qos-group 3
 
mtu 4000
class type network-qos s1 match qos-group 2
 
mtu 5000
set cos 0
multicast-optimize
pause no-drop
class type network-qos s3 match qos-group 4
 
mtu 9216
class type network-qos s4 match qos-group 5
 
mtu 9216
class type network-qos class-fcoe match qos-group 1
 
pause no-drop
mtu 2158
class type network-qos class-default match qos-group 0
 
mtu 1500
 
 
Service-policy (qos) input: s
policy statistics status: disabled
 
Class-map (qos): s1 (match-any)
Match: cos 0
set qos-group 2
 
Class-map (qos): class-1-2 (match-any)
Match: cos 1-2
set qos-group 3
 
Class-map (qos): class-4-5 (match-any)
Match: cos 4-5
set qos-group 4
 
Class-map (qos): class-6 (match-any)
Match: cos 6
set qos-group 5
 
Class-map (qos): class-fcoe (match-any)
Match: cos 3
set qos-group 1
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
Service-policy (queuing) input: pqe1
policy statistics status: disabled
 
Class-map (queuing): cqe1 (match-any)
Match: qos-group 2
bandwidth percent 20
 
Class-map (queuing): cqe2 (match-any)
Match: qos-group 3
priority
 
Class-map (queuing): cqe3 (match-any)
Match: qos-group 4
bandwidth percent 20
 
Class-map (queuing): cqe4 (match-any)
Match: qos-group 5
bandwidth percent 40
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 5
 
Service-policy (queuing) output: pqe1
policy statistics status: disabled
 
Class-map (queuing): cqe1 (match-any)
Match: qos-group 2
bandwidth percent 20
 
Class-map (queuing): cqe2 (match-any)
Match: qos-group 3
priority
 
Class-map (queuing): cqe3 (match-any)
Match: qos-group 4
bandwidth percent 20
 
Class-map (queuing): cqe4 (match-any)
Match: qos-group 5
bandwidth percent 40
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 5
 
switch#
 

次に、システムのアクティブなネットワーク QoS タイプのポリシー マップを表示する例を示します。

switch# show policy-map system type network-qos
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos s
class type network-qos s2 match qos-group 3
 
mtu 4000
class type network-qos s1 match qos-group 2
 
mtu 5000
set cos 0
multicast-optimize
pause no-drop
class type network-qos s3 match qos-group 4
 
mtu 9216
class type network-qos s4 match qos-group 5
 
mtu 9216
class type network-qos class-fcoe match qos-group 1
 
pause no-drop
mtu 2158
class type network-qos class-default match qos-group 0
 
mtu 1500
switch#

 
関連コマンド

コマンド
説明

show policy-map

すべてのポリシー マップを表示します。

show policy-map type control-plane

コントロール プレーン ポリシー マップ情報を表示するには、 show policy-map type control-plane コマンドを使用します。

show policy-map type control-plane [ expand ] [ name policy-map-name ]

 
構文の説明

expand

(任意)拡張されたコントロール プレーン ポリシー マップ情報を表示します。

name policy-map-name

(任意)コントロール プレーン ポリシー マップの名前を指定します。名前は最大 64 文字の英数字で、大文字と小文字が区別されます。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、コントロール プレーン ポリシー マップ情報を表示する例を示します。

switch# show policy-map type control-plane
 
policy-map type control-plane copp-system-policy-customized
class copp-system-class-igmp
police cir 1024 kbps bc 65535 bytes
class copp-system-class-pim-hello
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-bridging
police cir 20000 kbps bc 4800000 bytes
class copp-system-class-arp
police cir 1024 kbps bc 3600000 bytes
class copp-system-class-dhcp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-mgmt
police cir 12000 kbps bc 4800000 bytes
class copp-system-class-lacp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-lldp
police cir 2048 kbps bc 4800000 bytes
class copp-system-class-udld
police cir 2048 kbps bc 4800000 bytes
<--Output truncated-->
switch#
 

次に、コントロール プレーン ポリシー マップ情報を拡張形式で表示する例を示します。

switch# show policy-map type control-plane expand
 

 
関連コマンド

コマンド
説明

policy-map type control-plane

コントロール プレーン ポリシー マップを作成または設定します。

 

show policy-map vlan

VLAN ポリシー マップを表示するには、 show policy-map vlan コマンドを使用します。

show policy-map vlan [vlan-number]

 
構文の説明

vlan-number

指定する VLAN に設定されている QoS ポリシーを表示します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.1(3)N2(1)

このコマンドが追加されました。

 
使用上のガイドライン

show policy-map vlan コマンドを使用する前に、インターフェイス QoS 制限とポリシー マップを設定する必要があります。TCAM には VLAN でのサービス ポリシーの設定に十分な空きエントリが必要です。

次に、指定する VLAN に設定されている QoS ポリシーを表示する例を示します。

switch# show policy-map vlan 101
 
 
Service-policy (qos) input: vpq1
===============================
 
policy status statistics: disabled
class-map (qos): vcq2 (match-any)
match: cos 2
match: precedence 1
set cos-group 2
set prec 2
 
class-map (qos): vcq4 (match-any)
match: access-group ipacl1-vq
match: prec 7
set cos-group 4
 
class-map (qos): vcq4 (match-any)
match: cos 1
set cos-group 3
 
class-map (qos): vcq4 (match-any)
match: any
set cos-group 0
switch#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

show queuing interface

インターフェイスのキューイング情報を表示するには、 show queuing interface コマンドを使用します。

show queuing interface [ ethernet slot-no / port-no ]

 
構文の説明

ethernet

(任意)イーサネット インターフェイスに表示されるキューイング情報を指定します。

slot-no

イーサネット インターフェイスのスロット番号を指定します。指定できる範囲は 1 ~ 255 です。

port-no

イーサネット インターフェイスのポート番号を指定します。指定できる範囲は 1 ~ 128 です。

 
コマンド デフォルト

すべてのインターフェイスのキューイング情報を表示します。

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、すべてのインターフェイスのキューイング情報を表示する例を示します。

switch# show queuing interface
Ethernet1/1 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 73
1 WRR 0
2 WRR 1
3 WRR 6
4 WRR 20
5 priority 0
 
RX Queuing
qos-group 0
q-size: 25600, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 160
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 1
q-size: 76800, HW MTU: 2240 (2158 configured)
drop-type: no-drop, xon: 128, xoff: 240
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 2
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 3
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 4
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 5
q-size: 81920, HW MTU: 9280 (9216 configured)
drop-type: no-drop, xon: 128, xoff: 230
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
Total Multicast crossbar statistics:
Mcast pkts received from the cross-bar : 0
 
Ethernet1/2 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 73
1 WRR 0
2 WRR 1
3 WRR 6
4 WRR 20
5 priority 0
<---output truncated--->
switch#
 

次に、イーサネット インターフェイス 1/2 のキューイング情報を表示する例を示します。

switch# show queuing interface ethernet 1/2
Ethernet1/2 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 73
1 WRR 0
2 WRR 1
3 WRR 6
4 WRR 20
5 priority 0
 
RX Queuing
qos-group 0
q-size: 25600, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 160
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 1851526994
Pkts sent to the port : 1851527000
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 1
q-size: 76800, HW MTU: 2240 (2158 configured)
drop-type: no-drop, xon: 128, xoff: 240
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 2
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
--More--
switch#
 

表 1 に、この出力で表示される重要なフィールドの説明を示します。

 

表 1 show queuing interface フィールドの説明

フィールド
説明

Ethernet ...

イーサネット インターフェイス情報。

qoS-group

スイッチに設定されている QoS グループの情報。

sched-type

スケジュールのタイプ。

WRR

重み付けラウンドロビン(WRR)。スケジューリングのキューの重み付け。

Priority

キューのプライオリティ。

q-size

キュー サイズ。

drop-type

キューのドロップ タイプ。drop も no-drop も可能。

MTU

キューの Maximum Transmit Unit(MTU)。

Xon

このしきい値で伝送をオンにします。

Xoff

このしきい値で伝送をオフにします。

 
関連コマンド

コマンド
説明

hardware buffer-threshold

ハードウェア バッファしきい値を設定します。

hardware queue-limit

ハードウェア キュー制限を設定します。

show fex

スイッチに接続されている、すべての設定済みファブリック エクステンダ シャーシを表示します。

 

show running-config copp

実行コンフィギュレーションのコントロール プレーン ポリシング(CoPP)の設定情報を表示するには、 show running-config copp コマンドを使用します。

show running-config copp [ all ]

 
構文の説明

all

(任意)設定済みおよびデフォルトの情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、Cisco NX-OS Release 5.1(3)N1(1) を実行しているスイッチで実行コンフィギュレーションに設定されている CoPP 情報を表示する例を示します。

switch# show running-config copp
 

次に、実行コンフィギュレーションの設定済み CoPP 情報およびデフォルトの CoPP 情報を表示する例を示します。

switch# show running-config copp all
 

 
関連コマンド

コマンド
説明

control-plane

コントロール プレーン コンフィギュレーション モードを開始します。

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show startup-config aclmgr

ACL のスタートアップ コンフィギュレーションを表示します。

show startup-config copp

スタートアップ コンフィギュレーション ファイルの CoPP の設定情報を表示します。

 

show running-config ipqos

システムの実行コンフィギュレーションについて、Quality of Service(QoS)関連の情報を表示するには、 show running-config ipqos コマンドを使用します。

show running-config ipqos [ all ]

 
構文の説明

all

(任意)設定済みおよびデフォルトの情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスを表示するサポートが追加されました。

 
使用上のガイドライン

デフォルトおよび設定済みクラス マップとポリシー マップのリストと、インターフェイスに割り当てられているポリシーを表示するために使用します。

次に、Cisco NX-OS Release 5.0(2)N1(1) を実行しているスイッチの QoS 情報を表示する例を示します。

switch# show running-config ipqos
 
 
!Command: show running-config ipqos
!Time: Thu Sep 9 06:26:49 2010
 
version 5.0(2)N1(1)
class-map type qos class-fcoe
match cos 4
class-map type qos match-all 1
match cos 1
class-map type qos match-all 2
match cos 2
class-map type qos match-all 3
match cos 3
class-map type qos match-all 4
class-map type qos match-any 5
match cos 5,7
class-map type qos match-all arp
match protocol dhcp
match protocol arp
match cos 3
class-map type qos match-all cos
match cos 5
class-map type qos match-all dot
match access-group name dot
class-map type qos match-all my_class
match dscp 3
match precedence 0
match protocol dhcp
class-map type qos match-all new
match protocol netbios
:
<snip>
class-map type queuing my_qclass
match qos-group 3
class-map type queuing Video-Signalling
match qos-group 4
class-map type queuing class-ip-multicast
match qos-group 4
policy-map type qos 5
class 5
set qos-group 2
class Video
set qos-group 3
policy-map type qos my_policy
class my_class
set precedence 5
set dscp 5
class myQAll
set precedence 3
set dscp 48
:
<snip>
policy-map type network-qos my_policy1
class type network-qos my_class1
pause no-drop buffer-size 143680 pause-threshold 58860 resume-threshold 3840
class type network-qos class-fcoe
pause no-drop
mtu 2158
class type network-qos class-default
:
<snip>
system qos
service-policy type qos input voice
service-policy type network-qos Network
service-policy type queuing output Queu
service-policy type queuing input Queue
 
<--output truncated-->
switch#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチの QoS 情報を表示する例を示します。

switch# show running-config ipqos
 
!Command: show running-config ipqos
!Time: Sun Apr 20 07:22:36 2008
 
version 5.0(3)N1(1)
class-map type qos class-fcoe
class-map type qos match-all c1
match cos 3-5
class-map type queuing class-fcoe
match qos-group 1
class-map type queuing class-all-flood
match qos-group 2
class-map type queuing class-ip-multicast
match qos-group 2
policy-map type qos p1
class c1
set qos-group 3
class-map type network-qos n1
match qos-group 1
class-map type network-qos class-fcoe
match qos-group 1
class-map type network-qos class-all-flood
match qos-group 2
class-map type network-qos class-ip-multicast
match qos-group 2
policy-map type network-qos n2
class type network-qos n1
class type network-qos class-default
multicast-optimize
 
 
interface Ethernet1/5
priority-flow-control mode on
untagged cos 3
 
switch#
 

上記の出力はレイヤ 3 インターフェイス(レイヤ 3 インターフェイスとして設定されたイーサネット 1/5)の QoS 情報を示しています。

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show class-map

クラス マップ情報を表示します。

show policy-map

ポリシー マップ情報を表示します。

 

show startup-config copp

スタートアップ コンフィギュレーションのコントロール プレーン ポリシング(CoPP)の設定情報を表示するには、 show startup-config copp コマンドを使用します。

show startup-config copp

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、スタートアップ コンフィギュレーションの CoPP 情報を表示する例を示します。

switch# show startup-config copp
 

 
関連コマンド

コマンド
説明

control-plane

コントロール プレーン コンフィギュレーション モードを開始します。

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show running-config copp

実行コンフィギュレーション内の CoPP 設定情報を表示します。

 

show startup-config ipqos

スタートアップ コンフィギュレーションの Quality of Service(QoS)の設定情報を表示するには、 show startup-config ipqos コマンドを使用します。

show startup-config ipqos [ all ]

 
構文の説明

all

(任意)設定済みおよびデフォルトの情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスを表示するサポートが追加されました。

次に、スタートアップ コンフィギュレーション ファイルの QoS 情報を表示する例を示します。

switch# show startup-config ipqos
 
!Command: show startup-config ipqos
!Time: Thu Sep 9 07:42:33 2010
!Startup config saved at: Tue Sep 7 08:45:03 2010
 
version 5.0(2)N1(1)
class-map type qos class-fcoe
match cos 4
class-map type qos match-all 1
match cos 1
class-map type qos match-all 2
match cos 2
class-map type qos match-all 3
match cos 3
class-map type qos match-all 4
class-map type qos match-any 5
match cos 5,7
class-map type qos match-all arp
match protocol dhcp
match protocol arp
match cos 3
class-map type qos match-all cos
match cos 5
class-map type qos match-all dot
match access-group name dot
class-map type qos match-all new
match protocol netbios
class-map type qos match-all rtp
match ip rtp 2000-40000
class-map type qos match-all dscp
match dscp 46
match precedence 7
match protocol arp
class-map type qos match-all Video
match dscp 34
class-map type qos match-all Voice
match dscp 40,46
class-map type qos match-all class1
match ip rtp 2000
class-map type qos match-all class2
match cos 1
class-map type qos match-all class3
match protocol arp
class-map type qos match-all class4
match protocol dhcp
class-map type qos match-all class5
match protocol ldp
:
:
<--output truncated--
 
switch#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show class-map

クラス マップ情報を表示します。

show policy-map

ポリシー マップ情報を表示します。

show wrr-queue cos-map

出力キューにマッピングされたサービス クラス(CoS)値を表示するには、 show wrr-queue cos-map コマンドを使用します。

show wrr-queue cos-map

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

次に、出力キューにマッピングされた CoS 値を表示する例を示します。

switch# show wrr-queue cos-map
MCAST Queue ID Cos Map
0 0 1
1 2
2 3 4 5
3 6 7
switch#
 

 
関連コマンド

コマンド
説明

wrr-queue cos-map

サービス クラス(CoS)値を出力キューのいずれかを選択するためにマッピングします。