Cisco Nexus 5000 Series NX-OS Virtual Port Channel コマンド リファレンス Cisco NX-OS Release 4.x、5.x
show コマンド
show コマンド
発行日;2012/06/22 | 英語版ドキュメント(2012/01/02 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 902KB) | フィードバック

目次

show コマンド

show ip arp vpc-statistics

show port-profile

show port-profile brief

show port-profile expand-interface

show port-profile name profile_name

show port-profile usage

show running-config expand-port-profile

show running-config port-profile

show running-config switch-profile

show running-config vpc

show startup-config interface

show startup-config port-profile

show startup-config switch-profile

show startup-config vpc

show switch-profile

show switch-profile buffer

show switch-profile peer

show switch-profile session-history

show switch-profile status

show tech-support vpc

show version

show vpc

show vpc brief

show vpc consistency-parameters

show vpc orphan-ports

show vpc peer-keepalive

show vpc role

show vpc statistics

show コマンド

この章では、Cisco NX-OS 仮想ポート チャネル(vPC)の show コマンドについて説明します。

show ip arp vpc-statistics

仮想ポート チャネル(vPC)のアドレス解決プロトコル(ARP)に関するグローバル統計情報を表示するには、 show ip arp vpc-statistics コマンドを使用します

show ip arp vpc-statistics

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、vPC のグローバルな ARP 統計情報を表示する例を示します。

switch# show ip arp vpc-statistics
ARP sync Enabled
 
ARP vPC global statistics
MCECM api failed while processing CFS payload : 2980
switch#
 

 
関連コマンド

コマンド
説明

ip arp synchronize

vPC ドメインでの ARP 同期をイネーブルにします。

show running-config vpc

vPC の実行コンフィギュレーション情報を表示します。

 

show port-profile

スイッチに設定されたポート プロファイルを表示するには show port-profile コマンドを使用します。

show port-profile

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

スイッチに設定されているポート プロファイル、およびポート プロファイルを継承したインターフェイスの設定情報を表示するには、このコマンドを使用します。

次に、スイッチに設定されたポート プロファイルを表示する例を示します。

switch# show port-profile
 
port-profile p1
type: Ethernet
description:
status: enabled
max-ports: 512
inherit:
config attributes:
ip port access-group denyv4 in
evaluated config attributes:
ip port access-group denyv4 in
assigned interfaces:
 
port-profile ppEth
type: Ethernet
description: Port profile to configure batch commands for Ethernet interfaces
status: enabled
max-ports: 512
inherit:
pp
config attributes:
evaluated config attributes:
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
assigned interfaces:
Ethernet198/1/11
 
switch#
 

表 1 に、この出力で表示されるフィールドの説明を示します。

 

表 1 show port-profile フィールドの説明

フィールド
説明

type

ポート プロファイルが表すインターフェイス タイプ。値にはイーサネット、インターフェイス VLAN、またはポート チャネルを指定できます。

description

ポート プロファイルの目的のサマリー。

status

ポート プロファイルのイネーブルまたはディセーブルの状態。

max-ports

このプロファイルを継承できるポートの最大数。デフォルトは 512 です。

inherit

このポート プロファイルが継承したポート プロファイルの名前。このフィールドは、ポート プロファイルが別のポート プロファイルを継承しなければブランクです。

config attributes

ポート プロファイルのコンフィギュレーション コマンド。

evaluated config attributes

このポート プロファイルの確認されたコンフィギュレーション コマンドおよび別のポート プロファイルから継承されたコマンド。

assigned interfaces

このポート プロファイルを継承するインターフェイス。

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

inherit

インターフェイスにポート プロファイルをアタッチします。

show port-profile name profile_name

特定のポート プロファイルに関する情報を表示します。

show running-config port-profile

ポート プロファイルの実行コンフィギュレーションを表示します。

show port-profile brief

スイッチに設定されているポート プロファイルに関する要約情報を表示するには、 show port-profile brief コマンドを使用します。

show port-profile brief

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポート プロファイルを継承したインターフェイスの数、子ポート プロファイルの数、およびポート プロファイルに設定されているコマンドの数やポート プロファイルに継承されたコマンドの数を表示するには、このコマンドを使用します。

次に、スイッチに設定されているポート プロファイルに関する要約情報を表示する例を示します。

switch# show port-profile brief
----------------------------------------------------------
Port Profile Conf Eval Assigned Child
Profile State Items Items Intfs Profs
----------------------------------------------------------
ppEth 1 3 3 1 1
p1 1 1 1 0 0
switch#
 

表 2 に、この出力で表示されるフィールドの説明を示します。

 

表 2 show port-profile brief で表示されるフィールドの説明

フィールド
説明

Port Profile

ポート プロファイルの名前。

Profile State

ポート プロファイルのステート。値 1 はプロファイルがイネーブルであることを表し、0 はディセーブルであることを表します。

Conf Items

ポート プロファイルで設定されているコマンドの数。

Eval Items

ポート プロファイルに設定されているコマンド、または別のポート プロファイルから継承されているコマンドの数。

Assigned Intfs

ポート プロファイルに割り当てられているインターフェイス。

Child Profs

このポート プロファイルによって継承されているポート プロファイルの数。

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

show port-profile

設定済みのすべてのポート プロファイルに関する情報を表示します。

show port-profile name profile_name

特定のポート プロファイルに関する情報を表示します。

show running-config port-profile

ポート プロファイルの実行コンフィギュレーションを表示します。

show port-profile expand-interface

インターフェイスに適用されたアクティブ ポート プロファイル設定を表示するには、 show port-profile expand-interface コマンドを使用します。

show port-profile expand-interface [ pp-profile-name ]

 
構文の説明

pp-profile-name

(任意)ポート プロファイルの名前。名前は最大 80 文字の英数字で、アンダースコア、ハイフンを含めることができます。名前にはスペースや特殊文字は使用できません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、インターフェイスに適用されているポート プロファイル設定を表示するために使用します。

次に、割り当てられたインターフェイスに適用されるポート プロファイルの設定を表示する例を示します。

switch# show port-profile expand-interface
 
port-profile ppEth
Ethernet198/1/11
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
 
port-profile p1
 
port-profile pp
 
switch#
 

次に、インターフェイスに割り当てられている特定のポート プロファイルの設定を表示する例を示します。

switch# show port-profile expand-interface name ppEth
 
port-profile ppEth
Ethernet198/1/11
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
 
switch#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

show port-profile

設定済みのすべてのポート プロファイルに関する情報を表示します。

show running-config port-profile

ポート プロファイルの実行コンフィギュレーションを表示します。

show port-profile name profile_name

特定のポート プロファイルの設定情報を表示するには、 show port-profile name コマンドを使用します。

show port-profile name pp-profile-name

 
構文の説明

pp-profile-name

ポート プロファイルの名前。名前は最大 80 文字の英数字で、アンダースコア、ハイフンを含めることができます。名前にはスペースや特殊文字は使用できません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、ppEth というポート プロファイルの設定情報を表示する例を示します。

switch# show port-profile name ppEth
 
port-profile ppEth
type: Ethernet
description: Port profile to configure batch commands for Ethernet interfaces
status: enabled
max-ports: 512
inherit:
pp
config attributes:
evaluated config attributes:
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
assigned interfaces:
Ethernet198/1/11
 
switch#
 

表 3 に、この出力で表示されるフィールドの説明を示します。

 

表 3 show port-profile フィールドの説明

フィールド
説明

type

ポート プロファイルが表すインターフェイス タイプ。値にはイーサネット、インターフェイス VLAN、またはポート チャネルを指定できます。

description

ポート プロファイルの目的のサマリー。

status

ポート プロファイルのイネーブルまたはディセーブルの状態。

max-ports

このプロファイルを継承できるポートの最大数。デフォルトは 512 です。

inherit

このポート プロファイルが継承したポート プロファイルの名前。このフィールドは、ポート プロファイルが別のポート プロファイルを継承しなければブランクです。

config attributes

ポート プロファイルのコンフィギュレーション コマンド。

evaluated config attributes

このポート プロファイルの確認されたコンフィギュレーション コマンドおよび別のポート プロファイルから継承されたコマンド。

assigned interfaces

このポート プロファイルを継承するインターフェイス。

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

inherit

インターフェイスにポート プロファイルをアタッチします。

show port-profile

すべてのポート プロファイルに関する情報を表示します。

show running-config port-profile

ポート プロファイルの実行コンフィギュレーションを表示します。

show port-profile usage

ポート プロファイルを継承したインターフェイスのリストを表示するには、 show port-profile usage コマンドを使用します。

show port-profile usage [ pp-profile-name ]

 
構文の説明

pp-profile-name

(任意)ポート プロファイルの名前。名前は最大 80 文字の英数字で、アンダースコア、ハイフンを含めることができます。名前にはスペースや特殊文字は使用できません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、スイッチに設定されたポート プロファイルに割り当てられたインターフェイスを表示する例を示します。

switch# show port-profile usage
 
port-profile eth
Ethernet198/1/11
 
port-profile p1
 
port-profile pp
 
switch#
 

次に、ppEth というポート プロファイルにアタッチされているインターフェイスを表示する例を示します。

switch# show port-profile usage name ppEth
 
port-profile ppEth
Ethernet198/1/11
 
switch#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

show port-profile

設定済みのすべてのポート プロファイルに関する情報を表示します。

show running-config port-profile

ポート プロファイルの実行コンフィギュレーションを表示します。

show startup-config port-profile

ポート プロファイルのスタートアップ コンフィギュレーションを表示します。

show running-config expand-port-profile

ポート プロファイルの詳細な実行コンフィギュレーションを表示するには、 show running-config expand expand-port-profile コマンドを使用します。

show running-config expand-port-profile

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、拡張ポート プロファイルの実行コンフィギュレーションを表示する例を示します。

switch# show running-config expand-port-profile
 
!Command: show running-config expand-port-profile
!Time: Wed Sep 8 09:19:41 2010
 
version 5.0(2)N1(1)
feature fcoe
 
feature telnet
feature tacacs+
cfs ipv4 distribute
cfs eth distribute
feature udld
feature interface-vlan
feature lacp
feature dhcp
feature vpc
feature lldp
feature vtp
feature fex
 
username admin password 5 $1$wmFN7Wly$/pjqx1DfAkCCAg/KyxbUz/ role network-admin
username install password 5 ! role network-admin
username praveena password 5 ! role network-operator
no password strength-check
ip domain-lookup
ip domain-lookup
tacacs-server host 192.0.131.54 key 7 "wawy1234"
tacacs-server host 192.0.131.37
tacacs-server host 192.0.131.37 test username user1
:
<--Snip-->
:
vpc domain 1000
role priority 65534
system-mac 00:23:04:ee:c1:e8
peer-keepalive destination 192.0.10.2 source 192.0.10.3 vrf default
port-profile type interface-vlan ppVlan
bandwidth 30000000
mtu 3000
description Sample port-profile for VLAN interfaces
port-profile type ethernet eth
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
state enabled
port-profile type port-channel ppPO
delay 5000000
load-interval counter 1 30
switchport mode trunk
description Sample port profile for Port Channel interface
state enabled
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
 
interface Vlan1
 
:
<--snip-->
:
mac address-table notification threshold limit 99 interval 60
interface fc2/1
interface fc2/2
interface fc2/3
interface fc2/4
logging server 192.0.20.101
logging server 192.0.20.102
logging timestamp milliseconds
no logging console
 
 
switch#
 

 
関連コマンド

コマンド
説明

port-profile

ポート プロファイルを設定します。

show port-profile

ポート プロファイル情報を表示します。

show running-config port-profile

実行コンフィギュレーションとポート プロファイル設定を表示します。

show running-config port-profile

ポート プロファイルの実行コンフィギュレーションを表示するには、 show running-config port-profile コマンドを使用します。

show running-config port-profile [ pp-profile-name ]

 
構文の説明

pp-profile-name

ポート プロファイルの名前。名前は最大 80 文字の英数字で、アンダースコア、ハイフンを含めることができます。名前にはスペースや特殊文字は使用できません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、スイッチに設定されたすべてのポート プロファイルの実行コンフィギュレーションを表示する例を示します。

switch# show running-config port-profile
 
!Command: show running-config port-profile
!Time: Mon Sep 6 07:31:24 2010
 
version 5.0(2)N1(1)
port-profile type interface-vlan ppVlan
bandwidth 30000000
mtu 3000
description Sample port-profile for VLAN interfaces
port-profile type ethernet eth
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
state enabled
port-profile type port-channel ppPO
delay 5000000
load-interval counter 1 30
switchport mode trunk
description Sample port profile for Port Channel interface
state enabled
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
switch#
 

次に、スイッチに設定された ppEth という名前のポート プロファイルの実行コンフィギュレーションを表示する例を示します。

switch# show running-config port-profile ppEth
 
!Command: show running-config port-profile ppEth
!Time: Mon Sep 6 07:32:10 2010
 
version 5.0(2)N1(1)
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
 
switch#
 

 
関連コマンド

コマンド
説明

port-profile

ポート プロファイルを設定します。

show port-profile

ポート プロファイルの設定情報を表示します。

show startup-config switch-profile

スイッチ プロファイルのスタートアップ コンフィギュレーション情報を表示します。

show running-config switch-profile

スイッチ プロファイルの実行コンフィギュレーションを表示するには、 show running-config switch-profile コマンドを使用します。

show running-config switch-profile

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、ピアのスイッチ 1 に設定された s5010 というスイッチ プロファイルの実行コンフィギュレーションを表示する例を示します。

switch# show running-config switch-profile
switch-profile s5010
sync-peers destination 192.0.120.3
interface Ethernet1/1
switchport mode trunk
speed 1000
 
switch#
 

 
関連コマンド

コマンド
説明

switch-profile

スイッチ プロファイルを設定します。

show startup-config switch-profile

スイッチ プロファイルのスタートアップ コンフィギュレーション情報を表示します。

show running-config vpc

仮想ポート チャネル(vPC)の実行コンフィギュレーション情報を表示するには、 show running-config vpc コマンドを使用します。

show running-config vpc [ all ]

 
構文の説明

all

(任意)設定済みおよびデフォルトの情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、Cisco NX-OS Release 4.1(2) を実行するスイッチの vPC の実行コンフィギュレーションを表示する例を示します。

switch (config)# show running-config vpc
version 4.1(2)
feature vpc
vpc domain 2
role priority 1
system-priority 32667
peer-keepalive destination 192.0.76.52 source 192.0.76.51 udp-port 3200 vrf ma
engagement interval 1000 timeout 5
 
 
interface port-channel10
vpc 20
 
interface port-channel101
vpc 101
 
interface port-channel200
vpc peer-link
 
interface port-channel201
vpc 201
 

次に、Cisco NX-OS Release 4.2(1) を実行するスイッチの vPC の実行コンフィギュレーションを表示する例を示します。

switch# show running-config vpc
 
!Command: show running-config vpc
!Time: Wed Mar 31 06:11:52 2010
 
version 4.2(1)N1(1)
feature vpc
 
vpc domain 1000
role priority 2000
peer-keepalive destination 192.0.183.52 source 192.0.76.51 vrf management
peer-config-check-bypass
 
 
interface port-channel1
vpc peer-link
 
interface port-channel3
vpc 4096
 
interface port-channel5
vpc 4001
 
interface port-channel12
vpc 4000
 
interface port-channel24
vpc 2000
 
interface port-channel41
vpc 41
 
interface port-channel48
vpc 48
 
--More--

switch#

 

次に、Cisco NX-OS Release 5.0(2)N1(1) を実行するスイッチの vPC のリロードの設定を表示する例を示します。

switch# show running-config vpc
 
 
!Command: show running-config vpc
!Time: Wed Oct 27 21:24:24 2010
 
version 5.0(2)N1(1)
feature vpc
 
vpc domain 10
peer-keepalive destination 192.0.1.48
reload restore
 
--More--
<--output truncated>
switch#
 

次に、Cisco NX-OS Release 5.0(2)N2(1) を実行するスイッチの vPC の自動回復の設定を表示する例を示します。

switch# show running-config vpc
 
!Command: show running-config vpc
!Time: Fri Dec 10 04:13:57 2010
 
version 5.0(2)N2(1)
feature vpc
 
vpc domain 100
peer-keepalive destination 192.0.51.138
auto-recovery reload-delay 300
 
interface port-channel1
vpc 1
 
interface port-channel100
vpc peer-link
 
switch#
 

 
関連コマンド

コマンド
説明

show vpc brief

vPC の情報を表示します。この機能がイネーブルになっていないと、このコマンドからはエラーが返されます。

 

show startup-config interface

スタートアップ コンフィギュレーションのインターフェイス設定情報を表示するには、 show startup-config interface コマンドを使用します。

show startup-config interface [ ethernet slot / port | expand-port-profile | loopback number | mgmt 0 | port-channel { channel-number } [ membership ] | tunnel number | { vlan vlan-id }

 
構文の説明

ethernet slot / port

(任意)モジュールの数とポート番号を表示します。 スロット 番号は 1 ~ 255、 ポート 番号は 1 ~ 128 です。

expand-port-profile

ポート プロファイルを表示します。

loopback number

ループバック インターフェイスの数を表示します。値の範囲は 1 ~ 4096 です。

mgmt 0

管理インターフェイスのコンフィギュレーション情報を表示します。

port-channel channel-number

ポート チャネル グループの数を表示します。値の範囲は 0 ~ 1023 です。

membership

(任意)指定したポート チャネルのメンバーシップを表示します。

tunnel number

トンネル インターフェイスの数を表示します。値の範囲は 0 ~ 65535 です。

vlan vlan-id

VLAN の数を表示します。値の範囲は 1 ~ 4096 です。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、インターフェイス イーサネット 7/1 のスタートアップ コンフィギュレーションの情報を表示する例を示します。

switch(config)# show startup-config interface ethernet 7/1
version 4.1(2)
 
interface Ethernet7/1
ip pim sparse-mode
switch(config)#
 

 
関連コマンド

コマンド
説明

show interface

指定されたインターフェイスに関する情報を表示します。

show startup-config port-profile

ポート プロファイルのスタートアップ コンフィギュレーションを表示するには、 show startup-config port-profile コマンドを使用します。

show startup-config switch-profile [ pp-profile-name ]

 
構文の説明

pp-profile-name

(任意)ポート プロファイルの名前。名前は最大 80 文字の英数字で、アンダースコア、ハイフンを含めることができます。名前にはスペースや特殊文字は使用できません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、スタートアップ コンフィギュレーション ファイルに保存されているすべてのポート プロファイルの設定情報を表示する例を示します。

switch# show startup-config switch-profile
 
!Command: show startup-config port-profile
!Time: Mon Sep 6 07:32:48 2010
!Startup config saved at: Mon Sep 6 07:29:19 2010
 
version 5.0(2)N1(1)
port-profile type interface-vlan ppVlan
bandwidth 30000000
mtu 3000
description Sample port-profile for VLAN interfaces
port-profile type ethernet eth
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
state enabled
port-profile type port-channel ppPO
delay 5000000
load-interval counter 1 30
switchport mode trunk
description Sample port profile for Port Channel interface
state enabled
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
 
switch#
 

次に、スイッチのポート チャネル インターフェイス用に設定された ppPO というポート プロファイルのスタートアップ コンフィギュレーションを表示する例を示します。

switch# show startup-config port-profile ppPO
 
!Command: show startup-config port-profile ppPO
!Time: Mon Sep 6 07:34:31 2010
!Startup config saved at: Mon Sep 6 07:29:19 2010
 
version 5.0(2)N1(1)
port-profile type port-channel ppPO
delay 5000000
load-interval counter 1 30
switchport mode trunk
description Sample port profile for Port Channel interface
state enabled
 
 
switch#
 

次に、スイッチのイーサネット インターフェイス用に設定された ppEth というポート プロファイルのスタートアップ コンフィギュレーションを表示する例を示します。

switch# show startup-config port-profile ppEth
 
!Command: show startup-config port-profile ppEth
!Time: Mon Sep 6 07:35:44 2010
!Startup config saved at: Mon Sep 6 07:29:19 2010
 
version 5.0(2)N1(1)
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
 
switch#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

show running-config switch-profile

スイッチ プロファイルの実行コンフィギュレーション情報を表示します。

show startup-config switch-profile

スイッチ プロファイルのスタートアップ コンフィギュレーションを表示するには、 show startup-config switch-profile コマンドを使用します。

show startup-config switch-profile

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、ピアのスイッチ 1 に設定された s5010 というスイッチ プロファイルのスタートアップ コンフィギュレーションを表示する例を示します。

switch# show running-config switch-profile
switch-profile s5010
sync-peers destination 192.0.120.3
 
interface Ethernet101/1/35
switchport mode trunk
switchport trunk native vlan 300
switchport trunk allowed vlan 300-800
switch#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

switch-profile

スイッチ プロファイルを設定します。

show running-config switch-profile

スイッチ プロファイルの実行コンフィギュレーション情報を表示します。

show startup-config vpc

スタートアップ コンフィギュレーションの仮想ポート チャネル(vPC)の設定情報を表示するには、 show startup-config vpc コマンドを使用します。

show startup-config vpc [ all ]

 
構文の説明

all

(任意)すべての vPC のスタートアップ コンフィギュレーション情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、スタートアップ コンフィギュレーションの vPC 情報を表示する例を示します。

switch(config)# show startup-config vpc
version 4.1(2)
feature vpc
vpc domain 1
 
 
interface port-channel10
vpc peer-link
 
interface port-channel20
vpc 100
switch(config)#
 

 
関連コマンド

コマンド
説明

show vpc brief

vPC の情報を表示します。この機能がイネーブルになっていない状態でこのコマンドを入力すると、システムはエラーを表示します。

show switch-profile

スイッチに設定されたスイッチ プロファイルを表示するには、 show switch-profile コマンドを使用します。

show switch-profile

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、ピアのスイッチ 1 に設定されたスイッチ プロファイルを表示する例を示します。

switch# show switch-profile
----------------------------------------------------------
Profile-name Config-revision
----------------------------------------------------------
s5010 1
 
switch#
 

表 4 に、この出力で表示されるフィールドの説明を示します。

 

表 4 show switch-profile で表示されるフィールドの説明

フィールド
説明

Profile-name

スイッチ プロファイルの名前。

Config-revision

スイッチ プロファイル コンフィギュレーションのリビジョン。リビジョン番号は、ピア スイッチでコンフィギュレーションを同期するために使用されます。

詳細については、 commit コマンドを参照してください。

 
関連コマンド

コマンド
説明

commit

スイッチ プロファイル コンフィギュレーションをコミットします。

switch-profile

スイッチ プロファイルを設定します。

show switch-profile status

スイッチ プロファイルのステータスを表示します。

show switch-profile buffer

スイッチ プロファイル バッファを表示するには、 show switch-profile buffer コマンドを使用します。

show switch-profile sw-profile-name buffer

 
構文の説明

sw-profile-name

スイッチ プロファイルの名前。名前は、大文字と小文字が区別され、最大 64 文字の英数字を使用でき、アンダースコアおよびハイフンを含めることができます。名前にはスペースや特殊文字は使用できません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、s5010 というスイッチ プロファイルのバッファを表示する例を示します。

switch# show switch-profile s5010 buffer
----------------------------------------------------------
Seq-no Command
----------------------------------------------------------
1 interface ethernet 1/1
1.1 switchport mode trunk
1.2 speed 1000
2 interface port-channel 102
2.1 vpc 1
2.2 switchport mode trunk
 
switch#
 

表 5 に、この出力で表示されるフィールドの説明を示します。

 

表 5 show switch-profile buffer で表示されるフィールドの説明

フィールド
説明

Seq-no

スイッチ プロファイル バッファのコマンドのシーケンス番号または入力順序。

Command

スイッチ プロファイルの設定に使用されるコマンド。

 
関連コマンド

コマンド
説明

command(スイッチ プロファイル)

スイッチ プロファイルにコマンドを追加します。

import

スイッチ プロファイルにコマンドをインポートします。

switch-profile

スイッチ プロファイルを設定します。

show switch-profile status

スイッチ プロファイルのステータスを表示します。

show switch-profile peer

スイッチ プロファイル コンフィギュレーション内の宛先ピア スイッチに関する情報を表示するには、 show switch-profile peer コマンドを使用します。

show switch-profile sw-profile-name peer ip-address

 
構文の説明

sw-profile-name

スイッチ プロファイルの名前。名前は、大文字と小文字が区別され、最大 64 文字の英数字を使用でき、アンダースコアおよびハイフンを含めることができます。名前にはスペースや特殊文字は使用できません。

ip-address

A . B . C . D 形式の宛先ピア スイッチの IPv4 アドレス。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、ピアのスイッチ 1 の s5010 というスイッチ プロファイルに追加する IPv4 アドレス 192.168.120.3 の宛先ピアのスイッチに関する情報を表示する例を示します。

switch# show switch-profile s5010 peer 192.168.120.3
Peer-sync-status : Not yet merged. pending-merge:1 received_merge:0
Peer-status : Peer not reachable
Peer-error(s) :
switch#
 

次に、ピアのスイッチ 1 の s5010 というスイッチ プロファイルの IPv4 アドレス 192.168.120.3 の宛先ピアのスイッチに関する正常なコミット情報を表示する例を示します。

switch1# show switch-profile sp peer 192.168.120.3
Peer-sync-status : In Sync.
Peer-status : Commit Success
Peer-error(s) :
switch1#
 

表 6 に、この出力で表示されるフィールドの説明を示します。

 

表 6 show switch-profile peer で表示されるフィールドの説明

フィールド
説明

Peer-sync-status

ピア スイッチの同期されたコンフィギュレーションのステータス。次のいずれかとなります。

In Sync:両方のスイッチのコンフィギュレーションが同期された。

Not yet merged.pending-merge:1 received_merge:0:ローカル スイッチのコンフィギュレーションがピア スイッチにマージされていない。

Peer-status

コンフィギュレーション同期中のピア スイッチのステータス。到達可能か到達不能か、正常に検証またはコミットされたかどうか。

Peer-error(s)

ピア スイッチへの接続が失敗した理由。

 
関連コマンド

コマンド
説明

show switch-profile status

スイッチ プロファイルのステータスを表示します。

switch-profile

スイッチ プロファイルを設定します。

sync-peers destination

コンフィギュレーションを同期するピア スイッチを設定します。

show switch-profile session-history

スイッチ プロファイル コンフィギュレーションのセッション履歴を表示するには、 show switch-profile session-history コマンドを使用します。

show switch-profile sw-profile-name session-history

 
構文の説明

sw-profile-name

スイッチ プロファイルの名前。名前は、大文字と小文字が区別され、最大 64 文字の英数字を使用でき、アンダースコアおよびハイフンを含めることができます。名前にはスペースや特殊文字は使用できません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、ピアのスイッチ 1 の s5010 というスイッチ プロファイルのセッション履歴を表示する例を示します。

switch# show switch-profile s5010 session-history
 
Start-time: 959269 usecs after Fri Aug 13 06:16:29 2010
End-time: 961304 usecs after Fri Aug 13 06:16:29 2010
 
Profile-Revision: 1
Session-type: Initial-Exchange
Peer-triggered: No
Profile-status: -
 
Local information:
----------------
Status: -
Error(s):
 
Peer information:
----------------
IP-address: 192.168.120.3
Pending-merge: 1
Received-merge: 0
Sync-status: Not yet merged. pending-merge:1 received-merge:0
Status: Peer not reachable
Error(s):
 
Start-time: 794606 usecs after Fri Aug 13 06:16:40 2010
End-time: 796861 usecs after Fri Aug 13 06:16:40 2010
 
Profile-Revision: 1
Session-type: Peer-delete
Peer-triggered: No
Profile-status: Sync Success
 
Local information:
----------------
Status: Verify Success
Error(s):
 
switch#
 

表 7 に、この出力で表示されるフィールドの説明を示します。

 

表 7 show switch-profile session-history で表示されるフィールドの説明

フィールド
説明

Start-time

nn usecs after Day-of-week Month Date hh : mm : ss Year という形式で表されたコンフィギュレーション セッションの開始時刻。usecs はマイクロ秒を表します。

例:265561 usecs after Fri Aug 13 06:21:30 2010

End-time

nn usecs after Day-of-week Month Date hh : mm : ss Year という形式で表されたコンフィギュレーション セッションの終了時刻。usecs はマイクロ秒を表します。

Profile-Revision

スイッチ プロファイル コンフィギュレーションの変更回数。

Session-type

スイッチ プロファイル コンフィギュレーションに対して実行された操作(Initial-Exchange、Commit、Peer-Delete など)。

Peer-triggered

ピア到達可能通知の受信ステータス。

Profile-status

コンフィギュレーション同期のステータス。

Local information

ローカル スイッチ プロファイルに関する情報。

Status

ローカル スイッチでのコンフィギュレーション同期操作のステータス。

Error(s)

コンフィギュレーションの同期中にローカル スイッチ側で表示されるエラーの理由。

Peer information

ピア スイッチ プロファイルに関する情報。

IP-address

宛先ピア スイッチの IPv4 アドレス。

Pending-merge

ピア スイッチのコンフィギュレーションとマージするローカル スイッチの最新のコンフィギュレーション リビジョン番号。

Received-merge

ピア スイッチと同期するローカル スイッチから受信したコンフィギュレーション リビジョン。

Sync-status

ピア スイッチの同期されたコンフィギュレーションのステータス。次のいずれかとなります。

In Sync:ピア スイッチのコンフィギュレーションがローカル スイッチのコンフィギュレーションと同期された。

Not yet merged.pending-merge:1 received_merge:0:ローカル スイッチのコンフィギュレーションがピア スイッチにマージされていない。

Status

ピア スイッチのステータス(接続状況やコマンドの実行ステータスなど)。

Error(s)

ピア スイッチでのコンフィギュレーションの同期中に表示されるエラーの理由。

 
関連コマンド

コマンド
説明

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンを表示します。

show switch-profile status

スイッチ プロファイルのステータスを表示します。

switch-profile

スイッチ プロファイルを設定します。

show switch-profile status

スイッチ プロファイル コンフィギュレーションのステータスを表示するには、 show switch-profile コマンドを使用します。

show switch-profile sw-profile-name status

 
構文の説明

sw-profile-name

スイッチ プロファイルの名前。名前は、大文字と小文字が区別され、最大 64 文字の英数字を使用でき、アンダースコアおよびハイフンを含めることができます。名前にはスペースや特殊文字は使用できません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

次に、ピアのスイッチ 1 の s5010 というスイッチ プロファイルのステータスを表示する例を示します。

switch# show switch-profile s5010 status
 
Start-time: 794606 usecs after Fri Aug 13 06:16:40 2010
End-time: 796861 usecs after Fri Aug 13 06:16:40 2010
 
Profile-Revision: 3
Session-type: Commit
Peer-triggered: Yes
Profile-status: Sync Success
 
Local information:
----------------
Status: Commit Success
Error(s):
 
Peer information:
----------------
IP-address: 192.168.120.3
Sync-status: In Sync.
Status: Commit Success
Error(s):
 
switch#
 

表 8 に、この出力で表示されるフィールドの説明を示します。

 

表 8 show switch-profile status で表示されるフィールドの説明

フィールド
説明

Start-time

nn usecs after Day-of-week Month Date hh : mm : ss Year という形式で表されたコンフィギュレーション セッションの開始時刻。usecs はマイクロ秒を表します。

例:265561 usecs after Fri Aug 13 06:21:30 2010

End-time

nn usecs after Day-of-week Month Date hh : mm : ss Year という形式で表されたコンフィギュレーション セッションの終了時刻。usecs はマイクロ秒を表します。

Profile-Revision

スイッチ プロファイル コンフィギュレーションの変更回数。

Session-type

スイッチ プロファイル コンフィギュレーションに対して実行された操作(Commit や Peer-Delete など)。

Peer-triggered

ピア到達可能通知の受信ステータス。

Profile-status

コンフィギュレーション同期のステータス。

Local information

ローカル スイッチ プロファイルに関する情報。

Status

ローカル スイッチでのコンフィギュレーション同期操作のステータス。

Error(s)

コンフィギュレーションの同期中にローカル スイッチ側で表示されるエラーの理由。

Peer information

ピア スイッチ プロファイルに関する情報。

IP-address

宛先ピア スイッチの IPv4 アドレス。

Sync-status

ピア スイッチの同期されたコンフィギュレーションのステータス。

In Sync:ピア スイッチのコンフィギュレーションがローカル スイッチのコンフィギュレーションと同期された。

Not yet merged.pending-merge:1 received_merge:0:ローカル スイッチのコンフィギュレーションがピア スイッチにマージされていない。

Status

ピア スイッチでのコンフィギュレーション同期操作のステータス。

Error(s)

ピア スイッチでのコンフィギュレーションの同期中に表示されるエラーの理由。

 
関連コマンド

コマンド
説明

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンを表示します。

switch-profile

スイッチ プロファイルを設定します。

show tech-support vpc

仮想ポート チャネル(vPC)に関するトラブルシューティング情報を表示するには、 show tech-support vpc コマンドを使用します。

show tech-support vpc

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.2(1)N1(1)

このコマンドが追加されました。

次に、vPC トラブルシューティング情報を表示する例を示します。

switch# show tech-support vpc
`show version`
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2010, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 1.3.0
loader: version N/A
kickstart: version 4.2(1)N1(1) [build 4.2(1)N1(0.329)]
system: version 4.2(1)N1(1) [build 4.2(1)N1(0.329)]
power-seq: version v1.2
BIOS compile time: 09/08/09
kickstart image file is: bootflash:/n5000-uk9-kickstart.4.2.1.N1.latest.bin
kickstart compile time: 4/18/2010 8:00:00 [04/18/2010 15:03:44]
system image file is: bootflash:/n5000-uk9.4.2.1.N1.latest.bin
system compile time: 4/18/2010 8:00:00 [04/18/2010 16:08:18]
 
 
Hardware
cisco Nexus5020 Chassis ("40x10GE/Supervisor")
Intel(R) Celeron(R) M CPU with 2074284 kB of memory.
Processor Board ID JAF1413ADCS
 
Device name: d14-switch-2
bootflash: 1003520 kB
 
Kernel uptime is 0 day(s), 2 hour(s), 25 minute(s), 26 second(s)
 
Last reset at 414529 usecs after Mon Apr 19 05:59:19 2010
 
Reason: Disruptive upgrade
System version: 4.2(1u)N1(1u)
Service:
 
plugin
Core Plugin, Ethernet Plugin, Fc Plugin
`show module`
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ---------------------- ------------
1 40 40x10GE/Supervisor N5K-C5020P-BF-SUP active *
2 8 8x1/2/4G FC Module N5K-M1008 ok
3 6 6x10GE Ethernet Module N5K-M1600 ok
 
Mod Sw Hw World-Wide-Name(s) (WWN)
--- -------------- ------ --------------------------------------------------
1 4.2(1)N1(1) 1.3 --
2 4.2(1)N1(1) 0.200 20:41:00:05:9b:78:6e:40 to 20:48:00:05:9b:78:6e:40
3 4.2(1)N1(1) 0.100 --
 
Mod MAC-Address(es) Serial-Num
--- -------------------------------------- ----------
1 0005.9b78.6e48 to 0005.9b78.6e6f JAF1413ADCS
2 0005.9b78.6e70 to 0005.9b78.6e77 JAB1228016M
3 0005.9b78.6e78 to 0005.9b78.6e7f JAB12310214
`show vpc brief`
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 1000
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
vPC role : secondary
Number of vPCs configured : 150
Peer Gateway : Disabled
Dual-active excluded VLANs : -
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po1 up 1-330,335,338-447,1000-1023,2000-2018
 
vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
41 Po41 down* failed Consistency Check Not -
Performed
48 Po48 down* failed Consistency Check Not -
Performed
2000 Po24 down success success -
4000 Po12 down success success -
4001 Po5 down success success -
4096 Po3 down success success -
101376 Eth100/1/1 down* failed Consistency Check Not -
Performed
101377 Eth100/1/2 down* failed Consistency Check Not -
Performed
101378 Eth100/1/3 down* failed Consistency Check Not -
Performed
101379 Eth100/1/4 down* failed Consistency Check Not -
Performed
101380 Eth100/1/5 down* failed Consistency Check Not -
--More--
switch#
 

 
関連コマンド

コマンド
説明

show vpc brief

vPC の情報を表示します。この機能がイネーブルになっていない状態でこのコマンドを入力すると、システムはエラーを表示します。

show version

ソフトウェアおよびハードウェアのバージョン情報を表示するには、 show version コマンドを使用します。

show version

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

すべてのバージョン情報

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、Cisco NX-OS Release 4.2(1)N1(1) を実行するスイッチのバージョン情報を表示する例を示します。

switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2010, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 1.3.0 [last: ]
loader: version N/A
kickstart: version 4.2(1u)N1(1u) [build 4.2(1)N1(0.328)]
system: version 4.2(1u)N1(1u) [build 4.2(1)N1(0.328)]
power-seq: version v1.2
BIOS compile time: 09/08/09 [last: ]
kickstart image file is: bootflash:///n5000-uk9-kickstart.4.2.1.N1.latest.bin.
upg
kickstart compile time: 12/25/2020 12:00:00 [04/17/2010 15:06:29]
system image file is: bootflash:/n5000-uk9.4.2.1.N1.latest.bin.upg
system compile time: 12/25/2020 12:00:00 [04/17/2010 16:11:29]
 
 
Hardware
cisco Nexus5020 Chassis ("40x10GE/Supervisor")
Intel(R) Celeron(R) M CPU with 2074284 kB of memory.
Processor Board ID JAF1413ADCS
 
Device name: d14-switch-2
bootflash: 1003520 kB
 
Kernel uptime is 0 day(s), 1 hour(s), 2 minute(s), 41 second(s)
 
Last reset at 167864 usecs after Mon Apr 19 04:22:45 2010
 
Reason: Reset due to upgrade
System version: 4.2(1)N1(1)
Service:
 
plugin
Core Plugin, Ethernet Plugin, Fc Plugin
switch#
 

次に、Cisco NX-OS Release 5.0(2)N2(1) を実行するデバイスで実行中のキックスタート イメージおよびシステム イメージのバージョン情報を表示する例を示します。

switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2010, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 1.3.0
loader: version N/A
kickstart: version 5.0(2)N2(1) [build 5.0(2)N2(1)]
system: version 5.0(2)N2(1) [build 5.0(2)N2(1)]
power-seq: version v1.2
BIOS compile time: 09/08/09
kickstart image file is: bootflash:/sanity-kickstart
kickstart compile time: 12/6/2010 7:00:00 [12/06/2010 07:35:14]
system image file is: bootflash:/sanity-system
system compile time: 12/6/2010 7:00:00 [12/06/2010 08:56:45]
 
 
Hardware
cisco Nexus5010 Chassis ("20x10GE/Supervisor")
Intel(R) Celeron(R) M CPU with 2073416 kB of memory.
Processor Board ID JAF1228BTAS
 
Device name: BEND-2
bootflash: 1003520 kB
 
Kernel uptime is 0 day(s), 3 hour(s), 30 minute(s), 45 second(s)
 
Last reset
Reason: Unknown
System version:
Service:
 
plugin
Core Plugin, Ethernet Plugin, Fc Plugin
switch#
 

 
関連コマンド

コマンド
説明

show vpc brief

vPC の情報を表示します。この機能がイネーブルになっていない状態でこのコマンドを入力すると、システムはエラーを表示します。

show vpc

スイッチに設定されている仮想ポート チャネル(vPC)の詳細な情報を表示するには、 show vpc コマンドを使用します。

show vpc [ vpc-number ]

 
構文の説明

vpc-number

(任意)vPC 番号。指定できる範囲は 1 ~ 4096 です。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、vPC 情報を表示する例を示します。

switch# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 10
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
Type-2 consistency reason : Consistency Check Not Performed
vPC role : secondary
Number of vPCs configured : 1
Peer Gateway : Disabled
Dual-active excluded VLANs : -
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po4000 up 1,3001-3500
 
vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
10 Po10 up success success 3001-3200
 
switch#
 

次に、特定の vPC 情報を表示する例を示します。

switch# show vpc 10
 
 
vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
10 Po10 up success success 3001-3200
 
switch#
 

 
関連コマンド

コマンド
説明

show vpc brief

vPC 情報の要約を表示します。

vpc

スイッチに vPC 機能を設定します。

show vpc brief

仮想ポート チャネル(vPC)に関する要約情報を表示するには、 show vpc brief コマンドを使用します。

show vpc brief [ vpc number ]

 
構文の説明

vpc number

(任意)指定した vPC の要約情報を表示します。指定できる範囲は 1 ~ 4096 です。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

show vpc brief コマンドは、vPC ドメイン ID、ピアリンク ステータス、キープアライブ メッセージ ステータス、設定が一致しているかどうか、ピア リンクが形成されたかまたは形成に失敗したかどうかを表示します。

vPC 機能がイネーブルになっていないと、このコマンドは使用できません。vPC をイネーブルにするための情報は、 feature vpc コマンドを参照してください。

vPC ドメイン コンフィギュレーション モードでの単一モジュールにおける vPC の実行に対し、トラッキング対象オブジェクトを設定してある場合は、トラック オブジェクトを表示できます。

次に、Cisco NX-OS Release 4.1(3)N1(1) を実行するスイッチの vPC に関する要約情報を表示する例を示します。

switch(config)# show vpc brief
 
Legend:
(*) - local vpc is down, forwarding via vPC peer-link
 
vPC domain id : 10
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
vPC role : primary
Number of vPC configured : 1
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po10 up 1-100
 
vPC status
----------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
-- ---- ------ ----------- -------------------------- ------------
20 Po20 up success success 1-100
switch(config)#
 

次に、vPC に関する要約情報を表示する例を示します。この例では、ポート チャネルで整合性検査が失敗し、デバイスが失敗の理由を表示します。

switch(config)# show vpc brief
 
Legend:
(*) - local vpc is down, forwarding via vPC peer-link
 
vPC domain id : 10
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: failed
Configuration consistency reason: vPC type-1 configuration incompatible - STP interface port type inconsistent
vPC role : secondary
Number of vPC configured : 1
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po10 up 1-100
 
vPC status
----------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
-- ---- ------ ----------- -------------------------- ------------
20 Po20 up failed vPC type-1 configuration -
incompatible - STP
interface port type
inconsistent
switch(config)#
 

次に、vPC 内のトラッキング対象オブジェクトに関する情報を表示する例を示します。

switch(config)# show vpc brief
 
Legend:
(*) - local vpc is down, forwarding via vPC peer-link
 
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
vPC role : secondary
Number of vPC configured : 3
Track object : 12
 
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po10 up 1-100
switch(config)#
 

次に、Cisco NX-OS Release 5.0(2)N2(1) を実行するスイッチでグレースフル タイプ 1 整合性の設定を含めて vPC の設定を表示する例を示します。

switch# show vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 100
Peer status : peer link is down
vPC keep-alive status : peer is alive, but domain IDs do not match
Configuration consistency status: success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 1
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 down -
 
vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1 Po1 down success success -
 
switch#
 

 
関連コマンド

コマンド
説明

feature vpc

デバイスで vPC をイネーブルにします。

show port channel summary

ポート チャネルの情報を表示します。

vpc

vPC ドメインとピアを設定します。

show vpc consistency-parameters

仮想ポート チャネル(vPC)インターフェイス全体で互換性が必要なパラメータの一貫性を表示するには、 show vpc consistency-parameters コマンドを使用します。

show vpc consistency-parameters { global | interface port-channel channel-number | vlans | vpc number }

 
構文の説明

global

両端の vPC ピア リンクの タイプ 1 グローバル パラメータのコンフィギュレーションをすべて表示します。

interface port-channel channel-number

両端の vPC ピア リンクの タイプ 1 インターフェイス パラメータのコンフィギュレーションをすべて表示します。

vlans

指定 vPC の vPC ピア リンクの両端 すべての VLAN の設定 を、互換性のない VLAN を含めて表示します。

vpc number

指定した vPC の両端の vPC ピア リンクの タイプ 1 インターフェイス パラメータのコンフィギュレーションをすべて表示します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

5.0(2)N2(1)

vlans キーワードが追加されました。

 
使用上のガイドライン

show vpc consistency-parameters コマンドは、両端の vPC ピア リンクの vPC タイプ 1 パラメータのコンフィギュレーションをすべて表示します。


) すべてのタイプ 1 コンフィギュレーションは、vPC ピア リンクの両端で同じである必要があります。同じでないと、リンクが確立されません。


vPC タイプ 1 コンフィギュレーション パラメータは次のとおりです。

ポート チャネル モード:on、off、active

チャネルごとのリンク速度

チャネルごとのデュプレックス モード

チャネルごとのトランク モード

Native VLAN

トランク上の許可 VLAN

Native VLAN トラフィックのタギング

Spanning Tree Protocol(STP; スパニング ツリー プロトコル)モード

多重スパニング ツリーの STP 領域コンフィギュレーション

イネーブルまたはディセーブル状態(VLAN ごとに同一)

STP グローバル設定

Bridge Assurance 設定

ポート タイプ設定:すべての vPC ピア リンク ポートをネットワーク ポートとして設定することを推奨します。

ループ ガード設定

STP インターフェイス設定:

ポート タイプ設定

ループ ガード

ルート ガード

Maximum Transmission Unit(MTU; 最大伝送ユニット)

許可 VLAN ビット設定

vPC 機能がイネーブルになっていないと、このコマンドは使用できません。vPC をイネーブルにするための情報は、 feature vpc を参照してください。

次に、Cisco NX-OS Release 4.1(3)N1(1) を実行するスイッチの vPC のグローバル整合性パラメータを表示する例を示します。

switch(config)# show vpc consistency-parameters global
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
QoS 1 ([], [3], [0], [1-2], ([], [3], [0], [1-2],
[4-5], [6]) [4-5], [6])
Network QoS (MTU) 1 (1538, 2240, 5038, (1538, 2240, 5038,
4038, 9216, 9216) 4038, 9216, 9216)
Network Qos (Pause) 1 (F, T, F, F, F, F) (F, T, F, F, F, F)
Input Queuing (Bandwidth) 1 (5, 10, 20, 0, 20, 40) (5, 10, 20, 0, 20, 40)
Input Queuing (Absolute 1 (F, F, F, T, F, F) (F, F, F, T, F, F)
Priority)
Output Queuing (Bandwidth) 1 (5, 10, 20, 0, 20, 40) (5, 10, 20, 0, 20, 40)
Output Queuing (Absolute 1 (F, F, F, T, F, F) (F, F, F, T, F, F)
Priority)
STP Mode 1 Rapid-PVST Rapid-PVST
STP Disabled 1 None None
STP MST Region Name 1 "" ""
STP MST Region Revision 1 0 0
STP MST Region Instance to 1
VLAN Mapping
STP Loopguard 1 Disabled Disabled
STP Bridge Assurance 1 Enabled Enabled
STP Port Type, Edge 1 Normal, Disabled, Normal, Disabled,
BPDUFilter, Edge BPDUGuard Disabled Disabled
STP MST Simulate PVST 1 Enabled Enabled
Allowed VLANs - 1-330,335,338-450,1000 1-330,333-447,1000-102
-1023,2000-2023 8,2000-2018
Local suspended VLANs - 331-334,336-337,448-45 -
0,2019-2023
switch(config)#
 

次に、Cisco NX-OS Release 5.0(2)N2(1) を実行するスイッチの vPC のグローバル整合性パラメータを表示する例を示します。

switch# show vpc consistency-parameters global
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
QoS 2 ([], [3], [], [], [], ([], [3], [], [], [],
[]) [])
Network QoS (MTU) 2 (1538, 2240, 0, 0, 0, (1538, 2240, 0, 0, 0,
0) 0)
Network Qos (Pause) 2 (F, T, F, F, F, F) (1538, 2240, 0, 0, 0,
0)
Input Queuing (Bandwidth) 2 (50, 50, 0, 0, 0, 0) (50, 50, 0, 0, 0, 0)
Input Queuing (Absolute 2 (F, F, F, F, F, F) (50, 50, 0, 0, 0, 0)
Priority)
Output Queuing (Bandwidth) 2 (50, 50, 0, 0, 0, 0) (50, 50, 0, 0, 0, 0)
Output Queuing (Absolute 2 (F, F, F, F, F, F) (50, 50, 0, 0, 0, 0)
Priority)
STP Mode 1 Rapid-PVST Rapid-PVST
STP Disabled 1 None None
STP MST Region Name 1 "" ""
STP MST Region Revision 1 0 0
STP MST Region Instance to 1
VLAN Mapping
STP Loopguard 1 Disabled Disabled
STP Bridge Assurance 1 Enabled Enabled
STP Port Type, Edge 1 Normal, Disabled, Normal, Disabled,
BPDUFilter, Edge BPDUGuard Disabled Disabled
STP MST Simulate PVST 1 Enabled Enabled
VTP domain 2 cisco cisco
VTP version 2 2 2
VTP mode 2 Server Server
VTP password 2
VTP pruning status 2 Disabled Disabled
VTP trunk status 2 Enabled Enabled
Pruning eligible vlans 2 2-1001 2-1001
Allowed VLANs - 1-10 1-2
Local suspended VLANs - 3-10 -
 
switch#
 

次に、Cisco NX-OS Release 4.1(3)N1(1) を実行するスイッチの特定のポート チャネルの vPC の整合性パラメータを表示する例を示します。

switch(config)# show vpc consistency-parameters interface port-channel 20
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ------------------------ --------------------------
STP Port Type 1 Default Default
STP Port 1 None None
Guard
mode 1 on on
Speed 1 10 Gb/s 10 Gb/s
Duplex 1 full full
Port Mode 1 trunk trunk
Native Vlan 1 1 1
MTU 1 1500 1500
Allowed VLAN - 1-100 1-100
bitset
switch(config)#
 

次に、Cisco NX-OS Release 5.0(2)N2(1) を実行するスイッチの特定のポート チャネルの vPC の整合性パラメータを表示する例を示します。

switch# show vpc consistency-parameters interface port-channel 1
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
Shut Lan 1 No No
STP Port Type 1 Default Default
STP Port Guard 1 None None
STP MST Simulate PVST 1 Default Default
mode 1 on on
Speed 1 10 Gb/s 10 Gb/s
Duplex 1 full full
Port Mode 1 trunk trunk
Native Vlan 1 1 1
MTU 1 1500 1500
VTP trunk status 2 Enabled Enabled
Pruning eligible vlans 2 2-1001 2-1001
Allowed VLANs - 1-3967,4048-4093 1-3967,4048-4093
Local suspended VLANs - 3-10 -
switch#
 

次に、Cisco NX-OS Release 4.1(3)N1(1) を実行するスイッチの指定 vPC の vPC の整合性パラメータを表示する例を示します。

switch# show vpc consistency-parameters vpc 1
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
Shut Lan 1 No No
STP Port Type 1 Default Default
STP Port Guard 1 None None
STP MST Simulate PVST 1 Default Default
lag-id 1 [(7f9b, [(7f9b,
0-23-4-ee-be-64, 8001, 0-23-4-ee-be-64, 8001,
0, 0), (8000, 0, 0), (8000,
0-5-9b-23-40-3c, 0, 0, 0-5-9b-23-40-3c, 0, 0,
0)] 0)]
mode 1 active active
Speed 1 1000 Mb/s 10 Gb/s
Duplex 1 full full
Port Mode 1 access access
MTU 1 1500 1500
Allowed VLANs - 1 1
Local suspended VLANs - - -
switch#
 

次に、Cisco NX-OS Release 4.1(3)N1(1) を実行するスイッチの VLAN の vPC の整合性パラメータを表示する例を示します。

switch# show vpc consistency-parameters vlans
 
Name Type Reason Code Pass Vlans
 
------------- ---- ---------------------- -----------------------
STP Mode 1 success 0-4095
STP Disabled 1 success 0-4095
STP MST Region Name 1 success 0-4095
STP MST Region Revision 1 success 0-4095
STP MST Region Instance to 1 success 0-4095
VLAN Mapping
STP Loopguard 1 success 0-4095
STP Bridge Assurance 1 success 0-4095
STP Port Type, Edge 1 success 0-4095
BPDUFilter, Edge BPDUGuard
STP MST Simulate PVST 1 success 0-4095
Pass Vlans - 0-4095
switch#
 

 
関連コマンド

コマンド
説明

show vpc brief

vPC の情報を表示します。この機能がイネーブルになっていない状態でこのコマンドを入力すると、システムはエラーを表示します。

show port channel summary

ポート チャネルの情報を表示します。

vpc

vPC ドメインとピアを設定します。

show vpc orphan-ports

仮想ポート チャネル(vPC)の一部ではないが、共通の VLAN を持っているポートを表示するには、 show vpc orphan-ports コマンドを使用します。

show vpc orphan-ports

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

show vpc orphan-ports コマンドは、vPC の一部ではないが、vPC の一部であるポートと同じ VLAN を共有しているポートを表示します。

vPC 機能がイネーブルになっていないと、このコマンドは使用できません。vPC をイネーブルにするための情報は、 feature vpc コマンドを参照してください。

次に、vPC の孤立ポートを表示する例を示します。

switch(config)# show vpc orphan-ports
 
Note:
--------::Going through port database. Please be patient.::--------
 
VLAN Orphan Ports
------- -------------------------
1 Po600
2 Po600
3 Po600
4 Po600
5 Po600
6 Po600
7 Po600
8 Po600
9 Po600
10 Po600
11 Po600
12 Po600
13 Po600
14 Po600
--More--
switch(config)#
 

 
関連コマンド

コマンド
説明

feature vpc

デバイスで vPC をイネーブルにします。

vpc orphan-port suspend

非 vPC ポートを一時停止します。

show vpc brief

vPC に関する要約情報を表示します。

show vpc peer-keepalive

仮想ポート チャネル(vPC)のピア キープアライブ メッセージの宛先 IP とメッセージのステータスを表示するには、 show vpc peer-keepalive コマンドを使用します。

show vpc peer-keepalive

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

show vpc peer-keepalive コマンドは、vPC のピア キープアライブ メッセージの宛先 IP を表示します。また、このコマンドは送受信ステータスと、ピアからの最終の更新を秒単位およびミリ秒単位で表示します。


) vPC ピア キープアライブ メッセージを送受信するために、ピア デバイスに個別の VRF を作成することを推奨します。ピア リンク自体を使用して vPC ピアキープアライブ メッセージを送信しないでください。


vPC 機能がイネーブルになっていないと、このコマンドは使用できません。vPC をイネーブルにするための情報は、 feature vpc コマンドを参照してください。

次に、ピアキープアライブ メッセージの情報を表示する例を示します。

switch(config)# show vpc peer-keepalive
 
vPC keep-alive status : peer is alive
--Send status : Success
--Last send at : 2008.05.17 18:23:53 986 ms
--Sent on interface : Eth7/16
--Receive status : Success
--Last receive at : 2008.05.17 18:23:54 99 ms
--Received on interface : Eth7/16
--Last update from peer : (0) seconds, (486) msec
 
vPC Keep-alive parameters
--Destination : 192.168.145.213
--Keepalive interval : 1000 msec
--Keepalive timeout : 5 seconds
--Keepalive hold timeout : 3 seconds
--Keepalive vrf : pkal
--Keepalive udp port : 3200
--Keepalive tos : 192
switch(config)#
 

 
関連コマンド

コマンド
説明

show vpc brief

vPC の情報を表示します。この機能がイネーブルになっていない状態でこのコマンドを入力すると、システムはエラーを表示します。

show vpc role

ピア デバイスの仮想ポート チャネル(vPC)ロールに関する情報を表示するには、 show vpc role コマンドを使用します。

show vpc role

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

show vpc role コマンドは、vPC ステータスに関する次の情報を表示します。

ピアの隣接状態

vPC ロール

vPC MAC アドレス

vPC システム プライオリティ

作業対象のデバイスの MAC アドレス

作業対象のデバイスのシステム プライオリティ

vPC 機能がイネーブルになっていないと、このコマンドは使用できません。vPC をイネーブルにするための情報は、 feature vpc コマンドを参照してください。

次に、作業対象のデバイスの vPC ロール情報を表示する例を示します。

switch(config)# show vpc role
 
Primary:
 
vPC Role status
----------------------------------------------------
vPC role : primary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:01
vPC system-priority : 32667
vPC local system-mac : 00:22:55:79:ea:c1
vPC local role-priority : 32667
 
 
Secondary:
 
vPC Role status
----------------------------------------------------
vPC role : secondary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:01
vPC system-priority : 32667
vPC local system-mac : 00:22:55:79:de:41
vPC local role-priority : 32667
switch(config)#
 

プライマリ vPC ピア デバイスをリロードすると、セカンダリ vPC ピア デバイスはプライマリ デバイスのロールを担います。次に、新しいプライマリ デバイス上で vPC ロールが表示される例を示します。

switch(config)# show vpc role
 
vPC Role status
----------------------------------------------------
vPC role : secondary, operational primary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:64
vPC system-priority : 32667
vPC local system-mac : 00:22:55:79:de:41
vPC local role-priority : 32667
 
switch(config)#
 

 
関連コマンド

コマンド
説明

role

vPC デバイスにプライマリまたはセカンダリのロールを割り当てます。

show vpc brief

vPC の情報を表示します。この機能がイネーブルになっていない状態でこのコマンドを入力すると、システムはエラーを表示します。

show port channel summary

ポート チャネルの情報を表示します。

show vpc statistics

仮想ポート チャネル(vPC)の統計情報を表示するには、 show vpc statistics コマンドを使用します。

show vpc statistics { peer-keepalive | peer-link | vpc number }

 
構文の説明

peer-keepalive

ピアキープアライブ メッセージに関する統計情報を表示します。

peer-link

ピア リンクに関する統計情報を表示します。

vpc number

指定した vPC に関する統計情報を表示します。指定できる範囲は 1 ~ 4096 です。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

peer-link パラメータは、vPC ピアリンク ポート チャネルの show interface port-channel channel number コマンドと同じ情報を表示します。

vpc number パラメータは、指定した vPC ポート チャネルの show interface port-channel channel number コマンドと同じ情報を表示します。

vPC 機能がイネーブルになっていないと、このコマンドは使用できません。vPC をイネーブルにするための情報は、 feature vpc コマンドを参照してください。

次に、ピアキープアライブ メッセージに関する統計情報を表示する例を示します。

switch# show vpc statistics peer-keepalive
 
vPC keep-alive status : peer is alive
 
VPC keep-alive statistics
----------------------------------------------------
peer-keepalive tx count: 1036
peer-keepalive rx count: 1028
average interval for peer rx: 995
Count of peer state changes: 1
switch(config)#
 

 
関連コマンド

コマンド
説明

show vpc brief

vPC の情報を表示します。この機能がイネーブルになっていない状態でこのコマンドを入力すると、システムはエラーを表示します。

show port channel summary

ポート チャネルの情報を表示します。