Cisco Nexus 5000 Series NX-OS Virtual Port Channel コマンド リファレンス Cisco NX-OS Release 4.x、5.x
C コマンド
C コマンド
発行日;2012/06/22 | 英語版ドキュメント(2012/01/02 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 902KB) | フィードバック

目次

C コマンド

command(ポート プロファイル)

command(スイッチ プロファイル)

commit(スイッチ プロファイル)

config sync

copy running-config startup-config

C コマンド

この章では、C で始まる Cisco NX-OS の仮想ポート チャネル(vPC)コマンドについて説明します。

command(ポート プロファイル)

ポート プロファイルにコマンドを追加したり変更したりするには、ポート プロファイルでサポートされているコマンドを使用します。スイッチ プロファイルからコマンドを削除するには、サポートされているコマンドの no 形式を使用します。

command argument

no command argument

 
構文の説明

command

ポート プロファイルでサポートされているコマンド。

argument

サポートされているコマンドの引数。

 
コマンド デフォルト

なし

 
コマンド モード

ポート プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

イーサネット、VLAN、または EtherChannel の各インターフェイスにインターフェイス コマンドを(バッチ モードで)設定するには、このコマンドを使用します。

ポート プロファイルに含まれるコマンドは、そのポート プロファイルの外部で設定できます。ポート プロファイルの新しいコンフィギュレーションがポート プロファイル外部のコンフィギュレーションと競合する場合は、コンフィギュレーション端末モードでインターフェイスに設定されたコマンドのプライオリティがポート プロファイルのコマンドよりも高くなります。ポート プロファイルを割り当てた後にインターフェイス設定を変更し、その設定がポート プロファイルの設定と競合する場合は、インターフェイスの設定が優先されます。

このコマンドの no 形式を使用すると、ポート プロファイルからコマンドを削除できます。ポート プロファイルからコマンドを削除すると、対応するコマンドが、ポート プロファイルに割り当てられたインターフェイスから削除されます。

次に、イーサネット インターフェイス用に設定された ppEth という名前のポート プロファイルにインターフェイス コマンドを追加する例を示します。

switch# configure terminal
switch(config)# port-profile ppEth
switch(config-port-prof)# switchport mode trunk
switch(config-port-prof)# switchport trunk allowed vlan 300-400
switch(config-port-prof)# flowcontrol receive on
switch(config-port-prof)# speed 10000
switch(config-port-prof)#
 

次に、イーサネット インターフェイス用に設定された ppEth という名前のポート プロファイルからコマンドを削除する例を示します。

switch# configure terminal
switch(config)# port-profile ppEth
switch(config-port-prof)# switchport mode trunk
switch(config-port-prof)# switchport trunk allowed vlan 300-400
switch(config-port-prof)# flowcontrol receive on
switch(config-port-prof)# no speed 10000
switch(config-port-prof)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

inherit

インターフェイスにポート プロファイルをアタッチします。

show port-profile name profile_name

特定のポート プロファイルに関する情報を表示します。

show running-config port-profile

ポート プロファイルの実行コンフィギュレーションを表示します。

state enabled

ポート プロファイルをイネーブルにします。

command(スイッチ プロファイル)

スイッチ プロファイルにコマンドを追加したり変更したりするには、スイッチ プロファイルでサポートされているコマンドを使用します。スイッチ プロファイルからコマンドを削除するには、サポートされているコマンドの no 形式を使用します。

command argument

no command argument

 
構文の説明

command

スイッチ プロファイルでサポートされているコマンド。

argument

サポートされるコマンドの引数。

 
コマンド デフォルト

なし

 
コマンド モード

スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

各ピアのスイッチ プロファイルを設定した後で、スイッチ プロファイルにインターフェイス コンフィギュレーション、Quality of Service(QoS)、および仮想ポート チャネル(vPC)コマンドを追加できます。


) Cisco NX-OS の本リリースでは、FCoE コマンドはスイッチ プロファイルでサポートされません。


追加または変更するコマンドは、 commit コマンドを使用してスイッチ コンフィギュレーションに適用するまでスイッチ プロファイル バッファに保存されます。スイッチ コンフィギュレーションに適用する前に、バッファにあるコマンドを( verify コマンドを使用して)確認できます。コンフィギュレーションをコミットした後、続けてスイッチ プロファイル コンフィギュレーションにコマンドを追加することも、コマンドを削除することもできます。コンフィギュレーションを再度コミットすると、更新されたコマンドが検証後にスイッチ プロファイル コンフィギュレーションに適用され、コンフィギュレーションがピア間で同期されます。

コマンドは、バッファリングされた順序で実行されます。 buffer-delete コマンドを使用してスイッチ プロファイル バッファからコマンドを削除したり、 buffer-move コマンドを使用してスイッチ プロファイル バッファ内でのコマンドの順序を変更したりできます。

次に、ピアのスイッチ 1 の s5010 というスイッチ プロファイルにインターフェイス コマンドを追加する例を示します。

ピア A

switch# config sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
switch(config-sync-sp)# interface ethernet 1/1
switch(config-sync-sp-if)# switchport mode trunk
switch(config-sync-sp-if)# speed 1000
switch(config-sync-sp-if)# exit
switch(config-sync-sp)#
 

次に、ピアのスイッチ 2 の s5010 というスイッチ プロファイルにコマンドを追加する例を示します。

ピア B

switch# config sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# interface ethernet 1/1
switch(config-sync-sp-if)# switchport mode trunk
switch(config-sync-sp-if)# speed 1000
switch(config-sync-sp-if)# interface port-channel 102
switch(config-sync-sp-if)# vpc 1
switch(config-sync-sp-if)# switchport mode trunk
switch(config-sync-sp-if)# exit
switch(config-sync-sp)#
 

次に、ピアのスイッチ 2 の s5010 というスイッチ プロファイルからコマンドを削除する例を示します。

ピア B

switch# config sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# interface ethernet 1/1
switch(config-sync-sp-if)# switchport mode trunk
switch(config-sync-sp-if)# speed 1000
switch(config-sync-sp-if)# interface port-channel 102
switch(config-sync-sp-if)# vpc 1
switch(config-sync-sp-if)# no switchport mode trunk <-- command removed from configuration
switch(config-sync-sp-if)# exit
switch(config-sync-sp)#
 

 
関連コマンド

コマンド
説明

buffer-delete

スイッチ プロファイル バッファからコマンドを削除します。

buffer-move

スイッチ プロファイル バッファのコマンドの順序を修正します。

commit

スイッチ コンフィギュレーションにコマンドを適用します。

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

show switch-profile buffer

スイッチ プロファイル バッファに関する情報を表示します。

show switch-profile status

スイッチ プロファイルのステータスを表示します。

verify

スイッチ プロファイルのコマンドを検証します。

commit(スイッチ プロファイル)

スイッチ プロファイル バッファ内のコマンドをコミットし、コンフィギュレーションをスイッチに保存するには、 commit コマンドを使用します。

commit

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、スイッチ プロファイル コンフィギュレーションを保存し、コンフィギュレーションをピア スイッチと同期するために使用します。コミットに失敗した場合は、手動でコンフィギュレーション コマンドを修正し、再度コンフィギュレーションをコミットする必要があります。

コンフィギュレーションをコミットする際には、コンフィギュレーションがピア スイッチ全体に適用されるように、次の処理が実行されます。

ピア スイッチが到達可能な場合は両方のスイッチでコマンドの相互排除チェックを実行し、ピア スイッチが到達可能でない場合はローカル スイッチでのみ相互排除チェックを実行します。


) あるスイッチ プロファイルに含まれるコマンドをそのスイッチ プロファイルの外部やピア スイッチで設定することはできません。スイッチ プロファイルの新しいコンフィギュレーションがそのスイッチ プロファイルの外部または別のスイッチ プロファイル内の設定と競合していないことを確認します。この機能を相互排除チェック(mutex)と呼びます。


ロールバック インフラストラクチャでチェックポイントを作成します。

ローカル スイッチおよびピア スイッチのコンフィギュレーションを適用します。

いずれかのスイッチでコミットが失敗した場合は、両方のスイッチでコンフィギュレーションがロール バックされます。

チェックポイントを削除します。

コミット中に、次のようにスイッチ プロファイルのコンフィギュレーション リビジョンを使用して、ピア スイッチのコンフィギュレーションの同期を判断します。

ローカル スイッチ プロファイルのリビジョン番号がピアと同じであり、同期の必要があるローカルに適用されるコンフィギュレーションがある場合は、コンフィギュレーションがピア内で同期されます。

リビジョン番号が両方のスイッチで同じであり、ピアと同期する必要があるローカルに適用するコンフィギュレーションがない場合は、同期セッションはただちに終了します。

ローカル スイッチのリビジョン番号がピア スイッチのリビジョン番号と一致しない場合は、ピア内でコンフィギュレーションが同期されます。

スイッチ プロファイル コンフィギュレーションをコミットした後で、続けてスイッチ プロファイルに対するコマンドの追加または削除を行うことができます。コンフィギュレーションを再度コミットすると、更新されたコマンドだけが確認に使用され、次にコンフィギュレーションがスイッチ プロファイルに適用されて、ピア スイッチと同期されます。

次に、ピアのスイッチ 1 の s5010 というスイッチ プロファイルに対する変更を適用する例を示します。

switch# config sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# interface ethernet 1/1
switch(config-sync-sp-if)# switchport mode trunk
switch(config-sync-sp-if)# speed 1000
switch(config-sync-sp-if)# exit
switch(config-sync-sp)# commit
switch(config-sync-sp)#

 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

show switch-profile buffer

スイッチ プロファイル バッファに関する情報を表示します。

show running-config switch-profile

スイッチ プロファイルの実行コンフィギュレーションを表示します。

verify

スイッチ プロファイルのコマンドを検証します。

config sync

コンフィギュレーション同期モードを開始してスイッチ プロファイルを作成するには、 config sync コマンドを使用します。

config sync

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

同期させるローカル スイッチとピア スイッチで config sync コマンドを使用します。

スイッチのコンフィギュレーションを同期する前に、次のことを行う必要があります。

ピア スイッチを特定します。

ピア スイッチの管理インターフェイス(mgmt0)に対して、IPv4 による Cisco Fabric Services(CFS)配信をイネーブルにします。

コンフィギュレーション同期機能を使用すると、1 台のスイッチ上に作成したコンフィギュレーションがピア スイッチで同期され、使用可能になります。

config sync コマンドを使用した後で、ピア スイッチでスイッチ プロファイルを作成または設定できます。

次に、ピア構成のスイッチで IPv4 による CFS をイネーブルにし、そのスイッチでコンフィギュレーション同期モードを開始する例を示します。

switch# configure terminal
switch(config)# cfs ipv4 distribute
switch(config)# exit
switch# config sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)#
 

 
関連コマンド

コマンド
説明

cfs ipv4 distribute

スイッチで IPv4 による CFS 配信をイネーブルにします。

switch-profile

スイッチ プロファイルを作成または設定します。

copy running-config startup-config

現在のすべての設定情報をリブート後にも使用可能になるよう、実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルに保存するには、 copy running-config startup-config コマンドを使用します。

copy running-config startup-config

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

 
使用上のガイドライン

変更した設定を表示するには、 show startup-config コマンドを使用します。


copy running-config startup-config コマンドを入力した後は、実行中の設定と起動時の設定が同じになります。


次に、実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルに保存する例を示します。

switch# copy running-config startup-config
[########################################] 100%
switch#
 

 
関連コマンド

コマンド
説明

show running-config

現在の実行コンフィギュレーションを表示します。

show startup-config

スタートアップ コンフィギュレーション ファイルを表示します。