Cisco Nexus 5000 シリーズ NX-OS コマンド リファレンス Cisco NX-OS Release 4.x、5.x
Quality of Service(QoS)コマンド
Quality of Service(QoS)コマンド
発行日;2012/03/14 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

Quality of Service(QoS)コマンド

bandwidth(QoS)

class(QoS タイプのポリシー マップ)

class type network-qos

class type queuing

class-map

class-map type network-qos

class-map type queuing

description

flowcontrol

hardware multicast disable-slow-port-pruning

hardware unicast voq-limit

match access-group

match cos

match dscp

match ip rtp

match precedence

match protocol

match qos-group

mtu

multicast-optimize

pause no-drop

pause no-drop buffer-size

policy-map type network-qos

policy-map(QoS タイプ)

policy-map type queuing

priority

priority-flow-control

queue-limit

service-policy

service-policy(システム QoS)

set cos(ネットワーク QoS タイプのポリシー マップ)

set dscp

set precedence

set qos-group

show class-map type network-qos

show class-map type qos

show class-map type queuing

show interface flowcontrol

show interface priority-flow-control

show interface untagged-cos

show policy-map

show policy-map interface

show policy-map interface brief

show policy-map system

show queuing interface

show running-config ipqos

show startup-config ipqos

show wrr-queue cos-map

system jumbomtu

system qos

untagged cos

wrr-queue cos-map

Quality of Service(QoS)コマンド

この章では、Cisco Nexus 5000 シリーズ スイッチで使用できる Cisco NX-OS Quality of Service(QoS)コマンドについて説明します。

bandwidth(QoS)

キューにインターフェイス帯域幅の最小割合を割り当て、入力キューと出力キューの両方に帯域幅を設定するには、 bandwidth コマンドを使用します。帯域幅設定を削除するには、このコマンドの no 形式を使用します。

bandwidth percent percent

no bandwidth percent percent

 
構文の説明

percent

基盤となるリンクの残存帯域幅の割り当て率を指定します。

percent

パーセント値。範囲は 0 ~ 100 です。

 
コマンド デフォルト

デフォルトの帯域幅率は kbps です。

 
コマンド モード

キューイング タイプのポリシー クラス マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、特定のキューに対して帯域幅を割り当てる例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing 1p7q4t-out-pq1
switch(config-pmap-c-que)# bandwidth percent 25
switch(config-pmap-c-que)#
 

次に、特定のキューに割り当てた帯域幅を取り消す例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing 1p7q4t-out-pq1
switch(config-pmap-c-que)# no bandwidth percent 25
switch(config-pmap-c-que)#
 

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

show policy-map

ポリシー マップを表示します。

class(QoS タイプのポリシー マップ)

ポリシー マップで既存の QoS クラス マップを参照し、クラス モードを開始するには、 class コマンドを使用します。ポリシー マップからクラスを削除するには、このコマンドの no 形式を使用します。

class [ type qos ] class-map-name

no class class-map-name

 
構文の説明

type qos

(任意)コンポーネント タイプ(このクラスでは QoS)を指定します。デフォルトのタイプは QoS です。

class-map-name

クラス マップを参照します。クラス マップ名には最大 40 文字を使用できます。名前は大文字と小文字が区別され、英字、数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

トラフィック タイプと最初に一致したクラスに基づいて、ポリシーのアクションが実行されます。

デフォルトでは、QoS タイプの class-default クラスが、システムの QoS タイプの各ポリシー マップの下に作成され、QoS グループ 0 にマッピングされます。このマッピングは変更できません。

QoS タイプの class-default は削除できません。class-default クラスを削除しようとすると、スイッチはエラー メッセージを返します。

次に、ポリシー マップで最後の QoS クラス マップを参照する例を示します。

switch(config)# policy-map my_policy1
switch(config-pmap-qos)# class traffic_class2
switch(config-pmap-c-qos)#
 

次に、ポリシー マップのクラス マップ参照を削除する例を示します。

switch(config)# policy-map my_policy1
switch(config-pmap-qos)# no class traffic_class1
switch(config-pmap-qos)#
 

 
関連コマンド

コマンド
説明

set dscp

トラフィック クラスに DSCP 値を割り当てます。

set precedence

トラフィック クラスに IP precedence を割り当てます。

set qos-group

トラフィック クラスに QoS グループを割り当てます。

show class-map type qos

QoS タイプのクラス マップを表示します。

show policy-map

ポリシー マップを表示します。

class type network-qos

ポリシー マップで既存のネットワーク QoS クラス マップを参照し、クラス モードを開始するには、 class type network-qos コマンドを使用します。ポリシー マップからクラスを削除するには、このコマンドの no 形式を使用します。

class type network-qos class-map-name

no class type network-qos class-map-name

 
構文の説明

class-map-name

ネットワーク QoS クラス マップを参照します。クラス マップ名には最大 40 文字を使用できます。名前は大文字と小文字が区別され、英字、数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

トラフィック タイプと最初に一致したクラスに基づいて、ポリシーのアクションが実行されます。

次に、ネットワーク QoS タイプのポリシー マップでクラス マップを参照する例を示します。

switch(config)# policy-map type network-qos nqos_policy
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)#
 

次に、ネットワーク QoS タイプのポリシー マップのクラス マップ参照を削除する例を示します。

switch(config)# policy-map type network-qos nqos_policy
switch(config-pmap-nq)# no class type network-qos nqos_class
switch(config-pmap-nq)#
 

 
関連コマンド

コマンド
説明

mtu

トラフィック クラスのジャンボ フレームをイネーブルにします。

multicast-optimize

クラスで複数のパケットを送信できるようにします。

pause no-drop

トラフィック クラスの CBFC ポーズ特性をイネーブルにします。

queue-limit

トラフィック クラスのキュー制限を設定します。

set cos

トラフィック クラスに CoS 値を割り当てます。

show class-map type network-qos

ネットワーク QoS タイプのクラス マップを表示します。

show policy-map

ポリシー マップを表示します。

class type queuing

ポリシー マップで既存のキューイング クラス マップを参照し、クラス モードを開始するには、 class type queuing コマンドを使用します。ポリシー マップからクラスを削除するには、このコマンドの no 形式を使用します。

class type queuing class-map-name

no class type queuing class-map-name

 
構文の説明

class-map-name

キューイング クラス マップを参照します。クラス マップ名には最大 40 文字を使用できます。名前は大文字と小文字が区別され、英字、数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

キューイング タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

トラフィック タイプと最初に一致したクラスに基づいて、ポリシーのアクションが実行されます。

次に、キューイング タイプのポリシー マップでクラス マップを参照する例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing 1p7q4t-out-q3
switch(config-pmap-c-que)#
 

次に、キューイング タイプのポリシー マップのクラス マップ参照を削除する例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# no class type queuing 1p7q4t-out-q3
switch(config-pmap-que)#
 

 
関連コマンド

コマンド
説明

show class-map type queuing

キューイング タイプのクラス マップを表示します。

show policy-map

ポリシー マップを表示します。

class-map

クラス マップを作成または修正して、クラス マップ コンフィギュレーション モードを開始するには、 class-map コマンドを使用します。クラス マップを削除するには、このコマンドの no 形式を使用します。

class-map [ type qos ] [ match-all | match-any ] class-map-name

no class-map [ type qos ] [ match-all | match-any ] class-map-name

 
構文の説明

type qos

(任意)QoS タイプのクラス マップのコンポーネントを指定します。デフォルトでは、クラス マップ タイプは QoS です。

match-all

match コマンドでこのクラス マップに設定された基準のすべてに一致した場合、パケットにこのクラス マップを適用します。

match-any

match コマンドでこのクラス マップに設定された基準のいずれかに一致した場合、パケットにこのクラス マップを適用します。match-all が指定されていない場合、これがデフォルトのアクションです。

class-map-name

QoS クラス マップに割り当てられた名前。最大 40 文字までの名前を指定できます。名前は大文字と小文字が区別され、英数字、ハイフン、下線だけを含めることができます。

class-default という名前は予約されています。

 
コマンド デフォルト

type qos

match-all

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

4.1(3)N1(1)

type qos キーワードが追加されました。

5.0(2)N1(1)

match-all キーワードのサポートが追加されました。

 
使用上のガイドライン

QoS ポリシーで使用される各トラフィックのクラスにクラス マップを定義できます。

match コマンドでこのクラス マップに設定された基準のいずれかにパケットが一致した場合、このクラス マップがパケットに適用されます。実行方針を指定しなかった場合(match-any または match-all)、デフォルト値 match-any がトラフィック クラスに適用されます。

次に、QoS クラス マップを作成または修正する例を示します。

switch(config)# class-map my_class1
switch(config-cmap-qos)#
 

次に、すべてのトラフィック パケットに一致する QoS クラス マップを作成する例を示します。

switch(config)# class-map type qos match-all my_class2
switch(config-cmap-qos)#
 

次に、QoS クラス マップを削除する例を示します。

switch(config)# no class-map my_class1
switch(config)#
 

次に、class-fcoe クラス マップを削除しようとしたときに表示されるエラー メッセージを示します。

switch(config)# no class-map class-fcoe
ERROR: Reserved class-map(s) cannot be deleted/modified
 
switch(config)#
 

 
関連コマンド

コマンド
説明

description

クラス マップの目的のサマリーを追加します。

feature fcoe

スイッチ上で FCoE をイネーブルにします。

match

トラフィック クラスの基準を設定します。

policy-map type qos

QoS ポリシー マップを作成または変更します。

service-policy

インターフェイスまたはシステム ポリシーにポリシー マップを関連付けます。

show class-map type qos

QoS クラス マップを表示します。

class-map type network-qos

トラフィックのネットワーク QoS クラスを定義するクラス マップを作成または修正して、クラス マップ コンフィギュレーション モードを開始するには、 class-map type network-qos コマンドを使用します。クラス マップを削除するには、このコマンドの no 形式を使用します。

class-map type network-qos class_map_name

no class-map type network-qos class_map_name

 
構文の説明

class-map-name

クラス マップに割り当てられた名前。class-default という名前は予約されています。最大 40 文字までの名前を指定できます。名前は大文字と小文字が区別され、英数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ネットワーク QoS タイプのクラス マップは、 match qos-group コマンドだけをサポートします。 match コマンドでこのクラス マップに設定された基準のいずれかにトラフィック パケットが一致した場合、このクラス マップがパケットに適用されます。デフォルトでは、トラフィックは、暗黙の match-any オプションを使用してフィルタリングされます。

次に、my_class1 という名前のネットワーク QoS クラス マップを作成または修正する例を示します。

switch(config)# class-map type network-qos my_class1
switch(config-cmap-nq)#
 

次に、ネットワーク QoS クラス マップを削除する例を示します。

switch(config)# no class-map my_class1
switch(config)#
 

 
関連コマンド

コマンド
説明

feature fcoe

スイッチの FCoE をイネーブルにします。

match qos-group

QoS グループ値と一致するトラフィック クラスを定義します。

show class-map type network-qos

システムに設定されているネットワーク QoS クラス マップを表示します。

class-map type queuing

トラフィックのキューイング クラスを定義するクラス マップを作成または修正して、クラス マップ コンフィギュレーション モードを開始するには、 class-map type queuing コマンドを使用します。キューイング クラス マップを削除するには、このコマンドの no 形式を使用します。

class-map type queuing class_map_name

no class-map type queuing class_map_name

 
構文の説明

class-map-name

クラス マップに割り当てられた名前、またはシステム定義のキューイング クラス マップ名。class-default という名前は予約されています。最大 40 文字までの名前を指定できます。名前は大文字と小文字が区別され、英数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

キューイング タイプのクラス マップを修正する場合、指定したポート タイプの全ポートの設定も変更されます。

システムで定義されたキューイング クラス マップ名は削除できません。

キューイング タイプのクラス マップは、 match qos-group コマンドだけをサポートします。 match コマンドでこのクラス マップに設定された基準のいずれかにトラフィック パケットが一致した場合、このクラス マップがパケットに適用されます。デフォルトでは、トラフィックは、暗黙の match-any オプションを使用してフィルタリングされます。

次に、キューイング クラス マップを作成または修正する例を示します。

switch(config)# class-map type queuing my_class1
switch(config-cmap-que)#
 

次に、class-default という名前のシステム定義のキューイング クラス マップを修正する例を示します。

switch(config)# class-map type queuing match-any class-default
switch(config-cmap-que)#
 

次に、キューイング クラス マップを削除する例を示します。

switch(config)# no class-map type queuing my_class1
switch(config)#
 

 
関連コマンド

コマンド
説明

feature fcoe

スイッチ上で FCoE をイネーブルにします。

match qos-group

QoS グループ値と一致するトラフィック クラスを設定します。

show class-map type queuing

システムに設定されているキューイング クラス マップを表示します。

description

クラス マップ、ポリシー マップ、またはテーブル マップに説明を追加するには、 description コマンドを使用します。説明を削除するには、このコマンドの no 形式を使用します。

description text

no description text

 
構文の説明

text

クラス マップ、ポリシー マップ、またはテーブル マップの説明。最大 200 文字の英数字を入力できます。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS タイプのクラス マップ コンフィギュレーション モード
QoS タイプのクラス マップ コンフィギュレーション モード
キューイング タイプのクラス マップ コンフィギュレーション モード
ネットワーク QoS タイプのポリシー マップ コンフィギュレーション
QoS タイプのポリシー マップ コンフィギュレーション
キューイング タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、QoS クラス マップに説明を追加する例を示します。

switch(config)# class-map my_class1
switch(config-cmap-qos)# description This class map filters packets that matches an ACL
switch(config-cmap-qos)#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

policy-map

ポリシー マップを作成、または変更します。

show class-map

クラス マップを表示します。

show policy-map

ポリシー マップを表示します。

flowcontrol

選択したインターフェイスの IEEE 802.3x リンクレベル フロー制御をイネーブルにするには、 flowcontrol コマンドを使用します。

flowcontrol [ receive { on | off }] [ send { on | off }]

 
構文の説明

receive

(任意)フロー制御を受信方向で設定します。

off

インターフェイスでフロー制御トラフィックをディセーブルにします。

on

インターフェイスでフロー制御トラフィックをイネーブルにします。

send

(任意)フロー制御を送信方向で設定します。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

 
使用上のガイドライン

このコマンドは次のインターフェイスで使用できます。

レイヤ 2 インターフェイス

レイヤ 3 インターフェイス


) インターフェイスをレイヤ 3 インターフェイスとして設定するには、no switchport コマンドを使用します。


次に、インターフェイス上で受信されたトラフィックのフロー制御をイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/2
switch(config-if)# flowcontrol receive on
 

 
関連コマンド

コマンド
説明

no switchport

インターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

priority-flow-control

選択したインターフェイスの PFC モードを設定します。

show interface flowcontrol

すべてのインターフェイスでフロー制御設定の詳細なリストを表示します。

hardware multicast disable-slow-port-pruning

マルチキャスト パケットで低速ポートのプルーニングをディセーブルにするには、 hardware multicast disable-slow-port-pruning コマンドを使用します。表示ポートのプルーニングをイネーブルにするには、このコマンドの no 形式を使用します。

hardware multicast disable-slow-port-pruning

no hardware multicast disable-slow-port-pruning

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン


) このコマンドは、Cisco Nexus 5548 スイッチだけに適用されます。


次に、スイッチでマルチキャスト パケットの低速ポートのプルーニングをディセーブルにする例を示します。

switch(config)# hardware multicast disable-slow-port-pruning
switch(config)#
 

 
関連コマンド

コマンド
説明

hardware unicast voq-limit

VOQ 制限をイネーブルにします。

show running-config

スイッチの実行コンフィギュレーションを表示します。

hardware unicast voq-limit

スイッチのユニキャスト トラフィックの仮想出力キューイング(VOQ)制限をイネーブルにするには、 hardware unicast voq-limit コマンドを使用します。VOQ 制限をディセーブルにするには、このコマンドの no 形式を使用します。

hardware unicast voq-limit

no hardware unicast voq-limit

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン


) このコマンドは、Cisco Nexus 5548 スイッチだけに適用されます。


輻輳とブロッキングを軽減するために、仮想出力キューイング(VOQ)を使用して、1 つのブロックされたレシーバのトラフィックが他の輻輳していないレシーバに送信されないようにすることができます(行頭ブロッキング)。

次に、スイッチでユニキャスト パケットの VOQ 制限をイネーブルにする例を示します。

switch(config)# hardware unicast voq-limit
switch(config)#
 

 
関連コマンド

コマンド
説明

hardware multicast disable-slow-port-pruning

スイッチで低速ポートのプルーニングをディセーブルにします。

show running-config

スイッチの実行コンフィギュレーションを表示します。

match access-group

特定の Access Control List(ACL; アクセス コントロール リスト)グループをクラス マップの一致基準として識別するには、 match access-group コマンドを使用します。ACL 一致基準をクラス マップから削除するには、このコマンドの no 形式を使用します。

match access-group name acl-name

no match access-group name acl-name

 
構文の説明

name acl-name

特性を一致基準として使用する ACL 名を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン


permit および deny ACL キーワードは、パケットの一致に影響を与えません。


次に、my_acl という ACL の特性を一致基準として使用し、QoS クラス マップを作成する例を示します。

switch(config)# class-map class_acl
switch(config-cmap-qos)# match access-group name my_acl
 

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

match cos

QoS タイプのクラス マップで、Class of Service(CoS; サービス クラス)値を使用してトラフィックのクラスを定義するには、 match cos コマンドを使用します。一致基準として指定した CoS 値を取り消すには、このコマンドの no 形式を使用します。

match [ not ] cos cos-list

no match [ not ] cos cos-list

 
構文の説明

not

(任意)指定した一致結果を除外します。

cos-list

一致基準として指定する CoS 値または CoS 値のリスト。有効値は、0 ~ 7 です。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する


) このコマンドのオプションの not キーワードをサポートしているのは、QoS タイプのクラス マップだけです。キューイング タイプのクラス マップでは not キーワードがサポートされません。


次に、QoS タイプ クラス マップの一致基準として CoS 値を設定する例を示します。

switch(config)# class-map class_acl
switch(config-cmap-qos)# match cos 5-7
 

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

match dscp

特定の Differentiated Services Code Point(DSCP; DiffServ コード ポイント)値を一致基準として識別するには、 match dscp コマンドを使用します。一致条件として指定した DSCP 値を削除するには、このコマンドの no 形式を使用します。

match [ not ] dscp dscp-list

no match [ not ] dscp dscp-list

 
構文の説明

not

(任意)指定した一致結果を除外します。

dscp-list

一致基準として指定する DSCP 値または DSCP 値のリスト。有効な DSCP 値のリストについては、 表 7-1 を参照してください。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

標準の DSCP 値については、 表 7-1 を参照してください。

 

表 7-1 標準の DSCP 値

DSCP 値
説明

af11

AF11 dscp(001010):10 進数の 10

af12

AF12 dscp(001100):10 進数の 12

af13

AF13 dscp(001110):10 進数の 14

af21

AF21 dscp(010010):10 進数の 18

af22

AF22 dscp(010100):10 進数の 20

af23

AF23 dscp(010110):10 進数の 22

af31

AF31 dscp(011010):10 進数の 26

af32

AF40 dscp(011100):10 進数の 28

af33

AF33 dscp(011110):10 進数の 30

af41

AF41 dscp(100010):10 進数の 34

af42

AF42 dscp(100100):10 進数の 36

af43

AF43 dscp(100110):10 進数の 38

cs1

CS1(優先順位 1)dscp(001000):10 進数の 8

cs2

CS2(優先順位 2)dscp(010000):10 進数の 16

cs3

CS3(優先順位 3)dscp(011000):10 進数の 24

cs4

CS4(優先順位 4)dscp(100000):10 進数の 32

cs5

CS5(優先順位 5)dscp(101000):10 進数の 40

cs6

CS6(優先順位 6)dscp(110000):10 進数の 48

cs7

CS7(優先順位 7)dscp(111000):10 進数の 56

default

デフォルト dscp(000000):10 進数の 0

ef

EF dscp(101110):10 進数の 46

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する

次に、DSCP 値 af21 を一致基準として設定する例を示します。

switch(config)# class-map my_test
switch(config-cmap-qos)# match dscp af21
 

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

match ip rtp

クラス マップで、Real-Time Protocol(RTP)ポートを一致基準として使用するよう設定するには、 match ip rtp コマンドを使用します。一致条件として指定した RTP ポートを削除するには、このコマンドの no 形式を使用します。

match [ not ] ip rtp port-list

no match [ not ] ip rtp port-list

 
構文の説明

not

(任意)指定した一致結果を除外します。

port-list

一致条件として指定される、RTP を使用する UDP ポートまたは UDP ポートのリスト。有効値の範囲は 2000 ~ 65535 秒です。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する

次に、一致基準として RTP を使用するポートを指定する例を示します。

switch(config)# class-map my_test
switch(config-cmap-qos)# match ip rtp 2300
 

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

match precedence

クラス マップで、IP ヘッダーの Type of Service(ToS; タイプ オブ サービス)バイト フィールドに含まれる precedence 値を一致基準として使用するよう設定するには、 match precedence コマンドを使用します。一致条件として指定した precedence 値を削除するには、このコマンドの no 形式を使用します。

match [ not ] precedence precedence-list

no match [ not ] precedence precedence-list

 
構文の説明

not

(任意)指定した一致結果を除外します。

precedence-list

バイト単位で指定される、IP precedence 値または IP precedence 値のリスト。有効な値については、 表 7-2 を参照してください。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

precedence 値のリストについては、 表 7-2 を参照してください。

 

表 7-2 優先順位値

precedence 値
説明

0 ~ 7

IP precedence 値

critical

クリティカル precedence(5)

flash

フラッシュ precedence(3)

flash-override

フラッシュ上書き precedence(4)

immediate

即時 precedence(2)

internet

インターネットワーク コントロール precedence(6)

network

ネットワーク コントロール precedence(7)

priority

優先 precedence(1)

routine

ルーチン precedence(0)

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する

次に、一致基準として IP precedence 値を指定する例を示します。

switch(config)# class-map my_test
switch(config-cmap-qos)# match precedence 7
 

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

match protocol

クラス マップで、特定のプロトコルを一致基準として使用するよう設定するには、 match protocol コマンドを使用します。一致条件として指定したプロトコルを削除するには、このコマンドの no 形式を使用します。

match [ not ] protocol protocol-name

no match [ not ] protocol protocol-name

 
構文の説明

not

(任意)指定した一致結果を除外します。

protocol-name

指定されるプロトコル名。有効な値については、 表 7-3 を参照してください。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

表 7-3 に、有効なプロトコル名のリストを示します。

 

表 7-3 プロトコル名

引数
説明

arp

アドレス解決プロトコル(ARP)

clns_es

CLNS エンド システム

clns_is

CLNS 中継システム

dhcp

Dynamic Host Configuration(DHCP)

ldp

Label Distribution Protocol(LDP; ラベル配布プロトコル)

netbios

NetBIOS Extended User Interface(NetBEUI)

複数のプロトコルを指定するには、該当するプロトコル値ごとにこのコマンドを入力する必要があります。

次に、一致基準として特定のプロトコルを指定する例を示します。

switch(config)# class-map my_test
switch(config-cmap-qos)# match protocol ldp
 

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

match qos-group

クラス マップで、特定の QoS グループ値を一致基準として使用するよう設定するには、 match qos-group コマンドを使用します。一致条件として指定したプロトコルを削除するには、このコマンドの no 形式を使用します。

match [ not ] qos-group qos-group-list

no match [ not ] qos-group qos-group-list

 
構文の説明

not

(任意)指定した一致結果を除外します。

qos-group-list

一致基準として使用する QoS グループ値または QoS グループ値のリストを、バイト数で指定します。有効値は、2 ~ 5 です。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS タイプのクラス マップ コンフィギュレーション モード
キューイング タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

QoS グループは内部ラベルであり、パケット ペイロードまたは任意のパケット ヘッダーの一部ではありません。QoS グループ値に数学的な意味はありません。たとえば、QoS グループ値の 2 は 1 より大きいことを意味せず、各 QoS 値は QoS グループを内部的に区別するためだけに使用されます。このように、QoS 値はローカルでの処理についてだけ使用されます。

QoS グループの値は入力ポリシー内で設定されるまで未定義になっているため、QoS グループについての照合は、出力ポリシー内でだけ行います。

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する

次に、一致基準として特定の QoS グループ値を指定する例を示します。

switch(config)# class-map type queuing my_test
switch(config-cmap-qos)# match qos-group 6
switch(config-cmap-qos)#
 

 
関連コマンド

コマンド
説明

class-map type network-qos

ネットワーク QoS クラス マップを作成または修正します。

class-map type queuing

キューイング クラス マップを作成または変更します。

show class-map

クラス マップを表示します。

mtu

レイヤ 2 およびレイヤ 3 イーサネット インターフェイスの最大伝送ユニット(MTU)サイズを設定するには、 mtu コマンドを使用します。設定した MTU を削除するには、このコマンドの no 形式を使用します。

mtu mtu-value

no mtu mtu-value

 
構文の説明

mtu-value

Class of Service(CoS; サービス クラス)の MTU 値。有効値は、1500 ~ 9216 です。

 
コマンド デフォルト

デフォルトの MTU 値は 1500 です。FCoE cos 3 の場合、デフォルトは 2158 です。

 
コマンド モード

ネットワーク QoS クラス タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

4.2(1)N1(1)

MTU の範囲が 1500 ~ 9216 に変更されました。

Cisco NX-OS Release 4.1(3)N2(1) 以前のバージョンを実行する Cisco Nexus 5000 シリーズ では、MTU の範囲は 1538 ~ 9216 です。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

 
使用上のガイドライン

MTU はシステムの各仮想リンクに設定できます。

次に、ネットワーク QoS タイプのポリシー マップのクラスに MTU 値を設定する例を示します。

switch(config)# class-map type network-qos my_class1
switch(config-cmap-nq)# match qos-group 1
switch(config-cmap-nq)# exit
switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)# class type network-qos my_class1
switch(config-pmap-nq-c)# mtu 5000
switch(config-pmap-nq-c)#
 

 
関連コマンド

コマンド
説明

service-policy

インターフェイスまたはシステム ポリシーにポリシー マップを関連付けます。

show class-map

クラス マップを表示します。

show policy-map

ポリシー マップを表示します。

system qos

システム ポリシーを設定します。

multicast-optimize

クラスを最適化して複数のパケットを送信するには、 multicast-optimize コマンドを使用します。

multicast-optimize

no multicast-optimize

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS クラス タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

クラスのマルチキャスト トラフィックは、使用可能なすべてのマルチキャスト キューによってサポートされます。

ポリシー マップのクラスのうち、1 つだけをマルチキャストの最適化用に設定できます。


) Cisco Nexus 5548 スイッチでは、マルチキャスト最適化は class-default クラスではデフォルトでイネーブルです。マルチキャスト最適化を class-default クラスから削除してから、ユーザ定義クラスでマルチキャスト最適化をイネーブルにする必要があります。


次に、トラフィック クラスで最適化されたマルチキャストをイネーブルにする例を示します。

switch(config)# policy-map type network-qos my_queue
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)# multicast-optimize
switch(config-pmap-nq-c)#
 

次に、マルチキャスト最適化をトラフィック クラスから削除する例を示します。

switch(config)# policy-map type network-qos my_queue
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)# no multicast-optimize
switch(config-pmap-nq-c)#
 

 
関連コマンド

コマンド
説明

show policy-map

ポリシー マップを表示します。

pause no-drop

ネットワーク QoS タイプのポリシー マップで参照されるクラスで、Class Based Flow Control(CBFC)ポーズ特性をイネーブルにするには、 pause コマンドを使用します。クラスの CBFC ポーズ特性をディセーブルにするには、このコマンドの no 形式を使用します。

pause no-drop [ pfc-cos pfc-cos-list ]

no pause no-drop [ pfc-cos pfc-cos-list ]

 
構文の説明

pfc-cos

(任意)プライオリティ フロー制御(PFC)をアサートする CoS 値を指定します。

pfc-cos-list

PFC CoS リスト。範囲は 0 ~ 7 です。

カンマ(,)を使用して複数の値を区別するか、ハイフン(-)を使用して値の範囲を指定します。たとえば、0, 2, 3, または 2-5 のように指定します。

 
コマンド デフォルト

デフォルトでは、pause no-drop はオフです。

 
コマンド モード

ネットワーク QoS クラス タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

イーサネット インターフェイスは、Priority Flow Control(PFC; プライオリティ フロー制御)を使用して、ロスレス サービスを no-drop システム クラスに提供します。PFC はクラス単位でポーズ フレームを実装し、IEEE 802.1p CoS 値を使用してロスレス サービスを必要とするクラスを特定します。

CoS 値(match cos)以外の条件と一致するトラフィック クラスの PFC CoS だけを設定できます。

次に、ネットワーク QoS タイプのポリシー マップで参照されるクラスで pause no-drop をイネーブルにする例を示します。

switch(config)# class-map type network-qos my_class1
switch(config-cmap-nq)# match qos-group 2
switch(config-cmap-nq)# exit
switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)# class type network-qos my_class1
switch(config-pmap-nq-c)# pause no-drop
switch(config-pmap-nq-c)#
 

 
関連コマンド

コマンド
説明

show class-map type network-qos

ネットワーク QoS タイプのクラス マップを表示します。

show policy-map

ポリシー マップを表示します。

pause no-drop buffer-size

ネットワーク QoS タイプのポリシー マップで参照されるクラスで、Class Based Flow Control(CBFC)ポーズ特性をイネーブルにし、no-drop クラスの入力バッファ サイズを設定するには、 pause no drop buffer-size コマンドを使用します。クラスで CBFC ポーズ特性をディセーブルにし、バッファをリセットするには、このコマンドの no 形式を使用します。

pause no-drop buffer-size buffer-size pause-threshold xoff-size resume-threshold xon-size

no pause no-drop buffer-size buffer-size pause-threshold xoff-size resume-threshold xon-size

 
構文の説明

buffer-size

入力トラフィックのバッファ サイズ(バイト単位)。有効な値は 10240 ~ 490880 です。

Cisco Nexus 5548 スイッチでは、152000 バイトの最大バッファ サイズを設定できます。

pause-threshold

ポートがピアを一時停止するバッファ制限を指定します。

xoff-size

一時停止するときのバッファ制限(バイト単位)。有効な値は 0 ~ 490880 です。

Cisco Nexus 5548 スイッチでは、103360 バイトの最大一時停止しきい値を設定できます。

resume-threshold

ポートがピアを再開するバッファ制限を指定します。

xon-size

再開するときのバッファ制限(バイト単位)。有効な値は 0 ~ 490880 です。

Cisco Nexus 5548 スイッチでは、83520 バイトの最大再開しきい値を設定できます。

 
コマンド デフォルト

デフォルトでは、pause no-drop は on です。

 
コマンド モード

ネットワーク QoS クラス タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

no-drop クラスのバッファ サイズとしきい値を設定するために使用します。3000 m(9843 フィート)のリンク距離でロスレス イーサネットをサポートするバッファ サイズを設定します。Cisco NX-OS Release 5.0(2)N1(1) では、ポリシーをサポートするのに十分なバッファ リソースを確保できない場合は、スイッチ ソフトウェアによってそのポリシーが拒否されます。

バッファ サイズを設定するときには、次の点を確認してください。

バッファ サイズは一時停止しきい値よりも大きく、一時停止しきい値は再開しきい値よりも大きくなければなりません。それ以外の場合は、次のメッセージが表示されます。

ERROR: buffer-size can't be less then pause/resume-threshold
 

一時停止しきい値と再開しきい値の間の最小差は、20480 バイト(Cisco Nexus 5020 スイッチ)および 19840 バイト(Cisco Nexus 5548 スイッチ)でなければなりません。それ以外の場合、Cisco Nexus 5020 スイッチでは次のメッセージが表示されます。

Warning: The recommended difference between pause and resume threshold is 20480 bytes
 

Cisco Nexus 5548 スイッチでは次のメッセージが表示されます。

Warning: The recommended difference between pause and resume threshold is 19840 bytes
 

一時停止しきい値は再開しきい値よりも大きくなければなりません。それ以外の場合は、次のメッセージが表示されます。

ERROR: pause-threshold can't be less then resume-threshold
 

次に、ネットワーク QoS タイプのポリシー マップで参照されるクラスで pause no-drop をイネーブルにする例を示します。

switch(config)# class-map type network-qos my_class1
switch(config-cmap-nq)# match qos-group 2
switch(config-cmap-nq)# exit
switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)# class type network-qos my_class1
switch(config-pmap-nq-c)# pause no-drop
switch(config-pmap-nq-c)#
 

次に、Cisco Nexus 5000 シリーズ スイッチのネットワーク QoS タイプのポリシー マップで参照されるクラスで、3000 m の no-drop バッファ サイズを設定する方法を示します。

switch(config)# policy-map type network-qos pu-buffer
switch(config-pmap-nq)# class type network-qos cu1
switch(config-pmap-nq-c)# pause no-drop buffer-size 143680 pause-threshold 58860 resume-threshold 38400
switch(config-pmap-nq-c)#
 

次に、Cisco Nexus 5548 スイッチのネットワーク QoS タイプのポリシー マップで参照されるクラスで、3000 m の no-drop バッファ サイズを設定する方法を示します。

switch(config-pmap-nq)# policy-map type network-qos policy-test
switch(config-pmap-nq)# class type network-qos cu1-ta1
switch(config-pmap-nq-c)# pause no-drop buffer-size 152000 pause-threshold 103360 resume-threshold 83520
switch(config-pmap-nq-c)#
 

 
関連コマンド

コマンド
説明

show class-map type network-qos

ネットワーク QoS タイプのクラス マップを表示します。

show policy-map

ポリシー マップを表示します。

policy-map type network-qos

ポリシー マップを作成または修正し、ネットワーク QoS タイプのポリシー マップ コンフィギュレーション モードを開始するには、 policy-map type network-qos コマンドを使用します。ポリシー マップを削除するには、このコマンドの no 形式を使用します。

policy-map type network-qos policy-map-name

no policy-map type network-qos policy-map-name

 
構文の説明

policy-map-name

ネットワーク QoS タイプのポリシー マップに割り当てられる名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポリシー マップをインターフェイスに割り当てるには、 service-policy コマンドを使用します。

Cisco NX-OS Release 5.0(2)N1(1) を実行している Cisco Nexus 5548 スイッチでは、class-fcoe クラス マップは、スイッチ ソフトウェアによってポリシー マップに自動的に追加されません。class-fcoe クラスは手動でポリシー マップに追加できます。その他のすべての Cisco Nexus 5000 シリーズ スイッチでは、このクラスはデフォルトでポリシー マップに含まれています。Cisco Nexus 5548 スイッチでは、ポリシー マップから class-fcoe クラスを削除できます。

set qos-group コマンドを使用して、Cisco Nexus 5548 スイッチで class-fcoe クラス マップの qos-group を設定できます。デフォルトの qos-group 値は 1 です。

次に、QoS ネットワーク タイプのポリシー マップを作成または修正する例を示します。

switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)#
 

次に、ネットワーク QoS タイプのポリシー マップを削除する例を示します。

switch(config)# no policy-map type network-qos my_policy1
switch(config)
 

 
関連コマンド

コマンド
説明

class type network-qos

ポリシー マップのネットワーク QoS タイプのクラス マップを参照します。

description

クラス マップまたはポリシー マップに説明を追加します。

feature fcoe

スイッチ上で FCoE をイネーブルにします。

set qos-group

トラフィック クラスに QoS グループ ID を割り当てます。

show policy-map

ポリシー マップを表示します。

policy-map(QoS タイプ)

ポリシー マップを作成または修正し、QoS タイプのポリシー マップ コンフィギュレーション モードを開始するには、 policy-map コマンドを使用します。QoS ポリシー マップを削除するには、このコマンドの no 形式を使用します。

policy-map [ type qos ] qos-policy-map-name

no policy-map [ type qos ] qos-policy-map-name

 
構文の説明

type qos

(任意)QoS タイプのポリシー マップを指定します。

qos-policy-map-name

QoS タイプのポリシー マップに割り当てられる名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

タイプを指定せずに policy-map コマンドを実行すると、QoS タイプのポリシー マップ コンフィギュレーション モードが開始されます。

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポリシー マップをインターフェイスに割り当てるには、 service-policy コマンドを使用します。

Cisco NX-OS Release 5.0(2)N1(1) を実行している Cisco Nexus 5548 スイッチでは、class-fcoe クラス マップは、スイッチ ソフトウェアによってポリシー マップに自動的に追加されません。class-fcoe クラスは手動でポリシー マップに追加できます。その他のすべての Cisco Nexus 5000 シリーズ スイッチでは、このクラスはデフォルトでポリシー マップに含まれています。Cisco Nexus 5548 スイッチでは、ポリシー マップから class-fcoe クラスを削除できます。

set qos-group コマンドを使用して、Cisco Nexus 5548 スイッチで class-fcoe クラス マップの qos-group を設定できます。デフォルトの qos-group 値は 1 です。

次に、QoS タイプのポリシー マップを作成または修正する例を示します。

switch(config)# policy-map my_policy1
switch(config-pmap-qos)#
 

次に、QoS タイプのポリシー マップを削除する例を示します。

switch(config)# no policy-map my_policy1
 

 
関連コマンド

コマンド
説明

class-map type qos

QoS クラス マップを設定します。

feature fcoe

スイッチで FCoE 機能をイネーブルにします。

service-policy

ポリシー マップをインターフェイスに関連付けます。

set dscp

QoS トラフィックの DSCP 値を設定します。

set precedence

QoS トラフィックの IP precedence 値を設定します。

set qos-group

トラフィック クラスに QoS グループ ID を割り当てます。

show policy-map

ポリシー マップを表示します。

policy-map type queuing

ポリシー マップを作成または修正し、キューイング タイプのポリシー マップ コンフィギュレーション モードを開始するには、 policy-map type queuing コマンドを使用します。ポリシー マップを削除するには、このコマンドの no 形式を使用します。

policy-map type queuing queuing-policy-map-name

no policy-map type queuing queuing-policy-map-name

 
構文の説明

queuing-policy-map-name

キューイング タイプのポリシー マップに割り当てられる名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポリシー マップをインターフェイスに割り当てるには、 service-policy コマンドを使用します。

Cisco NX-OS Release 5.0(2)N1(1) を実行している Cisco Nexus 5548 スイッチでは、class-fcoe クラス マップは、スイッチ ソフトウェアによってポリシー マップに自動的に追加されません。class-fcoe クラスは手動でポリシー マップに追加できます。その他のすべての Cisco Nexus 5000 シリーズ スイッチでは、このクラスはデフォルトでポリシー マップに含まれています。Cisco Nexus 5548 スイッチでは、ポリシー マップから class-fcoe クラスを削除できます。

class-fcoe クラス マップでは、次の項目を設定できます。

帯域幅

帯域幅は、ゼロ(0)よりも大きな値で指定してください。

qos-group(Cisco Nexus 5548 スイッチ)


) Cisco Nexus 5548 スイッチでは、デフォルトの qos-group 値は 1 です。


次に、キューイング タイプのポリシー マップを作成または修正する例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing my_class1
switch(config-pmap-c-que)# bandwidth percent 75
switch(config-pmap-c-que)# exit
switch(config-pmap-que)#
 

次に、キューイング タイプのポリシー マップを削除する例を示します。

switch(config)# no policy-map type queuing my_policy1
switch(config)#
 

 
関連コマンド

コマンド
説明

bandwidth

インターフェイス帯域幅を設定します。

service-policy

ポリシー マップをインターフェイスに関連付けます。

set qos-group

トラフィック クラスに QoS グループ ID を割り当てます。

show policy-map

ポリシー マップを表示します。

priority

ポリシー マップのトラフィック クラスにプライオリティ キューを割り当てるには、 priority コマンドを使用します。マッピングを削除するには、このコマンドの no 形式を使用します。

priority

no priority

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

キューイング タイプのポリシー クラス マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポリシー マップのトラフィック クラスに完全優先キューを設定する場合、プライオリティ クラスは、他のクラス キューより優先されます。このキューは、キュー ゼロ(データ トラフィックではなく制御トラフィックを伝送)以外の他のすべてのキューより先に処理されます。

次に、トラフィック クラスを完全優先キューにマッピングする例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing 8q2t-in-q4
switch(config-pmap-c-que)# priority
switch(config-pmap-que)#
 

 
関連コマンド

コマンド
説明

show policy-map

ポリシー マップを表示します。

priority-flow-control

選択されたインターフェイスの Priority-Flow-Control(PFC; プライオリティフロー制御)モードを設定するには、 priority-flow-control コマンドを使用します。

priority-flow-control mode { auto | on }

no priority-flow-control mode { auto | on }

 
構文の説明

auto

PFC 機能をネゴシエーションします。

on

PFC を強制的にイネーブルにします。

 
コマンド デフォルト

auto

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

 
使用上のガイドライン

このコマンドは次のインターフェイスで使用できます。

レイヤ 2 インターフェイス

レイヤ 3 インターフェイス


) インターフェイスをレイヤ 3 インターフェイスとして設定するには、no switchport コマンドを使用します。


次に、インターフェイス上で PFC を強制的にイネーブルにする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/2
switch(config-if)# priority-flow-control mode on
switch(config-if)#
 

 
関連コマンド

コマンド
説明

flowcontrol

選択したインターフェイスにリンクレベル フロー制御を設定します。

no switchport

インターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

show interface flowcontrol

すべてのインターフェイスでフロー制御設定の詳細なリストを表示します。

show interface priority-flow-control

指定されたインターフェイスのプライオリティ フロー制御詳細を表示します。

queue-limit

入力キューおよび出力キューの両方にキュー制限を設定してテール廃棄を設定するには、 queue-limit コマンドを使用します。キュー制限を削除するには、このコマンドの no 形式を使用します。

queue-limit queue-size bytes

no queue-limit queue-size bytes

 
構文の説明

queue-size

キューサイズのしきい値(バイト単位)です。有効な範囲は 20480 ~ 204800 です。Cisco Nexus 5548 スイッチの場合、範囲は 20480~426880 バイトです。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS クラス タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドを使用すると、ポリシー マップで設定されるクラス ポリシーに対してキューが保持できるパケットの最大数を指定または修正できます。設定したキュー サイズしきい値を超えるパケットはドロップされます。

このコマンドは、「pause」コマンドを実行しないネットワーク QoS クラス マップだけで使用できます。

次に、キュー制限をネットワーク QoS クラス ポリシー マップに割り当てる例を示します。

switch(config)# policy-map type network-qos my_queue
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)# queue-limit 10 mbytes
switch(config-pmap-nq-c)#
 

次に、ポリシー マップ キューイング クラスからキュー制限を削除する例を示します。

switch(config)# policy-map type network-qos my_queue
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)# no queue-limit 10 mbytes
switch(config-pmap-nq-c)#
 

 
関連コマンド

コマンド
説明

pause no-drop

ネットワーク QoS タイプのポリシー マップで参照されるクラスでポーズ特性をイネーブルにします。

show policy-map

ポリシー マップを表示します。

service-policy

ポリシー マップをインターフェイスに関連付けるには、 service-policy コマンドを使用します。インターフェイスからサービス ポリシーを削除するには、このコマンドの no 形式を使用します。

service-policy { input | type { qos input | queuing { input | output }}} policy-map-name

no service-policy { input | type { qos input | queuing { input | output }}} policy-map-name

 
構文の説明

input

このポリシー マップをこのインターフェイスに着信するパケットに適用します。

type

ポリシー マップのタイプが QoS かキューイングかを指定します。

qos

QoS タイプのポリシー マップを指定します。

queuing

キューイング タイプのポリシー マップを指定します。

output

このインターフェイスから発信されるパケットにこのポリシー マップを適用します。

policy-map-name

このインターフェイスに関連付けるポリシー マップの名前。QoS およびキューイング タイプの各ポリシーに対して、インターフェイスの入力および出力に関連付けることができるポリシー マップはそれぞれ 1 つだけです。

ポリシー マップ名には最大 40 文字の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

4.2(1)N1(1)

ポリシー マップをシステム ポリシーに関連付けることができます。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

 
使用上のガイドライン

ポートおよびポート チャネル タイプのインターフェイスに対して、キューイング タイプのポリシー マップの入力および出力をそれぞれ 1 つずつ関連付けることができます。QoS およびキューイング タイプの各ポリシーに対して、インターフェイスの入力に関連付けることができるポリシー マップは 1 つだけです。

Cisco NX-OS Release 5.0(3)N1(1) から、レイヤ 3 ルーテッド インターフェイスまたはサブインターフェイスでこのコマンドを使用できるようになりました。

次に、キューイング ポリシー マップをレイヤ 2 ポート インターフェイスの入力パケットに関連付ける例を示します。

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# service-policy type queuing input my_input_q_policy
switch(config-if)#
 

次に、QoS タイプのポリシー マップをレイヤ 2 インターフェイスの着信パケットに関連付ける例を示します。

switch# configure terminal
switch(config)# system qos
switch(config-sys-qos)# service-policy type qos input my_policy1
switch(config-sys-qos)#
 

次に、set-dscp という名前の QoS タイプのポリシー マップをレイヤ 2 インターフェイスの着信パケットに関連付ける例を示します。

switch# configure terminal
switch(config)# policy-map type qos set-dscp
switch(config-pmap-qos)# class class-0
switch(config-pmap-c-qos)# set dscp ef
switch(config-pmap-c-qos)# exit
switch(config-pmap-qos)# class class-1-2
switch(config-pmap-c-qos)# set precedence 4
switch(config-pmap-c-qos)# exit
switch(config-pmap-qos)# exit
switch(config)# interface ethernet 2/1
switch(config-if)# service-policy type qos input set-dscp
switch(config-if)#
 

次に、キューイング ポリシー マップをレイヤ 3 インターフェイスに関連付ける例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# service-policy type queuing input my_input_q_policy
switch(config-if)#
 

 
関連コマンド

コマンド
説明

no switchport

インターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

show policy-map interface brief

すべてのインターフェイスと VLAN、および関連付けられたサービス ポリシーの概要を表示します。

system qos

システム ポリシーを設定します。

service-policy(システム QoS)

ポリシー マップをシステム ポリシーに関連付けるには、 service-policy コマンドを使用します。システム ポリシーからサービス ポリシーを削除するには、このコマンドの no 形式を使用します。

service-policy { input | type { network-qos | qos input | queuing { input | output }}} policy-map-name

no service-policy { input | type { network-qos | qos input | queuing { input | output }}} policy-map-name

 
構文の説明

input

このポリシー マップをこのインターフェイスに着信するパケットに適用します。

type

ポリシー マップのタイプがネットワーク QoS、QoS、またはキューイングかを指定します。

network-qos

ネットワーク QoS タイプのポリシー マップを指定します。

qos

QoS タイプのポリシー マップを指定します。

queuing

キューイング タイプのポリシー マップを指定します。

output

このインターフェイスから発信されるパケットにこのポリシー マップを適用します。

policy-map-name

このインターフェイスに関連付けるポリシー マップの名前。ポリシー マップ名には最大 40 文字の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

システム QoS コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

次に、キューイング ポリシー マップをシステム ポリシーに関連付ける例を示します。

switch# configure terminal
switch(config)# system qos
switch(config-sys-qos)# service-policy type queuing input my_input_q_policy
switch(config-sys-qos)#
 

 
関連コマンド

コマンド
説明

show policy-map

ポリシー マップを表示します。

system qos

システム ポリシーを設定します。

set cos(ネットワーク QoS タイプのポリシー マップ)

ネットワーク QoS タイプのポリシー マップのトラフィックのクラスに Class of Service(CoS; サービス クラス)値を割り当てるには、 set コマンドを使用します。割り当てられた値をクラスから削除するには、このコマンドの no 形式を使用します。

set cos cos-value

no set cos cos-value

 
構文の説明

cos-value

トラフィックのこのクラスに割り当てる CoS 値。範囲は 0 ~ 7 です。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS クラス タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 トラフィックのサポートが追加されました。

 
使用上のガイドライン

このコマンドを使用できるのは、出力ポートに関連付けられるネットワーク QoS タイプのポリシー上だけです。

Cisco NX-OS Release 5.0(3)N1(1) からは、レイヤ 3 トポロジで一意の CoS 値を使用してネットワーク QoS ポリシーの各 qos-group を設定する必要があります。

次に、ネットワーク QoS タイプのポリシー マップのトラフィックのクラスに CoS 値を割り当てる例を示します。

switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)# class type network-qos traffic_class2
switch(config-pmap-nq-c)# set cos 3
switch(config-pmap-nq-c)#
 

次に、ネットワーク QoS タイプのポリシー マップのトラフィックのクラスから CoS 値の割り当てを削除する例を示します。

switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)# class type network-qos traffic_class2
switch(config-pmap-nq-c)# no set cos 3
switch(config-pmap-nq-c)#
 

 
関連コマンド

コマンド
説明

show policy-map

ポリシー マップを表示します。

set dscp

Cisco Nexus 5548 スイッチで QoS タイプのポリシー マップのトラフィック クラスに DiffServ コード ポイント(DSCP)値を割り当てるには、 set dscp コマンドを使用します。以前に設定した DSCP 値を削除するには、このコマンド no 形式を使用します。

set dscp dscp-value

no set dscp dscp-value

 
構文の説明

dscp-value

このトラフィック クラスに割り当てる DSCP 値またはパラメータを指定します。有効値は 0 ~ 63 です。

標準的な DSCP 値の一覧については、 表 7-1 を参照してください。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン


) このコマンドは、Cisco Nexus 5548 スイッチでだけサポートされています。


マーキングは、着信および発信パケットの Quality of Service(QoS)フィールドを変更するために使用する方式です。

標準の QoS フィールドである、IP precedence、DSCP、サービス クラス(CoS)の値、および後続のアクションで使用できる内部ラベルを設定できます。マーキングは、トラフィックのポリシング、キューイング、およびスケジューリングで使用するトラフィックのタイプを識別するのに使用します(スケジューリングでは CoS だけを使用します)。

このコマンドは、DSCP パケット ヘッダー フィールドに基づいてトラフィックを分類するために使用します。パケットの DSCP 値を設定するときには、class-default システム クラス以外のトラフィック クラスを使用する必要があります。たとえば、qos-group x x は 1 ~ 5 の任意の値)を使用します。


) トラフィックが class-default システム クラス(qos-group 0)の場合、DSCP パケット ヘッダー フィールドを設定できません。


IP ヘッダーの DiffServ フィールドの上位 6 ビットで、DSCP 値を指定の値に設定できます。0 ~ 63 の数値のほか、 表 7-1 に示す標準の DSCP 値も入力できます。

3 つ以上の IP ヘッダー フィールドの値を設定すると、次のようなエラー メッセージが表示されます。

ERROR: Only 2 sets out of qos-group/cos/dscp/precedence/discard-class are allowed. Please remove other set action before applying this one.
 

) DSCP と IP precedence のいずれかの値は設定できますが、IP パケットの同じフィールドを変更するため、両方の値は設定できません。


QoS ポリシー マップが正常に機能し、指定の QoS グループを作成するようにするために、DSCP 値を設定した後で、QoS ポリシー マップをシステム ポリシーに関連付けてから、ネットワーク QoS タイプのポリシー マップを定義し、そのポリシー マップをシステム ポリシーに関連付けてください。QoS ポリシー マップの QoS グループがネットワーク QoS ポリシーの QoS グループと一致することを確認します。

次に、QoS ポリシーの DSCP 値を設定する例を示します。

switch(config)# policy-map type qos my_policy
switch(config-pmap-qos)# class type qos my_class
switch(config-pmap-c-qos)# set dscp cs6
switch(config-pmap-c-qos)# set qos-group 2
switch(config-pmap-c-qos)# exit
switch(config-pmap-qos)# exit
switch(config)# system qos
switch(config-sys-qos)# service-policy type qos input my_policy
switch(config-sys-qos)# exit
switch(config)# class-map type network-qos nqos_class
switch(config-cmap-nq)# match qos-group 2
switch(config-cmap-nq)# exit
switch(config)# policy-map type network-qos nqos_policy
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)# exit
switch(config-pmap-nq)# exit
switch(config)# system qos
switch(config-sys-qos)# service-policy type network-qos nqos_policy
switch(config-sys-qos)# exit
switch(config)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーション ファイルにコピーします。

show policy-map type qos

QoS ポリシー マップを表示します。

show running-config ipqos

QoS の実行コンフィギュレーションを表示します。

set precedence

Cisco Nexus 5548 スイッチで QoS タイプのポリシー マップのトラフィック クラスの IP ヘッダーに含まれる precedence 値を設定するには、 set precedence コマンドを使用します。クラスの precedence 値をデフォルト値に戻すには、このコマンドの no 形式を使用します。

set precedence precedence-value

no set precedence precedence-value

 
構文の説明

precedence-value

このクラスのトラフィックに割り当てる IP precedence 値。有効値は、0 ~ 7 です。

標準的な precedence 値の一覧については、 表 7-2 を参照してください。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン


) このコマンドは、Cisco Nexus 5548 スイッチでだけサポートされています。


マーキングは、着信および発信パケットの Quality of Service(QoS)フィールドを変更するために使用する方式です。

標準の QoS フィールドである、IP precedence、DSCP、サービス クラス(CoS)の値、および後続のアクションで使用できる内部ラベルを設定できます。マーキングは、トラフィックのポリシング、キューイング、およびスケジューリングで使用するトラフィックのタイプを識別するのに使用します(スケジューリングでは CoS だけを使用します)。

このコマンドは、IP precedence パケット ヘッダー フィールドに基づいてトラフィックを分類するために使用します。パケットの IP precedence 値を設定するときには、class-default システム クラス以外のトラフィック クラスを使用する必要があります。たとえば、qos-group x x は 1 ~ 5 の任意の値)を使用します。


) トラフィックが class-default システム クラス(qos-group 0)の場合、IP precedence パケット ヘッダー フィールドを設定できません。


3 つ以上の IP ヘッダー フィールドの値を設定すると、次のメッセージが表示されます。

ERROR: Only 2 sets out of qos-group/cos/dscp/precedence/discard-class are allowed. Please remove other set action before applying this one.
 

) DSCP と IP precedence のいずれかの値は設定できますが、IP パケットの同じフィールドを変更するため、両方の値は設定できません。


QoS ポリシー マップが正常に機能し、指定の QoS グループを作成するようにするために、IP precedence 値を設定した後で、QoS ポリシー マップをシステム ポリシーに関連付けてから、ネットワーク QoS タイプのポリシー マップを定義し、そのポリシー マップをシステム ポリシーに関連付けてください。QoS ポリシー マップの QoS グループがネットワーク QoS ポリシーの QoS グループと一致することを確認します。

次に、QoS ポリシーの IP precedence 値を設定する例を示します。

switch(config)# policy-map type qos my_policy
switch(config-pmap-qos)# class type qos my_class
switch(config-pmap-c-qos)# set precedence 5
switch(config-pmap-c-qos)# set qos-group 2
switch(config-pmap-c-qos)# exit
switch(config-pmap-qos)# exit
switch(config)# system qos
switch(config-sys-qos)# service-policy type qos input my_policy
switch(config-sys-qos)# exit
switch(config)# class-map type network-qos nqos_class
switch(config-cmap-nq)# match qos-group 2
switch(config-cmap-nq)# exit
switch(config)# policy-map type network-qos nqos_policy
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)# exit
switch(config-pmap-nq)# exit
switch(config)# system qos
switch(config-sys-qos)# service-policy type network-qos nqos_policy
switch(config-sys-qos)# exit
switch(config)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーション ファイルにコピーします。

show policy-map type qos

QoS ポリシー マップを表示します。

show running-config ipqos

QoS の実行コンフィギュレーションを表示します。

show startup-config ipqos

スタートアップ ファイルに保存されている QoS の設定を表示します。

set qos-group

QoS タイプのポリシー マップのトラフィックのクラスに QoS グループ ID を割り当てるには、 set qos-group コマンドを使用します。割り当てられた値をクラスから削除するには、このコマンドの no 形式を使用します。

set qos-group qos-group-value

no set qos-group qos-group-value

 
構文の説明

qos-group-value

トラフィックのこのクラスに割り当てる QoS グループ値。範囲は、Cisco Nexus 5020 スイッチの場合 2 ~ 5、Cisco Nexus 5548 スイッチの場合 1 ~ 5、その他のすべての Cisco Nexus 5000 シリーズ スイッチでは 0 ~ 5 です。

(注) Cisco Nexus 5548 スイッチのデフォルトは 1 です。

 
コマンド デフォルト

Cisco Nexus 5548 スイッチの場合は 1。

 
コマンド モード

QoS クラス タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

5.0(2)N1(1)

有効な QoS グループ値の範囲は 1 ~ 5 です。

 
使用上のガイドライン

QoS グループ ID 値は、入力ポリシーだけで設定できます。入力ポリシーには、最大 5 つの QoS グループを設定できます。

ポリシー マップ クラスで 3 つ以上の IP ヘッダー フィールドの値を設定すると、次のようなエラー メッセージが表示されます。

ERROR: Only 2 sets out of qos-group/cos/dscp/precedence/discard-class are allowed. Please remove other set action before applying this one.
 

次に、Cisco NX-OS Release 4.1(3)N1(1) で、QoS タイプのポリシー マップのトラフィックのクラスに QoS グループ ID を割り当てる例を示します。

switch(config)# policy-map my_policy1
switch(config-pmap-qos)# class traffic_class2
switch(config-pmap-c-qos)# set qos-group 10
switch(config-pmap-c-qos)#
 

次に、Cisco NX-OS Release 5.0(2)N1(1) で、QoS タイプのポリシー マップのトラフィックのクラスに QoS グループ ID を割り当てる例を示します。

switch(config)# policy-map my_policy
switch(config-pmap-qos)# class my_class
switch(config-pmap-c-qos)# set qos-group 3
switch(config-pmap-c-qos)#

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーション ファイルにコピーします。

show policy-map type qos

QoS ポリシー マップを表示します。

show running-config ipqos

QoS の実行コンフィギュレーションを表示します。

show startup-config ipqos

スタートアップ ファイルに保存されている QoS の設定を表示します。

show class-map type network-qos

ネットワーク QoS タイプのクラス マップを表示するには、 show class-map type network-qos コマンドを使用します。

show class-map type network-qos [ class-map-name ]

 
構文の説明

class-map-name

クラス マップ名です。最大 40 の英数字を使用できます。

 
コマンド デフォルト

クラス マップ名が指定されていない場合、ネットワーク QoS タイプのすべてのクラス マップが表示されます。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

タイプを指定しない場合、システムで設定されているすべてのクラス マップが表示されます。

次に、ネットワーク QoS タイプのすべてのクラス マップを表示する例を示します。

switch(config)# show class-map type network-qos
 
 
Type network-qos class-maps
==============================
 
class-map type network-qos s1
match qos-group 2
 
class-map type network-qos s2
match qos-group 3
 
class-map type network-qos s3
match qos-group 4
 
class-map type network-qos s4
match qos-group 5
 
class-map type network-qos cu1
match qos-group 2
 
class-map type network-qos cu2
match qos-group 3
 
class-map type network-qos cu3
match qos-group 4
 
class-map type network-qos cu4
match qos-group 5
 
class-map type network-qos new
match qos-group 2
 
class-map type network-qos class7
match qos-group 5
 
class-map type network-qos class-0
match qos-group 2
 
class-map type network-qos ip-based
match qos-group 5
 
class-map type network-qos class-1-2
match qos-group 3
 
class-map type network-qos class-4-7
match qos-group 4
 
class-map type network-qos cos-based
match qos-group 2
 
class-map type network-qos class-fcoe
match qos-group 1
 
class-map type network-qos class-flood
match qos-group 2
 
class-map type network-qos cos-based-3
match qos-group 3
 
class-map type network-qos cos-based-4
match qos-group 4
 
class-map type network-qos class-default
match qos-group 0
 
class-map type network-qos class-multicast
 
class-map type network-qos class-ip-multicast
match qos-group 5
 
 
switch(config)#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

show class-map type qos

QoS タイプのクラス マップを表示するには、 show class-map type qos コマンドを使用します。

show class-map type qos [ class-map-name ]

 
構文の説明

class-map-name

クラス マップの名前。 class-default という名前は予約されています。最大 40 の英数字を使用できます。

 
コマンド デフォルト

クラス マップ名が指定されていない場合、QoS タイプのすべてのクラス マップが表示されます。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、Cisco NX-OS Release 4.1(3)N1(1) を実行しているスイッチ上のすべての QoS タイプのクラス マップを表示する例を示します。

switch(config)# show class-map type qos
 
 
Type qos class-maps
===================
 
class-map type qos s1
match cos 0
 
class-map type qos s2
match protocol ldp
match ip rtp 2000
match protocol dhcp
match protocol arp
 
class-map type qos s3
match access-group name mac
 
class-map type qos s4
match access-group name ipv4
 
class-map type qos cp1
match precedence 4-5
match cos 0,4
match dscp 4
match protocol ldp
match protocol arp
 
class-map type qos cp2
match ip rtp 2000
match cos 0
 
class-map type qos cp3
match access-group name mac
 
class-map type qos cp5
 
class-map type qos cq1
match protocol ldp
match precedence 7
match cos 0
 
class-map type qos cq2
match protocol ldp
match cos 1-2
 
class-map type qos cq3
match access-group name mac
 
class-map type qos cq4
match access-group name ipv4-1
 
class-map type qos cq5
match access-group name ipv6-based
 
class-map type qos p1.1
match cos 7
 
class-map type qos p1.2
match protocol ldp
match ip rtp 2000-6001,10000-20000,60000-65535
match dscp 1
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p1.3
match access-group name mac
 
class-map type qos p1.4
match access-group name ipv4
 
class-map type qos p2.1
match cos 0,7
 
class-map type qos p2.2
match protocol ldp
match ip rtp 2000-6000,6002,10000-20000,60000-65535
match dscp 2
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p2.3
match access-group name mac
 
class-map type qos p2.4
match access-group name ipv4
 
class-map type qos p3.1
match cos 0,7
 
class-map type qos p3.2
match protocol ldp
match ip rtp 2000-6000,6003,10000-20000,60000-65535
match dscp 3
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p3.3
match access-group name mac
 
class-map type qos p3.4
match access-group name ipv4
 
class-map type qos p4.1
match cos 0,7
 
class-map type qos p4.2
match protocol ldp
match ip rtp 2000-6000,6004,10000-20000,60000-65535
match dscp 4
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p4.3
match access-group name mac
 
class-map type qos p4.4
match access-group name ipv4
 
class-map type qos p5.1
match cos 0,7
 
class-map type qos p5.2
match protocol ldp
match ip rtp 2000-6000,6005,10000-20000,60000-65535
match dscp 5
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p5.3
match access-group name mac
 
class-map type qos p5.4
match access-group name ipv4
 
class-map type qos p6.1
match cos 0,7
 
class-map type qos p6.2
match protocol ldp
match ip rtp 2000-6000,6006,10000-20000,60000-65535
match dscp 6
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p6.3
match access-group name mac
 
class-map type qos p6.4
match access-group name ipv4
 
class-map type qos p7.1
match cos 0,7
 
class-map type qos p7.2
match protocol ldp
match ip rtp 2000-6000,6007,10000-20000,60000-65535
match dscp 7
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p7.3
match access-group name mac
 
class-map type qos p7.4
match access-group name ipv4
 
class-map type qos p8.1
match cos 0,7
 
class-map type qos p8.2
match protocol ldp
match ip rtp 2000-6000,6008,10000-20000,60000-65535
match dscp 8
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p8.3
match access-group name mac
 
class-map type qos p8.4
match access-group name ipv4
 
class-map type qos p9.1
match cos 0,7
 
class-map type qos p9.2
match protocol ldp
match ip rtp 2000-6000,6009,10000-20000,60000-65535
match dscp 9
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p9.3
match access-group name mac
 
class-map type qos p9.4
match access-group name ipv4
 
class-map type qos class-0
match cos 0
 
class-map type qos class-6
match cos 6
 
class-map type qos class-7
match cos 7
 
class-map type qos clsas-0
 
class-map type qos cos-6-7
match cos 7
 
class-map type qos ip-based
match access-group name ip-based
 
class-map type qos acl-based
match access-group name ipPacl
 
class-map type qos class-1-2
match cos 1-2
 
class-map type qos class-4-5
match cos 4-5
 
class-map type qos class-4-6
match cos 5
 
class-map type qos class-4-7
match cos 5,7
 
class-map type qos class-405
 
class-map type qos cos-based
 
class-map type qos mac-based
match access-group name foo
 
class-map type qos udp-based
match access-group name ip-based
 
class-map type qos class-fcoe
match cos 3
 
class-map type qos class-flood
 
class-map type qos class-default
match any
 
class-map type qos class-all-flood
match all flood
 
class-map type qos class-ip-multicast
match ip multicast
 
switch(config)#
 

次に、特定のクラス マップを表示する例を示します。

switch# show class-map type qos class-4-6
 
 
Type qos class-maps
===================
 
class-map type qos class-4-6
match cos 5
 
switch#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチ上のすべての QoS タイプのクラス マップを表示する例を示します。

switch# show class-map type qos
 
 
Type qos class-maps
===================
 
class-map type qos match-any class-fcoe
match cos 3
 
class-map type qos match-any class-default
match any
 
class-map type qos match-any class-all-flood
match all flood
 
class-map type qos match-any class-ip-multicast
match ip multicast
 
switch#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

show class-map type queuing

キューイング タイプのクラス マップを表示するには、 show class-map type queuing コマンドを使用します。

show class-map type queuing [ class-map-name ]

 
構文の説明

class-map-name

クラス マップの名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

クラス マップ名が指定されていない場合、キューイング タイプのすべてのクラス マップが表示されます。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、Cisco NX-OS Release 4.1(3)N1(1) を実行しているスイッチ上のすべてのキューイング タイプのクラス マップを表示する例を示します。

switch(config)# show class-map type queuing
 
 
Type queuing class-maps
=======================
 
class-map type queuing s1
match qos-group 2
 
class-map type queuing s2
match qos-group 3
 
class-map type queuing s3
match qos-group 4
 
class-map type queuing s4
match qos-group 5
 
class-map type queuing cq1
match qos-group 2
 
class-map type queuing cq2
match qos-group 3
 
class-map type queuing cq3
match qos-group 4
 
class-map type queuing cq4
match qos-group 5
 
class-map type queuing pq1
 
class-map type queuing cqe1
match qos-group 2
 
class-map type queuing cqe2
match qos-group 3
 
class-map type queuing cqe3
match qos-group 4
 
class-map type queuing cqe4
match qos-group 5
 
class-map type queuing p1.1
match qos-group 2
 
class-map type queuing p1.2
match qos-group 3
 
class-map type queuing p1.3
match qos-group 4
 
class-map type queuing p1.4
match qos-group 5
 
class-map type queuing p2.1
match qos-group 2
 
class-map type queuing p2.2
match qos-group 3
 
class-map type queuing p2.3
match qos-group 4
 
class-map type queuing p2.4
match qos-group 5
 
class-map type queuing p3.1
match qos-group 2
 
class-map type queuing p3.2
match qos-group 3
 
<--Output truncated-->
switch(config)#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチ上のすべてのキューイング タイプのクラス マップを表示する例を示します。

switch# show class-map type queuing
 
 
Type queuing class-maps
=======================
 
class-map type queuing class-fcoe
match qos-group 1
 
class-map type queuing class-default
match qos-group 0
 
class-map type queuing class-all-flood
match qos-group 2
 
class-map type queuing class-ip-multicast
match qos-group 2
 
switch#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

show interface flowcontrol

すべてのインターフェイスにおけるフロー制御の詳細なリストを表示するには、 show interface flowcontrol コマンドを使用します。

show interface flowcontrol [ module number ]

 
構文の説明

module number

(任意)指定したモジュールのすべてのインターフェイスにおけるフロー制御設定を表示します。有効なモジュール 番号 の範囲は 1 ~ 3 です。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

 
使用上のガイドライン

このコマンドを使用して、次のインターフェイスのフロー制御情報を表示できます。

レイヤ 2 インターフェイス

レイヤ 3 インターフェイス


no switchport コマンドを使用してインターフェイスをレイヤ 3 インターフェイスとして設定してから、flowcontrol コマンドを使用してインターフェイスのフロー制御を設定します。


次に、スイッチ上のすべてのインターフェイスにおけるフロー制御設定を表示する例を示します。

switch# show interface flowcontrol
 
--------------------------------------------------------------------------------
Port Send FlowControl Receive FlowControl RxPause TxPause
admin oper admin oper
--------------------------------------------------------------------------------
Eth1/1 off off off off 0 0
 
Eth1/2 off off off off 0 0
 
Eth1/3 off off off off 0 0
 
Eth1/4 off off off off 0 0
 
Eth1/5 off off off off 0 0
 
Eth1/6 off off off off 0 0
 
Eth1/7 off off off off 0 0
 
Eth1/8 off off off off 0 0
 
Eth1/9 off off off off 0 0
 
Eth1/10 off off off off 0 0
 
Eth1/11 off off off off 0 0
 
--More--
switch#
 

次に、指定したモジュール上のすべてのインターフェイスにおけるフロー制御設定を表示する例を示します。

switch# show interface flowcontrol module 1
 
-------------------------------------------------------------------------------
Port Send FlowControl Receive FlowControl RxPause TxPause
admin oper admin oper
-------------------------------------------------------------------------------
Eth1/1 off off off off 0 0
 
Eth1/2 off off off off 0 0
 
Eth1/3 off off off off 0 0
 
Eth1/4 off off off off 0 0
 
Eth1/5 off off off off 0 0
 
Eth1/6 off off off off 0 0
 
Eth1/7 off off off off 0 0
 
Eth1/8 off off off off 0 0
 
Eth1/9 off off off off 0 0
 
Eth1/10 off off off off 0 0
 
Eth1/11 off off off off 0 0
 
Eth1/12 off off off off 0 0
 
Eth1/13 off off off off 0 0
 
Eth1/14 off off off off 0 0
--More--
switch#
 

次に、イーサネット 1/5 がルーテッド インターフェイスとして設定されているレイヤ 3 インターフェイスのフロー制御設定を表示する例を示します。

switch# show interface flowcontrol
 
--------------------------------------------------------------------------------
Port Send FlowControl Receive FlowControl RxPause TxPause
admin oper admin oper
--------------------------------------------------------------------------------
Eth1/1 off off off off 0 0
 
Eth1/2 off off off off 0 0
 
Eth1/3 off off off off 0 0
 
Eth1/4 off off off off 0 0
 
Eth1/5 off off on on 0 0
 
Eth1/6 off off off off 0 0
 
Eth1/7 off off off off 0 0
 
Eth1/8 off off off off 0 0
 
Eth1/9 off off off off 0 0
 
Eth1/10 off off off off 0 0
 
Eth1/11 off off off off 0 0
 
Eth1/12 off off off off 0 0
 
Eth1/13 off off off off 0 0
 
Eth1/14 off off off off 0 0
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

flowcontrol

インターフェイス上の IEEE 802.3x リンクレベル フロー制御をイネーブルにします。

no switchport

インターフェイスを、レイヤ 3 インターフェイスとして設定します。

priority-flow-control

選択したインターフェイスを Priority Flow Control(PFC; プライオリティ フロー制御)モードに設定します。

show interface priority-flow-control

指定したインターフェイスのプライオリティ フロー制御の詳細を表示するには、 show interface priority-flow-control コマンドを使用します。

show interface [ ethernet slot / port ] priority-flow-control

 
構文の説明

ethernet slot / port

(任意)イーサネット インターフェイス、およびそのスロット番号とポート番号を指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

 
使用上のガイドライン

このコマンドを使用して、次のインターフェイスのプライオリティ フロー制御情報を表示できます。

レイヤ 2 インターフェイス

レイヤ 3 インターフェイス


no switchport コマンドを使用してインターフェイスをレイヤ 3 インターフェイスとして設定してから、flowcontrol コマンドを使用してインターフェイスのフロー制御を設定します。


インターフェイスを指定しない場合 show interface priority-flow-control コマンドはすべてのインターフェイス(レイヤ 2、レイヤ 3)のプライオリティ フロー制御情報を表示します。

次に、指定したインターフェイスのプライオリティ フロー制御の詳細を表示する例を示します。

switch# show interface ethernet 1/2 priority-flow-control
============================================================
Port Mode Oper(VL bmap) RxPPP TxPPP
============================================================
 
Ethernet1/2 Auto On (9) 4088353 1890
switch#
 

イーサネット 1/2 がインターフェイスとして指定され、PFC モードは PFC 機能をネゴシエートするように設定されていて、動作がオンになっており、転送パケットは 1890 です。

次に、指定されたレイヤ 3 インターフェイスのプライオリティ フロー制御情報を表示する例を示します。

switch# show interface ethernet 1/5 priority-flow-control
============================================================
Port Mode Oper(VL bmap) RxPPP TxPPP
============================================================
 
Ethernet1/5 On On (0) 0 0
switch#
 

次に、すべてのインターフェイスのプライオリティ フロー制御情報を表示する例を示します。

switch# show interface priority-flow-control
============================================================
Port Mode Oper(VL bmap) RxPPP TxPPP
============================================================
 
Ethernet1/1 Auto Off 0 0
Ethernet1/2 Auto Off 0 0
Ethernet1/3 Auto Off 0 0
Ethernet1/4 Auto Off 0 0
Ethernet1/5 On On (0) 0 0
Ethernet1/6 Auto Off 0 0
Ethernet1/7 Auto Off 0 0
Ethernet1/8 Auto Off 0 0
Ethernet1/9 Auto Off 0 0
Ethernet1/10 Auto Off 0 0
Ethernet1/11 Auto Off 0 0
Ethernet1/12 Auto Off 0 0
Ethernet1/13 Auto Off 0 0
Ethernet1/14 Auto Off 0 0
Ethernet1/15 Auto Off 0 0
Ethernet1/16 Auto Off 0 0
Ethernet1/17 Auto Off 0 0
Ethernet1/18 Auto Off 0 0
Ethernet1/19 Auto Off 0 0
Ethernet1/20 Auto Off 0 0
Ethernet1/21 Auto Off 0 0
Ethernet1/22 Auto Off 0 0
Ethernet1/23 Auto Off 0 0
Ethernet1/24 Auto Off 0 0
Ethernet1/25 Auto Off 0 0
Ethernet1/26 Auto Off 0 0
Ethernet1/27 Auto Off 0 0
Ethernet1/28 Auto Off 0 0
Ethernet1/29 Auto Off 0 0
Ethernet1/30 Auto Off 0 0
Ethernet1/31 Auto Off 0 0
Ethernet1/32 Auto Off 0 0
Ethernet3/1 Auto Off 0 0
Ethernet3/2 Auto Off 0 0
Ethernet3/3 Auto Off 0 0
Ethernet3/4 Auto Off 0 0
Ethernet3/5 Auto Off 0 0
Ethernet3/6 Auto Off 0 0
Ethernet3/7 Auto Off 0 0
Ethernet3/8 Auto Off 0 0
Ethernet3/9 Auto Off 0 0
Ethernet3/10 Auto Off 0 0
Ethernet3/11 Auto Off 0 0
Ethernet3/12 Auto Off 0 0
Ethernet3/13 Auto Off 0 0
Ethernet3/14 Auto Off 0 0
Ethernet3/15 Auto Off 0 0
Ethernet3/16 Auto Off 0 0
Ethernet3/17 Auto Off 0 0
Ethernet3/18 Auto Off 0 0
Ethernet3/19 Auto Off 0 0
Ethernet3/20 Auto Off 0 0
Ethernet3/21 Auto Off 0 0
Ethernet3/22 Auto Off 0 0
Ethernet3/23 Auto Off 0 0
Ethernet3/24 Auto Off 0 0
Ethernet3/25 Auto Off 0 0
Ethernet3/26 Auto Off 0 0
Ethernet3/27 Auto Off 0 0
Ethernet3/28 Auto Off 0 0
Ethernet3/29 Auto Off 0 0
Ethernet3/30 Auto Off 0 0
Ethernet3/31 Auto Off 0 0
Ethernet3/32 Auto Off 0 0
Ethernet100/1/1 Auto Off 0 0
Ethernet100/1/2 Auto Off 0 0
Ethernet100/1/3 Auto Off 0 0
Ethernet100/1/4 Auto Off 0 0
Ethernet100/1/5 Auto Off 0 0
Ethernet100/1/6 Auto Off 0 0
Ethernet100/1/7 Auto Off 0 0
Ethernet100/1/8 Auto Off 0 0
Ethernet100/1/9 Auto Off 0 0
Ethernet100/1/10 Auto Off 0 0
Ethernet100/1/11 Auto Off 0 0
Ethernet100/1/12 Auto Off 0 0
Ethernet100/1/13 Auto Off 0 0
Ethernet100/1/14 Auto Off 0 0
Ethernet100/1/15 Auto Off 0 0
Ethernet100/1/16 Auto Off 0 0
switch#
 

 
関連コマンド

コマンド
説明

no switchport

レイヤ 3 ルーテッド インターフェイスとして設定します。

priority-flow-control

選択したインターフェイスの PFC モードを設定します。

show interface untagged-cos

指定したインターフェイスのタグなし Class of Service(CoS; サービス クラス)値を表示するには、 show interface untagged-cos コマンドを使用します。

show interface untagged-cos [ module module_no ]

 
構文の説明

module

(任意)スイッチ シャーシのこのモジュールのインターフェイスを表示します。

module_no

スイッチ シャーシのモジュール番号。有効な範囲は 1 ~ 18 です。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスを表示するサポートが追加されました。

次に、インターフェイスのタグなし CoS 値を表示する例を示します。

switch# show interface untagged-cos
=================================
 
Interface Untagged-CoS
=================================
 
port-channel1
port-channel3 2
port-channel5 5
port-channel6
port-channel12
port-channel15
port-channel20
port-channel24
port-channel25
port-channel33
port-channel41
port-channel44
--More--
switch#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチ上のすべてのインターフェイス(レイヤ 2、レイヤ 3)のタグなし CoS 値を表示する例を示します。

switch# show interface untagged-cos
S3(config-if)# show int untagged-cos
=================================
 
Interface Untagged-CoS
=================================
 
port-channel100
port-channel127
port-channel128
Ethernet1/1
Ethernet1/2
Ethernet1/3
Ethernet1/4
Ethernet1/5 3
Ethernet1/6
Ethernet1/7
Ethernet1/8
Ethernet1/9
Ethernet1/10
Ethernet1/11
Ethernet1/12
:
<--snip-->
Ethernet3/31
Ethernet3/32
Ethernet100/1/1
Ethernet100/1/2
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

untagged cos

タグなしイーサネット フレームの CoS 値を設定します。

show policy-map

ポリシー マップを表示するには、 show policy-map コマンドを使用します。

show policy-map [ type { network-qos | qos | queuing }] [ policy-map-name ]

 
構文の説明

type

(任意)表示するコンポーネント タイプを指定します。

network-qos

ネットワーク QoS タイプのポリシー マップを表示します。

qos

QoS タイプのポリシー マップだけを表示します。

queuing

キューイング タイプのポリシー マップだけを表示します。

policy-map-name

(任意)ポリシー マップの名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

引数やキーワードを指定せずに show policy-map コマンドを入力すると、Control Plane Policing(CoPP; コントロール プレーン ポリシング)情報も表示されます。

次に、指定したネットワーク QoS タイプのポリシー マップを表示する例を示します。

switch# show policy-map type network-qos my_pnq
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos my_pnq
class type network-qos cl_nq
multicast-optimize
queue-limit 20480 bytes
mtu 1500
class type network-qos class-fcoe
pause no-drop
mtu 2158
class type network-qos class-default
mtu 1500
switch#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

show policy-map interface

各インターフェイスに設定されているサービス ポリシー マップを表示するには、 show policy-map interface コマンドを使用します。

show policy-map interface [ ethernet slot / port | port-channel channel-number ] [ input | output ] [ type { qos | queuing }]

 
構文の説明

ethernet

(任意)イーサネット インターフェイスに割り当てられているポリシー マップを表示します。

slot/port

イーサネット インターフェイスのスロット番号とポート番号を指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

port-channel

(任意)EtherChannel に割り当てられているポリシー マップを表示します。

channel-number

EtherChannel 番号。範囲は 1 ~ 4096 です。

input

(任意)入力トラフィックに割り当てられているポリシー マップだけを表示します。

output

(任意)出力トラフィックに割り当てられているポリシー マップだけを表示します。

type

(任意)表示するコンポーネント タイプを指定します。

qos

QoS タイプのポリシー マップだけを表示します。

queuing

キューイング タイプのポリシー マップだけを表示します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 サブインターフェイスのサポートが追加されました。

 
使用上のガイドライン

デフォルトでは統計情報が表示されます。

次に、指定したインターフェイスに割り当てられているポリシー マップを表示する例を示します。

switch(config)# show policy-map interface ethernet 2/10
 

次に、指定したインターフェイスに割り当てられている QoS ポリシー マップを表示する例を示します。

switch# show policy-map interface ethernet 3/1 type qos
 
 
Global statistics status : disabled
 
Ethernet3/1
 
Service-policy (qos) input: s
policy statistics status: disabled
 
Class-map (qos): s1 (match-any)
Match: cos 0
set qos-group 2
 
Class-map (qos): class-1-2 (match-any)
Match: cos 1-2
set qos-group 3
 
Class-map (qos): class-4-5 (match-any)
Match: cos 4-5
set qos-group 4
 
Class-map (qos): class-6 (match-any)
Match: cos 6
set qos-group 5
 
Class-map (qos): class-fcoe (match-any)
Match: cos 3
set qos-group 1
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
switch#
 

次に、指定したインターフェイスの出力トラフィックに割り当てられたポリシー マップを表示する例を示します。

switch# show policy-map interface ethernet 3/1 output
 
 
Global statistics status : disabled
 
Ethernet3/1
 
Service-policy (queuing) output: pqe1
policy statistics status: disabled
 
Class-map (queuing): cqe1 (match-any)
Match: qos-group 2
bandwidth percent 20
 
Class-map (queuing): cqe2 (match-any)
Match: qos-group 3
priority
 
Class-map (queuing): cqe3 (match-any)
Match: qos-group 4
bandwidth percent 20
 
Class-map (queuing): cqe4 (match-any)
Match: qos-group 5
bandwidth percent 40
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 5
 
switch#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

show policy-map interface brief

インターフェイスに適用されるポリシー マップの概要を表示するには、 show policy-map interface brief コマンドを使用します。

show policy-map interface brief

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスを表示するサポートが追加されました。

次に、割り当てられているポリシー マップの概要を表示する例を示します。

switch(config)# show policy-map interface brief
 
 
Interface [Status]:INP QOS INP QUE OUT QUE
===================================================================
port-channel1 [Active]:p1 pqe1 pqe1
port-channel3 [Active]:s pqe1 pqe1
port-channel5 [Active]:s pqe1 pqe1
port-channel6 [Active]:s pqe1 pqe1
port-channel12 [Active]:p12 p12-in p12-out
port-channel15 [Active]:s pqe1 pqe1
port-channel20 [Active]:s pqe1 pqe1
port-channel24 [Active]:p4 pqe1 pqe1
port-channel25 [Active]:p4 pqe1 pqe1
port-channel33 [Active]:s pqe1 pqe1
port-channel41 [Active]:s pqe1 pqe1
port-channel44 [Active]:s pqe1 pqe1
port-channel48 [Active]:s pqe1 pqe1
port-channel101 [Active]:s pqe1 pqe1
port-channel102 [Active]:p4
port-channel103 [Active]:p4
port-channel104 [Active]:p4
port-channel105 [Active]:p4
port-channel106 [Active]:p4
port-channel107 [Active]:p4
--More--
switch(config)#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチで割り当てられているポリシー マップの概要を表示する例を示します。

switch# show policy-map interface brief
S3(config-if)# show policy-map interface brief
 
 
Interface/VLAN [Status]:INP QOS OUT QOS INP QUE OUT QUE
================================================================================
port-channel100 [Active]:default-in-po default-in-po default-out-p
 
port-channel127 [Active]:default-in-po default-in-po default-out-p
 
port-channel128 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/1 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/2 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/3 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/4 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/5 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/6 [Active]:default-in-po default-in-po default-out-p
 
:
<Snip>
:
Ethernet3/31 [Active]:default-in-po default-in-po default-out-p
 
Ethernet3/32 [Active]:default-in-po default-in-po default-out-p
 
Ethernet100/1/1 [Active]:default-in-po default-in-po default-out-p
 
Ethernet100/1/2 [Active]:default-in-po default-in-po default-out-p
 
Ethernet100/1/3 [Active]:default-in-po default-in-po default-out-p
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

show policy-map

ポリシー マップを表示します。

show policy-map system

システムのすべてのアクティブ ポリシー マップを表示するには、 show policy-map system コマンドを使用します。

show policy-map system [ type { network-qos | qos [ input ] | queuing [ input | output ]}]

 
構文の説明

type

(任意)表示するコンポーネント タイプを指定します。

network-qos

ネットワーク QoS タイプのポリシー マップだけを表示します。

qos

QoS タイプのポリシー マップだけを表示します。

input

(任意)入力トラフィックに割り当てられているポリシー マップを表示します。

queuing

キューイング タイプのポリシー マップだけを表示します。

output

(任意)出力トラフィックに割り当てられているポリシー マップを表示します。

 
コマンド デフォルト

すべてのポリシー マップ

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポリシー マップのタイプと名前を指定しない場合、システムのすべてのアクティブ ポリシー マップが表示されます。

次に、システムのすべてのアクティブ ポリシー マップを表示する例を示します。

switch# show policy-map system
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos s
class type network-qos s2 match qos-group 3
 
mtu 4000
class type network-qos s1 match qos-group 2
 
mtu 5000
set cos 0
multicast-optimize
pause no-drop
class type network-qos s3 match qos-group 4
 
mtu 9216
class type network-qos s4 match qos-group 5
 
mtu 9216
class type network-qos class-fcoe match qos-group 1
 
pause no-drop
mtu 2158
class type network-qos class-default match qos-group 0
 
mtu 1500
 
 
Service-policy (qos) input: s
policy statistics status: disabled
 
Class-map (qos): s1 (match-any)
Match: cos 0
set qos-group 2
 
Class-map (qos): class-1-2 (match-any)
Match: cos 1-2
set qos-group 3
 
Class-map (qos): class-4-5 (match-any)
Match: cos 4-5
set qos-group 4
 
Class-map (qos): class-6 (match-any)
Match: cos 6
set qos-group 5
 
Class-map (qos): class-fcoe (match-any)
Match: cos 3
set qos-group 1
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
Service-policy (queuing) input: pqe1
policy statistics status: disabled
 
Class-map (queuing): cqe1 (match-any)
Match: qos-group 2
bandwidth percent 20
 
Class-map (queuing): cqe2 (match-any)
Match: qos-group 3
priority
 
Class-map (queuing): cqe3 (match-any)
Match: qos-group 4
bandwidth percent 20
 
Class-map (queuing): cqe4 (match-any)
Match: qos-group 5
bandwidth percent 40
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 5
 
Service-policy (queuing) output: pqe1
policy statistics status: disabled
 
Class-map (queuing): cqe1 (match-any)
Match: qos-group 2
bandwidth percent 20
 
Class-map (queuing): cqe2 (match-any)
Match: qos-group 3
priority
 
Class-map (queuing): cqe3 (match-any)
Match: qos-group 4
bandwidth percent 20
 
Class-map (queuing): cqe4 (match-any)
Match: qos-group 5
bandwidth percent 40
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 5
 
switch#
 

次に、システムのアクティブなネットワーク QoS タイプのポリシー マップを表示する例を示します。

switch# show policy-map system type network-qos
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos s
class type network-qos s2 match qos-group 3
 
mtu 4000
class type network-qos s1 match qos-group 2
 
mtu 5000
set cos 0
multicast-optimize
pause no-drop
class type network-qos s3 match qos-group 4
 
mtu 9216
class type network-qos s4 match qos-group 5
 
mtu 9216
class type network-qos class-fcoe match qos-group 1
 
pause no-drop
mtu 2158
class type network-qos class-default match qos-group 0
 
mtu 1500
switch#
 

 
関連コマンド

コマンド
説明

show policy-map

すべてのポリシー マップを表示します。

show queuing interface

インターフェイスのキューイング情報を表示するには、 show queuing interface コマンドを使用します。

show queuing interface [ ethernet slot-no / port-no ]

 
構文の説明

ethernet

(任意)イーサネット インターフェイスに表示されるキューイング情報を指定します。

slot-no

イーサネット インターフェイスのスロット番号を指定します。範囲は 1 ~ 255 です。

port-no

イーサネット インターフェイスのポート番号を指定します。範囲は 1 ~ 128 です。

 
コマンド デフォルト

すべてのインターフェイスのキューイング情報を表示します。

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.1(3)N1(1)

このコマンドが追加されました。

次に、すべてのインターフェイスのキューイング情報を表示する例を示します。

switch# show queuing interface
Ethernet1/1 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 73
1 WRR 0
2 WRR 1
3 WRR 6
4 WRR 20
5 priority 0
 
RX Queuing
qos-group 0
q-size: 25600, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 160
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 1
q-size: 76800, HW MTU: 2240 (2158 configured)
drop-type: no-drop, xon: 128, xoff: 240
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 2
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 3
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 4
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 5
q-size: 81920, HW MTU: 9280 (9216 configured)
drop-type: no-drop, xon: 128, xoff: 230
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
Total Multicast crossbar statistics:
Mcast pkts received from the cross-bar : 0
 
Ethernet1/2 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 73
1 WRR 0
2 WRR 1
3 WRR 6
4 WRR 20
5 priority 0
<---output truncated--->
switch#
 

次に、イーサネット インターフェイス 1/2 のキューイング情報を表示する例を示します。

switch# show queuing interface ethernet 1/2
Ethernet1/2 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 73
1 WRR 0
2 WRR 1
3 WRR 6
4 WRR 20
5 priority 0
 
RX Queuing
qos-group 0
q-size: 25600, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 160
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 1851526994
Pkts sent to the port : 1851527000
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 1
q-size: 76800, HW MTU: 2240 (2158 configured)
drop-type: no-drop, xon: 128, xoff: 240
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 2
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
--More--
switch#
 

表 7-4 に、この出力で表示される重要なフィールドの説明を示します。

 

表 7-4 show queuing interface フィールドの説明

フィールド
説明

Ethernet ...

イーサネット インターフェイス情報。

qoS-group

スイッチに設定されている QoS グループの情報。

sched-type

スケジュールのタイプ。

WRR

Weighted Round Robin(WRR; 重み付けラウンドロビン)。スケジューリングのキューの重み付け。

Priority

キューのプライオリティ。

q-size

キュー サイズ。

drop-type

キューのドロップ タイプ。drop も no-drop も可能。

MTU

キューの Maximum Transmit Unit(MTU)。

Xon

このしきい値で伝送をオンにします。

Xoff

このしきい値で伝送をオフにします。

 
関連コマンド

コマンド
説明

hardware buffer-threshold

ハードウェア バッファしきい値を設定します。

hardware queue-limit

ハードウェア キュー制限を設定します。

show fex

スイッチに接続されている、すべての設定済みファブリック エクステンダ シャーシを表示します。

show running-config ipqos

システムの実行コンフィギュレーションについて、QoS 関連の情報を表示するには、 show running-config ipqos コマンドを使用します。

show running-config ipqos [ all ]

 
構文の説明

all

(任意)設定済みおよびデフォルトの情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスを表示するサポートが追加されました。

 
使用上のガイドライン

このコマンドは、デフォルトおよび設定済みクラス マップとポリシー マップのリストおよびインターフェイスに関連付けられているポリシーを表示するために使用します。

次に、Cisco NX-OS Release 5.0(2)N1(1) を実行しているスイッチの QoS 情報を表示する例を示します。

switch# show running-config ipqos
 
 
!Command: show running-config ipqos
!Time: Thu Sep 9 06:26:49 2010
 
version 5.0(2)N1(1)
class-map type qos class-fcoe
match cos 4
class-map type qos match-all 1
match cos 1
class-map type qos match-all 2
match cos 2
class-map type qos match-all 3
match cos 3
class-map type qos match-all 4
class-map type qos match-any 5
match cos 5,7
class-map type qos match-all arp
match protocol dhcp
match protocol arp
match cos 3
class-map type qos match-all cos
match cos 5
class-map type qos match-all dot
match access-group name dot
class-map type qos match-all my_class
match dscp 3
match precedence 0
match protocol dhcp
class-map type qos match-all new
match protocol netbios
:
<snip>
class-map type queuing my_qclass
match qos-group 3
class-map type queuing Video-Signalling
match qos-group 4
class-map type queuing class-ip-multicast
match qos-group 4
policy-map type qos 5
class 5
set qos-group 2
class Video
set qos-group 3
policy-map type qos my_policy
class my_class
set precedence 5
set dscp 5
class myQAll
set precedence 3
set dscp 48
:
<snip>
policy-map type network-qos my_policy1
class type network-qos my_class1
pause no-drop buffer-size 143680 pause-threshold 58860 resume-threshold 3840
class type network-qos class-fcoe
pause no-drop
mtu 2158
class type network-qos class-default
:
<snip>
system qos
service-policy type qos input voice
service-policy type network-qos Network
service-policy type queuing output Queu
service-policy type queuing input Queue
 
<--output truncated-->
switch#
 

次に、Cisco NX-OS Release 5.0(3)N1(1) を実行しているスイッチの QoS 情報を表示する例を示します。

switch# show running-config ipqos
 
!Command: show running-config ipqos
!Time: Sun Apr 20 07:22:36 2008
 
version 5.0(3)N1(1)
class-map type qos class-fcoe
class-map type qos match-all c1
match cos 3-5
class-map type queuing class-fcoe
match qos-group 1
class-map type queuing class-all-flood
match qos-group 2
class-map type queuing class-ip-multicast
match qos-group 2
policy-map type qos p1
class c1
set qos-group 3
class-map type network-qos n1
match qos-group 1
class-map type network-qos class-fcoe
match qos-group 1
class-map type network-qos class-all-flood
match qos-group 2
class-map type network-qos class-ip-multicast
match qos-group 2
policy-map type network-qos n2
class type network-qos n1
class type network-qos class-default
multicast-optimize
 
 
interface Ethernet1/5
priority-flow-control mode on
untagged cos 3
 
switch#
 

上記の出力はレイヤ 3 インターフェイス(レイヤ 3 インターフェイスとして設定されたイーサネット 1/5)の QoS 情報を示しています。

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーション ファイルにコピーします。

show class-map

クラス マップ情報を表示します。

show policy-map

ポリシー マップに関する情報を表示します。

show startup-config ipqos

スタートアップ コンフィギュレーションの Quality of Service(QoS)設定情報を表示するには、 show startup-config ipqos コマンドを使用します。

show startup-config ipqos [ all ]

 
構文の説明

all

(任意)設定済みおよびデフォルトの情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(2)N1(1)

このコマンドが追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスを表示するサポートが追加されました。

次に、スタートアップ コンフィギュレーション ファイルの QoS 情報を表示する例を示します。

switch# show startup-config ipqos
 
!Command: show startup-config ipqos
!Time: Thu Sep 9 07:42:33 2010
!Startup config saved at: Tue Sep 7 08:45:03 2010
 
version 5.0(2)N1(1)
class-map type qos class-fcoe
match cos 4
class-map type qos match-all 1
match cos 1
class-map type qos match-all 2
match cos 2
class-map type qos match-all 3
match cos 3
class-map type qos match-all 4
class-map type qos match-any 5
match cos 5,7
class-map type qos match-all arp
match protocol dhcp
match protocol arp
match cos 3
class-map type qos match-all cos
match cos 5
class-map type qos match-all dot
match access-group name dot
class-map type qos match-all new
match protocol netbios
class-map type qos match-all rtp
match ip rtp 2000-40000
class-map type qos match-all dscp
match dscp 46
match precedence 7
match protocol arp
class-map type qos match-all Video
match dscp 34
class-map type qos match-all Voice
match dscp 40,46
class-map type qos match-all class1
match ip rtp 2000
class-map type qos match-all class2
match cos 1
class-map type qos match-all class3
match protocol arp
class-map type qos match-all class4
match protocol dhcp
class-map type qos match-all class5
match protocol ldp
:
:
<--output truncated--
 
switch#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションを、スタートアップ コンフィギュレーション ファイルにコピーします。

show class-map

クラス マップ情報を表示します。

show policy-map

ポリシー マップに関する情報を表示します。

show wrr-queue cos-map

出力キューにマッピングされたサービス クラス(CoS)値を表示するには、 show wrr-queue cos-map コマンドを使用します。

show wrr-queue cos-map

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

次に、出力キューにマッピングされた CoS 値を表示する例を示します。

switch# show wrr-queue cos-map
MCAST Queue ID Cos Map
0 0 1
1 2
2 3 4 5
3 6 7
switch#
 

 
関連コマンド

コマンド
説明

wrr-queue cos-map

サービス クラス(CoS)値を出力キューのいずれかを選択するためにマッピングします。

system jumbomtu

システムで最大伝送ユニット(MTU)の上限を定義するには、 system jumbomtu コマンドを使用します。

system jumbomtu [ value ]

 
構文の説明

value

ジャンボ MTU 値。有効な範囲は 2158 ~ 9216 です。

 
コマンド デフォルト

9216 バイト

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、システムでの MTU の上限を定義する例を示します。

switch(config)# system jumbomtu 9216
switch(config)#
 

 
関連コマンド

コマンド
説明

show interface

指定したインターフェイスで送受信されるジャンボ MTU フレームを表示します。

system qos

システム ポリシーを設定するには、 system qos コマンドを使用します。

system qos

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが追加されました。

次に、キューイング ポリシーをシステムのすべてのインターフェイスに適用するようにシステム QoS を設定する例を示します。

switch(config)# system qos
switch(config-sys-qos)#
 

 
関連コマンド

コマンド
説明

service-policy

システム クラス ポリシー マップをシステムのサービス ポリシーに関連付けます。

untagged cos

選択したインターフェイスの Class of Service(CoS; サービス クラス)値を上書きするには、 untagged cos コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

untagged cos cos-value

no untagged cos cos-value

 
構文の説明

cos-value

タグなしフレームの Class of Service(CoS; サービス クラス)値。値の範囲は 1 ~ 7 です。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(1a)N1(1)

このコマンドが追加されました。

5.0(2)N1(1)

同じインターフェイスで QoS タイプのポリシー マップとタグなし CoS を設定するサポートが、Cisco Nexus 5548 スイッチに対して追加されました。

5.0(3)N1(1)

レイヤ 3 インターフェイスのサポートが追加されました。

 
使用上のガイドライン

このコマンドは次のインターフェイスで使用できます。

レイヤ 2 インターフェイス

レイヤ 3 インターフェイス


) インターフェイスをレイヤ 3 インターフェイスとして設定するには、no switchport コマンドを使用します。


CoS 値なしで受信したイーサネット フレームには、CoS 値 0 が設定されます。

Cisco NX-OS 5.0(2)N1(1) を実行している Cisco Nexus 5548 スイッチでは、同じインターフェイスに QoS タイプのポリシー マップとタグなし CoS を設定できます。

次に、インターフェイスで受信するタグなしフレームに CoS 値 4 を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/2
switch(config-if)# untagged cos 4
 

次に、レイヤ 3 インターフェイスで受信するタグなしフレームに CoS 値 3 を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# untagged cos 3
switch(config-if)#
 

 
関連コマンド

コマンド
説明

match cos

選択したクラスの一致条件とする CoS 値を設定します。

no switchport

インターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

show interface untagged-cos

インターフェイスのタグなし CoS 値を表示します。

wrr-queue cos-map

割り当てられたサービス クラス(CoS)値をマッピングして、出力キューのいずれかを選択するには、 wrr-queue cos-map コマンドを使用します。CoS マップをデフォルト設定に戻すには、このコマンドの no 形式を使用します。

wrr-queue cos-map queue-id cos1 ... cos8

no wrr-queue cos-map queue-id cos1 ... cos8

 
構文の説明

queue-id

出力キューの ID。範囲は 0 ~ 3 です。

cos1... cos8

キューを選択するためにマッピングする CoS 値。最大 8 個の CoS 値を入力します。各値はスペースで区切ります。範囲は 0 ~ 7 です。

 
コマンド デフォルト

デフォルトの設定は次のとおりです。

受信キュー 0 および送信キュー 0:CoS 0 および 1。

受信キュー 1 および送信キュー 1:CoS 2 および 3。

受信キュー 2 および送信キュー 2:CoS 4 および 5。

受信キュー 3 および送信キュー 3:CoS 6 および 7。

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン


) このコマンドを適用できるのは、レイヤ 3 マルチキャスト トラフィックだけです。


このコマンドを使用して、各キューが異なる重み付けラウンドロビン(WRR)パラメータで設定されている複数の異なるキューにトラフィックを配分できます。

レイヤ 3 マルチキャスト トラフィックに対して最大 4 個のマルチキャスト キューを設定できます。各マルチキャスト キューに少なくとも 1 つのサービス クラス(CoS)値を設定することを推奨します。

次に、CoS 値 0 および 1 をキュー 1 にマッピングする例を示します。

switch(config)# wrr-queue cos-map 1 0 1
switch(config)#
 

 
関連コマンド

コマンド
説明

show wrr-queue cos-map

重み付けラウンドロビン(WRR)キュー情報を表示します。