Cisco Nexus 5000 シリーズ コマンド リファレンス Release 4.0
Cisco Nexus 5000 シリーズ イーサネット コマンド
Cisco Nexus 5000 シリーズ イーサネット コマンド
発行日;2012/02/02 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

Cisco Nexus 5000 シリーズ イーサネット コマンド

channel-group(イーサネット コンフィギュレーション)

clear mac access-list counters

clear mac dynamic

clear mac-address-table dynamic

clear ntp session

clear ntp statistics

clear spanning-tree counters

clear spanning-tree detected-protocol

feature interface-vlan

feature lacp

feature private-vlan

instance vlan

interface ethernet

interface port-channel

interface vethernet

ip igmp snooping(EXEC)

ip igmp snooping(VLAN)

lacp port-priority

lacp system-priority

mac-address-table aging-time

mac-address-table notification

mac-address-table static

monitor session

name(VLAN コンフィギュレーション)

name(MST コンフィギュレーション)

ntp

ntp abort

ntp commit

ntp distribute

ntp sync-retry

port-channel load-balance ethernet

private-vlan

private-vlan association

private-vlan synchronize

revision

shutdown(VLAN コンフィギュレーション)

spanning-tree bpdufilter

spanning-tree bpduguard

spanning-tree cost

spanning-tree guard

spanning-tree link-type

spanning-tree loopguard default

spanning-tree mode

spanning-tree mst configuration

spanning-tree mst cost

spanning-tree mst forward-time

spanning-tree mst hello-time

spanning-tree mst max-age

spanning-tree mst max-hops

spanning-tree mst port-priority

spanning-tree mst priority

spanning-tree mst root

spanning-tree mst simulate pvst

spanning-tree mst simulate pvst global

spanning-tree pathcost method

spanning-tree port type edge

spanning-tree port type edge bpdufilter default

spanning-tree port type edge bpduguard default

spanning-tree port type edge default

spanning-tree port type network

spanning-tree port type network default

spanning-tree port-priority

spanning-tree vlan

state

svi enable

switchport access vlan

switchport block

switchport mode private-vlan host

switchport mode private-vlan promiscuous

switchport private-vlan host-association

switchport private-vlan mapping

vlan(EXEC モード)

vrf context

Cisco Nexus 5000 シリーズ イーサネット コマンド

この章では、Cisco Nexus 5000 シリーズ スイッチで使用可能な Cisco NX-OS イーサネット コマンドおよび仮想イーサネット コマンドについて説明します。

channel-group(イーサネット コンフィギュレーション)

ポート チャネル グループに物理インターフェイスを割り当てて設定するには、 channel-group コマンドを使用します。インターフェイスからチャネル グループ設定を削除するには、このコマンドの no 形式を使用します。

channel-group number [mode {active | on | passive}]

no channel-group [ number ]

 
シンタックスの説明

number

チャネル グループの番号。 number の有効範囲は、1 ~ 4096 です。既存のポート チャネルがない場合は、 Cisco NX-OS によってこのチャネル グループに関連付けられたポート チャネルが作成されます。

mode

(任意)インターフェイスのポート チャネル モードを指定します。

active

このコマンドを使用すると、ユーザが Link Aggregation Control Protocol(LACP)をイネーブルにしたときに、指定のインターフェイスの LACP がイネーブルになります。インターフェイスは、アクティブなネゴシエーション状態となります。この状態のポートは、LACP パケットを送信することにより、他のポートとのネゴシエーションを開始します。

on

これがデフォルト チャネル モードです。 LACP を実行していないすべてのポート チャネルは、このモードになります。LACP をイネーブルにする前に、チャネル モードをアクティブまたはパッシブに変更しようとすると、スイッチからエラー メッセージが返されます。

まず LACP をグローバルにイネーブルにしてから、 feature lacp コマンドを使用して、チャネル モードをアクティブまたはパッシブに設定して各チャネルの LACP をイネーブルにします。ON モードのインターフェイスは、LACP パケットの開始、および LACP パケットへの応答は行いません。LACP によって ON 状態のインターフェイスとのネゴシエーションが試行されても、このインターフェイスは LACP パケットを受信しません。このインターフェイスとのリンクは個別リンクとなります。つまり、ON 状態のインターフェイスは、チャネル グループには参加しません。

デフォルト モードは on です。

passive

このコマンドを使用すると、LACP をイネーブルにしたときに、LACP デバイスが検出された場合にだけ LACP がイネーブルになります。インターフェイスは、パッシブなネゴシエーション状態になります。この状態のポートは、受信した LACP パケットには応答しますが、LACP ネゴシエーションは開始しません。

 
コマンドのデフォルト設定

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

使用するインターフェイスが含まれるチャネル グループを作成し、チャネル グループに特定のインターフェイスを追加または削除する場合は、このコマンドを使用します。1 つのチャネル グループから別のチャネル グループにポートを移動するにも、このコマンドを使用します。ポートを移動する先のチャネル グループを入力すると、スイッチによって自動的に現在のチャネル グループから指定のポートが削除され、指定のチャネル グループにポートが追加されます。

LACP をグローバルにイネーブルにしてから、 feature lacp コマンドを使用して、チャネル モードを active または passive に設定することで各チャネルの LACP をイネーブルにします。 on チャネル モードのポート チャネルは、モードが未設定のポート チャネルであり、最大 8 ポートを集約できます。このチャネル モードのポート チャネルは LACP を実行しません。

ポート チャネルが LACP を実行していない場合は、既存のポート チャネルまたはそのいずれのインターフェイスについてもモードを変更できません。チャネル モードは、 on のままになります。モードを変更しようとすると、システムからエラー メッセージが返されます。

ポート チャネルから物理インターフェイスを削除するには、このコマンドの no 形式を使用します。ポート チャネルから最後の物理インターフェイスを削除しても、ポート チャネルは削除されません。ポート チャネルを完全に削除するには、 interface port-channel コマンドの no 形式を使用します。

互換性チェックには次の動作アトリビュートが含まれます。

ポート モード

アクセス VLAN

トランク ネイティブ VLAN

タグ付きかタグなしか

許可されている VLAN リスト

Switched Port Analyzer(SPAN; スイッチド ポート アナライザ[SPAN 送信元ポートまたは宛先ポートにはできません])

ストーム制御

Cisco NX-OS が使用する完全な互換性チェック リストを表示するには、 show port-channel compatibility-parameters コマンドを使用します。

スタティック ポート チャネル、つまり集約プロトコルが設定されていないポート チャネルには、チャネル モードが on に設定されたインターフェイスだけを追加できます。LACP を実行するポート チャネルには、チャネル モードが active または passive に設定されたインターフェイスだけを追加できます。

これらのアトリビュートは、個々のメンバー ポート上で設定できます。互換性がないアトリビュートを持つメンバー ポートを設定すると、Cisco NX-OS はポート チャネルでそのポートを一時停止します。

インターフェイスがポート チャネルに参加すると、インターフェイス個別のパラメータのうち、次のような一部のパラメータがポート チャネルの値によって上書きされます。

MAC アドレス

Spanning Tree Protocol(STP; スパニング ツリー プロトコル)

サービス ポリシー

QoS(Quality Of Service)

Access Control List(ACL; アクセス コントロール リスト)

インターフェイスがポート チャネルに参加、または削除された場合も、次のようなインターフェイス パラメータは影響を受けません。

説明

Cisco Discovery Protocol(CDP; シスコ検出プロトコル)

LACP ポート プライオリティ

デバウンス

速度モード

シャットダウン

SNMP トラップ

インターフェイスがポート チャネル インターフェイス用に設定されている場合にメンバー ポートがそのポート チャネルから削除されると、ポート チャネル インターフェイスの設定はそのメンバー ポートには伝播されません。

ポート チャネル インターフェイスに対して行った任意の互換性パラメータの設定変更は、ポート チャネルと同じチャネル グループ内のすべてのインターフェイスに伝播されます(たとえば、ポート チャネルのメンバーではないが、チャネル グループのメンバーとなっている物理インターフェイスにも設定変更が伝播されます)。

次に、LACP チャネル グループ 5 にアクティブ モードのインターフェイスを追加する例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# channel-group 5 mode active

 
関連コマンド

コマンド
説明

show interface port-channel

指定のポート チャネル インターフェイスのトラフィックに関する情報を表示します。

show lacp

LACP 情報を表示します。

show port-channel summary

ポート チャネルに関する情報を表示します。

clear mac access-list counters

アクセス リストから統計情報をクリアするには、 clear mac access-list counters コマンドを使用します。

clear mac access-list counters [ name ]

 
シンタックスの説明

name

(任意)クリアする特定のカウンタの名前。.

 
コマンドのデフォルト設定

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、アクセス リストから統計情報をクリアする例を示します。

switch# clear mac access-list counters

 
関連コマンド

コマンド
説明

show mac access-lists

MAC アドレス テーブルに関する情報を表示します。

clear mac dynamic

フォワーディング テーブルからダイナミック エントリをクリアするには、 clear mac dynamic コマンドを使用します。

clear mac dynamic [address mac_addr ] | [interface { type slot / port | port-channel number }] [vlan vlan_id ]

 
シンタックスの説明

address mac_addr

(任意)テーブルから MAC アドレスを削除するように指定します。EEEE.EEEE.EEEE の形式を使用します。

interface type slot / port

(任意)テーブルから MAC アドレスを削除するインターフェイスを指定します。タイプは、ethernet または vethernet のいずれかにできます。適切なスロット番号または仮想インターフェイス グループ番号、およびポート番号を指定します。

port-channel number

(任意)テーブルから MAC アドレスを削除するポート チャネルを指定します。ポート チャネル番号を使用します。

vlan vlan_id

(任意)テーブルから MAC アドレスを削除する VLAN を指定します。有効値の範囲は、1 ~ 4094 です。

 
コマンドのデフォルト設定

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、MAC アドレス テーブルからすべてのダイナミック エントリをクリアする例を示します。

switch# clear mac dynamic

次に、MAC アドレス テーブルから VLAN 2 のダイナミック エントリをクリアする例を示します。

switch# clear mac dynamic address 001b.2106.58bc vlan 2

次に、MAC アドレス テーブルから仮想イーサネットのすべてのダイナミック エントリをクリアする例を示します。

switch# clear mac dynamic interface vethernet 1/1

次に、MAC アドレス テーブルから VLAN 2 のすべてのダイナミック エントリをクリアする例を示します。

switch# clear mac dynamic vlan 2

 
関連コマンド

コマンド
説明

show mac dynamic

MAC アドレス テーブルのダイナミック アドレスを表示します。

clear mac-address-table dynamic

MAC アドレス テーブルからダイナミック アドレス エントリをクリアするには、 clear mac-address-table dynamic コマンドを使用します。

clear mac-address-table dynamic [[address mac_addr ] | [interface { type slot / port | port-channel number }]] [vlan vlan_id ]

 
シンタックスの説明

address mac_addr

(任意)テーブルから MAC アドレスを削除するように指定します。EEEE.EEEE.EEEE の形式を使用します。

interface type slot / port

(任意)テーブルから MAC アドレスを削除するインターフェイスを指定します。タイプは、ethernet または vethernet のいずれかにできます。適切なスロット番号または仮想インターフェイス グループ番号、およびポート番号を指定します。

port-channel number

(任意)テーブルから MAC アドレスを削除するポート チャネルを指定します。ポート チャネル番号を使用します。

vlan vlan_id

(任意)テーブルから MAC アドレスを削除する VLAN を指定します。有効値の範囲は、1 ~ 4094 です。

 
コマンドのデフォルト設定

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

テーブルからすべてのダイナミック エントリを削除するには、引数を指定せずに、 clear mac-address-table dynamic コマンドを使用します。

テーブルからスタティック MAC アドレスをクリアするには、コンフィギュレーション モードで no mac-address-table static コマンドを使用します。

オプションを指定しないで clear mac-address-table dynamic コマンドを入力すると、すべてのダイナミック アドレスが削除されます。アドレスを指定してインターフェイスを指定しないと、すべてのインターフェイスからアドレスが削除されます。インターフェイスを指定してアドレスを指定しないと、スイッチによって指定のインターフェイス上のすべてのアドレスが削除されます。

次に、MAC アドレス テーブルからすべてのダイナミック エントリをクリアする例を示します。

switch# clear mac-address-table dynamic

次に、VLAN 2 の MAC アドレス テーブルからすべてのダイナミック エントリをクリアする例を示します。

switch# clear mac-address-table dynamic vlan 2

 
関連コマンド

コマンド
説明

show mac-address-table

MAC アドレス テーブルに関する情報を表示します。

clear ntp session

Network Time Protocol(NTP; ネットワーク タイム プロトコル)セッションをクリアするには、 clear ntp session コマンドを使用します。

clear ntp session

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、進行中の NTP CFS 配信セッションを廃棄する例を示します。

switch# clear ntp session

 
関連コマンド

コマンド
説明

show ntp

NTP 情報を表示します。

clear ntp statistics

NTP セッションをクリアするには、 clear ntp session コマンドを使用します。

clear ntp statistics {all-peers | io | local | memory}

 
シンタックスの説明

all-peers

すべてのピア トランザクション統計情報をクリアします。

io

I/O 統計情報をクリアします。

local

ローカル統計情報をクリアします。

memory

メモリ統計情報をクリアします。

 
コマンドのデフォルト設定

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、NTP I/O 統計情報を廃棄する例を示します。

switch# clear ntp statistics io

 
関連コマンド

コマンド
説明

show ntp

NTP 情報を表示します。

clear spanning-tree counters

STP のカウンタをクリアするには、 clear spanning-tree counters コマンドを使用します。

clear spanning-tree counters [interface {ethernet interface-num | port-channel channel-num | vethernet interface-num }] [vlan vlan-id ]

 
シンタックスの説明

interface

(任意)インターフェイス タイプを指定します。

ethernet interface-num

スロット番号およびポート番号。

port-channel channel-num

ポート チャネル番号。

vethernet interface-num

スロット番号およびポート番号。

vlan vlan-id

(任意)VLAN を指定します。有効範囲は 1 ~ 4094 です。

 
コマンドのデフォルト設定

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

スイッチ全体、VLAN 単位、またはインターフェイス単位ですべての STP カウンタをクリアできます。

次に、VLAN 5 の STP カウンタをクリアする例を示します。

switch# clear spanning-tree counters vlan 5

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

clear spanning-tree detected-protocol

プロトコル移行を再開するには、 clear spanning-tree detected-protocol コマンドを使用します。引数を指定しない場合、コマンドはスイッチのすべてのポートに適用されます。

clear spanning-tree detected-protocol [interface {ethernet interface | port-channel channel | vethernet interface }]

 
シンタックスの説明

interface

(任意)インターフェイス タイプを指定します。

ethernet interface

スロット番号およびポート番号。

port-channel channel

ポート チャネル番号。

vethernet interface

スロット番号およびポート番号。

 
コマンドのデフォルト設定

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

Rapid per VLAN Spanning Tree Plus(Rapid PVST+)および Multiple Spanning Tree(MST)には、別バージョンの IEEE スパニング ツリーや別のリージョンとの適切な対話が可能になる組み込みの互換性メカニズムがあります。たとえば、Rapid PVST+ を実行しているスイッチは、ポートの 1 つがレガシー デバイスに接続されている場合には、そのポートで 802.1D Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)を送信できます。MST スイッチは、レガシー BPDU または別のリージョンと関連付けられた MST BPDU を受信すると、ポートがリージョンの境界に位置していることを検出できます。

ただし、これらのメカニズムにより、常に最も効率的なモードに戻れるわけではありません。たとえば、レガシー 802.1D ブリッジに指定された Rapid PVST+ スイッチは、レガシー ブリッジがリンクから取り外された後も 802.1D モードにとどまります。同様に、MST ポートは、接続先のブリッジが同じリージョンに参加している場合には自身を境界ポートとみなします。

ポートがネイバーと再ネゴシエーションするように強制するには、 clear spanning-tree detected-protocol コマンドを使用します。

次に、特定のインターフェイスでプロトコル移行を再開する例を示します。

switch# clear spanning-tree detected-protocol interface ethernet 1/4

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

feature interface-vlan

VLAN インターフェイスの作成をイネーブルにするには、 feature interface-vlan コマンドを使用します。VLAN インターフェイス機能をディセーブルにするには、このコマンドの no 形式を使用します。

feature interface-vlan

no feature interface-vlan

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

VLAN インターフェイスはディセーブルです。

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

VLAN インターフェイスを作成する前に、 feature interface-vlan または svi enable コマンドを使用してください。

次に、スイッチでインターフェイス上の VLAN 機能をイネーブルにする例を示します。

switch(config)# feature interface-vlan

 
関連コマンド

コマンド
説明

interface vlan

VLAN インターフェイスを作成します。

feature lacp

LACP をイネーブルにするには、 feature lacp コマンドを使用します。LACP は、複数の物理ポートをバンドルして単一の論理チャネルを作成します。スイッチで LACP をディセーブルにするには、このコマンドの no 形式を使用します。

feature lacp

no feature lacp

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

LACP はディセーブルです。

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

LACP をディセーブルにするには、まずスイッチのすべてのポート チャネルからすべての LACP 設定パラメータを削除する必要があります。

グローバルに LACP をイネーブルにした後でも、スイッチのすべてのポート チャネルで LACP を実行する必要はありません。 channel-group mode コマンドを使用して、各チャネル モードで LACP をイネーブルにします。

次に、スイッチで LACP ポート チャネリングをイネーブルにする例を示します。

switch(config)# feature lacp

 
関連コマンド

コマンド
説明

show lacp

LACP に関する情報を表示します。

feature private-vlan

プライベート VLAN をイネーブルにするには、 feature private-vlan コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

feature private-vlan

no feature private-vlan

 
シンタックスの説明

なし

 
コマンドのデフォルト設定

プライベート VLAN はディセーブルです。

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

4.0(0)N1(2)

仮想イーサネット ポートをプライベート VLAN ホスト ポートとして設定するサポートが利用可能になりました。

 
使用上のガイドライン

プライベート VLAN コマンドは、ユーザがプライベート VLAN 機能をイネーブルにするまで使用可能になりません。

プライベート VLAN モードのスイッチに動作中のポートがある場合は、プライベート VLAN をディセーブルにはできません。


) 最新リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチの PVLAN 独立ポートは、IEEE 802.1q カプセル化をサポートしておらず、トランク ポートとして使用することはできません。


次に、スイッチでプライベート VLAN 機能をイネーブルにする例を示します。

switch(config)# feature private-vlan

 
関連コマンド

コマンド
説明

private-vlan

VLAN をコミュニティ プライベート VLAN、独立 プライベート VLAN、プライマリ プライベート VLAN のいずれかに設定します。

show vlan private-vlan

プライベート VLAN に関する情報を表示します。機能がイネーブルになっていない場合には、このコマンドは使用できません。

instance vlan

VLAN または VLAN セットを Multiple Spanning Tree Instance(MSTI)にマッピングするには、 instance vlan コマンドを使用します。インスタンスを削除して、VLAN をデフォルト インスタンス(CIST)に戻すには、このコマンドの no 形式を使用します。

instance instance-id vlan vlan-id

no instance instance-id [vlan vlan-id ]

 
シンタックスの説明

instance-id

指定の VLAN がマッピングされるインスタンス。有効値の範囲は、0 ~ 4094 です。

vlan vlan-id

指定の MSTI にマッピングする VLAN の番号。有効値の範囲は、0 ~ 4094 です。

 
コマンドのデフォルト設定

VLAN はいずれの MST インスタンスにもマッピングされません(すべての VLAN は CIST インスタンスにマッピングされます)。

 
コマンド モード

MST コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

VLAN ID は、単一の値または範囲として入力します。

マッピングは、絶対的ではなく差分的に行われます。VLAN の範囲を入力すると、その範囲が既存のインスタンスに追加されるか、既存のインスタンスから削除されます。

マッピングされていない VLAN は、CIST インスタンスにマッピングされます。


注意 VLAN と MSTI のマッピングを変更すると、システムによって MST が再起動されます。

次に、VLAN 範囲を MSTI 4 にマッピングする例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)# instance 4 vlan 100-200

 
関連コマンド

コマンド
説明

show spanning-tree mst configuration

MST プロトコルに関する情報を表示します。

spanning-tree mst configuration

MST コンフィギュレーション モードを開始します。

interface ethernet

10 ギガビット イーサネット IEEE 802.3 インターフェイスのインターフェイス コンフィギュレーション モードを開始するには、 interface ethernet コマンドを使用します。

interface ethernet slot / port

 
シンタックスの説明

slot

1 ~ 3 のスロットを指定します。次のリストに使用可能なスロットを示します。

スロット 1 は、すべての固定ポートを含みます。

スロット 2 は、上部拡張モジュール(取り付けられている場合)のポートを含みます。

スロット 3 は、下部拡張モジュール(取り付けられている場合)のポートを含みます。

port

特定のスロット内のポート番号を指定します。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、イーサネット インターフェイス 1/4 のコンフィギュレーション モードを開始する例を示します。

switch(config)# interface ethernet 1/4
switch(config-if)#

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを設定します。

show interface ethernet

10 ギガビット イーサネット IEEE 802.3 インターフェイスのさまざまなパラメータを表示します。

interface port-channel

ポート チャネル インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface port-channel コマンドを使用します。論理ポート チャネル インターフェイスまたはサブインターフェイスを削除するには、このコマンドの no 形式を使用します。

interface port-channel channel-number

no interface port-channel channel-number

 
シンタックスの説明

channel-number

このポート チャネル論理インターフェイスに割り当てられているチャネル番号。有効値の範囲は、1 ~ 4096 です。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

ポートは、1 つのチャネル グループにのみ属すことができます。

インターフェイス ポート チャネル コマンドを使用するときは、次のガイドラインを守ってください。

CDP を使用する場合は、ポート チャネル インターフェイス上ではなく物理インターフェイス上でのみ設定します。

ポート チャネル インターフェイス上にスタティック MAC アドレスを割り当てない場合は、MAC アドレスが自動的に割り当てられます。スタティック MAC アドレスを割り当て、後で削除した場合は、MAC アドレスが自動的に割り当てられます。

ポート チャネルの MAC アドレスは、チャネル グループに追加される最初の動作ポートのアドレスです。この最初に追加されたポートがチャネルから削除されると、次に追加された動作ポート(存在する場合)の MAC アドレスになります。

次に、チャネル グループ番号 50 を持つポート チャネル グループ インターフェイスを作成する例を示します。

switch(config)# interface port-channel 50
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface port-channel

指定のポート チャネル インターフェイス上のトラフィックに関する情報を表示します。

show lacp

LACP 情報を表示します。

show port-channel summary

ポート チャネルに関する情報を表示します。

interface vethernet

仮想イーサネット インターフェイスのインターフェイス コンフィギュレーション モードを開始するには、 interface vethernet コマンドを使用します。

interface vethernet vig-num / port

 
シンタックスの説明

vig-num

仮想インターフェイス グループ(VIG)番号を指定します。あらかじめ VIG を作成しておく必要があります。

port

ポート番号の有効な値は、1 のみです。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、仮想イーサネット インターフェイス 16/1 のコンフィギュレーション モードを開始する例を示します。

switch(config)# interface vethernet 16/1
switch(config-if)#

 
関連コマンド

コマンド
説明

interface ethernet

10 ギガビット イーサネット IEEE 802.3 インターフェイスを設定します。

show interface vethernet

仮想イーサネット インターフェイスのさまざまなパラメータを表示します。

ip igmp snooping(EXEC)

Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)をイネーブルにするには、 ip igmp snooping コマンドを使用します。IGMP スヌーピングをディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp snooping

no ip igmp snooping

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

IGMP スヌーピングはイネーブルです。


) グローバル設定がディセーブルの場合は、VLAN がイネーブルであってもなくても、すべての VLAN がディセーブルとして扱われます。


 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、IGMP スヌーピングをイネーブルにする例を示します。

switch# ip igmp snooping

 
関連コマンド

コマンド
説明

show ip igmp snooping

IGMP スヌーピング情報および設定を表示します。

ip igmp snooping(VLAN)

VLAN で IGMP を設定するには、 ip igmp snooping コマンドを使用します。コマンドを無効にするか、デフォルト設定に戻すには、このコマンドの no 形式を使用します。

ip igmp snooping parameter

no ip igmp snooping parameter

 
シンタックスの説明

parameter

設定するパラメータ。追加情報については、「使用上のガイドライン」セクションを参照してください。

 
コマンドのデフォルト設定

デフォルト設定は、次のとおりです。

explicit-tracking ― イネーブル

fast-leave ― すべての VLAN についてディセーブル

last-member-query-interval seconds ― 1

querier IP-address ― ディセーブル

report-suppression ― イネーブル

 
コマンド モード

VLAN コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

パラメータ の有効な値は、次のとおりです。

キーワードおよび引数
説明

explicit-tracking

VLAN ベースで各ポートの IGMPv3 メンバーシップ レポートのトラッキングをイネーブルにします。すべての VLAN 上で、デフォルトはイネーブルです。

fast-leave

IGMPv3 スヌーピングの高速脱退処理をイネーブルにします。すべての VLAN 上で、デフォルトはディセーブルです。

last-member-query-interval seconds

すべてのホストが IGMP クエリ メッセージに応答しない場合は、グループを削除します。有効な値は 1 ~ 25 秒です。デフォルトは 1 秒です。

mrouter interface interface

マルチキャスト ルータへのスタティック接続を設定します。指定するインターフェイスは、イーサネットまたはポート チャネルです。

querier IP-address

スヌーピング クエリアを設定します。メッセージで送信元として IP アドレスを使用します。デフォルトはディセーブルです。

report-suppression

マルチキャスト対応ルータに送信されるメンバーシップ レポートのトラフィックを制限します。レポート抑制をディセーブルにすると、すべての IGMP レポートがそのままマルチキャスト対応ルータに送信されます。デフォルトはイネーブルです。

static-group group-ip-addr [ source source-ip-addr ] interface interface

マルチキャスト グループのスタティック メンバーとして VLAN に属すインターフェイスを設定します。指定のインターフェイスは、イーサネット、ポート チャネル、または仮想イーサネットです。

次に、VLAN 5 の IGMP スヌーピング パラメータを設定する例を示します。

switch# configure terminal
switch(config)# vlan 5
switch(config-vlan)# ip igmp snooping last-member-query-interval 3
switch(config-vlan)# ip igmp snooping querier 172.20.52.106
switch(config-vlan)# ip igmp snooping explicit-tracking
switch(config-vlan)# ip igmp snooping fast-leave
switch(config-vlan)# ip igmp snooping report-suppression
switch(config-vlan)# ip igmp snooping mrouter interface ethernet 1/10
switch(config-vlan)# ip igmp snooping static-group 230.0.0.1 interface ethernet 1/10
switch(config-vlan)# ip igmp snooping static-group 230.0.0.1 interface vethernet 4/1

 
関連コマンド

コマンド
説明

show ip igmp snooping

IGMP スヌーピング情報および設定を表示します。

lacp port-priority

LACP の物理インターフェイスのプライオリティを設定するには、 lacp port-priority コマンドを使用します。ポート プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

lacp port-priority priority

no lacp port-priority

 
シンタックスの説明

priority

物理インターフェイスのプライオリティ。有効値の範囲は、1 ~ 65535 です。

 
コマンドのデフォルト設定

システム プライオリティ値は 32768 です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

LACP を使用するように設定された各ポートは、LACP ポート プライオリティを持ちます。1 ~ 65535 の値を設定できます。LACP では、ポート プライオリティをポート番号と組み合わせて使用してポート ID を作成します。ポート プライオリティは、ポート ID を作成するためにポート番号とともに使用されます。ポート プライオリティは、ハードウェアに制約があることが原因で互換性のあるポートをすべて集約できない場合、どのポートをスタンバイ モードにするかを決めるために使用されます。


) プライオリティを設定するときには、番号が大きいほどプライオリティが低くなることに注意してください。


次に、インターフェイスの LACP ポート プライオリティを 2000 に設定する例を示します。

switch(config-if)# lacp port-priority 2000

 
関連コマンド

コマンド
説明

show lacp

LACP 情報を表示します。

lacp system-priority

スイッチの LACP システム プライオリティを設定するには、 lacp system-priority コマンドを使用します。システム プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

lacp system-priority priority

no lacp system-priority

 
シンタックスの説明

priority

物理インターフェイスのプライオリティ。有効値の範囲は、1 ~ 65535 です。

 
コマンドのデフォルト設定

システム プライオリティ値は 32768 です。

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

LACP を稼働する各デバイスは、LACP システム プライオリティ値を持ちます。1 ~ 65535 の値を設定できます。LACP では、システム プライオリティを MAC アドレスとともに使用してシステム ID を作成します。また、他のシステムとのネゴシエーション時にもシステム プライオリティを使用します。

プライオリティを設定するときには、番号が 大きい ほどプライオリティが 低く なることに注意してください。

次に、デバイスの LACP システム プライオリティを 2500 に設定する例を示します。

switch(config)# lacp system-priority 2500

 
関連コマンド

コマンド
説明

show lacp

LACP 情報を表示します。

mac-address-table aging-time

MAC アドレス テーブル エントリのエージング タイムを設定するには、 mac-address-table aging-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

mac-address-table aging-time seconds [vlan vlan_id ]

no mac-address-table aging-time [vlan vlan_id ]

 
シンタックスの説明

seconds

MAC アドレス テーブル エントリのエージング タイムを指定します。有効範囲は 0 ~ 1000000 秒です。デフォルトは 1800 秒です。ゼロ(0)を入力すると、MAC アドレス エージングがディセーブルになります。

vlan vlan_id

(任意)変更されたエージング タイムを適用する VLAN を指定します。

 
コマンドのデフォルト設定

300 秒

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

エージング プロセスをディセーブルにするには、ゼロ(0)を入力します。

エージング値は、5 秒の倍数に最も近い値に丸められます。システムによって丸められた値が、ユーザが指定した(丸め処理による)値と異なる場合、システムから情報メッセージが返されます。

このコマンドを EXEC モードで使用すると、設定を指定していないすべての VLAN のエージング値が変更され、個別にエージング タイムを変更した VLAN は変更されません。VLAN パラメータを指定しないで、このコマンドの no 形式を使用すると、個別にエージング タイムが設定されていない VLAN のみがデフォルトにリセットされます。個別にエージング タイムが変更されている VLAN は変更されません。

このコマンドを使用して VLAN を指定すると、指定した VLAN のエージング タイムだけが変更されます。このコマンドの no 形式を使用し、VLAN を指定すると、VLAN のエージング タイムが現在のエージング タイムのグローバル設定に戻ります。デフォルト値の 300 秒に戻るかどうかは、スイッチのエージング タイムのグローバル設定の変更の有無に応じて異なります。

エージング タイムは、スイッチが最後に MAC アドレスを検出した時点からカウントされます。

次に、スイッチ全体でエントリが MAC アドレス テーブルにとどまる時間を 500 秒に変更する例を示します。

switch(config)# mac-address-table aging-time 500

 
関連コマンド

コマンド
説明

show mac-address-table

MAC アドレス テーブルに関する情報を表示します。

show mac-address-table aging-time

MAC アドレスのエージング タイムに関する情報を表示します。

mac-address-table notification

MAC アドレス テーブル イベントのログ メッセージ通知を設定するには、 mac-address-table notification コマンドを使用します。ログ メッセージ通知をディセーブルにするには、このコマンドの no 形式を使用します。

mac-address-table notification {mac-move | threshold [limit percentage interval seconds ]}

no mac-address-table notification {mac-move | threshold}

 
シンタックスの説明

mac-move

MAC アドレスが移動された場合に、通知メッセージを送信します。

threshold

MAC アドレス テーブルのしきい値を超えた場合に、通知メッセージを送信します。

limit percentage

(任意)この割合を超えた時点でしきい値の通知を送信する、割合の上限(1 ~ 100)を指定します。

interval seconds

(任意)連続する 2 つの通知間の最小時間を秒単位で指定します(10 ~ 10000 秒)。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、しきい値が 45% を超えたときにログ メッセージ通知が送信され、アップデート間隔が 1024 秒に 1 回に制限されるように設定する例を示します。

switch(config)# mac-address-table notification threshold limit 45 interval 1024

 
関連コマンド

コマンド
説明

show mac-address-table

MAC アドレス テーブルに関する情報を表示します。

mac-address-table static

MAC アドレス テーブルのスタティック エントリを設定するには、 mac-address-table static コマンドを使用します。スタティック エントリを削除するには、このコマンドの no 形式を使用します。

mac-address-table static mac_address vlan vlan_id {drop | interface { type slot / port | port-channel number } [auto-learn]

no mac-address-table static mac_address {vlan vlan_id }

 
シンタックスの説明

mac_address

テーブルに追加する MAC アドレスを指定します。EEEE.EEEE.EEEE の形式を使用します。

vlan vlan_id

スタティック MAC アドレスを適用する VLAN を指定します。有効な値は 1 ~ 4094 です。

drop

指定の VLAN 内の設定済みの MAC アドレスとの間で送受信されるすべてのトラフィックをドロップします。

interface type slot / port

インターフェイスを指定します。タイプは、ethernet または vethernet のいずれかにできます。適切なスロット番号または仮想インターフェイス グループ番号、およびポート番号を指定します。

port-channel number

インターフェイスを指定します。ポート チャネル番号を使用します。

auto-learn

(任意)この MAC アドレスの移動を許可します。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

マルチキャスト MAC アドレスには、 mac-address-table static mac_address vlan vlan_id drop コマンドは適用できません。

スタティック MAC アドレスをインストールすると、スタティック MAC アドレスはポートに関連付けられます。別のポートに同じ MAC アドレスが表示される場合には、 auto-learn キーワードを入力すると、エントリが新しいポートによってアップデートされます。

次に、スタティック エントリを MAC アドレス テーブルに追加する例を示します。

switch(config)# mac-address-table static 0050.3e8d.6400 vlan 3 interface ethernet 1/4

 
関連コマンド

コマンド
説明

show mac-address-table

MAC アドレス テーブルに関する情報を表示します。

monitor session

新しい SPAN セッション設定を作成する場合や既存のセッション設定に追加する場合は、 monitor session コマンドを使用します。SPAN セッションをクリアするには、このコマンドの no 形式を使用します。

monitor session { number | all} [suspend]

no monitor session { number | all} [suspend]

 
シンタックスの説明

number

作成または設定する SPAN セッションを指定します。セッション 1 ~ 18 を選択します。

all

設定情報をすべての SPAN セッションに適用するように指定します。

suspend

(任意)参照されている SPAN セッションを一時停止するように指定します。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

完全に新しいセッションを利用できるように、任意のセッション番号またはすべての SPAN セッションをクリアできます。

次に、SPAN セッションを作成する例を示します。

switch# configure terminal
switch(config)# monitor session 2

 
関連コマンド

コマンド
説明

show monitor session

SPAN セッション設定情報を表示します。

name(VLAN コンフィギュレーション)

VLAN の名前を設定するには、 name コマンドを使用します。ユーザが設定した名前を VLAN から削除するには、このコマンドの no 形式を使用します。

name vlan_name

no name

 
シンタックスの説明

vlan_name

VLAN の名前。最大で 32 文字の英数字を使用でき、大文字と小文字が区別されます。デフォルト名は、VLAN xxxx です(例:VLAN0002)。 xxxx は、VLAN ID 番号と同じ 4 桁の数字を表します(先頭のゼロも含みます)。

 
コマンドのデフォルト設定

なし

 
コマンド モード

VLAN コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

デフォルト VLAN、VLAN 1、または内部的に割り当てられている VLAN の名前は変更できません。

次に、VLAN 2 に名前を付ける例を示します。

switch(config)# vlan 2
switch(config-vlan)# name accounting

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

name(MST コンフィギュレーション)

MST リージョンの名前を設定するには、 name コマンドを使用します。デフォルト名に戻すには、このコマンドの no 形式を使用します。

name name

no name name

 
シンタックスの説明

name

MST リージョンに割り当てる名前。最大 32 文字の英数字からなる任意のストリングにできます。

 
コマンドのデフォルト設定

なし

 
コマンド モード

MST コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

同じ VLAN マッピングと設定バージョン番号を持つ 2 台以上のスイッチは、リージョン名が異なる場合には、別々の MST リージョンにあるとみなされます。


注意 name コマンドを使用して MST リージョン名を設定する場合には注意してください。設定を間違えると、スイッチが別のリージョンに配置されてしまう可能性があります。設定名は、大文字と小文字が区別されるパラメータです。

次に、リージョンに名前を付ける例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)# name accounting

 
関連コマンド

コマンド
説明

show spanning-tree mst configuration

MST プロトコルに関する情報を表示します。

spanning-tree mst configuration

MST コンフィギュレーション モードを開始します。

ntp

スイッチの NTP ピアおよび NTP サーバを設定するには、 ntp コマンドを使用します。設定済みのピアおよびサーバを削除するには、このコマンドの no 形式を使用します。

ntp {peer hostname | server hostname }

no ntp {peer hostname | server hostname }

 
シンタックスの説明

peer hostname

NTP ピアのホスト名または IP アドレス。

server hostname

NTP サーバのホスト名または IP アドレス。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、サーバとのサーバ アソシエーションを作成する例を示します。

switch(config)# ntp server ntp.cisco.com

複数のアソシエーションを指定できます。次に、ピアとのピア アソシエーションを作成する例を示します。

switch(config)# ntp peer 10.20.10.0

次に、ピアとのアソシエーションを削除する例を示します。

switch(config)# no ntp peer 10.20.10.0

 
関連コマンド

コマンド
説明

ntp distribute

NTP の CFS 配信をイネーブルにします。

show ntp

NTP 情報を表示します。

ntp abort

進行中の NTP Cisco Fabric Services(CFS)配信セッションを廃棄するには、 ntp abort コマンドを使用します。

ntp abort

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、進行中の NTP CFS 配信セッションを廃棄する例を示します。

switch(config)# ntp abort

 
関連コマンド

コマンド
説明

ntp distribute

NTP の CFS 配信をイネーブルにします。

show ntp

NTP 情報を表示します。

ntp commit

ファブリック内で進行中の NTP CFS 配信セッションに関する未決定コンフィギュレーションを適用するには、 ntp commit コマンドを使用します。

ntp commit

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、アクティブ NTP コンフィギュレーションへの変更を確定する例を示します。

switch(config)# ntp commit

 
関連コマンド

コマンド
説明

ntp distribute

NTP の CFS 配信をイネーブルにします。

show ntp

NTP 情報を表示します。

ntp distribute

NTP CFS 配信をイネーブルにするには、 ntp distribute コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ntp distribute

no ntp distribute

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

ディセーブル

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

ファイバ チャネル タイマーの変更をファブリックに配信する前に、 ntp commit コマンドを使用して、コンフィギュレーションへの一時的な変更をアクティブ コンフィギュレーションに確定する必要があります。

次に、アクティブ NTP コンフィギュレーションをファブリックに配信する例を示します。

switch(config)# ntp distribute

 
関連コマンド

コマンド
説明

ntp commit

NTP コンフィギュレーションの変更をアクティブ コンフィギュレーションに確定します。

show ntp

NTP 情報を表示します。

ntp sync-retry

設定されている NTP サーバとの同期を再試行するには、 ntp sync-retry コマンドを使用します。

ntp sync-retry

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、設定されている NTP サーバとの同期を再試行する例を示します。

switch# ntp sync-retry

 
関連コマンド

コマンド
説明

ntp distribute

NTP の CFS 配信をイネーブルにします。

show ntp

NTP 情報を表示します。

port-channel load-balance ethernet

チャネル グループ バンドルのインターフェイス間でロード バランシング方式を設定するには、 port-channel load-balance ethernet コマンドを使用します。システム プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

port-channel load-balance ethernet method

no port-channel load-balance ethernet [ method ]

 
シンタックスの説明

method

ロード バランシング方式。有効値のリストについては、「使用上のガイドライン」セクションを参照してください。

 
コマンドのデフォルト設定

送信元および宛先 MAC アドレスの負荷分散。

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

有効なロード バランシング method 値は、次のとおりです。

destination-ip ― 宛先 IP アドレスの負荷分散。

destination-mac ― 宛先 MAC アドレスの負荷分散。

destination-port ― 宛先ポートの負荷分散。

source-destination-ip ― 送信元および宛先 IP アドレスの負荷分散。

source-destination-mac ― 送信元および宛先 MAC アドレスの負荷分散。

source-destination-port ― 送信元および宛先ポートの負荷分散。

source-ip ― 送信元 IP アドレスの負荷分散。

source-mac ― 送信元 MAC アドレスの負荷分散。

source-port ― 送信元ポートの負荷分散。

使用する設定で最多の種類のバランシング条件を提供するオプションを使用してください。たとえば、ポート チャネルのトラフィックが 1 つだけの MAC アドレスに送信され、ポート チャネル ロード バランシングが宛先 MAC アドレスに基づいて実行されている場合、ポート チャネルは常にそのポート チャネルの同一リンクを選択します。その場合は、送信元アドレスまたは IP アドレスを使用する方が、より有効なロードバランシングを実現できる可能性があります。

次に、送信元 IP を使用するロード バランシング方式を設定する例を示します。

switch(config)# port-channel load-balance ethernet source-ip

 
関連コマンド

コマンド
説明

show port-channel load-balance

ポート チャネル ロード バランシングに関する情報を表示します。

private-vlan

プライベート VLAN を設定するには、 private-vlan コマンドを使用します。指定の VLAN を標準 VLAN モードに戻すには、このコマンドの no 形式を使用します。.

private-vlan {isolated | community | primary}

no private-vlan {isolated | community | primary}

 
シンタックスの説明

isolated

VLAN を独立セカンダリ VLAN として指定します。

community

VLAN をコミュニティ セカンダリ VLAN として指定します。

primary

VLAN をプライマリ VLAN として指定します。

 
コマンドのデフォルト設定

なし

 
コマンド モード

VLAN コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

4.0(0)N1(2)

仮想イーサネット ポートをプライベート VLAN ホスト ポートとして設定するサポートが利用可能になりました。

 
使用上のガイドライン

プライベート VLAN を設定する前に、feature private-vlan コマンドを使用してプライベート VLAN をイネーブルにしてください。プライベート VLAN をイネーブルにするまで、プライベート VLAN の設定コマンドは表示されません。

プライマリ VLAN またはセカンダリ VLAN のいずれかを削除すると、その VLAN に関連付けられているポートは非アクティブになります。 no private-vlan コマンドを入力すると、VLAN が標準 VLAN モードに戻ります。その VLAN のすべてのプライマリおよびセカンダリ アソシエーションが一時停止されますが、インターフェイスはプライベート VLAN モードのままです。指定の VLAN をプライベート VLAN モードに再変換すると、元のアソシエーションが復元されます。

プライマリ VLAN に対して no vlan コマンドを入力すると、その VLAN とのすべてのプライベート VLAN アソシエーションが失われます。セカンダリ VLAN に対して no vlan コマンドを入力すると、その VLAN とのプライベート VLAN アソシエーションが一時停止されます。指定の VLAN を再作成し、以前のセカンダリ VLAN として設定すると、再度イネーブルになります。

VLAN1 または内部的に割り当てられている VLAN は、プライベート VLAN として設定できません。

プライベート VLAN は、VLAN 番号ペアの共通セットを使用することを特徴とするプライベート ポートのセットです。各ペアは、少なくとも 2 つの特別な単方向 VLAN から構成され、ルータと通信するために独立ポートまたはコミュニティ ポートが使用します

独立 VLAN は、混合モード ポートと通信するために独立ポートが使用する VLAN です。独立 VLAN のトラフィックは、同じ VLAN の他のすべてのプライベート ポートでブロックされ、対応するプライマリ VLAN に割り当てられた標準トランキング ポートおよび混合モード ポートによってのみ受信できます。

混合モード ポートは、プライマリ VLAN に割り当てられたプライベート ポートです。

コミュニティ VLAN は、対応するプライマリ VLAN 上にある、コミュニティポート間のトラフィックおよびコミュニティ ポートから混合モード ポートへのトラフィックを運ぶ VLAN です。

プライマリ VLAN は、トラフィックをルータからプライベート ポート上の顧客端末ステーションへ伝送するために使用される VLAN です。

複数のコミュニティ VLAN および独立 VLAN が許可されます。プライマリ VLAN 範囲を入力すると、システムによって範囲の最初の番号がアソシエーション用に使用されます。


) 最新リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチの PVLAN 独立ポートは、IEEE 802.1q カプセル化をサポートしておらず、トランク ポートとしては使用できません。


次に、VLAN 5 をプライマリ VLAN としてプライベート VLAN に割り当てる例を示します。

switch# configure terminal
switch(config)# vlan 5
switch(config-vlan)# private-vlan primary

次に、VLAN 100 をコミュニティ VLAN としてプライベート VLAN に割り当てる例を示します。

switch(config-vlan)# exit
switch(config)# vlan 100
switch(config-vlan)# private-vlan community

次に、VLAN 109 を独立 VLAN としてプライベート VLAN に割り当てる例を示します。

switch(config-vlan)# exit
switch(config)# vlan 109
switch(config-vlan)# private-vlan isolated

 
関連コマンド

コマンド
説明

feature private-vlan

プライベート VLAN をイネーブルにします。

show vlan

VLAN に関する情報を表示します。

show vlan private-vlan

プライベート VLAN に関する情報を表示します。

private-vlan association

プライベート VLAN 上のプライマリ VLAN とセカンダリ VLAN 間のアソシエーションを設定するには、 private-vlan association コマンドを使用します。アソシエーションを削除するには、このコマンドの no 形式を使用します。

private-vlan association {[add] secondary_vlan_list | remove secondary_vlan_list }

no private-vlan association

 
シンタックスの説明

add

(任意)セカンダリ VLAN をプライマリ VLAN に関連付けます。

secondary_vlan_list

セカンダリ VLAN の番号。

remove

セカンダリ VLAN とプライマリ VLAN 間のアソシエーションをクリアします。

 
コマンドのデフォルト設定

なし

 
コマンド モード

VLAN コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

プライベート VLAN を設定する前に、feature private-vlan コマンドを使用してプライベート VLAN をイネーブルにしてください。プライベート VLAN をイネーブルにするまで、プライベート VLAN の設定コマンドは表示されません。

プライマリ VLAN またはセカンダリ VLAN のいずれかを削除すると、その VLAN に関連付けられているポートは非アクティブになります。 no private-vlan コマンドを入力すると、VLAN が標準 VLAN モードに戻ります。その VLAN のすべてのプライマリおよびセカンダリ アソシエーションが一時停止されますが、インターフェイスはプライベート VLAN モードのままです。ただし、指定した VLAN をプライベート VLAN モードに再変換すると、元のアソシエーションが復元されます。

プライマリ VLAN に対して no vlan コマンドを入力すると、その VLAN とのすべてのプライベート VLAN アソシエーションが失われます。一方、セカンダリ VLAN に対して no vlan コマンドを入力すると、その VLAN とのプライベート VLAN アソシエーションが一時停止されます。指定の VLAN を再作成し、以前のセカンダリ VLAN として設定すると復元されます。

secondary_vlan_list 引数にスペースを含めることはできません。カンマで区切って複数の項目を指定できます。各項目は、単一のセカンダリ VLAN ID またはハイフンで指定したセカンダリ VLAN ID 範囲です。 secondary_vlan_list パラメータには、複数のセカンダリ VLAN ID を含められます。

プライベート VLAN は、VLAN 番号ペアの共通セットを使用することを特徴とするプライベート ポートのセットです。各ペアは、少なくとも 2 つの特別な単方向 VLAN から構成され、ルータと通信するために独立ポートまたはコミュニティ ポートが使用します

複数のコミュニティ VLAN および独立 VLAN が許可されます。プライマリ VLAN 範囲を入力すると、システムによって範囲の最初の番号がアソシエーション用に使用されます。

独立 VLAN およびコミュニティ VLAN は、1 つのプライマリ VLAN とのみ関連付けられます。すでにプライマリ VLAN としてプライマリ VLAN に関連付けられている VLAN を設定することはできません。


) 最新リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチの PVLAN 独立ポートは、IEEE 802.1q カプセル化をサポートしておらず、トランク ポートとしては使用できません。


次に、プライマリ VLAN 14、独立 VLAN 19、およびコミュニティ VLAN 20 と 21 間のプライベート VLAN 関係を作成する例を示します。

switch(config)# vlan 19
switch(config-vlan)# private-vlan isolated
switch(config)# vlan 20
switch(config-vlan)# private-vlan community
switch(config)# vlan 21
switch(config-vlan)# private-vlan community
switch(config)# vlan 14
switch(config-vlan)# private-vlan primary
switch(config-vlan)# private-vlan association 19-21

次に、プライベート VLAN アソシエーションから独立 VLAN 18 およびコミュニティ VLAN 20 を削除する例を示します。

switch(config)# vlan 14
switch(config-vlan)# private-vlan association remove 18,20

 
関連コマンド

コマンド
説明

feature private-vlan

プライベート VLAN をイネーブルにします。

show vlan

VLAN に関する情報を表示します。

show vlan private-vlan

プライベート VLAN に関する情報を表示します。

private-vlan synchronize

セカンダリ VLAN をプライマリ VLAN として同じ MST インスタンスにマッピングするには、 private-vlan synchronize コマンドを使用します。

private-vlan synchronize

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

なし

 
コマンド モード

MST コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

関連付けられたプライマリ VLAN として、セカンダリ VLAN を同じ MST インスタンスにマッピングしていない場合、MST コンフィギュレーション モードの終了時に警告メッセージが表示され、関連付けられた VLAN として同じインスタンスにマッピングされていないセカンダリ VLAN のリストが示されます。 private-vlan synchronize コマンドを使用すると、すべてのセカンダリ VLAN が、関連付けられたプライマリ VLAN として自動的に同じインスタンスにマッピングされます。

次に、PVLAN 同期を初期化する例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)# private-vlan synchronize

 
関連コマンド

コマンド
説明

show spanning-tree mst configuration

MST プロトコルに関する情報を表示します。

spanning-tree mst configuration

MST コンフィギュレーション モードを開始します。

revision

MST リージョン コンフィギュレーションのリビジョン番号を設定するには、 revision コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

revision version

no revision version

 
シンタックスの説明

version

MST リージョン コンフィギュレーションのリビジョン番号。有効値の範囲は 0 ~ 65535 です。

 
コマンドのデフォルト設定

リビジョン 0

 
コマンド モード

MST コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

同じ VLAN マッピングと名前を持つ 2 台以上のスイッチは、コンフィギュレーション リビジョン番号が異なる場合には、別々の MST リージョンにあるとみなされます。


注意 設定を間違えるとスイッチが別のリージョンに配置されてしまう可能性があるので、revision コマンドを使用して MST リージョン コンフィギュレーションのリビジョン番号を設定する場合は注意してください。

次に、MST リージョン コンフィギュレーションのリビジョン番号を設定する例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)# revision 5

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

shutdown(VLAN コンフィギュレーション)

VLAN 上のローカル トラフィックをシャットダウンするには、 shutdown コマンドを使用します。VLAN をデフォルトの動作ステートに戻すには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

シャットダウンしません。

 
コマンド モード

VLAN コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

VLAN 1 または VLAN 1006 ~ 4094 は、シャットダウンしたりディセーブルにしたりできません。

VLAN をシャットダウンすると、その VLAN 上でトラフィックがフローを終了します。VLAN 上のアクセス ポートもダウンします。トランク ポートは、そのポートで許可されている他の VLAN へのトラフィック搬送を継続します。一方、指定の VLAN のインターフェイス アソシエーションは保持されます。その指定の VLAN を再度イネーブルにするか再作成すると、スイッチによってその VLAN の元のポートがすべて自動的に復元されます。

VLAN が内部的にシャットダウンされているかどうかを調べるには、 show vlan コマンド出力のステータス フィールドをチェックします。VLAN が内部的にシャットダウンされている場合は、ステータス フィールドに次の値のいずれか 1 つが表示されます。

act/lshut ― VLAN ステータスはアクティブですが、内部的にシャットダウンされています。

sus/lshut ― VLAN ステータスは一時停止ですが、内部的にシャットダウンされています。


) VLAN が一時停止およびシャットダウンされている場合は、no shutdown および state active コマンドの両方を使用して VLAN をアクティブ ステートに戻します。


次に、VLAN をシャットダウンまたはディセーブルにした後、VLAN 2 上のローカル トラフィックを復元する例を示します。

switch(config)# vlan 2
switch(config-vlan)# no shutdown

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

spanning-tree bpdufilter

インターフェイス上で BPDU フィルタリングをイネーブルにするには、 spanning-tree bpdufilter コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree bpdufilter {enable | disable}

no spanning-tree bpdufilter

 
シンタックスの説明

enable

このインターフェイス上で BPDU フィルタリングをイネーブルにします。

disable

このインターフェイス上で BPDU フィルタリングをディセーブルにします。

 
コマンドのデフォルト設定

spanning-tree port type edge bpdufilter default コマンドの入力時点ですでに設定されている設定。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

spanning-tree bpdufilter enable コマンドを入力して BPDU フィルタリングをイネーブルにすると、スパニング ツリー エッジ ポート設定が上書きされます。そのポートは、標準スパニング ツリー ポート タイプに戻り、標準スパニング ツリーの遷移をたどります。


注意 指定のインターフェイスで spanning-tree bpdufilter enable コマンドを入力する場合は注意してください。ホストに接続されていないポート上で BPDU フィルタリングを明示的に設定すると、そのポートはすべての受信 BPDU を無視することになるので、ブリッジング ループが生じ、ポートが STP フォワーディング ステートに移行する可能性があります。

すべてのスパニング ツリー エッジ ポート上で BPDU フィルタリングをイネーブルにするには、 spanning-tree port type edge bpdufilter default コマンドを使用します。

次に、イーサネット スパニング ツリー エッジ ポート 1/4 上で BPDU フィルタリングを明示的にイネーブルにする例を示します。

switch (config)# interface ethernet 1/4
switch(config-if)# spanning-tree bpdufilter enable

次に、仮想イーサネット インターフェイス上で BPDU フィルタリングを明示的にイネーブルにする例を示します。

switch (config)# interface vethernet 4/1
switch(config-if)# spanning-tree bpdufilter enable

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

spanning-tree bpduguard

インターフェイス上で BPDU ガードをイネーブルにするには、 spanning-tree bpduguard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree bpduguard {enable | disable}

no spanning-tree bpduguard

 
シンタックスの説明

enable

このインターフェイス上で BPDU ガードをイネーブルにします。

disable

このインターフェイス上で BPDU ガードをディセーブルにします。

 
コマンドのデフォルト設定

spanning-tree port type edge bpduguard default コマンドの入力時点ですでに設定されている設定。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

BPDU ガードにより、ポートは BPDU を受信しなくなります。ポートが引き続き BPDU を受信する場合は、保護対策としてポートが error-disabled ステートに置かれます。


注意 このコマンドを使用するときには注意してください。このコマンドは、端末に接続されているインターフェイスに対してのみ使用してください。それ以外の場合は、予想外のトポロジー ループが原因でデータ パケット ループが発生し、スイッチおよびネットワークの動作が中断する可能性があります。

この BPDU ガード コマンドをグローバルにイネーブルにすると、スパニング ツリー エッジ ポートにのみこのコマンドが適用されます。BPDU ガードのグローバル コマンドについての詳細は、 spanning-tree port type edge bpduguard default を参照してください。一方、インターフェイス上でこの機能をイネーブルにすると、スパニング ツリー ポート タイプに関わらず、そのインターフェイスに機能が適用されます。

このコマンドには、次の 3 つのステートがあります。

spanning-tree bpduguard enable ― インターフェイス上で BPDU ガードを無条件でイネーブルにします。

spanning-tree bpduguard disable ― インターフェイス上で BPDU ガードを無条件でディセーブルにします。

no spanning-tree bpduguard ― インターフェイスが動作中のスパニング ツリー エッジ ポートであり、 spanning-tree port type edge bpduguard default コマンドが設定されていれば、インターフェイス上で BPDU ガードをイネーブルにします。

通常、この機能は、アクセス ポートがスパニング ツリーに参加しないようにネットワーク管理者によって設定されるサービス プロバイダの環境で使用されます。

次に、このインターフェイス上で BPDU ガードをイネーブルにする例を示します。

switch(config-if)# spanning-tree bpduguard enable

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

spanning-tree cost

STP 計算用にインターフェイスのパス コストを設定するには、 spanning-tree cost コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree [vlan vlan_id ] cost { value | auto}

no spanning-tree [vlan vlan_id ] cost

 
シンタックスの説明

vlan vlan_id

(任意)パス コストを割り当てるこのトランク インターフェイス上の VLAN のリストを示します。このパラメータは、アクセス ポートでは使用しません。有効範囲は 1 ~ 4094 です。

value

ポート コストの値。使用可能なコスト範囲は、次に示すパス コスト計算方式によって異なります。

short ― 有効範囲は 1 ~ 65536 です。

long ― 有効範囲は 1 ~ 200,000,000 です。

auto

インターフェイスのメディア速度によってポート コストの値を設定します(値については、 表2-1 を参照)。

 
コマンドのデフォルト設定

メディア速度によってポート コストが設定されます。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

STP ポート パス コストのデフォルト値は、LAN インターフェイスのメディア速度とパス コスト計算方式によって決まります( 表2-1 を参照)。Rapid PVST+ のパス コスト計算方式の設定については、 spanning-tree pathcost method コマンドを参照してください。

 

表2-1 デフォルトのポート コスト

帯域幅
ショート パス コスト方式のポート コスト
ロング パス コスト方式の
ポート コスト

10 Mbps

100

2,000,000

100 Mbps

19

200,000

1 ギガビット イーサネット

4

20,000

10 ギガビット イーサネット

2

2,000

value を設定するときは、高い値ほどコストが高くなります。

アクセス ポートでは、ポート コストをポートごとに割り当てます。トランク ポートでは、ポート コストを VLAN ごとに割り当てます。トランク ポートのすべての VLAN を同じポート コストに設定できます。

ポート チャネル バンドルは、単一ポートとみなされます。ポート コストは、そのチャネルに割り当てられている設定済みのすべてのポート コストの合計です。


) このコマンドを使用して Rapid PVST+ のポート コストを設定します。MST のポート コストを設定するには、spanning-tree mst cost コマンドを使用します。


次に、インターフェイスにアクセスして、そのインターフェイスに関連付けられているスパニング ツリー VLAN に 250 の値のパス コストを設定する例を示します。

switch(config)# interface ethernet 1/4
switch(config-if)# spanning-tree cost 250

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー設定に関する情報を表示します。

spanning-tree guard

ループ ガードまたはルート ガードをイネーブルまたはディセーブルにするには、 spanning-tree guard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree guard {loop | none | root}

no spanning-tree guard

 
シンタックスの説明

loop

インターフェイス上で ループ ガードをイネーブルにします。

none

ガード モードを None に設定します。

root

インターフェイス上で ルート ガードをイネーブルにします。

 
コマンドのデフォルト設定

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

スパニング ツリー エッジ ポート上でループ ガードをイネーブルにするコマンドはスイッチによって受け入れられますが、ルート ガードがイネーブルになっている場合はループ ガードをイネーブルにすることはできません。

次に、ルート ガードをイネーブルにする例を示します。

switch(config-if)# spanning-tree guard root

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

spanning-tree link-type

ポートのリンク タイプを設定するには、 spanning-tree link-type コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree link-type {auto | point-to-point | shared}

no spanning-tree link-type

 
シンタックスの説明

auto

インターフェイスのデュプレックス設定に基づいてリンク タイプを設定します。

point-to-point

インターフェイスが point-to-point(p2p; ポイントツーポイント)リンクになるように指定します。

shared

インターフェイスが共有メディアになるように指定します。

 
コマンドのデフォルト設定

デュプレックス設定に基づいて自動的に設定されるリンク タイプ。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

高速過渡(IEEE 802.1w で規定)は、2 つのブリッジ間の p2p リンク上でのみ機能します。

デフォルトでは、スイッチはデュプレックス モードからポートのリンク タイプを判断します。つまり、全二重ポートは p2p リンクとみなされ、半二重設定は共有リンク上にあるとみなされます。


) Cisco Nexus 5000 シリーズ スイッチでは、ポート デュプレックスを設定できません。


次に、ポートを共有リンクとして設定する例を示します。

switch(config-if)# spanning-tree link-type shared

 
関連コマンド

コマンド
説明

show spanning-tree interface

スパニング ツリー ステートに関する情報を表示します。

spanning-tree loopguard default

ループ ガードを、すべての標準スパニング ツリーおよびネットワーク ポート上でデフォルトとしてイネーブルにするには、 spanning-tree loopguard default コマンドを使用します。ループ ガードをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree loopguard default

no spanning-tree loopguard default

 
シンタックスの説明

このコマンドには、追加の引数またはキーワードはありません。

 
コマンドのデフォルト設定

ディセーブル

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

ループ ガードは、ブリッジ ネットワークのセキュリティを強化します。ループ ガードを使用すると、障害による単方向リンクが原因で、代替ポートまたはルート ポートが指定ポートになるのを防止できます。

ループ ガードは、スパニング ツリーによって p2p リンクとみなされるポートでのみ動作し、スパニング ツリー エッジ ポート上では稼働しません。

指定のインターフェイスでループ ガード コマンドの spanning-tree guard loop を入力すると、このグローバル ループ ガード コマンドが上書きされます。

次に、ループ ガードをイネーブルにする例を示します。

switch(config)# spanning-tree loopguard default

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

spanning-tree mode

Rapid per VLAN Spanning Tree Plus(Rapid PVST+)モードと MST STP モードを切り替えるには、 spanning-tree mode コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mode {rapid-pvst | mst}

no spanning-tree mode

 
シンタックスの説明

rapid-pvst

STP モードを Rapid PVST+ に設定します。

mst

STP モードを MST に設定します。

 
コマンドのデフォルト設定

Rapid PVST+

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

スイッチ上で MST と Rapid PVST+ を同時に実行することはできません。


注意 spanning-tree mode コマンドを使用して、Rapid PVST+ モードと MST モードを切り替えるときには注意してください。コマンドを入力すると、以前のモードのすべての STP インスタンスが停止して、新しいモードで再開されます。このコマンドの使用は、ユーザ トラフィックを妨げる可能性があります。

次に、MST モードに切り替える例を示します。

switch(config)# spanning-tree mode mst
switch(config-mst)#

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree mst configuration

MST コンフィギュレーション モードを開始するには、 spanning-tree mst configuration コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst configuration

no spanning-tree mst configuration

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

次の MST コンフィギュレーションのデフォルト値は、その全パラメータのデフォルト値となります。

VLAN はいずれの MST インスタンスにもマッピングされません(すべての VLAN は CIST インスタンスにマッピングされます)。

リージョン名は空のストリングです。

リビジョン番号は 0 です。

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

MST コンフィギュレーションは、次の 3 つの主要パラメータから構成されます。

Instance VLAN mapping ― instance vlan コマンドを参照してください。

Region name ― name(MST コンフィギュレーション) コマンドを参照してください。

Configuration revision number ― revision コマンドを参照してください。

abort および exit コマンドを使用して、MST コンフィギュレーション モードを終了できます。2 つのコマンドは、変更を保存するかどうかの点で違いがあります。

exit コマンドを使用すると、MST コンフィギュレーション モードを終了する前にすべての変更が確定されます。

abort コマンドを使用すると、変更は確定されないで MST コンフィギュレーション モードが終了します。

関連付けられたプライマリ VLAN として同じインスタンスにセカンダリ VLAN をマッピングしていない場合は、MST コンフィギュレーション モードの終了時に次の警告メッセージが表示されます。

These secondary vlans are not mapped to the same instance as their primary:
-> 3
 

switchport mode private-vlan host コマンドを参照して、この問題を修正してください。

MST コンフィギュレーション モード パラメータを変更すると、接続が失われる可能性があります。サービスの中断を最小限に抑えるために、MST コンフィギュレーション モードを開始したら、現在の MST コンフィギュレーションのコピーに変更を行ってください。コンフィギュレーションの編集が終了したら、exit キーワードを使用して、すべての変更を一度に適用できます。

万一、二人の管理者がまったく同時に新しいコンフィギュレーションを確定した場合は、次の警告メッセージが表示されます。

% MST CFG:Configuration change lost because of concurrent access

次に、MST コンフィギュレーション モードを開始する例を示します。

switch(config)# spanning-tree mst configuration
switch(config-mst)#

次に、MST コンフィギュレーション(名前、インスタンス マッピング、およびリビジョン番号)をデフォルト設定にリセットする例を示します。

switch(config)# no spanning-tree mst configuration

 
関連コマンド

コマンド
説明

instance vlan

VLAN または VLAN セットを MST インスタンスにマッピングします。

name(MST コンフィギュレーション)

MST リージョンの名前を設定します。

revision

MST コンフィギュレーションのリビジョン番号を設定します。

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst cost

MST インスタンス(インスタンス ID が 0 の Common and Internal Spanning Tree [CIST] も含む)のパス コスト パラメータを設定するには、 spanning-tree mst cost コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance_id cost { cost | auto}

no spanning-tree mst instance_id cost

 
シンタックスの説明

instance_id

インスタンス ID 番号。有効値の範囲は、0 ~ 4094 です。

cost

インスタンスのポート コスト。有効値の範囲は、1 ~ 200,000,000 です。

auto

インターフェイスのメディア速度によってポート コストの値を設定します。

 
コマンドのデフォルト設定

次のポート コスト値を自動的に設定します。

10 Mbps ― 2,000,000

100 Mbps ― 200,000

1 ギガビット イーサネット ― 20,000

10 ギガビット イーサネット ― 2,000

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

ポート コストは、ポート速度に応じて異なります。インターフェイス速度が速いほど、コスト値は小さくなります。MST は、常にロング パス コストを使用します。

コスト値が大きいほど、コストが高くなります。コストを入力する際はカンマを入力しないでください。たとえば、1,000 ではなく 1000 と入力します。

ポート チャネル バンドルは、単一ポートとみなされます。ポート コストは、そのチャネルに割り当てられている設定済みのすべてのポート コストの合計です。

次に、インターフェイス パス コストを設定する例を示します。

switch(config-if)# spanning-tree mst 0 cost 17031970

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst forward-time

スイッチ上のすべてのインスタンスの転送遅延タイマーを設定するには、 spanning-tree mst forward-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst forward-time seconds

no spanning-tree mst forward-time

 
シンタックスの説明

seconds

スイッチ上のすべてのインスタンスの転送遅延タイマーに設定する秒数。有効値の範囲は、4 ~ 30 秒です。

 
コマンドのデフォルト設定

15 秒

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、転送遅延タイマーを設定する例を示します。

switch(config)# spanning-tree mst forward-time 20

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst hello-time

スイッチ上のすべてのインスタンスの hello タイム遅延タイマーを設定するには、 spanning-tree mst hello-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst hello-time seconds

no spanning-tree mst hello-time

 
シンタックスの説明

seconds

スイッチ上のすべてのインスタンスの hello タイム遅延タイマーに設定する秒数。有効値の範囲は、1 ~ 10 秒です。

 
コマンドのデフォルト設定

2 秒

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

hello-time 値を指定しない場合は、ネットワークの直径から値が計算されます。

次に、hello タイム遅延タイマーを設定する例を示します。

switch(config)# spanning-tree mst hello-time 3

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst max-age

スイッチ上のすべてのインスタンスの最大経過時間タイマーを設定するには、 spanning-tree mst max-age コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst max-age seconds

no spanning-tree mst max-age

 
シンタックスの説明

seconds

スイッチ上のすべてのインスタンスの最大経過時間タイマーに設定する秒数。有効値の範囲は、6 ~ 40 秒です。

 
コマンドのデフォルト設定

20 秒

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

このパラメータは、インスタンス 0 または IST のみが使用します。

このコマンドにライセンスは必要ありません。

次に、最大経過時間タイマーを設定する例を示します。

switch(config)# spanning-tree mst max-age 40

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst max-hops

BPDU が廃棄される前にリージョンで許容されるホップ数を指定するには、 spanning-tree mst max-hops コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst max-hops hop_count

no spanning-tree mst max-hops

 
シンタックスの説明

hop_count

BPDU が廃棄される前にリージョンで許容されるホップ数。有効値の範囲は、1 ~ 255 ホップです。

 
コマンドのデフォルト設定

20 ホップ

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

なし

次に、許容されるホップ数を設定する例を示します。

switch(config)# spanning-tree mst max-hops 25

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst port-priority

MST インスタンス(インスタンス ID が 0 の CIST も含む)のポート プライオリティ パラメータを設定するには、 spanning-tree mst port-priority コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance_id port-priority priority

no spanning-tree mst instance_id port-priority

 
シンタックスの説明

instance_id

インスタンス ID 番号。有効値の範囲は、0 ~ 4094 です。

priority

インスタンスのポート プライオリティ。有効値の範囲は、0 ~ 224 です(32 単位で増分)。

 
コマンドのデフォルト設定

ポート プライオリティ値は 128 です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

port-priority priority 値が大きいほど、プライオリティは低くなります。

プライオリティ値は、0、32、64、96、128、160、192、および 224 です。その他のすべての値は拒否されます。

次に、インターフェイス プライオリティを設定する例を示します。

switch(config-if)# spanning-tree mst 0 port-priority 64

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree port-priority

デフォルト STP のポート プライオリティを設定します。デフォルト STP は、Rapid PVST+ です。

spanning-tree mst priority

ブリッジ プライオリティを設定するには、 spanning-tree mst priority コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance_id priority priority_value

no spanning-tree mst instance_id priority

 
シンタックスの説明

instance_id

インスタンス ID 番号。有効値の範囲は、0 ~ 4094 です。

priority_value

ブリッジ プライオリティ。有効な値および追加情報については「使用上のガイドライン」セクションを参照してください。

 
コマンドのデフォルト設定

ブリッジ プライオリティのデフォルト値は、32768 です。

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

ブリッジ プライオリティは、4096 ずつ増分して設定できます。プライオリティを設定する場合の有効な値は、0、4096、8192、12288、16384、20480、24576、28672、32768、36864、40960、45056、49152、53248、57344、および 61440 です。

priority_value 引数に 0 を設定することで、スイッチをルートにできます。

instance_id 引数には、1 つのインスタンスまたはインスタンス範囲を入力できます。たとえば、0-3、5、7-9 などを入力できます。

次に、ブリッジ プライオリティを設定する例を示します。

switch(config)# spanning-tree mst 0 priority 4096

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst root

プライマリ ルートおよびセカンダリ ルートを指定して、インスタンスのタイマー値を設定するには、 spanning-tree mst root コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance_id root {primary | secondary} [diameter dia [hello-time hello_time ]]

no spanning-tree mst instance_id root

 
シンタックスの説明

instance_id

インスタンス ID 番号。有効値の範囲は、0 ~ 4094 です。

primary

スパニング ツリー インスタンスのブリッジ ルートを作成するのに十分な高優先順位(小さな値)を指定します。

secondary

プライマリ ルートに障害が発生した場合に、セカンダリ ルートとなるようにスイッチを指定します。

diameter dia

(任意)ネットワークの直径に基づく、ブリッジのタイマー値を指定します。

hello-time hello_time

(任意)ルート スイッチが設定メッセージを生成する間隔を指定します。有効範囲は 1 ~ 10 秒です。デフォルトは 2 秒です。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

instance_id 引数には、1 つのインスタンスまたはインスタンス範囲を入力できます。たとえば、0-3、5、7-9 などを入力できます。

hello-time 引数を指定しない場合は、ネットワークの直径から引数が計算されます。 hello-time hello_time キーワードと引数を指定するには、まず diameter dia キーワードと引数を指定する必要があります。

次に、プライオリティ ルートを指定する例を示します。

switch(config)# spanning-tree mst 0 root primary

次に、ブリッジのプライオリティ値およびタイマー値を設定する例を示します。

switch(config)# spanning-tree mst 0 root primary diameter 7 hello-time 2

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree mst simulate pvst

指定のインターフェイスを再度イネーブルにして、MST と Rapid PVST+ 間で自動的に相互運用するには、 spanning-tree mst simulate pvst コマンドを使用します。特定の MST インターフェイスと Rapid PVST+ を実行している接続先デバイスとの自動的な相互運用を回避するには、 spanning-tree mst simulate pvst disable コマンドを使用します。指定のインターフェイスをスイッチにグローバルに設定されているデフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst simulate pvst

spanning-tree mst simulate pvst disable

no spanning-tree mst simulate pvst

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

イネーブルデフォルトでは、スイッチ上のすべてのインターフェイスが MST と Rapid PVST+ 間でシームレスに相互運用します。この設定をグローバルに変更する方法は、 spanning-tree mst simulate pvst global を参照してください。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

ユーザ設定を行わなくても MST は Rapid PVST+ と相互運用します。PVST シミュレーション機能により、このシームレスな相互運用が可能になります。一方、MST 対応ポートを Rapid PVST+ 対応ポートに誤って接続してしまうことを防ぐために、MST と Rapid PVST+ 間の接続を制御できます。

spanning-tree mst simulate pvst disable コマンドを使用すると、Rapid PVST+(SSTP)BPDU を受信した指定の MST インターフェイスが STP ブロッキング ステートに移行します。これらのインターフェイスは、ポートが Rapid PVST+ BPDU の受信を停止するまで不整合なステートにとどまります。その後、ポートは STP の通常の遷移プロセスを再開します。


) スイッチ全体で MST と Rapid PVST+ の自動的な相互運用をブロックするには、no spanning-tree mst simulate pvst global コマンドを使用します。


このコマンドは、Rapid PVST+ を実行するデバイスに誤って接続するのを防止する上で役立ちます。

特定のインターフェイス上で MST と Rapid PVST+ 間のシームレスな運用を再度イネーブルにするには、 spanning-tree mst simulate pvst コマンドを使用します。

次に、指定したポートと Rapid PVST+ を実行する接続先デバイスとの自動的な相互運用を回避する例を示します。

switch(config-if)# spanning-tree mst simulate pvst disable

 
関連コマンド

コマンド
説明

spanning-tree mst simulate pvst global

MST と Rapid PVST+ 間のシームレスな相互運用をグローバルにイネーブルにします。

spanning-tree mst simulate pvst global

MST スイッチと Rapid PVST+ を実行する接続先デバイスとの自動的な相互運用を回避するには、 no spanning-tree mst simulate pvst global コマンドを使用します。スイッチ上で MST と Rapid PVST+ 間のシームレスな運用が行われるデフォルト設定に戻すには、 spanning-tree mst simulate pvst global コマンドを使用します。

spanning-tree mst simulate pvst global

no spanning-tree mst simulate pvst global

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

イネーブルデフォルトでは、スイッチが MST と Rapid PVST+ 間でシームレスに相互運用します。

 
コマンド モード

コンフィギュレーション モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

MST では、Rapid PVST+ と相互運用するためのユーザ設定は必要ありません。PVST シミュレーション機能により、このシームレスな相互運用が可能になります。一方、MST 対応ポートを Rapid PVST+ 対応ポートに誤って接続してしまうことを防ぐために、MST と Rapid PVST+ 間の接続を制御できます。

no spanning-tree mst simulate pvst global コマンドを使用すると、MST モードで稼働するスイッチにより、Rapid PVST+(SSTP)BPDU を受信するすべてのインターフェイスが STP ブロッキング ステートに移行します。これらのインターフェイスは、ポートが Rapid PVST+ BPDU の受信を停止するまで不整合なステートにとどまります。その後、ポートは STP の通常の遷移プロセスを再開します。

インターフェイス モードからもこのコマンドを使用でき、設定はスイッチ全体に適用されます。


) 特定のインターフェイス上で MST と Rapid PVST+ の自動的な相互運用をブロックするには、spanning-tree mst simulate pvst コマンドを使用します。


このコマンドは、MST を実行していないデバイスに誤って接続するのを防止する上で役立ちます。

スイッチを MST と Rapid PVST+ 間のシームレスな運用に戻すには、 spanning-tree mst simulate pvst global コマンドを使用します。

次に、スイッチのすべてのポートと Rapid PVST+ を実行する接続先デバイスとの自動的な相互運用を回避する例を示します。

switch(config)# no spanning-tree mst simulate pvst global

 
関連コマンド

コマンド
説明

spanning-tree mst simulate pvst

MST と Rapid PVST+ 間のシームレスな相互運用をインターフェイス単位でイネーブルにします。

spanning-tree pathcost method

デフォルト パス コスト計算方式を設定するには、 spanning-tree pathcost method コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree pathcost method {long | short}

no spanning-tree pathcost method

 
シンタックスの説明

long

ポートのパス コストに 32 ビット ベース値を指定します。

short

ポートのパス コストに 16 ビット ベース値を指定します。

 
コマンドのデフォルト設定

ショート

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

long パス コスト計算方式では、パス コスト計算に 32 ビットをすべて利用して、2 ~ 2,00,000,000 の値を生成します。

short パス コスト計算方式(16ビット)では、1 ~ 65535 の値を生成します。


) このコマンドは、デフォルト モードである Rapid PVST+ スパニング ツリー モードにのみ適用されます。MST スパニング ツリー モードを使用している場合、スイッチはパス コストの計算に long 方式のみを使用します。これは MST についてはユーザ設定可能ではありません。


次に、デフォルト パス コスト方式に long を設定する例を示します。

switch(config)# spanning-tree pathcost method long

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー ステートに関する情報を表示します。

spanning-tree port type edge

ホストに接続されているインターフェイスをエッジ ポートとして設定するには、 spanning-tree port type edge コマンドを使用します。設定されたポートは、自動的にブロッキング ステートまたはラーニング ステートを経ずにスパニング ツリー フォワーディング ステートに遷移します。標準スパニング ツリー ポートに戻すには、 spanning-tree port type normal コマンドまたは no spanning-tree port type コマンドを使用します。

spanning-tree port type edge [trunk]

spanning-tree port type normal

no spanning-tree port type

 
シンタックスの説明

trunk

(任意)トランク ポートをスパニング ツリー エッジ ポートして設定します。

 
コマンドのデフォルト設定

デフォルトは、 spanning-tree port type edge default コマンドの入力時に設定されるデフォルト ポート タイプ エッジのグローバル設定です。グローバル設定を設定しなかった場合、デフォルトのスパニング ツリー ポート タイプは標準(normal)です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

またこのコマンドを使用して、ポートをスパニング ツリー エッジ ポートとしてトランク モードに設定できます。


注意 このコマンドは、端末に接続されているインターフェイスに対してのみ使用してください。そうでない場合、予想外のトポロジー ループが原因でデータ パケット ループが発生し、スイッチおよびネットワークの動作が中断する可能性があります。

リンクがアップすると、スパニング ツリー エッジ ポートは、標準の転送遅延時間を待機せずに直接スパニング ツリー フォワーディング ステートに移行します。


) これは、以前にシスコ独自の PortFast 機能が提供していた機能性と同じです。


このコマンドを使用すると、システムによって次のようなメッセージが返されます。

Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 

trunk キーワードを指定せずにこのコマンドを使用すると、システムから次のような追加メッセージが返されます。

%Portfast has been configured on Ethernet1/40 but will only
have effect when the interface is in a non-trunking mode.
 

トランク インターフェイスをスパニング ツリー エッジ ポートとして設定するには、 spanning-tree port type trunk コマンドを使用します。スパニング ツリー エッジ ポート タイプ設定を削除するには、 spanning-tree port type normal コマンドを使用します。

デフォルトのスパニング ツリー ポート タイプは、標準(normal)です。

次に、ホストに接続されたインターフェイスをエッジ ポートとして設定する例を示します。設定されたインターフェイスは、リンクがアップしたとき自動的にフォワーディング ステートに遷移します。

switch(config-if)# spanning-tree port type edge

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

spanning-tree port type edge bpdufilter default

すべてのスパニング ツリー エッジ ポート上でデフォルトで BPDU フィルタリングをイネーブルにするには、 spanning-tree port type edge bpdufilter default コマンドを使用します。すべてのエッジ ポート上でデフォルトで BPDU フィルタリングをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree port type edge bpdufilter default

no spanning-tree port type edge bpdufilter default

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

ディセーブル

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

デフォルトで BPDU フィルタリングをイネーブルにするには、次を実行する必要があります。

spanning-tree port type edge または spanning-tree port type edge default コマンドを使用して、インターフェイスをスパニング ツリー エッジ ポートとして設定します。

BPDU フィルタリングをイネーブルにします。

すべてのスパニング ツリー エッジ ポート上で BPDU フィルタリングをグローバルにイネーブルにするには、このコマンドを使用します。BPDU フィルタリングにより、ポートは BPDU を送受信しなくなります。


注意 このコマンドを使用するときには注意してください。誤って使用すると、ブリッジング ループが発生する可能性があります。

インターフェイス レベルで BPDU フィルタリングを設定することにより、この spanning-tree port type edge bpdufilter default コマンドのグローバルな影響を無効にできます。この機能をインターフェイス レベルで使用する場合の詳細については、 spanning-tree bpdufilter コマンドを参照してください。


) BPDU フィルタリング機能は、ポート単位でイネーブルにしたときとグローバルにイネーブルにしたときでは、その機能性が異なります。グローバルにイネーブルにした BPDU フィルタリングは、動作状態のスパニング ツリー エッジ ポート上にのみ適用されます。リンクがアップすると、ポートは BPDU をいくつか送信してから、発信 BPDU を効率的にフィルタリングします。BPDU を受信したエッジ ポートはただちに標準スパニング ツリー ポートになり、通常の遷移が起こり、BPDU フィルタリングがディセーブルになります。ポートでローカルに BPDU フィルタリングをイネーブルにすると、スイッチはこのポートで BPDU の送受信を行わなくなります。


次に、動作状態のすべてのスパニング ツリー エッジ ポート上でデフォルトで BPDU フィルタリングをグローバルにイネーブルにする例を示します。

switch(config)# spanning-tree port type edge bpdufilter default

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree bpdufilter

インターフェイス上で BPDU フィルタリングをイネーブルにします。

spanning-tree port type edge

インターフェイスをスパニング ツリー エッジ ポートとして設定します。

spanning-tree port type edge bpduguard default

すべてのスパニング ツリー エッジ ポート上でデフォルトで BPDU ガードをイネーブルにするには、 spanning-tree port type edge bpduguard default コマンドを使用します。すべてのエッジ ポート上でデフォルトで BPDU ガードをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree port type edge bpduguard default

no spanning-tree port type edge bpduguard default

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

ディセーブル

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

デフォルトで BPDU ガードをイネーブルにするには、次を実行する必要があります。

spanning-tree port type edge または spanning-tree port type edge default コマンドを入力して、インターフェイスをスパニング ツリー エッジ ポートとして設定します。

BPDU ガードをイネーブルにします。

すべてのスパニング ツリー エッジ ポート上で BPDU ガードをグローバルにイネーブルにするには、このコマンドを使用します。BPDU を受信したポートは、BPDU ガードによってディセーブルになります。

グローバル BPDU ガードは、スパニング ツリー エッジ ポート上にのみ適用されます。

BPDU ガードは、インターフェイス単位でもイネーブルにできます。詳細については、 spanning-tree bpduguard コマンドを参照してください。


) すべてのスパニング ツリー エッジ ポート上で BPDU ガードをイネーブルにすることを推奨します。


次に、すべてのスパニング ツリー エッジ ポート上でデフォルトで BPDU ガードをイネーブルにする例を示します。

switch(config)# spanning-tree port type edge bpduguard default

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree bpduguard

インターフェイス上で BPDU ガードをイネーブルにします。

spanning-tree port type edge

インターフェイスをスパニング ツリー エッジ ポートとして設定します。

spanning-tree port type edge default

ホストに接続されているすべてのアクセス ポートをデフォルトでエッジ ポートとして設定するには、 spanning-tree port type edge default コマンドを使用します。ホストに接続されているすべてのポートをデフォルトで標準スパニング ツリー ポートに戻すには、このコマンドの no 形式を使用します。

spanning-tree port type edge default

no spanning-tree port type edge default

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

ディセーブル

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

すべてのインターフェイスをデフォルトでスパニング ツリー エッジ ポートとして自動的に設定するには、このコマンドを使用します。このコマンドは、トランク ポート上では機能しません。


注意 このコマンドを使用するときには注意してください。このコマンドは、端末に接続されているインターフェイスに対してのみ使用してください。そうでない場合、予想外のトポロジー ループが原因でデータ パケット ループが発生し、スイッチおよびネットワークの動作が中断する可能性があります。

リンクがアップすると、エッジ ポートとして設定されているインターフェイスは、自動的に標準の転送遅延時間を待機せずに直接スパニング ツリー フォワーディング ステートに移行します。(以前には、この遷移はシスコ独自の PortFast 機能として設定されていました。)

このコマンドを使用すると、システムによって次のようなメッセージが返されます。

Warning: this command enables portfast by default on all interfaces. You
should now disable portfast explicitly on switched ports leading to hubs,
switches and bridges as they may create temporary bridging loops.
 

spanning-tree port type edge コマンドを使用して、個々のインターフェイスをエッジ ポートして設定できます。

デフォルトのスパニング ツリー ポート タイプは、標準(normal)です。

次に、ホストに接続されているすべてのポートをスパニング ツリー エッジ ポートとしてグローバルに設定する例を示します。

switch(config)# spanning-tree port type edge default

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree port type edge

インターフェイスをスパニング ツリー エッジ ポートとして設定します。

spanning-tree port type network

グローバル設定に関係なく、スイッチに接続されているインターフェイスをスパニング ツリー ネットワーク ポートとして設定するには、 spanning-tree port type network コマンドを使用します。ポートを標準スパニング ツリー ポートに戻すには、 spanning-tree port type normal コマンド、またはこのコマンドの no 形式を使用します。

spanning-tree port type network

spanning-tree port type normal

no spanning-tree port type

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

デフォルトは、 spanning-tree port type network default コマンドの入力時に設定されるデフォルト ポート タイプ ネットワークのグローバル設定です。グローバル設定を設定しなかった場合、デフォルトのスパニング ツリー ポート タイプは標準(normal)です。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

スイッチに接続されているインターフェイスをスパニング ツリー ネットワーク ポートとして設定するには、このコマンドを使用します。ブリッジ保証は、STP ネットワーク ポート上でのみ実行されます。


) ホストに接続されているポートを誤って STP ネットワーク ポートとして設定し、ブリッジ保証をイネーブルにしていると、それらのポートは自動的にブロッキング ステートに移行します。



) ブリッジ保証はデフォルトでイネーブルとなり、スパニング ツリー ネットワーク ポートとして設定されているすべてのインターフェイスのブリッジ保証がイネーブルになります。


ポートをスパニング ツリー ネットワーク ポートとして設定するには、 spanning-tree port type network コマンドを使用します。この設定を削除するには、 spanning-tree port type normal コマンドを使用します。 no spanning-tree port type コマンドを使用すると、ソフトウェアによってポートがネットワーク ポート タイプのグローバルなデフォルト設定に戻されます。

spanning-tree port type network default コマンドを使用すると、スイッチに接続されているすべてのポートをデフォルトでスパニング ツリー ネットワーク ポートとして設定できます。

デフォルトのスパニング ツリー ポート タイプは、標準(normal)です。

次に、スイッチまたはブリッジに接続されているインターフェイスをスパニング ツリー ネットワーク ポートとして設定する例を示します。

switch(config-if)# spanning-tree port type network

 
関連コマンド

コマンド
説明

show spanning-tree interface

指定のインターフェイス単位でスパニング ツリー設定に関する情報を表示します。

spanning-tree port type network default

すべてのポートをデフォルトでスパニング ツリー ネットワーク ポートとして設定するには、 spanning-tree port type network default コマンドを使用します。すべてのポートをデフォルトで標準スパニング ツリー ポートに戻すには、このコマンドの no 形式を使用します。.

spanning-tree port type network default

no spanning-tree port type network default

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

ディセーブル

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

スイッチに接続されているすべてのインターフェイスをデフォルトでスパニング ツリー ネットワーク ポートとして自動的に設定するには、このコマンドを使用します。さらに、 spanning-tree port type edge コマンドを使用して、ホストに接続されている指定のポートをスパニング ツリー エッジ ポートとして設定できます。


) ホストに接続されているポートを誤って STP ネットワーク ポートとして設定し、ブリッジ保証がイネーブルになっていると、それらのポートは自動的にブロッキング ステートに移行します。


ブリッジ保証機能により、ホストに接続されているネットワーク ポートはスパニング ツリー ブロッキング ステートに移行するので、他のスイッチに接続されているポートのみをネットワーク ポートとして設定してください。

spanning-tree port type network コマンドを使用して、個々のインターフェイスをネットワーク ポートして指定できます。

デフォルトのスパニング ツリー ポート タイプは、標準(normal)です。

次に、スイッチに接続されているすべてのポートをスパニング ツリー ネットワーク ポートとしてグローバルに設定する例を示します。

switch(config)# spanning-tree port type network default

 
関連コマンド

コマンド
説明

show spanning-tree summary

スパニング ツリー設定に関する情報を表示します。

spanning-tree port-priority

2 台のブリッジがルート ブリッジとして競合している場合に、インターフェイス プライオリティを設定するには、 spanning-tree port-priority コマンドを使用します。設定されたプライオリティによって、差が生じます。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree [vlan vlan_id ] port-priority value

no spanning-tree [vlan vlan_id ] port-priority

 
シンタックスの説明

vlan vlan_id

(任意)VLAN ID 番号を指定します。有効値の範囲は、0 ~ 4094 です。

value

ポート プライオリティ。有効値の範囲は、1 ~ 224 です(32 単位で増分)。

 
コマンドのデフォルト設定

ポート プライオリティのデフォルト値は 128 です。

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

アクセス ポート上では、 vlan vlan_id パラメータを使用しないでください。ソフトウェアは、アクセス ポートにはポート プライオリティ値、トランク ポートには VLAN ポート プライオリティ値を使用します。

プライオリティ値は、0、32、64、96、128、160、192、および 224 です。その他のすべての値は拒否されます。


) デフォルト STP モードである Rapid PVST+ スパニング ツリー モードのポート プライオリティを設定するには、このコマンドを使用します。MST スパニング ツリー モードのポート プライオリティを設定するには、spacing-tree mst port-priority コマンドを使用します。


次に、ポート プライオリティを 32 に変更して、アクセス ポート インターフェイス 2/0 上のスパニング ツリー インスタンスがルート ブリッジとして選択される確率を高める例を示します。

switch(config-if)# spanning-tree port-priority 32

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

spanning-tree interface priority

インターフェイスのスパニング ツリー ポート プライオリティに関する情報を表示します。

spanning-tree vlan

VLAN 単位で STP パラメータを設定するには、 spanning-tree vlan コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree vlan vlan_id [forward-time value | hello-time value | max-age value | priority value | [root {primary | secondary} [diameter dia [hello-time value ]]]]

no spanning-tree vlan vlan_id [forward-time | hello-time | max-age | priority | root]

 
シンタックスの説明

vlan_id

VLAN ID 番号。有効値の範囲は、0 ~ 4094 です。

forward-time value

(任意)STP 転送遅延時間を指定します。有効値の範囲は、4 ~ 30 秒です。

hello-time value

(任意)ルート スイッチが設定メッセージを生成する間隔を秒単位で指定します。有効値の範囲は、1 ~ 10 秒です。

max-age value

(任意)BPDU の情報が有効になっている最大時間を秒単位で指定します。有効値の範囲は、6 ~ 40 秒です。

priority value

(任意)STP ブリッジ プライオリティを指定します。有効な値は、0、4096、8192、12288、16384、20480、24576、28672、32768、36864、40960、45056、49152、53248、57344、または 61440 です。その他のすべての値は拒否されます。

root primary

(任意)このスイッチを強制的にルート ブリッジにします。

root secondary

(任意)プライマリ ルートに障害が発生した場合には、このスイッチを強制的にルート ブリッジにします。

diameter dia

(任意)端末間の 2 つの接続ポイントの間に存在するブリッジの最大数を指定します。

 
コマンドのデフォルト設定

デフォルトは、次のとおりです。

forward-time ― 15 秒

hello-time ― 2 秒

max-age ― 20 秒

priority ― 32768

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン


注意 no spanning-tree vlan vlan_id コマンドを使用して、VLAN 上のスパニング ツリーをディセーブルにする場合は、VLAN のすべてのスイッチおよびブリッジのスパニング ツリーがディセーブルになっていることを確認してください。VLAN 内の一部のスイッチおよびブリッジのスパニング ツリーをディセーブルにし、同じ VLAN 内の別のスイッチおよびブリッジのスパニング ツリーをイネーブルにしておくことはできません。なぜなら、スパニング ツリーがイネーブルになっているスイッチおよびブリッジは、ネットワークの物理トポロジーについて不完全な情報しか持たないからです。


注意 物理的なループがないトポロジーであっても、スパニング ツリーをディセーブルにしないことを推奨します。スパニングツリーは誤設定やケーブル障害を防ぐ役割を果たします。VLAN 内に物理的なループがないことが確認されるまで、VLAN 内のスパニングツリーをディセーブルにしないでください。

ブリッジは、 max-age seconds の設定時にルート ブリッジから指定のインターバル内に BPDU を受信しないと、ネットワークが変更されたものとみなし、スパニングツリー トポロジーを再計算します。

spanning-tree root primary コマンドを入力すると、このスイッチのブリッジ プライオリティが 24576 に変更されます。spanning-tree root primary コマンドを入力してもスイッチがルートにならない場合、ブリッジ プライオリティは現在のブリッジのブリッジ プライオリティより 4096 だけ小さい値に変更されます。ルート ブリッジになるために必要な値が 1 より小さい場合は、このコマンドは機能しません。スイッチがルートにならない場合は、エラーが発生します。

ネットワーク デバイスのデフォルト ブリッジ プライオリティが 32768 に設定されている場合に、spanning-tree root secondary コマンドを入力すると、ソフトウェアによってこのスイッチのブリッジ プライオリティが 28762 に変更されます。ルート スイッチに障害が発生すると、このスイッチが次のルート スイッチになります。

spanning-tree root コマンドは、バックボーン スイッチ上でのみ使用してください。

次に、VLAN 200 上でスパニング ツリーをイネーブルにする例を示します。

switch(config)# spanning-tree vlan 200

次に、ネットワーク直径が 4 の VLAN 10 のルート スイッチとしてスイッチを設定する例を示します。

switch(config)# spanning-tree vlan 10 root primary diameter 4

次に、ネットワーク直径が 4 の VLAN 10 のセカンダリ ルート スイッチとしてスイッチを設定する例を示します。

switch(config)# spanning-tree vlan 10 root secondary diameter 4

 
関連コマンド

コマンド
説明

show spanning-tree

スパニング ツリー ステートに関する情報を表示します。

state

VLAN の動作ステートを設定するには、 state コマンドを使用します。VLAN をデフォルトの動作ステートに戻すには、このコマンドの no 形式を使用します。

state {active | suspend}

no state

 
シンタックスの説明

active

VLAN がアクティブにトラフィックを受け渡すように指定します。

suspend

VLAN がパケットを受け渡さないように指定します。

 
コマンドのデフォルト設定

VLAN がアクティブにトラフィックを受け渡します。

 
コマンド モード

VLAN コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

VLAN 1 または VLAN 1006 ~ 4094 のステートを一時停止にすることはできません。

一時停止ステートになっている VLAN は、パケットを受け渡しません。

次に、VLAN 2 を一時停止する例を示します。

switch(config)# vlan 2
switch(config-vlan)# state suspend

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

svi enable

VLAN インターフェイスの作成をイネーブルにするには、 svi enable コマンドを使用します。VLAN インターフェイス機能をディセーブルにするには、このコマンドの no 形式を使用します。

svi enable

no svi enable

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

VLAN インターフェイスはディセーブルです。

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

VLAN インターフェイスを作成する前に、 feature interface-vlan または svi enable コマンドを使用してください。

次に、スイッチでインターフェイス上の VLAN 機能をイネーブルにする例を示します。

switch(config)# svi enable

 
関連コマンド

コマンド
説明

interface vlan

VLAN インターフェイスを作成します。

switchport access vlan

インターフェイスがアクセス モードのときにアクセス VLAN を設定するには、 switchport access vlan コマンドを使用します。アクセス モード VLAN をスイッチの適切なデフォルト VLAN にリセットするには、このコマンドの no 形式を使用します。

switchport access vlan vlan_id

no switchport access vlan

 
シンタックスの説明

vlan_id

インターフェイスがアクセス モードのときに設定する VLAN。有効な値は、1 ~ 4094 です。ただし、内部で使用するために予約されている VLAN は除きます。

 
コマンドのデフォルト設定

VLAN 1

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

アクセス モード VLAN をスイッチの適切なデフォルト VLAN にリセットするには、 switchport access vlan コマンドの no 形式を使用します。この処理により、ポートが接続されているデバイスに関するメッセージが生成される場合があります。

次に、イーサネット インターフェイスが VLAN 2 に参加するように設定する例を示します。

switch(config)# interface ethernet 1/7
switch(config-if)# switchport access vlan 2

 
関連コマンド

コマンド
説明

show interface switchport

ポートの管理ステータスおよび動作ステータスを表示します。

switchport block

不明のマルチキャストまたはユニキャスト パケットが転送されないようにするには、 switchport block インターフェイス コンフィギュレーション コマンドを使用します。不明のマルチキャストまたはユニキャスト パケットの転送を許可するには、このコマンドの no 形式を使用します。

switchport block {multicast | unicast}

no switchport block {multicast | unicast}

 
シンタックスの説明

multicast

不明のマルチキャスト トラフィックがブロックされるように指定します。

unicast

不明のユニキャスト トラフィックがブロックされるように指定します。

 
コマンドのデフォルト設定

不明のマルチキャストおよびユニキャスト トラフィックはブロックされません。不明の MAC アドレスを持つすべてのトラフィックが、すべてのポートに送信されます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

スイッチ ポート上の不明のマルチキャストまたはユニキャスト トラフィックをブロックできます。

スイッチ ポート上で不明のマルチキャストまたはユニキャスト トラフィックのブロッキングは、自動的にはイネーブルにならないので、明示的に設定する必要があります。

次に、インターフェイス上の不明のマルチキャスト トラフィックをブロックする例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport block multicast

show interface interface switchport コマンドを入力して、設定を確認できます。

 
関連コマンド

コマンド
説明

show interface switchport

指定のインターフェイスまたはすべてのインターフェイスのスイッチ ポート情報を表示します。

switchport mode private-vlan host

インターフェイス タイプをプライベート VLAN ホスト ポートとして設定するには、 switchport mode private-vlan host コマンドを使用します。

switchport mode private-vlan host

 
シンタックスの説明

このコマンドには、追加のキーワードまたは引数はありません。

 
コマンドのデフォルト設定

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

4.0(0)N1(2)

仮想イーサネット ポートをプライベート VLAN ホスト ポートとして設定するサポートが利用可能になりました。

 
使用上のガイドライン

ポートをプライベート VLAN ホスト ポートとして設定し、次のいずれか 1 つが当てはまる場合にはポートが非アクティブになります。

ポートに有効なプライベート VLAN アソシエーションが設定されていない。

ポートが SPAN 宛先である。

プライベート VLAN アソシエーションが一時停止されている。

プライベート VLAN ポート アソシエーションを削除するか、プライベート ポートを SPAN 宛先として設定した場合、削除されたプライベート VLAN ポート アソシエーションまたは SPAN 宛先として設定されたプライベート ポートは非アクティブになります。


) スパニング ツリー BPDU ガードをすべてのプライベート VLAN ホスト ポートでイネーブルにすることを推奨します。


次に、ポートをプライベート VLAN ホスト モードに設定する例を示します。

switch(config-if)# switchport mode private-vlan host

 
関連コマンド

コマンド
説明

show interface switchport

スイッチ ポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport mode private-vlan promiscuous

インターフェイス タイプをプライベート VLAN 混合モード ポートに設定するには、 switchport mode private-vlan promiscuous コマンドを使用します。

switchport mode private-vlan promiscuous

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

ポートをプライベート VLAN 混合モード ポートとして設定し、次のいずれか 1 つが当てはまる場合はポートが非アクティブになります。

ポートに有効なプライベート VLAN マッピングが設定されていない。

ポートが SPAN 宛先である。

プライベート VLAN ポート マッピングを削除するか、プライベート ポートを SPAN 宛先として設定した場合、削除されたプライベート VLAN ポート マッピングまたは SPAN 宛先として設定されたプライベート ポートは、非アクティブになります。

混合モード ポートの詳細については、 private-vlan コマンドを参照してください。

次に、ポートをプライベート VLAN 混合モードに設定する例を示します。

switch(config-if)# switchport mode private-vlan promiscuous

 
関連コマンド

コマンド
説明

show interface switchport

スイッチ ポートとして設定されているすべてのインターフェイスに関する情報を表示します。

switchport private-vlan host-association

独立ポートまたはコミュニティ ポートのプライベート VLAN アソシエーションを定義するには、 switchport private-vlan host-association コマンドを使用します。ポートからプライベート VLAN アソシエーションを削除するには、このコマンドの no 形式を使用します。

switchport private-vlan host-association { primary_vlan_id } { secondary_vlan_id }

no switchport private-vlan host-association

 
シンタックスの説明

primary_vlan_id

プライベート VLAN 関係のプライマリ VLAN の番号。

secondary_vlan_id

プライベート VLAN 関係のセカンダリ VLAN の番号。

 
コマンドのデフォルト設定

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

4.0(0)N1(2)

仮想イーサネット ポートをプライベート VLAN ホスト ポートとして設定するサポートが利用可能になりました。

 
使用上のガイドライン

ポートがプライベート VLAN ホスト モードでない限り、ポート上で実行時の効果を得ることはできません。ポートがプライベート VLAN ホスト モードであっても、VLAN がどちらも存在しない場合は、コマンドは許可されますが、ポートは非アクティブになります。プライベート VLAN 間のアソシエーションが一時停止されている場合も、ポートが非アクティブになる可能性があります。

セカンダリ VLAN は、独立 VLAN またはコミュニティ VLAN である可能性があります。

プライマリ VLAN、セカンダリ VLAN、および独立ポートまたはコミュニティ ポートについての詳細は、 private-vlan コマンドを参照してください。


) 最新リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチの PVLAN 独立ポートは、IEEE 802.1q カプセル化をサポートしておらず、トランク ポートとしては使用できません。


次に、プライマリ VLAN(VLAN 18)およびセカンダリ VLAN(VLAN 20)とのレイヤ 2 プライベート VLAN ホスト ポートを設定する例を示します。

switch(config-if)# switchport private-vlan host-association 18 20

次に、ポートからプライベート VLAN アソシエーションを削除する例を示します。

switch(config-if)# no switchport private-vlan host-association

 
関連コマンド

コマンド
説明

show vlan private-vlan

プライベート VLAN に関する情報を表示します。

switchport private-vlan mapping

混合モード ポートのプライベート VLAN アソシエーションを定義するには、 switchport private-vlan mapping コマンドを使用します。プライマリ VLAN からすべてのマッピングをクリアするには、このコマンドの no 形式を使用します。

switchport private-vlan mapping { primary_vlan_id } {[add] secondary_vlan_id | remove secondary_vlan_id }

no switchport private-vlan mapping

 
シンタックスの説明

primary_vlan_id

プライベート VLAN 関係のプライマリ VLAN の番号。

add

(任意)セカンダリ VLAN をプライマリ VLAN に関連付けます。

secondary_vlan_id

プライベート VLAN 関係のセカンダリ VLAN の番号。

remove

セカンダリ VLAN とプライマリ VLAN 間のアソシエーションをクリアします。

 
コマンドのデフォルト設定

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

ポートがプライベート VLAN 混合モードでない限り、ポート上で実行時の効果を得ることはできません。ポートがプライベート VLAN 混合モードであっても、プライマリ VLAN が存在しない場合は、コマンドは許可されますが、ポートは非アクティブになります。

セカンダリ VLAN は、独立 VLAN またはコミュニティ VLAN である可能性があります。

プライマリ VLAN、セカンダリ VLAN、および独立ポートまたはコミュニティ ポートについての詳細は、 private-vlan コマンドを参照してください。


) 最新リリースの Cisco NX-OS を実行している Cisco Nexus 5000 シリーズ スイッチの PVLAN 独立ポートは、IEEE 802.1q カプセル化をサポートしておらず、トランク ポートとしては使用できません。


次に、プライベート VLAN 混合モード ポートでプライマリ VLAN 18 をセカンダリ独立 VLAN 20 に プライマリ VLAN 18 を関連付けるように設定する例を示します。

switch(config-if)# switchport private-vlan mapping 18 20

次に、混合モード ポート上のアソシエーションに VLAN を追加する例を示します。

switch(config-if)# switchport private-vlan mapping 18 add 21

次に、ポートからすべてのプライベート VLAN アソシエーションを削除する例を示します。

switch(config-if)# no switchport private-vlan mapping

 
関連コマンド

コマンド
説明

show interface switchport

スイッチ ポートとして設定されているすべてのインターフェイスに関する情報を表示します。

show interface private-vlan mapping

VLAN インターフェイスのプライベート VLAN マッピングまたは SVI に関する情報を表示します。

vlan(EXEC モード)

VLAN を追加するか VLAN コンフィギュレーション モードを開始するには、 vlan コマンドを使用します。VLAN を削除して VLAN コンフィギュレーション モードを終了するには、このコマンドの no 形式を使用します。

vlan { vlan_id | vlan_range }

no vlan { vlan_id | vlan_range }

 
シンタックスの説明

vlan_id

VLAN の 番号。有効値の範囲は、1 ~ 4094 です。


) VLAN 1 または内部的に割り当てられているいずれの VLAN も作成、削除、または修正できません。


vlan_range

設定された VLAN の範囲。有効値のリストについては、「使用上のガイドライン」セクションを参照してください。.

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード


) またこれらの同じコマンドを使用して、VLAN コンフィギュレーション モードで VLAN を作成および削除できます。


 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

vlan vlan_id コマンドを入力すると、すべてのデフォルト パラメータが設定された新しい VLAN が作成され、CLI が表示されて VLAN コンフィギュレーション モードが開始されます。入力した vlan_id 引数が既存の VLAN に一致する場合は、単に VLAN コンフィギュレーション モードが開始されます。

カンマ( , )、ダッシュ( - )、および番号を使用して、 vlan_range を入力できます。

VLAN 1 パラメータは出荷時に設定されており、変更できません。VLAN 1 は、作成も削除もできません。さらに、VLAN 4095 または内部的に割り当てられているいずれの VLAN も作成または削除できません。

VLAN を削除すると、その VLAN のすべてのアクセス ポートがシャットダウンされ、トラフィック フローが停止します。トランク ポートでは、ポートで許可されている他の VLAN へのトラフィック フローは継続されますが、削除された VLAN 宛てのパケットはドロップされます。ただし、その VLAN の VLAN とポートのマッピングは保持されます。その指定の VLAN を再度イネーブルにするか再作成すると、スイッチによってその VLAN への元のポートがすべて自動的に復元されます。

次に、新しい VLAN を追加して、VLAN コンフィギュレーション モードを開始する例を示します。

switch(config)# vlan 2
switch(config-vlan)#

次に、新しい VLAN 範囲を追加して、VLAN コンフィギュレーション モードを開始する例を示します。

switch(config)# vlan 2,5,10-12,20,25,4000
switch(config-vlan)#

次に、VLAN を削除する例を示します。

switch(config)# no vlan 2

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

vrf context

Virtual Routing and Forwarding Instance(VRF; 仮想ルーティング/転送インスタンス)を作成して、VRF コンフィギュレーション モードを開始するには、 vrf context コマンドを使用します。VRF エントリを削除するには、このコマンドの no 形式を使用します。

vrf context { name | management}

no vrf context { name | management}

 
シンタックスの説明

name

VRF の名前。

management

設定可能な VRF 名を指定します。

 
コマンドのデフォルト設定

なし

 
コマンド モード

コンフィギュレーション モード

 
コマンド履歴

リリース
変更内容

4.0(0)N1(1a)

このコマンドが導入されました。

 
使用上のガイドライン

VRF コンフィギュレーション モードを開始すると、次のコマンドが使用可能になります。

exit ― 現在のコマンド モードを終了します。

ip ― IP 機能の設定をイネーブルにします。

IP コンフィギュレーション モードで使用可能な追加コマンド

domain-list ― 追加のドメイン名を追加します。

domain-lookup ― DNS lookup をイネーブルまたはディセーブルにします。

domain-name ― デフォルト ドメイン名を指定します。

host ― IP ホスト名テーブルにエントリを追加します。

name-server ― DNS ネームサーバの IP アドレスを指定します。

route ― Next Hop Server(NHS)の IP アドレスを指定することで、ルート情報を追加します。

no ― コマンドを無効にするか、そのデフォルトに設定します。

shutdown ― 現在の VRF コンテキストをシャットダウンします。

次に、VRF コンテキスト モードを開始する例を示します。

switch(config)# vrf context management
switch(config-vrf)#

 
関連コマンド

コマンド
説明

show vrf

VRF 情報を表示します。