Cisco Nexus 5600 シリーズ NX-OS Fibre Channel over Ethernet コンフィギュレーション ガイド、リリース 7.x
FabricPath を使用したダイナミック FCoE の設定
FabricPath を使用したダイナミック FCoE の設定

目次

FabricPath を使用したダイナミック FCoE の設定

この章の内容は、次のとおりです。

FabricPath を使用したダイナミック FCoE に関する情報

Fibre Channel over Ethernet(FCoE)は I/O 統合を可能にします。 つまり、LAN と SAN の両方のトラフィックを、同じスイッチおよび同じ回線上で共存させます。 この機能により、複数の異なるネットワークを単一のインフラに統合できます。

従来の FCoE を使用した I/O 統合の主な価値は次のとおりです。

  • SAN と LAN のトラフィックの個別ネットワーク インフラが不要。

  • 配線やサーバ インターフェイス カード(NIC、HBA)などのハードウェア要件の軽減、および導入コストの低減。

  • 少ない物理資産による消費電力と冷却要件の軽減。

  • マルチプロトコル ネットワーク用として導入の敏捷性を高め、将来のプロトコル ニーズの不確実性に備えながら、長期的投資を維持する。

FabricPath イーサネット テクノロジを使用して、FCoE 統合ではさらに以下を行います。

  • 物理的でなく、論理的 SAN A/B の分離を作成する。

  • データセンター内でマルチプロトコル トラフィックを効率的に負荷分散する。

  • スイッチ間の関係を動的に確立し、設定中のヒューマン エラーの可能性を減らす。

  • 規模拡大に合わせてハイ アベイラビリティの割合を高める。

FabricPath アーキテクチャは、冗長性を備えた固有のマルチパス機能によってノード障害を処理します。 ファブリック レベルの冗長性は、デュアル ファブリック モデル(SAN A / SAN B)によって提供されます。 2 つの SAN の分離は、2 つの異なる VLAN (VLAN A および B) にマッピングされる 2 つの異なる VSAN として論理的に行われます。 SAN A のファイバ チャネル トラフィックは VLAN A の FCoE トラフィックとなり、SAN B のファイバ チャネル トラフィックは VLAN B の FCoE トラフィックになり、 LAN トラフィックは統合イーサネット インフラ経由で 1 つ以上の追加 VLAN 上で転送されます。 この論理環境で、VSAN A /VSAN B 設定はファブリック全体のコントロール プレーン障害から保護されます。

2 つの別々の SAN に接続するホストの従来の方式は、FabricPath アーキテクチャ上で FCoE とともにサポートされています。 ホストは、VSAN の分離したセットをホストする 2 つの異なるリーフ ノードに接続されます。 これらのリーフ ノード以外に、ファブリック自体は同じインフラで統合されますが、ホストは 2 つの SAN ファブリックの管理を継続します。

次の図は、n 個のスパイン(S)と m 個のリーフ(L)を持つ FabricPath トポロジを示しています。 m 個のリーフは FabricPath カプセル化を使用して n 個のスパインを介して互いに通信します。

図 1. FabricPath トポロジ



FCoE は、基盤となるイーサネット トポロジの上部に FCoE 仮想リンクのオーバーレイを作成します。そのイーサネット トポロジがどのように構築されたか、そして MAC アドレスのルート計算にどのプロトコルが使用されているかは関係ありません。

ダイナミック FCoE 環境で、トポロジはリーフをトランスペアレント スパインを介して転送される FCoE Forwarder (FCF)スイッチとして使用し展開されます。

FCoE ホストおよび FCoE ストレージ デバイスは、リーフ スイッチを介して FabricPath トポロジに接続されます。 この設定では、リーフ スイッチだけが FCoE 転送を行います(リーフ スイッチだけが FCF として機能します)。スパイン スイッチは、外部の宛先 MAC アドレスに基づいて、MAC-in-MAC でカプセル化されたイーサネット フレームを転送するだけです。

次の図は、FabricPath トポロジ上の VE_Port から VE_Port の仮想リンクの論理 FCoE オーバーレイ トポロジを示しています。

図 2. VE_Port から VE_Port の仮想リンクの FCoE オーバーレイ



リーフ スイッチによって実装される FCF のみが、このオーバーレイ トポロジの一部です。 このトポロジは、FCoE VLAN ごとに Fabric Shortest Path First (FSPF)によって認識されます。 FSPF は、DomainID (D_ID)に基づき、FCoE フレームを転送するための仮想リンクを計算します。 仮想リンクは、論理的に接続された 2 つの VE_Port に関連付けられたペアの MAC アドレスによって一意に識別されます。 仮想リンクの識別は、転送ネットワークの FCoE カプセル化にどの MAC アドレスが使用されるかを識別することと同じです。

機能がイネーブルになっているリーフの数として、L m を使用します。 この機能はすべてのリーフでイネーブルではない場合があります。 FCoE メッシュは、基本的に FCoE または FabricPath がイネーブルになっているリーフです。

SAN A/B の分離

ダイナミック FCoE では、SAN A/B の分離が論理的に実現されます。 次の図に示すように、分離は最初のホップの FCF リーフまでは物理的な分離のみです。 リーフに加えて、複数 VSAN の FCoE トラフィックは統合され、FabricPath クラウドによって引き継がれます。 SAN A および SAN B のクラスタにノードの物理的な分離はありません。 FabricPath マルチトポロジ設定によって物理的な分離は 可能ですが、必須ではありません。 FabricPath ネットワークに固有の冗長性は物理的に重複するネットワーク リソースを持たずに、ハイアベイラビリティ要件を十分に満たします。
図 3. 物理トポロジ図



前の図では、トポロジの物理的接続は、一般的なリーフ/スパイン CLOS アーキテクチャのベスト プラクティスに従っています。 論理的には、SAN A および SAN B は Top of Rack(ToR)スイッチで物理的に分離されます。 トラフィックが FabricPath ネットワークに入ると、ストレージ トラフィックはネットワーク上で論理的に分離されます(次の図を参照)。これはストレージ デバイス エッジに対して再度物理的に分離されます。

図 4. 論理トポロジ図



ダイナミック FCoE はスパインの接続増加を利用して、FabricPath ネットワーク内のさらなる冗長性を実現します。 多数のスパインを持つ大規模ネットワークは、ストレージ ネットワークの信頼性と安定性向上を意味します。 これは、ストレージ環境のベスト プラクティス要件の維持とともに達成されます。

ダイナミック VFC 上の FCoE トラフィックのロード バランシング

FabricPath は、送信元と宛先の間に冗長パスを提供します。 FCoE トラフィックは 1 つ以上の FCoE ノードと非 FCoE ノード(スパイン、リーフ)を含む FabricPath ネットワークを通過するため、冗長パス全体で適切なポート チャネル ハッシュにより順序どおりの配信を保証する必要があります。 すべての FabricPath ノードでは交換 ID を含むポート チャネル ハッシュがイネーブルになっています。 順序どおりの配信を維持するために、単一フローからのトラフィックはネットワークを通る際に 1 セットのノードのみを常に通過します。

FabricPath トポロジを使用してサポートされるダイナミック FCoE

FabricPath を使用してダイナミック FCoE でサポートされているトポロジは次のとおりです。

  • 直接 FCF リーフに接続された FCoE デバイス

  • FCF リーフへの従来の FCoE VE_Port 接続

  • FCF リーフに接続されたレガシー FC ファブリック

  • FCF リーフに接続された NPV および FCoE NPV デバイス

  • 直接 FCF リーフに接続されたネイティブ FC デバイス


(注)  


FabricPath マルチトポロジ設定によって物理的な分離は可能ですが、必須ではありません。


FabricPath を使用したダイナミック FCoE のライセンス要件

次の表に、この機能のライセンス要件を示します。
製品 ライセンス要件

Fibre Channel over Ethernet

リーフ ロールの FCoE ライセンス機能と FabricPath ライセンス機能。

FabricPath

スパインとリーフの FabricPath 機能。

FabricPath を使用したダイナミック FCoE の前提条件

ダイナミック FCoE の前提条件は次のとおりです。

  • FabricPath をイネーブルにする必要があります。

  • FCF リーフ用に fcoe 機能をイネーブルにします。

  • FCF リーフに vPC+ MCT がある場合、MCT に最大の FabricPath コストを割り当てます。

  • すべてのノード(リーフおよびスパイン)で VSAN にマッピングされている VLAN のファブリック パス モードをイネーブルにします。

FabricPath を使用したダイナミック FCoE に関する注意事項と制約事項

FabricPath を使用したダイナミック FCoE には、次の注意事項と制約事項があります。

  • FabricPath リーフ ノードで FCoE 機能をイネーブルにします。

  • ストレージ トラフィックに使用する FCoE VLAN で、FabricPath モードをイネーブルにします。

  • FabricPath を使用したダイナミック FCoE は、Dynamic Fabric Automation(DFA)の展開に現時点では対応していません。 DFA に参加するスイッチがダイナミック FCoE を実行するように設定しないでください。

  • FabricPath 展開のスイッチの最小数は 1 台です。 ただし、SAN A/B を分離する場合は 2 台のスパイン スイッチが必要です。 そのようにしないと、分離はまったく行われません。
  • FabricPath スイッチ ID をスタティックに定義します。 ダイナミック vFC にはスイッチ ID の変更が必要です。 トラフィック損失は、スイッチ ID の変更時に発生する可能性があります。 スイッチ ID はスタティックに設定することをお勧めします。

  • Multichassis EtherChannel Trunk(MCT)は最大の Intermediate System-to-Intermediate System(IS-IS)コストであり、16777215 です。 FCoE VLAN は MCT として起動しません。 Fabric IS-IS は FCoE/FTP トラフィックが通過しないように大きい値にする必要があります。

  • 以下を確認してください。

    • 別々のトポロジの FCoE VLAN を定義し、MCT リンクを明示的に削除します。

    • 通常転送に使用されるのを避けるため、MCT のコストを高く設定します。

  • VFC を動的にシャットダウンすると、レイヤ 2 マルチパス(L2MP)ループが発生してトラフィック損失が起きる可能性があるため、お勧めしません。

  • VSAN に特定のデータ パスを使用する場合、FabricPath を使用したダイナミック FCoE のトポロジで FabricPath マルチトポロジを使用します。

設定トポロジの例

次の図は、以下のセクションで説明する設定の例を示しています。

図 5. 設定例




(注)  


この図の部品ラベルは、説明のみを目的としています。

FabricPath を使用したダイナミック FCoE の設定

手順
    ステップ 1   FabricPath インフラを確立します。

    すべてのスパインおよびリーフで、FabricPath インフラを設定する必要があります。 FabricPath トポロジ内のすべてのスパインおよびすべてのリーフの設定を参照してください。

    ステップ 2   FCoE トラフィックのスパインを設定します。

    FabricPath トポロジ内のすべてのスパインおよびすべてのリーフの設定 を参照してください。

    ステップ 3   FCoE トラフィックには FCoE 以外のリーフを設定します。

    フェールオーバーの場合、リーフはこの設定を必要とします。 FabricPath トポロジ内のすべてのスパインおよびすべてのリーフの設定を参照してください。

    ステップ 4   FCoE(FCF)処理にはリーフを設定します。

    フェールオーバーの場合、リーフはこの設定を必要とします。

    1. FCF リーフの設定を参照してください。

    2. FCoE および FabricPath 対応 VLAN の設定を参照してください。

      (注)      vPC または vPC+ がリーフでイネーブルになっている場合は、FCF リーフ用 vPC+ ピア リンクの FabricPath コストを増やすの手順に従います。
    ステップ 5   FC/FCoE 用リーフでポートを設定します。

    vPC または vPC+ がイネーブルの場合は、FCF リーフ用 vPC+ ピア リンクの FabricPath コストを増やすの手順に従います。


    FabricPath のイネーブル化

    手順
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal  

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2switch(config)# install feature-set fabricpath  

      スイッチで FabricPath フィーチャ セットをインストールします。

       
      ステップ 3switch(config)# feature-set fabricpath  

      スイッチで FabricPath フィーチャ セットをイネーブルにします。

       
      ステップ 4switch(config)# copy running-config startup-config   (任意)

      リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

       

      次の例では、FabricPath をイネーブルにする方法を示します。

      switch# configure terminal
      switch(config)# install feature-set fabricpath
      switch(config)# feature-set fabricpath
      switch(config)# copy running-config startup-config 

      FabricPath トポロジ内のすべてのスパインおよびすべてのリーフの設定

      Quality of Service(QoS)の設定はスパイン上でイネーブルになります。 FCF は確立されていません。

      手順
         コマンドまたはアクション目的
        ステップ 1switch# configure terminal  

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2switch(config)# install feature-set fabricpath  

        スイッチで FabricPath フィーチャ セットをインストールします。

         
        ステップ 3switch(config)# feature-set fabricpath  

        スイッチで FabricPath フィーチャ セットをイネーブルにします。

         
        ステップ 4switch(config)# system qos  

        システム クラス コンフィギュレーション モードを開始します。

         
        ステップ 5switch(config-sys-qos)# service-policy type {network-qos | qos | queuing} [input | output] fcoe-default-policy-name  

        システムのサービス ポリシーを、FCoE トラフィックのデフォルト ポリシー マップを指定するようにセットアップします。 FCoE 用の 4 種類の定義済みポリシー マップは次のとおりです。

        • service-policy type qos input fcoe-default-in-policy

        • service-policy type queuing input fcoe-default-in-policy

        • service-policy type queuing output fcoe-default-out-policy

        • service-policy type network-qos fcoe-default-nq-policy

        (注)      Cisco Nexus デバイスで FCoE をイネーブルにする前に、事前定義された FCoE ポリシー マップをタイプ qos、タイプ network-qos、およびタイプ queuing の各ポリシー マップに追加する必要があります。
         
        ステップ 6switch(config-sys-qos)# vlan vlan-id  

        VLAN コンフィギュレーション モードを開始します。 VLAN 番号の有効範囲は 1 ~ 4,096 です。

         
        ステップ 7switch(config-vlan)# mode fabricpath  

        VLAN を FabricPath VLAN として設定します。

         
        ステップ 8switch(config-vlan)# interface [ethernet slot/port | port-channel channel-no]  

        インターフェイス コンフィギュレーション モードを開始し、FabricPath として設定するインターフェイスを指定します。

        特定のスロット内のポート番号には 1 ~ 128 を指定できます。

        EtherChannel 論理インターフェイスに割り当てられるポート チャネル番号には 1 ~ 4096 を指定できます。

         
        ステップ 9switch(config-if)# switchport mode fabricpath  

        FabricPath ポートとしてインターフェイスを指定します。

         
        ステップ 10switch(config-if)# copy running-config startup-config   (任意)

        リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

         

        次の例では、スパインを設定する方法を示します。

        switch# configure terminal
        switch(config)# install feature-set fabricpath
        switch(config)# feature-set fabricpath
        switch(config)# system qos
        switch(config)# service-policy type queuing input fcoe-default-in-policy
        switch(config)# service-policy type queuing output fcoe-default-out-policy
        switch(config)# service-policy type qos input fcoe-default-in-policy
        switch(config)# service-policy type network-qos fcoe-default-nq-policy
        switch(config)# vlan 10
        switch(config-vlan)# mode fabricpath
        switch(config-vlan)# interface ethernet1/11
        switch(config-if)# switchport mode fabricpath
        switch(config-if)# copy running-config startup-config

        FCF リーフの設定

        手順
           コマンドまたはアクション目的
          ステップ 1switch# configure terminal  

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2switch(config)# feature fcoe  

          FCoE 機能をイネーブルにします。

           
          ステップ 3switch(config)# fcoe fka-adv-period interval  

          ファブリックのアドバタイズメント間隔を設定します。 デフォルト値は 8 秒です。 有効な範囲は 4 ~ 60 秒です。

           
          ステップ 4switch(config)# fabricpath switch-id switch-id-value  

          スイッチ ID を設定します。 指定できる範囲は 1 ~ 4094 です。

           
          ステップ 5switch(config)# vlan vlan-id  

          VLAN コンフィギュレーション モードを開始します。 VLAN 番号の有効範囲は 1 ~ 4,096 です。

           
          ステップ 6switch(config)# vsan database  

          VSAN コンフィギュレーション モードを開始します。

           
          ステップ 7switch(config-vsan-db)# vsan vsan-id  

          VSAN を設定します。

           
          ステップ 8switch(config-vsan-db)# show vpc  

          vPC に関する情報を表示します。

          (注)      vPC がイネーブルになっている場合は、次の手順をFCF リーフ用 vPC+ ピア リンクの FabricPath コストを増やす実行します。
           
          ステップ 9switch(config)# copy running-config startup-config   (任意)

          リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

           

          次の例は、FCF リーフを設定する方法を示しています。

          switch# configure terminal
          switch(config)# feature fcoe
          switch(config)# fcoe fka-adv-period 20
          switch(config)# fabricpath switch-id 5
          switch(config)# vlan 100
          
          switch(config-vsan-db)# vsan database
          switch(config-vsan-db)# vsan 100
          switch(config-vsan-db)# show vpc
          

          FCoE および FabricPath 対応 VLAN の設定

          手順
             コマンドまたはアクション目的
            ステップ 1switch# configure terminal  

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 2switch(config)# vlan vlan-id  

            VLAN コンフィギュレーション モードを開始します。 VLAN 番号の有効範囲は 1 ~ 4,096 です。

             
            ステップ 3switch(config-vlan)# fcoe [vsan vsan-id]  

            指定された VLAN で FCoE をイネーブルにします。 VSAN 番号を指定しない場合は、対象の VLAN から番号が同じ VSAN へマッピングが作成されます。

            対象の VLAN から指定した VSAN へのマッピングを設定します。

             

            次に、FCoE および FabricPath 対応 VLAN を設定する方法の例を示します。

            switch# configure terminal
            switch(config)# vlan 100
            switch(config-vlan)# fcoe vsan 10
            

            FabricPath VLAN の定義

            手順
               コマンドまたはアクション目的
              ステップ 1switch# configure terminal  

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2switch(config)# vlan vlan-id  

              VLAN コンフィギュレーション モードを開始します。 VLAN 番号の有効範囲は 1 ~ 4,096 です。

               
              ステップ 3switch(config-vlan)# mode fabricpath  

              VLAN の動作モードを設定します。

               

              次に、FabricPath VLAN の定義方法の例を示します。

              switch# configure terminal
              switch(config)# vlan 100
              switch(config-vlan)# mode fabricpath
              switch(config-vlan)# copy running-config startup-config 

              FCF リーフ用 vPC+ ピア リンクの FabricPath コストを増やす

              手順
                 コマンドまたはアクション目的
                ステップ 1switch# configure terminal  

                グローバル コンフィギュレーション モードを開始します。

                 
                ステップ 2switch(config)# show vpc  

                show vpc コマンドの出力に基づく 3 つのオプションがあります。

                • show vpc コマンドを使用できない場合は、この手順を続行しないでください。

                • vPC+ がコマンド出力にない場合は、この手順を続行しないでください。

                • vPC+ がコマンド出力にある場合は、この手順の残りのステップを実行します。

                 
                ステップ 3switch(config)# interface [ethernet slot/port | port-channel channel-no]  

                インターフェイス コンフィギュレーション モードを開始し、FabricPath として設定するインターフェイスを指定します。

                特定のスロット内のポート番号には 1 ~ 128 を指定できます。

                EtherChannel 論理インターフェイスに割り当てられるポート チャネル番号には 1 ~ 4096 を指定できます。

                 
                ステップ 4switch(config-if)# fabricpath isis metric default-metric  

                MCT インターフェイスのメトリックを設定します。 default-metric を16777215 に設定します。

                 
                ステップ 5switch(config-if)# copy running-config startup-config   (任意)

                リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

                 

                次に、vPC+ ピア リンクの FabricPath を増やす方法の例を示します。

                switch# configure terminal
                switch(config)# show vpc
                switch(config)# interface ethernet 1/11
                switch(config-if)# fabricpath isis metric 16777210 

                ダイナミック VFC のインスタンス化および初期化

                ダイナミック FCoE は、仮想ファイバ チャネル ポート(VFC)を作成し、スイッチ間リンクのポート タイプ(VE_Port/TE Port)をインスタンス化する機能をイネーブルにします。 同じ VLAN の FCoE と FabricPath をイネーブルにすると、TE モードのダイナミック VFC のインスタンス化および初期化をトリガーとして実行する必要があります。 そのプロセスは次のとおりです。

                1. 各 FCF リーフは、グローバル FCF-MAC アドレスによって一意に識別されます。

                2. 各 FCF リーフは、FIPS の要求されていないマルチキャスト検出アドバタイズメントを ALL-FCF MAC アドレスに、送信元 MAC アドレスを FabricPath-enabled FCoE VLAN 上のグローバル FCF-MAC アドレスにフラッディングします。 これは次の 2 つの要因によってトリガーされます。

                  1. FCoE 機能はリーフでイネーブルになっています。

                  2. FabricPath は FCoE VLAN でイネーブルになっています。

                3. この FabricPath クラウド上のすべての FCF リーフは、対応する FCoE イネーブルの FP VLAN で、このマルチキャスト アドバタイズメントを受信します。 この FIPS マルチキャスト フレームを受信すると、VE モードのダイナミック VFC が 2 つの FCF リーフ ノードの間に作成されます。

                4. 2 つの FCF リーフ間の TE モードには、ダイナミック VFC が 1 つだけあります。

                5. ダイナミック VFC は、その VFC ID 範囲に基づいて区別できます。 すべてのダイナミック VFC は、32000 より大きい ID を取得します。

                6. VFC には、有効な FabricPath FCoE VLAN が複数存在する可能性があります。 VLAN は、同じトポロジである場合と、そうでない場合とがあります。

                7. 各 FCF は 1 ホップずつ離れています。 FabricPath を使用するすべての VE パスでは、デフォルト固定の FSPF コスト値が使用されます。

                FabricPath 設定を使用するダイナミック FCoE の確認

                FabricPath 設定情報を使用してダイナミック FCoE を表示するには、次のいずれかの作業を行います。

                コマンド 目的

                show interface brief

                インターフェイス設定情報の概要を表示します。

                show interface brief コマンド を参照してください。

                show interface vfc

                仮想ファイバ チャネル インターフェイスの設定情報を表示します。

                show interface vfc コマンド を参照してください。

                show vpc

                仮想ポート チャネルの設定情報を表示します。

                show vpc コマンド を参照してください。

                show topology

                接続された SAN スイッチのトポロジ情報を表示します。

                show topology コマンド を参照してください。

                show fcoe

                スイッチの FCoE パラメータのステータスを表示します。

                show fcoe コマンド を参照してください。

                show running-config

                スイッチ上で現在実行されているコンフィギュレーションを表示します。

                show running-config コマンド を参照してください。

                show fcoe dce

                FabricPath を使用してダイナミック FCoE データベースを表示します。

                show fcoe dce コマンド を参照してください。

                show interface brief コマンド

                switch(config)# show interface brief
                --------------------------------------------------------------------------------
                Ethernet      VLAN    Type Mode   Status  Reason                   Speed     Por
                t
                Interface                                                                    Ch 
                #
                --------------------------------------------------------------------------------
                Eth1/1        1       eth  access up      none                        10G(D) --
                Eth1/2        1       eth  access down    Link not connected          10G(D) --
                Eth1/3        1       eth  access up      none                        10G(D) --
                Eth1/4        1       eth  access up      none                        10G(D) --
                Eth1/5        1       eth  access up      none                        10G(D) --
                Eth1/6        1       eth  access up      none                        10G(D) --
                Eth1/7        1       eth  access up      none                        10G(D) --
                Eth1/8        1       eth  access down    SFP not inserted            10G(D) --
                Eth1/9        1       eth  access down    SFP validation failed       10G(D) --
                Eth1/10       1       eth  access down    SFP not inserted            10G(D) --
                Eth1/11       1       eth  f-path up      none                        10G(D) --
                Eth1/12       1       eth  access down    SFP not inserted            10G(D) --
                Eth1/13       1       eth  access up      none                        10G(D) --
                Eth1/14       1       eth  access up      none                        10G(D) --
                Eth1/15       1       eth  access down    SFP validation failed       10G(D) --
                Eth1/16       1       eth  access down    Link not connected          10G(D) --
                Eth1/17       1       eth  access up      none                        10G(D) --
                Eth1/18       1       eth  access up      none                        10G(D) --
                Eth1/19       1       eth  access down    SFP validation failed       10G(D) --
                Eth1/20       1       eth  access up      none                        10G(D) --
                Eth1/21       1       eth  access down    SFP validation failed       10G(D) --
                Eth1/22       1       eth  access up      none                        10G(D) --
                Eth1/23       1       eth  access down    SFP validation failed       10G(D) --
                Eth1/24       1       eth  access down    SFP not inserted            10G(D) --
                Eth1/25       1       eth  access up      none                        10G(D) --
                Eth1/26       1       eth  access up      none                        10G(D) --
                Eth1/27       1       eth  access up      none                        10G(D) --
                Eth1/28       1       eth  access up      none                        10G(D) --
                Eth1/29       1       eth  access up      none                        10G(D) --
                Eth1/30       1       eth  access down    SFP not inserted            10G(D) --
                Eth1/31       1       eth  access down    SFP not inserted            10G(D) --
                Eth1/32       1       eth  access down    SFP not inserted            10G(D) --
                
                --------------------------------------------------------------------------------
                Port   VRF          Status IP Address                              Speed    MTU
                --------------------------------------------------------------------------------
                mgmt0  --           up     10.193.52.117                           1000     1500
                
                -------------------------------------------------------------------------------
                Interface  Vsan   Admin  Admin   Status      Bind                 Oper    Oper
                                  Mode   Trunk               Info                 Mode    Speed
                                         Mode                                            (Gbps)
                -------------------------------------------------------------------------------
                vfc32002   1      E     on     trunking    54:7f:ee:b1:8a:00        TE   10
                vfc32003   1      E     on     trunking    54:7f:ee:73:e8:00        TE   10
                 		

                show interface vfc コマンド

                switch(config)# show interface vfc 32002
                vfc32002 is trunking
                    Dynamic VFC Peer MAC is 54:7f:ee:b1:8a:00
                    Hardware is Ethernet 
                    Port WWN is 2d:01:54:7f:ee:73:e6:78
                    Admin port mode is E, trunk mode is on
                    snmp link state traps are enabled
                    Port mode is TE
                    Port vsan is 1
                    Trunk vsans (admin allowed and active) (1,100)
                    Trunk vsans (up)                       (100)
                    Trunk vsans (isolated)                 ()
                    Trunk vsans (initializing)             (1)
                    1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
                    1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
                      0 frames input, 0 bytes
                      0 frames output, 0 bytes
                    Interface last changed at Mon Feb 14 19:46:53 2011
                
                switch(config)# show interface vfc 32003
                vfc32003 is trunking
                    Dynamic VFC Peer MAC is 54:7f:ee:73:e8:00
                    Hardware is Ethernet 
                    Port WWN is 2d:02:54:7f:ee:73:e6:78
                    Admin port mode is E, trunk mode is on
                    snmp link state traps are enabled
                    Port mode is TE
                    Port vsan is 1
                    Trunk vsans (admin allowed and active) (1,100)
                    Trunk vsans (up)                       (100)
                    Trunk vsans (isolated)                 ()
                    Trunk vsans (initializing)             (1)
                    1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
                    1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
                      0 frames input, 0 bytes
                      0 frames output, 0 bytes
                    Interface last changed at Mon Feb 14 19:49:23 2011
                
                
                ===========================================================================

                show vpc コマンド

                switch(config)# show vpc
                			vPC domain id : 300 vPC+ switch id : 1550
                   vPC Peer-link status
                   ---------------------------------------------------------------------
                   id   Port   Status Active vlans
                   --   ----   ------ --------------------------------------------------
                   1   Po1    up     -
                

                show topology コマンド

                switch(config)# show topology
                FC Topology for VSAN 100 :
                --------------------------------------------------------------------------------
                       Interface  Peer Domain Peer Interface     Peer IP Address(Switch Name)
                --------------------------------------------------------------------------------
                         vfc32002  0x0b(11)         vfc32002  10.193.52.108(nc-9)
                         vfc32003 0x64(100)         vfc32003  10.193.52.118(o2-356)

                show fcoe コマンド

                switch(config)# show fcoe
                Global FCF details
                        FCF-MAC is 54:7f:ee:73:e6:20
                        FC-MAP is 0e:fc:00
                        FCF Priority is 128
                        FKA Advertisement period for FCF is 8 seconds
                
                VFC MAC details
                

                show running-config コマンド

                switchconfig)# show running-config 
                
                !Command: show running-config
                !Time: Mon Feb 14 19:58:47 2011
                
                version 7.0(3)N1(1)
                feature fcoe
                
                install feature-set fabricpath
                feature-set fabricpath
                
                feature telnet
                feature lldp
                
                username admin password 5 $1$1dLADwhf$7Ip2IYSMp/0nsII8rU5qh/  role network-admin
                no password strength-check
                ip domain-lookup
                system qos
                  service-policy type qos input fcoe-default-in-policy
                  service-policy type queuing input fcoe-default-in-policy
                  service-policy type queuing output fcoe-default-out-policy
                  service-policy type network-qos fcoe-default-nq-policy
                snmp-server user admin network-admin auth md5 0x95d13d5b1da2ee92b77769b4c177a94b
                 priv 0x95d13d5b1da2ee92b77769b4c177a94b localizedkey
                rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
                rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
                rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
                rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
                rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO
                
                vlan 1
                vlan 100
                  fcoe vsan 100
                  mode fabricpath
                vrf context management
                  ip route 0.0.0.0/0 10.193.48.1
                vsan database
                  vsan 100
                
                
                interface vfc32002
                  bind mac-address 54:7f:ee:b1:8a:00
                  dce
                  switchport mode E
                  no shutdown
                
                interface vfc32003
                  bind mac-address 54:7f:ee:73:e8:00
                  dce
                  switchport mode E
                  no shutdown
                
                interface Ethernet1/1
                
                interface Ethernet1/2
                
                interface Ethernet1/3
                
                interface Ethernet1/4
                
                interface Ethernet1/5
                
                interface Ethernet1/6
                
                interface Ethernet1/7
                
                interface Ethernet1/8
                
                interface Ethernet1/9
                
                interface Ethernet1/10
                
                interface Ethernet1/11
                  switchport mode fabricpath
                
                interface Ethernet1/12
                
                interface Ethernet1/13
                
                interface Ethernet1/14
                
                interface Ethernet1/15
                
                interface Ethernet1/16
                
                interface Ethernet1/17
                
                interface Ethernet1/18
                
                interface Ethernet1/19
                
                interface Ethernet1/20
                
                interface Ethernet1/21
                
                interface Ethernet1/22
                
                interface Ethernet1/23
                
                interface Ethernet1/24
                
                interface Ethernet1/25
                
                interface Ethernet1/26
                
                interface Ethernet1/27
                
                interface Ethernet1/28
                
                interface Ethernet1/29
                
                interface Ethernet1/30
                
                interface Ethernet1/31
                
                interface Ethernet1/32
                
                interface mgmt0
                  vrf member management
                  ip address 10.193.52.117/21
                line console
                line vty
                fabricpath domain default
                fabricpath switch-id 302
                

                show fcoe dce コマンド

                switch# show fcoe dce
                
                Dynamic VFC MAC details :
                -----------------------------------------------------------
                   Interface    Peer-swid       Peer-mac 
                -----------------------------------------------------------
                   vfc32002     303             54:7f:ee:b1:8a:00       
                   vfc32003     301             54:7f:ee:73:e8:00     
                
                

                FabricPath を使用したダイナミック FCoE の設定の出力例

                次の出力例は、FabricPath を使用してダイナミック FCoE を設定する方法を示します。 feature fabricpath コマンドを入力し、適切なリンクを FabricPath コア ポートとして設定します。

                この例は、VSAN 100 と VSAN 200 について説明します。

                次は、トポロジ例の説明です。

                • S1 および S2 は FabricPath スパインです。

                • L1 ~ L4 は FCF リーフです。

                • L5 と L6 は非 FCoE リーフです。

                図 6. ダイナミック FCoE 設定の例



                この例では、S1 と S2 の設定を示します。

                switch# show running-config
                system qos
                  service-policy type qos input fcoe-default-in-policy
                  service-policy type queuing input fcoe-default-in-policy
                  service-policy type queuing output fcoe-default-out-policy
                  service-policy type network-qos fcoe-default-nq-policy
                vlan 100
                    mode fabric path
                vlan 200
                     mode fabric path
                
                

                この例では、L5 と L6 の非 FCoE リーフの設定を示します。

                switch# show running-config
                system qos
                  service-policy type qos input fcoe-default-in-policy
                  service-policy type queuing input fcoe-default-in-policy
                  service-policy type queuing output fcoe-default-out-policy
                  service-policy type network-qos fcoe-default-nq-policy
                vlan 100
                    mode fabric path
                vlan 200
                     mode fabric path
                
                

                この例では、L1 ~ FCF リーフの設定を示します(VSAN 100)。

                switch# show running-config
                feature fcoe
                vlan 100
                    mode fabric path
                    fcoe vsan 100
                vlan 200
                     mode fabric path
                
                vsan database
                     vsan 100
                
                fabricpath switch-id 301
                
                fcoe fka-adv-period  20
                
                

                この例では、L4 FCF リーフの設定を示します(VSAN 100、VSAN 200)。

                switch# show running-config
                feature fcoe
                vlan 100
                    mode fabric path
                    fcoe vsan 100
                vlan 200
                     mode fabric path
                     fcoe vsan 200
                vsan database
                     vsan 100
                     vsan 200
                
                fabricpath switch-id  304
                
                fcoe fka-adv-period 20
                
                

                この例では、L2 FCF リーフの設定を示します(VSAN 100)。

                switch# show running-config
                feature fcoe
                
                vlan 100
                    mode fabric path
                    fcoe vsan 100
                vlan 200
                     mode fabric path
                
                vsan database
                     vsan 100
                
                fabricpath switch-id 302
                
                fcoe fka-adv-period 20
                
                switch# show vpc
                vPC domain id                     : 1
                vPC+ switch id                    : 123
                
                :
                vPC Peer-link status
                -----------------------------------------------------------
                id Port Status Active vlans
                -- ---- ------ --------------------------------------------
                1  Po93 up     1,10,20,30,101,201,500
                interface port-channel93
                           fabricpath isis metric 16777215
                
                

                この例では、L3 FCF リーフの設定を示します(VSAN 200)。

                switch# show running-config
                feature fcoe
                
                vlan 100
                    mode fabric path
                
                vlan 200
                     mode fabric path
                     fcoe vsan 200
                vsan database
                     vsan 200
                
                fabricpath switch-id 303
                
                fcoe fka-adv-period 20
                
                switch# show vpc
                vPC domain id        : 1
                vPC+ switch id       : 123
                
                :
                -----------------------------------------------------------
                id Port Status Active vlans
                -- ---- ------ --------------------------------------------
                1  Po93 up     1,10,20,30,101,201,500
                interface port-channel93
                  fabricpath isis metric 16777215