Cisco Nexus 5600 シリーズ NX-OS Fibre Channel over Ethernet コンフィギュレーション ガイド、リリース 7.x
Cisco Adapter FEX with FCoE の設定
Cisco Adapter FEX with FCoE の設定

Cisco Adapter FEX with FCoE の設定

この章の内容は、次のとおりです。

概要

Cisco Adapter FEX with FCoE 機能を使用すると、Cisco Nexus 2000 シリーズ ファブリック エクステンダ(FEX)への FCoE 接続を作成し、仮想インターフェイス カード(VIC)アダプタによってサーバへの FCoE 接続を確立できます。

たとえば、この機能を使用して Cisco UCS P81E 仮想インターフェイス カードを含む Cisco UCS C シリーズ ラックマウント サーバに Nexus スイッチを接続したり、Broadcom BCM57712 コンバージェンスのネットワーク インターフェイス カード(C-NIC)がインストールされているサードパーティ製サーバに接続したりすることができます。

スイッチは仮想ポート チャネル(vPC)経由で FEX に接続し、FEX は FEX と VIC アダプタ間の標準 FCoE リンクを使用してサーバに接続します。

注意事項と制限

Enhanced vPC を使用する場合、FEX は FCoE 転送を行うために 1 つの Cisco Nexus ファブリックにのみ関連付けます。

FabricPath を使用する場合は、FCoE トラフィックの専用リンクを使用する必要があります。

Cisco UCS P81E 仮想インターフェイス カード(VIC)付きの Cisco UCS C シリーズ ラックマウント サーバを使用する場合は、次のとおりです。

  • VIC をネットワーク インターフェイス仮想化(NIV)モードで設定する必要があります。これにより、2 つの統合ポートが仮想ホスト バス アダプタ(vHBA)としてシステムに表示されます。

  • VNP ポートを介して VIC を FEX に接続することはできません。 このタイプの接続を使用する場合は、NIV モードを VIC でイネーブルにすることはできません。

  • Cisco UCS C シリーズ ラックマウント サーバ上の NIC モードは、active-standby に設定する必要があります。

Cisco Adapter FEX with FCoE の設定

手順
     コマンドまたはアクション目的
    ステップ 1configure terminal


    例:
    switch# configure terminal
    switch(config)#
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2install feature-set virtualization


    例:
    switch(config) # install feature-set virtualization
    switch(config) #
     

    仮想化機能セットをインストールします。

     
    ステップ 3feature-set virtualization


    例:
    switch(config) # feature-set virtualization
    switch(config)#
     

    仮想化機能を有効にします。

     
    ステップ 4fex fex-chassis-ID


    例:
    switch(config) # fex 101
    switch(config-fex) # 
     

    指定された FEX のコンフィギュレーション モードを開始します。

    fex-chassis_ID の範囲は 100 ~ 199 です。

     
    ステップ 5fcoe


    例:
    switch(config-fex) # fcoe
    switch(config-fex) # 
     

    FEX の Fibre Channel over Ethernet トラフィックをイネーブルにします。

     
    ステップ 6interface ethernet [fex-chassis-ID/slot/port]


    例:
    switch(config-fex)# interface ethernet 101/1/1
    switch(config-if)#
     

    指定されたイーサネット インターフェイスのコンフィギュレーション モードを開始します。

    fex-chassis-ID に指定できる範囲は 100 ~ 199 です。 FCoE の slot の場合、port の範囲は 1 ~ 32 です。

    (注)     

    これが 10G ブレークアウト ポートの場合、slot/port 構文は slot/QSFP-module/port になります。

     
    ステップ 7switchport mode vntag


    例:
    switch(config-if) # switchport mode vntag
    switch(config-if) # 
     

    ポート モードでインターフェイスを設定します。

     
    ステップ 8interface vethernet veth-id


    例:
    switch(config-if) # interface vethernet 2
    switch(config-if) # 
     

    仮想イーサネット インターフェイスを作成し、そのインターフェイスのコンフィギュレーション モードを開始します。

    veth-id の範囲は 1 ~ 1,048,575 です。

    (注)     

    2 台の Cisco Nexus シリーズ スイッチが冗長設定されている場合は、仮想イーサネット インターフェイス ID が各スイッチで一意である必要があります。

     
    ステップ 9bind interface ethernet [fex-chassis-ID/]slot/port channel channel-no


    例:
    switch(config-if) # bind interface ethernet 101/1/1 channel 1
    switch(config-if) # 
     

    指定したポート チャネルに指定したイーサネット インターフェイスをバインドします。

    fex-chassis-ID に指定できる範囲は 100 ~ 199 です。 slot は 1 にする必要があります。 FCoE の場合、port の範囲は 1 ~ 32 です。 channel-no の範囲は 1 ~ 4096 です。

    (注)     

    これが 10G ブレークアウト ポートの場合、slot/port 構文は slot/QSFP-module/port になります。

     
    ステップ 10switchport mode {trunk|access}


    例:
    switch(config-if) # switchport mode trunk
    switch(config-if) # 
     

    インターフェイスをトランク ポートまたはアクセス ポートとして設定します。

     
    ステップ 11switchport trunk allowed vlan vlan-ID


    例:
    switch(config-if) # switchport trunk allowed vlan 33
    switch(config-if) # 
     
    (任意)

    インターフェイスをトランク ポートとして設定する場合は、このコマンドを使用して FCoE トラフィックの VLAN を指定します。

    内部使用のために予約された VLAN を除いて、vlan-ID の範囲は 1 ~ 4094 です。

     
    ステップ 12switchport access vlan vlan-ID


    例:
    switch(config-if) # switchport access vlan 33
    switch(config-if) # 
     
    (任意)

    インターフェイスをアクセス ポートとして設定する場合は、このコマンドを使用して FCoE トラフィックの VLAN を指定します。

     
    ステップ 13interface vfc vfc-id


    例:
    switch(config-if) # interface vfc 4
    switch(config-if) # 
     

    スイッチ上で仮想ファイバ チャネル インターフェイスを作成し、コンフィギュレーション モードを開始します。

    vfc-id の範囲は 1 ~ 8192 です。

     
    ステップ 14bind interface vethernet veth-num


    例:
    switch(config-if) # bind interface veth 2
    switch(config-if) # 
     

    仮想ファイバ チャネル インターフェイスを、指定した仮想イーサネット インターフェイスにバインドします。

    veth-num の範囲は 1 ~ 1048575 です。

     
    ステップ 15no shutdown


    例:
    switch(config-if) # no shutdown
    switch(config-if) # 
     

    デフォルトの動作ステートにインターフェイスを戻します。

     

    次に、トランク ポートとして設定されたチャネル 1 の FEX 101 およびイーサネット インターフェイスを使用して、SAN ファブリック A の Cisco Adapter FEX with FCoE を設定する例を示します。

    nexus5000-sanA(config)#configure terminal
    nexus5000-sanA(config)#install feature-set virtualization
    nexus5000-sanA(config)#feature-set virtualization
    nexus5000-sanA(config)#fex 101
    nexus5000-sanA(config-fex)#fcoe
    nexus5000-sanA(config-fex)#interface ethernet 101/1/1
    nexus5000-sanA(config-if)#switchport mode vntag
    nexus5000-sanA(config-if)#interface veth 2
    nexus5000-sanA(config-if)#bind interface eth 101/1/1 channel 1
    nexus5000-sanA(config-if)#switchport mode trunk
    nexus5000-sanA(config-if)#switchport trunk allowed vlan 33
    nexus5000-sanA(config-if)#interface vfc 4
    nexus5000-sanA(config-if)#bind interface veth 2
    nexus5000-sanA(config-if)#no shutdown
    
    
    nexus6000-sanA(config)#configure terminal
    nexus6000-sanA(config)#install feature-set virtualization
    nexus6000-sanA(config)#feature-set virtualization
    nexus6000-sanA(config)#fex 101
    nexus6000-sanA(config-fex)#fcoe
    nexus6000-sanA(config-fex)#interface ethernet 101/1/1
    nexus6000-sanA(config-if)#switchport mode vntag
    nexus6000-sanA(config-if)#interface veth 2
    nexus6000-sanA(config-if)#bind interface eth 101/1/1 channel 1
    nexus6000-sanA(config-if)#switchport mode trunk
    nexus6000-sanA(config-if)#switchport trunk allowed vlan 33
    nexus6000-sanA(config-if)#interface vfc 4
    nexus6000-sanA(config-if)#bind interface veth 2
    nexus6000-sanA(config-if)#no shutdown
    

    次に、アクセス ポートとして設定されたチャネル 2 の FEX 102 およびイーサネット インターフェイスを使用して、SAN ファブリック B の Cisco Adapter FEX with FCoE を設定する例を示します。

    nexus5000-sanB(config)#configure terminal
    nexus5000-sanB(config)#install feature-set virtualization
    nexus5000-sanB(config)#feature-set virtualization
    nexus5000-sanB(config)#fex 102
    nexus5000-sanB(config-fex)#fcoe
    nexus5000-sanB(config-fex)#interface ethernet 102/1/1
    nexus5000-sanB(config-if)#switchport mode vntag
    nexus5000-sanB(config-if)#interface veth 5
    nexus5000-sanB(config-if)#bind interface eth 102/1/1 channel 2
    nexus5000-sanB(config-if)#switchport mode access
    nexus5000-sanB(config-if)#switchport access vlan 40
    nexus5000-sanB(config-if)#interface vfc 6
    nexus5000-sanB(config-if)#bind interface veth 5
    nexus5000-sanB(config-if)#no shutdown
    nexus6000-sanB(config)#configure terminal
    nexus6000-sanB(config)#install feature-set virtualization
    nexus6000-sanB(config)#feature-set virtualization
    nexus6000-sanB(config)#fex 102
    nexus6000-sanB(config-fex)#fcoe
    nexus6000-sanB(config-fex)#interface ethernet 102/1/1
    nexus6000-sanB(config-if)#switchport mode vntag
    nexus6000-sanB(config-if)#interface veth 5
    nexus6000-sanB(config-if)#bind interface eth 102/1/1 channel 2
    nexus6000-sanB(config-if)#switchport mode access
    nexus6000-sanB(config-if)#switchport access vlan 40
    nexus6000-sanB(config-if)#interface vfc 6
    nexus6000-sanB(config-if)#bind interface veth 5
    nexus6000-sanB(config-if)#no shutdown