Cisco Nexus 5500 シリーズ NX-OS SAN Release 7.x スイッチング コンフィギュレーション ガイド
ファイバ チャネル インターフェイスの設定
ファイバ チャネル インターフェイスの設定

目次

ファイバ チャネル インターフェイスの設定

この章の内容は、次のとおりです。

ファイバ チャネル インターフェイスの設定

ファイバ チャネル インターフェイスの概要

ファイバ チャネルのライセンス要件

Cisco Nexus デバイスでは、ファイバ チャネル機能は Storage Protocol Services ライセンスに含まれます。

ファイバ チャネル インターフェイスとその機能を使用する前に、正しいライセンス(N5010SS または N5020SS)がインストールされていることを確認します。


(注)  


Storage Protocol Services ライセンスなしで仮想ファイバ チャネル インターフェイスを設定できますが、ライセンスがアクティブになるまでこれらのインターフェイスは動作状態になりません。


物理ファイバ チャネル インターフェイス

Cisco Nexus デバイスは、2 つのオプション拡張モジュールを使用することにより、最大 16 の物理ファイバ チャネル(FC)アップリンクをサポートします。 最初のモジュールには 8 つの FC インターフェイスが搭載されています。 2 番めのモジュールには 4 つのファイバ チャネル ポートと 4 つのイーサネット ポートが搭載されています。

各ファイバ チャネル ポートをダウンリンク(サーバに接続)、またはアップリンク(データセンター SAN ネットワークに接続)として使用できます。 ファイバ チャネル インターフェイスは、E、F、NP、TE、TF、TNP、SD、auto の各モードをサポートしています。

仮想ファイバ チャネル インターフェイス

Fibre Channel over Ethernet(FCoE)カプセル化により、物理イーサネット ケーブルでファイバ チャネルとイーサネット トラフィックを同時に伝送できます。 Cisco Nexus デバイスでは、FCoE 対応の物理イーサネット インターフェイスは、1 つの仮想のファイバ チャネル(vFC)インターフェイスのトラフィックを伝送できます。

vFC インターフェイスは、Cisco NX-OS の他のインターフェイスと同様に、設定やステータスなどのプロパティを持つ、操作可能なオブジェクトです。 ネイティブ ファイバ チャネル インターフェイスと vFC インターフェイスは、同じ CLI コマンドを使用して設定します。

vFC インターフェイスは、F モードだけをサポートし、トランク モードでだけ動作します。

次の機能は、仮想ファイバ チャネル インターフェイスではサポートされません。

  • SAN ポート チャネル

  • SPAN 宛先は vFC インターフェイスにすることはできません。

  • Buffer-to-Buffer credit(BB_credit)

  • Exchange Link Parameter(ELP)または Fabric Shortest Path First(FSPF)プロトコル

  • 物理属性の設定(速度、レート、モード、トランスミッタ情報、MTU サイズ)

  • ポート トラッキング

VF ポート

vFC インターフェイスは、トランク モードで常に実行されます。vFC インターフェイスは、他のどのモードでも動作しません。 vFC インターフェイスでは、switchport trunk allowed vsan コマンドを使用して vFC の許可 VSAN を設定できます(FC TF および TE ポートと類似)。 ホストに接続されている vFC インターフェイスの場合、ログイン(FLOGI)をサポートする VSAN はポート VSAN だけです。 VF ポートを設定する switchport trunk allowed vsan コマンドをインターフェイス モードで使用し、このような vFC インターフェイスの許可 VSAN をポート VSAN に制限することを推奨します。

160 vFC インターフェイスのサポートが含まれます。

Cisco Nexus デバイスは、vFC VSAN 割り当てとグローバルな VLAN-to-VSAN マッピング テーブルにより、VF ポートに対して適切な VLAN を選択できます。

10G-FEX インターフェイス経由の VF ポートのサポートは、各ファブリック エクステンダが Cisco Nexus デバイスに直接接続する、Cisco Nexus ファブリック エクステンダ ストレート型トポロジでのみサポートされます。

VE ポート

仮想 E ポート(VE ポート)は、非ファイバ チャネル リンク上の E ポートをエミュレートするポートです。 Fibre Channel Forwarder(FCF)間の VE ポート接続は、ポイントツーポイント リンク上でサポートされます。 このリンクは、個々のイーサネット インターフェイス、またはイーサネット ポートチャネル インターフェイスのメンバです。 FCF が接続された各イーサネット インターフェイスに、vFC インターフェイスを作成し、バインドする必要があります。 インターフェイス モードで switchport mode e コマンドを使用して、vFC インターフェイスを VE ポートとして設定します。

VE ポートに関する注意事項は次のとおりです。

  • vFC で auto モードはサポートされません。

  • VE ポート トランキングは、FCoE 対応 VLAN 上でサポートされます。

  • MAC アドレスにバインドされている VE ポート インターフェイスはサポートされません。

  • デフォルトでは、VE ポートはトランク モードでイネーブルになります。

    VE ポート上に複数の VSAN を設定できます。 VE ポートの VSAN に対応する FCoE VLAN を、バインドしたイーサネット インターフェイスに設定する必要があります。

  • スパニングツリー プロトコルは、vFC インターフェイスがバインドされたすべてのインターフェイスの FCoE VLAN 上でディセーブルになります。これには、VE ポートがバインドされたインターフェイスが含まれます。

特定の FCF とピア FCF 間でサポートされる VE ポート ペアの数は、ピア FCF の FCF-MAC アドバタイジング機能に依存します。

  • ピア FCF がそのすべてのインターフェイス上で同じ FCF-MAC アドレスをアドバタイズする場合、1 つの VE ポート上で FCF をピア FCF に接続できます。 このようなトポロジでは、冗長性のために 1 つのポートチャネル インターフェイスを使用することを推奨します。

  • ピア FCF が複数の FCF-MAC アドレスをアドバタイズする場合は、テーブルの制限が適用されます。

vPC トポロジの VE ポート

vPC トポロジの VE ポートに関する注意事項は次のとおりです。

  • LAN トラフィック用の vPC 上で接続された FCF 間の FCoE VLAN には、専用リンクが必要です。

  • FCoE VLAN はスイッチ間の vPC インターフェイス上に設定しないでください。

FSPF のパラメータ

FSPF は、VSAN で起動すると、VE ポート上で VSAN 単位で動作します。 vFC インターフェイスのデフォルトの FSPF コスト(メトリック)は、10 Gbps 単位の帯域幅です。 イーサネット ポート チャネルにバインドされた VE ポートの場合、FSPF コストは動作可能なメンバ ポートの数に基づいて調整されます。

VE ポート設定の制限

Interface Type Platform
  Cisco Nexus 5500 シリーズ スイッチ 10 G のファブリック エクステンダ

イーサネット インターフェイスにバインドされた VE ポート

16 の VE ポート

サポート対象外

イーサネット ポートチャネル インターフェイスにバインドされた VE ポート

4 つの VE ポート

サポート対象外

VNP ポート

FCoE NPV ブリッジから FCF への接続は、ポイントツーポイント リンク上でのみサポートされます。 このリンクは、個々のイーサネット インターフェイス、またはイーサネット ポートチャネル インターフェイスのメンバです。 FCF が接続された各イーサネット インターフェイスに、vFC インターフェイスを作成し、バインドする必要があります。 これらの vFC インターフェイスは、VNP ポートとして設定する必要があります。 VNP ポートでは、FCoE NPV ブリッジが、それぞれ固有の eNode MAC アドレスが設定された複数の eNode を持つ FCoE 対応ホストをエミュレートします。 MAC アドレスにバインドされる VNP ポート インターフェイスはサポートされません。 デフォルトでは、VNP ポートはトランク モードでイネーブルになります。 VNP ポートには、複数の VSAN を設定できます。 VNP ポート VSAN に対応する FCoE VLAN を、バインドしたイーサネット インターフェイスに設定する必要があります。

スパニングツリー プロトコル(STP)は、VNP ポートがバインドされたインターフェイス上の FCoE VLAN では自動的にディセーブルになります。

インターフェイス モード

スイッチ内の各物理ファイバ チャネル インターフェイスは、複数のポート モード(E モード、TE モード、F モード、TF モード、TNP モード、および SD モード)のうちのいずれかで動作します。 物理ファイバ チャネル インターフェイスを E ポート、F ポート、または SD ポートとして設定できます。 インターフェイスを auto モードに設定することもできます。ポート タイプは、インターフェイスの初期化中に判別されます。

NPV モードでは、ファイバ チャネル インターフェイスは NP モード、F モード、または SD モードで動作します。

仮想ファイバ チャネル インターフェイスは F モードでだけ設定できます。

デフォルトでは、インターフェイスには VSAN 1 が自動的に割り当てられます。

各インターフェイスには、管理設定と動作ステータスが対応付けられています。

  • 管理設定は、修正を加えない限り変更されません。 この設定には、管理モードで設定できる各種の属性があります。

  • 動作ステータスは、インターフェイス速度のような指定された属性の現在のステータスを表します。 このステータスは変更できず、読み取り専用です。 インターフェイスがダウンの状態のときは、値の一部(たとえば、動作速度)が有効にならない場合があります。

E ポート

拡張ポート(E ポート)モードでは、インターフェイスがファブリック拡張ポートとして機能します。 このポートを別の E ポートに接続し、2 つのスイッチ間でスイッチ間リンク(ISL)を作成できます。 E ポートはフレームをスイッチ間で伝送し、ファブリックを設定および管理できるようにします。 リモート N ポート宛てフレームのスイッチ間コンジットとして機能します。 E ポートは、クラス 3 およびクラス F サービスをサポートします。

別のスイッチに接続された E ポートも、SAN ポート チャネルを形成するように設定できます。

F ポート

ファブリック ポート(F ポート)モードでは、インターフェイスがファブリック ポートとして機能します。 このポートをノード ポート(N ポート)として動作する周辺装置(ホストまたはディスク)に接続できます。 F ポートは、1 つの N ポートだけに接続できます。 F ポートはクラス 3 サービスをサポートします。

NP ポート

スイッチが NPV モードで動作しているとき、スイッチをコア ネットワーク スイッチに接続するインターフェイスは NP ポートとして設定されます。 NP ポートは N ポートと同様に動作しますが、複数の物理 N ポートに対するプロキシとして機能します。

関連情報

TE ポート

トランキング E ポート(TE ポート)モードでは、インターフェイスがトランキング拡張ポートとして機能します。 別の TE ポートに接続し、2 つのスイッチ間で Extended ISL(EISL)を作成します。 TE ポートは別の Cisco Nexus デバイスまたは Cisco MDS 9000 ファミリ スイッチに接続します。 E ポートの機能を拡張して、次の内容をサポートします。

  • VSAN(仮想 SAN)トランキング。

  • ファイバ チャネル トレース(fctrace)機能

TE ポート モードでは、すべてのフレームが VSAN 情報を含む EISL フレーム フォーマットで送信されます。 相互接続されたスイッチは VSAN ID を使用して、1 つまたは複数の VSAN からのトラフィックを同一の物理リンク上で多重化します。 この機能は、Cisco Nexus デバイスでは VSAN トランキングと呼ばれます。 TE ポートは、クラス 3 およびクラス F サービスをサポートします。

TF ポート

スイッチが NPV モードで動作しているとき、スイッチをコア ネットワーク スイッチに接続するインターフェイスは NP ポートとして設定されます。 NP ポートは N ポートと同様に動作しますが、複数の物理 N ポートに対するプロキシとして機能します。

トランキング F ポート(TF ポート)モードでは、インターフェイスがトランキング拡張ポートとして機能します。 トランキングした別の N ポート(TN ポート)または NP ポート(TNP ポート)に接続して、コア スイッチと NPV スイッチまたは HBA の間のリンクを作成し、タグ付きフレームを伝送できます。 TF ポートは、F ポートの機能を拡張して、VSAN トランキングをサポートします。

TF ポート モードでは、すべてのフレームが、VSAN 情報を含む EISL フレーム フォーマットで送信されます。 相互接続されたスイッチは VSAN ID を使用して、1 つまたは複数の VSAN からのトラフィックを同一の物理リンク上で多重化します。 この機能は、Cisco Nexus デバイスでは VSAN トランキングと呼ばれます。 TF ポートは、クラス 3 およびクラス F サービスをサポートします。

TNP ポート

トランキング NP ポート(TNP ポート)モードでは、インターフェイスがトランキング拡張ポートとして機能します。 TNP ポートは、トランキングされた F ポート(TF ポート)に接続し、NPV スイッチからコア NPIV スイッチへのリンクを作成できます。

SD ポート

SPAN 宛先ポート(SD ポート)モードでは、インターフェイスがスイッチド ポート アナライザ(SPAN)として機能します。 SPAN 機能は、ファイバ チャネル インターフェイスを通過するネットワーク トラフィックを監視します。 このモニタリングは、SD ポートに接続された標準ファイバ チャネル アナライザ(または同様のスイッチ プローブ)を使用して行われます。 SD ポートはフレームを受信しません。送信元トラフィックのコピーを送信するだけです。 SPAN 機能は他の機能に割り込むことなく、SPAN 送信元ポートのネットワーク トラフィックのスイッチングに影響しません。

auto モード

auto モードに設定されたインターフェイスは、E ポート、F ポート、NP ポート、TE ポート、TF ポート、または TNP ポートのいずれかのモードで動作します。 ポート モードは、インターフェイスの初期設定中に決定されます。 たとえば、インターフェイスがノード(ホストまたはディスク)に接続されている場合、F ポート モードで動作します。 インターフェイスがサードパーティ製のスイッチに接続されている場合、E ポート モードで動作します。 インターフェイスが Cisco Nexus デバイスまたは Cisco MDS 9000 ファミリの別のスイッチに接続されている場合、TE ポート モードで動作できます。

SD ポートは初期化で判別されず、管理上設定されます。

インターフェイス ステート

インターフェイス ステートは、インターフェイスの管理設定および物理リンクのダイナミック ステートによって異なります。

管理ステート

管理のステートは、インターフェイスの管理設定を表します。 次の表に、管理ステートを示します。

表 1 管理ステート

管理ステート

説明

Up

インターフェイスはイネーブルです。

Down

インターフェイスはディセーブルです。 インターフェイスをシャットダウンして管理上のディセーブル状態にした場合は、物理リンク層ステートの変更が無視されます。

動作ステート

動作ステートは、インターフェイスの現在の動作ステートを示します。 次の表に、動作ステートを示します。

表 2 動作ステート

動作ステート

説明

Up

インターフェイスは、トラフィックを要求に応じて送受信しています。 このステートにするためには、インターフェイスが管理上アップの状態、インターフェイス リンク層ステートがアップの状態で、インターフェイスの初期化が完了している必要があります。

Down

インターフェイスが(データ)トラフィックを送信または受信できません。

トランキング

インターフェイスが TE または TF モードで正常に動作しています。

理由コード

理由コードは、インターフェイスの動作ステートによって異なります。 次の表に、動作ステートの理由コードを示します。

表 3  インターフェイス ステートの理由コード

管理設定

動作ステート

原因コード

Up

Up

なし。

Down

Down

管理上のダウン。 インターフェイスを管理上ダウンの状態に設定する場合、インターフェイスをディセーブルにします。 トラフィックが受信または送信されません。

Up

Down

次の表を参照してください。

管理ステートが up で、動作ステートが down の場合、理由コードは、動作不能理由コードに基づいて異なります。 次の表に、動作不能ステートの理由コードを示します。


(注)  


表に示されている理由コードは一部だけです。


表 4 非動作ステートの原因コード

理由コード(長いバージョン)

説明

適用可能なモード

Link failure or not connected

物理層リンクが正常に動作していません。

すべて(All)

SFP not present

Small Form-Factor Pluggable(SFP)ハードウェアが接続されていません。

すべて(All)

Initializing

物理層リンクが正常に動作しており、プロトコル初期化が進行中です。

すべて(All)

Reconfigure fabric in progress

ファブリックが現在再設定されています。

Offline

初期化を再試行する前に、スイッチ ソフトウェアが指定された R_A_TOV 時間待機します。

Inactive

インターフェイス VSAN が削除されているか、suspended ステートにあります。

インターフェイスを正常に動作させるには、設定されたアクティブな VSAN にポートを割り当てます。

Hardware failure

ハードウェア障害が検出されました。

Error disabled

エラー条件は、管理上の注意を必要とします。 さまざまな理由でインターフェイスがエラーディセーブルになることがあります。 次に例を示します。

  • 設定障害。

  • 互換性のない BB_credit 設定。

インターフェイスを正常に動作させるには、まずこのステートの原因となるエラー条件を修正し、次にインターフェイスを管理上シャットダウンにするか、インターフェイスをイネーブルにします。

Isolation because limit of active port channels is exceeded.

スイッチにアクティブ SAN ポート チャネルの最大数がすでに設定されているので、インターフェイスは隔離されます。

Isolation due to ELP failure

ポート ネゴシエーションが失敗しました。

E ポートと TE ポートのみ

Isolation due to ESC failure

ポート ネゴシエーションが失敗しました。

Isolation due to domain overlap

Fibre Channel Domain(fcdomain)のオーバーラップ。

Isolation due to domain ID assignment failure

割り当てられたドメイン ID が無効です。

Isolation due to the other side of the link E port isolated

リンクのもう一方の端の E ポートが分離しています。

Isolation due to invalid fabric reconfiguration

ファブリックの再設定によりポートが分離されました。

Isolation due to domain manager disabled

fcdomain 機能がディセーブルです。

Isolation due to zone merge failure

ゾーン結合に失敗しました。

Isolation due to VSAN mismatch

ISL の両端の VSAN が異なります。

port channel administratively down

SAN ポート チャネルに所属するインターフェイスがダウンの状態です。

SAN ポート チャネル インターフェイスのみ

Suspended due to incompatible speed

SAN ポート チャネルに所属するインターフェイスに互換性のない速度が存在します。

Suspended due to incompatible mode

SAN ポート チャネルに所属するインターフェイスに互換性のないモードが存在します。

Suspended due to incompatible remote switch WWN

不適切な接続が検出されました。 SAN ポート チャネルのすべてのインターフェイスが同一のスイッチ ペアに接続されている必要があります。

Bound physical interface down

仮想ファイバ チャネル インターフェイスにバインドされたイーサネット インターフェイスが動作していません。

仮想ファイバ チャネル インターフェイスのみ

STP not forwarding in FCoE mapped VLAN

仮想ファイバ チャネル インターフェイスにバインドされたイーサネット インターフェイスが、仮想ファイバ チャネル インターフェイスに関連付けられた VLAN に対して STP フォワーディング ステートではありません。

仮想ファイバ チャネル インターフェイスのみ

Buffer-to-Buffer credit(BB_credit)

BB_credit はフロー制御メカニズムで、ファイバ チャネル インターフェイスがフレームをドロップしないようにします。 BB_creditは、ホップごとにネゴシエーションします。

Cisco Nexus デバイスでは、ファイバ チャネル インターフェイスで BB_credit メカニズムが使用されますが、仮想ファイバ チャネル インターフェイスでは使用されません。 受信 BB_credit では、ピアへの確認応答を必要とせずに、受信側の受信バッファの容量が決まります。 これは、帯域幅遅延が大きいリンク(遅延が大きい長距離リンク)で、遅延時間が長い回線レート トラフィックを維持できるようにするうえで重要です。

受信 BB_credit 値(fcrxbbcredit)は、ファイバ チャネル インターフェイスごとに設定できます。 ほとんどの場合、デフォルト設定を変更する必要がありません。

仮想ファイバ チャネル インターフェイスの場合、BB_credit は使用されません。 仮想ファイバ チャネル インターフェイスは、基本の物理イーサネット インターフェイスの機能に基づいて、フロー制御を実行します。


(注)  


受信 BB_credit 値は、ポート モードによって異なります。 物理ファイバ チャネル インターフェイスの場合、F モードおよび E モード インターフェイスのデフォルト値は 16 です。 必要に応じて、この値を変更できます。 最大値は 240 です。


ファイバ チャネル インターフェイスの設定

ファイバ チャネル インターフェイスの設定

ファイバ チャネル インターフェイスを設定する手順は、次のとおりです。

手順
     コマンドまたはアクション目的
    ステップ 1 switch# configuration terminal
     

    コンフィギュレーション モードに入ります。

     
    ステップ 2 switch(config)# interface {fc slot/port}|{vfc vfc-id}
     

    ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

    (注)     

    ファイバ チャネル インターフェイスが設定された場合、自動的に一意の World Wide Name(WWN)が割り当てられます。 インターフェイスの動作ステートが up の場合、ファイバ チャネル ID(FC ID)も割り当てられます。

    (注)     

    これが QSFP+ GEMS の場合、slot/port 構文は slot/QSFP-module/port になります。

     

    ファイバ チャネル インターフェイスの範囲の設定

    ファイバ チャネル インターフェイスの範囲を設定する手順は、次のとおりです。

    手順
       コマンドまたはアクション目的
      ステップ 1 switch# configuration terminal
       

      コンフィギュレーション モードに入ります。

       
      ステップ 2 switch(config)# interface { fc slot/port - port [ , fc slot/port - port ] | vfc vfc-id - vfc-id [ , vfc vfc-id - vfc-id ] }
       

      ファイバ チャネル インターフェイスの範囲を選択し、インターフェイス コンフィギュレーション モードを開始します。

      (注)     

      これが QSFP+ GEMS の場合、slot/port 構文は slot/QSFP-module/port になります。

       

      インターフェイスの管理ステートの設定

      インターフェイスを正常にシャットダウンする手順は、次のとおりです。

      トラフィック フローをイネーブルにする手順は、次のとおりです。

      手順
         コマンドまたはアクション目的
        ステップ 1 switch# configuration terminal
         

        コンフィギュレーション モードに入ります。

         
        ステップ 2 switch(config)# interface {fc slot/port}|{vfc vfc-id}
         

        ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

        (注)     

        これが QSFP+ GEMS の場合、slot/port 構文は slot/QSFP-module/port になります。

         
        ステップ 3 switch(config-if)# shutdown
         

        インターフェイスを正常にシャットダウンし、トラフィック フローを管理上ディセーブルにします(デフォルト)。

         

        インターフェイス モードの設定

        手順

           コマンドまたはアクション目的
          ステップ 1configure terminal


          例:
          switch# configure terminal
          switch(config)#
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2switch(config) # interface vfc vfc-id}

          例:
          switch(config) # interface vfc 20
          switch(config-if) #
          
           

          仮想ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

           
          ステップ 3switch(config-if) # switchport mode {E|NP}

          例:
          switch(config-if) # switchport mode E
          switch(config-if) #
          
           

          ポート モードを設定します。

          vFC インターフェイスは、モード E および NP だけをサポートします。

          (注)     

          SD ポートを自動では設定できません。 このポートは管理上設定する必要があります。

           

          次に、VE ポート 20 を設定し、イーサネット スロット 1、ポート 3 にバインドする例を示します。

          switch# config t
          switch(config) # interface vfc 20
          switch(config-if) # bind interface ethernet 1/3
          switch(config-if) # switchport mode E
          switch(config-if) # exit
          switch#
          
          

          次に、イーサネット slot1、ポート 3 インターフェイスにバインドされた vFC 20 の実行コンフィギュレーションの例を示します。

          switch# show running-config
          switch(config) # interface vfc20
          switch(config-if) # bind interface Ethernet 1/3
          switch(config-if) # switchport mode E
          switch(config-if) # no shutdown
          
          

          次に、VNP ポート 10 を設定し、イーサネット スロット 2、ポート 1 にバインドする例を示します。

          switch # config t
          switch(config) # interface vfc 10
          switch(config-if) # bind interface ethernet 2/1
          switch(config-if) # switchport mode NP
          switch(config-if) # exit
          switch#
          
          

          インターフェイスの説明の設定

          インターフェイスの説明は、トラフィックを識別したり、インターフェイスの使用状況を知る場合に役立ちます。 インターフェイスの説明には、任意の英数字の文字列を使用できます。

          インターフェイスの説明を設定する手順は、次のとおりです。

          手順
             コマンドまたはアクション目的
            ステップ 1 switch# configuration terminal
             

            コンフィギュレーション モードに入ります。

             
            ステップ 2 switch(config)# interface {fc slot/port}|{vfc vfc-id}
             

            ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

            (注)     

            これが QSFP+ GEMS の場合、slot/port 構文は slot/QSFP-module/port になります。

             
            ステップ 3 switch(config-if)# switchport description cisco-HBA2
             

            インターフェイスの説明を設定します。 ストリングの長さは、最大 80 文字まで可能です。

             
            ステップ 4 switch(config-if)# no switchport description
             

            インターフェイスの説明をクリアします。

             

            ポート速度の設定

            ポート速度は、物理ファイバ チャネル インターフェイスで設定できますが、仮想ファイバ チャネル インターフェイスでは設定できません。 デフォルトでは、インターフェイスのポート速度はスイッチによって自動計算されます。


            注意    


            ポート速度の変更は中断を伴う動作です。


            インターフェイスのポート速度を設定する手順は、次のとおりです。

            手順
               コマンドまたはアクション目的
              ステップ 1 switch# configuration terminal
               

              コンフィギュレーション モードに入ります。

               
              ステップ 2 switch(config)# interface fc slot/port
               

              指定されたインターフェイスを選択して、インターフェイス コンフィギュレーション モードを開始します。

              (注)     

              仮想ファイバ チャネル インターフェイスのポート速度は設定できません。

              (注)     

              これが QSFP+ GEMS の場合、slot/port 構文は slot/QSFP-module/port になります。

               
              ステップ 3 switch(config-if)# switchport speed 1000
               

              インターフェイスのポート速度を 1000 Mbps に設定します。

              数値は、Mbps 単位の速度を表します。 1 Gbps インターフェイスには 1000 Mbps の速度、2 Gbps インターフェイスには 2000 Mbps の速度、4 Gbps インターフェイスには 4000、または auto(デフォルト)を設定できます。

               
              ステップ 4 switch(config-if)# no switchport speed
               

              インターフェイスの管理速度を工場出荷時のデフォルト(auto)に戻します。

               

              自動検知

              デフォルトではすべての 4 Gbps インターフェイスで 速度自動検知がイネーブルになっています。 この設定を使用すると、4 Gbps ポートのインターフェイスは 1 Gbps、2 Gbps、または 4 Gbps の速度で動作します。 専用レート モードで動作するインターフェイスに対して自動検知をイネーブルにすると、ポートが 1 Gbps または 2 Gbps の動作速度をネゴシエートした場合でも、4 Gbps 帯域幅が予約されます。

              SD ポート フレーム カプセル化の設定

              switchport encap eisl コマンドは、SD ポート インターフェイスにだけ適用されます。 このコマンドは、SD ポート モードにあるインターフェイスによって送信されたすべてのフレームのフレーム フォーマットを判別します。 カプセル化を EISL に設定すると、すべての SPAN 送信元について、すべての発信フレームが EISL フレーム フォーマットで送信されます。

              switchport encap eisl コマンドは、デフォルトではディセーブルです。 カプセル化をイネーブルにする場合、すべての発信フレームがカプセル化され、show interface SD_port_interface コマンド出力に新しい行(Encapsulation is eisl)が表示されます。

              受信データ フィールド サイズの設定

              仮想ファイバ チャネル インターフェイスではなく、ネイティブ ファイバ チャネル インターフェイスの受信データ フィールド サイズを設定できます。 デフォルトのデータ フィールド サイズが 2112 バイトの場合、フレームの長さは 2148 バイトです。

              受信データ フィールド サイズを設定する手順は、次のとおりです。

              手順
                 コマンドまたはアクション目的
                ステップ 1 switch# configuration terminal
                 

                コンフィギュレーション モードに入ります。

                 
                ステップ 2 switch(config)# interface fc slot/port
                 

                ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

                (注)     

                これが QSFP+ GEMS の場合、slot/port 構文は slot/QSFP-module/port になります。

                 
                ステップ 3 switch(config-if)# switchport fcrxbufsize 2000
                 

                選択されたインターフェイスのデータ フィールド サイズを 2000 バイトに減らします。 デフォルトは 2112 バイトで、範囲は 256 ~ 2112 バイトです。

                 

                ビット エラーしきい値の概要

                ビット エラー レートしきい値は、パフォーマンスの低下がトラフィックに重大な影響を与える前にエラー レートの増加を検出するために、スイッチにより使用されます。

                ビット エラーは、次の理由で発生することがあります。

                • ケーブル故障または不良
                • GBIC または SFP 故障または不良
                • GBIC または SFP は 1 Gbps で動作するように指定されているが、2 Gbps で使用されている。
                • GBIC または SFP は 2 Gbps で動作するように指定されているが、4 Gbps で使用されている。
                • 長距離に短距離ケーブルが使用されている、または短距離に長距離ケーブルが使用されている。
                • 一時的な同期ロス
                • ケーブルの片端または両端の接続のゆるみ
                • 片端または両端での不適切な GBIC 接続または SFP 接続

                5 分間に 15 のエラー バーストが発生すると、ビット エラー レートしきい値が検出されます。 デフォルトでは、しきい値に達するとスイッチはインターフェイスをディセーブルにします。

                shutdown/no shutdown コマンドを入力して、インターフェイスを再度イネーブルにできます。

                しきい値を超えてもインターフェイスがディセーブルにならないようにスイッチを設定できます。


                (注)  


                ビット エラーしきい値イベントによってインターフェイスがディセーブルにならないように設定されていても、ビット エラーしきい値イベントが検出されると、スイッチによって syslog メッセージが生成されます。


                インターフェイスのビット エラーしきい値をディセーブルにする手順は、次のとおりです。

                手順
                   コマンドまたはアクション目的
                  ステップ 1 switch# configuration terminal
                   

                  コンフィギュレーション モードに入ります。

                   
                  ステップ 2 switch(config)# interface fc slot/port
                   

                  ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

                  (注)     

                  これが QSFP+ GEMS の場合、slot/port 構文は slot/QSFP-module/port になります。

                   
                  ステップ 3 switch(config-if)# switchport ignore bit-errors
                   

                  ビット エラーしきい値イベントを検出したとき、インターフェイスがディセーブルにならないようにします。

                   
                  ステップ 4 switch(config-if)# no switchport ignore bit-errors
                   

                  ビット エラーしきい値イベントを検出したとき、インターフェイスがイネーブルにならないようにします。

                   

                  Buffer-to-Buffer Credits の設定

                  手順
                     コマンドまたはアクション目的
                    ステップ 1switch# configure terminal  

                    グローバル コンフィギュレーション モードを開始します。

                     
                    ステップ 2 switch(config)# interface fc slot/port
                     

                    ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

                    (注)     

                    これが QSFP+ GEMS の場合、slot/port 構文は slot/QSFP-module/port になります。

                     
                    ステップ 3 switch(config-if)# switchport fcrxbbcredit default
                     

                    デフォルトの使用可能な値を選択されたインターフェイスに適用します。 使用可能な値は、ポート モードによって異なります。

                    デフォルト値は、ポート機能に応じて割り当てられます。

                     
                    ステップ 4 switch(config-if)# switchport fcrxbbcredit number mode {E | F | TE}
                     

                    選択したインターフェイスに Buffer-to-Buffer credit 番号を割り当て、必要に応じてポートが E、F、または TE のどのモードで動作するかを指定します。

                    (注)     

                    modeEF、または TE を指定すると、ポートをそのモードに設定した場合にのみ Buffer-to-Buffer credit 値が適用可能になります。

                    Buffer-to-Buffer credit には、number で 1~240 の範囲の番号を指定します。

                    デフォルト値は 16 です。

                     
                    ステップ 5 switch(config-if)# do show int fc slot/port
                     

                    送受信の Buffer-to-Buffer credit を、このインターフェイスのその他の関連インターフェイス情報とともに表示します。

                    (注)     

                    正しい Buffer-to-Buffer credit 値は、レジスタの読み取り時に得られます。 データ トラフィックが遅いときに状況を確認するのに役立ちます。

                    (注)     

                    これが QSFP+ GEMS の場合、slot/port 構文は slot/QSFP-module/port になります。

                     
                    ステップ 6switch(config-if)# copy running-config startup-config   (任意)

                    リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

                     

                    ファイバ チャネル インターフェイスのグローバル属性の設定

                    スイッチ ポート属性のデフォルト値の設定

                    各種のスイッチ ポート属性の属性デフォルト値を設定できます。 これらの属性は、この時点でそれぞれを指定しなくても、今後のすべてのスイッチ ポート設定にグローバルに適用されます。

                    スイッチ ポート属性を設定する手順は、次のとおりです。

                    手順
                       コマンドまたはアクション目的
                      ステップ 1 switch# configuration terminal
                       

                      コンフィギュレーション モードに入ります。

                       
                      ステップ 2 switch(config)# no system default switchport shutdown san
                       

                      インターフェイス管理ステートのデフォルト設定を up に設定します (出荷時のデフォルト設定は down です)。

                      ヒント   

                      このコマンドは、管理ステートに対してユーザ設定が存在しないインターフェイスにだけ適用されます。

                       
                      ステップ 3 switch(config)# system default switchport shutdown san
                       

                      インターフェイス管理ステートのデフォルト設定を down に設定します。 これが出荷時のデフォルト設定です。

                      ヒント   

                      このコマンドは、管理ステートに対してユーザ設定が存在しないインターフェイスにだけ適用されます。

                       
                      ステップ 4 switch(config)# system default switchport trunk mode auto
                       

                      インターフェイスの管理トランク モード ステートのデフォルト設定を auto に設定します。

                      (注)     

                      デフォルト設定のトランク モードは on です。

                       

                      N ポート識別子仮想化について

                      N ポート識別子仮想化(NPIV)は単一 N ポートに複数の FC ID を割り当てる手段を提供します。 この機能を使用すると、N ポート上の複数のアプリケーションが異なる ID を使用したり、アクセス コントロール、ゾーニング、ポート セキュリティをアプリケーション レベルで実装したりできます。 次の図に、NPIV を使用するアプリケーションの例を示します。

                      図 1. NPIV の例

                      N ポート ID バーチャライゼーションのイネーブル化

                      スイッチで NPIV をイネーブルまたはディセーブルにできます。

                      はじめる前に

                      スイッチ上のすべての VSAN に対して NPIV をグローバルでイネーブルにし、NPIV 対応のアプリケーションが複数の N ポート ID を使用できるようにする必要があります。


                      (注)  


                      すべての N ポート ID は同じ VSAN 内で割り当てられます。


                      手順
                         コマンドまたはアクション目的
                        ステップ 1 configure terminal


                        例:
                        switch# configure terminal
                        switch(config)#
                         

                        コンフィギュレーション モードに入ります。

                         
                        ステップ 2 feature npiv


                        例:
                        switch(config)# feature npiv
                         

                        スイッチ上のすべての VSAN の NPIV をイネーブルにします。

                         
                        ステップ 3 no feature npiv


                        例:
                        switch(config)# no feature npiv
                         

                        スイッチ上の NPIV をディセーブルにします(デフォルト)。

                         

                        ポート チャネルの設定例

                        この項では、F ポート チャネルを共有モードで設定する方法、および NPIV コア スイッチの F ポートと NPV スイッチの NP ポート間のリンクを起動する方法の例を示します。 F ポート チャネルを設定する前に、F ポート トランキング、F ポート チャネリング、および NPIV がイネーブルであることを確認します。

                        次の例は、ポート チャネルの作成方法を示しています。

                        switch(config)# interface port-channel 2
                        switch(config-if)# switchport mode F
                        switch(config-if)# switchport  dedicated
                        switch(config-if)# channel mode active
                        switch(config-if)# exit
                         

                        次に、コア スイッチで専用モードでポート チャネル メンバ インターフェイスを設定する例を示します。

                        switch(config)# interface fc1/4-6
                        switch(config-if)# shut
                        switch(config-if)# switchport mode F
                        switch(config-if)# switchport speed 4000
                        switch(config-if)# switchport rate-mode dedicated
                        switch(config-if)# switchport trunk mode on
                        switch(config-if)# channel-group 2
                        switch(config-if)# no shut
                        switch(config-if)# exit
                         

                        次に、NPV スイッチで専用モードでポート チャネルを作成する例を示します。

                        switch(config)# interface san-port-channel 2
                        switch(config-if)# switchport mode NP
                        switch(config-if)# no shut
                        switch(config-if)# exit
                         

                        次に、NPV スイッチ上でポート チャネル メンバ インターフェイスを設定する例を示します。

                        switch(config)# interface fc2/1-2
                        switch(config-if)# shut
                        switch(config-if)# switchport mode NP
                        switch(config-if)# switchport trunk mode on
                        switch(config-if)# channel-group 2
                        switch(config-if)# no shut
                        switch(config-if)# exit
                         

                        ファイバ チャネル インターフェイスの確認

                        SFP トランスミッタ タイプの確認

                        SFP トランスミッタ タイプは、仮想ファイバ チャネルではなく、物理ファイバ チャネル インターフェイス用に表示できます。

                        SFP ハードウェア トランスミッタは、show interface brief コマンドで表示される際に略語で示されます。 関連する SFP がシスコによって割り当てられた拡張 ID を持つ場合、show interface コマンドと show interface brief コマンドは、トランスミッタ タイプではなく、ID を表示します。 show interface transceiver コマンドと show interface fc slot/port transceiver コマンドは、シスコがサポートする SFP に対して両方の値を表示します。

                        インターフェイス情報の確認

                        show interface コマンドはインターフェイス情報を表示します。 引数を入力しないと、このコマンドはスイッチ内に設定されたすべてのインターフェイスの情報を表示します。

                        インターフェイス情報を表示するのに引数(インターフェイスの範囲、または複数の指定されたインターフェイス)を指定することもできます。 interface fc2/1 - 4 , fc3/2 - 3 の形式でコマンドを入力して、インターフェイスの範囲を指定できます。

                        次に、すべてのインターフェイスを表示する例を示します。

                        switch# show interface
                        
                        fc3/1 is up
                        ...
                        fc3/3 is up
                        ...
                        Ethernet1/3 is up
                        ...
                        mgmt0 is up
                        ...
                        vethernet1/1 is up
                        ...
                        vfc 1 is up
                        
                        

                        次に、指定された複数のインターフェイスを表示する例を示します。

                        switch# show interface fc3/1 , fc3/3
                        fc3/1 is up
                        ...
                        fc3/3 is up
                        ...
                        
                        

                        次に、特定の 1 つのインターフェイスを表示する例を示します。

                        switch# show interface vfc 1
                        
                        vfc 1 is up
                        ...

                        次に、インターフェイスの説明を表示する例を示します。

                        switch# show interface description
                        -------------------------------------------------
                        Interface          Description
                        -------------------------------------------------
                        fc3/1              test intest
                        Ethernet1/1              --
                        vfc 1              --
                        ...
                        
                        

                        次に、すべてのインターフェイスを表示する例を示します(簡略)。

                        switch# show interface brief
                        

                        次に、インターフェイス カウンタを表示する例を示します。

                        switch# show interface counters
                        

                        次に、特定のインターフェイスのトランシーバ情報を表示する例を示します。

                        switch# show interface fc3/1 transceiver
                        

                        (注)  


                        SFP が存在する場合にだけ、show interface transceiver コマンドは有効です。


                        show running-configuration コマンドを実行すると、すべてのインターフェイスの情報を含む実行コンフィギュレーション全体が表示されます。 スイッチがリロードしたとき、インターフェイス コンフィギュレーション コマンドが正しい順序で実行するように、インターフェイスはコンフィギュレーション ファイルに複数のエントリを持っています。 特定のインターフェイスの実行コンフィギュレーションを表示する場合、そのインターフェイスのすべてのコンフィギュレーション コマンドはグループ化されます。

                        次の例では、すべてのインターフェイスの実行コンフィギュレーションを表示する場合のインターフェイスの表示を示します。

                        switch# show running configuration
                        ...
                        interface fc3/5
                          switchport speed 2000
                        ...
                        interface fc3/5
                          switchport mode E 
                        ...
                        interface fc3/5
                          channel-group 11 force
                          no shutdown
                        
                        

                        次の例では、特定のインターフェイスの実行コンフィギュレーションを表示する場合のインターフェイスの表示を示します。

                        switch# show running configuration fc3/5
                        interface fc3/5
                          switchport speed 2000
                          switchport mode E
                          channel-group 11 force
                          no shutdown
                        
                        

                        BB_credit 情報の確認

                        次に、すべてのファイバ チャネル インターフェイスの BB_credit 情報を表示する例を示します。

                        switch# show interface fc2/1
                        ...
                        fc2/1 is up
                           Hardware is Fibre Channel, SFP is short wave laser w/o OFC (SN)
                            Port WWN is 20:41:00:2a:6a:78:5a:80
                            Admin port mode is F, trunk mode is on
                            snmp link state traps are enabled
                            Port mode is F, FCID is 0x400220
                            Port vsan is 1
                            Speed is 8 Gbps
                            Transmit B2B Credit is 5
                            Receive B2B Credit is 15
                            Receive data field Size is 2112
                            Beacon is turned off
                            1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
                            1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
                              50797511 frames input, 94079655820 bytes
                                0 discards, 0 errors
                                1 CRC,  0 unknown class
                                0 too long, 0 too short
                              53584181 frames output, 94072838324 bytes
                                0 discards, 0 errors
                              0 input OLS, 0 LRR, 0 NOS, 0 loop inits
                              1 output OLS, 1 LRR, 0 NOS, 0 loop inits
                            last clearing of "show interface" counters never
                              15 receive B2B credit remaining
                              5 transmit B2B credit remaining
                              0 low priority transmit B2B credit remaining
                            Interface last changed at Mon May 19 20:15:53 2014
                            
                        

                        ファイバ チャネル インターフェイスのデフォルト設定

                        次の表に、ネイティブ ファイバ チャネル インターフェイス パラメータのデフォルト設定を示します。

                        表 5  デフォルトのネイティブ ファイバ チャネル インターフェイス パラメータ

                        パラメータ(Parameters)

                        デフォルト

                        インターフェイス モード

                        自動

                        インターフェイス速度

                        自動

                        管理状態

                        Shutdown(初期設定時に変更された場合を除く)

                        トランク モード

                        On(初期設定時に変更された場合を除く)

                        トランク許可 VSAN

                        1 ~ 4093

                        インターフェイス VSAN

                        デフォルト VSAN(1)

                        標識モード

                        Off(ディセーブル)

                        EISL カプセル化

                        ディセーブル

                        データ フィールド サイズ

                        2112 バイト

                        次の表に、仮想ファイバ チャネル インターフェイス パラメータのデフォルト設定を示します。

                        表 6  デフォルトの仮想ファイバ チャネル インターフェイス パラメータ

                        パラメータ(Parameters)

                        デフォルト

                        インターフェイス モード

                        F モード

                        インターフェイス速度

                        n/a

                        管理状態

                        Shutdown(初期設定時に変更された場合を除く)

                        トランク モード

                        On

                        トランク許可 VSAN

                        すべての VSAN

                        インターフェイス VSAN

                        デフォルト VSAN(1)

                        EISL カプセル化

                        n/a

                        データ フィールド サイズ

                        n/a