Cisco Nexus 5500 シリーズ NX-OS インターフェイス コンフィギュレーション ガイド リリース 6.0(2)N1(1)
ポート チャネルの設定
ポート チャネルの設定
発行日;2013/03/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

ポート チャネルの設定

この章の内容は、次のとおりです。

ポート チャネルについて

ポート チャネルは、個別インターフェイスを 1 つのグループに集約して、帯域幅と冗長性の向上を実現します。 これらの集約された各物理インターフェイス間でトラフィックのロード バランシングも行います。 ポート チャネルの物理インターフェイスが少なくとも 1 つ動作していれば、そのポート チャネルは動作しています。

互換性のあるインターフェイスをバンドルすることにより、ポート チャネルを作成します。 スタティック ポート チャネル、またはリンク アグリゲーション制御プロトコル(LACP)を実行するポート チャネルを設定および実行できます。

変更した設定をポート チャネルに適用すると、そのポート チャネルのメンバ インターフェイスにもそれぞれ変更が適用されます。 たとえば、スパニングツリー プロトコル(STP)パラメータをポート チャネルに設定すると、Cisco NX-OS はこれらのパラメータをポート チャネルのそれぞれのインターフェイスに適用します。

プロトコルが関連付けられていない場合でもスタティック ポート チャネルを使用して設定を簡略化できます。 より効率的にポート チャネルを使用するには、IEEE 802.3ad に規定されているリンク アグリゲーション制御プロトコル(LACP)を使用します。 LACP を使用すると、リンクによってプロトコル パケットが渡されます。

関連コンセプト

ポート チャネルの概要

Cisco NX-OS は、ポート チャネルを使用して、広い帯域幅、冗長性、チャネル全体のロードバランシングを実現します。

ポートを 1 つのスタティック ポート チャネルに集約するか、またはリンク集約制御プロトコル(LACP)をイネーブルにできます。 LACP でポート チャネルを設定する場合、スタティック ポート チャネルを設定する場合とは若干異なる手順が必要です。 ポート チャネル設定の制約事項については、プラットフォームの『Verified Scalability』マニュアルを参照してください。 ロード バランシングの詳細については、ポート チャネルを使ったロード バランシングを参照してください。


(注)  


Cisco NX-OS はポート チャネルのポート集約プロトコル(PAgP)をサポートしません。


ポート チャネルは、個々のリンクを 1 つのチャネル グループにバンドルしたもので、それによりいくつかの物理リンクの帯域幅を集約した単一の論理リンクが作成されます。 ポート チャネル内のメンバ ポートに障害が発生すると、障害が発生したリンクで伝送されていたトラフィックはポート チャネル内のその他のメンバ ポートに切り替わります。

各ポートにはポート チャネルが 1 つだけあります。 ポート チャネル内のすべてのポートは互換性がなければなりません。つまり、回線速度が同じで、全二重モードで動作する必要があります。 スタティック ポート チャネルを LACP なしで稼働すると、個々のリンクがすべて on チャネル モードで動作します。このモードを変更するには、LACP をイネーブルにする必要があります。


(注)  


チャネル モードを、on から active、または on から passive に変更することはできません。


ポート チャネル インターフェイスを作成すると、ポート チャネルを直接作成できます。またはチャネル グループを作成して個別ポートをバンドルに集約させることができます。 インターフェイスをチャネル グループに関連付けると、ポート チャネルがまだ存在していない場合は、対応するポート チャネルが Cisco NX-OS によって自動的に作成されます。 最初にポート チャネルを作成することもできます。 このインスタンスで、Cisco NX-OS は、ポート チャネルと同じチャネル番号で空のチャネル グループを作成し、デフォルトの設定を採用します。


(注)  


少なくともメンバ ポートの 1 つがアップしており、そのポートのステータスがチャネリングであれば、ポート チャネルはアップしています。 メンバ ポートがすべてダウンしていれば、ポート チャネルはダウンしています。


ポート チャネルの設定に関する注意事項および制約事項

ポート チャネルは、グローバル コンフィギュレーション モードまたはスイッチ プロファイル モードの 2 つの方法のいずれかで設定できます。 ポート チャネルを Cisco NX-OS の設定同期機能で設定する場合は、次の注意事項および制約事項を考慮してください。

  • ポート チャネルがスイッチ プロファイル モードを使用して設定した後は、グローバル コンフィギュレーション(config terminal)モードを使用して設定できません。

    (注)  


    いくつかのポート チャネル サブコマンドは、スイッチ プロファイル モードで設定できません。 これらのコマンドはグローバル コンフィギュレーション モードで設定できます。ポート チャネルがスイッチ プロファイル モードで作成されて設定された場合も同様です。

    たとえば、次のコマンドはグローバル コンフィギュレーション モードでだけ設定できます。

    switchport private-vlan association trunk primary-vlan secondary-vlan


  • shutdown および no shutdown はグローバル コンフィギュレーション モードまたはスイッチ プロファイル モードで設定できます。
  • ポート チャネルがグローバル コンフィギュレーション モードで作成されている場合、メンバ インターフェイスを含むチャネル グループも、グローバル コンフィギュレーション モードを使用して作成する必要があります。
  • スイッチ プロファイル モードで設定されたポート チャネルでは、スイッチ プロファイルの内側と外側の両方にメンバを持つ場合があります。
  • スイッチ プロファイルにメンバ インターフェイスをインポートする場合は、メンバ インターフェイスと対応するポート チャネルもスイッチ プロファイル内に存在する必要があります。

スイッチ プロファイルの詳細については、を参照してください。

互換性要件

ポート チャネル グループにインターフェイスを追加すると、Cisco NX-OS は、特定のインターフェイス属性をチェックし、そのインターフェイスがチャネル グループと互換性があることを確認します。 また Cisco NX-OS は、インターフェイスがポート チャネル集約に参加することを許可する前に、そのインターフェイスの多数の動作属性もチェックします。

互換性チェックの対象となる動作属性は次のとおりです。

  • ポート モード
  • アクセス VLAN
  • トランク ネイティブ VLAN
  • 許可 VLAN リスト
  • 速度
  • 802.3x フロー制御設定
  • MTU Cisco Nexus デバイスは、システム レベル MTU だけをサポートします。 この属性を個々のポートごとに変更できません。
  • ブロードキャスト/ユニキャスト/マルチキャスト ストーム制御設定
  • プライオリティ フロー制御
  • タグなし CoS

Cisco NX-OS で使用される互換性チェックの全リストを表示するには、show port-channel compatibility-parameters コマンドを使用します。

チャネル モード セットを on に設定したインターフェイスだけをスタティック ポート チャネルに追加できます。 また、チャネル モードを active または passive に設定したインターフェイスだけを、LACP を実行するポート チャネルに追加できます。 これらの属性は個別のメンバ ポートに設定できます。

インターフェイスがポート チャネルに参加すると、次の個々のパラメータは、ポート チャネルの値に置き換えられます。

  • 帯域幅
  • MAC アドレス
  • STP

インターフェイスがポート チャネルに参加しても、次に示すインターフェイス パラメータは影響を受けません。

  • 説明
  • CDP
  • LACP ポート プライオリティ
  • デバウンス

channel-group force コマンドを入力して、ポートのチャネル グループへの強制追加をイネーブルにした後、次の 2 つの状態が発生します。

  • インターフェイスがポート チャネルに参加すると、次のパラメータは削除され、動作上ポート チャネルの値と置き換えられます。ただし、この変更は、インターフェイスの実行コンフィギュレーションには反映されません
    • QoS
    • 帯域幅
    • 遅延
    • STP
    • サービス ポリシー
    • ACL
  • インターフェイスがポート チャネルに参加するか脱退しても、次のパラメータは影響を受けません。
    • ビーコン
    • 説明
    • CDP
    • LACP ポート プライオリティ
    • デバウンス
    • UDLD
    • シャットダウン
    • SNMP トラップ

ポート チャネルを使ったロード バランシング

Cisco NX-OS は、ポート チャネルを構成するすべての動作中インターフェイス間でトラフィックのロード バランスを実現します。フレーム内のアドレスから生成されたバイナリ パターンの一部を数値に圧縮変換し、それを使用してチャネル内の 1 つのリンクを選択することによってロードバランシングを行います。 ポート チャネルはデフォルトでロード バランシングを備えています。

基本設定では、次の基準を使用してリンクを選択します。
  • レイヤ 2 フレームの場合は、送信元および宛先の MAC アドレスを使用します。
  • レイヤ 3 フレームの場合は、送信元および宛先の MAC アドレスと送信元および宛先の Internet Protocol(IP)アドレスを使用します。
  • レイヤ 4 フレームの場合は、送信元および宛先の MAC アドレスと送信元および宛先の IP アドレスを使用します。

    (注)  


    レイヤ 4 フレームの場合、送信元ポートと宛先ポート番号を含めるオプションがあります。


次のいずれかの方法(詳細については次の表を参照)を使用してポート チャネル全体をロード バランシングするようにスイッチを設定できます。

  • 宛先 MAC アドレス
  • 送信元 MAC アドレス
  • 送信元および宛先 MAC アドレス
  • 宛先 IP アドレス
  • 送信元 IP アドレス
  • 送信元および宛先 IP アドレス
  • 宛先 Transmission Control Protocol(TCP)/User Datagram Protocol(UDP)ポート番号
  • 送信元 TCP/UDP ポート番号
  • 送信元および宛先 TCP/UDP ポート番号
表 1  ポート チャネル ロードバランシング基準

設定

レイヤ 2 基準

レイヤ 3 基準

レイヤ 4 基準

宛先 MAC

宛先 MAC

宛先 MAC

宛先 MAC

送信元 MAC

送信元 MAC

送信元 MAC

送信元 MAC

送信元/宛先 MAC

送信元/宛先 MAC

送信元/宛先 MAC

送信元/宛先 MAC

宛先 IP

宛先 MAC

宛先 MAC、宛先 IP

宛先 MAC、宛先 IP

送信元 IP

送信元 MAC

送信元 MAC、送信元 IP

送信元 MAC、送信元 IP

送信元/宛先 IP

送信元/宛先 MAC

送信元/宛先 MAC、送信元/宛先 IP

送信元/宛先 MAC、送信元/宛先 IP

宛先 TCP/UDP ポート

宛先 MAC

宛先 MAC、宛先 IP

宛先 MAC、宛先 IP、宛先ポート

送信元 TCP/UDP ポート

送信元 MAC

送信元 MAC、送信元 IP

送信元 MAC、送信元 IP、送信元ポート

送信元および宛先 TCP/UDP ポート

送信元/宛先 MAC

送信元/宛先 MAC、送信元/宛先 IP

送信元/宛先 MAC、送信元/宛先 IP、送信元/宛先ポート

ファブリック エクステンダは個別に設定できません。 ファブリック エクステンダの設定は、Cisco Nexus デバイスで定義されます。 ポート チャネル ロード バランシング プロトコルにおいて、Cisco Nexus デバイスで実行された設定の結果に応じてファブリック エクステンダ モジュール上で自動的に設定されるポート チャネル ロード バランシング オプションについては下記の表を参照してください。

次の表に、各設定で使用する基準を示します。

表 2  Cisco Nexus 2232 および Cisco Nexus 2248 ファブリック エクステンダのポート チャネル ロードバランシング基準

設定

レイヤ 2 基準

レイヤ 3 基準

レイヤ 4 基準

宛先 MAC

送信元/宛先 MAC

送信元/宛先 MAC

送信元/宛先 MAC

送信元 MAC

送信元/宛先 MAC

送信元/宛先 MAC

送信元/宛先 MAC

送信元/宛先 MAC

送信元/宛先 MAC

送信元/宛先 MAC

送信元/宛先 MAC

宛先 IP

送信元/宛先 MAC

送信元/宛先 MAC と送信元/宛先 IP

送信元/宛先 MAC と送信元/宛先 IP

送信元 IP

送信元/宛先 MAC

送信元/宛先 MAC と送信元/宛先 IP

送信元/宛先 MAC と送信元/宛先 IP

送信元/宛先 IP

送信元/宛先 MAC

送信元/宛先 MAC と送信元/宛先 IP

送信元/宛先 MAC と送信元/宛先 IP

宛先 TCP/UDP ポート

送信元/宛先 MAC

送信元/宛先 MAC と送信元/宛先 IP

送信元/宛先 MAC、送信元/宛先 IP、および送信元/宛先ポート

送信元 TCP/UDP ポート

送信元/宛先 MAC

送信元/宛先 MAC と送信元/宛先 IP

送信元/宛先 MAC、送信元/宛先 IP、および送信元/宛先ポート

送信元および宛先 TCP/UDP ポート

送信元/宛先 MAC

送信元/宛先 MAC、送信元/宛先 IP

送信元/宛先 MAC、送信元/宛先 IP、および送信元/宛先ポート

使用する設定で最多の種類のロード バランス条件を提供するオプションを使用してください。 たとえば、ポート チャネルのトラフィックが 1 つの MAC アドレスにだけ送られ、ポート チャネルのロードバランシングの基準としてその宛先 MAC アドレスが使用されている場合、ポート チャネルでは常にそのポート チャネルの同じリンクが選択されます。したがって、送信元アドレスまたは IP アドレスを使用すると、結果的により優れたロードバランシングが得られることになります。

LACP の概要

LACP の概要


(注)  


LACP 機能を設定して使用する前に、LACP 機能をイネーブルにする必要があります。


次の図に、個別リンクを LACP ポート チャネルおよびチャネル グループに組み込み、個別リンクとして機能させる方法を示します。

図 1. 個別リンクをポート チャネルに組み込む

スタティック ポート チャネルと同様に、LACP を使用すると、チャネル グループに最大 16 のインターフェイスをバンドルできます。


(注)  


ポート チャネルを削除すると、Cisco NX-OS は関連付けられたチャネル グループを自動的に削除します。 すべてのメンバ インターフェイスは以前の設定に戻ります。


LACP 設定が 1 つでも存在する限り、LACP をディセーブルにはできません。

LACP ID パラメータ

LACP では次のパラメータを使用します。

  • LACP システム プライオリティ:LACP を稼働している各システムは、LACP システム プライオリティ値を持っています。 このパラメータのデフォルト値である 32768 をそのまま使用するか、1 ~ 65535 の範囲で値を設定できます。 LACP は、このシステム プライオリティと MAC アドレスを組み合わせてシステム ID を生成します。また、システム プライオリティを他のデバイスとのネゴシエーションにも使用します。 システム プライオリティ値が大きいほど、プライオリティは低くなります。

(注)  


LACP システム ID は、LACP システム プライオリティ値と MAC アドレスを組み合わせたものです。


  • LACP ポート プライオリティ:LACP を使用するように設定された各ポートには、LACP ポート プライオリティが割り当てられます。 デフォルト値である 32768 をそのまま使用するか、1 ~ 65535 の範囲で値を設定できます。 LACP はポート プライオリティとポート番号を使用してポート ID を形成します。 また、互換性のあるポートのうち一部を束ねることができない場合に、どのポートをスタンバイ モードにし、どのポートをアクティブ モードにするかを決定するのに、ポート プライオリティを使用します。 LACP では、ポート プライオリティ値が大きいほど、プライオリティは低くなります。 指定ポートが、より低い LACP プライオリティを持ち、ホット スタンバイ リンクではなくアクティブ リンクとして選択される可能性が最も高くなるように、ポート プライオリティを設定できます。
  • LACP 管理キー:LACP は、LACP を使用するように設定された各ポート上のチャネル グループ番号に等しい管理キー値を自動的に設定します。 管理キーは、他のポートと集約されるポートの機能を定義します。 他のポートと集約されるポート機能は、次の要因によって決まります。
    • ポートの物理特性(データ レート、デュプレックス機能、ポイントツーポイントまたは共有メディア ステートなど)
    • ユーザが作成した設定に関する制限事項

チャネル モード

ポート チャネルの個別インターフェイスは、チャネル モードで設定します。 プロトコルを使用せずにスタティック ポート チャネルを実行すると、チャネル モードは常に on に設定されます。 デバイス上で LACP をグローバルにイネーブルにした後、各チャネルの LACP をイネーブルにします。それには、各インターフェイスのチャネル モードを active または passive に設定します。 LACP チャネル グループを構成する個々のリンクについて、どちらかのチャネル モードを設定できます。


(注)  


active または passive のチャネル モードで、個々のインターフェイスを設定するには、まず、LACP をグローバルにイネーブルにする必要があります。


次の表に、各チャネル モードについて説明します。

表 3 ポート チャネルの個別リンクのチャネル モード

チャネル モード

説明

passive

ポートをパッシブなネゴシエーション状態にする LACP モード。この状態では、ポートは受信した LACP パケットに応答はしますが、LACP ネゴシエーションを開始することはありません。

active

LACP モード。ポートをアクティブ ネゴシエーション ステートにします。ポートは LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

on

すべてのスタティック ポート チャネル、つまり LACP を稼働していないポート チャネルは、このモードのままになります。 LACP をイネーブルにする前にチャネル モードを active または passive に変更しようとすると、デバイスがエラー メッセージを返します。

チャネルで LACP をイネーブルにするには、そのチャネルのインターフェイスでチャネル モードを active または passive に設定します。 LACP は、on 状態のインターフェイスとネゴシエートする場合、LACP パケットを受信しないため、そのインターフェイスと個別のリンクを形成します。つまり、LACP チャネル グループには参加しません。

passive および active の両モードでは、LACP は、ポート間でネゴシエートし、ポート速度やトランキング ステートなどの基準に基づいて、ポート チャネルを形成可能かどうかを決定できます。 passive モードは、リモート システム、つまり、パートナーが、LACP をサポートしているかどうかが不明な場合に便利です。

ポートは、異なる LACP モードであっても、それらのモード間で互換性があれば、LACP ポート チャネルを形成できます。次に、LACP ポート チャネルのモードの組み合わせの例を示します。

  • active モードのポートは、active モードの別のポートとともにポート チャネルを正しく形成できます。
  • active モードのポートは、passive モードの別のポートとともにポート チャネルを形成できます。
  • passive モードのポートは、どちらのポートもネゴシエーションを開始しないため、passive モードの別のポートとともにポート チャネルを形成できません。
  • on モードのポートは LACP を実行していません。

LACP マーカー レスポンダ

ポート チャネルを使用すると、リンク障害またはロード バランシング動作によって、データ トラフィックが動的に再配信されます。 LACP では、マーカー プロトコルを使用して、こうした再配信によってフレームが重複したり順序が変わったりしないようにします。 Cisco NX-OS は、マーカー レスポンダだけをサポートしています。

LACP がイネーブルのポート チャネルとスタティック ポート チャネルの相違点

次の表に、LACP がイネーブルのポート チャネルとスタティック ポート チャネルの主な相違点の簡単な概要を説明します。 設定の最大制限値の詳細については、デバイスの『Verified Scalability』マニュアルを参照してください。

表 4 LACP がイネーブルのポート チャネルとスタティック ポート チャネル

構成

LACP がイネーブルのポート チャネル

スタティック ポート チャネル

適用されるプロトコル

グローバルにイネーブル化

該当なし

リンクのチャネル モード

次のいずれか。

  • Active
  • Passive

on モードのみ

ポート チャネルの設定

ポート チャネルの作成

チャネル グループを作成する前に、ポート チャネルを作成します。 Cisco NX-OS は、対応するチャネル グループを自動的に作成します。


(注)  


LACP ベースのポート チャネルが必要な場合は、LACP をイネーブルにする必要があります。


手順
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal  

    コンフィギュレーション モードを開始します。

     
    ステップ 2switch(config)# interface port-channel channel-number  

    設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。 指定できる範囲は 1 ~ 4096 です。チャネル グループがまだ存在していなければ、 Cisco NX-OS によって自動的に作成されます。

     
    ステップ 3 switch(config)# no interface port-channel channel-number  

    ポート チャネルを削除し、関連するチャネル グループを削除します。

     

    次の例は、ポート チャネルの作成方法を示しています。

    switch# configure terminal
    switch (config)# interface port-channel 1

    ポート チャネルへのポートの追加

    新規のチャネル グループ、または他のポートがすでに属しているチャネル グループにポートを追加できます。 Cisco NX-OS では、このチャネル グループに関連付けられたポート チャネルがなければ作成されます。


    (注)  


    LACP ベースのポート チャネルが必要な場合は、LACP をイネーブルにする必要があります。


    手順
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal 

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2 switch(config)# interface type slot/port  

      チャネル グループに追加するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 3 switch(config-if)# switchport mode trunk   (任意)

      トランク ポートとしてインターフェイスを設定します。

       
      ステップ 4switch(config-if)# switchport trunk {allowed vlan vlan-id | native vlan vlan-id}   (任意)

      トランク ポートに必要なパラメータを設定します。

       
      ステップ 5switch(config-if)# channel-group channel-number  

      チャネル グループ内にポートを設定し、モードを設定します。 channel-number の指定できる範囲は 1 ~ 4096 です。 Cisco NX-OS では、このチャネル グループに関連付けられたポート チャネルがなければ作成されます。 これはポート チャネルの暗黙的作成と呼ばれます。

       
      ステップ 6 switch(config-if)# no channel-group   (任意)

      チャネル グループからポートを削除します。 チャネル グループから削除されたポートは元の設定に戻ります。

       

      次に、イーサネット インターフェイス 1/4 をチャネル グループ 1 に追加する例を示します。

      switch# configure terminal
      switch (config)# interface ethernet 1/4
      switch(config-if)# switchport mode trunk
      switch(config-if)# channel-group 1
      

      ポート チャネルを使ったロード バランシングの設定

      デバイス全体に適用される、ポート チャネル用のロードバランシング アルゴリズムを設定できます。


      (注)  


      LACP ベースのポート チャネルが必要な場合は、LACP をイネーブルにする必要があります。


      手順
         コマンドまたはアクション目的
        ステップ 1 switch# configure terminal  

        コンフィギュレーション モードを開始します。

         
        ステップ 2switch(config)# port-channel load-balance ethernet {[destination-ip | destination-mac | destination-port | source-dest-ip | source-dest-mac | source-dest-port | source-ip | source-mac | source-port] crc-poly}  

        デバイスのロード バランシング アルゴリズムを指定します。 指定可能なアルゴリズムはデバイスによって異なります。 デフォルトは source-dest-mac です。

        Cisco Nexus 5500 プラットフォーム スイッチはハッシュ パラメータの圧縮に使用できる 8 種のハッシュ多項式をサポートします。 ポート チャネルからの出力トラフィック フローのハッシュ パラメータの種類によっては、多項式ごとに異なる負荷分散の結果となることがあります。 デフォルトのハッシュ多項式は CRC8a です。 変数は、次のように設定できます。
        • CRC8a
        • CRC8b
        • CRC8c
        • CRC8d
        • CRC8e
        • CRC8f
        • CRC8g
         
        ステップ 3 switch(config)# no port-channel load-balance ethernet   (任意)

        source-dest-mac のデフォルトのロードバランシング アルゴリズムを復元します。

         
        ステップ 4 switch# show port-channel load-balance   (任意)

        ポート チャネル ロードバランシング アルゴリズムを表示します。

         

        次に、ポート チャネルの送信元 IP ロードバランシングを設定する例を示します。

        switch# configure terminal
        switch (config)# port-channel load-balance ethernet source-ip

        マルチキャスト トラフィックのハードウェア ハッシュの設定

        スイッチのいずれのポートにある入力マルチキャスト トラフィックでも、デフォルトで、特定のポート チャネル メンバが選択され、トラフィックが出力されます。 潜在的な帯域幅の問題を減らし、入力マルチキャスト トラフィックの効率的なロードバランシングを提供するために、マルチキャスト トラフィックにハードウェア ハッシュを設定できます。 ハードウェア ハッシュをイネーブルにするには、hardware multicast hw-hash コマンドを使用します。 デフォルトに戻すには、no hardware multicast hw-hash コマンドを使用します。

        手順
           コマンドまたはアクション目的
          ステップ 1 switch# configure terminal
           

          コンフィギュレーション モードを開始します。

           
          ステップ 2 switch(config)# interface port-channel channel-number
           

          ポート チャネルを選択し、インターフェイス コンフィギュレーション モードを開始します。

           
          ステップ 3 switch(config-if)# hardware multicast hw-hash
           

          指定したポート チャネルにハードウェア ハッシュを設定します。

           

          次に、ポート チャネルでハードウェア ハッシュを設定する例を示します。

          switch# configure terminal
          
          switch (config)# interface port-channel 21
          
          switch(config-if)# hardware multicast hw-hash
          
          

          次に、ポート チャネルからハードウェア ハッシュを削除する例を示します。

          switch# configure terminal
          
          switch (config)# interface port-channel 21
          
          switch(config-if)# no hardware multicast hw-hash
          

          LACP のイネーブル化

          LACP はデフォルトではディセーブルです。LACP の設定を開始するには、LACP をイネーブルにする必要があります。 LACP 設定が 1 つでも存在する限り、LACP をディセーブルにはできません。

          LACP は、LAN ポート グループの機能を動的に学習し、残りの LAN ポートに通知します。 LACP は、正確に一致しているイーサネット リンクを識別すると、これらのリンクを 1 つのポート チャネルとして容易にまとめます。 次に、ポート チャネルは単一ブリッジ ポートとしてスパニングツリーに追加されます。

          手順
             コマンドまたはアクション目的
            ステップ 1 switch# configure terminal
             

            コンフィギュレーション モードを開始します。

             
            ステップ 2 switch(config)# feature lacp
             

            スイッチ上で LACP をイネーブルにします。

             
            ステップ 3 switch(config)# show feature
             
            (任意)

            イネーブルにされた機能を表示します。

             

            次に、LACP をイネーブルにする例を示します。

            switch# configure terminal
            
            switch(config)# feature lacp
            
             

            ポートのチャネル モードの設定

            LACP ポート チャネルのそれぞれのリンクのチャネル モードを active または passive に設定できます。 このチャネル コンフィギュレーション モードを使用すると、リンクは LACP で動作可能になります。

            関連するプロトコルを使用せずにポート チャネルを設定すると、リンク両端のすべてのインターフェイスは on チャネル モードを維持します。

            はじめる前に

            LACP 機能がイネーブルになっていることを確認します。

            手順
               コマンドまたはアクション目的
              ステップ 1switch# configure terminal 

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2 switch(config)# interface type slot/port
               

              設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

               
              ステップ 3switch(config-if)# channel-group channel-number [force] [mode {on | active | passive}]
               

              ポート チャネルのリンクのポート モードを指定します。 LACP をイネーブルにしたら、各リンクまたはチャネル全体を active または passive に設定します。

              force:LAN ポートをチャネル グループに強制的に追加することを指定します。

              mode:インターフェイスのポート チャネル モードを指定します。

              active:LACP をイネーブルにすると、このコマンドは、指定されたインターフェイスで LACP をイネーブルにすることを指定します。 インターフェイスはアクティブなネゴシエーション状態になります。この状態では、ポートは LACP パケットを送信して他のポートとネゴシエーションを開始します。

              on:(デフォルト モード)LACP を実行していないすべてのポート チャネルがこのモードを維持することを指定します。

              passive:LACP デバイスが検出された場合にだけ、LACP をイネーブルにします。 インターフェイスはパッシブなネゴシエーション状態になります。この状態では、ポートは受信した LACP パケットに応答しますが、LACP ネゴシエーションを開始しません。

              関連するプロトコルを使用せずにポート チャネルを実行する場合、チャネル モードは常に on です。

               
              ステップ 4 switch(config-if)# no channel-group number mode
               

              指定インターフェイスのポート モードを on に戻します

               

              次に、チャネル グループ 5 のイーサネット インターフェイス 1/4 で、LACP がイネーブルなインターフェイスを active ポート チャネル モードに設定する例を示します。

              switch# configure terminal
              switch (config)# interface ethernet 1/4
              switch(config-if)# channel-group 5 mode active
              
              

              次に、強制的にチャネル グループ 5 にインターフェイスを追加する例を示します。

              switch(config)# interface ethernet 1/1
              switch(config-if)# channel-group 5 force
              switch(config-if)#
              

              LACP 高速タイマー レートの設定

              LACP タイム アウト期間を変更するには、LACP タイマー レートを変更します。 LACP をサポートするインターフェイスに LACP 制御パケットが送信されるレートを設定するには、lacp rate コマンドを使用します。 デフォルト レート(30 秒)から高速レート(1 秒)にタイムアウト レートを変更できます。 このコマンドは、LACP 対応インターフェイスだけでサポートされます。

              はじめる前に

              LACP 機能がイネーブルになっていることを確認します。

              手順
                 コマンドまたはアクション目的
                ステップ 1switch# configure terminal 

                グローバル コンフィギュレーション モードを開始します。

                 
                ステップ 2 switch(config)# interface type slot/port
                 

                設定するインターフェイスを指定します。インターフェイス コンフィギュレーション モードを開始します。

                 
                ステップ 3 switch(config-if)# lacp rate fast
                 

                LACP をサポートするインターフェイスに LACP 制御パケットが送信される高速レート(1 秒)を設定します。

                 

                次に、イーサネット インターフェイス 1/4 の LACP 高速レートを設定する例を示します。

                switch# configure terminal
                switch(config)# interface ethernet 1/4
                switch(config-if)# lacp rate fast

                次に、イーサネット インターフェイス 1/4 の LACP のデフォルト レート(30 秒)を復元する例を示します。

                switch# configure terminal
                switch(config)# interface ethernet 1/4
                switch(config-if)# no lacp rate fast

                LACP のシステム プライオリティおよびシステム ID の設定

                LACP システム ID は、LACP システム プライオリティ値と MAC アドレスを組み合わせたものです。

                はじめる前に

                LACP 機能がイネーブルになっていることを確認します。

                手順
                   コマンドまたはアクション目的
                  ステップ 1 switch# configure terminal
                   

                  コンフィギュレーション モードを開始します。

                   
                  ステップ 2 switch(config)# lacp system-priority priority
                   

                  LACP で使用するシステム プライオリティを設定します。 指定できる範囲は 1 ~ 65535 で、値が大きいほどプライオリティは低くなります。 デフォルト値は 32768 です。

                   
                  ステップ 3 switch# show lacp system-identifier
                   
                  (任意)

                  LACP システム識別子を表示します。

                   

                  次に、LACP システム プライオリティを 2500 に設定する例を示します。

                  switch# configure terminal
                  
                  switch(config)# lacp system-priority 2500
                  
                   

                  LACP ポート プライオリティの設定

                  ポート プライオリティに LACP ポート チャネルの各リンクを設定できます。

                  はじめる前に

                  LACP 機能がイネーブルになっていることを確認します。

                  手順
                     コマンドまたはアクション目的
                    ステップ 1switch# configure terminal 

                    グローバル コンフィギュレーション モードを開始します。

                     
                    ステップ 2 switch(config)# interface type slot/port
                     

                    設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

                     
                    ステップ 3 switch(config-if)# lacp port-priority priority
                     

                    LACP で使用するポート プライオリティを設定します。 指定できる範囲は 1 ~ 65535 で、値が大きいほどプライオリティは低くなります。 デフォルト値は 32768 です。

                     

                    次に、イーサネット インターフェイス 1/4 の LACP ポート プライオリティを 40000 に設定する例を示します。

                    switch# configure terminal
                    switch (config)# interface ethernet 1/4
                    switch(config-if)# lacp port priority 40000

                    LACP グレースフル コンバージェンスのディセーブル化

                    はじめる前に
                    • LACP 機能をイネーブルにします。
                    • ポート チャネルが管理上ダウン状態であることを確認します。
                    • 正しい VDC を使用していることを確認します。 正しい VDC に切り替えるには、switchto vdc コマンドを入力します。
                    手順
                       コマンドまたはアクション目的
                      ステップ 1configure terminal


                      例:
                      switch# configure terminal
                      switch(config)#
                       

                      グローバル コンフィギュレーション モードを開始します。

                       
                      ステップ 2interface port-channel number


                      例:
                      switch(config)# interface port-channel 1
                      switch(config) #
                       

                      設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

                       
                      ステップ 3shutdown


                      例:
                      switch(config-if)# shutdown
                      switch(config-if) #
                       

                      ポート チャネルを管理シャットダウンします。

                       
                      ステップ 4no lacp graceful-convergence


                      例:
                      switch(config-if)# no lacp graceful-convergence
                      switch(config-if) #
                       

                      指定したポート チャネルの LACP グレースフル コンバージェンスをディセーブルにします。

                       
                      ステップ 5no shutdown


                      例:
                      switch(config-if)# no shutdown
                      switch(config-if) #
                       

                      ポート チャネルを管理的にアップします。

                       
                      ステップ 6copy running-config startup-config


                      例:
                      switch(config-if)# copy running-config startup-config
                      
                       
                      (任意)

                      リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を継続的に保存します。

                       

                      次に、ポート チャネルの LACP グレースフル コンバージェンスをディセーブルにする例を示します。

                      switch# configure terminal
                      switch(config) # interface port-channel 1
                      switch(config-if) # shutdown
                      switch(config-if) # no lacp graceful-convergence
                      switch(config-if) # no shutdown
                      switch(config-if) #

                      LACP グレースフル コンバージェンスの再イネーブル化

                      はじめる前に
                      • LACP 機能をイネーブルにします。
                      • ポート チャネルが管理上ダウン状態であることを確認します。
                      • 正しい VDC を使用していることを確認します。 正しい VDC に切り替えるには、switchto vdc コマンドを入力します。
                      手順
                         コマンドまたはアクション目的
                        ステップ 1configure terminal


                        例:
                        switch# configure terminal
                        switch(config)#
                         

                        グローバル コンフィギュレーション モードを開始します。

                         
                        ステップ 2interface port-channel number


                        例:
                        switch(config)# interface port-channel 1
                        switch(config) #
                         

                        設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

                         
                        ステップ 3shutdown


                        例:
                        switch(config-if)# shutdown
                        switch(config-if) #
                         

                        ポート チャネルを管理シャットダウンします。

                         
                        ステップ 4lacp graceful-convergence


                        例:
                        switch(config-if)# lacp graceful-convergence
                        switch(config-if) #
                         

                        指定したポート チャネルの LACP グレースフル コンバージェンスをイネーブルにします。

                         
                        ステップ 5no shutdown


                        例:
                        switch(config-if)# no shutdown
                        switch(config-if) #
                         

                        ポート チャネルを管理的にアップします。

                         
                        ステップ 6copy running-config startup-config


                        例:
                        switch(config-if)# copy running-config startup-config
                        
                         
                        (任意)

                        リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を継続的に保存します。

                         

                        次に、ポート チャネルの LACP グレースフル コンバージェンスをディセーブルにする例を示します。

                        switch# configure terminal
                        switch(config) # interface port-channel 1
                        switch(config-if) # shutdown
                        switch(config-if) # lacp graceful-convergence
                        switch(config-if) # no shutdown
                        switch(config-if) #

                        ポート チャネルの設定の確認

                        ポート チャネルの設定情報を表示するには、次の作業のいずれかを行います。

                        コマンド

                        目的

                        switch# show interface port-channel channel-number

                        ポート チャネル インターフェイスのステータスを表示します。

                        switch# show feature

                        イネーブルにされた機能を表示します。

                        switch# show resource

                        システムで現在使用可能なリソースの数を表示します。

                        switch# show lacp {counters | interface type slot/port | neighbor | port-channel | system-identifier}

                        LACP 情報を表示します。

                        switch# show port-channel compatibility-parameters

                        ポート チャネルに追加するためにメンバ ポート間で同じにするパラメータを表示します。

                        switch# show port-channel database [interface port-channel channel-number]

                        1 つ以上のポート チャネル インターフェイスの集約状態を表示します。

                        switch# show port-channel summary

                        ポート チャネル インターフェイスの概要を表示します。

                        switch# show port-channel traffic

                        ポート チャネルのトラフィック統計情報を表示します。

                        switch# show port-channel usage

                        使用済みおよび未使用のチャネル番号の範囲を表示します。

                        switch# show port-channel database

                        現在実行中のポート チャネル機能に関する情報を表示します。

                        switch# show port-channel load-balance

                        ポート チャネルを使用したロードバランシングに関する情報を表示します。

                        ロードバランシングの発信ポート ID の確認

                        コマンドのガイドライン

                        show port-channel load-balance コマンドでは、特定のフレームがハッシュされるポート チャネルのポートを確認することができます。 正確な結果を得るためには、VLAN と宛先 MAC を指定する必要があります。

                        (注)  


                        ポート チャネルのポートが 1 つだけの場合など、特定のトラフィック フローはハッシュ対象ではありません。

                        ロードバランシングの発信ポート ID を表示するには、次の表に示すタスクの 1 つを実行します。

                        コマンド

                        目的

                        switch# show port-channel load-balance forwarding-path interface port-channel port-channel-id vlan vlan-id dst-ip src-ip dst-mac src-mac l4-src-port port-id l4-dst-port port-id

                        発信ポート ID を表示します。

                        次に、短い port-channel load-balance コマンドの出力例を示します。

                        switch# show port-channel load-balance forwarding-path interface port-channel 10 vlan 1 dst-ip 1.225.225.225 src-ip 1.1.10.10 src-mac aa:bb:cc:dd:ee:ff
                        l4-src-port 0 l4-dst-port 1
                        Missing params will be substituted by 0's. Load-balance Algorithm on switch: source-dest-port crc8_hash:204 Outgoing port id: Ethernet 1/1 Param(s) used to calculate load balance:
                        dst-port: 0
                        src-port: 0
                        dst-ip: 1.225.225.225
                        src-ip: 1.1.10.10
                        dst-mac: 0000.0000.0000
                        src-mac: aabb.ccdd.eeff