Cisco Nexus 5000 シリーズ NX-OS レイヤ 2 スイッチング コンフィギュレーション ガイド リリース 5.0(2)N1(1)
イーサネット インターフェイスの設定
イーサネット インターフェイスの設定
発行日;2013/02/26   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

イーサネット インターフェイスの設定

この章の内容は、次のとおりです。

イーサネット インターフェイスの概要

イーサネット ポートは、サーバまたは LAN に接続される標準のイーサネット インターフェイスとして機能します。

イーサネット インターフェイスはデフォルトでイネーブルです。

interface コマンドについて

interface コマンドを使用すれば、イーサネット インターフェイスのさまざまな機能をインターフェイスごとにイネーブルにできます。 interface コマンドを入力する際には、次の情報を指定します。

  • インターフェイス タイプ:すべての物理イーサネット インターフェイスには、常にキーワード ethernet を使用します。
  • スロット番号
    • スロット 1 にはすべての固定ポートが含まれます。
    • スロット 2 には上位拡張モジュールのポートが含まれます(実装されている場合)。
    • スロット 3 には下位拡張モジュールのポートが含まれます(実装されている場合)。
    • スロット 4 には下位拡張モジュールのポートが含まれます(実装されている場合)。
  • ポート番号:グループ内のポート番号。

Cisco Nexus 2000 シリーズ ファブリック エクステンダ との使用をサポートするために、インターフェイスのナンバリング規則は、次のように拡張されています。

switch(config)# interface ethernet [chassis/]slot/port

  • シャーシ ID は、接続されている ファブリック エクステンダ のポートをアドレス指定するための任意のエントリです。 インターフェイス経由で検出された ファブリック エクステンダ を識別するために、シャーシ ID はスイッチ上の物理イーサネットまたは EtherChannel インターフェイスに設定されます。 シャーシ ID の範囲は、100 ~ 199 です。

単一方向リンク検出パラメータについて

シスコ独自の Unidirectional Link Detection(UDLD; 単一方向リンク検出)プロトコルでは、光ファイバまたは銅線(たとえば、カテゴリ 5 のケーブル)のイーサネット ケーブルで接続されているポートでケーブルの物理的な構成をモニタリングし、単一方向リンクの存在を検出できます。 スイッチが単方向リンクを検出すると、UDLD は関連する LAN ポートをシャットダウンし、ユーザに警告します。 単一方向リンクは、スパニングツリー トポロジ ループをはじめ、さまざまな問題を引き起こす可能性があります。

UDLD は、レイヤ 1 プロトコルと協調してリンクの物理ステータスを検出するレイヤ 2 プロトコルです。 レイヤ 1 では、物理的シグナリングおよび障害検出は、自動ネゴシエーションによって処理されます。 UDLD は、ネイバーの ID の検知、誤って接続された LAN ポートのシャットダウンなど、自動ネゴシエーションでは実行不可能な処理を実行します。 自動ネゴシエーションと UDLD の両方をイネーブルにすると、レイヤ 1 とレイヤ 2 の検出が協調して動作して、物理的な単一方向接続と論理的な単一方向接続を防止し、その他のプロトコルの異常動作を防止できます。

リンク上でローカル デバイスが送信したトラフィックはネイバーで受信されるが、ネイバーから送信されたトラフィックはローカル デバイスで受信されない場合に、単一方向リンクが発生します。 対になっているファイバ ケーブルのいずれかの接続が切断された場合、自動ネゴシエーションがアクティブである限り、そのリンクは存続できません。 この場合、論理リンクは不定であり、UDLD は何の処理も行いません。 レイヤ 1 で両方の光ファイバが正常に動作している場合は、レイヤ 2 で UDLD が、これらの光ファイルが正しく接続されているかどうか、および正しいネイバー間でトラフィックが双方向に流れているかを調べます。 自動ネゴシエーションはレイヤ 1 で動作するため、このチェックは、自動ネゴシエーションでは実行できません。

Cisco Nexus デバイスは、UDLD がイネーブルになっている LAN ポート上のネイバー デバイスに定期的に UDLD フレームを送信します。 一定の時間内にフレームがエコー バックされてきて、特定の確認応答(echo)が見つからなければ、そのリンクは単一方向のフラグが立てられ、その LAN ポートはシャットダウンされます。 プロトコルが単一方向リンクを正しく識別してディセーブルにするには、リンクの両端のデバイスで UDLD をサポートする必要があります。


(注)  


UDLD は、銅線の LAN ポート上では、このタイプのメディアでの不要な制御トラフィックの送信を避けるために、ローカルでディセーブル(デフォルト)になっています。


次の図は、単一方向リンク状態の例を示します。 デバイス B はこのポートでデバイス A からのトラフィックを正常に受信していますが、 デバイス A は同じポート上でデバイス B からのトラフィックを受信していません。 UDLD によって問題が検出され、ポートがディセーブルにされます。

図 1. 単方向リンク

UDLD のデフォルト設定

次の表に、UDLD のデフォルト設定を示します。

表 1  UDLD のデフォルト設定

機能

デフォルト値

UDLD グローバル イネーブル ステート

グローバルにディセーブル

UDLD アグレッシブ モード

ディセーブル

ポート別の UDLD イネーブル ステート(光ファイバ メディア用)

すべてのイーサネット光ファイバ LAN ポートでイネーブル

ポート別の UDLD イネーブル ステート(ツイストペア(銅製)メディア用)

すべてのイーサネット 10/100 および 1000BASE-TX LAN ポートでディセーブル

UDLD アグレッシブ モードと非アグレッシブ モード

UDLD アグレッシブ モードはデフォルトではディセーブルに設定されています。 UDLD アグレッシブ モードは、UDLD アグレッシブ モードをサポートするネットワーク デバイスの間のポイントツーポイントのリンク上に限って設定できます。 UDLD アグレッシブ モードがイネーブルになっている場合、UDLD ネイバー関係が確立されている双方向リンク上のポートが UDLD フレームを受信しなくなったとき、UDLD はネイバーとの接続の再確立を試行します。 この試行に 8 回失敗すると、ポートはディセーブルになります。

スパニングツリー ループを防止するために、デフォルトの 15 秒間隔を使用する非アグレッシブな UDLD により、(デフォルトのスパニングツリー パラメータを使用している場合)ブロッキング ポートがフォワーディング ステートに移行する前に、すみやかに単一方向リンクをシャットダウンすることができます。

UDLD アグレッシブ モードをイネーブルにすると、次のようなことが発生します。

  • リンクの一方にポート スタックが生じる(送受信どちらも)
  • リンクの一方がダウンしているにもかかわらず、リンクのもう一方がアップしたままになる

このような場合、UDLD アグレッシブ モードでは、リンクのポートの 1 つがディセーブルになり、トラフィックが廃棄されるのを防止します。

インターフェイス速度

5596T スイッチには、48 個のベース ボード ポートと 3 つの GEM スロットが装備されています。 最初の 32 個のポートは 10GBase-T ポートであり、最後の 16 個のポートは SFP+ ポートです。 10GBase-T ポートは、1 ギガビット、10 ギガビット、または Auto の速度をサポートしています。 Auto に設定すると、リンク パーサーと自動的にネゴシエートして 1 ギガビットまたは 10 ギガビットのどちらかの速度を選択します。

Cisco Discovery Protocol について

Cisco Discovery Protocol(CDP)はすべてのシスコ デバイス(ルータ、ブリッジ、アクセス サーバ、およびスイッチ)のレイヤ 2(データリンク層)で動作するデバイス検出プロトコルです。ネットワーク管理アプリケーションは CDP を使用することにより、既知のデバイスにネイバー シスコ デバイスを検出できます。 また、下位レイヤのトランスペアレント プロトコルが稼働しているネイバー デバイスのデバイス タイプや、Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)エージェント アドレスを学習することもできます。 この機能によって、アプリケーションからネイバー デバイスに SNMP クエリーを送信できます。

CDP は、Subnetwork Access Protocol(SNAP; サブネットワーク アクセス プロトコル)をサポートしているすべてのメディアで動作します。 CDP はデータリンク層でのみ動作するため、異なるネットワーク層プロトコルをサポートする 2 つのシステムで互いの情報を学習できます。

CDP が設定された各デバイスはマルチキャスト アドレスに定期的にメッセージを送信して、SNMP メッセージを受信可能なアドレスを 1 つまたは複数アドバタイズします。 このアドバタイズには、受信側デバイスで CDP 情報を廃棄せずに保持する時間を表す存続可能時間、つまりホールドタイム情報も含まれます。 各デバイスは他のデバイスから送信されたメッセージも待ち受けて、ネイバー デバイスについて学習します。

このスイッチは、CDP バージョン 1 とバージョン 2 の両方をサポートします。

CDP のデフォルト設定

次の表に、CDP のデフォルト設定を示します。

表 2  CDP のデフォルト設定

機能

デフォルト設定

CDP インターフェイス ステート

イネーブル

CDP タイマー(パケット更新頻度)

60 秒

CDP ホールドタイム(廃棄までの時間)

180 秒

CDP バージョン 2 アドバタイズ

イネーブル

error-disabled ステートについて

インターフェイスが(no shutdown コマンドを使用して)管理上イネーブルであるが、プロセスによってランタイム時にディセーブルになる場合、そのインターフェイスは errdisable(err-disabled)ステートです。 たとえば、UDLD が単一方向リンクを検出した場合、インターフェイスはランタイム時にシャットダウンされます。 ただし、インターフェイスは管理上イネーブルなので、インターフェイス ステータスは errdisabled として表示されます。 いったん errdisable ステートになったインターフェイスは、手動でイネーブルにする必要があります。ただし、自動回復までのタイムアウト値を設定することもできます。errdisable 検出はすべての原因に対してデフォルトでイネーブルです。自動リカバリはデフォルトでは設定されていません。

インターフェイスが errdisabled ステートにある場合は、エラーに関する情報を見つけるために、errdisable detect cause コマンドを使用します。

time 変数の変更によって起きる特定の errdisabled に対しては自動 errdisabled リカバリ タイムアウトを設定できます。

errdisable recovery cause コマンドを使用すると、300 秒後に自動的にリカバリします。 リカバリ期間を変更するには、errdisable recovery interval コマンドを使用してタイムアウト期間を指定します。 30 ~ 65535 秒を指定できます。

原因に対する err-disabled リカバリをイネーブルにしない場合、インターフェイスは、shutdown および no shutdown コマンドが入力されるまで err-disabled ステートのままです。 原因に対するリカバリをイネーブルにした場合、インターフェイスは errdisabled ステートから抜け出し、すべての原因がタイムアウトになったときに動作を再試行できるようになります。 エラーの原因を表示するには、show interface status err-disabled コマンドを使用します。

ポート プロファイルについて

さまざまなインターフェイス コマンドを含むポート プロファイルを作成し、そのポート プロファイルを のインターフェイス(複数可)に適用することができます。 ポート プロファイルは、次のインターフェイス タイプに適用できます。

  • イーサネット
  • VLAN ネットワーク インターフェイス
  • ポート チャネル

ポート プロファイルに含まれるコマンドは、ポート プロファイル外に設定できます。 ポート プロファイルの新規設定とポート プロファイル外にある設定が競合する場合、コンフィギュレーション ターミナル モードのインターフェイスに設定されているコマンドがポート プロファイルのコマンドよりもプライオリティが高くなります。 ポート プロファイルがインターフェイスにアタッチされた後でインターフェイスの設定を変更したとき、ポート プロファイルの設定とインターフェイスの設定が競合する場合は、インターフェイスの設定が優先されます。

ポート プロファイルをインターフェイスまたはインターフェイスの範囲にアタッチするとポート プロファイルが継承されます。ポート プロファイルをインターフェイスまたはインターフェイスの範囲にアタッチするか継承すると、スイッチがそのポート プロファイルのすべてのコマンドをインターフェイスに適用します。

1 つのポート プロファイルで別のポート プロファイルから設定を継承できます。 別のポート プロファイルを継承すると、最初のポート プロファイルは、2 番目の継承されたポート プロファイルのコマンドのすべてが最初のポート プロファイルと競合しないと想定できます。 4 つのレベルの継承がサポートされています。 任意の数のポート プロファイルで同じポート プロファイルを継承できます。

ポート プロファイル設定をインターフェイスに適用するには、特定のポート プロファイルをイネーブルにする必要があります。 ポート プロファイルをイネーブルにする前に、インターフェイスの範囲に対してポート プロファイルを設定および継承できます。その後、指定したインターフェイスに反映するために、この設定に対してポート プロファイルをイネーブルにします。

ポート プロファイルをインターフェイスの範囲から削除すると、まずスイッチはインターフェイスから設定を取り消して、ポート プロファイル リンク自体を削除します。 また、ポート プロファイルを削除すると、スイッチによってインターフェイスの設定が確認され、直接入力されたインターフェイス コマンドで無効にされたポート プロファイル コマンドをスキップするか、それらのコマンドをデフォルト値に戻します。

他のポート プロファイルによって継承されたポート プロファイルを削除するには、ポート プロファイルを削除する前に継承を削除する必要があります。

最初にプロファイルを適用したインターフェイスのグループの中から、ポート プロファイルを削除するインターフェイスのサブセットを選択できます。 たとえば、ポート プロファイルを設定し、そのポート プロファイルを継承するよう 10 個のインターフェイスを設定した場合、指定した 10 個のインターフェイスの一部だけからポート プロファイルを削除できます。 ポート プロファイルは、適用されている残りのインターフェイスで引き続き動作します。

インターフェイス コンフィギュレーション モードを使用して指定したインターフェイスの範囲の特定のコンフィギュレーションを削除する場合、そのコンフィギュレーションもそのインターフェイスの範囲のポート プロファイルからのみ削除されます。 たとえば、ポート プロファイル内にチャネル グループがあり、インターフェイス コンフィギュレーション モードでそのポート チャネルを削除する場合、指定したポート チャネルも同様にポート プロファイルから削除されます。

インターフェイスまたはインターフェイスの範囲のポート プロファイルを継承したあとに特定の設定値を削除すると、そのポート プロファイル設定は指定のインターフェイスで動作しなくなります。

ポート プロファイルを誤ったタイプのインターフェイスに適用しようとすると、スイッチからエラーが返されます。

ポート プロファイルをイネーブル、継承、または変更しようとすると、スイッチはチェックポイントを作成します。 ポート プロファイルの設定が失敗すると、スイッチは前の設定にロール バックし、エラーが返されます。 ポート プロファイルは部分的にだけ適用されることはありません。

ポート プロファイルに関する注意事項および制約事項

ポート プロファイル設定時の注意事項と制限事項は次のとおりです。

  • 各ポート プロファイルは、インターフェイス タイプにかかわらず、ネットワーク全体で一意の名前を持つ必要があります。
  • 競合が発生している場合、インターフェイス モードで入力するコマンドは、ポート プロファイルのコマンドに優先します。 しかし、ポート プロファイルはそのコマンドをポート プロファイルに保持します。
  • ポート プロファイルのコマンドは、デフォルト コマンドが明示的にポート プロファイルのコマンドを上書きしない限り、インターフェイスのデフォルト コマンドに優先します。
  • ポート プロフィルをインターフェイスまたはインターフェイスの範囲に継承した後、インターフェイス コンフィギュレーション レベルで新しい値を入力して、個々の設定値を上書きできます。 インターフェイス コンフィギュレーション レベルで個々の設定値を削除すると、インターフェイスによりその値がポート プロファイルで再度使用されます。
  • ポート プロファイルに関連したデフォルト設定はありません。
  • 指定するインターフェイス タイプにより、コマンドのサブセットがポート プロファイル コンフィギュレーション モードで使用できます。
  • Session Manager にポート プロファイルは使用できません。

デバウンス タイマー パラメータについて

MTU 設定について

Cisco Nexus デバイス スイッチはフレームをフラグメント化しません。 その結果、スイッチは異なる最大伝送単位(MTU)が設定された同じレイヤ 2 ドメイン内の 2 個のポートを持てません。 物理イーサネット インターフェイスごとの MTU はサポートされません。 代わりに、MTU は QoS クラスに応じて設定されます。 クラス マップとポリシー マップを設定して、MTU を変更します。


(注)  


インターフェイス設定を表示すると、物理イーサネット インターフェイスのデフォルト MTU は 1500 と表示されます。


イーサネット インターフェイスの設定

ここでは、次の内容について説明します。

Cisco Nexus 5500 プラットフォーム スイッチのレイヤ 3 インターフェイスの設定

Cisco Nexus デバイス(複数)に、レイヤ 3 インターフェイスを設定できます。

レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変更するには、switchport コマンドを使用します。 レイヤ 2 インターフェイスをレイヤ 3 インターフェイスに変更するには、no switchport コマンドを使用します。


(注)  



手順の概要

    1.    switch# configure terminal

    2.    switch(config)# interface ethernet slot/port

    3.    switch(config-if)# no switchport

    4.    switch(config-if)# no shutdown


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 switch# configure terminal
     

    コンフィギュレーション モードを開始します。

     
    ステップ 2 switch(config)# interface ethernet slot/port
     

    指定されたインターフェイスのコンフィギュレーション モードを開始します。

     
    ステップ 3 switch(config-if)# no switchport
     

    レイヤ 3 インターフェイスを選択します。

     
    ステップ 4 switch(config-if)# no shutdown
     

    インターフェイスを再起動します。

     

    次に、レイヤ 3 インターフェイスを設定する例を示します。

    switch# configure terminal
    switch(config)# interface ethernet 1/2
    switch(config-if)# no switchport
    switch(config-if)# no shutdown
    
    

    UDLD モードの設定

    Unidirectional Link Detection(UDLD; 単一方向リンク検出)を実行するように設定されているデバイス上のイーサネット インターフェイスには、ノーマル モードまたはアグレッシブ モードの UDLD を設定できます。 インターフェイスの UDLD モードをイネーブルにするには、そのインターフェイスを含むデバイス上で UDLD を事前にイネーブルにしておく必要があります。 UDLD は他方のリンク先のインターフェイスおよびそのデバイスでもイネーブルになっている必要があります。

    ノーマル UDLD モードを使用するには、ポートの 1 つをノーマル モードに設定し、他方のポートをノーマル モードまたはアグレッシブ モードに設定する必要があります。 アグレッシブ UDLD モードを使用するには、両方のポートをアグレッシブ モードに設定する必要があります。


    (注)  


    設定前に、リンクされている他方のポートとそのデバイスの UDLD をイネーブルにしておかなければなりません。


    手順の概要

      1.    switch# configure terminal

      2.    switch(config)# feature udld

      3.    switch(config)# no feature udld

      4.    switch(config)# show udld global

      5.    switch(config)# interface type slot/port

      6.    switch(config-if)# udld {enable | disable | aggressive}

      7.    switch(config-if)# show udld interface


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 switch# configure terminal
       

      コンフィギュレーション モードを開始します。

       
      ステップ 2 switch(config)# feature udld
       

      デバイスの UDLD をイネーブルにします。

       
      ステップ 3 switch(config)# no feature udld
       

      デバイスの UDLD をディセーブルにします。

       
      ステップ 4 switch(config)# show udld global
       

      デバイスの UDLD ステータスを表示します。

       
      ステップ 5 switch(config)# interface type slot/port
       

      設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 6 switch(config-if)# udld {enable | disable | aggressive}
       

      ノーマル UDLD モードをイネーブルにするか、UDLD をディセーブルにするか、またはアグレッシブ UDLD モードをイネーブルにします。

       
      ステップ 7 switch(config-if)# show udld interface
       

      インターフェイスの UDLD ステータスを表示します。

       

      次の例は、スイッチの UDLD をイネーブルにする方法を示しています。

       
      switch# configure terminal
      switch(config)# feature udld
      

      次の例は、イーサネット ポートのノーマル UDLD モードをイネーブルにする方法を示しています。

       
      switch# configure terminal
      switch(config)# interface ethernet 1/4
      switch(config-if)# udld enable
      

      次の例は、イーサネット ポートのアグレッシブ UDLD モードをイネーブルにする方法を示しています。

      switch# configure terminal
      switch(config)# interface ethernet 1/4
      switch(config-if)# udld aggressive
      

      次の例は、イーサネット ポートの UDLD をディセーブルにする例を示しています。

       
      switch# configure terminal
      switch(config)# interface ethernet 1/4
      switch(config-if)# udld disable
      

      次の例は、スイッチの UDLD をディセーブルにする方法を示しています。

      switch# configure terminal
      switch(config)# no feature udld
      

      インターフェイスの速度の設定

      Cisco Nexus 5596T スイッチの最初の 32 個のポートは、スイッチ可能な 1 ギガビット ポートと 10 ギガビット ポートです。 これらのポートはまた、1 ギガビットまたは 10 ギガビットに自動ネゴシエーションするようにも設定できます。 最後のポート 33 ~ 48 は SFP+ ポートであり、自動ネゴシエーションをサポートしていません。


      (注)  


      インターフェイスとトランシーバの速度が一致しない場合、show interface ethernet slot/port コマンドを入力すると、SFP 検証失敗メッセージが表示されます。 たとえば、speed 1000 コマンドを設定しないで 1 ギガビット SFP トランシーバをポートに挿入すると、このエラーが発生します。 デフォルトでは、すべてのポートが 10 ギガビットです。


      手順の概要

        1.    switch# configure terminal

        2.    switch(config)# interface type slot/port

        3.    switch(config-if)# speed speed


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1switch# configure terminal 

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2 switch(config)# interface type slot/port
         

        特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。 このインターフェイスに、1 ギガビット イーサネット SFP トランシーバが挿入されている必要があります。

         
        ステップ 3 switch(config-if)# speed speed
         

        物理イーサネット インターフェイスの速度を設定します。

        Cisco Nexus 5500 シリーズ スイッチの場合は、speed 引数を次のいずれかに設定できます。

        • 1000:1 Gbps
        • 10000:10Gbps
        • auto
        (注)     

        100 Mbps は、Cisco Nexus 5596 スイッチまたは CU-96 GEM カードでサポートされる速度ではありません。

        Cisco Nexus 5596T スイッチの場合、ベース ボード ポートは 1 Gbps と 10 Gbps をサポートしています。 10GBase-T ポートでは、auto も選択できます。

         

        次に、1 ギガビット イーサネット ポートを設定する例を示します。

        switch# configure terminal
        switch(config)# interface ethernet 1/4
        switch(config-if)# speed 1000

        リンク ネゴシエーションのディセーブル化

        リンク ネゴシエーションをディセーブルにするには、no negotiate auto コマンドを使用します。 デフォルトでは、自動ネゴシエーションは 1 ギガビット ポートでイネーブルであり、10 ギガビット ポートでディセーブルです。

        このコマンドは、Cisco IOS の speed non-negotiate コマンドに相当します。


        (注)  


        10 ギガビット ポートで自動ネゴシエーションをイネーブルにすることは推奨しません。 10 ギガビット ポートで自動ネゴシエーションをイネーブルにすると、リンクがダウンします。 デフォルトでは、リンク ネゴシエーションは 10 ギガビット ポートでディセーブルです。


        手順の概要

          1.    switch# configure terminal

          2.    switch(config)# interface ethernet slot/port

          3.    switch(config-if)# no negotiate auto

          4.    (任意) switch(config-if)# negotiate auto


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 switch# configure terminal 

          コンフィギュレーション モードを開始します。

           
          ステップ 2 switch(config)# interface ethernet slot/port 

          インターフェイスを選択し、インターフェイス モードを開始します。

           
          ステップ 3 switch(config-if)# no negotiate auto 

          選択したイーサネット インターフェイス(1 ギガビット ポート)のリンク ネゴシエーションをディセーブルにします。

           
          ステップ 4 switch(config-if)# negotiate auto  (任意)

          選択したイーサネット インターフェイスのリンク ネゴシエーションをイネーブルにします。 1 ギガビット ポートに対するデフォルトはイネーブルです。

          (注)     

          このコマンドは、10GBase-T ポートには適用できません。 このコマンドを 10GBase-T ポートでは使用しないでください。

           
          次に、指定したイーサネット インターフェイス(1 ギガビット ポート)で自動ネゴシエーションをディセーブルにする例を示します。
          switch# configure terminal
          switch(config)# interface ethernet 1/1
          switch(config-if)# no negotiate auto
          switch(config-if)#
          次に、指定したイーサネット インターフェイス(1 ギガビット ポート)で自動ネゴシエーションをイネーブルにする例を示します。
          switch# configure terminal
          switch(config)# interface ethernet 1/5
          switch(config-if)# negotiate auto
          switch(config-if)#

          CDP の特性の設定

          Cisco Discovery Protocol(CDP)更新の頻度、廃棄するまで情報を保持する期間、およびバージョン 2 アドバタイズメントを送信するかどうかを設定できます。

          手順の概要

            1.    switch# configure terminal

            2.    (任意) switch(config)# [no] cdp advertise {v1 | v2 }

            3.    (任意) switch(config)# [no] cdp format device-id {mac-address | serial-number | system-name}

            4.    (任意) switch(config)# [no] cdp holdtime seconds

            5.    (任意) switch(config)# [no] cdp timer seconds


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 switch# configure terminal
             

            コンフィギュレーション モードを開始します。

             
            ステップ 2 switch(config)# [no] cdp advertise {v1 | v2 }
             
            (任意)

            使用するバージョンを設定して、CDP アドバタイズメントを送信します。 バージョン 2 がデフォルト ステートです。

            デフォルト設定に戻すには、このコマンドの no 形式を使用します。

             
            ステップ 3 switch(config)# [no] cdp format device-id {mac-address | serial-number | system-name}
             
            (任意)

            CDP デバイス ID の形式を設定します。 デフォルトはシステム名です。完全修飾ドメイン名で表すことができます。

            デフォルト設定に戻すには、このコマンドの no 形式を使用します。

             
            ステップ 4 switch(config)# [no] cdp holdtime seconds
             
            (任意)

            受信デバイスがユーザのデバイスから送信された情報を破棄せずに保持する時間を指定します。 指定できる範囲は 10 ~ 255 秒です。デフォルトは 180 秒です。

            デフォルト設定に戻すには、このコマンドの no 形式を使用します。

             
            ステップ 5 switch(config)# [no] cdp timer seconds
             
            (任意)

            CDP アップデートの送信頻度を秒単位で設定します。 指定できる範囲は 5 ~ 254 です。デフォルトは 60 秒です。

            デフォルト設定に戻すには、このコマンドの no 形式を使用します。

             

            次の例は、CDP 特性を設定する方法を示しています。

            switch# configure terminal
            
            switch(config)# cdp timer 50
            
            switch(config)# cdp holdtime 120
            
            switch(config)# cdp advertise v2
            
             

            CDP のイネーブル化/ディセーブル化

            CDP をイーサネット インターフェイスに対してイネーブルにしたり、ディセーブルにしたりできます。 このプロトコルは、同一リンクの両方のインターフェイスでイネーブルになっている場合にだけ機能します。

            手順の概要

              1.    switch# configure terminal

              2.    switch(config)# interface type slot/port

              3.    switch(config-if)# cdp enable

              4.    switch(config-if)# no cdp enable


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 switch# configure terminal
               

              コンフィギュレーション モードを開始します。

               
              ステップ 2 switch(config)# interface type slot/port
               

              特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

               
              ステップ 3 switch(config-if)# cdp enable
               

              インターフェイスに対して CDP をイネーブルにします。

              正常に機能するには、このパラメータが同一リンク上の両方のインターフェイスでイネーブルになっている必要があります。

               
              ステップ 4 switch(config-if)# no cdp enable
               

              インターフェイスに対して CDP をディセーブルにします。

               

              次に、イーサネット ポートに対して CDP をイネーブルにする例を示します。

              switch# configure terminal
              
              switch(config)# interface ethernet 1/4
              
              switch(config-if)# cdp enable
              
               

              このコマンドは、物理的なイーサネット インターフェイスにしか適用できません。

              error-disabled 検出のイネーブル化

              アプリケーションでの error-disable(err-disabled)検出をイネーブルにできます。 その結果、原因がインターフェイスで検出された場合、インターフェイスは err-disabled ステート(リンクダウン ステートに類似した動作ステート)となります。

              手順の概要

                1.    config t

                2.    errdisable detect cause {all | link-flap | loopback}

                3.    shutdown

                4.    no shutdown

                5.    show interface status err-disabled

                6.    copy running-config startup-config


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1 config t


                例:
                switch# config t
                switch(config)#
                 

                コンフィギュレーション モードを開始します。

                 
                ステップ 2errdisable detect cause {all | link-flap | loopback}


                例:
                switch(config)# errdisable detect cause all
                switch(config)#
                 

                インターフェイスを err-disabled ステートにする条件を指定します。 デフォルトはイネーブルです。

                 
                ステップ 3shutdown


                例:
                switch(config)# shutdown
                switch(config)#
                 

                インターフェイスを管理的にダウンさせます。 インターフェイスを err-disabled ステートから手動で回復させるには、最初にこのコマンドを入力します。

                 
                ステップ 4no shutdown


                例:
                switch(config)# no shutdown
                switch(config)#
                 

                インターフェイスを管理的にアップし、err-disabled ステートからインターフェイスを手動で回復できるようにします。

                 
                ステップ 5show interface status err-disabled


                例:
                switch(config)# show interface status err-disabled
                 

                err-disabled インターフェイスに関する情報を表示します。

                 
                ステップ 6copy running-config startup-config


                例:
                switch(config)# copy running-config startup-config
                 

                (任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

                 

                次の例では、すべての場合で err-disabled 検出をイネーブルにする方法を示します。

                switch(config)#errdisable detect cause all
                switch(config)#
                

                errdisable リカバリのイネーブル化

                アプリケーションを指定してインターフェイスを errdisable(err-disabled)ステートから抜け出させ、稼働を再試行できます。 回復タイマーを設定しない限り、300 秒後にリトライします(errdisable recovery interval コマンドを参照)。

                手順の概要

                  1.    config t

                  2.    errdisable recovery cause {all | udld | bpduguard | link-flap | failed-port-state | pause-rate-limit}

                  3.    show interface status err-disabled

                  4.    copy running-config startup-config


                手順の詳細
                   コマンドまたはアクション目的
                  ステップ 1 config t


                  例:
                  switch#config t
                  switch(config)#
                   

                  コンフィギュレーション モードを開始します。

                   
                  ステップ 2errdisable recovery cause {all | udld | bpduguard | link-flap | failed-port-state | pause-rate-limit}


                  例:
                  switch(config)#errdisable recovery cause all
                  switch(config-if)#
                   

                  インターフェイスが err-disabled ステートから自動的に回復する条件を指定し、デバイスはインターフェイスのアップを再試行します。 デバイスは 300 秒待機してからリトライします。 デフォルトはディセーブルです。

                   
                  ステップ 3show interface status err-disabled


                  例:
                  switch(config)#show interface status err-disabled
                   

                  err-disabled インターフェイスに関する情報を表示します。

                   
                  ステップ 4copy running-config startup-config


                  例:
                  switch(config)#copy running-config startup-config
                   

                  (任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

                   

                  次に、すべての条件下で err-disabled リカバリをイネーブルにする例を示します。

                  switch(config)#errdisable recovery cause all
                  switch(config)#
                  

                  errdisable リカバリ間隔の設定

                  errdisabled リカバリ時間値を設定するには、この手順を使用します。 有効な範囲は 30 ~ 65535 秒です。 デフォルト値は 300 秒です。

                  手順の概要

                    1.    config t

                    2.    errdisable recovery interval interval

                    3.    show interface status err-disabled

                    4.    copy running-config startup-config


                  手順の詳細
                     コマンドまたはアクション目的
                    ステップ 1config t


                    例:
                    switch#config t
                    switch(config)#
                     

                    コンフィギュレーション モードを開始します。

                     
                    ステップ 2errdisable recovery interval interval


                    例:
                    switch(config)#errdisable recovery interval 32
                    switch(config-if)#
                     

                    インターフェイスが errdisabled ステートから回復する間隔を指定します。 有効な範囲は 30 ~ 65535 秒です。 デフォルト値は 300 秒です。

                     
                    ステップ 3show interface status err-disabled


                    例:
                    switch(config)#show interface status err-disabled
                     

                    errdisabled インターフェイスに関する情報を表示します。

                     
                    ステップ 4copy running-config startup-config


                    例:
                    switch(config)#copy running-config startup-config
                     

                    (任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

                     

                    次に、すべての条件下で errdisabled リカバリをイネーブルにする例を示します。

                    switch(config)#errdisable recovery cause all
                    switch(config)#
                    

                    ポート プロファイル

                    ポート プロファイルの作成

                    スイッチにポート プロファイルを作成できます。 各ポート プロファイルは、インターフェイス タイプにかかわらず、ネットワーク全体で一意の名前を持つ必要があります。

                    手順の概要

                      1.    configure terminal

                      2.    port-profile [type {ethernet | interface-vlan | port channel}] name

                      3.    exit

                      4.    (任意) show port-profile

                      5.    (任意) copy running-config startup-config


                    手順の詳細
                       コマンドまたはアクション目的
                      ステップ 1 configure terminal


                      例:
                      switch# configure terminal
                      switch(config)#
                       

                      コンフィギュレーション モードを開始します。

                       
                      ステップ 2 port-profile [type {ethernet | interface-vlan | port channel}] name


                      例:
                      switch(config)# port-profile type ethernet test
                      switch(config-port-prof)#
                      
                       

                      指定されたタイプのインターフェイスのポート プロファイルを作成して命名し、ポート プロファイル コンフィギュレーション モードを開始します。

                       
                      ステップ 3 exit


                      例:
                      switch(config-port-prof)# exit
                      switch(config)#
                       

                      ポート プロファイル コンフィギュレーション モードを終了します。

                       
                      ステップ 4 show port-profile


                      例:
                      switch(config)# show port-profile name
                       
                      (任意)

                      ポート プロファイルの設定を表示します。

                       
                      ステップ 5 copy running-config startup-config


                      例:
                      switch(config)# copy running-config startup-config
                       
                      (任意)

                      実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                       

                      次に、イーサネット インターフェイスの test という名前のポート プロファイルを作成する例を示します。

                      switch# configure terminal 
                      switch(config)# port-profile type ethernet test
                      switch(config-port-prof)# 

                      次に、イーサネット インターフェイスに設定された ppEth という名前のポート プロファイルにインターフェイス コマンドを追加する例を示します。

                      switch# configure terminal
                      switch(config)# port-profile ppEth
                      switch(config-port-prof)# switchport mode trunk
                      switch(config-port-prof)# switchport trunk allowed vlan 300-400
                      switch(config-port-prof)# flowcontrol receive on
                      switch(config-port-prof)# speed 10000
                      switch(config-port-prof)#

                      ポート プロファイルの変更

                      ポート プロファイル コンフィギュレーション モードでポート プロファイルを変更できます。

                      このコマンドの no 形式を使用して、ポート プロファイルからコマンドを削除できます。 ポート プロファイルからコマンドを削除すると、対応するコマンドは、ポート プロファイルにアタッチされているインターフェイスから削除されます。

                      手順の概要

                        1.    configure terminal

                        2.    port-profile [type {ethernet | interface-vlan | port channel}] name

                        3.    exit

                        4.    (任意) show port-profile

                        5.    (任意) copy running-config startup-config


                      手順の詳細
                         コマンドまたはアクション目的
                        ステップ 1 configure terminal


                        例:
                        switch# configure terminal
                        switch(config)#
                         

                        コンフィギュレーション モードを開始します。

                         
                        ステップ 2 port-profile [type {ethernet | interface-vlan | port channel}] name


                        例:
                        switch(config)# port-profile type ethernet test
                        switch(config-port-prof)#
                        
                         

                        指定されたポート プロファイルのポート プロファイル コンフィギュレーション モードを開始し、プロファイルの設定を追加または削除します。

                         
                        ステップ 3 exit


                        例:
                        switch(config-port-prof)# exit
                        switch(config)#
                         

                        ポート プロファイル コンフィギュレーション モードを終了します。

                         
                        ステップ 4 show port-profile


                        例:
                        switch(config)# show port-profile name
                         
                        (任意)

                        ポート プロファイルの設定を表示します。

                         
                        ステップ 5 copy running-config startup-config


                        例:
                        switch(config)# copy running-config startup-config
                         
                        (任意)

                        実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                         

                        次に、イーサネット インターフェイスに設定された ppEth という名前のポート プロファイルからコマンドを削除する例を示します。

                        switch# configure terminal
                        switch(config)# port-profile ppEth
                        switch(config-port-prof)# switchport mode trunk
                        switch(config-port-prof)# switchport trunk allowed vlan 300-400
                        switch(config-port-prof)# flowcontrol receive on
                        switch(config-port-prof)# no speed 10000
                        switch(config-port-prof)#

                        特定のポート プロファイルのイネーブル化

                        手順の概要

                          1.    configure terminal

                          2.    port-profile [type {ethernet | interface-vlan | port channel}] name

                          3.    state enabled name

                          4.    exit

                          5.    (任意) show port-profile

                          6.    (任意) copy running-config startup-config


                        手順の詳細
                           コマンドまたはアクション目的
                          ステップ 1 configure terminal


                          例:
                          switch# configure terminal
                          switch(config)#
                           

                          コンフィギュレーション モードを開始します。

                           
                          ステップ 2 port-profile [type {ethernet | interface-vlan | port channel}] name


                          例:
                          switch(config)# port-profile type ethernet test
                          switch(config-port-prof)# no shutdown
                          switch(config-port-prof)# 
                          
                           

                          指定されたポート プロファイルに対して、ポート プロファイル コンフィギュレーション モードを開始します。

                           
                          ステップ 3 state enabled name


                          例:
                          switch(config-port-prof)# state enabled
                          switch(config-port-prof)#  
                          
                           

                          ポート プロファイルをイネーブルにします。

                           
                          ステップ 4 exit


                          例:
                          switch(config-port-prof)# exit
                          switch(config)#
                           

                          ポート プロファイル コンフィギュレーション モードを終了します。

                           
                          ステップ 5 show port-profile


                          例:
                          switch(config)# show port-profile name
                           
                          (任意)

                          ポート プロファイルの設定を表示します。

                           
                          ステップ 6 copy running-config startup-config


                          例:
                          switch(config)# copy running-config startup-config
                           
                          (任意)

                          実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                           

                          次に、ポート プロファイル コンフィギュレーション モードを開始し、ポート プロファイルをイネーブルにする例を示します。

                          switch# configure terminal 
                          switch(config)# port-profile type ethernet test
                          switch(config-port-prof)# state enabled
                          switch(config-port-prof)#

                          ポート プロファイルの継承

                          ポート プロファイルを既存のポート プロファイルに継承できます。 スイッチは 4 つのレベルの継承をサポートしています。

                          手順の概要

                            1.    configure terminal

                            2.    port-profile name

                            3.    inherit port-profile name

                            4.    exit

                            5.    (任意) show port-profile

                            6.    (任意) copy running-config startup-config


                          手順の詳細
                             コマンドまたはアクション目的
                            ステップ 1 configure terminal


                            例:
                            switch# configure terminal
                            switch(config)#
                             

                            コンフィギュレーション モードを開始します。

                             
                            ステップ 2 port-profile name


                            例:
                            switch(config)# port-profile test
                            switch(config-port-prof)#
                            
                             

                            指定したポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。

                             
                            ステップ 3 inherit port-profile name


                            例:
                            switch(config-port-prof)#  inherit port-profile adam
                            switch(config-port-prof)#  
                            
                             

                            別のポート プロファイルを既存のポート プロファイルに継承します。 元のポート プロファイルは、継承されたポート プロファイルのすべての設定を想定します。

                             
                            ステップ 4 exit


                            例:
                            switch(config-port-prof)# exit
                            switch(config)#
                             

                            ポート プロファイル コンフィギュレーション モードを終了します。

                             
                            ステップ 5 show port-profile


                            例:
                            switch(config)# show port-profile name
                             
                            (任意)

                            ポート プロファイルの設定を表示します。

                             
                            ステップ 6 copy running-config startup-config


                            例:
                            switch(config)# copy running-config startup-config
                             
                            (任意)

                            実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                             

                            次の例では、adam という名前のポート プロファイルを test という名前のポート プロファイルに継承する方法を示します。

                            switch# configure terminal 
                            switch(config)# port-profile test
                            switch(config-ppm)# inherit port-profile adam
                            switch(config-ppm)# 

                            次に、イーサネット インターフェイスに設定された ppEth という名前のポート プロファイルにインターフェイス コマンドを追加する例を示します。

                            switch# configure terminal
                            switch(config)# port-profile ppEth
                            switch(config-port-prof)# switchport mode trunk
                            switch(config-port-prof)# switchport trunk allowed vlan 300-400
                            switch(config-port-prof)# flowcontrol receive on
                            switch(config-port-prof)# speed 10000
                            switch(config-port-prof)#

                            次に、test という名前の既存のポート プロファイルにイーサネット インターフェイスに設定された ppEth という名前のポート プロファイルを継承する例を示します。

                            switch# configure terminal
                            switch(config)# port-profile test
                            switch(config-port-prof)# inherit port-profile ppEth
                            switch(config-port-prof)#
                            

                            次に、ppEth という名前のイーサネット インターフェイスに設定されたポート プロファイルをイーサネット インターフェイスの範囲に割り当てる例を示します。

                            switch# configure terminal
                            switch(config)# interface ethernet 1/2-5
                            switch(config-if)# inherit port-profile ppEth
                            switch(config-if)#
                            

                            次の例では、ppEth という名前の継承されたポート プロファイルを test という名前の既存のポート プロファイルから削除する方法を示します。

                            switch# configure terminal
                            switch(config)# port-profile test
                            switch(config-port-prof)# no inherit port-profile ppEth
                            switch(config-port-prof)#
                            

                            継承されたポート プロファイルの削除

                            継承されたポート プロファイルを削除できます。

                            手順の概要

                              1.    configure terminal

                              2.    port-profile name

                              3.    no inherit port-profile name

                              4.    exit

                              5.    (任意) show port-profile

                              6.    (任意) copy running-config startup-config


                            手順の詳細
                               コマンドまたはアクション目的
                              ステップ 1 configure terminal


                              例:
                              switch# configure terminal
                              switch(config)#
                               

                              コンフィギュレーション モードを開始します。

                               
                              ステップ 2 port-profile name


                              例:
                              switch(config)# port-profile test
                              switch(config-port-prof)#
                              
                               

                              指定したポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。

                               
                              ステップ 3 no inherit port-profile name


                              例:
                              switch(config-port-prof)#  no inherit port-profile adam
                              switch(config-port-prof)#  
                              
                               

                              このポート プロファイルから継承されたポート プロファイルを削除します。

                               
                              ステップ 4 exit


                              例:
                              switch(config-port-prof)# exit
                              switch(config)#
                               

                              ポート プロファイル コンフィギュレーション モードを終了します。

                               
                              ステップ 5 show port-profile


                              例:
                              switch(config)# show port-profile name
                               
                              (任意)

                              ポート プロファイルの設定を表示します。

                               
                              ステップ 6 copy running-config startup-config


                              例:
                              switch(config)# copy running-config startup-config
                               
                              (任意)

                              実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                               

                              次の例では、adam という名前の継承されたポート プロファイルを test という名前のポート プロファイルから削除する方法を示します。

                              switch# configure terminal 
                              switch(config)# port-profile test
                              switch(config-ppm)# no inherit port-profile adam
                              switch(config-ppm)# 

                              一定範囲のインターフェイスへのポート プロファイルの割り当て

                              インターフェイスまたはインターフェイスの範囲にポート プロファイルを割り当てることができます。 すべてのインターフェイスが同じタイプである必要があります。

                              手順の概要

                                1.    configure terminal

                                2.    interface [ethernet slot/port | interface-vlan vlan-id | port-channel number]

                                3.    inherit port-profile name

                                4.    exit

                                5.    (任意) show port-profile

                                6.    (任意) copy running-config startup-config


                              手順の詳細
                                 コマンドまたはアクション目的
                                ステップ 1 configure terminal


                                例:
                                switch# configure terminal
                                switch(config)#
                                 

                                コンフィギュレーション モードを開始します。

                                 
                                ステップ 2interface [ethernet slot/port | interface-vlan vlan-id | port-channel number]


                                例:
                                switch(config)# interface ethernet 7/3-5, 10/2, 11/20-25
                                switch(config-if)#
                                 

                                インターフェイスの範囲を選択します。

                                 
                                ステップ 3 inherit port-profile name


                                例:
                                switch(config-if)# inherit port-profile adam
                                switch(config-if)#
                                 

                                選択したインターフェイスに指定されたポート プロファイルを割り当てます。

                                 
                                ステップ 4 exit


                                例:
                                switch(config-port-prof)# exit
                                switch(config)#
                                 

                                ポート プロファイル コンフィギュレーション モードを終了します。

                                 
                                ステップ 5 show port-profile


                                例:
                                switch(config)# show port-profile name
                                 
                                (任意)

                                ポート プロファイルの設定を表示します。

                                 
                                ステップ 6 copy running-config startup-config


                                例:
                                switch(config)# copy running-config startup-config
                                 
                                (任意)

                                実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                                 

                                次に、イーサネット インターフェイス 2/3 ~ 2/5、3/2、および 1/20 ~ 1/25 に adam という名前のポート プロファイルを割り当てる例を示します。

                                switch# configure terminal 
                                switch(config)# interface ethernet 2/3 to 2/5, 3/2, and 1/20 to 1/25
                                switch(config-if)# inherit port-profile adam
                                switch(config-if)# 

                                一定範囲のインターフェイスからのポート プロファイルの削除

                                プロファイルを適用した一部またはすべてのインターフェイスから、ポート プロファイルを削除できます。

                                手順の概要

                                  1.    configure terminal

                                  2.    interface [ethernet slot/port | interface-vlan vlan-id | port-channel number]

                                  3.    no inherit port-profile name

                                  4.    exit

                                  5.    (任意) show port-profile

                                  6.    (任意) copy running-config startup-config


                                手順の詳細
                                   コマンドまたはアクション目的
                                  ステップ 1 configure terminal


                                  例:
                                  switch# configure terminal
                                  switch(config)#
                                   

                                  コンフィギュレーション モードを開始します。

                                   
                                  ステップ 2interface [ethernet slot/port | interface-vlan vlan-id | port-channel number]


                                  例:
                                  switch(config)# interface ethernet 7/3-5, 10/2, 11/20-25
                                  switch(config-if)#
                                   

                                  インターフェイスの範囲を選択します。

                                   
                                  ステップ 3 no inherit port-profile name


                                  例:
                                  switch(config-if)# no inherit port-profile adam
                                  switch(config-if)#
                                   

                                  選択されたインターフェイスから指定されたポート プロファイルを削除します。

                                   
                                  ステップ 4 exit


                                  例:
                                  switch(config-port-prof)# exit
                                  switch(config)#
                                   

                                  ポート プロファイル コンフィギュレーション モードを終了します。

                                   
                                  ステップ 5 show port-profile


                                  例:
                                  switch(config)# show port-profile name
                                   
                                  (任意)

                                  ポート プロファイルの設定を表示します。

                                   
                                  ステップ 6 copy running-config startup-config


                                  例:
                                  switch(config)# copy running-config startup-config
                                   
                                  (任意)

                                  実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                                   

                                  tos がイーサネット インターフェイス 1/3-5 から adam という名前のポート プロファイルを削除する例を示します。

                                  switch# configure terminal 
                                  switch(config)# interface ethernet 1/3-5
                                  switch(config-if)# no inherit port-profile adam
                                  switch(config-if)# 

                                  ポート プロファイルの設定例

                                  次に、ポート プロファイルを設定し、イーサネット インターフェイスのポート プロファイルを継承して、ポート プロファイルをイネーブルにする例を示します。

                                  switch(config)#
                                  switch(config)# show running-config interface Ethernet1/14
                                   
                                  !Command: show running-config interface Ethernet1/14
                                  !Time: Thu Aug 26 07:01:32 2010
                                   
                                  version 5.0(2)N1(1)
                                   
                                  interface Ethernet1/14
                                   
                                  switch(config)# port-profile type ethernet alpha
                                  switch(config-port-prof)# switchport mode trunk
                                  switch(config-port-prof)# switchport trunk allowed vlan 10-15
                                  switch(config-port-prof)#
                                  switch(config-port-prof)# show running-config port-profile alpha
                                   
                                  !Command: show running-config port-profile alpha
                                  !Time: Thu Aug 26 07:02:29 2010
                                   
                                  version 5.0(2)N1(1)
                                  port-profile type ethernet alpha
                                    switchport mode trunk
                                    switchport trunk allowed vlan 10-15
                                   
                                  
                                  switch(config-port-prof)# int eth 1/14
                                  switch(config-if)# inherit port-profile alpha
                                  switch(config-if)#
                                  switch(config-if)# port-profile type ethernet alpha
                                  switch(config-port-prof)# state enabled
                                  switch(config-port-prof)#
                                  switch(config-port-prof)# sh running-config interface ethernet 1/14
                                   
                                  !Command: show running-config interface Ethernet1/14
                                  !Time: Thu Aug 26 07:03:17 2010
                                   
                                  version 5.0(2)N1(1)
                                   
                                  interface Ethernet1/14
                                    inherit port-profile alpha
                                   
                                  switch(config-port-prof)# sh running-config interface ethernet 1/14 expand-port-profile
                                   
                                  !Command: show running-config interface Ethernet1/14 expand-port-profile
                                  !Time: Thu Aug 26 07:03:21 2010
                                   
                                  version 5.0(2)N1(1)
                                   
                                  interface Ethernet1/14
                                    switchport mode trunk
                                    switchport trunk allowed vlan 10-15
                                   
                                  switch(config-port-prof)#
                                  

                                  デバウンス タイマーの設定

                                  イーサネットのデバウンス タイマーは、デバウンス時間(ミリ秒単位)を指定することによりイネーブル化でき、デバウンス時間に 0 を指定することによりディセーブル化できます。

                                  show interface debounce コマンドを使用すれば、すべてのイーサネット ポートのデバウンス時間を表示できます。

                                  デバウンス タイマーをイネーブル/ディセーブルにする手順は、次のとおりです。

                                  手順の概要

                                    1.    switch# configure terminal

                                    2.    switch(config)# interface type slot/port

                                    3.    switch(config-if)# link debounce time milliseconds


                                  手順の詳細
                                     コマンドまたはアクション目的
                                    ステップ 1 switch# configure terminal
                                     

                                    コンフィギュレーション モードを開始します。

                                     
                                    ステップ 2 switch(config)# interface type slot/port
                                     

                                    特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

                                     
                                    ステップ 3 switch(config-if)# link debounce time milliseconds
                                     

                                    指定した時間(1 ~ 5,000 ミリ秒)でデバウンス タイマーをイネーブルにします。

                                    0 ミリ秒を指定すると、デバウンス タイマーはディセーブルになります。

                                     

                                    次の例は、イーサネット インターフェイスでデバウンス タイマーをイネーブルにして、デバウンス時間を 1000 ミリ秒に設定する方法を示しています。

                                    switch# configure terminal
                                    switch(config)# interface ethernet 1/4
                                    switch(config-if)# link debounce time 1000

                                    次の例は、イーサネット インターフェイスでデバウンス タイマーをディセーブルにする方法を示しています。

                                    switch# configure terminal
                                    switch(config)# interface ethernet 1/4
                                    switch(config-if)# link debounce time 0

                                    説明パラメータの設定

                                    イーサネット ポートのインターフェイスに関する説明を入力することができます。

                                    手順の概要

                                      1.    switch# configure terminal

                                      2.    switch(config)# interface type slot/port

                                      3.    switch(config-if)# description test


                                    手順の詳細
                                       コマンドまたはアクション目的
                                      ステップ 1 switch# configure terminal
                                       

                                      コンフィギュレーション モードを開始します。

                                       
                                      ステップ 2 switch(config)# interface type slot/port
                                       

                                      特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

                                       
                                      ステップ 3 switch(config-if)# description test
                                       

                                      インターフェイスの説明を指定します。

                                       

                                      次に、インターフェイスの説明を Server 3 Interface に設定する例を示します。

                                      switch# configure terminal
                                      
                                      switch(config)# interface ethernet 1/3
                                      
                                      switch(config-if)# description Server 3 Interface
                                      
                                       

                                      イーサネット インターフェイスのディセーブル化と再起動

                                      イーサネット インターフェイスは、シャットダウンして再起動することができます。 この操作により、すべてのインターフェイス機能がディセーブル化され、すべてのモニタリング画面でインターフェイスがダウンしているものとしてマークされます。 この情報は、すべてのダイナミック ルーティング プロトコルを通じて、他のネットワーク サーバに伝達されます。 シャットダウンされたインターフェイスは、どのルーティング アップデートにも含まれません。

                                      手順の概要

                                        1.    switch# configure terminal

                                        2.    switch(config)# interface type slot/port

                                        3.    switch(config-if)# shutdown

                                        4.    switch(config-if)# no shutdown


                                      手順の詳細
                                         コマンドまたはアクション目的
                                        ステップ 1 switch# configure terminal
                                         

                                        コンフィギュレーション モードを開始します。

                                         
                                        ステップ 2 switch(config)# interface type slot/port
                                         

                                        特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

                                         
                                        ステップ 3 switch(config-if)# shutdown
                                         

                                        インターフェイスをディセーブルにします。

                                         
                                        ステップ 4 switch(config-if)# no shutdown
                                         

                                        インターフェイスを再起動します。

                                         

                                        次に、イーサネット ポートをディセーブルにする例を示します。

                                        switch# configure terminal
                                        
                                        switch(config)# interface ethernet 1/4
                                        
                                        switch(config-if)# shutdown
                                        

                                        次に、イーサネット インターフェイスを再起動する例を示します。

                                        switch# configure terminal
                                        
                                        switch(config)# interface ethernet 1/4
                                        
                                        switch(config-if)# no shutdown
                                        

                                        インターフェイス情報の表示

                                        定義済みインターフェイスに関する設定情報を表示するには、次のうちいずれかの手順を実行します。

                                        コマンド

                                        目的

                                        switch# show interface type slot/port

                                        指定したインターフェイスの詳細設定が表示されます。

                                        switch# show interface type slot/port capabilities

                                        指定したインターフェイスの機能に関する詳細情報が表示されます。 このオプションは、物理インターフェイスにしか使用できません。

                                        switch# show interface type slot/port transceiver

                                        指定したインターフェイスに接続されているトランシーバに関する詳細情報が表示されます。 このオプションは、物理インターフェイスにしか使用できません。

                                        switch# show interface brief

                                        すべてのインターフェイスのステータスが表示されます。

                                        switch# show interface debounce

                                        すべてのインターフェイスのデバウンス ステータスが表示されます。

                                        switch# show interface flowcontrol

                                        すべてのインターフェイスでフロー制御設定の詳細なリストを表示します。

                                        show interface コマンドは、EXEC モードから呼び出され、インターフェイスの設定を表示します。 引数を入力せずにこのコマンドを実行すると、スイッチ内に設定されたすべてのインターフェイスの情報が表示されます。

                                        次に、物理イーサネット インターフェイスを表示する例を示します。

                                        switch# show interface ethernet 1/1
                                          Ethernet1/1 is up
                                          Hardware is 1000/10000 Ethernet, address is 000d.eca3.5f08 (bia 000d.eca3.5f08)
                                          MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,
                                             reliability 255/255, txload 190/255, rxload 192/255
                                          Encapsulation ARPA
                                          Port mode is trunk
                                          full-duplex, 10 Gb/s, media type is 1/10g
                                          Input flow-control is off, output flow-control is off
                                          Auto-mdix is turned on
                                          Rate mode is dedicated
                                          Switchport monitor is off
                                          Last clearing of "show interface" counters never
                                          5 minute input rate 942201806 bytes/sec, 14721892 packets/sec
                                          5 minute output rate 935840313 bytes/sec, 14622492 packets/sec
                                          Rx
                                            129141483840 input packets 0 unicast packets 129141483847 multicast packets
                                            0 broadcast packets 0 jumbo packets 0 storm suppression packets
                                            8265054965824 bytes
                                            0 No buffer 0 runt 0 Overrun
                                            0 crc 0 Ignored 0 Bad etype drop
                                            0 Bad proto drop
                                          Tx
                                            119038487241 output packets 119038487245 multicast packets
                                           0 broadcast packets 0 jumbo packets
                                            7618463256471 bytes
                                            0 output CRC 0 ecc
                                            0 underrun 0 if down drop     0 output error 0 collision 0 deferred
                                            0 late collision 0 lost carrier 0 no carrier
                                            0 babble
                                            0 Rx pause 8031547972 Tx pause 0 reset

                                        次に、物理イーサネットの機能を表示する例を示します。

                                        switch# show interface ethernet 1/1 capabilities
                                        Ethernet1/1
                                          Model:                 734510033
                                          Type:                  10Gbase-(unknown)
                                          Speed:                 1000,10000
                                          Duplex:                full
                                          Trunk encap. type:     802.1Q
                                          Channel:               yes
                                          Broadcast suppression: percentage(0-100)
                                          Flowcontrol:           rx-(off/on),tx-(off/on)
                                          Rate mode:             none
                                          QOS scheduling:        rx-(6q1t),tx-(1p6q0t)
                                          CoS rewrite:           no
                                          ToS rewrite:           no
                                          SPAN:                  yes
                                          UDLD:                  yes
                                          Link Debounce:         yes
                                          Link Debounce Time:    yes
                                          MDIX:                  no
                                          FEX Fabric:            yes
                                        

                                        次に、物理イーサネット トランシーバを表示する例を示します。

                                        switch# show interface ethernet 1/1 transceiver
                                        Ethernet1/1
                                            sfp is present
                                            name is CISCO-EXCELIGHT
                                            part number is SPP5101SR-C1
                                            revision is A
                                            serial number is ECL120901AV
                                            nominal bitrate is 10300 MBits/sec
                                            Link length supported for 50/125mm fiber is 82 m(s)
                                            Link length supported for 62.5/125mm fiber is 26 m(s)
                                            cisco id is --
                                            cisco extended id number is 4

                                        次に、インターフェイス ステータスの要約を表示する例を示します(簡潔にするため、一部の出力が削除されています)。

                                        switch# show interface brief
                                        
                                        --------------------------------------------------------------------------------
                                        Ethernet      VLAN   Type Mode   Status  Reason                   Speed     Port
                                        Interface                                                                   Ch #
                                        --------------------------------------------------------------------------------
                                        Eth1/1        200    eth  trunk  up      none                        10G(D) --
                                        Eth1/2        1      eth  trunk  up      none                        10G(D) --
                                        Eth1/3        300    eth  access down    SFP not inserted            10G(D) --
                                        Eth1/4        300    eth  access down    SFP not inserted            10G(D) --
                                        Eth1/5        300    eth  access down    Link not connected         1000(D) --
                                        Eth1/6        20     eth  access down    Link not connected          10G(D) --
                                        Eth1/7        300    eth  access down    SFP not inserted            10G(D) --
                                        ...
                                        

                                        次に、リンクのデバウンス ステータスを表示する例を示します(簡潔にするため、一部の出力が削除されています)。

                                        switch# show interface debounce
                                        
                                        --------------------------------------------------------------------------------
                                        Port          Debounce time   Value(ms)
                                        --------------------------------------------------------------------------------
                                        ...
                                        Eth1/1        enable               100
                                        Eth1/2        enable               100
                                        Eth1/3        enable               100
                                        ...
                                        

                                        次に、CDP ネイバーを表示する例を示します。

                                        switch# show cdp neighbors
                                        Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
                                                          S - Switch, H - Host, I - IGMP, r - Repeater,
                                                          V - VoIP-Phone, D - Remotely-Managed-Device,
                                                          s - Supports-STP-Dispute
                                        Device ID              Local Intrfce   Hldtme  Capability  Platform      Port ID
                                        d13-dist-1               mgmt0           148     S I      WS-C2960-24TC  Fas0/9
                                        n5k(FLC12080012)         Eth1/5          8       S I s    N5K-C5020P-BA  Eth1/5

                                        物理イーサネットのデフォルト設定

                                        次の表に、すべての物理イーサネット インターフェイスのデフォルト設定を示します。

                                        パラメータ

                                        デフォルト設定

                                        デバウンス

                                        イネーブル、100 ミリ秒

                                        デュプレックス

                                        オート(全二重)

                                        カプセル化

                                        ARPA

                                        MTU1

                                        1500 バイト

                                        ポート モード

                                        アクセス

                                        速度

                                        オート(10000)

                                        1 MTU を物理イーサネット インターフェイスごとに変更することはできません。 MTU の変更は、QoS クラスのマップを選択することにより行います。