Cisco Nexus 5000 シリーズ NX-OS レイヤ 2 スイッチング コンフィギュレーション ガイド リリース 5.2(1)N1(2)
拡張仮想ポート チャネルの設定
拡張仮想ポート チャネルの設定
発行日;2013/01/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

拡張仮想ポート チャネルの設定

この章の内容は、次のとおりです。

拡張 vPC について

拡張仮想ポート チャネルの概要

仮想ポート チャネル(vPC)機能により、ホストから 2 つのファブリック エクステンダ(FEX)へのデュアル ホーム接続または FEX から 2 つのスイッチへのデュアルホーム接続が可能になります。 拡張 vPC 機能、つまり、2 レイヤ vPC により、次の図のように 2 つのデュアル ホーミング トポロジを同時に組み合わせることができます。

拡張 vPC では、ホストから FEX、および FEX からスイッチへのパスがアクティブとなり、使用可能なすべてのパスがアクティブとなり、イーサネット トラフィックを伝送し、使用可能な帯域幅を最大限に活用し、両方のレベルで冗長性を提供します。

vPC については、仮想ポート チャネルの設定を参照してください。

サポートされているプラットフォームとトポロジ

サポートされているプラットフォーム

拡張 vPC は、NX-OS Release 5.1(3)N1(1) 以降のリリースを実行している Cisco Nexus 5500 プラットフォーム でサポートされます。

すべての Cisco Nexus 2000 シリーズ ファブリック エクステンダは、拡張 vPC と組み合わせて使用できます。

拡張 vPC は、スイッチでレイヤ 3 機能と互換性があります。

サポートされているトポロジとサポートされていないトポロジ

拡張 vPC では、次のトポロジをサポートしています。

  • 単一の FEX に接続されているシングルホーム接続サーバ
  • ポート チャネルによって単一の FEX に接続されているデュアルホーム接続サーバ
  • ポート チャネルによって FEX のペアに接続されているデュアルホーム接続サーバ このトポロジにより、vPC ドメインで同一のスイッチ ペアに接続されている 2 つの FEX への接続が可能になります。 スタティック ポート チャネルと LACP ベースのポート チャネルがサポートされています。
  • FCoE とポート チャネルによって FEX のペアに接続されているデュアルホーム接続サーバ
  • アクティブ/スタンバイ NIC チーミングによって FEX のペアに接続されているデュアルホーム接続サーバ

拡張 vPC は次のトポロジをサポートしていません。

  • 1 つのスイッチに接続する FEX のペアに接続されているデュアルホーム接続サーバ このトポロジは 1 つのスイッチに障害が発生した場合に機能するシステムになりますが、これは通常の動作で推奨されません。
  • ポート チャネルによって 2 つを超える FEX に接続されているマルチホーム接続サーバ このトポロジによって、複雑性が増し、利点がほとんどなくなります。

拡張 vPC のスケーラビリティ

拡張 vPC のスケーラビリティは、デュアルホーム接続 FEX トポロジのスケーラビリティと似ています。

Cisco Nexus 5500 プラットフォーム スイッチは、最大 24 台の FEX(レイヤ 3 設定なし)または 16 台の FEX(レイヤ 3 設定あり)をサポートしています。 デュアルホーム接続 FEX トポロジでは、拡張 vPC の場合のように各 FEX は 2 つのスイッチによって管理されるため、ペアも同時に 24 台または 16 台の FEX をサポートします。

拡張 vPC の失敗応答

拡張 vPC トポロジにより、次のシナリオで説明しているシステム コンポーネントおよびリンクの障害の高レベルの復元力が実現します。

  • ポート チャネルの 1 つ以上のメンバ リンクの障害 ポート チャネルの 1 つのメンバ リンクに障害が発生した場合、トラフィック フローはポート チャネルの残りのメンバ リンクに移動されます。 ポート チャネルのすべてのメンバ リンクに障害が発生した場合、トラフィック フローは vPC の残りのポート チャネルにリダイレクトされます。
  • 1 つの FEX の障害 1 つの FEX に障害が発生した場合、すべてのデュアルホーム接続ホストからのトラフィック フローは残りの FEX に移動されます。
  • 1 つのスイッチの障害 1 つのスイッチに障害が発生した場合、すべてのデュアルホーム接続 FEX からのトラフィック フローは残りのスイッチに移動されます。 ホストからのトラフィックは影響を受けません。
  • 1 つの FEX からの両方のアップリンクの障害 1 つの FEX からの両方のアップリンクに障害が発生した場合、FEX はそのホスト ポートをシャットダウンし、すべてのデュアルホーム接続ホストからのトラフィック フローは他の FEX に移動されます。
  • vPC ピア リンクの障害 vPC セカンダリ スイッチでピア リンクの障害が検出される場合、ピアキープアライブ リンクを介してプライマリ スイッチのステータスを確認します。 プライマリ スイッチが応答しない場合には、セカンダリ スイッチはすべてのトラフィック フローを元どおりに保持します。 プライマリ スイッチがアクティブな場合には、セカンダリ スイッチはその FEX へのインターフェイスをシャットダウンし、すべてのデュアルホーム接続 FEX からのトラフィック フローはプライマリ スイッチに移動されます。 いずれの場合でも、ホストからのイーサネット トラフィックは影響を受けません。 セカンダリ スイッチが FCoE トラフィックを伝送してその FEX へのインターフェイスをシャットダウンする場合、FEX ホスト ポートにバインドされるすべての仮想ファイバ チャネル(vFC)インターフェイスもシャットダウンします。 この場合、ホストでは、マルチパスを使用して SAN トラフィックを残りの vFC インターフェイスに移動する必要があります。
  • vPC ピアキープアライブ リンクの障害 vPC ピアキープアライブ リンクの障害自体は、トラフィック フローに影響しません。

拡張 vPC のライセンス要件

次の表に、この機能のライセンス要件を示します。

製品 ライセンス要件

Cisco NX-OS

この機能にはライセンスは不要です。 ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。 NX-OS ライセンス方式の詳細については、『Cisco NX-OS Licensing Guide』を参照してください。

拡張 vPC の設定

拡張 vPC 設定手順の概要

拡張 vPC 設定は、2 つの標準 vPC 設定(ホストから 2 つのファブリック エクステンダへのデュアルホーム接続とファブリック エクステンダから 2 つのスイッチへのデュアルホーム接続)の組み合わせで構成されています。 ここでは、必要な設定作業について説明しますが、この 2 つの標準設定の詳細な手順については、このマニュアルの「仮想ポート チャネルの設定」に記述されています。

拡張 vPC を設定するには、次のステップを実行します。 特に明記されていない限り、各ステップの手順は仮想ポート チャネルの設定に記載されています。


(注)  


両方のスイッチで設定を繰り返す必要がある手順では、設定の同期(config-sync)機能を使用すると、1 つのスイッチを設定し、その設定が自動的にピア スイッチに同期されるようにすることができます。 設定の同期については、『Cisco Nexus 5000 Series NX-OS Operations Guide』を参照してください。



    ステップ 1   各スイッチで vPC 機能と LACP 機能をイネーブルにします。
    ステップ 2   各スイッチで必要な VLAN を作成します。
    ステップ 3   vPC ドメイン ID を割り当てて、各スイッチで vPC ピアキープアライブ リンクを設定します。
    ステップ 4   各スイッチで vPC ピア リンクを設定します。
    ステップ 5   最初の FEX から各スイッチへのポート チャネルを設定します。
    ステップ 6   2 番めの FEX から各スイッチへのポート チャネルを設定します。
    ステップ 7   拡張 vPC が FCoE トラフィックに対応する必要がある場合、最初の FEX を 1 つのスイッチにアソシエートし、2 番めの FEX をもう一方のスイッチにアソシエートします。

    Cisco Nexus 5000 Series NX-OS Fibre Channel over Ethernet Configuration Guide』の「拡張 vPC での FCoE の設定」を参照してください。

    ステップ 8   各 FEX でホスト ポート チャネルを設定します。

    拡張 vPC の確認

    拡張 vPC 設定の確認

    vPC を使用し始める前に、同じ vPC ドメインの 2 つのピア スイッチでは、両方のスイッチで vPC トポロジの設定に互換性があるかについて確認するため、設定情報がやり取りされます。 設定不一致の場合の影響の重大度によって、一部の設定パラメータはタイプ 1 整合性検査パラメータと見なされ、一部はタイプ 2 と見なされます。

    タイプ 1 パラメータで不一致が見つかると、両方のピア スイッチで vPC ポート上の VLAN が停止されます。 タイプ 2 パラメータで不一致が見つかると、警告の Syslog メッセージが生成されますが、vPC はアップ状態で実行中のままです。


    (注)  


    拡張 vPC では、グレースフル整合性検査はサポートされていません。


    拡張 vPC のグローバル コンフィギュレーション パラメータに対する整合性検査は、デュアルホーム接続 FEX トポロジに対するものと同じであり、デュアルホーム接続 FEX のマニュアルに記載されています。 グローバル整合性検査に加え、拡張 vPC では、ここで説明されている作業によるインターフェイス レベルの検査が必要です。

    次のコマンドを使用して、拡張 vPC の設定と整合性を確認します。

    コマンド 目的

    switch# show feature

    vPC がイネーブルになっているかどうかを表示します。

    switch# show running-config vpc

    vPC の実行コンフィギュレーションの情報を表示します。

    switch# show vpc brief

    vPC に関する簡単な情報を表示します。

    switch(config)# show vpc consistency-parameters global

    すべての vPC インターフェイス全体で一貫している必要がある vPC グローバル パラメータのステータスを表示します。

    switch(config)# show vpc consistency-parameters interface port-channel channel-number

    vPC デバイス全体で一貫している必要がある特定のポート チャネルのステータスを表示します。

    これらのコマンドの出力フィールドの詳細については、『Cisco Nexus 5000 Series Command Reference』を参照してください。

    ポート チャネル番号の整合性の確認

    拡張 vPC の両方のスイッチでは、FEX へのデュアルホーム接続の同じポート チャネル番号を使用する必要があります。 異なるポート チャネル番号を使用すると、両方のスイッチでポート チャネルとそのメンバ ポートが停止されます。

    この手順では、ポート チャネル番号設定の整合性を確認します。

    手順の概要

      1.    show running-config interface type/slot[, type/slot[, ...]]

      2.    show interface type/slot


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1show running-config interface type/slot[, type/slot[, ...]]


      例:
      switch-1# show running-config interface Ethernet110/1/1, Ethernet111/1/1
      
       

      ポート チャネル メンバ ポートの指定されたリストの設定を表示します。

      両方のピア スイッチでこのコマンドを実行し、報告された channel-group 番号を比較して、スイッチ間でそれらの番号が一致していることを確認します。

       
      ステップ 2show interface type/slot


      例:
      switch-1# show interface Ethernet110/1/1
      
       

      指定されたポート チャネル メンバ ポートのステータスと設定を表示します。

      両方のピア スイッチでこのコマンドを実行し、ポートのステータスを確認します。

       

      次の例は、2 つのスイッチ間でポート チャネル番号設定の整合性を確認する方法を示しています。 次の例では、ポート チャネル番号設定が不整合であるため、メンバ ポートは停止されます。

      switch-1# show running-config interface Ethernet110/1/1, Ethernet111/1/1
      
      !Command: show running-config interface Ethernet110/1/1, Ethernet111/1/1
      !Time: Sun Aug 28 03:38:23 2011
      
      version 5.1(3)N1(1)
      
      interface Ethernet110/1/1
      channel-group 102
      
      interface Ethernet111/1/1
      channel-group 102
      
      switch-2# show running-config interface Ethernet110/1/1, Ethernet111/1/1
      
      !Command: show running-config interface Ethernet110/1/1, Ethernet111/1/1
      !Time: Sun Aug 28 03:38:23 2011
      
      version 5.1(3)N1(1)
      
      interface Ethernet110/1/1
      channel-group 101
      
      interface Ethernet111/1/1
      channel-group 101
      
      switch-1# show interface Ethernet110/1/1
      Ethernet110/1/1 is down (suspended by vpc)
        Hardware: 100/1000 Ethernet, address: 7081.0500.2402 (bia 7081.0500.2402)
        MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
        [...]
      
      switch-2# show interface Ethernet110/1/1
      Ethernet110/1/1 is down (suspended by vpc)
        Hardware: 100/1000 Ethernet, address: 7081.0500.2402 (bia 7081.0500.2402)
        MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
        [...]
      
      

      共通のポート チャネル メンバの確認

      2 つのスイッチ間に共通のポート チャネル メンバが少なくとも 1 つあれば、FEX からスイッチ ペアへのポート チャネルはアップし、動作します。 1 つのスイッチでのみポート チャネルが割り当てられている FEX インターフェイスは停止されます。

      手順の概要

        1.    show port-channel summary

        2.    (任意) show interface type/slot


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 show port-channel summary


        例:
        switch-1# show port-channel summary
        
         

        ポート チャネル インターフェイスの概要を表示します。

         
        ステップ 2 show interface type/slot


        例:
        switch-1# show interface ethernet 111/1/3
        
         
        (任意)

        指定されたインターフェイスのステータスと設定を表示します。

         

        次の例は、vPC の共通のメンバ ポートを確認する方法を示しています。 次の例では、vPC は両方のスイッチに共通していない 1 つのチャネル メンバを使用して設定されています。 そのメンバ ポートはシャットダウンとして示され、詳細な検査でメンバが vPC によって停止されていることが示されます。 このセッション部分では、各スイッチでポート チャネルが設定され、最初のスイッチに追加ポートがあります。

        switch-1(config)# interface ethernet 110/1/3, ethernet 111/1/3
        switch-1(config-if)# channel-group 101
        switch-1(config-if)# interface port-channel 101
        switch-1(config-if)# switchport access vlan 20
        
        switch-2(config)# interface ethernet 110/1/3
        switch-2(config-if)# channel-group 101
        switch-2(config-if)# interface port-channel 101
        switch-2(config-if)# switchport access vlan 20
        
        

        このセッション部分では、追加ポートはダウン状態であると示され、ポート詳細の表示にポートが vPC によって停止されていることが示されます。

        switch-1# show port-channel summary 
        Flags:  D - Down        P - Up in port-channel (members)
                I - Individual  H - Hot-standby (LACP only)
                s - Suspended   r - Module-removed
                S - Switched    R - Routed
                U - Up (port-channel)
                M - Not in use. Min-links not met
        --------------------------------------------------------------------------------
        Group Port-       Type     Protocol  Member Ports
              Channel
        --------------------------------------------------------------------------------
        1     Po1(SU)     Eth      LACP      Eth1/1(P)    Eth1/2(P)    
        [...]
        101   Po101(SU)   Eth      NONE      Eth110/1/3(P)  Eth111/1/3(D)  
        
        switch-1# show interface ethernet 111/1/3
        Ethernet111/1/3 is down (suspended by vpc)
          Hardware: 100/1000 Ethernet, address: 7081.0500.2582 (bia 7081.0500.2582)
          MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
          reliability 255/255, txload 1/255, rxload 1/255
        
        

        拡張 vPC のインターフェイス レベルの整合性の確認

        vPC の場合、ポート チャネル インターフェイス設定でポート モードおよび共有 VLAN の整合性をとるようにする必要があります。

        この手順では、設定が vPC インターフェイスで一貫していることを確認します。

        手順の概要

          1.    show vpc consistency-parameters port-channel channel-number


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 show vpc consistency-parameters port-channel channel-number


          例:
          switch# show vpc consistency-parameters interface port-channel 101
          switch(config)#
          
           

          指定したポート チャネルの場合、vPC デバイス全体で一貫している必要があるステータス情報を表示します。

           

          次の例は、vPC の 2 つのピア間でのインターフェイス設定も比較を表示する方法を示しています。 この場合、VLAN 10 が両方のピアで許可されていますが、ポート モードが一致しないため、VLAN は停止されます。

          NX-5000-1# show vpc consistency-parameters interface port-channel 101
          
              Legend:
                  Type 1 : vPC will be suspended in case of mismatch
          
          Name                        Type  Local Value            Peer Value             
          -------------               ----  ---------------------- -----------------------
          mode                        1     on                     on                    
          Speed                       1     1000 Mb/s              1000 Mb/s             
          Duplex                      1     full                   full                  
          Port Mode                   1     access                 trunk                 
          MTU                         1     1500                   1500                  
          Admin port mode             1                                                  
          Shut Lan                    1     No                     No                    
          vPC+ Switch-id              1     3000                   3000                  
          Allowed VLANs               -     10                     1-57,61-3967,4048-4093
          Local suspended VLANs       -     10                     -                     
          
          

          拡張 vPC の設定例

          次の例は、この章の拡張 vPC 図のトポロジを使用した完全な設定手順を示しています。 トポロジ図では、各ポート チャネル リンクの横にある番号ペアは、インターフェイス ポート番号を表します。 たとえば、番号「3、4」というラベルが付いたスイッチ リンクは、スイッチ上のインターフェイス eth1/3 および eth1/4 を表します。


          (注)  


          両方のスイッチで設定を繰り返す必要がある手順では、設定の同期(config-sync)機能を使用すると、1 つのスイッチを設定し、その設定が自動的にピア スイッチに同期されるようにすることができます。 設定の同期については、『Cisco Nexus 5000 Series NX-OS Operations Guide』を参照してください。


          はじめる前に

          Cisco Nexus 2000 シリーズ ファブリック エクステンダ FEX101 および FEX102 が接続され、オンラインであることを確認してください。

          手順の概要

            1.    各スイッチで vPC 機能と LACP 機能をイネーブルにします。

            2.    各スイッチで必要な VLAN を作成します。

            3.    vPC ドメイン ID を割り当てて、各スイッチで vPC ピアキープアライブ リンクを設定します。

            4.    各スイッチで vPC ピア リンクを設定します。

            5.    最初の FEX から各スイッチへのポート チャネルを設定します。

            6.    2 番めの FEX から各スイッチへのポート チャネルを設定します。

            7.    各 FEX でホスト ポート チャネルを設定します。


          手順の詳細
            ステップ 1   各スイッチで vPC 機能と LACP 機能をイネーブルにします。

            例:
            NX-5000-1(config)# feature vpc
            NX-5000-1(config)# feature lacp
            
            NX-5000-2(config)# feature vpc
            NX-5000-2(config)# feature lacp
            
            
            ステップ 2   各スイッチで必要な VLAN を作成します。

            例:
            NX-5000-1(config)# vlan 10-20
            
            NX-5000-2(config)# vlan 10-20
            
            
            ステップ 3   vPC ドメイン ID を割り当てて、各スイッチで vPC ピアキープアライブ リンクを設定します。

            例:
            NX-5000-1(config)# vpc domain 123
            NX-5000-1(config-vpc)# peer-keepalive destination 172.25.182.100
            
            NX-5000-2(config)# vpc domain 123
            NX-5000-2(config-vpc)# peer-keepalive destination 172.25.182.99
            
            
            (注)     

            各スイッチを設定する際に、ピア スイッチの IP アドレスをピアキープアライブの宛先として使用します。

            ステップ 4   各スイッチで vPC ピア リンクを設定します。

            例:
            NX-5000-1(config)# interface eth1/1-2
            NX-5000-1(config-if)# channel-group 1 mode active
            NX-5000-1(config-if)# interface Po1
            NX-5000-1(config-if)# switchport mode trunk
            NX-5000-1(config-if)# switchport trunk allowed vlan 1, 10-20
            NX-5000-1(config-if)# vpc peer-link
            
            NX-5000-2(config)# interface eth1/1-2
            NX-5000-2(config-if)# channel-group 1 mode active
            NX-5000-2(config-if)# interface Po1
            NX-5000-2(config-if)# switchport mode trunk
            NX-5000-2(config-if)# switchport trunk allowed vlan 1, 10-20
            NX-5000-2(config-if)# vpc peer-link
            
            
            ステップ 5   最初の FEX から各スイッチへのポート チャネルを設定します。

            例:
            NX-5000-1(config)# fex 101
            NX-5000-1(config-fex)# interface eth1/3-4
            NX-5000-1(config-if)# channel-group 101
            NX-5000-1(config-if)# interface po101
            NX-5000-1(config-if)# switchport mode fex-fabric
            NX-5000-1(config-if)# vpc 101
            NX-5000-1(config-if)# fex associate 101
            
            NX-5000-2(config)# fex 101
            NX-5000-2(config-fex)# interface eth1/3-4
            NX-5000-2(config-if)# channel-group 101
            NX-5000-2(config-if)# interface po101
            NX-5000-2(config-if)# switchport mode fex-fabric
            NX-5000-2(config-if)# vpc 101
            NX-5000-2(config-if)# fex associate 101
            
            
            ステップ 6   2 番めの FEX から各スイッチへのポート チャネルを設定します。

            例:
            NX-5000-1(config)# fex 102
            NX-5000-1(config-fex)# interface eth1/5-6
            NX-5000-1(config-if)# channel-group 102
            NX-5000-1(config-if)# interface po102
            NX-5000-1(config-if)# switchport mode fex-fabric
            NX-5000-1(config-if)# vpc 102
            NX-5000-1(config-if)# fex associate 102
            
            NX-5000-2(config)# fex 102
            NX-5000-2(config-fex)# interface eth1/5-6
            NX-5000-2(config-if)# channel-group 102
            NX-5000-2(config-if)# interface po102
            NX-5000-2(config-if)# switchport mode fex-fabric
            NX-5000-2(config-if)# vpc 102
            NX-5000-2(config-if)# fex associate 102
            
            
            ステップ 7   各 FEX でホスト ポート チャネルを設定します。

            例:
            NX-5000-1(config)# interface eth101/1/1, eth101/1/2
            NX-5000-1(config-if)# channel-group 2 mode active
            NX-5000-1(config-if)# interface eth102/1/1, eth102/1/2
            NX-5000-1(config-if)# channel-group 2 mode active
            NX-5000-1(config-if)# int po2
            NX-5000-1(config-if)# switchport access vlan 10
            
            NX-5000-2(config)# interface eth101/1/1, eth101/1/2
            NX-5000-2(config-if)# channel-group 2 mode active
            NX-5000-2(config-if)# interface eth102/1/1, eth102/1/2
            NX-5000-2(config-if)# channel-group 2 mode active
            NX-5000-2(config-if)# int po2
            NX-5000-2(config-if)# switchport access vlan 10