Cisco Nexus 5000 シリーズ NX-OS レイヤ 2 スイッチング コンフィギュレーション ガイド リリース 5.2(1)N1(2)
VM-FEX の設定
VM-FEX の設定
発行日;2013/01/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

VM-FEX の設定

この章の内容は、次のとおりです。

VM-FEX について

VM-FEX の概要

(先行標準)IEEE 802.1Qbh ポート エクステンダ テクノロジーに基づいて、Cisco Virtual Machine Fabric Extender(VM-FEX)はファブリックをスイッチ シャーシから仮想マシン(VM)にまで拡張します。 各 VM はネットワーク アダプタ vNIC に関連付けられ、次に親スイッチの仮想イーサネット(vEthernet または vEth)ポートに関連付けられます。 この専用仮想インターフェイスは、物理インターフェイスと同じ方法で管理、監視、およびスパニングすることができます。 ハイパーバイザーのローカル スイッチングは排除され、すべてのスイッチングは物理スイッチによって実行されます。

VM-FEX のコンポーネント

サーバ

VM-FEX は、ハイパーバイザとして VMware 仮想化環境 Cisco UCS C シリーズ ラックマウント サーバによってサポートされます。

サーバの設定は、Cisco Integrated Management Controller(CIMC)を使用して実行され、GUI と CLI インターフェイスの両方が提供されます。 ハイパーバイザおよび仮想化サービスの設定は、VMware vSphere クライアントを使用して実行されます。

CIMC および VM-FEX 設定の詳細については、次のマニュアルを参照してください。

  • 『Cisco UCS C-Series Servers Integrated Management Controller GUI Configuration Guide』
  • 『Cisco UCS Manager VM-FEX for VMware GUI Configuration Guide』

仮想インターフェイス カード アダプタ

VM-FEX は、仮想化されたスタティック インターフェイスまたはダイナミック インターフェイスをサポートするデュアルポート 10 ギガビット イーサネット PCle アダプタである、Cisco UCS P81E 仮想インターフェイス カード (VIC) によりサポートされています。これには、128 までの仮想ネットワーク インターフェイス カード(vNIC)が含まれます。

VIC とその vNIC の設定は、Cisco UCS C シリーズ サーバの CIMC インターフェイスを使用して実行されます。

FEX

サーバの物理ポートは、スイッチに、またはスイッチに接続されているファブリック エクステンダ(FEX)に直接接続することができます。 VM-FEX は、Cisco Nexus 2000 シリーズ ファブリック エクステンダによってサポートされます。

スイッチ

VM-FEX は、Cisco NX-OS Release 5.1(3)N1(1) 以降のリリースを稼働している Cisco Nexus 5500 プラットフォーム によってサポートされます。 単一スイッチ シャーシは、VM-FEX に接続することができますが、一般的なアプリケーションでは、仮想ポート チャネル(vPC)ドメインとして展開されるスイッチのペアが使用されます。

スイッチでは、vEthernet インターフェイスは vNIC を表します。 ネットワーク管理者が実行するすべての操作は、vEthernet インターフェイスで実行されます。

VM-FEX の用語

VM-FEX のコンポーネントおよびインターフェイスの説明では、次の用語が使用されます。

仮想イーサネット インターフェイス

仮想イーサネット インターフェイス(vEthernet または vEth)は、仮想マシンの vNIC に接続されるスイッチ ポートを表します。 従来のスイッチ インターフェイスとは異なり、vEth インターフェイスの名前は、ポートが関連付けられているモジュールを表しません。 従来のスイッチ ポートが GigX/Y として指定されている場合、X はモジュール番号で、Y はモジュールのポート番号です。vEth インターフェイスは vEthY として指定されます。 この表記法を使用すると、VM が別の物理サーバに移行する際にインターフェイスを同じ名前のままにすることができます。

ダイナミック インターフェイス

ダイナミック インターフェイスとは、アダプタとスイッチの通信結果により自動的に設定される vEthernet インターフェイスです。 ダイナミック インターフェイスのプロビジョニング モデルは、vEthernet ポート プロファイルのスイッチの設定で構成されており、ポート グループとしてネットワーク アダプタに伝播され、その後、ポート グループが vNIC に関連付けられます。 ポート プロファイルは、ネットワーク管理者によってスイッチに作成される一方、vNIC との関連付けがサーバ管理者によってアダプタで実行されます。

スタティック インターフェイス

スタティック インターフェイスは、スイッチとアダプタに手動で設定されます。 スタティック仮想アダプタは、vNIC または仮想ホスト バス アダプタ(vHBA)にすることができます。 スティック インターフェイスは、vEthernet、またはスタティック vEthernet インターフェイスにバインドされている仮想ファイバ チャネル(vFC)インターフェイスにすることができます。

スタティック vEthernet を作成する 1 つの方法では、ネットワーク管理者はチャネル番号(VN-Tag または先行標準の IEEE 802.1BR タグ番号)を vEthernet に割り当てます。 サーバ管理者は、アダプタの vNIC を必ず同じチャネル番号で定義します。

別の方法では、ネットワーク管理者は、仮想スイッチング インターフェイス(VSI)MAC アドレスと DVPort ID を使用して vEthernet を設定することで、スタティック浮動 vEthernet を作成できます。

浮動 vEthernet インターフェイス

ハイパーバイザ環境では、ネットワーク アダプタの各 vNIC は 1 つの仮想マシン(VM)に関連付けられます。 VM は、物理サーバ間の移行が可能です。 VM および仮想ネットワーク リンクとともに移行する仮想インターフェイスは、浮動 vEthernet インターフェイスと呼ばれます。

固定 vEthernet インターフェイス

固定 vEthernet インターフェイスとは、物理インターフェイス間の移行をサポートしない仮想インターフェイスです。 固定 vEthernet(スタティックまたはダイナミック)の場合、管理者はいつでも設定を変更できます。 vEthernet インターフェイス番号とチャネル番号のバインディングは、管理者がそれを変更しない限り変化しません。

VM-FEX のライセンス要件

次の表に、この機能のライセンス要件を示します。

製品 ライセンス要件

Cisco NX-OS

各 Nexus 5500 シリーズ スイッチ シャーシに VM-FEX ライセンスが必要です。 ライセンス パッケージ名は  VMFEX_ FEATURE_PKG であり、PID は N55-VMFEXK9 です。 ライセンスされた機能を初めて設定すると、120 日間の猶予期間が始まります。

Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、『Cisco NX-OS Licensing Guide』を参照してください。

VM-FEX のデフォルト設定

次の表に、VM-FEX に関連するパラメータのデフォルト設定を示します。

パラメータ

デフォルト

仮想化機能セット

ディセーブル

FEX

ディセーブル

VM-FEX

ディセーブル

LLDP

イネーブル

vPC

ディセーブル

svs vethernet auto-setup

イネーブル

FCoE

ディセーブル

VM-FEX の設定

VM-FEX 設定手順の概要

次の手順では、スイッチと VM をホストしているサーバ間で VM-FEX を設定するために必要な一連の手順について簡単に説明します。 スイッチで実行する手順については、このマニュアルに記載されています。 サーバまたは VMware vCenter で実行する手順については、サーバおよび vCenter のマニュアルを参照してください。


    ステップ 1   サーバ:VIC アダプタで vNIC を作成します。
    1. ホストからアップリンクとして使用する 2 つのスタティック vNIC を作成します。
    2. 最大 112 個の VM-FEX インターフェイスを作成します。
    3. サーバをリブートします。
    ステップ 2   スイッチ: VM-FEX および他の必須サービスをイネーブルにします。

    VM-FEX に必要な機能のイネーブル化を参照してください。

    ステップ 3   スイッチ:2 つのスタティック vEthernet インターフェイスを設定し、それらを物理ポートおよびチャネルにバインドします。

    固定スタティック インターフェイスの設定を参照してください。

    ステップ 4   スイッチ:VM に関連付けるポート プロファイルを定義します。

    ダイナミック インターフェイスのポート プロファイルの設定を参照してください。

    ステップ 5   スイッチ:2 つのスタティック vEthernet インターフェイスがアクティブで、スイッチの vEthernet インターフェイスに関連付けられていることを確認します。

    仮想インターフェイスのステータスの確認を参照してください。

    ステップ 6   スイッチおよび vCenter:XML 証明書をスイッチから vCenter にインストールします。
    1. スイッチ:設定モードで feature http コマンドを使用して HTTP をイネーブルにします。
    2. Web ブラウザから、スイッチの IP アドレスにアクセスして表示された XML 証明書をダウンロードします。
    3. スイッチ:設定モードで no feature http コマンドを使用して HTTP をディセーブルにします。
    4. vCenter:XML 証明書プラグインをインストールします。
    ステップ 7   スイッチ:vPC をイネーブルにし、vPC システムを分散仮想スイッチ(DVS)として vCenter に登録します。

    vCenter Server への SVS 接続の設定を参照してください。

    ステップ 8   vCenter:vCenter でデータセンターを作成します。
    ステップ 9   スイッチ:vCenter への SVS 接続をアクティブにして確認します。

    vCenter Server への SVS 接続のアクティブ化およびvCenter Server への接続の確認を参照してください。

    ステップ 10   vCenter:ポート プロファイル(ポート グループ)が vCenter に伝播されていることを確認します。
    ステップ 11   サーバ:リソースを DVS に追加します。
    1. ESX ホストを DVS に追加します。
    2. スタティック vNIC をアップリンクとして DVS に追加します。
    3. VM を、スイッチによって定義されているポート グループに関連付けます。
    4. VM をアクティブにします。
    ステップ 12   スイッチ:ダイナミック vNIC がアクティブであり、スイッチの vEthernet インターフェイスに接続されていることを確認します。

    仮想インターフェイスのステータスの確認を参照してください。

    ステップ 13   サーバ:インターフェイスがアクティブであり、VM に割り当てられていることを確認します。
    ステップ 14   vCenter:ダイナミック vNICs がアクティブであることを確認します。

    VM-FEX に必要な機能のイネーブル化

    手順の概要

      1.    configure terminal

      2.    install feature-set virtualization

      3.    feature-set virtualization

      4.    feature fex

      5.    feature vmfex

      6.    feature vpc

      7.    (任意) vethernet auto-create

      8.    (任意) feature fcoe

      9.    (任意) end

      10.    (任意) copy running-config startup-config

      11.    (任意) reload


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 configure terminal


      例:
      switch# configure terminal
      switch(config)#
       

      コンフィギュレーション モードに入ります。

       
      ステップ 2 install feature-set virtualization


      例:
      switch(config)# install feature-set virtualization
      
       

      仮想化機能セットをスイッチにインストールします。

       
      ステップ 3 feature-set virtualization


      例:
      switch(config)# feature-set virtualization
      
       

      スイッチで仮想化機能セットをイネーブルにします。 この機能セットにより、スタティック vEthernet インターフェイスが使用できるようなります。

       
      ステップ 4 feature fex


      例:
      switch(config)# feature fex
      
       

      スイッチで FEX 機能をイネーブルにします。

       
      ステップ 5 feature vmfex


      例:
      switch(config)# feature vmfex
      
       

      スイッチで VM-FEX 機能をイネーブルにします。 この機能セットにより、ダイナミック vEthernet インターフェイスが使用できるようになります。

       
      ステップ 6 feature vpc


      例:
      switch(config)# feature vpc
      
       

      スイッチで仮想ポート チャネル(vPC)をイネーブルにします。

       
      ステップ 7 vethernet auto-create


      例:
      switch(config)# vethernet auto-create
      
       
      (任意)

      仮想イーサネット インターフェイスの自動作成をグローバルにイネーブルにします。 固定 vEthernet インターフェイスが静的に設定されている場合、この機能は不要です。

       
      ステップ 8 feature fcoe


      例:
      switch(config)# feature fcoe
      
       
      (任意)

      スイッチで Fibre Channel over Ethernet(FCoE)をイネーブルにします。

       
      ステップ 9 end


      例:
      switch(config-mvr)# end
      switch#
       
      (任意)

      特権 EXEC モードに戻ります。

       
      ステップ 10 copy running-config startup-config


      例:
      switch# copy running-config startup-config
       
      (任意)

      実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

       
      ステップ 11 reload


      例:
      switch# reload
       
      (任意)

      スイッチをリロードします。

       

      次に、VM-FEX に必要な機能をイネーブルにする例を示します。

      switch# configure terminal
      switch(config)# install feature-set virtualization
      switch(config)# feature-set virtualization
      switch(config)# feature fex
      switch(config)# feature vmfex
      switch(config)# feature vpc
      switch(config)# vethernet auto-create
      switch(config)# feature fcoe
      switch(config)# end
      switch# copy running-config startup-config
      switch# reload
      
      

      固定スタティック インターフェイスの設定

      次の手順では、2 つの物理インターフェイスを設定し、2 つの仮想インターフェイスを物理インターフェイスにバインドして、固定スタティック vEthernet インターフェイスを作成します。 固定スタティック インターフェイスの設定に関する詳細については、『Cisco Nexus 5000 NX-OS Adapter-FEX Configuration Guide』を参照してください。

      冗長スイッチを使用して、プライマリとセカンダリの両方のスイッチでこの手順を同じ設定で実行します。

      はじめる前に
      • VM-FEX および他の必須サービスをスイッチでイネーブルにする必要があります。
      • ホスト サーバにインストールされている VIC アダプタで 2 つのスタティック vNIC を設定する必要があります。
      手順の概要

        1.    configure terminal

        2.    interface ethernet slot/port

        3.    shutdown

        4.    switchport mode vntag

        5.    interface ethernet slot/port

        6.    shutdown

        7.    switchport mode vntag

        8.    interface vethernet interface-number

        9.    bind interface ethernet slot/port channel channel-number

        10.    no shutdown

        11.    interface vethernet interface-number

        12.    bind interface ethernet slot/port channel channel-number

        13.    no shutdown

        14.    interface vethernet interface-number

        15.    bind interface ethernet slot/port channel channel-number

        16.    no shutdown

        17.    interface vethernet interface-number

        18.    bind interface ethernet slot/port channel channel-number

        19.    no shutdown

        20.    interface ethernet slot/port

        21.    no shutdown

        22.    interface ethernet slot/port

        23.    no shutdown

        24.    冗長スイッチを使用して、セカンダリ スイッチでこの手順を同じ設定で繰り返します。


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 configure terminal


        例:
        switch# configure terminal
        switch(config)#
         

        コンフィギュレーション モードに入ります。

         
        ステップ 2interface ethernet slot/port


        例:
        switch(config)# interface ethernet1/17
        switch(config-if)#
         

        最初のイーサネット ポートの設定モードを開始します。

         
        ステップ 3shutdown


        例:
        switch(config-if)# shutdown
         

        インターフェイスでローカル トラフィックをディセーブルにします。

        (注)     

        VN-Tag モードをイネーブルにする前にインターフェイスをシャットダウンすると、固定 vEthernet インターフェイスのダイナミック作成は行われません。

         
        ステップ 4switchport mode vntag


        例:
        switch(config-if)# switchport mode vntag
         

        インターフェイスでポート エクステンダのサポートをイネーブルにします。

         
        ステップ 5interface ethernet slot/port


        例:
        switch(config)# interface ethernet1/18
        switch(config-if)#
         

        2 番目のイーサネット ポートの設定モードを開始します。

         
        ステップ 6shutdown


        例:
        switch(config-if)# shutdown
         

        インターフェイスでローカル トラフィックをディセーブルにします。

         
        ステップ 7switchport mode vntag


        例:
        switch(config-if)# switchport mode vntag
         

        インターフェイスでポート エクステンダのサポートをイネーブルにします。

         
        ステップ 8interface vethernet interface-number


        例:
        switch(config-if)# interface vethernet 1
        switch(config-if)#
         

        最初のイーサネット ポートの 1 番目の仮想インターフェイスの設定モードを開始します。

         
        ステップ 9bind interface ethernet slot/port channel channel-number


        例:
        switch(config-if)# bind interface ethernet 1/17 channel 10
         

        仮想インターフェイスを物理インターフェイスと指定されたポート チャネルにバインドします。

        (注)     

        仮想インターフェイスのポート チャネル数は、vNIC で設定されているポート チャネル数と一致している必要があります。

         
        ステップ 10no shutdown


        例:
        switch(config-if)# no shutdown
         

        インターフェイスでローカル トラフィックをイネーブルにします。

         
        ステップ 11interface vethernet interface-number


        例:
        switch(config-if)# interface vethernet 3
        switch(config-if)#
         

        最初のイーサネット ポートの 2 番目の仮想インターフェイスの設定モードを開始します。

         
        ステップ 12bind interface ethernet slot/port channel channel-number


        例:
        switch(config-if)# bind interface ethernet 1/17 channel 11
         

        仮想インターフェイスを物理インターフェイスと指定されたポート チャネルにバインドします。

         
        ステップ 13no shutdown


        例:
        switch(config-if)# no shutdown
         

        インターフェイスでローカル トラフィックをイネーブルにします。

         
        ステップ 14interface vethernet interface-number


        例:
        switch(config-if)# interface vethernet 2
        switch(config-if)#
         

        2 番目のイーサネット ポートの 1 番目の仮想インターフェイスの設定モードを開始します。

         
        ステップ 15bind interface ethernet slot/port channel channel-number


        例:
        switch(config-if)# bind interface ethernet 1/18 channel 10
         

        仮想インターフェイスを物理インターフェイスと指定されたポート チャネルにバインドします。

         
        ステップ 16no shutdown


        例:
        switch(config-if)# no shutdown
         

        インターフェイスでローカル トラフィックをイネーブルにします。

         
        ステップ 17interface vethernet interface-number


        例:
        switch(config-if)# interface vethernet 4
        switch(config-if)#
         

        2 番目のイーサネット ポートの 2 番目の仮想インターフェイスの設定モードを開始します。

         
        ステップ 18bind interface ethernet slot/port channel channel-number


        例:
        switch(config-if)# bind interface ethernet 1/18 channel 11
         

        仮想インターフェイスを物理インターフェイスと指定されたポート チャネルにバインドします。

         
        ステップ 19no shutdown


        例:
        switch(config-if)# no shutdown
         

        インターフェイスでローカル トラフィックをイネーブルにします。

         
        ステップ 20interface ethernet slot/port


        例:
        switch(config)# interface ethernet1/17
        switch(config-if)#
         

        最初のイーサネット ポートの設定モードを開始します。

         
        ステップ 21no shutdown


        例:
        switch(config-if)# no shutdown
         

        インターフェイスでローカル トラフィックをイネーブルにします。

         
        ステップ 22interface ethernet slot/port


        例:
        switch(config)# interface ethernet1/18
        switch(config-if)#
         

        2 番目のイーサネット ポートの設定モードを開始します。

         
        ステップ 23no shutdown


        例:
        switch(config-if)# no shutdown
         

        インターフェイスでローカル トラフィックをイネーブルにします。

         
        ステップ 24冗長スイッチを使用して、セカンダリ スイッチでこの手順を同じ設定で繰り返します。   

        次に、2 つの物理インターフェイスを設定し、2 つの仮想インターフェイスを各物理インターフェイスにバインドして、インターフェイスをイネーブルにする例を示します。

        switch-1# configure terminal
        switch-1(config)# interface ethernet 1/17
        switch-1(config-if)# shutdown
        switch-1(config-if)# switchport mode vntag
        switch-1(config-if)# interface ethernet 1/18
        switch-1(config-if)# shutdown
        switch-1(config-if)# switchport mode vntag
        
        switch-1(config-if)# interface vethernet 1
        switch-1(config-if)# bind interface ethernet 1/17 channel 10
        switch-1(config-if)# no shutdown
        switch-1(config-if)# interface vethernet 3
        switch-1(config-if)# bind interface ethernet 1/17 channel 11
        switch-1(config-if)# no shutdown
        
        switch-1(config-if)# interface vethernet 2
        switch-1(config-if)# bind interface ethernet 1/18 channel 10
        switch-1(config-if)# no shutdown
        switch-1(config-if)# interface vethernet 4
        switch-1(config-if)# bind interface ethernet 1/18 channel 11
        switch-1(config-if)# no shutdown
        
        switch-1(config-if)# interface ethernet 1/17
        switch-1(config-if)# no shutdown
        switch-1(config-if)# interface ethernet 1/18
        switch-1(config-if)# no shutdown
        
        switch-1(config-if)#
        
        次の作業

        ホスト サーバでスタティック サーバとスタティック vNIC 間の接続ステータスを確認します。

        ダイナミック インターフェイスのポート プロファイルの設定

        次の手順では、ダイナミック仮想インターフェイスのポート プロファイルを設定します。 このポート プロファイルは、ポート グループとして VMware vCenter 分散仮想スイッチ(DVS)にエクスポートされます。

        冗長スイッチを使用して、プライマリとセカンダリの両方のスイッチでこの手順を同じ設定で実行します。

        はじめる前に
        • ホスト サーバにインストールされている VIC アダプタでダイナミック vNIC を設定する必要があります。
        • ポート プロファイルで指定されている VLAN を作成する必要があります。
        手順の概要

          1.    configure terminal

          2.    port-profile type vethernet profilename

          3.    (任意) switchport mode access

          4.    (任意) switchport access vlan vlan-id

          5.    dvs-name {all | name}

          6.    (任意) port-binding dynamic

          7.    state enabled


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 configure terminal


          例:
          switch# configure terminal
          switch(config)#
           

          コンフィギュレーション モードに入ります。

           
          ステップ 2port-profile type vethernet profilename


          例:
          switch(config)# port-profile type vethernet vm-fex-vlan-60
          switch(config-port-prof)#
           

          指定されたポート プロファイルの設定モードを開始し、必要に応じてそのプロファイルを作成します。

           
          ステップ 3switchport mode access


          例:
          switch(config-port-prof)# switchport mode access
           
          (任意)

          アクセス モードになるようにインターフェイスを設定します。

           
          ステップ 4switchport access vlan vlan-id


          例:
          switch(config-port-prof)# switchport access vlan 60
           
          (任意)

          インターフェイスがアクセス モードのときに VLAN を設定します。

           
          ステップ 5dvs-name {all | name}


          例:
          switch(config-port-prof)# dvs-name all
           

          ポート プロファイルがポート グループとしてエクスポートされる vCenter DVS を指定します。 キーワード all を使用すると、ポート プロファイルが vCenter のすべての DVS にエクスポートされます。

           
          ステップ 6port-binding dynamic


          例:
          switch(config-port-prof)# port-binding dynamic
           
          (任意)

          ダイナミック ポート バインディングを指定します。 ポートは、VM の電源がオンになると接続され、オフになると接続解除されます。 max-port 制限値が適用されます。 デフォルトは、スタティック ポート バインディングです。

           
          ステップ 7state enabled


          例:
          switch(config-port-prof)# state enabled
           

          ポート プロファイルをイネーブルにします。

           

          次に、ダイナミック仮想インターフェイスのポート プロファイルを設定する例を示します。

          switch-1# configure terminal
          switch-1(config)# port-profile type vethernet vm-fex-vlan-60
          switch-1(config-port-prof)# switchport mode access
          switch-1(config-port-prof)# switchport access vlan 60
          switch-1(config-port-prof)# dvs-name all
          switch-1(config-port-prof)# port-binding dynamic
          switch-1(config-port-prof)# state enabled
          switch-1(config-port-prof)# end
          switch-1# 
          
          

          vCenter Server への SVS 接続の設定

          この手順では、スイッチから vCenter Server への安全な接続を設定します。

          冗長スイッチを使用して、プライマリとセカンダリの両方のスイッチでこの手順を実行します。 通常の操作では、プライマリ スイッチのみが vCenter に接続され、プライマリに障害が発生した場合に限り、セカンダリ スイッチが接続されます。

          手順の概要

            1.    configure terminal

            2.    svs connection svs-name

            3.    protocol vmware-vim

            4.    vmware dvs datacenter-name dc-name

            5.    dvs-name dvs-name

            6.    次のいずれかを選択します。

            • remote ip address ipv4-addr [port port-num] [vrf {vrf-name | default | management}]
            • remote hostname host-name [port port-num] [vrf {vrf-name | default | management}]

            7.    install certificate {bootflash:[//server/] | default}

            8.    extension-key: extn-ID


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 configure terminal


            例:
            switch# configure terminal
            switch(config)#
             

            コンフィギュレーション モードに入ります。

             
            ステップ 2 svs connection svs-name


            例:
            switch(config)# svs connection vCenter
            switch(config-svs-conn)#
             

            スイッチから vCenter Server への SVS 接続の設定モードをイネーブルにして開始します。

             
            ステップ 3 protocol vmware-vim


            例:
            switch(config-svs-conn)# protocol vmware-vim
             

            VMware インフラストラクチャ ソフトウェア開発キット(VI SDK)をイネーブルにし、クライアントと vCenter の通信を可能にします。

             
            ステップ 4 vmware dvs datacenter-name dc-name


            例:
            switch(config-svs-conn)# vmware dvs datacenter-name DC1
             

            指定されたデータセンターで VMware 分散仮想スイッチ(DVS)を作成します。

             
            ステップ 5 dvs-name dvs-name


            例:
            switch(config-svs-conn)# dvs-name Pod1
             

            vCenter Server で DVS の名前を設定します。

             
            ステップ 6次のいずれかを選択します。
            • remote ip address ipv4-addr [port port-num] [vrf {vrf-name | default | management}]
            • remote hostname host-name [port port-num] [vrf {vrf-name | default | management}]


            例:
            switch(config-svs-conn)# remote ip address 192.0.20.125 port 80 vrf management
             

            vCenter Server のホスト名または IP アドレスを指定します。 任意でポート番号と VRF を指定します。

             
            ステップ 7 install certificate {bootflash:[//server/] | default}


            例:
            switch(config-svs-conn)# install certificate default
             

            vCenter Server への接続に使用される証明書をインストールします。

            server 引数には、その証明書をインストールするブート フラッシュ メモリの場所を指定します。 引数の値には、module-1sup-1sup-active、または sup-local を指定できます。

             
            ステップ 8 extension-key: extn-ID


            例:
            switch(config-svs-conn)# extension-key: Cisco_Nexus_5500_1543569268
             

            vCenter Server への接続に使用される拡張キーを設定します。

            (注)     

            冗長スイッチを使用して、プライマリ スイッチでのみこの手順を実行します。 このキーは、自動的にセカンダリ スイッチと同期されます。

             

            次に、プライマリ スイッチとセカンダリ スイッチで SVS 接続を設定する例を示します。

            switch-1# configure terminal
            switch-1(config)# svs connection 2VC
            switch-1(config-svs-conn)# protocol vmware-vim
            switch-1(config-svs-conn)# vmware dvs datacenter-name DC1
            switch-1(config-svs-conn)# dvs-name Pod1
            switch-1(config-svs-conn)# remote ip address 192.0.20.125 port 80 vrf management
            switch-1(config-svs-conn)# install certificate default
            switch-1(config-svs-conn)# extension-key: Cisco_Nexus_5500_1543569268 
            switch-1(config-svs-conn)#
            
            switch-2# configure terminal
            switch-2(config)# svs connection 2VC
            switch-2(config-svs-conn)# protocol vmware-vim
            switch-2(config-svs-conn)# vmware dvs datacenter-name DC1
            switch-2(config-svs-conn)# dvs-name Pod1
            switch-2(config-svs-conn)# remote ip address 192.0.20.125 port 80 vrf management
            switch-2(config-svs-conn)# install certificate default
            switch-2(config-svs-conn)#
            
            
            次の作業

            プライマリ スイッチでのみ SVS 接続をアクティブにします。

            vCenter Server への SVS 接続のアクティブ化

            スイッチでこの手順を実行し、vCenter Server への接続をアクティブにします。

            はじめる前に
            • vCenter Server が実行され、到達可能であることが必要です。
            • 拡張ファイルが vCenter Server に登録済みであることが必要です。
            • スイッチで SVS 接続を設定する必要があります。
            手順の概要

              1.    configure terminal

              2.    svs connection svs-name

              3.    [no] connect


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 configure terminal


              例:
              switch# configure terminal
              switch(config)#
               

              コンフィギュレーション モードに入ります。

               
              ステップ 2 svs connection svs-name


              例:
              switch(config)# svs connection vCenter
              switch(config-svs-conn)#
               

              スイッチから vCenter Server への SVS 接続の設定モードをイネーブルにして開始します。

               
              ステップ 3 [no] connect


              例:
              switch(config-svs-conn)# connect
               

              vCenter Server との接続を開始します。

              (注)     

              冗長スイッチを使用して、プライマリとセカンダリの両方のスイッチでこの手順を実行します。 プライマリのみが接続されます。

              スイッチが vCenter に接続され、DVS になります。

               

              次に、vCenter Server に接続する例を示します。

              switch-1# configure terminal
              switch-1(config)# svs connection 2VC
              switch-1(config-svs-conn)# connect
              Note: Command execution in progress..please wait
              switch-1(config-svs-conn)#
              
              

              VM-FEX 設定の確認

              仮想インターフェイスのステータスの確認

              仮想インターフェイスのステータス情報を表示するには、次の作業のいずれかを行います。

              コマンド 目的
              show interface vethernet interface-number [detail]

              仮想インターフェイスのステータスを表示します。 各スタティック仮想インターフェイスでこの手順を実行し、各インターフェイスがアクティブであり、物理インターフェイスにバインドされていることを確認します。

              show interface virtual status vm-fex

              すべての浮動仮想インターフェイスに関する情報を表示します。

              show interface virtual summary vm-fex

              仮想イーサネット インターフェイスに関するサマリー情報を表示します。

              show interface virtual status bound interface ethernet port/slot

              バインドされたイーサネット インターフェイスの仮想インターフェイスに関する情報を表示します。

              show interface virtual summary bound interface ethernet port/slot

              バインドされたイーサネット インターフェイスの仮想インターフェイスに関するサマリー情報を表示します。

              次に、スタティック インターフェイスに関するステータスおよび設定情報を表示する例を示します。

              switch-1# show interface vethernet 1
              
              Vethernet1 is up
              Bound Interface is Ethernet1/17
              Hardware is Virtual, address is 0005.73fc.24a0
              Port mode is access
              Speed is auto-speed
              Duplex mode is auto
              300 seconds input rate 0 bits/sec, 0 packets/sec
              300 seconds output rate 0 bits/sec, 0 packets/sec
              Rx
              0 unicast packets  0 multicast packets  0 broadcast packets
              0 input packets  0 bytes
              0 input packet drops 
              Tx
              0 unicast packets  0 multicast packets  0 broadcast packets
              0 output packets  0 bytes
              0 flood packets
              0 output packet drops
              
              switch-1# show interface vethernet 1 detail
              
              vif_index: 20
              --------------------------
                veth is bound to interface Ethernet1/17 (0x1a010000)
                priority: 0
                vntag: 16
                status: active
                channel id: 10
                registered mac info:
                    vlan 0 - mac 00:00:00:00:00:00
                    vlan 0 - mac 58:8d:09:0f:0b:3c
                    vlan 0 - mac ff:ff:ff:ff:ff:ff
              
              switch-1# 
              
              

              次に、すべての仮想インターフェイスに関するステータスおよびサマリー情報を表示する例を示します。

              switch-1# show interface virtual status vm-fex 
              
              Interface VIF-index   Bound If      Chan  Vlan  Status     Mode     Vntag
              -------------------------------------------------------------------------
              Veth32769 VIF-37      Eth1/20       ----   101  Up         Active       7
              Veth32770 VIF-39      Eth1/20       ----     1  Up         Active       8
              Veth32771 VIF-41      Eth1/20       ----     1  Up         Standby      9
              Veth32772 VIF-43      Eth1/20       ----     1  Up         Active      10
              Veth32773 VIF-47      Eth1/20       ----     1  Up         Active      12
              Veth32774 VIF-48      Eth1/20       ----     1  Up         Standby     13
              Veth32775 VIF-49      Eth1/20       ----     1  Up         Active      14
              
              
              switch-1# show interface virtual summary vm-fex 
              
              Veth       Bound      Channel/  Port                     Mac                VM 
              Interface  Interface  DV-Port   Profile                  Address            Name 
              -----------------------------------------------------------------------------------------
              Veth32769  Eth1/20    7415    Unused_Or_Quarantine_Veth  00:50:56:9b:33:a7  ESX145_1_RH55.
              Veth32770  Eth1/20    7575    Unused_Or_Quarantine_Veth  00:50:56:9b:33:a8  ESX145_1_RH55.
              Veth32771  Eth1/20    7576    Unused_Or_Quarantine_Veth  00:50:56:9b:33:a9  ESX145_1_RH55.
              Veth32772  Eth1/20    7577    Unused_Or_Quarantine_Veth  00:50:56:9b:33:aa  ESX145_1_RH55.
              Veth32773  Eth1/20    7578    Unused_Or_Quarantine_Veth  00:50:56:9b:33:ac  ESX145_1_RH55.
              Veth32774  Eth1/20    7579    Unused_Or_Quarantine_Veth  00:50:56:9b:33:ad  ESX145_1_RH55.
              Veth32775  Eth1/20    7580    Unused_Or_Quarantine_Veth  00:50:56:9b:33:ae  ESX145_1_RH55.
              Veth32776  Eth1/20    7607    Unused_Or_Quarantine_Veth  00:50:56:9b:33:ab  ESX145_1_RH55.
              
              switch-1#
              
              

              次に、固定 vEthernet インターフェイスに関するステータスおよびサマリー情報を表示する例を示します。

              switch-1# show interface virtual status bound interface ethernet 1/20
              
              Interface VIF-index   Bound If      Chan  Vlan  Status     Mode     Vntag
              -------------------------------------------------------------------------
              Veth32769 VIF-16      Eth1/20          1     1  Up         Active       2
              Veth32770 VIF-17      Eth1/20          5     1  Up         Active      46
              Veth32771 VIF-18      Eth1/20          8     1  Up         Active      49
              Veth32772 VIF-19      Eth1/20          9     1  Up         Active      50
              Veth32773 VIF-20      Eth1/20         11     1  Up         Active      52
              Veth32774 VIF-21      Eth1/20         12     1  Up         Active      53
              Veth32775 VIF-22      Eth1/20         13     1  Up         Active      54
              Veth32776 VIF-23      Eth1/20         14     1  Up         Active      55
              Veth32777 VIF-24      Eth1/20         15     1  Up         Active      56
              Total 9 Veth interfaces
              
              switch-1# show interface virtual summary bound interface ethernet 1/20
              
              Veth       Bound        Channel/  Port        Mac                VM
              Interface  Interface    DV-Port   Profile     Address            Name
              -------------------------------------------------------------------------
              Veth32769  Eth1/20         1    sample
              Veth32770  Eth1/20         5    sample
              Veth32771  Eth1/20         8    sample
              Veth32772  Eth1/20         9    sample
              Veth32773  Eth1/20        11    sample
              Veth32774  Eth1/20        12    sample
              Veth32775  Eth1/20        13    sample
              Veth32776  Eth1/20        14    sample
              Veth32777  Eth1/20        15    sample
              Total 9 Veth interfaces
              
              switch-1#
              

              vCenter Server への接続の確認

              手順の概要

                1.    configure terminal

                2.    show svs connections [svs-name]


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1 configure terminal


                例:
                switch# configure terminal
                switch(config)#
                 

                コンフィギュレーション モードに入ります。

                 
                ステップ 2 show svs connections [svs-name]


                例:
                switch(config)# show svs connection
                 

                現在の SVS 接続を表示します。

                 

                次に、SVS 接続の詳細を表示する例を示します。

                switch-1# configure terminal
                switch-1(config)# show svs connections
                
                Local Info:
                -----------
                connection 2VC:
                    ip address: 192.0.20.125
                    remote port: 80
                    vrf: management
                    protocol: vmware-vim https
                    certificate: default
                    datacenter name: DC1
                    extension key: Cisco_Nexus_5500_1945593678
                    dvs name: Pod1
                    DVS uuid: cd 05 25 50 6d a9 a5 c4-eb 9c 8f 6b fa 51 b1 aa
                    config status: Enabled
                    operational status: Connected
                    sync status: in progress
                    version: VMware vCenter Server 5.0.0 build-388657
                
                
                Peer Info:
                ----------
                    hostname: -
                    ip address: -
                    vrf:
                    protocol: -
                    extension key: Cisco_Nexus_5500_1945593678
                    certificate: default
                      certificate match: TRUE
                    datacenter name: DC1
                    dvs name: Pod1
                    DVS uuid: cd 05 25 50 6d a9 a5 c4-eb 9c 8f 6b fa 51 b1 aa
                    config status: Disabled
                    operational status: Connected
                
                switch-1(config)#