Cisco Nexus 5000 シリーズ NX-OS Adapter-FEX コンフィギュレーション ガイド リリース 5.2(1)N1(1)
Adapter-FEX の設定
Adapter-FEX の設定
発行日;2012/11/16   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

Adapter-FEX の設定

この章では、Cisco Nexus 5000 シリーズ Adapter-FEX を設定する方法について説明します。

この章は、次の項目を取り上げます。

サーバ ネットワーク アダプタ搭載のサーバの追加

ここでは、Adapter-FEX 対応のサーバ ネットワーク アダプタを搭載したサーバを設定する方法について説明します。

Adapter-FEX 対応のスイッチのイネーブル化

サーバが接続されている各スイッチの Adapter-FEX 機能をイネーブルにします。

手順
     コマンドまたはアクション目的
    ステップ 1configure terminal


    例:
    switch# configure terminal
    switch(config)#
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2 install feature-set virtualization


    例:
    switch(config)# install feature-set virtualization
    switch(config)# 
     

    スイッチに Cisco 仮想マシン フィーチャ セットをインストールします。

     
    ステップ 3 feature-set virtualization


    例:
    switch(config)# feature-set virtualization
    switch(config)#
     

    スイッチで Cisco 仮想マシン機能をイネーブルにします。

     
    ステップ 4 vethernet auto-create


    例:
    switch(config)# vethernet auto-create 
    switch(config)#
     

    スイッチで vEthernet インターフェイスの自動作成をイネーブルにします。

     

    例:

    switch# configure terminal
    switch(config)# install feature-set virtualization
    switch(config)# feature-set virtualization
    switch(config)# vethernet auto-create
    switch(config)#

    スイッチの設定

    Adapter-FEX をサポートするようにスイッチを設定します。

    手順
       コマンドまたはアクション目的
      ステップ 1port-profile type vethernet port-profile_name


      例:
      switch# port-profile type vethernet user_data1
      switch# state enabled
      
      switch# port-profile type vethernet user_data2
      switch# state enabled
      
      switch# port-profile type vethernet user_management
      switch# state enabled
      
      switch# port-profile type vethernet user_backup
      switch# state enabled
       

      アダプタの vNIC と関連付けるポート プロファイル(type vethernet)を作成します。

      ポート プロファイルに、VLAN、帯域幅、Quality of Service(QoS)、アクセス コントロール リスト(ACL)などの関連するプロパティおよびポリシーを設定します。

      この例では、4 つの vNIC がサーバに必要であるとします。 vNIC のタイプごとに、この例に示すように各タイプに 1 つのポート プロファイルを作成します。

       
      ステップ 2 switchport mode vntag


      例:
      switch(config)# interface Ethernet1/5 
         description ucs_vic2/0
         switch(config-if)# switchport mode vntag
       

      ネットワーク アダプタのアップリンク インターフェイスが接続されているスイッチのイーサネット インターフェイスで、VNTag モードのスイッチポートを設定します。

       
      ステップ 3サーバ ネットワーク アダプタのアップリンクを接続します。 

      サーバからスイッチまたは FEX にサーバ ネットワーク アダプタのアップリンクを接続します。

       

      4 つの vNIC の Nexus 5500 の設定例

      switch# install feature-set virtualization
      feature-set virtualization
      vethernet auto-create
      
      switch# port-profile type vethernet user_data1
          switchport trunk allowed vlan 2-100
          switchport trunk native vlan 2
          switchport mode trunk
      switch# state enabled 
      
      switch# port-profile type vethernet user_data2
          switchport trunk allowed vlan 2-100
          switchport trunk native vlan 2
          switchport mode trunk
      switch# state enabled
      
      switch# port-profile type vethernet user_management
          switchport access vlan 1
      switch# state enabled
      
      switch# port-profile type vethernet user_backup
          switchport mode trunk
          switchport trunk allowed vlan 2-100
          switchport trunk native vlan 2
          mac port access-group mac_acl1
          ip port access-group ip_acl1 in
          ipv6 port traffic-filter ipv6_acl1 in
      switch# state enabled
      
      switch# configure terminal
      
      switch(config)# interface Ethernet1/5 
         description ucs_vic2/0
      switch(config-if)# switchport mode vntag
      switch(config-if)#

      サーバ ネットワーク アダプタの設定

      サーバのネットワーク アダプタ設定ユーティリティを使用して、ネットワーク アダプタのネットワーク インターフェイス仮想化(NIV)モードをイネーブルにします。 詳細については、ご使用のサーバ ネットワーク アダプタのマニュアルを参照してください。 設定を完了するため、サーバをリブートしてネットワーク アダプタをリセットすることが必要になる場合があります。

      • Cisco UCS P81E サーバ ネットワーク アダプタについては、『Cisco UCS C-Series Servers Integrated Management Controller CLI Configuration Guide』の「Cisco UCS P81E Virtual Interface Card」を参照してください。
      • Broadcom BCM57712 コンバージェンス ネットワーク インターフェイス カードについては、Broadcom 社の資料を参照してください。

      サーバ ネットワーク アダプタの初期ハンドシェイクおよびネゴシエーション

      サーバ ネットワーク アダプタをスイッチのイネーブル化された VNTag モードのイーサネット ポートまたは FEX に接続すると、ハンドシェイクが開始されます。 NIV 機能に関する情報交換が実行され、通信は VNTag モードで開始されます。 スイッチは、設定されたポート プロファイルのリスト(type vethernet)をアダプタに渡します。 これらのポート プロファイル名は、選択可能なオプションとしてサーバ ネットワーク アダプタ設定ユーティリティに表示されます。

      サーバ ネットワーク アダプタには、ポート プロファイルの名前だけが渡されます。 ポート プロファイルの設定は、サーバ ネットワーク アダプタには渡されません。

      サーバ ネットワーク アダプタがスイッチに接続されていなければ、まだ、サーバの仮想ネットワーク インターフェイス カード(vNIC)を設定できます。 ただし、アダプタではポート プロファイル名を使用できません。

      サーバ ネットワーク アダプタの vNIC の設定

      サーバのネットワーク アダプタ設定ユーティリティを使用して、適切な数の vNIC を作成します。 各 vNIC は、固有のチャネル番号、MAC アドレス、アップリンク フェールオーバー プロパティ、ポート プロファイル名などの適切なプロパティで作成します。


      (注)  


      初期ハンドシェイクとネゴシエーションが終わると、スイッチに設定されたポート プロファイルのリストがサーバ アダプタで自動的に使用可能になります。 これらのポート プロファイル名を vNIC に関連付けることができます。


      各 vNIC には、固有のチャネル番号が関連付けられています。 vNIC は、物理ポートおよび vNIC のチャネル番号を vEthernet インターフェイスに関連付ける bind コマンドにより、スイッチで識別されます。 詳細については、ご使用のサーバ ネットワーク アダプタのマニュアルを参照してください。

      • Cisco UCS P81E サーバ ネットワーク アダプタについては、『Cisco UCS C-Series Servers Integrated Management Controller CLI Configuration Guide』の「Cisco UCS P81E Virtual Interface Card」を参照してください。
      • Broadcom BCM57712 コンバージェンス ネットワーク インターフェイス カードについては、Broadcom 社の資料を参照してください。

      VNtag 接続が確立されると、ポート プロファイル名(type vethernet)だけがサーバ ネットワーク アダプタに渡されます。 ポート プロファイルの設定は、サーバ ネットワーク アダプタには渡されません。

      ポート プロファイル名は、選択可能なオプションとしてサーバ ネットワーク アダプタ設定ユーティリティに表示されます。

      サーバ ネットワーク アダプタの初期化

      サーバ ネットワーク アダプタの vNIC を設定した後、次を考慮して設定を完了する必要があります。

      • サーバのリブートとサーバ ネットワーク アダプタのリセット。
      • ドライバのリロード。

      詳細については、ご使用のサーバ ネットワーク アダプタのマニュアルを参照してください。

      設定が完了すると、サーバ ネットワーク アダプタとスイッチはリンクを再確立し、初期ハンドシェイクとネゴシエーション プロセスを実行します。 また、サーバ ネットワーク アダプタとスイッチは、Virtual Interface Configuration(VIC)プロトコルを使用してさらに高いレベルのコントロール プレーン接続を確立します。


      (注)  


      VIC プロトコルは、リモート デバイスに仮想インターフェイスをプロビジョニングし、管理します。


      VIC プロトコル接続が確立されると、サーバ ネットワーク アダプタは、サーバ ネットワーク アダプタに設定されている各 vNIC 用の vEthernet インターフェイスを作成するよう、スイッチに要求します。 また、サーバ ネットワーク アダプタは、vEthernet インターフェイスの作成要求に加えて、アップリンクを介して次の属性を渡します。

      • ポート プロファイル名
      • チャネル番号
      • アクティブ/スタンバイ ステータス

      スイッチは、サーバ ネットワーク アダプタの各 vNIC の vEthernet インターフェイスを作成して応答し、vEthernet インターフェイスにポート プロファイルおよびチャネル番号を関連付けます。

      サーバの起動プロセスは、vEthernet の作成が完了するまで、BIOS 設定フェーズで保留されることがあります。 vEthernet が作成されると、起動プロセスが再開し、オペレーティング システムがロードされます。 詳細については、ご使用のアダプタのマニュアルを参照してください。

      グローバル コンフィギュレーション コマンド no vethernet auto-create は、vEthernet インターフェイスの自動作成を停止します。 スイッチに vethernet auto-create コマンドが設定されていない場合は、適切なバインディングとポート プロファイルの設定を使用して、vEthernet インターフェイスを手動で設定する必要があります。

      スイッチによって作成された vEthernet インターフェイスには、作成されるときに自動的に番号が付けられます。 これらの vEthernet 番号は、32769 から始まります。 スイッチは、vEthernet インターフェイスを作成するときに、最も小さい未使用の番号を選択します。

      vEthernet インターフェイスを手動で作成するときは、vEthernet に任意の番号を選択できます。 ただし、ベスト プラクティスとして、32678 より小さい番号を選択します。

      vEthernet インターフェイスの設定例

      switch# interface vethernet 21
          bind interface ethernet 1/5 channel 1
          inherit port-profile user_data
      switch# interface vethernet 22
          bind interface ethernet 1/5 channel 2
          inherit port-profile user_data
      switch# interface vethernet 23
          bind interface ethernet 1/5 channel 3
          inherit port-profile user_management
      switch# interface vethernet 24
          bind interface ethernet 1/5 channel 4
          inherit port-profile user_backup

      デュアル ホーム接続 FEX トポロジの Cisco Nexus 5500 アダプタの初期化の例

      次の図は、デュアル ホーム接続 FEX のトポロジを示します。

      図 1. Cisco Nexus 5500 デュアル ホーム接続トポロジ



      Cisco Nexus 5500-A スイッチの vEthernet インターフェイスの初期化の結果
      switch# interface vethernet 21
          bind interface ethernet 101/1/15 channel 1
          inherit port-profile user_data
      switch# interface vethernet 22
          bind interface ethernet 101/1/15 channel 2
          inherit port-profile user_data
      switch# interface vethernet 23
          bind interface ethernet 101/1/15 channel 3
          inherit port-profile user_management
      switch# interface vethernet 24
          bind interface ethernet 101/1/15 channel 4
          inherit port-profile user_backup
      switch# interface vethernet 21
          bind interface ethernet 101/1/15 channel 1
          inherit port-profile user_data
      switch# interface vethernet 22
          bind interface ethernet 101/1/15 channel 2
          inherit port-profile user_data
      switch# interface vethernet 23
          bind interface ethernet 101/1/15 channel 3
          inherit port-profile user_management
      switch# interface vethernet 24
          bind interface ethernet 101/1/15 channel 4
          inherit port-profile user_backup

      (注)  


      初期化の結果は、Cisco Nexus 5500-A および Cisco Nexus 5500-B の両方のスイッチで同じになります。


      アクティブ/スタンバイ トポロジでの Cisco Nexus 5500 アダプタの初期化の例

      ここで説明するアクティブ/スタンバイ トポロジは、一方のアップリンクがアクティブ、もう一方のアップリンクがスタンバイです。 一部のサーバ ネットワーク アダプタでは、vNIC ごとにアクティブ アップリンクとスタンバイ アップリンクを選択できます。 この場合、各アップリンクは特定の vNIC のアクティブなアップリンクであり、残りのアップリンクに対してスタンバイになります。 各 vNIC では、ベスト プラクティスとしてアクティブ アップリンクおよびスタンバイ アップリンクを選択する必要があります。

      スタンバイ アップリンク デバイスに作成された vEthernet インターフェイスのチャネル番号は、アクティブなアップリンクのチャネル番号と同じです。

      アクティブ/スタンバイ アップリンクのトポロジを示す次の図について考えてみます。

      図 2. Cisco Nexus 5500 アクティブ/スタンバイ トポロジ



      仮想ポート チャネル(vPC)トポロジでは、1 つの vNIC に関連付けられた vEthernet インターフェイスのインターフェイス番号は vPC プライマリおよびセカンダリ スイッチで同じです。

      この例のサーバ ネットワーク アダプタに、次の表に示す設定で 4 つの vNIC(eth0、eth1、eth2、eth3)と 2 つのアップリンク(uplink_0、uplink_1)があるとします。

      vNIC

      アップリンク

      ポート プロファイル名

      チャネル番号

      eth0

      Uplink_0

      user_data

      1

      eth1

      Uplink_1

      user_management

      2

      eth2

      Uplink_0

      user_data

      3

      eth3

      Uplink_1

      user_backup

      4

      また、uplink_0 が N5500-A のイーサネット 1/5 に接続され、uplink_1 が N5500-B のイーサネット 1/15 に接続されるとします。

      vPC アクティブ/スタンバイ トポロジでは、vEthernet 番号は、vPC プライマリ スイッチによって割り当てられます。 vEthernet 作成要求を受信すると、vPC セカンダリ スイッチはプライマリ スイッチに割り当てを要求します。 show vpc brief コマンドを実行すると、スイッチの vPC ロールが表示されます。

      サーバがプライマリ vPC スイッチまたはセカンダリ vPC スイッチの 1 つのポートから別のポートに移動されると、サーバ ネットワーク アダプタの接続は古い vEthernet インターフェイスが削除されるまで確立されません。

      Cisco Nexus 5500-A スイッチの vEthernet インターフェイスの初期化の結果
      switch# interface vethernet 37
          bind interface ethernet 1/5 channel 1
          inherit port-profile user_data
      switch# interface vethernet 38
          bind interface ethernet 1/5 channel 2
          inherit port-profile user_data
      switch# interface vethernet 39
          bind interface ethernet 1/5 channel 3
          inherit port-profile user_management
      switch# interface vethernet 40
          bind interface ethernet 1/5 channel 4
          inherit port-profile user_backup
      switch# interface vethernet 37
          bind interface ethernet 1/5 channel 1
          inherit port-profile user_data
      switch# interface vethernet 38
          bind interface ethernet 1/5 channel 2
          inherit port-profile user_data
      switch# interface vethernet 39
          bind interface ethernet 1/5 channel 3
          inherit port-profile user_management
      switch# interface vethernet 40
          bind interface ethernet 1/5 channel 4
          inherit port-profile user_backup

      (注)  


      初期化の結果は、Cisco Nexus 5500-A および Cisco Nexus 5500-B の両方のスイッチで同じになります。


      アクティブ/スタンバイ トポロジを使用したデュアル ホーム接続 FEX の Cisco Nexus 5500 アダプタの初期化の例

      次の図は、アクティブ/スタンバイ アップリンクのトポロジを示します。

      図 3. Cisco Nexus 5500 デュアル ホーム接続アクティブ/スタンバイ トポロジ



      この例のアダプタに、次の表に示す設定で 4 つの vNIC(eth0、eth1、eth2、eth3)と 2 つのアップリンク(uplink_0、uplink_1)があるとします。

      vNIC

      アップリンク

      ポート プロファイル名

      チャネル番号

      eth0

      Uplink_0

      user_data

      1

      eth1

      Uplink_1

      user_management

      2

      eth2

      Uplink_0

      user_data

      3

      eth3

      Uplink_1

      user_backup

      4

      また uplink_0 がイーサネット 100/1/15 に接続され、uplink_1 がイーサネット 101/1/15 に接続されているとします。

      Cisco Nexus 5500-A スイッチの vEthernet インターフェイスの初期化の結果
      switch# interface vethernet 37
          bind interface ethernet 100/1/15 channel 1
          bind interface ethernet 101/1/15 channel 1
          inherit port-profile user_data
      switch# interface vethernet 38 
          bind interface ethernet 100/1/15 channel 2
          bind interface ethernet 101/1/15 channel 2
          inherit port-profile user_data
      switch# interface vethernet 39
          bind interface ethernet 100/1/15 channel 3
          bind interface ethernet 101/1/15 channel 3
          inherit port-profile user_management
      switch# iinterface vethernet 40
          bind interface ethernet 100/1/15 channel 4
          bind interface ethernet 101/1/15 channel 4
          inherit port-profile user_backup
      switch# interface vethernet 37
          bind interface ethernet 100/1/15 channel 1
          bind interface ethernet 101/1/15 channel 1
          inherit port-profile user_data
      switch# interface vethernet 38
          bind interface ethernet 100/1/15 channel 2
          bind interface ethernet 101/1/15 channel 2
          inherit port-profile user_data
      switch# interface vethernet 39
          bind interface ethernet 100/1/15 channel 3
          bind interface ethernet 101/1/15 channel 3
          inherit port-profile user_management
      switch# interface vethernet 40
          bind interface ethernet 100/1/15 channel 4
          bind interface ethernet 101/1/15 channel 4
          inherit port-profile user_backup

      (注)  


      初期化の結果は、Cisco Nexus 5500-A および Cisco Nexus 5500-B の両方のスイッチで同じになります。


      vEthernet インターフェイスの作成

      サーバ ネットワーク アダプタは、スイッチに vEthernet インターフェイスを 1 つずつ作成するように要求します。

      vEthernet インターフェイスを作成した結果の例

      switch# show running-config interface Vethernet32773
      
      interface Vethernet32773
        inherit port-profile sample
        bind interface Ethernet1/20 channel 11
      
      switch# show interface Vethernet32773 detail
      vif_index: 29
      --------------------------
        veth is bound to interface Ethernet1/20 (0x1a013000)
        priority: 0
        vntag: 52
        status: standby
        channel id: 11
        registered mac info:
            vlan 0 - mac 00:00:00:00:00:00
            vlan 0 - mac 00:22:bd:d6:5f:4b
            vlan 0 - mac ff:ff:ff:ff:ff:ff
      

      スタートアップ コンフィギュレーションへの vEthernet インターフェイスの保存

      VIC プロトコル インターフェイス作成要求で作成された vEthernet インターフェイスは、実行コンフィギュレーションに保存されます。 実行コンフィギュレーションを保存すると、vEthernet インターフェイスおよびその設定はスタートアップ コンフィギュレーションに保存されます。

      スイッチがリロードされると、スイッチはスタートアップ コンフィギュレーションをロードし、vEthernet インターフェイスがスタートアップ コンフィギュレーションからスタティックに作成されます。 VNTag インターフェイスが初期化され、サーバ ネットワーク アダプタが vEthernet 作成の要求を行うと、すでに存在する vEthernet インターフェイスが使用されます。


      (注)  


      システムから vEthernet インターフェイスを削除するには、no interface vethernet veth-id コマンドを使用します。 vEthernet インターフェイスはスタートアップ コンフィギュレーションに保存されているため、ベスト プラクティスは実行コンフィギュレーションをスタートアップ コンフィギュレーションに保存することです。


      vEthernet インターフェイスの手動設定

      サーバ ネットワーク アダプタがスイッチの VNTag モードのイーサネット インターフェイスに接続されている場合、vEthernet インターフェイスは自動的に作成されます。 ただし、vEthernet インターフェイスは、コンフィギュレーション モードから interface vethernet veth-id コマンドを使用して手動で作成することもできます。


      (注)  


      vEthernet インターフェイスを手動で作成する場合、no vethernet auto-create コマンドを使用して vEthernet インターフェイスの自動作成をディセーブルにします。


      サーバ ネットワーク アダプタが接続され、vEthernet 作成要求が受信されると、スイッチは vEthernet 作成要求のチャネル番号と一致する手動設定された vEthernet インターフェイスがないか確認します。 手動設定された vEthernet インターフェイスがすでに存在する場合、手動設定された vEthernet インターフェイスが使用され、新しい vEthernet インターフェイスは作成されません。

      スイッチとサーバ ネットワーク アダプタ間の設定の競合

      手動で設定された vEthernet インターフェイスまたはスタートアップ コンフィギュレーションに保存された vEthernet インターフェイスの設定と、サーバ ネットワーク アダプタでの設定の間に、ポート プロファイル名の競合が発生する場合があります。

      たとえば、サーバ ネットワーク アダプタがチャネル番号 5 の vNIC をポート プロファイル user_backup に関連付けるのに対し、スイッチはチャネル番号 5 にバインドされた vEthernet インターフェイスをポート プロファイル user_data に関連付ける場合があります。

      この種の競合が発生した場合は、サーバ ネットワーク アダプタの設定が優先され、スイッチの設定は上書きされます。


      (注)  


      ポート プロファイルが vNIC に関連付けられた場合に、そのポート プロファイルがスイッチに存在しないと、vEthernet の作成と初期化は失敗します。


      スイッチ間の設定の競合

      vPC トポロジでは、特定の vEthernet インターフェイスの設定は、両方のスイッチで同じでなければなりません。 スイッチの設定に不一致がある場合、設定が競合し、vEthernet インターフェイスに障害が発生します。

      この種の競合が発生すると、vEthernet インターフェイスが正常に起動する前に競合を手動で解決する必要があります。

      サーバ ネットワーク アダプタ搭載のサーバの削除

      サーバ ネットワーク アダプタがスイッチに接続している場合、サーバ ネットワーク アダプタをサポートするために、vEthernet インターフェイスが作成されます。 トポロジからサーバ ネットワーク アダプタを削除する場合、サーバの接続解除または電源切断を行ってもこれらの vEthernet インターフェイスは削除されません。 古い vEthernet インターフェイスは、手動で削除されるまで存在します。

      古い vEthernet インターフェイスを手動で削除すると、サーバ ネットワーク アダプタに接続されたサーバをトポロジから削除できます。


      (注)  


      ベスト プラクティスとして、スイッチ リソースを節約するために未使用の vEthernet インターフェイスを削除する必要があります。


      手順
         コマンドまたはアクション目的
        ステップ 1configure terminal


        例:
        switch# configure terminal
        switch(config)#
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2no interface vethernet veth-id


        例:
        switch(config)# no interface vethernet 1
        switch(config)#
         

        vEthernet インターフェイスを削除します。

         
        ステップ 3copy running-config startup-config


        例:
        switch(config)# copy running-config startup-config
        
         
        (任意)

        リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

         

        vEthernet インターフェイスの削除例

        switch# configure terminal
        switch(config)# no interface vethernet 1
        switch(config)# copy running-config startup-config
        switch(config)# 

        別の物理インターフェイスへのサーバの再配置

        サーバ ネットワーク アダプタをスイッチ上の物理インターフェイスから別の同一のスイッチに移動すると、新しい vEthernet インターフェイスが作成され、新しい物理インターフェイスにバインドされます。 元の物理インターフェイスにバインドされた元の vEthernet インターフェイスは、削除されるまで存在します。

        新しいサーバを元のサーバが接続されていた物理インターフェイスに接続すると、vEthernet インターフェイスは再利用されます(vEthernet インターフェイスが削除されていないと仮定します)。 ただし、このアクションにより、スイッチの設定とサーバ ネットワーク アダプタの設定との間に競合が発生する場合があります。


        (注)  


        サーバ ネットワーク アダプタをサーバから別のサーバに移動すると、vNIC に関する情報などのサーバ ネットワーク アダプタの設定も一緒に移動されます。 設定は、サーバ ネットワーク アダプタに保存されます。


        vPC トポロジでは、vNIC の vEthernet 番号が両方の vPC ピアで同じでなければなりません。 サーバ ネットワーク アダプタを搭載したサーバを、最初にスイッチの vEthernet インターフェイスを削除せずに、1 つの物理インターフェイスからいずれかの vPC ピアのインターフェイスに移動すると、異なる番号を持つ新しい vEthernet インターフェイスが作成されます。 この結果、2 つの vPC ピアは同期されません。 vEthernet の作成の障害は、vPC ピアが同期されていない場合に発生します。 ベスト プラクティスとして、元の vEthernet インターフェイスはサーバが新しい物理インターフェイスに接続される前に削除する必要があります。

        手順
           コマンドまたはアクション目的
          ステップ 1 shutdown


          例:
          switch# shutdown
           

          元の物理インターフェイスでシャットダウンを実行します。

           
          ステップ 2configure terminal


          例:
          switch# configure terminal
          switch(config)#
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3 no interface vethernet veth-id


          例:
          switch(config)# no interface vethernet 21
          switch(config)#
           

          サーバに関連付けられた各 vEthernet インターフェイスを削除します。

           
          ステップ 4 no switchport mode vntag


          例:
          switch(config-if)# no switchport mode vntag 
          switch(config)#
           

          両方の vPC スイッチの元の物理インターフェイスで switchport mode vntag を設定解除します。

           
          ステップ 5両方の vPC スイッチからサーバを取り外します。 

          両方の vPC スイッチからサーバを切断します。

           
          ステップ 6サーバを新規の物理インターフェイスに接続します。 

          サーバを新規の物理インターフェイスに接続します。

           
          ステップ 7サーバ ネットワーク アダプタを設定します。 

          新規スイッチのサーバ ネットワーク アダプタを設定します。

           

          例:

          • 次のコマンドを実行します。
            switch# shutdown
            switch# configure terminal
            switch(config)# no interface vethernet 21
            switch(config-if)# no switchport mode vntag
            switch(config-if)#
          • 両方の vPC スイッチからサーバを取り外します。
          • サーバを新規の物理インターフェイスに接続します。
          • サーバ ネットワーク アダプタを設定します。

          ポート プロファイルの追加または削除

          type vethernet の新しいポート プロファイルを追加すると、そのポート プロファイルはすべての接続されたサーバ ネットワーク アダプタにただちに渡され、使用可能になります。 同様に、ポート プロファイルを削除すると、接続しているすべてのサーバ ネットワーク アダプタからその名前が取り消されます。


          (注)  


          ポート プロファイル名だけがサーバ ネットワーク アダプタに渡されるため、ポート プロファイル内の設定を変更しても、サーバ ネットワーク アダプタに情報は渡されません。



          (注)  


          既存または新規 vNIC との関連付けなど、新しく追加されたポート プロファイルを使用すると、サーバを再起動してサーバ ネットワーク アダプタをリセットする必要がある場合があります。 詳細については、ご使用のアダプタのマニュアルを参照してください。


          ポート プロファイルを削除すると、関連付けられたすべての vEthernet インターフェイスがダウンします。

          スイッチの Adapter-FEX のディセーブル化

          サーバが接続されている各スイッチの Adapter-FEX 機能をディセーブルにします。

          手順
             コマンドまたはアクション目的
            ステップ 1configure terminal


            例:
            switch# configure terminal
            switch(config)#
             

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 2 no interface vethernet veth-id


            例:
            switch(config)# no interface vethernet 21
             

            実行コンフィギュレーションの各 vEthernet インターフェイスを削除します。

             
            ステップ 3 no port-profile type vethernet port-profile_name


            例:
            switch(config-if)# no port-profile type vethernet user_data
            switch(config)#
             

            アダプタの vNIC と関連付けるポート プロファイル(type vethernet)を削除します。

             
            ステップ 4 no switchport mode vntag


            例:
            switch(config-if)# no switchport mode vntag
            switch(config)#
             

            VNTag モードのスイッチポートの設定を解除します。

             
            ステップ 5 no feature-set virtualization


            例:
            switch(config)# no feature-set virtualization
            switch(config)#
             

            仮想化をディセーブルにします。

             

            例:

            switch# configure terminal
            switch(config)# no interface vethernet 21
            switch(config-if)# no port-profile type vethernet user_data
            switch(config-if)# no switchport mode vntag
            switch(config-if)# no feature-set virtualization
            switch(config-if)#