Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 5.2(1)N1(1)
レイヤ 3 仮想化の設定
レイヤ 3 仮想化の設定
発行日;2012/10/25 | 英語版ドキュメント(2012/08/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

レイヤ 3 仮想化の設定

レイヤ 3 仮想化

レイヤ 3 仮想化の概要

VRF およびルーティング

VRF-Lite

VRF 認識サービス

到達可能性

フィルタリング

到達可能性とフィルタリングの組み合わせ

VRF のライセンス要件

注意事項および制約事項

デフォルト設定

VRF の設定

VRF の作成

インターフェイスへの VRF メンバーシップの割り当て

ルーティング プロトコルに関する VRF パラメータの設定

VRF 認識サービスの設定

VRF スコープの設定

VRF コンフィギュレーションの確認

設定:VRF の例

関連資料

その他の関連資料

関連資料

標準

VRF 機能の履歴

レイヤ 3 仮想化の設定

この章では、レイヤ 3 仮想化の設定手順について説明します。

この章では、次の内容について説明します。

「レイヤ 3 仮想化」

「VRF のライセンス要件」

「注意事項および制約事項」

「デフォルト設定」

「VRF の設定」

「VRF コンフィギュレーションの確認」

「設定:VRF の例」

「関連資料」

「その他の関連資料」

「VRF 機能の履歴」

レイヤ 3 仮想化

ここでは、次の内容について説明します。

「レイヤ 3 仮想化の概要」

「VRF およびルーティング」

「VRF 認識サービス」

レイヤ 3 仮想化の概要

Cisco NX-OS は、仮想ルーティングおよび転送(VRF)インスタンスをサポートしています。各 VRF には、IPv4 および IPv6 に対応するユニキャストおよびマルチキャスト ルート テーブルを備えた、独立したアドレス スペースが 1 つずつあり、他の VRF と無関係にルーティングを決定できます。

ルータごとに、デフォルト VRF および管理 VRF があります。すべてのレイヤ 3 インターフェイスおよびルーティング プロトコルは、ユーザが別の VRF に割り当てないかぎり、デフォルト VRF に存在します。mgmt0 インターフェイスは、管理 VRF 内に存在します。スイッチは、VRF-Lite 機能を使用して、カスタマー エッジ(CE)スイッチで複数の VRF をサポートします。VRF-Lite によって、サービス プロバイダーは 1 つのインターフェイスを使用して、重複する IP アドレスを持つ複数のバーチャル プライベート ネットワーク(VPN)をサポートできます。


) スイッチでは、VPN のサポートのためにマルチプロトコル ラベル スイッチング(MPLS)が使用されません。


VRF およびルーティング

すべてのユニキャストおよびマルチキャスト ルーティング プロトコルは VRF をサポートします。VRF でルーティング プロトコルを設定する場合は、同じルーティング プロトコル インスタンスの別の VRF のルーティング パラメータに依存しないルーティング パラメータをその VRF に設定します。

VRF にインターフェイスおよびルーティング プロトコルを割り当てることによって、仮想レイヤ 3 ネットワークを作成できます。インターフェイスが存在する VRF は 1 つだけです。図 11-1 に、1 つの物理ネットワークが 2 つの VRF からなる 2 つの仮想ネットワークに分割されている例を示します。ルータ Z、A、および B は、VRF Red にあり、1 つのアドレス ドメインを形成しています。これらのルータは、ルータ C が含まれないルート アップデートを共有します。ルータ C は別の VRF で設定されているからです。

図 11-1 ネットワーク内の VRF

 

Cisco NX-OS はデフォルトで、着信インターフェイスの VRF を使用して、ルート検索に使用するルーティング テーブルを選択します。ルート ポリシーを設定すると、この動作を変更し、Cisco NX-OS が着信パケットに使用する VRF を設定できます。

Cisco NX-OS は、VRF 間のルート リーク(インポートまたはエクスポート)を防止します。

VRF-Lite

VRF-Lite の機能によって、サービス プロバイダーは、VPN 間で重複した IP アドレスを使用できる複数の VPN をサポートできます。VRF-Lite は入力インターフェイスを使用して異なる VPN のルートを区別し、各 VRF に 1 つまたは複数のレイヤ 3 インターフェイスを対応付けて仮想パケット転送テーブルを形成します。VRF のインターフェイスは、イーサネット ポートなどの物理インターフェイス、または VLAN SVI などの論理インターフェイスにすることができますが、レイヤ 3 インターフェイスは、一度に複数の VRF に属することはできません。


) VRF-Lite の実装では、マルチプロトコル ラベル スイッチング(MPLS)および MPLS コントロール プレーンはサポートされません。



) VRF-Lite インターフェイスは、レイヤ 3 インターフェイスである必要があります。


VRF 認識サービス

Cisco NX-OS アーキテクチャの基本的な特徴として、すべての IP ベースの機能が VRF を認識することがあげられます。

次の VRF 認識サービスは、特定の VRF を選択することによって、リモート サーバに接続したり、選択した VRF に基づいて情報をフィルタリングすることができます。

AAA:詳細については、『 Cisco Nexus 5000 Series NX-OS Security Configuration Guide, Release 5.0(2)N2(1) 』を参照してください。

Call Home:詳細については、『 Cisco Nexus 5000 Series NX-OS System Management Configuration Guide 』を参照してください。

HSRP:詳細については、「HSRP の設定」を参照してください。

HTTP:詳細については、『 Cisco Nexus 5000 Series NX-OS Fundamentals Configuration Guide 』を参照してください。

Licensing:詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

NTP:詳細については、『 Cisco Nexus 5000 Series NX-OS System Management Configuration Guide 』を参照してください。

RADIUS:詳細については、『 Cisco Nexus 5000 Series NX-OS Security Configuration Guide, Release 5.0(2)N2(1) 』を参照してください。

ping および traceroute:詳細については、『 Cisco Nexus 5000 Series NX-OS Fundamentals Configuration Guide 』を参照してください。

SSH:詳細については、『 Cisco Nexus 5000 Series NX-OS Fundamentals Configuration Guide 』を参照してください。

SNMP:詳細については、『 Cisco Nexus 5000 Series NX-OS System Management Configuration Guide 』を参照してください。

Syslog:詳細については、『 Cisco Nexus 5000 Series NX-OS System Management Configuration Guide 』を参照してください。

TACACS+:詳細については、『 Cisco Nexus 5000 Series NX-OS Security Configuration Guide, Release 5.0(2)N2(1) 』を参照してください。

TFTP:詳細については、『 Cisco Nexus 5000 Series NX-OS Fundamentals Configuration Guide 』を参照してください。

VRRP:詳細については、「VRRP の設定」を参照してください。

各サービスで VRF サポートを設定する詳細については、各サービスの適切なコンフィギュレーション ガイドを参照してください。

ここで説明する内容は、次のとおりです。

「到達可能性」

「フィルタリング」

「到達可能性とフィルタリングの組み合わせ」

到達可能性

到達可能性は、サービスを提供するサーバに到達するために必要なルーティング情報がどの VRF にあるかを示します。たとえば、管理 VRF で到達可能な SNMP サーバを設定できます。ルータ上でサーバ アドレスを設定する場合は、サーバに到達するために Cisco NX-OS が使用しなければならない VRF も設定します。

図 11-2 に、管理 VRF を介して到達できる SNMP サーバを示します。SNMP サーバ ホスト 192.0.2.1 には管理 VRF を使用するように、ルータ A を設定します。

図 11-2 サービス VRF の到達可能性

 

フィルタリング

フィルタリングによって、VRF に基づいて VRF 認識サービスに渡す情報のタイプを制限できます。たとえば、Syslog サーバが特定の VRF をサポートするように設定できます。図 11-3 に示す 2 つの Syslog サーバは、それぞれ 1 つの VRF をサポートしています。Syslog サーバ A は VRF Red で設定されているので、Cisco NX-OS は VRF Red で生成されたシステム メッセージだけを Syslog サーバ A に送信します。

図 11-3 サービス VRF のフィルタリング

 

到達可能性とフィルタリングの組み合わせ

VRF 認識サービスの到達可能性とフィルタリングを組み合わせることができます。そのサービスに接続するために Cisco NX-OS が使用する VRF とともに、サービスがサポートする VRF も設定できます。デフォルト VRF でサービスを設定する場合は、任意で、すべての VRF をサポートするようにサービスを設定できます。

図 11-4 に、管理 VRF 上で到達できる SNMP サーバを示します。たとえば、SNMP サーバが VRF Red からの SNMP 通知だけをサポートするように設定できます。

図 11-4 サービス VRF の到達可能性とフィルタリング

 

VRF のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

VRF にライセンスは不要です。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS ライセンス方式の詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

(注) NX-OS 基本ライセンスではデフォルトの VRF を使用でき、mgmt0 ポートには管理 VRF を使用できます。2 つのデフォルト VRF が自動的に作成されます。VRF-lite では追加 VRF を作成できます。追加 VRF は、レイヤ 3 LAN エンタープライズ ライセンスが必要です。

注意事項および制約事項

VRF 設定時の注意事項と制約事項は次のとおりです。

インターフェイスを既存の VRF のメンバにすると、Cisco NX-OS はあらゆるレイヤ 3 設定を削除します。VRF にインターフェイスを追加したあとで、すべてのレイヤ 3 パラメータを設定する必要があります。

管理 VRF に mgmt0 インターフェイスを追加し、そのあとで mgmt0 の IP アドレスおよびその他のパラメータを設定します。

VRF が存在しないうちに VRF のインターフェイスを設定した場合は、VRF を作成するまで、そのインターフェイスは運用上のダウンになります。

Cisco NX-OS はデフォルトで、デフォルト VRF および管理 VRF を作成します。mgmt0 は管理 VRF のメンバにする必要があります。

write erase boot コマンドを実行しても、管理 VRF 設定は削除されません。 write erase コマンドを使用してから write erase boot コマンドを使用する必要があります。

VRF-lite には、次の注意事項と制限事項があります。

VRF-lite を備えたスイッチは、各 VRF に対してそれぞれ、グローバル ルーティング テーブルとは異なる IP ルーティング テーブルを持ちます。

VRF-lite が異なる VRF テーブルを使用するため、同じ IP アドレスを再利用できます。別々の VPN では IP アドレスの重複が許可されます。

VRF-lite では、一部の MPLS-VRF 機能(ラベル交換、LDP の隣接関係、またはラベル付きパケット)がサポートされていません。

複数の仮想レイヤ 3 インターフェイスを VRF-lite スイッチに接続できます。

スイッチでは、物理ポートか VLAN SVI、またはその両方の組み合わせを使用して、VRF を設定できます。SVI は、アクセス ポートまたはトランク ポートで接続できます。

レイヤ 3 TCAM リソースは、すべての VRF 間で共有されます。各 VRF が十分な CAM 領域を持つようにするには、maximum routes コマンドを使用します。

VRF を使用したスイッチは、1 つのグローバル ネットワークと最大 64 の VRF をサポートできます。サポートされるルートの総数は、TCAM のサイズに制限されます。

VRF-lite は、BGP、RIP、スタティック ルーティング、EIGRP、OSPF をサポートします。

VRF-Lite は、パケット スイッチング レートに影響しません。

マルチキャストを同時に同一のレイヤ 3 インターフェイス上に設定することはできません。

VRF-lite は IPv4 ネットワーク上でのみサポートされます。

デフォルト設定

表 11-1 に、VRF パラメータのデフォルト設定を示します。

 

表 11-1 デフォルトの VRF パラメータ

パラメータ
デフォルト

設定されている VRF

デフォルト、管理

ルーティング コンテキスト

デフォルト VRF

VRF の設定

ここで説明する内容は、次のとおりです。

「VRF の作成」

「インターフェイスへの VRF メンバーシップの割り当て」

「ルーティング プロトコルに関する VRF パラメータの設定」

「VRF 認識サービスの設定」

「VRF スコープの設定」


) Cisco IOS の CLI に慣れている場合、この機能の Cisco NX-OS コマンドは従来の Cisco IOS コマンドと異なる点があるため注意が必要です。


VRF の作成

スイッチに VRF を作成できます。

手順の概要

1. configure terminal

2. vrf context name

3. ip route { ip-prefix | ip-addr ip-mask } {[ next-hop | nh-prefix ] | [ interface next-hop | nh-prefix ]} [ tag tag-value [ pref ]]

4. (任意) show vrf [ vrf-name ]

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

vrf context name

 

Example:

switch(config)# vrf context Enterprise

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。 name には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

ステップ 3

ip route { ip-prefix | ip-addr ip-mask } {[ next-hop | nh-prefix ] | [ interface next-hop | nh-prefix ]} [ tag tag-value [ pref ]

 

Example :

switch(config-vrf)# ip route 192.0.2.0/8 ethernet 1/2 192.0.2.4

スタティック ルートおよびこのスタティック ルート用のインターフェイスを設定します。任意でネクストホップ アドレスを設定できます。 preference 値でアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 1 です。

ステップ 4

show vrf [ vrf-name ]

 

Example :

switch(config-vrf)# show vrf Enterprise

(任意)VRF 情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

VRF および関連する設定を削除するには、 no vrf context コマンドを使用します。

 

コマンド
目的

no vrf context name

 

Example:

switch(config)# no vrf context Enterprise

VRF および関連するすべての設定を削除します。

グローバル コンフィギュレーション モードで使用できるコマンドはすべて、VRF コンフィギュレーション モードでも使用できます。

次に、VRF を作成し、VRF にスタティック ルートを追加する例を示します。

switch# configure terminal
switch(config)# vrf context Enterprise
switch(config-vrf)# ip route 192.0.2.0/8 ethernet 1/2
switch(config-vrf)# exit
switch(config)# copy running-config startup-config
 

インターフェイスへの VRF メンバーシップの割り当て

インターフェイスを VRF のメンバにできます。

はじめる前に

VRF 用のインターフェイスを設定したあとで、インターフェイスに IP アドレスを割り当てます。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. no switchport

4. vrf member vrf-name

5. ip-address ip-prefix/length

6. (任意) show vrf vrf-name interface interface-type number

7. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

Example :

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no switchport

 

Example:

switch(config-if)# no switchport

そのインターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

ステップ 4

vrf member vrf-name

 

Example:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 5

ip address ip-prefix/length

 

Example:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 6

show vrf vrf-name interface interface-type number

 

Example :

switch(config-vrf)# show vrf Enterprise interface ethernet 1/2

(任意)VRF 情報を表示します。

ステップ 7

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF にインターフェイスを追加する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# vrf member RemoteOfficeVRF
switch(config-if)# ip address 192.0.2.1/16
switch(config-if)# copy running-config startup-config
 

ルーティング プロトコルに関する VRF パラメータの設定

1 つまたは複数の VRF にルーティング プロトコルを関連付けることができます。ルーティング プロトコルに関する VRF の設定については、該当する章を参照してください。ここでは、詳細な設定手順の例として、OSPFv2 プロトコルを使用します。

手順の概要

1. configure terminal

2. router ospf instance-tag

3. vrf vrf-name

4. (任意) maximum-paths paths

5. interface interface-type slot/port

6. no switchport

7. vrf member vrf-name

8. ip address ip-prefix/length

9. ip router ospf i nstance-tag area area-id

10. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf instance-tag

 

Example:

switch(config-vrf)# router ospf 201

switch(config-router)#

新規 OSPFv2 インスタンスを作成して、設定済みのインスタンス タグを割り当てます。

ステップ 3

vrf vrf-name

 

Example:

switch(config-router)# vrf RemoteOfficeVRF

switch(config-router-vrf)#

VRF コンフィギュレーション モードを開始します。

ステップ 4

maximum-paths paths

 

Example:

switch(config-router-vrf)# maximum-paths 4

(任意)この VRF のルート テーブル内の宛先への、同じ OSPFv2 パスの最大数を設定します。ロード バランシングに使用されます。

ステップ 5

interface interface-type slot/port

 

Example :

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

no switchport

 

Example:

switch(config-if)# no switchport

そのインターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

ステップ 7

vrf member vrf-name

 

Example:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 8

ip address ip-prefix/length

 

Example:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 9

ip router ospf instance-tag area area-id

 

Example:

switch(config-if)# ip router ospf 201 area 0

このインターフェイスを OSPFv2 インスタンスおよび設定エリアに割り当てます。

ステップ 10

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF を作成して、その VRF にインターフェイスを追加する例を示します。

switch# configure terminal
switch(config)# vrf context RemoteOfficeVRF
switch(config-vrf)# exit
switch(config)# router ospf 201
switch(config-router)# vrf RemoteOfficeVRF
switch(config-router-vrf)# maximum-paths 4
switch(config-router-vrf)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# vrf member RemoteOfficeVRF
switch(config-if)# ip address 192.0.2.1/16
switch(config-if)# ip router ospf 201 area 0
switch(config-if)# exit
switch(config)# copy running-config startup-config
 

VRF 認識サービスの設定

VRF 認識サービスの到達可能性およびフィルタリングを設定できます。VRF 用サービスの設定手順を扱っている、該当する章またはコンフィギュレーション ガイドへのリンクについては、「VRF 認識サービス」を参照してください。ここでは、サービスの詳細な設定手順の例として、SNMP および IP ドメイン リストを使用します。

手順の概要

1. configure terminal

2. snmp-server host ip-address [ filter_vrf vrf-name ] [ use-vrf vrf-name ]

3. vrf context [ vrf-name ]

4. ip domain-list domain-name [ all-vrfs ] [ use-vrf vrf-name ]

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

snmp-server host ip-address [ filter-vrf vrf-name ] [ use-vrf vrf-name ]

 

Example:

switch(config)# snmp-server host 192.0.2.1 use-vrf Red

switch(config-vrf)#

グローバル SNMP サーバを設定し、サービスに到達するために Cisco NX-OS が使用する VRF を設定します。選択された VRF からこのサーバへの情報をフィルタリングするには、 filter-vrf キーワードを使用します。

ステップ 3

vrf context vrf-name

 

Example:

switch(config)# vrf context Blue

switch(config-vrf)#

新しい VRF を作成します。

ステップ 4

ip domain-list domain-name [ all-vrfs ][ use-vrf vrf-name ]

 

Example:

switch(config-vrf)# ip domain-list List all-vrfs use-vrf Blue

switch(config-vrf)#

VRF でドメイン リストを設定し、さらに任意で、指定されたドメイン名に接続するために Cisco NX-OS が使用する VRF を設定します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF Red で到達可能な SNMP ホスト 192.0.2.1 に、すべての VRF の SNMP 情報を送信する例を示します。

switch# configure terminal
switch(config)# snmp-server host 192.0.2.1 for-all-vrfs use-vrf Red
switch(config)# copy running-config startup-config
 

次に、VRF Red で到達可能な SNMP ホスト 192.0.2.12 に対して、VRF Blue の SNMP 情報をフィルタリングする例を示します。

switch# configure terminal
switch(config)# vrf definition Blue
switch(config-vrf)# snmp-server host 192.0.2.12 use-vrf Red
switch(config)# copy running-config startup-config
 

VRF スコープの設定

すべての EXEC コマンド( show コマンドなど)に対応する VRF スコープを設定できます。VRF スコープを設定すると、EXEC コマンド出力のスコープが設定された VRF に自動的に限定されます。このスコープは、一部の EXEC コマンドで使用できる VRF キーワードによって上書きできます。

VRF スコープを設定するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

routing-context vrf vrf-name

 

Example:

switch# routing-context vrf red

switch%red#

すべての EXEC コマンドに対応するルーティング コンテキストを設定します。デフォルトのルーティング コンテキストはデフォルト VRF です。

デフォルトの VRF スコープに戻すには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

routing-context vrf default

 

Example:

switch%red# routing-context vrf default

switch#

デフォルトのルーティング コンテキストを設定します。

VRF コンフィギュレーションの確認

VRF の設定情報を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show vrf [vrf-name]

すべてまたは 1 つの VRF の情報を表示します。

show vrf [vrf-name] detail

すべてまたは 1 つの VRF の詳細情報を表示します。

show vrf [vrf-name] [interface interface-type slot/port]

インターフェイスの VRF ステータスを表示します。

設定:VRF の例

次に、VRF Red を設定し、その VRF に SNMP サーバを追加し、VRF Red に OSPF インスタンスを追加する例を示します。

configure terminal

vrf context Red

snmp-server host 192.0.2.12 use-vrf Red

router ospf 201

interface ethernet 1/2

no switchport

vrf member Red

ip address 192.0.2.1/16

ip router ospf 201 area 0

 

次に、VRF Red および Blue を設定し、各 VRF に OSPF インスタンスを追加し、各 OSPF インスタンスの SNMP コンテキストを作成する例を示します。

configure terminal

!Create the VRFs

vrf context Red

vrf context Blue

!Create the OSPF instances and associate them with each VRF

feature ospf

router ospf Lab

vrf Red

router ospf Production

vrf Blue

!Configure one interface to use ospf Lab on VRF Red

interface ethernet 1/2

no switchport

vrf member Red

ip address 192.0.2.1/16

ip router ospf Lab area 0

no shutdown

!Configure another interface to use ospf Production on VRF Blue

interface ethernet 10/2

no switchport

vrf member Blue

ip address 192.0.2.1/16

ip router ospf Production area 0

no shutdown

!configure the SNMP server

snmp-server user admin network-admin auth md5 nbv-12345

snmp-server community public ro

!Create the SNMP contexts for each VRF
snmp-server context lab instance Lab vrf Red
snmp-server context production instance Production vrf Blue
 

この例で、VRF Red の OSPF インスタンス Lab の OSPF-MIB 値にアクセスするには、SNMP コンテキスト lab を使用します。

関連資料

VRF の詳細については、次の項目を参照してください。

Cisco Nexus 5000 Series NX-OS Fundamentals Configuration Guide

Cisco Nexus 5000 Series NX-OS System Management Configuration Guide

その他の関連資料

仮想化の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

「標準」

関連資料

関連項目
マニュアル名

VRF CLI

『Cisco Nexus 5000 Series Command Reference, Cisco NX-OS Releases 4.x, 5.x

標準

標準
タイトル

この機能でサポートされる新規または改訂された標準規格はありません。また、この機能による既存の標準規格サポートの変更はありません。

--

VRF 機能の履歴

表 11-2 は、この機能のリリースの履歴です。

 

表 11-2 VRF 機能の履歴

機能名
リリース
機能情報

IPv6

5.2(1)N1(1)

サポートが追加されました。

VRF

5.0(3)N1(1)

この機能が導入されました。