Cisco Nexus 5000 シリーズ NX-OS システム管理コンフィギュレーション ガイド リリース 5.1(3)N1(1)
スイッチ プロファイルの設定
スイッチ プロファイルの設定
発行日;2012/09/04   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

スイッチ プロファイルの設定

この章の内容は、次のとおりです。

スイッチ プロファイルに関する情報

複数のアプリケーションは、ネットワーク内のCisco Nexus シリーズスイッチ間で整合性のある設定が必要です。 たとえば、仮想ポート チャネル(vPC)を使用する場合、同じ設定にする必要があります。 設定の不一致により、エラーや設定ミスが発生し、サービスが中断されることがあります。

設定の同期(config-sync)機能では、1 つのスイッチ プロファイルを設定し、設定を自動的にピア スイッチに同期させることができます。 スイッチ プロファイルには、次の利点があります。

  • 設定をスイッチ間で同期できます。
  • 2 台のスイッチ間で接続が確立されると、設定がマージされます。
  • 同期される設定を正確に制御できます。
  • マージおよび相互排除チェックを通じて、ピア全体の設定の一貫性を保証します。
  • 確認とコミットのセマンティックが提供されます。
  • ポート プロファイル コンフィギュレーションの設定と同期をサポートします。
  • 既存の vPC 設定をスイッチ プロファイルに移行するためのインポート コマンドが提供されます。

スイッチ プロファイル コンフィギュレーション モード

スイッチ プロファイル機能には、次のコンフィギュレーション モードがあります。

  • コンフィギュレーション同期モード
  • スイッチ プロファイル モード
  • スイッチ プロファイル インポート モード

コンフィギュレーション同期モード

コンフィギュレーション同期モード(config-sync)では、マスターとして使用するローカル スイッチ上で config sync コマンドを使用して、スイッチ プロファイルを作成できます。 プロファイルの作成後、同期するピア スイッチで config sync コマンドを入力できます。

スイッチ プロファイル モード

スイッチ プロファイル モードでは、後でピア スイッチと同期化されるスイッチ プロファイルに、サポートされているコンフィギュレーション コマンドを追加できます。 スイッチ プロファイル モードで入力したコマンドは、commit コマンドを入力するまでバッファに格納されます。

スイッチ プロファイル インポート モード

以前のリリースからアップグレードするとき、スイッチ プロファイルに、サポートされている実行コンフィギュレーション コマンドをコピーするため、import コマンドを入力できます。 import コマンドを入力した後、スイッチ プロファイル モード(config-sync-sp)は、スイッチ プロファイル インポート モード(config-sync-sp-import)に変わります。 スイッチ プロファイル インポート モードでは、既存のスイッチ設定を実行コンフィギュレーションからインポートし、どのコマンドをスイッチ プロファイルに含めるかを指定できます。

異なるトポロジで、スイッチ プロファイルに含まれる異なるコマンドが必要になるため、import コマンド モードでは、特定のトポロジに合うようにインポートされたコマンドを変更できます。 たとえば、デュアル ホーム ファブリック エクステンダ(FEX)トポロジでは、大部分の設定が同期している必要があります。 他の vPC トポロジでは、同期する必要がある設定は、かなり小さいコマンドのセットである可能性があります。

インポート プロセスを完了し、スイッチ プロファイルにコンフィギュレーションを移動するには、commit コマンドを入力する必要があります。 インポート プロセス中の設定変更がサポートされないため、新しいコマンドを commit コマンドを入力する前に追加すると、スイッチ プロファイルが保存されないまま残り、スイッチはスイッチ プロファイル インポート モードのままになります。 追加したコマンドを削除するか、またはインポートを中断します。 未保存のコンフィギュレーションは、プロセスが中断されると失われます。 インポートの完了後、スイッチ プロファイルに新しいコマンドを追加できます。

設定の確認

2 種類の設定の有効性検査により、2 種類のスイッチ プロファイルの障害を識別できます。

  • 相互排除チェック
  • マージ チェック

相互排除チェック

スイッチ プロファイルに含まれる設定を上書きする可能性を減らすため、相互排除(mutex)は、スイッチ プロファイルのコマンドを、ローカル スイッチ上に存在するコマンドと、ピア スイッチ上のコマンドに対してチェックします。 あるスイッチ プロファイルに含まれるコマンドをそのスイッチ プロファイルの外部やピア スイッチで設定することはできません。 この要件は、既存のコマンドが意図せず上書きされる可能性を減らします。

mutex チェックは、コミット プロセスの一部として、ピア スイッチに到達できる場合は両方のスイッチで行われ、そうでない場合はローカルで実行されます。 設定端末から行われた設定変更は、ローカル スイッチだけで発生します。

mutex チェックがエラーを識別すると、mutex の障害として報告され、手動で修正する必要があります。

次の例外は相互排除ポリシーに適用されます。

  • インターフェイス設定:Release 5.1(3) よりも前のリリースでは、競合がない限り、インターフェイス設定の一部がスイッチ プロファイルに存在し、一部が実行コンフィギュレーションに存在できました。 Release 5.1(3) 以降では、ポート チャネル インターフェイスは、スイッチ プロファイル モードまたはグローバル コンフィギュレーション モードのいずれかで完全に設定する必要があります。

    (注)  


    一部のポート チャネル サブコマンドは、スイッチ プロファイル モードで設定できません。 これらのコマンドは、ポート チャネルがスイッチ プロファイル モードで作成および設定されている場合でも、グローバル コンフィギュレーション モードで設定できます。

    たとえば、次のコマンドはグローバル コンフィギュレーション モードでしか設定できません。

    switchport private-vlan association trunk primary-vlan secondary-vlan


  • shutdown/no shutdown
  • システム QoS

マージ チェック

マージ チェックは設定を受信するピア スイッチで行われます。 マージ チェックによって、受信したコンフィギュレーションが受信側スイッチ上の既存のスイッチ プロファイル コンフィギュレーションと競合しないことが確認されます。 マージ チェックは、マージまたはコミット プロセスで実行されます。 マージが失敗した場合はエラーが報告され、手動で修正する必要があります。

いずれかまたは両方のスイッチがリロードされ、コンフィギュレーションが最初に同期されると、マージ チェックは、スイッチ プロファイルの設定が両方のスイッチで同じであることを確認します。 スイッチ プロファイルの違いは、マージ障害として報告され、手動で修正する必要があります。

スイッチ プロファイルを使用したソフトウェアのアップグレードおよびダウングレード

以前のリリースにダウングレードすると、以前のリリースではサポートされていない既存のスイッチ プロファイルを削除するように要求されます。

以前のリリースからアップグレードする場合、スイッチ プロファイルに一部の実行コンフィギュレーション コマンドを移動することを選択できます。 import コマンドでは、関連するスイッチ プロファイル コマンドをインポートできます。 アップグレードは、バッファされた設定(コミットされていない)がある場合に実行できます。ただし、コミットされていない設定は失われます。

スイッチ プロファイルに含まれるスイッチの 1 つで、In Service Software Upgrade(ISSU)を実行すると、ピアが到達不能であるため、設定の同期は実行できません。

スイッチ プロファイルの前提条件

スイッチ プロファイルには次の前提条件があります。

  • cfs ipv4 distribute コマンドを入力して、両方のスイッチで mgmt0 上の IP を介した Cisco Fabric Series(CFSoIP)配布をイネーブルにする必要があります。
  • config sync コマンドと switch-profile コマンドを入力して、両方のピア スイッチで同じ名前を持つスイッチ プロファイルを設定する必要があります。
  • sync-peers destination コマンドを入力して、各スイッチをピア スイッチとして設定します

スイッチ プロファイルの注意事項および制約事項

スイッチ プロファイルを設定する場合は、次の注意事項および制約事項を考慮してください。

  • mgmt0 インターフェイスを使用してのみ設定同期化をイネーブルにできます。
  • 設定の同期は、mgmt 0 インターフェイスを使用して実行され、管理 SVI を使用して実行できません。
  • 同じスイッチ プロファイル名で同期されたピアを設定する必要があります。
  • スイッチ プロファイル設定で使用可能なコマンドを、設定スイッチ プロファイル(config-sync-sp)モードで設定できます。
  • サポートされているスイッチ プロファイル コマンドは、vPC コマンドに関連します。 FCoE コマンドはサポートされません。
  • 1 つのスイッチ プロファイル セッションが一度に進行できます。 別のセッションの開始を試みると失敗します。
  • スイッチ プロファイル セッションの進行中は、コンフィギュレーション端末モードから実行されたサポートされているコマンドの変更はブロックされます。 スイッチ プロファイル セッションが進行しているときは、コンフィギュレーション端末モードからサポートされていないコマンドの変更を行わないでください。
  • commit コマンドを入力し、ピア スイッチに到達可能である場合、設定は、両方のピア スイッチに適用されるか、いずれのスイッチにも適用されません。 コミットの障害が発生した場合、コマンドは、スイッチ プロファイル バッファに残ります。 その場合、必要な修正をし、コミットを再試行します。
  • シスコでは、インターフェイス コンフィギュレーションが設定同期機能を使用して同期される、すべての Generic Expansion Module(GEM)モジュールおよび Cisco Nexus ファブリック エクステンダ モジュールで事前プロビジョニングをイネーブルにすることを推奨します。 ファブリック エクステンダが 1 台のスイッチでオンラインでない可能性があり、その設定が変更され、他のスイッチで同期される、Cisco Nexus ファブリック エクステンダ アクティブ/アクティブ トポロジでは、次の注意事項に従ってください。 このシナリオでは、事前プロビジョニングをイネーブルにしない場合、コミットに失敗し、設定が両方のスイッチでロール バックされます。
  • ポート チャネルがスイッチ プロファイル モードを使用して設定されている場合、グローバル コンフィギュレーション(config 端末)モードを使用して設定できません。

    (注)  


    一部のポート チャネル サブコマンドは、スイッチ プロファイル モードで設定できません。 これらのコマンドは、ポート チャネルがスイッチ プロファイル モードで作成および設定されている場合でも、グローバル コンフィギュレーション モードで設定できます。

    たとえば、次のコマンドはグローバル コンフィギュレーション モードでしか設定できません。

    switchport private-vlan association trunk primary-vlan secondary-vlan


  • shutdown および no shutdown はグローバル コンフィギュレーション モードまたはスイッチ プロファイル モードで設定できます。
  • ポート チャネルがグローバル コンフィギュレーション モードで作成されている場合、メンバ インターフェイスを含むチャネル グループも、グローバル コンフィギュレーション モードを使用して作成する必要があります。
  • スイッチ プロファイル モードで設定されたポート チャネルでは、スイッチ プロファイルの内側と外側の両方にメンバを持つ場合があります。
  • スイッチ プロファイルにメンバ インターフェイスをインポートする場合、メンバ インターフェイスを含むポート チャネルもスイッチ プロファイル内に存在する必要があります。

リブート、接続損失、または障害後の同期化に関する注意事項

  • vPC ピア リンクの障害後の設定の同期化:ピア リンクに障害が発生したときに両方のスイッチが動作している場合、セカンダリ スイッチが vPC ポートをシャットダウンします。 ファブリック エクステンダ A/A トポロジでは、A/A ファブリック エクステンダがセカンダリ スイッチから切断されます。 プライマリ スイッチでスイッチ プロファイルを使用して設定が変更された場合、A/A ファブリック エクステンダが事前にプロビジョニングされていない限り、設定はセカンダリ スイッチで受け入れられません。 設定の同期機能を使用する場合、すべての A/A ファブリック エクステンダを事前プロビジョニングすることを推奨します。
  • mgmt0 インターフェイスの接続が失われた後の設定の同期化:mgmt0 インターフェイスの接続が失われ、設定変更が必要な場合は、スイッチ プロファイルを使用して、両方のスイッチの設定変更を適用します。 mgmt0 インターフェイスへの接続が復元されると、両方のスイッチが自動的に同期されます。 設定変更を 1 台のスイッチだけで実行する場合、マージは、mgmt0 インターフェイスが起動し、設定が他のスイッチに適用されると実行されます。
  • ISSU が 1 台のスイッチで実行され、設定変更がピア スイッチで行われる場合の設定の同期化:vPC トポロジでは、ピア スイッチの設定変更は、ISSU が他のスイッチで実行される場合は許可されません。 vPC のないトポロジでは、設定変更は許可され、アップグレードが完了すると、ISSU を実行しているスイッチは新しい設定を同期します。

スイッチ プロファイルの設定

スイッチ プロファイルは作成および設定できます。 コンフィギュレーション同期モード(config-sync)で、switch-profile name コマンドを入力します。

はじめる前に

各スイッチに同じ名前を持つスイッチ プロファイルを作成し、スイッチを互いにピアとして設定する必要があります。 同じアクティブ スイッチ プロファイルを持つスイッチ間で接続が確立されると、スイッチ プロファイルが同期されます。

手順の概要

    1.    configure terminal

    2.    cfs ipv4 distribute

    3.    config sync

    4.    switch-profile name

    5.    sync-peers destination IP-address

    6.    (任意) show switch-profile name status

    7.    exit

    8.    (任意) copy running-config startup-config


手順の詳細
     コマンドまたはアクション目的
    ステップ 1configure terminal


    例:
    switch# configure terminal
    switch(config)#
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2cfs ipv4 distribute


    例:
    switch(config)# cfs ipv4 distribute
    switch(config)#
     

    ピア スイッチ間の CFS 配信をイネーブルにします。

     
    ステップ 3 config sync


    例:
    switch# config sync
    switch(config-sync)#
     

    コンフィギュレーション同期モードを開始します。

     
    ステップ 4switch-profile name


    例:
    switch(config-sync)# switch-profile abc
    switch(config-sync-sp)#
     

    スイッチ プロファイルを設定し、スイッチ プロファイルの名前を設定し、スイッチ プロファイル同期コンフィギュレーション モードを開始します。

     
    ステップ 5sync-peers destination IP-address


    例:
    switch(config-sync-sp)# sync-peers destination 10.1.1.1
    switch(config-sync-sp)#
     

    ピア スイッチを設定します。

     
    ステップ 6show switch-profile name status


    例:
    switch(config-sync-sp)# show switch-profile abc status
    switch(config-sync-sp)#
     
    (任意)

    ローカル スイッチのスイッチ プロファイルおよびピア スイッチ情報を表示します。

     
    ステップ 7exit


    例:
    switch(config-sync-sp)# exit
    switch#
     

    スイッチ プロファイル コンフィギュレーション モードを終了し、EXEC モードに戻ります。

     
    ステップ 8copy running-config startup-config


    例:
    switch(config)# copy running-config startup-config
    
     
    (任意)

    リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

     

    次に、スイッチ プロファイルを設定し、スイッチ プロファイルのステータスを表示する例を示します。

    switch# configuration terminal
    switch(config)# cfs ipv4 distribute
    switch(config-sync)# switch-profile abc 
    switch(config-sync-sp)# sync-peers destination 10.1.1.1
    switch(config-sync-sp)# show switch-profile abc status
    Start-time:  15801 usecs after Mon Aug 23 06:21:08 2010
    End-time:   6480 usecs after Mon Aug 23 06:21:13 2010
     
    Profile-Revision: 1
    Session-type: Initial-Exchange
    Peer-triggered: Yes
    Profile-status: Sync Success
     
    Local information:
    ----------------
    Status: Commit Success
    Error(s):
     
    Peer information:
    ----------------
    IP-address: 10.1.1.1
    Sync-status: In Sync.
    Status: Commit Success
    Error(s):
    switch(config-sync-sp)# exit
    switch#

    スイッチ プロファイルへのスイッチの追加

    スイッチ プロファイル コンフィギュレーション モードで sync-peers destination destination IP コマンドを入力し、スイッチ プロファイルにスイッチを追加します。

    スイッチを追加する場合は、次の注意事項に従ってください。

    • スイッチは IP アドレスで識別されます。
    • 宛先 IP は同期するスイッチの IP アドレスです。
    • コミットされたスイッチ プロファイルは、ピア スイッチでも設定の同期が設定されている場合に、新しく追加されたピアと(オンラインの場合)同期されます。 スイッチ プロファイルにメンバ インターフェイスをインポートする場合、メンバ インターフェイスを含むポート チャネルもスイッチ プロファイル内に存在する必要があります。
    はじめる前に

    ローカル スイッチでスイッチ プロファイルを作成した後、同期に含まれる 2 番めのスイッチを追加する必要があります。

    手順の概要

      1.    config sync

      2.    switch-profile name

      3.    sync-peers destination destination IP

      4.    exit

      5.    (任意) show switch-profile peer

      6.    (任意) copy running-config startup-config


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 config sync


      例:
      switch# config sync
      switch(config-sync)#
       

      コンフィギュレーション同期モードを開始します。

       
      ステップ 2 switch-profile name


      例:
      switch(config-sync)# switch-profile abc
      switch(config-sync-sp)#
       

      スイッチ プロファイルを設定し、スイッチ プロファイルの名前を設定し、スイッチ プロファイル同期コンフィギュレーション モードを開始します。

       
      ステップ 3 sync-peers destination destination IP


      例:
      switch(config-sync-sp)# sync-peers destination 10.1.1.1
      switch(config-sync-sp)#
       

      スイッチ プロファイルにスイッチを追加します。

       
      ステップ 4 exit


      例:
      switch(config-sync-sp)# exit
      switch#
       

      スイッチ プロファイル コンフィギュレーション モードを終了します。

       
      ステップ 5 show switch-profile peer


      例:
      switch# show switch-profile peer
       
      (任意)

      スイッチ プロファイルのピアの設定を表示します。

       
      ステップ 6 copy running-config startup-config


      例:
      switch# copy running-config startup-config
       
      (任意)

      実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

       

      スイッチ プロファイルのコマンドの追加または変更

      スイッチ プロファイルのコマンドを変更するには、変更されたコマンドをスイッチ プロファイルに追加し、commit コマンドを入力してコマンドを適用し、ピア スイッチが到達可能な場合にスイッチ プロファイルを同期します。

      スイッチ プロファイル コマンドを追加または変更するときは、次の注意事項に従ってください。

      • 追加または変更されたコマンドは、commit コマンドを入力するまでバッファに格納されます。
      • コマンドは、バッファリングされた順序で実行されます。 特定のコマンドに順序の依存関係がある場合(たとえば、QoS ポリシーは適用前に定義する必要がある)、その順序を維持する必要があります。そうしないとコミットに失敗する可能性があります。 show switch-profile name buffer コマンド、buffer-delete コマンド、buffer-move コマンドなどのユーティリティ コマンドを使用して、バッファを変更し、入力済みのコマンドの順序を修正できます。
      はじめる前に

      ローカルおよびピア スイッチでスイッチ プロファイルを設定したら、スイッチ プロファイルにサポートされているコマンドを追加し、コミットする必要があります。 コマンドは、commit コマンドを入力するまでスイッチ プロファイル バッファに追加されます。 commit コマンドは次を行います。

      • mutex チェックとマージ チェックを起動し、同期を確認します。
      • ロールバック インフラストラクチャでチェックポイントを作成します。
      • ローカル スイッチおよびピア スイッチのコンフィギュレーションを適用します。
      • スイッチ プロファイル内の任意のスイッチでアプリケーション障害がある場合は、すべてのスイッチでロール バックを実行します。
      • チェックポイントを削除します。
      手順の概要

        1.    config sync

        2.    switch-profile name

        3.    command argument

        4.    (任意) show switch-profile name buffer

        5.    verify

        6.    commit

        7.    (任意) show switch-profile name status

        8.    exit

        9.    (任意) copy running-config startup-config


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 config sync


        例:
        switch# config sync
        switch(config-sync)#
         

        コンフィギュレーション同期モードを開始します。

         
        ステップ 2 switch-profile name


        例:
        switch(config-sync)# switch-profile abc
        switch(config-sync-sp)#
         

        スイッチ プロファイルを設定し、スイッチ プロファイルの名前を設定し、スイッチ プロファイル同期コンフィギュレーション モードを開始します。

         
        ステップ 3 command argument


        例:
        switch(config-sync-sp)# interface Port-channel100
        switch(config-sync-sp-if)# speed 1000
        switch(config-sync-sp-if)# interface Ethernet1/1
        switch(config-sync-sp-if)# speed 1000
        switch(config-sync-sp-if)# channel-group 100
         

        スイッチ プロファイルにコマンドを追加します。

         
        ステップ 4 show switch-profile name buffer


        例:
        switch(config-sync-sp)# show switch-profile abc buffer
        switch(config-sync-sp)#
         
        (任意)

        スイッチ プロファイル バッファ内のコンフィギュレーション コマンドを表示します。

         
        ステップ 5 verify


        例:
        switch(config-sync-sp)# verify
         

        スイッチ プロファイル バッファ内のコマンドを確認します。

         
        ステップ 6 commit


        例:
        switch(config-sync-sp)# commit
         

        スイッチ プロファイルにコマンドを保存し、ピア スイッチと設定を同期します。

         
        ステップ 7 show switch-profile name status


        例:
        switch(config-sync-sp)# show switch-profile abc status
        switch(config-sync-sp)#
         
        (任意)

        ローカル スイッチのスイッチ プロファイルのステータスとピア スイッチのステータスを表示します。

         
        ステップ 8 exit


        例:
        switch(config-sync-sp)# exit
        switch#
         

        スイッチ プロファイル コンフィギュレーション モードを終了します。

         
        ステップ 9 copy running-config startup-config


        例:
        switch# copy running-config startup-config
         
        (任意)

        実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

         

        次に、スイッチ プロファイルを作成し、ピア スイッチを設定し、スイッチ プロファイルにコマンドを追加する例を示します。

        switch# configuration terminal
        switch(config)# cfs ipv4 distribute
        switch(config-sync)# switch-profile abc 
        switch(config-sync-sp)# sync-peers destination 10.1.1.1
        switch(config-sync-sp)# interface port-channel100
        switch(config-sync-sp-if)# speed 1000
        switch(config-sync-sp-if)# interface Ethernet1/1
        switch(config-sync-sp-if)# speed 1000
        switch(config-sync-sp-if)# channel-group 100
        switch(config-sync-sp)# verify
        switch(config-sync-sp)# commit
        switch(config-sync-sp)# exit
        switch#
        

        次に、定義されたスイッチ プロファイルがある既存のコンフィギュレーションの例を示します。 2 番めの例は、スイッチ プロファイルに変更されたコマンドを追加することによって、スイッチ プロファイル コマンドを変更する方法を示します。

        switch# show running-config
        switch-profile abc
          interface Ethernet1/1
            switchport mode trunk
            switchport trunk allowed vlan 1-10
        
        switch# config sync
        switch(config-sync)# switch-profile abc
        switch(config-sync-sp)# interface Ethernet1/1
        switch(config-sync-sp-if)# switchport trunk allowed vlan 5-10
        switch(config-sync-sp-if)# commit
        
        switch# show running-config
        switch-profile abc
          interface Ethernet1/1
            switchport mode trunk
            switchport trunk allowed vlan 5-10

        スイッチ プロファイルのインポート

        インポートするコマンドのセットに基づいてスイッチ プロファイルをインポートできます。 コンフィギュレーション端末モードの使用:

        • 選択したコマンドをスイッチ プロファイルに追加する。
        • インターフェイスに指定された、サポートされているコマンドを追加する。
        • サポートされているシステムレベル コマンドを追加する。
        • サポートされるシステムレベル コマンドを追加する(物理インターフェイス コマンドを除く)。

        スイッチ プロファイルにコマンドをインポートする場合、スイッチプロファイル バッファが空である必要があります。

        新しいコマンドがインポート中に追加されると、スイッチ プロファイルが保存されていないままになり、スイッチはスイッチ プロファイル インポート モードのままになります。 abort コマンドを入力してインポートを停止します。 スイッチ プロファイルのインポートの詳細については、「スイッチ プロファイル インポート モード」の項を参照してください。

        手順の概要

          1.    config sync

          2.    switch-profile name

          3.    import {interface port/slot | running-config [exclude interface ethernet]}

          4.    commit

          5.    (任意) abort

          6.    exit

          7.    (任意) show switch-profile

          8.    (任意) copy running-config startup-config


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 config sync


          例:
          switch# config sync
          switch(config-sync)#
           

          コンフィギュレーション同期モードを開始します。

           
          ステップ 2 switch-profile name


          例:
          switch(config-sync)# switch-profile abc
          switch(config-sync-sp)#
           

          スイッチ プロファイルを設定し、スイッチ プロファイルの名前を設定し、スイッチ プロファイル同期コンフィギュレーション モードを開始します。

           
          ステップ 3 import {interface port/slot | running-config [exclude interface ethernet]}


          例:
          switch(config-sync-sp)# import ethernet 1/2
          switch(config-sync-sp-import)#
           

          インポートするコマンドを識別し、スイッチ プロファイル インポート モードを開始します。

          • <CR>:選択したコマンドを追加します。
          • interface:指定したインターフェイスのサポートされるコマンドを追加します。
          • running-config:サポートされるシステムレベル コマンドを追加します。
          • running-config exclude interface ethernet:物理インターフェイス コマンドを除く、サポートされるシステムレベル コマンドを追加します。
           
          ステップ 4 commit


          例:
          switch(config-sync-sp-import)# commit
          
           

          コマンドをインポートし、スイッチ プロファイルにコマンドを保存します。

           
          ステップ 5 abort


          例:
          switch(config-sync-sp-import)# abort
          
           
          (任意)

          インポート プロセスを中止します。

           
          ステップ 6 exit


          例:
          switch(config-sync-sp)# exit
          switch#
           

          スイッチ プロファイル インポート モードを終了します。

           
          ステップ 7 show switch-profile


          例:
          switch# show switch-profile
          
           
          (任意)

          スイッチ プロファイル コンフィギュレーションを表示します。

           
          ステップ 8 copy running-config startup-config


          例:
          switch# copy running-config startup-config
           
          (任意)

          実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

           

          次に、sp というスイッチ プロファイルに、イーサネット インターフェイス コマンドを除く、サポートされるシステムレベル コマンドをインポートする例を示します。

          switch(config-vlan)# conf sync
          switch(config-sync)# switch-profile sp
          Switch-Profile started, Profile ID is 1
          switch(config-sync-sp)# show switch-profile buffer
           
          switch-profile  : sp
          ----------------------------------------------------------
          Seq-no  Command
          ----------------------------------------------------------
           
          switch(config-sync-sp)# import running-config exclude interface ethernet
          switch(config-sync-sp-import)#
          switch(config-sync-sp-import)# show switch-profile buffer
           
          switch-profile  : sp
          ----------------------------------------------------------
          Seq-no  Command
          ----------------------------------------------------------
          3       vlan 100-299
          4       vlan 300
          4.1       state suspend
          5       vlan 301-345
          6       interface port-channel100
          6.1       spanning-tree port type network
          7       interface port-channel105
           
          switch(config-sync-sp-import)#
          

          vPC トポロジでの設定のインポート

          2 スイッチ vPC トポロジで設定をインポートできます。


          (注)  


          次の手順の詳細については、この章の該当する項を参照してください。


          1. 両方のスイッチで、同じ名前を持つスイッチ プロファイルを設定します。
          2. 両方のスイッチに設定を個別にインポートします。

            (注)  


            両方のスイッチで、スイッチ プロファイルに移動された設定が同じであることを確認します。同じでない場合、マージ チェックの障害が発生する場合があります。


          3. sync-peer destination コマンドを入力してスイッチを設定します。
          4. 適切な show コマンドを入力して、スイッチ プロファイルが同一であることを確認します。

          スイッチ プロファイルのコマンドの確認

          スイッチ プロファイル モードで verify コマンドを入力し、スイッチ プロファイルに含まれるコマンドを確認できます。

          手順の概要

            1.    config sync

            2.    switch-profile name

            3.    verify

            4.    exit

            5.    (任意) copy running-config startup-config


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 config sync


            例:
            switch# config sync
            switch(config-sync)#
             

            コンフィギュレーション同期モードを開始します。

             
            ステップ 2 switch-profile name


            例:
            switch(config-sync)# switch-profile abc
            switch(config-sync-sp)#
             

            スイッチ プロファイルを設定し、スイッチ プロファイルの名前を設定し、スイッチ プロファイル同期コンフィギュレーション モードを開始します。

             
            ステップ 3 verify


            例:
            switch(config-sync-sp)# verify
             

            スイッチ プロファイル バッファ内のコマンドを確認します。

             
            ステップ 4 exit


            例:
            switch(config-sync-sp)# exit
            switch#
             

            スイッチ プロファイル コンフィギュレーション モードを終了します。

             
            ステップ 5 copy running-config startup-config


            例:
            switch# copy running-config startup-config
             
            (任意)

            実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

             

            ピア スイッチの分離

            スイッチ プロファイルを変更するためにピア スイッチを分離できます。 このプロセスは、設定の同期をブロックする場合、または設定をデバッグするときに使用できます。

            ピア スイッチを分離するには、スイッチ プロファイルからスイッチを削除し、スイッチ プロファイルにピア スイッチを追加する必要があります。


            (注)  


            次の手順の詳細については、この章の該当する項を参照してください。


            一時的にピア スイッチを分離するには、次の手順を実行します。

            1. スイッチ プロファイルからピア スイッチを削除します。
            2. スイッチ プロファイルを変更して、変更をコミットします。
            3. debug コマンドを入力します。
            4. 手順 2 でスイッチ プロファイル対して行った変更を元に戻し、コミットします。
            5. スイッチ プロファイルにピア スイッチを追加します。

            スイッチ プロファイルの削除

            all-config または local-config オプションを選択してスイッチ プロファイルを削除できます。

            • all-config:両方のピア スイッチでスイッチ プロファイルを削除します(両方が到達可能な場合)。 このオプションを選択し、ピアの 1 つが到達不能である場合、ローカル スイッチ プロファイルだけが削除されます。 all-config オプションは両方のピア スイッチでスイッチ プロファイルを完全に削除します。
            • local-config:ローカル スイッチのみのスイッチ プロファイルを削除します。
            手順の概要

              1.    config sync

              2.    no switch-profile name {all-config | local-config}

              3.    exit

              4.    (任意) copy running-config startup-config


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 config sync


              例:
              switch# config sync
              switch(config-sync)#
               

              コンフィギュレーション同期モードを開始します。

               
              ステップ 2 no switch-profile name {all-config | local-config}


              例:
              switch(config-sync)# no switch-profile abc local-config
              switch(config-sync-sp)#
               

              次の手順に従って、スイッチ プロファイルを削除します。

              • all-config:ローカル スイッチおよびピア スイッチのスイッチ プロファイルを削除します。 ピア スイッチが到達可能でない場合は、ローカル スイッチ プロファイルだけが削除されます。
              • local-config:スイッチ プロファイルおよびローカル コンフィギュレーションを削除します。
               
              ステップ 3 exit


              例:
              switch(config-sync-sp)# exit
              switch#
               

              コンフィギュレーション同期モードを終了します。

               
              ステップ 4 copy running-config startup-config


              例:
              switch# copy running-config startup-config
               
              (任意)

              実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

               

              スイッチ プロファイルからのスイッチの削除

              スイッチ プロファイルからスイッチを削除できます。

              手順の概要

                1.    config sync

                2.    switch-profile name

                3.    no sync-peers destination destination IP

                4.    exit

                5.    (任意) show switch-profile

                6.    (任意) copy running-config startup-config


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1 config sync


                例:
                switch# config sync
                switch(config-sync)#
                 

                コンフィギュレーション同期モードを開始します。

                 
                ステップ 2 switch-profile name


                例:
                switch(config-sync)# switch-profile abc
                switch(config-sync-sp)#
                 

                スイッチ プロファイルを設定し、スイッチ プロファイルの名前を設定し、スイッチ プロファイル同期コンフィギュレーション モードを開始します。

                 
                ステップ 3 no sync-peers destination destination IP


                例:
                switch(config-sync-sp)# no sync-peers destination 10.1.1.1
                switch(config-sync-sp)#
                 

                スイッチ プロファイルから指定のスイッチを削除します。

                 
                ステップ 4 exit


                例:
                switch(config-sync-sp)# exit
                switch#
                 

                スイッチ プロファイル コンフィギュレーション モードを終了します。

                 
                ステップ 5 show switch-profile


                例:
                switch# show switch-profile
                 
                (任意)

                スイッチ プロファイル コンフィギュレーションを表示します。

                 
                ステップ 6 copy running-config startup-config


                例:
                switch# copy running-config startup-config
                 
                (任意)

                実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                 

                スイッチ プロファイル バッファの表示

                手順の概要

                  1.    switch# configure sync

                  2.    switch(config-sync) # switch-profile profile-name

                  3.    switch(config-sync-sp) # show switch-profileprofile-name buffer


                手順の詳細
                   コマンドまたはアクション目的
                  ステップ 1switch# configure sync 

                  コンフィギュレーション同期モードを開始します。

                   
                  ステップ 2switch(config-sync) # switch-profile profile-name 

                  指定されたスイッチ プロファイルに対するスイッチ プロファイル同期コンフィギュレーション モードを開始します。

                   
                  ステップ 3switch(config-sync-sp) # show switch-profileprofile-name buffer 

                  指定されたインターフェイスに対するインターフェイス スイッチ プロファイル同期コンフィギュレーション モードを開始します。

                   

                  次に、sp という名前のサービス プロファイルのスイッチ プロファイル バッファの表示例を示します。

                  switch# configure sync
                  Enter configuration commands, one per line.  End with CNTL/Z.
                  switch(config-sync)# switch-profile sp
                  Switch-Profile started, Profile ID is 1 
                  switch(config-sync-sp)# show switch-profile sp buffer
                  ----------------------------------------------------------
                  Seq-no  Command
                  ----------------------------------------------------------
                  1       vlan 101
                  1.1       ip igmp snooping querier 10.101.1.1
                  2       mac address-table static 0000.0000.0001 vlan 101 drop
                  3       interface Ethernet1/2
                  3.1       switchport mode trunk
                  3.2       switchport trunk allowed vlan 101
                  
                  switch(config-sync-sp)# buffer-move 3 1
                  switch(config-sync-sp)# show switch-profile sp buffer
                  ----------------------------------------------------------
                  Seq-no  Command
                  ----------------------------------------------------------
                  1       interface Ethernet1/2
                  1.1       switchport mode trunk
                  1.2       switchport trunk allowed vlan 101
                  2       vlan 101
                  2.1       ip igmp snooping querier 10.101.1.1
                  3       mac address-table static 0000.0000.0001 vlan 101 drop
                  switch(config-sync-sp)# 

                  スイッチのリブート後のコンフィギュレーションの同期化

                  スイッチ プロファイルを使用してピア スイッチで新しい設定をコミット中に Cisco Nexus シリーズ スイッチがリブートする場合、リロード後にピア スイッチを同期するには、次の手順を実行します。

                  手順の概要

                    1.    リブート中にピア スイッチ上で変更された設定を再適用します。

                    2.    commit コマンドを入力します。

                    3.    設定が正しく適用されており、両方のピアが同期されていることを確認します。


                  手順の詳細
                    ステップ 1   リブート中にピア スイッチ上で変更された設定を再適用します。
                    ステップ 2   commit コマンドを入力します。
                    ステップ 3   設定が正しく適用されており、両方のピアが同期されていることを確認します。

                    スイッチ プロファイル設定の show コマンド

                    次の show コマンドは、スイッチ プロファイルに関する情報を表示します。

                    コマンド 目的
                    show switch-profile name スイッチ プロファイル中のコマンドを表示します。
                    show switch-profile name buffer スイッチ プロファイル中のコミットされていないコマンド、移動されたコマンド、削除されたコマンドを表示します。
                    show switch-profile name peer IP-address ピア スイッチの同期ステータスが表示されます。
                    show switch-profile name session-history 最後の 20 のスイッチ プロファイル セッションのステータスを表示します。
                    show switch-profile name status ピア スイッチのコンフィギュレーション同期ステータスを表示します。
                    show running-config expand-port-profile ポート プロファイルについての詳細が表示されます。
                    show running-config exclude-provision オフラインで事前プロビジョニングされた非表示のインターフェイスの設定を表示します。
                    show running-config switch-profile ローカル スイッチのスイッチ プロファイルの実行コンフィギュレーションを表示します。
                    show startup-config switch-profile ローカル スイッチのスイッチ プロファイルのスタートアップ コンフィギュレーションを表示します。

                    これらのコマンドの出力フィールドの詳細については、『Cisco Nexus 5000 Series Command Reference』を参照してください。

                    スイッチ プロファイルの設定例

                    ローカルおよびピア スイッチでのスイッチ プロファイルの作成例

                    次に、ローカルおよびピア スイッチで正常にスイッチ プロファイル設定を作成する例を示します。これには QoS ポリシー(vPC ピアリンクおよびスイッチ プロファイル中の vPC)の設定が含まれます

                    手順の概要

                      1.    ローカルおよびピア スイッチで CFSoIP 配信をイネーブルにします。

                      2.    ローカルおよびピア スイッチでスイッチ プロファイルを作成します。

                      3.    スイッチ プロファイルが、ローカルおよびピア スイッチで同じであることを確認します。

                      4.    ローカル スイッチでスイッチ プロファイルにコンフィギュレーション コマンドを追加します。 コマンドがコミットされたときに、コマンドがピア スイッチに適用されます。

                      5.    バッファ リングされたコマンドを表示します。

                      6.    スイッチ プロファイルのコマンドを検証します。

                      7.    スイッチ プロファイルにコマンドを適用し、ローカルとピア スイッチ間の設定を同期させます。


                    手順の詳細
                       コマンドまたはアクション目的
                      ステップ 1ローカルおよびピア スイッチで CFSoIP 配信をイネーブルにします。

                      例:
                      switch# configuration terminal
                      switch(config)# cfs ipv4 distribute
                       
                       
                      ステップ 2ローカルおよびピア スイッチでスイッチ プロファイルを作成します。

                      例:
                      switch(config-sync)# switch-profile abc 
                      switch(config-sync-sp)# sync-peers destination 10.1.1.1
                       
                       
                      ステップ 3 スイッチ プロファイルが、ローカルおよびピア スイッチで同じであることを確認します。

                      例:
                      switch(config-sync-sp)# show switch-profile abc status
                       
                      Start-time:  15801 usecs after Mon Aug 23 06:21:08 2010
                      End-time:   6480 usecs after Mon Aug 23 06:21:13 2010
                       
                      Profile-Revision: 1
                      Session-type: Initial-Exchange
                      Peer-triggered: Yes
                      Profile-status: Sync Success
                       
                      Local information:
                      ----------------
                      Status: Commit Success
                      Error(s):
                       
                      Peer information:
                      ----------------
                      IP-address: 10.1.1.1
                      Sync-status: In Sync.
                      Status: Commit Success
                      Error(s):
                      
                       
                       
                      ステップ 4ローカル スイッチでスイッチ プロファイルにコンフィギュレーション コマンドを追加します。 コマンドがコミットされたときに、コマンドがピア スイッチに適用されます。

                      例:
                      switch(config-sync-sp)# class-map type qos c1 
                      switch(config-sync-sp-cmap-qos)# match cos 2 
                      switch(config-sync-sp-cmap-qos)# class-map type qos c2 
                      switch(config-sync-sp-cmap-qos)# match cos 5 
                      switch(config-sync-sp-cmap-qos)# policy-map type qos p1 
                      switch(config-sync-sp-pmap-qos)# class c1 
                      switch(config-sync-sp-pmap-c-qos)# set qos-group 2 
                      switch(config-sync-sp-pmap-c-qos)# class c2 
                      switch(config-sync-sp-pmap-c-qos)# set qos-group 3 
                      switch(config-sync-sp-pmap-c-qos)# system qos 
                      switch(config-sync-sp-sys-qos)# service-policy type qos input p1 
                      switch(config-sync-sp-sys-qos)# vlan 1-50 
                      switch(config-sync-sp-vlan)# interface port-channel 100 
                      switch(config-sync-sp-if)# vpc peer-link 
                      switch(config-sync-sp-if)# switchport mode trunk 
                      switch(config-sync-sp-if)# interface port-channel 10 
                      switch(config-sync-sp-if)# vpc 1 
                      switch(config-sync-sp-if)# switchport mode trunk 
                      switch(config-sync-sp-if)# switchport trunk allowed vlan 1, 10-50
                      
                       
                       
                      ステップ 5 バッファ リングされたコマンドを表示します。

                      例:
                      switch(config-sync-sp-if)# show switch-profile switch-profile buffer
                      ----------------------------------------------------------
                      Seq-no  Command
                      ----------------------------------------------------------
                      1       class-map type qos match-all c1
                      1.1       match cos 2
                      2       class-map type qos match-all c2
                      2.1       match cos 5
                      3       policy-map type qos p1
                      3.1       class c1
                      3.1.1       set qos-group 2
                      3.2       class c2
                      3.2.1       set qos-group 3
                      4       system qos
                      4.1       service-policy type qos input p1
                      5       vlan 2-50
                      6       interface port-channel100
                      6.1       vpc peer-link
                      6.2       switchport mode trunk
                      7       interface port-channel10
                      7.1       vpc 1
                      7.2       switchport mode trunk
                      7.3       switchport trunk allowed vlan 1, 10-50
                      
                       
                       
                      ステップ 6 スイッチ プロファイルのコマンドを検証します。

                      例:
                      switch(config-sync-sp-if)# verify
                      Verification Successful
                      
                       
                       
                      ステップ 7 スイッチ プロファイルにコマンドを適用し、ローカルとピア スイッチ間の設定を同期させます。

                      例:
                      switch(config-sync-sp)# commit
                      Commit Successful
                      switch(config-sync)#
                      
                       
                       

                      同期ステータスの確認例

                      次に、ローカルとピア スイッチ間の同期ステータスを確認する例を示します。

                      手順の概要

                        1.    show switch-profile switch-profile status コマンドを入力します。


                      手順の詳細
                         コマンドまたはアクション目的
                        ステップ 1 show switch-profile switch-profile status コマンドを入力します。


                        例:
                        switch(config-sync)# show switch-profile switch-profile status
                         
                        Start-time: 804935 usecs after Mon Aug 23 06:41:10 2010
                        End-time: 956631 usecs after Mon Aug 23 06:41:20 2010
                         
                        Profile-Revision: 2
                        Session-type: Commit
                        Peer-triggered: No
                        Profile-status: Sync Success
                         
                        Local information:
                        ----------------
                        Status: Commit Success
                        Error(s):
                         
                        Peer information:
                        ----------------
                        IP-address: 10.1.1.1
                        Sync-status: In Sync.
                        Status: Commit Success
                        Error(s):
                         
                        switch(config-sync)# 
                        
                         
                         

                        実行コンフィギュレーションの表示

                        次に、ローカル スイッチでスイッチ プロファイルの実行コンフィギュレーションを表示する例を示します。

                        switch# configure sync
                        switch(config-sync)# show running-config switch-profile
                        switch-profile sp
                          sync-peers destination 10.1.1.1
                          class-map type qos match-all c1
                            match cos 2
                          class-map type qos match-all c2
                            match cos 5
                          policy-map type qos p1
                            class c1
                              set qos-group 2
                            class c2
                              set qos-group 3
                          system qos
                            service-policy type qos input p1
                          vlan 2-50
                         
                          interface port-channel10
                            switchport mode trunk
                            vpc 1
                            switchport trunk allowed vlan 1,10-50
                         
                          interface port-channel100
                            switchport mode trunk
                            vpc peer-link
                        switch(config-sync)#
                        

                        ローカル スイッチとピア スイッチ間のスイッチ プロファイルの同期の表示

                        次に、2 台のピア スイッチの同期ステータスを表示する例を示します。

                        switch1# show switch-profile sp status
                        
                        Start-time: 491815 usecs after Thu Aug 12 11:54:51 2010
                        End-time: 449475 usecs after Thu Aug 12 11:54:58 2010
                        
                        Profile-Revision: 1
                        Session-type: Initial-Exchange
                        Peer-triggered: No
                        Profile-status: Sync Success
                        
                        Local information:
                        ----------------
                        Status: Commit Success
                        Error(s): 
                        
                        Peer information:
                        ----------------
                        IP-address: 10.193.194.52
                        Sync-status: In Sync.
                        Status: Commit Success
                        Error(s): 
                        
                        switch1# 
                        
                        
                        switch2# show switch-profile sp status
                        
                        Start-time: 503194 usecs after Thu Aug 12 11:54:51 2010
                        End-time: 532989 usecs after Thu Aug 12 11:54:58 2010
                        
                        Profile-Revision: 1
                        Session-type: Initial-Exchange
                        Peer-triggered: Yes
                        Profile-status: Sync Success
                        
                        Local information:
                        ----------------
                        Status: Commit Success
                        Error(s): 
                        
                        Peer information:
                        ----------------
                        IP-address: 10.193.194.51
                        Sync-status: In Sync.
                        Status: Commit Success
                        Error(s): 
                        
                        switch2# 
                        

                        ローカル スイッチとピア スイッチでの確認とコミットの表示

                        次に、ローカル スイッチおよびピア スイッチで正常に確認とコミットを設定する例を示します。

                        switch1# configure sync
                        Enter configuration commands, one per line.  End with CNTL/Z.
                        switch1(config-sync)# switch-profile sp
                        Switch-Profile started, Profile ID is 1
                        switch1(config-sync-sp)# interface ethernet1/1
                        switch1(config-sync-sp-if)# description foo
                        switch1(config-sync-sp-if)# verify
                        Verification Successful
                        switch1(config-sync-sp)# commit
                        Commit Successful
                        switch1(config-sync)# show running-config switch-profile
                        switch-profile sp
                          sync-peers destination 10.193.194.52
                          interface Ethernet1/1
                            description foo
                        switch1(config-sync)# show switch-profile sp status
                        
                        Start-time: 171513 usecs after Wed Aug 11 17:51:28 2010
                        End-time: 676451 usecs after Wed Aug 11 17:51:43 2010
                        
                        Profile-Revision: 3
                        Session-type: Commit
                        Peer-triggered: No
                        Profile-status: Sync Success
                        
                        Local information:
                        ----------------
                        Status: Commit Success
                        Error(s): 
                        
                        Peer information:
                        ----------------
                        IP-address: 10.193.194.52
                        Sync-status: In Sync.
                        Status: Commit Success
                        Error(s): 
                        
                        switch1(config-sync)# 
                        
                        
                        switch2# show running-config switch-profile
                        switch-profile sp
                          sync-peers destination 10.193.194.51
                          interface Ethernet1/1
                            description foo
                        switch2# show switch-profile sp status
                        
                        Start-time: 265716 usecs after Wed Aug 11 16:51:28 2010
                        End-time: 734702 usecs after Wed Aug 11 16:51:43 2010
                        
                        Profile-Revision: 3
                        Session-type: Commit
                        Peer-triggered: Yes
                        Profile-status: Sync Success
                        
                        Local information:
                        ----------------
                        Status: Commit Success
                        Error(s): 
                        
                        Peer information:
                        ----------------
                        IP-address: 10.193.194.51
                        Sync-status: In Sync.
                        Status: Commit Success
                        Error(s): 
                        
                        switch2# 
                        

                        同期の成功と失敗の例

                        次に、ピア スイッチでのスイッチ プロファイルの同期の成功例を示します。

                        switch# show switch-profile abc peer
                        
                        switch# show switch-profile sp peer 10.193.194.52
                        Peer-sync-status           : In Sync.
                        Peer-status                : Commit Success
                        Peer-error(s)              : 
                        switch1# 

                        次に、到達不能ステータスのピアを使用した、ピア スイッチでのスイッチ プロファイルの同期の失敗例を示します。

                        switch# show switch-profile sp peer 10.193.194.52
                        Peer-sync-status           : Not yet merged. pending-merge:1 received_merge:0
                        Peer-status                : Peer not reachable
                        Peer-error(s)              : 
                        switch# 

                        スイッチ プロファイル バッファの設定、バッファ移動、およびバッファの削除

                        次に、スイッチ プロファイル バッファの設定、バッファ移動、バッファ削除を設定する例を示します。

                        switch# configure sync
                        Enter configuration commands, one per line.  End with CNTL/Z.
                        switch(config-sync)# switch-profile sp
                        Switch-Profile started, Profile ID is 1
                        switch(config-sync-sp)# vlan 101
                        switch(config-sync-sp-vlan)# ip igmp snooping querier 10.101.1.1
                        switch(config-sync-sp-vlan)# exit
                        switch(config-sync-sp)# mac address-table static 0000.0000.0001 vlan 101 drop 
                        switch(config-sync-sp)# interface ethernet1/2
                        switch(config-sync-sp-if)# switchport mode trunk 
                        switch(config-sync-sp-if)# switchport trunk allowed vlan 101
                        switch(config-sync-sp-if)# exit
                        switch(config-sync-sp)# show switch-profile sp buffer
                        ----------------------------------------------------------
                        Seq-no  Command
                        ----------------------------------------------------------
                        1       vlan 101
                        1.1       ip igmp snooping querier 10.101.1.1
                        2       mac address-table static 0000.0000.0001 vlan 101 drop
                        3       interface Ethernet1/2
                        3.1       switchport mode trunk
                        3.2       switchport trunk allowed vlan 101
                        
                        switch(config-sync-sp)# buffer-move 3 1
                        switch(config-sync-sp)# show switch-profile sp buffer
                        ----------------------------------------------------------
                        Seq-no  Command
                        ----------------------------------------------------------
                        1       interface Ethernet1/2
                        1.1       switchport mode trunk
                        1.2       switchport trunk allowed vlan 101
                        2       vlan 101
                        2.1       ip igmp snooping querier 10.101.1.1
                        3       mac address-table static 0000.0000.0001 vlan 101 drop
                        
                        switch(config-sync-sp)# buffer-delete 1
                        switch(config-sync-sp)# show switch-profile sp buffer
                        ----------------------------------------------------------
                        Seq-no  Command
                        ----------------------------------------------------------
                        2       vlan 101
                        2.1       ip igmp snooping querier 10.101.1.1
                        3       mac address-table static 0000.0000.0001 vlan 101 drop
                        
                        switch(config-sync-sp)# buffer-delete all
                        switch(config-sync-sp)# show switch-profile sp buffer
                        switch(config-sync-sp)# 
                        

                        設定のインポート

                        次に、インターフェイス コンフィギュレーションをインポートする例を示します。

                        switch# show running-config interface ethernet1/3
                        
                        !Command: show running-config interface Ethernet1/3
                        !Time: Wed Aug 11 18:12:44 2010
                        
                        version 5.0(2)N1(1)
                        
                        interface Ethernet1/3
                          switchport mode trunk
                          switchport trunk allowed vlan 1-100
                        
                        switch# configure sync 
                        Enter configuration commands, one per line.  End with CNTL/Z.
                        switch(config-sync)# switch-profile sp
                        Switch-Profile started, Profile ID is 1
                        
                        switch(config-sync-sp)# import interface Ethernet1/3
                        switch(config-sync-sp-import)# show switch-profile sp buffer
                        ----------------------------------------------------------
                        Seq-no  Command
                        ----------------------------------------------------------
                        1       interface Ethernet1/3
                        1.1       switchport mode trunk
                        1.2       switchport trunk allowed vlan 1-100
                        
                        switch(config-sync-sp-import)# verify
                        Verification Successful
                        switch(config-sync-sp-import)# commit
                        Commit Successful
                        switch(config-sync)# 
                        

                        次に、実行コンフィギュレーションにサポートされるコマンドをインポートする例を示します。

                        switch(config-sync)# switch-profile sp
                        Switch-Profile started, Profile ID is 1
                        switch(config-sync-sp)# import running-config 
                        switch(config-sync-sp-import)# show switch-profile sp buffer
                        ----------------------------------------------------------
                        Seq-no  Command
                        ----------------------------------------------------------
                        1       logging event link-status default
                        2       vlan 1
                        3       port-profile type ethernet pp1
                        3.1       bandwidth 5000
                        3.2       bandwidth inherit
                        3.3       speed 10000
                        3.4       state enabled
                        4       interface port-channel3
                        4.1       switchport mode trunk
                        4.2       vpc peer-link
                        4.3       spanning-tree port type network
                        5       interface port-channel30
                        5.1       switchport mode trunk
                        5.2       vpc 30
                        5.3       switchport trunk allowed vlan 2-10
                        6       interface port-channel31
                        6.1       switchport mode trunk
                        6.2       vpc 31
                        6.3       switchport trunk allowed vlan 11-20
                        7       interface port-channel101
                        7.1       switchport mode fex-fabric
                        7.2       fex associate 101
                        8       interface port-channel102
                        8.1       switchport mode fex-fabric
                        8.2       vpc 102
                        8.3       fex associate 102
                        9       interface port-channel103
                        9.1       switchport mode fex-fabric
                        9.2       vpc 103
                        9.3       fex associate 103
                        10      interface Ethernet1/1
                        11      interface Ethernet1/2
                        12      interface Ethernet1/3
                        13      interface Ethernet1/4
                        13.1      switchport mode trunk
                        13.2      channel-group 3
                        14      interface Ethernet1/5
                        14.1      switchport mode trunk
                        14.2      channel-group 3
                        15      interface Ethernet1/6
                        15.1      switchport mode trunk
                        15.2      channel-group 3
                        16      interface Ethernet1/7
                        16.1      switchport mode trunk
                        16.2      channel-group 3
                        17      interface Ethernet1/8
                        18      interface Ethernet1/9
                        18.1      switchport mode trunk
                        18.2      switchport trunk allowed vlan 11-20
                        18.3      channel-group 31 mode active
                        19      interface Ethernet1/10
                        19.1      switchport mode trunk
                        19.2      switchport trunk allowed vlan 11-20
                        19.3      channel-group 31 mode active
                        20      interface Ethernet1/11
                        21      interface Ethernet1/12
                        ...
                        45      interface Ethernet2/4
                        45.1      fex associate 101
                        45.2      switchport mode fex-fabric
                        45.3      channel-group 101
                        46      interface Ethernet2/5
                        46.1      fex associate 101
                        46.2      switchport mode fex-fabric
                        46.3      channel-group 101
                        47      interface Ethernet2/6
                        47.1      fex associate 101
                        47.2      switchport mode fex-fabric
                        47.3      channel-group 101
                        48      interface Ethernet2/7
                        48.1      fex associate 101
                        48.2      switchport mode fex-fabric
                        48.3      channel-group 101
                        49      interface Ethernet2/8
                        49.1      fex associate 101
                        ...
                        89      interface Ethernet100/1/32
                        90      interface Ethernet100/1/33
                        91      interface Ethernet100/1/34
                        92      interface Ethernet100/1/35
                        93      interface Ethernet100/1/36
                        ...
                        105     interface Ethernet100/1/48
                        switch(config-sync-sp-import)# 
                        

                        次に、選択したサポートされているコマンドをインポートする例を示します。 最初に、インポートしようとしているコンフィギュレーションを識別するため、ポート プロファイルの実行コンフィギュレーションを表示します。

                        switch# show running-config port-profile 
                        
                        !Command: show running-config port-profile
                        !Time: Thu Aug 12 12:09:11 2010
                        
                        version 5.0(2)N1(1)
                        port-profile type ethernet pp1
                          bandwidth 5000
                          bandwidth inherit
                          speed 10000
                          state enabled
                        
                        switch# 
                        
                        switch# configure sync
                        Enter configuration commands, one per line.  End with CNTL/Z.
                        switch(config-sync)# switch-profile sp
                        Switch-Profile started, Profile ID is 1
                        switch(config-sync-sp)# import
                        switch(config-sync-sp-import)# port-profile type ethernet pp1
                        switch(config-sync-sp-import-if)# bandwidth 5000
                        switch(config-sync-sp-import-if)# bandwidth inherit
                        switch(config-sync-sp-import-if)# speed 10000
                        switch(config-sync-sp-import-if)# state enabled
                        switch(config-sync-sp-import-if)# show switch-profile sp buffer
                        ----------------------------------------------------------
                        Seq-no  Command
                        ----------------------------------------------------------
                        1       port-profile type ethernet pp1
                        1.1       bandwidth 5000
                        1.2       bandwidth inherit
                        1.3       speed 10000
                        1.4       state enabled
                        
                        switch(config-sync-sp-import-if)# verify
                        Verification Successful
                        switch(config-sync-sp-import)# commit
                        Commit Successful
                        switch(config-sync)# show running-config switch-profile 
                        switch-profile sp
                          sync-peers destination 10.193.194.52
                          port-profile type ethernet pp1
                            bandwidth 5000
                            bandwidth inherit
                            speed 10000
                            state enabled
                        switch(config-sync)# 
                        

                        import コマンドを使用したサンプル移行

                        ファブリック エクステンダ A-A トポロジでの Cisco NX-OS Release 5.0(2)N1(1) の移行例

                        次に、ファブリック エクステンダ A-A トポロジで Cisco NX-OS Release 5.0(2)N1(1) に移行するために使用するタスクを示します。 タスクの詳細については、この章の該当する項を参照してください。

                        手順の概要

                          1.    設定が両方のスイッチで同じであることを確認します。

                          2.    両方のスイッチで、同じ名前を持つスイッチ プロファイルを設定します。

                          3.    両方のスイッチで import running config コマンドを入力します。

                          4.    switch-profile name buffer コマンドを入力し、すべての設定が両方のスイッチで正しくインポートされていることを確認します。

                          5.    バッファを編集して不要な設定を削除します。

                          6.    両方のスイッチで commit コマンドを入力します。

                          7.    両方のスイッチでピア スイッチを設定するには、sync-peers destination IP-address コマンドを入力します。

                          8.    両方のスイッチが同期されていることを確認するには、switch-profile name status コマンドを入力します。


                        手順の詳細
                          ステップ 1   設定が両方のスイッチで同じであることを確認します。
                          ステップ 2   両方のスイッチで、同じ名前を持つスイッチ プロファイルを設定します。
                          ステップ 3   両方のスイッチで import running config コマンドを入力します。
                          ステップ 4   switch-profile name buffer コマンドを入力し、すべての設定が両方のスイッチで正しくインポートされていることを確認します。
                          ステップ 5   バッファを編集して不要な設定を削除します。

                          詳細については、例:スイッチ プロファイル バッファの設定、バッファ移動、およびバッファの削除を参照してください。

                          ステップ 6   両方のスイッチで commit コマンドを入力します。
                          ステップ 7   両方のスイッチでピア スイッチを設定するには、sync-peers destination IP-address コマンドを入力します。
                          ステップ 8   両方のスイッチが同期されていることを確認するには、switch-profile name status コマンドを入力します。

                          ファブリック エクステンダのストレート型トポロジでの Cisco NX-OS Release 5.0(2)N1(1) の移行例

                          次に、ファブリック エクステンダのストレート型トポロジで Cisco NX-OS Release 5.0(2)N1(1) に移行するために使用するタスクを示します。 タスクの詳細については、この章の該当する項を参照してください。

                          手順の概要

                            1.    vPC ポートチャネルの設定が、両方のスイッチで同じであることを確認します。

                            2.    両方のスイッチで、同じ名前を持つスイッチ プロファイルを設定します。

                            3.    両方のスイッチのすべての vPC ポートチャネルについて、import interface port-channel x-y, port-channel z コマンドを入力します。

                            4.    show switch-profile name buffer コマンドを入力し、すべての設定が両方のスイッチで正しくインポートされていることを確認します。

                            5.    バッファを編集して不要な設定を削除します。

                            6.    両方のスイッチで commit コマンドを入力します。

                            7.    両方のスイッチでピア スイッチを設定するには、sync-peers destination IP-address コマンドを入力します。

                            8.    両方のスイッチが同期されていることを確認するには、show switch-profile name status コマンドを入力します。


                          手順の詳細
                            ステップ 1   vPC ポートチャネルの設定が、両方のスイッチで同じであることを確認します。
                            ステップ 2   両方のスイッチで、同じ名前を持つスイッチ プロファイルを設定します。
                            ステップ 3   両方のスイッチのすべての vPC ポートチャネルについて、import interface port-channel x-y, port-channel z コマンドを入力します。
                            ステップ 4   show switch-profile name buffer コマンドを入力し、すべての設定が両方のスイッチで正しくインポートされていることを確認します。
                            ステップ 5   バッファを編集して不要な設定を削除します。

                            詳細については、例:スイッチ プロファイル バッファの設定、バッファ移動、およびバッファの削除を参照してください。

                            ステップ 6   両方のスイッチで commit コマンドを入力します。
                            ステップ 7   両方のスイッチでピア スイッチを設定するには、sync-peers destination IP-address コマンドを入力します。
                            ステップ 8   両方のスイッチが同期されていることを確認するには、show switch-profile name status コマンドを入力します。