Cisco Nexus 5000 シリーズ NX-OS Fibre Channel over Ethernet コンフィギュレーション ガイド リリース 5.1(3)N1(1)
Cisco Adapter FEX with FCoE の設定
Cisco Adapter FEX with FCoE の設定
発行日;2012/07/23   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

Cisco Adapter FEX with FCoE の設定

この章の内容は、次のとおりです。

概要

Cisco Adapter FEX with FCoE 機能を使用すると、Cisco Nexus 2000 シリーズ ファブリック エクステンダ(FEX)に FCoE 接続を作成できます。これにより、Virtual Interface Card(VIC; 仮想インターフェイス カード)アダプタへの FCoE 接続を確立できるようになります。

たとえば、この機能を使用し、Cisco UCS P81E 仮想インターフェイス カード を含む Nexus スイッチを Cisco UCS C シリーズ ラックマウント サーバ に接続したり、Broadcom BCM57712 Convergence Network Interface Card(C-NIC; 統合ネットワーク インターフェイス カード)を搭載したサードパーティのサーバに接続することができます。

スイッチは、仮想ポート チャネル(vPC)を通じて FEX に接続されます。一方、FEX は、FEX と VIC アダプタ間の標準的な FCoE リンクを使用してサーバに接続されます。

注意事項および制約事項

Enhanced vPC を使用する場合、FEX は FCoE 転送を行うために 1 つの Nexus 5000 ファブリックにのみ関連付けます。

FabricPath を使用する場合は、FCoE トラフィック専用のリンクを使用する必要があります。

Cisco UCS C シリーズ ラックマウント サーバCisco UCS P81E 仮想インターフェイス カード(VIC)と使用する場合:

  • VIC はネットワーク インターフェイス仮想化(NIV)モードで構成する必要があります。これにより、2 つの集約ポートは、システムに仮想ホスト バス アダプタ(vHBA)として表示されます。
  • VIC は、VNP ポートを通じて FEX に接続できません。 このような接続が行われる場合は、VIC で NIV モードをイネーブルにできません。
  • Cisco UCS C シリーズ ラックマウント サーバ の NIC モードも アクティブ-スタンバイに設定する必要があります。

Cisco Adapter FEX with FCoE の設定

手順の概要

    1.    configure terminal

    2.    install feature-set virtualization

    3.    feature-set virtualization

    4.    fex fex-chassis-ID

    5.    fcoe

    6.    interface ethernet [fex-chassis-ID/]slot/port

    7.    switchport mode vntag

    8.    interface vethernet veth-id

    9.    bind interface ethernet [fex-chassis-ID/]slot/port channel channel-no

    10.    switchport mode {trunk|access}

    11.    (任意) switchport trunk allowed vlan vlan-ID

    12.    (任意) switchport access vlan vlan-ID

    13.    interface vfc vfc-id

    14.    bind interface vethernet veth-num

    15.    no shutdown


手順の詳細
     コマンドまたはアクション目的
    ステップ 1configure terminal


    例:
    switch# configure terminal
    switch(config)#
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2install feature-set virtualization


    例:
    switch(config) # install feature-set virtualization
    switch(config) #
     

    仮想化機能をインストールします。

     
    ステップ 3feature-set virtualization


    例:
    switch(config) # feature-set virtualization
    switch(config)#
     

    仮想化機能をイネーブルにします。

     
    ステップ 4fex fex-chassis-ID


    例:
    switch(config) # fex 101
    switch(config-fex) # 
     

    指定された FEX のコンフィギュレーション モードを開始します。

    fex-chassis_ID の範囲は 100 ~ 199 です。

     
    ステップ 5fcoe


    例:
    switch(config-fex) # fcoe
    switch(config-fex) # 
     

    FEX で Fibre Channel over Ethernet トラフィックをイネーブルにします。

     
    ステップ 6interface ethernet [fex-chassis-ID/]slot/port


    例:
    switch(config-fex)# interface ethernet 101/1/1
    switch(config-if)# 
     

    指定されたイーサネットインターフェイスのコンフィギュレーション モードを開始します。

    fex-chassis_ID の範囲は 100 ~ 199 です。 Cisco Nexus 5000 プラットフォームでは、slot は 1 である必要があります。 FCoE では、port の範囲は 1 ~ 32 です。

     
    ステップ 7switchport mode vntag


    例:
    switch(config-if) # switchport mode vntag
    switch(config-if) # 
     

    インターフェイスをポート モードで設定します。

     
    ステップ 8interface vethernet veth-id


    例:
    switch(config-if) # interface vethernet 2
    switch(config-if) # 
     

    仮想イーサネット インターフェイスを作成し、そのインターフェイスのコンフィギュレーション モードを開始します。

    veth-id の範囲は、1 ~ 1,048,575 です。

    (注)     

    冗長性を持たせるために 2 台の Cisco Nexus シリーズ スイッチがある場合は、仮想イーサネット インターフェイス ID は各スイッチで一意である必要があります。

     
    ステップ 9bind interface ethernet [fex-chassis-ID/]slot/port channel channel-no


    例:
    switch(config-if) # bind interface ethernet 101/1/1 channel 1
    switch(config-if) # 
     

    指定されたイーサネット インターフェイスを、指定されたポート チャネルにバインドします。

    fex-chassis_ID の範囲は 100 ~ 199 です。 Cisco Nexus 5000 プラットフォームでは、slot は 1 である必要があります。 FCoE では、port の範囲は 1 ~ 32 です。channel-no の範囲は 1 ~ 4096 です。

     
    ステップ 10switchport mode {trunk|access}


    例:
    switch(config-if) # switchport mode trunk
    switch(config-if) # 
     

    インターフェイスを、トランク ポートまたはアクセス ポートとして設定します。

     
    ステップ 11switchport trunk allowed vlan vlan-ID


    例:
    switch(config-if) # switchport trunk allowed vlan 33
    switch(config-if) # 
     
    (任意)

    インターフェイスをトランク ポートとして設定した場合は、このコマンドを使用し、FCoE トラフィックの VLAN を指定します。

    内部使用に予約されている VLAN を除き、vlan-ID の範囲は 1 ~ 4094 秒です。

     
    ステップ 12switchport access vlan vlan-ID


    例:
    switch(config-if) # switchport access vlan 33
    switch(config-if) # 
     
    (任意)

    インターフェイスをアクセス ポートとして設定した場合は、このコマンドを使用し、FCoE トラフィックの VLAN を指定します。

     
    ステップ 13interface vfc vfc-id


    例:
    switch(config-if) # interface vfc 4
    switch(config-if) # 
     

    スイッチに仮想ファイバ チャネル インターフェイスを作成し、コンフィギュレーション モードを開始します。

    vfc-id の範囲は、1 ~ 8192 です。

     
    ステップ 14bind interface vethernet veth-num


    例:
    switch(config-if) # bind interface veth 2
    switch(config-if) # 
     

    仮想ファイバ チャネル インターフェイスを指定された物理イーサネット インターフェイスにバインドします。

    veth-num の範囲は、1 ~ 1048575 です。

     
    ステップ 15no shutdown


    例:
    switch(config-if) # no shutdown
    switch(config-if) # 
     

    インターフェイスを、デフォルトの操作状態に戻します。

     

    この例では、FEX 101 を使用して SAN ファブリック A に Cisco Adapter FEX with FCoE を設定し、トランク ポートとして使用されるチャネル 1 にイーサネット インターフェイスを設定します。

    nexus5000-sanA(config)#configure terminal
    nexus5000-sanA(config)#install feature-set virtualization
    nexus5000-sanA(config)#feature-set virtualization
    nexus5000-sanA(config)#fex 101
    nexus5000-sanA(config-fex)#fcoe
    nexus5000-sanA(config-fex)#interface ethernet 101/1/1
    nexus5000-sanA(config-if)#switchport mode vntag
    nexus5000-sanA(config-if)#interface veth 2
    nexus5000-sanA(config-if)#bind interface eth 101/1/1 channel 1
    nexus5000-sanA(config-if)#switchport mode trunk
    nexus5000-sanA(config-if)#switchport trunk allowed vlan 33
    nexus5000-sanA(config-if)#interface vfc 4
    nexus5000-sanA(config-if)#bind interface veth 2
    nexus5000-sanA(config-if)#no shutdown
    
    

    この例では、FEX 102 を使用して SAN ファブリック B に Cisco Adapter FEX with FCoE を設定し、アクセス ポートとして使用されるチャネル 2 にイーサネット インターフェイスを設定します。

    nexus5000-sanB(config)#configure terminal
    nexus5000-sanB(config)#install feature-set virtualization
    nexus5000-sanB(config)#feature-set virtualization
    nexus5000-sanB(config)#fex 102
    nexus5000-sanB(config-fex)#fcoe
    nexus5000-sanB(config-fex)#interface ethernet 102/1/1
    nexus5000-sanB(config-if)#switchport mode vntag
    nexus5000-sanB(config-if)#interface veth 5
    nexus5000-sanB(config-if)#bind interface eth 102/1/1 channel 2
    nexus5000-sanB(config-if)#switchport mode access
    nexus5000-sanB(config-if)#switchport access vlan 40
    nexus5000-sanB(config-if)#interface vfc 6
    nexus5000-sanB(config-if)#bind interface veth 5
    nexus5000-sanB(config-if)#no shutdown