Cisco Nexus 5000 シリーズ NX-OS レイヤ 2 スイッチング コンフィギュレーション ガイド リリース 5.0(2)N2(1)
仮想ポート チャネルの設定
仮想ポート チャネルの設定
発行日;2012/08/14   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

仮想ポート チャネルの設定

この章の内容は、次のとおりです。

vPC について

vPC の概要

仮想ポート チャネル(vPC)を使用すると、物理的には 2 台の異なる Cisco Nexus 5000 シリーズ スイッチまたは Cisco Nexus 2000 シリーズ ファブリック エクステンダに接続されている複数のリンクを、第 3 のデバイスからは単一のポート チャネルとして認識されるようにすることができます(次の図を参照)。 第 3 のデバイスには、スイッチやサーバなどあらゆるネットワーキング デバイスが該当します。 Cisco NX-OS Release 4.1(3)N1(1) 以降では、ファブリック エクステンダに接続された Cisco Nexus 5000 シリーズ スイッチを含む vPC トポロジを設定することができます。 vPC では、マルチパス機能を使用することができます。この機能では、ノード間の複数のパラレル パスをイネーブルにし、さらには存在する代替パスでトラフィックのロード バランシングを行うことにより、冗長性が確保されます。

図 1. vPC のアーキテクチャ

EtherChannel の設定は、次のいずれかを使用して行います。

  • プロトコルなし
  • Link Aggregation Control Protocol(LACP)

vPC ピア リンク チャネルなど、vPC で EtherChannel を設定した場合、それぞれのスイッチでは 1 つの EtherChannel に最大 16 個のアクティブ リンクをまとめることができます。 ファブリック エクステンダ上で vPC を設定した場合、各 EtherChannel で使用できるポートは 1 つだけです。


(注)  


vPC の機能を設定したり実行したりするには、まず vPC 機能をイネーブルにする必要があります。


vPC 機能をイネーブルにするためには、vPC 機能を実現する 2 つの vPC ピア スイッチの vPC ドメインにピアキープアライブ リンクおよびピアリンクを作成する必要があります。

vPC ピア リンクを作成する場合は、まず一方の Cisco Nexus 5000 シリーズ スイッチ上で、2 つ以上の Ethernet ポートを使用して EtherChannel を設定します。 さらに他方のスイッチ上で、2 つ以上の Ethernet ポートを使用して別の EtherChannel を設定します。 これら 2 つの EtherChannel を接続することにより、vPC ピア リンクが作成されます。


(注)  


vPC ピアリンク EtherChannel はトランクとして設定することが推奨されます。


vPC ドメインには、両方の vPC ピア デバイス、vPC ピアキープアライブ リンク、vPC ピア リンク、および vPC ドメイン内にあってダウンストリーム デバイスに接続されているすべての EtherChannel が含まれます。 各 vPC ピア デバイスに設定できる vPC ドメイン ID は 1 つだけです。


(注)  


EtherChannel を使用する vPC デバイスはすべて、両方の vPC ピア デバイスに接続する必要があります。


vPC には次のような特長があります。

  • 単独のデバイスが、2 つのアップストリーム デバイスを介して EtherChannel を使用できるようになります。
  • スパニング ツリー プロトコル(STP)のブロック ポートが不要になります。
  • ループフリーなトポロジが実現されます。
  • 利用可能なすべてのアップリンク帯域幅を使用します。
  • リンクまたはスイッチに障害が発生した場合、高速コンバージェンスが実行されます。
  • リンクレベルの復元力を提供します。
  • ハイ アベイラビリティが保証されます。

用語

vPC の用語

vPC で使用される用語は、次のとおりです。

  • vPC:vPC ピア デバイスとダウンストリーム デバイスの間の結合された EtherChannel。
  • vPC ピア デバイス:vPC ピア リンクと呼ばれる特殊な EtherChannel により接続されることで対をなす個々のデバイス。
  • vPC ピア リンク:vPC ピア デバイス間の状態を同期するために使用されるリンク。
  • vPC メンバ ポート:vPC に属するインターフェイス。
  • ホスト vPC ポート:vPC に属するファブリック エクステンダのホスト インターフェイス。
  • vPC ドメイン:このドメインには、両方の vPC ピア デバイス、vPC ピアキープアライブ リンク、vPC 内にあってダウンストリーム デバイスに接続されているすべてのポート チャネルが含まれます。 また、このドメインは、vPC グローバル パラメータを割り当てるために使用する必要があるコンフィギュレーション モードに関連付けられています。 vPC ドメイン ID は、両スイッチで同じであることが必要です。
  • vPC ピアキープアライブ リンク:ピアキープアライブ リンクでは、さまざまな vPC ピア Cisco Nexus 5000 シリーズ デバイスのモニタリングが行われます。 ピアキープアライブ リンクは、vPC ピア デバイス間での設定可能なキープアライブ メッセージの定期的な送信を行います。 vPCs ピアキープアライブ リンク上を移動するデータまたは同期トラフィックはありません。このリンクを流れるトラフィックは、送信元スイッチが稼働しており、vPC を実行していることを知らせるメッセージだけです。

ファブリック エクステンダの用語

Cisco Nexus 2000 シリーズ ファブリック エクステンダで使用される用語は、次のとおりです。

  • ファブリック インターフェイス:ファブリック エクステンダから親スイッチへの接続に特化した 10 ギガビット イーサネットのアップリンク ポートです。 ファブリック インターフェイスは他の目的には使用できません。 親スイッチに直接接続する必要があります。
  • EtherChannel ファブリック インターフェイス:ファブリック エクステンダから親スイッチへの EtherChannel アップリンク接続です。 この接続は、単一論理チャネルにバンドルされているファブリック インターフェイスで構成されます。
  • ホスト インターフェイス:サーバ接続またはホスト接続に使用するイーサネット インターフェイスです。 これらのポートは、ファブリック エクステンダのモデルに応じて、1 ギガビット イーサネット インターフェイスになる場合と、10 ギガビット イーサネット インターフェイスになる場合があります。
  • EtherChannel ホスト インターフェイス:ファブリック エクステンダのホスト インターフェイスからサーバ ポートへの EtherChannel ダウンリンク接続です。

    (注)  


    リリース 4.1(3)N1(1) では、EtherChannel ホスト インターフェイスはただ 1 つのホスト インターフェイスで構成され、Link Aggregation Control Protocol(LACP)EtherChannel として設定することも非 LACP EtherChannel として設定することもできます。


サポートされている vPC トポロジ

Cisco Nexus 5000 シリーズ スイッチの vPC トポロジ

vPC では Cisco Nexus 5000 シリーズ スイッチのペア、または Cisco Nexus 5500 シリーズ スイッチのペアを、別のスイッチまたはサーバに直接接続することができます。 vPC ピア スイッチは同じタイプであることが必要です。たとえば、Nexus 5000 シリーズ スイッチ同士、または Nexus 5500 シリーズ スイッチ同士を接続することはできますが、vPC トポロジにおいて Nexus 5000 シリーズ スイッチを Nexus 5500 シリーズ スイッチに接続することはできません。Cisco Nexus 5000 シリーズ スイッチに接続できるインターフェイスは最大 8 個で、vPC ペアに対して 16 個のインターフェイスをバンドルすることができます。 次の図に示したトポロジは、10 ギガビット イーサネット アップリンク インターフェイスまたは 1 ギガビット イーサネット アップリンク インターフェイスにより接続された 2 台のスイッチまたはサーバに対して vPC 機能を実現したものです。

図 2. スイッチ間の vPC トポロジ


(注)  


Cisco Nexus 5010 スイッチの最初の 8 ポートおよび Cisco Nexus 5020 スイッチの最初の 16 ポートでは、1 ギガビット ポートと 10 ギガビット ポートとを切り替えることができます。 これらのポートに対して vPC 機能は実現する場合は、1 ギガビット モードを使用します。


Cisco Nexus 5000 シリーズ スイッチのペアに接続するスイッチには、標準ベースのイーサネット スイッチであればいずれも使用できます。 このような構成を持つ環境としては、2 台のスイッチが vPC を介して Cisco Nexus 5000 シリーズ スイッチのペアに接続されたブレード シャーシや Cisco Nexus 5000 シリーズ スイッチのペアに接続されたユニファイド コンピューティング システムなどが一般的です。

シングル ホーム ファブリック エクステンダの vPC トポロジ

下の図のように、Cisco Nexus 5000 シリーズ スイッチに接続した Cisco Nexus 2000 シリーズ ファブリック エクステンダのペアに、vPC で 2 台、4 台、またはそれ以上のネットワーク アダプタが設定されたサーバを接続することができます。 各ファブリック エクステンダには、FEX モデルに応じて、1 台以上のネットワーク アダプタ インターフェイスを接続できます。 図 10 はその具体例として、Cisco Nexus 2148T ファブリック エクステンダを使用して構成したトポロジを示したものです。サーバから各ファブリック エクステンダへのリンクはそれぞれ 1 つだけです。 Cisco Nexus 2248TP ファブリック エクステンダまたは Cisco Nexus 2232PP ファブリック エクステンダを使用したトポロジは、サーバから各ファブリック エクステンダに対して複数のリンクを設定して構成することもできます。

下図に示したトポロジでは、1 ギガビット イーサネット アップリンク インターフェイスを持つデュアル ホーム サーバに対して vPC 機能が実現されています。

図 3. シングル ホーム ファブリック エクステンダの vPC トポロジ

Cisco Nexus 5000 シリーズ スイッチは、このトポロジで最大 12 台の設定済みシングル ホーム ファブリック エクステンダ(ポート数は 576)をサポートできますが、この構成による vPC では 480 576 台のデュアル ホーム ホスト サーバを設定することかできます。


(注)  


Cisco Nexus 2148T ファブリック エクステンダは、ホスト インターフェイスでの EtherChannel はサポートしていません。 そのため、1 つの EtherChannel で設定できるサーバからのリンクは最大 2 つで、各リンクは別々のファブリック エクステンダに接続されます。


デュアル ホーム ファブリック エクステンダの vPC トポロジ

Cisco Nexus 2000 シリーズ ファブリック エクステンダを、アップストリームにある 2 台の Cisco Nexus 5000 シリーズ スイッチ、およびダウンストリームにある複数のシングル ホーム サーバに接続することができます。 次の図に示したトポロジは、1 ギガビット イーサネット アップリンク インターフェイスでそれぞれ別々に接続されたサーバに対して vPC 機能を実現したものです。

図 4. デュアルホーム接続 ファブリック エクステンダ vPC トポロジ

Cisco Nexus 5000 シリーズ スイッチは、このトポロジで最大 12 台の設定済みデュアル ホーム ファブリック エクステンダをサポートできます。 この構成では、最大 576 台のシングル ホーム サーバを接続できます。

vPC ドメイン

vPC ドメインを作成するには、まず各 vPC ピア スイッチに対し、1 ~ 1000 の範囲にある値を使用して vPC ドメイン ID を作成する必要があります。 この ID は、対象となるすべての vPC ピア デバイス上で同じであることが必要です。

EtherChannel および vPC ピア リンクは、LACP を使用するかまたはプロトコルなしのいずれかで設定できます。 LACP では EtherChannel における設定不一致の検査を実行できるため、ピアリンク上では可能な限り、LACP を使用することが推奨されます。

vPC ピア スイッチでは、設定した vPC ドメイン ID に基づいて、一意の vPC システム MAC アドレスが自動的に割り当てられます。 各 vPC ドメインには一意の MAC アドレスがあり、vPC に関連する特定の処理の際に固有識別子として使用されます。ただしスイッチで vPC システム MAC アドレスが使用されるのは、LACP などリンク関連の処理に限ります。 連続したネットワーク内の vPC ドメインはそれぞれ、一意のドメイン ID を使用して作成することが推奨されます。 ただし、Cisco NX-OS ソフトウェアでアドレスを割り当てる代わりに、vPC ドメインに特定の MAC アドレスを設定することもできます。

vPC ピア スイッチでは、設定した vPC ドメイン ID に基づいて、一意の vPC システム MAC アドレスが自動的に割り当てられます。 スイッチで vPC システム MAC アドレスが使用されるのは、LACP や BPDU などリンク関連の処理に限ります。 vPC ドメインに特定の MAC アドレスを設定することもできます。

どちらのピアにも同じ vPC ドメイン ID を設定することが推奨されます。またドメイン ID はネットワーク内で一意であることが必要です。 たとえば、2 つの異なる vPC(一方がアクセス スイッチ、もう一方が集約スイッチ)がある場合は、それぞれの vPC に固有のドメイン ID を割り当ててください。

vPC ドメインを作成すると、その vPC ドメインのシステム プライオリティが Cisco NX-OS ソフトウェアによって自動的に作成されます。 vPC ドメインに特定のシステム プライオリティを手動で設定することもできます。


(注)  


システム プライオリティを手動で設定する場合は、必ず両方の vPC ピア スイッチ上に同じプライオリティ値を割り当てるようにしてください。 両側の vPC ピア スイッチに異なるシステム プライオリティ値が割り当てられている場合、vPC は稼働しません。


ピアキープアライブ リンクとメッセージ

Cisco NX-OS ソフトウェアでは、vPC ピア間のピアキープアライブ リンクを使用して、設定可能なキープアライブ メッセージが定期的に送信されます。 これらのメッセージを送信するためには、ピア スイッチ間にレイヤ 3 接続が必要です。ピアキープアライブ リンクがアップ状態で稼働していなければ、システムでは vPC ピア リンクをアップすることができません。

一方の vPC ピア スイッチに障害が発生すると、vPC ピア リンクのもう一方の側にある vPC ピア スイッチでは、ピアキープアライブ メッセージを受信しなくなることによってその障害を検知します。 vPC ピアキープアライブ メッセージのデフォルトの時間間隔は 1 秒です。 この時間間隔は、400 ミリ秒~ 10 秒の範囲で設定することができます。 タイムアウト値は、3 ~ 20 秒の範囲内で設定可能で、デフォルトのタイムアウト値は 5 秒です。 ピアキープアライブのステータスの確認は、ピアリンクがダウンした場合にのみ行われます。

vPC ピアキープアライブは、Cisco Nexus 5000 シリーズ スイッチ上の管理 VRF でもデフォルトの VRF でも伝送できます。 管理 VRF を使用するようスイッチを設定した場合は、mgmt 0 インターフェイスの IP アドレスがキープアライブ メッセージの送信元および宛先となります。 デフォルトの VRF を使用するようスイッチを設定した場合は、vPC キープアライブ メッセージの送信元アドレスおよび宛先アドレスとしての役割を果たす SVI を作成する必要があります。 ピアキープアライブ メッセージに使用される送信元 IP アドレスと宛先 IP アドレスがどちらもネットワーク上で一意であり、かつそれらの IP アドレスがその vPC ピアキープアライブ リンクに関連付けられている VRF から到達可能であることを確認してください。


(注)  


Cisco Nexus 5000 シリーズ スイッチの vPC ピアキープアライブ リンクは、管理 VRF で mgmt 0 インターフェイスを使用して実行されるように設定することが推奨されます。 デフォルトの VRF を設定する場合は、vPC ピアキープアライブ メッセージの伝送に vPC ピア リンクが使用されないようにしてください。


vPC ピア リンクの互換パラメータ

多くの設定パラメータおよび動作パラメータが、vPC 内のすべてのインターフェイスで同じでなければなりません。 vPC 機能をイネーブルにし、さらに両方の vPC ピア スイッチ上でピア リンクを設定すると、シスコ ファブリック サービス(CFS)メッセージにより、ローカル vPC ピア スイッチに関する設定のコピーがリモート vPC ピア スイッチへ送信されます。 これによりシステムでは、2 つのスイッチ間で重要な設定パラメータに違いがないかどうか判定が行われます。

vPC 内のすべてのインターフェイスで設定されている値を表示するには、show vpc consistency-parameters コマンドを入力します。 表示される設定は、vPC ピア リンクおよび vPC の稼働を制限する可能性のある設定だけです。

vPC に関する互換性チェックのプロセスは、正規の EtherChannel に関する互換性チェックとは異なります。

同じでなければならない設定パラメータ

ここで説明する設定パラメータは、vPC ピア リンクの両側のスイッチ上で設定が同じであることが必要です。


(注)  


ここで説明する動作パラメータおよび設定パラメータは、vPC 内のすべてのインターフェイスで一致している必要があります。

vPC 内のすべてのインターフェイスで設定されている値を表示するには、show vpc consistency-parameters コマンドを入力します。 表示される設定は、vPC ピア リンクおよび vPC の稼働を制限する可能性のある設定だけです。


スイッチでは、vPC インターフェイス上でこれらのパラメータに関する互換性チェックが自動的に行われます。 インターフェイス別のパラメータはインターフェイスごとに整合性を保っていることが必要であり、グローバル パラメータはグローバルに整合性を保っていることが必要です。

  • ポート チャネル モード:on、off、active
  • チャネルごとのリンク速度
  • チャネルごとのデュプレックス モード
  • チャネルごとのトランク モード:
    • ネイティブ VLAN
    • トランク上の許可 VLAN
    • ネイティブ VLAN トラフィックのタギング
  • Spanning Tree Protocol(STP; スパニング ツリー プロトコル)モード
  • マルチ スパニング ツリーの STP 領域コンフィギュレーション(MST)
  • VLAN ごとのイネーブル/ディセーブル状態
  • STP グローバル設定:
    • Bridge Assurance 設定
    • ポート タイプ設定:vPC インターフェイスはすべて標準ポートとして設定することが推奨されます
    • ループ ガード設定
  • STP インターフェイス設定:
    • ポート タイプ設定
    • ループ ガード
    • ルート ガード
  • ファブリック エクステンダの vPC トポロジの場合、上記のインターフェイス レベル パラメータはすべて、両側スイッチのホスト インターフェイスに対して設定を同じにする必要があります。
  • EtherChannel ファブリック インターフェイス上で設定された ファブリック エクステンダの FEX 番号(ファブリック エクステンダの vPC トポロジの場合)。

これらのうち、イネーブルでないパラメータや一方のスイッチでしか定義されていないパラメータは、vPC の整合性検査では無視されます。


(注)  


どの vPC インターフェイスもサスペンド モードになっていないことを確認するには、show vpc brief コマンドおよび show vpc consistency-parameters コマンドを入力して、syslog メッセージをチェックします。


同じにすべき設定パラメータ

次に挙げるパラメータのいずれかが両側の vPC ピア スイッチ上で設定が一致しないと、誤設定に伴ってトラフィック フローに望ましくない動作が発生する可能性があります。

  • MAC エージング タイマー
  • スタティック MAC エントリ
  • VLAN インターフェイス:vPC ピア リンクの両端にある各スイッチの VLAN インターフェイスは同じ VLAN 用に設定されている必要があり、さらにそれらの管理モードおよび動作モードも同じであることが必要です。 ピア リンクの一方のスイッチでのみ設定されている VLAN では、vPC またはピア リンクを使用したトラフィックの転送は行われません。 VLAN はすべて、プライマリ vPC スイッチとセカンダリ vPC スイッチの両方で作成する必要があります。両方で作成されていない場合、VLAN は停止することになります。
  • プライベート VLAN 設定
  • ACL のすべての設定とパラメータ
  • Quality of Service(QoS)の設定およびパラメータ:ローカル パラメータです。グローバル パラメータは同じであることが必要です
  • STP インターフェイス設定:
    • BPDU フィルタ
    • BPDU ガード
    • コスト
    • リンク タイプ
    • プライオリティ
    • VLAN(Rapid PVST+)

すべての設定パラメータについて互換性があることを確認するためにも、vPC の設定後は各 vPC ピア スイッチの設定を表示することが推奨されます。

グレースフル タイプ 1 検査

Cisco NX-OS Release 5.0(2)N2(1) 以降では、整合性検査で不整合が検出された場合、セカンダリ vPC スイッチ上でのみ vPC がダウン状態になります。 プライマリ vPC スイッチ上の VLAN はアップ状態が維持されるため、トラフィックを中断することなくタイプ 1 の設定を実行することができます。 この機能は、グローバル タイプ 1 不整合の場合にも、インターフェイス別タイプ 1 不整合の場合にも使用されます。

この機能は、デュアルアクティブ FEX ポートに対しては無効です。 タイプ 1 の不一致が発生すると、両側スイッチのこれらのポートでは VLAN が停止します。

VLAN ごとの整合性検査

Cisco NX-OS Release 5.0(2)N2(1) 以降では、VLAN 上でスパニング ツリーのイネーブル/ディセーブルが切り替わるたびに、いくつかのタイプ 1 整合性検査が VLAN ごとに実行されます。 この整合性検査に合格しない VLAN は、プライマリ スイッチおよびセカンダリ スイッチでダウン状態になりますが、その他の VLAN は影響を受けません。

vPC 自動リカバリ

Cisco NX-OS Release 5.0(2)N2(1) 以降では、次のような状況が発生すると、vPC 自動リカバリ機能により vPC リンクが再イネーブル化されます。

両側の vPC ピア スイッチでリロードが実行され、かつ一方のスイッチのみリブートした場合、自動リカバリによってそのスイッチがプライマリ スイッチとして機能し、一定時間が経過した後に vPC リンクがアップ状態になります。 このシナリオにおけるリロード遅延時間は、240 ~ 3600 秒の範囲で設定できます。

ピアリンクの障害に伴ってセカンダリ vPC スイッチ上の vPC がディセーブルになり、さらにプライマリ vPC スイッチで障害が発生するか、またはトラフィックが転送できなくなると、セカンダリ スイッチでは vPC が再イネーブル化されます。 このシナリオの場合、vPC ではキープアライブが 3 回連続して検出されないのを待ってから vPC リンクが回復します。

vPC 自動リカバリ機能は、デフォルトではディセーブルです。

vPC ピア リンク

vPC ピア リンクは、vPC ピア デバイス間の状態を同期するために使用されるリンクです。


(注)  


vPC ピア リンクを設定する場合は、あらかじめピアキープアライブ リンクを設定しておく必要があります。設定しておかないと、ピア リンクは機能しません


vPC ピア リンクの概要

vPC ピアとして設定できるのは、対をなす 2 台のスイッチです。それぞれのスイッチは互いに、他方の vPC ピアに対してのみ vPC ピアとして機能します。 vPC ピア スイッチには、他のスイッチへの非 vPC リンクを設定することもできます。

適正な設定を行うため、各スイッチに EtherChannel を設定し、さらに vPC ドメインを設定します。 各スイッチの EtherChannel をピア リンクとして割り当てます。 冗長性を確保できるよう、EtherChannel には少なくとも 2 つの専用ポートを設定することが推奨されます。これにより、vPC ピア リンクのインターフェイスの 1 つに障害が発生すると、スイッチは自動的にフォールバックし、そのピア リンクの別のインターフェイスが使用されます。


(注)  


EtherChannel はトランク モードで設定することが推奨されます。


多くの動作パラメータおよび設定パラメータは、vPC ピア リンクにより接続されている各スイッチ上で同じ値であることが必要です。 各スイッチは管理プレーンから完全に独立しているため、重要なパラメータについてスイッチ同士に互換性があることを確認する必要があります。 vPC ピア スイッチには、独立したコントロール プレーンがあります。 vPC ピア リンクの設定が完了したら、各 vPC ピア スイッチの設定を表示し、それらの設定に互換性があることを確認してください。


(注)  


vPC ピア リンクによって接続されている 2 つのスイッチでは必ず、同一の動作パラメータおよび設定パラメータが設定されている必要があります。


vPC ピア リンクを設定する際、vPC ピア スイッチでは、接続されたスイッチの一方がプライマリ スイッチ、もう一方がセカンダリ スイッチとなるようにネゴシエーションが行われます。 デフォルトの場合、Cisco NX-OS ソフトウェアでは、最小の MAC アドレスを基にプライマリ スイッチが選択されます。 特定のフェールオーバー条件の下でのみ、このソフトウェアは各スイッチ(つまり、プライマリ スイッチとセカンダリ スイッチ)に対して別々の処理を行います。 プライマリ スイッチに障害が発生した場合、システムが回復した時点でセカンダリ スイッチがプライマリ スイッチとして動作し、元々のプライマリ スイッチがセカンダリ スイッチとなります。

ただし、どちらの vPC スイッチをプライマリ スイッチにするか設定することもできます。 一方の vPC スイッチをプライマリ スイッチにするためロール プライオリティを再設定する場合は、まずプライマリ vPC スイッチとセカンダリ vPC スイッチのそれぞれに対してロール プライオリティを適切な値に設定し、shutdown コマンドを入力して両スイッチの vPC ピア リンクである EtherChannel をシャットダウンした後、no shutdown コマンドを入力して両スイッチの EtherChannel を再度イネーブルにします。

ピア間では、vPC リンクを介して認識された MAC アドレスの同期も行われます。

設定情報は、Cisco Fabric Service over Ethernet(CFSoE)プロトコルを使用して vPC ピア リンクを転送されます。 両方のスイッチで設定されているこれらの VLAN の MAC アドレスはすべて、vPC ピア スイッチ間で同期されています。 この同期に、CFSoE が使用されます

vPC ピア リンクに障害が発生すると、ソフトウェアでは、両方のスイッチが稼働していることを確認するため、vPC ピア スイッチ間のリンクであるピアキープアライブ リンクを使用してリモート vPC ピア スイッチのステータス確認が行われます、 vPC ピア スイッチが稼働している場合は、セカンダリ vPC スイッチにあるすべて vPC ポートがディセーブルになります。 さらにデータは、EtherChannel において依然アクティブ状態にあるリンクに転送されます。

ソフトウェアは、ピアキープアライブ リンクを介してキープアライブ メッセージが返されない場合、vPC ピア スイッチに障害が発生したと認識します。

vPC ピア スイッチ間では、別途用意されたリンク(vPC ピアキープアライブ リンク)を使用して、設定可能なキープアライブ メッセージが送信されます。 vPC ピアキープアライブ リンク上のキープアライブ メッセージにより、障害が vPC ピア リンク上でだけ発生したのか、vPC ピア スイッチ上で発生したのかが判断されます。 キープアライブ メッセージは、ピア リンク内のすべてのリンクで障害が発生した場合にだけ使用されます。

vPC 番号

vPC ドメイン ID と vPC ピア リンクを作成すると、ダウンストリーム スイッチを各 vPC ピア スイッチに接続するための EtherChannel を作成することができます。 ダウントストリーム スイッチ上で EtherChannel を 1 つだけ作成し、そのポートの半分をプライマリ vPC ピア スイッチ用、残りの半分をセカンダリ vPC ピア スイッチ用として使用します。

各 vPC ピア スイッチ上では、ダウンとリーム スイッチに接続された EtherChannel に同じ vPC 番号を割り当てます。 vPC の作成時にトラフィックが中断されることはほとんどありません。 設定を簡素化するため、各 EtherChannel に対してその EtherChannel と同じ番号の vPC ID 番号を割り当てることもできます(EtherChannel 10 に対しては vPC ID 10 を割り当てるなど)。


(注)  


vPC ピア スイッチからダウンストリーム スイッチに接続する EtherChannel に割り当てる vPC 番号は、両側の vPC ピア スイッチで同じであることが必要です。


その他の機能との vPC の相互作用

vPC と LACP

Link Aggregation Control Protocol(LACP)では、vPC ドメインのシステム MAC アドレスに基づいて、その vPC に対する LACP Aggregation Group(LAG)ID が構成されます。

LACP は、ダウンストリーム スイッチからのチャネルも含め、すべての vPC EtherChannel 上で使用できます。 vPC ピア スイッチの各 EtherChannel のインターフェイスに対しては、LACP をアクティブ モードで設定することが推奨されます。 この設定により、スイッチ、単方向リンク、およびマルチホップ接続の間の互換性をより簡単に検出できるようになり、実行時の変更およびリンク障害に対してダイナミックな応答が可能になります。

vPC ピア リンクは、16 個の EtherChannel インターフェイスをサポートしています。


(注)  


システム プライオリティを手動で設定する場合は、必ず両側の vPC ピア スイッチ上に同じプライオリティ値を割り当てるようにしてください。 両側の vPC ピア スイッチに異なるシステム プライオリティ値が割り当てられている場合、vPC は稼働しません。


vPC ピア リンクと STP

vPC 機能の初回起動時には、STP は再コンバージェンスします。 STP は、vPC ピア リンクを特殊なリンクとして扱い、常に vPC ピア リンクを STP のアクティブ トポロジに含めます。

すべての vPC ピア リンク インターフェイスを STP ネットワーク ポート タイプに設定して、すべての vPC リンク上で Bridge Assurance が自動的にイネーブルになるようにすることを推奨します。 また、vPC ピア リンク上ではどの STP 拡張機能もイネーブルにしないことが推奨されます。

一連のパラメータは、vPC ピア リンクの両端の vPC ピア スイッチ上で設定を同じにする必要があります。

STP は分散型です。つまり、このプロトコルは、両端の vPC ピア スイッチ上で継続的に実行されます。 ただし、セカンダリ vPC ピア スイッチ上の vPC インターフェイスの STP プロセスは、プライマリ スイッチとして選択されている vPC ピア スイッチ上での設定により制御されます。

プライマリ vPC スイッチでは、Cisco Fabric Services over Ethernet(CFSoE)を使用して、vPC セカンダリ ピア スイッチ上の STP 状態の同期化が行われます。

vPC ピア スイッチ間では、プライマリ スイッチとセカンダリ スイッチを設定して 2 つのスイッチを STP 用に調整する提案/ハンドシェイク合意が vPC マネージャによって実行されます。 さらにプライマリ vPC ピア スイッチにより、プライマリ スイッチおよびセカンダリ スイッチの vPC インターフェイスに対する STP プロトコルの制御が行われます。

ブリッジ プロトコル データ ユニット(BPDU)では、代表ブリッジ ID フィールドの STP ブリッジ ID として、vPC に対して設定された MAC アドレスが使用されます。 これら vPC インターフェイスの BPDU は vPC プライマリ スイッチにより送信されます。


(注)  


vPC ピア リンクの両側での設定を表示して、設定が同じであることを確認してください。 vPC に関する情報を表示する場合は、show spanning-tree コマンドを使用します。


vPC と ARP

Cisco NX-OS では、Cisco Fabric Services over Ethernet(CFSoE)プロトコルが持つ信頼性の高い転送メカニズムによって、vPC ピア間のテーブルの同期が管理されます。 vPC ピア間でアドレス テーブルの高速コンバージェンスをサポートするためには、ip arp synchronize コマンドをイネーブルにする必要があります。 このコンバージェンスは、ピアリンク ポート チャネルがフラップした場合や vPC ピアがオンラインに戻った場合に、ARP テーブルの復元に伴う遅延の解消を目的としたものです。

パフォーマンスを向上させるためにも、ARP 同期機能はイネーブルにすることが推奨されます。 デフォルトではディセーブルです。

ARP 同期がイネーブルかどうかを確認する場合は、次のコマンドを入力します。

switch# show running

ARP 同期をイネーブルにする場合は、次のコマンドを入力します。

switch(config-vpc-domain) # ip arp synchronize

CFSoE

Cisco Fabric Services over Ethernet(CFSoE)は、vPC ピア デバイスの動作を同期化するために使用される信頼性の高い状態転送メカニズムです。 CFSoE は、vPC にリンクされている、STP、IGMP などの多くの機能のメッセージとパケットを伝送します。 情報は、CFS/CFSoE プロトコル データ ユニット(PDU)に入れて伝送されます。

CFSoE は、vPC 機能をイネーブルにすると、デバイスによって自動的にイネーブルになります。何も設定する必要はありません。 vPC の CFSoE 分散には、IP を介してまたは CFS リージョンに分散する機能は必要ありません。 CFSoE 機能が vPC 上で正常に機能するために必要な設定は一切ありません。

show mac address-table コマンドを使用すれば、CFSoE が vPC ピア リンクのために同期する MAC アドレスを表示できます。


(注)  


no cfs eth distribute コマンドと no cfs distribute コマンドは入力しないでください。 vPC 機能に対しては CFSoE をイネーブルにする必要があります。 vPC がイネーブルの場合にこれらのコマンドのいずれかを入力すると、エラー メッセージが表示されます。


show cfs application コマンドを入力すると、出力に「Physical-eth」と表示されます。これは、CFSoE を使用しているアプリケーションを表します。

VRF に関する注意事項と制約事項

vPC には、次の注意事項と制約事項があります。

  • vPC ピアリンクおよび vPC インターフェイスを設定する場合は、あらかじめ vPC 機能をイネーブルにしておく必要があります。
  • システムにおいて vPC ピア リンクを構成するためには、その前にピアキープアライブ リンクを設定しておく必要があります。
  • vPC ピアリンクは、少なくとも 2 つの 10 ギガビット イーサネット インターフェイスを使用して構成する必要があります。
  • vPC に使用できるのは、ポート チャネルのみです。 vPC は、通常のポート チャネル上(スイッチ間 vPC トポロジ)、ポート チャネルのファブリック インターフェイス上(ファブリック エクステンダの vPC トポロジ)、およびポート チャネルのホスト インターフェイス上(ホスト インターフェイスの vPC トポロジ)で設定できます。
  • ファブリック エクステンダは、ホスト インターフェイスの vPC トポロジのメンバになることもファブリック エクステンダの vPC トポロジのメンバになることも可能ですが、同時に両方のメンバになることはできません。
  • 両側の vPC ピア スイッチを設定する必要があります。ただし vPC ピア デバイス間で設定が自動的に同期化されることはありません。
  • 必要な設定パラメータが、vPC ピア リンクの両側で互換性を保っているかチェックしてください。
  • vPC の設定中に、最小限のトラフィックの中断が発生する可能性があります。
  • vPC 内の LACP を使用するポート チャネルはすべて、アクティブ モードのインターフェイスで設定することが推奨されます。

vPC の設定

vPC のイネーブル化

vPC を設定して使用する場合は、事前に vPC 機能をイネーブルにしておく必要があります。

手順の概要

    1.    switch# configure terminal

    2.    switch(config)# feature vpc

    3.    (任意) switch# show feature

    4.    (任意) switch# copy running-config startup-config


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 switch# configure terminal
     

    コンフィギュレーション モードを開始します。

     
    ステップ 2 switch(config)# feature vpc
     

    スイッチで vPC をイネーブルにします。

     
    ステップ 3 switch# show feature
     
    (任意)

    スイッチ上でイネーブルになっている機能を表示します。

     
    ステップ 4 switch# copy running-config startup-config
     
    (任意)

    実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

     

    次の例は、vPC 機能をイネーブルにする方法を示します。

    switch# configure terminal
    switch(config)# feature vpc

    vPC のディセーブル化

    vPC 機能をディセーブルにできます。


    (注)  


    vPC 機能をディセーブルにすると、Cisco Nexus 5000 シリーズ スイッチ上のすべての vPC 設定がクリアされます。


    手順の概要

      1.    switch# configure terminal

      2.    switch(config)# no feature vpc

      3.    (任意) switch# show feature

      4.    (任意) switch# copy running-config startup-config


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 switch# configure terminal
       

      コンフィギュレーション モードを開始します。

       
      ステップ 2 switch(config)# no feature vpc
       

      スイッチで vPC をディセーブルにします。

       
      ステップ 3 switch# show feature
       
      (任意)

      スイッチ上でイネーブルになっている機能を表示します。

       
      ステップ 4 switch# copy running-config startup-config
       
      (任意)

      実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

       

      次の例は、vPC 機能をディセーブルにする方法を示します。

      switch# configure terminal
      switch(config)# no feature vpc

      vPC ドメインの作成

      両側の vPC ピア スイッチに対して、同じ vPC ドメイン ID を作成する必要があります。 このドメイン ID を基に、vPC システムの MAC アドレスが自動的に構成されます。

      はじめる前に

      vPC 機能をイネーブルにしていることを確認します。

      vPC ピア リンクの両端にあるそれぞれのスイッチで設定を行う必要があります。手順は次のとおりです。

      手順の概要

        1.    switch# configure terminal

        2.    switch(config)# vpc domain domain-id

        3.    (任意) switch# show vpc brief

        4.    (任意) switch# copy running-config startup-config


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 switch# configure terminal
         

        コンフィギュレーション モードを開始します。

         
        ステップ 2 switch(config)# vpc domain domain-id
         

        スイッチに対して vPC ドメインを作成し、vpc-domain コンフィギュレーション モードを開始します。 domain-id のデフォルト値はありません。指定できる値の範囲は 1 ~ 1000 です。

        (注)     

        既存の vPC ドメインに対して vpc-domain コンフィギュレーション モードを開始する場合は、vpc domain コマンドを使用することもできます。

         
        ステップ 3 switch# show vpc brief
         
        (任意)

        各 vPC ドメインに関する要約情報を表示します。

         
        ステップ 4 switch# copy running-config startup-config
         
        (任意)

        実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

         

        次に、vPC ドメインを作成する例を示します。

        switch# configure terminal
        switch(config)# vpc domain 5

        vPC キープアライブ リンクと vPC キープアライブ メッセージの設定

        キープアライブ メッセージを伝送するピアキープアライブ リンクの宛先 IP を設定できます。 必要に応じて、キープアライブ メッセージのその他のパラメータも設定できます。

        Cisco NX-OS Release 5.0(3)N1(1) 以降、Cisco Nexus 5500 プラットフォーム スイッチでは、レイヤ 3 モジュールを備え基本ライセンスまたは LAN Enterprise ライセンスがインストールされた VRF Lite がサポートされています。 これにより、VRF を作成し、その VRF に特定のインターフェイスを割り当てることができます。 旧リリースでは、管理 VRF、デフォルト VRF という 2 つの VRF がデフォルトで作成されます。 管理 VRF とデフォルト VRF には mgmt0 インターフェイスおよびすべての SVI インターフェイスが配置されます。

        Cisco NX-OS ソフトウェアは、vPC ピア間でピアキープアライブ リンクを使用して、設定可能なキープアライブ メッセージを定期的に送信します。 これらのメッセージを送信するには、ピア デバイス間にレイヤ 3 接続が必要です。 ピアキープアライブ リンクが起動および動作していないと、システムは vPC ピア リンクを開始できません。

        ピアキープアライブ メッセージに使用される送信元 IP アドレスと宛先の IP アドレスの両方が、ネットワーク内で一意であることを確認してください。また、vPC ピアキープアライブ リンクに関連付けられている Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)から、これらの IP アドレスが到達可能であることを確認してください。


        (注)  


        vPC ピアキープアライブ リンクを使用する際は、個別の VRF インスタンスを設定して、各 vPC ピア スイッチからその VRF にレイヤ 3 ポートを接続することが推奨されます。 ピア リンク自体を使用して vPC ピアキープアライブ メッセージを送信しないでください。 VRF の作成および設定に関する詳細については、『Cisco Nexus 5000 Series NX-OS Unicast Routing Configuration Guide, Release 5.0(3)N1(1)』を参照してください。


        はじめる前に

        vPC 機能をイネーブルにしていることを確認します。

        システムで vPC ピア リンクを形成できるようにするには、まず vPC ピアキープアライブ リンクを設定する必要があります。

        vPC ピア リンクの両端にあるそれぞれのスイッチで設定を行う必要があります。手順は次のとおりです。

        手順の概要

          1.    switch# configure terminal

          2.    switch(config)# vpc domain domain-id

          3.    switch(config-vpc-domain)# peer-keepalive destination ipaddress [hold-timeout secs | interval msecs {timeout secs} | precedence {prec-value | network | internet | critical | flash-override | flash | immediate priority | routine} | tos {tos-value | max-reliability | max-throughput | min-delay | min-monetary-cost | normal} | tos-byte tos-byte-value} | source ipaddress | vrf {name | management vpc-keepalive}]

          4.    (任意) switch(config-vpc-domain)# vpc peer-keepalive destination ipaddress source ipaddress

          5.    (任意) switch# show vpc peer-keepalive

          6.    (任意) switch# copy running-config startup-config


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 switch# configure terminal
           

          コンフィギュレーション モードを開始します。

           
          ステップ 2 switch(config)# vpc domain domain-id
           

          スイッチ上に vPC ドメインが存在しない場合はそれを作成し、vpc-domain コンフィギュレーション モードを開始します。

           
          ステップ 3 switch(config-vpc-domain)# peer-keepalive destination ipaddress [hold-timeout secs | interval msecs {timeout secs} | precedence {prec-value | network | internet | critical | flash-override | flash | immediate priority | routine} | tos {tos-value | max-reliability | max-throughput | min-delay | min-monetary-cost | normal} | tos-byte tos-byte-value} | source ipaddress | vrf {name | management vpc-keepalive}]
           

          vPC ピアキープアライブ リンクのリモート エンドの IPv4 アドレスを設定します。

          (注)     

          vPC ピアキープアライブ リンクを設定するまで、vPC ピア リンクは構成されません。

          管理ポートと VRF がデフォルトです。

           
          ステップ 4 switch(config-vpc-domain)# vpc peer-keepalive destination ipaddress source ipaddress
           
          (任意)

          vPC ピアキープアライブ リンクに対し、個別の VRF インスタンスを設定して、各 vPC ピア デバイスからその VRF にレイヤ 3 ポートを接続します。

           
          ステップ 5 switch# show vpc peer-keepalive
           
          (任意)

          キープアライブ メッセージのコンフィギュレーションに関する情報を表示します。

           
          ステップ 6 switch# copy running-config startup-config
           
          (任意)

          実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

           

          次の例は、vPC ピアキープアライブ リンクの宛先 IP アドレスを設定する方法を示したものです。

          switch# configure terminal
          switch(config)# vpc domain 5
          switch(config-vpc-domain)# peer-keepalive destination 10.10.10.42

          次に、プライマリとセカンダリの vPC デバイス間でピア キープアライブ リンク接続を設定する例を示します。

          switch(config)# vpc domain 100
          switch(config-vpc-domain)# peer-keepalive destination 192.168.2.2 source 192.168.2.1
          Note:--------:: Management VRF will be used as the default VRF ::--------
          switch(config-vpc-domain)#

          次の例は、vPC ピアキープアライブ リンクに対して、vpc_keepalive という名前の VRF インスタンスを別途設定する方法、およびその新しい VRF を検査する方法を示したものです。

          次の例は、vPC ピアキープアライブ リンクに対して、vpc_keepalive という名前の VRF インスタンスを別途設定する方法、およびその新しい VRF を検査する方法を示したものです。

          vrf context vpc_keepalive
          interface Ethernet1/31
            switchport access vlan 123
          interface Vlan123
            vrf member vpc_keepalive
            ip address 123.1.1.2/30
            no shutdown
          vpc domain 1
            peer-keepalive destination 123.1.1.1 source 123.1.1.2 vrf 
          vpc_keepalive
          
          L3-NEXUS-2# sh vpc peer-keepalive 
          
          vPC keep-alive status           : peer is alive                 
          --Peer is alive for             : (154477) seconds, (908) msec
          --Send status                   : Success 
          --Last send at                  : 2011.01.14 19:02:50 100 ms
          --Sent on interface             : Vlan123
          --Receive status                : Success
          --Last receive at               : 2011.01.14 19:02:50 103 ms
          --Received on interface         : Vlan123
          --Last update from peer         : (0) seconds, (524) msec
          
          vPC Keep-alive parameters
          --Destination                   : 123.1.1.1
          --Keepalive interval            : 1000 msec
          --Keepalive timeout             : 5 seconds
          --Keepalive hold timeout        : 3 seconds
          --Keepalive vrf                 : vpc_keepalive
          --Keepalive udp port            : 3200
          --Keepalive tos                 : 192
          
          The services provided by the switch , such as ping, ssh, telnet, 
          radius, are VRF aware. The VRF name need to be configured or 
          specified in order for the correct routing table to be used.
          L3-NEXUS-2# ping 123.1.1.1 vrf vpc_keepalive 
          PING 123.1.1.1 (123.1.1.1): 56 data bytes
          64 bytes from 123.1.1.1: icmp_seq=0 ttl=254 time=3.234 ms
          64 bytes from 123.1.1.1: icmp_seq=1 ttl=254 time=4.931 ms
          64 bytes from 123.1.1.1: icmp_seq=2 ttl=254 time=4.965 ms
          64 bytes from 123.1.1.1: icmp_seq=3 ttl=254 time=4.971 ms
          64 bytes from 123.1.1.1: icmp_seq=4 ttl=254 time=4.915 ms
          
          --- 123.1.1.1 ping statistics ---
          5 packets transmitted, 5 packets received, 0.00% packet loss
          round-trip min/avg/max = 3.234/4.603/4.971 ms
          

          vPC ピア リンクの作成

          vPC ピア リンクを作成する場合は、指定した vPC ドメインのピア リンクとする EtherChannel を各スイッチ上で指定します。 冗長性を確保するため、トランク モードで vPC ピア リンクとして指定する EtherChannel を設定し、各 vPC ピア スイッチで個別のモジュールの 2 つのポートを使用することを推奨します。

          はじめる前に

          vPC 機能をイネーブルにしていることを確認します。

          vPC ピア リンクの両端にあるそれぞれのスイッチで設定を行う必要があります。手順は次のとおりです。

          手順の概要

            1.    switch# configure terminal

            2.    switch(config)# interface port-channel channel-number

            3.    switch(config-if)# vpc peer-link

            4.    (任意) switch# show vpc brief

            5.    (任意) switch# copy running-config startup-config


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 switch# configure terminal
             

            コンフィギュレーション モードを開始します。

             
            ステップ 2 switch(config)# interface port-channel channel-number
             

            このスイッチの vPC ピア リンクとして使用する EtherChannel を選択し、インターフェイス コンフィギュレーション モードを開始します。

             
            ステップ 3 switch(config-if)# vpc peer-link
             

            選択した EtherChannel を vPC ピア リンクとして設定し、vpc-domain コンフィギュレーション モードを開始します。

             
            ステップ 4 switch# show vpc brief
             
            (任意)

            vPC ピア リンクに関する情報など、各 vPC の情報を表示します。

             
            ステップ 5 switch# copy running-config startup-config
             
            (任意)

            実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

             

            次の例は、vPC ピア リンクを設定する方法を示します。

            switch# configure terminal
            switch(config)# interface port-channel 20
            switch(config-if)# vpc peer-link

            設定の互換性の検査

            両側の vPC ピア スイッチに vPC ピア リンクを設定した後に、すべての vPC インターフェイスで設定に整合性があるかどうかの検査を行います。


            (注)  


            Cisco NX-OS Release 5.0(2)N1(1) 以降では、次の QoS パラメータでタイプ 2 整合性検査がサポートされています。
            • Network QoS:MTU および Pause
            • Input Queuing:Bandwidth および Absolute Priority
            • Output Queuing:Bandwidth および Absolute Priority

            タイプ 2 の不一致の場合、vPC は停止しません。 タイプ 1 の不一致が検出されると vPC は停止します。

            パラメータ

            デフォルト設定

            switch# show vpc consistency-parameters {global | interface port-channel channel-number}

            すべての vPC インターフェイス全体で一貫している必要があるパラメータのステータスを表示します。

            次の例は、すべての vPC インターフェイスの間で必須設定の互換性が保たれているかチェックする方法を示します。
            switch# show vpc consistency-parameters global
                 Legend:
                     Type 1 : vPC will be suspended in case of mismatch
            Name                        Type  Local Value            Peer Value 
            
            ------------- ----  ---------------------- -----------------------
            QoS                         2     ([], [], [], [], [],   ([], [], [], [], [],
                                               [])                    []) 
            
            Network QoS (MTU)           2     (1538, 0, 0, 0, 0, 0)  (1538, 0, 0, 0, 0, 0)
            Network Qos (Pause)         2     (F, F, F, F, F, F)     (1538, 0, 0, 0, 0, 0)
            Input Queuing (Bandwidth)   2     (100, 0, 0, 0, 0, 0)   (100, 0, 0, 0, 0, 0)
            Input Queuing (Absolute     2     (F, F, F, F, F, F)     (100, 0, 0, 0, 0, 0)
            Priority) 
            Output Queuing (Bandwidth)  2     (100, 0, 0, 0, 0, 0)   (100, 0, 0, 0, 0, 0)
            Output Queuing (Absolute    2     (F, F, F, F, F, F)     (100, 0, 0, 0, 0, 0)
            Priority) 
            STP Mode                    1     Rapid-PVST             Rapid-PVST 
            STP Disabled                1     None                   None 
            STP MST Region Name         1     ""                     "" 
            STP MST Region Revision     1     0                      0 
            STP MST Region Instance to  1 
              VLAN Mapping 
            
            STP Loopguard               1     Disabled               Disabled 
            STP Bridge Assurance        1     Enabled                Enabled 
            STP Port Type, Edge         1     Normal, Disabled,      Normal, Disabled,
            BPDUFilter, Edge BPDUGuard        Disabled               Disabled 
            STP MST Simulate PVST       1     Enabled                Enabled 
            Allowed VLANs               -     1,624                  1 
            Local suspended VLANs       -     624                    - 
            switch#
            

            次の例は、1 つの EtherChannel インターフェイスについて必須設定の互換性があるかどうか検査する方法を示したものです。

            switch#  show vpc consistency-parameters interface port-channel 20
             
                Legend:
                    Type 1 : vPC will be suspended in case of mismatch
            Name                        Type  Local Value            Peer Value
            -------------               ----  ---------------------- -----------------------
            Fex id                      1     20                     20
            STP Port Type               1     Default                Default
            STP Port Guard              1     None                   None
            STP MST Simulate PVST       1     Default                Default
            mode                        1     on                     on
            Speed                       1     10 Gb/s                10 Gb/s
            Duplex                      1     full                   full
            Port Mode                   1     fex-fabric             fex-fabric
            Shut Lan                    1     No                     No
            Allowed VLANs               -     1,3-3967,4048-4093     1-3967,4048-4093
             

            vPC 自動リカバリのイネーブル化

            手順の概要

              1.    switch# configure terminal

              2.    switch(config)# vpc domain domain-id

              3.    switch(config-vpc-domain)# auto-recovery reload-delay delay


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 switch# configure terminal
               

              コンフィギュレーション モードを開始します。

               
              ステップ 2 switch(config)# vpc domain domain-id
               

              既存の vPC ドメインに対して vpc-domain コンフィギュレーション モードを開始します。

               
              ステップ 3 switch(config-vpc-domain)# auto-recovery reload-delay delay
               

              自動リカバリ機能をイネーブルにし、リロード遅延時間を設定します。 デフォルトではディセーブルになっています。

               

              次の例は、vPC ドメイン 10 で自動リカバリ機能をイネーブルにし、遅延時間を 240 秒に設定する方法を示したものです。

              switch(config)# vpc domain 10
              switch(config-vpc-domain)# auto-recovery reload-delay 240
              Warning:
               Enables restoring of vPCs in a peer-detached state after reload, will wait for 240 seconds (by default) to determine if peer is un-reachable
              
              

              次の例は、vPC ドメイン 10 における自動リカバリ機能のステータスを表示する方法を示したものです。

              switch(config-vpc-domain)# show running-config vpc
              !Command: show running-config vpc
              !Time: Tue Dec  7 02:38:44 2010
              
              version 5.0(2)N2(1)
              
              feature vpc
              vpc domain 10
                peer-keepalive destination 10.193.51.170
                auto-recovery
              
              

              vPC トポロジにおけるセカンダリ スイッチの孤立ポートの一時停止

              セカンダリ vPC ピア リンクがダウンした場合、非仮想ポート チャネル(vPC)ポートを一時停止することができます。 非 vPC ポート(孤立ポート)とは、vPC に属していないポートです。

              はじめる前に

              vPC 機能がイネーブルであることを確認します。

              手順の概要

                1.    switch# configure terminal

                2.    switch(config)# interface ethernet slot/port

                3.    switch(config-if)# vpc orphan-port suspend

                4.    switch(config-if)# exit

                5.    (任意) switch# show vpc orphan-port

                6.    (任意) switch# copy running-config startup-config


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1 switch# configure terminal
                 

                コンフィギュレーション モードを開始します。

                 
                ステップ 2 switch(config)# interface ethernet slot/port
                 

                設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

                 
                ステップ 3 switch(config-if)# vpc orphan-port suspend
                 

                セカンダリ スイッチがダウンした場合に、指定したポートを一時停止します。

                (注)     

                vpc-orphan-port suspend コマンドは、物理ポート上でのみサポートされています。

                 
                ステップ 4 switch(config-if)# exit
                 

                インターフェイス コンフィギュレーション モードを終了します。

                 
                ステップ 5 switch# show vpc orphan-port
                 
                (任意)

                孤立ポートの設定を表示します。

                 
                ステップ 6 switch# copy running-config startup-config
                 
                (任意)

                実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                 

                次の例は、孤立ポートを一時停止する方法を示したものです。

                switch# configure terminal
                switch(config)# interface ethernet ½0
                switch(config-if)# vpc orphan-port suspend
                
                

                次の例は、vPC には属していないポートのうち、vPC に属しているポートと同じ VLAN を共有するポートの表示方法を示したものです。

                switch# configure terminal
                switch(config)# show vpc orphan-ports
                Note:
                --------::Going through port database. Please be patient.::--------
                VLAN Orphan Ports
                ------- -------------------------
                1 Po600
                2 Po600
                3 Po600
                4 Po600
                5 Po600
                6 Po600
                7 Po600
                8 Po600
                9 Po600
                10 Po600
                11 Po600
                12 Po600
                13 Po600
                14 Po600
                ...
                

                EtherChannel ホスト インターフェイスの作成

                Cisco Nexus 2000 シリーズ ファブリック エクステンダからダウンストリーム サーバに接続するため、EtherChannel ホスト インターフェイスを作成することができます。 ファブリック エクステンダのモデルによっては、EtherChannel ホスト インターフェイス 1 つにつきメンバにできるホスト インターフェイスは 1 つだけです。 Cisco Nexus 2148T では、個々のファブリック エクステンダに対してメンバにできるインターフェイスは 1 つだけですが、新しいファブリック エクステンダでは、それぞれに対して同じポートチャネルを最大 8 個までメンバにすることができます。 EtherChannel ホスト インターフェイスでファブリック エクステンダのトポロジを使用する vPC を設定するためには、その EtherChannel ホスト インターフェイスを作成する必要があります。

                はじめる前に

                vPC 機能をイネーブルにしていることを確認します。

                接続されているファブリック エクステンダがオンラインになっていることを確認します。

                vPC ピア リンクの両端にあるそれぞれのスイッチで設定を行う必要があります。手順は次のとおりです。

                手順の概要

                  1.    switch# configure terminal

                  2.    switch(config)# interface ethernet chassis/slot/port

                  3.    switch(config-if)# channel-group channel-number mode {active | passive | on}

                  4.    (任意) switch# show port-channel summary

                  5.    (任意) switch# copy running-config startup-config


                手順の詳細
                   コマンドまたはアクション目的
                  ステップ 1 switch# configure terminal
                   

                  コンフィギュレーション モードを開始します。

                   
                  ステップ 2 switch(config)# interface ethernet chassis/slot/port
                   

                  設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

                   
                  ステップ 3 switch(config-if)# channel-group channel-number mode {active | passive | on}
                   

                  選択したホスト インターフェイスで EtherChannel ホスト インターフェイスを作成します。

                   
                  ステップ 4 switch# show port-channel summary
                   
                  (任意)

                  各 EtherChannel ホスト インターフェイスに関する情報を表示します。

                   
                  ステップ 5 switch# copy running-config startup-config
                   
                  (任意)

                  実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                   

                  次の例は、EtherChannel ホスト インターフェイスの設定方法を示したものです。

                  switch# configure terminal
                  switch(config)# interface ethernet 101/1/20
                  switch(config-if)# channel-group 7 mode active
                  

                  他のポート チャネルの vPC への移行

                  はじめる前に

                  vPC 機能をイネーブルにしていることを確認します。

                  vPC ピア リンクの両端にあるそれぞれのスイッチで設定を行う必要があります。手順は次のとおりです。

                  手順の概要

                    1.    switch# configure terminal

                    2.    switch(config)# interface port-channel channel-number

                    3.    switch(config-if)# vpc number

                    4.    (任意) switch# show vpc brief

                    5.    (任意) switch# copy running-config startup-config


                  手順の詳細
                     コマンドまたはアクション目的
                    ステップ 1 switch# configure terminal
                     

                    コンフィギュレーション モードを開始します。

                     
                    ステップ 2 switch(config)# interface port-channel channel-number
                     

                    vPC に配置してダウンストリーム スイッチに接続するポート チャネルを選択し、インターフェイス コンフィギュレーション モードを開始します。

                    (注)     

                    vPC は、通常のポート チャネル上(物理 vPC トポロジ)、ポート チャネルのファブリック インターフェイス上(ファブリック エクステンダの vPC トポロジ)、およびポート チャネルのホスト インターフェイス上(ホスト インターフェイスの vPC トポロジ)で設定できます。

                     
                    ステップ 3 switch(config-if)# vpc number
                     

                    選択したポート チャネルを vPC に配置してダウンストリーム スイッチに接続するように設定します。 指定できる範囲は 1 ~ 4096 です。

                    vPC ピア スイッチからダウンストリーム デバイスに接続するポート チャネルに割り当てる vPC number は、両側の vPC ピア スイッチで同じであることが必要です。

                     
                    ステップ 4 switch# show vpc brief
                     
                    (任意)

                    各 vPC に関する情報を表示します。

                     
                    ステップ 5 switch# copy running-config startup-config
                     
                    (任意)

                    実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                     

                    次の例は、ダウンストリーム デバイスに接続されるポート チャネルを設定する方法を示します。

                    switch# configure terminal
                    switch(config)# interface port-channel 20
                    switch(config-if)# vpc 5
                     

                    vPC ドメイン MAC アドレスの手動での設定


                    (注)  


                    system-mac の設定を行うかどうかは任意です。 この項では、必要に応じてシステムの MAC アドレスを設定する方法について説明します。


                    はじめる前に

                    vPC 機能をイネーブルにしていることを確認します。

                    vPC ピア リンクの両端にあるそれぞれのスイッチで設定を行う必要があります。手順は次のとおりです。

                    手順の概要

                      1.    switch# configure terminal

                      2.    switch(config)# vpc domain domain-id

                      3.    switch(config-vpc-domain)# system-mac mac-address

                      4.    (任意) switch# show vpc role

                      5.    (任意) switch# copy running-config startup-config


                    手順の詳細
                       コマンドまたはアクション目的
                      ステップ 1 switch# configure terminal
                       

                      コンフィギュレーション モードを開始します。

                       
                      ステップ 2 switch(config)# vpc domain domain-id
                       

                      スイッチ上にある既存の vPC ドメインを選択するか、または新規の vPC ドメインを作成して、vpc-domain コンフィギュレーション モードを開始します。 domain-id のデフォルト値はありません。指定できる値の範囲は 1 ~ 1000 です。

                       
                      ステップ 3 switch(config-vpc-domain)# system-mac mac-address
                       

                      指定した vPC ドメインに割り当てる MAC アドレスを aaaa.bbbb.cccc の形式で入力します。

                       
                      ステップ 4 switch# show vpc role
                       
                      (任意)

                      vPC システムの MAC アドレスを表示します。

                       
                      ステップ 5 switch# copy running-config startup-config
                       
                      (任意)

                      実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                       

                      次の例は、vPC ドメインの MAC アドレスを設定する方法を示したものです。

                      switch# configure terminal
                      switch(config)# vpc domain 5
                      switch(config-if)# system-mac 23fb.4ab5.4c4e
                       

                      システム プライオリティの手動での設定

                      vPC ドメインを作成すると、vPC システム プライオリティが自動的に作成されます。 ただし、vPC ドメインのシステム プライオリティは手動で設定することもできます。

                      はじめる前に

                      vPC 機能をイネーブルにしていることを確認します。

                      vPC ピア リンクの両端にあるそれぞれのスイッチで設定を行う必要があります。手順は次のとおりです。

                      手順の概要

                        1.    switch# configure terminal

                        2.    switch(config)# vpc domain domain-id

                        3.    switch(config-vpc-domain)# system-priority priority

                        4.    (任意) switch# show vpc brief

                        5.    (任意) switch# copy running-config startup-config


                      手順の詳細
                         コマンドまたはアクション目的
                        ステップ 1 switch# configure terminal
                         

                        コンフィギュレーション モードを開始します。

                         
                        ステップ 2 switch(config)# vpc domain domain-id
                         

                        スイッチ上にある既存の vPC ドメインを選択するか、または新規の vPC ドメインを作成して、vpc-domain コンフィギュレーション モードを開始します。 domain-id のデフォルト値はありません。指定できる値の範囲は 1 ~ 1000 です。

                         
                        ステップ 3 switch(config-vpc-domain)# system-priority priority
                         

                        指定した vPC ドメインに割り当てるシステム プライオリティを入力します。 指定できる値の範囲は、1 ~ 65535 です。 デフォルト値は 32667 です。

                         
                        ステップ 4 switch# show vpc brief
                         
                        (任意)

                        vPC ピア リンクに関する情報など、各 vPC の情報を表示します。

                         
                        ステップ 5 switch# copy running-config startup-config
                         
                        (任意)

                        実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                         

                        次の例は、vPC ピア リンクを設定する方法を示します。

                        switch# configure terminal
                        switch(config)# vpc domain 5
                        switch(config-if)# system-priority 4000
                         

                        vPC ピア スイッチのロールの手動による設定

                        デフォルトの場合、Cisco NX-OS では、vPC ドメインおよび vPC ピア リンクの両側を設定した後、プライマリおよびセカンダリの vPC ピア スイッチが選択されます。 ただし、vPC のプライマリ スイッチとして、特定の vPC ピア スイッチを選択することもできます。 選択したら、プライマリ スイッチにする vPC ピア スイッチに、他の vPC ピア スイッチより小さいロール値を手動で設定します。

                        vPC はロールのプリエンプションをサポートしていません。 プライマリ vPC ピア スイッチに障害が発生すると、セカンダリ vPC ピア スイッチが、vPC プライマリ デバイスの機能を引き継ぎます。 ただし、以前のプライマリ vPC が再び稼働しても、機能のロールは元に戻りません。

                        はじめる前に

                        vPC 機能をイネーブルにしていることを確認します。

                        vPC ピア リンクの両端にあるそれぞれのスイッチで設定を行う必要があります。手順は次のとおりです。

                        手順の概要

                          1.    switch# configure terminal

                          2.    switch(config)# vpc domain domain-id

                          3.    switch(config-vpc-domain)# role priority priority

                          4.    (任意) switch# show vpc brief

                          5.    (任意) switch# copy running-config startup-config


                        手順の詳細
                           コマンドまたはアクション目的
                          ステップ 1 switch# configure terminal
                           

                          コンフィギュレーション モードを開始します。

                           
                          ステップ 2 switch(config)# vpc domain domain-id
                           

                          スイッチ上にある既存の vPC ドメインを選択するか、または新規の vPC ドメインを作成して、vpc-domain コンフィギュレーション モードを開始します。 domain-id のデフォルト値はありません。指定できる値の範囲は 1 ~ 1000 です。

                           
                          ステップ 3 switch(config-vpc-domain)# role priority priority
                           

                          vPC システム プライオリティとして使用するロール プライオリティを指定します。 指定できる値の範囲は、1 ~ 65535 です。 デフォルト値は 32667 です。

                           
                          ステップ 4 switch# show vpc brief
                           
                          (任意)

                          vPC ピア リンクに関する情報など、各 vPC の情報を表示します。

                           
                          ステップ 5 switch# copy running-config startup-config
                           
                          (任意)

                          実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                           

                          次の例は、vPC ピア リンクを設定する方法を示します。

                          switch# configure terminal
                          switch(config)# vpc domain 5
                          switch(config-if)# role priority 4000
                           

                          vPC 設定の確認

                          vPC の設定情報を表示する場合は、次のコマンドを使用します。

                          コマンド

                          目的

                          switch# show feature

                          vPC がイネーブルかどうかを表示します。

                          switch# show port-channel capacity

                          設定されている EtherChannel の数、およびスイッチ上でまだ使用可能な EtherChannel の数を表示します。

                          switch# show running-config vpc

                          vPC の実行コンフィギュレーションの情報を表示します。

                          switch# show vpc brief

                          vPC に関する簡単な情報を表示します。

                          switch# show vpc consistency-parameters

                          すべての vPC インターフェイス全体で一貫している必要があるパラメータのステータスを表示します。

                          switch# show vpc peer-keepalive

                          ピアキープアライブ メッセージの情報を表示します。

                          switch# show vpc role

                          ピア ステータス、ローカル スイッチのロール、vPC システムの MAC アドレスとシステム プライオリティ、およびローカル vPC スイッチの MAC アドレスとプライオリティを表示します。

                          switch# show vpc statistics

                          vPC に関する統計情報を表示します。

                          (注)     

                          このコマンドは、現在作業している vPC ピア デバイスの vPC 統計情報しか表示しません。

                          スイッチの出力に関する詳細については、ご使用の Cisco Nexus シリーズ スイッチに関するコマンド リファレンスを参照してください。

                          グレースフル タイプ 1 検査ステータスの表示

                          グレースフル タイプ 1 整合性検査の現在のステータスを表示する場合は、show vpc brief コマンドを入力します。

                          switch# show vpc brief
                          Legend:
                                          (*) - local vPC is down, forwarding via vPC peer-link
                          
                          vPC domain id                   : 10
                          Peer status                     : peer adjacency formed ok
                          vPC keep-alive status           : peer is alive
                          Configuration consistency status: success
                          Per-vlan consistency status     : success
                          Type-2 consistency status       : success
                          vPC role                        : secondary
                          Number of vPCs configured       : 34
                          Peer Gateway                    : Disabled
                          Dual-active excluded VLANs      : -
                          Graceful Consistency Check      : Enabled
                          
                          vPC Peer-link status
                          ---------------------------------------------------------------------
                          id   Port   Status Active vlans
                          --   ----   ------ --------------------------------------------------
                          1    Po1    up     1
                          

                          グローバル タイプ 1 不整合の表示

                          グローバル タイプ 1 不整合が発生すると、セカンダリ スイッチの vPC はダウンします。 次の例は、スパニングツリー モードでの不一致に伴って生じたこのタイプの不整合を示したものです。

                          一時停止した vPC VLAN のステータスを表示する場合は、セカンダリ スイッチに対して show vpc コマンドを入力します。

                          switch(config)# show vpc
                          Legend:
                                          (*) - local vPC is down, forwarding via vPC peer-link
                          
                          vPC domain id                   : 10
                          Peer status                     : peer adjacency formed ok
                          vPC keep-alive status           : peer is alive
                          Configuration consistency status: failed
                          Per-vlan consistency status     : success
                          Configuration consistency reason: vPC type-1 configuration incompatible - STP 
                                                            Mode inconsistent
                          Type-2 consistency status       : success
                          vPC role                        : secondary
                          Number of vPCs configured       : 2
                          Peer Gateway                    : Disabled
                          Dual-active excluded VLANs      : -
                          Graceful Consistency Check      : Enabled
                          
                          vPC Peer-link status
                          ---------------------------------------------------------------------
                          id   Port   Status Active vlans
                          --   ----   ------ --------------------------------------------------
                          1    Po1    up     1-10
                          
                          vPC status
                          ----------------------------------------------------------------------------
                          id     Port        Status Consistency Reason                     Active vlans
                          ------ ----------- ------ ----------- -------------------------- -----------
                          20     Po20        down*  failed      Global compat check failed -
                          30     Po30        down*  failed      Global compat check failed -
                          
                          

                          不整合のステータスを表示する場合は、プライマリ スイッチに対して show vpc コマンドを入力します(プライマリ vPC の VLAN は一時停止しません)。

                          switch(config)# show vpc
                          Legend:
                                          (*) - local vPC is down, forwarding via vPC peer-link
                          
                          vPC domain id                   : 10
                          Peer status                     : peer adjacency formed ok
                          vPC keep-alive status           : peer is alive
                          Configuration consistency status: failed
                          Per-vlan consistency status     : success
                          Configuration consistency reason: vPC type-1 configuration incompatible - STP Mo
                          de inconsistent
                          Type-2 consistency status       : success
                          vPC role                        : primary
                          Number of vPCs configured       : 2
                          Peer Gateway                    : Disabled
                          Dual-active excluded VLANs      : -
                          Graceful Consistency Check      : Enabled
                          
                          vPC Peer-link status
                          ---------------------------------------------------------------------
                          id   Port   Status Active vlans
                          --   ----   ------ --------------------------------------------------
                          1    Po1    up     1-10
                          
                          vPC status
                          ----------------------------------------------------------------------------
                          id     Port        Status Consistency Reason                     Active vlans
                          ------ ----------- ------ ----------- -------------------------- -----------
                          20     Po20        up     failed      Global compat check failed 1-10
                          30     Po30        up     failed      Global compat check failed 1-10
                          
                          

                          インターフェイス別タイプ 1 不整合の表示

                          インターフェイス別タイプ 1 不整合が発生すると、セカンダリ スイッチの vPC ポートはダウンしますが、プライマリ スイッチの vPC ポートはアップ状態が維持されます。次の例は、スイッチポート モードでの不一致に伴って生じたこのタイプの不整合を示したものです。

                          一時停止した vPC VLAN のステータスを表示する場合は、セカンダリ スイッチに対して show vpc brief コマンドを入力します。

                          switch(config-if)# show vpc brief
                          Legend:
                                          (*) - local vPC is down, forwarding via vPC peer-link
                          
                          vPC domain id                   : 10
                          Peer status                     : peer adjacency formed ok
                          vPC keep-alive status           : peer is alive
                          Configuration consistency status: success
                          Per-vlan consistency status     : success
                          Type-2 consistency status       : success
                          vPC role                        : secondary
                          Number of vPCs configured       : 2
                          Peer Gateway                    : Disabled
                          Dual-active excluded VLANs      : -
                          Graceful Consistency Check      : Enabled
                          
                          vPC Peer-link status
                          ---------------------------------------------------------------------
                          id   Port   Status Active vlans
                          --   ----   ------ --------------------------------------------------
                          1    Po1    up     1
                          
                          vPC status
                          ----------------------------------------------------------------------------
                          id     Port        Status Consistency Reason                     Active vlans
                          ------ ----------- ------ ----------- -------------------------- -----------
                          20     Po20        up     success     success                    1
                          30     Po30        down*  failed      Compatibility check failed -
                                                                 for port mode
                          
                          
                          

                          不整合のステータスを表示する場合は、プライマリ スイッチに対して show vpc brief コマンドを入力します(プライマリ vPC の VLAN は一時停止しません)。

                          switch(config-if)# show vpc brief
                          Legend:
                                          (*) - local vPC is down, forwarding via vPC peer-link
                          
                          vPC domain id                   : 10
                          Peer status                     : peer adjacency formed ok
                          vPC keep-alive status           : peer is alive
                          Configuration consistency status: success
                          Per-vlan consistency status     : success
                          Type-2 consistency status       : success
                          vPC role                        : primary
                          Number of vPCs configured       : 2
                          Peer Gateway                    : Disabled
                          Dual-active excluded VLANs      : -
                          Graceful Consistency Check      : Enabled
                          
                          vPC Peer-link status
                          ---------------------------------------------------------------------
                          id   Port   Status Active vlans
                          --   ----   ------ --------------------------------------------------
                          1    Po1    up     1
                          
                          vPC status
                          ----------------------------------------------------------------------------
                          id     Port        Status Consistency Reason                     Active vlans
                          ------ ----------- ------ ----------- -------------------------- -----------
                          20     Po20        up     success     success                    1
                          30     Po30        up     failed      Compatibility check failed 1
                                                                 for port mode
                          
                          

                          VLAN ごとの整合性ステータスの表示

                          VLAN ごとの整合性ステータスまたは不整合のステータスを表示する場合は、show vpc consistency-parameters vlans コマンドを入力します。

                          次の例では最初に、不整合が発生する前の(整合性がある状態での)VLAN のステータスが表示されています。 その後で no spanning-tree vlan 5 コマンドを入力することにより、プライマリ スイッチとセカンダリ スイッチとの間に不整合が生じます。

                          show vpc brief コマンドを実行して、プライマリ スイッチおよびセカンダリ スイッチの VLAN の整合性ステータスを表示します。

                          switch(config-if)# show vpc brief
                          Legend:
                                          (*) - local vPC is down, forwarding via vPC peer-link
                          
                          vPC domain id                   : 10
                          Peer status                     : peer adjacency formed ok
                          vPC keep-alive status           : peer is alive
                          Configuration consistency status: success
                          Per-vlan consistency status     : success
                          Type-2 consistency status       : success
                          vPC role                        : secondary
                          Number of vPCs configured       : 2
                          Peer Gateway                    : Disabled
                          Dual-active excluded VLANs      : -
                          Graceful Consistency Check      : Enabled
                          
                          vPC Peer-link status
                          ---------------------------------------------------------------------
                          id   Port   Status Active vlans
                          --   ----   ------ --------------------------------------------------
                          1    Po1    up     1-10
                          
                          vPC status
                          ----------------------------------------------------------------------------
                          id     Port        Status Consistency Reason                     Active vlans
                          ------ ----------- ------ ----------- -------------------------- -----------
                          20     Po20        up     success     success                    1-10
                          30     Po30        up     success     success                    1-10
                          
                          

                          no spanning-tree vlan 5 コマンドを実行することにより、プライマリ VLAN とセカンダリ VLAN との間に不整合が生じます。

                          switch(config)# no spanning-tree vlan 5
                          

                          セカンダリ スイッチに対して show vpc brief コマンドを実行すると、VLAN ごとの整合性ステータスが Failed と表示されます。

                          switch(config)# show vpc brief
                          Legend:
                                          (*) - local vPC is down, forwarding via vPC peer-link
                          
                          vPC domain id                   : 10
                          Peer status                     : peer adjacency formed ok
                          vPC keep-alive status           : peer is alive
                          Configuration consistency status: success
                          Per-vlan consistency status     : failed
                          Type-2 consistency status       : success
                          vPC role                        : secondary
                          Number of vPCs configured       : 2
                          Peer Gateway                    : Disabled
                          Dual-active excluded VLANs      : -
                          Graceful Consistency Check      : Enabled
                          
                          vPC Peer-link status
                          ---------------------------------------------------------------------
                          id   Port   Status Active vlans
                          --   ----   ------ --------------------------------------------------
                          1    Po1    up     1-4,6-10
                          
                          vPC status
                          ----------------------------------------------------------------------------
                          id     Port        Status Consistency Reason                     Active vlans
                          ------ ----------- ------ ----------- -------------------------- -----------
                          20     Po20        up     success     success                    1-4,6-10
                          30     Po30        up     success     success                    1-4,6-10
                          
                          

                          プライマリ スイッチに対して show vpc brief コマンドを実行しても、VLAN ごとの整合性ステータスが Failed と表示されます。

                          switch(config)# show vpc brief
                          Legend:
                                          (*) - local vPC is down, forwarding via vPC peer-link
                          
                          vPC domain id                   : 10
                          Peer status                     : peer adjacency formed ok
                          vPC keep-alive status           : peer is alive
                          Configuration consistency status: success
                          Per-vlan consistency status     : failed
                          Type-2 consistency status       : success
                          vPC role                        : primary
                          Number of vPCs configured       : 2
                          Peer Gateway                    : Disabled
                          Dual-active excluded VLANs      : -
                          Graceful Consistency Check      : Enabled
                          
                          vPC Peer-link status
                          ---------------------------------------------------------------------
                          id   Port   Status Active vlans
                          --   ----   ------ --------------------------------------------------
                          1    Po1    up     1-4,6-10
                          
                          vPC status
                          ----------------------------------------------------------------------------
                          id     Port        Status Consistency Reason                     Active vlans
                          ------ ----------- ------ ----------- -------------------------- -----------
                          20     Po20        up     success     success                    1-4,6-10
                          30     Po30        up     success     success                    1-4,6-10
                          

                          次の例では、STP Disabled という不整合が表示されています。

                          switch(config)# show vpc consistency-parameters vlans
                          
                          Name                        Type  Reason Code             Pass Vlans
                          
                          -------------               ----  ---------------------- -----------------------
                          STP Mode                    1     success                0-4095
                          STP Disabled                1     vPC type-1             0-4,6-4095
                                                            configuration
                                                            incompatible - STP is
                                                            enabled or disabled on
                                                             some or all vlans
                          STP MST Region Name         1     success                0-4095
                          STP MST Region Revision     1     success                0-4095
                          STP MST Region Instance to  1     success                0-4095
                           VLAN Mapping
                          STP Loopguard               1     success                0-4095
                          STP Bridge Assurance        1     success                0-4095
                          STP Port Type, Edge         1     success                0-4095
                          BPDUFilter, Edge BPDUGuard
                          STP MST Simulate PVST       1     success                0-4095
                          Pass Vlans                  -                            0-4,6-4095
                          

                          vPC の設定例

                          デュアル ホーム ファブリック エクステンダにおける vPC の設定例

                          次の例は、スイッチ NX-5000-1 でピアキープアライブ メッセージを伝送するため、下図のような管理 VRF を使用したデュアル ホーム ファブリック エクステンダの vPC トポロジを設定する方法を示したものです。

                          図 5. vPC の設定例

                          はじめる前に

                          Cisco Nexus 2000 シリーズ ファブリック エクステンダの NX-2000-100 が接続され、かつオンラインになっていることを確認します。

                          手順の概要

                            1.    vPC および LACP をイネーブルにします。

                            2.    vPC ドメインを作成し、vPC ピアキープアライブ リンクを追加します。

                            3.    vPC ピア リンクを 2 ポートの EtherChannel として設定します。

                            4.    ファブリック エクステンダの識別子(100 など)を作成します。

                            5.    ファブリック エクステンダ 100 に対してファブリック EtherChannel リンクを設定します。

                            6.    他のすべての手順と同様、両側の Nexus 5000 シリーズ スイッチで、ファブリック エクステンダ 100 の各ホスト インターフェイス ポートを設定します。

                            7.    設定を保存します。


                          手順の詳細
                            ステップ 1   vPC および LACP をイネーブルにします。
                            NX-5000-1# configure terminal
                            NX-5000-1(config)# feature lacp
                            NX-5000-1(config)# feature vpc
                             
                            ステップ 2   vPC ドメインを作成し、vPC ピアキープアライブ リンクを追加します。
                            NX-5000-1(config)# vpc domain 1
                            NX-5000-1(config-vpc-domain)# peer-keepalive destination 10.10.10.237
                            NX-5000-1(config-vpc-domain)# exit
                             
                            ステップ 3   vPC ピア リンクを 2 ポートの EtherChannel として設定します。
                            NX-5000-1(config)# interface ethernet 1/1-2
                            NX-5000-1(config-if-range)# switchport mode trunk
                            NX-5000-1(config-if-range)# switchport trunk allowed vlan 20-50
                            NX-5000-1(config-if-range)# switchport trunk native vlan 20
                            NX-5000-1(config-if-range)# channel-group 20 mode active
                            NX-5000-1(config-if-range)# exit
                            NX-5000-1(config)# interface port-channel 20
                            NX-5000-1(config-if)# vpc peer-link
                            NX-5000-1(config-if)# exit
                             
                            ステップ 4   ファブリック エクステンダの識別子(100 など)を作成します。
                            NX-5000-1(config)# fex 100
                            NX-5000-1(config-fex)# pinning max-links 1
                            NX-5000-1(fex)# exit
                             
                            ステップ 5   ファブリック エクステンダ 100 に対してファブリック EtherChannel リンクを設定します。
                            NX-5000-1(config)# interface ethernet 1/20
                            NX-5000-1(config-if)# channel-group 100
                            NX-5000-1(config-if)# exit
                            NX-5000-1(config)# interface port-channel 100
                            NX-5000-1(config-if)# switchport mode fex-fabric
                            NX-5000-1(config-if)# vpc 100
                            NX-5000-1(config-if)# fex associate 100
                            NX-5000-1(config-if)# exit
                             
                            ステップ 6   他のすべての手順と同様、両側の Nexus 5000 シリーズ スイッチで、ファブリック エクステンダ 100 の各ホスト インターフェイス ポートを設定します。
                            NX-5000-1(config)# interface ethernet 100/1/1-48
                            NX-5000-1(config-if)# switchport mode access
                            NX-5000-1(config-if)# switchport access vlan 50
                            NX-5000-1(config-if)# no shutdown
                            NX-5000-1(config-if)# exit
                             
                            ステップ 7   設定を保存します。
                            NX-5000-1(config)# copy running-config startup-config
                             

                            NX-5000-2 スイッチに対して上記の手順を繰り返します。


                            シングル ホーム ファブリック エクステンダにおける vPC の設定例

                            次の例は、スイッチ NX-5000-1 でピアキープアライブ メッセージを伝送するため、下図のようなデフォルト VRF を使用したシングル ホーム ファブリック エクステンダの vPC トポロジを設定する方法を示したものです。

                            図 6. vPC の設定例


                            (注)  


                            次の例は、ファブリック エクステンダの NX-2000-100 に接続された NX-5000-1 の設定方法だけを示したものです。 NX-5000-1 の vPC ピアである、ファブリック エクステンダの NX-2000-101 に接続された NX-5000-2 についても、これらの手順を繰り返す必要があります。


                            はじめる前に

                            Cisco Nexus 2000 シリーズ ファブリック エクステンダの NX-2000-100 と NX-2000-101 が接続され、かつオンラインになっていることを確認します。

                            手順の概要

                              1.    vPC および LACP をイネーブルにします。

                              2.    SVI インターフェイスをイネーブルにし、vPC ピアキープアライブ リンクで使用する VLAN および SVI を作成します。

                              3.    vPC ドメインを作成し、vPC ピアキープアライブ リンクをデフォルト VRF に追加します。

                              4.    vPC ピア リンクを 2 ポートの EtherChannel として設定します。

                              5.    ファブリック エクステンダの NX-2000-100 を設定します。

                              6.    ファブリック エクステンダの NX-2000-100 に対して、ファブリック EtherChannel リンクを設定します。

                              7.    ファブリック エクステンダの NX-2000-100 に vPC サーバ ポートを設定します。

                              8.    設定を保存します。


                            手順の詳細
                              ステップ 1   vPC および LACP をイネーブルにします。
                              NX-5000-1# configure terminal
                              NX-5000-1(config)# feature lacp
                              NX-5000-1(config)# feature vpc
                               
                              ステップ 2   SVI インターフェイスをイネーブルにし、vPC ピアキープアライブ リンクで使用する VLAN および SVI を作成します。
                              NX-5000-1(config)# feature interface-vlan
                              NX-5000-1(config)# vlan 900
                              NX-5000-1(config-vlan)# int vlan 900
                              NX-5000-1(config-if)# ip address 10.10.10.236 255.255.255.0
                              NX-5000-1(config-if)# no shutdown
                              NX-5000-1(config-if)# exit
                               
                              ステップ 3   vPC ドメインを作成し、vPC ピアキープアライブ リンクをデフォルト VRF に追加します。
                              NX-5000-1(config)# vpc domain 30
                              NX-5000-1(config-vpc-domain)# peer-keepalive destination 10.10.10.237 source 10.10.10.236 vrf default
                              NX-5000-1(config-vpc-domain)# exit
                               
                              (注)     

                              VLAN 900 は、vPC ピアキープアライブ メッセージが伝送されるため、vPC ピアリンク上をトランクされないようにする必要があります。 vPC ピアキープアライブ メッセージを伝送できるように、NX-5000-1 スイッチと NX-5000-2 スイッチの間には代替パスが必要です。

                              ステップ 4   vPC ピア リンクを 2 ポートの EtherChannel として設定します。
                              NX-5000-1(config)# interface ethernet 1/1-2
                              NX-5000-1(config-if-range)# switchport mode trunk
                              NX-5000-1(config-if-range)# switchport trunk allowed vlan 20-50
                              NX-5000-1(config-if-range)# switchport trunk native vlan 20
                              NX-5000-1(config-if-range)# channel-group 30 mode active
                              NX-5000-1(config-if-range)# exit
                              NX-5000-1(config)# interface port-channel 30
                              NX-5000-1(config-if)# vpc peer-link
                              NX-5000-1(config-if)# exit
                               
                              ステップ 5   ファブリック エクステンダの NX-2000-100 を設定します。
                              NX-5000-1(config)# fex 100
                              NX-5000-1(config-fex)# pinning max-links 1
                              NX-5000-1(fex)# exit
                               
                              ステップ 6   ファブリック エクステンダの NX-2000-100 に対して、ファブリック EtherChannel リンクを設定します。
                              NX-5000-1(config)# interface ethernet 1/20-21
                              NX-5000-1(config-if)# channel-group 100
                              NX-5000-1(config-if)# exit
                              NX-5000-1(config)# interface port-channel 100
                              NX-5000-1(config-if)# switchport mode fex-fabric
                              NX-5000-1(config-if)# fex associate 100
                              NX-5000-1(config-if)# exit
                               
                              ステップ 7   ファブリック エクステンダの NX-2000-100 に vPC サーバ ポートを設定します。
                              NX-5000-1(config-if)# interface ethernet 100/1/1
                              NX-5000-1(config-if)# switchport mode trunk
                              NX-5000-1(config-if)# switchport trunk native vlan 100
                              NX-5000-1(config-if)# switchport trunk allowed vlan 100-105
                              NX-5000-1(config-if)# channel-group 600
                              NX-5000-1(config-if)# no shutdown
                              NX-5000-1(config-if)# exit
                              NX-5000-1(config)# interface port-channel 600
                              NX-5000-1(config-if)# vpc 600
                              NX-5000-1(config-if)# no shutdown
                              NX-5000-1(config-if)# exit
                               
                              ステップ 8   設定を保存します。
                              NX-5000-1(config)# copy running-config startup-config
                               

                              vPC のデフォルト設定

                              次の表は、vPC パラメータのデフォルト設定をまとめたものです。

                              表 1  デフォルト vPC パラメータ

                              パラメータ

                              デフォルト

                              vPC システム プライオリティ

                              32667

                              vPC ピアキープアライブ メッセージ

                              ディセーブル

                              vPC ピアキープアライブ間隔

                              1 秒

                              vPC ピアキープアライブ タイムアウト

                              5 秒

                              vPC ピアキープアライブ UDP ポート

                              3200