Cisco Nexus 5000 シリーズ スイッチ CLI ソフト ウェア コンフィギュレーション ガイド
ファイバ チャネル インターフェイスの設定
ファイバ チャネル インターフェイスの設定
発行日;2012/02/01 | 英語版ドキュメント(2009/08/13 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

ファイバ チャネル インターフェイスの設定

ファイバ チャネル インターフェイスの概要

ライセンス要件

物理ファイバ チャネル インターフェイス

仮想ファイバ チャネル インターフェイス

インターフェイス モード

E ポート

F ポート

NP ポート

TE ポート

SD ポート

auto モード

インターフェイス ステート

管理ステート

動作ステート

理由コード

Buffer-to-Buffer credit(BB_credit)

ファイバ チャネル インターフェイスの設定

ファイバ チャネル インターフェイスの設定

インターフェイス管理ステートの設定

インターフェイス モードの設定

インターフェイスの説明の設定

ポート速度の設定

自動検知

SD ポート フレーム カプセル化の設定

受信データ フィールド サイズの設定

ビット エラーしきい値の概要

BB_credit の設定

ファイバ チャネル インターフェイスのグローバル属性の設定

スイッチ ポート属性のデフォルト値の設定

N ポート識別子仮想化の概要

N ポート識別子仮想化のイネーブル化

ファイバ チャネル インターフェイスの確認

SFP トランスミッタ タイプの確認

インターフェイス情報の確認

BB_credit 情報の確認

デフォルト設定値

ファイバ チャネル インターフェイスの設定

この章では、ファイバ チャネル インターフェイスおよび仮想ファイバ チャネル インターフェイスのインターフェイス設定について説明します。この章の内容は、次のとおりです。

「ファイバ チャネル インターフェイスの概要」

「ファイバ チャネル インターフェイスの設定」

「ファイバ チャネル インターフェイスのグローバル属性の設定」

「ファイバ チャネル インターフェイスの確認」

「デフォルト設定値」

ファイバ チャネル インターフェイスの概要

ここでは、ファイバ チャネル インターフェイスおよび仮想ファイバ チャネル インターフェイスについて説明します。ここで説明する内容は、次のとおりです。

「ライセンス要件」

「物理ファイバ チャネル インターフェイス」

「仮想ファイバ チャネル インターフェイス」

「インターフェイス モード」

「インターフェイス ステート」

「Buffer-to-Buffer credit(BB_credit)」

ライセンス要件

Cisco Nexus 5000 シリーズ スイッチでは、ファイバ チャネル 機能は Storage Protocol Services ライセンスに含まれます。

ファイバ チャネル インターフェイスとその機能を使用する前に、正しいライセンス(N5010SS または N5020SS)がインストールされていることを確認します。


) Storage Protocol Services ライセンスなしで仮想ファイバ チャネル インターフェイスを設定できますが、ライセンスがアクティブになるまでこれらのインターフェイスは動作状態になりません。


物理ファイバ チャネル インターフェイス

Cisco Nexus 5000 シリーズ スイッチは最大 8 つの物理ファイバ チャネル アップリンクを提供します。ファイバ チャネル インターフェイスは任意の拡張モジュールでサポートされます。ファイバ チャネルおよびイーサネット拡張モジュールには 4 つのファイバ チャネル インターフェイスが含まれます。

各ファイバ チャネル ポートをダウンリンク(サーバに接続)、またはアップリンク(データセンター SAN ネットワークに接続)として使用できます。ファイバ チャネル インターフェイスは、F、NP、E、TE、および SD のモードをサポートします。

仮想ファイバ チャネル インターフェイス

Fibre Channel over Ethernet(FCoE)カプセル化により、物理イーサネット ケーブルでファイバ チャネルとイーサネット トラフィックを同時に伝送できます。Cisco Nexus 5000 シリーズ スイッチでは、FCoE 対応の物理イーサネット インターフェイスは、1 つの仮想のファイバ チャネル インターフェイスのトラフィックを伝送できます。

ネイティブ ファイバ チャネル インターフェイスと仮想ファイバ チャネル インターフェイスは、同じ CLI コマンドを使用して設定します。仮想ファイバ チャネル インターフェイスは F モードだけをサポートし、ネイティブ ファイバ チャネル インターフェイスでサポートされる機能のサブセットを提供します。

次の機能は、仮想ファイバ チャネル インターフェイスではサポートされません。

SAN ポート チャネル

VSAN(仮想 SAN)トランキング。仮想ファイバ チャネルは 1 つの VSAN に関連付けられます。

SPAN 宛先は仮想ファイバ チャネル インターフェイスになることはできません。

Buffer-to-Buffer credit(BB_credit)

Exchange Link Parameter(ELP)または Fabric Shortest Path First(FSPF)プロトコル

物理属性の設定(速度、レート、モード、トランスミッタ情報、MTU サイズ)

ポート トラッキング

インターフェイス モード

スイッチ内の各物理ファイバ チャネル インターフェイスは、複数のポート モード(E モード、TE モード、F モード、および SD モード)のうちのいずれかで動作します(図 32-1を参照)。物理ファイバ チャネル インターフェイスを E ポート、F ポート、または SD ポートとして設定できます。インターフェイスを auto モードに設定することもできます。ポート タイプは、インターフェイスの初期化中に判別されます。

NPV モードでは、ファイバ チャネル インターフェイスは NP モード、F モード、または SD モードで動作します。NPV モードの詳細については、 第 34 章「NPV の設定」 を参照してください。

仮想ファイバ チャネル インターフェイスは F モードでだけ設定できます。

図 32-1 スイッチ ポート モード

 


) デフォルトでは、インターフェイスには VSAN 1 が自動的に割り当てられます。第 37 章「VSAN の設定と管理」を参照してください。


各インターフェイスには、管理設定と動作ステータスが対応付けられています。

管理設定は、変更を加えないかぎり変更されません。この設定には、管理モードで設定できる各種の属性があります。

動作ステータスは、インターフェイス速度のような指定された属性の現在のステータスを表します。このステータスは変更できず、読み取り専用です。インターフェイスがダウンの状態のときは、値の一部(たとえば、動作速度)が有効にならない場合があります。

ここでは、各インターフェイス モードの概要を示します。

「E ポート」

「F ポート」

「NP ポート」

「TE ポート」

「SD ポート」

「auto モード」

E ポート

拡張ポート(E ポート)モードでは、インターフェイスがファブリック拡張ポートとして機能します。このポートを別の E ポートに接続し、2 つのスイッチ間で Inter Switch Link(ISL; スイッチ間リンク)を作成できます。E ポートはフレームをスイッチ間で伝送し、ファブリックを設定および管理できるようにします。リモート N ポート宛てフレームのスイッチ間コンジットとして機能します。E ポートは、クラス 3 およびクラス F サービスをサポートします。

別のスイッチに接続された E ポートも、SAN ポート チャネルを形成するように設定できます( 第 36 章「SAN ポート チャネルの設定」 を参照)。

F ポート

ファブリック ポート(F ポート)モードでは、インターフェイスがファブリック ポートとして機能します。このポートを N ポートとして動作する周辺装置(ホストまたはディスク)に接続できます。F ポートは、1 つの N ポートだけに接続できます。F ポートはクラス 3 サービスをサポートします。

NP ポート

スイッチが NPV モードで動作しているとき、スイッチをコア ネットワーク スイッチに接続するインターフェイスは NP ポートとして設定されます。NP ポートは N ポートと同様に動作しますが、複数の物理 N ポートに対するプロキシとして機能します。

NP ポートおよび NPV の詳細については、 第 34 章「NPV の設定」 を参照してください。

TE ポート

トランキング E ポート(TE ポート)モードでは、インターフェイスがトランキング拡張ポートとして機能します。別の TE ポートに接続し、2 つのスイッチ間で Extended ISL(EISL)を作成します。TE ポートは別の Cisco Nexus 5000 シリーズ スイッチまたは Cisco MDS 9000 ファミリ スイッチに接続します。E ポートの機能を拡張して、次の内容をサポートします。

VSAN(仮想 SAN)トランキング。

ファイバ チャネル トレース(fctrace)機能

TE ポート モードでは、すべてのフレームが VSAN 情報を含む EISL フレーム フォーマットで送信されます。相互接続されたスイッチは VSAN ID を使用して、1 つまたは複数の VSAN からのトラフィックを同一の物理リンク上で多重化します。この機能は、Cisco Nexus 5000 シリーズでは VSAN トランキングと呼ばれます( 第 35 章「VSAN トランキングの設定」 を参照)。TE ポートは、クラス 3 およびクラス F サービスをサポートします。

SD ポート

SPAN 宛先ポート(SD ポート)モードでは、インターフェイスが Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)として機能します。SPAN 機能は、ファイバ チャネル インターフェイスを通過するネットワーク トラフィックを監視します。このモニタリングは、SD ポートに接続された標準ファイバ チャネル アナライザ(または同様のスイッチ プローブ)を使用して行われます。SD ポートはフレームを受信しません。送信元トラフィックのコピーを送信するだけです。SPAN 機能は他の機能に割り込むことなく、SPAN 送信元ポートのネットワーク トラフィックのスイッチングに影響しません。

auto モード

auto モードに設定されたインターフェイスは、F ポート、E ポート、または TE ポートのいずれかのモードで動作します。ポート モードは、インターフェイスの初期設定中に決定されます。たとえば、インターフェイスがノード(ホストまたはディスク)に接続されている場合、F ポート モードで動作します。インターフェイスがサードパーティ製のスイッチに接続されている場合、E ポート モードで動作します。インターフェイスが Cisco Nexus 5000 シリーズ または Cisco MDS 9000 ファミリの別のスイッチに接続されている場合、TE ポート モードで動作できます( 第 35 章「VSAN トランキングの設定」 を参照)。

SD ポートは初期化で判別されず、管理上設定されます。

インターフェイス ステート

インターフェイス ステートは、インターフェイスの管理設定および物理リンクのダイナミック ステートによって異なります。ここでは、ステートと、ステートに影響を与える設定について説明します。

「管理ステート」

「動作ステート」

「理由コード」

管理ステート

管理のステートは、インターフェイスの管理設定を表します。 表 32-1 に、管理ステートを示します。

 

表 32-1 管理ステート

管理ステート
説明

up

インターフェイスはイネーブルです。

down

インターフェイスはディセーブルです。インターフェイスをシャットダウンして管理上のディセーブル状態にした場合は、物理リンク層ステートの変更が無視されます。

動作ステート

動作ステートは、インターフェイスの現在の動作ステートを示します。 表 32-2 に動作ステートを示します。

 

表 32-2 動作ステート

動作ステート
説明

up

インターフェイスは、トラフィックを要求に応じて送受信しています。このステートにするためには、インターフェイスが管理上アップの状態、インターフェイス リンク レイヤ ステートがアップの状態で、インターフェイスの初期化が完了している必要があります。

down

インターフェイスが(データ)トラフィックを送信または受信できません。

トランキング

インターフェイスが TE モードで正常に動作しています。

理由コード

理由コードは、インターフェイスの動作ステートによって異なります。 表 32-3 に動作ステートの理由コードを示します。

 

表 32-3 インターフェイス ステートの理由コード

管理設定
動作ステータス
理由コード

up

up

なし

down

down

管理上のダウン。インターフェイスを管理上ダウンの状態に設定する場合、インターフェイスをディセーブルにします。トラフィックが受信または送信されません。

up

down

表 32-4 を参照してください。


表 32-4に示されている理由コードは一部だけです。


管理ステートが up で、動作ステートが down の場合、理由コードは、動作不能理由コードに基づいて異なります。 表 32-4 に動作不能ステートの理由コードを示します。

 

表 32-4 動作不能ステートの理由コード

理由コード(長いバージョン)
説明
適用可能なモード

Link failure or not connected

物理層リンクが正常に動作していません。

すべて

SFP not present

Small Form-factor Pluggable(SFP)ハードウェアが接続されていません。

Initializing

物理層リンクが正常に動作しており、プロトコル初期化が進行中です。

すべて

Reconfigure fabric in progress

ファブリックが現在再設定されています。

Offline

初期化を再試行する前に、スイッチ ソフトウェアが指定された R_A_TOV 時間待機します。

Inactive

インターフェイス VSAN が削除されているか、suspended ステートにあります。

インターフェイスを正常に動作させるには、設定されたアクティブな VSAN にポートを割り当てます。

Hardware failure

ハードウェア障害が検出されました。

Error disabled

エラー条件は、管理上の注意を必要とします。さまざまな理由でインターフェイスがエラーディセーブルになることがあります。次に例を示します。

設定障害

互換性のない BB_credit 設定

インターフェイスを正常に動作させるには、まずこのステートの原因となるエラー条件を修正し、次にインターフェイスを管理上シャットダウンにするか、インターフェイスをイネーブルにします。

Isolation because limit of active port channels is exceeded.

スイッチにアクティブ SAN ポート チャネルの最大数がすでに設定されているので、インターフェイスは隔離されます。

Isolation due to ELP failure

ポート ネゴシエーションが失敗しました。

E ポートと TE ポートのみ

Isolation due to ESC failure

ポート ネゴシエーションが失敗しました。

Isolation due to domain overlap

Fibre Channel Domain(fcdomain)のオーバーラップ

Isolation due to domain ID assignment failure

割り当てられたドメイン ID が無効です。

Isolation due to the other side of the link E port isolated

リンクのもう一方の端の E ポートが分離しています。

Isolation due to invalid fabric reconfiguration

ファブリックの再設定によりポートが分離されました。

Isolation due to domain manager disabled

fcdomain 機能がディセーブルです。

Isolation due to zone merge failure

ゾーン結合に失敗しました。

Isolation due to VSAN mismatch

ISL の両端の VSAN が異なります。

port channel administratively down

SAN ポート チャネルに所属するインターフェイスがダウンの状態です。

SAN ポート チャネル インターフェイスのみ

Suspended due to incompatible speed

SAN ポート チャネルに所属するインターフェイスに互換性のない速度が存在します。

Suspended due to incompatible mode

SAN ポート チャネルに所属するインターフェイスに互換性のないモードが存在します。

Suspended due to incompatible remote switch WWN

不適切な接続が検出されました。SAN ポート チャネルのすべてのインターフェイスが同一のスイッチ ペアに接続されている必要があります。

Bound physical interface down

仮想ファイバ チャネル インターフェイスにバインドされたイーサネット インターフェイスが動作していません。

仮想ファイバ チャネル インターフェイスのみ

STP not forwarding in FCoE mapped VLAN

仮想ファイバ チャネル インターフェイスにバインドされたイーサネット インターフェイスが、仮想ファイバ チャネル インターフェイスに関連付けられた VLAN に対して STP フォワーディング ステートではありません。

仮想ファイバ チャネル インターフェイスのみ

Buffer-to-Buffer credit(BB_credit)

BB_credit はフロー制御メカニズムで、ファイバ チャネル インターフェイスがフレームをドロップしないようにします。BB_creditは、ホップごとにネゴシエーションします。

Cisco Nexus 5000 シリーズ スイッチでは、BB_credit メカニズムは仮想ファイバ チャネル インターフェイスではなく、ファイバ チャネル インターフェイスで使用されます。仮想ファイバ チャネル インターフェイスは、基本の物理イーサネット インターフェイスの機能に基づいて、フロー制御を実行します。

受信 BB_credit(fcrxbbcredit)値を各ファイバ チャネル インターフェイスに設定できます。ほとんどの場合、デフォルト設定を変更する必要がありません。


) 受信 BB_credit 値は、ポート モードによって異なります。物理ファイバ チャネル インターフェイスの場合、F モードおよび E モード インターフェイスのデフォルト値は 16 です。必要に応じて、この値を変更できます。最大値は 64 です。



) 仮想ファイバ チャネル インターフェイスの場合、BB_credit は使用されません。


ファイバ チャネル インターフェイスの設定

ここでは、ファイバ チャネル インターフェイスを設定する方法について説明します。内容は次のとおりです。

「ファイバ チャネル インターフェイスの設定」

「インターフェイス管理ステートの設定」

「インターフェイス モードの設定」

「インターフェイスの説明の設定」

「ポート速度の設定」

「SD ポート フレーム カプセル化の設定」

「受信データ フィールド サイズの設定」

「ビット エラーしきい値の概要」

「BB_credit の設定」

ファイバ チャネル インターフェイスの設定

ファイバ チャネル インターフェイスを設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface { fc slot / port }|{ vfc vfc-id }

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

(注) ファイバ チャネル インターフェイスが設定された場合、自動的に一意の World Wide Name(WWN)が割り当てられます。インターフェイスの動作ステートが up の場合、ファイバ チャネル ID(FC ID)も割り当てられます。

インターフェイスの範囲を設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface fc slot / port - port [ , fc slot / port - port ]

または

switch(config)# interface vfc vfc-id - vfc-id [ , vfc vfc-id - vfc-id ]

ファイバ チャネル インターフェイスの範囲を選択し、インターフェイス コンフィギュレーション モードを開始します。

 

 

インターフェイス管理ステートの設定

インターフェイスを正常にシャットダウンする手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface { fc slot / port }|{ vfc vfc-id }

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# shutdown

インターフェイスを正常にシャットダウンし、トラフィック フローを管理上ディセーブルにします(デフォルト)。

トラフィック フローをイネーブルにする手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface { fc slot / port }|{ vfc vfc-id }

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# no shutdown

no プレフィクスが使用された場合(動作ステートは up)、管理上トラフィックを許可するようにトラフィック フローをイネーブルにします。

バインドされたイーサネット インターフェイスが動作し、その STP ポート ステートがアクティブである場合は、仮想ファイバ チャネル インターフェイスが動作状態になります。

インターフェイス モードの設定

インターフェイス モードを設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface { fc slot / port }|{ vfc vfc-id }

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport mode F

仮想ファイバ チャネルの場合、F ポート モードだけがサポートされます。

switch(config-if)# switchport mode E | F | SD | auto

ファイバ チャネル インターフェイスの場合、モードを E、F、または SD ポート モードに設定できます。E、F、または TE ポート モード動作(SD ポート モードは含まない)を自動ネゴシエーションするには、モードを auto に設定します。

(注) SD ポートを自動では設定できません。このポートは管理上設定する必要があります。

インターフェイスの説明の設定

インターフェイスの説明は、トラフィックを識別したり、インターフェイスの使用状況を知る場合に役立ちます。インターフェイスの説明には、任意の英数字ストリングを指定できます。

インターフェイスの説明を設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface { fc slot / port }|{ vfc vfc-id }

 

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport description cisco-HBA2

インターフェイスの説明を設定します。ストリングの長さは、最大 80 文字まで可能です。

switch(config-if)# no switchport description

インターフェイスの説明をクリアします。

ポート速度の設定

ポート速度は、仮想ファイバ チャネル インターフェイスではなく、物理ファイバ チャネル インターフェイスで設定できます。デフォルトでは、インターフェイスのポート速度はスイッチによって自動計算されます。


注意 ポート速度の変更は中断を伴う動作です。

インターフェイスのポート速度を設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface fc slot / port

指定されたインターフェイスを選択して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport speed 1000

インターフェイスのポート速度を 1000 Mbps に設定します。

数値は、Mbps 単位の速度を表します。1 Gbps インターフェイスには 1000 Mbps の速度、2 Gbps インターフェイスには 2000 Mbps の速度、4 Gbps インターフェイスには 4000 、または auto (デフォルト)を設定できます。

switch(config-if)# no switchport speed

インターフェイスの出荷時の設定( auto )管理速度に戻します。

自動検知

デフォルトではすべての 4 Gbps インターフェイスで 速度自動検知がイネーブルになっています。この設定を使用すると、4 Gbps ポートのインターフェイスは 1 Gbps、2 Gbps、または 4 Gbps の速度で動作します。専用レート モードで動作するインターフェイスに対して自動検知をイネーブルにすると、ポートが 1 Gbps または 2 Gbps の動作速度をネゴシエートした場合でも、4 Gbps 帯域幅が予約されます。

SD ポート フレーム カプセル化の設定

switchport encap eisl コマンドは、SD ポート インターフェイスにだけ適用されます。このコマンドは、SD ポート モードにあるインターフェイスによって送信されたすべてのフレームのフレーム フォーマットを判別します。カプセル化を EISL に設定すると、すべての SPAN 送信元について、すべての発信フレームが EISL フレーム フォーマットで送信されます。

switchport encap eisl コマンドは、デフォルトではディセーブルです。カプセル化をイネーブルにする場合、すべての発信フレームがカプセル化され、 show interface SD_port_interface コマンド出力に新しい行(Encapsulation is eisl)が表示されます。

受信データ フィールド サイズの設定

仮想ファイバ チャネル インターフェイスではなく、ネイティブ ファイバ チャネル インターフェイスの受信データ フィールド サイズを設定できます。デフォルトのデータ フィールド サイズが 2112 バイトの場合、フレームの長さは 2148 バイトです。

受信データ フィールド サイズを設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface fc slot / port

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport fcrxbufsize 2000

選択されたインターフェイスのデータ フィールド サイズを 2000 バイトに減らします。デフォルトは 2112 バイトで、範囲は 256 ~ 2112 バイトです。

ビット エラーしきい値の概要

ビット エラー レートしきい値は、パフォーマンスの低下がトラフィックに重大な影響を与える前にエラー レートの増加を検出するために、スイッチにより使用されます。

ビット エラーは次のような理由のため発生します。

ケーブル故障または不良

GBIC または SFP 故障または不良

GBIC または SFP は 1 Gbps で動作するように指定されているが、2 Gbps で使用されている。

GBIC または SFP は 2 Gbps で動作するように指定されているが、4 Gbps で使用されている。

長距離に短距離ケーブルが使用されている、または短距離に長距離ケーブルが使用されている。

一時的な同期ロス

ケーブルの片端または両端の接続のゆるみ

片端または両端での不適切な GBIC 接続または SFP 接続

5 分間に 15 のエラー バーストが発生すると、ビット エラー レートしきい値が検出されます。デフォルトでは、しきい値に達するとスイッチはインターフェイスをディセーブルにします。

shutdown/no shutdown コマンドを入力して、インターフェイスを再度イネーブルにできます。

しきい値を超えてもインターフェイスがディセーブルにならないようにスイッチを設定できます。

インターフェイスのビット エラーしきい値をディセーブルにする手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface fc slot / port

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport ignore bit-errors

ビット エラーしきい値イベントを検出したとき、インターフェイスがディセーブルにならないようにします。

switch(config-if)# no switchport ignore bit-errors

ビット エラーしきい値イベントを検出したとき、インターフェイスがイネーブルにならないようにします。


) ビット エラーしきい値イベントによってインターフェイスがディセーブルにならないように設定されていても、ビット エラーしきい値イベントが検出されると、スイッチによって syslog メッセージが生成されます。


BB_credit の設定

ファイバ チャネル インターフェイスの BB_credit を設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface fc slot / port

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport fcrxbbcredit default

デフォルトの使用可能な値を選択されたインターフェイスに適用します。使用可能な値は、ポート モードによって異なります。デフォルト値は、ポート機能に応じて割り当てられます。

switch(config-if)# switchport fcrxbbcredit 5

選択されたインターフェイスの BB_credit を 5 に割り当てます。BB_credit を割り当てる範囲は、1 ~ 64 です。

switch(config-if)# switchport fcrxbbcredit 5 mode E

ポートが E モードまたは TE モードで動作する場合は、この値を割り当てます。BB_credit を割り当てる範囲は、1 ~ 64 です。

switch(config-if)# switchport fcrxbbcredit 5 mode Fx

ポートが F モードで動作する場合は、この値を割り当てます。BB_credit を割り当てる範囲は、1 ~ 64 です。

ステップ 4

switch(config-if# do show int fc slot / port

送受信の BB_credit をこのインターフェイスのその他の関連インターフェイス情報とともに表示します。

(注) レジスタが読み取られるとき、BB_credit は正しい値です。データ トラフィックが遅いときに状況を確認するのに役立ちます。

ファイバ チャネル インターフェイスのグローバル属性の設定

ここでは、スイッチのすべてのファイバ チャネル インターフェイスに適用されるグローバル属性の設定について説明します。ここで説明する内容は、次のとおりです。

「スイッチ ポート属性のデフォルト値の設定」

「N ポート識別子仮想化の概要」

「N ポート識別子仮想化のイネーブル化」

スイッチ ポート属性のデフォルト値の設定

各種のスイッチ ポート属性の属性デフォルト値を設定できます。これらの属性は、この時点でそれぞれを指定しなくても、今後のすべてのスイッチ ポート設定にグローバルに適用されます。

スイッチ ポート属性を設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# no system default switchport shutdown san

インターフェイス管理ステートのデフォルト設定を up に設定します (出荷時のデフォルト設定は down です)。

ヒント このコマンドは、管理ステートに対してユーザ設定が存在しないインターフェイスにだけ適用されます。

switch(config)# system default switchport shutdown san

インターフェイス管理ステートのデフォルト設定を down に設定します。これが出荷時のデフォルト設定です。

ヒント このコマンドは、管理ステートに対してユーザ設定が存在しないインターフェイスにだけ適用されます。

switch(config)# system default switchport trunk mode auto

インターフェイスの管理トランク モード ステートのデフォルト設定を auto に設定します。

(注) デフォルト設定のトランク モードは on です。

N ポート識別子仮想化の概要

N port identifier virtualization(NPIV; N ポート識別子仮想化)は単一 N ポートに複数の FC ID を割り当てる手段を提供します。この機能を使用すると、N ポート上の複数のアプリケーションが異なる ID を使用したり、アクセス コントロール、ゾーニング、ポート セキュリティをアプリケーション レベルで実装したりできます。図 32-2 に、NPIV を使用したアプリケーション例を示します。

図 32-2 NPIV の例

 

N ポート識別子仮想化のイネーブル化

スイッチ上のすべての VSAN に対して NPIV をグローバルでイネーブルにし、NPIV 対応のアプリケーションが複数の N ポート ID を使用できるようにする必要があります。


) すべての N ポート ID は同じ VSAN 内で割り当てられます。


スイッチの NPIV をイネーブルまたはディセーブルにする手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configuration terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# npiv enable

スイッチ上のすべての VSAN の NPIV をイネーブルにします。

ステップ 3

switch(config)# no npiv enable

スイッチ上の NPIV をディセーブルにします(デフォルト)。

ファイバ チャネル インターフェイスの確認

ここでは、ファイバ チャネル インターフェイスを表示するコマンドについて説明します。

「SFP トランスミッタ タイプの確認」

「インターフェイス情報の確認」

「BB_credit 情報の確認」

SFP トランスミッタ タイプの確認

SFP トランスミッタ タイプは、仮想ファイバ チャネルではなく、物理ファイバ チャネル インターフェイス用に表示できます。

SFP ハードウェア トランスミッタは、 show interface brief コマンドで表示される際に略語で示されます。関連する SFP がシスコによって割り当てられた拡張 ID を持つ場合、 show interface コマンドと show interface brief コマンドは、トランスミッタ タイプではなく、ID を表示します。 show interface transceiver コマンドと show interface fc slot / port transceiver コマンドは、シスコがサポートする SFP に対して両方の値を表示します。

インターフェイス情報の確認

show interface コマンドはインターフェイス情報を表示します。引数を入力しないと、このコマンドはスイッチ内に設定されたすべてのインターフェイスの情報を表示します。

インターフェイス情報を表示するのに引数(インターフェイスの範囲、または複数の指定されたインターフェイス)を指定することもできます。次の形式でコマンドを入力して、インターフェイスの範囲を指定できます。

interface fc2/1 - 4 , fc3/2 - 3
 

次に、すべてのインターフェイスを表示する例を示します。

switch# show interface
fc3/1 is up
...
fc3/3 is up
...
Ethernet1/3 is up
...
mgmt0 is up
...
vethernet1/1 is up
...
vfc 1 is up
...
 

次に、指定された複数のインターフェイスを表示する例を示します。

switch# show interface fc3/1 , fc3/3
fc3/1 is up
...
fc3/3 is up
...
 

次に、特定の 1 つのインターフェイスを表示する例を示します。

switch# show interface vfc 1
vfc 1 is up
...
 

次に、インターフェイスの説明を表示する例を示します。

switch# show interface description
-------------------------------------------------------------------------------
Interface Description
-------------------------------------------------------------------------------
fc3/1 test intest
Ethernet1/1 --
vfc 1 --
...
 

次に、すべてのインターフェイスを表示する例を示します(簡略)。

switch# show interface brief
 

次に、インターフェイス カウンタを表示する例を示します。

switch# show interface counters
 

次に、特定のインターフェイスのトランシーバ情報を表示する例を示します。

switch# show interface fc3/1 transceiver
 

) SFP が存在する場合にだけ、show interface transceiver コマンドは有効です。


show running-configuration コマンドを実行すると、すべてのインターフェイスの情報を含む実行コンフィギュレーション全体が表示されます。スイッチがリロードしたとき、インターフェイス コンフィギュレーション コマンドが正しい順序で実行するように、インターフェイスはコンフィギュレーション ファイルに複数のエントリを持っています。特定のインターフェイスの実行コンフィギュレーションを表示する場合、そのインターフェイスのすべてのコンフィギュレーション コマンドはグループ化されます。

次の例では、すべてのインターフェイスの実行コンフィギュレーションを表示する場合のインターフェイスの表示を示します。

switch# show running configuration
...
interface fc3/5
switchport speed 2000
...
interface fc3/5
switchport mode E
...
interface fc3/5
channel-group 11 force
no shutdown
 

次の例では、特定のインターフェイスの実行コンフィギュレーションを表示する場合のインターフェイスの表示を示します。

switch# show running configuration fc3/5
interface fc3/5
switchport speed 2000
switchport mode E
channel-group 11 force
no shutdown
 

BB_credit 情報の確認

次に、すべてのファイバ チャネル インターフェイスの BB_credit 情報を表示する例を示します。

switch# show interface bbcredit
...
fc2/3 is trunking
Transmit B2B Credit is 255
Receive B2B Credit is 12
Receive B2B Credit performance buffers is 375
12 receive B2B credit remaining
255 transmit B2B credit remaining
 

デフォルト設定値

表 32-5 に、ネイティブ ファイバ チャネル インターフェイス パラメータのデフォルト設定値を示します。

 

表 32-5 デフォルトのネイティブ ファイバ チャネル インターフェイス パラメータ

パラメータ
デフォルト

インターフェイス モード

auto

インターフェイス速度

auto

管理ステート

Shutdown(初期設定時に変更された場合を除く)

トランク モード

On(初期設定時に変更された場合を除く)

トランク許可 VSAN

1 ~ 4093

インターフェイス VSAN

デフォルト VSAN(1)

標識モード

Off(ディセーブル)

EISL カプセル化

ディセーブル

データ フィールド サイズ

2112 バイト

表 32-6 に、仮想ファイバ チャネル インターフェイス パラメータのデフォルト設定値を示します。

 

表 32-6 デフォルトの仮想ファイバ チャネル インターフェイス パラメータ

パラメータ
デフォルト

インターフェイス モード

auto

インターフェイス速度

なし

管理ステート

Shutdown(初期設定時に変更された場合を除く)

トランク モード

なし

トランク許可 VSAN

なし

インターフェイス VSAN

デフォルト VSAN(1)

EISL カプセル化

なし

データ フィールド サイズ

なし