Cisco Nexus 4001I/4005I Switch Module for IBM BladeCenter NX-OS コンフィギュレーション ガイド
スイッチの設定
スイッチの設定
発行日;2012/05/10 | 英語版ドキュメント(2012/05/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 15MB) | フィードバック

目次

スイッチの設定

スイッチのイメージ ファイル

スイッチの起動

ブーティング メカニズム

コンソール設定

スイッチのアップグレード

アップグレード手順の概要

アップグレードの詳細手順

以前のリリースへのダウングレード

初期設定

設定要件

初期設定

スイッチの設定準備

デフォルトのログイン

スイッチの設定

初期設定の変更

スイッチへのアクセス

スイッチのその他の設定

スイッチ名の割り当て

日付、時刻、およびタイム ゾーンの設定

夏時間への調整

NTP 設定

NTP について

NTP 設定時の注意事項

NTP の設定

管理インターフェイスの設定

mgmt インターフェイスについて

管理インターフェイスの設定

管理インターフェイスの設定の表示

管理インターフェイスのシャットダウン

スイッチ コンフィギュレーションの管理

スイッチ コンフィギュレーションの表示

コンフィギュレーションの保存

コンフィギュレーションのクリア

スイッチ ファイル システムの使用

カレント ディレクトリの設定

カレント ディレクトリの表示

ディレクトリ内のファイルの一覧表示

ディレクトリの作成

既存のディレクトリの削除

ファイルの移動

ファイルのコピー

ファイルの削除

ファイル内容の表示

コマンド出力のファイルへの保存

ファイルの圧縮および圧縮解除

スイッチのイメージ ファイル

Cisco Nexus 4001I/4005I Switch Module for IBM BladeCenterには次のイメージがあります。

1 つのファイルに組み合わされた BIOS イメージおよびローダ イメージ

キックスタート イメージ

アップグレード可能な BIOS イメージを含むシステム イメージ

このスイッチにはフラッシュ メモリがあり、次の 2 つのフラッシュ部分から構成されています。

2 つの BIOS イメージおよびローダ イメージを保持する、2 MB のフラッシュ部分

設定ファイル、キックスタート イメージ、システム イメージ、その他のファイルを保持する、1 GB のフラッシュ部分

アップグレード可能な BIOS およびゴールデン BIOS は、2 MB のフラッシュ部分にプログラムされています。ゴールデン BIOS はアップグレードできません。

キックスタート イメージとシステム イメージの新しいペアをダウンロードすると、新しい BIOS イメージも取得されます。BIOS イメージがシステム イメージに組み込まれているからです。キックスタート イメージ、システム イメージ、アップグレード可能 BIOS イメージをアップグレードするには、 install all コマンドを使用します。

ここでは、次の内容について説明します。

「スイッチの起動」

「ブーティング メカニズム」

「コンソール設定」

スイッチの起動

スイッチを IBM BladeCenter のスロットに完全に挿入すると、ブート プロセスが始まります。このスイッチには電源スイッチがありません。

ブーティング メカニズム

このスイッチには冗長ブート BIOS メカニズムがあります。

スイッチのブート時に、BIOS の場所をチェックします。プライマリ ブートフラッシュに有効な BIOS が含まれている場合、スイッチはそこからブートします。プライマリ ブートフラッシュがそこにないか、壊れている場合、スイッチはセカンダリ BIOS をチェックしてそこからブートします。

BIOS は多数のテストを実行し、いずれかのテストに失敗すると、ブート プロセスが停止し、ローダ プロンプトが表示されます。

コンソール設定

ローダ イメージ、キックスタート イメージ、システム イメージのデフォルト コンソール設定は次のとおりです。

速度:9600 ボー

データビット:1 バイトごとに 8 ビット

ストップビット:1 ビット

パリティ:なし

この設定はスイッチに保存されており、3 つすべてのイメージは保存されているコンソール設定を使用します。

コンソール設定を変更するには、コンフィギュレーション モードで line console コマンドを使用します。次の例ではライン コンソールを設定し、その端末ラインのオプションを設定しています。

switch# configure terminal
switch(config)# line console
switch(config-console)# databits 7
switch(config-console)# exec-timeout 30
switch(config-console)# parity even
switch(config-console)# stopbits 2

BIOS コンソール設定は変更できません。この設定は、デフォルトのコンソール設定と同じです。

スイッチのアップグレード


) network-administrator ロールを持つユーザは、スイッチのソフトウェア イメージをアップグレードできます。


ここでは、次の内容について説明します。

「アップグレード手順の概要」

「アップグレードの詳細手順」

アップグレード手順の概要

スイッチ ソフトウェアをアップグレードするには、次の手順を実行します。


ステップ 1 スイッチのコンソール ポートにログインします。

ステップ 2 Cisco.com にログインし、キックスタート イメージおよびシステム イメージをサーバにダウンロードします。

ステップ 3 copy コマンドを使用し、キックスタート イメージおよびシステム イメージをスイッチにダウンロードします。

ステップ 4 install all コマンドを使用し、イメージをインストールします。


注意 スイッチがインストールを実行している間、スイッチを通過するすべてのトラフィックは中断されます。


 

アップグレードの詳細手順


注意 スイッチをアップグレードすると、すべてのトラフィックは中断されます。

スイッチのソフトウェアをアップグレードする手順は次のとおりです。


ステップ 1 コンソール ポート接続でスイッチにログインします。

ステップ 2 Cisco.com にログインし、Software Download Center にアクセスします。Cisco.com にログインするには、 http://www.cisco.com/ を表示してページ最上部の [Log In] をクリックします。シスコ ユーザ名およびパスワードを入力してください。


) Cisco.com に登録していないユーザは、このマニュアルに記載されているリンクにアクセスできません。


ステップ 3 次の URL を使用し、Software Download Center にアクセスします。

http://www.cisco.com/cisco/software/navigator.html?a=a&i=rpm

ステップ 4 スイッチのソフトウェア ダウンロード ページに移動します。

スイッチのダウンロード イメージへのリンクが表示されます。

ステップ 5 関連イメージ ファイルのリリース ノートを参照します。

ステップ 6 キックスタート ソフトウェア ファイルおよびシステム ソフトウェア ファイルを選択し、サーバにダウンロードします。

ステップ 7 コピーするイメージ ファイルに必要となるスペースが、bootflash: ディレクトリにあることを確認します。

switch# dir bootflash:
49 Jul 20 16:09:07 2009 ..tmp-kickstart
26 Jul 20 16:09:08 2009 ..tmp-system
1347 Jan 22 10:54:09 2009 StartupConfigFile
4096 Jan 06 00:13:05 2009 TCLscipts/
9244 Aug 12 07:17:06 2009 aclqosapi.log
20834304 Aug 15 09:40:33 2009 block_kic.bin
73822994 Aug 15 10:02:45 2009 block_sys.bin
26001920 Feb 16 22:38:46 2009 diag-dce1ru-4.0.1a.bin
4096 Dec 08 12:09:05 2008 electra/
1537212 Aug 14 10:08:27 2009 fipsm.out
4130990 Aug 15 14:09:11 2009 fwm_cm.bin
399430 Sep 02 01:03:18 2009 klm_solm.klm
78007 Sep 02 01:02:58 2009 libsolmcli.so
1210 Mar 04 00:40:45 2009 linux-gdbserver.sh
2155 Apr 01 00:13:32 2009 local.isan.init
49152 Jul 20 16:09:07 2009 lost+found/
3514473 Aug 31 18:52:18 2009 n4000_dplug.4.1.2.E1.0.175.gbin
20768768 Aug 29 23:17:18 2009 n4000_kickstart.4.1.2.E1.0.174.gbin
20272128 Aug 31 18:53:33 2009 n4000_kickstart.4.1.2.E1.0.175.gbin
74497726 Aug 31 19:13:35 2009 n4000_system.4.1.2.E1.0.175.gbin
73946627 Sep 09 11:36:46 2009 n4000_system.4.1.2.E1.0.189.bin
6190714 Sep 02 06:56:42 2009 netstack.bin
4096 Apr 14 03:01:17 2009 newer-fs/
73844616 Aug 15 16:29:00 2009 pc_block.sys.bin
4096 Mar 26 22:11:09 2009 plugin/
493264 Sep 02 00:59:10 2009 solm.bin
5446 Sep 02 00:59:31 2009 solm.cli
20683264 Aug 14 11:18:28 2009 taishan_kickstart.4.1.2.E1.0.164.bin
73837768 Aug 14 11:07:30 2009 taishan_system.4.1.2.E1.0.164.bin
4096 Mar 19 21:26:29 2009 vdc_2/
4096 Mar 19 21:26:29 2009 vdc_3/
4096 Mar 19 21:26:29 2009 vdc_4/
 
Usage for bootflash://sup-local
846000128 bytes used
671744 bytes free
846671872 bytes total

ヒント 新しい イメージ ファイルが正常にロードしない場合に使用できるように、最低でも 1 つ前のソフトウェア リリースのキックスタート イメージ ファイルおよびシステム イメージ ファイルを保存しておいてください。


ステップ 8 ダウンロードした新しいイメージ名を指定し、新しいイメージをインストールします。

switch(config)# install all kickstart bootflash:n4000-bk9-kickstart.4.1.2.E1.1.bin system bootflash:n4000-bk9.4.1.2.E1.1.bin

install コマンドは次の処理を実行します。

指定したイメージの互換性チェック( show incompatibility コマンドに相当)を実行します。互換性の問題がある場合はエラー メッセージが表示され、インストールは中断されます。

互換性チェックの結果を表示し、インストールを中断するかどうかを表示します。

プロンプトが表示され、インストールの継続または中断を行うことができるようになります。


) インストールを中断すると、スイッチのリブート中にトラフィックが中断されます。


指定イメージを参照するようにブート変数を更新し、スタートアップ コンフィギュレーション ファイルに設定を保存します。

ステップ 9 スイッチでインストールが完了したらログインし、必要なソフトウェア バージョンをスイッチが実行していることを確認します。

switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2009, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 1.0.28
loader: version N/A
kickstart: version 4.1(2)E1(1) [build 4.1(2)E1(1)] [gdb]
system: version 4.1(2)E1(1) [build 4.1(2)E1(1)] [gdb]
BIOS compile time: 06/17/09
kickstart image file is: bootflash:///n4000_kickstart.4.1.2.E1.1.gbin
kickstart compile time: 8/28/2009 23:00:00 [08/29/2009 10:06:33]
system image file is: bootflash:///n4000_system.4.1.2.E1.1.gbin
system compile time: 8/28/2009 23:00:00 [08/29/2009 09:50:46]
 
 
Hardware
cisco Nexus4010 Chassis ("20x10GE/supervisor")
Motorola, e500v2 with 2076512 kB of memory.
Processor Board ID JAB1303003F
 
Device name: n4000
bootflash: 589836 kB
 
Kernel uptime is 0 day(s), 7 hour(s), 52 minute(s), 10 second(s)
 
Last reset at 899227 usecs after Thu Sep 3 07:27:36 2009
 
Reason: Reset Requested by CLI command reload
System version: 4.1(2)E1(0.170)
Service:
 
plugin
Core Plugin, Ethernet Plugin
 


 

以前のリリースへのダウングレード

スイッチをダウングレードする手順はスイッチのアップグレードと同じですが、ロードするイメージ ファイルは、スイッチで現在実行しているイメージよりも前のリリースになります。


) 特定リリースにダウングレードする前に、スイッチにインストールされている現在のリリースのリリース ノートを確認し、ハードウェアにその特定リリースとの互換性があることを確認してください。


スイッチのソフトウェアをダウングレードする手順は次のとおりです。


ステップ 1 dir bootflash: コマンドを入力し、ダウングレードに使用するイメージ ファイルを特定します。

イメージ ファイルがブートフラッシュ メモリに保存されていない場合は、Cisco.com からファイルをダウンロードします。ソフトウェア アップグレード手順の 1 ~ 9 を使用してください。

ステップ 2 新しいイメージをインストールします。

switch(config)# install all kickstart bootflash:n4000-bk9-kickstart.4.1.2.E1.1.bin system bootflash:n4000-bk9.4.1.2.E1.1.bin

install all コマンドは次の処理を実行します。

指定したイメージの互換性チェック( show incompatibility コマンドに相当)を実行します。互換性の問題がある場合はエラー メッセージが表示され、インストールは中断されます。

互換性チェックの結果を表示し、インストールを中断するかどうかを表示します。

プロンプトが表示され、インストールの継続または中断を行うことができるようになります。


) インストールを中断すると、スイッチのリブート中にトラフィックが中断されます。


指定イメージを参照するようにブート変数を更新し、スタートアップ コンフィギュレーション ファイルに設定を保存します。

ステップ 3 スイッチでインストールが完了したらログインし、必要なソフトウェア バージョンをスイッチが実行していることを確認します。

switch# show version


 

初期設定

ここでは、次の内容について説明します。

「設定要件」

「初期設定」

「スイッチの設定準備」

「デフォルトのログイン」

「スイッチの設定」

「初期設定の変更」

設定要件

ハードウェア インストレーションに必要な作業が完了しているかどうかを次の手順で再確認してください。各作業を完了しないと、スイッチの設定はできません。

次の手順を実行した後に、スイッチを設定できます。


ステップ 1 新しい スイッチの次の物理接続を確認します。

コンピュータ端末(または端末サーバ)にコンソール ポートが物理的に接続されている

管理イーサネット ポート(mgmt0)が外部のハブ、スイッチ、またはルータに接続されている

詳細については、『 Cisco Nexus 4001I and 4005I Switch Module for IBM BladeCenter Hardware Installation Guide 』を参照してください。


ヒント 後で使用するためにホスト ID 情報を控えておいてください(たとえば、ライセンス機能をイネーブルにする場合など)。ホスト ID 情報は、スイッチに同梱されている Proof of Purchase 文書に記載されています。


ステップ 2 デフォルトのコンソール ポートのパラメータが、スイッチ コンソール ポートに接続されたコンピュータ端末(または端末サーバ)のパラメータと同じであることを確認します。

9600 ボー

8 データ ビット

パリティなし

1 ストップ ビット


 

初期設定

IBM BladeCenter でスイッチに初めてアクセスすると、セットアップ プログラムが実行され、スイッチがイーサネット インターフェイス経由で通信するために必要な IP アドレスおよびその他の情報の入力を要求するプロンプトが表示されます。スイッチの設定や管理にも、この情報が必要となります。


) IP アドレスは、CLI からだけ設定できます。スイッチの初回の起動時には、IP アドレスを割り当てる必要があります。


スイッチの設定準備

スイッチを初めて設定する前に、次の情報を確認してください。

管理者パスワード


) パスワードが弱い(短く、解読されやすい)場合、パスワード設定が拒否されます。必ず強固なパスワードを設定するようにしてください。


管理インターフェイスに IPv4 アドレスを使用する場合は、次の情報が必要です。

スイッチの管理インターフェイスの IPv4 サブネット マスク

デフォルト ゲートウェイの IPv4 アドレス(任意)

スイッチの SSH サービス(任意)

このサービスをイネーブルにするには、SSH のキー タイプ(dsa/rsa/rsa1)とキーのビット数(768 ~ 2048)を選択します。

NTP サーバの IPv4 アドレス(任意)

SNMP コミュニティ ストリング(任意)

スイッチ名(任意)

スイッチのプロンプトになります。

追加ログイン アカウントおよびパスワード(任意)


) IPv4 を使用する場合、SNMP アクセスをイネーブルにするには、必ず IPv4 ルート、IPv4 デフォルト ネットワーク アドレス、および IPv4 デフォルト ゲートウェイ アドレスを設定してください。


デフォルトのログイン

スイッチには、デフォルトのユーザであるネットワーク管理者(admin)が設定されています。デフォルトのユーザはどの時点でも変更できません。

デフォルトのパスワードはないので、強固なパスワードを明示的に設定する必要があります。パスワードが簡単な(短く、解読されやすい)場合、パスワード設定が拒否されます。必ず強固なパスワードを設定するようにしてください。新しいパスワードを設定した後に忘れてしまった場合は、このパスワードを回復することもできます。


write erase コマンドを入力してスイッチをリロードした場合、設定手順を使用して、デフォルト ユーザ(admin)のパスワードを再設定する必要があります。


スイッチの設定

ここでは、スイッチの初期設定の方法について説明します。


) プロンプトで Ctrl+C キーを押すことによって、残りの設定オプションを省略し、この時点までの設定で先に進めます。管理者用の新規パスワードの入力は必須で、省略はできません。



ヒント 事前に設定された質問に応答しない場合、または任意の質問の回答を省略する場合は、Enter を押します。デフォルトの回答が見つからない場合(たとえば、スイッチ名)、スイッチは以前の設定を使用して、次の質問に飛びます。

スイッチが起動し、シリアル コンソール接続で初期設定ダイアログを表示すると、スイッチを設定できます。

基本的な設定パラメータを入力する手順は次のとおりです。


ステップ 1 スイッチのコンソール ポートにアクセスするには、ターミナル エミュレータを使用します。

ここでスイッチを設定できます。


) スイッチを購入した代理店にすぐに登録してください。登録に失敗すると、最初のサービスコールの応答に時間がかかることがあります。サポート サービスを受けるにはデバイスを登録する必要があります。


ステップ 2 基本的な設定情報を入力します。

次に、基本的な設定を入力する例を示します。

switch# setup
 
 
---- Basic System Configuration Dialog ----
 
This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.
 
*Note: setup is mainly used for configuring the system initially,
when no configuration is present. So setup always assumes system
defaults and not the current system configuration values.
 
Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.
 

ステップ 3 yes と入力して、セットアップ モードを開始します。

次に、コンフィギュレーション モードを開始する例を示します。

Would you like to enter the basic configuration dialog (yes/no): yes
 

ステップ 4 yes と入力して(デフォルトは no)、追加のアカウントを作成します。

次に、追加のアカウントを作成する例を示します。

Create another login account (yes/no) [n]: y
 

a. ユーザ ログイン ID を入力します。

Enter the User login Id : <ID>
 

b. ユーザ パスワードを入力します。

Enter the password for "qatest": <password>
Please enter a valid password.
 
Confirm the password for "qatest":<password>
Please enter a valid password.
 

c. デフォルトのユーザ ロールを入力します。

Enter the user role [network-operator]:<role>
 

ステップ 5 yes と入力して、SNMP コミュニティ ストリングを設定します。

次に、SNMP コミュニティ ストリングを設定する例を示します。

Configure read-only SNMP community string (yes/no) [n]: y
 
SNMP community string : <string>
 

ステップ 6 スイッチの名前を入力します。

次に、スイッチの名前を入力する例を示します。

Enter the switch name : ibm-switch-1
 

ステップ 7 yes と入力して、帯域外管理を設定します。

次に、帯域外管理を設定する例を示します。

Continue with Out-of-band (mgmt0) management configuration? (yes/no) [y]:
 
Mgmt0 IPv4 address : 10.10.10.1
 
Mgmt0 IPv4 netmask : 255.255.255.0
 

ステップ 8 yes と入力して、IPv4 デフォルト ゲートウェイ(推奨)を設定します。これで、IP アドレスを入力できます。

次に、デフォルト ゲートウェイを設定する例を示します。

Configure the default gateway? (yes/no) [y]:
 
IPv4 address of the default gateway : 10.10.10.100
 

ステップ 9 yes と入力して、Telnet サービスをイネーブルにします。

次に、Telnet サービスをイネーブルにする例を示します。

Enable the telnet service? (yes/no) [y]:
 

ステップ 10 yes と入力して、SSH サービスをイネーブルにします。

次に、SSH サービスをイネーブルにする例を示します。

Enable the ssh service? (yes/no) [n]:
 

ステップ 11 yes と入力して、NTP サーバを設定します。

次に、NTP サーバを設定する例を示します。

Configure the ntp server? (yes/no) [n]:
 
The following configuration will be applied:
username qatest password <user-password> role network-operator
snmp-server community topspin ro
switchname ibm-switch-1
interface mgmt0
ip address 10.10.10.1 255.255.255.0
no shutdown
ip route 0.0.0.0/0 10.10.10.100
telnet server enable
no ssh server enable
 

ステップ 12 次の例のように、 yes (または y )と入力して FCOE サービスを設定します(デフォルトは no)。

Enable FCOE service? (yes/no) [n]:
 

FCOE サービスのプロンプトの後、設定が表示されます。

The following configuration will be applied:
username qatest password <user-password> role network-operator
snmp-server community topspin ro
switchname ibm-switch-1
interface mgmt0
ip address 10.10.10.1 255.255.255.0
no shutdown
ip route 0.0.0.0/0 10.10.10.100
telnet server enable
no ssh server enable
 
Would you like to edit the configuration? (yes/no) [n]:
 
Use this configuration and save it? (yes/no) [y]: y
 

ステップ 13 表示された設定を変更する場合は、 yes (または y )と入力します。デフォルトのまま(no)でよければ Enter を押します。

yes と入力すると、セットアップ ユーティリティは設定の最初に戻り、各ステップを繰り返します。

ステップ 14 次の例のように、 yes (または y )と入力してこの設定を保存します(デフォルトは no)。

ここで設定を保存しておかないと、次回のデバイス起動時に設定が更新されません。設定を保存すると、キックスタート イメージとシステム イメージのブート変数も自動的に設定されます。

Use this configuration and save it? (yes/no) [y]: y
 
ibm-switch-1 #

) スイッチには 2 つの帯域外管理インターフェイスが存在します。AMM 設定は mgmt1 です。Mgmt 0 は mgmt1 以外のサブネットに置く必要があります。



 

初期設定の変更

初期設定を後で変更する場合、EXEC モードで setup コマンドを入力します。

switch# setup

---- Basic System Configuration Dialog ----

This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.

*Note: setup is mainly used for configuring the system initially,
when no configuration is present. So setup always assumes system
defaults and not the current system configuration values.

Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.

Would you like to enter the basic configuration dialog (yes/no): yes

セットアップ ユーティリティに従って設定していけば、基本的な設定プロセスを完了できます。

スイッチへのアクセス

初期設定の後、次のように多くの方法でスイッチにアクセスできます。

シリアル コンソール アクセス:CLI にアクセスするのにシリアル ポート接続を使用できます。

帯域外アクセス:Telnet または SSH を使用してスイッチにアクセスします。

スイッチのその他の設定

ここでは、次の内容について説明します。

「スイッチ名の割り当て」

「日付、時刻、およびタイム ゾーンの設定」

「夏時間への調整」

スイッチ名の割り当て

ネットワークの各スイッチには、一意の名前を付ける必要があります。物理的な位置、ネットワークのアソシエーション、または配置された組織からスイッチを簡単に識別できる名前を割り当てることができます。割り当てられた名前は、コマンドライン プロンプトで表示されます。スイッチの名前は英数字 20 文字以内で指定してください。


) このマニュアルでは、Cisco Nexus 4001I/4005I Switch Module for IBM BladeCenterをスイッチとして表し、switch# プロンプトを使用します。


スイッチ名を変更する手順は次のとおりです。

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# switchname myswitch1
myswitch1(config)#

指定どおりにスイッチ名のプロンプトを変更します(myswitch1)。

ステップ 3

myswitch1(config)# no switchname
switch(config)#

スイッチ名のプロンプトをデフォルト(switch#)に戻します。

日付、時刻、およびタイム ゾーンの設定

スイッチは、Greenwich Mean Time(GMT; グリニッジ標準時)と同一の Coordinated Universal Time(UTC; 協定世界時)を使用します。スイッチのデフォルトの時刻を変更する手順は次のとおりです。

 

コマンド
目的
switch# clock set HH:MM:SS DD Month YYYY

スイッチのデフォルトの時刻を設定します。HH は 24 時間制の時(午後 3 時は 15)、MM は分(58)、SS は秒(09)、DD は日付(29)、Month は英単語の月(February)、YYYY は年(2008)を表します。

次の例ではスイッチの時刻が設定されます。

switch# clock set 15:58:09 29 February 2009
Mon Feb 20 15:58:09 UTC 2009

clock コマンドによる変更は、システムをリセットしても保存されます。


スイッチのタイム ゾーンを指定できます。夏時間機能なしのローカル タイムを指定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# clock timezone timezone hours_offset minutes_offset

タイム ゾーンを設定します。timezone は 3 文字で表すタイム ゾーン(Pacific Standard(太平洋標準時)は PST)、hours_offset は UTC からのオフセット(PST オフセットの場合は -8)を表します。minutes_offset は、Newfoundland Standard(NST; ニューファンドランド標準時)やIndia Standard(IST; インド標準時)などのタイム ゾーンで必要となります。

ステップ 3

switch(config)# exit

EXEC モードに戻ります。

ステップ 4

switch# show clock

タイム ゾーンの設定を確認します。

ステップ 5

switch# show run

タイム ゾーン設定に加えられた変更とその他の設定情報を表示します。

次の例では、タイム ゾーンを Pacific Standard Time(PST)に設定し、UTC 時間からのオフセットをマイナス 8 時間と 0 分にします。

switch# configure terminal
switch(config)# clock timezone PST -8 0

ローカル時間設定をディセーブルにする手順は、次のとおりです。

 

switch(config)# no clock timezone

タイム ゾーン調整機能をディセーブルにします。

夏時間への調整

スイッチは夏時間へ調整するよう設定できます。デフォルトでは、Cisco NX-OS は自動的に夏時間に調整しません。したがって、スイッチを夏時間に調整するよう手動で設定する必要があります。

たとえば米国の基準に従って(2005 年の エネルギー政策法 で定義)、スイッチの時間を 3 月の第 2 日曜日の午前 2 時に 1 時間早め、11 月の第 1 日曜日の午前 2 時に元の時間に 1 時間戻すことができます。または、開始日時、終了日時、毎年時間調整が繰り返されるか否かを明示的に指定できます。

夏時間調整をイネーブルにするには、次の手順を行います。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# clock summer-time timezone start_week start_day start_month start_time end_week end_day end_month end_time offset

指定されたタイム ゾーンに夏時間を設定します。

開始および終了値は次のとおりです。

週の範囲は、1 ~ 5 です。

曜日の範囲は、Sunday から Saturday です。

月の範囲は、January から December です。

夏時間オフセットの範囲は 1 ~ 1440 分で、開始時間に追加され、終了時間で削除されます。

switch(config)# no clock summer-time

夏時間調整機能をディセーブルにします。

ステップ 3

switch(config)# exit

EXEC モードに戻ります。

ステップ 4

switch# show running-config | include summer-time

タイム ゾーンの設定を確認します。

次の例では、3 月の第二日曜日の午前 2 時に開始し、11 月の第一日曜日の午前 2 時に終了するように、米国太平洋夏時間を 60 分調整します。

switch# configure terminal
switch(config)# clock summer-time PDT 1 Sunday March 02:00 5 Sunday November 02:00 60

NTP 設定

Network Time Protocol(NTP; ネットワーク タイム プロトコル)サーバは、ラジオ クロックまたは原子時計などの正確なタイム ソースをネットワーク装置のシステム クロックに同期化させます。NTP は、User Datagram Protocol(UDP; ユーザ データグラム プロトコル)/IP 上でトランスポートされます。すべての NTP 通信は UTC を使用します。NTP サーバは、タイム サーバに接続されたラジオ クロックまたは原子時計などの基準タイム ソースから時刻を受け取ります。NTP はネットワークにこの時刻を配信します。

ここでは、次の内容について説明します。

「NTP について」

「NTP 設定時の注意事項」

「NTP の設定」

「管理インターフェイスの設定」

NTP について

規模の大きい企業ネットワークでは、複数の装置間で記録される相互作用イベントのアソシエーションを試みる場合、すべてのネットワーク装置で 1 つの時間基準を持つことは、管理レポーティングおよびイベント ロギング機能において重要です。重要なネットワークを保有する多くの企業のお客様は、独自のストラタム 1 NTP ソースを保持しています。

クライアントとサーバ間で複数のフレームが交換されたときに時刻の同期化が行われます。クライアント モードにあるスイッチは、1 つまたは複数の NTP サーバのアドレスを認識します。NTP サーバはタイム ソースとして動作し、クライアントの同期要求を受け取ります。

ピアとして IP アドレスを設定することによって、スイッチは必要に応じて時刻を入手し、提供できます。ピアでは、独自に時刻を提供することができ、サーバが設定されている場合も対応できます。これらの両方のインスタンスが別のタイム サーバに指定される場合、NTP サービスがより信頼性の高いものになります。アクティブ サーバ リンクが失われた場合でも、ピアの存在によって正確な時間を保つことができます。


ヒント アクティブ サーバに障害が発生する場合、設定されたピアが NTP 時刻の提供に役立ちます。アクティブ サーバに障害が発生した場合のバックアップ サポートを確保するには、直接的な NTP サーバ アソシエーションを指定して、ピアを設定します。

ピアだけを設定すると、最も正確なピアが NTP サーバの役割を引き受け、他のピアがピアとして動作します。

NTP 設定時の注意事項

すべての NTP 設定に次の注意事項が適用されます。

時計が信頼できる状態の場合にだけ、別のスイッチにピア アソシエーションを適用する必要があります(つまり、信頼できる NTP サーバのクライアントである場合)。

ピアだけが設定されている場合、そのピアがサーバの役割を引き受け、バック アップとして使用される必要があります。2 つのサーバが存在する場合、複数のスイッチが 1 つのサーバを指定し、残りのスイッチが別のサーバを指定するようにできます。この 2 つのセットの間でピア アソシエーションを設定すると、クロックの信頼性がさらに高まります。

サーバが 1 つしかない場合は、すべてのスイッチがそのサーバに対してクライアント アソシエーションを持つことを推奨します。

ネットワーク内に適切に設定されているスイッチはサーバのダウンタイムにも影響されません。図 2-1 に、2 つの NTP ストラタム 2 サーバおよび 2 つのスイッチを含むネットワークを示します。

図 2-1 NTP のピアおよびサーバ アソシエーション

 

この設定では、スイッチは次のように設定されています。

ストラタム 2 サーバ 1

IPv4 アドレス:10.10.10.10

ストラタム 2 サーバ 2

IPv4 アドレス:10.10.10.9

スイッチ 1 の IPv4 アドレス:10.10.10.1

スイッチ 1 NTP コンフィギュレーション コマンド

ntp server 10.10.10.10

ntp peer 10.10.10.2

スイッチ 2 の IPv4 アドレス:10.10.10.2

スイッチ 2 NTP コンフィギュレーション コマンド

ntp server 10.10.10.9

ntp peer 10.10.10.1

NTP の設定

IPv4 アドレス、IPv6 アドレス、または DNS 名のいずれかを使用して NTP を設定できます。NTP アソシエーションを設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# ntp server { ip-address | ipv6-address | dns-name }

1 つのサーバと 1 つのサーバ アソシエーションを形成します。

ステップ 3

switch(config)# ntp peer { ip-address | ipv6-address | dns-name }

1 つのピアと 1 つのピア アソシエーションを形成します。複数のアソシエーションを指定できます。

ステップ 4

switch(config)# exit

EXEC モードに戻ります。

ステップ 5

switch# copy running-config startup-config

設定の変更内容を Nonvolatile Random-Access Memory(NVRAM; 不揮発性 RAM)に保存します。

ヒント これは、NTP 設定の変更結果の保存先の一例です。いつでもこのコマンドを入力できます。

ステップ 6

switch# show ntp peers

設定されたサーバおよびピア アソシエーションを表示します。

管理インターフェイスの設定

スイッチ上の管理インターフェイスは、同時に複数の Telnet または SNMP セッションを許可します。管理インターフェイス(mgmt0)を介してスイッチを遠隔から設定することができますが、スイッチにアクセスできるようにまず一部の IP パラメータを設定する必要があります。CLI から手動で管理インターフェイスを設定できます。

ここでは、次の内容について説明します。

「mgmt インターフェイスについて」

「管理インターフェイスの設定」

「管理インターフェイスの設定の表示」

「管理インターフェイスのシャットダウン」

mgmt インターフェイスについて

Cisco NX-OS デバイスの mgmt0 インターフェイスでは帯域外管理を実行できます。これにより、デバイスを IPv4 または IPv6 アドレスで管理できます。mgmt0 インターフェイスは 10/100/1000 イーサネットを使用します。

Cisco NX-OS 上の mgmt1 インターフェイスは、スイッチ を管理するために Advanced Management Module(AMM)を使用する設定のために用意されています。AMM を使用して mgmt1 インターフェイスを設定するには、IBM 社の AMM のマニュアルを参照してください。


) 手動による管理インターフェイスの設定を始める前に、スイッチの IP アドレスと IP サブネット マスクを取得します。また、コンソール ケーブルがコンソール ポートに接続されていることを確認します。


管理インターフェイスの設定

管理(mgmt0)イーサネット インターフェイスを設定して IP 上で接続する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface mgmt 0

スイッチの管理イーサネット インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# ip address ipv4-address [ / length ]

IPv4 アドレスとそのサブネット マスクを設定します。

switch(config-if)# ip address ipv4-address [ subnet-mask ]

IPv4 アドレスとそのサブネット マスクを設定するもう 1 つの方法です。

switch(config-if)# ipv6 address ipv6-address [ / length ]

IPv6 アドレスとそのサブネット マスクを設定します。

ステップ 4

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

switch(config-if)# exit

コンフィギュレーション モードに戻ります。

ステップ 6

switch(config)# vrf context management

VRF コンテキスト管理コンフィギュレーション モードを開始します。

ステップ 7

switch(config-vrf)# ip route ipv4-prefix [ / length ] ipv4-nexthop-address

ネクストホップの IPv4 アドレスを設定します。

switch(config-vrf)# ipv6 route ipv6-prefix [ / length ] ipv6-nexthop-address

ネクストホップの IPv6 アドレスを設定します。

ステップ 8

switch(config-if)# duplex { auto | full | half }

(任意)ポートのデュプレックス モードを設定します。デフォルトの設定は auto です。

ステップ 9

switch(config-if)# speed { 10 | 100 | 1000 | auto }

(任意)ポート速度を設定します。デフォルトの設定は auto です。

ステップ 10

switch(config-vrf)# exit

EXEC モードに戻ります。

ステップ 11

switch# copy running-config startup-config

(任意)ファイル システムへの設定の変更を保存します。

次に、mgmt 0 で管理インターフェイスを設定する例を示します。

switch# configure terminal
switch(config)# interface mgmt 0
switch(config-if)# ip address 10.65.122.252/24
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# vrf context management
switch(config-vrf)# ip route 0.0.0.0/0 10.65.122.2
switch(config-vrf)# exit
switch(config)# interface mgmt 0
switch(config-if)#
 

スイッチ インターフェイスが管理上のシャットダウン状態である場合があります。 show interface mgmt 0 コマンドを使用して、いつでもインターフェイスのステータスを確認できます。

管理インターフェイスの設定の表示

管理インターフェイスの設定を表示するには、 show interface mgmt0 コマンドを使用します。

switch# show interface mgmt0
mgmt0 is up
Hardware: GigabitEthernet, address: 0005.ad00.36d8 (bia 0005.ad00.36d8)
Internet Address is 172.29.231.220/23
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
full-duplex, 100 Mb/s
1 minute input rate 1792 bits/sec, 2 packets/sec
1 minute output rate 24 bits/sec, 0 packets/sec
Rx
136170 input packets 7896 unicast packets 119763 multicast packets
8511 broadcast packets 10446815 bytes
Tx
793 output packets 14 unicast packets 723 multicast packets
56 broadcast packets 187697 bytes

管理インターフェイスのシャットダウン

管理インターフェイス(mgmt0)をシャットダウンするには、 shutdown コマンドを使用します。システム プロンプトにより、コマンドの実行前に処理を確認するように要求されます。 force オプションを使用して、この確認を省略できます。

次に、 force オプションを使用せずに、管理インターフェイスをシャットダウンする例を示します。

switch# configure terminal
switch(config)# interface mgmt 0
switch(config-if)# shutdown
Shutting down this interface will drop all telnet sessions.
Do you wish to continue (y/n)? y

次に、 force オプションを使用して、管理インターフェイスをシャットダウンする例を示します。

switch# configure terminal
switch(config)# interface mgmt 0
switch(config-if)# shutdown force

スイッチ コンフィギュレーションの管理

ここでは、次の内容について説明します。

「スイッチ コンフィギュレーションの表示」

「コンフィギュレーションの保存」

「コンフィギュレーションのクリア」

スイッチ コンフィギュレーションの表示

必要に応じて、コンフィギュレーション ファイルを ASCII 形式で表示できます。EXEC プロンプトから現在の設定ツリーを表示させるには、 show running-config コマンドを入力します。実行コンフィギュレーションがスタートアップ コンフィギュレーションと異なり、再起動後に copy running-config startup-config コマンドを入力していない場合に限り、 show startup-config コマンドを入力して、スイッチの起動に使用された現在のスタートアップ コンフィギュレーションの ASCII バージョンを表示します。現在のスタートアップ コンフィギュレーションの内容を表示するには、 show startup-config コマンドを使用します。

また、スイッチ全体の特定の情報を得るためには、それに関連する show コマンドを入力します。指定した機能、インターフェイス、またはモジュールに基づいてコンフィギュレーションが表示されます。各機能に対して使用できる show コマンドをここで簡単に説明し、さらに各章の最後に一覧表示しています。

コンフィギュレーションの保存

不揮発性ストレージに新しいコンフィギュレーションを保存するには、 copy running-config startup-config コマンドを使用します。このコマンドを入力すると、実行中および起動時の設定が同一の内容になります。

コンフィギュレーションのクリア

スタートアップ コンフィギュレーションをクリアするには、 write erase コマンドを使用します。このコマンドを実行すると、スイッチのスタートアップ コンフィギュレーションが工場出荷時(デフォルト)の状態に戻ります。実行コンフィギュレーションに影響はありません。


注意 write erase コマンドは起動時の設定を、ローダ機能に影響する設定以外、すべて削除します。

write erase boot コマンドは、ローダ機能に影響する設定だけを削除します。ローダ機能コンフィギュレーションには、ブート変数と mgmt0 IP コンフィギュレーション情報(IP アドレス、ネットマスク、デフォルト ゲートウェイ)が含まれています。

switch# write erase boot

このコマンドにより、インターフェイス mgmt0 のブート変数および IP 設定が削除されます。

スイッチ ファイル システムの使用

ここでは、次の内容について説明します。

「カレント ディレクトリの設定」

「カレント ディレクトリの表示」

「ディレクトリ内のファイルの一覧表示」

「ディレクトリの作成」

「既存のディレクトリの削除」

「ファイルの移動」

「ファイルのコピー」

「ファイルの削除」

「ファイル内容の表示」

「コマンド出力のファイルへの保存」

「ファイルの圧縮および圧縮解除」

カレント ディレクトリの設定

cd コマンドを使用することで、カレント ディレクトリ レベルを指定のディレクトリ レベルに変更できます。CLI のデフォルトでは、volatile: ファイル システムになります。このコマンドにはディレクトリ名を入力する必要があります。

volatile: ファイル システムに保存されているファイルは、スイッチのリブート時に削除されます。

このコマンドの構文は、 cd directory name です。

次に、bootflash: ファイル システム上のルート ディレクトリにカレント ディレクトリを変更する例を示します。

switch# cd bootflash:

次に、カレント ディレクトリにある mystorage ディレクトリをカレント ディレクトリにする例を示します。

switch# cd mystorage

カレント ディレクトリの表示

pwd コマンドを使用して、カレント ディレクトリの場所を表示します。次に、ディレクトリを変更し、カレント ディレクトリを表示する例を示します。

switch# cd bootflash:
switch# pwd
bootflash:

ディレクトリ内のファイルの一覧表示

dir コマンドを使用して、カレント ディレクトリ、または指定のディレクトリの内容を表示します。このコマンドの構文は、 dir directory または dir filename です。

次に、デフォルトの volatile: ファイル システム上にあるファイルを一覧表示する方法の例を示します。

switch# dir volatile:

Usage for volatile://sup-local
0 bytes used
20971520 bytes free
20971520 bytes total

ディレクトリの作成

mkdir コマンドを使用することで、カレント ディレクトリ レベルまたは指定のディレクトリ レベルに、新しいディレクトリを作成できます。

このコマンドの構文は、 mkdir name です。

次に、bootflash: ディレクトリに新しいディレクトリ test を作成する例を示します。

switch# mkdir bootflash:test

次に、カレント ディレクトリ レベルで新しいディレクトリ test を作成する例を示します。

switch# mkdir test

既存のディレクトリの削除

rmdir コマンドを使用すると、カレント ディレクトリ レベルまたは指定のディレクトリ レベルで、既存のディレクトリを削除できます。削除対象のディレクトリは空である必要があります。

このコマンドの構文は、 rmdir name です。

次に、bootflash ディレクトリにあるディレクトリ test を削除する例を示します。

switch# rmdir bootflash:test
This is a directory. Do you want to continue (y/n)? [y] y

delete コマンドでは、空のディレクトリおよび空でないディレクトリも削除できます。このコマンドを入力する場合、ディレクトリを削除する意思を確認する警告が表示されます。

次に、カレント ディレクトリ レベルでディレクトリ test を削除する例を示します。

switch# delete test
This is a directory. Do you want to continue (y/n)? [y] y

カレント ディレクトリが bootflahs:mydir である場合、このコマンドでは bootflash:mydir/test ディレクトリが削除されます。

ファイルの移動

move コマンドを使用することで、ソース ディレクトリからファイルを削除し、宛先ディレクトリにそのファイルを配置することができます。


注意 宛先ディレクトリに同名のファイルがすでに存在する場合は、そのファイルは移動対象のファイルによって上書きされます。

この例では、samplefile というファイルをルート ディレクトリから mystorage ディレクトリに移動します。

switch# move bootflash:samplefile bootflash:mystorage/samplefile

次に、カレント ディレクトリ レベルからファイルを移動する例を示します。

switch# move samplefile mystorage/samplefile

カレント ディレクトリが bootflash:mydir の場合、このコマンドは bootflash:mydir/samplefile を bootflash:mydir/mystorage/samplefile に移動します。

ファイルのコピー

スイッチ内のファイル システム間でファイルをコピーするには、 copy コマンドを使用します。


dir コマンドを使用して、コピー先のファイル システムに十分な領域があることを確認します。十分な領域が残っていない場合は、delete コマンドを使用して不要なファイルを削除します。


この例では、samplefile というファイルをルート ディレクトリから mystorage ディレクトリにコピーします。

switch# copy bootflash:samplefile bootflash:mystorage/samplefile

次に、カレント ディレクトリ レベルからファイルをコピーする例を示します。

switch# copy samplefile mystorage/samplefile

カレント ディレクトリが bootflash:mydir の場合、このコマンドは bootflash:mydir/samplefile を bootflash:mydir/mystorage/samplefile にコピーします。

ファイルの削除

delete コマンドは、指定したファイル、または指定したディレクトリとその内容を削除します。

次に、現在の作業ディレクトリからファイルを削除する例を示します。

switch# delete dns_config.cfg

次の例では、bootflash: ディレクトリ全体およびそのすべての内容が削除されます。

switch# delete bootflash:my-dir

注意 1 つのディレクトリを指定している場合、delete コマンドではディレクトリ全体とその内容すべてが削除されます。

ファイル内容の表示

show file コマンドを使用して、ファイル システム上の指定のファイルの内容を表示できます。

次に、カレント ディレクトリにあるファイルの内容を表示する例を示します。

switch# show file myfile

コマンド出力のファイルへの保存

スクリーンに表示される出力結果をすべてファイルに保存するには、コマンドの後ろに > filename を指定します。たとえば、EXEC モードのスイッチ プロンプトで show interface > Samplefile と入力すると、同じディレクトリ レベルに作成された Samplefile にインターフェイス コンフィギュレーションが保存されます。EXEC モード スイッチ プロンプトで dir コマンドを入力すると、最近保存した Samplefile をはじめ、このディレクトリにあるすべてのファイルが表示されます。

ファイルの圧縮および圧縮解除

gzip コマンドは、指定のファイルを LZ77 コーディングで圧縮(zip)します。

次に、 show tech-support コマンドの出力結果をファイル(Samplefile)に出力してそのファイルを zip 圧縮し、volatile: ディレクトリでの消費容量の違いを表示させる例を示します。

switch# show tech-support > Samplefile
Building Configuration ...
switch# dir
1525859 Jul 04 00:51:03 2003 Samplefile
Usage for volatile://
1527808 bytes used
19443712 bytes free
20971520 bytes total
switch# gzip volatile:Samplefile
switch# dir
266069 Jul 04 00:51:03 2003 Samplefile.gz
Usage for volatile://
266240 bytes used
20705280 bytes free
20971520 bytes total

gunzip コマンドは、LZ77 コーディングされたファイルを圧縮解除(unzip)します。

次に、前回の例で圧縮されたファイルを圧縮解除する例を示します。

switch# gunzip Samplefile
switch# dir
1525859 Jul 04 00:51:03 2003 Samplefile
Usage for volatile://
1527808 bytes used
19443712 bytes free
20971520 bytes total