Cisco Nexus 4001I/4005I Switch Module for IBM BladeCenter NX-OS コンフィギュレーション ガイド
アクセス インターフェイスとトランク イン ターフェイスの設定
アクセス インターフェイスとトランク インターフェイスの設定
発行日;2012/05/10 | 英語版ドキュメント(2012/05/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 15MB) | フィードバック

目次

アクセス インターフェイスとトランク インターフェイスの設定

アクセス インターフェイスとトランク インターフェイスについて

アクセス インターフェイスとトランク インターフェイスの概要

IEEE 802.1Q カプセル化の概要

アクセス VLAN の概要

トランク ポートのネイティブ VLAN ID の概要

許可 VLAN の概要

アクセス インターフェイスとトランク インターフェイスの設定

イーサネット アクセス ポートとしての LAN インターフェイスの設定

アクセス ホスト ポートの設定

トランク ポートの設定

802.1Q トランク ポートのネイティブ VLAN の設定

トランキング ポートの許可 VLAN の設定

インターフェイスの設定の確認

アクセス インターフェイスとトランク インターフェイスの設定

イーサネット インターフェイスは、アクセス ポートまたはトランク ポートとして設定できます。トランクは単一のリンクを介して複数の Virtual LAN(VLAN; 仮想 LAN)トラフィックを伝送します。これにより、ネットワーク全体に VLAN を拡張できます。

この章で説明する内容は、次のとおりです。

「アクセス インターフェイスとトランク インターフェイスについて」

「アクセス インターフェイスとトランク インターフェイスの設定」

「インターフェイスの設定の確認」

アクセス インターフェイスとトランク インターフェイスについて

ここでは、次の内容について説明します。

「アクセス インターフェイスとトランク インターフェイスの概要」

「IEEE 802.1Q カプセル化の概要」

「アクセス VLAN の概要」

「トランク ポートのネイティブ VLAN ID の概要」

「許可 VLAN の概要」


) Cisco NX-OS では、IEEE 802.1Q タイプの VLAN トランク カプセル化だけをサポートしています。


アクセス インターフェイスとトランク インターフェイスの概要

イーサネット インターフェイスは、次のように、アクセス ポートまたはトランク ポートとして設定できます。

アクセス ポートはインターフェイス上に設定された 1 つの VLAN だけに対応し、1 つの VLAN のトラフィックだけを伝送します。

トランク ポートはインターフェイス上に設定された 2 つ以上の VLAN に対応しているため、複数の VLAN のトラフィックを同時に伝送できます。

図 12-1 に、ネットワークでのトランク ポートの使用例を示します。トランク ポートは、2 つ以上の VLAN のトラフィックを伝送します。

図 12-1 トランキング環境におけるデバイス

 

複数の VLAN に対応するトランク ポート上で正しくトラフィックを伝送するために、スイッチは、IEEE 802.1Q カプセル化、つまり、タギング方式(詳細については、「IEEE 802.1Q カプセル化の概要」を参照してください)を使用します。

アクセス ポートでのパフォーマンスを最適化するには、そのポートをホスト ポートとして設定します。ホスト ポートとして設定されたポートは、自動的にアクセス ポートとして設定され、チャネル グループ化はディセーブルになります。ホスト ポートを使用すると、指定ポートがパケットの転送を開始するための所要時間を短縮できます。


) ホスト ポートとして設定できるのは端末だけです。端末以外のポートをホストとして設定しようとするとエラーになります。


アクセス ポートは、アクセス VLAN 値の他に 802.1Q タグがヘッダーに設定されたパケットを受信すると、送信元の MAC アドレスを学習せずにドロップします。


) イーサネット インターフェイスはアクセス ポートまたはトランク ポートとして動作できますが、両方のポート タイプとして同時に動作することはできません。


IEEE 802.1Q カプセル化の概要

トランクは、デバイスと他のネットワーク デバイス間のポイントツーポイント リンクです。トランクは単一のリンクを介して複数の VLAN トラフィックを伝送します。これにより、ネットワーク全体に VLAN を拡張できます。

複数の VLAN に対応するトランク ポート上で正しくトラフィックを伝送するために、スイッチは、IEEE 802.1Q カプセル化、つまり、タギング方式(フレーム ヘッダーに挿入されたタグを使用する方式)を使用します(図 12-2を参照)。このタグには、そのフレームおよびパケットが属する特定の VLAN に関する情報が含まれます。タグ方式を使用すると、複数の異なる VLAN 用にカプセル化されたパケットが、同じポートを通過しても、各 VLAN のトラフィックを区別することができます。また、VLAN タグのカプセル化を使用すると、同じ VLAN 上のネットワークを経由するエンドツーエンドでトラフィックを転送できます。

図 12-2 802.1Q タグが含まれているヘッダーと含まれていないヘッダー

 

アクセス VLAN の概要


) アクセス VLAN を割り当て、プライベート VLAN のプライマリ VLAN としても動作させると、そのアクセス VLAN に対応するすべてのアクセス ポートが、プライベート VLAN モードのプライマリ VLAN 向けのすべてのブロードキャスト トラフィックを受信するようになります。


アクセス モードでポートを設定すると、そのインターフェイスのトラフィックを伝送する VLAN を指定できます。アクセス モードのポート(アクセス ポート)用に VLAN を設定しないと、そのインターフェイスはデフォルトの VLAN(VLAN1)のトラフィックだけを伝送します。

VLAN のアクセス ポート メンバーシップを変更するには、新しい VLAN を指定します。VLAN をアクセス ポートのアクセス VLAN として割り当てるには、まず、VLAN を作成する必要があります。アクセス ポート上のアクセス VLAN を、まだ作成されていない VLAN に変更すると、システムはそのアクセス ポートをシャット ダウンします。

アクセス ポートは、アクセス VLAN 値の他に 802.1Q タグがヘッダーに設定されたパケットを受信すると、送信元の MAC アドレスを学習せずにドロップします。

トランク ポートのネイティブ VLAN ID の概要


) ネイティブ VLAN ID 番号は、トランクの両端で一致していなければなりません


トランク ポートは、タグなしのパケットと 802.1Q タグ付きのパケットを同時に伝送できます。デフォルトのポート VLAN ID をトランク ポートに割り当てると、すべてのタグなしトラフィックが、そのトランク ポートのデフォルトのポート VLAN ID で伝送され、タグなしトラフィックはすべてこの VLAN に属するものと見なされます。この VLAN のことを、トランク ポートのネイティブ VLAN ID といいます。ネイティブ VLAN ID とは、トランク ポート上でタグなしトラフィックを伝送する VLAN のことです。

トランク ポートは、デフォルトのポート VLAN ID と同じ VLAN が設定された出力パケットをタグなしで送信します。他のすべての出力パケットは、トランク ポートによってタグ付けされます。ネイティブ VLAN ID を設定しないと、トランク ポートはデフォルト VLAN を使用します。

許可 VLAN の概要

デフォルトでは、トランク ポートは、すべての VLAN へのトラフィックを送信し、すべての VLAN からのトラフィックを受信します。各トランク上では、すべての VLAN ID が許可されます。この包括的なリストから VLAN を削除することによって、特定の VLAN からのトラフィックが、そのトランクを通過するのを禁止できます。トランク経由でトラフィックを伝送したい VLAN を後でリストに戻すこともできます。

デフォルト VLAN の Spanning Tree Protocol(STP; スパニング ツリー プロトコル)トポロジを分割するには、許可 VLAN のリストから VLAN1 を削除します。この分割を行わないと、VLAN1(デフォルトでは、すべてのポートでイネーブル)が非常に大きな STP トポロジを形成し、STP の収束中に問題が発生する可能性があります。VLAN1 を削除すると、そのポート上で VLAN1 のデータ トラフィックはすべてブロックされますが、制御トラフィックは通過し続けます。

アクセス インターフェイスとトランク インターフェイスの設定

ここでは、次の内容について説明します。

「イーサネット アクセス ポートとしての LAN インターフェイスの設定」

「アクセス ホスト ポートの設定」

「トランク ポートの設定」

「802.1Q トランク ポートのネイティブ VLAN の設定」

「トランキング ポートの許可 VLAN の設定」

イーサネット アクセス ポートとしての LAN インターフェイスの設定

イーサネット ポートはアクセス ポートとして設定できます。アクセス ポートは、パケットを、1 つのタグなし VLAN 上だけで送信します。管理者は、そのインターフェイスで伝送する VLAN トラフィックを指定します。アクセス ポートの VLAN を指定しないと、そのインターフェイスは、デフォルト VLAN だけのトラフィックを伝送します。デフォルトの VLAN は VLAN 1 です。

VLAN をアクセス VLAN として指定するには、その VLAN が存在していなければなりません。システムは、存在しないアクセス VLAN に割り当てられたアクセス ポートをシャット ダウンします。

イーサネット アクセス ポートを設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface {{ type slot / port } | { port-channel number }}

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport mode { access | trunk }

トランキングなし、タグなしの単一 VLAN イーサネット インターフェイスとして、インターフェイスを設定します。アクセス ポートは、1 つの VLAN だけのトラフィックを伝送できます。デフォルトでは、アクセス ポートは VLAN1 のトラフィックを伝送します。異なる VLAN のトラフィックを伝送するようにアクセス ポートを設定するには、 switchport access vlan コマンドを使用します。

ステップ 4

switch(config-if)# switchport access vlan vlan-id

このアクセス ポートでトラフィックを伝送する VLAN を指定します。このコマンドを入力しないと、アクセス ポートは VLAN1 だけのトラフィックを伝送します。このコマンドを使用して、アクセス ポートがトラフィックを伝送する VLAN を変更できます。

次に、イーサネット 1/10 を、VLAN 5 だけのトラフィックを伝送するイーサネット アクセス ポートとして設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/10
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan 5
 

アクセス ホスト ポートの設定


switchport host コマンドは、エンド ステーションに接続されたインターフェイスだけに適用する必要があります。


エンド ステーションに接続されたアクセス ポートでのパフォーマンスを最適化するには、そのポートをホスト ポートとしても設定します。アクセス ホスト ポートは、エッジ ポートと同じようにスパニング ツリー プロトコル(STP)を処理して、ブロッキング ステートおよびラーニング ステートを経由せずに、フォワーディング ステートに直接移行します。インターフェイスをアクセス ホスト ポートとして設定すると、そのインターフェイス上でポート チャネル動作がディセーブルになります。


) ポート チャネル インターフェイスの詳細については、を、スパニング ツリー プロトコルの詳細については、を参照してください。


エンド ステーションのインターフェイスに接続された適切なインターフェイスを設定することを確認してください。

アクセス ホスト ポートを設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface type slot / port

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport host

インターフェイスをアクセス ホスト ポートとして設定します。このポートはただちに、スパニング ツリー フォワーディング ステートに移行し、このインターフェイスのポート チャネル動作をディセーブルにします。

(注) このコマンドは端末だけに適用します。

次に、イーサネット 1/10 を、PortFast がイネーブルにされ、ポート チャネルがディセーブルにされたイーサネット アクセス ポートとして設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/10
switch(config-if)# switchport host
 

トランク ポートの設定

イーサネット ポートをトランク ポートとして設定できます。トランク ポートは、ネイティブ VLAN のタグなしパケット、および複数の VLAN のカプセル化されたタグ付きパケットを伝送します(カプセル化の詳細については、「IEEE 802.1Q カプセル化の概要」を参照してください)。


) Cisco NX-OS は、IEEE 802.1Q カプセル化だけをサポートしています。


トランク ポートを設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface { type slot / port | port-channel number }

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport mode { access | trunk }

インターフェイスをイーサネット トランク ポートとして設定します。トランク ポートは、同じ物理リンクで 1 つ以上の VLAN 内のトラフィックを伝送できます(各 VLAN はトランキングが許可された VLAN リストに基づいています)。デフォルトでは、トランク インターフェイスはすべての VLAN のトラフィックを伝送できます。特定のトランク上で特定の VLAN だけを許可するように指定するには、 switchport trunk allowed vlan コマンドを使用します。

次に、イーサネット 1/1 をイーサネット トランク ポートとして設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport mode trunk
 

802.1Q トランク ポートのネイティブ VLAN の設定

このパラメータを設定しないと、トランク ポートは、デフォルト VLAN をネイティブ VLAN ID として使用します。

802.1Q トランク ポートのネイティブ VLAN を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface { type slot / port | port-channel number }

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport trunk native vlan vlan-id

802.1Q トランクのネイティブ VLAN を設定します。指定できる範囲は 1 ~ 4094 です(ただし、内部使用に予約されている VLAN は除きます)。デフォルト値は VLAN 1 です。

次に、イーサネット トランク ポート 1/1 のネイティブ VLAN を VLAN 5 に設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport trunk native vlan 5

トランキング ポートの許可 VLAN の設定

特定のトランク ポートで許可されている VLAN の ID を指定できます。

指定トランク ポートの許可 VLAN を設定する前に、正しいインターフェイスを設定していること、およびそのインターフェイスがトランクであることを確認してください。

トランク ポートの許可 VLAN を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface { type slot / port | port-channel number }

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport trunk allowed vlan { vlan-list all | none [ add |except | none | remove { vlan-list }]}

トランク インターフェイスの許可 VLAN を設定します。デフォルトでは、トランク インターフェイス上のすべての VLAN(1 ~ 3967 および 4048 ~ 4094)が許可されます。VLAN 3968 ~ 4047 は、内部利用のためにデフォルトで予約されている VLAN です。この VLAN グループは設定できません。デフォルトでは、すべてのトランク インターフェイスですべての VLAN が許可されます。

(注) 内部で割り当て済みの VLAN を、トランク ポート上の許可 VLAN として追加することはできません。内部で割り当て済みの VLAN を、トランク ポートの許可 VLAN として登録しようとすると、メッセージが返されます。

次に、イーサネット トランク ポート 1/1 の許可 VLAN のリストに、VLAN 15 ~ 20 を追加する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport trunk allow vlan 15-20

インターフェイスの設定の確認

アクセス インターフェイスとトランク インターフェイスの設定情報を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

switch# show interface

インターフェイスの設定を表示します。

switch# show interface switchport

すべてのイーサネット インターフェイス(アクセス インターフェイスとトランク インターフェイスを含む)の情報を表示します。

switch# show interface brief

インターフェイス設定情報を表示します。