Cisco Nexus 3000 シリーズ NX-OS Quality of Service コマンド リファレンス リリース 5.0(3)x
Quality of Service(QoS)コマンド
Quality of Service(QoS)コマンド
発行日;2012/08/19 | 英語版ドキュメント(2012/08/01 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 845KB) | フィードバック

目次

Quality of Service(QoS)コマンド

bandwidth(QoS)

class(コントロール プレーン ポリシー マップ)

class(QoS タイプのポリシー マップ)

class class-default

class type network-qos

class type queuing

class-map

class-map type control-plane

class-map type network-qos

class-map type queuing

clear copp statistics

clear qos statistics

congestion-control random-detect

congestion-control random-detect ecn

control-plane

description

ip dscp(ERSPAN)

ip ttl(ERSPAN)

match access-group

match cos

match dscp

match ip rtp

match precedence

match qos-group

mtu(ERSPAN)

mtu(インターフェイス)

police(ポリシー マップ)

policy-map type control-plane

policy-map type network-qos

policy-map(QoS タイプ)

policy-map type queuing

priority

service-policy(コントロール プレーン)

service-policy(ポリシーマップ クラス)

service-policy(システム QoS)

set cos(ネットワーク QoS タイプのポリシー マップ)

set dscp

set precedence

setqos-group

show class-map type control-plane

show class-map type network-qos

show class-map type qos

show class-map type queuing

show copp status

show hardware internal buffer info pkt-stats

show interface untagged-cos

show policy-map

show policy-map interface

show policy-map interface brief

show policy-map interface control-plane

show policy-map system

show policy-map type control-plane

show queuing interface

show running-config copp

show running-config ipqos

show startup-config copp

show startup-config ipqos

show wrr unicast-bandwidth

show wrr-queue qos-group-map

system jumbomtu

system qos

untagged cos

wrr-queue qos-group-map

wrr unicast-bandwidth

Quality of Service(QoS)コマンド

この章では、Cisco Nexus 3000 シリーズ スイッチで使用できる Cisco NX-OS QoS(Quality of Service)コマンドについて説明します。

bandwidth(QoS)

キューにインターフェイス帯域幅の最小割合を割り当て、入力キューと出力キューの両方に帯域幅を設定するには、 bandwidth コマンドを使用します。帯域幅設定を削除するには、このコマンドの no 形式を使用します。

bandwidth percent percent

no bandwidth percent percent

 
構文の説明

percent

基盤となるリンクの残存帯域幅の割り当て率を指定します。

percent

パーセント値。範囲は 0 ~ 100 です。

 
コマンド デフォルト

デフォルトの帯域幅率は kbps です。

 
コマンド モード

キューイング タイプのポリシー クラス マップ コンフィギュレーション

 
コマンド履歴

 

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

次に、特定のキューに対して帯域幅を割り当てる例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing 1p7q4t-out-pq1
switch(config-pmap-c-que)# bandwidth percent 25
switch(config-pmap-c-que)#
 

次に、特定のキューに割り当てた帯域幅を取り消す例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing 1p7q4t-out-pq1
switch(config-pmap-c-que)# no bandwidth percent 25
switch(config-pmap-c-que)#
 

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

class(コントロール プレーン ポリシー マップ)

コントロール プレーン ポリシー マップのコントロール プレーン クラス マップを指定するには、 class コマンドを使用します。コントロール プレーン ポリシー マップからコントロール プレーン クラス マップを削除するには、このコマンドの no 形式を使用します。

class { class-map-name [ insert-before class-map-name2 ]}

no class class-map-name

 
構文の説明

class-map-name

クラス マップ名です。名前は、英数字で指定します。大文字と小文字が区別され、最大文字数は 64 です。

insert-before class-map-name2

(任意)コントロール プレーン ポリシー マップの別のコントロール プレーン クラス マップの前にコントロール プレーン クラス マップを挿入します。クラス マップ名には英数字を使用します。大文字と小文字が区別され、最大文字数は 64 です。

 
コマンド デフォルト

なし

 
コマンド モード

コントロール プレーン ポリシー マップの設定

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドでコントロール プレーン ポリシー マップを指定する前にコントロール プレーン クラス マップを作成します。

このコマンドには、ライセンスは必要ありません。

次に、コントロール プレーン ポリシー マップのクラス マップを設定する例を示します。

switch# configure terminal
switch(config)# policy-map type control-plane copp-system-policy
switch(config-pmap)# class ClassMapA
swtich(config-pmap-c)
 

次に、コントロール プレーン ポリシー マップのクラス マップを設定し、既存のクラス マップの前に挿入する例を示します。

switch# configure terminal
switch(config)# policy-map type control-plane copp-system-policy
switch(config-pmap)# class classMapB insert-before copp-stftp
switch(config-pmap-c)#
 

次に、コントロール プレーン ポリシー マップからクラス マップを削除する例を示します。

switch# configure terminal
switch(config)# policy-map type control-plane copp-system-policy
switch(config-pmap)# no class ClassMapA
switch(config-pmap)#
 

 
関連コマンド

コマンド
説明

class-map type control-plane

コントロール プレーン クラス マップを作成または設定します。

police(ポリシー マップ)

コントロール プレーン ポリシー マップのクラス マップのポリシングを設定します。

policy-map type control-plane

コントロール プレーン ポリシー マップを指定し、ポリシー マップ コンフィギュレーション モードを開始します。

show policy-map type control-plane

コントロール プレーン ポリシー マップの設定情報を表示します。

 

class(QoS タイプのポリシー マップ)

ポリシー マップで既存の QoS クラス マップを参照し、クラス モードを開始するには、 class コマンドを使用します。ポリシー マップからクラスを削除するには、このコマンドの no 形式を使用します。

class [ type qos ] class-map-name

no class class-map-name

 
構文の説明

type qos

(任意)コンポーネント タイプ(このクラスでは QoS)を指定します。デフォルトのタイプは QoS です。

class-map-name

クラス マップを参照します。クラス マップ名には最大 40 文字を使用できます。名前は大文字と小文字が区別され、英字、数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

Qos ポリシー マップ コンフィギュレーション
スイッチ プロファイル コンフィギュレーション モードでの Qos ポリシー マップ

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

トラフィック タイプと最初に一致したクラスに基づいて、ポリシーのアクションが実行されます。

デフォルトで、QoS タイプの class-default クラスはシステムで QoS タイプの各ポリシー マップで作成され、QoS グループ 0 にマッピングされます。このマッピングは変更できません。

QoS タイプの class-default は削除できません。class-default クラスを削除しようとすると、スイッチはエラー メッセージを返します。

次に、ポリシー マップで最後の QoS クラス マップを参照する例を示します。

switch(config)# policy-map my_policy1
switch(config-pmap-qos)# class traffic_class2
switch(config-pmap-c-qos)#
 

次に、ポリシー マップのクラス マップ参照を削除する例を示します。

switch(config)# policy-map my_policy1
switch(config-pmap-qos)# no class traffic_class1
switch(config-pmap-qos)#
 

 
関連コマンド

コマンド
説明

set dscp

トラフィック クラスに DSCP 値を割り当てます。

set precedence

トラフィック クラスに IP precedence を割り当てます。

set qos-group

トラフィック クラスに QoS グループを割り当てます。

show class-map type qos

QoS タイプのクラス マップを表示します。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

class class-default

どのトラフィック クラスにも一致しないシステムのデフォルト クラスへの参照を追加するには、 class class-default コマンドを使用します。ポリシー マップからシステムのデフォルト クラスを削除するには、このコマンドの no 形式を使用します。

class class-default

no class class-default

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

QoS ポリシー マップ コンフィギュレーション
スイッチ プロファイル コンフィギュレーション モードでの QoS ポリシー マップ

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

どのクラスにも一致しないトラフィックは、class-default と呼ばれるデフォルトのトラフィック クラスに割り当てられます。このクラスを削除することはできません。

次に、スイッチ プロファイルのポリシー マップの最後にあるシステムのデフォルト クラスを参照する例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# policy-map type qos my_policy1
switch(config-sync-sp-pmap-qos)# class class-default
switch(config-sync-sp-pmap-c-qos)#
 

 
関連コマンド

コマンド
説明

set dscp

QoS トラフィックの DSCP 値を設定します。

set precedence

QoS トラフィックの IP precedence 値を設定します。

set qos-group

トラフィック クラスに QoS グループ ID を割り当てます。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

class type network-qos

ポリシー マップで既存のネットワーク QoS クラス マップを参照し、クラス モードを開始するには、 class type network-qos コマンドを使用します。ポリシー マップからクラスを削除するには、このコマンドの no 形式を使用します。

class type network-qos class-map-name

no class type network-qos class-map-name

 
構文の説明

class-map-name

ネットワーク QoS クラス マップを参照します。クラス マップ名には最大 40 文字を使用できます。名前は大文字と小文字が区別され、英字、数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS タイプのポリシー マップ コンフィギュレーション
スイッチ プロファイル コンフィギュレーション モードでのネットワーク QoS タイプのポリシー マップ

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

トラフィック タイプと最初に一致したクラスに基づいて、ポリシーのアクションが実行されます。

次に、ネットワーク QoS タイプのポリシー マップでクラス マップを参照する例を示します。

switch(config)# policy-map type network-qos nqos_policy
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)#
 

次に、ネットワーク QoS タイプのポリシー マップのクラス マップ参照を削除する例を示します。

switch(config)# policy-map type network-qos nqos_policy
switch(config-pmap-nq)# no class type network-qos nqos_class
switch(config-pmap-nq)#
 

次に、ネットワーク QoS タイプのポリシー マップでスイッチ プロファイルのクラス マップを参照する例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# policy-map type network-qos sp-nwpolicy
switch(config-sync-sp-pmap-nq)# class type network-qos sp-nwpolicy-class
switch(config-sync-sp-pmap-nq-c)#

 
関連コマンド

コマンド
説明

mtu

トラフィック クラスのジャンボ フレームをイネーブルにします。

set cos

トラフィック クラスに CoS 値を割り当てます。

show class-map type network-qos

ネットワーク QoS タイプのクラス マップを表示します。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

class type queuing

ポリシー マップで既存のキューイング クラス マップを参照し、クラス モードを開始するには、 class type queuing コマンドを使用します。ポリシー マップからクラスを削除するには、このコマンドの no 形式を使用します。

class type queuing class-map-name

no class type queuing class-map-name

 
構文の説明

class-map-name

キューイング クラス マップを参照します。クラス マップ名には最大 40 文字を使用できます。名前は大文字と小文字が区別され、英字、数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

キューイング タイプのポリシー マップ コンフィギュレーション

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

トラフィック タイプと最初に一致したクラスに基づいて、ポリシーのアクションが実行されます。

次に、キューイング タイプのポリシー マップでクラス マップを参照する例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing 1p7q4t-out-q3
switch(config-pmap-c-que)#
 

次に、キューイング タイプのポリシー マップのクラス マップ参照を削除する例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# no class type queuing 1p7q4t-out-q3
switch(config-pmap-que)#
 

 
関連コマンド

コマンド
説明

show class-map type queuing

キューイング タイプのクラス マップを表示します。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

class-map

クラス マップを作成または修正して、クラス マップ コンフィギュレーション モードを開始するには、 class-map コマンドを使用します。クラス マップを削除するには、このコマンドの no 形式を使用します。

class-map [ type qos ] [ match-all | match-any ] class-map-name

no class-map [ type qos ] [ match-all | match-any ] class-map-name

 
構文の説明

type qos

(任意)QoS タイプのクラス マップのコンポーネントを指定します。デフォルトでは、クラス マップ タイプは QoS です。

match-all

match コマンドでこのクラス マップに設定された基準のすべてに一致した場合、パケットにこのクラス マップを適用します。

match-any

match コマンドでこのクラス マップに設定された基準のいずれかに一致した場合、パケットにこのクラス マップを適用します。match-all が指定されていない場合、これがデフォルトのアクションです。

class-map-name

QoS クラス マップに割り当てられた名前。最大 40 文字までの名前を指定できます。名前は大文字と小文字が区別され、英数字、ハイフン、下線だけを含めることができます。

class-default という名前は予約されています。

 
コマンド デフォルト

type:qos

match-all

 
コマンド モード

グローバル コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

QoS ポリシーで使用される各トラフィックのクラスにクラス マップを定義できます。

match コマンドでこのクラス マップに設定された基準のいずれかにパケットが一致した場合、このクラス マップがパケットに適用されます。実行計画を指定しない(match-any または match-all)と、match-any のデフォルト値がトラフィック クラスに適用されます。

次に、QoS クラス マップを作成または修正する例を示します。

switch(config)# class-map my_class1
switch(config-cmap-qos)#
 

次に、すべてのトラフィック パケットに一致する QoS クラス マップを作成する例を示します。

switch(config)# class-map type qos match-all my_class2
switch(config-cmap-qos)#
 

次に、QoS クラス マップを削除する例を示します。

switch(config)# no class-map my_class1
switch(config)#
 

 
関連コマンド

コマンド
説明

description

クラス マップの目的の概要を追加します。

match

トラフィック クラスの基準を設定します。

policy-map type qos

QoS ポリシー マップを作成または変更します。

service-policy

インターフェイスまたはシステム ポリシーにポリシー マップを関連付けます。

show class-map type qos

QoS クラス マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

class-map type control-plane

コントロール プレーン クラス マップを作成または指定して、クラス マップ コンフィギュレーション モードを開始するには、 class-map type control-plane コマンドを使用します。コントロール プレーン クラス マップを削除するには、このコマンドの no 形式を使用します。

class-map type control-plane [ match-any ] class-map-name

no class-map type control-plane [ match-any ] class-map-name

 
構文の説明

match-any

(任意)クラス マップの任意の一致条件と一致するように指定します。

class-map-name

クラス マップ名です。名前には英数字を使用します。大文字と小文字が区別され、 最大で 64 文字の長さまで指定可能です。

 
コマンド デフォルト

match-any

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

コントロール プレーン クラス マップの名前として、match-any または class-default は使用できません。

control-plane タイプのダイナミック クラス マップだけを削除できます。control-plane タイプのスタティック クラス マップは削除できません。

このコマンドには、ライセンスは必要ありません。

次に、コントロール プレーン クラス マップを指定して、クラス マップ コンフィギュレーション モードを開始する例を示します。

switch# configure terminal
switch(config)# class-map type control-plane ClassMapA
switch(config-cmap)#
 

次に、コントロール プレーン クラス マップを削除する例を示します。

switch# configure terminal
switch(config)# no class-map type control-plane ClassMapA
switch(config)#

 
関連コマンド

コマンド
説明

match access-group

指定したアクセス コントロール リスト(ACL)グループにトラフィックを一致させます。

show class-map type control-plane

コントロール プレーン ポリシー マップの設定情報を表示します。

 

class-map type network-qos

トラフィックのネットワーク QoS クラスを定義するクラス マップを作成または修正して、クラス マップ コンフィギュレーション モードを開始するには、 class-map type network-qos コマンドを使用します。クラス マップを削除するには、このコマンドの no 形式を使用します。

class-map type network-qos class_map_name

no class-map type network-qos class_map_name

 
構文の説明

class-map-name

クラス マップに割り当てられた名前。class-default という名前は予約されています。最大 40 文字までの名前を指定できます。名前は大文字と小文字が区別され、英数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

ネットワーク QoS タイプのクラス マップは、 match qos-group コマンドだけをサポートしています。 match コマンドでこのクラス マップに設定された条件のいずれかにトラフィック パケットが一致した場合、このクラス マップがパケットに適用されます。デフォルトでは、トラフィックは暗黙の match-any オプションを使用してフィルタ処理されます。

次に、my_class1 という名前のネットワーク QoS クラス マップを作成または修正する例を示します。

switch(config)# class-map type network-qos my_class1
switch(config-cmap-nq)#
 

次に、ネットワーク QoS クラス マップを削除する例を示します。

switch(config)# no class-map my_class1
switch(config)#
 

 
関連コマンド

コマンド
説明

match qos-group

QoS グループ値と一致するトラフィック クラスを定義します。

show class-map type network-qos

システムに設定されているネットワーク QoS クラス マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

class-map type queuing

キューイング トラフィック クラスを定義し、クラス マップ コンフィギュレーション モードを開始するクラス マップを作成または変更するには、 class-map type queuing コマンドを使用します。キューイング クラス マップを削除するには、このコマンドの no 形式を使用します。

class-map type queuing class_map_name

no class-map type queuing class_map_name

 
構文の説明

class-map-name

クラス マップに割り当てられた名前、またはシステムで定義されたキューイング クラス マップ名。class-default という名前は予約されています。最大 40 文字までの名前を指定できます。名前は大文字と小文字が区別され、英数字、ハイフン、下線だけを含めることができます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

キューイング タイプのクラス マップを修正する場合、指定したポート タイプの全ポートの設定も変更されます。

システムで定義されたキューイング クラス マップ名は削除できません。

キューイング タイプのクラス マップは、 match qos-group コマンドだけをサポートしています。 match コマンドでこのクラス マップに設定された条件のいずれかにトラフィック パケットが一致した場合、このクラス マップがパケットに適用されます。デフォルトでは、トラフィックは暗黙の match-any オプションを使用してフィルタ処理されます。

次に、キューイング タイプのクラス マップを作成または修正する例を示します。

switch(config)# class-map type queuing my_class1
switch(config-cmap-que)#
 

次に、キューイング タイプのクラス マップを削除する例を示します。

switch(config)# no class-map type queuing my_class1
switch(config)#
 

 
関連コマンド

コマンド
説明

match qos-group

QoS グループ値と一致するトラフィック クラスを設定します。

show class-map type queuing

システムに設定されているキューイング クラス マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

clear copp statistics

コントロール プレーン ポリシング(CoPP)統計情報をクリアするには、 clear copp statistics コマンドを使用します。

clear copp statistics

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次の例では、CoPP 統計情報をクリアする方法を示します。

switch# show policy-map interface control-plane
switch# clear copp statistics
switch#

 
関連コマンド

コマンド
説明

class-map type control-plane

コントロール プレーン クラス マップを設定します。

show policy-map interface control-plane

インターフェイスの CoPP 統計情報を表示します。

 

clear qos statistics

Quality of Service(QoS)統計情報をクリアするには、 clear qos statistics コマンドを使用します。

clear qos statistics

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、すべての QoS 統計情報をクリアする場合の例を示します。

switch# clear qos statistics
switch#
 

 
関連コマンド

コマンド
説明

show queuing interface

インターフェイスのキューイング情報を表示します。

 

congestion-control random-detect

重み付けランダム早期検出(WRED)を設定するには、 congestion-control random-detect コマンドを使用します。WRED 設定を削除するには、このコマンドの no 形式を使用します。

congestion-control random-detect

no congestion-control random-detect

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS タイプのポリシー マップ コンフィギュレーション モード
スイッチ プロファイルでのネットワーク QoS タイプのポリシー マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

WRED は、輻輳が予想される任意の出力インターフェイスに有効です。

このコマンドには、ライセンスは必要ありません。

次に、輻輳制御を設定する例を示します。

switch# configure terminal
switch(config)# policy-map type network-qos my_policy
switch(config-pmap-nq)# class type network-qos my_cnqos
switch(config-pmap-nq-c)# congestion-control random-detect
switch(config-pmap-nq-c)#
 

次に、スイッチ プロファイルで ECN を設定する例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# policy-map type network-qos sp-nwpolicy
switch(config-sync-sp-pmap-nq)# class type network-qos sp-nwpolicy-class
switch(config-sync-sp-pmap-nq-c)# congestion-control random-detect
switch(config-sync-sp-pmap-nq-c)#
 

 
関連コマンド

コマンド
説明

class type network-qos

ポリシー マップのネットワーク QoS タイプのクラス マップを参照します。

congestion-control random-detect ecn

明示的輻輳通知(ECN)を設定します。

show policy-map

すべてのポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

congestion-control random-detect ecn

明示的輻輳通知(ECN)を設定するには、 congestion-control random-detect ecn コマンドを使用します。ECN 設定を削除するには、このコマンドの no 形式を使用します。

congestion-control random-detect ecn

no congestion-control random-detect ecn

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS タイプのポリシー マップ コンフィギュレーション モード
スイッチ プロファイルでのネットワーク QoS タイプのポリシー マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

ECN は、指定したしきい値をキューの平均の長さが超えると、パケットをドロップせずにマーキングします。

このコマンドには、ライセンスは必要ありません。

次に、ECN を設定する例を示します。

switch# configure terminal
switch(config)# policy-map type network-qos my_policy
switch(config-pmap-nq)# class type network-qos my_cnqos
switch(config-pmap-nq-c)# congestion-control random-detect ecn
switch(config-pmap-nq-c)#
 

次に、スイッチ プロファイルで ECN を設定する例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# policy-map type network-qos sp-nwpolicy
switch(config-sync-sp-pmap-nq)# class type network-qos sp-nwpolicy-class
switch(config-sync-sp-pmap-nq-c)# congestion-control random-detect ecn
switch(config-sync-sp-pmap-nq-c)#

 
関連コマンド

コマンド
説明

class type network-qos

ポリシー マップのネットワーク QoS タイプのクラス マップを参照します。

congestion-control random-detect

WRED を設定します。

show policy-map

すべてのポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

control-plane

デバイスのコントロール プレーンに関連付けられている属性を関連付けることができるコントロール プレーン コンフィギュレーション モードを開始するには、 control-plane コマンドを使用します。

control-plane

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

control-plane コマンドを使用した後、コントロール プレーン宛てのすべてのトラフィックをポリシングするためのサービス ポリシーを関連付けることができます。

次に、コントロール プレーン コンフィギュレーション モードを開始する例を示します。

switch# configure terminal
switch(config)# control-plane
switch(config-cp)#

 
関連コマンド

コマンド
説明

service-policy(コントロール プレーン)

集約コントロール プレーン サービスのためにポリシー マップをコントロール プレーンに適用します。

show policy-map type control-plane

コントロール プレーンのポリシー マップのあるクラス、またはすべてのクラスの設定を表示します。

 

description

クラス マップ、ポリシー マップ、またはテーブル マップに説明を追加するには、 description コマンドを使用します。説明を削除するには、このコマンドの no 形式を使用します。

description text

no description text

 
構文の説明

text

クラス マップ、ポリシー マップ、またはテーブル マップの説明。最大 200 文字の英数字を入力できます。

 
コマンド デフォルト

なし

 
コマンド モード

クラス マップ(ネットワーク QoS タイプ、QoS タイプ、キューイング タイプ)コンフィギュレーション モード
ポリシー マップ(ネットワーク QoS タイプ、QoS タイプ、キューイング タイプ)コンフィギュレーション モード
スイッチ プロファイルでのクラス マップ コンフィギュレーション モード
スイッチ プロファイルでのポリシー マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

次に、QoS クラス マップに説明を追加する例を示します。

switch(config)# class-map my_class1
switch(config-cmap-qos)# description This class map filters packets that matches an ACL
switch(config-cmap-qos)#

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

policy-map

ポリシー マップを作成、または変更します。

show class-map

クラス マップを表示します。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

ip dscp(ERSPAN)

Encapsulated Remote Switched Port Analyzer(ERSPAN)トラフィック中のパケットの DiffServ コード ポイント(DSCP)値を設定するには、 ip dscp コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

ip dscp dscp_value

no ip dscp dscp_value

 
構文の説明

dscp_value

ERSPAN トラフィックのパケットの DSCP 値。指定できる範囲は 0 ~ 63 です。

 
コマンド デフォルト

0

 
コマンド モード

ERSPAN セッション コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(2)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、ESRSPAN トラフィックのパケットの DSCP 値を設定する例を示します。

switch# configure terminal
switch(config)# monitor session 1 type erspan-source
switch(config-erspan-src)# ip dscp 10
switch(config-erspan-src)#
 

 
関連コマンド

コマンド
説明

ip prec

ERSPAN トラフィックの IP precedence 値を設定します。

ip ttl

ERSPAN トラフィックの IP 存続可能時間(TTL)値を設定します。

monitor-session

ポート間トラフィックを分析する ERSPAN セッションを設定するためのモニタ コンフィギュレーション モードを開始します。

 

ip ttl(ERSPAN)

Encapsulated Remote Switched Port Analyzer(ERSPAN)トラフィックの IP 存続可能時間(TTL)値を設定するには、 ip ttl コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

ip ttl ttl_value

no ip ttl ttl_value

 
構文の説明

ttl_value

ERSPAN トラフィックの IP TTL 値。指定できる範囲は 1 ~ 255 です。

 
コマンド デフォルト

255

 
コマンド モード

ERSPAN セッション コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(2)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、ESRSPAN 送信元の IP TTL 値を設定する例を示します。

switch# configure terminal
switch(config)# monitor session 1 type erspan-source
switch(config-erspan-src)# ip ttl 30
switch(config-erspan-src)#
 

次に、ESRSPAN 送信元から IP TTL 値を削除する例を示します。

switch# configure terminal
switch(config)# monitor session 1 type erspan-source
switch(config-erspan-src)# no ip ttl 30
switch(config-erspan-src)#
 

 
関連コマンド

コマンド
説明

ip dscp

ERSPAN トラフィックのパケットの DSCP 値を設定します。

monitor-session

ポート間トラフィックを分析する ERSPAN セッションを設定するためのモニタ コンフィギュレーション モードを開始します。

 

match access-group

特定のアクセス コントロール リスト(ACL)グループをクラス マップの一致基準として識別するには、 match access-group コマンドを使用します。ACL 一致基準をクラス マップから削除するには、このコマンドの no 形式を使用します。

match access-group name acl-name

no match access-group name acl-name

 
構文の説明

name acl-name

特性を一致基準として使用する ACL 名を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

QoS クラスマップ コンフィギュレーション モード
コントロール プレーン クラスマップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートが、コントロール プレーン クラス マップで導入されました。

 
使用上のガイドライン

このコマンドで ACL を参照するには、事前に IP ACL を作成する必要があります。

control-plane タイプの 1 つの class-map と関連付けることができる ACL は 1 つだけです。


permit および deny ACL キーワードは、パケットの一致に影響を与えません。


次に、my_acl という ACL の特性を一致基準として使用し、QoS クラス マップを作成する例を示します。

switch# configure terminal
switch(config)# class-map class_acl
switch(config-cmap-qos)# match access-group name my_acl
switch(config-cmap-qos)#
 

次に、copp-system-acl-snmp という ACL の特性を一致基準として使用し、コントロール プレーン クラス マップを作成する例を示します。

switch# configure terminal
switch(config)# class-map type control-plane match-any copp-snmp
switch(config-cmap)# match access-group name copp-system-acl-snmp
switch(config-cmap)#
 

次に、コントロール プレーン クラス マップからアクセス グループを削除する例を示します。

switch# configure terminal
switch(config)# class-map type control-plane match-any copp-snmp
switch(config-cmap)# no match access-group name copp-system-acl-snmp
switch(config-cmap)#

 
関連コマンド

コマンド
説明

class-map type control-plane

コントロール プレーン クラス マップを作成または指定して、クラス マップ コンフィギュレーション モードを開始します。

show class-map

クラス マップを表示します。

show class-map type control-plane

コントロール プレーン クラス マップの設定情報を表示します。

 

match cos

QoS タイプのクラス マップで、サービス クラス(CoS)値を使用してトラフィックのクラスを定義するには、 match cos コマンドを使用します。一致基準として指定した CoS 値を取り消すには、このコマンドの no 形式を使用します。

match [ not ] cos cos-list

no match [ not ] cos cos-list

 
構文の説明

not

(任意)指定した一致結果を除外します。

cos-list

一致基準として指定する CoS 値または CoS 値のリスト。有効値の範囲は 0 ~ 7 です。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する


) このコマンドのオプションの not キーワードをサポートしているのは、QoS タイプのクラス マップだけです。キューイング タイプのクラス マップでは not キーワードがサポートされません。


次に、QoS タイプ クラス マップの一致基準として CoS 値を設定する例を示します。

switch(config)# class-map type qos match-any class_acl
switch(config-cmap-qos)# match cos 5-7
switch(config-cmap-qos)#

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

match dscp

特定の DiffServ コード ポイント(DSCP)値を一致基準として識別するには、 match dscp コマンドを使用します。一致条件として指定した DSCP 値を削除するには、このコマンドの no 形式を使用します。

match [ not ] dscp dscp-list

no match [ not ] dscp dscp-list

 
構文の説明

not

(任意)指定した一致結果を除外します。

dscp-list

一致基準として指定する DSCP 値または DSCP 値のリスト。有効な DSCP 値のリストについては、 表 i-1 を参照してください。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

標準の DSCP 値については、 表 i-1 を参照してください。

 

表 i-1 標準の DSCP 値

DSCP 値
説明

af11

AF11 dscp(001010):10 進数の 10

af12

AF12 dscp(001100):10 進数の 12

af13

AF13 dscp(001110):10 進数の 14

af21

AF21 dscp(010010):10 進数の 18

af22

AF22 dscp(010100):10 進数の 20

af23

AF23 dscp(010110):10 進数の 22

af31

AF31 dscp(011010):10 進数の 26

af32

AF40 dscp(011100):10 進数の 28

af33

AF33 dscp(011110):10 進数の 30

af41

AF41 dscp(100010):10 進数の 34

af42

AF42 dscp(100100):10 進数の 36

af43

AF43 dscp(100110):10 進数の 38

cs1

CS1(優先順位 1)dscp(001000):10 進数の 8

cs2

CS2(優先順位 2)dscp(010000):10 進数の 16

cs3

CS3(優先順位 3)dscp(011000):10 進数の 24

cs4

CS4(優先順位 4)dscp(100000):10 進数の 32

cs5

CS5(優先順位 5)dscp(101000):10 進数の 40

cs6

CS6(優先順位 6)dscp(110000):10 進数の 48

cs7

CS7(優先順位 7)dscp(111000):10 進数の 56

default

デフォルト dscp(000000):10 進数の 0

ef

EF dscp(101110):10 進数の 46

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する

次に、DSCP 値 af21 を一致基準として設定する例を示します。

switch(config)# class-map type qos my_test
switch(config-cmap-qos)# match dscp af21
switch(config-cmap-qos)#

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

match ip rtp

クラス マップで、Real-Time Protocol(RTP)ポートを一致基準として使用するよう設定するには、 match ip rtp コマンドを使用します。一致条件として指定した RTP ポートを削除するには、このコマンドの no 形式を使用します。

match [ not ] ip rtp port-list

no match [ not ] ip rtp port-list

 
構文の説明

not

(任意)指定した一致結果を除外します。

port-list

一致条件として指定される、RTP を使用する UDP ポートまたは UDP ポートのリスト。有効値の範囲は 2000 ~ 65535 秒です。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する

次に、一致基準として RTP を使用するポートを指定する例を示します。

switch(config)# class-map type qos my_test
switch(config-cmap-qos)# match ip rtp 2300
switch(config-cmap-qos)#

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

match precedence

クラス マップで、IP ヘッダーのタイプ オブ サービス(ToS)バイト フィールドに含まれる precedence 値を一致基準として使用するよう設定するには、 match precedence コマンドを使用します。一致条件として指定した precedence 値を削除するには、このコマンドの no 形式を使用します。

match [ not ] precedence precedence-list

no match [ not ] precedence precedence-list

 
構文の説明

not

(任意)指定した一致結果を除外します。

precedence-list

バイト単位で指定される、IP precedence 値または IP precedence 値のリスト。有効な値については、 表 i-2 を参照してください。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

precedence 値のリストについては、 表 i-2 を参照してください。

 

表 i-2 優先順位値

precedence 値
説明

<0-7>

IP precedence 値

critical

クリティカル precedence(5)

flash

フラッシュ precedence(3)

flash-override

フラッシュ上書き precedence(4)

immediate

即時 precedence(2)

internet

インターネットワーク コントロール precedence(6)

network

ネットワーク コントロール precedence(7)

priority

優先 precedence(1)

routine

ルーチン precedence(0)

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する

次に、一致基準として IP precedence 値を指定する例を示します。

switch(config)# class-map my_test
switch(config-cmap-qos)# match precedence 7
switch(config-cmap-qos)#

 
関連コマンド

コマンド
説明

show class-map

クラス マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

match qos-group

クラス マップで、特定の QoS グループ値を一致基準として使用するよう設定するには、 match qos-group コマンドを使用します。一致条件として指定したプロトコルを削除するには、このコマンドの no 形式を使用します。

match qos-group qos-group-list

no match qos-group qos-group-list

 

qos-group-list

1 つまたは複数の QoS グループ値を、バイト数で指定します。有効値の範囲は 1 ~ 7 です。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS タイプのクラス マップ コンフィギュレーション モード
キューイング タイプのクラス マップ コンフィギュレーション モード
スイッチ プロファイルでのクラス マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

QoS グループは内部ラベルであり、パケット ペイロードまたは任意のパケット ヘッダーの一部ではありません。QoS グループ値に数学的な意味はありません。たとえば、QoS グループ値の 2 は 1 より大きいことを意味せず、各 QoS 値は QoS グループを内部的に区別するためだけに使用されます。このように、QoS 値はローカルでの処理についてだけ使用されます。

QoS グループの値は入力ポリシー内で設定されるまで未定義になっているため、QoS グループについての照合は、出力ポリシー内でだけ行います。

値のリストは、次のいずれかの方法で指定します。

値の範囲をダッシュで区切って指定する

連続していない複数の値を、カンマで区切って指定する

次に、一致基準として特定の QoS グループ値を指定する例を示します。

switch(config)# class-map type queuing my_test
switch(config-cmap-qos)# match qos-group 6
switch(config-cmap-qos)#
 

 
関連コマンド

コマンド
説明

class-map type network-qos

ネットワーク QoS クラス マップを作成または修正します。

class-map type queuing

キューイング クラス マップを作成または変更します。

show class-map

クラス マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

mtu(ERSPAN)

モニタ セッションの ERSPAN パケットの最大伝送ユニット(MTU)サイズを設定するには、 mtu コマンドを使用します。設定した MTU を削除するには、このコマンドの no 形式を使用します。

mtu mtu-value

no mtu mtu-value

 
構文の説明

mtu-value

モニタ セッションの ERSPAN パケットの最大許容 MTU。指定できる範囲は 64 ~ 1518 バイトです。

 
コマンド デフォルト

切り捨てはイネーブルではありません。

 
コマンド モード

ERSPAN セッション コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(2)

このコマンドが追加されました。

 
使用上のガイドライン

モニタ セッションの指定された許容サイズより大きい ERSPAN パケットは切り捨てられます。

このコマンドには、ライセンスは必要ありません。

次に、ERSPAN セッションの MTU 値を設定する例を示します。

switch# configure terminal
switch(config)# monitor session 1 type erspan-source
switch(config-erspan-src)# mtu 100
switch(config-erspan-src)#
 

 
関連コマンド

コマンド
説明

monitor session

SPAN または ERSPAN セッションを設定します。

show monitor session

SPAN または ERSPAN セッションの設定を表示します。

 

mtu(インターフェイス)

レイヤ 2 およびレイヤ 3 イーサネット インターフェイスの最大伝送ユニット(MTU)サイズを設定するには、 mtu コマンドを使用します。設定した MTU を削除するには、このコマンドの no 形式を使用します。

mtu mtu-value

no mtu mtu-value

 
構文の説明

mtu-value

サービス クラス(CoS)の MTU 値。有効値は、1500 ~ 9216 です。

 
コマンド デフォルト

デフォルトの MTU 値は 1500 です。

 
コマンド モード

ネットワーク QoS クラス タイプのポリシー マップ コンフィギュレーション
スイッチ プロファイル コンフィギュレーション モードでのネットワーク QoS クラス タイプのポリシー マップ

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

設定する MTU 値は、class-default クラス マップで設定した MTU 値によって決まります。


) システムのすべてのクラス マップで同じ MTU 値を設定してください。


次に、ネットワーク QoS タイプのポリシー マップのクラスに MTU 値を設定する例を示します。

switch(config)# class-map type network-qos my_class1
switch(config-cmap-nq)# match qos-group 1
switch(config-cmap-nq)# exit
switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)# class type network-qos my_class1
switch(config-pmap-nq-c)# mtu 5000
switch(config-pmap-nq-c)#
 

次に、スイッチ プロファイルのネットワーク QoS ポリシー マップのクラスの MTU 値を設定する例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# policy-map type network-qos sp-nwpolicy
switch(config-sync-sp-pmap-nq)# class type network-qos sp-nwpolicy-class
switch(config-sync-sp-pmap-nq-c)# mtu 3000
switch(config-sync-sp-pmap-nq-c)#
 

 
関連コマンド

コマンド
説明

service-policy

インターフェイスまたはシステム ポリシーにポリシー マップを関連付けます。

show class-map

クラス マップを表示します。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

system qos

システム ポリシーを設定します。

 

police(ポリシー マップ)

コントロール プレーン ポリシー マップのクラス マップにトラフィック ポリシングを設定するには、 police コマンドを使用します。

police { rate | pps rate }

 
構文の説明

rate

平均レートをパケット/秒(pps)の単位で指定します。有効な範囲は 0 ~ 20,000 です。

pps

(任意)パケット/秒でトラフィック レートの単位を指定します。

 
コマンド デフォルト

100 pps

 
コマンド モード

コントロール プレーン ポリシー マップ コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

PPS のクレジット制限(PCL)は、ポリシー内のすべてのクラスのパケット/秒(pps)レート集約であり、コントロール プレーン ポリシー マップの 22,800 パケット/秒を超えることはできません。この制限を超えた場合、設定が拒否され、次のエラー メッセージが表示されます。

ERROR: Police config. failed
 

このエラー メッセージが表示された場合、次のいずれかを実行します。

トラフィック ポリシング クラスをより小さい pps 値に設定します。

ポリシー マップの 1 秒間のパケット数(pps)の合計数を減らすように、ポリシー マップに含まれる既存クラスのトラフィック ポリシング値を再設定します。

このコマンドには、ライセンスは必要ありません。

次に、200 パケット/秒の平均レートでコントロール プレーン ポリシー マップにトラフィック ポリシングを設定する例を示します。

switch# configure terminal
switch(config)# policy-map type control-plane copp-system-policy
switch(config-pmap)# class ClassMapA
switch(config-pmap-c)# police pps 200
switch(config-pmap-c)#
 

 
関連コマンド

コマンド
説明

class(ポリシー マップ)

コントロール プレーン ポリシー マップのコントロール プレーン クラス マップを指定して、ポリシー マップ クラス コンフィギュレーション モードを開始します。

show policy-map type control-plane

コントロール プレーン ポリシー マップの設定情報を表示します。

 

policy-map type control-plane

コントロール プレーン ポリシー マップ コンフィギュレーション モードを開始するには、 policy-map type control-plane コマンドを使用します。

policy-map type control-plane policy-map-name

 
構文の説明

policy-map-name

デフォルトのコントロール プレーン ポリシー マップの名前。名前は、英数字で指定します。大文字と小文字が区別され、最大文字数は 64 です。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

Cisco Nexus 3000 シリーズ スイッチでは、ユーザ定義のコントロール プレーン ポリシング(CoPP)ポリシー マップを作成できません。スイッチ ソフトウェアにはデフォルトのコントロール プレーン ポリシー マップ、copp-system-policy が含まれます。ただし、デフォルトのコントロール プレーン ポリシー マップのクラスを追加または削除できます。

デフォルト以外の名前でコントロール プレーン ポリシーを作成しようとすると、次のエラー メッセージが表示されます。

ERROR: Policy-map create failed
 

このコマンドには、ライセンスは必要ありません。

次に、コントロール プレーン ポリシー マップ コンフィギュレーション モードを開始する例を示します。

switch# configure terminal
switch(config)# policy-map type control-plane copp-system-policy
switch(config-pmap)#
 

次に、デフォルトのコントロール プレーン ポリシー マップ以外のコントロール プレーン ポリシー マップを作成したときに表示されるエラー メッセージの例を示します。

switch# configure terminal
switch(config)# policy-map type control-plane PolicyMapA
ERROR: Policy-map create failed
switch(config)#
 

 
関連コマンド

コマンド
説明

show policy-map type control-plane

コントロール プレーン ポリシー マップの設定情報を表示します。

 

policy-map type network-qos

ポリシー マップを作成または修正し、ネットワーク QoS タイプのポリシー マップ コンフィギュレーション モードを開始するには、 policy-map type network-qos コマンドを使用します。ポリシー マップを削除するには、このコマンドの no 形式を使用します。

policy-map type network-qos policy-map-name

no policy-map type network-qos policy-map-name

 
構文の説明

policy-map-name

ネットワーク QoS タイプのポリシー マップに割り当てられる名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

ポリシー マップをインターフェイスに割り当てるには、 service-policy コマンドを使用します。

次に、QoS ネットワーク タイプのポリシー マップを作成または修正する例を示します。

switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)#
 

次に、ネットワーク QoS タイプのポリシー マップを削除する例を示します。

switch(config)# no policy-map type network-qos my_policy1
switch(config)
 

次に、スイッチ プロファイルのネットワーク QoS ポリシー マップを作成または修正する例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# policy-map type network-qos sp-nwpolicy
switch(config-sync-sp-pmap-nq)#
 

 
関連コマンド

コマンド
説明

class type network-qos

ポリシー マップのネットワーク QoS タイプのクラス マップを参照します。

description

クラス マップまたはポリシー マップに説明を追加します。

set qos-group

トラフィック クラスに QoS グループ ID を割り当てます。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

policy-map(QoS タイプ)

ポリシー マップを作成または修正し、QoS タイプのポリシー マップ コンフィギュレーション モードを開始するには、 policy-map コマンドを使用します。QoS ポリシー マップを削除するには、このコマンドの no 形式を使用します。

policy-map [ type qos ] qos-policy-map-name

no policy-map [ type qos ] qos-policy-map-name

 
構文の説明

type qos

(任意)QoS タイプのポリシー マップを指定します。

qos-policy-map-name

QoS タイプのポリシー マップに割り当てられる名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

タイプを指定せずに policy-map コマンドを実行すると、QoS タイプのポリシー マップ コンフィギュレーション モードが開始されます。

 
コマンド モード

グローバル コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

QoS ポリシー マップは、スイッチ プロファイルでサポートされます。

 
使用上のガイドライン

ポリシー マップをインターフェイスに割り当てるには、 service-policy コマンドを使用します。

次に、QoS タイプのポリシー マップを作成または修正する例を示します。

switch(config)# policy-map my_policy1
switch(config-pmap-qos)#
 

次に、QoS タイプのポリシー マップを削除する例を示します。

switch(config)# no policy-map my_policy1
 

 
関連コマンド

コマンド
説明

class-map type qos

QoS クラス マップを設定します。

service-policy

ポリシー マップをインターフェイスに関連付けます。

set dscp

QoS トラフィックの DSCP 値を設定します。

set precedence

QoS トラフィックの IP precedence 値を設定します。

set qos-group

トラフィック クラスに QoS グループ ID を割り当てます。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

policy-map type queuing

ポリシー マップを作成または修正し、キューイング タイプのポリシー マップ コンフィギュレーション モードを開始するには、 policy-map type queuing コマンドを使用します。ポリシー マップを削除するには、このコマンドの no 形式を使用します。

policy-map type queuing queuing-policy-map-name

no policy-map type queuing queuing-policy-map-name

 
構文の説明

queuing-policy-map-name

キューイング タイプのポリシー マップに割り当てられる名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

キューイング ポリシー マップは、スイッチ プロファイルでサポートされます。

 
使用上のガイドライン

ポリシー マップをインターフェイスに割り当てるには、 service-policy コマンドを使用します。

次に、キューイング タイプのポリシー マップを作成または修正する例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing my_class1
switch(config-pmap-c-que)# bandwidth percent 75
switch(config-pmap-c-que)# exit
switch(config-pmap-que)#
 

次に、キューイング タイプのポリシー マップを削除する例を示します。

switch(config)# no policy-map type queuing my_policy1
switch(config)#
 

 
関連コマンド

コマンド
説明

bandwidth

インターフェイスの帯域幅を設定します。

service-policy

ポリシー マップをインターフェイスに関連付けます。

set qos-group

トラフィック クラスに QoS グループ ID を割り当てます。

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

priority

ポリシー マップのトラフィック クラスにプライオリティ キューを割り当てるには、 priority コマンドを使用します。マッピングを削除するには、このコマンドの no 形式を使用します。

priority

no priority

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

キューイング タイプのポリシー クラス マップ コンフィギュレーション

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポリシー マップのトラフィック クラスに完全優先キューを設定する場合、プライオリティ クラスは、他のクラス キューより優先されます。このキューは、キュー ゼロ(データ トラフィックではなく制御トラフィックを伝送)以外の他のすべてのキューより先に処理されます。

1 種類のトラフィック クラスだけでの厳密なプライオリティ キューを設定できます。

次に、トラフィック クラスを完全優先キューにマッピングする例を示します。

switch(config)# policy-map type queuing my_policy1
switch(config-pmap-que)# class type queuing 8q2t-in-q4
switch(config-pmap-c-que)# priority
switch(config-pmap-que)#
 

 
関連コマンド

コマンド
説明

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

service-policy(コントロール プレーン)

集約コントロール プレーン サービスのコントロール プレーンにポリシーマップを付加するには、 service-policy コマンドを使用します。

service-policy input policy-map-name

 
構文の説明

input

コントロール プレーンに着信するパケットに指定のサービス ポリシーを適用します。

policy-map-name

関連付けるコントロール プレーン ポリシー マップの名前。この名前には最大 64 文字までの英数字を指定できます。

 
コマンド デフォルト

サービス ポリシーは指定されていません。

 
コマンド モード

コントロール プレーン コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

control-plane コマンドの使用後、 service-policy コマンドを使用して、Quality of Service(QoS)ポリシーを設定する必要があります。このポリシーは集約コントロール プレーン サービスのコントロール プレーン インターフェイスに付加されて、プロセス レベルに入るパケットの数やレートを制御します。

次に、コントロール プレーンにコントロール プレーン ポリシー マップを関連付ける例を示します。

switch# configure terminal
switch(config)# ip access-list ipv4-acl-telnet
switch(config-acl)# permit tcp 10.23.0.0/16 10.176.0.0/16
switch(config-acl)# exit
switch(config)# class-map type control-plane telnet-class
switch(config-cmap)# match access-group name ipv4-acl-telnet
switch(config-cmap)# exit
switch(config)# policy-map type control-plane copp-system-policy
switch(config-pmap)# class telnet-class
switch(config-pmap-c)# police pps 1000
switch(config-pmap-c)# exit
switch(config-pmap)# exit
switch(config)# control-plane
switch(config-cp)# service-policy input copp-system-policy
switch(config-cp)# exit
switch(config)#
 

 
関連コマンド

コマンド
説明

control-plane

コントロール プレーン コンフィギュレーション モードを開始します。

policy-map type control-plane

コントロール プレーン ポリシー マップを作成または変更します。

show policy-map control-plane

コントロール プレーンのポリシー マップのあるクラス、またはすべてのクラスの設定を表示します。

 

service-policy(ポリシーマップ クラス)

ポリシー マップをインターフェイスに付加するには、 service-policy コマンドを使用します。インターフェイスからサービス ポリシーを削除するには、このコマンドの no 形式を使用します。

service-policy { input | type { qos input | queuing output }} policy-map-name

no service-policy { input | type { qos input | queuing output }} policy-map-name

 
構文の説明

input

このポリシー マップをこのインターフェイスに着信するパケットに適用します。

type

ポリシー マップのタイプが QoS かキューイングかを指定します。

qos

QoS タイプのポリシー マップを指定します。

queuing

キューイング タイプのポリシー マップを指定します。

output

このインターフェイスから発信されるパケットにこのポリシー マップを適用します。

policy-map-name

このインターフェイスに関連付けるポリシー マップの名前。QoS およびキューイング タイプの各ポリシーに対して、インターフェイスの入力および出力に関連付けることができるポリシー マップはそれぞれ 1 つだけです。

ポリシー マップ名には最大 40 文字の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポートおよびポート チャネル タイプのインターフェイスに対して、キューイング タイプのポリシー マップの出力を 1 つ関連付けることができます。QoS タイプのポリシーの場合、特定のインターフェイスの入力に関連付けることができるポリシー マップは 1 つだけです。

次に、QoS タイプのポリシー マップをレイヤ 2 インターフェイスの着信パケットに関連付ける例を示します。

switch# configure terminal
switch(config)# system qos
switch(config-sys-qos)# service-policy type qos input my_policy1
switch(config-sys-qos)#
 

次に、set-dscp という名前の QoS タイプのポリシー マップをレイヤ 2 インターフェイスの着信パケットに関連付ける例を示します。

switch# configure terminal
switch(config)# policy-map type qos set-dscp
switch(config-pmap-qos)# class class-0
switch(config-pmap-c-qos)# set dscp ef
switch(config-pmap-c-qos)# exit
switch(config-pmap-qos)# class class-1-2
switch(config-pmap-c-qos)# set precedence 4
switch(config-pmap-c-qos)# exit
switch(config-pmap-qos)# exit
switch(config)# interface ethernet 2/1
switch(config-if)# service-policy type qos input set-dscp
switch(config-if)#
 

 
関連コマンド

コマンド
説明

no switchport

インターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

show policy-map interface brief

すべてのインターフェイスと VLAN、および関連付けられたサービス ポリシーの概要を表示します。

system qos

システム ポリシーを設定します。

 

service-policy(システム QoS)

システム ポリシーにポリシー マップを関連付けるには、 service-policy コマンドを使用します。システム ポリシーからサービス ポリシーを削除するには、このコマンドの no 形式を使用します。

service-policy { input | type { network-qos | qos input | queuing output }} policy-map-name

no service-policy { input | type { network-qos | qos input | queuing output }} policy-map-name

 
構文の説明

input

このポリシー マップをこのインターフェイスに着信するパケットに適用します。

type

ポリシー マップのタイプが network-qos、qos、またはキューイングかを指定します。

network-qos

network-qos タイプのポリシー マップを指定します。

qos

QoS タイプのポリシー マップを指定します。

queuing

キューイング タイプのポリシー マップを指定します。

output

このインターフェイスから発信されるパケットにこのポリシー マップを適用します。

policy-map-name

このインターフェイスに関連付けるポリシー マップの名前。ポリシー マップ名には最大 40 文字の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

システム QoS コンフィギュレーション モード
スイッチ プロファイル システム QoS コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

次に、システム ポリシーにキューイング ポリシー マップを関連付ける例を示します。

switch# configure terminal
switch(config)# system qos
switch(config-sys-qos)# service-policy type queuing output my_input_q_policy
switch(config-sys-qos)#
 

 
関連コマンド

コマンド
説明

show policy-map

ポリシー マップを表示します。

system qos

システム ポリシーを設定します。

 

set cos(ネットワーク QoS タイプのポリシー マップ)

ネットワーク QoS タイプのポリシー マップのトラフィックのクラスにサービス クラス(CoS)値を割り当てるには、 set cos コマンドを使用します。割り当てられた値をクラスから削除するには、このコマンドの no 形式を使用します。

set cos cos-value

no set cos cos-value

 
構文の説明

cos-value

トラフィックのこのクラスに割り当てる CoS 値。有効な範囲は 0 ~ 7 です。

 
コマンド デフォルト

なし

 
コマンド モード

ネットワーク QoS クラス タイプのポリシー マップ コンフィギュレーション
スイッチ プロファイル コンフィギュレーション モードでのネットワーク QoS クラス タイプのポリシー マップ

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

このコマンドを使用できるのは、出力ポートに関連付けられるネットワーク QoS タイプのポリシー上だけです。

次に、ネットワーク QoS タイプのポリシー マップのトラフィックのクラスに CoS 値を割り当てる例を示します。

switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)# class type network-qos traffic_class2
switch(config-pmap-nq-c)# set cos 3
switch(config-pmap-nq-c)#
 

次に、ネットワーク QoS タイプのポリシー マップのトラフィックのクラスから CoS 値の割り当てを削除する例を示します。

switch(config)# policy-map type network-qos my_policy1
switch(config-pmap-nq)# class type network-qos traffic_class2
switch(config-pmap-nq-c)# no set cos 3
switch(config-pmap-nq-c)#
 

次に、スイッチ プロファイルのネットワーク QoS ポリシー マップのトラフィックのクラスに CoS 値を割り当てる例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# policy-map type network-qos sp-nwpolicy
switch(config-sync-sp-pmap-nq)# class type network-qos sp-nwpolicy-class
switch(config-sync-sp-pmap-nq-c)# set cos 3
switch(config-sync-sp-pmap-nq-c)#
 

 
関連コマンド

コマンド
説明

show policy-map

ポリシー マップを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

set dscp

QoS タイプのポリシー マップで、トラフィック クラスに DiffServ コード ポイント(DSCP)値を割り当てるには、 set dscp コマンドを使用します。以前に設定した DSCP 値を削除するには、このコマンド no 形式を使用します。

set dscp dscp-value

no set dscp dscp-value

 
構文の説明

dscp-value

このトラフィック クラスに割り当てる DSCP 値またはパラメータを指定します。有効値は、0 ~ 63 です。

標準的な DSCP 値の一覧については、 表 i-1 を参照してください。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのポリシー マップ コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モードでの QoS ポリシー マップ

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

スイッチ プロファイルに DSCP 値を設定するサポートが追加されました。

 
使用上のガイドライン

マーキングは、着信および発信パケットの Quality of Service(QoS)フィールドを変更するために使用する方式です。

標準の QoS フィールドである、IP precedence、DSCP、サービス クラス(CoS)の値、および後続のアクションで使用できる内部ラベルを設定できます。マーキングは、トラフィックのポリシング、キューイング、およびスケジューリングで使用するトラフィックのタイプを識別するのに使用します(スケジューリングでは CoS だけを使用します)。

このコマンドは、DSCP パケット ヘッダー フィールドに基づいてトラフィックを分類するために使用します。パケットの DSCP 値を設定する場合は、class-default システム クラス以外のトラフィック クラスを使用する必要があります。たとえば、qos-group x で、 x の値は 1 ~ 7 のいずれかです。


) トラフィックが class-default システム クラス(QoS-group 0)の場合、DSCP パケット ヘッダー フィールドを設定することはできません。


IP ヘッダーの DiffServ フィールドの上位 6 ビットで、DSCP 値を指定の値に設定できます。0 ~ 63 の数値のほか、 表 i-1 に示す標準の DSCP 値も入力できます。

3 つ以上の IP ヘッダー フィールドに値を設定すると、次に類似するエラー メッセージが表示されます。

ERROR: Only 2 sets out of qos-group/cos/dscp/precedence/discard-class are allowed. Please remove other set action before applying this one.
 

) DSCP または IP precedence を設定できますが、IP パケットの同じフィールドを変更することになるため、両方の値を設定することはできません。


DSCP 値を設定した後、QoS ポリシー マップが正しく動作して特定の QoS グループが作成されるようにするため、システム ポリシーに QoS ポリシー マップを関連付け、network-qos タイプのポリシー マップを定義してから、システム ポリシーにこのポリシー マップを関連付けます。QoS ポリシー マップの QoS グループがネットワーク QoS ポリシーの QoS グループと一致することを確認します。

次に、QoS ポリシーの DSCP 値を設定する例を示します。

switch(config)# policy-map type qos my_policy
switch(config-pmap-qos)# class type qos my_class
switch(config-pmap-c-qos)# set dscp cs6
switch(config-pmap-c-qos)# set qos-group 2
switch(config-pmap-c-qos)# exit
switch(config-pmap-qos)# exit
switch(config)# system qos
switch(config-sys-qos)# service-policy type qos input my_policy
switch(config-sys-qos)# exit
switch(config)# class-map type network-qos nqos_class
switch(config-cmap-nq)# match qos-group 2
switch(config-cmap-nq)# exit
switch(config)# policy-map type network-qos nqos_policy
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)# exit
switch(config-pmap-nq)# exit
switch(config)# system qos
switch(config-sys-qos)# service-policy type network-qos nqos_policy
switch(config-sys-qos)# exit
switch(config)#
 

次に、スイッチ プロファイルで QoS ポリシーの DSCP 値を設定する例を示します。

switch# configure sync
switch(config-sync)# switch-profile s5010
switch(config-sync-sp)# policy-map type qos sp_pm_qos
switch(config-sync-sp-pmap-qos)# class type qos sp_cl_qos
switch(config-sync-sp-pmap-c-qos)# set dscp cs6
switch(config-sync-sp-pmap-c-qos)# set qos-group 1
switch(config-sync-sp-pmap-c-qos)# exit
switch(config-sync-sp-pmap-qos)# exit
switch(config-sync-sp)# system qos
switch(config-sync-sp-sys-qos)# service-policy type qos input my_policy
switch(config-sync-sp-sys-qos)# exit
switch(config-sync-sp)# class-map type network-qos nqos_class
switch(config-sync-sp-cmap-nq)# match qos-group 2
switch(config-sync-sp-cmap-nq)# exit
switch(config-sync-sp)# policy-map type network-qos nqos_policy
switch(config-sync-sp-pmap-nq)# class type network-qos nqos_class
switch(config-sync-sp-pmap-nq-c)# exit
switch(config-sync-sp-pmap-nq)# exit
switch(config-sync-sp)# system qos
switch(config-sync-sp-sys-qos)# service-policy type network-qos nqos_policy
switch(config-sync-sp-sys-qos)# exit
switch(config-sync-sp)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show policy-map type qos

QoS ポリシー マップを表示します。

show running-config ipqos

QoS の実行コンフィギュレーションを表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

set precedence

QoS タイプのポリシー マップで、トラフィック クラスの IP ヘッダーに含まれる precedence 値を設定するには、 set precedence コマンドを使用します。クラスの precedence 値をデフォルト値に戻すには、このコマンドの no 形式を使用します。

set precedence precedence-value

no set precedence precedence-value

 
構文の説明

precedence-value

トラフィックのこのクラスに割り当てる IP precedence 値。有効値の範囲は 0 ~ 7 です。

標準的な precedence 値の一覧については、 表 i-2 を参照してください。

 
コマンド デフォルト

なし

 
コマンド モード

QoS タイプのポリシー マップ コンフィギュレーション
スイッチ プロファイル コンフィギュレーション モードでの QoS タイプのポリシー マップ

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

スイッチ プロファイルに IP precedence 値を設定するサポートが追加されました。

 
使用上のガイドライン

マーキングは、着信および発信パケットの Quality of Service(QoS)フィールドを変更するために使用する方式です。

標準の QoS フィールドである、IP precedence、DSCP、サービス クラス(CoS)の値、および後続のアクションで使用できる内部ラベルを設定できます。マーキングは、トラフィックのポリシング、キューイング、およびスケジューリングで使用するトラフィックのタイプを識別するのに使用します(スケジューリングでは CoS だけを使用します)。

このコマンドは、IP precedence パケット ヘッダー フィールドに基づいてトラフィックを分類するために使用します。パケットの IP precedence 値を設定する場合は、class-default システム クラス以外のトラフィック クラスを使用する必要があります。たとえば、qos-group x で、 x の値は 1 ~ 7 のいずれかです。


) トラフィックが class-default システム クラス(QoS-group 0)の場合、IP precedence パケット ヘッダー フィールドを設定することはできません。


3 つ以上の IP ヘッダー フィールドに値を設定すると、次のようなエラー メッセージが表示されます。

ERROR: Only 2 sets out of qos-group/cos/dscp/precedence/discard-class are allowed. Please remove other set action before applying this one.
 

) DSCP または IP precedence を設定できますが、IP パケットの同じフィールドを変更することになるため、両方の値を設定することはできません。


IP precedence 値を設定した後、QoS ポリシー マップが正しく動作して特定の QoS グループが作成されるようにするため、システム ポリシーに QoS ポリシー マップを関連付け、network-qos タイプのポリシー マップを定義してから、システム ポリシーにこのポリシー マップを関連付けます。QoS ポリシー マップの QoS グループがネットワーク QoS ポリシーの QoS グループと一致することを確認します。

次に、QoS ポリシーの IP precedence 値を設定する例を示します。

switch(config)# policy-map type qos my_policy
switch(config-pmap-qos)# class type qos my_class
switch(config-pmap-c-qos)# set precedence 5
switch(config-pmap-c-qos)# set qos-group 1
switch(config-pmap-c-qos)# exit
switch(config-pmap-qos)# exit
switch(config)# system qos
switch(config-sys-qos)# service-policy type qos input my_policy
switch(config-sys-qos)# exit
switch(config)# class-map type network-qos nqos_class
switch(config-cmap-nq)# match qos-group 1
switch(config-cmap-nq)# exit
switch(config)# policy-map type network-qos nqos_policy
switch(config-pmap-nq)# class type network-qos nqos_class
switch(config-pmap-nq-c)# exit
switch(config-pmap-nq)# exit
switch(config)# system qos
switch(config-sys-qos)# service-policy type network-qos nqos_policy
switch(config-sys-qos)# exit
switch(config)#
 

次に、スイッチ プロファイルで QoS ポリシーの IP precedence 値を設定する例を示します。

switch# configure sync
switch(config-sync)# switch-profile s5010
switch(config-sync-sp)# policy-map type qos sp_pm_qos
switch(config-sync-sp-pmap-qos)# class type qos sp_cl_qos
switch(config-sync-sp-pmap-c-qos)# set precedence 3
switch(config-sync-sp-pmap-c-qos)# set qos-group 5
switch(config-sync-sp-pmap-c-qos)# exit
switch(config-sync-sp-pmap-qos)# exit
switch(config-sync-sp)# system qos
switch(config-sync-sp-sys-qos)# service-policy type qos input my_policy
switch(config-sync-sp-sys-qos)# exit
switch(config-sync-sp)# class-map type network-qos nqos_class
switch(config-sync-sp-cmap-nq)# match qos-group 5
switch(config-sync-sp-cmap-nq)# exit
switch(config-sync-sp)# policy-map type network-qos nqos_policy
switch(config-sync-sp-pmap-nq)# class type network-qos nqos_class
switch(config-sync-sp-pmap-nq-c)# exit
switch(config-sync-sp-pmap-nq)# exit
switch(config-sync-sp)# system qos
switch(config-sync-sp-sys-qos)# service-policy type network-qos nqos_policy
switch(config-sync-sp-sys-qos)# exit
switch(config-sync-sp)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show policy-map type qos

QoS ポリシー マップを表示します。

show running-config ipqos

QoS の実行コンフィギュレーションを表示します。

show startup-config ipqos

スタートアップ ファイルに保存されている QoS の設定を表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

set qos-group

QoS タイプのポリシー マップのトラフィックのクラスに QoS グループ ID を割り当てるには、 set qos-group コマンドを使用します。割り当てられた値をクラスから削除するには、このコマンドの no 形式を使用します。

set qos-group qos-group-value

no set qos-group qos-group-value

 
構文の説明

qos-group-value

トラフィックのこのクラスに割り当てる QoS グループ値。指定できる範囲は 1 ~ 7 です。

 
コマンド デフォルト

なし

 
コマンド モード

QoS クラス タイプのポリシー マップ コンフィギュレーション
スイッチ プロファイル コンフィギュレーション モードでの QoS タイプのポリシー マップ

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

スイッチ プロファイルに QoS グループを設定するサポートが追加されました。

 
使用上のガイドライン

QoS グループ ID 値は、入力ポリシーだけで設定できます。入力ポリシーには最大 7 つの QoS グループを設定できます。

次に、QoS タイプのポリシー マップのトラフィックのクラスに QoS グループ ID を割り当てる例を示します。

switch(config)# policy-map my_policy1
switch(config-pmap-qos)# class traffic_class2
switch(config-pmap-c-qos)# set qos-group 3
switch(config-pmap-c-qos)#
 

次に、スイッチ プロファイルの QoS ポリシーに QoS グループ ID を割り当てる例を示します。

switch# configure sync
switch(config-sync)# switch-profile s5010
switch(config-sync-sp)# policy-map type qos sp_pm_qos
switch(config-sync-sp-pmap-qos)# class type qos sp_cl_qos
switch(config-sync-sp-pmap-c-qos)# set qos-group 2
switch(config-sync-sp-pmap-c-qos)#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show policy-map type qos

QoS ポリシー マップを表示します。

show running-config ipqos

QoS の実行コンフィギュレーションを表示します。

show startup-config ipqos

スタートアップ ファイルに保存されている QoS の設定を表示します。

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

show class-map type control-plane

コントロール プレーン クラス マップ情報を表示するには、 show class-map type control-plane コマンドを使用します。

show class-map type control-plane [ class-map-name ]

 
構文の説明

class-map-name

(任意)コントロール プレーン クラス マップの名前 名前には英数字を使用します。大文字と小文字が区別され、 最大で 64 文字の長さまで指定可能です。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、コントロール プレーン クラス マップ情報を表示する例を示します。

switch# show class-map type control-plane
 
class-map type control-plane match-any ClassMapA
match access-grp name copp-system-acl-snmp
 
class-map type control-plane match-any classMapA
match access-grp name copp-system-acl-telnet
 
class-map type control-plane match-any copp-icmp
match access-grp name copp-system-acl-icmp
 
class-map type control-plane match-any copp-ntp
match access-grp name copp-system-acl-ntp
 
class-map type control-plane match-any copp-s-arp
 
class-map type control-plane match-any copp-s-bpdu
 
class-map type control-plane match-any copp-s-dai
 
class-map type control-plane match-any copp-s-default
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

class-map type control-plane

コントロール プレーン クラス マップを作成または設定します。

 

show class-map type network-qos

ネットワーク QoS タイプのクラス マップを表示するには、 show class-map type network-qos コマンドを使用します。

show class-map type network-qos [ class-map-name ]

 
構文の説明

class-map-name

クラス マップ名です。最大 40 の英数字を使用できます。

 
コマンド デフォルト

クラス マップ名が指定されていない場合、ネットワーク QoS タイプのすべてのクラスマップが表示されます。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

タイプを指定しない場合、システムで設定されているすべてのクラス マップが表示されます。

次に、ネットワーク QoS タイプのすべてのクラス マップを表示する例を示します。

switch# show class-map type network-qos
 
class-map type network-qos cn1
match qos-group 1
 
class-map type network-qos cn2
match qos-group 2
 
class-map type network-qos cn3
match qos-group 3
 
class-map type network-qos cn4
match qos-group 4
 
class-map type network-qos cn5
match qos-group 5
 
class-map type network-qos cn6
match qos-group 6
 
class-map type network-qos cn7
match qos-group 7
 
class-map type network-qos class-default
match qos-group 0
 
switch#
 

次に、すべてのすべてのネットワーク QoS クラス マップを表示する例を示します。

switch# show class-map
 
 
Type qos class-maps
===================
 
class-map type qos match-all cqos1
match cos 1
 
class-map type qos match-all cqos6
match cos 6
 
class-map type qos match-any class-default
match any
 
 
Type queuing class-maps
=======================
 
class-map type queuing cqu1
match qos-group 1
 
class-map type queuing cqu6
match qos-group 6
 
class-map type queuing class-default
match qos-group 0
 
 
 
Type network-qos class-maps
==============================
 
class-map type network-qos cnq1
match qos-group 1
 
class-map type network-qos cnq6
match qos-group 6
 
class-map type network-qos class-default
match qos-group 0
 
switch#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

 

show class-map type qos

QoS タイプのクラス マップを表示するには、 show class-map type qos コマンドを使用します。

show class-map type qos [ class-map-name ]

 
構文の説明

class-map-name

クラス マップの名前。 class-default という名前は予約されています。最大 40 の英数字を使用できます。

 
コマンド デフォルト

クラス マップ名が指定されていない場合、QoS タイプのすべてのクラスマップが表示されます。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

次に、QoS タイプのすべてのクラス マップを表示する例を示します。

switch(config)# show class-map type qos
 
 
Type qos class-maps
===================
 
class-map type qos match-all cq1
match cos 1
 
class-map type qos match-all cq2
match cos 2
 
class-map type qos match-all cq3
match cos 3
 
class-map type qos match-all cq4
match cos 4
 
class-map type qos match-all cq5
match cos 5
 
class-map type qos match-all cq6
match cos 6
 
class-map type qos match-all cl_acl
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

 

show class-map type queuing

キューイング タイプのクラス マップを表示するには、 show class-map type queuing コマンドを使用します。

show class-map type queuing [ class-map-name ]

 
構文の説明

class-map-name

クラス マップの名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

クラス マップ名が指定されていない場合、キューイング タイプのすべてのクラスマップが表示されます。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

次に、キューイング タイプのすべてのクラス マップを表示する例を示します。

switch(config)# show class-map type queuing
 
 
Type queuing class-maps
=======================
 
class-map type queuing q1
match qos-group 1
 
class-map type queuing q2
match qos-group 2
 
class-map type queuing q3
match qos-group 3
 
class-map type queuing q4
match qos-group 4
 
class-map type queuing q5
match qos-group 5
 
class-map type queuing q6
match qos-group 6
 
class-map type queuing q7
match qos-group 7
 
class-map type queuing class-default
match qos-group 0
 
switch(config)#
 

 
関連コマンド

コマンド
説明

class-map

クラス マップを作成、または変更します。

 

show copp status

コントロール プレーン ポリシング(CoPP)の設定ステータスを表示するには、 show copp status コマンドを使用します。

show copp status

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、CoPP 設定ステータス情報を表示する例を示します。

switch# show copp status
Last Config Operation: class-map type control-plane ClassMapA
Last Config Operation Timestamp: 06:15:21 UTC Aug 23 2011
Last Config Operation Status: Success
Policy-map attached to the control-plane: copp-system-policy
 
switch#
 

 
関連コマンド

コマンド
説明

clear copp statistics

CoPP 統計情報をクリアします。

show running-config copp

実行コンフィギュレーションの CoPP コンフィギュレーション情報を表示します。

 

show hardware internal buffer info pkt-stats

実行中のシステムで、出力ポートごとおよびキューごとの占有をモニタするには、 show hardware internal buffer info pkt-stats コマンドを使用します。

show hardware internal buffer info pkt-stats [ brief | clear | detail | port-log ]

 
構文の説明

brief

システム バッファの統計情報だけを表示します。

clear

最大セル使用状況値をクリアします。

detail

詳細な統計情報を表示します。

port-log

セル使用状況のしきい値制限を超えるポートに関する情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

システムにおけるキューおよびバッファの瞬間的な占有をチェックするためにこのコマンドを使用します。スイッチの出力では次のデータが表示されます。

ユニキャストおよびマルチキャスト トラフィックの両方について、システムでのポートごとの瞬間的なキューの増大。

システム レベルでの瞬間的および最大の出力バッファの占有。

キーワードを指定しないでこのコマンドを使用すると、スイッチの出力は、システム レベルのバッファの占有およびポート レベルのバッファの占有を示します。ポート レベルのバッファの占有は、一定の瞬間バッファ使用量があるポートに対してのみ表示されます。

brief キーワードを指定してこのコマンドを使用すると、スイッチの出力は、(ポートに一定の瞬間バッファ使用量があるかどうかに関係なく)システム レベルのバッファの占有だけを示します。

detail キーワードを指定してこのコマンドを使用すると、スイッチの出力は、一定の瞬間バッファ使用量がないポートについても、すべてのポートのシステム レベルおよびポート レベルのバッファの占有を示します。

次に、システムにおけるキューおよびバッファの瞬間的な占有をチェックする例を示します。

switch# show hardware internal buffer info pkt-stats
|----------------------------------------------------------------------------------------|
 
Total Instant Usage 0
Remaining Instant Usage 46080
Max Cell Usage 2
Switch Cell Count 46080
|----------------------------------------------------------------------------------------|
 
 
switch#
 

次に、システムの最大セル使用状況値をクリアする例を示します。

switch# show hardware internal buffer info pkt-stats clear
 
Max Cell Usage has been reset successfully
 
switch#
switch# show hardware internal buffer info pkt-stats
|----------------------------------------------------------------------------------------|
 
Total Instant Usage 0
Remaining Instant Usage 46080
Max Cell Usage 1
Switch Cell Count 46080
|----------------------------------------------------------------------------------------|
 
 
switch#
 

次に、システムにおけるキューおよびバッファの瞬間の占有に関する詳細情報を表示する例を示します。

switch# show hardware internal buffer info pkt-stats detail
|----------------------------------------------------------------------------------------|
 
Total Instant Usage 0
Remaining Instant Usage 46080
Max Cell Usage 2
Switch Cell Count 46080
|----------------------------------------------------------------------------------------|
 
|----------------------------------------------------------------------------------------|
| Instant Buffer utilization per queue per port |
| Each line displays the number of cells utilized for a given port for each QoS queue |
| One cell represents approximately 208 bytes |
|---------+---------+---------+---------+---------+---------+--------+---------+---------|
|Port Q1 Q2 Q3 Q4 Q5 Q6 Q7 Q8 |
|---------+---------+---------+---------+---------+---------+--------+---------+---------|
 
 
[ 1]
UC-> 0 0 0 0 0 0 0 0
MC-> 0 0 0 0
 
[ 2]
UC-> 0 0 0 0 0 0 0 0
MC-> 0 0 0 0
 
[ 3]
UC-> 0 0 0 0 0 0 0 0
MC-> 0 0 0 0
<--Output truncated-->
switch#
 

次に、システムのポート ログ情報を表示する例を示します。

switch# show hardware internal buffer info pkt-stats port-log
09-27-2011 15:09:30.806941 Port 2 buffer threshold exceeded
09-27-2011 15:09:30.807404 Port 13 buffer threshold exceeded
09-27-2011 15:09:30.807508 Port 14 buffer threshold exceeded
09-27-2011 15:09:30.808722 Port 47 buffer threshold exceeded
switch#

 

show interface untagged-cos

指定したインターフェイスのタグなしサービス クラス(CoS)値を表示するには、 show interface untagged-cos コマンドを使用します。

show interface untagged-cos [ module module_no ]

 
構文の説明

module

(任意)スイッチ シャーシのこのモジュールのインターフェイスを表示します。

module_no

スイッチ シャーシのモジュール番号。有効な範囲は 1 ~ 18 です。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

次に、インターフェイスのタグなし CoS 値を表示する例を示します。

switch# show interface untagged-cos
=================================
 
Interface Untagged-CoS
=================================
 
port-channel1
port-channel10
port-channel100
port-channel200
port-channel234
port-channel300
port-channel400
Ethernet1/1
Ethernet1/2
Ethernet1/3
Ethernet1/4
Ethernet1/5
<--Output trunctaed-->
switch#
 

 
関連コマンド

コマンド
説明

untagged cos

タグなしイーサネット フレームの CoS 値を設定します。

 

show policy-map

ポリシー マップを表示するには、 show policy-map コマンドを使用します。

show policy-map [ type { network-qos | qos | queuing }] [ policy-map-name ]

 
構文の説明

type

(任意)表示するコンポーネント タイプを指定します。

network-qos

ネットワーク QoS タイプのポリシー マップを表示します。

qos

QoS タイプのポリシー マップだけを表示します。

queuing

キューイング タイプのポリシー マップだけを表示します。

policy-map-name

(任意)ポリシー マップの名前。最大 40 の英数字を使用できます。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートが、コントロール プレーン ポリシー マップで導入されました。

 
使用上のガイドライン

引数やキーワードを指定せずに show policy-map コマンドを入力すると、Control Plane Policing(CoPP; コントロール プレーン ポリシング)情報も表示されます。

次に、Cisco NX-OS Release 5.0(3)U1(1) を実行しているスイッチ上のすべての設定済みポリシー マップを表示する例を示します。

switch# show policy-map
 
 
Type qos policy-maps
====================
 
policy-map type qos pqos
class type qos cqos1
set qos-group 1
class type qos cqos6
set qos-group 6
class type qos class-default
set qos-group 0
policy-map type qos default-in-policy
class type qos class-default
set qos-group 0
 
Type queuing policy-maps
========================
 
policy-map type queuing pqu
class type queuing cqu1
bandwidth percent 10
class type queuing cqu6
bandwidth percent 20
class type queuing class-default
bandwidth percent 70
policy-map type queuing default-out-policy
class type queuing class-default
bandwidth percent 100
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos pnqos
class type network-qos cnq1
mtu 1500
set cos 4
class type network-qos cnq6
mtu 1500
set cos 5
congestion-control random-detect ecn
class type network-qos class-default
mtu 9216
policy-map type network-qos default-nq-policy
class type network-qos class-default
mtu 1500
 
switch#
 

次に、Cisco NX-OS Release 5.0(3)U1(1) を実行するスイッチ上の、指定された名前のネットワーク QoS ポリシー マップを表示する例を示します。

switch# show policy-map type network-qos my_pnq
 

次に、Cisco NX-OS Release 5.0(3)U2(1) を実行しているスイッチ上のすべての設定済みポリシー マップを表示する例を示します。

switch# show policy-map
 
 
Type qos policy-maps
====================
 
policy-map type qos mix
class type qos ip-rtp-2000-3000
set qos-group 2
set dscp 20
class type qos ip-rtp-4000-5000
set qos-group 3
set prec 5
class type qos cos-prec
set qos-group 4
set dscp 25
class type qos class-default
set qos-group 0
:
<--snip-->
:
Type queuing policy-maps
========================
 
policy-map type queuing qqq
class type queuing q1
bandwidth percent 10
priority
class type queuing q2
bandwidth percent 10
class type queuing q3
bandwidth percent 10
class type queuing q4
bandwidth percent 20
class type queuing q5
bandwidth percent 20
class type queuing q6
bandwidth percent 10
class type queuing q7
bandwidth percent 10
class type queuing class-default
bandwidth percent 10
policy-map type queuing default-out-policy
class type queuing class-default
bandwidth percent 100
 
 
Type control-plane policy-maps
==============================
 
policy-map type control-plane copp-system-policy
class copp-s-default
police pps 400
class copp-s-l2switched
police pps 200
class copp-s-ping
police pps 100
class copp-telnet
police pps 500
class copp-ssh
police pps 500
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

 

show policy-map interface

各インターフェイスに設定されているサービス ポリシー マップを表示するには、 show policy-map interface コマンドを使用します。

show policy-map interface [ ethernet slot / port | port-channel channel-number ] [ input | output ] [ type { qos | queuing }]

 
構文の説明

ethernet

(任意)イーサネット インターフェイスに割り当てられているポリシー マップを表示します。

slot/port

イーサネット インターフェイスのスロット番号とポート番号を指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

port-channel

(任意)EtherChannel に割り当てられているポリシー マップを表示します。

channel-number

EtherChannel 番号。範囲は 1 ~ 4096 です。

input

(任意)入力トラフィックに割り当てられているポリシー マップだけを表示します。

output

(任意)出力トラフィックに割り当てられているポリシー マップだけを表示します。

type

(任意)表示するコンポーネント タイプを指定します。

qos

QoS タイプのポリシー マップだけを表示します。

queuing

キューイング タイプのポリシー マップだけを表示します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

デフォルトでは統計情報が表示されます。

次に、指定したインターフェイスに割り当てられているポリシー マップを表示する例を示します。

switch# show policy-map interface ethernet 1/1
 
 
Global statistics status : disabled
 
Ethernet1/1
 
Service-policy (qos) input: pqos
policy statistics status: disabled
 
Class-map (qos): cqos1 (match-all)
Match: cos 1
set qos-group 1
 
Class-map (qos): cqos6 (match-all)
Match: cos 6
set qos-group 6
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
Service-policy (queuing) output: pqu
policy statistics status: disabled
<--Output truncated-->
switch#
 

次に、指定したインターフェイスに割り当てられている QoS ポリシー マップを表示する例を示します。

switch# show policy-map interface ethernet 1/1 type qos
 
 
Global statistics status : disabled
 
Ethernet1/1
 
Service-policy (qos) input: default-in-policy
policy statistics status: disabled
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
switch#
 

次に、指定したインターフェイスの出力トラフィックに割り当てられたポリシー マップを表示する例を示します。

switch# show policy-map interface ethernet 3/1 output
 
 
Global statistics status : disabled
 
Ethernet1/1
 
Service-policy (queuing) output: default-out-policy
policy statistics status: disabled
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 100
 
switch#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

 

show policy-map interface brief

インターフェイスに適用されるポリシー マップの概要を表示するには、 show policy-map interface brief コマンドを使用します。

show policy-map interface brief

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

次に、割り当てられているポリシー マップの概要を表示する例を示します。

switch(config)# show policy-map interface brief
 
 
Interface/VLAN [Status]:INP QOS OUT QOS INP QUE OUT QUE
================================================================================
Ethernet1/1 [Active]:default-in-po default-out-p
 
Ethernet1/2 [Active]:default-in-po default-out-p
 
Ethernet1/3 [Active]:default-in-po default-out-p
 
Ethernet1/4 [Active]:default-in-po default-out-p
 
Ethernet1/5 [Active]:default-in-po default-out-p
 
<--output truncated-->
switch(config)#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

show policy-map

ポリシー マップを表示します。

 

show policy-map interface control-plane

インターフェイスに適用されたコントロール プレーン ポリシー マップを表示するには、 show policy-map interface control-plane コマンドを使用します。

show policy-map interface control-plane

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

次に、割り当てられたコントロール プレーン ポリシー マップを表示する例を示します。

switch(config)# show policy-map interface control-plane
control Plane
 
service-policy input: copp-system-policy
 
class-map copp-s-default (match-any)
police pps 400
OutPackets 0
DropPackets 0
class-map copp-s-l2switched (match-any)
police pps 200
OutPackets 0
DropPackets 0
class-map copp-s-ping (match-any)
match access-grp name copp-system-acl-ping
police pps 100
OutPackets 0
DropPackets 0
class-map copp-telnet (match-any)
match access-grp name copp-system-acl-telnet
police pps 500
OutPackets 0
DropPackets 0
<--Output truncated-->
switch(config)#
 

 
関連コマンド

コマンド
説明

policy-map

ポリシー マップを作成、または変更します。

show policy-map

ポリシー マップを表示します。

 

show policy-map system

システムのすべてのアクティブ ポリシー マップを表示するには、 show policy-map system コマンドを使用します。

show policy-map system [ type { network-qos | qos [ input ] | queuing [ input | output ]}]

 
構文の説明

type

(任意)表示するコンポーネント タイプを指定します。

network-qos

ネットワーク QoS タイプのポリシー マップだけを表示します。

qos

QoS タイプのポリシー マップだけを表示します。

input

(任意)入力トラフィックに割り当てられているポリシー マップを表示します。

queuing

キューイング タイプのポリシー マップだけを表示します。

output

(任意)出力トラフィックに割り当てられているポリシー マップを表示します。

 
コマンド デフォルト

すべてのポリシー マップ

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポリシー マップのタイプと名前を指定しない場合、システムのすべてのアクティブ ポリシー マップが表示されます。

次に、システムのすべてのアクティブ ポリシー マップを表示する例を示します。

switch# show policy-map system
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos pnqos
class type network-qos cnq1 match qos-group 1
 
mtu 1500
set cos 4
class type network-qos cnq6 match qos-group 6
 
mtu 1500
set cos 5
congestion-control random-detect ecn
class type network-qos class-default match qos-group 0
 
mtu 9216
 
Service-policy (qos) input: pqos
policy statistics status: disabled
 
Class-map (qos): cqos1 (match-all)
Match: cos 1
set qos-group 1
 
Class-map (qos): cqos6 (match-all)
Match: cos 6
set qos-group 6
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
Service-policy (queuing) output: pqu
policy statistics status: disabled
 
Class-map (queuing): cqu1 (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): cqu6 (match-any)
Match: qos-group 6
bandwidth percent 20
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 70
 
switch#
 

次に、システムのアクティブなネットワーク QoS タイプのポリシー マップを表示する例を示します。

switch# show policy-map system type network-qos
 

 
関連コマンド

コマンド
説明

show policy-map

すべてのポリシー マップを表示します。

 

show policy-map type control-plane

コントロール プレーン ポリシー マップ情報を表示するには、 show policy-map type control-plane コマンドを使用します。

show policy-map type control-plane [ expand ] [ name policy-map-name ]

 
構文の説明

expand

(任意)拡張されたコントロール プレーン ポリシー マップ情報を表示します。

name policy-map-name

(任意)コントロール プレーン ポリシー マップの名前を指定します。名前は最大 64 文字の英数字で、大文字と小文字が区別されます。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、コントロール プレーン ポリシー マップ情報を表示する例を示します。

switch# show policy-map type control-plane
 
policy-map type control-plane copp-system-policy
class copp-s-default
police pps 400
class copp-s-l2switched
police pps 200
class copp-s-ping
police pps 100
class copp-telnet
police pps 500
class copp-ssh
police pps 500
class copp-snmp
police pps 500
class copp-ntp
police pps 100
<--Output truncated-->
switch#
 

次に、コントロール プレーン ポリシー マップ情報を拡張形式で表示する例を示します。

switch# show policy-map type control-plane expand
 

 
関連コマンド

コマンド
説明

policy-map type control-plane

コントロール プレーン ポリシー マップを作成または設定します。

 

show queuing interface

インターフェイスのキューイング情報を表示するには、 show queuing interface コマンドを使用します。

show queuing interface [ ethernet slot-no / port-no ]

 
構文の説明

ethernet

(任意)イーサネット インターフェイスに表示されるキューイング情報を指定します。

slot-no

イーサネット インターフェイスのスロット番号を指定します。指定できる範囲は 1 ~ 255 です。

port-no

イーサネット インターフェイスのポート番号を指定します。指定できる範囲は 1 ~ 128 です。

 
コマンド デフォルト

すべてのインターフェイスのキューイング情報を表示します。

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

次に、特定のインターフェイスのキューイング情報を表示する例を示します。

switch# show queuing interface ethernet 1/10
Ethernet1/10 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 0
1 WRR 10
2 WRR 90
3 WRR 0
4 WRR 0
5 WRR 0
6 WRR 0
7 WRR 0
 
RX Queuing
qos-group 0
HW MTU: 9216 (9216 configured)
drop-type: drop, xon: 0, xoff: 0
Statistics:
Ucast pkts sent over the port : 0
Ucast bytes sent over the port : 0
Mcast pkts sent over the port : 2416
Mcast bytes sent over the port : 164288
Ucast pkts dropped : 0
Ucast bytes dropped : 0
Mcast pkts dropped : 0
Mcast bytes dropped : 0
<--Output truncated-->
switch#
 

表 i-3 に、この出力で表示される重要なフィールドの説明を示します。

 

表 i-3 show queuing interface フィールドの説明

フィールド
説明

Ethernet ...

イーサネット インターフェイス情報。

qos-group

スイッチに設定されている QoS グループの情報。

sched-type

スケジュールのタイプ。

WRR

Weighted Round Robin(WRR; 重み付けラウンドロビン)。スケジューリングのキューの重み付け。

MTU

キューの Maximum Transmit Unit(MTU)。

drop-type

キューのドロップ タイプ。drop も no-drop も可能。

Xon

このしきい値で伝送をオンにします。

Xoff

このしきい値で伝送をオフにします。

 
関連コマンド

コマンド
説明

hardware buffer-threshold

ハードウェア バッファしきい値を設定します。

hardware queue-limit

ハードウェア キュー制限を設定します。

 

show running-config copp

実行コンフィギュレーションのコントロール プレーン ポリシング(CoPP)設定情報を表示するには、 show running-config copp コマンドを使用します。

show running-config copp [ all ]

 
構文の説明

all

(任意)設定済みおよびデフォルトの情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

5.0(3)U2(2)

CoPP スタティック クラス マップ、copp-s-bfd および copp-s-ptp が導入されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、Cisco NX-OS Release 5.0(3)U2(1) を実行しているスイッチで実行コンフィギュレーションに設定されている CoPP 情報を表示する例を示します。

switch# show running-config copp
 
!Command: show running-config copp
!Time: Tue Aug 23 06:32:48 2011
 
version 5.0(3)U2(1)
class-map type control-plane match-any ClassMapA
class-map type control-plane match-any copp-icmp
match access-group name copp-system-acl-icmp
class-map type control-plane match-any copp-ntp
match access-group name copp-system-acl-ntp
class-map type control-plane match-any copp-s-arp
class-map type control-plane match-any copp-s-bpdu
class-map type control-plane match-any copp-s-dai
class-map type control-plane match-any copp-s-default
class-map type control-plane match-any copp-s-dhcpreq
class-map type control-plane match-any copp-s-dhcpresp
class-map type control-plane match-any copp-s-eigrp
match access-group name copp-system-acl-eigrp
class-map type control-plane match-any copp-s-igmp
<--Output truncated-->
switch#
 

次に、実行コンフィギュレーションの設定済み CoPP 情報およびデフォルトの CoPP 情報を表示する例を示します。

switch# show running-config copp all
 

 
関連コマンド

コマンド
説明

control-plane

コントロール プレーン コンフィギュレーション モードを開始します。

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show startup-config aclmgr

ACL のスタートアップ コンフィギュレーションを表示します。

show startup-config copp

スタートアップ コンフィギュレーション ファイルの CoPP の設定情報を表示します。

 

show running-config ipqos

システムの実行コンフィギュレーションについて、Quality of Service(QoS)関連の情報を表示するには、 show running-config ipqos コマンドを使用します。

show running-config ipqos [ all ]

 
構文の説明

all

(任意)設定済みおよびデフォルトの情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

デフォルトおよび設定済みクラス マップとポリシー マップのリストと、インターフェイスに割り当てられているポリシーを表示するために使用します。

次に、QoS 情報を表示する場合の例を示します。

switch# show running-config ipqos
 
!Command: show running-config ipqos
!Time: Mon Mar 15 08:24:12 2010
 
version 5.0(3)U1(1)
class-map type qos match-all cqos1
match cos 1
class-map type qos match-all cqos6
match cos 6
class-map type queuing cqu1
match qos-group 1
class-map type queuing cqu6
match qos-group 6
policy-map type qos pqos
class cqos1
set qos-group 1
class cqos6
set qos-group 6
policy-map type queuing pqu
class type queuing cqu1
bandwidth percent 10
class type queuing cqu6
bandwidth percent 20
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show class-map

クラス マップ情報を表示します。

show policy-map

ポリシー マップ情報を表示します。

 

show startup-config copp

スタートアップ コンフィギュレーションのコントロール プレーン ポリシング(CoPP)設定情報を表示するには、 show startup-config copp コマンドを使用します。

show startup-config copp

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U2(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、スタートアップ コンフィギュレーションの CoPP 情報を表示する例を示します。

switch# show startup-config copp
 
!Command: show startup-config copp
!Time: Tue Aug 23 07:00:41 2011
!Startup config saved at: Sat Aug 20 04:58:59 2011
 
version 5.0(3)U2(1)
class-map type control-plane match-any copp-icmp
match access-group name copp-system-acl-icmp
class-map type control-plane match-any copp-ntp
match access-group name copp-system-acl-ntp
class-map type control-plane match-any copp-s-arp
class-map type control-plane match-any copp-s-bpdu
class-map type control-plane match-any copp-s-dai
class-map type control-plane match-any copp-s-default
class-map type control-plane match-any copp-s-dhcpreq
class-map type control-plane match-any copp-s-dhcpresp
class-map type control-plane match-any copp-s-eigrp
match access-group name copp-system-acl-eigrp
class-map type control-plane match-any copp-s-igmp
match access-group name copp-system-acl-igmp
class-map type control-plane match-any copp-s-ipmcmiss
<--output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

control-plane

コントロール プレーン コンフィギュレーション モードを開始します。

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show running-config copp

実行コンフィギュレーション内の CoPP 設定情報を表示します。

 

show startup-config ipqos

スタートアップ コンフィギュレーションの Quality of Service(QoS)の設定情報を表示するには、 show startup-config ipqos コマンドを使用します。

show startup-config ipqos [ all ]

 
構文の説明

all

(任意)設定済みおよびデフォルトの情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

次に、スタートアップ コンフィギュレーション ファイルの QoS 情報を表示する例を示します。

switch# show startup-config ipqos
 
 
!Command: show startup-config ipqos
!Time: Fri Jun 4 06:10:27 2010
!Startup config saved at: Thu Jun 3 18:13:44 2010
 
version 5.0(3)U1(1)
policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo
 
 
switch#
 

 
関連コマンド

コマンド
説明

copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーション ファイルにコピーします。

show class-map

クラス マップ情報を表示します。

show policy-map

ポリシー マップ情報を表示します。

 

show wrr unicast-bandwidth

重み付けラウンドロビン(WRR)の帯域幅情報を表示するには、 show wrr unicast-bandwidth コマンドを使用します。

show wrr unicast-bandwidth

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

次に、WRR の帯域幅値を表示する例を示します。

switch# show wrr unicast-bandwidth
UCAST Bandwidth percent: 75
switch#
 

 
関連コマンド

コマンド
説明

wrr unicast-bandwidth

インターフェイスに重み付けラウンド ロビン(WRR)の帯域幅値を割り当てます。

 

show wrr-queue qos-group-map

出力キューにマッピングされた Quality of Service(QoS)値を表示するには、 show wrr-queue qos-group-map コマンドを使用します。

show wrr-queue qos-group-map

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

次に、出力キューにマッピングされた QoS グループを表示する例を示します。

switch# show wrr-queue qos-group-map
MCAST Queue ID Qos-Group Map
0 0 1
1 2 3
2 4 5
3 6 7
switch#
 

 
関連コマンド

コマンド
説明

wrr-queue qos-group-map

Quality of Service(QoS)値をマッピングして、いずれかの出力キューを選択します。

 

system jumbomtu

システムで最大伝送ユニット(MTU)の上限を定義するには、 system jumbomtu コマンドを使用します。

system jumbomtu [ value ]

 
構文の説明

value

ジャンボ MTU 値。有効な範囲は 1500 ~ 9216 です。

 
コマンド デフォルト

9216 バイト

 
コマンド モード

グローバル コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

次に、システムでの MTU の上限を定義する例を示します。

switch(config)# system jumbomtu 9216
switch(config)#
 

次に、s5010 というスイッチ プロファイルで MTU の上限を定義する例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# system jumbomtu 3000
switch(config-sync-sp)#

 

 
関連コマンド

コマンド
説明

show interface

指定したインターフェイスで送受信されるジャンボ MTU フレームを表示します。

 

system qos

システム ポリシーを設定するには、 system qos コマンドを使用します。

system qos

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

次に、キューイング ポリシーをシステムのすべてのインターフェイスに適用するようにシステム QoS を設定する例を示します。

switch(config)# system qos
switch(config-sys-qos)#
 

次に s5010 というスイッチ プロファイルのシステム QoS を設定する例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# system qos
switch(config-sync-sp-sys-qos)#

 

 
関連コマンド

コマンド
説明

service-policy

システム クラス ポリシー マップをシステムのサービス ポリシーに関連付けます。

 

untagged cos

選択したインターフェイスのサービス クラス(CoS)値を上書きするには、 untagged cos コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

untagged cos cos-value

no untagged cos cos-value

 
構文の説明

cos-value

タグなしフレームのサービス クラス(CoS)値。指定できる範囲は 0 ~ 7 です。

 
コマンド デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード
サブインターフェイス コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

 
使用上のガイドライン

CoS 値なしで受信したイーサネット フレームには、CoS 値 0 が設定されます。

次に、インターフェイスで受信するタグなしフレームに CoS 値 4 を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/2
switch(config-if)# untagged cos 4
 

次に、レイヤ 3 インターフェイスで受信するタグなしフレームに CoS 値 3 を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# untagged cos 3
switch(config-if)#
 

 
関連コマンド

コマンド
説明

match cos

選択したクラスの一致条件とする CoS 値を設定します。

no switchport

インターフェイスを、レイヤ 3 ルーテッド インターフェイスとして設定します。

show interface untagged-cos

インターフェイスのタグなし CoS 値を表示します。

 

wrr-queue qos-group-map

割り当てられた Quality of Service(QoS)グループ値をマッピングしていずれかの出力キューを選択するには、 wrr-queue qos-group-map コマンドを使用します。QoS マップをデフォルト設定に戻すには、このコマンドの no 形式を使用します。

wrr-queue qos-group-map queue-id qos1 ... qos8

no wrr-queue qos-group-map queue-id qos1 ... qos8

 
構文の説明

queue-id

出力キューの ID。範囲は 0 ~ 3 です。

qos1... qos8

キューを選択するためにマッピングする QoS グループ値。最大 8 個の QoS 値を入力します。各値はスペースで区切ります。有効な範囲は 0 ~ 7 です。

 
コマンド デフォルト

デフォルトの設定は次のとおりです。

受信キュー 0 および送信キュー 0:QoS 0 および 1

受信キュー 1 および送信キュー 1:QoS 2 および 3

受信キュー 2 および送信キュー 2:QoS 4 および 5

受信キュー 3 および送信キュー 3:QoS 6 および 7

 
コマンド モード

グローバル コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン


) このコマンドは、レイヤ 3 マルチキャスト トラフィックにのみ適用されます。


このコマンドを使用すると、各キューが異なる重み付けラウンドロビン(WRR)パラメータで設定されたさまざまなキューに、トラフィックを配信できます。

レイヤ 3 マルチキャスト トラフィックには、最大レイヤ 4 つのマルチキャスト キューを設定できます。各マルチキャスト キューには、少なくとも 1 つの Quality of Service(QoS)値を設定することを推奨します。

次に、QoS 値 0 および 1 をキュー 1 にマッピングする例を示します。

switch(config)# wrr-queue qos-group-map 1 0 1
switch(config)#
 

次に、スイッチ プロファイルのキュー 1 に QoS 値 0 および 1 をマッピングする例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# wrr-queue qos-group-map 1 0 1
switch(config-sync-sp)#
 

 
関連コマンド

コマンド
説明

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

show wrr-queue qos-group-map

重み付けラウンドロビン(WRR)キュー情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。

 

wrr unicast-bandwidth

重み付けラウンドロビン(WRR)の重みを、インターフェイスのデータ レートのパーセンテージとして出力キューに割り当てるには、 wrr unicast-bandwidth コマンドを使用します。WRR の帯域幅値の割り当てを解除するには、このコマンドの no 形式 を使用します。

wrr unicast-bandwidth percentage-value

no wrr unicast-bandwidth percentage-value

 
構文の説明

percentage-value

帯域幅のパーセンテージ。範囲は 0 ~ 100 です。

 
コマンド デフォルト

50

 
コマンド モード

グローバル コンフィギュレーション モード
インターフェイス コンフィギュレーション モード
スイッチ プロファイル コンフィギュレーション モード

 
コマンド履歴

リリース
変更箇所

5.0(3)U1(1)

このコマンドが追加されました。

5.0(3)U2(1)

このコマンドのサポートがスイッチ プロファイルに追加されました。

 
使用上のガイドライン

トラフィック輻輳時に、ユニキャストおよびマルチキャスト トラフィックに割り当てられた帯域幅を変更するには、このコマンドを使用します。

次に、特定のインターフェイスの 75% に帯域幅を設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# wrr unicast-bandwidth 75
switch(config-if)#
 

次に、スイッチ プロファイルの 75% に帯域幅を設定する例を示します。

switch# configure sync
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-sync)# switch-profile s5010
Switch-Profile started, Profile ID is 1
switch(config-sync-sp)# wrr unicast-bandwidth 75
switch(config-sync-sp)#
 

 
関連コマンド

コマンド
説明

show switch-profile

スイッチ プロファイルおよびコンフィギュレーション リビジョンに関する情報を表示します。

show wrr unicast-bandwidth

重み付けラウンドロビン(WRR)帯域幅情報を表示します。

switch-profile

スイッチ プロファイルを作成または設定します。