Cisco Nexus 3000 NX-OS QoS コンフィギュレーション ガイド リリース 5.0(3)U3(1)
QoS の設定
QoS の設定
発行日;2013/01/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

QoS の設定

この章では、Cisco Nexus 3000 シリーズ デバイスで Quality of Service(QoS)を設定する方法について説明します。 内容は次のとおりです。

Quality of Service

設定可能なCisco NX-OS Quality of Service(QoS)機能を使用して、ネットワーク トラフィックを分類し、トラフィック フローに優先順位を付けて、輻輳回避を実行できます。

デバイス上のデフォルトの QoS 設定により、 イーサネット トラフィックの Class of Service(CoS; サービス クラス)を追加するよう QoS を設定できます。 Cisco NX-OS QoS 機能は、Cisco Modular QoS CLI(MQC)を使用して設定されます。


(注)  


輻輳や衝突が発生した場合、イーサネットではパケットが廃棄されます。 失われたデータの検出および廃棄されたパケットの再送信は、上位プロトコルにより行われます。


モジュラ QoS CLI

Cisco MQC は、QoS を設定するための標準コマンド セットを提供します。

MQC を使用して、追加のトラフィック クラスを定義し、システム全体および個別のインターフェイスに対して QoS ポリシーを設定できます。 MQC で QoS ポリシーを設定するには、次の手順を実行します。

  1. トラフィック クラスを定義します。
  2. 各トラフィック クラスにポリシーおよびアクションをアソシエートします。
  3. ポリシーを論理インターフェイスまたは物理インターフェイスに結合します。同様にグローバル システム レベルで結合できます。

MQC には、トラフィックのクラスとポリシーを定義するために、2 つのコマンド タイプが用意されています。

class-map

パケット一致基準に基づいて、トラフィックのクラスを表すクラス マップを定義します。 クラス マップはポリシー マップ内で参照されます。

クラス マップは、IEEE 802.1p CoS 値などの一致基準に基づいて、着信パケットを分類します。 ユニキャスト パケットおよびマルチキャスト パケットが分類されます。

policy-map

:クラス マップ単位でクラス マップに適用するポリシーのセットを表すポリシー マップを定義します。

ポリシー マップは、帯域幅の制限やパケットのドロップなど、アソシエートされたトラフィック クラスで実行するアクション セットを定義します。

クラス マップおよびポリシー マップを作成する場合は、次の class-map および policy-map オブジェクト タイプを定義します。

network-qos

システム レベルの関連アクションに使用できる MQC オブジェクトを定義します。

qos

分類に使用できる MQC オブジェクトを定義します。

queuing

キューイングおよびスケジューリングに使用できる MQC オブジェクトを定義します。


(注)  


qos タイプは、class-map コマンドおよび policy-map コマンドのデフォルトですが、タイプを明示的に指定する必要がある service-policy では、デフォルトではありません。


ポリシーは、service-policy コマンドを使用して、インターフェイスまたは EtherChannel に追加できるほか、グローバル システム レベルで追加できます。

show class-map コマンドおよび show policy-map コマンドを使用して、MQC オブジェクトのすべてまたは個々の値を表示できます。

MQC ターゲットは、パケットのフローを表すエンティティ(イーサネット インターフェイスなど)です。 サービス ポリシーはポリシー マップを MQC ターゲットに関連付け、着信または発信パケットでポリシーを適用するかどうかを指定します。 このマッピングにより、マーキング、帯域割り当て、バッファ割り当てなど、QoS ポリシーの設定をイネーブルにします。

システム クラス

システム qos は一種の MQC ターゲットです。 service-policy を使用して、ポリシー マップをシステム qos ターゲットに関連付けます。 特定のインターフェイスでサービス ポリシー設定を上書きしない限り、システム qos ポリシーはスイッチのインターフェイス全体に適用されます。 システム qos ポリシーは、システム クラスやスイッチ全体のトラフィック クラスのほか、それらの属性を定義するために使用します。 QoS 一貫性の確保(および設定の利便性)の目的で、スイッチは、Data Center Bridging Exchange(DCBX)プロトコルを使用して、システム クラス パラメータ値を接続されたすべてのネットワーク アダプタに配布します。

サービス ポリシーがインターフェイス レベルで設定されている場合、インターフェイス レベルのポリシーは常にシステム クラス設定またはデフォルト値よりも優先されます。

Cisco Nexus 3000 シリーズ スイッチでは、システム クラスは qos-group 値によって一意に識別されます。 全体で 8 つのシステム クラスがサポートされています。 Cisco Nexus 3000 シリーズ スイッチでは、必ずスイッチに存在する 1 つのデフォルト クラスをサポートします。 最大 7 つの追加システム クラスを管理者が作成できます。

デフォルトのシステム クラス

スイッチは、次のシステム クラスを提供します。

  • ドロップ システム クラス デフォルトでは、すべてのユニキャストおよびマルチキャスト イーサネット トラフィックは、デフォルトのドロップ システム クラスに分類されます。 このクラスは qos-group 0 で識別されます。 システムの起動時にこのクラスは自動的に作成されます(クラス名は CLI で class-default です)。 このクラスは削除できません。このデフォルト クラスに関連付けられた一致基準も変更できません。

ポリシー タイプに関する情報

このスイッチは、複数のポリシー タイプをサポートしています。 クラス マップはポリシー タイプで作成します。

3 つのポリシー タイプがあります。 クラスの各タイプには、次の QoS パラメータを指定できます。

  • type network-qos:network-qos ポリシーを使用して、システム クラスを配置し、システム全体のスコープを持つそれらのクラスにパラメータを関連付けます。
    • 分類:このクラスに一致するトラフィックは次のとおりです。
      • QoS グループ:type network-qos のクラス マップはシステム クラスを示し、関連付けられた qos-group によって照合されます。
    • ポリシー:一致したトラフィックで実行されるアクションは次のとおりです。

      (注)  


      network-qos ポリシーは、システム qos ターゲットだけに結合できます。


      • MTU:システム クラスにマッピングされたトラフィックに適用する必要のある最大伝送単位(MTU)。

        (注)  


        Cisco Nexus 3000 シリーズは、すべてのポートのすべてのクラスで 1 MTU をサポートします。


      • CoS 値の設定:このシステム クラスにマッピングされたすべてのトラフィックに 802.1p 値をマーク付けする場合に使用します。
      • 輻輳制御 WRED:WRED は、輻輳が発生する前に輻輳を予測し、回避します。 WRED は、輻輳を示す、特定のしきい値を超える平均キュー長に基づいてパケットをドロップします。 出力ポリシー マップで WRED を使用して輻輳回避を設定できます。 デフォルトでは、テール ドロップが輻輳制御メカニズムです。 WRED をイネーブルにするには、network-qos ポリシー マップ モードで congestion-control random-detect コマンドを使用します。
      • ECN:ECN は WRED の拡張で、平均キュー長が特定のしきい値を超えた場合にパケットをドロップせずにマーキングします。 WRED 明示的輻輳通知機能を設定すると、ルータとエンド ホストは、このマーキングをネットワークの輻輳によってパケットの送信速度が低下していることを示す警告として使用します。 ECN をイネーブルにするには、network-qos ポリシー マップ モードで congestion-control random-detect ecn コマンドを使用します。

        (注)  


        network-qos ポリシー クラスの WRED/ECN をイネーブルにすると、システムのすべてのポートで WRED/ECN がイネーブルにされることを意味します。


  • type queuing:type queuing ポリシーを使用して、システム クラスと関連付けられたキューのスケジューリング特性を定義します。 Cisco Nexus 3000 シリーズは、出方向の type queuing をサポートします。

    (注)  


    一部の設定パラメータは、EtherChannel に適用されていると、メンバ ポートの設定に反映されません。


    • 分類:このクラスに一致するトラフィックは次のとおりです。
      • QoS グループ:type queuing のクラス マップは、システム クラスを示し、関連付けられた qos-group によって照合されます。
    • ポリシー:一致したトラフィックで実行されるアクションは次のとおりです。

      (注)  


      システム qos ターゲットまたは任意のインターフェイスに結合できます。 出力キューイング ポリシーを使用して、システム クラスに関連付けられた、スイッチの出力キューを設定します。


      • 帯域幅:保証されるスケジューリング Deficit Weighted Round Robin(DWRR)の割合(%)をシステム クラスに設定します。
      • プライオリティ:システム クラスを完全プライオリティ スケジューリング用に設定します。 指定されたキューイング ポリシーで優先するシステム クラスを 1 つだけ設定できます。
  • type qos:type qos ポリシーを使用して、フレーム内にあるレイヤ 2、レイヤ 3、レイヤ 4 の各種フィールドに基づいたトラフィックを分類し、システム クラスにマッピングします。

    (注)  


    一部の設定パラメータは、EtherChannel に適用されていると、メンバ ポートの設定に反映されません。


    • 分類:このクラスに一致するトラフィックは次のとおりです。
      • アクセス コントロール リスト(ACL):既存の ACL の基準に基づいてトラフィックを分類します。
      • サービス クラス:フレーム ヘッダーの CoS フィールドに基づいてトラフィックを照合します。
      • DSCP:IP ヘッダーの DiffServ フィールドにある DiffServ コード ポイント(DSCP)値に基づいてトラフィックを分類します。
      • IP リアルタイム プロトコル:リアルタイム アプリケーションで使用されるポート番号に基づいてトラフィックを分類します。
      • 優先順位:IP ヘッダーのタイプ オブ サービス(ToS)フィールドの優先順位値に基づいてトラフィックを分類します。
    • ポリシー:一致したトラフィックで実行されるアクションは次のとおりです。

      (注)  


      このポリシーは、システムまたは任意のインターフェイスに追加できます。 このポリシーは入力トラフィックだけに適用されます。


      • QoS グループ:このトラフィック フローがマッピングされたシステム クラスに対応する qos-group を設定します。
        • Cisco Nexus 3000 シリーズは、次のものをサポートします。
          • 8 つの qos-group
          • ユニキャスト用の 8 つのキュー
          • マルチキャスト用の 4 つのキュー
          デフォルトでは、2 つの qos-group がそれぞれ 1 つのマルチキャスト キューにマッピングされます。 qos-group 0 および 1 はマルチキャスト キューにマッピングされ、qos-group 2 および 3 が次のマルチキャスト キューにマッピングされ、以降も同じようにマッピングされます。

信頼境界

信頼境界は、次のように着信インターフェイスによって実行されます。

  • デフォルトでは、すべてのイーサネット インターフェイスは信頼できるインターフェイスです。マーキングが設定されている場合を除き、802.1p CoS および DSCP は保持されます。 CoS および DSCP のデフォルトのキュー マッピングはありません。 これらのマッピングを作成するポリシーを定義し、適用できます。 デフォルトでは、ユーザ定義のポリシーがない場合、すべてのトラフィックがデフォルト キューに割り当てられます。
  • 802.1p CoS 値でタグ付けされていないパケットは、デフォルトのドロップ システム クラスに分類されます。 タグなしパケットがトランク上で送信される場合、このパケットにはデフォルトのタグなし CoS 値 0 がタグ付けされます。
  • イーサネット インターフェイスまたはポート チャネルのデフォルトのタグなし Cos 値は上書きできます。
  • イーサネット インターフェイスまたはポート チャネル インターフェイスのデフォルトのタグなし Cos 値を上書きするには、untagged cos cos-value コマンドを使用します。
  • イーサネットまたはレイヤ 3 インターフェイスまたはポート チャネル インターフェイスのデフォルトのタグなし CoS 値を上書きするには、untagged cos cos-value コマンドを使用します。

システムがタグなし CoS 値を適用しても、QoS は、CoS 値がタグ付けされたシステムに入るパケットと同様に機能します。

入力分類ポリシー

分類は、トラフィックをクラスに区分けするのに使用します。 トラフィックは、ポート特性(CoS フィールド)またはパケット ヘッダー フィールドに基づいて分類します。パケット ヘッダー フィールドには、IP precedence、DiffServ コード ポイント(DSCP)、レイヤ 2 からレイヤ 4 までのパラメータが含まれます。 トラフィックの分類に使用する値を、一致基準と呼びます。 トラフィック クラスを定義する場合、複数の一致基準を指定することも、一部または全部の基準を照合することによってトラフィック クラスを決定することもできます。

どのクラスにも一致しないトラフィックは、class-default と呼ばれるデフォルトのトラフィック クラスに割り当てられます。

出力キューイング ポリシー

出力ポリシー マップをイーサネット インターフェイスにアソシエートし、指定されたトラフィック クラスの帯域幅を保証したり、出力キューを設定したりできます。

帯域割り当ての制限は、、インターフェイス上のすべてのトラフィックに適用されます。

イーサネット インターフェイスごとに最大 6 つのキュー(システム クラスごとに 1 つ)をサポートします。 キューには次のデフォルト設定があります。

  • 6 つのキューに加え、CPU に転送される制御トラフィックは完全プライオリティ キューを使用します。 ユーザ設定ではこのキューにはアクセスできません。
  • デフォルトのドロップ システム クラスの標準イーサネット トラフィックにキューが割り当てられます。 このキューは、帯域幅の 50% で WRR スケジューリングを使用します。

システム クラスを追加すると、キューがクラスに割り当てられます。 影響を受けたすべてのインターフェイスで帯域割り当てを再設定する必要があります。 帯域幅は、自動的にユーザ定義のシステム クラス専用にはなりません。

完全プライオリティ キューを設定できます。 このキューは、制御トラフィック キュー(データ トラフィックではなく制御トラフィックを伝送)以外の他のすべてのキューより先に処理されます。

CPU 方向のトラフィックの QoS

デバイスは、CPU でパケットがフラッディングしないように、CPU 方向のトラフィックに自動的に QoS ポリシーを適用します。 ブリッジ プロトコル データ ユニット(BPDU)フレームなどの制御トラフィックには、確実に配信できるように、より高いプライオリティが与えられます。

QoS 設定の注意事項と制限事項

最適なスイッチ パフォーマンスを維持するには、システム クラスおよびポリシーの設定時に次の注意事項に従ってください。

  • スイッチ リソース(バッファ、仮想出力キュー、および出力キューなど)は、デフォルト クラスおよびユーザ設定のシステム クラスに基づいて分割されます。 Cisco NX-OS は、設定済みシステム クラスに合わせて自動的にリソース割り当てを調整します。
  • WRED および ECN 設定はユニキャスト フローだけでサポートされます。 WRED および ECN 設定は、マルチキャスト、ブロードキャスト、未知のユニキャストなどの他のフローには影響しません。
  • WRED および ECN 設定は qos-group 1 にマッピングされているクラスではサポートされません。

EtherChannel を設定するときには、次の点に注意してください。

  • EtherChannel に設定されたサービス ポリシーはすべてのメンバー インターフェイスに適用されます。

システム クラスの設定

クラス マップの設定

class-map コマンドを使用して、クラス マップを作成または変更できます。 クラス マップは、トラフィックのクラスを表す名前付きオブジェクトです。 クラス マップでは、パケットを分類する一致基準を指定します。 以降は、クラス マップをポリシー マップで参照できるようになります。


(注)  


クラス マップ タイプのデフォルトは type qos で、その一致基準のデフォルトは match-all です。


手順
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal 

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2 switch(config)# class-map [type {network-qos | qos | queuing}] class-map name
     

    指定されたトラフィックのクラスを表す名前付きオブジェクトを作成するか、名前付きオブジェクトにアクセスします。

    クラス マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。クラス マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

    次のように 3 つのクラス マップ コンフィギュレーション モードがあります。

    • network-qos:ネットワーク全体(グローバル)モード。 CLI プロンプト:switch (config-cmap-nq)#
    • qos:分類モード。これがデフォルト モードです。 CLI プロンプト:switch (config-cmap-qos)#
    • queuing:キューイング モード。 CLI プロンプト:switch(config-cmap-que)#
     
    ステップ 3switch(config)# class-map [type qos] [match-all | match-any] class-map name
     
    (任意)

    パケットがクラス マップに定義された基準の一部またはすべてを満たす必要があることを指定します。

    • match-all:パケットが、指定したクラス マップに定義されているすべての基準を満たす場合(たとえば、定義された CoS と ACL 基準の両方が一致する場合)、トラフィックを分類します。
    • match-any:パケットが、指定したクラス マップに定義されているいずれかの基準を満たす場合(たとえば、CoS または ACL の基準のいずれかが一致する場合)、トラフィックを分類します。

    クラス マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。クラス マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

     
    ステップ 4 switch(config)# no class-map [type {network-qos | qos | queuing}] class-name
     
    (任意)

    指定されたクラス マップを削除します。

    (注)     

    システム定義のクラス マップ(class-default)は削除できません。

    クラス マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。クラス マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

     

    ACL 分類の設定

    既存のアクセス コントロール リスト(ACL)に基づいたパケットの照合により、トラフィックを分類できます。 ACL で定義された基準によってトラフィックが分類されます。 ACL キーワードの permit および deny は、照合時には無視されます。アクセス リストの一致基準に deny アクションが含まれる場合でも、そのクラスの照合では使用されます。

    手順
       コマンドまたはアクション目的
      ステップ 1 switch# configure terminal
       

      コンフィギュレーション モードを開始します。

       
      ステップ 2 switch(config)# class-map type qos class-name
       

      トラフィックのクラスを表す名前付きオブジェクトを作成します。 クラス マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。クラス マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

       
      ステップ 3 switch(config-cmap-qos)# match access-group name acl-name
       

      acl-name に基づいてパケットを照合することによって、トラフィック クラスを設定します。 ACL キーワードの permit および deny は、照合時には無視されます。

      (注)     

      1 つのクラス マップで定義できる ACL は 1 つだけです。

      match access-group が定義されたクラスには、その他の一致基準を追加できません。

       
      ステップ 4 switch(config-cmap-qos)# no match access-group name acl-name
       
      (任意)

      一致するトラフィックをトラフィック クラスから削除します。

       

      次に、既存の ACL に基づいたパケットの照合により、トラフィックを分類する例を示します。

      switch# configure terminal
      switch(config)# class-map type qos class_acl
      switch(config-cmap-qos)# match access-group name acl-01
       

      ACL のクラス マップ設定を表示するには、show class-map コマンドを使用します。

      switch# show class-map class_acl
       

      CoS 分類の設定

      IEEE 802.1Q ヘッダー内のサービス クラス(CoS)フィールドに基づいてトラフィックを分類できます。 この 3 ビットのフィールドは IEEE 802.1p で QoS トラフィック クラスをサポートするために規定されています。 CoS は Virtual Local Area Network(VLAN; バーチャル LAN)ID タグ フィールドの上位 3 ビットで符号化され、user_priority と呼ばれます。

      手順
         コマンドまたはアクション目的
        ステップ 1 switch# configure terminal
         

        コンフィギュレーション モードを開始します。

         
        ステップ 2 switch(config)# class-map type qos class-name
         

        トラフィックのクラスを表す名前付きオブジェクトを作成します。 クラス マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。クラス マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

         
        ステップ 3 switch(config-cmap-qos)# match cos cos-value
         

        パケットをこのクラスに分類する場合に照合する CoS 値を指定します。 CoS 値は、0 ~ 7 の範囲で設定できます。

         
        ステップ 4 switch(config-cmap-qos)# no match cos cos-value
         
        (任意)

        一致するトラフィックをトラフィック クラスから削除します。

         

        次の例は、定義された CoS 値に基づいてパケットを照合することにより、トラフィックを分類する方法を示しています。

        switch# configure terminal
        switch(config)# class-map type qos match-any class_cos
        switch(config-cmap-qos)# match cos 4, 5-6
        
        

        CoS 値のクラス マップ設定を表示するには、show class-map コマンドを使用します。

        switch# show class-map class_cos
        

        DSCP 分類の設定

        IP ヘッダー(IPv4 または IPv6 のいずれか)の DiffServ フィールドにある DiffServ コード ポイント(DSCP)値に基づいてトラフィックを分類できます。
        表 1 標準の DSCP 値

        DSCP 値のリスト

        af11

        AF11 dscp(001010):10 進数の 10

        af12

        AF12 dscp(001100):10 進数の 12

        af13

        AF13 dscp(001110):10 進数の 14

        af21

        AF21 dscp(010010):10 進数の 18

        af22

        AF22 dscp(010100):10 進数の 20

        af23

        AF23 dscp(010110):10 進数の 22

        af31

        AF31 dscp(011010):10 進数の 26

        af32

        AF32 dscp(011100):10 進数の 28

        af33

        AF33 dscp(011110):10 進数の 30

        af41

        AF41 dscp(100010):10 進数の 34

        af42

        AF42 dscp(100100):10 進数の 36

        af43

        AF43 dscp(100110):10 進数の 38

        cs1

        CS1(優先順位 1)dscp(001000):10 進数の 8

        cs2

        CS2(優先順位 2)dscp(010000):10 進数の 16

        cs3

        CS3(優先順位 3)dscp(011000):10 進数の 24

        cs4

        CS4(優先順位 4)dscp(100000):10 進数の 32

        cs5

        CS5(優先順位 5)dscp(101000):10 進数の 40

        cs6

        CS6(優先順位 6)dscp(110000):10 進数の 48

        cs7

        CS7(優先順位 7)dscp(111000):10 進数の 56

        default

        デフォルト dscp(000000):10 進数の 0

        ef

        EF dscp(101110):10 進数の 46

        手順
           コマンドまたはアクション目的
          ステップ 1switch# configure terminal 

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2 switch(config)# class-map type qos class-name
           

          トラフィックのクラスを表す名前付きオブジェクトを作成します。 クラス マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。クラス マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

           
          ステップ 3 switch(config-cmap-qos)# match dscp dscp-list
           

          dscp-list 変数の値に基づいて、パケットの照合によってトラフィック クラスを設定します。 DSCP 値の一覧については、標準の DSCP 値の表を参照してください。

           
          ステップ 4 switch(config-cmap-qos)# no match dscp dscp-list
           
          (任意)

          一致するトラフィックをトラフィック クラスから削除します。 DSCP 値の一覧については、標準の DSCP 値の表を参照してください。

           

          次の例は、IP ヘッダーの DiffServ フィールドの DSCP 値に基づいてパケットを照合することにより、トラフィックを分類する方法を示しています。

          switch# configure terminal
          switch(config)# class-map type qos match-any class_dscp
          switch(config-cmap-qos)# match  dscp af21, af32

          DSCP のクラス マップ設定を表示するには、show class-map コマンドを使用します。

          switch# show class-map class_dscp

          IP RTP 分類の設定

          IP Real-time Transport Protocol(RTP)は、オーディオやビデオなどのデータを送信するリアルタイム アプリケーション用のトランスポート プロトコルで、Request For Comments(RFC)3550 で規定されています。 RTP では一般的な TCP ポートや UDP ポートは使用されませんが、通常はポート 16384 ~ 32767 を使用するように RTP を設定します。 偶数ポートを UDP 通信に使用し、次の上位の奇数ポートを RTP Control Protocol(RTCP)通信に使用します。

          UDP ポート範囲に基づいて分類できます。UDP ポート範囲は、RTP を使用するアプリケーションを対象とする可能性があります。

          手順
             コマンドまたはアクション目的
            ステップ 1 switch# configure terminal
             

            コンフィギュレーション モードを開始します。

             
            ステップ 2 switch(config)# class-map type qos class-name
             

            トラフィックのクラスを表す名前付きオブジェクトを作成します。 クラス マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。クラス マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

             
            ステップ 3 switch(config-cmap-qos)# match ip rtp port-number
             

            UDP ポート番号の下限と上限に基づいてパケットを照合することによって、トラフィック クラスを設定します。UDP ポート番号の範囲は、RTP を使用するアプリケーションを対象とする可能性があります。 値の範囲は 2000 ~ 65535 です。

             
            ステップ 4 switch(config-cmap-qos)# no match ip rtp port-number
             
            (任意)

            一致するトラフィックをトラフィック クラスから削除します。

             

            次の例は、RTP アプリケーションで一般に使用される UDP ポート範囲に基づいてパケットを照合することにより、トラフィックを分類する方法を示しています。

            switch# configure terminal
            switch(config)# class-map type qos match-any class_rtp
            switch(config-cmap-qos)# match  ip rtp 2000-2100, 4000-4100

            RTP のクラス マップ設定を表示するには、show class-map コマンドを使用します。

            switch# show class-map class_rtp

            Precedence 分類の設定

            IP ヘッダー(IPv4 または IPv6 のいずれか)のサービス タイプ(ToS)バイト フィールドの優先順位値に基づいてトラフィックを分類できます。 次の表に、優先順位値を示します。

            表 2 優先順位値

            優先順位値の一覧

            <0-7>

            IP precedence 値

            critical

            クリティカル precedence(5)

            flash

            フラッシュ precedence(3)

            flash-override

            フラッシュ上書き precedence(4)

            immediate

            即時 precedence(2)

            internet

            インターネットワーク コントロール precedence(6)

            network

            ネットワーク コントロール precedence(7)

            priority

            優先 precedence(1)

            routine

            ルーチン precedence(0)

            手順
               コマンドまたはアクション目的
              ステップ 1switch# configure terminal 

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2 switch(config)# class-map type qos match-any class-name  

              トラフィックのクラスを表す名前付きオブジェクトを作成します。 クラス マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。クラス マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

               
              ステップ 3 switch(config-cmap-qos)#match precedence precedence-values  

              優先順位の値に基づいたパケットの照合により、トラフィック クラスを設定します。 優先順位値の一覧については、優先順位値の表を参照してください。

               
              ステップ 4switch((config-cmap-qos)# no match precedence precedence-values   (任意)

              一致するトラフィックをトラフィック クラスから削除します。 優先順位値の一覧については、優先順位値の表を参照してください。

               

              次の例は、IP ヘッダーの ToS バイトの優先順位値に基づいてパケットを照合することにより、トラフィックを分類する方法を示しています。

              switch# configure terminal
              switch(config)# class-map type qos match-any class_precedence
              switch(config-cmap-qos)# match precedence 1-2, critical

              IP precedence 値のクラス マップ設定を表示するには、show class-map コマンドを使用します。

              switch# show class-map class_precedence

              ポリシーマップの作成

              policy-map コマンドを使用して、トラフィック クラスのセットに適用されるポリシーのセットを表す名前付きオブジェクトを作成します。

              スイッチのデフォルトのシステム クラスは 1 つで、ベスト エフォート型サービス用のドロップ クラス(class-default)です。 イーサネット トラフィックには最大 4 つの追加システム クラスを定義できます。

              次の事前定義ポリシー マップがデフォルトのサービス ポリシーとして使用されます。

              • network-qos:default-nq-policy
              • 入力 qos:default-in-policy
              • 出力キューイング:default-out-policy

              ポリシー マップを作成して、任意のユーザ定義のクラスにポリシーを指定する必要があります。 このポリシー マップで、各クラスに QoS パラメータを設定できます。 同じポリシー マップを使用して、デフォルト クラスの設定を変更できます。

              スイッチは、接続されたネットワーク アダプタにすべてのポリシー マップ設定値を配布します。

              はじめる前に

              ポリシー マップを作成する前に、新しいシステム クラスごとにクラス マップを定義します。

              手順
                 コマンドまたはアクション目的
                ステップ 1 switch# configure terminal
                 

                コンフィギュレーション モードに入ります。

                 
                ステップ 2 switch(config)# policy-map [type {network-qos | qos | queuing}] policy-name
                 

                トラフィック クラスのセットに適用されるポリシーのセットを表す名前付きオブジェクトを作成します。 ポリシー マップ名は、最大 40 文字の英字、ハイフン、または下線文字を使用でき、大文字と小文字が区別されます。

                次のように 3 つのポリシー マップ コンフィギュレーション モードがあります。

                • network-qos:ネットワーク全体(グローバル)モード。 CLI プロンプト:switch(config-pmap-nq)#
                • qos:分類モード。これがデフォルト モードです。 CLI プロンプト:switch(config-pmap-qos)#
                • queuing:キューイング モード。 CLI プロンプト:switch(config-pmap-que)#
                 
                ステップ 3 switch(config)# no policy-map [type {network-qos | qos | queuing}] policy-name
                 
                (任意)

                指定されたポリシー マップを削除します。

                 
                ステップ 4 switch(config-pmap)# class [type {network-qos | qos | queuing}] class-name
                 

                クラス マップをポリシー マップにアソシエートし、指定されたシステム クラスのコンフィギュレーション モードを開始します。 次のように 3 つのクラス マップ コンフィギュレーション モードがあります。

                • network-qos:ネットワーク全体(グローバル)モード。 CLI プロンプト:switch(config-pmap-c-nq)#
                • qos:分類モード。これがデフォルト モードです。 CLI プロンプト:switch(config-pmap-c-qos)#
                • queuing:キューイング モード。 CLI プロンプト:switch(config-pmap-c-que)#
                (注)     

                アソシエートされるクラス マップには、ポリシー マップ タイプと同じタイプが必要です。

                 
                ステップ 5 switch(config-pmap)# no class [type {network-qos | qos | queuing}] class-name
                 
                (任意)

                クラス マップの関連付けを削除します。

                 

                type qos ポリシーの設定

                一意の qos グループ値で識別される特定のシステム クラスのトラフィックを分類するには、type qos ポリシーを使用します。 type qos ポリシーは、入力トラフィックに関してのみ、システムまたは個々のインターフェイスに追加できます。

                入力トラフィックには最大 5 つの qos グループを設定できます。

                手順
                   コマンドまたはアクション目的
                  ステップ 1switch# configure terminal 

                  グローバル コンフィギュレーション モードを開始します。

                   
                  ステップ 2switch(config)# policy-map type qos policy-name  

                  トラフィック クラスのセットに適用されるポリシーのセットを表す名前付きオブジェクトを作成します。 ポリシー マップ名は、最大 40 文字の英字、ハイフン、または下線文字を使用でき、大文字と小文字が区別されます。

                   
                  ステップ 3switch(config-pmap-qos)# class type qos class-name  

                  クラス マップをポリシー マップにアソシエートし、指定されたシステム クラスのコンフィギュレーション モードを開始します。

                  (注)     

                  アソシエートされるクラス マップには、ポリシー マップ タイプと同じタイプが必要です。

                   
                  ステップ 4switch(config-pmap-c-qos)# set qos-group qos-group-value  

                  トラフィックをこのクラス マップに分類する場合に照合する 1 つまたは複数の qos-group 値を設定します。 次のリストに、qos-group-value の範囲を示します。 デフォルト値はありません。

                  (注)     

                  スイッチでサポートできるのは、この範囲内の最大 5 つの qos-group だけです。

                   
                  ステップ 5switch(config-pmap-c-qos)# no set qos-group qos-group-value   (任意)

                  このクラスから qos-group 値を削除します。

                   

                  次の例は、type qos ポリシー マップを定義する方法を示しています。

                  switch# configure terminal
                  switch(config)# policy-map type qos policy-s1
                  switch(config-pmap-qos)# class type qos class-s1
                  switch(config-pmap-c-qos)# set qos-group 2

                  type network-qos ポリシーの設定

                  type network-qos ポリシーは、システム qos の結合時だけで設定でき、 特定のクラス用にスイッチ全体に適用されます。

                  手順
                     コマンドまたはアクション目的
                    ステップ 1 switch# configure terminal
                     

                    コンフィギュレーション モードを開始します。

                     
                    ステップ 2 switch(config)# policy-map type network-qos policy-name
                     

                    トラフィック クラスのセットに適用されるポリシーのセットを表す名前付きオブジェクトを作成します。 ポリシー マップ名は、最大 40 文字の英字、ハイフン、または下線文字を使用でき、大文字と小文字が区別されます。

                     
                    ステップ 3 switch(config-pmap-nq)# class type network-qos class-name
                     

                    クラス マップをポリシー マップにアソシエートし、指定されたシステム クラスのコンフィギュレーション モードを開始します。

                    (注)     

                    アソシエートされるクラス マップには、ポリシー マップ タイプと同じタイプが必要です。

                     
                    ステップ 4 switch(config-pmap-c-nq)# mtu mtu-value
                     

                    MTU 値をバイト単位で指定します。

                    (注)     

                    設定する mtu-value は、system jumbomtu コマンドで設定した値より小さくする必要があります。

                     
                    ステップ 5 switch(config-pmap-c-nq)# no mtu
                     
                    (任意)

                    このクラスの MTU 値をリセットします。

                     
                    ステップ 6 switch(config-pmap-c-nq)# congestion-control random-detect
                     
                    (任意)

                    出力ポリシー マップで WRED を使用して輻輳回避を設定します。 デフォルトでは、テール ドロップが輻輳制御メカニズムです。

                     
                    ステップ 7 switch(config-pmap-c-nq)# congestion-control random-detect ecn
                     
                    (任意)

                    キューの平均の長さが、指定されたしきい値を超えると、パケットをドロップせずにマーキングします。 ルータとエンド ホストは、このマーキングをネットワークの輻輳によってパケットの送信速度が低下していることを示す警告として使用します。

                     
                    ステップ 8 switch(config-pmap-c-nq)# set cos cos-value
                     

                    このインターフェイスでパケットのマーキングに使用する 802.1Q CoS 値を指定します。 値の範囲は 0 ~ 7 です。

                     
                    ステップ 9 switch(config-pmap-c-nq)# no set cos cos-value
                     
                    (任意)

                    このクラスのマーキング動作をディセーブルにします。

                     

                    次の例は、type network-qos ポリシー マップを定義する方法を示しています。

                    switch# configure terminal
                    switch(config)# policy-map type network-qos policy-que1
                    switch(config-pmap-nq)# class type network-qos class-que1
                    switch(config-pmap-c-nq)# mtu 5000
                    switch(config-pmap-c-nq)# set cos 4

                    type queuing ポリシーの設定

                    type queuing ポリシーを使用して、特定のシステム クラスのトラフィックをスケジューリングおよびバッファリングします。 type queuing policy は qos-group で識別され、入力または出力トラフィック用にシステムまたは個々のインターフェイスに追加できます。

                    手順
                       コマンドまたはアクション目的
                      ステップ 1switch# configure terminal 

                      グローバル コンフィギュレーション モードを開始します。

                       
                      ステップ 2 switch(config)# policy-map type queuing policy-name
                       

                      トラフィック クラスのセットに適用されるポリシーのセットを表す名前付きオブジェクトを作成します。 ポリシー マップ名は、最大 40 文字の英字、ハイフン、または下線文字を使用でき、大文字と小文字が区別されます。

                       
                      ステップ 3 switch(config-pmap-que)# class type queuing class-name
                       

                      クラス マップをポリシー マップにアソシエートし、指定されたシステム クラスのコンフィギュレーション モードを開始します。

                       
                      ステップ 4 switch(config-pmap-c-que)# bandwidth percent percentage
                       

                      このクラスに割り当てられたインターフェイスの保証帯域幅の割合を指定します。 デフォルトでは、クラスの帯域幅は指定されていません。

                      (注)     

                      帯域幅をクラスに正常に割り当てるには、まず class-default および class-fcoe で帯域幅のデフォルト設定を下げる必要があります。

                       
                      ステップ 5 switch(config-pmap-c-que)# no bandwidth percent percentage
                       
                      (任意)

                      帯域幅の指定をこのクラスから削除します。

                       
                      ステップ 6 switch(config-pmap-c-que)# priority
                       

                      このクラスの該当するトラフィックが完全プライオリティ キューにマッピングされるよう指定します。

                      (注)     

                      完全プライオリティを設定できるクラスは、各ポリシー マップで 1 つだけです。

                       
                      ステップ 7 switch(config-pmap-c-que)# no priority
                       
                      (任意)

                      完全プライオリティ キューイングをこのクラスのトラフィックから削除します。

                       

                      次の例は、type queuing ポリシー マップを定義する方法を示しています。

                      switch# configure terminal
                      switch(config)# policy-map type queuing policy-queue1
                      switch(config-pmap-que)# class type queuing class-queue1
                      switch(config-pmap-c-que)# bandwidth 20

                      マーキングについて

                      マーキングは、着信および発信パケットの Quality of Service(QoS)フィールドを変更するために使用する方式です。

                      マーキングのコマンドは、ポリシー マップ内で参照されるトラフィック クラスで使用できます。 設定できるマーキング機能を次に示します。

                      • DSCP
                      • IP precedence
                      • CoS

                      CoS マーキングの設定

                      CoS フィールドの値は、IEEE 802.1Q ヘッダーの VLAN ID タグ フィールドの上位 3 ビットに記録されます。

                      手順
                         コマンドまたはアクション目的
                        ステップ 1switch# configure terminal 

                        グローバル コンフィギュレーション モードを開始します。

                         
                        ステップ 2 switch(config) # policy-map [type network-qos] policy-map name
                         

                        policy-map-name という名前のポリシー マップを作成するか、そのポリシー マップにアクセスし、ポリシー マップ モードを開始します。

                        ポリシー マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。ポリシー マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

                         
                        ステップ 3 switch(config-pmap-nq) # class [type network-qos] {class-map name |class-default}
                         

                        class-map-name への参照を作成し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

                        ポリシー マップ内のクラスと現在一致していないトラフィックをすべて選択するには、class-default キーワードを使用します。

                         
                        ステップ 4 switch(config-pmap-c-nq) # set cos cos-value
                         

                        CoS 値を cos-value に指定します。

                        cos-value 値は、0 ~ 7 の範囲で指定します。

                        (注)     

                        このコマンドは、出力ポリシーに対してのみサポートされます。

                         

                        DSCP マーキングの設定

                        IP ヘッダーの DiffServ フィールドの上位 6 ビットで、DSCP 値を指定の値に設定できます。 次の表に示す標準の DSCP 値のほか、0 ~ 60 の数値も入力できます。


                        (注)  


                        DSCP と IP precedence のいずれかの値は設定できますが、IP パケットの同じフィールドを変更するため、両方の値は設定できません。


                        表 3 標準の DSCP 値

                        DSCP 値のリスト

                        af11

                        AF11 dscp(001010):10 進数の 10

                        af12

                        AF12 dscp(001100):10 進数の 12

                        af13

                        AF13 dscp(001110):10 進数の 14

                        af21

                        AF21 dscp(010010):10 進数の 18

                        af22

                        AF22 dscp(010100):10 進数の 20

                        af23

                        AF23 dscp(010110):10 進数の 22

                        af31

                        AF31 dscp(011010):10 進数の 26

                        af32

                        AF40 dscp(011100):10 進数の 28

                        af33

                        AF33 dscp(011110):10 進数の 30

                        af41

                        AF41 dscp(100010):10 進数の 34

                        af42

                        AF42 dscp(100100):10 進数の 36

                        af43

                        AF43 dscp(100110):10 進数の 38

                        cs1

                        CS1(優先順位 1)dscp(001000):10 進数の 8

                        cs2

                        CS2(優先順位 2)dscp(010000):10 進数の 16

                        cs3

                        CS3(優先順位 3)dscp(011000):10 進数の 24

                        cs4

                        CS4(優先順位 4)dscp(100000):10 進数の 32

                        cs5

                        CS5(優先順位 5)dscp(101000):10 進数の 40

                        cs6

                        CS6(優先順位 6)dscp(110000):10 進数の 48

                        cs7

                        CS7(優先順位 7)dscp(111000):10 進数の 56

                        default

                        デフォルト dscp(000000):10 進数の 0

                        ef

                        EF dscp(101110):10 進数の 46

                        手順
                           コマンドまたはアクション目的
                          ステップ 1config t
                           

                          コンフィギュレーション モードに入ります。

                           
                          ステップ 2 policy-map type qos qos-policy-map-name
                           

                          policy-map-name という名前のポリシー マップを作成するか、そのポリシー マップにアクセスし、ポリシー マップ モードを開始します。 ポリシー マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。ポリシー マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

                           
                          ステップ 3 class [type qos] {class-map-name | class-default}
                           

                          class-map-name への参照を作成し、ポリシー マップ クラス コンフィギュレーション モードを開始します。 ポリシー マップ内のクラスと現在一致していないトラフィックをすべて選択するには、class-default キーワードを使用します。

                           
                          ステップ 4 set dscp dscp-value
                           

                          DSCP 値を dscp-value に設定します。 標準の DSCP 値の表を参照してください。

                           

                          次に、ポリシー マップ設定の表示方法例を示します。

                          switch# show policy-map policy1
                          
                          

                          IP precedence マーキングの設定

                          IP precedence のフィールドの値を、IP ヘッダーの IPv4 サービス タイプ(ToS)フィールドまたは IPv6 の同等の [Traffic Class] フィールドの 0 ~ 2 ビットに設定できます。 次の表に、優先順位値を示します。


                          (注)  


                          IP precedence と DSCP のいずれかの値は設定できますが、IP パケットの同じフィールドを変更するため、両方の値は設定できません。


                          表 4 優先順位値

                          優先順位値の一覧

                          <0-7>

                          IP precedence 値

                          critical

                          クリティカル precedence(5)

                          flash

                          フラッシュ precedence(3)

                          flash-override

                          フラッシュ上書き precedence(4)

                          immediate

                          即時 precedence(2)

                          internet

                          インターネットワーク コントロール precedence(6)

                          network

                          ネットワーク コントロール precedence(7)

                          priority

                          優先 precedence(1)

                          routine

                          ルーチン precedence(0)

                          手順
                             コマンドまたはアクション目的
                            ステップ 1config t
                             

                            コンフィギュレーション モードに入ります。

                             
                            ステップ 2 policy-map [type qos] qos-policy-map-name
                             

                            policy-map-name という名前のポリシー マップを作成するか、そのポリシー マップにアクセスし、ポリシー マップ モードを開始します。 ポリシー マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。ポリシー マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

                             
                            ステップ 3 class [type qos] {class-map-name | class-default}
                             

                            class-map-name への参照を作成し、ポリシー マップ クラス コンフィギュレーション モードを開始します。 ポリシー マップ内のクラスと現在一致していないトラフィックをすべて選択するには、class-default キーワードを使用します。

                             
                            ステップ 4 set precedence precedence-value
                             

                            IP precedence 値を precedence-value に設定します。 優先順位値の表に示す値のいずれか 1 つを入力できます。

                             
                            switch(config)# policy-map type qos my_policy
                            switch(config-pmap-qos)# class type qos my_class
                            switch(config-pmap-c-qos)# set precedence 5
                            switch(config-pmap-c-qos)#
                            

                            レイヤ 3 ルーティングの QoS 設定

                            レイヤ 3 トポロジの必須の CoS マーキング設定

                            レイヤ 3 トポロジでは、一意の cos 値でネットワーク QoS ポリシーに各 qos-group を設定する必要があります。

                            手順
                               コマンドまたはアクション目的
                              ステップ 1switch# show policy-map system 

                              設定済みの policy-maps および CoS 値を表示します。

                              レイヤ 3 トポロジでは、各 qos-group に一意の CoS 値が必要です。 show policy-map system コマンドを使用して、使用されている CoS 値と、qos-group には使用できない CoS 値を表示します。

                               
                              ステップ 2switch# configure terminal 

                              グローバル コンフィギュレーション モードを開始します。

                               
                              ステップ 3switch(config) # policy-map [type network-qos] policy-map name  

                              policy-map-name という名前のポリシー マップを作成するか、そのポリシー マップにアクセスし、ポリシー マップ モードを開始します。

                              ポリシー マップ名には、アルファベット、ハイフン、またはアンダースコア文字を含めることができます。ポリシー マップ名は大文字と小文字が区別され、最大 40 文字まで設定できます。

                               
                              ステップ 4switch(config-pmap-nq) # class [type network-qos] {class-map name |class-default}  

                              class-map-name への参照を作成し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

                              ポリシー マップ内のクラスと現在一致していないトラフィックをすべて選択するには、class-default キーワードを使用します。

                               
                              ステップ 5switch(config-pmap-nq-c) # set cos cos-value  

                              CoS 値を指定します。

                              値の範囲は 0 ~ 7 です。

                              (注)     

                              このコマンドは出力ポリシーだけで使用できます。

                              レイヤ 3 トポロジでは、各 qos-group に固有の cos 設定が必要です。

                               

                              次に、レイヤ 3 トポロジで、CoS 値を 4 に設定する例を示します。

                              switch# show policy-map system
                                Type network-qos policy-maps
                                ===============================
                               
                                policy-map type network-qos pn-01
                                  class type network-qos cn-01      match qos-group 1
                                    mtu 8500
                                    pause no-drop 
                                    set cos 2
                                  class type network-qos cn-02      match qos-group 2
                                    set cos 4
                                    mtu 9216
                                  class type network-qos cn-03      match qos-group 3 
                                    mtu 8000
                                    set cos 6
                                  class type network-qos cn-04      match qos-group 4 
                                    mtu 8750
                                    set cos 7
                                  class type network-qos cn-ip-multicast      match qos-group 5
                                    set cos 5
                                    mtu 7500
                                  class type network-qos class-default      match qos-group 0 
                                    mtu 1500
                                    multicast-optimize
                                    set cos 1
                              ...
                              switch# configure terminal 
                              switch(config)# policy-map type network-qos pn-01 
                              switch(config-pmap-nq)# class type network-qos cn-05 
                              switch(config-pmap-c-nq)# set cos 3

                              レイヤ 3 マルチキャスト キューイングの設定

                              出力キューに CoS 値をマッピングできます。 レイヤ 3 マルチキャスト トラフィック用に最大 4 つのマルチキャスト キューを設定できます。

                              この手順を使用すると、各キューが異なる重み付けラウンドロビン(WRR)パラメータで設定されたさまざまなキューに、トラフィックを配信できます。

                              手順
                                 コマンドまたはアクション目的
                                ステップ 1 switch# configure terminal
                                 

                                コンフィギュレーション モードに入ります。

                                 
                                ステップ 2 switch(config)# wrr-queue qos-group-map queue-id group1 ...group8
                                 

                                割り当てられた CoS 値を出力キューにマッピングします。

                                出力キューの範囲は 1~4 です。4 は緊急キューとして設定できます。

                                最大 8 つの CoS 値を入力できます。 各値はスペースで区切ります。 有効な範囲は 0 ~ 7 です。

                                デフォルトの設定は次のとおりです。
                                • 受信キュー 0 および送信キュー 0:CoS 0 および 1。
                                • 受信キュー 1 および送信キュー 1:CoS 2 および 3。
                                • 受信キュー 2 および送信キュー 2:CoS 4 および 5。
                                • 受信キュー 3 および送信キュー 3:CoS 6 および 7。
                                 

                                次に、レイヤ 3 インターフェイスを設定する例を示します。

                                switch# configure terminal
                                switch(config)# wrr-queue qos-group-map 1 5
                                switch(config)#
                                

                                レイヤ 3 インターフェイスのサービス ポリシーの設定

                                レイヤ 3 インターフェイスのサービス ポリシーを設定できます。

                                手順
                                   コマンドまたはアクション目的
                                  ステップ 1 switch# configure terminal
                                   

                                  コンフィギュレーション モードに入ります。

                                   
                                  ステップ 2 switch(config)# interface ethernet slot/port
                                   

                                  指定されたインターフェイスのコンフィギュレーション モードを開始します。

                                   
                                  ステップ 3 switch(config-if)# no switchport
                                   

                                  レイヤ 3 インターフェイスを選択します。

                                   
                                  ステップ 4 switch(config-if)# service-policy [type {qos | queuing output}policy-name
                                   

                                  ポリシー マップをレイヤ 3 インターフェイスのサービス ポリシーとして使用するように指定します。 2 つのポリシー マップ コンフィギュレーション モードがあります。

                                  • qos:分類モード。これがデフォルト モードです。
                                  • queuing:キューイング モード。
                                  (注)     

                                  output キーワードは、そのポリシー マップがインターフェイスの送信トラフィックに適用されることを示します。 queuing ポリシーには output のみ適用できます。

                                   

                                  次に、キューイング ポリシー マップをレイヤ 3 インターフェイスに関連付ける例を示します。

                                  switch# configure terminal
                                  switch(config)# interface ethernet 1/5
                                  switch(config-if)# no switchport
                                  switch(config-if)# service-policy type queuing output my_output_q_policy
                                  switch(config-if)#

                                  ユニキャストおよびマルチキャスト トラフィックに割り当てられた帯域幅の変更

                                  重み付けラウンドロビン(WRR)の重み付けをインターフェイス データ レートの割合(%)として出力キューに割り当てることにより、ユニキャストおよびマルチキャスト トラフィックに割り当てられた帯域幅を変更できます。

                                  手順
                                     コマンドまたはアクション目的
                                    ステップ 1 switch# configure terminal
                                     

                                    コンフィギュレーション モードに入ります。

                                     
                                    ステップ 2 switch(config)# interface ethernet slot/port
                                     

                                    指定されたインターフェイスのコンフィギュレーション モードを開始します。

                                     
                                    ステップ 3 switch(config-if)# wrr unicast-bandwidth percentage-value
                                     

                                    ユニキャストおよびマルチキャスト トラフィックに割り当てられたトラフィック輻輳時の帯域幅を変更します。 帯域幅のパーセント値の範囲は 0 ~ 100% です。

                                     

                                    次に、キューイング ポリシー マップをレイヤ 3 インターフェイスに関連付ける例を示します。

                                    switch# configure terminal
                                    switch(config)# interface ethernet 1/5
                                    switch(config-if)# wrr unicast-bandwidth 75
                                    switch(config-if)#
                                    

                                    システム サービス ポリシーの追加

                                    service-policy コマンドは、システムのサービス ポリシーとしてシステム クラス ポリシー マップを指定します。

                                    手順
                                       コマンドまたはアクション目的
                                      ステップ 1switch# configure terminal 

                                      グローバル コンフィギュレーション モードを開始します。

                                       
                                      ステップ 2 switch(config)# system qos
                                       

                                      システム クラス コンフィギュレーション モードを開始します。

                                       
                                      ステップ 3 switch(config-sys-qos)# service-policy type {network-qos [input | output] | qos input |queuing output} policy-name
                                       

                                      ポリシー マップをシステムのサービス ポリシーとして使用するよう指定します。 3 つのポリシー マップ コンフィギュレーション モードがあります。

                                      • network-qos:ネットワーク全体(system qos)モード。
                                      • qos:分類モード(システム qos の input またはインターフェイスの input のみ)。
                                      • queuing:キューイング モード(システム qos およびインターフェイスの output)。
                                      (注)     

                                      デフォルトのポリシー マップ コンフィギュレーション モードはありません。type を指定してください。 input キーワードは、そのポリシー マップがインターフェイスの受信トラフィックに適用されることを示します。 output キーワードは、そのポリシー マップがインターフェイスの送信トラフィックに適用されることを示します。 qos ポリシーには input だけを、queuing ポリシーには output だけを適用できます。

                                       

                                      次の例は、no-drop イーサネット ポリシー マップをシステム クラスとして設定する方法を示しています。

                                      デフォルト システム サービス ポリシーの復元

                                      新しいポリシーを作成して、それをシステム QoS コンフィギュレーションに追加した場合、コマンドの no フォームを入力して、デフォルト ポリシーを再適用します。

                                      手順
                                         コマンドまたはアクション目的
                                        ステップ 1switch# configure terminal 

                                        グローバル コンフィギュレーション モードを開始します。

                                         
                                        ステップ 2 switch(config)# system qos
                                         

                                        システム クラス コンフィギュレーション モードを開始します。

                                         
                                        ステップ 3 switch(config-sys-qos)# no service-policy type qos input policy-map name
                                         

                                        分類モードのポリシー マップをリセットします。 このポリシー マップ設定はシステム qos 入力またはインターフェイス入力のみに使用します。

                                         
                                        ステップ 4 switch(config-sys-qos)# no service-policy type network-qos policy-map name
                                         

                                        ネットワーク全体のポリシー マップをリセットします。

                                         
                                        ステップ 5 switch(config-sys-qos)# no service-policy type queuing output policy-map name
                                         

                                        出力キューイング モードのポリシー マップをリセットします。

                                         

                                        次の例は、システム QoS 設定をリセットする方法を示しています。

                                        switch# configure terminal
                                        switch(config)# system qos
                                        switch(config-sys-qos)# no service-policy type qos input my-in-policy
                                        switch(config-sys-qos)# no service-policy type network-qos my-nq-policy
                                        switch(config-sys-qos)# no service-policy type queuing output my-out-policy
                                        

                                        次に、デフォルト サービス ポリシーの例を示します。

                                        ジャンボ MTU のイネーブル化

                                        スイッチ全体のジャンボ MTU は、デフォルトのイーサネット システム クラス(class-default)のポリシー マップで MTU を最大サイズ(9216 バイト)に設定することによって、イネーブルにできます。


                                        (注)  


                                        Cisco Nexus 3000 シリーズは、すべてのポートのすべてのクラスで 1 MTU をサポートします。


                                        次の例は、ジャンボ MTU をサポートするようにデフォルトのイーサネット システム クラスを設定する方法を示しています。

                                        switch(config)# policy-map type network-qos jumbo
                                        switch(config-pmap-nq)# class type network-qos class-default
                                        switch(config-pmap-c-nq)# mtu 9216
                                        switch(config-pmap-c-nq)# exit
                                        switch(config-pmap-nq)# exit
                                        switch(config)# system qos
                                        switch(config-sys-qos)# service-policy type network-qos jumbo

                                        (注)  


                                        system jumbomtu コマンドは、スイッチの最大 MTU サイズを定義します。 ただし、ジャンボ MTU は MTU が設定されたシステム クラスだけにサポートされます。


                                        ジャンボ MTU の確認

                                        Cisco Nexus 5000 シリーズ デバイスでは、トラフィックは 8 つの QoS グループの 1 つに分類され、MTU は QoS グループ レベルで設定されます。 Cisco Nexus 5000 シリーズ デバイスでは、QoS グループごとに異なる MTU 値がサポートされているため、インターフェイスごとに 1 つの値として MTU を表すことはできません。 デフォルトでは、すべてのイーサネット トラフィックは、QoS グループ 0 にあります。 そのため、イーサネット トラフィックに対するジャンボ MTU を確認するには、show queuing interface ethernet slot/chassis_number コマンドを使用し、QoS グループ 0 のハードウェア MTU フィールドが 9216 であることを確認します。 show interface コマンドは、1500 という MTU の値をいつでも表示して、これは予想値です。

                                        次に、Ethernet 1/19 のジャンボ MTU 情報を表示する例を示します。
                                        switch# sh queuing int e1/19
                                        Ethernet1/19 queuing information:
                                          TX Queuing
                                            qos-group  sched-type  oper-bandwidth
                                                0       WRR             50
                                                1       WRR             50
                                        
                                          RX Queuing
                                            qos-group 0
                                            q-size: 243200, HW MTU: 9280 (9216 configured)
                                            drop-type: drop, xon: 0, xoff: 1520
                                            Statistics:
                                                Pkts received over the port             : 2119963420
                                                Ucast pkts sent to the cross-bar        : 2115648336
                                                Mcast pkts sent to the cross-bar        : 4315084
                                                Ucast pkts received from the cross-bar  : 2592447431
                                                Pkts sent to the port                   : 2672878113
                                                Pkts discarded on ingress               : 0
                                                Per-priority-pause status               : Rx (Inactive), Tx (Inactive)
                                        
                                            qos-group 1
                                            q-size: 76800, HW MTU: 2240 (2158 configured)
                                            drop-type: no-drop, xon: 128, xoff: 240
                                            Statistics:
                                                Pkts received over the port             : 0
                                                Ucast pkts sent to the cross-bar        : 0
                                                Mcast pkts sent to the cross-bar        : 0
                                                Ucast pkts received from the cross-bar  : 0
                                                Pkts sent to the port                   : 0
                                                Pkts discarded on ingress               : 0
                                                Per-priority-pause status               : Rx (Inactive), Tx (Inactive)
                                        
                                          Total Multicast crossbar statistics:
                                            Mcast pkts received from the cross-bar      : 80430744

                                        インターフェイスでの QoS の設定

                                        タグなし CoS の設定

                                        802.1p CoS 値でタグ付けされていない着信パケットは、デフォルトのタグなし CoS 値(0)に割り当てられます(これはデフォルトのイーサネット ドロップ システム クラスにマッピングされます)。 イーサネットまたは EtherChannel インターフェイスのデフォルトのタグなし Cos 値は上書きできます。

                                        手順
                                           コマンドまたはアクション目的
                                          ステップ 1 switch# configure terminal
                                           

                                          コンフィギュレーション モードを開始します。

                                           
                                          ステップ 2 switch(config)# interface {ethernet [chassis/]slot/port | port-channel channel-number}
                                           

                                          指定されたインターフェイスまたはポート チャネルのコンフィギュレーション モードを開始します。

                                           
                                          ステップ 3 switch(config-if)# no switchport
                                           
                                          (任意)

                                          レイヤ 3 インターフェイスを選択します。

                                           
                                          ステップ 4 switch(config-if)# untagged cos cos-value
                                           

                                          タグなし CoS 値を設定します。 指定できる値は 1 ~ 7 です。

                                           

                                          次に、インターフェイスで受信するタグなしフレームに CoS 値 4 を設定する例を示します。

                                          switch# configure terminal
                                          switch(config)# interface ethernet 1/2
                                          switch(config-if)# untagged cos 4

                                          次に、レイヤ 3 インターフェイスで受信するタグなしフレームに CoS 値 3 を設定する例を示します。

                                          switch# configure terminal
                                          switch(config)# interface ethernet 1/5
                                          switch(config-if)# no switchport
                                          switch(config-if)# untagged cos 3
                                          switch(config-if)#

                                          インターフェイスのサービス ポリシーの設定

                                          入力 qos ポリシーは、イーサネット インターフェイスの着信トラフィックに適用される分類用のサービス ポリシーです。 type queuing の場合、出力ポリシーは、指定されたクラスに一致するすべての発信トラフィックに適用されます。

                                          手順
                                             コマンドまたはアクション目的
                                            ステップ 1 switch# configure terminal
                                             

                                            コンフィギュレーション モードを開始します。

                                             
                                            ステップ 2 switch(config)# interface {ethernet [chassis/]slot/port | port-channel channel-number}
                                             

                                            指定されたインターフェイスのコンフィギュレーション モードを開始します。

                                            (注)     

                                            ポート チャネルのサービス ポリシーはすべてのメンバー インターフェイスに適用されます。

                                             
                                            ステップ 3 switch(config-if)# service-policy [type {qos input | queuing output}] policy-name
                                             

                                            ポリシー マップをシステムのサービス ポリシーとして使用するよう指定します。 2 つのポリシー マップ コンフィギュレーション モードがあります。

                                            • qos:分類モード。これがデフォルト モードです。
                                            • queuing:キューイング モード。
                                            (注)     

                                            input キーワードは、そのポリシー マップがインターフェイスの受信トラフィックに適用されることを示します。 output キーワードは、そのポリシー マップがインターフェイスの送信トラフィックに適用されることを示します。 qos ポリシーには input だけを、queuing ポリシーには output だけを適用できます。

                                             
                                            ステップ 4 switch(config-if)# service-policy input policy-name
                                             

                                            インターフェイスにポリシー マップを適用します。

                                            (注)     

                                            制約事項として、システム type qos ポリシーは、インターフェイスや EtherChannel に適用される type qos ポリシーと同じものにできません。

                                             

                                            次の例は、イーサネット インターフェイスにポリシーを適用する方法を示しています。

                                            switch# configure terminal
                                            switch(config)# interface ethernet 1/1
                                            switch(config-if)# service-policy type qos input policy1
                                             

                                            QoS の設定の確認

                                            Cisco Nexus 3000 シリーズの QoS 設定を確認するには、次のいずれかの作業を行います。

                                            コマンド

                                            目的

                                            switch# show class-map

                                            スイッチで定義されたクラス マップを表示します。

                                            switch# show policy-map [name]

                                            スイッチで定義されたポリシー マップを表示します。 指定したポリシーだけを表示することもできます。

                                            switch# show policy-map interface [interface number]

                                            1 つまたはすべてのインターフェイスのポリシー マップ設定を表示します。

                                            switch# show policy-map system

                                            システム qos に結合されたポリシー マップ設定を表示します。

                                            switch# show policy-map type {network-qos | qos | queuing} [name]

                                            特定のポリシー タイプのポリシー マップ設定を表示します。 指定したポリシーだけを表示することもできます。

                                            switch# show interface untagged-cos [ module number] すべてのインターフェイスのタグなし CoS 値を表示します。
                                            switch# show wrr-queue cos-map [var]

                                            出力キューにマッピングされた CoS 値を表示します。

                                            switch# running-config ipqos

                                            QoS の実行コンフィギュレーションに関する情報を表示します。

                                            switch# startup-config ipqos

                                            QoS のスタートアップ コンフィギュレーションに関する情報を表示します。

                                            switch# show queuing interface ethernet slot-no/port-no

                                            インターフェイスのキューイング情報を表示します。

                                            次に、ネットワーク QoS ポリシーを設定する例を示します。

                                            switch(config)# class-map type network-qos cnq1
                                            switch(config-cmap-nq)# match qos-group 1
                                            switch(config-cmap-nq)# exit
                                            switch(config)# class-map type network-qos cnq6
                                            switch(config-cmap-nq)# match qos-group 6
                                            switch(config-cmap-nq)# 
                                            switch(config-cmap-nq)# exit
                                            switch(config)# policy-map type network-qos pnqos
                                            switch(config-pmap-nq)# class type network-qos cnq1
                                            switch(config-pmap-nq-c)# set cos 4
                                            switch(config-pmap-nq-c)# exit
                                            switch(config-pmap-nq)# class type network-qos cnq6
                                            switch(config-pmap-nq-c)# set cos 5
                                            switch(config-pmap-nq-c)# congestion-control random-detect ecn
                                            switch(config-pmap-nq-c)# exit
                                            switch(config-pmap-nq)# class type network-qos class-default
                                            switch(config-pmap-nq-c)# mtu 9216
                                            switch(config-pmap-nq-c)# exit
                                            switch(config-pmap-nq)# exit
                                            switch(config)# system qos
                                            switch(config-sys-qos)# service-policy type network-qos pnqos
                                            switch(config-sys-qos)#

                                            次に、キューイング ポリシーを設定する例を示します。

                                            switch(config)# class-map type queuing cqu1
                                            switch(config-cmap-que)# match qos-group 1
                                            switch(config-cmap-que)# exit
                                            switch(config)# class-map type queuing cqu6
                                            switch(config-cmap-que)# match qos-group 6
                                            switch(config-cmap-que)# exit
                                            switch(config)# policy-map type queuing pqu
                                            switch(config-pmap-que)# class type queuing class-default
                                            switch(config-pmap-c-que)# bandwidth percent 70
                                            switch(config-pmap-c-que)# exit
                                            switch(config-pmap-que)# class type queuing cqu1
                                            switch(config-pmap-c-que)# bandwidth percent 10
                                            switch(config-pmap-c-que)# exit
                                            switch(config-pmap-que)# class type queuing cqu6
                                            switch(config-pmap-c-que)# bandwidth percent 20
                                            switch(config-pmap-c-que)# exit
                                            switch(config-pmap-que)# exit
                                            switch(config)# system qos
                                            switch(config-sys-qos)# service-policy type queuing output pqu
                                            switch(config-sys-qos)#

                                            次に、QoS ポリシーを設定する例を示します。

                                            switch(config)# class-map type qos cqos1
                                            switch(config-cmap-qos)# match cos 1
                                            switch(config-cmap-qos)# exit
                                            switch(config)# class-map type qos cqos6
                                            switch(config-cmap-qos)# match cos 6
                                            switch(config-cmap-qos)# exit
                                            switch(config)# policy-map type qos pqos
                                            switch(config-pmap-qos)# class type qos cqos1
                                            switch(config-pmap-c-qos)# set qos-group 1
                                            switch(config-pmap-c-qos)# exit
                                            switch(config-pmap-qos)# class type qos cqos6
                                            switch(config-pmap-c-qos)# set qos-group 6
                                            switch(config-pmap-c-qos)# exit
                                            switch(config-pmap-qos)# exit
                                            switch(config)# system qos
                                            switch(config-sys-qos)# service-policy type qos input pqos
                                            switch(config-sys-qos)#

                                            次に、インターフェイス上でタグなし cos の設定を確認する例を示します。

                                            switch(config-if)# show interface untagged-cos
                                            =================================
                                            
                                            Interface      Untagged-CoS
                                            =================================
                                            
                                            Ethernet1/1  4
                                            Ethernet1/2
                                            Ethernet1/3  5
                                            Ethernet1/4
                                            Ethernet1/5
                                            Ethernet1/6
                                            Ethernet1/7
                                            Ethernet1/8
                                            Ethernet1/9
                                            Ethernet1/10
                                            Ethernet1/11
                                            Ethernet1/12
                                            Ethernet1/13
                                            Ethernet1/14
                                            Ethernet1/15
                                            Ethernet1/16
                                            Ethernet1/17

                                            次に、QoS の実行コンフィギュレーションを表示する例を示します。

                                            switch(config)# show running-config ipqos
                                            
                                            !Command: show running-config ipqos
                                            !Time: Mon Mar 15 08:24:12 2010
                                            
                                            version 5.0(3)U1(1)
                                            class-map type qos match-all cqos1
                                              match cos 1
                                            class-map type qos match-all cqos6
                                              match cos 6
                                            class-map type queuing cqu1
                                              match qos-group 1
                                            class-map type queuing cqu6
                                              match qos-group 6
                                            policy-map type qos pqos
                                              class cqos1
                                                set qos-group 1
                                              class cqos6
                                                set qos-group 6
                                            policy-map type queuing pqu
                                              class type queuing cqu1
                                                bandwidth percent 10
                                              class type queuing cqu6
                                                bandwidth percent 20
                                              class type queuing class-default
                                                bandwidth percent 70
                                            class-map type network-qos cnq1
                                              match qos-group 1
                                            class-map type network-qos cnq6
                                              match qos-group 6
                                            policy-map type network-qos pnqos
                                              class type network-qos cnq1
                                                set cos 4
                                              class type network-qos cnq6
                                                set cos 5
                                                congestion-control random-detect ecn
                                              class type network-qos class-default
                                                mtu 9216
                                            system qos
                                              service-policy type qos input pqos
                                              service-policy type network-qos pnqos
                                              service-policy type queuing output pqu
                                            
                                            
                                            interface Ethernet1/1
                                              untagged cos 4
                                            
                                            interface Ethernet1/3
                                              untagged cos 5
                                            
                                            switch(config)#

                                            次に、出力キューにマッピングされた QoS グループを表示する例を示します。

                                            switch(config)# wrr-queue qos-group-map 3 1
                                            switch(config)# show wrr-queue qos-group-map
                                            MCAST Queue ID           Qos-Group Map
                                            0                       0
                                            1                       2 3
                                            2                       4 5
                                            3                       1 6 7
                                            switch(config)#
                                            

                                            次に、クラス マップ設定を表示する例を示します。

                                            switch(config)# show class-map
                                            
                                            
                                              Type qos class-maps
                                              ===================
                                            
                                                class-map type qos match-all cqos1
                                                  match cos 1
                                            
                                                class-map type qos match-all cqos6
                                                  match cos 6
                                            
                                                class-map type qos match-any class-default
                                                  match any
                                            
                                            
                                              Type queuing class-maps
                                              =======================
                                            
                                                class-map type queuing cqu1
                                                  match qos-group 1
                                            
                                                class-map type queuing cqu6
                                                  match qos-group 6
                                            
                                                class-map type queuing class-default
                                                  match qos-group 0
                                            
                                            
                                            
                                              Type network-qos class-maps
                                              ==============================
                                            
                                                class-map type network-qos cnq1
                                                  match qos-group 1
                                            
                                                class-map type network-qos cnq6
                                                  match qos-group 6
                                            
                                                class-map type network-qos class-default
                                                  match qos-group 0
                                            
                                            switch(config)#

                                            次に、ポリシー マップ設定を表示する例を示します。

                                            switch(config)# show policy-map
                                            
                                            
                                              Type qos policy-maps
                                              ====================
                                            
                                              policy-map type qos pqos
                                                class type qos cqos1
                                                  set qos-group 1
                                                class type qos cqos6
                                                  set qos-group 6
                                                class type qos class-default
                                                  set qos-group 0
                                              policy-map type qos default-in-policy
                                                class type qos class-default
                                                  set qos-group 0
                                            
                                              Type queuing policy-maps
                                              ========================
                                            
                                              policy-map type queuing pqu
                                                class type queuing cqu1
                                                  bandwidth percent 10
                                                class type queuing cqu6
                                                  bandwidth percent 20
                                                class type queuing class-default
                                                  bandwidth percent 70
                                              policy-map type queuing default-out-policy
                                                class type queuing class-default
                                                  bandwidth percent 100
                                            
                                            
                                              Type network-qos policy-maps
                                              ===============================
                                            
                                              policy-map type network-qos pnqos
                                                class type network-qos cnq1
                                                  mtu 1500
                                                  set cos 4
                                                class type network-qos cnq6
                                                  mtu 1500
                                                  set cos 5
                                                  congestion-control random-detect ecn
                                                class type network-qos class-default
                                                  mtu 9216
                                              policy-map type network-qos default-nq-policy
                                                class type network-qos class-default
                                                  mtu 1500
                                            switch(config)#

                                            次に、システム内のすべてのアクティブ ポリシー マップを表示する例を示します。

                                            switch(config)# show policy-map system
                                            
                                            
                                              Type network-qos policy-maps
                                              ===============================
                                            
                                              policy-map type network-qos pnqos
                                                class type network-qos cnq1      match qos-group 1
                                            
                                                  mtu 1500
                                                  set cos 4
                                                class type network-qos cnq6      match qos-group 6
                                            
                                                  mtu 1500
                                                  set cos 5
                                                  congestion-control random-detect ecn
                                                class type network-qos class-default      match qos-group 0
                                            
                                                  mtu 9216
                                            
                                              Service-policy (qos) input:   pqos
                                                policy statistics status:   disabled
                                            
                                                Class-map (qos):   cqos1 (match-all)
                                                  Match: cos 1
                                                  set qos-group 1
                                            
                                                Class-map (qos):   cqos6 (match-all)
                                                  Match: cos 6
                                                  set qos-group 6
                                            
                                                Class-map (qos):   class-default (match-any)
                                                  Match: any
                                                  set qos-group 0
                                            
                                              Service-policy (queuing) output:   pqu
                                                policy statistics status:   disabled
                                            
                                                Class-map (queuing):   cqu1 (match-any)
                                                  Match: qos-group 1
                                                  bandwidth percent 10
                                            
                                                Class-map (queuing):   cqu6 (match-any)
                                                  Match: qos-group 6
                                                  bandwidth percent 20
                                            
                                                Class-map (queuing):   class-default (match-any)
                                                  Match: qos-group 0
                                                  bandwidth percent 70
                                            
                                            switch(config)#

                                            次に、インターフェイスに設定されているサービス ポリシー マップを表示する例を示します。

                                            switch(config)# show policy-map interface ethernet 1/1
                                            
                                            
                                            Global statistics status :   disabled
                                            
                                            Ethernet1/1
                                            
                                              Service-policy (qos) input:   pqos
                                                policy statistics status:   disabled
                                            
                                                Class-map (qos):   cqos1 (match-all)
                                                  Match: cos 1
                                                  set qos-group 1
                                            
                                                Class-map (qos):   cqos6 (match-all)
                                                  Match: cos 6
                                                  set qos-group 6
                                            
                                                Class-map (qos):   class-default (match-any)
                                                  Match: any
                                                  set qos-group 0
                                            
                                              Service-policy (queuing) output:   pqu
                                                policy statistics status:   disabled
                                            
                                                Class-map (queuing):   cqu1 (match-any)
                                                  Match: qos-group 1
                                                  bandwidth percent 10
                                            
                                                Class-map (queuing):   cqu6 (match-any)
                                                  Match: qos-group 6
                                                  bandwidth percent 20
                                            
                                                Class-map (queuing):   class-default (match-any)
                                                  Match: qos-group 0
                                                  bandwidth percent 70
                                            
                                            switch(config)#

                                            次に、特定のインターフェイスのキューイング情報を表示する例を示します。

                                            switch(config)# show queuing interface ethernet 1/1
                                            Ethernet1/1 queuing information:
                                              TX Queuing
                                                qos-group  sched-type  oper-bandwidth
                                                    0       WRR             70
                                                    1       WRR             10
                                                    6       WRR             20
                                            
                                              RX Queuing
                                                qos-group 0
                                                HW MTU: 1500 (1500 configured)
                                                drop-type: drop, xon: 0, xoff: 0
                                                Statistics:
                                                    Ucast pkts sent over the port           : 0
                                                    Ucast bytes sent over the port          : 0
                                                    Mcast pkts sent over the port           : 0
                                                    Mcast bytes sent over the port          : 0
                                                    Ucast pkts dropped                      : 0
                                                    Ucast bytes dropped                     : 0
                                                    Mcast pkts dropped                      : 0
                                                    Mcast bytes dropped                     : 0
                                                qos-group 1
                                                HW MTU: 1500 (1500 configured)
                                                drop-type: drop, xon: 0, xoff: 0
                                                Statistics:
                                                    Ucast pkts sent over the port           : 0
                                                    Ucast bytes sent over the port          : 0
                                                    Mcast pkts sent over the port           : 0
                                                    Mcast bytes sent over the port          : 0
                                                    Ucast pkts dropped                      : 0
                                                    Ucast bytes dropped                     : 0
                                                    Mcast pkts dropped                      : 0
                                                    Mcast bytes dropped                     : 0
                                                qos-group 6
                                                HW MTU: 1500 (1500 configured)
                                                drop-type: drop, xon: 0, xoff: 0
                                                Statistics:
                                                    Ucast pkts sent over the port           : 0
                                                    Ucast bytes sent over the port          : 0
                                                    Mcast pkts sent over the port           : 0
                                                    Mcast bytes sent over the port          : 0
                                                    Ucast pkts dropped                      : 0
                                                    Ucast bytes dropped                     : 0
                                                    Mcast pkts dropped                      : 0
                                                    Mcast bytes dropped                     : 0
                                            switch(config)#

                                            QoS パケット バッファのモニタリング

                                            Cisco Nexus 3000 シリーズには、ポートおよびダイナミック共有メモリごとに専用として区切られた 9MB のバッファ メモリがあります。 各前面パネル ポートの出力には、8 個のユニキャスト キューと 4 個のマルチキャスト キューがあります。

                                            バーストまたは輻輳シナリオでは、各出力ポートはダイナミック共有メモリからバッファを消費します。

                                            Cisco NX-OS Release 5.0(3) U 2(1) から、ポート単位で共有バッファのステータスをリアルタイムで表示できます。 セルの数に関して、すべてのカウンタが表示されます。 各セルは 208 バイトです。 また消費量と使用可能なセルの数に関して、グローバル レベル バッファの消費を表示できます。

                                            次の例は、次の方法を示します。
                                            switch(config)# show hardware  internal  buffer  info pkt-stats
                                            
                                            |-----------------------------------------------------------------------------------------|
                                            
                                                                      Total Instant Usage          7588
                                                                      Remaining Instant Usage     38492
                                                                      Max Cell Usage               7945
                                                                      Switch Cell Count           46080
                                            |-----------------------------------------------------------------------------------------|
                                            
                                            |-----------------------------------------------------------------------------------------|
                                            |                         Instant Buffer utilization per queue per port                   |
                                            |   Each line displays the number of cells utilized for a given port for each QoS queue   |
                                            |                         One cell represents approximately 208 bytes                     |
                                            |---------+---------+---------+---------+---------+---------+--------+---------+---------+|
                                            |Port         Q1        Q2        Q3        Q4        Q5        Q6        Q7        Q8    |
                                            |---------+---------+---------+---------+---------+---------+--------+---------+---------+|
                                            
                                             [ 6]
                                             UC->         0         0         0         0         0         0         0         0
                                             MC->         4         0         0         0
                                            
                                             [ 9]
                                             UC->         0         0         0         0         0         0         0         0
                                             MC->      3807         0         0         0
                                            
                                             [13]
                                             UC->         0         0         0         0         0         0         0         0
                                             MC->         4         0         0         0
                                            
                                             [19]
                                             UC->         0         0         0         0         0         0         0         0
                                             MC->      3802         0         0         0
                                            

                                            使用量の情報:

                                            • 合計瞬間使用量 --- グローバル ベースでセル数に関する現在のバッファの使用量。
                                            • 瞬間残留使用量 --- グローバル ベースで使用できる有効な空きセル数。
                                            • 最大セル使用量 --- 最後にクリアされるまでに検出された最大バッファ使用量。
                                            • スイッチのセル数 --- グローバル ベースでセル数に関してプラットフォームで利用可能な合計グローバル バッファ スペース。

                                            UC と MC は 8 ユニキャスト(Q1-Q8)および 4 マルチキャスト(Q1-Q4)瞬間セル使用量を表します。 上記の例では、マルチキャスト キュー Q1 がポート 9 で 3807 個のセルを即座に消費していることを示しています。

                                            次に、システム バッファの最大セルの使用カウンタをクリアする例を示します。:
                                            switch# clear counters buffers
                                            Max Cell Usage has been reset successfully
                                            
                                            次に、ポート単位でバッファ使用率しきい値を設定する例を示します。 バッファの占有がこの数を超えた場合、syslog を生成したり、show hardware internal buffer info pkt-stats port-log コマンドのステータスを確認したりできます。
                                            switch# hardware profile buffer info port-threshold front-port  1 threshold  10
                                            Port threshold changed successfully
                                            
                                            次の例は、このポートのバッファ使用状況が、設定したしきい値を超えた時刻を示しています。
                                            switch(config)# sh hardware  internal  buffer  info pkt-stats port-log
                                            02-27-2012  04:10:36.63345 Port  9 buffer threshold 3685 exceeded 810[3%]
                                            02-27-2012  04:10:36.63764 Port 17 buffer threshold 3684 exceeded 2430[9%]
                                            02-27-2012  04:10:36.65436 Port 63 buffer threshold 3681 exceeded 270[1%]