Cisco Nexus 3548 スイッチ NX-OS インターフェイス コンフィギュレーション ガイド リリース 5.0(3)A1(1)
レイヤ 3 インターフェイスの設定
レイヤ 3 インターフェイスの設定
発行日;2013/02/05   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

レイヤ 3 インターフェイスの設定

この章の内容は、次のとおりです。

レイヤ 3 インターフェイスについて

レイヤ 3 インターフェイスは、スタティックまたはダイナミック ルーティング プロトコルを使って、パケットを別のデバイスに転送します。 レイヤ 2 トラフィックの IP ルーティングおよび内部 Virtual Local Area Network(VLAN)ルーティングにはレイヤ 3 インターフェイスが使用できます。

ルーテッド インターフェイス

ポートをレイヤ 2 インターフェイスまたはレイヤ 3 インターフェイスとして設定できます。 ルーテッド インターフェイスは、IP トラフィックを他のデバイスにルーティングできる物理ポートです。 ルーテッド インターフェイスはレイヤ 3 インターフェイスだけで、スパニングツリー プロトコル(STP)などのレイヤ 2 プロトコルはサポートしません。

すべてのイーサネット ポートは、デフォルトでレイヤ 2(スイッチポート)です。 このデフォルト動作を変更するには、インターフェイス コンフィギュレーション モードで no switchport コマンドを使用します。 複数のポートを一度に変更するには、インターフェイスの範囲を指定してから、no switchport コマンドを適用します。

ポートに IP アドレスを割り当て、ルーティングをイネーブルにし、このルーテッド インターフェイスにルーティング プロトコル特性を割り当てることができます。

レイヤ 3 インターフェイスにスタティック MAC アドレスを割り当てることができます。 MAC アドレスの設定については、デバイスの『Layer 2 Switching Configuration Guide』を参照してください。

ルーテッド インターフェイスからレイヤ 3 ポート チャネルも作成できます。

ルーテッド インターフェイスおよびサブインターフェイスは、指数関数的に減少するレート カウンタをサポートします。 Cisco NX-OS はこれらの平均カウンタを用いて次の統計情報を追跡します。
  • 入力パケット数/秒
  • 出力パケット数/秒
  • 入力バイト数/秒
  • 出力バイト数/秒

サブインターフェイス

レイヤ 3 インターフェイスとして設定した親インターフェイスに仮想サブインターフェイスを作成できます。 親インターフェイスは物理ポートでもポート チャネルでもかまいません。

親インターフェイスはサブインターフェイスによって複数の仮想インターフェイスに分割されます。これらの仮想インターフェイスに IP アドレスやダイナミック ルーティング プロトコルなど固有のレイヤ 3 パラメータを割り当てることができます。 各サブインターフェイスの IP アドレスは、親インターフェイスの他のサブインターフェイスのサブネットとは異なります。

サブインターフェイスの名前は、親インターフェイスの名前(たとえば Ethernet 2/1)+ ピリオド(.)+そのインターフェイス独自の番号です。 たとえば、イーサネット インターフェイス 2/1 に Ethernet 2/1.1 というサブインターフェイスを作成できます。この場合、.1 はそのサブインターフェイスを表します。

Cisco NX-OS では、親インターフェイスがイネーブルの場合にサブインターフェイスがイネーブルになります。 サブインターフェイスは、親インターフェイスには関係なくシャットダウンできます。 親インターフェイスをシャットダウンすると、関連するサブインターフェイスもすべてシャットダウンされます。

サブインターフェイスを使用すると、親インターフェイスがサポートするそれぞれの VLAN に独自のレイヤ 3 インターフェイスを実現できます。 この場合、親インターフェイスは別のデバイスのレイヤ 2 トランキング ポートに接続します。 サブインターフェイスを設定したら 802.1Q トランキングを使って VLAN ID に関連付けます。

次の図は、インターフェイス E 2/1 のルータ B に接続するスイッチのトランク ポートを示します。 このインターフェイスには 3 つのサブインターフェイスがあり、トランキング ポートに接続する 3 つの VLAN にそれぞれ関連付けられています。

図 1. VLAN のサブインターフェイス



VLAN インターフェイス

VLAN インターフェイスまたはスイッチ仮想インターフェイス(SVI)は、デバイスの VLAN を同じデバイスのレイヤ 3 ルータ エンジンに接続する仮想ルーテッド インターフェイスです。 VLAN には 1 つの VLAN インターフェイスだけを関連付けることができますが、VLAN に VLAN インターフェイスを設定する必要があるのは、VLAN 間でルーティングする場合か、または管理 VRF(仮想ルーティング/転送)以外の VRF インスタンスを経由してデバイスを IP ホスト接続する場合だけです。 VLAN インターフェイスの作成をイネーブルにすると、Cisco NX-OS によってデフォルト VLAN(VLAN 1)に VLAN インターフェイスが作成され、リモート スイッチ管理が許可されます。

設定の前に VLAN ネットワーク インターフェイス機能をイネーブルにする必要があります。 システムはこの機能をディセーブルにする前のチェックポイントを自動的に取得するため、このチェックポイントにロール バックできます。 ロールバックとチェックポイントの詳細については、デバイスの『System Management Configuration Guide』を参照してください。


(注)  


VLAN 1 の VLAN インターフェイスは削除できません。


VLAN インターフェイスをルーティングするには、トラフィックをルーティングする VLAN ごとに VLAN インターフェイスを作成し、その VLAN インターフェイスに IP アドレスを割り当ててレイヤ 3 内部 VLAN ルーティングを実現します。 IP アドレスと IP ルーティングの詳細については、デバイスの『Unicast Routing Configuration Guide』を参照してください。

次の図に、デバイス上の 2 つの VLAN に接続されている 2 つのホストを示します。 VLAN ごとに VLAN インターフェイスを設定し、VLAN 間の IP ルーティングを使ってホスト 1 とホスト 2 を通信させることができます。 VLAN 1 は VLAN インターフェイス 1 のレイヤ 3 で、VLAN 10 は VLAN インターフェイス 10 のレイヤ 3 で通信します。

図 2. VLAN インターフェイスによる 2 つの VLAN の接続



ループバック インターフェイス

ループバック インターフェイスは、常にアップ状態にある単独のエンドポイントを持つ仮想インターフェイスです。 ループバック インターフェイスを通過するパケットは、このインターフェイスでただちに受信されます。 ループバック インターフェイスは物理インターフェイスをエミュレートします。

ループバック インターフェイスを使用すると、パフォーマンスの分析、テスト、ローカル通信が実行できます。 ループバック インターフェイスは、ルーティング プロトコル セッションの終端アドレスとして設定することができます。 ループバックをこのように設定すると、アウトバウンド インターフェイスの一部がダウンしている場合でもルーティング プロトコル セッションはアップしたままです。

レイヤ 3 インターフェイスのライセンス要件

この機能にはライセンスは不要です。 ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。 NX-OS ライセンス方式の詳細については、『Cisco NX-OS Licensing Guide』を参照してください。

レイヤ 3 インターフェイスの注意事項および制約事項

レイヤ 3 インターフェイスの設定には次の注意事項と制約事項があります。
  • レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変更する場合、Cisco NX-OS はインターフェイスをシャットダウンしてインターフェイスを再度イネーブルにし、レイヤ 3 固有の設定をすべて削除します。
  • レイヤ 2 インターフェイスをレイヤ 3 インターフェイスに変更する場合、Cisco NX-OS はインターフェイスをシャットダウンしてインターフェイスを再度イネーブルにし、レイヤ 2 固有の設定をすべて削除します。

レイヤ 3 インターフェイスのデフォルト設定

レイヤ 3 の管理ステートのデフォルト設定は Shut です。

レイヤ 3 インターフェイスの設定

ルーテッド インターフェイスの設定

手順
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal 

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2switch(config)# interface ethernet slot/port 

    インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 3switch(conifg-if)# no switchport 

    インターフェイスをレイヤ 3 インターフェイスとして設定し、このインターフェイス上のレイヤ 2 に固有の設定をすべて削除します。

    (注)     

    レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに再び変換するには、switchport コマンドを使用します。

     
    ステップ 4switch(config-if)# ipip-address/length 

    このインターフェイスの IP アドレスを設定します。

     
    ステップ 5switch(config-if)# medium {broadcast | p2p}  (任意)

    ポイント ツー ポイントまたはブロードキャストとしてインターフェイスのメディアを設定します。

    (注)     

    デフォルト設定は broadcast であり、この設定はいずれの show コマンドにも表示されません。 ただし、p2p に設定を変更した場合、show running-config コマンドを入力すると、この設定が表示されます。

     
    ステップ 6switch(config-if)# show interfaces  (任意)

    レイヤ 3 インターフェイスの統計情報を表示します。

     
    ステップ 7switch(config-if)# copy running-config startup-config  (任意)

    リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

     

    次に、IPv4 ルーテッド レイヤ 3 インターフェイスを設定する例を示します。

    switch# configure terminal
    switch(config)# interface ethernet 2/1
    switch(config-if)# no switchport
    switch(config-if)# ip address 192.0.2.1/8
    switch(config-if)# copy running-config startup-config

    サブインターフェイスの設定

    はじめる前に
    • 親インターフェイスをルーテッド インターフェイスとして設定します。
    • このポート チャネル上にサブインターフェイスを作成するには、ポート チャネル インターフェイスを作成します。
    手順
       コマンドまたはアクション目的
      ステップ 1switch(config-if)# copy running-config startup-config  (任意)

      リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

       
      ステップ 2switch(config)# interface ethernet slot/port.number
       

      インターフェイス コンフィギュレーション モードを開始します。 slot の範囲は 1 ~ 255 です。 port の範囲は 1 ~ 128 です。

       
      ステップ 3switch(config-if)# ip address ip-address/length 

      このインターフェイスの IP アドレスを設定します。

       
      ステップ 4switch(config-if)# encapsulation dot1Q vlan-id  サブインターフェイスで IEEE 802.1Q VLAN カプセル化を設定します。 vlan-id の範囲は 2 ~ 4093 です。 
      ステップ 5switch(config-if)# show interfaces  (任意)

      レイヤ 3 インターフェイスの統計情報を表示します。

       
      ステップ 6switch(config-if)# copy running-config startup-config  (任意)

      リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

       

      次に、サブインターフェイスを作成する例を示します。

      switch# configure terminal
      switch(config)# interface ethernet 2/1
      switch(config-if)# ip address 192.0.2.1/8
      switch(config-if)# encapsulation dot1Q 33
      switch(config-if)# copy running-config startup-config

      インターフェイスでの帯域幅の設定

      ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅を設定できます。

      手順
         コマンドまたはアクション目的
        ステップ 1switch# configure terminal 

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2switch(config)# interface ethernet slot/port 

        インターフェイス コンフィギュレーション モードを開始します。 slot の範囲は 1 ~ 255 です。 port の範囲は 1 ~ 128 です。

         
        ステップ 3switch(conifg-if)# bandwidth [value | inherit [value]]  次のように、ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅パラメータを設定します。
        • value:帯域幅のサイズ(キロバイト)。 範囲は 1 ~ 10000000 です。
        • inherit:このインターフェイスのすべてのサブインターフェイスが、帯域幅の値(値が指定されている場合)または親インターフェイスの帯域幅(値が指定されていない場合)のどちらかを継承することを示します。
         
        ステップ 4switch(config-if)# copy running-config startup-config  (任意)

        リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

         

        次に、イーサネット インターフェイス 2/1 に 80000 の帯域幅の値を設定する例を示します。

        switch# configure terminal
        switch(config)# interface ethernet 2/1
        switch(config-if)# bandwidth 80000
        switch(config-if)# copy running-config startup-config

        VLAN インターフェイスの設定

        手順
           コマンドまたはアクション目的
          ステップ 1switch# configure terminal 

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2switch(config)# feature interface-vlan 

          VLAN インターフェイス モードをイネーブルにします。

           
          ステップ 3switch(config)# interface vlan number 

          VLAN インターフェイスを作成します。 number の範囲は 1 ~ 4094 です。

           
          ステップ 4switch(config-if)# ip address ip-address/length 

          このインターフェイスの IP アドレスを設定します。

           
          ステップ 5switch(config-if)# show interface vlan number  (任意)

          VLAN インターフェイスの統計情報を表示します。 number の範囲は 1 ~ 4094 です。

           
          ステップ 6switch(config-if)# copy running-config startup-config  (任意)

          リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

           

          次に、VLAN インターフェイスを作成する例を示します。

          switch# configure terminal
          switch(config)# feature interface-vlan
          switch(config)# interface vlan 10
          switch(config-if)# ip address 192.0.2.1/8
          switch(config-if)# copy running-config startup-config

          ループバック インターフェイスの設定

          はじめる前に

          ループバック インターフェイスの IP アドレスが、ネットワークの全ルータで一意であることを確認します。

            手順
               コマンドまたはアクション目的
              ステップ 1switch# configure terminal 

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2switch(config)# interface loopback instance 

              ループバック インターフェイスを作成します。 instance の範囲は 0 ~ 1023 です。

               
              ステップ 3switch(config-if)# ip address ip-address/length 

              このインターフェイスの IP アドレスを設定します。

               
              ステップ 4switch(config-if)# show interface loopback instance  (任意)

              ループバック インターフェイスの統計情報を表示します。 instance の範囲は 0 ~ 1023 です。

               
              ステップ 5switch(config-if)# copy running-config startup-config  (任意)

              リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

               

              次に、ループバック インターフェイスを作成する例を示します。

              switch# configure terminal
              switch(config)# interface loopback 0
              switch(config-if)# ip address 192.0.2.100/8
              switch(config-if)# copy running-config startup-config
              

              VRF へのインターフェイスの割り当て

              はじめる前に

              VRF 用のインターフェイスを設定した後で、トンネル インターフェイスに IP アドレスを割り当てます。

                手順
                   コマンドまたはアクション目的
                  ステップ 1switch# configure terminal 

                  グローバル コンフィギュレーション モードを開始します。

                   
                  ステップ 2switch(config)# interface interface-typenumber 

                  インターフェイス コンフィギュレーション モードを開始します。

                   
                  ステップ 3switch(conifg-if)#vrf member vrf-name 

                  このインターフェイスを VRF に追加します。

                   
                  ステップ 4switch(config-if)# ipip-address/length 

                  このインターフェイスの IP アドレスを設定します。 このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

                   
                  ステップ 5switch(config-if)# show vrf [vrf-name] interface interface-type number  (任意)

                  VRF 情報を表示します。

                   
                  ステップ 6switch(config-if)# show interfaces  (任意)

                  レイヤ 3 インターフェイスの統計情報を表示します。

                   
                  ステップ 7switch(config-if)# copy running-config startup-config  (任意)

                  リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

                   

                  次に、VRF にレイヤ 3 インターフェイスを追加する例を示します。

                  switch# configure terminal 
                  switch(config)# interface loopback 0 
                  switch(config-if)# vrf member RemoteOfficeVRF 
                  switch(config-if)# ip address 209.0.2.1/16 
                  switch(config-if)# copy running-config startup-config 
                  

                  レイヤ 3 インターフェイス設定の確認

                  設定を確認するには、次のいずれかのコマンドを使用します。

                  コマンド

                  目的

                  show interface ethernet slot/port

                  レイヤ 3 インターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

                  show interface ethernet slot/port brief

                  レイヤ 3 インターフェイスの動作ステータスを表示します。

                  show interface ethernet slot/port capabilities

                  ポート タイプ、速度、デュプレックスを含むレイヤ 3 インターフェイス機能を表示します。

                  show interface ethernet slot/port description

                  レイヤ 3 インターフェイスの説明を表示します。

                  show interface ethernet slot/port status

                  レイヤ 3 インターフェイスの管理ステータス、ポート モード、速度、およびデュプレックスを表示します。

                  show interface ethernet slot/port.number

                  サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

                  show interface port-channel channel-id.number

                  ポート チャネル サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

                  show interface loopback number

                  ループバック インターフェイスの設定情報、ステータス、カウンタを表示します。

                  show interface loopback number brief

                  ループバック インターフェイスの動作ステータスを表示します。

                  show interface loopback number description

                  ループバック インターフェイスの説明を表示します。

                  show interface loopback number status

                  ループバック インターフェイスの管理ステータスおよびプロトコル ステータスを表示します。

                  show interface vlan number

                  VLAN インターフェイスの設定情報、ステータス、カウンタを表示します。

                  show interface vlan number brief

                  VLAN インターフェイスの動作ステータスを表示します。

                  show interface vlan number description

                  VLAN インターフェイスの説明を表示します。

                  show interface vlan number private-vlan mapping

                  VLAN インターフェイスのプライベート VLAN 情報を表示します。

                  show interface vlan number status

                  VLAN インターフェイスの管理ステータスおよびプロトコル ステータスを表示します。

                  レイヤ 3 インターフェイスのモニタリング

                  機能に関する統計情報を表示するには、次のいずれかのコマンドを使用します。

                  コマンド

                  目的

                  show interface ethernet slot/port counters

                  レイヤ 3 インターフェイスの統計情報を表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

                  show interface ethernet slot/port counters brief

                  レイヤ 3 インターフェイスの入出力カウンタを表示します。

                  show interface ethernet slot/port counters detailed [all]

                  レイヤ 3 インターフェイスの統計情報を表示します。 オプションとして、すべての 32 ビットおよび 64 ビット パケットおよびバイト カウンタ(エラーを含む)を含めることができます。

                  show interface ethernet slot/port counters error

                  レイヤ 3 インターフェイスの入出力エラーを表示します。

                  show interface ethernet slot/port counters snmp

                  SNMP MIB から報告されたレイヤ 3 インターフェイス カウンタを表示します。 これらのカウンタはクリアできません。

                  show interface ethernet slot/port.number counters

                  サブインターフェイスの統計情報を表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

                  show interface port-channel channel-id.number counters

                  ポート チャネル サブインターフェイスの統計情報を表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

                  show interface loopback number counters

                  ループバック インターフェイスの入出力カウンタを表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

                  show interface loopback number counters detailed [all]

                  ループバック インターフェイスの統計情報を表示します。 オプションとして、すべての 32 ビットおよび 64 ビット パケットおよびバイト カウンタ(エラーを含む)を含めることができます。

                  show interface loopback number counters errors

                  ループバック インターフェイスの入力および出力エラーを表示します。

                  show interface vlan number counters

                  VLAN インターフェイスの入出力カウンタを表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

                  show interface vlan number counters detailed [all]

                  VLAN インターフェイスの統計情報を表示します。 オプションとして、レイヤ 3 パケットおよびバイト カウンタをすべて含めることができます(ユニキャストおよびマルチキャスト)。

                  show interface vlan counters snmp

                  SNMP MIB から報告された VLAN インターフェイス カウンタを表示します。 これらのカウンタはクリアできません。

                  レイヤ 3 インターフェイスの設定例

                  次に、イーサネット サブインターフェイスを設定する例を示します。
                  switch# configuration terminal
                  switch(config)# interface ethernet 2/1.10
                  switch(config-if)# no switchport
                  switch(config-if)# description Layer 3 for VLAN 10
                  switch(config-if)# encapsulation dot1q 10
                  switch(config-if)# ip address 192.0.2.1/8
                  switch(config-if)# copy running-config startup-config
                  次に、VLAN インターフェイスを設定する例を示します。
                  switch# configuration terminal
                  switch(config)# interface vlan 100
                  switch(config-if)# no switchport
                  switch(config-if)# ip address 192.0.2.1/8
                  
                  switch(config-if)# copy running-config startup-config
                  次に、ループバック インターフェイスを作成する例を示します。
                  switch# configuration terminal
                  switch(config)# interface loopback 3
                  switch(config-if)# no switchport
                  switch(config-if)# ip address 192.0.2.2/32
                  switch(config-if)# copy running-config startup-config

                  レイヤ 3 インターフェイスの関連資料

                  関連トピック 参照先

                  コマンド構文

                  『Cisco Nexus 3548 Switch NX-OS Interfaces Command Reference』

                  IP

                  『Cisco Nexus 3548 Switch NX-OS Unicast Routing Configuration Guide』の「Configuring IP」の章

                  VLAN

                  『Cisco Nexus 3548 Switch NX-OS Layer 2 Switching Configuration Guide』の「Configuring VLANs」の章

                  レイヤ 3 インターフェイスの MIB

                  MIB MIB のリンク

                  CISCO-IF-EXTENSION-MIB

                  MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

                  http:/​/​www.cisco.com/​public/​sw-center/​netmgmt/​cmtk/​mibs.shtml

                  ETHERLIKE-MIB

                  レイヤ 3 インターフェイスの標準

                  この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。