Cisco Nexus 3000 シリーズ NX-OS インターフェイス コンフィギュレーション ガイド リリース 5.0(3)U4(1)
IP トンネルの設定
IP トンネルの設定
発行日;2012/11/21   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

IP トンネルの設定

この章の内容は、次のとおりです。

IP トンネルについて

IP トンネルを使うと、同じレイヤまたは上位レイヤのプロトコルをカプセル化して、2 台のデバイス間で作成されたトンネルを通じて IP に結果を転送できます。

IP トンネルは次の 3 つの主要コンポーネントで構成されています。

  • パッセンジャ プロトコル:カプセル化する必要があるプロトコル。 パッセンジャ プロトコルの例には IPv4 があります。
  • キャリア プロトコル:パッセンジャ プロトコルをカプセル化するために使用するプロトコル。 Cisco NX-OS はキャリア プロトコルとして総称ルーティング カプセル化(GRE)をサポートします。
  • トランスポート プロトコル:カプセル化したプロトコルを伝送するために使用するプロトコル。 トランスポート プロトコルの例には IPv4 があります。

IP トンネルは IPv4 などのパッセンジャ プロトコルを使用し、このプロトコルを GRE などのキャリア プロトコル内にカプセル化します。 次に、このキャリア プロトコルは IPv4 などのトランスポート プロトコルを通じてデバイスから送信されます。

対応する特性を持つトンネル インターフェイスをトンネルの両端にそれぞれ設定します。

設定の前にトンネル機能をイネーブルにする必要があります。

GRE トンネル

さまざまなパッセンジャ プロトコルのキャリア プロトコルとして GRE を使用できます。

この図は、GRE トンネルの IP トンネルのコンポーネントを示しています。 オリジナルのパッセンジャ プロトコル パケットは GRE ペイロードとなり、デバイスはパケットに GRE ヘッダーを追加します。 次にデバイスはトランスポート プロトコル ヘッダーをパケットに追加して送信します。

図 1. GRE Protocol Data Unit(PDU)



IP トンネルのライセンス要件

製品

ライセンス要件

Cisco NX-OS

IP トンネルには Enterprise Services ライセンスが必要です。 Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、『Cisco NX-OS Licensing Guide』を参照してください。

IP トンネルの前提条件

IP トンネルには次の前提条件があります。

  • IP トンネルを設定するための TCP/IP に関する基礎知識があること。
  • スイッチにログインしている。
  • Cisco NX-OS の Enterprise Services ライセンスをインストールしていること。
  • IP トンネルを設定してイネーブルにする前にデバイスのトンネリング機能をイネーブルにしておくこと。

IP トンネルの注意事項および制約事項

IP トンネルの設定に関する注意事項と制約事項は次のとおりです。

  • Cisco NX-OS は、IETF RFC 2784 に定義されている GRE ヘッダーをサポートします。 Cisco NX-OS は、トンネル キーと IETF RFC 1701 のその他のオプションをサポートしません。
  • Cisco Nexus 3000 シリーズ スイッチは、最大 8 個のトンネルをサポートします。
  • Cisco Nexus 3000 シリーズ スイッチは、次の機能をサポートしません。
    • パスの最大伝送単位(MTU)の検出
    • 統計情報
    • アクセス コントロール リスト(ACL)
    • ユニキャスト リバース パス転送(URPF)
    • マルチキャスト トラフィックおよびインターネット グループ管理プロトコル(IGMP)、Protocol Independent Multicast(PIM)などの関連するマルチキャスト プロトコル
  • Cisco NX-OS は、トンネル インターフェイスの Web Cache Control Protocol(WCCP)をサポートしません。

IP トンネリングのデフォルト設定

次の表に、IP トンネル パラメータのデフォルト設定を示します。

表 1  デフォルトの IP トンネル パラメータ

パラメータ

デフォルト

トンネル機能

ディセーブル

IP トンネルの設定

トンネリングのイネーブル化

はじめる前に

IP トンネルを設定する前にトンネリング機能をイネーブルにする必要があります。

手順
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal 

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2switch(config)# feature tunnel 

    スイッチのトンネル機能をイネーブルにします。

     
    ステップ 3switch(config)# exit 

    コンフィギュレーション モードに戻ります。

     
    ステップ 4switch(config)# show feature tunnel 

    スイッチのトンネル機能を表示します。

     
    ステップ 5switch# copy running-config startup-config  (任意)

    リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

     

    次に、トンネル機能をイネーブルにする例を示します。

    switch# configure terminal
    switch(config)# feature tunnel
    switch(config)# exit
    switch(config)# copy running-config startup-config

    トンネル インターフェイスの作成

    トンネル インターフェイスを作成して、この論理インターフェイスを IP トンネルに設定できます。

    はじめる前に

    トンネルの送信元と宛先の両方が同じ仮想ルーティングおよび転送(VRF)インスタンス内にある必要があります。

    トンネリング機能がイネーブルになっていることを確認します。

    手順
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal 

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2switch(config)# [no] interface tunnel number 

      新しいトンネル インターフェイスを作成します。

       
      ステップ 3switch(config)#tunnel source {ip address | interface-name} 

      この IP トンネルの送信元アドレスを設定します。

       
      ステップ 4switch(config)#tunnel destination {ip address | host-name} 

      この IP トンネルの宛先アドレスを設定します。

       
      ステップ 5switch(config)#tunnel use-vrf vrf-name  (任意)

      設定された VRF をトンネルの IP 宛先アドレスの検索に使用します。

       
      ステップ 6switch(config)#show interface tunnel number  (任意)

      トンネル インターフェイスの統計情報を表示します。

       
      ステップ 7switch# copy running-config startup-config  (任意)

      リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

       

      次に、トンネル インターフェイスを作成する例を示します。

      switch# configure terminal
      switch(config)# interface tunnel 1
      switch(config)# tunnel source ethernet 1/2
      switch(config)# tunnel destination 192.0.2.1 
      switch(config)# copy running-config startup-config

      GRE トンネルの作成

      トンネル インターフェイスを GRE トンネル モードに設定できます。

      はじめる前に

      トンネリング機能がイネーブルになっていることを確認します。

      手順
         コマンドまたはアクション目的
        ステップ 1switch# configure terminal 

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2switch(config)# interface tunnel number 

        トンネル インターフェイス コンフィギュレーション モードを開始します。

         
        ステップ 3switch(config)#tunnel mode gre ip  

        このトンネル モードを GRE に設定します。

         
        ステップ 4switch(config)#show interface tunnel number  (任意)

        トンネル インターフェイスの統計情報を表示します。

         
        ステップ 5switch(config-if)# copy running-config startup-config  (任意)

        リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

         

        次に、トンネル インターフェイスを GRE に作成して、GRE トンネル キープアライブを設定する例を示します。

        switch# configure terminal
        switch(config)# interface tunnel 1
        switch(config)# tunnel mode gre ip
        switch(config)# copy running-config startup-config

        トンネル インターフェイスへの VRF メンバーシップの割り当て

        VRF にトンネル インターフェイスを追加できます。

        はじめる前に

        トンネリング機能がイネーブルになっていることを確認します。

        VRF 用のインターフェイスを設定した後で、トンネル インターフェイスに IP アドレスを割り当てます。

        手順
           コマンドまたはアクション目的
          ステップ 1switch# configure terminal 

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2switch(config)# interface tunnel number 

          インターフェイス コンフィギュレーション モードを開始します。

           
          ステップ 3switch(config)# vrf member vrf-name 

          このインターフェイスを VRF に追加します。

           
          ステップ 4switch(config)# ip address ip-prefix/length 

          このインターフェイスの IP アドレスを設定します。 このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

           
          ステップ 5switch(config)# show vrf [vrf-name] interface interface-type number  (任意)

          VRF 情報を表示します。

           
          ステップ 6switch(config-if)# copy running-config startup-config  (任意)

          リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

           

          次に、VRF にトンネル インターフェイスを追加する例を示します。

          switch# configure terminal
          switch(config)# interface tunnel 0
          switch(config-if)# vrf member RemoteOfficeVRF
          switch(config-if)# ip address 209.0.2.1/16
          switch(config-if)# copy running-config startup-config

          IP トンネル設定の確認

          IP トンネルの設定情報を確認するには、次のいずれかの作業を行います。

          コマンド 目的

          show interface tunnel number

          トンネル インターフェイスの設定を表示します(MTU、プロトコル、転送、および VRF)。 入力および出力パケット、バイト、およびパケット レートを表示します。

          show interface tunnel number brief

          トンネル インターフェイスの動作状態、IP アドレス、カプセル化のタイプ、MTU を表示します。

          show interface tunnel number description

          トンネル インターフェイスに設定された説明を表示します。

          show interface tunnel number status

          トンネル インターフェイスの動作ステータスを表示します。

          show interface tunnel number status err-disabled

          トンネル インターフェイスの errdisable 状態を表示します。

          IP トンネリングの設定例

          次に、単純な GRE トンネルを示します。 イーサネット 1/2 は、ルータ A のトンネル送信元であり、ルータ B のトンネル宛先です。 イーサネット インターフェイス 1/3 は、ルータ B のトンネル送信元であり、ルータ A のトンネル宛先です。

          router A:
          feature tunnel
          interface tunnel 0
            ip address 209.165.20.2/8
            tunnel source ethernet 1/2
            tunnel destination 192.0.2.2
            tunnel mode gre ip
          interface ethernet1/2
            ip address 192.0.2.55/8
          
          router B:
          feature tunnel 
          interface tunnel 0
            ip address 209.165.20.1/8
            tunnel source ethernet 1/3
            tunnel destination 192.0.2.55
            tunnel mode gre ip
          interface ethernet 1/3
          ip address 192.0.2.2/8

          IP トンネルの関連資料

          関連トピック 参照先

          IP トンネル コマンド

          『Cisco Nexus 3000 Series Interfaces Command Reference』

          IP トンネルの標準

          この機能でサポートされる新規または改訂された標準規格はありません。また、この機能による既存の標準規格サポートの変更はありません。

          IP トンネル設定の機能履歴

          表 2 IP トンネル設定の機能履歴

          機能名

          リリース

          機能情報

          IP トンネル

          5.0(3)U4(1)

          この機能が導入されました。