Cisco Nexus 3000 シリーズ NX-OS システム管理コンフィギュレーション ガイド リリース 5.0(3)U4(1)
ERSPAN の設定
ERSPAN の設定
発行日;2012/11/14   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

ERSPAN の設定

この章は、次の内容で構成されています。

ERSPAN について

Cisco NX-OS システムは、送信元ポートと宛先ポートの両方で ERSPAN(Encapsulated Remote Switching Port Analyser)機能をサポートします。 ERSPAN は、ミラーリングされたトラフィックを IP ネットワーク経由で転送します。 トラフィックは送信元ルータでカプセル化され、ネットワーク全体にわたって転送されます。 パケットは宛先ルータでカプセル化解除されてから、宛先インターフェイスに送信されます。

ERSPAN は、ERSPAN 送信元セッション、ルーティング可能な ERSPAN GRE(Generic Routing Encapsulation)カプセル化トラフィック、および ERSPAN 宛先セッションで構成されています。 異なるスイッチで ERSPAN 送信元セッションおよび宛先セッションを個別に設定します。

ERSPAN 送信元

トラフィックをモニタできるモニタ元インターフェイスのことを ERSPAN 送信元と呼びます。 送信元では、監視するトラフィックを指定し、さらに入力、出力、または両方向のトラフィックをコピーするかどうかを指定します。 ERSPAN 送信元には次のものが含まれます。
  • イーサネット ポートおよびポート チャネル。
  • VLAN:VLAN が ERSPAN 送信元として指定されている場合、VLAN でサポートされているすべてのインターフェイスが ERSPAN 送信元となります。
ERSPAN 送信元ポートには、次の特性があります。
  • 送信元ポートとして設定されたポートを宛先ポートとしても設定することはできません。
  • ERSPAN は送信元に関係なく、スーパーバイザによって生成されるパケットをモニタしません。

ERSPAN 宛先

宛先ポートは ERSPAN 送信元からコピーされたトラフィックを受信します。

ERSPAN 宛先ポートには、次の特性があります。
  • ERSPAN セッションの宛先には、アクセス モードまたはトランク モードのイーサネット ポートまたはポートチャネル インターフェイスが含まれます。
  • 宛先ポートとして設定されたポートを送信元ポートとしても設定することはできません。
  • 宛先ポートは、一度に 1 つの ERSPAN セッションだけで設定できます。
  • 宛先ポートは、どのスパニングツリー インスタンスにも、どのレイヤ 3 プロトコルにも参加しません。
  • モニタ宛先ポートでは、入力オプションおよび入力ラーニング オプションはサポートされていません。
  • HIF ポート チャネルおよびファブリック ポート チャネルのポートは、SPAN 宛先ポートとしてサポートされていません。

ERSPAN セッション

モニタする送信元と宛先を指定する ERSPAN セッションを作成できます。

ERSPAN 送信元セッションを設定する場合は、宛先 IP アドレスを設定する必要があります。 ERSPAN 宛先セッションを設定する場合は、送信元 IP アドレスを設定する必要があります。 送信元セッションのプロパティについては ERSPAN 送信元を、宛先セッションのプロパティについては ERSPAN 宛先を参照してください。


(注)  


すべてのスイッチにわたって同時に実行できるのは 2 つの ERSPAN または SPAN 送信元セッションだけです。 すべてのスイッチにわたって同時に実行できるのは 23 の ERSPAN 宛先セッションだけです。


次の図は、ERSPAN の設定を示しています。

図 1. ERSPAN の設定



マルチ ERSPAN セッション

最大 48 個の ERSPAN セッションを定義できますが、同時に実行できる ERSPAN または SPAN セッションは 2 個だけです。 未使用の ERSPAN セッションはシャット ダウンできます。

ERSPAN セッションのシャットダウンについては、ERSPAN セッションのシャットダウンまたはアクティブ化を参照してください。

ハイ アベイラビリティ

ERSPAN 機能はステートレス リスタートおよびステートフル リスタートをサポートします。 リブートまたはスーパーバイザ スイッチオーバー後に、実行コンフィギュレーションを適用します。

ERSPAN のライセンス要件

次の表に、この機能のライセンス要件を示します。

製品 ライセンス要件

Cisco NX-OS

ERSPAN にはライセンスは不要です。 ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。 Cisco NX-OS のライセンス方式の詳細については、『License and Copyright Information for Cisco NX-OS Software』を参照してください。次の URL で入手できます。http:/​/​www.cisco.com/​en/​US/​docs/​switches/​datacenter/​sw/​4_0/​nx-os/​license_agreement/​nx-ossw_​lisns.html)を参照してください。

ERSPAN の前提条件

ERSPAN の前提条件は、次のとおりです。

•各デバイス上で、まず所定の ERSPAN 設定をサポートするポートのイーサネット インターフェイスを設定する必要があります。

ERSPAN の注意事項および制約事項

ERSPAN 設定時の注意事項と制限事項は次のとおりです。

  • ERSPAN は次をサポートしています。
    • 4 ~ 6 トンネルから
    • 非トンネル パケット
    • IP-in-IP トンネル
    • IPv4 トンネル(制限あり)
    • ERSPAN 送信元セッション タイプ(パケットは GRE トンネル パケットとしてカプセル化され、IP ネットワーク上で送信されます。 ただし、他のシスコ デバイスとは異なり、ERSPAN ヘッダーはパケットに追加されません。)
    • ERSPAN 宛先セッション タイプ(ただし、ERSPAN パケットをカプセル化解除するためのサポートは使用できません。 カプセル化されたパケット全体が、ERSPAN 終端ポイントにある前面パネル ポートにスパンされます。)
  • カプセル化されたミラー パケットがレイヤ 2 の MTU チェックに失敗すると、ERSPAN パケットはドロップされます。
  • 出力カプセル化には、112 バイトの制限があります。 この制限を超えるパケットはドロップされます。 このシナリオは、トンネルとミラーリングが混在しているときに発生することがあります。
  • ERSPAN セッションは複数のローカル セッションで共有されます。 最大 18 セッションが設定できます。ただし、同時に動作できるのは最大 4 セッションのみです。 受信ソースと送信ソースの両方が同じセッションで設定されている場合、2 セッションのみが動作できます。
  • NX-OS 5.0(3) U 2(2) をインストールし、ERSPAN を設定し、その後でソフトウェアを以前のバージョンにダウングレードすると、ERSPAN の設定は失われます。 この状況は、ERSPAN が NX-OS 5.0(3) U 2(2) よりも前のバージョンでサポートされていないため発生します。 同様の SPAN の制約事項については、SPAN についてSPAN の注意事項および制約事項を参照してください。
  • ERSPAN、および ERSPAN ACL は、スーパーバイザが生成したパケットではサポートされません。
  • ERSPAN と ERSPAN ACL セッションは、宛先ルータで同様に終了します。
  • ERSPAN は、管理ポートではサポートされません。
  • 宛先ポートは、一度に 1 つの ERSPAN セッションだけで設定できます。
  • ポートをソース ポートと宛先ポートの両方として設定することはできません。
  • 1 つの ERSPAN セッションに、次の送信元を組み合わせて使用できます。
    • イーサネット ポートまたはポート チャネル(サブ インターフェイスを除く)。
    • ポート チャネル サブインターフェイスに割り当てることのできる VLAN またはポート チャネル。
    • コントロール プレーン CPU へのポート チャネル。

      (注)  


      ERSPAN は送信元に関係なく、スーパーバイザによって生成されるパケットをモニタしません。


  • 宛先ポートはスパニングツリー インスタンスまたはレイヤ 3 プロトコルに参加しません。
  • ERSPAN セッションに、送信方向または送信および受信方向でモニタされている送信元ポートが含まれている場合、パケットが実際にはその送信元ポートで送信されなくても、これらのポートを受け取るパケットが ERSPAN の宛先ポートに複製される可能性があります。 送信元ポートでこの動作が生じる例の一部を示します。
    • フラッディングから発生するトラフィック
    • ブロードキャストおよびマルチキャスト トラフィック
  • 入力と出力の両方が設定されている VLAN ERSPAN セッションでは、パケットが同じ VLAN 上でスイッチングされる場合に、宛先ポートから 2 つのパケット(入力側から 1 つ、出力側から 1 つ)が転送されます。
  • VLAN ERSPAN がモニタするのは、VLAN のレイヤ 2 ポートを出入りするトラフィックだけです。
  • パケットがミラーリングされ、ERSPAN 宛先ポートに送信された場合、GRE ヘッダーは削除されません。 パケットは、GRE ペイロードとして元のパケットを含む GRE パケットとして GRE ヘッダーとともに送信されます。

デフォルト設定値

次の表に、ERSPAN パラメータのデフォルト設定を示します。

表 1 デフォルトの ERSPAN パラメータ

パラメータ

デフォルト

ERSPAN セッション

シャット ステートで作成されます。

ERSPAN の設定

ERSPAN 送信元セッションの設定

ERSPAN セッションを設定できるのはローカル デバイス上だけです。 デフォルトでは、ERSPAN セッションはシャット ステートで作成されます。

送信元には、イーサネット ポート、ポート チャネル、および VLAN を指定できます。 1 つの ERSPAN セッションに、イーサネット ポートまたは VLAN を組み合わせた送信元を使用できます。


(注)  


ERSPAN は送信元に関係なく、スーパーバイザによって生成されるパケットをモニタしません。


手順
     コマンドまたはアクション目的
    ステップ 1config t


    例:
    switch# config t
    switch(config)#
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2monitor erspan origin ip-address ip-address global


    例:
    switch(config)# monitor erspan origin 
    ip-address 10.0.0.1 global
     

    ERSPAN のグローバルな送信元 IP アドレスを設定します。

     
    ステップ 3no monitor session {session-number | all}


    例:
    switch(config)# no monitor session 3
     

    指定した ERSPAN セッションのコンフィギュレーションを消去します。 新しいセッション コンフィギュレーションは、既存のセッション コンフィギュレーションに追加されます。

     
    ステップ 4monitor session {session-number | all} type erspan-source


    例:
    switch(config)# monitor session 3 type erspan-source
    switch(config-erspan-src)#
     

    ERSPAN 送信元セッションを設定します。

     
    ステップ 5description description


    例:
    switch(config-erspan-src)# description erspan_src_session_3
     

    セッションの説明を設定します。 デフォルトでは、説明は定義されません。 説明には最大 32 の英数字を使用できます。

     
    ステップ 6source {[interface [type slot/port[-port][, type slot/port[-port]]] [port-channel channel-number]] | [vlan {number | range}]} [rx | tx | both]


    例:
    switch(config-erspan-src)# source interface ethernet 2/1-3, ethernet 3/1 rx


    例:
    switch(config-erspan-src)# source interface port-channel 2


    例:
    switch(config-erspan-src)# source interface sup-eth 0 both


    例:
    switch(config-erspan-src)# source vlan 3, 6-8 tx


    例:
    switch(config-monitor)# source interface ethernet 101/1/1-3
     

    送信元およびパケットをコピーするトラフィックの方向を設定します。 イーサネット ポート範囲、ポート チャネル、または VLAN 範囲を入力できます。

    送信元は 1 つ設定することも、またはカンマで区切った一連のエントリとして、または番号の範囲として、複数設定することもできます。 最大 128 のインターフェイスを指定できます。 VLAN 範囲の詳細については、『Cisco Nexus 3000 Series NX-OS Layer 2 Switching Configuration Guide, Release 5.x』を参照してください。

    入力、出力、またはその両方としてコピーするトラフィックの方向を指定できます。 デフォルトは both です。

     
    ステップ 7ステップ 6 を繰り返して、すべての ERSPAN 送信元を設定します。  (任意)

     
    ステップ 8destination ip ip-address


    例:
    switch(config-erspan-src)# destination ip 10.1.1.1
     

    ERSPAN セッションの宛先 IP アドレスを設定します。 ERSPAN 送信元セッションごとに宛先 IP アドレスが 1 つだけサポートされます。

     
    ステップ 9vrf vrf-name


    例:
    switch(config-erspan-src)# vrf default
     

    ERSPAN 送信元セッションがトラフィックの転送に使用する VRF を設定します。

     
    ステップ 10ip ttl ttl-number


    例:
    switch(config-erspan-src)# ip ttl 25
     
    (任意)

    ERSPAN トラフィックの IP 存続可能時間(TTL)値を設定します。 指定できる範囲は 1 ~ 255 です。

     
    ステップ 11ip dscp dscp-number


    例:
    switch(config-erspan-src)# ip dscp 42
     
    (任意)

    ERSPAN トラフィックのパケットの DiffServ コード ポイント(DSCP)値を設定します。 指定できる範囲は 0 ~ 63 です。

     
    ステップ 12no shut


    例:
    switch(config-erspan-src)# no shut
     
    ERSPAN 送信元セッションをイネーブルにします。 デフォルトでは、セッションはシャット ステートで作成されます。
    (注)     

    同時に実行できる ERSPAN 送信元セッションは 2 つだけです。

     
    ステップ 13show monitor session {all | session-number | range session-range}


    例:
    switch(config-erspan-src)# show monitor session 3
     
    (任意)

    ERSPAN セッション設定を表示します。

     
    ステップ 14show running-config monitor


    例:
    switch(config-erspan-src)# show running-config monitor
     
    (任意)

    実行 ERSPAN コンフィギュレーションを表示します。

     
    ステップ 15show startup-config monitor


    例:
    switch(config-erspan-src)# show startup-config monitor
     
    (任意)

    ERSPAN のスタートアップ コンフィギュレーションを表示します。

     
    ステップ 16copy running-config startup-config


    例:
    switch(config-erspan-src)# copy running-config startup-config
     
    (任意)

    実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

     

    ERSPAN 宛先セッションの設定

    ERSPAN 宛先セッションを送信元 IP アドレスからローカル デバイス上の宛先ポートにパケットをコピーするように設定できます。 デフォルトでは、ERSPAN 宛先セッションはシャット ステートで作成されます。

    はじめる前に

    すでにモニタ モードで宛先ポートが設定されていることを確認します。

    手順
       コマンドまたはアクション目的
      ステップ 1config t


      例:
      switch# config t
      switch(config)#
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2 interface ethernet slot/port[-port]


      例:
      switch(config)# interface ethernet 2/5
      switch(config-if)#
       

      選択したスロットおよびポートまたはポート範囲で、インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 3switchport


      例:
      switch(config-if)# switchport
       

      選択したスロットおよびポートまたはポート範囲でスイッチポート パラメータを設定します。

       
      ステップ 4switchport mode [access | trunk]


      例:
      switch(config-if)# switchport mode trunk
       
      選択したスロットおよびポートまたはポート範囲で次のスイッチポート モードを設定します。
      • access
      • trunk
       
      ステップ 5switchport monitor


      例:
      switch(config-if)# switchport monitor
       

      ERSPAN 宛先としてスイッチポート インターフェイスを設定します。

       
      ステップ 6ステップ 2 ~ 5 を繰り返して、追加の ERSPAN 宛先でモニタリングを設定します。 

       
      ステップ 7no monitor session {session-number | all}


      例:
      switch(config-if)# no monitor session 3
       

      指定した ERSPAN セッションのコンフィギュレーションを消去します。 新しいセッション コンフィギュレーションは、既存のセッション コンフィギュレーションに追加されます。

       
      ステップ 8monitor session {session-number | all} type erspan-destination


      例:
      switch(config-if)# monitor session 3 type erspan-destination
      switch(config-erspan-dst)#
       

      ERSPAN 宛先セッションを設定します。

       
      ステップ 9description description


      例:
      switch(config-erspan-dst)# description erspan_dst_session_3
       

      セッションの説明を設定します。 デフォルトでは、説明は定義されません。 説明には最大 32 の英数字を使用できます。

       
      ステップ 10source ip ip-address


      例:
      switch(config-erspan-dst)# source ip 10.1.1.1
       

      ERSPAN セッションの送信元 IP アドレスを設定します。 ERSPAN 宛先セッションごとに送信元 IP アドレスが 1 つだけサポートされます。

       
      ステップ 11destination {[interface [type slot/port[-port][, type slot/port[-port]]] [port-channel channel-number]]}


      例:
      switch(config-erspan-dst)# destination interface ethernet 2/5, ethernet 3/7
       
      コピーされた送信元パケットの宛先を設定します。 1 つ以上のインターフェイスをカンマで区切った一連のエントリとして設定できます。
      (注)     

      トランク ポートとして宛先ポートを設定できます。

       
      ステップ 12ステップ 11 を繰り返して、すべての ERSPAN 宛先を設定します。  (任意)

       
      ステップ 13no shut


      例:
      switch(config)# no shut
       
      ERSPAN 宛先セッションをイネーブルにします。 デフォルトでは、セッションはシャット ステートで作成されます。
      (注)     

      同時に実行できる ERSPAN 宛先セッションは 23 個だけです。

       
      ステップ 14show monitor session {all | session-number | range session-range}


      例:
      switch(config)# show monitor session 3
       
      (任意)

      ERSPAN セッション設定を表示します。

       
      ステップ 15show running-config monitor


      例:
      switch(config-erspan-src)# show running-config monitor
       
      (任意)

      実行 ERSPAN コンフィギュレーションを表示します。

       
      ステップ 16show startup-config monitor


      例:
      switch(config-erspan-src)# show startup-config monitor
       
      (任意)

      ERSPAN のスタートアップ コンフィギュレーションを表示します。

       
      ステップ 17copy running-config startup-config


      例:
      switch(config-erspan-src)# copy running-config startup-config
       
      (任意)

      実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

       

      ERSPAN セッションのシャットダウンまたはアクティブ化

      ERSPAN セッションをシャットダウンすると、送信元から宛先へのパケットのコピーを切断することができます。 同時に実行できる ERSPAN セッションは、Cisco Nexus 5000 シリーズ スイッチでは 2 つだけであるため、セッションをシャットダウンすることにより、ハードウェア リソースを解放して別のセッションをイネーブルにすることができます。 デフォルトでは、ERSPAN セッションはシャット ステートで作成されます。

      送信元から宛先へのパケットのコピーをアクティブにするために、ERSPAN セッションをイネーブルにすることができます。 すでにイネーブルになっているが、動作状況がダウンの ERSPAN セッションをイネーブルにするには、そのセッションをいったんシャットダウンしてから、改めてイネーブルにする必要があります。 ERSPAN セッション ステートをシャットダウンしてイネーブルにするには、グローバルまたはモニタ コンフィギュレーション モードのどちらのコマンドでも使用できます。

      手順
         コマンドまたはアクション目的
        ステップ 1configuration terminal


        例:
        switch# configuration terminal
        switch(config)#
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2 monitor session {session-range | all} shut


        例:
        switch(config)# monitor session 3 shut
         

        指定された ERSPAN セッションをシャットダウンします。 セッションの範囲は 1 ~ 48 です。 デフォルトでは、セッションはシャット ステートで作成されます。 同時に実行できるセッションは 2 つだけです。

         
        ステップ 3no monitor session {session-range | all} shut


        例:
        switch(config)# no monitor session 3 shut
         
        指定された ERSPAN セッションを再開(イネーブルに)します。 セッションの範囲は 1 ~ 48 です。 デフォルトでは、セッションはシャット ステートで作成されます。 同時に実行できるセッションは 2 つだけです。
        (注)     

        モニタ セッションがイネーブルになっているが、その動作状況がダウンの場合に、そのセッションをイネーブルにするには、最初に monitor session shut コマンドを指定してから、no monitor session shut コマンドを続ける必要があります。

         
        ステップ 4monitor session session-number type erspan-source


        例:
        switch(config)# monitor session 3 type erspan-source
        switch(config-erspan-src)#
         

        ERSPAN 送信元タイプのモニタ コンフィギュレーション モードを開始します。 新しいセッション コンフィギュレーションは、既存のセッション コンフィギュレーションに追加されます。

         
        ステップ 5monitor session session-number type erspan-destination


        例:
        switch(config-erspan-src)# monitor session 3 type erspan-destination
         

        ERSPAN 宛先タイプのモニタ コンフィギュレーション モードを開始します。

         
        ステップ 6shut


        例:
        switch(config-erspan-src)# shut
         

        ERSPAN セッションをシャットダウンします。 デフォルトでは、セッションはシャット ステートで作成されます。

         
        ステップ 7no shut


        例:
        switch(config-erspan-src)# no shut
         

        ERSPAN セッションをイネーブルにします。 デフォルトでは、セッションはシャット ステートで作成されます。

         
        ステップ 8show monitor session all


        例:
        switch(config-erspan-src)# show monitor session all
         
        (任意)

        ERSPAN セッションのステータスを表示します。

         
        ステップ 9show running-config monitor


        例:
        switch(config-erspan-src)# show running-config monitor
         
        (任意)

        実行 ERSPAN コンフィギュレーションを表示します。

         
        ステップ 10show startup-config monitor


        例:
        switch(config-erspan-src)# show startup-config monitor
         
        (任意)

        ERSPAN のスタートアップ コンフィギュレーションを表示します。

         
        ステップ 11copy running-config startup-config


        例:
        switch(config-erspan-src)# copy running-config startup-config
         
        (任意)

        実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

         

        ERSPAN 設定の確認

        ERSPAN の設定を表示するには、次のいずれかの作業を行います。

        コマンド

        目的

        show monitor session {all | session-number | range session-range}

        ERSPAN セッション設定を表示します。

        show running-config monitor

        実行 ERSPAN コンフィギュレーションを表示します。

        show startup-config monitor

        ERSPAN のスタートアップ コンフィギュレーションを表示します。

        ERSPAN の設定例

        ERSPAN 送信元セッションの設定例

        次に、ERSPAN 送信元セッションを設定する例を示します。

        switch# config t
        switch(config)# interface e14/30
        switch(config-if)# no shut
        switch(config-if)# exit
        switch(config)# monitor erspan origin ip-address 3.3.3.3 global
        switch(config)# monitor session 1 type erspan-source
        switch(config-erspan-src)# source interface e14/30
        switch(config-erspan-src)# ip ttl 16
        switch(config-erspan-src)# ip dscp 5
        switch(config-erspan-src)# vrf default
        switch(config-erspan-src)# destination ip 9.1.1.2
        switch(config-erspan-src)# no shut
        switch(config-erspan-src)# exit
        switch(config)# show monitor session 1

        ERSPAN 宛先セッションの設定例

        次に、ERSPAN 宛先セッションを設定する例を示します。

        switch# config t
        switch(config)# interface e14/29
        switch(config-if)# no shut
        switch(config-if)# switchport
        switch(config-if)# switchport monitor
        switch(config-if)# exit
        switch(config)# monitor session 2 type erspan-destination
        switch(config-erspan-dst)# source ip 9.1.1.2
        switch(config-erspan-dst)# destination interface e14/29
        switch(config-erspan-dst)# no shut
        switch(config-erspan-dst)# exit
        switch(config)# show monitor session 2

        その他の参考資料

        関連資料

        関連項目

        マニュアル タイトル

        ERSPAN コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

        Cisco Nexus 3000 Series NX-OS System Management Command Reference』『Cisco Nexus 5000 Series NX-OS System Management Command Reference