Cisco Nexus 3000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 5.0(3)U3(1)
OSPFv2 の双方向フォワーディング検出の設定
OSPFv2 の双方向フォワーディング検出の設定
発行日;2012/07/19 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

OSPFv2 の双方向フォワーディング検出の設定

BFD について

非同期モード

BFD の障害検出

BFD エコー機能

Security

仮想化のサポート

BFD のライセンス要件

BFD の前提条件

注意事項および制約事項

デフォルト設定

BFD の設定

設定階層

BFD 設定のタスク フロー

BFD 機能のイネーブル化

グローバルな BFD パラメータの設定

インターフェイスでの BFD の設定

ポート チャネルの BFD の設定

BFD エコー機能の設定

サブインターフェイスの BFD の最適化

OSPFv2 での BFD の設定

BFD 設定の確認

BFD のモニタ

BFD の機能の履歴

OSPFv2 の双方向フォワーディング検出の設定

この章では、OSPFv2 の双方向フォワーディング検出(BFD)を設定する方法について説明します。

この章は、次の内容で構成されています。

「BFD について」

「BFD のライセンス要件」

「BFD の前提条件」

「注意事項および制約事項」

「デフォルト設定」

「BFD の設定」

「BFD 設定の確認」

「BFD のモニタ」

「BFD の機能の履歴」

BFD について

BFD は、メディア タイプ、カプセル化、トポロジ、およびルーティング プロトコルの転送パス障害を高速で検出するように設計された検出プロトコルです。BFD を使用することで、さまざまなプロトコルの Hello メカニズムにより、変動速度ではなく一定速度で転送パス障害を検出できます。BFD はプロファイリングおよびプランニングを簡単にし、再コンバージェンス時間の一貫性を保ち、予測可能にします。

BFD では、2 台の隣接デバイス間のサブセカンド障害を検出します。

ここでは、次の内容について説明します。

「非同期モード」

「BFD の障害検出」

「BFD エコー機能」

「Security」

非同期モード

Cisco NX-OS は、BFD 非同期モードをサポートします。BFD 非同期モードでは、2 個の隣接するデバイス間で BFD 制御パケットが送信され、デバイス間の BFD ネイバー セッションがアクティベートされ、維持されます。両方のデバイス(または BFD ネイバー)で BFD を設定できます。適切なプロトコルで一度 BFD がイネーブルになると、Cisco NX-OS は BFD セッションを作成し、BFD セッション パラメータをネゴシエートし、BFD 制御パケットをネゴシエートされた間隔で各 BFD ネイバーに送信し始めます。BFD セッション パラメータは、次のとおりです。

目的の最小送信間隔:このデバイスが BFD Hello メッセージを送信する間隔。

必要最小受信間隔:このデバイスが別の BFD デバイスからの BFD Hello メッセージを受け付ける最小間隔。

検出乗数:転送パスの障害を検出するまでに喪失した、別の BFD デバイスからの BFD Hello メッセージの数。

次の図は、BFD セッションがどのように確立されているかを示します。この図は、OSPF と BFD を実行する 2 台のルータがある単純なネットワークを示します。OSPF がネイバーを検出すると(1)、OSPF 隣接ルータで BFD ネイバー セッションを開始する要求が、ローカル BFD プロセスに送信されます(2)。これで、OSPF 隣接ルータとの BFD ネイバー セッションが確立されました(3)。

図 10-1 BFD ネイバー関係の確立

 

BFD の障害検出

一度 BFD セッションが確立され、タイマー ネゴシエーションが終了すると、BFD ネイバーは、より速い速度の場合を除き IGP Hello プロトコルと同じ動作をする BFD 制御パケットを送信し、活性度を検出します。BFD は障害を検出しますが、プロトコルが障害の発生したピアをバイパスするための処置を行う必要があります。

BFD は転送パスに障害を検出したとき、障害検出通知を BFD 対応プロトコルに送信します。ローカル デバイスは、プロトコル再計算プロセスを開始してネットワーク全体の収束時間を削減できます。

そのプロセスは次のとおりです。

1. BFD 隣接ルータでの BFD ネイバー セッションが停止されます。

2. BFD はローカル BFD プロセスに BFD ネイバーに接続できなくなったことを通知します。

3. ローカル BFD プロセスは BFD ネイバー関係を解除します。

4. 代替パスが使用可能な場合、ルータはただちにそのパスでコンバージェンスを開始します。

次の図は、ネットワークで障害が発生した場合を示します(1)。OSPF ネイバーとの BFD ネイバー セッションが停止されます(2)。BFD では、BFD ネイバーが到達不可能になったことをローカル Open Shortest Path First(OSPF)プロセスに通知します(3)。ローカル OSPF プロセスは OSPF ネイバー関係を解除します(4)。代替パスが使用可能な場合、ルータはただちにそのパスでコンバージェンスを開始します。


) BFD 障害検出は 1 秒未満で行われます。これは OSPF Hello メッセージが同じ障害を検出するより速い必要があります。


図 10-2 OSPF ネイバー関係の解除

 

BFD エコー機能

BFD エコー機能は、転送エンジンからリモート BFD ネイバーにエコー パケットを送信します。BFD ネイバーは検出を実行するために同じパスに沿ってエコー パケットを返送します。BFD ネイバーは、エコー パケットの実際の転送に参加しません。エコー機能および転送エンジンが検出の処理を行います。BFD はエコー機能がイネーブルになっている場合に非同期セッションの速度を低下させ、2 台の BFD ネイバー間で送信される BFD 制御パケット数を減らすために、slow timer を使用できます。また、転送エンジンは、リモート システムを含めないでリモート(ネイバー)システムの転送パスをテストするので、パケット間遅延の変動が少なくなり、障害検出時間が短縮されます。

エコー機能は BFD ネイバーの両方がエコー機能を実行しているときに対称です。

Security

Cisco NX-OS は BFD パケットを隣接する BFD ピアから受信したことを確認するためにパケットの存続可能時間(TTL)値を使用します。すべての非同期およびエコー要求パケットの場合、BFD ネイバーは TTL 値を 255 に設定し、ローカル BFD プロセスは着信パケットを処理する前に TTL 値を 255 として確認します。エコー応答パケットの場合、BFD は TTL 値を 254 に設定します。

仮想化のサポート

BFD では、仮想ルーティングおよび転送(VRF)インスタンスをサポートしています。VRF は仮想化デバイス コンテキスト(VDC)内にあります。デフォルトでは、特に別の VDC および VRF を設定しない限り、Cisco NX-OS によりデフォルト VDC およびデフォルト VRF が使用されます。

BFD のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

BFD にはライセンスは不要です。ライセンス パッケージに含まれていない機能はすべて Cisco NX-OS システム イメージにバンドルされており、追加費用は一切発生しません。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

BFD の前提条件

BFD には、次の前提条件があります。

BFD 機能をイネーブルにする必要があります(「BFD 機能のイネーブル化」を参照)。

BFD をイネーブルにする任意のクライアント プロトコルでは、そのクライアント プロトコルの BFD をイネーブルにします。「OSPFv2 での BFD の設定」を参照してください。

BFD 対応インターフェイスでインターネット制御メッセージ プロトコル(ICMP)リダイレクト メッセージをディセーブルにします。

設定作業とともに一覧表示されているその他の詳細な前提条件を参照してください。

注意事項および制約事項

BFD 設定時の注意事項と制限事項は次のとおりです。

BFD は BFD バージョン 1 をサポートします。

BFD は IPv4 をサポートします。

BFD は、シングルホップ BFD をサポートします。

OSPFv2 の BFD は、シングルホップ OSPFv2 ピアおよびシングルホップ OSPFv2 ピアをサポートします。

BFD は、次のレイヤ 3 インターフェイスをサポートします。物理インターフェイス、ポート チャネル、サブインターフェイス、および VLAN インターフェイス(SVI)。

OSPFv2 の BFD は、ポート チャネル上の BFD の認証またはリンクごとの BFD セッションはサポートしません。

BFD はレイヤ 3 隣接情報に応じて、レイヤ 2 のトポロジ変更を含むトポロジ変更を検出します。レイヤ 3 隣接情報が使用できない場合、VLAN インターフェイス(SVI)の BFD セッションはレイヤ 2 トポロジのコンバージェンス後に稼動しない可能性があります。

ポート チャネル設定の制限事項

BFD で使用されるレイヤ 3 ポート チャネルでは、ポート チャネルの Link Aggregation and Control Protocol(LACP)をイネーブルにする必要があります。

スイッチ仮想インターフェイス(SVI)セッションによって使用されるレイヤ 2 ポート チャネルでは、ポート チャネルの LACP をイネーブルにする必要があります。

SVI の制限事項

ASIC リセットにより他のポートのトラフィックが中断されます。このイベントは、その他のポートの SVI セッションがフラップする原因になることがあります。

トポロジを変更すると(たとえば、VLAN へのリンクの追加または削除、レイヤ 2 ポート チャネルからのメンバの削除など)、SVI セッションが影響を受ける場合があります。SVI セッションはダウンした後、トポロジ ディスカバリの終了後に起動する場合があります。


ヒント SVI のセッションがフラップしないようにし、トポロジを変更する必要がある場合は、変更を加える前に BFD 機能をディセーブルにして、変更後、BFD を再度イネーブルにできます。また、大きな値(たとえば、5 秒)になるように BFD タイマーを設定し、上記のイベントの完了後に高速なタイマーに戻すこともできます。


BFD 制御パケットの処理制限(Rx および Tx)は 544 パケット/秒(PPS)です。


) 制御パケットの処理制限に到達すると、新しく設定された BFD セッションがダウン状態になります。LOG_NOTICE レベルの Syslog メッセージは、BFD セッションが再度インストールされた後に記録されます。次に、Syslog メッセージの例を示します。

2010 Jun 25 00:23:47 BLR-QS1 %BFD-5-SESSION_NO_RESOURCES: No resource for session to neighbor 251.1.1.2 on interface Eth1/29.14


Cisco NX-OS は、BFD パケット処理のために CPU の負荷を軽減するために互換性のあるモジュールへ BFD 動作を配布しません。

BFD はステートレス リスタートおよびインサービス ソフトウェア アップグレード(ISSU)をサポートしません。

ポート チャネルを介して到達可能なピアの BFD をイネーブルにする場合は、ポート チャネルで LACP を設定する必要があります。

BFD エコー モードおよびユニキャスト リバース パス転送(URPF)は相互に排他的で、BFD インターフェイスで両方をイネーブルにできません。BFD に対するインターフェイスを設定する場合は、BFD エコー モードまたは URPF のいずれかをディセーブルにする必要があります。

デフォルト設定

表 10-1 に、BFD パラメータのデフォルト設定を示します。

 

表 10-1 デフォルトの BFD パラメータ

パラメータ
デフォルト

BFD 機能

ディセーブル

必要最小受信間隔

250 ミリ秒

目的の最小送信間隔

250 ミリ秒

検出乗数

3

エコー機能

イネーブル

モード

非同期

ポート チャネル

論理モード(送信元/宛先ペアのアドレスごとに 1 セッション)

slow timer

2000 ミリ秒

サブインターフェイスの最適化

ディセーブル

BFD の設定

ここでは、次の内容について説明します。

「設定階層」

「BFD 設定のタスク フロー」

「BFD 機能のイネーブル化」

「グローバルな BFD パラメータの設定」

「インターフェイスでの BFD の設定」

「ポート チャネルの BFD の設定」

「BFD エコー機能の設定」

「サブインターフェイスの BFD の最適化」

「OSPFv2 での BFD の設定」

設定階層

グローバル レベル、VRF のレベル、インターフェイスまたはポート チャネル レベル、またはサブインターフェイス レベルで BFD を設定できます(物理インターフェイスとポート チャネルの場合)。VRF の設定はグローバル設定よりも優先されます。インターフェイスまたはポート チャネルの設定は、VRF またはグローバル設定よりも優先されます。サポートされているインターフェイス上で、サブインターフェイス レベルの設定は、サブインターフェイスの最適化がイネーブルになっていない限りインターフェイスまたはポート チャネル設定よりも優先されます。詳細については、「サブインターフェイスの BFD の最適化」を参照してください。

ポート チャネルのメンバである物理ポートについては、メンバ ポートはマスター ポート チャネルの BFD 設定を継承します。メンバ ポート サブインターフェイスは、サブインターフェイスの最適化がイネーブルになっていない限りマスター ポート チャネルの BFD 設定より優先することができます。

BFD 設定のタスク フロー

BFD の設定には、次の作業を行います。


ステップ 1 BFD 機能のイネーブル化.

ステップ 2 グローバルな BFD パラメータの設定または インターフェイスでの BFD の設定

ステップ 3 OSPFv2 での BFD の設定.


 

BFD 機能のイネーブル化

手順の概要

1. configure terminal

2. feature bfd

3. (任意) show feature | include bfd

4. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

feature bfd

 

Example:

switch(config)# feature bfd

BFD 機能をイネーブルにします。

ステップ 3

show feature | include bfd

 

Example:

switch(config)# show feature bfd

 

(任意)BFD 機能を表示します。

ステップ 4

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

no feature bfd コマンドを使用して、BFD 機能をディセーブルにし、関連するコンフィギュレーションをすべて削除します。

 

コマンド
目的

no feature bfd

 

Example:

switch(config)# no feature bfd

BFD 機能をディセーブルにして、関連するすべての設定を削除します。

グローバルな BFD パラメータの設定

デバイスのすべての BFD セッションの BFD セッション パラメータを設定できます。BFD セッション パラメータは、スリーウェイ ハンドシェイクの BFD ピア間でネゴシエートされます。

インターフェイスのグローバルなセッション パラメータを無効にするには、「インターフェイスでの BFD の設定」を参照してください。

はじめる前に

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. bfd interval mintx min_rx msec multiplier value

3. bfd slow-timer [ interval ]

4. (任意) show running-config bfd

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

bfd interval mintx min_rx msec multiplier value

 

Example:

switch(config)# bfd interval 250 min_rx 250 multiplier 3

デバイスのすべての BFD セッションの BFD セッション パラメータを設定します。インターフェイスで BFD セッション パラメータを設定することにより、これらの値を無効にすることができます。 mintx および msec の範囲は 250 ~ 999 ミリ秒で、デフォルトは 250 です。乗数の範囲は 3 ~ 50 です。乗数のデフォルトは 3 です。

デフォルト設定に戻すには、 no bfd interval コマンドを使用します。

ステップ 3

bfd slow-timer [ interval ]

 

Example:

switch(config)# bfd slow-timer 2000.

エコー機能で使用される slow-timer を設定します。 interval はエコー機能がイネーブルの場合、BFD が新しいセッションを開始する速度および非同期セッションが BFD 制御パケットに使用する速度を決定します。slow-timer 値は新しい制御パケット間隔として使用されますが、エコー パケットは設定された BFD 間隔を使用します。エコー パケットはリンク障害検出に使用されますが、低速の制御パケットは BFD セッションを維持します。指定できる範囲は 1000 ~ 30000 ミリ秒です。デフォルトは 2000 です。デフォルト設定に戻すには、 no bfd slow-timer コマンドを使用します。

ステップ 4

show running-config bfd

 

Example:

switch(config)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

インターフェイスでの BFD の設定

インターフェイスのすべての BFD セッションの BFD セッション パラメータを設定できます。BFD セッション パラメータは、スリーウェイ ハンドシェイクの BFD ピア間でネゴシエートされます。

この設定は、設定されたインターフェイスのグローバル セッション パラメータより優先されます。

はじめる前に

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. interface int-if

3. bfd interval mintx min_rx msec multiplier value

4. (任意) show running-config bfd

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface int-if

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。「 ? 」 キーワードを使用してサポートされているインターフェイスを表示します。 int-if 引数の範囲は 1 ~ 48 です。

ステップ 3

bfd interval mintx min_rx msec multiplier value

 

Example:

switch(config-if)# bfd interval 250 min_rx 250 multiplier 3

インターフェイスのすべての BFD セッションの BFD セッション パラメータを設定します。これはグローバルな BFD セッション パラメータより優先されます。 mintx および msec の範囲は 250 ~ 999 ミリ秒で、デフォルトは 250 です。乗数の範囲は 3 ~ 50 です。乗数のデフォルトは 3 です。

デフォルト設定に戻すには、 no bfd interval コマンドを使用します。

ステップ 4

show running-config bfd

 

Example:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

ポート チャネルの BFD の設定

ポート チャネルのすべての BFD セッションの BFD セッション パラメータを設定できます。BFD セッション パラメータは、スリーウェイ ハンドシェイクの BFD ピア間でネゴシエートされます。

この設定は、設定されたポート チャネルのグローバル セッション パラメータより優先されます。ポート チャネルのメンバ ポートはメンバ ポートのサブインターフェイス レベルで BFD パラメータを設定しない限り、ポート チャネルの BFD セッション パラメータを継承します。その場合、サブインターフェイス最適化がイネーブルにされていなければ、メンバ ポート サブインターフェイスはサブインターフェイス BFD コンフィギュレーションを使用します。詳細については、「サブインターフェイスの BFD の最適化」を参照してください。

はじめる前に

BFD をイネーブルにする前に、ポート チャネルの Link Aggregation Control Protocol(LACP)がイネーブルにされていることを確認します。

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

手順の概要

1. configure terminal

2. interface port-channel number

3. (任意) bfd interval mintx min_rx msec multiplier value

4. (任意) show running-config bfd

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel number

 

Example:

switch(config)# interface port-channel 2

switch(config-if)#

ポート チャネル コンフィギュレーション モードを開始します。「 ? 」 キーワードを使用してサポートされている番号の範囲を表示します。 number の範囲は 1 ~ 4096 です。

ステップ 3

bfd interval mintx min_rx msec multiplier value

 

Example:

switch(config-if)# bfd interval 250 min_rx 250 multiplier 3

(任意)ポート チャネルのすべての BFD セッションの BFD セッション パラメータを設定します。これはグローバルな BFD セッション パラメータより優先されます。 mintx および msec の範囲は 250 ~ 999 ミリ秒で、デフォルトは 250 です。乗数の範囲は 3 ~ 50 です。乗数のデフォルトは 3 です。

デフォルト設定に戻すには、 no bfd interval コマンドを使用します。

ステップ 4

show running-config bfd

 

Example:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

BFD エコー機能の設定

BFD モニタ対象リンクの一端または両端で BFD エコー機能を設定できます。エコー機能は設定された slow timer に基づいて必要最小受信間隔を遅くします。RequiredMinEchoRx BFD セッション パラメータは、エコー機能がディセーブルの場合、ゼロに設定されます。slow timer は、エコー機能がイネーブルの場合、必要最小受信間隔になります。

はじめる前に

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバルな BFD パラメータの設定」または「インターフェイスでの BFD の設定」を参照してください。

インターネット制御メッセージ プロトコル(ICMP)のリダイレクト メッセージが BFD 対応インターフェイスでディセーブルであることを確認します。インターフェイスで no ip redirects コマンドを使用します。

手順の概要

1. configure terminal

2. bfd slow-timer echo-interval

3. interface int-if

4. bfd echo

5. (任意) show running-config bfd

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

bfd slow-timer echo-interval

 

Example:

switch(config)# bfd slow-timer 2000

エコー機能で使用される slow timer を設定します。 echo-interval 引数は BFD が新しいセッションを開始する速度を決定し、BFD エコー機能がイネーブルの場合に非同期セッションの速度を低下させるために使用されます。この値は、エコー機能がイネーブルの場合、必要最小受信間隔より優先されます。 echo-interval の範囲は 1000 ~ 30000 ミリ秒です。デフォルトは 2000 です。

デフォルト設定に戻すには、 no bfd slow-timer コマンドを使用します。

ステップ 3

interface int-if

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。「 ? 」 キーワードを使用してサポートされているインターフェイスを表示します。

ステップ 4

bfd echo

 

Example:

switch(config-if)# bfd echo

エコー機能をイネーブルにします。デフォルトはイネーブルです。

エコー機能をディセーブルにするには、 no bfd echo コマンドを使用します。

ステップ 5

show running-config bfd

 

Example:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

サブインターフェイスの BFD の最適化

サブインターフェイスで BFD を最適化できます。BFD により、設定されているすべてのサブインターフェイスのセッションが作成されます。BFD により、設定されている最小の VLAN ID を持つサブインターフェイスがマスター サブインターフェイスとして設定され、そのサブインターフェイスは親インターフェイスの BFD セッション パラメータを使用します。残りのサブインターフェイスは slow timer を使用します。最適化されたサブインターフェイス セッションでエラーが検出されると、BFD により、その物理インターフェイスのすべてのサブインターフェイスがダウンとマークされます。

はじめる前に

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバルな BFD パラメータの設定」または「インターフェイスでの BFD の設定」を参照してください。

これらのサブインターフェイスが別の Cisco NX-OS デバイスに接続するようにしてください。この機能は、Cisco NX-OS でだけサポートされます。

手順の概要

1. configure terminal

2. interface int-if

3. bfd optimize subinterface

4. (任意) show running-config bfd

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

interface int-if

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。「 ? 」 キーワードを使用してサポートされているインターフェイスを表示します。

ステップ 3

bfd optimize subinterface

 

Example:

switch(config-if)# bfd optimize subinterface

BFD 対応インターフェイスのサブインターフェイスを最適化します。デフォルトはディセーブルです。

最適化されたサブインターフェイスをディセーブルにするには、 no bfd optimize subinterface コマンドを使用します。

ステップ 4

show running-config bfd

 

Example:

switch(config-if)# show running-config bfd

(任意)BFD 実行コンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

OSPFv2 での BFD の設定

Open Shortest Path First Protocol(OSPFv2)で BFD を設定できます。

はじめる前に

BFD 機能をイネーブルにします。「BFD 機能のイネーブル化」を参照してください。

BFD セッション パラメータを設定します。「グローバルな BFD パラメータの設定」または「インターフェイスでの BFD の設定」を参照してください。

OSPFv2 機能をイネーブルにします。詳細については、『 Cisco Nexus 3000 Series NX-OS Unicast Routing Configuration Guide 』を参照してください。

手順の概要

1. configure terminal

2. router ospf as-number

3. neighbor { ip-address | ipv6-address } remote-as as-number

4. bfd

5. (任意) show running-config ospf

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

router ospf as-number

 

Example:

switch(config)# router ospf 64496

switch(config-router)#

OSPFv2 をイネーブルにし、ローカル OSPFv2 のスピーカに as-number を割り当てます。 as-number は 16 ビット整数または 32 ビット整数にできます。上位 16 ビット 10 進数と下位 16 ビット 10 進数による xx.xx という形式です。

ステップ 3

neighbor { ip-address | ipv6-address } remote-as as-number

 

Example:

switch(config-router)# neighbor 209.165.201.1 remote-as 64497

switch(config-router-neighbor)#

リモート OSPFv2 ピアの IPv4 アドレスまたは IPv6 アドレスおよび AS 番号を設定します。 ip-address の形式は x.x.x.x です。 ipv6-address の形式は A:B::C:D です。

ステップ 4

bfd

 

Example:

switch(config-router-neighbor)# bfd

この OSPFv2 ピアの BFD をイネーブルにします。デフォルト値はディセーブルです。

ステップ 5

interface int-if

 

Example:

switch(config-router)# interface ethernet 2/1

switch (config-router-if)#

インターフェイス コンフィギュレーション モードを開始します。「 ? 」キーワードを使用してサポートされているインターフェイスを表示します。

ステップ 6

[no] ip ospf bfd disable

 

Example:

switch(config-router-if)# ip ospf bfd disable

(任意)OSPFv2 インターフェイスの BFD をディセーブルにします。デフォルト値はイネーブルです。

ステップ 7

show running-config ospf

 

Example:

switch(config-router-neighbor)# show running-config ospf

(任意)OSPFv2 実行コンフィギュレーションを表示します。

ステップ 8

copy running-config startup-config

 

Example:

switch(config-router-neighbor)# copy running-config startup-config

(任意)この設定の変更を保存します。

BFD 設定の確認

BFD 設定情報を表示するには、次の作業のいずれかを行います。

コマンド
目的

show running-config bfd

実行 BFD コンフィギュレーションを表示します。

show startup-config bfd

次のシステム起動時に適用される BFD コンフィギュレーションを表示します。

これらのコマンド出力のフィールドの詳細については、『 Cisco Nexus 3000 Series NX-OS Unicast Routing Configuration Guide 』を参照してください。

BFD のモニタ

BFD を表示するには、次のコマンドを使用します。

 

コマンド
目的

show bfd neighbors [ application name ] [ details ]

OSPFv2 などのサポートされるアプリケーションの BFD に関する情報を表示します。

show bfd neighbors [ interface int-if ] [ details ]

インターフェイス上での OSPFv2 セッションに関する情報を表示します。

show bfd neighbors [ dest-ip ip-address ] [ src-ip ip-address ][ details ]

インターフェイス上の指定された OSPFv2 セッションに関する情報を表示します。

show bfd neighbors [ vrf vrf-name ] [ details ]

VRF の BFD に関する情報を表示します。

これらのコマンド出力のフィールドの詳細については、『 Cisco Nexus 3000 Series Command Reference, 』を参照してください。

BFD の機能の履歴

表 10-2 は、この機能のリリースの履歴です。

 

表 10-2 OSPFv2 機能の履歴

機能名
リリース
機能情報

OSPFv2 の BFD

5.0(3)U2(2)

OSPFv2 の BFD のサポートが追加されました。詳細については、「OSPFv2 の双方向フォワーディング検出の設定」を参照してください。

OSPFv2 の BFD

5.0(3)U2(2a)

LACP の設定、BFD エコー、および URFP の注意事項および制約事項が追加されました。詳細については、「注意事項および制約事項」を参照してください。