スイッチ : Cisco Nexus 2000 シリーズ ファブリック エクステンダ

Cisco Nexus B22 Fabric Extender for HP スタートアップ ガイド

Cisco Nexus B22 Fabric Extender for HP スタートアップ ガイド
発行日;2012/06/21 | 英語版ドキュメント(2012/03/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco Nexus B22 Fabric Extender for HP

Cisco Nexus B22 Fabric Extender for HP について

最新のオンライン マニュアルの検索

梱包内容

HP ブレード システムのアーキテクチャ

Cisco Nexus B22 Fabric Extender for HP の取り付け

NX-OS の更新

Cisco Nexus B22 Fabric Extender for HP の設定

のファブリック インターフェイスへの関連付け

のイーサネット インターフェイスへの関連付け

の EtherChannel への関連付け

とインターフェイスとの関連付けの解除

の設定

リンクの再配布

リンク数の変更

ピン接続順序の維持

情報の表示

設定情報の表示

シャーシ管理情報の表示

設定の確認

その他の情報

関連資料

テクニカル サポート

Hewlett Packard のサポートについて

シスコのテクニカル サポート

Cisco Nexus B22 Fabric Extender for HP
スタートアップ ガイド

本スタートアップ ガイドでは、Cisco Nexus B22 Fabric Extender for HP およびその使用を開始する方法について説明します。本製品は、HP では Cisco Fabric Extender for HP BladeSystem と呼ばれています。このスタートアップ ガイドは、次の内容で構成されています。

「Cisco Nexus B22 Fabric Extender for HP について」

「梱包内容」

「HP ブレード システムのアーキテクチャ」

「Cisco Nexus B22 Fabric Extender for HP の取り付け」

「NX-OS の更新」

「Cisco Nexus B22 Fabric Extender for HP の設定」

「設定の確認」

「HP Integrity Superdome 2 の場合、最小ファームウェア バンドルは 2.51.102 です。」

「関連資料」

「テクニカル サポート」

Cisco Nexus B22 Fabric Extender for HP について

Cisco Nexus B22 Fabric Extender for HP は、HP ブレード サーバ エッジに Cisco Nexus スイッチ ファブリックを拡張します。

Cisco Nexus B22 Fabric Extender は、親の Cisco Nexus 5000 シリーズ スイッチのリモート ラインカードとして動作します。この Fabric Extender は、基本的には親の Cisco Nexus スイッチ ファブリックの拡張機能であり、Fabric Extender と親の Cisco Nexus スイッチとともに分散モジュール システムを形成します。

最大 24 個の Cisco Nexus B22 Fabric Extender を 1 台の Nexus 5000 シリーズ スイッチに接続可能であり、1 つの分散モジュール システムを 384 HP ブレード サーバに拡張できます。

各 Cisco Nexus B22 Fabric Extender は、1 ギガビット イーサネットまたは 10 ギガビット イーサネットを介して、HP BladeSystem と HP Integrity Superdome 2 シャーシ内の最大 16 台のサーバに接続し、Cisco Nexus 5000 シリーズ スイッチへの 8 つの 10 ギガビット イーサネット ファブリック アップリンクを備えています。Cisco Nexus B22 と Cisco Nexus 5000 シリーズ スイッチ間のファブリック接続には、複数の低コストなオプションを利用できます。最大 10 メートルの低コスト接続には Twin-ax 銅線ケーブルを使用でき、最大 100 メートルの遠距離接続には Fabric Extender トランシーバを使用できます。また、これらのファブリック接続には、10Gbase-SR や 10Gbase-LR など、その他の標準 10 ギガビット イーサネット光もサポートされています。

最新のオンライン マニュアルの検索

ご使用のサーバ製品の最新マニュアルを確認するには、次のリンクを使用してください。

http://www.cisco.com/en/US/products/ps9670/tsd_products_support_series_home.html

http://h18004.www1.hp.com/products/blades/components/c-class-tech-installing.html

http://www.hp.com/go/Integrity_Servers-docs

これらのリンクを頻繁にチェックして、マニュアルが最新であることを確認してください。

梱包内容

Cisco Nexus B22 Fabric Extender for HP の梱包箱の内容は、次のとおりです。

Cisco Nexus B22 Fabric Extender for HP(内部ホスト ポート X 16、外部ネットワーク ポート X 8)。

この箱には、16 台の Fabric Extender トランシーバを収容できます。Cisco Nexus B22 Fabric Extender および Fabric Extender トランシーバ付きバンドルの製品 ID は、N2K-B22HP-F です。

次のものが収録された CD X 1

スタートアップ ガイド

適合規格および安全性に関する情報

HP エンド ユーザ ライセンス契約書

保証書

図 1 に、Cisco Nexus B22 Fabric Extender for HP を示します。

図 1 Cisco Nexus B22 Fabric Extender for HP

 

1

ミッドプレーン コネクタ

2

8 個の外部ネットワーク ポート

3

取り付けハンドル

4

ユニット ID(UID)LED およびヘルス LED

HP ブレード システムのアーキテクチャ

図 2 に、スイッチ モジュールを取り付けるブレード エンクロージャの背面図を示します。

図 2 ブレード エンクロージャの背面図

 

1

エンクロージャの背面

7

インターコネクト モジュール ベイ 5

2

エンクロージャのファン

8

インターコネクト モジュール ベイ 6

3

インターコネクト モジュール ベイ 1

9

インターコネクト モジュール ベイ 7

4

インターコネクト モジュール ベイ 2

10

インターコネクト モジュール ベイ 8

5

インターコネクト モジュール ベイ 3

11

オンボード アドミニストレータ モジュール

6

インターコネクト モジュール ベイ 4

図 3 に、HP Superdome 2 IOX エンクロージャの背面を示します。

図 3 HP Superdome 2 IOX エンクロージャの背面

 

サーバ ブレード信号
エンクロージャ インターコネクト ベイの計算
インターコネクト ベイのラベル

NIC 1(組み込み)

1

NIC 2(組み込み)

2

NIC 3(組み込み)

1

NIC 4(組み込み)

2

スイッチ モジュールを取り付ける前に、次の前提条件を確認してください。

ブレード エンクロージャ内の使用されていないインターコネクト ベイや電源モジュール ベイには、ブランク パネルを装着してください。

スイッチ モジュールを挿入するベイを確認してください。可能な場合には、最初のスイッチ モジュールをベイ 1、2 番めをベイ 2 のように、ベイ 8 まで順番に取り付けます。各スイッチ モジュールを取り付けるベイは、メザニン カードまたはイーサネット カードがブレード エンクロージャに取り付けられているかどうか、およびどのように設定されているかによって異なります。メザニン カードまたはイーサネット カードの取り付けおよび設定については、ブレード エンクロージャのマニュアルを参照してください。

ブレード エンクロージャとスイッチ モジュール間のポート マッピングの情報については、HP c-Class または HP Integrity Superdome 2 のマニュアルを参照してください。

Cisco Nexus B22 Fabric Extender for HP の取り付け


注意 スイッチを扱う前に、身体を適切に接地してください。

すべてのエンクロージャ インターコネクト ベイに、インターコネクト モジュールまたはエンクロージャに付属するブランク パネルを装着します。HP Integrity Superdome 2 の場合、Fabric Extender は、ベイ 1 かベイ 2 またはその両方に装着します。

Cisco Nexus B22 Fabric Extender for HP をエンクロージャに取り付けるには、次の手順を実行します。

1. エンクロージャ背面の該当するインターコネクト ベイを確認します。エンクロージャに付属するセットアップおよび設置ガイドを参照してください。

2. ハンドル ラッチを押して、ハンドルをロック解除します。図 4 を参照してください。

図 4 取り付けハンドルの解除

 

1

取り付けハンドルのラッチ位置

2

ハンドル ラッチ

3

取り付けハンドル(解除状態)


) Cisco Nexus B22 Fabric Extender for HP は、ホットプラグ可能なデバイスです。取り付け時に、エンクロージャの電源はオンとオフのどちらでもかまいません。


3. エンクロージャの構成に従って、Cisco Nexus B22 Fabric Extender for HP を適切なインターコネクト ベイに合わせます。HP Integrity Superdome 2 の場合、ベイ 1 およびベイ 2 のみ使用可能です。スイッチをインターコネクト ベイにしっかり押し込みます。図 5 を参照してください。

図 5 インターコネクト ベイへの Fabric Extender の取り付け

 

4. 取り付けハンドルをラッチに押し込み、スイッチを所定の位置に固定します。

5. ケーブルを接続します。

6. Cisco Nexus B22 Fabric Extender for HP を認識および起動するように、Cisco Nexus 5000 スイッチを設定します。

NX-OS の更新

最大のパフォーマンスを実現するために、HP は、最新の NX-OS ソフトウェア バージョンへの更新を推奨しています。

Cisco Nexus B22 Fabric Extender for HP は、接続された Cisco Nexus 5x00 スイッチから必要なファームウェアをダウンロードします。 install all コマンドを使用して、Cisco Nexus 5x00 スイッチを中断なしで更新できます。Cisco Nexus 5x00 スイッチの購入元にお問い合わせください。

HP から購入したユニットについては、HP StorageWorks Single Point of Connectivity Knowledge(SPOCK)の Web サイト( www.hp.com/storage/spock )で、HP がサポートする最新の NX-OS バージョンを参照してください。

HP を通して Nexus 5000 を購入した場合は、次の HP Support Center Web サイトから最新の NX-OS ソフトウェアを取得してください。

http://h20565.www2.hp.com/portal/site/hpsc/public

NX-OS ソフトウェアは、シスコの Web サイト( http://www.cisco.com/cisco/software/navigator.html?mdfid=282076290&i=rm )からダウンロードできます。

シスコからユニットを購入した場合は、『 Cisco Nexus 5000 Series NX-OS Software Upgrade and Downgrade Guide 』で NX-OS をシスコからダウンロードする手順を参照してください。

Cisco Nexus B22 Fabric Extender for HP は、親の Cisco Nexus 5000 シリーズ スイッチにより、ゼロタッチ設定モデルを使用してファブリック インターフェイスから管理されます。Fabric Extender は、親の Cisco Nexus 5000 シリーズ スイッチのソフトウェアをアップグレードすることによってアップグレードします。

Fabric Extender が親スイッチに正しく関連付けられている場合、次のアップグレード動作が実行されます。

スイッチは、ソフトウェア イメージの互換性を確認し、必要に応じて Fabric Extender をアップグレードします。

スイッチは、設定データを Fabric Extender にプッシュします。Fabric Extender は、設定をローカルに保存しません。

Fabric Extender は、更新された動作ステータスをスイッチに通知します。Fabric Extender のすべての情報は、スイッチのモニタリングおよびトラブルシューティングのためのコマンドを使用して表示されます。

Cisco Nexus 5000 シリーズ スイッチでは、In-service Software Upgrade(ISSU)がサポートされています。ISSU は、データ トラフィックを中断させることなく、デバイス上のソフトウェア イメージを更新できます。ISSU は、キックスタート イメージ、システム イメージ、および Fabric Extender イメージを更新します。

install all コマンドにより、Cisco Nexus 5000 シリーズ スイッチと Cisco Nexus B22 Fabric Extender for HP で ISSU が起動されます。このコマンドには、次の利点があります。

1 つのコマンドだけで、Cisco Nexus 5000 シリーズ スイッチと Cisco Nexus B22 Fabric Extender for HP をアップグレードできます。

インストールを続行する前に、システムに加えようとしている変更についての説明を参照できます。たとえば、アップグレードで中断が生じる可能性があるかどうかが確認されます。

次の質問が表示され、アップグレードを続行するか、または取り消すことができます(デフォルトは no です)。

Do you want to continue (y/n) [n] : y

中断のない手順で Cisco NX-OS ソフトウェアをアップグレードできます。

このコマンドは、イメージの整合性を自動的に確認します。これには、実行中のキックスタート イメージとシステム イメージが含まれます。キックスタートとシステムのブート変数が設定されます。

プラットフォームの有効性チェックが実行され、正しくないイメージが使用されていないかどうかが確認されます。

Ctrl+C エスケープ シーケンスを使用すると、 install all コマンドが正常終了されます。このコマンド シーケンスは、進行中の更新ステップを完了してから、EXEC プロンプトに戻ります。

install all コマンドの実行後、シーケンス内のいずれかのステップで問題が発生した場合、アップグレードは終了します。

パワー シーケンサをアップグレードした場合の影響について警告するメッセージが、次のように表示されます。

Warning: please do not remove or power off the module at this time.
Note: Power-seq upgrade needs a power-cycle to take into effect.
On success of power-seq upgrade, SWITCH OFF THE POWER to the system and then, power it up.

中断を伴うアップグレードを強制実行できます。

詳細については、『 Cisco Nexus 5000 Series NX-OS Software Upgrade and Downgrade Guide 』を参照してください

Cisco Nexus B22 Fabric Extender for HP の設定

この項では、Cisco Nexus B22 Fabric Extender for HP と Cisco Nexus 5000 シリーズ スイッチとの設定方法について説明します。この項の内容は、次のとおりです。

「ファブリック エクステンダ のファブリック インターフェイスへの関連付け」

「ファブリック エクステンダ の設定」

「リンクの再配布」

「ファブリック エクステンダ 情報の表示」

ファブリック エクステンダ のファブリック インターフェイスへの関連付け

ファブリック エクステンダ は物理的なイーサネット インターフェイスまたは EtherChannel を介してスイッチに接続されます。ファブリック エクステンダ は、デフォルトでは、シャーシ ID を割り当てるか、接続するインターフェイスに関連付けるまで、スイッチに接続できません。


) ファブリック エクステンダ は、複数の異なる物理イーサネット インターフェイスまたは最大 1 つの EtherChannel インターフェイスを介してスイッチに接続できます。


ここでは、次の内容について説明します。

「ファブリック エクステンダ のイーサネット インターフェイスへの関連付け」

「ファブリック エクステンダ の EtherChannel への関連付け」

「ファブリック エクステンダ とインターフェイスとの関連付けの解除」

ファブリック エクステンダ のイーサネット インターフェイスへの関連付け

ファブリック エクステンダ をイーサネット インターフェイスに関連付ける手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface ethernet slot / port

設定するイーサネット インターフェイスを指定します。

ステップ 3

switch(config-if)# switchport mode fex-fabric

外部 ファブリック エクステンダ をサポートするように、インターフェイスを設定します。

ステップ 4

switch(config-if)# fex associate chassis

インターフェイスに接続されている ファブリック エクステンダ 装置に、シャーシ ID を関連付けます。シャーシ ID の範囲は、100 ~ 199 です。

ステップ 5

switch# show interface ethernet port / slot fex-intf

(オプション)ファブリック エクステンダ のイーサネット インターフェイスへの関連付けを表示します。

次に、ファブリック エクステンダ をスイッチのイーサネット インターフェイスに関連付ける例を示します。

switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)# interface ethernet 1/19
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 102

次に、ファブリック エクステンダ とスイッチとの関連付けを表示する例を示します。

switch# show interface ethernet 1/19 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/19 Eth100/1/16 Eth100/1/15 Eth100/1/14 Eth100/1/13
Eth100/1/12 Eth100/1/11 Eth100/1/10 Eth100/1/9
Eth100/1/8 Eth100/1/7 Eth100/1/6 Eth100/1/5
Eth100/1/4 Eth100/1/3 Eth100/1/2 Eth100/1/1
 

ファブリック エクステンダ の EtherChannel への関連付け

ファブリック エクステンダ を EtherChannel に関連付ける手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface port-channnel channel

設定する EtherChannel を指定します。

ステップ 3

switch(config-if)# switchport mode fex-fabric

外部 ファブリック エクステンダ をサポートするように、EtherChannel を設定します。

ステップ 4

switch(config-if)# fex associate chassis

インターフェイスに接続されている ファブリック エクステンダ 装置に、シャーシ ID を関連付けます。シャーシ ID の範囲は、100 ~ 199 です。

ステップ 5

switch# show interface port-channel channel fex-intf

(オプション)ファブリック エクステンダ の EtherChannel インターフェイスへの関連付けを表示します。

次に、ファブリック エクステンダ をスイッチの EtherChannel インターフェイスに関連付ける例を示します。

switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)# interface port-channel 2
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# exit
switch(config)# interface ethernet 1/19
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 2
switch(config-if)# exit
switch(config)# interface ethernet 1/20
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 2
switch(config-if)# exit
switch(config)# interface ethernet 1/21
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 2
switch(config-if)# exit
switch(config)# interface ethernet 1/22
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 2
switch(config-if)# exit
 

) 上記の例に示されているように、EtherChannel のメンバーの各イーサネット インターフェイスをファブリック インターフェイスとして関連付ける必要があります。


次に、ファブリック エクステンダ とスイッチとの関連付けを表示する例を示します。

switch# show interface port-channel 2 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Po2 Eth100/1/1 Eth100/1/2 Eth100/1/3 Eth100/1/4
Eth100/1/5 Eth100/1/6 Eth100/1/7 Eth100/1/8
Eth100/1/9 Eth100/1/10 Eth100/1/11 Eth100/1/12
Eth100/1/13 Eth100/1/14 Eth100/1/15 Eth100/1/16
 

ファブリック エクステンダ とインターフェイスとの関連付けの解除

ファブリック エクステンダ とインターフェイスとの関連付けを解除する手順は、次のとおりです。

 

コマンド
目的

switch(config-if)# no fex associate

インターフェイスに接続されている ファブリック エクステンダ 装置の関連付けを解除します。

ファブリック エクステンダ の設定

ファブリック エクステンダ のグローバル機能を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# fex chassis

指定した ファブリック エクステンダ シャーシ ID のコンフィギュレーション モードを開始します。シャーシ ID の範囲は、100 ~ 199 です。

ステップ 3

switch(config-fex)# description desc

説明を指定します。デフォルトは、文字列 FEX xxxx で、 xxxx はシャーシ ID です。シャーシ ID が 123 の場合、説明は FEX0123 です。

switch(config-fex)# no description

説明を削除します。

switch(config-fex)# pinning max-links uplinks

アップリンクの数を定義します。デフォルトは 1 です。範囲は 1 ~ 4 です。

このコマンドは、ファブリック エクステンダ が 1 つまたは複数の静的にピン接続されたファブリック インターフェイスを使用して親スイッチに接続されている場合だけ、適用できます。EtherChannel 接続は 1 つだけ可能です。

switch(config-fex)# no pinning max-links

アップリンクの数をデフォルトにリセットします。

switch(config-fex)# serial serial

シリアル番号文字列を定義します。このコマンドが設定され、ファブリック エクステンダ が一致するシリアル番号文字列を報告する場合、スイッチでは、対応するシャーシ ID だけが関連付けることができます( fex associate コマンドを使用します)。

使用するファブリック エクステンダのシリアル番号とは異なるシリアル番号を設定すると、ファブリック エクステンダは強制的にオフラインになります。

switch(config-fex)# no serial

シリアル番号文字列を削除します。

switch(config-fex)# beacon

ビーコン LED を点灯します。この LED の点灯により、特定の ファブリック エクステンダ をラック内で見つけることができます。

switch(config-fex)# no beacon

ビーコン LED を消灯します。


注意 pinning max-links コマンドまたは no pinning max-links コマンドを使用してアップリンクの数を変更すると、ファブリック エクステンダ のすべてのホスト インターフェイス ポートは中断します。

リンクの再配布

静的にピン接続されたインターフェイスを使用して ファブリック エクステンダ をプロビジョニングすると、ファブリック エクステンダ のダウンリンク ホスト インターフェイスは、最初に設定された順序でファブリック インターフェイスにピン接続されます。ファブリック インターフェイスへのホスト インターフェイスの特別な関係がリブートしても維持されるようにするには、リンクを再びピン接続する必要があります。

この機能は、次の 2 つの状況で行うことができます。

max-links 設定を変更する必要がある場合。

ファブリック インターフェイスへのホスト インターフェイスのピン接続順序を維持する必要がある場合。

リンク数の変更

最初に親スイッチのポート 19 を唯一のファブリック インターフェイスとして設定すると、16 のすべてのホスト インターフェイスがこのポートにピン接続されます。20 などの他のポートをプロビジョニングするには、 pinning max-links 2 コマンドを使用してホスト インターフェイスを再配布します。これにより、すべてのホスト インターフェイスがダウンし、ホスト インターフェイス 1 ~ 8 はファブリック インターフェイス 19 に、ホスト インターフェイス 9 ~ 16 はファブリック インターフェイス 20 にピン接続されます。

ピン接続順序の維持

ホスト インターフェイスのピン接続順序は、最初、ファブリック インターフェイスが設定された順序で決定されます。この例では、4 つのファブリック インターフェイスが次の順序で設定されます。

switch(config-fex)#
switch(config-fex)#
switch(config-fex)# show interface ethernet 1/19 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/19 Eth100/1/4 Eth100/1/3 Eth100/1/2 Eth100/1/1
 
switch(config-fex)# show interface ethernet 1/20 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/20 Eth100/1/8 Eth100/1/7 Eth100/1/6 Eth100/1/5
 
switch(config-fex)# show interface ethernet 1/21 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/21 Eth100/1/12 Eth100/1/11 Eth100/1/10 Eth100/1/9
 
switch(config-fex)# show interface ethernet 1/22 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/22 Eth100/1/16 Eth100/1/15 Eth100/1/14 Eth100/1/13
 

ファブリック エクステンダ を次回リブートすると、設定されたファブリック インターフェイスは、ファブリック インターフェイスのポート番号の昇順でホスト インターフェイスにピン接続されます。ファブリック エクステンダ を再起動せずに同じ固定配布でホスト インターフェイスを設定するには、 fex pinning redistribute コマンドを入力します。

ファブリック エクステンダ でホスト インターフェイスを再配布する手順は、次のとおりです。

 

コマンド
目的

switch# fex pinning redistribute chassis

ホスト接続を再配布します。シャーシ ID の範囲は、100 ~ 199 です。

次に、ファブリック エクステンダでホスト インターフェイスを再配布する例を示します。

switch# fex pinning redistribute 100

注意 fex pinning redistribute コマンドは、ファブリック エクステンダ のすべてのホスト インターフェイス ポートを中断します。

Cisco Nexus B22 Fabric Extender for HP および Cisco Nexus 5000 シリーズ スイッチの設定の詳細については、次のマニュアルを参照してください。

Cisco Nexus 2000 Series Fabric Extender Software Configuration Guide http://www.cisco.com/en/US/docs/switches/datacenter/nexus2000/sw/configuration/guide/rel_4_0_1a/NX2000CLIConfig.html

『Cisco Nexus 5000 Series NX-OS Software Configuration Guide』
http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli_rel_4_0_1a/CLIConfigurationGuide.html

ファブリック エクステンダ 情報の表示

ここでは、ファブリック エクステンダ の設定とステータスを表示する show コマンドについて、次の内容を説明します。

「設定情報の表示」

「シャーシ管理情報の表示」

設定情報の表示

定義されているインターフェイスの設定情報を表示するには、次のいずれかの作業を実行します。

 

コマンド
目的

switch# show fex [ chassis [ detail ]

特定の ファブリック エクステンダ または接続されているすべての装置の情報を表示します。

switch# show interface type number fex-intf

特定のスイッチ インターフェイスにピン接続されているファブリック エクステンダのポートを表示します。

switch# show interface fex-fabric

ファブリック エクステンダ のアップリンクを検出しているスイッチ インターフェイスを表示します。

次に、接続されているすべての ファブリック エクステンダ 装置を表示する例を示します。

switch(config-fex)# show fex
FEX FEX FEX FEX
Number Description State Model Serial
------------------------------------------------------------------------
100 FEX0100 Online N2K-B22HP-P FOC1516ZZLS
switch(config-fex)#
 

次に、特定の ファブリック エクステンダ の詳細なステータスを表示する例を示します。

switch# show fex 100 detail
FEX: 100 Description: FEX0100 state: Online
FEX version: 5.0(3)N2(1) [Switch version: 5.0(3)N2(1)]
FEX Interim version: 5.0(3)N2(0.236)
Switch Interim version: 5.0(3)N2(0.236)
Extender Model: N2K-B22HP-P, Extender Serial: FOC1514256S
Part No: 73-13780-05
Bay: 2
Rack: UnnamedRack
Enclosure: 1Z34AB789012
Enclosure Serial: USE6401VEX
Rack Id: Default RUID
Card Id: 145, Mac Addr: e8:b7:48:4b:e8:82, Num Macs: 64
Module Sw Gen: 21 [Switch Sw Gen: 21]
post level: complete
pinning-mode: static Max-links: 4
Fabric port for control traffic: Eth1/19
Fabric interface state:
Eth1/19 - Interface Up. State: Active
Eth1/20 - Interface Up. State: Active
Eth1/21 - Interface Up. State: Active
Eth1/22 - Interface Up. State: Active
Fex Port State Fabric Port
Eth100/1/1 Up Eth1/19
Eth100/1/2 Down Eth1/19
Eth100/1/3 Down Eth1/19
Eth100/1/4 Down Eth1/19
Eth100/1/5 Down Eth1/20
Eth100/1/6 Down Eth1/20
Eth100/1/7 Down Eth1/20
Eth100/1/8 Down Eth1/20
Eth100/1/9 Up Eth1/21
Eth100/1/10 Down Eth1/21
Eth100/1/11 Down Eth1/21
Eth100/1/12 Down Eth1/21
Eth100/1/13 Down Eth1/22
Eth100/1/14 Down Eth1/22
Eth100/1/15 Down Eth1/22
Eth100/1/16 Down Eth1/22
Logs:
06/22/2011 21:43:50.260429: Module register received
06/22/2011 21:43:50.261621: Image Version Mismatch
06/22/2011 21:43:50.261906: Registration response sent
06/22/2011 21:43:50.262180: Requesting satellite to download image
06/22/2011 21:47:36.78886: Deleting route to FEX
06/22/2011 21:47:36.83969: Module disconnected
06/22/2011 21:47:36.85724: Module Offline
06/22/2011 21:53:08.757010: Module register received
06/22/2011 21:53:08.758178: Registration response sent
06/22/2011 21:53:09.6227: Module Online Sequence
06/22/2011 21:53:11.736373: Module Online
06/22/2011 22:09:48.190062: Deleting route to FEX
06/22/2011 22:09:48.196995: Module disconnected
06/22/2011 22:09:48.198227: Deleting route to FEX
06/22/2011 22:09:48.203294: Module disconnected
06/22/2011 22:09:48.204160: Offlining Module
06/22/2011 22:09:48.204977: Module Offline Sequence
06/22/2011 22:09:48.527385: Module Offline
06/22/2011 22:10:23.644325: Module register received
06/22/2011 22:10:23.645444: Registration response sent
06/22/2011 22:10:23.864695: Module Online Sequence
06/22/2011 22:10:25.289316: Module Online
 

次に、特定のスイッチ インターフェイスにピン接続されている ファブリック エクステンダ のインターフェイスを表示する例を示します。

switch(config-fex)# show interface ethernet 1/19 fex-intf
'Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/19 Eth100/1/4 Eth100/1/3 Eth100/1/2 Eth100/1/1
 

次に、ファブリック エクステンダ のアップリンクに接続されているスイッチ インターフェイスを表示する例を示します。

switch(config-fex)# show interface fex-fabric
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
100 Eth1/19 Active 1 N2K-B22HP-P FOC1514256S
100 Eth1/20 Active 2 N2K-B22HP-P FOC1514256S
100 Eth1/21 Active 3 N2K-B22HP-P FOC1514256S
100 Eth1/22 Active 4 N2K-B22HP-P FOC1514256S
switch(config-fex)#
 

) 上記の例では、ファブリック エクステンダ に 4 つのアップリンク接続が設定されており、1 つだけが現在アクティブです。


次に、ファブリック エクステンダ のアップリンクの SFP+ トランシーバおよび Diagnostic Optical Monitoring(DOM)の情報を表示する例を示します。

switch# show interface ethernet 1/40 transceiver
Ethernet1/40
sfp is present
name is CISCO-EXCELIGHT
part number is SPP5101SR-C1
revision is A
serial number is ECL120901AV
nominal bitrate is 10300 MBits/sec
Link length supported for 50/125mm fiber is 82 m(s)
Link length supported for 62.5/125mm fiber is 26 m(s)
cisco id is --
cisco extended id number is 4
 
switch# show interface ethernet 1/40 transceiver fex-fabric
Ethernet1/40
sfp is present
name is CISCO-EXCELIGHT
part number is SPP5101SR-C1
revision is A
serial number is ECL120601U0
nominal bitrate is 10300 MBits/sec
Link length supported for 50/125mm fiber is 82 m(s)
Link length supported for 62.5/125mm fiber is 26 m(s)
cisco id is --
cisco extended id number is 4

) 上記の例の最初の show コマンドは、親スイッチのインターフェイスに接続されている SFP+ トランシーバを表示します。2 番目の show コマンドは、ファブリック エクステンダ のアップリンク ポートに接続されている SFP+ トランシーバを表示します。


シャーシ管理情報の表示

ファブリック エクステンダ を管理するためにスイッチ スーパーバイザで使用される設定情報を表示するには、次のいずれかの作業を実行します。

 

コマンド
目的

switch# show diagnostic result fex chassis

ファブリック エクステンダ のシャーシの診断テストの結果を表示します。

switch# show inventory fex chassis

ファブリック エクステンダ のシャーシのコンポーネント情報を表示します。

switch# show module fex chassis

ファブリック エクステンダ のシャーシのモジュール情報を表示します。

次に、接続されているすべての ファブリック エクステンダ 装置のモジュール情報を表示する例を示します。

switch(config-fex)# show module fex
FEX Mod Ports Card Type Model Status.
--- --- ----- ---------------------------------- ------------------ -----------
100 1 16 Fabric Extender 16x10GE + 8x10G Module N2K-B22HP-P present
 
FEX Mod Sw Hw World-Wide-Name(s) (WWN)
--- --- -------------- ------ -----------------------------------------------
100 1 5.0(3)N2(1) 0.501 --
 
FEX Mod MAC-Address(es) Serial-Num
--- --- -------------------------------------- ----------
100 1 e8b7.484b.e880 to e8b7.484b.e88f FOC1514256S
switch(config-fex)#
switch(config-fex)# show module fex 100
FEX Mod Ports Card Type Model Status.
--- --- ----- ---------------------------------- ------------------ -----------
100 1 16 Fabric Extender 16x10GE + 8x10G Module N2K-B22HP-P present
 
FEX Mod Sw Hw World-Wide-Name(s) (WWN)
--- --- -------------- ------ -----------------------------------------------
100 1 5.0(3)N2(1) 0.501 --
 
FEX Mod MAC-Address(es) Serial-Num
--- --- -------------------------------------- ----------
100 1 e8b7.484b.e880 to e8b7.484b.e88f FOC1514256S
switch(config-fex)#
 

次に、特定の ファブリック エクステンダ 装置のコンポーネント情報を表示する例を示します。

switch(config-fex)# show inventory fex 100
NAME: "FEX 100 CHASSIS", DESCR: "N2K-B22HP-P CHASSIS"
PID: N2K-B22HP-P , VID: V00 , SN: FOC1516ZZLS
 
NAME: "FEX 100 Module 1", DESCR: "Fabric Extender Module: 16x10GE, 8x10GE Supervisor"
PID: N2K-B22HP-P , VID: V00 , SN: FOC1514256S
switch(config-fex)#
 

次に、特定の ファブリック エクステンダ 装置の診断テストの結果を表示する例を示します。

switch(config-fex)# show diagnostic result fex 100
FEX-100: Fabric Extender 16x10GE + 8x10G Module SerialNo : FOC1514256S
Overall Diagnostic Result for FEX-100 : OK
 
Test results: (. = Pass, F = Fail, U = Untested)
TestPlatform:
0) SPROM: ---------------> .
1) Inband interface: ---------------> .
2) Fan: ---------------> .
3) Power Supply: ---------------> .
4) Temperature Sensor: ---------------> .
Eth 1 2 3 4 5 6 7 8
Port -------------------------
. . . . . . . .
 
Eth 9 10 11 12 13 14 15 16
Port ------------------------
. . . . . . . .
 
TestFabricPorts:
Fabric 1 2 3 4 5 6 7 8
Port -------------------------
. . . . . . . .
switch(config-fex)#
 

次に、特定の ファブリック エクステンダ 装置の環境ステータスの結果を表示する例を示します。

switch(config-fex)# show environment fex 100
Temperature Fex 100:
-----------------------------------------------------------------
Module Sensor MajorThresh MinorThres CurTemp Status
(Celsius) (Celsius) (Celsius)
-----------------------------------------------------------------
1 Outlet-1 85 75 39 ok
1 Outlet-2 85 75 48 ok
1 Inlet-1 85 75 36 ok
1 Inlet-2 85 75 27 ok
1 Die-1 110 105 55 ok
switch(config-fex)#
 

次に、特定の ファブリック エクステンダ 装置の SPROM を表示する例を示します。

switch(config-fex)# show sprom fex 100 all
DISPLAY FEX 100 SUP sprom contents
Common block:
Block Signature : 0xabab
Block Version : 3
Block Length : 160
Block Checksum : 0x1860
EEPROM Size : 65535
Block Count : 3
FRU Major Type : 0x6002
FRU Minor Type : 0x0
OEM String : Cisco Systems, Inc.
Product Number : N2K-B22HP-P
Serial Number : FOC1514256S
Part Number : 73-13780-05
Part Revision : 02
Mfg Deviation : 0
H/W Version : 0.501
Mfg Bits : 0
Engineer Use : 0
snmpOID : 9.12.3.1.9.78.9.0
Power Consump : 625
RMA Code : 0-0-0-0
CLEI Code : COUCAPKCAA
VID : V00
Supervisor Module specific block:
Block Signature : 0x6002
Block Version : 2
Block Length : 103
Block Checksum : 0x2603
Feature Bits : 0x0
HW Changes Bits : 0x0
Card Index : 11048
MAC Addresses : 00-00-00-00-00-00
Number of MACs : 0
Number of EPLD : 0
Port Type-Num : 1-8
Sensor #1 : 85,75
Sensor #2 : 85,75
Sensor #3 : 85,75
Sensor #4 : 85,75
Sensor #5 : 95,85
Sensor #6 : -128,-128
Sensor #7 : -128,-128
Sensor #8 : -128,-128
Max Connector Power: 625
Cooling Requirement: 8
Ambient Temperature: 40
 
DISPLAY FEX 100 backplane sprom contents:
Common block:
Block Signature : 0xabab
Block Version : 3
Block Length : 160
Block Checksum : 0x17e8
EEPROM Size : 65535
Block Count : 5
 
FRU Major Type : 0x6001
FRU Minor Type : 0x0
OEM String : Cisco Systems, Inc.
Product Number : N2K-B22HP-P
Serial Number : FOC1516ZZLS
Part Number : 68-4133-02
Part Revision : 05
Mfg Deviation : 0
H/W Version : 0.501
Mfg Bits : 0
Engineer Use : 0
snmpOID : 9.12.3.1.3.1058.0.0
Power Consump : 0
RMA Code : 0-0-0-0
CLEI Code : COUCAPKCAA
VID : V00
Chassis specific block:
Block Signature : 0x6001
Block Version : 3
Block Length : 39
Block Checksum : 0x465
Feature Bits : 0x0
HW Changes Bits : 0x0
Stackmib OID : 0
MAC Addresses : e8-b7-48-4b-e8-80
Number of MACs : 64
OEM Enterprise : 0
OEM MIB Offset : 0
MAX Connector Power: 0
WWN software-module specific block:
Block Signature : 0x6005
Block Version : 1
Block Length : 0
Block Checksum : 0x66
wwn usage bits:
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00
License software-module specific block:
Block Signature : 0x6006
Block Version : 1
Block Length : 16
Block Checksum : 0x77
lic usage bits:
00 00 00 00 00 00 00 00
 
DISPLAY FEX 100 UPLINK sprom contents
Common block:
Block Signature : 0x0
Block Version : 0
Block Length : 0
Block Checksum : 0x0
EEPROM Size : 0
Block Count : 0
FRU Major Type : 0x0
FRU Minor Type : 0x0
OEM String :
 
Product Number :
Serial Number :
Part Number :
Part Revision :
Mfg Deviation :
H/W Version : 0.0
Mfg Bits : 0
Engineer Use : 0
snmpOID : 0.0.0.0.0.0.0.0
Power Consump : 0
RMA Code : 0-0-0-0
CLEI Code :
VID : V00
Supervisor Module specific block:
Block Signature : 0x0
Block Version : 0
Block Length : 0
Block Checksum : 0x0
Feature Bits : 0x0
HW Changes Bits : 0x0
Card Index : 0
MAC Addresses : 00-00-00-00-00-00
Number of MACs : 0
Number of EPLD : 0
Port Type-Num : 0-0
Sensor #1 : 0,0
Sensor #2 : 0,0
Sensor #3 : 0,0
Sensor #4 : 0,0
Sensor #5 : 0,0
Sensor #6 : 0,0
Sensor #7 : 0,0
Sensor #8 : 0,0
Max Connector Power: 0
Cooling Requirement: 0
Ambient Temperature: 0
switch(config-fex)#
switch(config-fex)#
switch(config-fex)#
switch(config-fex)#
switch(config-fex)#
switch(config-fex)#

設定の確認

Onboard Administrator(OA)は、HP BladeSystem c-Class エンクロージャまたは HP Integrity Superdome 2、およびエンクロージャで使用されるすべてのデバイスのサポートおよび管理に使用される管理モジュールです。Onboard Administrator(OA)は、HP BladeSystem c-Class エンクロージャおよび HP Integrity Superdome 2 エンクロージャと、エンクロージャで使用されるすべてのデバイスのサポートおよび管理に使用される管理モジュールです。スイッチをインターコネクト ベイに取り付けると、OA は、スイッチ タイプがサーバ ブレードに存在するメザニン カードと一致することを確認します。不一致が検出されなかった場合、OA はスイッチの電源をオンにします。スイッチの電源がオンにならない場合は、OA Web インターフェイスを使用してエンクロージャとスイッチのステータスを確認します。詳細およびトラブルシューティングのヒントについては、『 HP BladeSystem Onboard Administrator User Guide 』または『 HP Integrity Superdome 2 Onboard Administrator User Guide 』を参照してください。

設定を確認するには、次の手順を実行します。

1. LED を確認します。図 6 を参照してください。

図 6 LED の識別

 

1

UID LED

2

ヘルス LED

2. LED を確認し、次の表に示すインジケータを参照します。

項目
説明
インジケータ

1

UID LED:置換用など、BladeSystem 内で特定モジュールを検出するのに役立ちます。

Off

2

ヘルス LED:通常の動作を示します。

緑のライトが点灯


) OA バージョン 3.3 が必要です。



HP Integrity Superdome 2 の場合、最小ファームウェア バンドルは 2.51.102 です。


その他の情報

サーバ メザニン ベイとエンクロージャ インターコネクト ベイの関連の詳細については、エンクロージャに付属のセットアップおよび設置ガイドを参照してください。詳細については、次の HP Web サイトを参照してください。

http://www.hp.com/go/bladesystem/interconnects

http://www.hp.com/go/bladesystem/documentation

http://www.hp.com/go/Integrity_Servers-docs

メザニン カードの取り付け場所により、Cisco Nexus B22 Fabric Extender for HP などのインターコネクト モジュールを取り付ける必要のある場所が決まります。

図 7 に、Cisco Nexus B22 Fabric Extender for HP の外部ポートを示します。

図 7 外部ポート

 

1

外部ポート 1、2、3、および 4

2

外部ポート 5、6、7、および 8


) BladeSystem エンクロージャの内部ポート マッピングに固有の情報については、エンクロージャに付属のセットアップおよび設置ガイドを参照してください。


関連資料

Cisco Nexus 5000 シリーズ スイッチおよび Cisco Nexus 2000 シリーズ Fabric Extender のマニュアルは、次の URL から入手できます。
http://www.cisco.com/en/US/products/ps9670/tsd_products_support_series_home.html

HP BladeSystem 用の設置マニュアルは、次の URL から入手できます。
http://h18004.www1.hp.com/products/blades/components/c-class-tech-installing.html

HP Integrity Superdome 2 用のマニュアルは、次の URL から入手できます。

http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?lang=en&cc=us&taskId=101&prodClassId=-1&contentType=SupportManual&docIndexId=64255&prodTypeId=15351&prodSeriesId=4311905

テクニカル サポート

Cisco Nexus B22 Fabric Extender for HP のテクニカル サポートは、シスコまたは Hewlett Packard のいずれかから入手できます。このトピックには、次の事項が含まれます。

「Hewlett Packard のサポートについて」

「シスコのテクニカル サポート」

Hewlett Packard のサポートについて

保証期間中のハードウェアの交換については、Hewlett Packard にお問い合わせください。

米国内での問い合わせオプションについては、 Contact HP United States の Web ページを参照してください。電話による HP への問い合わせ方法は、次のとおりです。

電話番号は 1-800-HP-INVENT(1-800-474-6836)です。このサービスは年中無休 24 時間体制でご利用できます。継続的な品質改善のため、通話内容が録音または監視される場合があります。

Care Pack(サービス アップグレード)を購入している場合は、1-800-633-3600 に電話してください。Care Pack の詳細については、 HP の Web サイト を参照してください。

その他の地域、または最寄りの HP 認定代理店については、 Contact HP worldwide(英語)Web ページ を参照してください。

シスコのテクニカル サポート

次の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

http://www.cisco.com/en/US/support/index.html

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

Japan テクニカル サポート Web サイトでは、Technical Support Web サイト( http://www.cisco.com/techsupport )の、利用頻度の高いドキュメントを日本語で提供しています。

Japan テクニカル サポート Web サイトには、次のURLからアクセスしてください。

http://www.cisco.com/jp/go/tac