Cisco Nexus 2000 シリーズ ファブリック エクステンダ ソフトウェア コンフィギュレーション ガイド
ファブリック エクステンダの設定
ファブリック エクステンダの設定
発行日;2013/01/16   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

ファブリック エクステンダの設定

この章では、親である Cisco Nexus 7000 シリーズ デバイスを使用して Cisco Nexus 2000 シリーズ ファブリック エクステンダを設定する方法について説明します。具体的な内容は、次のとおりです。

Cisco Nexus 2000 シリーズ ファブリック エクステンダの設定

ここでは、ファブリック エクステンダを設定する方法について説明します。

ファブリック エクステンダ フィーチャ セットの管理

ファブリック エクステンダ フィーチャ セットのインストール


(注)  


デフォルト VDC のファブリック エクステンダ フィーチャ セットをイネーブルにする必要があります。 デフォルト VDC でイネーブルにすると、FEX は任意の VDC に属することができ、またこれらの VDC から設定できます。 単一のファブリック エクステンダは、単一の VDC だけに属します。


はじめる前に

デフォルト VDC にいることを確認します。

IDS の予約アドレス チェックがディセーブルになっていることを確認します(デフォルトではディセーブル)。 show hardware ip verify コマンドを使用し、その出力から文字列「address reserved」を探します。 IDS の予約アドレス チェックがイネーブルの場合は、no hardware ip verify address reserved コマンドを使用してディセーブルにします。

手順の概要

    1.    configure terminal

    2.    install feature-set fex

    3.    exit


手順の詳細
     コマンドまたはアクション目的
    ステップ 1configure terminal


    例:
    switch# configure terminal
    switch(config)# 
     

    コンフィギュレーション モードを開始します。

     
    ステップ 2 install feature-set fex


    例:
    switch(config)# install feature-set fex
     

    デフォルト VDC にファブリック エクステンダ フィーチャ セットをインストールします。

    ファブリック エクステンダ フィーチャ セットをアンインストールするには、no install feature-set fex コマンドを使用します。 フィーチャ セットをアンインストールする前に、次のことを確認する必要があります。

    • フィーチャ セットは、デフォルト VDC にインストールする必要があります。
    • フィーチャ セットは任意の VDC ではイネーブルにできません。
     
    ステップ 3exit


    例:
    switch(config)# exit
    switch# 
     

    コンフィギュレーション モードを終了します。

     

    ファブリック エクステンダ フィーチャ セットのイネーブル化

    デバイスの任意の VDC でインストール済みのファブリック エクステンダ フィーチャ セットをイネーブルにできます。

    はじめる前に

    デフォルト VDC にファブリック エクステンダ フィーチャ セットをインストールしたことを確認します。

    正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

    手順の概要

      1.    configure terminal

      2.    feature-set fex

      3.    exit


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1configure terminal


      例:
      switch# configure terminal
      switch(config)# 
       

      コンフィギュレーション モードを開始します。

       
      ステップ 2 feature-set fex


      例:
      switch(config)# feature-set fex
       

      ファブリック エクステンダ フィーチャ セットをイネーブルにします。 フィーチャ セットは、このコマンドにオプションとして表示される前に、インストールしておく必要があります。

      ファブリック エクステンダ フィーチャ セットをディセーブルにするには、no feature-set fex コマンドを使用します。 フィーチャ セットをディセーブルにする前に、デフォルト VDC にフィーチャ セットをインストールする必要があります。

      (注)     

      no feature-set fex コマンドは、設定のサイズが非常に大きい場合、完了に時間がかかることがあります。 コマンドは、ファブリック エクステンダ フィーチャ セットに関連付けられている設定をすべて消去します。

       
      ステップ 3exit


      例:
      switch(config)# exit
      switch# 
       

      コンフィギュレーション モードを終了します。

       

      ファブリック エクステンダ フィーチャ セットの拒否

      デフォルトでは、ファブリック エクステンダ フィーチャ セットは、インストールするとすべての VDC で許可されます。 デバイスの特定の VDC で、インストールされたファブリック エクステンダ フィーチャ セットを拒否できます。

      はじめる前に

      デフォルト VDC にフィーチャ セットをインストールしたことを確認します。

      指定した VDC でフィーチャ セットをイネーブルにしていないことを確認します。

      手順の概要

        1.    configure terminal

        2.    vdc vdc_ID

        3.    no allow feature-set fex

        4.    end


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1configure terminal


        例:
        switch# configure terminal
        switch(config)# 
         

        コンフィギュレーション モードを開始します。

         
        ステップ 2vdc vdc_ID


        例:
        switch(config)# vdc 1
         

        VDC を指定し、VDC コンフィギュレーション モードを開始します。

         
        ステップ 3 no allow feature-set fex


        例:
        switch(config-vdc)# no allow feature-set fex
         

        VDC のフィーチャ セットを拒否します。 指定した VDC でイネーブルになっているフィーチャ セットは拒否できません。

        デフォルトでは、インストールされたファブリック エクステンダ フィーチャ セットは、デバイス上のすべての VDC で許可されます。 特定の VDC のフィーチャ セットを拒否できます。 その後、allow feature-set fex コマンドを使用して、ステータスを許可に戻すことができます。

         
        ステップ 4end


        例:
        switch(config-vdc)# end
        switch# 
         

        VDC コンフィギュレーション モードを終了して EXEC モードに戻ります。

         

        ファブリック インターフェイスへのファブリック エクステンダの関連付け

        FEX は、ポート チャネルを介して親デバイスに接続されます。 ファブリック エクステンダは、デフォルトでは、FEX-number を割り当てるか、接続するインターフェイスに関連付けるまで、親デバイスに接続できません。


        (注)  


        親スイッチに接続される ファブリック エクステンダ を設定して使用する前に、install feature-set fex コマンドと feature-set fex コマンドを使用して、ファブリック エクステンダ の機能をインストールしてイネーブルにする必要があります。


        ファブリック エクステンダのポート チャネルとのアソシエーション

        はじめる前に

        ファブリック エクステンダ フィーチャ セットインストールされ、イネーブルになっていることを確認します。

        正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

        手順の概要

          1.    configure terminal

          2.    interface port-channel channel

          3.    switchport

          4.    switchport mode fex-fabric

          5.    fex associate FEX-number

          6.    (任意) show interface port-channel channel fex-intf


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 configure terminal


          例:
          switch# configure terminal
          switch(config)# 
           

          コンフィギュレーション モードに入ります。

           
          ステップ 2 interface port-channel channel


          例:
          switch(config)# interface port-channel 4
          switch(config-if)# 
           

          設定するポート チャネルを指定します。

          (注)     

          ポート チャネルのすべてのインターフェイスは、同じ VDC であることが必要です。

           
          ステップ 3switchport


          例:
          switch(config-if)# switchport
           

          インターフェイスをレイヤ 2 スイッチング ポートとして設定します。

           
          ステップ 4 switchport mode fex-fabric


          例:
          switch(config-if)# switchport mode fex-fabric
           

          外部ファブリック エクステンダをサポートするように、ポート チャネルを設定します。

           
          ステップ 5 fex associate FEX-number


          例:
          switch(config-if)# fex associate 101
           

          インターフェイスに接続されているファブリック エクステンダ装置に、FEX 番号をアソシエートします。 範囲は 101 ~ 199 です。

           
          ステップ 6 show interface port-channel channel fex-intf


          例:
          switch# show interface port-channel 4 fex-intf
           
          (任意)

          ファブリック エクステンダのポート チャネル インターフェイスへのアソシエーションを表示します。

           

          次に、ファブリック エクステンダを親デバイスのポート チャネル インターフェイスにアソシエートする例を示します。

          switch# configure terminal
          switch(config)# interface ethernet 1/28
          switch(config-if)# channel-group 4
          switch(config-if)# no shutdown
          switch(config-if)# exit
          switch(config)# interface ethernet 1/29
          switch(config-if)# channel-group 4
          switch(config-if)# no shutdown
          switch(config-if)# exit
          switch(config)# interface ethernet 1/30
          switch(config-if)# channel-group 4
          switch(config-if)# no shutdown
          switch(config-if)# exit
          switch(config)# interface ethernet 1/31
          switch(config-if)# channel-group 4
          switch(config-if)# no shutdown
          switch(config-if)# exit
          switch(config)# interface port-channel 4
          switch(config-if)# switchport
          switch(config-if)# switchport mode fex-fabric
          switch(config-if)# fex associate 101
          

          ヒント


          ベスト プラクティスとして、物理インターフェイスからではなく、ポート チャネル インターフェイスからのみ fex associate コマンドを入力します。

          物理ポートをポート チャネルに接続する前に、その物理ポートを FEX にアソシエートしようとすると、その物理ポートはエラー ディセーブル ステートに移行し、Cisco Nexus 7000 シリーズ デバイスはそのリンク上の FEX と通信しません。 エラー ディセーブル ステートをクリアし、そのリンクをアップ状態にするには、shutdown コマンドと no shutdown コマンドをイーサネット インターフェイス(ポート チャネル インターフェイスではなく)で入力する必要があります (これは、ケーブル接続の前に設定を実行する場合には当てはまりません)。



          (注)  


          物理インターフェイスをポート チャネルに追加する際には、ポート チャネルと物理インターフェイス上の設定が一致していなければなりません。


          次に、ファブリック エクステンダと親デバイスとのアソシエーションを表示する例を示します。

          switch# show interface port-channel 4 fex-intf
          Fabric           FEX
          Interface        Interfaces
          ---------------------------------------------------
          Po4              Eth101/1/48   Eth101/1/47   Eth101/1/46   Eth101/1/45
                           Eth101/1/44   Eth101/1/43   Eth101/1/42   Eth101/1/41
                           Eth101/1/40   Eth101/1/39   Eth101/1/38   Eth101/1/37
                           Eth101/1/36   Eth101/1/35   Eth101/1/34   Eth101/1/33
                           Eth101/1/32   Eth101/1/31   Eth101/1/30   Eth101/1/29
                           Eth101/1/28   Eth101/1/27   Eth101/1/26   Eth101/1/25
                           Eth101/1/24   Eth101/1/23   Eth101/1/22   Eth101/1/21
                           Eth101/1/20   Eth101/1/19   Eth101/1/18   Eth101/1/17
                           Eth101/1/16   Eth101/1/15   Eth101/1/14   Eth101/1/13
                           Eth101/1/12   Eth101/1/11   Eth101/1/10   Eth101/1/9
                           Eth101/1/8    Eth101/1/7    Eth101/1/6    Eth101/1/5
                           Eth101/1/4    Eth101/1/3    Eth101/1/2    Eth101/1/1
           

          インターフェイスからファブリック エクステンダのアソシエーションの解除

          はじめる前に

          ファブリック エクステンダ フィーチャ セットインストールされ、イネーブルになっていることを確認します。

          正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

          手順の概要

            1.    configure terminal

            2.    interface {ethernet slot/port | port-channel channel}

            3.    no fex associate


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 configure terminal


            例:
            switch# configure terminal
            switch(config)# 
             

            コンフィギュレーション モードに入ります。

             
            ステップ 2 interface {ethernet slot/port | port-channel channel}


            例:
            switch(config)# interface port-channel 4
            switch(config-if)# 
             

            設定するインターフェイスを指定します。 インターフェイスは、イーサネット インターフェイスまたはポート チャネルにすることができます。

             
            ステップ 3 no fex associate


            例:
            switch(config-if)# no fex associate
             

            インターフェイスに接続されているファブリック エクステンダ装置の関連付けを解除します。

             

            ファブリック エクステンダの F2 モジュールへの関連付け

            ファブリック エクステンダを F2 モジュールに関連付けることができます。

            はじめる前に

            ファブリック エクステンダ フィーチャ セットがインストールされ、イネーブルになっていることを確認します。

            • switch# configure terminal
            • switch(config)# install feature-set fex
            • switch(config)# feature-set fex

            (注)  


            F2 モジュールは次の FEX デバイスでのみサポートされています。

            • 2248TP
            • 2248TP-E
            • 2232TP
            • 2232PP
            • 2232TM
            • 2224TP


            (注)  


            ASIC の各ポートはインデックスを持っています。 ASIC 間で類似したインデックスを持つポートだけをポート チャネルに追加できます。

            たとえば、ポート 1 が 1 のインデックスを持ち、ポート 2 が 2 のインデックスを持つ場合、

            • サポートされる:ASIC 1 のポート 1、および ASIC 2 のポート 1 は、ポート チャネルに追加されます。
            • サポートされない:ASIC 1 のポート 1 および ASIC 2 のポート 2 は、ポート チャネルを形成します。

            一般に、インデックス サブセット S(例:{1,2,4})を持つ ASIC からの一連のポートは、ポートチャネルが同等または空のセットを持つ場合にかぎり、ポートチャネルへの追加が許可されます。


            手順の概要

              1.    vdc switch

              2.    limit-resource module-type f2

              3.    interface ethernet <mod-number><port-range>

              4.    allocate interface ethernet <slot-port>

              5.    switchport mode fex -fabric

              6.    fex associate <FEX chassis number>

              7.    channel-group <port-channel number>

              8.    no shutdown

              9.    int po <port-channel number>

              10.    no shutdown


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 vdc switch


              例:
              switch(config)# vdc switch
               

              VDC を指定します。

               
              ステップ 2 limit-resource module-type f2


              例:
              switch(config)# limit-resource module-type f2
               

              モジュール タイプを指定します。

               
              ステップ 3 interface ethernet <mod-number><port-range>


              例:
              switch(config)# interface ethernet 1/1
               

              インターフェイスを指定します。

               
              ステップ 4 allocate interface ethernet <slot-port>


              例:
              switch(config)# allocate interface ethernet 1
               

              F2 インターフェイスを VDC に割り当てます。

               
              ステップ 5 switchport mode fex -fabric


              例:
              switch(config-if)# switchport mode fex -fabric
               

              FEX を設定します。

               
              ステップ 6 fex associate <FEX chassis number>


              例:
              switch(config-if)# fex associate 101
               

              シャーシを指定します。

               
              ステップ 7 channel-group <port-channel number>


              例:
              switch(config-if)# channel-group 1
               

              ポート チャネル番号を指定します。

               
              ステップ 8 no shutdown


              例:
              switch(config-if)# no shutdown
               

              ポートを起動します。

               
              ステップ 9int po <port-channel number>


              例:
              switch(config-if)# int po 1
               

              ポート チャネルを指定します。

               
              ステップ 10no shutdown


              例:
              switch(config-if)# no shutdown
               

              ポート チャネルを起動します。

               

              ファブリック エクステンダのグローバル機能の設定

              ファブリック エクステンダのグローバル機能を設定できます。

              はじめる前に

              ファブリック エクステンダ機能セットをイネーブルにしていることを確認します。

              正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

              手順の概要

                1.    configure terminal

                2.    fex FEX-number

                3.    (任意) description desc

                4.    (任意) no description

                5.    (任意) type FEX-type

                6.    (任意) no type

                7.    (任意) serial serial

                8.    (任意) no serial


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1 configure terminal


                例:
                switch# configure terminal
                switch(config)# 
                 

                コンフィギュレーション モードに入ります。

                 
                ステップ 2 fex FEX-number


                例:
                switch(config)# fex 101
                switch(config-fex)# 
                 

                指定されたファブリック エクステンダの設定モードを開始します。 FEX-number の範囲は 101 ~ 199 です。

                 
                ステップ 3 description desc


                例:
                switch(config-fex)# description Rack7A-N2K
                 
                (任意)

                説明を指定します。 デフォルトは、文字列 FEXxxxx で、xxxx は FEX-number です。 FEX-number が 123 の場合、説明は FEX0123 です。

                 
                ステップ 4 no description


                例:
                switch(config-fex)# no description
                 
                (任意)

                説明を削除します。

                 
                ステップ 5type FEX-type


                例:
                switch(config-fex)# type N2248T
                 
                (任意)

                ファブリック エクステンダのタイプを指定します。 FEX-type は次のいずれかです。

                • N2224TP:24 個の 100 Base-T/1000Base-T イーサネット ホスト インターフェイスと 2 個の 10 ギガビット SFP+ イーサネット ファブリック インターフェイス モジュール
                • N2232P および N2232TM:32 個の 10 ギガビット SFP+ イーサネット ホスト インターフェイスと 8 個の 10 ギガビット SFP+ イーサネット ファブリック インターフェイス モジュール
                • N2248T および N2248TP-E:48 個の 100 ギガビット Base-T/1000Base-T+ イーサネット ホスト インターフェイスと 4 個の 10 ギガビット SFP+ イーサネット ファブリック インターフェイス モジュール

                Cisco Nexus シリーズの親デバイスは、バイナリ コンフィギュレーションにあるファブリック エクステンダのタイプを記憶します。 この機能が設定されると、ファブリック エクステンダがオンラインになるのは、そのタイプが設定済みの FEX-type と一致する場合だけです。

                 
                ステップ 6no type


                例:
                switch(config-fex)# no type
                 
                (任意)

                FEX のタイプを削除します。 ファブリック エクステンダがファブリック インターフェイスに接続されており、親スイッチのバイナリ設定に保存された設定済みタイプが一致していなければ、ファブリック エクステンダのすべてのインターフェイスのすべての設定が削除されます。

                 
                ステップ 7 serial serial


                例:
                switch(config-fex)# serial JAF1339BDSK
                 
                (任意)

                シリアル番号文字列を定義します。 このコマンドが設定され、ファブリック エクステンダが一致するシリアル番号文字列を報告する場合、スイッチでは、対応するシャーシ ID だけが関連付けることができます(fex associate コマンドを使用します)。

                注意       

                指定されたファブリック エクステンダに一致しないシリアル番号を設定すると、ファブリック エクステンダが強制的にオフラインになります。

                 
                ステップ 8 no serial


                例:
                switch(config-fex)# no serial
                 
                (任意)

                シリアル番号文字列を削除します。

                 

                設定例

                ここでは、FEX の設定例を示します。

                レイヤ 3 ホスト インターフェイスでの FEX の設定

                次に、レイヤ 3 ホスト インターフェイスでファブリック エクステンダを設定する例を示します(インターフェイス レベル、サブ インターフェイス レベル、ポート チャネル レベル、およびポート チャネル サブ インターフェイス レベルで)。

                レイヤ 3 の設定 レイヤ 3 サブインターフェイスの設定
                config t
                interface ethernet 101/1/1
                no switchport
                ip address 192.0.1.1/24
                Mtu 9000
                no shutdown
                
                config t
                interface ethernet 101/1/1.12
                ip address 192.0.2.1/24
                encapsulation dot1Q 12
                mtu 850
                no shutdown
                
                レイヤ 3 ホスト インターフェイス ポート チャネルの設定 レイヤ 3 ホスト インターフェイス ポート チャネル サブ インターフェイスの設定
                config t
                interface ethernet 101/1/1-2
                no switchport
                channel-group 12
                no shutdown
                
                interface port-channel 12
                ip address 192.0.3.1/24
                mtu 2000
                no shutdown
                
                config t
                interface ethernet 101/1/1-2
                no switchport
                channel-group 12
                no shutdown
                
                interface port-channel 12.14
                ip address 192.0.4.1/24
                encapsulation dot1Q 14
                mtu 1700
                no shutdown
                

                (注)  


                レイヤ 3 ホスト インターフェイス(HIF)またはホスト インターフェイス ポート チャネル(HIFPC)サブ インターフェイスで使用される VLAN は、親インターフェイスに対してのみローカルな重要性を持ちます。 同じ VLAN ID は、同じスイッチまたは VDC のレイヤ 3 サブインターフェイス間で再利用できます。


                2 つの FEX に接続された vPC トポロジでのホスト インターフェイスの設定

                次に、FEX(2 つの異なる FEX に接続するホスト vPC)でホスト vPC を設定する方法の例を示します。

                スイッチ 1 の設定 スイッチ 2 の設定
                config t
                feature lacp
                int e101/1/1-2
                channel-group 12 mode active
                no shutdown
                
                Int port-channel10
                switchport
                  switchport mode trunk
                  switchport trunk allowed vlan 1-20
                vpc 10
                
                config t
                feature lacp
                int e101/1/1-2
                channel-group 12 mode active
                no shutdown
                
                Int port-channel10
                switchport
                  switchport mode trunk
                  switchport trunk allowed vlan 1-20
                vpc 10
                

                FabricPath での FEX へのサーバのデュアル ホーミング

                FabricPath で接続された 2 つの Cisco Nexus 7000 スイッチの FabricPath インターフェイスを設定するには、各スイッチ上で次のタスクを実行します。

                • 各スイッチで FabricPath をイネーブルにします。
                • FabricPath インターフェイスとして指定するインターフェイスを設定します。
                • すべての FabricPath レイヤ 2 ゲートウェイ デバイスの STP プライオリティ デバイスを 8192 に設定します。
                • (任意)FabricPath ネットワークに接続されている別個の STP ドメインごとに、STP ドメイン ID を設定します。
                • (任意)FEX スイッチ ID を設定します。

                FabricPath インターフェイスを設定するには、次の手順を実行します。

                1. (任意)各スイッチで FabricPath をイネーブルにします。
                  switch# config terminal
                  switch(config)# feature fabricpath
                  switch(config-lldp)# exit
                  switch(config)# 
                2. スイッチで FabricPath をイネーブルにした後、指定のインターフェイスを FabricPath インターフェイスとして設定します。
                  switch(config)# interface ethernet 1/2
                  switch(config-if)# switchport mode fabricpath 
                  switch(config-if)# exit
                  switch(config)# 
                3. すべての Rapid PVST+ VLAN の STP プライオリティを 8192 に設定します。
                  switch# config terminal 
                  switch(config)# spanning-tree vlan 11-20 priority 8192
                  switch(config)# 
                4. すべての MST インスタンスの STP プライオリティを 8192 に設定します。
                  switch# config terminal 
                  switch(config)# spanning-tree mst 1-5 priority 8192
                  switch(config)# 
                5. (任意)FabricPath ネットワークに接続された各 FabricPath レイヤ 2 ゲートウェイ スイッチに STP ドメイン ID を設定します。
                  switch# config terminal 
                  switch(config)# spanning-tree domain 5
                  switch(config)
                6. (任意)FEX スイッチ ID を設定します。

                  (注)  


                  FEX の設定の詳細については、『Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide』を参照してください。



                  (注)  


                  FEX VPC+ の設定は F2 モジュールだけでサポートされています。


                  F シリーズ モジュールで最初の FEX VPC+ 設定を設定する場合は、次の手順を実行します。
                  1. VPC ドメイン コンフィギュレーション モードで、fabricpath multicast load-balance コマンドで部分 DF モードをイネーブルにします。
                  2. ディセーブルの場合、mac address-table core-port-learning コマンドで、TRILL スタイルの MAC アドレス ラーニングをイネーブルにします。
                  3. VPC ドメイン コンフィギュレーション モードで、fabricpath switchid <switchid#> コマンドを使用してエミュレート スイッチ ID を設定します。
                  4. インターフェイス コンフィギュレーション モードの各 VPC/VPC+ ピア リンク インターフェイスで、switchport mode fabricpath コマンドを入力します。
                  5. 各 VPC/VPC+ ピアリンク ポート チャネルで、VPC peer-link コマンドを入力します。
                  6. vpc vpcid コマンドで VPC ID を設定します。
                  F シリーズ モジュールで既存の FEX VPC 設定を FEX VPC+ 設定に変更する場合は、次の手順を実行します。
                  1. VPC ドメイン コンフィギュレーション モードで、fabricpath multicast load-balance コマンドで部分 DF モードをイネーブルにします。
                  2. ディセーブルの場合、mac address-table core-port-learning コマンドで、TRILL スタイルの MAC アドレス ラーニングをイネーブルにします。
                  3. VPC ドメイン コンフィギュレーション モードで、fabricpath switchid <switchid#> コマンドを使用してエミュレート スイッチ ID を設定します。
                7. 設定をコピーします。
                  switch(config)# copy running-config startup-config
                  switch(config)#

                設定の確認

                ここでは、ファブリック エクステンダの設定を表示する方法およびシャーシのハードウェア ステータスを確認する方法について説明します。

                ファブリック エクステンダ設定の確認

                ファブリック エクステンダで定義されているインターフェイスの設定情報を表示するには、次のいずれかの作業を実行します。

                コマンドまたはアクション

                目的

                show fex [FEX-number] [detail]

                特定のファブリック エクステンダまたは接続されているすべての装置の情報を表示します。

                show interface type number fex-intf

                特定のスイッチ インターフェイスにピン接続されているファブリック エクステンダのポートを表示します。

                show interface fex-fabric

                ファブリック エクステンダのアップリンクを検出しているスイッチ インターフェイスを表示します。

                show interface ethernet number transceiver [fex-fabric]

                ファブリック エクステンダのアップリンクの SFP+ トランシーバおよび Diagnostic Optical Monitoring(DOM)の情報を表示します。

                show feature-set

                デバイスフィーチャ セットのステータスを表示します。

                ファブリック エクステンダの設定例

                次に、接続されているすべてのファブリック エクステンダ装置を表示する例を示します。

                switch# show fex
                  FEX         FEX           FEX                       FEX
                Number    Description      State            Model            Serial
                ------------------------------------------------------------------------
                101        FEX0101            Online     N2K-C2248TP-1GE   JAF1418AARL
                 

                次に、特定のファブリック エクステンダの詳細なステータスを表示する例を示します。

                switch# show fex 101 detail
                FEX: 101 Description: FEX0101   state: Online
                  FEX version: 5.1(1) [Switch version: 5.1(1)]
                  FEX Interim version: 5.1(0.159.6)
                  Switch Interim version: 5.1(1)
                  Extender Model: N2K-C2248TP-1GE,  Extender Serial: JAF1418AARL
                  Part No: 73-12748-05
                  Card Id: 99, Mac Addr: 54:75:d0:a9:49:42, Num Macs: 64
                  Module Sw Gen: 21  [Switch Sw Gen: 21]
                 pinning-mode: static    Max-links: 1
                  Fabric port for control traffic: Po101
                  Fabric interface state:
                    Po101 - Interface Up. State: Active
                    Eth2/1 - Interface Up. State: Active
                    Eth2/2 - Interface Up. State: Active
                    Eth4/1 - Interface Up. State: Active
                    Eth4/2 - Interface Up. State: Active
                  Fex Port        State  Fabric Port  Primary Fabric
                       Eth101/1/1    Up       Po101       Po101
                       Eth101/1/2    Up       Po101       Po101
                       Eth101/1/3  Down       Po101       Po101
                       Eth101/1/4  Down       Po101       Po101
                       Eth101/1/5  Down       Po101       Po101
                       Eth101/1/6  Down       Po101       Po101
                       Eth101/1/7  Down       Po101       Po101
                       Eth101/1/8  Down       Po101       Po101
                       Eth101/1/9  Down       Po101       Po101
                      Eth101/1/10  Down       Po101       Po101
                      Eth101/1/11  Down       Po101       Po101
                      Eth101/1/12  Down       Po101       Po101
                      Eth101/1/13  Down       Po101       Po101
                      Eth101/1/14  Down       Po101       Po101
                      Eth101/1/15  Down       Po101       Po101
                      Eth101/1/16  Down       Po101       Po101
                      Eth101/1/17  Down       Po101       Po101
                      Eth101/1/18  Down       Po101       Po101
                      Eth101/1/19  Down       Po101       Po101
                      Eth101/1/20  Down       Po101       Po101
                      Eth101/1/21  Down       Po101       Po101
                      Eth101/1/22  Down       Po101       Po101
                      Eth101/1/23  Down       Po101       Po101
                      Eth101/1/24  Down       Po101       Po101
                      Eth101/1/25  Down       Po101       Po101
                      Eth101/1/26  Down       Po101       Po101
                      Eth101/1/27  Down       Po101       Po101
                      Eth101/1/28  Down       Po101       Po101
                      Eth101/1/29  Down       Po101       Po101
                      Eth101/1/30  Down       Po101       Po101
                      Eth101/1/31  Down       Po101       Po101
                      Eth101/1/32  Down       Po101       Po101
                      Eth101/1/33  Down       Po101       Po101
                      Eth101/1/34  Down       Po101       Po101
                      Eth101/1/35  Down       Po101       Po101
                      Eth101/1/36  Down       Po101       Po101
                      Eth101/1/37  Down       Po101       Po101
                      Eth101/1/38  Down       Po101       Po101
                      Eth101/1/39  Down       Po101       Po101
                      Eth101/1/40  Down       Po101       Po101
                      Eth101/1/41  Down       Po101       Po101
                      Eth101/1/42  Down       Po101       Po101
                      Eth101/1/43  Down       Po101       Po101
                      Eth101/1/44  Down       Po101       Po101
                      Eth101/1/45  Down       Po101       Po101
                      Eth101/1/46  Down       Po101       Po101
                      Eth101/1/47  Down       Po101       Po101
                      Eth101/1/48  Down       Po101       Po101
                Logs:
                09/21/2010 21:14:26.843850: Module register received
                09/21/2010 21:14:26.845778: Registration response sent
                09/21/2010 21:14:27.663073: Module Online Sequence
                09/21/2010 21:14:30.191121: Module Online
                 

                次に、特定のスイッチ インターフェイスにピン接続されているファブリック エクステンダのインターフェイスを表示する例を示します。

                switch# show interface port-channel 101 fex-intf
                Fabric           FEX
                Interface        Interfaces
                ---------------------------------------------------
                 Po101           Eth101/1/2    Eth101/1/1
                 

                次に、ファブリック エクステンダのアップリンクに接続されているスイッチ インターフェイスを表示する例を示します。

                switch# show interface fex-fabric
                     Fabric      Fabric       Fex                FEX
                Fex  Port      Port State    Uplink    Model         Serial
                ---------------------------------------------------------------
                101    Eth2/1        Active     1    N2K-C2248TP-1GE  JAF1418AARL
                101    Eth2/2        Active     2    N2K-C2248TP-1GE  JAF1418AARL
                101    Eth4/1        Active     3    N2K-C2248TP-1GE  JAF1418AARL
                101    Eth4/2        Active     4    N2K-C2248TP-1GE  JAF1418AARL
                 

                次に、親スイッチ インターフェイスに接続されている SPF+ トランシーバのファブリック エクステンダのアップリンクの SFP+ トランシーバおよび Diagnostic Optical Monitoring(DOM)情報を表示する例を示します。

                switch# show interface ethernet 1/40 transceiver
                Ethernet1/40
                    sfp is present
                    name is CISCO-MOLEX INC
                    part number is 74752-9026
                    revision is A0
                    serial number is MOC13321057
                    nominal bitrate is 12000 MBits/sec
                    Link length supported for copper is 3 m(s)
                    cisco id is --
                    cisco extended id number is 4
                 

                次に、ファブリック エクステンダのアップリンク ポートに接続されている SPF+ トランシーバのファブリック エクステンダのアップリンクの SFP+ トランシーバおよび DOM 情報を表示する例を示します。

                switch# show interface ethernet 1/40 transceiver fex-fabric
                Ethernet1/40
                    sfp is present
                    name is CISCO-MOLEX INC
                    part number is 74752-9026
                    revision is A0
                    serial number is MOC13321057
                    nominal bitrate is 12000 MBits/sec
                    Link length supported for 50/125mm fiber is 0 m(s)
                    Link length supported for 62.5/125mm fiber is 0 m(s)
                    cisco id is --
                    cisco extended id number is 4
                 

                次に、デバイスのフィーチャ セットのステータスを表示する例を示します。

                switch# show feature-set
                Feature Set Name      ID        State
                --------------------  --------  --------
                fcoe                   1          installed
                fabricpath             2          enabled
                fex                    3          enabled
                switch#
                 

                次に、ファブリック エクステンダ機能セットで使用されているサービスを表示する例を示します。

                switch# show feature-set services fex
                vntag_mgr
                fex
                2 services in feature set fex
                switch#
                 

                シャーシ管理情報の確認

                ファブリック エクステンダを管理するためにスイッチ スーパーバイザで使用される設定情報を表示するには、次のいずれかの作業を実行します。

                コマンドまたはアクション

                目的

                show environment fex {all | FEX-number} [temperature | power | fan]

                環境センサーのステータスを表示します。

                show inventory fex FEX-number

                ファブリック エクステンダのコンポーネント情報を表示します。

                show module fex FEX-number

                ファブリック エクステンダのモジュール情報を表示します。

                show sprom fex FEX-number {all | backplane | powersupply ps-num} | all

                ファブリック エクステンダのシリアル PROM(SPROM)の内容を表示します。

                シャーシ管理の設定例

                次に、接続されているすべてのファブリック エクステンダ装置のモジュール情報を表示する例を示します。

                switch# show module fex
                
                FEX Mod Ports Card Type                          Model              Status.
                --- --- ----- ---------------------------------- ------------------ -----------
                101  1  48    Fabric Extender 48x1GE + 4x10G M   N2K-C2248TP-1GE    ok
                
                FEX Mod Sw              Hw      World-Wide-Name(s) (WWN)
                --- --- --------------  ------  -----------------------------------------------
                101  1  5.1(1)          3.5     --
                FEX Mod  MAC-Address(es)                         Serial-Num
                --- ---  --------------------------------------  ----------
                101  1   5475.d0a9.4940 to 5475.d0a9.496f        JAF1418AARL
                 

                次に、特定のファブリック エクステンダのコンポーネント情報を表示する例を示します。

                switch# show inventory fex 101
                NAME: "FEX 101 CHASSIS", DESCR: "N2K-C2248TP-1GE  CHASSIS"
                PID: N2K-C2248TP-1GE   , VID: V00 , SN: SSI13380FSM
                
                NAME: "FEX 101 Module 1", DESCR: "Fabric Extender Module: 48x1GE, 4x10GE Supervisor"
                PID: N2K-C2248TP-1GE   , VID: V00 , SN: JAF1339BDSK
                
                NAME: "FEX 101 Fan 1", DESCR: "Fabric Extender Fan module"
                PID: N2K-C2248-FAN     , VID: N/A , SN: N/A
                
                NAME: "FEX 101 Power Supply 2", DESCR: "Fabric Extender AC power supply"
                PID: NXK-PAC-400W      , VID:  000, SN:      LIT13370QD6
                 

                次に、特定のファブリック エクステンダの環境ステータスの結果を表示する例を示します。

                switch# show environment fex 101
                
                
                Temperature Fex 101:
                -----------------------------------------------------------------
                Module   Sensor     MajorThresh   MinorThres   CurTemp     Status
                                    (Celsius)     (Celsius)    (Celsius)
                -----------------------------------------------------------------
                1        Outlet-1   60            50           33          ok
                1        Outlet-2   60            50           38          ok
                1        Inlet-1    50            40           35          ok
                1        Die-1      100           90           44          ok
                
                
                Fan Fex: 101:
                ------------------------------------------------------
                Fan             Model                Hw         Status
                ------------------------------------------------------
                Chassis         N2K-C2148-FAN        --         ok
                PS-1            --                   --         absent
                PS-2            NXK-PAC-400W         --         ok
                
                
                Power Supply Fex 101:
                ---------------------------------------------------------------------------
                Voltage: 12 Volts
                -----------------------------------------------------
                PS  Model                Power       Power     Status
                                         (Watts)     (Amp)
                -----------------------------------------------------
                1   --                        --        --     --
                2   NXK-PAC-400W            4.32      0.36     ok
                
                
                Mod Model                Power     Power       Power     Power       Status
                                         Requested Requested   Allocated Allocated
                                         (Watts)   (Amp)       (Watts)   (Amp)
                --- -------------------  -------   ----------  --------- ----------  ----------
                1    N2K-C2248TP-1GE     0.00      0.00        0.00      0.00        powered-up
                
                
                Power Usage Summary:
                --------------------
                Power Supply redundancy mode:                 redundant
                
                Total Power Capacity                                4.32 W
                
                Power reserved for Supervisor(s)                    0.00 W
                Power currently used by Modules                     0.00 W
                
                                                                -------------
                Total Power Available                               4.32 W
                                                                -------------
                 

                次に、特定のファブリック エクステンダの SPROM を表示する例を示します。

                switch# show sprom fex 101 all
                DISPLAY FEX 101 SUP sprom contents
                Common block:
                 Block Signature : 0xabab
                 Block Version   : 3
                 Block Length    : 160
                 Block Checksum  : 0x1a1e
                 EEPROM Size     : 65535
                 Block Count     : 3
                 FRU Major Type  : 0x6002
                 FRU Minor Type  : 0x0
                 OEM String      : Cisco Systems, Inc.
                 Product Number  : N2K-C2248TP-1GE
                 Serial Number   : JAF1339BDSK
                 Part Number     : 73-12748-01
                 Part Revision   : 11
                 Mfg Deviation   : 0
                 H/W Version     : 0.103
                 Mfg Bits        : 0
                 Engineer Use    : 0
                 snmpOID         : 9.12.3.1.9.78.3.0
                 Power Consump   : 1666
                 RMA Code        : 0-0-0-0
                 CLEI Code       : XXXXXXXXXTBDV00
                 VID             : V00
                Supervisor Module specific block:
                 Block Signature : 0x6002
                 Block Version   : 2
                 Block Length    : 103
                 Block Checksum  : 0x2686
                 Feature Bits    : 0x0
                 HW Changes Bits : 0x0
                 Card Index      : 11016
                 MAC Addresses   : 00-00-00-00-00-00
                 Number of MACs  : 0
                 Number of EPLD  : 0
                 Port Type-Num   : 1-48;2-4
                 Sensor #1       : 60,50
                 Sensor #2       : 60,50
                 Sensor #3       : -128,-128
                 Sensor #4       : -128,-128
                 Sensor #5       : 50,40
                 Sensor #6       : -128,-128
                 Sensor #7       : -128,-128
                 Sensor #8       : -128,-128
                 Max Connector Power: 4000
                 Cooling Requirement: 65
                 Ambient Temperature: 40
                
                DISPLAY FEX 101 backplane sprom contents:
                Common block:
                 Block Signature : 0xabab
                 Block Version   : 3
                 Block Length    : 160
                 Block Checksum  : 0x1947
                 EEPROM Size     : 65535
                 Block Count     : 5
                 FRU Major Type  : 0x6001
                 FRU Minor Type  : 0x0
                 OEM String      : Cisco Systems, Inc.
                 Product Number  : N2K-C2248TP-1GE
                 Serial Number   : SSI13380FSM
                 Part Number     : 68-3601-01
                 Part Revision   : 03
                 Mfg Deviation   : 0
                 H/W Version     : 1.0
                 Mfg Bits        : 0
                 Engineer Use    : 0
                 snmpOID         : 9.12.3.1.3.914.0.0
                 Power Consump   : 0
                 RMA Code        : 0-0-0-0
                 CLEI Code       : XXXXXXXXXTDBV00
                 VID             : V00
                Chassis specific block:
                 Block Signature : 0x6001
                 Block Version   : 3
                 Block Length    : 39
                 Block Checksum  : 0x2cf
                 Feature Bits    : 0x0
                 HW Changes Bits : 0x0
                 Stackmib OID    : 0
                 MAC Addresses   : 00-0d-ec-e3-28-00
                 Number of MACs  : 64
                 OEM Enterprise  : 0
                 OEM MIB Offset  : 0
                 MAX Connector Power: 0
                WWN software-module specific block:
                 Block Signature : 0x6005
                 Block Version   : 1
                 Block Length    : 0
                 Block Checksum  : 0x66
                wwn usage bits:
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00 00 00 00 00 00 00
                 00 00
                License software-module specific block:
                 Block Signature : 0x6006
                 Block Version   : 1
                 Block Length    : 16
                 Block Checksum  : 0x86f
                lic usage bits:
                 ff ff ff ff ff ff ff ff
                
                DISPLAY FEX 101 power-supply 2 sprom contents:
                Common block:
                 Block Signature : 0xabab
                 Block Version   : 3
                 Block Length    : 160
                 Block Checksum  : 0x1673
                 EEPROM Size     : 65535
                 Block Count     : 2
                 FRU Major Type  : 0xab01
                 FRU Minor Type  : 0x0
                 OEM String      : Cisco Systems Inc   NXK-PAC-400W
                 Product Number  : NXK-PAC-400W
                 Serial Number   :      LIT13370QD6
                 Part Number     :         341
                 Part Revision   : -037
                 CLEI Code       : 5-01     01  000
                 VID             :  000
                 snmpOID         : 12336.12336.12336.12336.12336.12336.12374.12336
                 H/W Version     : 43777.2
                 Current         : 36
                 RMA Code        : 200-32-32-32
                Power supply specific block:
                 Block Signature : 0x0
                 Block Version   : 0
                 Block Length    : 0
                 Block Checksum  : 0x0
                 Feature Bits    : 0x0
                 Current 110v    : 36
                 Current 220v    : 36
                 Stackmib OID    : 0
                 

                その他の関連資料

                ここではCisco Nexus 2000 シリーズ ファブリック エクステンダの設定に関する追加情報について説明します。

                関連資料

                関連項目

                参照先

                Cisco NX-OS のライセンス

                『Cisco NX-OS Licensing Guide』

                仮想デバイス コンテキスト(VDC)

                『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide』

                インターフェイス コンフィギュレーション

                『Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide』

                コマンド リファレンス

                『Cisco Nexus 7000 Series Command References』は、次の URL から入手できます。http:/​/​www.cisco.com/​en/​US/​products/​ps9402/​prod_​command_​reference_​list.html

                機能の履歴

                次の表に、この機能のリリースの履歴を示します。

                表 1  Cisco Nexus 2000 シリーズ ファブリック エクステンダの機能の履歴
                機能名 リリース 機能情報

                Cisco Nexus 7000 シリーズのサポート

                6.1(1)

                48 ポート、100/1000BASE-T(100 Mb/1 ギガビット)N2248TP-E、および 32 ポート 10 ギガビット SFP+ N2248TP-E に FEX が接続された場合のサポートが追加されました。

                M2 シリーズ モジュールのサポート

                6.1(1)

                M2 シリーズ モジュールのサポート。

                Cisco Nexus 7000 シリーズのサポート

                6.0(1)

                FEX が 48 ポート、1/10 ギガビット F2 モジュール(N7K-F248XP-25)に接続されている場合のサポートが追加されました。

                Cisco Nexus 7000 シリーズ のサポート

                5.1(1)

                32 ポート、10 ギガビット M1 モジュール(N7K-M132XP-12)または 32 ポート、10 ギガビット M1 XL モジュール(N7K-M132XP-12L)に FEX が接続されている場合のサポートが追加されました。

                フィーチャ セットのコマンド

                5.1(1)

                ファブリック エクステンダは、親である Cisco Nexus 7000 シリーズ デバイス上で、install feature-set コマンドおよび feature-set コマンドによりイネーブルになります。

                ポート チャネルおよび vPC のサポート

                5.2(1)

                vPC ポート チャネルおよびホスト インターフェイス上での統合に対するサポートが追加されました。

                レイヤ 3 サポート

                5.2(1)

                IPv4 および IPv6 および IGMP スヌーピングを含むファブリック エクステンダ ホスト インターフェイス ポートに、レイヤ 3 機能が追加されました。