Cisco Nexus 2000 シリーズ Fabric Extender ソフトウェア コンフィギュレーション ガイド
Fabric Extender の設定
Fabric Extender の設定
発行日;2012/02/02 | 英語版ドキュメント(2009/02/26 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 749KB) | フィードバック

目次

Fabric Extender の設定

のファブリック インターフェイスへの関連付け

のイーサネット インターフェイスへの関連付け

の EtherChannel への関連付け

とインターフェイスとの関連付けの解除

の設定

リンクの再配布

リンク数の変更

ピン接続順序の維持

のアップグレード

情報の表示

設定情報の表示

シャーシ管理情報の表示

Fabric Extender の設定

この章では、Cisco Nexus 2000 シリーズ Fabric Extender を Cisco Nexus 5000 シリーズ スイッチに接続するための設定方法について説明します。この章の内容は、次のとおりです。

「Fabric Extender のファブリック インターフェイスへの関連付け」

「Fabric Extender の設定」

「リンクの再配布」

「Fabric Extender のアップグレード」

「Fabric Extender 情報の表示」

Fabric Extender のファブリック インターフェイスへの関連付け

Fabric Extender は物理的なイーサネット インターフェイスまたは EtherChannel を介してスイッチに接続されます。Fabric Extender は、デフォルトでは、シャーシ ID を割り当てるか、接続するインターフェイスに関連付けるまで、スイッチに接続できません。


) Fabric Extender は、複数の異なる物理イーサネット インターフェイスまたは最大 1 つの EtherChannel インターフェイスを介してスイッチに接続できます。



注意 リリース 4.0(1a)N2(1) では、Cisco Nexus 5000 シリーズ スイッチに含まれる拡張モジュールのイーサネット インターフェイスは Fabric Extender に接続できません。スイッチ シャーシ(スロット 1)上のイーサネット インターフェイスだけが、ファブリック インターフェイスとして使用できます。

ここで説明する内容は、次のとおりです。

「Fabric Extender のイーサネット インターフェイスへの関連付け」

「Fabric Extender の EtherChannel への関連付け」

「Fabric Extender とインターフェイスとの関連付けの解除」

Fabric Extender のイーサネット インターフェイスへの関連付け

Fabric Extender をイーサネット インターフェイスに関連付ける手順は、次のとおりです。

 

 
コマンド
目的

ステップ 1

switch# configure terminal

設定モードを開始します。

ステップ 2

switch(config)# interface ethernet slot / port

設定するイーサネット インターフェイスを指定します。

ステップ 3

switch(config-if)# switchport mode fex-fabric

外部 Fabric Extender をサポートするように、インターフェイスを設定します。

ステップ 4

switch(config-if)# fex associate chassis

インターフェイスに接続されている Fabric Extender 装置に、シャーシ ID を関連付けます。シャーシ ID の範囲は、100 ~ 199 です。

ステップ 5

switch# show interface ethernet port / slot fex-intf

(オプション)Fabric Extender のイーサネット インターフェイスへの関連付けを表示します。

次に、Fabric Extender をスイッチのイーサネット インターフェイスに関連付ける例を示します。

switch# configure terminal
switch(config)# interface ethernet 1/40
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100

次に、Fabric Extender とスイッチとの関連付けを表示する例を示します。

switch# show interface ethernet 1/40 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/40 Eth100/1/48 Eth100/1/47 Eth100/1/46 Eth100/1/45
Eth100/1/44 Eth100/1/43 Eth100/1/42 Eth100/1/41
Eth100/1/40 Eth100/1/39 Eth100/1/38 Eth100/1/37
Eth100/1/36 Eth100/1/35 Eth100/1/34 Eth100/1/33
Eth100/1/32 Eth100/1/31 Eth100/1/30 Eth100/1/29
Eth100/1/28 Eth100/1/27 Eth100/1/26 Eth100/1/25
Eth100/1/24 Eth100/1/23 Eth100/1/22 Eth100/1/21
Eth100/1/20 Eth100/1/19 Eth100/1/18 Eth100/1/17
Eth100/1/16 Eth100/1/15 Eth100/1/14 Eth100/1/13
Eth100/1/12 Eth100/1/11 Eth100/1/10 Eth100/1/9
Eth100/1/8 Eth100/1/7 Eth100/1/6 Eth100/1/5
Eth100/1/4 Eth100/1/3 Eth100/1/2 Eth100/1/1

Fabric Extender の EtherChannel への関連付け

Fabric Extender を EtherChannel に関連付ける手順は、次のとおりです。

 

 
コマンド
目的

ステップ 1

switch# configure terminal

設定モードを開始します。

ステップ 2

switch(config)# interface port-channnel channel

設定する EtherChannel を指定します。

ステップ 3

switch(config-if)# switchport mode fex-fabric

外部 Fabric Extender をサポートするように、EtherChannel を設定します。

ステップ 4

switch(config-if)# fex associate chassis

インターフェイスに接続されている Fabric Extender 装置に、シャーシ ID を関連付けます。シャーシ ID の範囲は、100 ~ 199 です。

ステップ 5

switch# show interface port-channel channel fex-intf

(オプション)Fabric Extender の EtherChannel インターフェイスへの関連付けを表示します。

次に、Fabric Extender をスイッチの EtherChannel インターフェイスに関連付ける例を示します。

switch# configure terminal
switch(config)# interface port-channel 4
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# exit
switch(config)# interface ethernet 1/37
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 4
switch(config-if)# exit
switch(config)# interface ethernet 1/38
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 4
switch(config-if)# exit
switch(config)# interface ethernet 1/39
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 4
switch(config-if)# exit
switch(config)# interface ethernet 1/40
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 4

) 上記の例に示されているように、EtherChannel のメンバーの各イーサネット インターフェイスをファブリック インターフェイスとして関連付ける必要があります。


次に、Fabric Extender とスイッチとの関連付けを表示する例を示します。

switch# show interface port-channel 4 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Po4 Eth100/1/48 Eth100/1/47 Eth100/1/46 Eth100/1/45
Eth100/1/44 Eth100/1/43 Eth100/1/42 Eth100/1/41
Eth100/1/40 Eth100/1/39 Eth100/1/38 Eth100/1/37
Eth100/1/36 Eth100/1/35 Eth100/1/34 Eth100/1/33
Eth100/1/32 Eth100/1/31 Eth100/1/30 Eth100/1/29
Eth100/1/28 Eth100/1/27 Eth100/1/26 Eth100/1/25
Eth100/1/24 Eth100/1/23 Eth100/1/22 Eth100/1/21
Eth100/1/20 Eth100/1/19 Eth100/1/18 Eth100/1/17
Eth100/1/16 Eth100/1/15 Eth100/1/14 Eth100/1/13
Eth100/1/12 Eth100/1/11 Eth100/1/10 Eth100/1/9
Eth100/1/8 Eth100/1/7 Eth100/1/6 Eth100/1/5
Eth100/1/4 Eth100/1/3 Eth100/1/2 Eth100/1/1

Fabric Extender とインターフェイスとの関連付けの解除

Fabric Extender とインターフェイスとの関連付けを解除する手順は、次のとおりです。

 

コマンド
目的

switch(config-if)# no fex associate

インターフェイスに接続されている Fabric Extender 装置の関連付けを解除します。

Fabric Extender の設定

Fabric Extender のグローバル機能を設定する手順は、次のとおりです。

 

 
コマンド
目的

ステップ 1

switch# configure terminal

設定モードを開始します。

ステップ 2

switch(config)# fex chassis

指定した Fabric Extender シャーシ ID の設定モードを開始します。シャーシ ID の範囲は、100 ~ 199 です。

ステップ 3

switch(config-fex)# description desc

説明を指定します。デフォルトは、文字列 FEX xxxx で、 xxxx はシャーシ ID です。シャーシ ID が 123 の場合、説明は FEX0123 です。

switch(config-fex)# no description

説明を削除します。

switch(config-fex)# pinning max-links uplinks

アップリンクの数を定義します。デフォルトは 1 です。範囲は、1 ~ 4 です。

このコマンドは、Fabric Extender が 1 つまたは複数の静的にピン接続されたファブリック インターフェイスを使用して親スイッチに接続されている場合だけ、適用できます。EtherChannel 接続は 1 つだけ可能です。

switch(config-fex)# no pinning max-links

アップリンクの数をデフォルトにリセットします。

switch(config-fex)# serial serial

シリアル番号文字列を定義します。このコマンドが設定され、Fabric Extender が一致するシリアル番号文字列を報告する場合、スイッチでは、対応するシャーシ ID だけが関連付けることができます( fex associate コマンドを使用します)。

使用する Fabric Extender のシリアル番号とは異なるシリアル番号を設定すると、Fabric Extender は強制的にオフラインになります。

switch(config-fex)# no serial

シリアル番号文字列を削除します。

switch(config-fex)# beacon

ビーコン LED を点灯します。この LED の点灯により、特定の Fabric Extender をラック内で見つけることができます。

switch(config-fex)# no beacon

ビーコン LED を消灯します。


注意 pinning max-links コマンドまたは no pinning max-links コマンドを使用してアップリンクの数を変更すると、Fabric Extender のすべてのホスト インターフェイス ポートは中断します。

リンクの再配布

静的にピン接続されたインターフェイス(「静的ピン接続ファブリック インターフェイス接続」を参照してください)を使用して Fabric Extender をプロビジョニングすると、Fabric Extender のダウンリンク ホスト インターフェイスは、最初に設定された順序でファブリック インターフェイスにピン接続されます。ファブリック インターフェイスへのホスト インターフェイスの特別な関係がリブートしても維持されるようにするには、リンクを再びピン接続する必要があります。

この機能は、次の 2 つの状況で行うことができます。

max-links 設定を変更する必要がある場合。

ファブリック インターフェイスへのホスト インターフェイスのピン接続順序を維持する必要がある場合。

リンク数の変更

最初に親スイッチのポート 33 を唯一のファブリック インターフェイスとして設定すると、48 のすべてのホスト インターフェイスがこのポートにピン接続されます。35 などの他のポートをプロビジョニングするには、 pinning max-links 2 コマンドを使用してホスト インターフェイスを再配布します。これにより、すべてのホスト インターフェイスがダウンし、ホスト インターフェイス 1 ~ 24 はファブリック インターフェイス 33 に、ホスト インターフェイス 25 ~ 48 はファブリック インターフェイス 35 にピン接続されます。

ピン接続順序の維持

ホスト インターフェイスのピン接続順序は、最初、ファブリック インターフェイスが設定された順序で決定されます。この例では、4 つのファブリック インターフェイスが次の順序で設定されます。

switch# show interface ethernet 1/35 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/35 Eth100/1/12 Eth100/1/11 Eth100/1/10 Eth100/1/9
Eth100/1/8 Eth100/1/7 Eth100/1/6 Eth100/1/5
Eth100/1/4 Eth100/1/3 Eth100/1/2 Eth100/1/1

switch# show interface ethernet 1/33 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/33 Eth100/1/24 Eth100/1/23 Eth100/1/22 Eth100/1/21
Eth100/1/20 Eth100/1/19 Eth100/1/18 Eth100/1/17
Eth100/1/16 Eth100/1/15 Eth100/1/14 Eth100/1/13

switch# show interface ethernet 1/38 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/38 Eth100/1/36 Eth100/1/35 Eth100/1/34 Eth100/1/33
Eth100/1/32 Eth100/1/31 Eth100/1/30 Eth100/1/29
Eth100/1/28 Eth100/1/27 Eth100/1/26 Eth100/1/25

switch# show interface ethernet 1/40 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/40 Eth100/1/48 Eth100/1/47 Eth100/1/46 Eth100/1/45
Eth100/1/44 Eth100/1/43 Eth100/1/42 Eth100/1/41
Eth100/1/40 Eth100/1/39 Eth100/1/38 Eth100/1/37

Fabric Extender を次回リブートすると、設定されたファブリック インターフェイスは、ファブリック インターフェイスのポート番号の昇順でホスト インターフェイスにピン接続されます。Fabric Extender を再起動せずに同じ固定配布でホスト インターフェイスを設定するには、 fex pinning redistribute コマンドを入力します(「静的ピン接続ファブリック インターフェイス接続」を参照してください)。

Fabric Extender でホスト インターフェイスを再配布する手順は、次のとおりです。

 

コマンド
目的

switch# fex pinning redistribute chassis

ホスト接続を再配布します。シャーシ ID の範囲は、100 ~ 199 です。

次に、Fabric Extender でホスト インターフェイスを再配布する例を示します。

switch# fex pinning redistribute 100

注意 fex pinning redistribute コマンドは、Fabric Extender のすべてのホスト インターフェイス ポートを中断します。

Fabric Extender のアップグレード

Cisco Nexus 2000 シリーズ Fabric Extender をアップグレードする手順は、次のとおりです。


ステップ 1 新しいキックスタート イメージとシステム イメージを親スイッチにダウンロードします。

ステップ 2 install all コマンドを入力します。

インストールが進行している間、Fabric Extender はオンラインに維持されます。

新しいイメージが親スイッチにより Fabric Extender にプッシュされます。ソフトウェア イメージが正常にインストールされると、親スイッチはリブートします。親スイッチと Fabric Extender との間のソフトウェア バージョンの互換性を維持するために、Fabric Extender も自動的にリブートされます。親スイッチはアップすると、Fabric Extender を再検出してオンラインにします。

この処理では、Fabric Extender に接続されているホストおよびサーバにおいて、ほとんど中断が発生しません。


 

Fabric Extender 情報の表示

ここでは、Fabric Extender の設定とステータスを表示する show コマンドについて、次の内容を説明します。

「設定情報の表示」

「シャーシ管理情報の表示」

設定情報の表示

定義されているインターフェイスの設定情報を表示するには、次のいずれかの作業を実行します。

 

コマンド
目的

switch# show fex [ chassis [ detail ]

特定の Fabric Extender または接続されているすべての装置の情報を表示します。

switch# show interface type number fex-intf

特定のスイッチ インターフェイスにピン接続されている Fabric Extender のポートを表示します。

switch# show interface fex-fabric

Fabric Extender のアップリンクを検出しているスイッチ インターフェイスを表示します。

次に、接続されているすべての Fabric Extender 装置を表示する例を示します。

switch# show fex
FEX FEX FEX FEX
Number Description State Model Serial
------------------------------------------------------------------------
100 FEX0100 Online N5K-C5110T-BF-1GE FOX1242GJSQ

次に、特定の Fabric Extender の詳細なステータスを表示する例を示します。

switch# show fex 100 detail
FEX: 100 Description: FEX0100 state: Online
FEX version: 4.0(1a)N2(0.101) [Switch version: 4.0(1a)N2(0.101)]
Extender Model: N5K-C5110T-BF-1GE, Extender Serial: JAF1241BLFN
Part No: 73-12009-02
Card Id: 70, Mac Addr: 00:0d:ec:b1:28:42, Num Macs: 64
Module Sw Gen: 17 [Switch Sw Gen: 17]
pinning-mode: static Max-links: 1
Fabric port for control traffic: Eth1/40
Fabric interface state:
Eth1/40 - Interface Up. State: Active
Fex Port State Fabric Port Primary Fabric
Eth100/1/1 Up Eth1/40 Eth1/40
Eth100/1/2 Down Eth1/40 Eth1/40
Eth100/1/3 Down Eth1/40 Eth1/40
Eth100/1/4 Down Eth1/40 Eth1/40
Eth100/1/5 Down Eth1/40 Eth1/40
Eth100/1/6 Down Eth1/40 Eth1/40
Eth100/1/7 Down Eth1/40 Eth1/40
Eth100/1/8 Down Eth1/40 Eth1/40
Eth100/1/9 Down Eth1/40 Eth1/40
Eth100/1/10 Down Eth1/40 Eth1/40
Eth100/1/11 Down Eth1/40 Eth1/40
Eth100/1/12 Down Eth1/40 Eth1/40
Eth100/1/13 Down Eth1/40 Eth1/40
Eth100/1/14 Down Eth1/40 Eth1/40
Eth100/1/15 Up Eth1/40 Eth1/40
Eth100/1/16 Down Eth1/40 Eth1/40
Eth100/1/17 Down Eth1/40 Eth1/40
Eth100/1/18 Down Eth1/40 Eth1/40
Eth100/1/19 Down Eth1/40 Eth1/40
Eth100/1/20 Down Eth1/40 Eth1/40
Eth100/1/22 Down Eth1/40 Eth1/40
Eth100/1/24 Down Eth1/40 Eth1/40
Eth100/1/25 Down Eth1/40 Eth1/40
Eth100/1/26 Down Eth1/40 Eth1/40
Eth100/1/27 Down Eth1/40 Eth1/40
Eth100/1/28 Down Eth1/40 Eth1/40
Eth100/1/29 Down Eth1/40 Eth1/40
Eth100/1/30 Down Eth1/40 Eth1/40
Eth100/1/31 Up Eth1/40 Eth1/40
Eth100/1/32 Down Eth1/40 Eth1/40
Eth100/1/33 Down Eth1/40 Eth1/40
Eth100/1/34 Down Eth1/40 Eth1/40
Eth100/1/35 Down Eth1/40 Eth1/40
Eth100/1/36 Down Eth1/40 Eth1/40
Eth100/1/37 Down Eth1/40 Eth1/40
Eth100/1/38 Down Eth1/40 Eth1/40
Eth100/1/39 Down Eth1/40 Eth1/40
Eth100/1/40 Down Eth1/40 Eth1/40
Eth100/1/41 Down Eth1/40 Eth1/40
Eth100/1/42 Down Eth1/40 Eth1/40
Eth100/1/43 Down Eth1/40 Eth1/40
Eth100/1/44 Down Eth1/40 Eth1/40
Eth100/1/45 Down Eth1/40 Eth1/40
Eth100/1/46 Down Eth1/40 Eth1/40
Eth100/1/47 Up Eth1/40 Eth1/40
Eth100/1/48 Down Eth1/40 Eth1/40
Logs:
[12/10/2008 00:11:40.698999] Module timed out
[12/10/2008 00:11:44.501221] Module register received
[12/10/2008 00:11:44.502240] Registration response sent
[12/10/2008 00:11:44.587581] Module Online Sequence
[12/10/2008 00:11:49.140170] Module Online
[12/10/2008 00:18:46.662135] Module disconnected
[12/10/2008 00:18:46.663222] Offlining Module
[12/10/2008 00:18:46.663856] Module Offline Sequence
[12/10/2008 00:18:49.317584] Module Offline
[12/10/2008 00:19:30.427864] Module register received
[12/10/2008 00:19:30.428875] Registration response sent
[12/10/2008 00:19:30.456882] Module Online Sequence
[12/10/2008 00:19:32.62827] Module Online
[12/10/2008 00:20:37.196648] Module disconnected
[12/10/2008 00:20:37.197782] Offlining Module
[12/10/2008 00:20:37.199299] Module Offline Sequence
[12/10/2008 00:20:39.859971] Module Offline
[12/10/2008 00:21:13.945372] Module register received
[12/10/2008 00:21:13.946435] Registration response sent
[12/10/2008 00:21:13.974962] Module Online Sequence
[12/10/2008 00:21:15.737667] Module Online

次に、特定のスイッチ インターフェイスにピン接続されている Fabric Extender のインターフェイスを表示する例を示します。

switch# show interface ethernet 1/40 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/40 Eth100/1/48 Eth100/1/47 Eth100/1/46 Eth100/1/45
Eth100/1/44 Eth100/1/43 Eth100/1/42 Eth100/1/41
Eth100/1/40 Eth100/1/39 Eth100/1/38 Eth100/1/37
Eth100/1/36 Eth100/1/35 Eth100/1/34 Eth100/1/33
Eth100/1/32 Eth100/1/31 Eth100/1/30 Eth100/1/29
Eth100/1/28 Eth100/1/27 Eth100/1/26 Eth100/1/25
Eth100/1/24 Eth100/1/22 Eth100/1/20 Eth100/1/19
Eth100/1/18 Eth100/1/17 Eth100/1/16 Eth100/1/15
Eth100/1/14 Eth100/1/13 Eth100/1/12 Eth100/1/11
Eth100/1/10 Eth100/1/9 Eth100/1/8 Eth100/1/7
Eth100/1/6 Eth100/1/5 Eth100/1/4 Eth100/1/3
Eth100/1/2 Eth100/1/1

次に、Fabric Extender のアップリンクに接続されているスイッチ インターフェイスを表示する例を示します。

switch# show interface fex-fabric
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
--- Eth1/1 Discovered 1 N5K-C5110T-BF-1GE FOX1242GJSQ
--- Eth1/2 Discovered 4 N5K-C5110T-BF-1GE FOX1242GJSQ
--- Eth1/3 Discovered 2 N5K-C5110T-BF-1GE FOX1242GJSQ
100 Eth1/40 Active 3 N5K-C5110T-BF-1GE FOX1242GJSQ

) 上記の例では、Fabric Extender に 4 つのアップリンク接続が設定されており、1 つだけが現在アクティブです。


次に、Fabric Extender のアップリンクの SFP+ トランシーバおよび Diagnostic Optical Monitoring(DOM)の情報を表示する例を示します。

switch# show interface ethernet 1/40 transceiver
Ethernet1/40
sfp is present
name is CISCO-EXCELIGHT
part number is SPP5101SR-C1
revision is A
serial number is ECL120901AV
nominal bitrate is 10300 MBits/sec
Link length supported for 50/125mm fiber is 82 m(s)
Link length supported for 62.5/125mm fiber is 26 m(s)
cisco id is --
cisco extended id number is 4
switch# show interface ethernet 1/40 transceiver fex-fabric
Ethernet1/40
sfp is present
name is CISCO-EXCELIGHT
part number is SPP5101SR-C1
revision is A
serial number is ECL120601U0
nominal bitrate is 10300 MBits/sec
Link length supported for 50/125mm fiber is 82 m(s)
Link length supported for 62.5/125mm fiber is 26 m(s)
cisco id is --
cisco extended id number is 4

) 上記の例の最初の show コマンドは、親スイッチのインターフェイスに接続されている SFP+ トランシーバを表示します。2 番目の show コマンドは、Fabric Extender のアップリンク ポートに接続されている SFP+ トランシーバを表示します。


シャーシ管理情報の表示

Fabric Extender を管理するためにスイッチ スーパーバイザで使用される設定情報を表示するには、次のいずれかの作業を実行します。

 

コマンド
目的

switch# show diagnostic result fex chassis

Fabric Extender のシャーシの診断テストの結果を表示します。

switch# show inventory fex chassis

Fabric Extender のシャーシのコンポーネント情報を表示します。

switch# show module fex chassis

Fabric Extender のシャーシのモジュール情報を表示します。

次に、接続されているすべての Fabric Extender 装置のモジュール情報を表示する例を示します。

switch# show module fex
FEX Mod Ports Card Type Model Status.
--- --- ----- ---------------------------------- ------------------ -----------
100 1 48 Fabric Extender 48x1GE Module N2K-C2148T-1GE ok

FEX Mod Sw Hw World-Wide-Name(s) (WWN)
--- --- -------------- ------ -----------------------------------------------
100 1 4.0(1a)N2(1) 0.2 --

FEX Mod MAC-Address(es) Serial-Num
--- --- -------------------------------------- ----------
100 1 000d.ecb1.3f00 to 000d.ecb1.3f2fff JAF1244ATER

次に、特定の Fabric Extender 装置のモジュール情報を表示する例を示します。

switch# show module fex 100
FEX Mod Ports Card Type Model Status.
--- --- ----- ---------------------------------- ------------------ -----------
100 1 48 Fabric Extender 48x1GE Module N2K-C2148T-1GE ok

FEX Mod Sw Hw World-Wide-Name(s) (WWN)
--- --- -------------- ------ -----------------------------------------------
100 1 4.0(1a)N2(1) 0.2 --

FEX Mod MAC-Address(es) Serial-Num
--- --- -------------------------------------- ----------
100 1 000d.ecb1.3f00 to 000d.ecb1.3f2fff JAF1244ATER

次に、特定の Fabric Extender 装置のコンポーネント情報を表示する例を示します。

switch# show inventory fex 100
NAME: "FEX 100 CHASSIS", DESCR: "N2K-C2148T-1GE CHASSIS"
PID: N2K-C2148T-1GE , VID: V00 , SN: JAF1244ATER

NAME: "FEX 100 Module 1", DESCR: "Fabric Extender Module: 48x1GE, 4X10GE Supervisor"
PID: N2K-C2148T-1GE , VID: V00 , SN: FOX1242GJT4

NAME: "FEX 100 Fan 1", DESCR: "Fabric Extender Fan module"
PID: N2K-C2148-FAN , VID: N/A , SN: N/A

NAME: "FEX 100 Power Supply 1", DESCR: "Fabric Extender AC power supply"
PID: N5K-PAC-200W , VID: 00V0, SN: PAC12473L2J

次に、特定の Fabric Extender 装置の診断テストの結果を表示する例を示します。

switch# show diagnostic result fex 100
FEX-100: 48x1GE/Supervisor SerialNo : JAF1241BLFN
Overall Diagnostic Result for FEX-100 : OK

Test results: (. = Pass, F = Fail, U = Untested)
TestPlatform:
0) SPROM: ---------------> .
1) MV88E6095: ---------------> .
2) Fan: ---------------> .
3) PowerSupply: ---------------> F
4) TempSensor: ---------------> .

TestForwardingPorts:
Eth 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
Port ------------------------------------------------------------------------
. . . . . . . . . . . . . . . . . . . . . . . .

Eth 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
Port ------------------------------------------------------------------------
. . . . . . . . . . . . . . . . . . . . . . . .

TestFabricPorts:
Fabric 1 2 3 4
Port ------------
. . . .

次に、特定の Fabric Extender 装置の環境ステータスの結果を表示する例を示します。

switch# show environment fex 100


Temperature Fex 100:
-----------------------------------------------------------------
Module Sensor MajorThresh MinorThres CurTemp Status
(Celsius) (Celsius) (Celsius)
-----------------------------------------------------------------
1 Outlet-1 60 50 29 ok
1 Inlet-1 50 40 21 ok


Fan Fex: 100:
------------------------------------------------------
Fan Model Hw Status
------------------------------------------------------
Chassis N2K-C2148-FAN -- ok
PS-1 N5K-PAC-200W -- failure
PS-2 N5K-PAC-200W -- ok


Power Supply Fex 100:
---------------------------------------------------------------------------
Voltage: 12 Volts
-----------------------------------------------------
PS Model Power Power Status
(Watts) (Amp)
-----------------------------------------------------
1 -- -- -- fail/shutdown
2 N5K-PAC-200W 200.04 16.67 ok


Mod Model Power Power Power Power Status
Requested Requested Allocated Allocated
(Watts) (Amp) (Watts) (Amp)
--- ------------------- ------- ---------- --------- ---------- ----------
1 N5K-C5110T-BF-1GE 96.00 8.00 96.00 8.00 powered-up


Power Usage Summary:
--------------------
Power Supply redundancy mode: redundant

Total Power Capacity 200.04 W

Power reserved for Supervisor(s) 96.00 W
Power currently used by Modules 0.00 W

-------------
Total Power Available 104.04 W
-------------

次に、特定の Fabric Extender 装置の SPROM を表示する例を示します。

switch# show sprom fex 100 all
DISPLAY FEX 100 SUP sprom contents
Common block:
Block Signature : 0xabab
Block Version : 3
Block Length : 160
Block Checksum : 0x1774
EEPROM Size : 4096
Block Count : 3
FRU Major Type : 0x6002
FRU Minor Type : 0x0
OEM String : Cisco Systems, Inc.
Product Number : N2K-C2148T-1GE
Serial Number : JAF1244ATER
Part Number : 73-12009-02
Part Revision : 07
Mfg Deviation : 0
H/W Version : 0.2
Mfg Bits : 0
Engineer Use : 0
snmpOID : 9.12.3.1.9.72.8.0
Power Consump : -800
RMA Code : 0-0-0-0
CLEI Code : COMEB00ARA
VID : V00
Supervisor Module specific block:
Block Signature : 0x6002
Block Version : 2
Block Length : 103
Block Checksum : 0x592
Feature Bits : 0x0
HW Changes Bits : 0x2
Card Index : 11011
MAC Addresses : 00-00-00-00-00-00
Number of MACs : 0
Number of EPLD : 0
Port Type-Num : 1-48;2-4
Sensor #1 : 60,50
Sensor #2 : 60,50
Sensor #3 : 60,50
Sensor #4 : 60,50
Sensor #5 : 50,40
Sensor #6 : 50,40
Sensor #7 : 50,40
Sensor #8 : 50,40
Max Connector Power: 1000
Cooling Requirement: 300
Ambient Temperature: 40

DISPLAY FEX 100 backplane sprom contents:
Common block:
Block Signature : 0xabab
Block Version : 3
Block Length : 160
Block Checksum : 0x173f
EEPROM Size : 65535
Block Count : 5
FRU Major Type : 0x6001
FRU Minor Type : 0x0
OEM String : Cisco Systems, Inc.
Product Number : N2K-C2148T-1GE
Serial Number : FOX1242GJT4
Part Number : 68-3342-02
Part Revision : 05
Mfg Deviation : 0
H/W Version : 0.0
Mfg Bits : 0
Engineer Use : 0
snmpOID : 9.12.3.1.3.820.0.0
Power Consump : 0
RMA Code : 0-0-0-0
CLEI Code : COMEB00ARA
VID : V00
Chassis specific block:
Block Signature : 0x6001
Block Version : 3
Block Length : 39
Block Checksum : 0x2b6
Feature Bits : 0x0
HW Changes Bits : 0x2
Stackmib OID : 0
MAC Addresses : 00-0d-ec-b1-3f-00
Number of MACs : 64
OEM Enterprise : 0
OEM MIB Offset : 0
MAX Connector Power: 0
WWN software-module specific block:
Block Signature : 0x6005
Block Version : 1
Block Length : 0
Block Checksum : 0x66
wwn usage bits:
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00
License software-module specific block:
Block Signature : 0x6006
Block Version : 1
Block Length : 16
Block Checksum : 0x77
lic usage bits:
00 00 00 00 00 00 00 00

DISPLAY FEX 100 power-supply 1 sprom contents:
Common block:
Block Signature : 0xabab
Block Version : 3
Block Length : 124
Block Checksum : 0x1610
EEPROM Size : 124
Block Count : 1
FRU Major Type : 0xab01
FRU Minor Type : 0x1
OEM String : Cisco Systems, Inc.
Product Number : N5K-PAC-200W
Serial Number : PAC12473L2J
Part Number : 341-0335-01
Part Revision : 01
CLEI Code : COUPADSBAA
VID : 00V0
snmpOID : 0.0.0.0.0.0.0.0
H/W Version : 0.1
Current : 1667
RMA Code : 0-0-0-0

DISPLAY FEX 100 power-supply 2 sprom contents:
Common block:
Block Signature : 0x0
Block Version : 0
Block Length : 0
Block Checksum : 0x0
EEPROM Size : 0
Block Count : 0
FRU Major Type : 0x0
FRU Minor Type : 0x0
OEM String :
Product Number :
Serial Number :
Part Number :
Part Revision :
CLEI Code :
VID : V00
snmpOID : 0.0.0.0.0.0.0.0
H/W Version : 0.0
Current : 0
RMA Code : 0-0-0-0