Cisco Nexus Virtual Services Appliance ソフトウェア インストレーション/ アップグレード ガイド リリース 4.2(1) SP1(5.1)
Cisco Virtual Services Applianceソフトウェア インストール
Cisco Virtual Services Applianceソフトウェア インストール
発行日;2012/11/26 | 英語版ドキュメント(2012/09/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

Cisco Virtual Services Applianceソフトウェア インストール

ソフトウェア インストールについて

前提条件

注意事項および制約事項

CIMC および BIOS 情報

Cisco CIMC ソフトウェアのバージョンの確認

管理ソフトウェアについての情報の収集

管理者クレデンシャル

High Availability(HA; ハイ アベイラビリティ)冗長ロール

HA 冗長ステート

ドメイン ID

ネットワーク アップリンク

VLAN

管理 VLAN

制御 VLAN

プライマリ の設定

セカンダリ の設定

ネットワーク アップリンク設定の例

設定の確認

を使用する前に

ソフトウェア インストールの機能の履歴

Cisco Virtual Services Applianceソフトウェア インストール

この章では、Cisco Nexus 1110-S ソフトウェアと Cisco Nexus 1110-X ソフトウェアのインストール方法について説明します。内容は次のとおりです。

「ソフトウェア インストールについて」

「前提条件」

「注意事項および制約事項」

「CIMC および BIOS 情報」

「管理ソフトウェアについての情報の収集」

「プライマリ Cisco Virtual Services Appliance の設定」

「セカンダリ Cisco Virtual Services Appliance の設定」

「ネットワーク アップリンク設定の例」

「Cisco Virtual Services Appliance 設定の確認」

「Cisco Virtual Services Appliance を使用する前に」

「ソフトウェア インストールの機能の履歴」


) VSB 上の Cisco Nexus 1000V ソフトウェアのアップグレードについては、『Cisco Nexus 1000V Software Installation and Upgrade Guide, Release 4.2(1)SV1(5.2)』を参照してください。


Cisco Virtual Services Appliance 製品ファミリの概要と、インストール後のソフトウェアの設定手順については、『 Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) 』を参照してください。

ソフトウェア インストールについて

Cisco Nexus 1110-S ソフトウェアと Cisco Nexus 1110-X ソフトウェアは、ISO イメージとしてあらかじめインストールされています。以下の手順を使用して、Cisco Nexus 1110-S ソフトウェアまたは Cisco Nexus 1110-X ソフトウェアをインストールします。インストールは以下の手順で行います。


ステップ 1 正しいバージョンの Cisco Integrated Management Controller(CIMC)ソフトウェアがインストールされていることを確認します。「CIMC および BIOS 情報」 を参照してください。

ステップ 2 管理ソフトウェアについての情報を収集します。「管理ソフトウェアについての情報の収集」 を参照してください。

ステップ 3 プライマリ Cisco Nexus 1110-S または Cisco Nexus 1110-X を設定します。「プライマリ Cisco Virtual Services Appliance の設定」を参照してください。

ステップ 4 セカンダリ Cisco Nexus 1110-S または Cisco Nexus 1110-X を設定します。「セカンダリ Cisco Virtual Services Appliance の設定」 を参照してください。

前提条件

Cisco Virtual Services Appliance リリース 4.2(1)SP1(5.1) のインストールを開始する前に、次のことを確認または実行する必要があります。

最新のファームウェア リリースを搭載していること。詳細については、「CIMC および BIOS 情報」を参照してください。

Cisco Integrated Management Controller(CIMC)ソフトウェア バージョン 1.2.1(b) 以降がインストールされていること。詳細については、「CIMC および BIOS 情報」を参照してください。

このバージョンの CIMC がインストール済みであることを確認する手順は、「Cisco CIMC ソフトウェアのバージョンの確認」を参照してください。詳細については、『 CIMC Firmware Management on UCS C-Series Servers』 を参照してください。

これよりも前のバージョンの CIMC がインストールされている場合は、インストールに失敗します。

Cisco Virtual Services Appliance CIMC GUI を使用して、マニュアルの手順に従い CIMC と BIOS ファームウェアを個別に更新してください。詳細については、「CIMC および BIOS 情報」を参照してください。

注意事項および制約事項

Cisco Virtual Services Appliance 製品ファミリの設定時に以下のガイドラインおよび制約事項に従ってください。

ドメイン ID は VLAN 内で一意である必要があります。

他の Cisco Virtual Services Appliance または Cisco Nexus 1000V が同じ VLAN に存在する場合も、ドメイン ID は全体で一意である必要があります。

ソフトウェアの設定時に、使用しているシステムのアップリンク タイプを設定します。アップリンク タイプを設定した場合、アップリンク タイプを変更するにはソフトウェアをリロードする必要があります。

HA スタンドアロン ロールは Cisco Virtual Services Appliance ではサポートされていません。

Cisco Virtual Services Appliance は HA モード以外ではサポートされていません。

シスコのベスト プラクティスとして、プライマリ Cisco Virtual Services Appliance をセカンダリ バックアップと同時に設定することをお勧めします。プライマリ Cisco Virtual Services Appliance は、セカンダリ バックアップなしで設定してもかまいませんが、この設定は実働環境ではサポートされていません。

プライマリおよびセカンダリの両方の Cisco Virtual Services Appliance で、ドメイン ID、アップリンク タイプ、制御 VLAN、管理 VLAN、制御アップリンク、管理アップリンクを同じものに設定することをお勧めします。

Cisco Nexus 1110 のペアリングは、ハードウェア プラットフォームと一致している必要があります。Cisco Nexus 1110-S と Cisco Nexus 1110-X をペアにすることはできません。

CIMC および BIOS 情報

CIMC の最新ソフトウェア バージョンのインストールと、CIMC および BIOS ファームウェアの更新を行うには、以下のガイドラインを使用してください。

CIMC ソフトウェア バージョン 1.2.1(b) 以降がインストールされていること。最新のファームウェア リリースを搭載することをお勧めします。

このバージョンの CIMC がインストール済みであることを確認する手順は、「Cisco CIMC ソフトウェアのバージョンの確認」を参照してください。詳細については、『 CIMC Firmware Management on UCS C-Series Servers』 を参照してください。

これよりも前のバージョンの CIMC がインストールされている場合は、アップグレードまたはインストールに失敗します。

次の手順を使用して CIMC ソフトウェアの最新バージョンをダウンロードします。

次の場所からシスコ ソフトウェアのダウンロード ページにアクセスします。 http://www.cisco.com/cisco/software/navigator.html

[Download Software] ページが表示されます。[Products] セクションで、[Unified Computing and Servers] をクリックします。

[Cisco UCS C-Series Rack-Mount Standalone Server Software] をクリックします。

[Cisco UCS C200 M2 Rack-Mount Server Software] をクリックします。

[Unified Computing System (UCS) Server Firmware] をクリックしてソフトウェアのタイプを選択します。[Download Software] ページが表示されます。

最新リリースを選択します。

[Download] をクリックして、CIMC ソフトウェアの最新バージョンをダウンロードします。

ファームウェア リリース 1.4(3) 以降の場合、Cisco UCS Host Upgrade Utility ツールは Cisco Nexus 1110-S と Cisco Nexus 1110-X をサポートします。

Cisco UCS Host Upgrade Utility ツールの関連資料については、以下を参照してください。

http://www.cisco.com/en/US/partner/products/ps10493/products_user_guide_list.html

1.4(3) よりも前のファームウェア リリースの場合、Cisco Virtual Services Appliance CIMC GUI を使用して、マニュアルの手順に従い CIMC と BIOS ファームウェアを個別に更新します。

次のマニュアルの手順に従い、最新の CIMC バージョンにアップグレードします。 http://www.cisco.com/en/US/products/ps10493/products_configuration_example09186a0080b07b7c.shtml#gui-firmware-browser

次のマニュアルの手順に従い、BIOS ファームウェアをアップグレードします。 http://www.cisco.com/en/US/docs/unified_computing/ucs/c/sw/bios/b_Upgrading_BIOS_Firmware.html#task_DD83FB75DB8C485FA4E8ED222C77BD3C

手動アップグレード用の CIMC バイナリ ファイルは、upd-pkg-c200-m1-cimc.full.x.x.x.bin ファイルです。このファイルは、HUU ISO イメージまたは旧バージョンの BIOS ファームウェアと CIMC ファームウェアが含まれる zip ファイルから抽出できます。

Cisco CIMC ソフトウェアのバージョンの確認

次の手順に従って、CIMC ソフトウェア バージョン 1.2.1(b) 以降が Cisco Virtual Services Appliance にインストール済みであることを確認します。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

CIMC ソフトウェア バージョン 1.2.1(b) 以降がインストールされていること。

CIMC ソフトウェア バージョン 1.2.1(b) 以降がインストールされている場合、 show hardware コマンドの出力で、Cisco Nexus 1110-S では製品 ID N1K-C1110-S、Cisco Nexus 1110-X では製品 ID N1K-C1110-X が得られます。ここで説明する手順には、この確認作業が含まれています。

CLI または Web ブラウザから Cisco Nexus 1010 または Cisco Nexus 1010-X にログイン済みであること。


ステップ 1 Cisco Nexus 1110-S または Cisco Nexus 1110-X から、次のいずれかを実行して製品 ID(PID)を表示します。

CLI で、 show hardware コマンドを実行して出力を表示します。
「Switch Hardware ID information」の下にある PID を探します。

Web ブラウザで、[Server Summary] ウィンドウを開いてサーバ プロパティを表示します。例については、図 2-1 を参照してください。

例:
switch# show hardware
unset
Software
loader: version unset
kickstart: version unset
system: version unset
kickstart image file is: unset
kickstart compile time: unset [unset]
system image file is: unset
system compile time: unset [unset]
 
 
Hardware
cisco unset ("unset")
unset with unset unset of memory.
Processor Board ID unset
 
Device name: unset
bootflash: unset kB
Disk Storage capacity for VM virtual disks: 345945 MB
Number of physical 1Gbps ethernet ports: 6
Number of CPU Cores: 16
CPU Cores details:
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
 
 
Kernel uptime is unset day(s), unset hour(s), unset minute(s), unset second(s)
 
 
plugin
Core Plugin, Ethernet Plugin, Virtualization Plugin
--------------------------------
Switch hardware ID information
--------------------------------
 
Switch is booted up
Switch type is : Nexus 1110-S (Virtual Services Appliance) 2 slot Chassis
Model number is Nexus 1110-S
PID-VID-SN: N1K-C1110-S-2.0-1846886525134693056
 
--------------------------------
Chassis has 2 Module slots
--------------------------------
 
Module1 ok
Module type is : Cisco Virtual Services Appliance
0 submodules are present
Model number is Nexus 1110-S
H/W version is 2.0
UUID is 0F823778-D54A-4970-E999-2077C67F0133
Manufacture date is 02/22/2012
Serial number is
 
Module2 ok
Module type is : Cisco Virtual Services Appliance
0 submodules are present
Model number is Nexus 1110-S
H/W version is 2.0
UUID is 68143FE5-207B-4989-F297-0937998C9424
Manufacture date is 02/22/2012
Serial number is QCI1410A4LP
 

図 2-1 CIMC のウィンドウに表示される製品 ID(PID)

 

 

ステップ 2 次のいずれかの手順を実行します。

表示される PID が Cisco Nexus 1110-S で N1K-C1110-S、あるいは Cisco Nexus 1110-X で N1K-C1110-X の場合は、インストールまたは Cisco Virtual Services Appliance リリース 4.2(1)SP1(5.1) へのアップグレードは行わないでください。

表示される PID が Cisco Nexus 1110-S で N1K-C1110-S 以外の場合、あるいは Cisco Nexus 1110-X で N1K-C1110-X 以外の場合は、インストールまたは リリース 4.2(1)SP1(5.1) へのアップグレードは行わないでください。代わりに、RMA プロセスを使用して Cisco Virtual Services Appliance を置き換える必要があります。「Cisco Virtual Services Appliance の交換」を参照してください。

管理ソフトウェアについての情報の収集

インストールを開始する前に、Cisco Virtual Services Appliance について以下の情報が必要です。

「管理者クレデンシャル」

「High Availability(HA; ハイ アベイラビリティ)冗長ロール」

「HA 冗長ステート」

「ドメイン ID」

「ネットワーク アップリンク」

「VLAN」

管理者クレデンシャル

システム ソフトウェアを設定する場合は、管理者パスワードを作成する必要があります。 表 2-1 に、パスワード強化のためのガイドラインを示します。

 

表 2-1 パスワード強化ためのガイドライン

強力なパスワードに含まれるもの
脆弱なパスワード構成:

最低 8 文字

大文字の英字

小文字の英字

数字

特殊文字

連続する文字(例:abcd)

文字の繰り返し(例:aaabbb)

辞書に載っている単語

固有名詞

High Availability(HA; ハイ アベイラビリティ)冗長ロール

Cisco Virtual Services Appliance 製品ファミリは、ハイ アベイラビリティを実現するために冗長なペアで提供されます。デバイスを設定する場合に、ハイ アベイラビリティ ロール(プライマリまたはセカンダリ)を設定します。 表 2-2 に、これらのロールの説明を示します。


) HA スタンドアロン ロールは Cisco Virtual Services Appliance 製品ファミリではサポートされていません。Cisco Virtual Services Appliance は HA モード以外ではサポートされていません。


 

表 2-2 HA 冗長ロール

ロール
説明

プライマリ

プライマリ ロールは、セカンダリ Cisco Virtual Services Appliance とアクティブまたはスタンバイ冗長ステートを調整します。

アクティブまたはスタンバイ冗長ステートをネゴシエートする場合は、ブートアップ中にプライマリ ロールが優先されます。つまり、ブートアップ時にセカンダリ Cisco Virtual Services Appliance がアクティブ ステートでない場合は、プライマリ Cisco Virtual Services Appliance がアクティブ冗長ステートになります。

プライマリ ロールを、デュアル システムで最初にインストールした Cisco Virtual Services Appliance に割り当てます。

セカンダリ

セカンダリ ロールは、プライマリ Cisco Virtual Services Appliance とアクティブまたはスタンバイ ステートを調整します。

セカンダリ ロールを、デュアル システムで 2 番目にインストールした Cisco Virtual Services Appliance に割り当てます。

HA 冗長ステート

表 2-3 に、HA 冗長ステートの説明を示します。

 

表 2-3 HA 冗長ステート

冗長性状態
説明

アクティブ

システムを制御し、外部から可視できます。

アクティブ システムは、初期設定後にネットワークからリモートでアクセスされます。

Cisco Virtual Services Appliance を管理するためのユーザ インターフェイスを使用できるのは、アクティブ システムだけです。

スタンバイ

設定をアクティブ Cisco Virtual Services Appliance のものと同期し、障害発生時や手動スイッチオーバーが必要な場合に設定を引き続き使用できるようにします。

Telnet または Secure Shell(SSH; セキュア シェル)プロトコルを使用してスタンバイ Cisco Virtual Services Appliance と通信することはできません。

スタンバイ Cisco Virtual Services Appliance はネットワークを介してアクセスできず、シリアル ポートを使用してアクセスされます。

Cisco Virtual Services Appliance を管理するためのユーザ インターフェイスは、スタンバイ システムから利用できません。

ドメイン ID

プライマリおよびセカンダリ Cisco Virtual Services Appliance は、ドメイン ID を使用してお互いを識別します。Cisco Virtual Services Appliance は同じスイッチング ドメインに属し、同じ管理 IP アドレスを共有する必要があります。

ネットワーク アップリンク

Cisco Virtual Services Appliance 製品ファミリは、ネットワークに接続するため次の 2 つのタイプのネットワーク アップリンク設定をサポートします。

フレキシブル ネットワーク アップリンク:フレキシブル ネットワーク設定により、Cisco Virtual Services Appliance 製品ファミリをネットワークに接続する完全な柔軟性が得られ、最大 6 個のアップリンクを設置できるようになります。

スタティック ネットワーク アップリンク:スタティック ネットワーク アップリンク設定では、Cisco Virtual Services Appliance 製品ファミリは 4 個の固定ネットワーク アップリンク設定を使用してネットワークに接続します。「ネットワーク アップリンク タイプ」 を参照してください。

上記の設定により、サポート対象の次の 5 つのアップリンク タイプのいずれかを使用してシステムをネットワークに接続できます。

1 つのアップリンク

共通の管理および制御トラフィックを持つ 2 つのアップリンク

共通の制御およびデータ トラフィックを持つ 2 つのアップリンク

3 つのアップリンク

フレキシブル ネットワーク アップリンク


) アップリンク タイプを設定した場合、アップリンク タイプを変更するにはソフトウェアをリロードする必要があります。


ネットワーク アップリンクのタイプについて詳しくは、『 Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) 』を参照してください。

Cisco Virtual Services Appliance 製品ファミリのインストール時に、フレキシブル ネットワーク アップリンク タイプかスタティック ネットワーク アップリンク タイプのいずれかを設定できます。アップリンク タイプを変更する場合、アップリンク タイプを変更するたびにリロードして変更内容を反映させる必要があります。

ネットワーク アップリンクのタイプの移行について詳しくは、『 Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) 』を参照してください。

表 2-4 に、サポートされた 4 つのネットワーク アップリンク タイプと各タイプの VLAN トラフィックを伝送するポートを示します。

表 2-4 ネットワーク アップリンク タイプ

アップリンク タイプ
管理 VLAN
制御 VLAN
データ VLAN

1

ポート 1 および 2

ポート 1 および 2

ポート 1 および 2

2

ポート 1 および 2

ポート 1 および 2

ポート 3 ~ 6

3

ポート 1 ~ 2

ポート 3 ~ 6

ポート 3 ~ 6

4

ポート 1 ~ 2

ポート 3 ~ 4

ポート 5 ~ 6

フレキシブル

トラフィック クラスに基づいたトラフィック分離はありません

VLAN

Cisco Virtual Services Appliance 製品ファミリでは、仮想サービス ブレードに対する管理と通信を行うために制御 VLAN と管理 VLAN が使用されます。これらの VLAN は、管理ソフトウェアの初期設定の一部として追加されます。制御 VLAN とパケット VLAN も作成された各仮想サービス ブレードに追加されます。管理 VLAN は、各仮想サービス ブレードによって Cisco Virtual Services Appliance 製品ファミリから継承されます。

Cisco Virtual Services Appliance 製品ファミリで制御 VLAN、パケット VLAN、または管理 VLAN を変更する場合、変更はすぐに反映されます。Cisco Virtual Services Appliance で制御 VLAN および管理 VLAN の変更を反映するには、リロードが必要です。ただし、サービスの持続性のため、ホストされた Virtual Supervisor Module(VSM)で同じ制御 VLAN とパケット VLAN を設定する必要があります。このように設定しないと、Cisco Virtual Services Appliance が VSM との通信を失います。

ここでは、次の内容について説明します。

「管理 VLAN」

「制御 VLAN」

管理 VLAN

管理 VLAN は、Cisco Nexus 1010 の管理ポートに対するトラフィックを転送する VLAN です。仮想サービス ブレードがトラフィックの管理クラスを使用する場合、仮想サービス ブレードは Cisco Virtual Services Appliance から管理 VLAN を継承します。

管理 VLAN は外部から使用され、Cisco Virtual Services Appliance の管理 0 インターフェイスに到達します。Cisco Virtual Services Appliance とホストされた Cisco Nexus 1000V VSM は同じ管理 VLAN を共有します。仮想サービス ブレードの作成時に設定された制御 VLAN とパケット VLAN とは異なり、管理 VLAN は Cisco Nexus 1010 がホストするすべての仮想サービス ブレードによって Cisco Virtual Services Appliance から継承されます。

制御 VLAN

制御 VLAN は、冗長な Cisco Virtual Services Appliance 間の通信に使用されるレイヤ 2 インターフェイスです。このインターフェイスは、ハートビートなどの下位の制御パケットと Cisco Nexus 1010 間で交換する必要があるすべての設定データを処理します。

プライマリ Cisco Virtual Services Appliance の設定

次に対して管理ソフトウェアを設定する手順を次に示します。

冗長 HA ペアのプライマリ Cisco Nexus 1110-S または Cisco Nexus 1110-X

シスコのベスト プラクティスとして、プライマリ Cisco Nexus 1110-S または Cisco Nexus 1110-X をセカンダリ バックアップと同時に設定することをお勧めします。プライマリ Cisco Virtual Services Appliance は、セカンダリ バックアップなしで設定してもかまいませんが、この設定は実働環境ではサポートされていません。

はじめる前に

この Cisco Virtual Services Appliance に対して次の情報が利用可能であること。

管理者パスワード

HA ロール(プライマリまたはセカンダリ)
HA ロールを指定しないと、ロールはプライマリとして設定されます。

ネットワーク アップリンク タイプ

制御 VLAN ID

ドメイン ID

管理 VLAN ID

管理 0 IP アドレス
これは、アプライアンスで mgmt0 ポートとして現れる管理インターフェイスの IP アドレスです。

デフォルト ゲートウェイの IP アドレス

SSH サービスのキー タイプとキー ビット数

手順の詳細


ステップ 1 次の方法のいずれかを使用して、Cisco Nexus 1110-S または Cisco Nexus 1110-X CLI にログインします。

セットアップ ウィザードが自動的に起動します。

ターミナル サーバからログインします。

例:
telnet 172.25.182.99 2005
Trying 172.25.182.99...
Connected to 172.25.182.99.
Escape character is '^]'
switch#
 
---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
 

CIMC で Serial over LAN 接続からログインします。

例:
ssh admin@172.25.182.230
admin@172.25.182.230's password:
switch# connect host
CISCO Serial Over LAN:
Close Network Connection to Exit
 
---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
 

ステップ 2 画面の指示に従って、管理者パスワードの入力と確認を行います。

例:

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":

ステップ 3 画面の指示に従って、HA ロールを入力します。ロールを指定しない場合は、プライマリが割り当てられます。

例:

Enter HA role[primary/secondary]: primary


) HA スタンドアロン ロールは Cisco Virtual Services Appliance 製品ファミリではサポートされていません。Cisco Virtual Services Appliance は HA モード以外ではサポートされていません。


ステップ 4 画面の指示に従って、アップリンク タイプを入力します。スタティック ネットワーク アップリンクを指定するには、1 ~ 4 の値を入力します。フレキシブル ネットワーク アップリンクを指定するには、5 の値を入力します。


) アップリンク タイプを設定した場合、アップリンク タイプを変更するにはソフトウェアをリロードする必要があります。


例:
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
5
 

ステップ 5 画面の指示に従って、制御 VLAN の VLAN ID を入力します。

例:

Enter control vlan <1-3967, 4048-4093>: 347
 

ステップ 6 画面の指示に従って、制御アップリンク タイプを入力します。

例:

Enter control uplink <1-6>: 1
 

ステップ 7 画面の指示に従って、ドメイン ID を入力します。

例:

Enter the domain id<1-4095>: 3477
 

ステップ 8 画面の指示に従って、管理 VLAN の VLAN ID を入力します。

例:

Enter management vlan<1-3967,4048-4093>: 180
 

ステップ 9 画面の指示に従って、管理アップリンク タイプを入力します。

例:

Enter management uplink <1-6>: 2
 

ステップ 10 このプロセスを完了すると、Cisco Virtual Services Appliance ソフトウェアは設定を保存し、ネットワーク アップリンクを設定するために自動的にリブートします。

新しい設定は不揮発性ストレージに保存され、その後、実行コンフィギュレーションとスタートアップ コンフィギュレーションが同一になります。

Saving boot configuration. Please wait...
 
[########################################] 100%
System is going to reboot to configure network uplinks
 

リブート後、デフォルトのスタティック トポロジまたはフレキシブル トポロジが設定されます。デフォルトのネットワーク アップリンク設定については、図 2-2を参照してください。詳細については、『 Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) 』を参照してください。

図 2-2 デフォルトのフレキシブル ネットワーク アップリンク設定(vPC/VSS を含まない)

 
 

図 2-3 デフォルトのフレキシブル ネットワーク アップリンク設定(vPC/VSS を含む)

ステップ 11 基本設定ダイアログボックスの入力を確認するメッセージが表示されたら、 yes と答えます。

例:
Would you like to enter the basic configuration dialog (yes/no): yes
 
---- Basic System Configuration Dialog ----
 
This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.
 
*Note: setup is mainly used for configuring the system initially,
when no configuration is present. So setup always assumes system
defaults and not the current system configuration values.
 
Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.
 

ステップ 12 別のログイン アカウントの作成を確認するメッセージが表示されたら、 no と答えます。

例:

Create another login account (yes/no) [n]: no
 

ステップ 13 読み取り専用 SNMP コミュニティ ストリングの設定を確認するメッセージが表示されたら、 no と答えます。

例:

Configure read-only SNMP community string (yes/no) [n]: no
 

ステップ 14 読み取りと書き込み SNMP コミュニティ ストリングの設定を確認するメッセージが表示されたら、 no と答えます。

例:
Configure read-write SNMP community string (yes/no) [n]:
 

ステップ 15 アプライアンスの名前を入力します。

例:
Enter the VSA name [Nexus1110]:
 

ステップ 16 アウトオブバンド管理の設定を確認するメッセージが表示されたら、 yes と答えて管理 0 IPv4/IPv6 アドレスを入力します。

これは、アプライアンスで mgmt0 ポートとして現れる管理インターフェイスの IP アドレスです。

例:
Continue with Out-of-band (mgmt0) management configuration? [yes/no] [y]: yes
Mgmt0 IP address type V4/V6? (V4): V6
Mgmt0 IPv6 address: 1:a:0::2
Mgmt0 IPv6 netmask prefix (1-128): 64

 

ステップ 17 デフォルト ゲートウェイの設定を確認するメッセージが表示されたら、 yes と答えます。

例:
Configure the default-gateway: (yes/no) [y]: yes
IPv6 address of the default gateway: 1:a:0::1
 

ステップ 18 高度な IP オプションを設定するかどうかを尋ねるプロンプトが表示されたら、 no と入力します。

例:
Configure Advanced IP options (yes/no)? [n]: no
 

ステップ 19 Telnet サービスの有効化を確認するメッセージが表示されたら、 yes と答えます。

例:
Enable the telnet service? (yes/no) [y]: yes
 

ステップ 20 SSH サービスの有効化を確認するメッセージが表示されたら、 yes と答えてキー タイプとキー ビット数を入力します。

例:
Enable the ssh service? (yes/no) [y]: yes
Type of ssh key you would like to generate (dsa/rsa) : rsa
Number of key bits <768-2048> : 1024
 

ステップ 21 NTP サーバの設定を確認するメッセージが表示されたら、 no と答えます。

設定の概要が表示されます。

例:
Configure NTP server? (yes/no) [n]: no
The following configuration will be applied:
Switchname n1010
interface Mgmt0
ip address 172.28.15.152 255.255.255.0
no shutdown
telnet server enable
ssh key rsa 1024 force
ssh server enable
svs-domain
control vlan 260
domain id 152
 

ステップ 22 次のいずれかの手順を実行します。

設定を編集しない場合は、 no と答えて次のステップに進む。

設定を編集する場合は、 yes と答えてステップ 12 に戻り、各コマンドを再度実行する。

例:
Would you like to edit the configuration? (yes/no) [n]:no
 

ステップ 23 この設定を使用および保存するかどうかを確認するメッセージが表示されたら、 yes と答えます。


注意 ここで設定を保存しておかないと、次回のスイッチ起動時に設定が更新されません。新しい設定を保存するには、yes と入力します。これによって、キックスタート イメージとシステム イメージも自動的に設定されます。

例:
Use this configuration and save it? (yes/no) [y]: yes
[########################################] 100%
 

新しい設定は不揮発性ストレージに保存され、その後、実行コンフィギュレーションとスタートアップ コンフィギュレーションが同一になります。


) EXEC モードで setup コマンドを入力すると、ステップ 12 からステップ 23 で実行した設定を更新するセットアップ ルーチンをいつでも使用できます。セットアップが開始されたら、Enter キーを押してコマンドをスキップします。Ctrl キーを押した状態で C キーを押して、残りのコマンドをスキップします。


ステップ 24 これで手順は完了です。設定を確認するには、次のコマンドを実行します。

show running configuration

!Command: show running-config
!Time: Mon Sep 10 21:31:34 2012
 
version 4.2(1)SP1(5.1)
feature telnet
 
username admin password 5 $1$8oEF.umL$mRRZTm3.sWL2ED5KZydz61 role network-admin
 
banner motd #Cisco VSA#
 
ip domain-lookup
ip domain-lookup
hostname N1110-S
snmp-server user admin network-admin auth md5 0xb64ad6879970f0e57600c443287a79f0 priv 0xb64ad6879970f0e57600c443287a79f0 localizedkey
snmp-server community public group network-admin
 
vrf context management
ip route 0.0.0.0/0 10.78.109.97
vlan 1,1352,1360
port-channel load-balance ethernet source-mac
port-profile default max-ports 32
 
vdc N1110-S id 1
limit-resource vlan minimum 16 maximum 2049
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 768
limit-resource u4route-mem minimum 32 maximum 32
limit-resource u6route-mem minimum 16 maximum 16
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
network-uplink type 4
interface GigabitEthernet1
interface GigabitEthernet2
interface GigabitEthernet3
interface GigabitEthernet4
interface GigabitEthernet5
interface GigabitEthernet6
interface PortChannel1
interface PortChannel2
interface PortChannel3
virtual-service-blade VSM1
virtual-service-blade-type name VSM-1.1
interface control vlan 1361
interface packet vlan 1362
ramsize 2048
disksize 3
numcpu 1
cookie 1555871292
no shutdown
interface VsbEthernet1/1
interface VsbEthernet1/2
interface VsbEthernet1/3
virtual-service-blade NAMC-1
virtual-service-blade-type name NAM-1.1
interface data vlan 1352
ramsize 2048
disksize 53
numcpu 2
cookie 753232953
no shutdown secondary
interface VsbEthernet2/1
virtual-service-blade DCNM61
virtual-service-blade-type name DCNM-VSB-6.1
interface eth1 vlan 0
ramsize 8192
disksize 80
numcpu 2
cookie 969732378
no shutdown primary
interface VsbEthernet3/1
virtual-service-blade VSG12
virtual-service-blade-type name VSG-1.2
interface data vlan 1365
interface ha vlan 1364
ramsize 2048
disksize 3
numcpu 1
cookie 2051820775
no shutdown primary
no shutdown secondary
interface VsbEthernet4/1
interface VsbEthernet4/2
interface VsbEthernet4/3
virtual-service-blade VSM-OVA
virtual-service-blade-type name VSM-1.2
interface control vlan 1364
interface packet vlan 1366
ramsize 2048
disksize 3
numcpu 1
cookie 448734513
no shutdown primary
no shutdown secondary
interface VsbEthernet5/1
interface VsbEthernet5/2
interface VsbEthernet5/3
virtual-service-blade VSG-OVA
virtual-service-blade-type name VSG-1.2
interface data vlan 1356
interface ha vlan 1355
ramsize 2048
disksize 3
numcpu 1
cookie 2105102293
no shutdown
interface VsbEthernet6/1
interface VsbEthernet6/2
interface VsbEthernet6/3
 
 
interface mgmt0
ip address 10.78.109.100/28
 
interface control0
line console
boot kickstart bootflash:/nexus-1010-kickstart-mz.4.2.1.SP1.5.1.bin
boot system bootflash:/nexus-1010-mz.4.2.1.SP1.5.1.bin
boot kickstart bootflash:/nexus-1010-kickstart-mz.4.2.1.SP1.5.1.bin
boot system bootflash:/nexus-1010-mz.4.2.1.SP1.5.1.bin
svs-domain
domain id 2222
control vlan 1360
management vlan 1352
svs mode L2
 
 
 
 
 
 
 
 


 

セカンダリ Cisco Virtual Services Appliance の設定

冗長ペアのセカンダリ Cisco Virtual Services Appliance に対して管理ソフトウェアを設定する手順を次に示します。

プライマリおよびセカンダリの両方の Cisco Virtual Services Appliance で、ドメイン ID、アップリンク タイプ、制御 VLAN、管理 VLAN、制御アップリンク、管理アップリンクを同じものに設定することをお勧めします。

手順の詳細


ステップ 1 画面の指示に従って、管理者パスワードの入力と確認を行います。

例:

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":

ステップ 2 画面の指示に従って、HA ロールを入力します。

例:

Enter HA role[primary/secondary]: secondary

 

ステップ 3 画面の指示に従って、アップリンク タイプを入力します。


) アップリンク タイプを設定した場合、アップリンク タイプを変更するにはソフトウェアをリロードする必要があります。


例:
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
5

 

ステップ 4 画面の指示に従って、制御 VLAN の VLAN ID を入力します。

例:

Enter control vlan <1-3967, 4048-4093>: 347
 

ステップ 5 画面の指示に従って、制御アップリンク タイプを入力します。

例:

Enter control uplink <1-6>: 1
 

ステップ 6 画面の指示に従って、ドメイン ID を入力します。

例:

Enter the domain id<1-4095>: 3477
 

ステップ 7 画面の指示に従って、管理 VLAN の VLAN ID を入力します。

例:

Enter management vlan<1-3967,4048-4093>: 180
 

ステップ 8 画面の指示に従って、管理アップリンク タイプを入力します。

例:

Enter management uplink <1-6>: 2
 

スイッチでは次のことが起こります。

新しい設定は不揮発性ストレージに保存され、その後、実行コンフィギュレーションとスタートアップ コンフィギュレーションが同一になります。

ネットワーク アップリンクを設定するためにシステムがリブートします。

システムが再起動し、プライマリ Cisco Nexus 1000V と設定を同期します。

例:
Saving boot configuration. Please wait...
 
[########################################] 100%
 
System is going to reboot to configure network uplinks
HA mode set to secondary. Rebooting now...
 

ステップ 9 これで手順は完了です。設定を確認するには、次のコマンドを実行します。

show running configuration

ネットワーク アップリンク設定の例

次の例は、インストール時にフレキシブル ネットワーク アップリンクを設定する方法を示します。

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
Enter HA role[primary/secondary]: secondary
_
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
5
_
Enter control vlan <1-3967, 4048-4093>: 347
Enter control uplink <1-6>: 1
_
Enter the domain id<1-4095>: 3477
_
Enter management vlan <1-3967, 4048-4093>: 180
Enter management uplink <1-6>: 2
_
Saving boot configuration. Please wait...
[########################################] 100%
System is going to reboot to configure network uplinks

 

次の例は、インストール時にスタティック ネットワーク アップリンクを設定する方法を示します。

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
Enter HA role[primary/secondary]: secondary
_
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
1
_
Enter control vlan <1-3967, 4048-4093>: 300
_
Enter the domain id<1-4095>: 300
_
Enter management vlan <1-3967, 4048-4093>: 233
_
Saving boot configuration. Please wait...
[########################################] 100%
System is going to reboot to configure network uplinks

 

Cisco Virtual Services Appliance 設定の確認

Cisco Virtual Services Appliance 設定を確認するには、次のコマンドを使用します。

 

コマンド
目的

show running-configuration

Cisco Virtual Services Appliance の実行コンフィギュレーションを表示します。

例 2-1(P.2-20) を参照してください。

show system redundancy status

Cisco Virtual Services Appliance の冗長ステート(アクティブまたはスタンバイ)と冗長ロール(プライマリまたはセカンダリ)を表示します。

例 2-2(P.2-22) を参照してください。

show svs domain

Cisco Virtual Services Appliance のドメイン情報を表示します。

例 2-3(P.2-23) を参照してください。

show network cdp neighbors

アクティブまたはスタンバイ Cisco Virtual Services Appliance のアップリンク接続を表示します。

例 2-4(P.2-23) を参照してください。

例 2-1 設定

次に、Cisco Virtual Services Appliance 設定を表示および確認する例を示します。

show running-config
!Command: show running-config
!Time: Mon Sep 10 21:31:34 2012
 
version 4.2(1)SP1(5.1)
feature telnet
 
username admin password 5 $1$8oEF.umL$mRRZTm3.sWL2ED5KZydz61 role network-admin
 
banner motd #Cisco VSA#
 
ip domain-lookup
ip domain-lookup
hostname N1110-S
snmp-server user admin network-admin auth md5 0xb64ad6879970f0e57600c443287a79f0 priv 0xb64ad6879970f0e57600c443287a79f0 localizedkey
snmp-server community public group network-admin
 
vrf context management
ip route 0.0.0.0/0 10.78.109.97
vlan 1,1352,1360
port-channel load-balance ethernet source-mac
port-profile default max-ports 32
 
vdc N1110-S id 1
limit-resource vlan minimum 16 maximum 2049
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 768
limit-resource u4route-mem minimum 32 maximum 32
limit-resource u6route-mem minimum 16 maximum 16
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
network-uplink type 4
interface GigabitEthernet1
interface GigabitEthernet2
interface GigabitEthernet3
interface GigabitEthernet4
interface GigabitEthernet5
interface GigabitEthernet6
interface PortChannel1
interface PortChannel2
interface PortChannel3
virtual-service-blade VSM1
virtual-service-blade-type name VSM-1.1
interface control vlan 1361
interface packet vlan 1362
ramsize 2048
disksize 3
numcpu 1
cookie 1555871292
no shutdown
interface VsbEthernet1/1
interface VsbEthernet1/2
interface VsbEthernet1/3
virtual-service-blade NAMC-1
virtual-service-blade-type name NAM-1.1
interface data vlan 1352
ramsize 2048
disksize 53
numcpu 2
cookie 753232953
no shutdown secondary
interface VsbEthernet2/1
virtual-service-blade DCNM61
virtual-service-blade-type name DCNM-VSB-6.1
interface eth1 vlan 0
ramsize 8192
disksize 80
numcpu 2
cookie 969732378
no shutdown primary
interface VsbEthernet3/1
virtual-service-blade VSG12
virtual-service-blade-type name VSG-1.2
interface data vlan 1365
interface ha vlan 1364
ramsize 2048
disksize 3
numcpu 1
cookie 2051820775
no shutdown primary
no shutdown secondary
interface VsbEthernet4/1
interface VsbEthernet4/2
interface VsbEthernet4/3
virtual-service-blade VSM-OVA
virtual-service-blade-type name VSM-1.2
interface control vlan 1364
interface packet vlan 1366
ramsize 2048
disksize 3
numcpu 1
cookie 448734513
no shutdown primary
no shutdown secondary
interface VsbEthernet5/1
interface VsbEthernet5/2
interface VsbEthernet5/3
virtual-service-blade VSG-OVA
virtual-service-blade-type name VSG-1.2
interface data vlan 1356
interface ha vlan 1355
ramsize 2048
disksize 3
numcpu 1
cookie 2105102293
no shutdown
interface VsbEthernet6/1
interface VsbEthernet6/2
interface VsbEthernet6/3
 
 
interface mgmt0
ip address 10.78.109.100/28
 
interface control0
line console
boot kickstart bootflash:/nexus-1010-kickstart-mz.4.2.1.SP1.5.1.bin
boot system bootflash:/nexus-1010-mz.4.2.1.SP1.5.1.bin
boot kickstart bootflash:/nexus-1010-kickstart-mz.4.2.1.SP1.5.1.bin
boot system bootflash:/nexus-1010-mz.4.2.1.SP1.5.1.bin
svs-domain
domain id 2222
control vlan 1360
management vlan 1352
svs mode L2
 

例 2-2 冗長ステート

switch# show system redundancy status
Redundancy role
---------------
administrative: primary
operational: primary
Redundancy mode
---------------
administrative: HA
operational: None
This supervisor (sup-1)
-----------------------
Redundancy state: Active
Supervisor state: Active
Internal state: Active with no standby
Other supervisor (sup-2)
------------------------
Redundancy state: Not present
---- ----
switch#
 

例 2-3 ドメイン

switch# show svs domain
SVS domain config:
Domain id: 3555
Control vlan: 305
Management vlan: 233
L2/L3 Control mode: L2
L3 control interface: NA
Status: Config not pushed to VC.
switch#

例 2-4 CDP ネイバー(スタンバイ)

switch# show network cdp neighbors
....
Device-ID Local Intrfce Hldtme Capability Platform Port ID
 
sfish-cat3k-K5-stack2 eth2 166 R T B S I r cisco WS-C375 GigabitEthernet1/0/23
switch#
 

Cisco Virtual Services Appliance を使用する前に

ソフトウェアのインストールが完了すると、Cisco Virtual Services Appliance 製品ファミリを設定することができます。詳細については、『 Cisco Nexus Virtual Services Appliance Software Configuration Guide, Release 4.2(1)SP1(5.1) 』を参照してください。

以下はソフトウェアの設定プロセスの基本的な手順です。


ステップ 1 フレキシブル ネットワーク アップリンク用ポート チャネルを設定します。フレキシブル ネットワーク アップリンク タイプの設定後、ポート チャネルを設定するにはこの手順を使用します。

ステップ 2 リモート管理を設定します。到達不能 Cisco Nexus 1110-S または Cisco Nexus 1110-X のリカバリで使用するスタートアップ コンフィギュレーションにリモート管理を設定するにはこの手順を使用します。

ステップ 3 新規 Cisco Virtual Services Appliance にサービス ブレードを追加するには、以下のいずれかを実行します。

仮想サービス ブレードを新たに作成する。

既存の VSM を VM から Cisco Virtual Services Appliance に移行する。


 

ソフトウェア インストールの機能の履歴

ここでは、ソフトウェア インストールおよびアップグレードのリリース履歴について説明します。

 

機能名
リリース
機能情報

Cisco Nexus 1110-SおよびCisco Nexus 1110-X

4.2(1)SP1(5.1)

このハードウェアが導入されました。

フレキシブル ネットワーク アップリンク

4.2(1)SP1(4)

この機能が導入されました。

Cisco Nexus 1010-X

4.2(1)SP1(3)

このハードウェアが導入されました。

ソフトウェア アップグレード

4.2(1)SP1(2)

この機能が導入されました。