Cisco Nexus Virtual Services Appliance コマンド リファレンス リリース 4.2(1) SP1(5.1)
T コマンド
T コマンド
発行日;2012/11/19 | 英語版ドキュメント(2012/09/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

T コマンド

tacacs+ enable

tacacs-server deadtime

tacacs-server directed-request

tacacs-server host

tacacs-server key

tacacs-server timeout

tail

telnet

telnet server enable

terminal event-manager bypass

terminal length

terminal monitor

terminal session-timeout

terminal terminal-type

terminal tree-update

terminal width

traceroute

T コマンド

この章では、T で始まる Cisco Nexus Virtual Services Appliance コマンドについて説明します。

tacacs+ enable

TACACS+ をイネーブルにするには、 tacacs+ enable コマンドを使用します。TACACS+ をディセーブルにするには、このコマンドの no 形式を使用します。

tacacs+ enable

no tacacs+ enable

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

次に、TACACS+ をイネーブルにする例を示します。

n1010(config)# tacacs+ enable
n1010(config)#
 

次に、TACACS+ をディセーブルにする例を示します。

n1010(config)# no tacacs+ enable
n1010(config)#

 
関連コマンド

コマンド
説明

show tacacs-server

TACACS+ サーバの設定を表示します。

tacacs-server host

Cisco Nexus 1000V と指定した TACACS+ サーバ ホストの間で共有されるキーを指定します。

tacacs-server key

Cisco Nexus 1000V と TACACS+ サーバ ホストの間で共有されるグローバル キーを指定します。

tacacs-server deadtime

応答性について到達不能(非応答)TACACS+ サーバをモニタする定期的な時間間隔を設定するには、 tacacs-server deadtime コマンドを使用します。非応答 TACACS+ サーバのモニタリングをディセーブルにするには、このコマンドの no 形式を使用します。

tacacs -server deadtime minutes

no tacacs -server deadtime minutes

 
構文の説明

time

分単位の時間間隔です。有効な範囲は 1 ~ 1440 です。

 
デフォルト

0 分

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

 
使用上のガイドライン

時間間隔の設定をゼロにすると、タイマーがディセーブルになります。個別の TACACS+ サーバのデッド タイム間隔がゼロ(0)よりも大きい場合は、サーバ グループに設定された値よりもその値が優先されます。

デッド タイム間隔が 0 分の場合、TACACS+ サーバがサーバ グループの一部でグループのデッド タイム間隔が 0 分を超えていない限り、TACACS+ サーバ モニタリングは実行されません。

その他の TACACS+ コマンドを使用して機能を設定する前に、グローバル コンフィギュレーション モードで、 tacacs+ enable コマンドを使用して TACACS+ 機能を最初にイネーブルにする必要があります。

次に、デッド タイム間隔を設定して、定期的なモニタリングをイネーブルにする例を示します。

n1010# configure terminal
n1010(config)# tacacs-server deadtime 10
 

次に、デッド タイム間隔をデフォルトに戻して、定期的なモニタリングをディセーブルにする例を示します。

n1010# configure terminal
n1010(config)# no tacacs-server deadtime 10
 

 
関連コマンド

コマンド
説明

deadtime

非応答 TACACS+ サーバをモニタリングするデッド タイム間隔を設定します。

show tacacs-server

TACACS+ サーバ情報を表示します。

tacacs+ enable

TACACS+ をイネーブルにします。

tacacs-server directed-request

ログイン時にユーザが認証要求を特定の TACACS+ サーバに送信できるようにするには、 tacacs-server directed-request コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

tacacs -server directed-request

no tacacs -server directed-request

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

 
使用上のガイドライン

その他の TACACS+ コマンドを使用して機能を設定する前に、グローバル コンフィギュレーション モードで、 tacacs+ enable コマンドを使用して TACACS+ 機能を最初にイネーブルにする必要があります。

ユーザは、ログイン中に username@vrfname : hostname を指定することができます。vrfname は使用する Virtual Routing and Forwarding(VRF; VPN ルーティングおよび転送)名で、hostname は設定した TACACS+ サーバ名です。ユーザ名が認証用にサーバ名に送信されます。

次に、ログイン時にユーザが認証要求を特定の TACACS+ サーバに送信できるようにする例を示します。

n1010# configure terminal
n1010(config)# tacacs-server directed-request
 

次に、ログイン時にユーザが認証要求を特定の TACACS+ サーバに送信できないようにする例を示します。

n1010# configure terminal
n1010(config)# no tacacs-server directed-request
 

 
関連コマンド

コマンド
説明

show tacacs-server

TACACS+ サーバの設定を表示します。

tacacs+ enable

TACACS+ をイネーブルにします。

tacacs-server host

TACACS+ サーバ ホスト パラメータを設定するには、コンフィギュレーション モードで tacacs-server host コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

tacacs-server host { hostname | ipv4-address | ipv6-address }
[
key [ 0 | 7 ] shared-secret ] [ port port-number ]
[
test { idle-time time | password password | username name }]
[
timeout seconds ]

no tacacs-server host { hostname | ipv4-address | ipv6-address }
[ key [ 0 | 7 ] shared-secret ] [ port port-number ]
[
test { idle-time time | password password | username name }]
[
timeout seconds ]

 
構文の説明

hostname

TACACS+ サーバのドメイン ネーム サーバ(DNS)名。名前は、英数字で指定します。大文字と小文字が区別され、最大文字数は 256 です。

ipv4-address

A.B.C.D 形式の TACACS+ サーバの IPv4 アドレス。

ipv6-address

X : X : X :: X 形式の TACACS+ サーバの IPv6 アドレスです。

key

(任意)TACACS+ サーバ用の共有秘密キーを設定します。

0

(任意)TACACS+ クライアントとサーバ間の通信を認証する、クリア テキストで指定された事前共有キー(0 で表示)を設定します。これはデフォルトです。

7

(任意)TACACS+ クライアントとサーバ間の通信を認証する、暗号文で指定された事前共有キー(7 で表示)を設定します。

shared-secret

TACACS+ クライアントとサーバ間の通信を認証する事前共有キー。事前共有キーは、英数字で指定します。大文字と小文字が区別され、最大文字数は 63 です。

port port-number

(任意)認証用の TACACS+ サーバのポートを設定します。有効な範囲は 1 ~ 65535 です。

test

(任意)テスト パケットを TACACS+ サーバに送信するようにパラメータを設定します。

idle-time time

(任意)サーバをモニタリングするための時間間隔を分数で指定します。時間の範囲は 1 ~ 1440 分です。

password password

(任意)テスト パケット内のユーザ パスワードを指定します。パスワードは、英数字で指定します。大文字と小文字が区別され、最大文字数は 32 です。

username name

(任意)テスト パケット内のユーザ名を指定します。ユーザ名は、英数字で指定します。大文字と小文字が区別され、最大文字数は 32 です。

timeout seconds

(任意)TACACS+ サーバへの再送信 TACACS+ サーバ タイムアウト期間(秒単位)を設定します。有効な範囲は 1 ~ 60 秒です。

 
デフォルト

パラメータ
デフォルト

アイドル時間

ディセーブル

サーバ モニタリング

ディセーブル

タイムアウト

1 秒

テスト ユーザ名

test

テスト パスワード

test

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

 
使用上のガイドライン

TACACS+ を設定する前に、 tacacs+ enable コマンドを使用する必要があります。

アイドル時間間隔が 0 分の場合、TACACS+ サーバの定期モニタリングは実行されません。

次に、TACACS+ サーバ ホスト パラメータを設定する例を示します。

n1010# configure terminal
n1010(config)# tacacs-server host 10.10.2.3 key HostKey
n1010(config)# tacacs-server host tacacs2 key 0 abcd
n1010(config)# tacacs-server host tacacs3 key 7 1234
n1010(config)# tacacs-server host 10.10.2.3 test idle-time 10
n1010(config)# tacacs-server host 10.10.2.3 test username tester
n1010(config)# tacacs-server host 10.10.2.3 test password 2B9ka5
 

 
関連コマンド

コマンド
説明

show tacacs-server

TACACS+ サーバ情報を表示します。

tacacs+ enable

TACACS+ をイネーブルにします。

tacacs-server key

グローバル TACACS+ 共有秘密キーを設定するには、 tacacs-server key コマンドを使用します。設定した共有秘密キーを削除するには、このコマンドの no 形式を使用します。

tacacs-server key [ 0 | 7 ] shared-secret

no tacacs-server key [ 0 | 7 ] shared-secret

 
構文の説明

0

(任意)TACACS+ クライアントとサーバ間の通信を認証する、クリア テキストで指定された事前共有キーを設定します。これはデフォルトです。

7

(任意)TACACS+ クライアントとサーバ間の通信を認証する、暗号文で指定された事前共有キーを設定します。

shared-secret

TACACS+ クライアントとサーバ間の通信を認証する事前共有キー。事前共有キーは、英数字で指定します。大文字と小文字が区別され、最大文字数は 63 です。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

 
使用上のガイドライン

TACACS+ 事前共有キーを設定して TACACS+ サーバに対してデバイスを認証する必要があります。キーの長さは 63 文字で、出力可能な任意の ASCII 文字を含めることができます(スペースは使用できません)。グローバル キーを設定して、デバイスにあるすべての TACACS+ サーバ コンフィギュレーションで使用するようにできます。 tacacs-server host コマンドで key キーワードを使用することで、このグローバル キーの割り当てを上書きできます。

TACACS+ を設定する前に、 tacacs+ enable コマンドを使用する必要があります。

次に、TACACS+ サーバ共有キーを設定する例を示します。

n1010# configure terminal
n1010(config)# tacacs-server key AnyWord
n1010(config)# tacacs-server key 0 AnyWord
n1010(config)# tacacs-server key 7 public
 

 
関連コマンド

コマンド
説明

show tacacs-server

TACACS+ サーバ情報を表示します。

tacacs+ enable

TACACS+ をイネーブルにします。

tacacs-server timeout

TACACS+ サーバへの再送信間隔を指定するには、 tacacs-server timeout コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

tacacs-server timeout seconds

no tacacs-server timeout seconds

 
構文の説明

seconds

TACACS+ サーバへの再送信間隔を秒単位で設定します。有効な範囲は 1 ~ 60 秒です。

 
デフォルト

5 秒

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

 
使用上のガイドライン

TACACS+ を設定する前に、 tacacs+ enable コマンドを使用する必要があります。

次に、TACACS+ サーバのタイムアウト値を設定する例を示します。

n1010# configure terminal
n1010(config)# tacacs-server timeout 3
 

次に、デフォルトの TACACS+ サーバのタイムアウト値に戻す例を示します。

n1010# configure terminal
n1010(config)# no tacacs-server timeout 3
 

 
関連コマンド

コマンド
説明

show tacacs-server

TACACS+ サーバ情報を表示します。

tacacs+ enable

TACACS+ をイネーブルにします。

tail

ファイルの末尾の行を表示するには、 tail コマンドを使用します。

tail [ filesystem : [ // module / ]][ directory / ] filename lines ]

 
構文の説明

filesystem :

(任意)ファイル システムの名前。名前では、大文字と小文字が区別されます。

// module /

(任意)スーパーバイザ モジュールの ID。有効な値は、 sup-active sup-local sup-remote または sup-standby です。ID では、大文字と小文字が区別されます。

directory /

(任意)ディレクトリの名前。名前では、大文字と小文字が区別されます。

filename

コマンドファイルの名前。名前では、大文字と小文字が区別されます。

lines

(任意)表示する行数。有効な範囲は 0 ~ 80 です。

 
デフォルト

10 行

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

次に、ファイルの末尾の 10 行を表示する例を示します。

n1010# tail bootflash:startup.cfg
ip arp inspection filter marp vlan 9
ip dhcp snooping vlan 13
ip arp inspection vlan 13
ip dhcp snooping
ip arp inspection validate src-mac dst-mac ip
ip source binding 10.3.2.2 0f00.60b3.2333 vlan 13 interface Ethernet2/46
ip source binding 10.2.2.2 0060.3454.4555 vlan 100 interface Ethernet2/10
logging level dhcp_snoop 6
logging level eth_port_channel 6
 

次に、ファイルの末尾の 20 行を表示する例を示します。

n1010# tail bootflash:startup.cfg 20
area 99 virtual-link 1.2.3.4
router rip Enterprise
router rip foo
address-family ipv4 unicast
router bgp 33.33
event manager applet sdtest
monitor session 1
monitor session 2
ip dhcp snooping vlan 1
ip arp inspection vlan 1
ip arp inspection filter marp vlan 9
ip dhcp snooping vlan 13
ip arp inspection vlan 13
ip dhcp snooping
ip arp inspection validate src-mac dst-mac ip
ip source binding 10.3.2.2 0f00.60b3.2333 vlan 13 interface Ethernet2/46
ip source binding 10.2.2.2 0060.3454.4555 vlan 100 interface Ethernet2/10
logging level dhcp_snoop 6
logging level eth_port_channel 6
 

 
関連コマンド

コマンド
説明

cd

現在の作業ディレクトリを変更します。

copy

ファイルをコピーします。

dir

ディレクトリの内容を表示します。

pwd

現在の作業ディレクトリ名を表示します。

telnet

Telnet セッションを作成するには、 telnet コマンドを使用します。

telnet { ipv4-address | hostname } [ port-number ] [ vrf vrf-name ]

 
構文の説明

ipv4-address

リモート デバイスの IPv4 アドレス。

hostname

リモート デバイスのホスト名。名前は、英数字で指定します。大文字と小文字が区別され、最大文字数は 64 です。

port-number

(任意)Telnet セッションのポート番号。有効な範囲は 1 ~ 65535 です。

vrf vrf-name

(任意)Telnet セッションで使用する Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)名を指定します。名前では、大文字と小文字が区別されます。

 
デフォルト

ポート 23

デフォルト VRF

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドを使用するには、 telnet server enable コマンドを使用して Telnet サーバをイネーブルにする必要があります。

次に、IPv4 アドレスで Telnet セッションを開始する例を示します。

n1010# telnet 10.10.1.1 vrf management
 

 
関連コマンド

コマンド
説明

clear line

Telnet セッションを消去します。

telnet server enable

Telnet サーバをイネーブルにします。

telnet server enable

Telnet サーバをイネーブルにするには、 telnet server enable コマンドを使用します。Telnet サーバをディセーブルにするには、このコマンドの no 形式を使用します。

telnet server enable

no telnet server enable

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

次に、Telnet サーバをイネーブルにする例を示します。

n1010# configure terminal
n1010(config)# telnet server enable
 

次に、Telnet サーバをディセーブルにする例を示します。

n1010# configure terminal
n1010(config)# no telnet server enable
XML interface to system may become unavailable since ssh is disabled
 

 
関連コマンド

コマンド
説明

show telnet server

Telnet サーバの設定を表示します。

telnet

Telnet セッションを作成します。

terminal event-manager bypass

CLI イベント マネージャをバイパスするには、 terminal event-manager bypass コマンドを使用します。

terminal event-manager byp ass

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

イベント マネージャはイネーブルです。

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者
ネットワーク オペレータ

 
構文の説明

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

次に、CLI イベント マネージャをディセーブルにする例を示します。

n1010# terminal event-manager bypass
n1010#

 
関連コマンド

コマンド
説明

show terminal

端末の設定を表示します。

terminal length

画面に表示される行数を設定するには、 terminal length コマンドを使用します。

terminal length number

 
構文の説明

number

行数。有効な範囲は 0 ~ 511 です。

 
デフォルト

28 行

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者
ネットワーク オペレータ

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

 
使用上のガイドライン

一時停止をディセーブルに設定するには number に 0 を指定します。

次に、画面に表示する行数を設定する例を示します。

n1010# terminal length 60
n1010#

 
関連コマンド

コマンド
説明

show terminal

端末の設定を表示します。

terminal monitor

Telnet または Secure Shell(SSH; セキュア シェル)へのロギングをイネーブルにするには、 terminal monitor コマンドを使用します。

terminal monitor

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

次に、Telnet または SSH へのロギングをイネーブルにする例を示します。

n1010# terminal monitor
n1010#

 
関連コマンド

コマンド
説明

show terminal

端末の設定を表示します。

terminal length

画面に表示される行数を設定します。

terminal session-timeout

セッション タイムアウトを設定します。

terminal terminal-type

端末タイプを指定します。

terminal width

端末の幅を設定します。

terminal session-timeout

セッション タイムアウトを設定するには、 terminal session-timeout コマンドを使用します。

terminal session-timeout time

 
構文の説明

time

タイムアウト時間を秒単位で指定します。有効な範囲は 0 ~ 525600 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者
ネットワーク オペレータ

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

 
使用上のガイドライン

タイムアウトをディセーブルに設定するには time に 0 を指定します。

次に、セッション タイムアウトを設定する例を示します。

n1010# terminal session-timeout 100
n1010#

 
関連コマンド

コマンド
説明

show terminal

端末の設定を表示します。

terminal terminal-type

端末タイプを指定するには、 terminal terminal-type コマンドを使用します。

terminal terminal-type type

 
構文の説明

type

端末タイプを指定します。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者
ネットワーク オペレータ

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

次に、端末タイプを指定する例を示します。

n1010# terminal terminal-type vt100
n1010#

 
関連コマンド

コマンド
説明

show terminal

端末の設定を表示します。

terminal tree-update

メインのパース ツリーを更新するには、 terminal tree-update コマンドを使用します。

terminal tree-update

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者
ネットワーク オペレータ

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

次に、メインのパース ツリーを更新する例を示します。

n1010# terminal tree-update
n1010#

 
関連コマンド

コマンド
説明

show terminal

端末の設定を表示します。

terminal width

端末の幅を設定するには、 terminal width コマンドを使用します。

terminal width number

 
構文の説明

number

1 行の文字数を指定します。有効な範囲は 24 ~ 511 です。

 
デフォルト

102 列

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者
ネットワーク オペレータ

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

次に、端末の幅を指定する例を示します。

n1010# terminal width 60
n1010#

 
関連コマンド

コマンド
説明

show terminal

端末の設定を表示します。

traceroute

パケットが IPv4 アドレスへの移動時に通るルートを検出するには、 traceroute コマンドを使用します。

traceroute { dest-ipv4-addr | hostname } [ vrf vrf-name ] [ show-mpls-hops ] [ source src-ipv4-addr ]

 
構文の説明

dest-ipv4-addr

宛先デバイスの IPv4 アドレス。形式は、 A . B . C . D です。

hostname

宛先デバイスの名前。名前では、大文字と小文字が区別されます。

vrf vrf-name

(任意)使用する Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)を指定します。名前では、大文字と小文字が区別されます。

show-mpls-hops

(任意)MPLS ホップ カウントが表示されます。

source src-ipv4-addr

(任意)送信元 IPv4 アドレスが指定されます。形式は、 A . B . C . D です。

 
デフォルト

デフォルトの VRF を使用します。
MPLS ホップを表示しません。
送信元アドレスに管理 IPv4 アドレスを使用します。

 
コマンド モード

任意のコマンド モード

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SP1(1)

このコマンドが追加されました。

 
使用上のガイドライン

IPv6 アドレス指定を使用してデバイスへのルートを検出するには、 traceroute6 コマンドを使用します。

次に、デバイスへのルートを調べる例を示します。

n1010# traceroute 172.28.255.18 vrf management
traceroute to 172.28.255.18 (172.28.255.18), 30 hops max, 40 byte packets
1 172.28.230.1 (172.28.230.1) 0.746 ms 0.595 ms 0.479 ms
2 172.24.114.213 (172.24.114.213) 0.592 ms 0.51 ms 0.486 ms
3 172.20.147.50 (172.20.147.50) 0.701 ms 0.58 ms 0.486 ms
4 172.28.255.18 (172.28.255.18) 0.495 ms 0.43 ms 0.482 ms
 

 
関連コマンド

コマンド
説明

ping

IPv4 アドレッシングを使用する別のデバイスへのネットワーク接続性を調べます。