Cisco Nexus 1000V コマンド リファレンス リリース 4.2(1)SV1(5.1)
S コマンド
S コマンド
発行日;2012/07/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

S コマンド

segment id

send

server

service-policy

service-port

session-limit

set

setup

shutdown(VLAN)

shutdown(インターフェイス)

shutdown(ポート プロファイル)

sleep

snmp-server aaa-user cache-timeout

snmp-server community

snmp-server contact

snmp-server globalEnforcePriv

snmp-server host

snmp-server location

snmp-server protocol enable

snmp-server tcp-session

snmp-server user

snmp trap link-status

source-interface

source mgmt(NetFlow)

speed

ssh

ssh key

state(VLAN)

state(ポート プロファイル)

statistics per-entry

sub-group

sub-group-id

svs connection

svs-domain

svs license transfer src-vem

svs license volatile

svs mode

svs upgrade complete

svs upgrade start

svs veth auto-config-purge

svs veth auto-delete

svs veth auto-setup

switchname

switchport access bridge-domain

switchport access vlan

switchport mode

switchport port-security

switchport private-vlan host-association

switchport private-vlan mapping

switchport private-vlan mapping trunk

switchport trunk allowed vlan

switchport trunk native vlan

system jumbomtu

system redundancy role

system storage-loss

system switchover

system update vem feature level

system vlan

S コマンド

この章では、S で始まる Cisco Nexus 1000V コマンドについて説明します。

segment id

VXLAN にセグメント ID を指定するには、 segment id コマンドを使用します。セグメント ID を削除するには、このコマンドの no 形式を使用します。

segment id segment-id

no segment id

 
構文の説明

segment-id

VXLAN のセグメント ID です。有効な値は 4096 ~ 16777215 です。(値 1 ~ 4095 は VLAN に予約されています)

 
デフォルト

なし

 
コマンド モード

ブリッジ ドメイン コンフィギュレーション(config-bd)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.2(1)SV1(5.1)

このコマンドが追加されました。

 
使用上のガイドライン

1 つのブリッジ ドメインだけが特定のセグメント ID 値を使用できます。

次に VXLAN にセグメント ID を指定する例を示します。

n1000v# configure terminal

n1000v(config)# bridge-domain tenant-red

n1000v(config-bd)# segment id 20480

n1000v(config-bd)#
 
 

 
関連コマンド

コマンド
説明

show bridge-domain

ブリッジ ドメインの情報を表示します。

send

オープン セッションにメッセージを送信するには、 send コマンドを使用します。

send { message | session device message }

 
構文の説明

message

メッセージです。

session

特定のセッションを指定します。

device

デバイス タイプです。

 
デフォルト

なし

 
コマンド モード

任意

 
サポートされるユーザ ロール

ネットワーク管理者
ネットワーク オペレータ

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、オープン セッションにメッセージを送信する例を示します。

n1000v# send session sessionOne testing
n1000v#

 
関連コマンド

コマンド
説明

show banner

バナーを表示します。

server

RADIUS サーバを RADIUS サーバ グループのメンバーとして設定するには、 server コマンドを使用します。サーバを削除するには、このコマンドの no 形式を使用します。

server { ipv4-address | server-name }

no server { ipv4-address | server-name }

 
構文の説明

ipv4-address

RADIUS サーバの IPV4 アドレスを指定します。

server-name

RADIUS サーバを識別する名前を指定します。

 
デフォルト

なし

 
コマンド モード

Radius コンフィギュレーション(config-radius)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、RADIUS サーバを RADIUS サーバ グループのメンバーとして設定する例を示します。

n1000v# config t
n1000v(config)# aaa group server radius RadServer
n1000v(config-radius)# server 10.10.1.1
n1000v(config-radius)#
 

次に、サーバの設定を削除する例を示します。

n1000v# config t
n1000v(config)# aaa group server radius RadServer
n1000v(config)# no server 10.10.1.1
 

 
関連コマンド

コマンド
説明

aaa group server radius

RADIUS サーバ グループを作成し、そのグループの RADIUS サーバ グループ コンフィギュレーション サブモードを開始します。

deadtime

モニタリング デッド タイムを設定します。

use-vrf

サーバ グループ内のサーバとの接続に使用する Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)を指定します。

show radius-server groups

RADIUS サーバ グループの設定を表示します。

service-policy

インターフェイスのサービス ポリシーを設定するには、 service-policy コマンドを使用します。サービス ポリシー設定を削除するには、このコマンドの no 形式を使用します。

service-policy { input name [ no-stats ] | output name [ no-stats ] | type qos { input name [ no-stats ] | output name [ no-stats ]}}

no service-policy { input name [ no-stats ] | output name [ no-stats ] | type qos { input name [ no-stats ] | output name [ no-stats ]}}

 
構文の説明

input

入力サービス ポリシーを指定します。

name

ポリシー名。有効な値の範囲は、1 ~ 40 です。

no-stats

(任意)統計情報がないことを指定します。

output

出力サービス ポリシーを指定します。

type qos

QoS サービス ポリシーを指定します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、vEthernet インターフェイス 10 に sp10 という入力 QoS サービス ポリシーを統計情報なしで追加する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 10
n1000v(config-if)# service-policy type qos input sp10 no-stats
n1000v(config-if)#
 

次に、vEthernet インターフェイス 10 から統計情報なしの sp10 という入力 QoS サービス ポリシーを
削除する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 10
n1000v(config-if)# no service-policy type qos input sp10 no-stats
n1000v(config-if)#

 
関連コマンド

コマンド
説明

show running-config interface

インターフェイス設定情報を表示します。

interface vethernet

vEthernet インターフェイス設定を作成します。

port-profile

ポート プロファイル設定を作成します。

service-port

バーチャル サービス ドメイン(VSD)ポート プロファイルに内部インターフェイスまたは外部インターフェイスを設定するには、 service-port コマンドを使用します。設定を削除するには、このコマンドの no 形式を使用します。

service-port { inside | outside } [ default-action { drop | forward }]

no service-port

 
構文の説明

inside

内部ネットワーク

outside

外部ネットワーク

default-action

(任意)サービス ポートがダウンした場合のアクションを指定します。

drop :パケットをドロップします

forward :パケットを転送します(デフォルト)

 
デフォルト

forward default-action

 
コマンド モード

ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(2)

このコマンドが追加されました。

 
使用上のガイドライン

SVM に対して設定されたポート プロファイルにサービス ポートが指定されていない場合は、ネットワーク上でパケット フラッディングが発生します。

SVM に対してポート プロファイルを設定するときは、初めにその SVM を停止させてください。このようにすれば、ポート プロファイルがサービス ポートを持たないように誤って設定されても、ネットワーク上でパケット フラッディングが発生することはありません。設定と確認が完了したら、SVM を再び稼動させます。

次に、サービス ポートがダウンした場合にパケットをドロップする内部インターフェイスを VSD ポート プロファイルに設定する例を示します。

n1000v# config t
n1000v(config)# port-profile svm_vsd1_in
n1000v(config-port-prof)# service-port inside default-action drop
n1000v(config-port-prof)#
 

次に、サービス ポート コンフィギュレーションを削除する例を示します。

n1000v# config t
n1000v(config)# port-profile svm_vsd1_in
n1000v(config-port-prof)# no service-port
n1000v(config-port-prof)#
 

 
関連コマンド

コマンド
説明

show virtual-service-domain

VSD 名やポート プロファイルなど、現在 VSM に設定されている VSD のリストを表示します。

session-limit

VSH セッションの数を制限するには、 session-limit コマンドを使用します。制限を削除するには、このコマンドの no 形式を使用します。

session-limit number

no session-limit number

 
構文の説明

number

VSH セッションの数です。有効な値の範囲は、1 ~ 64 です。

 
デフォルト

制限は設定されていません。

 
コマンド モード

ライン コンフィギュレーション(config-line)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、VSH セッションの数を制限する例を示します。

n1000v# configure terminal
n1000v(config)# line vty
n1000v(config-line)# session-limit 10
n1000v(config-line)#
 

次に、制限を解除する例を示します。

n1000v# configure terminal
n1000v(config)# line vty
n1000v(config-line)# no session-limit 10
n1000v(config-line)#

set

QoS クラス属性を設定するには、 set コマンドを使用します。クラス属性を削除するには、このコマンドの no 形式を使用します。

set {{ cos cos-val } | { dscp [ tunnel ] { dscp-val | dscp-enum }} | { precedence [ tunnel ] { prec-val | prec-enum }} | { discard-class dis-class-val } | { qos-group qos-grp-val } | {{{ cos cos } | { dscp dscp } | { precedence precedence } | { discard-class discard-class }} table table-map-name } | { cos1 {{ dscp table cos-dscp-map } | { precedence table cos-precedence-map } | { discard-class table cos-discard-class-map }}} | { dscp1 {{ cos table dscp-cos-map } | { prec3 table dscp-precedence-map } | { dis-class3 table dscp-discard-class-map }}} | { prec1 {{ cos3 table precedence-cos-map } | { dscp3 table precedence-dscp-map } | { dis-class3 table precedence-discard-class-map }}} | { dis-class1 {{ cos3 table discard-class-cos-map } | { dscp3 table discard-class-dscp-map } | { prec3 table discard-class-precedence-map }}}}

no set {{ cos cos-val } | { dscp [ tunnel ] { dscp-val | dscp-enum }} | { precedence [ tunnel ] { prec-val | prec-enum }} | { discard-class dis-class-val } | { qos-group qos-grp-val } | {{{ cos cos } | { dscp dscp } | { precedence precedence } | { discard-class discard-class }} table table-map-name } | { cos1 {{ dscp table cos-dscp-map } | { precedence table cos-precedence-map } | { discard-class table cos-discard-class-map }}} | { dscp1 {{ cos table dscp-cos-map } | { prec3 table dscp-precedence-map } | { dis-class3 table dscp-discard-class-map }}} | { prec1 {{ cos3 table precedence-cos-map } | { dscp3 table precedence-dscp-map } | { dis-class3 table precedence-discard-class-map }}} | { dis-class1 {{ cos3 table discard-class-cos-map } | { dscp3 table discard-class-dscp-map } | { prec3 table discard-class-precedence-map }}}}

 
構文の説明

cos

IEEE 802.1Q Class of Service(CoS; サービス クラス)を指定します。

cos-value

CoS 値 有効な値の範囲は、0 ~ 7 です。

dscp

IPv4 および IPv6 パケットの DSCP(Differentiated Services Code Point)を指定します。

tunnel

(任意)トンネル カプセル化の DSCP を指定します。

dscp-value

DSCP 値です。

dscp-enum

precedence

IP(v4)および IPv6 パケットのプレシデンスです。

prec-val

IP プレシデンス値です。

prec-enum

.

discard-class dis-class-val

廃棄クラスと廃棄クラス値です。

qos-group qos-grp-val

Qos グループと Qos グループ値です。

table table-map-name

入力から出力へのテーブル定義マッピングとテーブル マップ名です。

cos1

IEEE 802.1Q CoS です。

cos-dscp-map

Cos から DSCP への変換マップです。

cos-precedence-map

Cos からプレシデンスへの変換マップです。

cos-discard-class-map

Cos から廃棄クラスへの変換マップです。

dscp1

IP(v4)および IPv6 パケットの DSCP です。

dscp-cos-map

DSCP から CoS への変換マップです。

prec3

IP(v4)および IPv6 パケットのプレシデンスです。

dscp-precedence-map

DSCP からプレシデンスへの変換マップです。

dis-class3

廃棄クラスです。

dscp-discard-class-map

DSCP から廃棄クラスへの変換マップです。

prec1

IP(v4)および IPv6 パケットのプレシデンスです。

cos3

IEEE 802.1Q CoS です。

precedence-cos-map

プレシデンスから CoS への変換マップです。

dscp3

IP(v4)および IPv6 パケットの DSCP です。

precedence-dscp-map

プレシデンスから DSCP への変換マップです。

precedence-discard-class-map

プレシデンスから廃棄クラスへの変換マップです。

dis-class1

廃棄クラスです。

discard-class-cos-map

廃棄クラスから CoS への変換マップです。

discard-class-dscp-map

廃棄クラスから DSCP への変換マップです。

discard-class-precedence-map

廃棄クラスからプレシデンスへの変換マップです。

 
デフォルト

なし

 
コマンド モード

ポリシー マップ クラス コンフィギュレーション(config-pmap-c-qos)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、クラス属性を設定する例を示します。

n1000v# configure terminal
n1000v(config)# policy-map pm1
n1000v(config-pmap-qos)# class class-default
n1000v(config-pmap-c-qos)# set qos-group 1
n1000v(config-pmap-c-qos)#
 

次に、クラス属性を削除する例を示します。

n1000v# configure terminal
n1000v(config)# policy-map pm1
n1000v(config-pmap-qos)# class class-default
n1000v(config-pmap-c-qos)# no set qos-group 1
n1000v(config-pmap-c-qos)#
 

 
関連コマンド

コマンド
説明

show policy-map

ポリシー マップを表示します。

setup

コンフィギュレーション ファイルの作成または修正に Basic System Configuration Dialog を使用するには、 setup コマンドを使用します。

setup

 
構文の説明

このコマンドには、引数もキーワードもありませんが、Basic System Configuration Dialog ではセットアップ情報の入力を求められます(次の例を参照してください)。

 
デフォルト

なし

 
コマンド モード

任意

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

Basic System Configuration Dialog は出荷時を前提としています。既存のコンフィギュレーションを修正する場合はこの点に留意してください。

コンフィギュレーションに対して行われた変更はすべてセットアップ シーケンスの終了時に表示され、変更を保存するかしないかをオプションで選べます。

Ctrl+C キーを押すと、どの時点でもセットアップ シーケンスを終了できます。

次に、ベーシック システム コンフィギュレーションの作成または修正に setup コマンドを使用する例を示します。

n1000v# setup
 
 
Enter the domain id<1-4095>: 400
 
Enter HA role[standalone/primary/secondary]: standalone
 
[########################################] 100%
 
 
---- Basic System Configuration Dialog ----
 
This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.
 
*Note: setup is mainly used for configuring the system initially,
when no configuration is present. So setup always assumes system
defaults and not the current system configuration values.
 
Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.
 
Would you like to enter the basic configuration dialog (yes/no): y
 
Create another login account (yes/no) [n]: n
 
Configure read-only SNMP community string (yes/no) [n]: n
 
Configure read-write SNMP community string (yes/no) [n]: n
 
Enter the switch name : n1000v
 
Continue with Out-of-band (mgmt0) management configuration? (yes/no) [y]:
 
Mgmt0 IPv4 address :
 
Configure the default gateway? (yes/no) [y]: n
 
Configure advanced IP options? (yes/no) [n]:
 
Enable the telnet service? (yes/no) [y]:
 
Enable the ssh service? (yes/no) [n]:
 
Configure the ntp server? (yes/no) [n]:
 
Configure vem feature level? (yes/no) [n]:
 
Configure svs domain parameters? (yes/no) [y]:
 
Enter SVS Control mode (L2 / L3) : l2
Invalid SVS Control Mode
Enter SVS Control mode (L2 / L3) : L2
Enter control vlan <1-3967, 4048-4093> : 400
 
Enter packet vlan <1-3967, 4048-4093> : 405
 
The following configuration will be applied:
switchname n1000v
feature telnet
no feature ssh
svs-domain
svs mode L2
control vlan 400
packet vlan 405
domain id 400
vlan 400
vlan 405
 
Would you like to edit the configuration? (yes/no) [n]:
 
Use this configuration and save it? (yes/no) [y]: n
 
n1000v#

 
関連コマンド

コマンド
説明

show running-config

実行コンフィギュレーションを表示します。

shutdown(VLAN)

VLAN のスイッチングをシャットダウンするには、 shutdown コマンドを使用します。スイッチングを有効にするには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

no shutdown

 
コマンド モード

VLAN コンフィギュレーション(config-vlan)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

デフォルト VLAN の VLAN1、または VLAN 1006 ~ 4094 はシャットダウンできません。

次の例では、VLAN 10 のスイッチングをシャットダウンする方法を示します。

n1000v# configure terminal
n1000v(config)# vlan 10
n1000v(config-vlan)# shutdown
n1000v(config-vlan)#
 

次に、VLAN 10 のスイッチングを有効にする例を示します。

n1000v# configure terminal
n1000v(config)# vlan 10
n1000v(config-vlan)# no shutdown
n1000v(config-vlan)#

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

vlan

VLAN コンフィギュレーションを作成します。

shutdown(インターフェイス)

インターフェイスをディセーブルにするには、 shutdown コマンドを使用します。インターフェイスをイネーブルにするには、このコマンドの no 形式を使用します。

shutdown [ force ]

no shutdown [ force ]

 
構文の説明

force

(任意)インターフェイスを管理上イネーブルにするか、ディセーブルにします。

 
デフォルト

シャットダウンなし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドはインターフェイスをシャットダウンします。トラフィックは通過せず、インターフェイスは管理ダウン状態になります。

次に、イーサネット インターフェイス 3/1 を管理上ディセーブルにする例を示します。

n1000v# config t
n1000v(config)# interface ethernet 3/1
n1000v(config-if)# shutdown
n1000v(config-if)#
 

次に、イーサネット インターフェイス 3/1 を管理上イネーブルにする例を示します。

n1000v# config t
n1000v(config)# interface ethernet 3/1
n1000v(config-if)# no shutdown
n1000v(config-if)#

 
関連コマンド

コマンド
説明

show interface

インターフェイスの設定を表示します。

interface ethernet

イーサネット インターフェイス設定を作成します。

interface vethernet

vEthernet インターフェイス設定を作成します。

shutdown(ポート プロファイル)

ポート プロファイルのすべてのポートをディセーブルにするには、 shutdown コマンドを使用します。ポート プロファイルのポートをイネーブルにするには、このコマンドの no 形式を使用します。

shutdown [ force ]

no shutdown [ force ]

 
構文の説明

force

(任意)プロファイルのすべてのポートを管理上イネーブルまたはディセーブルにします。

 
デフォルト

すべてのポートが管理上ディセーブルです

 
コマンド モード

ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、プロファイルのすべてのポートを管理上ディセーブルにします。トラフィックは通過せず、ポートは管理ダウン状態で表示されます。

次に、TrunkProf のポート プロファイルのすべてのポートを管理上イネーブルにする例を示します。

n1000v# config t
n1000v(config)# port-profile TrunkProf
n1000v(config-port-prof)# no shutdown
n1000v(config-port-prof)#
 

次に、TrunkProf のポート プロファイルのすべてのポートを管理上ディセーブルにする例を示します。

n1000v# config t
n1000v(config)# port-profile TrunkProf
n1000v(config-port-prof)# shutdown
n1000v(config-port-prof)#
 

 
関連コマンド

コマンド
説明

show port-profile name profile_name

指定したポート プロファイル設定を表示します。

port-profile

ポート プロファイル設定を作成します。

sleep

スリープ時間を設定するには、 sleep コマンドを使用します。

sleep time

 
構文の説明

time

スリープ時間を秒単位で指定します。有効な値の範囲は、0 ~ 2147483647 です。

 
デフォルト

スリープ時間は設定されていません。

 
コマンド モード

任意

 
サポートされるユーザ ロール

ネットワーク管理者
ネットワーク オペレータ

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

time を 0 に設定した場合、スリープはディセーブルになります。

次に、スリープ時間を設定する例を示します。

n1000v# sleep 100
n1000v#
 

次に、スリープをディセーブルにする例を示します。

n1000v# sleep 0
n1000v#

snmp-server aaa-user cache-timeout

ローカル キャッシュで AAA 同期ユーザ設定を維持する時間を設定には、 snmp-server aaa-user cache-timeout コマンドを使用します。デフォルトの 3600 秒に戻すには、このコマンドの no 形式を使用します。

snmp-server user aaa-user cache-timeout seconds

no snmp-server user aaa-user cache-timeout seconds

 
構文の説明

seconds

ローカル キャッシュでユーザ設定を維持する時間の長さを指定します。範囲は 1 ~ 86400 秒です。

 
デフォルト

デフォルトのタイムアウトは 3600 秒です。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、AAA 同期ユーザ設定をローカル キャッシュで 1200 秒間維持するように設定する例を示します。

n1000v# config t
n1000v(config)# snmp-server aaa-user cache-timeout 1200
 

次に、デフォルトの 3600 秒に戻す例を示します。

n1000v# config t
n1000v(config)# no snmp-server aaa-user cache-timeout 1200

 
関連コマンド

コマンド
説明

show snmp

SNMP 情報を表示します。

snmp-server contact

sysContact(SNMP コンタクト)を設定します。

snmp-server protocol enable

SNMP プロトコルをイネーブルにします。

snmp-server globalEnforcePriv

すべてのユーザに対して SNMP メッセージ暗号化を適用します。

snmp-server host

SNMP トラップまたは応答要求のホスト レシーバを設定します。

snmp-server location

sysLocation(SNMP ロケーション)を設定します。

snmp-server tcp-session

TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

snmp-server user

認証およびプライバシー パラメータのある SNMP ユーザを設定します。

snmp-server community

SNMP コミュニティ ストリングを作成するには、 snmp-server community コマンドを使用します。コミュニティを削除するには、このコマンドの no 形式を使用します。

snmp-server community string [ group group-name ] [ ro | rw ]

no snmp-server community string [ group group-name ] [ ro | rw ]

 
構文の説明

string

SNMP コミュニティ ストリングです。これがコミュニティを識別します。

group

(任意)このコミュニティが属するグループを指定します。

group-name

既存のグループを識別する名前を指定します。

ro

(任意)このコミュニティの読み取り専用アクセスを指定します。

rw

(任意)このコミュニティの読み取りと書き込みアクセスを指定します。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

SNMPv1 または SNMPv2c の SNMP コミュニティを作成できます。

次に、public という名前の SNMP コミュニティの読み取り専用アクセスを設定する例を示します。

n1000v# config t
n1000v(config)# snmp-server community public ro
 

次に、public という名前の SNMP コミュニティを削除する例を示します。

n1000v# config t
n1000v(config)# no snmp-server community public

 
関連コマンド

コマンド
説明

show snmp

SNMP 情報を表示します。

snmp-server aaa-user cache-timeout

ローカル キャッシュで AAA 同期ユーザ設定を維持する時間を設定します。

snmp-server contact

sysContact(SNMP コンタクト)を設定します。

snmp-server protocol enable

SNMP をイネーブルにします。

snmp-server globalEnforcePriv

すべてのユーザに対して SNMP メッセージ暗号化を適用します。

snmp-server host

SNMP トラップまたは応答要求のホスト レシーバを設定します。

snmp-server location

sysLocation(SNMP ロケーション)を設定します。

snmp-server tcp-session

TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

snmp-server user

認証およびプライバシー パラメータのある SNMP ユーザを設定します。

snmp-server community

SNMP コミュニティ ストリングを作成してアクセス権限を割り当てます。

snmp-server contact

SNMP コンタクト名として sysContact を設定するには、 snmp-server contact コマンドを使用します。

sysContact を削除または変更するには、このコマンドの no 形式を使用します。

snmp-server contact [ name ]

no snmp-server contact [ name ]

 
構文の説明

name

(任意)SNMP コンタクト名(sysContact)を 32 文字以下の英数字で指定します。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

SNMPv1 または SNMPv2c の SNMP コミュニティを作成できます。

次に、sysContact を Admin に設定する例を示します。

n1000v# config t
n1000v(config)# snmp-server contact Admin
 

次に、sysContact を削除する例を示します。

n1000v# config t
n1000v(config)# no snmp-server contact

 
関連コマンド

コマンド
説明

show snmp

SNMP 情報を表示します。

snmp-server aaa-user cache-timeout

ローカル キャッシュで AAA 同期ユーザ設定を維持する時間を設定します。

snmp-server protocol enable

SNMP をイネーブルにします。

snmp-server globalEnforcePriv

すべてのユーザに対して SNMP メッセージ暗号化を適用します。

snmp-server host

SNMP トラップまたは応答要求のホスト レシーバを設定します。

snmp-server location

sysLocation(SNMP ロケーション)を設定します。

snmp-server tcp-session

TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

snmp-server user

認証およびプライバシー パラメータのある SNMP ユーザを設定します。

snmp-server globalEnforcePriv

SNMP メッセージの暗号化をすべてのユーザに強制するには、 snmp-server globalEnforcePriv コマンドを使用します。

snmp-server globalEnforcePriv

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、SNMP メッセージの暗号化をすべてのユーザに強制する例を示します。

n1000v# config t
n1000v(config)# snmp-server mib globalEnforcePriv
 

 
関連コマンド

コマンド
説明

show snmp

SNMP 情報を表示します。

snmp-server aaa-user cache-timeout

ローカル キャッシュで AAA 同期ユーザ設定を維持する時間を設定します。

snmp-server contact

sysContact(SNMP コンタクト)を設定します。

snmp-server protocol enable

SNMP をイネーブルにします。

snmp-server host

SNMP トラップまたは応答要求のホスト レシーバを設定します。

snmp-server location

sysLocation(SNMP ロケーション)を設定します。

snmp-server tcp-session

TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

snmp-server user

認証およびプライバシー パラメータのある SNMP ユーザを設定します。

snmp-server host

SNMPv1 トラップまたは SNMPv2c トラップのホスト レシーバを設定するには、 snmp-server host コマンドを使用します。ホストを削除するには、このコマンドの no 形式を使用します。

snmp-server host ip-address { traps | informs}{ version { 1 | 2c | 3 }} [ auth | noauth | priv ] community [ udp_port number ]

no snmp-server host ip-address { traps | informs} { version { 1 | 2c | 3 }} [ auth | noauth | priv ] community [ udp_port number ]

 
構文の説明

ip-address

SNMP 通知ホストの IPv4 アドレス、IPv6 アドレス、または DNS 名です。

informs

このホストへの通知メッセージを指定します。

traps

このホストへのトラップ メッセージを指定します。

version

通知メッセージに使用する SNMP バージョンを指定します。

1

バージョンとして SNMPv1 を指定します。

2c

バージョンとして SNMPv2c を指定します。

3

バージョンとして SNMPv3 を指定します。

auth

(任意)(SNMPv3 に)authNoPriv セキュリティ レベルを指定します。

noauth

(任意)(SNMPv3 に)noAuthNoPriv セキュリティ レベルを指定します。

priv

(任意)(SNMPv3 に)authPriv セキュリティ レベルを指定します。

community

SNMPv1/v2c コミュニティ ストリングまたは SNMPv3 ユーザ名を指定します。コミュニティ ストリングには、255 文字以下の英数字を使用できます。

udp-port

(任意)既存の UDP ポートを指定します。

number

通知ホストの UDP ポートを識別する番号を指定します。指定できる範囲は 0 ~ 65535 です

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

次に、SNMPv1 トラップのホスト レシーバ(192.0.2.1)を設定する例を示します。

n1000v# config t
n1000v(config)# snmp-server host 192.0.2.1 traps version 1 public
 

次に、設定を削除する例を示します。

n1000v# config t
n1000v(config)# no snmp-server host 192.0.2.1 traps version 1 public

 
関連コマンド

コマンド
説明

show snmp

SNMP 情報を表示します。

snmp-server aaa-user cache-timeout

ローカル キャッシュで AAA 同期ユーザ設定を維持する時間を設定します。

snmp-server contact

sysContact(SNMP コンタクト)を設定します。

snmp-server protocol enable

SNMP をイネーブルにします。

snmp-server globalEnforcePriv

すべてのユーザに対して SNMP メッセージ暗号化を適用します。

snmp-server location

sysLocation(SNMP ロケーション)を設定します。

snmp-server tcp-session

TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

snmp-server user

認証およびプライバシー パラメータのある SNMP ユーザを設定します。

snmp-server location

SNMP ロケーション名として sysLocation を設定するには、 snmp-server location コマンドを使用します。

sysLocation を削除するには、このコマンドの no 形式を使用します。

snmp-server location [ name ]

no snmp-server location [ name ]

 
構文の説明

name

(任意)SNMP ロケーション名(sysLocation)を 32 文字以下の英数字で指定します。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、sysLocation を Lab-7 に設定する例を示します。

n1000v# config t
n1000v(config)# snmp-server location Lab-7
 

次に、sysLocation を削除する例を示します。

n1000v# config t
n1000v(config)# no snmp-server location

 
関連コマンド

コマンド
説明

show snmp

SNMP 情報を表示します。

snmp-server aaa-user cache-timeout

ローカル キャッシュで AAA 同期ユーザ設定を維持する時間を設定します。

snmp-server contact

sysContact(SNMP コンタクト)を設定します。

snmp-server protocol enable

SNMP をイネーブルにします。

snmp-server globalEnforcePriv

すべてのユーザに対して SNMP メッセージ暗号化を適用します。

snmp-server host

SNMP トラップまたは応答要求のホスト レシーバを設定します。

snmp-server tcp-session

TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

snmp-server user

認証およびプライバシー パラメータのある SNMP ユーザを設定します。

snmp-server protocol enable

SNMP プロトコルの動作をイネーブルにするには、 snmp-server protocol enable コマンドを使用します。SNMP プロトコルの動作をディセーブルにするには、このコマンドの no 形式を使用します。

snmp-server protocol enable

no snmp-server protocol enable

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

このコマンドは、デフォルトでイネーブルにされています。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、SNTP プロトコルの動作をイネーブルにする例を示します。

n1000v# config t
n1000v(config)# snmp-server protocol enable
 

次に、SNTP プロトコルの動作をディセーブルにする例を示します。

n1000v# config t
n1000v(config)# no snmp-server protocol enable
 

 
関連コマンド

コマンド
説明

show snmp

SNMP 情報を表示します。

snmp-server aaa-user cache-timeout

ローカル キャッシュで AAA 同期ユーザ設定を維持する時間を設定します。

snmp-server contact

sysContact(SNMP コンタクト)を設定します。

snmp-server globalEnforcePriv

すべてのユーザに対して SNMP メッセージ暗号化を適用します。

snmp-server host

SNMP トラップまたは応答要求のホスト レシーバを設定します。

snmp-server location

sysLocation(SNMP ロケーション)を設定します。

snmp-server tcp-session

TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

snmp-server user

認証およびプライバシー パラメータのある SNMP ユーザを設定します。

snmp-server tcp-session

TCP で SNMP に対する認証をイネーブルにするには、 snmp-server tcp-session コマンドを使用します。TCP で SNMP に対する認証をディセーブルにするには、このコマンドの no 形式を使用します。

snmp-server tcp-session [ auth ]

no snmp-server tcp-session

 
構文の説明

auth

(任意)TCP セッション全体で(コマンド ベースではなく)SNMP に対するワンタイム認証をイネーブルにします。

 
デフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、TCP で SNMP に対するワンタイム認証をイネーブルにする例を示します。

n1000v# config t
n1000v(config)# snmp-server tcp-session auth
 

次に、TCP で SNMP に対するワンタイム認証をディセーブルにする例を示します。

n1000v# config t
n1000v(config)# no snmp-server tcp-session
 

 
関連コマンド

コマンド
説明

show snmp

SNMP 情報を表示します。

snmp-server aaa-user cache-timeout

ローカル キャッシュで AAA 同期ユーザ設定を維持する時間を設定します。

snmp-server contact

sysContact(SNMP コンタクト)を設定します。

snmp-server protocol enable

SNMP をイネーブルにします。

snmp-server globalEnforcePriv

すべてのユーザに対して SNMP メッセージ暗号化を適用します。

snmp-server host

SNMP トラップまたは応答要求のホスト レシーバを設定します。

snmp-server location

sysLocation(SNMP ロケーション)を設定します。

snmp-server user

認証およびプライバシー パラメータのある SNMP ユーザを設定します。

snmp-server user

SNMP エンジンにアクセスできるユーザを定義するには、 snmp-server user コマンドを使用します。SNMP エンジンへのユーザ アクセスを拒否するには、このコマンドの no 形式を使用します。

snmp-server user name [ auth { md5 | sha } passphrase-1 [ priv [ aes-128 ] passphrase-2 ] [ engineID id ] [ localizedkey ]]

no snmp-server user name

 
構文の説明

name

SNMP エンジンにアクセスできるユーザの名前を指定します。

auth

(任意)TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

md5

(任意)認証の HMAC MD5 アルゴリズムを指定します。

sha

(任意)認証の HMAC SHA アルゴリズムを指定します。

passphrase-1

このユーザの認証パスフレーズを指定します。パスフレーズには最大 64 文字の英数字を使用できます。大文字と小文字を区別します。

priv

(任意)ユーザの暗号パラメータを指定します。

aes-128

(任意)プライバシーの 128 バイトの AES アルゴリズムを指定します。

passphrase-2

このユーザの暗号パスフレーズを指定します。パスフレーズには最大 64 文字の英数字を使用できます。大文字と小文字を区別します。

engineID

(任意)通知ターゲット ユーザを設定する engineID を指定します(V3 informs 用)。

id

engineID を識別する番号です。コロンで区切った 12 桁の 10 進数で指定します。

localizedkey

(任意)パスフレーズを 130 文字以下の英数字で指定します。大文字と小文字が区別されます。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、HMAC SHA アルゴリズムを認証に使用して、Admin というユーザにワンタイム SNMP 認証を行う例を示します。

n1000v# config t
n1000v(config)# snmp-server user Admin auth sha abcd1234 priv abcdefgh
 

次に、SNMP エンジンへのユーザ アクセスを拒否する例を示します。

n1000v# config t
n1000v(config)# no snmp-server user Admin

 
関連コマンド

コマンド
説明

show snmp

SNMP 情報を表示します。

snmp-server aaa-user cache-timeout

ローカル キャッシュで AAA 同期ユーザ設定を維持する時間を設定します。

snmp-server contact

sysContact(SNMP コンタクト)を設定します。

snmp-server protocol enable

SNMP をイネーブルにします。

snmp-server globalEnforcePriv

すべてのユーザに対して SNMP メッセージ暗号化を適用します。

snmp-server host

SNMP トラップまたは応答要求のホスト レシーバを設定します。

snmp-server location

sysLocation(SNMP ロケーション)を設定します。

snmp-server tcp-session

TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

snmp trap link-status

インターフェイスの SNMP リンクステート トラップをイネーブルにするには、 snmp trap link-status コマンドを使用します。インターフェイスの SNMP リンクステート トラップをディセーブルにするには、このコマンドの no 形式を使用します。

snmp trap link-status

no snmp trap link-status

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

CLI インターフェイス コンフィギュレーション(config-if)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、デフォルトでイネーブルにされています。

次に、インターフェイスの SNMP リンクステート トラップをイネーブルにする例を示します。

n1000v# config t
n1000v(config)# interface veth 2
n1000v(config-if)# snmp trap link-status
n1000v(config-if)#
 

次に、インターフェイスの SNMP リンクステート トラップをディセーブルにする例を示します。

n1000v# config t
n1000v(config)# interface veth 2
n1000v(config-if)# no snmp trap link-status
n1000v(config-if)#

 
関連コマンド

コマンド
説明

interface vethernet

仮想イーサネット インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

snmp-server enable traps

すべての SNMP 通知をイネーブルにします。

snmp-server tcp-session

TCP セッション上で SNMP に対するワンタイム認証をイネーブルにします。

source-interface

RADIUS または TACACS+ サーバ グループに到達する送信元インターフェイスを指定するには、 source-interface コマンドを使用します。送信元インターフェイスを削除するには、このコマンドの no 形式を使用します。

source-interface interface-type interface-id

no source-interface

 
構文の説明

interface-type

インターフェイス タイプを指定します。

loopback:ループバック インターフェイス

mgmt:管理インターフェイス

null:ヌル インターフェイス

port-channel:ポート チャネル インターフェイス

interface-id

スロット/ポートまたは番号などのインターフェイス ID を指定します。

loopback:0 ~ 1023 の仮想インターフェイス番号

mgmt:管理インターフェイス 0

null:ヌル インターフェイス 0

port-channel:1 ~ 4096 のポートチャネル番号

 
デフォルト

なし

 
コマンド モード

RADIUS サーバ グループ コンフィギュレーション(config-radius)

TACACS+ サーバ グループ コンフィギュレーション(config-tacacs+)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.2(1)SV1(4)

このコマンドが追加されました。

 
使用上のガイドライン

次に、RadServer RADIUS サーバ グループの RADIUS サーバに到達する送信元インターフェイス mgmt0 を指定する例を示します。

n1000v # configure terminal

n1000v(config)# aaa group server radius RadServer

n1000v(config-radius)# source-interface mgmt0
n1000v(config-radius)#

次に、設定から送信元インターフェイスを削除する例を示します。

n1000v # configure terminal

n1000v(config)# aaa group server radius RadServer

n1000v(config-radius)# no source-interface
n1000v(config-radius)#

 
関連コマンド

コマンド
説明

aaa group server radius

RADIUS サーバ グループを作成します。

aaa group server tacacs+

TACACS+ サーバ グループを作成します。

show radius-server groups

RADIUS サーバ グループの設定を表示します。

show tacacs-server groups

 

TACACS+ サーバ グループの設定を表示します。

source mgmt(NetFlow)

NetFlow フロー レコードの送信元として指定するインターフェイスをフロー エクスポータに追加するには、 source コマンドを使用します。フロー エクスポータから送信元インターフェイスを削除するには、このコマンドの no 形式を使用します。

source mgmt 0

no source

 
構文の説明

mgmt 0

mgmt 0 インターフェイスをフロー エクスポータに追加します。

 
デフォルト

なし

 
コマンド モード

NetFlow フロー エクスポータ コンフィギュレーション( config-flow-exporter

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

mgmt0 インターフェイスはフロー エクスポータに追加できる唯一のインターフェイスです。

次に、送信元管理インターフェイス 0 を ExportTest フロー エクスポータに追加する例を示します。

n1000v# config t
n1000v(config)# flow exporter ExportTest
n1000v(config-flow-exporter)# source mgmt 0
 

次に、送信元管理インターフェイス 0 を ExportTest フロー エクスポータから削除する例を示します。

n1000v# config t
n1000v(config)# flow exporter ExportTest
n1000v(config-flow-exporter)# no source mgmt 0
 

 
関連コマンド

コマンド
説明

flow exporter

Flexible NetFlow フロー エクスポータを作成します。

flow record

Flexible NetFlow フロー レコードを作成します。

flow monitor

Flexible NetFlow フロー モニタを作成します。

show flow exporter

NetFlow フロー エクスポータに関する情報を表示します。

show flow record

NetFlow のフロー レコード情報を表示します。

show flow monitor

NetFlow フロー モニタに関する情報を表示します。

speed

インターフェイスの速度を設定するには、 speed コマンドを使用します。速度とデュプレックス パラメータの両方を自動的に自動に設定するには、このコマンドの no 形式を使用します。

speed { speed_val | auto [ 10 100 [ 1000 ]]}

no speed [{ speed_val | auto [ 10 100 [ 1000 ]]}]

 
構文の説明

speed_val

インターフェイスのポート速度を Mbps 単位で指定します。

auto

速度を接続先ポートと自動ネゴシエートするようにインターフェイスを設定します。

10

(任意)速度を 10 Mbps に設定します。

100

(任意)速度を 100 Mbps に設定します。

1000

(任意)速度を 1000 Mbps に設定します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

イーサネット ポート速度を自動以外の値(10 Mbps、100 Mbps、1000 Mbps など)に設定する場合は、それに合わせて接続先ポートを設定してください。接続先ポートが速度をネゴシエーションするように設定しないでください。

次に、スロット 3 にあるモジュールのイーサネット ポート 1 の速度を 1000 Mbps に設定する例を示します。

n1000v config t
n1000v(config)# interface ethernet 2/1
n1000v(config-if)# speed 1000
 

次に、速度を自動的に自動に設定する例を示します。

n1000v config t
n1000v(config)# interface ethernet 2/1
n1000v(config-if)# no speed 1000
 

 
関連コマンド

コマンド
説明

interface

設定するインターフェイスを指定します。

duplex

全二重モード、半二重モード、自動ネゴシエート モードを指定します。

show interface

インターフェイス ステータスを表示します。速度およびデュプレックス モード パラメータもあわせて表示します。

ssh

Secure Shell(SSH; セキュア シェル)セッションを作成するには、 ssh コマンドを使用します。

ssh [ username @ ]{ ipv4-address | hostname } [ vrf vrf-name ]

 
構文の説明

username

(任意)SSH セッションのユーザ名。ユーザ名では大文字と小文字は区別されません。

ipv4-address

リモート デバイスの IPv4 アドレス。

hostname

リモート デバイスのホスト名。ホスト名では、大文字と小文字が区別されます。

vrf vrf-name

(任意)SSH セッションで使用する Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)名を指定します。VRF 名では、大文字と小文字が区別されます。

 
デフォルト

デフォルト VRF

 
コマンド モード

任意

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

NX-OS ソフトウェア サポート SSH バージョン 2。

次に、SSH セッションを開始する例を示します。

n1000v# ssh 10.10.1.1 vrf management
The authenticity of host '10.10.1.1 (10.10.1.1)' can't be established.
RSA key fingerprint is 9b:d9:09:97:f6:40:76:89:05:15:42:6b:12:48:0f:d6.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '10.10.1.1' (RSA) to the list of known hosts.
User Access Verification
Password:
 

 
関連コマンド

コマンド
説明

clear ssh session

SSH セッションを消去します。

feature ssh

SSH サーバをイネーブルにします。

ssh key

スイッチのキー ペア(SSH サーバをイネーブルにしている場合に使用されます)を生成するには、 ssh key コマンドを使用します。SSH サーバ キーを削除するには、このコマンドの no 形式を使用します。

ssh key { dsa [ force ] | rsa [ length [ force ]]}

no ssh key [ dsa | rsa ]

 
構文の説明

dsa

Digital System Algorithm(DSA)SSH サーバ キーを指定します。

force

(任意)SSH キーの交換を強制します。

rsa

Rivest, Shamir, and Adelman(RSA)公開キー暗号法の SSH サーバ キーを指定します。

length

(任意)SSH サーバ キーを作成するときに使用するビット数。有効な範囲は 768 ~ 2048 です。

 
デフォルト

1024 ビットの長さ

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

NX-OS ソフトウェア サポート SSH バージョン 2。

SSH サーバ キーを削除または交換する場合、 no feature ssh コマンドを使用してまず SSH サーバをディセーブルにする必要があります。

次に、DSA を使用して SSH サーバ キーを作成する例を示します。

n1000v# config t
n1000v(config)# ssh key dsa
generating dsa key(1024 bits).....
..
generated dsa key
 

次に、デフォルトのキーの長さで RSA を使用して SSH サーバ キーを作成する例を示します。

n1000v# config t
n1000v(config)# ssh key rsa
generating rsa key(1024 bits).....
.
generated rsa key
 

次に、指定したキーの長さで RSA を使用して SSH サーバ キーを作成する例を示します。

n1000v# config t
n1000v(config)# ssh key rsa 768
generating rsa key(768 bits).....
.
generated rsa key
 

次に、force オプションで DSA を使用して SSH サーバ キーを交換する例を示します。

n1000v# config t
n1000v(config)# no feature ssh
n1000v(config)# ssh key dsa force
deleting old dsa key.....
generating dsa key(1024 bits).....
.
generated dsa key
n1000v(config)# feature ssh
 

次に、DSA SSH サーバ キーを削除する例を示します。

n1000v# config t
n1000v(config)# no feature ssh
XML interface to system may become unavailable since ssh is disabled
n1000v(config)# no ssh key dsa
n1000v(config)# feature ssh
 

次に、すべての SSH サーバ キーを削除する例を示します。

n1000v# config t
n1000v(config)# no feature ssh
XML interface to system may become unavailable since ssh is disabled
n1000v(config)# no ssh key
n1000v(config)# feature ssh
 

 
関連コマンド

コマンド
説明

show ssh key

SSH サーバ キーの情報を表示します。

feature ssh

SSH サーバをイネーブルにします。

state(VLAN)

VLAN の動作ステートを設定するには、 state コマンドを使用します。ステートのコンフィギュレーションをディセーブルにするには、このコマンドの no 形式を使用します。

state { active | suspend }

no state

 
構文の説明

active

アクティブ ステートを指定します。

suspend

サスペンド ステートを指定します。

 
デフォルト

なし

 
コマンド モード

VLAN コンフィギュレーション(config-vlan)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、VLAN の動作ステートを設定する例を示します。

n1000v# configure terminal
n1000v(config)# vlan 10
n1000v(config-vlan)# state active
n1000v(config-vlan)#
 

次に、ステートのコンフィギュレーションをディセーブルにする例を示します。

n1000v# configure terminal
n1000v(config)# vlan 10
n1000v(config-vlan)# no state
n1000v(config-vlan)#

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

state(ポート プロファイル)

ポート プロファイルの動作ステートを設定するには、 state コマンドを使用します。

state enabled

 
構文の説明

enabled

ポート プロファイルをイネーブルまたはディセーブルにします。

 
デフォルト

ディセーブル

 
コマンド モード

ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、ポート プロファイルの動作ステートをイネーブルまたはディセーブルにする例を示します。

n1000v# configure terminal
n1000v(config)# port-profile testprofile
n1000v(config-port-prof)# state enabled
n1000v(config-port-prof)#

 
関連コマンド

コマンド
説明

show port-profile

ポート プロファイル情報を表示します。

statistics per-entry

各 ACL エントリの統計情報を収集するには、 statistics per-entry コマンドを使用します。統計情報を削除するには、このコマンドの no 形式を使用します。

statistics per-entry

no statistics per-entry

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

統計情報は収集されません。

 
コマンド モード

ACL コンフィギュレーション(config-acl)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、各 ACL エントリの統計情報を収集する例を示します。

n1000v# configure terminal
n1000v(config)# ip access-list 1
n1000v(config-acl)# statistics per-entry
n1000v(config-acl)#
 

次に、統計情報を削除する例を示します。

n1000v# configure terminal
n1000v(config)# ip access-list 1
n1000v(config-acl)# no statistics per-entry
n1000v(config-acl)#

 
関連コマンド

コマンド
説明

show statistics

統計情報を表示します。

sub-group

インターフェイス ポート チャネル サブグループ割り当てを設定するには、 sub-group コマンドを使用します。この設定を削除するには、このコマンドの no 形式を使用します。

sub-group { cdp | manual }

no sub-group

 
構文の説明

cdp

トラフィック フローを管理するためのサブグループの自動作成に Cisco Discovery Protocol(CDP)情報を使用することを指定します。

manual

サブグループを手動で設定することを指定します。このオプションは、アップストリーム スイッチで CDP が設定されていない場合に使用します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが追加されました。

4.0(4)SV1(2)

manual キーワードが追加されました。

 
使用上のガイドライン

vPC-HM で使用されるポート チャネルを識別するには、このコマンドを使用します。vPC-HM では、メンバー ポートに接続される各アップストリーム スイッチごとにトラフィックを管理することが必要です。アップストリーム スイッチで CDP がイネーブルに設定された場合、Cisco Nexus 1000V はこの情報を使用してサブグループを自動的に割り当てます。アップストリーム スイッチで CDP をイネーブルにしない場合、サブグループを手動で設定する必要があります。

このコマンドは、ポート チャネル インターフェイスにより継承済みのポート プロファイルで指定されたサブグループ コンフィギュレーションをすべて無効にします。

次に、ポート チャネル インターフェイスのサブグループ タイプを設定する例を示します。

h1000v# config t
n1000v(config)# interface port-channel 1
n1000v(config-if)# sub-group cdp
 
 

次に、設定を削除する例を示します。

h1000v# config t
n1000v(config)# interface port-channel 1
n1000v(config-if)# no sub-group
 

 
関連コマンド

コマンド
説明

show interface port channel channel-number

ポート チャネル情報を表示します。

sub-group-id

vPC-HM のイーサネット メンバー ポートのサブグループ ID を設定するには、 sub-group-id コマンドを使用します。サブグループ ID を削除するには、このコマンドの no 形式を使用します。

sub-group-id group_id

no sub-group-id

 
構文の説明

group_id

サブグループの ID 番号です。指定できる範囲は 0 ~ 31 です。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが追加されました。

4.0(4)SV1(2)

サブグループの数は 32 に増えました。

次に、サブグループ 5 上にイーサネット メンバー ポートを設定する例を示します。

n1000v# config t
n1000v(config)# interface Ethernet 3/2
n1000v(config-if)# sub-group-id 1
 
 

次に、設定を削除する例を示します。

n1000v# config t
n1000v(config)# interface Ethernet 3/2
n1000v(config-if)# no sub-group-id
 

 
関連コマンド

コマンド
説明

show interface ethernet slot/port

イーサネット インターフェイスに関する情報を表示します。

svs connection

SVS 接続をイネーブルにするには、 svs connection コマンドを使用します。SVS 接続をディセーブルにするには、このコマンドの no 形式を使用します。

svs connection name

no svs connection name

 
構文の説明

name

接続名です。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

イネーブルにできる SVS 接続は、セッションごとに 1 つだけです。

次に、SVS 接続をイネーブルにする例を示します。

n1000v# configure terminal
n1000v(config)# svs connection conn1
n1000v(config-svs-conn)#
 

次に、SVS 接続をディセーブルにする例を示します。

n1000v# configure terminal
n1000v(config)# no svs connection conn1
n1000v(config)#

 
関連コマンド

コマンド
説明

show svs

SVS 情報を表示します。

svs-domain

SVS ドメインを設定し、SVS ドメイン コンフィギュレーション モードを開始するには、 svs-domain コマンドを使用します。

svs - domain

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、SVS ドメイン コンフィギュレーション モードを開始して、SVS ドメインを設定する例を示します。

n1000v# configure terminal
n1000v(config)# svs-domain
n1000v(config-svs-domain)#
 

 
関連コマンド

コマンド
説明

show svs

SVS 情報を表示します。

svs license transfer src-vem

指定の送信元 VEM から別の VEM にライセンスを転送する、または使用されていないライセンスを VSM ライセンス プールに転送するには、 svs license transfer src-vem コマンドを使用します。

svs license transfer src-vem module number [ dst-vem module number | license_pool ]

 
構文の説明

dst-vem module-number

転送されたライセンスを受信する VEM を指定します。

license_pool

ライセンスをすべて VSM ライセンス プールに転送します。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

VEM のすべての CPU のプールに十分なライセンスがない場合、その VEM にライセンスを移動できません。

ライセンスが転送元の VEM から別の VEM に転送されると、次のようになります。

転送元 VEM の仮想イーサネット インターフェイスがサービスから削除されます。

転送先 VEM の仮想イーサネット インターフェイスがサービスに追加されます。

VEM から VSM ライセンス プールへのライセンスの転送が成功すると、次のようになります。

転送元 VEM の仮想イーサネット インターフェイスがサービスから削除されます。

次に、VEM 3 から VEM 5 にライセンスを転送し、ライセンス設定を表示する例を示します。

n1000v# config t

n1000v(config)# svs license transfer src-vem 3 dst-vem 5
n1000v(config)# show license usage NEXUS1000V_LAN_SERVICES_PKG
Application
-----------
VEM 5 - Socket 1
VEM 5 - Socket 2
VEM 4 - Socket 1
VEM 4 - Socket 2
-----------
 
n1000v#

 

次に、VEM 3 から VSM ライセンス プールにライセンスを転送し、ライセンス設定を表示する例を示します。

n1000v# config t

n1000v(config)# svs license transfer src-vem 3 license_pool

n1000v(config)# show license usage NEXUS1000V_LAN_SERVICES_PKG
Application
-----------
VEM 4 - Socket 1
VEM 4 - Socket 2
-----------
 
n1000v#

 

 
関連コマンド

コマンド
説明

show license usage

VEM で使用される CPU ライセンスの数と位置を表示します。

logging level license

ライセンス メッセージをログに記録する重大度のレベルを指定します。

install license

VSM にライセンス ファイルをインストールします。

svs license transfer src-vem

ソース VEM から別の VEM に、または使用可能なライセンスの VSM プールに、ライセンスを転送します。

svs license volatile

VEM のサービスが中断された場合、常にライセンスが利用可能なライセンスの VSM プールに戻るように、変動ライセンスをイネーブルにするには、 svs license volatile コマンドを使用します。変動ライセンスをディセーブルにするには、このコマンドの no 形式を使用します。

svs license volatile

no svs license volatile

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン


注意 サービス中断
一時ライセンスは接続の喪失時に VEM から削除され、接続が再開されても VEM に戻りません。シスコでは、変動ライセンス機能はディセーブルのままにし、代わりに svs license transfer src-vem コマンドを使用して、使用されていないライセンスを転送することを推奨します。

次に、VSM の変動ライセンス機能をイネーブルにする例を示します。

n1000v(config)# svs license volatile

n1000v(config)#

 

次に、VSM の変動ライセンス機能をディセーブルにする例を示します。

n1000v(config)# no svs license volatile
 

 
関連コマンド

コマンド
説明

show license

VSM のライセンス設定を表示します。

logging level license

ライセンス メッセージをログに記録する重大度のレベルを指定します。

install license

VSM にライセンス ファイルをインストールします。

svs license transfer src-vem

ソース VEM から別の VEM に、または使用可能なライセンスの VSM プールに、ライセンスを転送します。

svs mode

仮想スーパーバイザ モジュール(VSM)ドメインの制御とパケット トラフィックに転送モードを設定するには、 svs mode コマンドを使用します。

svs mode { L2 | L3 interface { mgmt0 | control0 }}

 
構文の説明

L2

VSM ドメインに対する転送モードとしてレイヤ 2 を指定します。

L3 interface

VSM ドメインに対する転送モードとしてレイヤ 3 を指定し、レイヤ 3 転送インターフェイスを設定します。

mgmt0

レイヤ 3 転送インターフェイスとして mgmt0 を指定します。

control0

レイヤ 3 転送インターフェイスとして control0 を指定します。

 
デフォルト

レイヤ 2 モード

 
コマンド モード

SVS ドメイン コンフィギュレーション(config-svs-domain)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(2)

このコマンドが追加されました。

 
使用上のガイドライン

mgmt0 をレイヤ 3 制御インターフェイスとして使用する場合、VSM VM では、イーサネット アダプタ 1 および 3 は使用されません。

control0 をレイヤ 3 制御インターフェイスとして使用する場合、VSM VM では、イーサネット アダプタ 3 は使用されません。

次に、VSM ドメインのレイヤ 3 転送インターフェイスとして mgmt0 を設定する例を示します。

n1000v# config t

n1000v(config)# svs-domain

n1000v(config-svs-domain)# svs mode l3 interface mgmt0

n1000v(config-svs-domain)#

 

 
関連コマンド

コマンド
説明

show svs-domain

VSM ドメインの設定を表示します。

svs-domain

VSM ドメインを作成および設定します。

svs upgrade complete

VSM ソフトウェア アップグレードを実行し、アップグレードされたデータパスに切り替えるようにホストに通知するは svs upgrade complete コマンドを使用します。

svs upgrade complete

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.2(1)SV1(4)

このコマンドが追加されました。

 
使用上のガイドライン

次に、VSM アップグレードを実行し、アップグレードされたデータパスに切り替えるようにホストに通知して、アップグレード ステータスを表示する例を示します。

n1000v(config)# svs upgrade complete
Warning: Config saved but not pushed to vCenter Server due to inactive connection!
n1000v(config)# show running-config | in svs
svs-domain
svs mode L2
svs upgrade complete
svs connection vcenter
 

 
関連コマンド

コマンド
説明

show svs upgrade status

新しいソフトウェア バージョンへの VSM のアップグレードをモニタします。

svs upgrade start

手動 VSM アップグレードを開始し、スタンバイでアップグレード情報を保存します。

svs upgrade start

手動 VSM アップグレードを開始して、スタンバイでアップグレード情報を保存するには、svs upgrade start コマンドを使用します。手動アップグレードを停止するには、このコマンドの no 形式を使用します。

svs upgrade start mgmt0 { ip ipaddress | ipv6 ipv6address } + [control0 ip ipaddr]

no svs upgrade start

 
構文の説明

mgmt0

管理インターフェイスを指定します。

ip ipaddress

IP アドレスを指定します。

ipv6 ipv6address

IPv6 アドレスを指定します。

control0 ip

(任意)control0 IP アドレスを指定します。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.2(1)SV1(4)

このコマンドが追加されました。

 
使用上のガイドライン

手動 VSM アップグレードを開始する前に次を実行します。

システムのすべてのコンフィギュレーションを停止します。また、アップグレード中にコンフィギュレーションを変更しないでください。

アップグレード中に失われないように、実行コンフィギュレーションのすべての変更内容をスタートアップ コンフィギュレーションに保存します。

外部ストレージに実行コンフィギュレーションのコピーを保存します。

制御、パケット、管理、ストレージに使用するすべての VSM ポート、アップリンク、vmknic、vsif がシステム プロファイルで設定されていることを確認します。

VC、VSM ペア、およびホストまたはモジュールの間のネットワーク接続があることを確認します。

すべてのホストまたはモジュールが並行 VEM ソフトウェア バージョンにアップグレードされていることを確認します。

Cisco Nexus 1010 の VSM をアップグレードする場合、セカンダリ VSM2 がアクティブで、プライマリ VSM1 がスタンバイであることを確認します。

Cisco Nexus 1010 で VSM をアップグレードする場合は、Cisco Nexus 1010 が HA 設定に含まれている必要があります。

ソフトウェア アップグレード中の VSM2 へのアクセスを保つために、このプロセスでは VSM2 への代替管理 IP アドレスを割り当てる必要があります。

次に、手動 VSM アップグレードを開始して一時的な IP アドレスを割り当てる例を示します。

n1000v# configure terminal
n1000v(config)# svs upgrade start mgmt0 ip 10.78.109.44
WARNING!
1. Please do not change the configuration of the system from this point onwards
2. Ensure that all relevant ports, including uplinks, vmknics, and vsifs used for control, packet, management, storage as well as VSM ports, are all configured with system profiles
3. Ensure there is network connectivity between VC, VSM pair, and the hosts/modules
4. Ensure all the hosts/modules are upgraded with the next version of VEM software package
n1000v(config)#

 
関連コマンド

コマンド
説明

show svs upgrade status

新しいソフトウェア バージョンへの VSM のアップグレードをモニタします。

svs upgrade complete

VSM ソフトウェア アップグレードを実行し、アップグレードされたデータパスに切り替えるようにホストに通知します。

show module

システムで利用可能なすべての VSM と VEM に関する情報を表示します。

reload

プライマリ VSM とセカンダリ VSM の両方がリブートされます。

show system redundancy status

システムの HA 状態を表示します。

boot kickstart

キックスタート ブート変数が設定されます。

boot system

システム ブート変数が設定されます。

system redundancy role primary

VSM のプライマリ冗長ロールを設定します。

show svs connections

Cisco Nexus 1000V への現在の接続を表示します。

svs veth auto-config-purge

システム管理者がインターフェイスのポート プロファイルを変更するときに、VSM による vEthernet インターフェイスのすべての手動設定の削除をイネーブルにする には、 svs veth auto-config-purge コマンドを使用します。この制御を削除するには、このコマンドの no 形式を使用します。

svs veth auto-config-purge

no svs veth auto-config-purge

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.2(1)SV1(4)

このコマンドが追加されました。

 
使用上のガイドライン

システム管理者がインターフェイスのポート プロファイルを変更するときに、VSM による vEthernet インターフェイスのすべての手動設定の削除をイネーブルにする 例を示します。

n1000v(config)# svs veth auto-config-purge

n1000v(config)#
 

次に、xxx の設定を削除する例を示します。

n1000v(config)# no svs veth auto-config-purge

n1000v(config)#

 
関連コマンド

コマンド
説明

interface vethernet interface-number

vEthernet インターフェイスを作成します。

show running-config

システムの現在の実行コンフィギュレーションに関する情報を表示します。

show interface vethernet

vEthernet インターフェイスに関する情報を表示します。

svs veth auto-delete

vNIC またはハイパーバイザ ポートでもう使用されていない DVPorts の VSM による自動削除をイネーブルにします。

svs veth auto-setup

新しいポートがホストでアクティブになったとき、VSM による vEthernet インターフェイスの自動作成をイネーブルにします。

svs veth auto-delete

vNIC またはハイパーバイザ ポートでもう使用されていない DVPorts の VSM による自動削除をイネーブルにする には、 svs veth auto-delete コマンドを使用します。この制御をディセーブルにするには、このコマンドの no 形式を使用します。

svs veth auto-delete

no svs veth auto-delete

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.2(1)SV1(4)

このコマンドが追加されました。

 
使用上のガイドライン

次に、 vNIC またはハイパーバイザ ポートでもう使用されていない DVPorts の VSM による自動削除をイネーブルにする 例を示します。

n1000v(config)# svs veth auto-delete

n1000v(config)#
 

次に、 vNIC またはハイパーバイザ ポートでもう使用されていない DVPorts の自動削除 をディセーブルにする例を示します。

n1000v(config)# no svs veth auto-delete

n1000v(config)#

 
関連コマンド

コマンド
説明

interface vethernet interface-number

vEthernet インターフェイスを作成します。

show running-config

システムの現在の実行コンフィギュレーションに関する情報を表示します。

show interface vethernet

vEthernet インターフェイスに関する情報を表示します。

svs veth auto-config-purge

システム管理者がインターフェイスのポート プロファイルを変更するときに、VSM による vEthernet インターフェイスのすべての手動設定の削除をイネーブルにします。

svs veth auto-setup

新しいポートがホストでアクティブになったとき、VSM による vEthernet インターフェイスの自動作成をイネーブルにします。

svs veth auto-setup

新しいポートがホストでアクティブになったとき、VSM による vEthernet インターフェイスの自動作成をイネーブルにする には、 svs veth auto-setup コマンドを使用します。この制御を削除するには、このコマンドの no 形式を使用します。

svs veth auto-setup

no svs veth auto-setup

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.2(1)SV1(4)

このコマンドが追加されました。

 
使用上のガイドライン

次に、xxx を設定する例を示します。

n1000v(config)# xxx
 

次に、xxx の設定を削除する例を示します。

n1000v(config)# no xxx
 

 
関連コマンド

コマンド
説明

interface vethernet interface-number

vEthernet インターフェイスを作成します。

show running-config

システムの現在の実行コンフィギュレーションに関する情報を表示します。

show interface vethernet

vEthernet インターフェイスに関する情報を表示します。

svs veth auto-delete

vNIC またはハイパーバイザ ポートでもう使用されていない DVPorts の VSM による自動削除をイネーブルにします。

svs veth auto-config-purge

システム管理者がインターフェイスのポート プロファイルを変更するときに、VSM による vEthernet インターフェイスのすべての手動設定の削除をイネーブルにします。

switchname

デバイスのホスト名を設定するには、 switchname コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchname name

no switchname

 
構文の説明

name

デバイスの名前。この名前は、最大 32 文字の長さの英数字で、大文字と小文字が区別され、特殊文字を含むことができます。

 
デフォルト

switch

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

Cisco NX-OS ソフトウェアでは、コマンドライン インターフェイス(CLI)のプロンプトおよびデフォルトのコンフィギュレーション ファイル名でホスト名を使用します。

switchname コマンドは、 hostname コマンドと同じ機能を実行します。

次に、デバイスのホスト名を設定する例を示します。

n1000v# configure terminal
n1000v(config)# switchname Engineering2
Engineering2(config)#
 

次に、デバイスのホスト名をデフォルトの設定に戻す例を示します。

Engineering2# configure terminal
Engineering2(config)# no switchname
n1000v(config)#

 
関連コマンド

コマンド
説明

hostname

デバイスのホスト名が設定されます。

show switchname

デバイスのホスト名が表示されます。

switchport access bridge-domain

ポート プロファイルに VXLAN ブリッジ ドメインを割り当てるには、 switchport access bridge-domain コマンドを使用します。VXLAN ブリッジ ドメインを削除するには、このコマンドの no 形式を使用します。

switchport access bridge-domain bd-name

no switchport access bridge-domain

 
構文の説明

bd-name

VXLAN ブリッジ ドメインの名前です。

 
デフォルト

なし

 
コマンド モード

ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.2(1)SV1(5.1)

このコマンドが追加されました。

 
使用上のガイドライン

次に、ポート プロファイルに VXLAN ブリッジ ドメインを割り当てる例を示します。

n1000v# configure terminal
n1000v(config)# port-profile tenant-profile

n1000v(config-port-prof)# switchport mode access

n1000v(config-port-prof)# switchport access bridge-domain tenant-red
n1000v(config-port-prof)#
 

 
関連コマンド

コマンド
説明

show bridge-domain

ブリッジ ドメインの情報を表示します。

show running-config port-profile profile-name

指定したポート プロファイルの実行コンフィギュレーションを表示します。

show port-profile name profile_name

ポート プロファイルの設定を表示します。

switchport access vlan

インターフェイスのアクセス モードを設定するには、 switchport access vlan コマンドを使用します。アクセス モードの設定を削除するには、このコマンドの no 形式を使用します。

switchport access vlan id

no switchport access vlan

 
構文の説明

id

VLAN ID 番号。有効な値の範囲は、1 ~ 3967 です。

 
デフォルト

アクセス モードは設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)
ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、インターフェイスのアクセス モードを設定する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 1
n1000v(config-if)# switchport access vlan 10
n1000v(config-if)#
 

次に、アクセス モードの設定を削除する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 1
n1000v(config-if)# no switchport access vlan
n1000v(config-if)#

 
関連コマンド

コマンド
説明

show interface

インターフェイス情報を表示します。

switchport mode

インターフェイスのポート モードを設定するには、 switchport mode コマンドを使用します。ポート モードの設定を削除するには、このコマンドの no 形式を使用します。

switchport mode {access | private-vlan {host | promiscuous} | trunk}

no switchport mode {access | private-vlan {host | promiscuous} | trunk}

 
構文の説明

access

ポート モード アクセスを設定します。

private-vlan

ポート モードをプライベート VLAN に設定します。

host

ポート モード プライベート VLAN をホストに設定します。

promiscuous

ポート モード プライベート VLAN を混合モードに設定します。

trunk

ポート モードをトランクに設定します。

 
デフォルト

スイッチポート モードは設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)
ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、インターフェイスのポート モードを設定する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 1
n1000v(config-if)# switchport mode private-vlan host
n1000v(config-if)#
 

次に、モードの設定を削除する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 1
n1000v(config-if)# no switchport mode private-vlan host
n1000v(config-if)#

 
関連コマンド

コマンド
説明

show interface

インターフェイス情報を表示します。

switchport port-security

インターフェイスのポート セキュリティ特性を設定するには、 switchport port-security コマンドを使用します。ポート セキュリティの設定を削除するには、このコマンドの no 形式を使用します。

switchport port-security [aging {time time | type {absolute | inactivity}} | mac-address { address [vlan id ] |sticky} | maximum number [vlan id ] | violation {protect | shutdown}]

no switchport port-security [aging {time time | type {absolute | inactivity}} | mac-address { address [vlan id ] |sticky} | maximum number [vlan id ] | violation {protect | shutdown}]}

 
構文の説明

aging

ポート セキュリティ エージング特性を設定します。

time

ポート セキュリティ エージング タイムを指定します。

time

エージング タイムを分単位で指定します。有効値の範囲は、0 ~ 1440 です

type

タイマーの種類を指定します。

absolute

absolute タイマーを指定します。

inactivity

inactivity タイマーを指定します。

mac-address address

48 ビットの MAC アドレスを HHHH.HHHH.HHHH の形式で指定します。

vlan

MAC アドレスのセキュリティを設定する VLAN を指定します。

id

VLAN ID 番号。有効な値の範囲は、1 ~ 4094 です。

sticky

スティッキ MAC アドレスを指定します。

maximum number

アドレスの最大数を指定します。有効値の範囲は、1 ~ 1025 です。

violation

セキュリティ違反モードを指定します。

protect

セキュリティ違反保護モードを指定します。

shutdown

セキュリティ違反シャットダウン モードを指定します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)
ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、ポート セキュリティ エージング inactivity タイマーを設定する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 1
n1000v(config-if)# switchport port-security aging type inactivity
n1000v(config-if)#
 

次に、ポート セキュリティ エージング inactivity タイマーを削除する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 1
n1000v(config-if)# no switchport port-security aging type inactivity
n1000v(config-if)#

 
関連コマンド

コマンド
説明

show interface

インターフェイス情報を表示します。

show port-security

ポート セキュリティ情報を表示します。

switchport private-vlan host-association

独立ポートまたはコミュニティ ポートのプライベート VLAN 関連付けを定義するには、switchport private-vlan host-association コマンドを使用します。ポートからプライベート VLAN 関連付けを削除するには、このコマンドの no 形式を使用します。

switchport private-vlan host-association { primary-vlan-id } { secondary-vlan-id }

no switchport private-vlan host-association

 
構文の説明

primary-vlan-id

プライベート VLAN 関係のプライマリ VLAN の番号。

secondary-vlan-id

プライベート VLAN 関係のセカンダリ VLAN の番号。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)
ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポートがプライベート VLAN のホスト モードでない限り、ポート上でランタイムの効果はありません。ポートがプライベート VLAN ホスト モードであっても、VLAN がどちらも存在しない場合は、コマンドは許可されますが、ポートは非アクティブになります。プライベート VLAN 間の関連付けが一時停止されている場合も、ポートが非アクティブになる可能性があります。

セカンダリ VLAN は、独立 VLAN またはコミュニティ VLAN である可能性があります。

次に、プライマリ VLAN(VLAN 18)およびセカンダリ VLAN(VLAN 20)についてプライベート VLAN ホスト ポートを設定する例を示します。

n1000v(config-if)# switchport private-vlan host-association 18 20
n1000v(config-if)#
 

次に、ポートからプライベート VLAN 関連付けを削除する例を示します。

n1000v(config-if)# no switchport private-vlan host-association
n1000v(config-if)#

 
関連コマンド

コマンド
説明

show vlan private-vlan [type]

プライベート VLAN に関する情報を表示します。

switchport private-vlan mapping

混合モード ポートのプライベート VLAN 関連付けを定義するには、 switchport private-vlan mapping コマンドを使用します。プライマリ VLAN からすべてのマッピングをクリアするには、このコマンドの no 形式を使用します。

switchport private-vlan mapping { primary-vlan-id } {[ add ] secondary-vlan-list | remove secondary-vlan-list }

no switchport private-vlan mapping

 
構文の説明

primary-vlan-id

プライベート VLAN 関係のプライマリ VLAN の番号。

add

セカンダリ VLAN をプライマリ VLAN に関連付けます。

secondary-vlan-list

プライベート VLAN 関係のセカンダリ VLAN の番号。

remove

セカンダリ VLAN とプライマリ VLAN 間の関連付けを消去します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)
ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポートがプライベート VLAN の無差別モードでない限り、ポート上でランタイムの効果はありません。ポートがプライベート VLAN 無差別モードであっても、プライマリ VLAN が存在しない場合は、コマンドは許可されますが、ポートは非アクティブになります。

セカンダリ VLAN は、独立 VLAN またはコミュニティ VLAN である可能性があります。

次に、プライベート VLAN 混合ポート上でプライマリ VLAN 18 をセカンダリ隔離 VLAN 20 に関連付けるように設定する例を示します。

n1000v(config-if)# switchport private-vlan mapping 18 20
n1000v(config-if)#
 

次に、混合ポート上の関連付けに VLAN を追加する例を示します。

n1000v(config-if)# switchport private-vlan mapping 18 add 21
n1000v(config-if)#
 

次に、ポートからすべてのプライベート VLAN アソシエーションを削除する例を示します。

n1000v(config-if)# no switchport private-vlan mapping

n1000v(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチ ポートとして設定されているすべてのインターフェイスの情報を表示します。

show interface private-vlan mapping

VLAN インターフェイスのプライベート VLAN マッピングまたは SVI に関する情報を表示します。

switchport private-vlan mapping trunk

プライベート VLAN を指定するには、 switchport private-vlan trunk mapping trunk コマンドを使用します。プライマリ プライベート VLAN を削除するには、このコマンドの no 形式を使用します。

switchport private-vlan trunk native vlan id

no switchport private-vlan trunk native vlan

 
構文の説明

id

VLAN ID 番号。有効な値の範囲は、1 ~ 3967 です。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)
ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドを使用する場合は、セカンダリ VLAN を追加するか、VLAN を削除します。

次に、プライマリ プライベート VLAN を指定する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 1
n1000v(config-if)# n1000v(config-if)# switchport private-vlan mapping trunk 10 add 11
n1000v(config-if)#
 

次に、プライマリ プライベート VLAN を削除する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 1
n1000v(config-if)# n1000v(config-if)# no switchport private-vlan mapping trunk 10
n1000v(config-if)#

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

switchport trunk allowed vlan

トランキング インターフェイスで許可される VLAN のリストを設定するには、 switchport trunk allowed vlan コマンドを使用します。トランキング インターフェイスで すべて の VLAN を許可するには、このコマンドの no 形式を使用します。

switchport trunk allowed vlan { vlan-list | all | none | [ add | except | remove { vlan-list }]}

no switchport trunk allowed vlan

 
構文の説明

vlan-list

トランキング モード時にタグ付き形式でこのインターフェイス経由で送信を行う許可 VLAN。有効な値の範囲は 1 ~ 4094 です。

all

すべての適切な VLAN が、トランキング モード時にタグ付き形式でこのインターフェイス経由で送信を行うようにします。

none

VLAN が、トランキング モード時にタグ付き形式でこのインターフェイス経由で送信を行わないようにブロックします。

add

(任意) 現在設定されている VLAN リストを置き換えずに、定義済み VLAN リストを追加します。

except

(任意) トランキング モードの場合に、指定値を除き、タグ付き形式でこのインターフェイス上を伝送する VLAN をすべて許可します。

remove

(任意) 現在設定されている VLAN リストを置き換えずに、定義済み VLAN リストを削除します。

 
デフォルト

すべての VLAN

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)
ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

switchport trunk allowed vlan コマンドを入力する前に、キーワードなしで switchport コマンドを入力して、LAN インターフェイスをレイヤ 2 インターフェイスとして設定しておく必要があります。この処理は、インターフェイスに対して switchport コマンドを入力しなかった場合にのみ必要となります。

トランクから VLAN 1 を削除しても、トランク インターフェイスは引き続き、VLAN 1 で管理トラフィックの送受信を行います。

次に、連続する一連の VLAN を、トランキング ポートで許可された VLAN のリストに追加する例を示します。

n1000v(config-if)# switchport trunk allowed vlan add 40-50
n1000v(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

switchport trunk native vlan

インターフェイスのトランキング パラメータを設定するには、 switchport trunk native vlan コマンドを使用します。設定を削除するには、このコマンドの no 形式を使用します。

switchport trunk native vlan id

no switchport trunk native vlan

 
構文の説明

id

VLAN ID 番号。有効な値の範囲は、1 ~ 3967 です。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)
ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、インターフェイスのトランキング パラメータを設定する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 10
n1000v(config-if)# switchport trunk native vlan 20
n1000v(config-if)#

 
関連コマンド

コマンド
説明

show vlan

VLAN 情報を表示します。

system jumbomtu

イーサネット ポートが処理できる最大フレーム サイズを指定するシステム全体のジャンボ フレーム サイズを設定するには、 system jumbomtu コマンドを使用します。

system jumbomtu size

 
構文の説明

size

レイヤ 2 イーサネット インターフェイス ジャンボ最大伝送単位(MTU)のサイズ(バイト単位)です。これよりも大きなフレームはドロップされます。設定は 1500 ~ 9000 バイトの範囲の偶数である必要があります。

 
デフォルト

9000 バイト

 
コマンド モード

グローバル コンフィギュレーション(config)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

2 つのポート間で転送するには、どちらのポートにも同じ MTU サイズを設定する必要があります。

ポートの MTU サイズを超えたフレームはドロップされます。

システム ジャンボ MTU サイズを設定しない場合、デフォルトの 1500 バイトになります。

レイヤ 2 ポートには、MTU サイズとして、システム デフォルトの 1500 バイトまたはシステム デフォルトのジャンボ MTU サイズ 9000 バイトのいずれかを設定できます。

システム ジャンボ MTU サイズを変更すると、ポート単位で特に MTU サイズを個別に設定しない限り、レイヤ 2 ポートは自動的にシステム デフォルトの MTU サイズである 1500 バイトを使用します。

次に、システム全体の最大フレーム サイズを 8000 バイトに設定する例を示します。

n1000v# config t
n1000v(config)# system jumbomtu 8000
n1000v#

 
関連コマンド

コマンド
説明

show interface ethernet

設定された MTU サイズを含むイーサネット インターフェイスに関する情報を表示します。

show running-config

現在の稼動設定を表示します。システム ジャンボ MTU サイズもあわせて表示します。

interface ethernet

設定するインターフェイスを指定します。インターフェイス コンフィギュレーション モードを開始します。

mtu

システム ジャンボ MTU サイズを指定します。

system redundancy role

VSM の冗長ロールを設定するには、 system redundancy role コマンドを使用します。デフォルトの設定に戻す場合は、このコマンドの no 形式を使用します。

system redundancy role {primary | secondary | standalone}

no system redundancy role {primary | secondary | standalone}

 
構文の説明

primary

プライマリの冗長 VSM を指定します。

secondary

セカンダリの冗長 VSM を指定します。

standalone

冗長 VSM がないことを指定します。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、冗長 VSM を設定する例を示します。

n1000v# system redundancy role standalone
n1000v#

 
関連コマンド

コマンド
説明

show system redundancy

システムの冗長性ステータスを表示します。

system storage-loss

ストレージ接続の損失を検出して設定するには、 system storage-loss コマンドを使用します。ストレージ損失チェックをディセーブルにするには、このコマンドの no 形式を使用します。

system storage-loss { log | reboot } [ time <interval> ]

no system storage-loss { log | reboot } [ time <interval> ]

 
構文の説明

log

ストレージの損失が検出されるとシステム ログを表示します。

reboot

ストレージの損失が検出されると VSM をリロードします。

time

VSM がストレージ接続のステータスをチェックする時間間隔。デフォルトの時間間隔は 30 秒です。

 
コマンド デフォルト

デフォルトの時間間隔は 30 秒です。

 
コマンド モード

EXEC

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.2(1)SV1(5.1)

このコマンドが追加されました。

次に、実行されるストレージ損失の検出を 50 秒ごとにイネーブルにする例を示します。

n1000v# system storage-loss log time 50
n1000v#
 

次に、ストレージ損失チェックをディセーブルにする例を示します。

n1000v# no system storage-loss

 
関連コマンド

コマンド
説明

show system redundancy

システムの冗長性ステータスを表示します。

system switchover

スタンバイ スーパーバイザに切り替えるには、 system switchover コマンドを使用します。

system switchover

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、スタンバイ スーパーバイザに切り替える例を示します。

n1000v# system switchover
n1000v#

 
関連コマンド

コマンド
説明

show system redundancy

システムの冗長性ステータスを表示します。

system update vem feature level

VEM でサポートされるソフトウェアのバージョンを変更するには、 system update vem feature level コマンドを使用します。

system update vem feature level [ version_number ]

 
構文の説明

version_number

(任意)前述のリストからのバージョン番号インデックスです。

 
デフォルト

なし

 
コマンド モード

任意

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(2)

このコマンドが追加されました。

次に、サポートされるソフトウェアのバージョンを変更する例を示します。

n1000v# system update vem feature level
Error : the feature level is set to the highest value possible
n1000v#

 
関連コマンド

コマンド
説明

show system vem feature level

サポートされる現在のソフトウェア リリースを表示します。

system vlan

ポート プロファイルにシステム VLAN を追加するには、 system vlan コマンドを使用します。ポート プロファイルからシステム VLAN を削除するには、このコマンドの no 形式を使用します。

system vlan vlan-ID-list

no system vlan

 
構文の説明

vlan-ID-list

カンマで区切られた VLAN ID のリストです。有効な範囲は 1 ~ 3967 および 4048 ~ 4093 です。

 
デフォルト

なし

 
コマンド モード

ポート プロファイル コンフィギュレーション(config-port-prof)

 
サポートされるユーザ ロール

ネットワーク管理者

 
コマンド履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

システム VLAN は、仮想スーパーバイザ モジュール(VSM)が仮想イーサネット モジュール(VEM)との通信を確立する前に物理ポートまたは vEthernet ポートを設定し、起動することに使用されます。

次に、ポート プロファイルにシステム VLAN 260 と 261 を追加する例を示します。

n1000v# config t
n1000v (config)# port-profile system-uplink
n1000v(config-port-prof)# system vlan 260, 261
n1000v(config-port-prof)#

 

次に、ポート プロファイルからすべてのシステム VLAN を削除する例を示します。

n1000v# config t
n1000v (config)# port-profile system-uplink
n1000v(config-port-prof)# no system vlan
n1000v(config-port-prof)#
 

 
関連コマンド

コマンド
説明

vlan

VLAN を作成し、VLAN コンフィギュレーション モードを開始します。

show vlan all-ports

すべての VLAN およびそれらに設定されたポートのステータスを表示します。

show vlan private-vlan

プライベート VLAN 情報を表示します。

show vlan summary

VLAN サマリー情報を表示します。