Cisco Nexus 1000V コマンド リファレンス、 リリース 4.0(4)SV1(2)
P コマンド
P コマンド
発行日;2012/01/30 | 英語版ドキュメント(2011/06/20 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

P コマンド

packet vlan

permit (IPv4)

permit (MAC)

ping

pinning

pinning id

police

policy-map

port-channel load-balance ethernet

port-profile

protocol vmware-vim

pwd

P コマンド

この章では、コマンド名が P で始まる Cisco Nexus 1000V コマンドについて説明します。

packet vlan

ID を指定してパケット VLAN を作成するには、 packet vlan コマンドを使用します。パケット VLAN を削除するには、このコマンドの no 形式を使用します。

packet vlan { vlan-number}

no packet vlan { vlan-number }

 
シンタックスの説明

vlan-number

パケット VLAN ID を指定します。有効値の範囲は、 1 ~ 3967 と 4048 ~ 4093 です。

 
デフォルト

なし

 
コマンド モード

SVS ドメイン(config-svs-domain)

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

次に、パケット VLAN 261 を作成する例を示します。

switch# configure terminal
switch(config)# svs-domain
switch(config-svs-domain)# packet vlan 261
switch(config-svs-domain)#
 

次に、パケット VLAN 261 を削除する例を示します。

switch# configure terminal
switch(config)# svs-domain
switch(config-svs-domain)# no packet vlan 261
switch(config-svs-domain)#

 
関連コマンド

コマンド
説明

show running-config

スイッチの実行コンフィギュレーションに関する情報を表示します。

permit (IPv4)

条件に一致するトラフィックを許可する IPv4 ACL ルールを作成するには、 permit コマンドを使用します。ルールを削除するには、このコマンドの no 形式を使用します。

一般的な構文

[ sequence-number ] permit protocol source destination [ dscp dscp | precedence precedence ]

no permit protocol source destination [ dscp dscp | precedence precedence ]

no sequence-number

Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)

[ sequence-number ] permit icmp source destination [ icmp-message ] [ dscp dscp | precedence precedence ]

Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)

[ sequence-number ] permit igmp source destination [ igmp-message ] [ dscp dscp | precedence precedence ]

Internet Protocol v4(IPv4)

[ sequence-number ] permit ip source destination [ dscp dscp | precedence precedence ]

Transmission Control Protocol(TCP; 伝送制御プロトコル)

[ sequence-number ] permit tcp source [ operator port [ port ] | portgroup portgroup ] destination [ operator port [ port ] | portgroup portgroup ] [ dscp dscp | precedence precedence ]

User Datagram Protocol(UDP; ユーザ データグラム プロトコル)

[ sequence-number ] permit udp source [ operator port [ port ] | portgroup portgroup ] destination [ operator port [ port ] | portgroup portgroup ] [ dscp dscp | precedence precedence ]

 
シンタックスの説明

sequence-number

(任意) permit コマンドのシーケンス番号です。指定すると、コマンドはアクセス リスト内の指定された番号の位置に挿入されます。シーケンス番号は、ACL 内のルールの順番を維持します。

シーケンス番号の有効範囲は、1 から 4294967295 までの整数です。

デフォルトでは、ACL の最初のルールのシーケンス番号が 10 となります。

シーケンス番号を指定しない場合は、ルールは ACL の最後に追加され、直前のルールのシーケンス番号に 10 を足したシーケンス番号が割り当てられます。

ルールにシーケンス番号を再度割り当てるには、 resequence コマンドを使用します。

protocol

ルールが一致するパケットのプロトコルの名前または番号です。有効な番号は、0 ~ 255 です。プロトコル名として指定できるのは、次のキーワードです。

icmp :このルールが ICMP トラフィックだけに適用されることを指定します。このキーワードを使用する場合は、 protocol 引数のすべての有効な値に対するキーワードに加えて、 icmp-message 引数も使用できます。

igmp :このルールが IGMP トラフィックだけに適用されることを指定します。このキーワードを使用する場合は、 protocol 引数のすべての有効な値に対するキーワードに加えて、 igmp-type 引数も使用できます。

ip :このルールがすべての IPv4 トラフィックに適用されることを指定します。このキーワードを使用する場合は、他に使用できるキーワードと引数はすべての IPv4 プロトコルに適用されるものだけとなります。使用できるキーワードには次のものがあります。

dscp

precedence

tcp :このルールが TCP トラフィックだけに適用されることを指定します。このキーワードを使用する場合は、 protocol 引数のすべての有効な値に対するキーワードに加えて、 flags 引数と operator 引数、および portgroup キーワードと established キーワードも使用できます。

udp :このルールが UDP トラフィックだけに適用されることを指定します。このキーワードを使用する場合は、 protocol 引数のすべての有効な値に対するキーワードに加えて、 operator 引数と portgroup キーワードも使用できます。

source

ルールに一致する送信元 IPv4 アドレスです。この引数を指定する方法の詳細については、「使用上のガイドライン」セクションの「送信元と宛先」を参照してください。

destination

ルールに一致する宛先 IPv4 アドレスです。この引数を指定する方法の詳細については、「使用上のガイドライン」セクションの「送信元と宛先」を参照してください。

dscp dscp

(任意)指定した 6 ビットの Diffserv 値が IP ヘッダーの DSCP フィールドに存在するパケットだけがこのルールに一致することを指定します。 dscp 引数には、次の数値またはキーワードを指定できます。

0 ~ 63:DSCP フィールドの 6 ビットと等価な 10 進数値です。たとえば、10 を指定すると、ルールに一致するのは DSCP フィールドのビットが 001010 であるパケットだけとなります。

af11 :Assured Forwarding(AF)クラス 1、低ドロップ確率(001010)

af12 :AF クラス 1、中程度ドロップ確率(001100)

af13 :AF クラス 1、高ドロップ確率(001110)

af21 :AF クラス 2、低ドロップ確率(010010)

af22 :AF クラス 2、中程度ドロップ確率(010100)

af23 :AF クラス 2、高ドロップ確率(010110)

af31 :AF クラス 3、低ドロップ確率(011010)

af32 :AF クラス 3、中程度ドロップ確率(011100)

af33 :AF クラス 3、高ドロップ確率(011110)

af41 :AF クラス 4、低ドロップ確率(100010)

af42 :AF クラス 4、中程度ドロップ確率(100100)

af43 :AF クラス 4、高ドロップ確率(100110)

cs1 :クラス セレクタ(CS)1、プレシデンス 1(001000)

cs2 :CS2、プレシデンス 2(010000)

cs3 :CS3、プレシデンス 3(011000)

cs4 :CS4、プレシデンス 4(100000)

cs5 :CS5、プレシデンス 5(101000)

cs6 :CS6、プレシデンス 6(110000)

cs7 :CS7、プレシデンス 7(111000)

default :デフォルト DSCP 値(000000)

ef :Expedited Forwarding(EF)(101110)

precedence precedence

(任意) precedence 引数によって指定された値が IP プレシデンス フィールドに存在するパケットだけがこのルールに一致することを指定します。 precedence 引数には、次の数値またはキーワードを指定できます。

0 ~ 7:IP プレシデンス フィールドの 3 ビットと等価な 10 進数値です。たとえば、3 を指定すると、ルールに一致するのは DSCP フィールドのビットが 011 であるパケットだけとなります。

critical :プレシデンス 5(101)

flash :プレシデンス 3(011)

flash-override :プレシデンス 4(100)

immediate :プレシデンス 2(010)

internet :プレシデンス 6(110)

network :プレシデンス 7(111)

priority :プレシデンス 1(001)

routine :プレシデンス 0(000)

icmp-message

(ICMP のみ:任意)ルールに一致する ICMP メッセージ タイプです。この引数には、0 ~ 255 の整数または「使用上のガイドライン」セクションの「ICMP メッセージ タイプ」に記載されているキーワードの 1 つを指定できます。

igmp-message

(IGMP のみ:任意)ルールに一致する IGMP メッセージ タイプです。 igmp-message 引数には、IGMP メッセージ番号(0 ~ 15 の整数)を指定できます。次のキーワードの 1 つを指定することもできます。

dvmrp :Distance Vector Multicast Routing Protocol(DVMRP)

host-query :ホスト クエリ

host-report :ホスト レポート

pim :Protocol Independent Multicast(PIM)

trace :マルチキャスト トレース

operator port [ port ]

(任意:TCP および UDP のみ)ルールに一致するのは、 operator 引数および port 引数の条件を満たす送信元ポートからのパケット、またはこれらの引数の条件を満たす宛先ポートへのパケットだけとなります。これらの引数が送信元ポートと宛先ポートのどちらに適用されるかは、 source 引数と destination 引数のどちらの後に指定されたかによって決まります。

port 引数には、TCP ポートまたは UDP ポートの名前または番号を指定できます。有効な番号は、0 ~ 65535 の整数です。有効なポート名のリストについては、「使用上のガイドライン」セクションの「TCP ポート名」および「UDP ポート名」を参照してください。

2 番めの port 引数は、 operator 引数が範囲となっている場合にだけ必要となります。

operator 引数は、次のキーワードのうち 1 つにする必要があります。

eq :パケットのポートが port 引数と等しい場合にだけ一致します。

gt :パケットのポートが port 引数より大きい場合にだけ一致します。

lt :ポートが port 引数より小さい場合にだけ一致します。

neq :パケットのポートが port 引数と等しくない場合にだけ一致します。

range :2 つの port 引数が必要で、パケットのポートが最初の port 引数以上、2 番めの port 引数以下の場合にだけ一致します。

flags

(TCP のみ:任意)ルールに一致する TCP コントロール ビット フラグです。 flags 引数の値は、次の 1 つまたは複数のキーワードにする必要があります。

ack

fin

psh

rst

syn

urg

 
デフォルト

新しく作成された IPv4 ACL にはルールは含まれません。

シーケンス番号を指定しない場合は、デバイスにより ACL の最後のルールのシーケンス番号に 10 を足したシーケンス番号がルールに割り当てられます。

 
コマンド モード

IPv4 ACL コンフィギュレーション

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

デバイスは、IPv4 ACL をパケットに適用するときに、その ACL のすべてのルールについてパケットを評価します。ルールの条件をパケットが満たしていれば、そのルールが採用されます。複数のルールの条件を満たしている場合は、シーケンス番号が最も小さいルールが採用されます。

送信元と宛先

source 引数と destination 引数はいくつかの方法で指定できます。それぞれのルールで、これらの引数の 1 つを指定するのに使用する方法は、他の引数の指定方法には影響しません。ルールを設定するときは、次の方法を使用して source 引数と destination 引数を指定します。

アドレスおよびネットワーク ワイルドカード:IPv4 アドレスの後にネットワーク ワイルドカードを使用して、ホストまたはネットワークを送信元または宛先として指定できます。構文は次のようになります。

IPv4-address network-wildcard
 

次に、IPv4 アドレスとサブネット 192.168.67.0 を表すネットワーク ワイルドカードを使用して source 引数を指定する例を示します。

switch(config-acl)# permit tcp 192.168.67.0 0.0.0.255 any
 

アドレスおよび Variable-Length Subnet Mask(VLSM):IPv4 アドレスの後に VLSM を使用して、ホストまたはネットワークを送信元または宛先として指定できます。構文は次のようになります。

IPv4-address/prefix-len
 

次に、IPv4 アドレスとサブネット 192.168.67.0 を表す VLSM を使用して source 引数を指定する例を示します。

switch(config-acl)# permit udp 192.168.67.0/24 any
 

ホスト アドレス: host キーワードと IPv4 アドレスを使用して、ホストを送信元または宛先として指定できます。構文は次のようになります。

host IPv4-address
 

これは、 IPv4-address /32、および IPv4-address 0.0.0.0 と等しい構文です。

次に、 host キーワードと 192.168.67.132 という IPv4 アドレスを使用して source 引数を指定する例を示します。

switch(config-acl)# permit icmp host 192.168.67.132 any
 

任意のアドレス: any キーワードを使用すると、送信元または宛先が任意の IPv4 アドレスであることを指定できます。 any キーワードを使用する例については、このセクションの例を参照してください。それぞれの例で、 any キーワードを使用して送信元または宛先を指定する方法が示されています。

ICMP メッセージ タイプ

icmp-message 引数には ICMP メッセージ番号(0 ~ 255 の整数)を指定できます。次のキーワードの 1 つを指定することもできます。

administratively-prohibited :管理上禁止

alternate-address :代替アドレス

conversion-error :データグラム変換

dod-host-prohibited :禁止ホスト

dod-net-prohibited :禁止されていない

echo :エコー(ping)

echo-reply :エコー応答

general-parameter-problem :パラメータの問題

host-isolated :分離ホスト

host-precedence-unreachable :プレシデンスが到達不可能なホスト

host-redirect :ホスト リダイレクト

host-tos-redirect :ToS ホスト リダイレクト

host-tos-unreachable :ToS が到達不可能なホスト

host-unknown :不明ホスト

host-unreachable :到達不可能なホスト

information-reply :情報応答

information-request :情報要求

mask-reply :マスク応答

mask-request :マスク要求

mobile-redirect :モバイル ホスト リダイレクト

net-redirect :ネットワーク リダイレクト

net-tos-redirect :ToS ネット リダイレクト

net-tos-unreachable :ToS が到達不可能なネットワーク

net-unreachable :到達不可能なネット

network-unknown :不明ネットワーク

no-room-for-option :パラメータが必要であるが空きスペースがない

option-missing :パラメータが必要であるが存在しない

packet-too-big :フラグメント化と DF セットが必要

parameter-problem :すべてのパラメータの問題

port-unreachable :到達不可能なポート

precedence-unreachable :プレシデンス カットオフ

protocol-unreachable :到達不可能なプロトコル

reassembly-timeout :再アセンブリ タイムアウト

redirect :すべてのリダイレクト

router-advertisement :ルータ ディスカバリ アドバタイズメント

router-solicitation :ルータ ディスカバリ要求

source-quench :送信元クエンチ

source-route-failed :送信元ルート失敗

time-exceeded :すべての time-exceeded メッセージ

timestamp-reply :タイムスタンプ応答

timestamp-request :タイムスタンプ要求

traceroute :Traceroute

ttl-exceeded :TTL 超過

unreachable :すべての到達不能

TCP ポート名

protocol 引数に tcp を指定した場合は、 port 引数に TCP ポート番号(0 ~ 65535 の整数)を指定できます。次のキーワードの 1 つを指定することもできます。

bgp :ボーダー ゲートウェイ プロトコル(179)

chargen :文字ジェネレータ(19)

cmd :リモート コマンド(rcmd、514)

daytime :Daytime(13)

discard :廃棄(9)

domain :ドメイン ネーム サーバ(53)

drip :ダイナミック ルーティング情報プロトコル(3949)

echo :エコー(7)

exec :EXEC(rsh、512)

finger :フィンガー(79)

ftp :FTP(21)

ftp-data :FTP データ接続(2)

gopher :Gopher(7)

hostname :NIC ホスト名サーバ(11)

ident :Ident プロトコル(113)

irc :インターネット リレー チャット(194)

klogin :Kerberos ログイン(543)

kshell :Kerberos シェル(544)

login :ログイン(rlogin、513)

lpd :プリンタ サービス(515)

nntp :Network News Transport Protocol(119)

pim-auto-rp :PIM Auto-RP(496)

pop2 :Post Office Protocol v2(19)

pop3 :Post Office Protocol v3(11)

smtp :Simple Mail Transport Protocol(25)

sunrpc :Sun Remote Procedure Call(111)

tacacs :TAC Access Control System(49)

talk :Talk(517)

telnet :Telnet(23)

time :Time(37)

uucp :UNIX-to-UNIX Copy Program(54)

whois :WHOIS/NICNAME(43)

www :World Wide Web(HTTP、8)

UDP ポート名

protocol 引数に udp を指定した場合は、 port 引数に UDP ポート番号(0 ~ 65535 の整数)を指定できます。次のキーワードの 1 つを指定することもできます。

biff :Biff(メール通知、comsat、512)

bootpc :Bootstrap Protocol(BOOTP)クライアント(68)

bootps :Bootstrap Protocol(BOOTP)サーバ(67)

discard :廃棄(9)

dnsix :DNSIX セキュリティ プロトコル監査(195)

domain :ドメイン ネーム サーバ(DNS、53)

echo :エコー(7)

isakmp :Internet Security Association および Key Management Protocol(5)

mobile-ip :モバイル IP 登録(434)

nameserver :IEN116 ネーム サービス(廃止、42)

netbios-dgm :NetBIOS データグラム サービス(138)

netbios-ns :NetBIOS ネーム サービス(137)

netbios-ss :NetBIOS セッション サービス(139)

non500-isakmp :Internet Security Association および Key Management Protocol(45)

ntp :Network Time Protocol(123)

pim-auto-rp :PIM Auto-RP(496)

rip :ルーティング情報プロトコル(ルータ、in.route、52)

snmp :Simple Network Management Protocol(161)

snmptrap :SNMP トラップ(162)

sunrpc :Sun Remote Procedure Call(111)

syslog :システム ロガー(514)

tacacs :TAC Access Control System(49)

talk :Talk(517)

tftp :Trivial File Transfer Protocol(69)

time :Time(37)

who :Who サービス(rwho、513)

xdmcp :X Display Manager Control Protocol(177)

次に、acl-lab-01 という名前で IPv4 ACL を設定する例を示します。この ACL のルールでは、10.23.0.0 および 192.168.37.0 ネットワークから 10.176.0.0 ネットワークへのすべての TCP および UDP トラフィックを許可します。

switch# config t
switch(config)# ip access-list acl-lab-01
switch(config-acl)# permit tcp 10.23.0.0/16 10.176.0.0/16
switch(config-acl)# permit udp 10.23.0.0/16 10.176.0.0/16
switch(config-acl)# permit tcp 192.168.37.0/16 10.176.0.0/16
switch(config-acl)# permit udp 192.168.37.0/16 10.176.0.0/16
 

次に、acl-eng-to-marketing という名前で IPv4 ACL を設定する例を示します。この ACL のルールでは、eng_workstations という名前の IP アドレス オブジェクト グループから marketing_group という名前の IP アドレス オブジェクト グループへのすべての IP トラフィックを許可します。

switch# config t
switch(config)# ip access-list acl-eng-to-marketing
switch(config-acl)# permit ip addrgroup eng_workstations addrgroup marketing_group
 

 
関連コマンド

コマンド
説明

deny (IPv4)

IPv4 ACL に拒否ルールを設定します。

ip access-list

IPv4 ACL を設定します。

remark

ACL にリマークを設定します。

show ip access-list

すべての IPv4 ACL または 1 つの IPv4 ACL を表示します。

statistics per-entry

ACL 内の各エントリに対する統計情報の収集をイネーブルにします。

permit (MAC)

条件に一致するトラフィックを許可する MAC ACL ルールを作成するには、 permit コマンドを使用します。ルールを削除するには、このコマンドの no 形式を使用します。

[ sequence-number ] permit source destination [ protocol ] [ cos cos-value ] [ vlan VLAN-ID ]

no permit source destination [ protocol ] [ cos cos-value ] [ vlan VLAN-ID ]

no sequence-number

 
シンタックスの説明

sequence-number

(任意) permit コマンドのシーケンス番号です。指定すると、コマンドはアクセス リスト内の指定された番号の位置に挿入されます。シーケンス番号は、ACL 内のルールの順番を維持します。

シーケンス番号の有効範囲は、1 から 4294967295 までの整数です。

デフォルトでは、ACL の最初のルールのシーケンス番号が 10 となります。

シーケンス番号を指定しない場合は、ルールは ACL の最後に追加され、直前のルールのシーケンス番号に 10 を足したシーケンス番号が割り当てられます。

ルールにシーケンス番号を再度割り当てるには、 resequence コマンドを使用します。

source

ルールに一致する送信元 MAC アドレスです。この引数を指定する方法の詳細については、「使用上のガイドライン」セクションの「送信元と宛先」を参照してください。

destination

ルールに一致する宛先 MAC アドレスです。この引数を指定する方法の詳細については、「使用上のガイドライン」セクションの「送信元と宛先」を参照してください。

protocol

(任意)ルールに一致するプロトコル番号です。有効なプロトコル番号の範囲は 0x0 から 0xffff です。有効なプロトコル名のリストについては、「使用上のガイドライン」セクションの「MAC プロトコル」を参照してください。

cos cos-value

(任意) cos-value 引数で指定された Class of Service(CoS; サービス クラス)値が IEEE 802.1Q ヘッダーに含まれるパケットだけがこのルールに一致することを指定します。 cos-value 引数に指定できるのは、0 ~ 7 の整数です。

vlan VLAN-ID

(任意)指定された VLAN ID が IEEE 802.1Q ヘッダーに含まれるパケットだけがこのルールに一致することを指定します。 VLAN-ID 引数に指定できるのは、1 ~ 4094 の整数です。

 
デフォルト

なし

 
コマンド モード

MAC ACL コンフィギュレーション

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

新しく作成された MAC ACL にはルールは含まれません。

シーケンス番号を指定しない場合は、ACL の最後のルールのシーケンス番号に 10 を足したシーケンス番号が割り当てられます。

デバイスは、MAC ACL をパケットに適用するときに、その ACL のすべてのルールについてパケットを評価します。ルールの条件をパケットが満たしていれば、そのルールが採用されます。複数のルールの条件を満たしている場合は、シーケンス番号が最も小さいルールが採用されます。

送信元と宛先

source 引数と destination 引数は 2 つの方法で指定できます。それぞれのルールで、これらの引数の 1 つを指定するのに使用する方法は、他の引数の指定方法には影響しません。ルールを設定するときは、次の方法を使用して source 引数と destination 引数を指定します。

アドレスとマスク:MAC アドレスの後にマスクを使用して、1 つのアドレスまたはアドレスのグループを指定できます。構文は次のようになります。

MAC-address MAC-mask
 

次に、MAC アドレス 00c0.4f03.0a72 を使用して source 引数を指定する例を示します。

switch(config-acl)# permit 00c0.4f03.0a72 0000.0000.0000 any
 

次に、MAC ベンダー コードが 00603e であるすべてのホストの MAC アドレスを使用して destination 引数を指定する例を示します。

switch(config-acl)# permit any 0060.3e00.0000 0000.0000.0000
 

任意のアドレス: any キーワードを使用すると、送信元または宛先が任意の MAC アドレスであることを指定できます。 any キーワードを使用する例については、このセクションの例を参照してください。それぞれの例で、 any キーワードを使用して送信元または宛先を指定する方法が示されています。

MAC プロトコル

protocol 引数は、MAC プロトコル番号またはキーワードを指定します。プロトコル番号は、先頭に 0x が付く 4 バイトの 16 進数です。有効なプロトコル番号の範囲は 0x0 から 0xffff です。有効なキーワードには、次のとおりです。

aarp :Appletalk ARP(0x80f3)

appletalk :Appletalk(0x809b)

decnet-iv :DECnet Phase IV(0x6003)

diagnostic :DEC Diagnostic Protocol(0x6005)

etype-6000 :EtherType 0x6000(0x6000)

etype-8042 :EtherType 0x8042(0x8042)

ip :Internet Protocol v4(0x0800)

lat :DEC LAT(0x6004)

lavc-sca :DEC LAVC、SCA(0x6007)

mop-console :DEC MOP リモート コンソール(0x6002)

mop-dump :DEC MOP ダンプ(0x6001)

vines-echo :VINES エコー(0x0baf)

次に、mac-ip-filter という名前の MAC ACL を設定する例を示します。この ACL のルールでは、2 つの MAC アドレス グループ間のすべての IPv4 トラフィックを許可します。

switch# config t
switch(config)# mac access-list mac-ip-filter
switch(config-mac-acl)# permit 00c0.4f00.0000 0000.00ff.ffff 0060.3e00.0000 0000.00ff.ffff ip
 

 
関連コマンド

コマンド
説明

deny(MAC)

MAC ACL に拒否ルールを設定します。

mac access-list

MAC ACL を設定します。

remark

ACL にリマークを設定します。

statistics per-entry

ACL 内の各エントリに対する統計情報の収集をイネーブルにします。

show mac access-list

すべての MAC ACL または 1 つの MAC ACL を表示します。

ping

IPv4 アドレッシングを使用する別のデバイスへのネットワーク接続性を調べるには、 ping コマンドを使用します。

ping [ dest-ipv4-address | hostname | mulitcast multicast-group-address interface [ethernet slot/port | loopback number | mgmt0 | port-channel channel-number | vethernet number ] ] [ count { number | unlimited }] [ df-bit ] [ interval seconds ] [ packet-size bytes ] [ source src-ipv4-address ] [ timeout seconds ] [ vrf vrf-name ]

 
シンタックスの説明

dest-ipv4-address

宛先デバイスの IPv4 アドレスを指定します。フォーマットは、 A . B . C . D です。

hostname

宛先デバイスのホスト名を指定します。ホスト名では、大文字と小文字が区別されます。

multicast

マルチキャスト ping です。

multicast-group-address

マルチキャスト グループ アドレスです。フォーマットは、 A . B . C . D です。

interface

マルチキャスト パケットを送信するインターフェイスを指定します。

ethernet slot/port

イーサネット インターフェイスのスロットとポート番号を指定します。

loopback number

仮想インターフェイス番号を 0 ~ 1023 の範囲内で指定します。

mgmt0

管理インターフェイスを指定します。

port-channel channel-number

ポート チャネル インターフェイスを 1 ~ 4096 の範囲内で指定します。

vethernet number

仮想イーサネット インターフェイスを 1 ~ 1048575 の範囲内で指定します。

count

(任意)送信の回数を指定します。

number

ping の数を指定します。指定できる範囲は 1 ~ 655350 です。デフォルトは 5 です。

unlimited

無制限の回数の ping を許可します。

df-bit

(任意)IPv4 ヘッダーの Do-Not-Fragment ビットをイネーブルにします。デフォルトではディセーブルです。

interval seconds

(任意)送信の間隔を秒数で指定します。指定できる範囲は 0 ~ 60 です。デフォルトは 1 秒です。

packet size bytes

(任意)送信するパケット サイズをバイト数で指定します。指定できる範囲は 1 ~ 65468 です。デフォルトは 56 バイトです。

source scr-ipv4-address

(任意)使用する送信元 IPv4 アドレスを指定します。フォーマットは、 A . B . C . D です。デフォルトは、デバイスの管理インターフェイスの IPv4 アドレスです。

timeout seconds

(任意)無応答タイムアウトの間隔を秒数で指定します。指定できる範囲は 1 ~ 60 です。デフォルト値は 2 秒です。

vrf vrf-name

(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよびフォワーディング)名を指定します。デフォルトではデフォルト VRF です。

 
デフォルト

デフォルト値については、このコマンドの「シンタックスの説明」を参照してください。

 
コマンド モード

任意

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

IPv6 アドレッシングを使用する別のデバイスへのネットワーク接続性を調べるには、 ping6 コマンドを使用します。

次に、IPv4 アドレッシングを使用する別のデバイスへの接続性を調べる例を示します。

switch# ping 172.28.231.246 vrf management
PING 172.28.231.246 (172.28.231.246): 56 data bytes
Request 0 timed out
64 bytes from 172.28.231.246: icmp_seq=1 ttl=63 time=0.799 ms
64 bytes from 172.28.231.246: icmp_seq=2 ttl=63 time=0.597 ms
64 bytes from 172.28.231.246: icmp_seq=3 ttl=63 time=0.711 ms
64 bytes from 172.28.231.246: icmp_seq=4 ttl=63 time=0.67 ms
 
--- 172.28.231.246 ping statistics ---
5 packets transmitted, 4 packets received, 20.00% packet loss
round-trip min/avg/max = 0.597/0.694/0.799 ms

 
関連コマンド

コマンド
説明

ping6

IPv6 アドレッシングを使用する別のデバイスへの接続性を調べます。

pinning

コントロールまたはパケット VLAN のトラフィックを特定のサブグループに固定(ピニング)するには、 pinning コマンドを使用します。設定を削除するには、このコマンドの no 形式を使用します。

pinning { control-vlan | packet-vlan } sub-group_id

no pinning { control-vlan | packet-vlan } sub-group_id

 
シンタックスの説明

control-vlan

コントロール VLAN トラフィックを特定のサブグループに固定することを指定します。

packet-vlan

パケット VLAN トラフィックを特定のサブグループに固定することを指定します。

sub-group-id

サブグループの ID 番号です。指定できる範囲は 0 ~ 31 です。

 
デフォルト

なし

 
コマンド モード

ポート プロファイル コンフィギュレーション(config-port-prof)

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(2)

このコマンドが追加されました。

次に、コントロール VLAN 上のトラフィックをサブグループ 0 に固定する例を示します。

n1000v# config t
n1000v(config)# port-profile SystemProfile1
n1000v(config-port-prof)# pinning control-vlan 3
n1000v(config-port-prof)# show port-profile SystemProfile1
port-profile SystemProfile1
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: 3
pinning packet-vlan: -
system vlans: 1
port-group: SystemProfile1
max ports: -
inherit:
config attributes:
switchport mode trunk
switchport trunk allowed vlan 1-5
no shutdown
evaluated config attributes:
switchport mode trunk
switchport trunk allowed vlan 1-5
no shutdown
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 
 

次に、パケット VLAN 上のトラフィックをサブグループ 0 に固定する例を示します。

n1000v# config t
n1000v(config)# port-profile SystemProfile1
n1000v(config-port-prof)# pinning packet-vlan 0
n1000v(config-port-prof)# show port-profile name SystemProfile1
port-profile SystemProfile1
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: 0
system vlans: 1
port-group:
max ports: -
inherit:
config attributes:
switchport mode access
switchport access vlan 1
switchport trunk native vlan 1
no shutdown
evaluated config attributes:
switchport mode access
switchport access vlan 1
switchport trunk native vlan 1
no shutdown
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 

 
関連コマンド

コマンド
説明

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

ポート プロファイル情報を表示します。

show running-config port-profile profile-name

指定されたポート プロファイルの実行コンフィギュレーションを表示します。この中に、ピニング コンフィギュレーションも含まれます。

pinning id

仮想イーサネット トラフィックを特定のサブグループに固定(ピニング)するには、 pinning id コマンドを使用します。設定を削除するには、このコマンドの no 形式を使用します。

pinning id sub-group-id

no pinning id

 
シンタックスの説明

sub-group-id

サブグループの ID 番号です。指定できる範囲は 0 ~ 31 です。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション モード(config-if)
ポート プロファイル コンフィギュレーション(config-port-prof)

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(2)

このコマンドが追加されました。

次に、仮想イーサネット インターフェイスをサブグループ 3 に固定する例を示します。

 
n1000v(config)# config t
n1000v(config)# interface vethernet 1
n1000v(config-if)# pinning id 0
n1000v(config-if)# show running-config interface vethernet 1
version 4.0(4)SV1(2)
 
interface Vethernet3
service-policy type qos input policy1
pinning id 0
 

n1000v(config-if)# exit

n1000v(config)# exit
n1000v# module vem 3 execute vemcmd show pinning
LTL IfIndex PC_LTL VSM_SGID VEM_SGID Eff_SGID
48 1b040000 304 0 0 0
 
n1000v(config-if)# copy running-config startup-config
 

 
関連コマンド

コマンド
説明

module vem module_number execute vemcmd show pinning

指定された VEM のピニング コンフィギュレーションを表示します。

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

ポート プロファイル情報を表示します。

show running-config interface vethernet interface-number

指定された仮想イーサネット インターフェイスの実行コンフィギュレーションを表示します。この中に、ピニング コンフィギュレーションも含まれます。

show running-config port-profile profile-name

指定されたポート プロファイルの実行コンフィギュレーションを表示します。この中に、ピニング コンフィギュレーションも含まれます。

police

トラフィック レートを制御するには、 police コマンドを使用します。制御を削除するには、このコマンドの no 形式を使用します。

police {{[ cir ] { cir [ bps | kbps | mbps | gbps ] | percent cir-percent } [[ bc ] { committed-burst [ bytes | kbytes | mbytes | ms | us ]}] [ pir { pir- [ bps2 | kbps2 | mbps2 | gbps2 ] | percent pir-percent } [[ be ] { extended-burst [ bytes2 | kbytes2 | mbytes2 | ms2 | us2 ]}]] [ conform { transmit | set-prec-transmit { precedence-number } | set-dscp-transmit { dscp-value | dscp-number } | set-cos-transmit cos-value | set-discard-class-transmit discard-class-value | set-qos-transmit qos-group-value } [ exceed { drop1 | set exc-from-field exc-to-field table cir-markdown-map }] [ violate { drop2 | set vio-from-field vio-to-field table2 pir-markdown-map }]]}}

no police {{[ cir ] { cir [ bps | kbps | mbps | gbps ] | percent cir-percent } [[ bc ] { committed-burst [ bytes | kbytes | mbytes | ms | us ]}] [ pir { pir [ bps2 | kbps2 | mbps2 | gbps2 ] | percent pir-percent } [[ be ] { extended-burst [ bytes2 | kbytes2 | mbytes2 | ms2 | us2 ]}]] [ conform { transmit | set-prec-transmit { precedence-number } | set-dscp-transmit { dscp-value | dscp-number } | set-cos-transmit cos-value | set-discard-class-transmit discard-class-value | set-qos-transmit qos-group-value } [ exceed { drop1 | set exc-from-field exc-to-field table cir-markdown-map }] [ violate { drop2 | set vio-from-field vio-to-field table2 pir-markdown-map }]]}}

 
シンタックスの説明

cir

(任意)Committed Information Rate(CIR; 認定情報レート)を指定します。

cir

bps kbps mbps 、または gbps 単位の CIR です。

bps

(任意)ビット/秒を指定します。

kbps

(任意)キロビット/秒を指定します。

mbps

(任意)メガビット/秒を指定します。

gbps

(任意)ギガビット/秒を指定します。

percent

CIR のパーセンテージを指定します。

cir-percent

CIR のパーセンテージです。

bc

(任意)BC(認定バースト)を指定します。

committed-burst

パケット バーストです。

bytes

(任意)バースト サイズをバイト単位で指定します。

kbytes

(任意)バースト サイズをキロバイト単位で指定します。

mbytes

(任意)バースト サイズをメガバイト単位で指定します。

ms

(任意)バースト間隔をミリ秒単位で指定します。

us

(任意)バースト間隔をマイクロ秒単位で指定します。

pir

(任意)PIR(Peak Information Rate; 最大情報レート)を指定します。

pir

bps kbps mbps 、または gbps 単位の PIR です。

bps2

(任意)ビット/秒を指定します。

kbps2

(任意)キロビット/秒を指定します。

mbps2

(任意)メガビット/秒を指定します。

gbps2

(任意)ギガビット/秒を指定します。

be

(任意)拡張バーストを指定します。

extended-burst

拡張パケット バーストです。

ms2

(任意)バースト間隔をミリ秒単位で指定します。

us2

(任意)バースト間隔をマイクロ秒単位で指定します。

conform

(任意)準拠アクションを指定します。

transmit

パケット送信を指定します。

set-prec-transmit

指定したプレシデンスを送信します。

precedence-number

プレシデンス番号です。有効な番号は次のとおりです。

0 - Routine プレシデンス

1 - Priority プレシデンス

2 - Immediate プレシデンス

3 - Flash プレシデンス

4 - Flash override プレシデンス

5 - Critical プレシデンス

6 - Internetwork control プレシデンス

7 - Network control プレシデンス

set-dscp-transmit

指定した Differentiated Services Code Point(DSCP; DiffServ コード ポイント)を送信します。

dscp-number

DSCP 番号またはコードです。有効な値の範囲は、1 ~ 63 です。DSCP を次のいずれかのコードに設定することもできます。

af11 - AF11 dscp(001010)

af12 - AF12 dscp(001100)

af13 - AF13 dscp(001110)

af21 - AF21 dscp(010010)

af22 - AF22 dscp(010100)

af23 - AF23 dscp(010110)

af31 - AF31 dscp(011010)

af32 - AF32 dscp(011100)

af33 - AF33 dscp(011110)

af41 - AF41 dscp(100010)

af42 - AF42 dscp(100100)

af43 - AF43 dscp(100110)

cs1 - CS1(プレシデンス 1)dscp(001000)

cs2 - CS2(プレシデンス 2)dscp(010000)

cs3 - CS3(プレシデンス 3)dscp(011000)

cs4 - CS4(プレシデンス 4)dscp(100000)

cs5 - CS5(プレシデンス 5)dscp(101000)

cs6 - CS6(プレシデンス 6)dscp(110000)

cs7 - CS7(プレシデンス 7)dscp(111000)

default - デフォルト dscp(000000)

ef - EF dscp(101110)

set-cos-transmit

指定した CoS 番号を送信します。

cos-value

CoS グループ番号です。有効な値の範囲は、0 ~ 7 です。

set-discard-class-
transmit

指定した廃棄クラス番号を送信します。

discard-class-value

廃棄クラス番号です。有効な値の範囲は、0 ~ 63 です。

set-qos-transmit

指定した QoS グループ番号を送信します。

qos-group-value

QoS グループ番号です。有効な値の範囲は、0 ~ 126 です。

exceed

(任意)超過アクションです。

drop1

パケットをドロップすることを指定します。

set

テーブルまたはマークダウン マップの中の特定の値を指定します。

exc-from-field

exc-to-field

table

cir-markdown-map

violate

(任意)違反アクションを指定します。

drop2

パケットをドロップすることを指定します。

vio-from-field

vio-to-field

table2

pir-markdown-
map

 
デフォルト

なし

 
コマンド モード

ポリシー マップ コンフィギュレーション(config-pmap-c-qos)

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、トラフィック レートを制御する例を示します。

switch# configure terminal
switch(config)# policy-map pm10
switch(config-pmap-qos)# class class-default
switch(config-pmap-c-qos)# police 100000 bps 10000 bytes
switch(config-pmap-c-qos)#

 
関連コマンド

コマンド
説明

show qos

QoS 情報を表示します。

policy-map

ポリシー マップを作成および設定するには、 policy-map コマンドを使用します。ポリシー マップを削除するには、このコマンドの no 形式を使用します。

policy-map { name | type qos name }

no policy-map { name | type qos name }

 
シンタックスの説明

name

ポリシー マップ名です。有効な値の範囲は、 1 ~ 40 です。

type qos

ポリシー マップのタイプを「QoS」と指定します。

 
デフォルト

ポリシー マップは存在しません。

 
コマンド モード

グローバル コンフィギュレーション(config)

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ポリシー マップを作成または設定するときは、自動的にポリシー マップ コンフィギュレーション モードが開始します。

次に、ポリシー マップを作成する例を示します。

switch# configure terminal
switch(config)# policy-map pm20
switch(config-pmap-qos)#
 

次に、ポリシー マップを削除する例を示します。

switch# configure terminal
switch(config)# no policy-map pm20
switch(config)#

 
関連コマンド

コマンド
説明

show policy-map

ポリシー マップの情報を表示します。

port-channel load-balance ethernet

チャネル グループ バンドルのインターフェイス間のロード バランシング方式を設定するには、 port-channel load-balance ethernet コマンドを使用します。システム プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

port-channel load-balance ethernet method [ module slot ]

no port-channel load-balance ethernet [ method [ module slot ]]

 
シンタックスの説明

method

ロード バランシング方式。有効値のリストについては、「使用上のガイドライン」セクションを参照してください。

module

(任意)モジュール番号を指定します。指定できる範囲は 1 ~ 66 です。

 
デフォルト

レイヤ 2 パケット - source-mac

レイヤ 3 パケット - source-mac

 
コマンド モード

グローバル コンフィギュレーション(config)

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

モジュールを指定しない場合は、デバイス全体のロード バランシングを設定することになります。module パラメータを指定した場合は、指定したモジュールのロード バランシングを設定することになります。

method の有効な値は、次のとおりです。

dest-ip-port - 宛先 IP アドレスと L4 ポートに基づいて負荷を分散します。

dest-ip-port-vlan - 宛先 IP アドレス、L4 ポート、および VLAN に基づいて負荷を分散します。

destination-ip-vlan - 宛先 IP アドレスと VLAN に基づいて負荷を分散します。

destination-mac - 宛先 MAC アドレスに基づいて負荷を分散します。

destination-port - 宛先 L4 ポートに基づいて負荷を分散します。

source-dest-ip-port - 送信元と宛先の IP アドレスおよび L4 ポートに基づいて負荷を分散します。

source-dest-ip-port-vlan - 送信元と宛先の IP アドレス、L4 ポート、および VLAN に基づいて負荷を分散します。

source-dest-ip-vlan - 送信元と宛先の IP アドレスおよび VLAN に基づいて負荷を分散します。

source-dest-mac - 送信元と宛先の MAC アドレスに基づいて負荷を分散します。

source-dest-port - 送信元と宛先の L4 ポートに基づいて負荷を分散します。

source-ip-port - 送信元 IP アドレスに基づいて負荷を分散します。

source-ip-port-vlan - 送信元 IP アドレス、L4、および VLAN に基づいて負荷を分散します。

source-ip-vlan - 送信元 IP アドレスおよび VLAN に基づいて負荷を分散します。

source-mac - 送信元 MAC アドレスに基づいて負荷を分散します。

source-port - 送信元ポートに基づいて負荷を分散します。

source-virtual-port-id - 送信元仮想ポート ID に基づいて負荷を分散します。

vlan-only - VLAN のみに基づいて負荷を分散します。

module 引数を使用すると、モジュール単独でポート チャネリングとロード バランシング モードを設定することができます。モジュール単独で設定した場合は、他のモジュールにはデバイス全体に対して現在設定されているロード バランシング方式が使用されます。デバイス全体に対して方式が設定されていない場合は、デフォルトの方式が使用されます。 no 引数を module 引数と共に指定した場合は、デバイス全体で現在使用されているロード バランシング方式が、指定したモジュールに対しても使用されるようになります。デバイス全体に対するロード バランシング方式が設定されている場合は、指定したモジュールのロード バランシング方式はデフォルトの source-mac ではなく、その設定された方式となります。モジュール単位のコンフィギュレーションは、デバイス全体に対して設定されているロード バランシング方式よりも優先されます。

使用する設定で最多の種類のバランシング条件を提供するオプションを使用してください。たとえば、あるポート チャネルのトラフィックの送信先 MAC アドレスが 1 つだけである場合に、ポート チャネル ロード バランシングの基準として宛先 MAC アドレスを使用すると、そのポート チャネルの中の同じリンクが常に選択されます。その場合は、送信元アドレスまたは IP アドレスを使用する方が、より有効なロード バランシングを実現できる可能性があります。

次に、デバイス全体のロード バランシング方式を発信元ポートを使用する方式に設定する例を示します。

switch(config)# port-channel load-balance ethernet src-port
switch(config)#

 
関連コマンド

コマンド
説明

show port-channel load-balance

ポート チャネル ロード バランシングに関する情報を表示します。

port-profile

ポート プロファイルを作成してポート プロファイル コンフィギュレーション モードを開始するには、 port-profile コマンドを使用します。ポート プロファイル コンフィギュレーションを削除するには、このコマンドの no 形式を使用します。

port-profile name

no port-profile name

 
シンタックスの説明

name

ポート プロファイル名を指定します。名前の長さは最大 80 文字です。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

Nexus 1000V 上の各ポート プロファイルのポート プロファイル名は一意であることが必要です。

次に、AccessProf という名前のポート プロファイルを作成する例を示します。

switch# configure terminal

switch(config)# port-profile AccessProf

switch(config-port-prof)
 

次に、AccessProf という名前のポート プロファイルを削除する例を示します。

switch# configure terminal
switch(config)# no port-profile AccessProf
switch(config)
 

 
関連コマンド

コマンド
説明

show port-profile name

ポート プロファイルに関する情報を表示します。

protocol vmware-vim

VMware VI SDK をイネーブルにするには、 protocol vmware-vim コマンドを使用します。VMware VI SDK をディセーブルにするには、このコマンドの no 形式を使用します。

protocol vmware-vim

no protocol vmware-vim

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

VMware VI SDK はディセーブルです。

 
コマンド モード

SVS 接続コンフィギュレーション(config-svs-conn)

サポートされるユーザの役割

network-admin

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

 
使用上のガイドライン

VMware VI SDK は VMware によって公開されています。この SDKを使用すると、クライアントと VMware vCenter との対話が可能になります。

VMware VI SDK をイネーブルにする前に SVS 接続を作成する必要があります。

次に、VMware VI SDK をイネーブルにする例を示します。

switch# configure terminal
switch(config)# svs connection svs1
switch(config-svs-conn)# protocol vmware-vim
switch(config-svs-conn)#

 
関連コマンド

コマンド
説明

show svs connection

SVS 接続の情報を表示します。

pwd

現在のディレクトリを表示するには、 pwd コマンドを使用します。

pwd

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意

サポートされるユーザの役割

network-admin
network-operator

 
コマンドの履歴

リリース
変更内容

4.0(4)SV1(1)

このコマンドが追加されました。

次に、現在のディレクトリを表示する例を示します。

switch# pwd
bootflash:
switch#