Cisco Nexus 1000V レイヤ 2 スイッチング コンフィギュレーション ガイド リリース 4.2(1)SV2(1.1)
vEthernet のネットワーク ロード バランシングの設定
vEthernet のネットワーク ロード バランシングの設定
発行日;2013/01/16   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

vEthernet のネットワーク ロード バランシングの設定

この章の内容は、次のとおりです。

Microsoft ネットワーク ロード バランシングについて

Microsoft ネットワーク ロード バランシング(NLB)は、Windows サーバのオペレーティング システムの一部として Microsoft 社から提供されるクラスタリング テクノロジーです。 クラスタリングを使用すると、独立したサーバ グループを 1 つのシステムとして管理できるようになるため、アベイラビリティの向上、管理性の容易化、スケーラビリティの増大が可能になります。

Microsoft ネットワーク ロード バランシングの詳細については、http:/​/​technet.microsoft.com/​en-us/​library/​bb742455.aspx を参照してください。


(注)  


このマニュアル内で示されているサードパーティ Web サイトへのアクセスは、お客様に便宜を図ることのみを目的として提供されています。 シスコおよびその関連会社は、サードパーティ Web サイトの動作の保証についていかなる責任も負いません。また、サードパーティ Web サイトを通じてアクセスしたソフトウェア プログラム等のダウンロード、パフォーマンス、品質、動作、サポートについても一切責任を負いません。さらに、サードパーティ Web サイトまたはそれらを通じてアクセスしたプログラム等により発生したいかなる損害、修理、修正、費用についても一切の責任を負いません。 シスコのエンド ユーザ ライセンス契約書は、サードパーティ Web サイトおよびそれらの Web サイトを通じてアクセスされるソフトウェア プログラムの使用条件に適用されるものではありません。


注意事項と制限事項

ネットワーク ロード バランシング機能には、次の注意事項と制限事項があります。

  • PVLAN ポートでは、no mac auto-static-learn 設定はサポートされません。
  • 不明なユニキャスト フラッディングのブロック(UUFB)が設定されたポートでは、no mac auto-static-learn 設定はサポートされません。
  • switchport port-security mac-address sticky が設定されたポートでは、no mac auto-static-learn 設定はサポートされません。

インターフェイス コンフィギュレーション モードでの Microsoft ネットワーク ロード バランシングの設定

インターフェイス コンフィギュレーション モードで Microsoft ネットワーク ロード バランシングを設定するには、次の手順を使用します。

はじめる前に

(注)  


Windows 仮想マシン(VM)で Microsoft NLB を設定する前に、Cisco Nexus 1000V が設定されていることを確認します。


  • EXEC モードで CLI にログインしていること。
  • デフォルトの Microsoft ネットワーク ロード バランシング動作モードは、ユニキャストです。
  • Microsoft NLB により、クラスタ内の各サーバの MAC アドレスが Microsoft NLB の共通 MAC アドレスに置き換えられます。
手順
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal 

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2switch(config)# show running-config interface veth number 

    no mac auto-static-learn が設定されているかどうかを確認できるように、vEthernet の設定を表示します。

     
    ステップ 3switc(config)# interface veth 

    vEthernet モジュールでインターフェイス コンフィギュレーション モードを設定します。

     
    ステップ 4switch(config-if)# [no] mac auto-static-learn 

    vEthernet モジュールで、auto-mac-learning を切り替えます。

     
    ステップ 5switch(config-if)# copy running-config startup-config  (任意)

    リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を継続的に保存します。

     

    次に、vEthernet で直接 Microsoft ネットワーク ロード バランシングを設定する例を示します。

    switch# configure terminal
    switch(config)# interface vethernet 1
    switch(config-if)# no mac auto-static-learn
    switch(config-if)# show running-config interface vethernet 1
    !Command: show running-config interface Vethernet1
    !Time: Tue Nov 15 19:01:36 2011
    
    version 4.2(1)SV1(5.1)
    
    interface Vethernet1
      inherit port-profile vm59
      description stc3, Network Adapter 2
      no mac auto-static-learn
      vmware dvport 34 dvswitch uuid "ea 5c 3b 50 cd 00 9f 55-41 a3 2d 61 84 9e 0e c4"
      vmware vm mac 0050.56B3.0071
    
    switch(config)#
    

    次に、vEthernet から直接 Microsoft ネットワーク ロード バランシング設定を削除する例を示します。

    switch# configure terminal
    switch(config)# interface vethernet 1
    switch(config-if)# mac auto-static-learn
    switch(config-if)# show running-config interface vethernet 1
    !Command: show running-config interface Vethernet1
    !Time: Tue Nov 15 19:01:52 2011
    
    version 4.2(1)SV1(5.1)
    
    interface Vethernet1
      inherit port-profile vm59
      description stc3, Network Adapter 2
      mac auto-static-learn
      vmware dvport 34 dvswitch uuid "ea 5c 3b 50 cd 00 9f 55-41 a3 2d 61 84 9e 0e c4"
      vmware vm mac 0050.56B3.0071
    
    switch(config)#
    

    ポート プロファイル コンフィギュレーション モードでの Microsoft ネットワーク ロード バランシングの設定

    ポート プロファイル コンフィギュレーション モードで Microsoft ネットワーク ロード バランシングを設定するには、次の手順を使用します。

    はじめる前に

    (注)  


    Windows 仮想マシン(VM)で Microsoft NLB を設定する前に、Cisco Nexus 1000V が設定されていることを確認します。


    • EXEC モードで CLI にログインしていること。
    • デフォルトの Microsoft ネットワーク ロード バランシング動作モードは、ユニキャストです。
    • Microsoft NLB により、クラスタ内の各サーバの MAC アドレスが Microsoft NLB の共通 MAC アドレスに置き換えられます。
    手順
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal 

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2switch(config)# show running config port-profile profile name 

      no mac auto-static-learn が設定されているかどうかを確認できるように、ポート プロファイルの設定を表示します。

       
      ステップ 3switch(config)# port profile type vethernet ms-nlb 

      vEthernet モジュールでポート プロファイル コンフィギュレーション モードを設定します。

       
      ステップ 4switch(config-port-prof)# [no] mac auto-static-learn 

      vEthernet モジュールで、auto-mac-learning を切り替えます。

       
      ステップ 5switch(config-port-prof)# copy running-config startup-config  (任意)

      リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を継続的に保存します。

       

      次に、ポート プロファイル モードで Microsoft ネットワーク ロード バランシングを設定する例を示します。

      switch# configure terminal
      switch(config)# port-profile type vethernet ms-nlb
      switch(config-port-prof)# vmware port-group
      switch(config-port-prof)# switchport mode access
      switch(config-port-prof)# switchport access vlan 59
      switch(config-port-prof)# no mac auto-static-learn
      switch(config-port-prof)# no shutdown
      switch(config-port-prof)# state enabled
      switch(config-port-prof)# show run port-profile ms-nlb
      !Command: show running-config port-profile ms-nlb
      !Time: Tue Nov 15 19:00:40 2011
      
      version 4.2(1)SV1(5.1)
      port-profile type vethernet ms-nlb
        vmware port-group
        switchport mode access
        switchport access vlan 59
        no mac auto-static-learn
        no shutdown
        state enabled
      switch(config-port-prof)# 
      

      次に、ポート プロファイル モードで vEthernet の Microsoft ネットワーク ロード バランシングの設定を解除する例を示します。

      switch# configure terminal
      switch(config)# port-profile type vethernet ms-nlb
      switch(config-port-prof)# mac auto-static-learn
      switch(config-port-prof)# show run port-profile ms-nlb
      !Command: show running-config port-profile ms-nlb
      !Time: Tue Nov 15 19:01:05 2011
      
      version 4.2(1)SV1(5.1)
      port-profile type vethernet ms-nlb
        vmware port-group
        switchport mode access
        switchport access vlan 59
        mac auto-static-learn
        no shutdown
        state enabled
      switch(config-port-prof)#
      

      vEthernet の Microsoft ネットワーク ロード バランシングの機能履歴

      機能名

      機能名

      リリース

      ネットワーク ロード バランシング

      4.2(1)SV1(5.1)

      この機能が導入されました。