Cisco Nexus 1000V スタートアップ ガイド リリース 4.2(1) SV1(4b)
CLI を使用したソフトウェアの設定
CLI を使用したソフトウェアの設定
発行日;2012/07/26 | 英語版ドキュメント(2012/04/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

CLI を使用したソフトウェアの設定

CLI ソフトウェアの設定プロセス

CLI を使用した VSM 仮想マシンの設定

VSM 接続の確認

vCenter Server での Cisco Nexus 1000V プラグインの作成

vCenter Server への接続

必要なポート プロファイルの作成

VSM と VEM 間の通信でのシステム ポート プロファイルの設定

設定例:クリティカルなポートのシステム プロファイル

VM トラフィックのアップリンク ポート プロファイルの設定

設定例:VM トラフィックのアップリンク プロファイル

VM トラフィックのデータ ポート プロファイルの設定

設定例:VM トラフィックのデータ プロファイル

ESX 4.0 ホストの DVS への追加

CLI を使用したソフトウェアの設定

この章では、CLI を ESX 4.0 または ESXi 4.0 VMware サーバにインストールした後で、CLI を使用して Cisco Nexus 1000V ソフトウェアを設定する方法について説明します。


) Cisco Nexus 1000V ソフトウェアを ESX 4.0 または ESXi 4.0 VMware サーバにインストールする方法については、『Cisco Nexus 1000V Software Installation Guide, Release 4.2(1)SV1(4b)』を参照してください。


CLI ソフトウェアの設定プロセス

ここでは、このプロセスをガイドします。1 つの手順を終了するたびに、この項に戻って、必要なすべての手順を正しい順序で実施してください。


ステップ 1 「CLI を使用した VSM 仮想マシンの設定」を使用して、VSM 仮想マシンを設定します。

ステップ 2 次のいずれかを実行します。

レイヤ 3 コントロールを設定している場合は、『 Cisco Nexus 1000V System Management Configuration Guide, Release 4.2(1)SV1(4a) 』の「Domain Configuration」を参照してから、次の手順に進みます。

レイヤ 3 コントロールを設定していない場合は、次の手順に進みます。

ステップ 3 「VSM 接続の確認」に従って VSM 接続を確認します。

ステップ 4 Cisco Nexus 1000V ライセンスを追加します。


) ソフトウェアでは、16 CPU ソケットに 60 日間のライセンスが提供されます。このライセンスを使用するのは、VSM に永続的なライセンスがインストールされていない場合のみです。60 日間の評価期間は、ソフトウェアのインストール時から開始されます。


ライセンスを購入した場合は、『 Cisco Nexus 1000V License Configuration Guide, Release 4.2(1)SV1(4a) 』を参照してください。

ステップ 5 「vCenter Server での Cisco Nexus 1000V プラグインの作成」に従って Cisco Nexus 1000V プラグインを作成します。

ステップ 6 「vCenter Server への接続」に従って vCenter Server に接続します。

ステップ 7 「VLAN の作成」に従って必要な VLAN を作成します。

ステップ 8 次の手順に従って、使用するポート プロファイルを作成します。

「VSM と VEM 間の通信でのシステム ポート プロファイルの設定」

「VM トラフィックのアップリンク ポート プロファイルの設定」

「VM トラフィックのデータ ポート プロファイルの設定」

ステップ 9 「ESX 4.0 ホストの DVS への追加」に従ってホストを DVS に追加します。

ステップ 10 このプロセスが完了しました。「ソフトウェアの設定プロセス」に戻ってください。


 

CLI を使用した VSM 仮想マシンの設定

次の手順に従って、CLI を使用して VSM 管理アクセスの設定と保存を行うことができます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

この Cisco Nexus 1000V VSM を設定するための次の情報を用意する必要があります。

管理者パスワード。

ドメイン ID。

HA ロール。

- 冗長ペアの最初の VSM ではプライマリ。

- 冗長ペアの 2 番目の VSM ではセカンダリ。

スイッチ名。

管理 0 の IP アドレスおよびネットワーク マスク。

生成する SSH キーの種類とキー ビット数。

SVS 制御モード(レイヤ 2 またはレイヤ 3)。

コントロール VLAN ID

パケット VLAN ID


) コントロール、パケット、および管理に同じ VLAN ID を使用できますが、柔軟性を必要とする場合は、別々の VLAN ID を使用することもできます。その場合は、ネットワーク セグメントに十分な帯域幅と遅延があることを確認します。


手順の詳細


ステップ 1 VM の電源をオンにして、Install Cisco Nexus 1000V を選択します。

Cisco Nexus 1000V ソフトウェアが起動します。


) VM の電源投入には最長で 5 分かかることがあります。


次のいずれかが表示されます。

 

 

 

 

ステップ 2 画面の指示に従って、管理者パスワードの入力と確認を行います。

例:

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":

ステップ 3 画面の指示に従って、ドメイン ID を入力します。

例:

Enter the domain id<1-4095>: 152

ステップ 4 画面の指示に従って、HA ロールを入力します。

ロールを指定しない場合は、スタンドアロン ロールがデフォルトで割り当てられます。

例:standalone または primary

Enter HA role[standalone/primary/secondary]: primary

 

[#########################################] 100%

 
---- Basic System Configuration Dialog ----
 
This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.
 
*Note: setup is mainly used for configuring the system initially,
when no configuration is present. So setup always assumes system
defaults and not the current system configuration values.
 
Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.
 
Would you like to enter the basic configuration dialog (yes/no):
 
 
 
例: Secondary
Enter HA role[standalone/primary/secondary]: secondary
 
 
Setting HA role to secondary will cause a system reboot. Are you sure (yes/no) ? :
 

ステップ 5 次のいずれかを実行します。

プライマリおよびアクティブ VSM を設定する場合は、ステップ 8へ進みます。

セカンダリおよびスタンバイ VSM を設定する場合は、次の手順に進みます。

ステップ 6 CD-ROM から起動するように VSM VM を設定済みで、CD-ROM に付属する ISO イメージをからセカンダリ VSM をインストールする場合は、VSM が CD から起動しないように、ここで仮想 CD-ROM を削除します。

VSM VM がハード ドライブより先に CD-ROM から起動するように設定している場合は、このステップが必要です。

ステップ 7 セカンダリおよびスタンバイ VSM を設定しているときに、VSM の再起動が要求された場合は、yes と入力します。

セカンダリ VSM VM が再起動し、スタンバイ モードになります。

セカンダリ VSM のパスワードは、アクティブおよびプライマリ VSM のパスワードと同期化されます。

アクティブおよびプライマリ VSM の設定はここで自動的にスタンバイと同期化されます。

例:secondary

Setting HA role to secondary will cause a system reboot.Are you sure (yes/no) ?: y

 

[########################################] 100%

 

HA mode set to secondary.Rebooting now...

 

セカンダリ VSM を設定する手順が完了しました。「CLI ソフトウェアの設定プロセス」に戻り、設定を続けます。

ステップ 8 基本設定ダイアログボックスの入力を確認するメッセージが表示されたら、yes と答えます。

例:

Would you like to enter the basic configuration dialog (yes/no): yes

 

ステップ 9 別のログイン アカウントの作成を確認するメッセージが表示されたら、 no と答えます。

例:

Create another login account (yes/no) [n]: no
 

ステップ 10 読み取り専用 SNMP コミュニティ ストリングの設定を確認するメッセージが表示されたら、 no と答えます。

例:

Configure read-only SNMP community string (yes/no) [n]: no
 

ステップ 11 読み取りと書き込み SNMP コミュニティ ストリングの設定を確認するメッセージが表示されたら、 no と答えます。

例:
Configure read-write SNMP community string (yes/no) [n]: no
 

ステップ 12 スイッチの名前を入力します。

例:
Enter the switch name: n1000v
 

ステップ 13 アウトオブバンド管理の設定を確認するメッセージが表示されたら、 yes と答えて mgmt0 IPv4 アドレスとサブネット マスクを入力します。

例:
Continue with Out-of-band (mgmt0) management configuration? [yes/no] [y]: yes
Mgmt0 IPv4 address:
172.28.15.152
Mgmt0 IPv4 netmask: 255.255.255.0
 

ステップ 14 デフォルト ゲートウェイの設定を確認するメッセージが表示されたら、 yes と答えます。

例:
Configure the default-gateway: (yes/no) [y]: yes
IPv4 address of the default gateway : 172.23.233.1
 

ステップ 15 高度な IP オプションを設定するかどうかを尋ねるプロンプトが表示されたら、 no と入力します。

例:
Configure Advanced IP options (yes/no)? [n]: no
 

ステップ 16 Telnet サービスの有効化を確認するメッセージが表示されたら、 yes と答えます。

例:
Enable the telnet service? (yes/no) [y]: yes
 

ステップ 17 SSH サービスの有効化を確認するメッセージが表示されたら、 yes と答えてキー タイプとキー ビット数を入力します。
詳細については、『 Cisco Nexus 1000V Security Configuration Guide, Release 4.2(1)SV1(4b) 』を参照してください。

例:
Enable the ssh service? (yes/no) [y]: yes
Type of ssh key you would like to generate (dsa/rsa) : rsa
Number of key bits <768-2048> : 1024
 

ステップ 18 HTTP サーバをイネーブルにするかどうかを確認するメッセージが表示されたら、 yes と答えます。

例:
Enable the http-server? (yes/no) [y]: yes
 

ステップ 19 NTP サーバの設定を確認するメッセージが表示されたら、 no と答えます。

例:
Configure NTP server? (yes/no) [n]: no
 

ステップ 20 SVS ドメイン パラメータを設定するかどうかを確認するメッセージが表示されたら、 yes と答えて、モード(L2 または L3)および制御 VLAN とパケット VLAN の ID を入力します。

例:
Configure svs domain parameters? (yes/no) [y]: yes
Enter SVS Control mode (L2 / L3) : L2
Enter control vlan <1-3967, 4048-4093> : 100
Enter packet vlan <1-3967, 4048-4093> : 101
 

ステップ 21 Virtual Ethernet Module(VEM)機能レベルを設定するかどうかを尋ねるプロンプトが表示されたら、 yes と入力して、0 または 1 を入力します

例:
Vem feature level will be set to 4.2(1)SV1(4b),
Do you want to reconfigure? (yes/no) [n] yes
Current vem feature level is set to 4.2(1)SV1(4b)
You can change the feature level to:
vem feature level is set to the highest value possible
 

システムによって設定全体が要約され、編集するかどうかが尋ねられます。

 
例:
The following configuration will be applied:
Switchname n1000v
interface Mgmt0
ip address 172.28.15.152 255.255.255.0
no shutdown
no telnet server enable
ssh key rsa 1024 force
ssh server enable
feature http-server
svs-domain
svs mode L2
control vlan 100
packet vlan 101
domain id 101
vlan 100
vlan 101
 

ステップ 22 次のいずれかを実行します。

設定を編集しない場合は、 no と答えて次のステップに進む。

設定を編集する場合は、 yes と答えてステップ 9 に戻り、各コマンドを再度実行する。

例:
Would you like to edit the configuration? (yes/no) [n]:no
 

ステップ 23 この設定を使用および保存するかどうかを確認するメッセージが表示されたら、 yes と答えます。


注意 ここで設定を保存しておかないと、次回のスイッチ起動時に設定が更新されません。新しい設定を保存するには、yes と入力します。これによって、キックスタート イメージとシステム イメージも自動的に設定されます。

例:
Use this configuration and save it? (yes/no) [y]: yes
[########################################] 100%
 

新しい設定は不揮発性ストレージに保存され、その後、実行コンフィギュレーションとスタートアップ コンフィギュレーションが同一になります。


) EXEC モードで setup コマンドを入力すると、ステップ 8からステップ 23 で実行した設定を更新するセットアップ ルーチンをいつでも使用できます。セットアップが開始されたら、Enter キーを押してコマンドをスキップします。Ctrl キーを押した状態で C キーを押して、残りのコマンドをスキップします。


ステップ 24 これで手順は完了です。
「CLI ソフトウェアの設定プロセス」に戻ってください。


 

VSM 接続の確認

次の手順に従って、アクティブ VSM への IP 接続を確認できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードでアクティブ VSM にログインしている必要があります。

手順の詳細


ステップ 1 アクティブ VSM への IP 接続を確認します。

ping ip_address

例:

n1000v# ping 172.28.15.1
PING 172.28.15.1 (172.28.15.1): 56 data bytes
Request 0 timed out
64 bytes from 172.28.15.1: icmp_seq=1 ttl=63 time=0.799 ms
64 bytes from 172.28.15.1: icmp_seq=2 ttl=63 time=0.597 ms
64 bytes from 172.28.15.1: icmp_seq=3 ttl=63 time=0.711 ms
64 bytes from 172.28.15.1: icmp_seq=4 ttl=63 time=0.67 ms
--- 172.28.15.1 ping statistics ---
5 packets transmitted, 4 packets received, 20.00% packet loss
round-trip min/avg/max = 0.597/0.694/0.799 ms
 

VSM への接続がここで確認され、SSH による安全な接続が使用できます。

ステップ 2 これで手順は完了です。
「CLI ソフトウェアの設定プロセス」に戻ってください。


 

vCenter Server での Cisco Nexus 1000V プラグインの作成

次の注意事項と VMware マニュアルに従って、vCenter Server に Cisco Nexus 1000V プラグイン(拡張機能)をインストールして登録します。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

アクティブ VSM の IP アドレスを知っている必要があります。

VSM ホーム ページから、次のファイルをダウンロードする必要があります。

cisco_nexus1000v_extension.xml


) VSM ホーム ページにアクセスするには、ブラウザでアクティブ VSM の IP アドレスを指定します。


古いバージョンまたは破損した cisco_nexus1000v_extension.xml ファイルを使用すると、エラー メッセージが表示されることがある。


) 古くなったキャッシュ済みファイルのコピーをダウンロードしないように、最初にブラウザ ウィンドウをリフレッシュしてください。


vCenter Server に接続する VSM ごとに、プラグインを vCenter Server に追加する必要がある。

デュアル スーパーバイザを使用している場合は、両方のスーパーバイザが同じプラグインを使用します。


) 「指定されたパラメータが適切ではありませんでした(The specified parameter was not correct)」というエラーが表示された場合は、すでに登録済みのプラグインを登録しようとしています。『Cisco Nexus 1000V Troubleshooting Guide, Release 4.2(1)SV1(4b)』の「Resolving a Plug-In Conflict」の手順を参照してください。


手順の詳細


ステップ 1 vSphere Client を起動します。

[local host -- VMware Infrastructure Client] ダイアログボックスが開きます。

ステップ 2 [Plug-Ins] メニューから [Manage Plug-Ins] を選択します。

[Plug-In Manager] ダイアログボックスが開きます。

ステップ 3 ダイアログボックスのスペースを右クリックし、ポップアップ メニューから [New Plug-In] を選択します。

[Register Plug-In] ダイアログボックスが開きます。

ステップ 4 [Browse] をクリックし、VSM ホームページからダウンロードした cisco_nexus1000v_extension.xml ファイルを選択します。

ステップ 5 [Register Plug-In] をクリックします。


) 「指定されたパラメータが適切ではありませんでした(The specified parameter was not correct)」というエラーが表示された場合は、すでに登録済みのプラグインを登録しようとしています。『Cisco Nexus 1000V Troubleshooting Guide, Release 4.2(1)SV1(4b)』の「Resolving a Plug-In Conflict」の手順を参照してください。


 

ステップ 6 [Security Warning] ダイアログボックスで、[Ignore] をクリックし、証明書の使用を継続します。

ステップ 7 [Register Plug-in] ダイアログボックスで、[OK] をクリックします。

プラグインが作成および登録されます。

ステップ 8 拡張機能が [Plug-in Manager] ウィンドウに表示されていることを確認します。

ステップ 9 ウィンドウを閉じます。

ステップ 10 これで手順は完了です。
「CLI ソフトウェアの設定プロセス」に戻り、VSM のセットアップを続けます。


 

vCenter Server への接続

次の手順に従って、VSM と vCenter Server 間の接続を設定し、再起動やリブートを行ってもこの設定が維持されるように永続メモリに保存できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードでスタンドアロンまたはアクティブ VSM にログインしている必要があります。

Cisco Nexus 1000V の拡張ファイルが、プラグインとしてすでに vCenter Server に登録されている。

大文字と小文字が区別されたデータセンター名を知っている必要があります。

すでに vCenter Server 上にデータセンターが存在している。

vCenter Server の IP アドレスを知っている必要があります。

手順の概要

1. config t

2. svs connection connection_name

3. vmware dvs datacenter-name dc_name

4. protocol vmware-vim

5. remote ip address ip_address

6. connect

7. show svs connections

8. copy running-config startup-config

手順の詳細

 

 
コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

svs connection name

 

例:

n1000v (config#) svs connection VC

n1000v(config-svs-conn#)

Cisco Nexus 1000V と vCenter Server 間の接続を追加するための接続コンフィギュレーション モードを開始します。名前を使用して、複数接続情報をコンフィギュレーションに格納できます。

ステップ 3

protocol vmware-vim [http]

 

例:

n1000v(config-svs-conn#) protocol vmware-vim

n1000v(config-svs-conn#)

この接続が VIM プロトコルを使用するように指定します。このコマンドはローカルに格納されます。

http:VIM プロトコルが HTTP で実行されるように指定します。デフォルトでは HTTP over SSL(HTTPS)を使用します。

ステップ 4

remote ip address ipaddress

 

例:

n1000v(config-svs-conn#) remote ip address 172.28.15.150

n1000v(config-svs-conn#)

 

この接続で使用する ESX サーバまたは vCenter Server の IP アドレスを指定します。このコマンドはローカルに格納されます。

ステップ 5

vmware dvs datacenter-name name

 

例:

n1000v(config-svs-conn#) vmware dvs datacenter-name Hamilton-DC

n1000v(config-svs-conn#)

Cisco Nexus 1000V が Distributed Virtual Switch(DVS; 分散仮想スイッチ)として作成される vCenter Server のデータセンター名を指定します。接続前または接続後に、このコマンドを使用できます。データセンター名はローカルに格納されます。

ステップ 6

connect

 

例:

n1000v(config-svs-conn#) connect

 

接続を開始します。

(注) 初回の接続では、最大で 10 秒間を要する場合があります。

この接続のユーザ名とパスワードが設定されていない場合は、ユーザ名とパスワード入力プロンプトが表示されます。

一度にアクティブにできる接続は 1 つだけです。定義済みの接続が有効な場合は、 no connect コマンドを使用して定義済みの接続を閉じるまでエラー メッセージが表示され、コマンドが拒否されます。

』を参照してください。

ステップ 7

show svs connections [name]

 

例:

n1000v(config-svs-conn#) show svs connections vc
connection VC:
hostname: 172.28.15.150
protocol: vmware-vim https
certificate: default
datacenter name: HamiltonDC
DVS uuid: 6d fd 37 50 37 45 05 64-b9 a4 90 4e 66 eb 8c f5
config status: Enabled
operational status: Connected
 
n1000v(config-svs-conn#)

確認のため、Cisco Nexus 1000V への現在の接続を表示します。

Cisco Nexus 1000V の Distributed Virtual Switch(DVS; 分散仮想スイッチ)が vCenter Server 上に作成され、vSphere Client で [Inventory] > [Networking] の下に表示されます。

(注) vCenter Server への接続がなんらかの理由でシャットダウンした場合、Cisco Nexus 1000V は接続を自動的に復元しません。この場合、次のコマンド シーケンスを使用して、手動で接続を復元する必要があります。

no connect
connect

ステップ 8

copy running-config startup-config

 

例:

n1000v(config-svs-conn#) copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

vCenter Server への接続が確立され、接続が実行コンフィギュレーションからスタートアップ コンフィギュレーションにコピーされます。この接続はリブート、再起動後もスタートアップ コンフィギュレーションに永続的に保存されます。

 


注意 この設定をスタートアップ コンフィギュレーションにコピーしていない場合は、VSM を再起動すると、この設定済み接続は失われます。

ステップ 9

これで手順は完了です。

「CLI ソフトウェアの設定プロセス」に戻り、VSM のセットアップを続けます。

必要なポート プロファイルの作成

VSM に必要なポート プロファイルを作成するには、ここに示す手順を使用します。

はじめる前に

ここで説明する手順を開始する前に、次のことを確認または実行しておく必要があります。

ポート プロファイルはインターフェイス コンフィギュレーション コマンド セットで、物理(アップリンク)インターフェイスまたは仮想インターフェイスに動的に適用できます。VSM は、vCenter Server への接続時に分散仮想スイッチ(DVS)を作成し、各ポート プロファイルはポート グループとして DVS 上に公開されます。ポート プロファイルに適用できる具体的な属性として、VLAN ID や VMware ポート グループがあります。

これらのポート プロファイルに適用する VLAN は、「VLAN の作成」を使用してすでに VSM に追加済みです。

EXEC モードでスタンドアロンまたはアクティブ VSM にログインしている必要があります。

セカンダリ VSM でポート プロファイルを設定する必要はありません。この設定がプライマリ VSM で完了すると、設定は自動的にセカンダリ VSM と同期化されます。

複数のイーサネット ポート プロファイルを同じ VEM 上でアクティブにしているインストール環境では、同じ VLAN を伝送しないことを推奨します。許可されている VLAN のリストは、相互に排他的であることが必要です。重複した VLAN を設定することはできますが、ネットワークでは重複したパケットを仮想マシンで受信する原因となることがあります。

ポート プロファイルの作成に使用した各コマンドをファイルに保存し、そのファイルを bootflash にコピーして、スクリプトとして実行できます。この目的で、ここでは各手順の後に設定例が用意されています。

スクリプト使用の詳細については、「コマンド スクリプトの使用方法」を参照してください。

この手順では、ポート プロファイル名を自由に指定できます。

ポート プロファイルの詳細については、次の各項を参照してください。

「ポート プロファイル」

「システム ポート プロファイルとシステム VLAN」

ポート プロファイルのすべての注意事項および制限事項の一覧については、『 Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.2(1)SV1(4a) 』を参照してください。

VSM と VEM 間の通信でのシステム ポート プロファイルの設定

次の手順に従って、システム VLAN でアップリンク ポート プロファイルを定義し、VSM と VEM 間の通信を確立できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

システム VLAN とシステム ポート プロファイルの詳細については、次を参照してください。

「システム ポート プロファイルとシステム VLAN」

Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.2(1)SV1(4a)

この場合のシステム ポート プロファイルは、物理ポートに使用するものなので、イーサネット タイプであることが必要です。この手順では、ポート プロファイルをイーサネット タイプとして指定する方法について説明します。

この手順で定義するシステム VLAN で、VSM と VEM 間の通信リンクを確立する必要があります。


注意 VMkernel に関連する VLAN をシステム VLAN として設定しないと、VMkernel の接続が失われる可能性があります。

システム ポート プロファイルのトランク設定で使用する VLAN を、その VLAN に接続した物理スイッチポートのトランク設定でも定義しておく必要があります。

この例では、単一のシステム VLAN 260 がコントロールおよびパケット トラフィックの両方に使用されます。個別の VLAN を使用できます。

システム VLAN の前に、ポート モード(アクセスまたはトランク)、許可された VLAN、およびシャット状態が定義される。

許可された VLAN のリストは、システム VLAN のリストのスーパーセット(または同じリスト)である必要がある。

ここで使用したコマンドをファイルに保存し、それを bootflash にコピーして、スクリプトとして実行できます。この目的で、「設定例:クリティカルなポートのシステム プロファイル」に設定例が用意されています。

手順の概要

1. config t

2. port-profile type ethernet profile_ name

3. description profile_description

4. switchport mode trunk

5. switchport trunk allowed vlan vlan_IDs

6. no shutdown

7. system vlan vlan_ID_list

8. (任意)mtu mtu_size

9. vmware port-group [ portgroup_name ]

10. state enabled

11. show port-profile [ brief | expand-interface | usage ] [ name profile_name ]

12. copy running-config startup-config

手順の詳細

 

 
コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile type ethernet name

 

例:

n1000v(config)# port-profile type ethernet system-uplink

n1000v(config-port-prof)#

名前付きポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。ポート プロファイルがない場合は、次の特性を使用して作成されます。

name :ポート プロファイル名は、最大 80 文字で、Cisco Nexus 1000V 上のポート プロファイルごとに一意である必要があります。

type :システム ポート プロファイルのポート プロファイル タイプ。ここでは、イーサネットとする必要があります。設定が完了すると、タイプは変更できません。デフォルトは vEthernet タイプです。

ポート プロファイル タイプをイーサネットとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できます。vCenter Server では、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルを Ethernet タイプとして設定すると、VMware 仮想ポートの設定には使用できなくなります。

ステップ 3

description profile_description

 

例:

n1000v(config-port-prof)# description “System profile for critical ports”

n1000v(config-port-prof)#

ポート プロファイルに説明を追加します。この説明は、自動的に vCenter Server にプッシュされます。

profile description:最大 80 の ASCII 文字

(注) 説明にスペースが含まれる場合、引用符で囲む必要があります。

ステップ 4

switchport mode trunk

 

例:

n1000v(config-port-prof)# switchport mode trunk

n1000v(config-port-prof)#

新しいポート プロファイルがトランク ポートとして使用されることを指定します。

ステップ 5

switchport trunk allowed vlan vlan_IDs

 

例:

n1000v(config-port-prof)# switchport trunk allowed vlan 260

 

新しいポート プロファイルのトランク ポートで許可された VLAN を指定します。

ステップ 6

no shutdown

 

例:

n1000v(config-port-prof)# no shutdown

n1000v(config-port-prof)#

新しいポート プロファイルのすべてのポートを管理上のイネーブル状態にします。

ステップ 7

system vlan vlan_ID_list

 

例:

n1000v(config-port-prof)# system vlan 260

n1000v(config-port-prof)#

システム VLAN を、このポート プロファイルに追加します。システム VLAN は、VSM が VEM との通信を確立する前に、物理ポートまたは vEthernet ポートの設定と起動に使用します。

(注) 個別のコントロールおよびパケット VLAN を定義した場合、別のシステム VLAN を追加します。

ステップ 8

mtu mtu-size

 

例:

n1000v(config-port-prof)# mtu 4000

n1000v(config-port-prof)#

(任意)MTU サイズを指定します。

ここで MTU サイズを設定しない場合は、デフォルトの 1500 が使用されます。

1500 ~ 9000 の範囲の偶数である必要があります。

インターフェイスの system jumbomtu のサイズよりも小さくする必要があります。

ステップ 9

vmware port-group [ portgroup_name ]

 

例:

n1000v(config-port-prof)# vmware port-group system-uplink

n1000v(config-port-prof)#

 

ポート プロファイルを同じ名前の VMware ポート グループとして指定します。

ポート プロファイルは、同じ名前の VMware ポート グループにマッピングされます。vCenter Server 接続が確立されると、このポート グループは vCenter Server 上の仮想スイッチに分散されます。

ステップ 10

state enabled

 

例:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

新しいシステム ポート プロファイルをイネーブルにします。

この新しいシステム ポート プロファイルの設定は、割り当てられたポートに適用されます。VMware ポート グループは vCenter Server 上の vSwitch で作成されます。

分散仮想ポート グループが、vSphere Client の [Inventory] > [Networking] > [DataCenter] タブに表示されます。

ステップ 11

show port-profile name profile-name

 

例:

n1000v(config-port-prof)# show port-profile name system-uplink

port-profile system-uplink

description: "System profile for critical ports"

type: ethernet

status: enabled

capability l3control: no

pinning control-vlan: -

pinning packet-vlan: -

system vlans: 260

port-group: system-uplink

max ports: -

inherit:

config attributes:

switchport mode trunk

switchport trunk allowed vlan 260

no shutdown

evaluated config attributes:

switchport mode trunk

switchport trunk allowed vlan 260

no shutdown

assigned interfaces:

n1000v(config-port-prof)#

(任意)システムアップリンク ポート プロファイル コンフィギュレーションを表示します。

ステップ 12

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。


注意 この設定をスタートアップ コンフィギュレーションにコピーしていない場合は、VSM を再起動すると、このポート グループは vCenter Server には引き続き存在しますが、VSM には存在しなくなります。

ステップ 13

これで手順は完了です。

「CLI ソフトウェアの設定プロセス」に戻り、VSM のセットアップを続けます。

設定例:クリティカルなポートのシステム プロファイル

config t
port-profile type ethernet system-uplink
description "System profile for critical ports"
switchport mode trunk
switchport trunk allowed vlan 260
no shutdown
system vlan 260
vmware port group system-uplink
state enabled

VM トラフィックのアップリンク ポート プロファイルの設定

次の手順に従って、物理インターフェイスが VM トラフィックの伝送に使用するアップリンク ポート プロファイルを定義します。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

ここで使用したコマンドは、ファイルに保存してそれをブートフラッシュにコピーし、スクリプトとして実行することができる。この目的で、「設定例:VM トラフィックのアップリンク プロファイル」に設定例が用意されています。

システムアップリンク ポート プロファイルを使用してデータ トラフィックを伝送する場合は、そのデータ VLAN ID をシステムアップリンク ポート プロファイルに追加し、それに対応する変更をアップストリーム スイッチ上で実施します。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. description profile_description

4. switchport mode access

5. switchport access vlan vlan_ID

6. vmware port-group [ portgroup_name ]

7. no shutdown

8. state enabled

9. show port-profile [ brief | expand-interface | usage ] [ name profile-name ]

10. copy running-config startup-config

手順の詳細

 

 
コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile type ethernet name

 

例:

n1000v(config)# port-profile type ethernet vm-uplink

n1000v(config-port-prof)#

指定したポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。

type :ポート プロファイルを Ethernet タイプまたは vEthernet タイプとして定義します。この設定を後で変更することはできません。デフォルトは vEthernet タイプです。

ポート プロファイルを vEthernet タイプとして定義すると、ポートがアップリンク ポートとして使用できます。vCenter Server では、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルを Ethernet タイプとして設定すると、VMware 仮想ポートの設定には使用できなくなります。

name :ポート プロファイル名の長さは最大 80 文字です。Cisco Nexus 1000V 上の各ポート プロファイルの名前は一意でなければなりません。

ステップ 3

description profile_description

 

例:

n1000v(config-port-prof)# description “Uplink profile for VM Traffic”

n1000v(config-port-prof)#

ポート プロファイルに説明を追加します。この説明は、自動的に vCenter Server にプッシュされます。

profile description:最大 80 の ASCII 文字

(注) 説明にスペースが含まれる場合、引用符で囲む必要があります。

ステップ 4

switchport mode access

 

例:

n1000v(config-port-prof)# switchport mode access

n1000v(config-port-prof)#

新しいポート プロファイルがアクセス ポートとして使用されることを指定します。

ステップ 5

switchport access vlan vlan_ID

 

例:

n1000v(config-port-prof)# switchport access vlan 260

新しいポート プロファイルのアクセス VLAN を指定します。

 

ステップ 6

vmware port-group [ portgroup_name ]

 

例:

n1000v(config-port-prof)# vmware port-group vm-uplink

n1000v(config-port-prof)#

ポート プロファイルを同じ名前の VMware ポート グループとして指定します。

ポート プロファイルは VMware ポート グループにマッピングされます。vCenter Server 接続が確立されると、このポート グループは vCenter Server 上の仮想スイッチに分散されます。

ステップ 7

no shutdown

 

例:

n1000v(config-port-prof)# no shutdown

n1000v(config-port-prof)#

新しいポート プロファイルのすべてのポートを管理上のイネーブル状態にします。

ステップ 8

state enabled

 

例:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

VM トラフィックの新しいアップリンク ポート プロファイルをイネーブルにします。

この新しいアップリンク ポート プロファイルの設定は、割り当てられたポートに適用されます。VMware ポート グループは vCenter Server 上の vSwitch で作成されます。

分散仮想ポート グループが、vSphere Client の [Inventory] > [Networking] > [DataCenter] タブに表示されます。

ステップ 9

show port-profile name profile-name

 

例:

n1000v(config-port-prof)# show port-profile name vm-uplink

port-profile vm-uplink

description: "Uplink profile for VM traffic

type: ethernet

status: enabled

capability l3control: no

pinning control-vlan: -

pinning packet-vlan: -

system vlans: none

port-group: vm-uplink

max ports: -

inherit:

config attributes:

switchport mode access

switchport access vlan 260

no shutdown

evaluated config attributes:

switchport mode access

switchport access vlan 260

no shutdown

assigned interfaces:

n1000v(config-port-prof)#

(任意)vm-uplink ポート プロファイル コンフィギュレーションを表示します。

ステップ 10

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。


注意 この設定をスタートアップ コンフィギュレーションにコピーしない場合、VSM を再起動すると、このポート グループは vCenter Server に継続して存在しますが、VSM には存在しなくなります。

ステップ 11

これで手順は完了です。

「CLI ソフトウェアの設定プロセス」に戻り、VSM のセットアップを続けます。

設定例:VM トラフィックのアップリンク プロファイル

config t
port-profile type ethernet vm-uplink
description "Uplink profile for VM traffic
switchport mode access
switchport access vlan 260
no shutdown
vmware port-group vm-uplink
state enabled

VM トラフィックのデータ ポート プロファイルの設定

次の手順に従って、データ ポート プロファイルを定義します。データ ポート プロファイルは、VM にネットワーク アダプタとして提供され、ゲスト VM とのトラフィック伝送を行います。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

ここで使用したコマンドをファイルに保存し、それを bootflash にコピーして、スクリプトとして実行できます。この目的で、「設定例:VM トラフィックのデータ プロファイル」に設定例が用意されています。スクリプト使用の詳細については、『 Cisco Nexus 1000V スタートアップ ガイド リリース 4.2(1) SV1(4b) 』を参照してください。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. description profile_description

4. switchport mode access

5. switchport access vlan vlan_ID

6. vmware port-group [ portgroup_name ]

7. no shutdown

8. state enabled

9. show port-profile [ brief | expand-interface | usage ] [ name profile-name ]

10. copy running-config startup-config

手順の詳細

 

 
コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile type vethernet data20

n1000v(config-port-prof)#

名前付きポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。ポート プロファイルがない場合は、次の特性を使用して作成されます。

name :ポート プロファイル名は、最大 80 文字で、Cisco Nexus 1000V 上のポート プロファイルごとに一意である必要があります。

type :(任意)ポート プロファイル タイプはイーサネットまたは vEthernet です。設定が完了すると、タイプは変更できません。デフォルトは vEthernet タイプです。

ポート プロファイル タイプをイーサネットとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できます。vCenter Server では、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルを Ethernet タイプとして設定すると、VMware 仮想ポートの設定には使用できなくなります。

ステップ 3

description profile_description

 

例:

n1000v(config-port-prof)# description “Data profile for VM Traffic”

n1000v(config-port-prof)#

ポート プロファイルに ASCII 文字で 80 文字までの説明を追加します。この説明は、自動的に vCenter Server にプッシュされます。

ステップ 4

switchport mode access

 

例:

n1000v(config-port-prof)# switchport mode access

n1000v(config-port-prof)#

 

新しいポート プロファイルをアクセス ポートとして使用することを指定します。

ステップ 5

switchport access vlan vlan_ID

 

例:

n1000v(config-port-prof)# switchport access vlan 20

新しいポート プロファイルのアクセス VLAN を指定します。

 

ステップ 6

no shutdown

 

例:

n1000v(config-port-prof)# no shutdown

n1000v(config-port-prof)#

新しいポート プロファイルのすべてのポートを管理上のイネーブル状態にします。

ステップ 7

vmware port-group [ portgroup_name ]

 

例:

n1000v(config-port-prof)# vmware port-group data20

n1000v(config-port-prof)#

ポート プロファイルを VMware ポート グループとして指定します。

ポート プロファイルは VMware ポート グループにマッピングされます。vCenter Server 接続が確立されると、このポート グループは vCenter Server 上の仮想スイッチに分散されます。

ステップ 8

state enabled

 

例:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

VM トラフィックの新しいデータ ポート プロファイルをイネーブルにします。

この新しいデータ ポート プロファイルの設定は、割り当てられたポートに適用されます。VMware ポート グループは vCenter Server 上の vSwitch で作成されます。

分散仮想ポート グループが、vSphere Client の [Inventory] > [Networking] > [DataCenter] タブに表示されます。

ステップ 9

show port-profile name profile-name

 

例:

n1000v(config-port-prof)# show port-profile name data260

port-profile data20

description: "Data profile for VM traffic"

type: vethernet

status: enabled

capability l3control: no

pinning control-vlan: -

pinning packet-vlan: -

system vlans: none

port-group: data20

max ports: -

inherit:

config attributes:

switchport mode access

switchport access vlan 20

no shutdown

evaluated config attributes:

switchport mode access

switchport access vlan 20

no shutdown

assigned interfaces:

n1000v(config-port-prof)#

(任意)VM トラフィックの物理 NIC にバインドされるポート プロファイル コンフィギュレーションを表示します。

ステップ 10

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。


注意 この設定をスタートアップ コンフィギュレーションにコピーしない場合、VSM を再起動すると、このポート グループは vCenter Server に継続して存在しますが、VSM には存在しなくなります。

ステップ 11

これで手順は完了です。

「CLI ソフトウェアの設定プロセス」に戻り、VSM のセットアップを続けます。

設定例:VM トラフィックのデータ プロファイル

config t
port-profile type vethernet data20
description "Data profile for VM traffic"
switchport mode access
switchport access vlan 20
no shutdown
vmware port-group data20
state enabled

ESX 4.0 ホストの DVS への追加

次の手順と VMware マニュアルに従って、ホストを DVS に追加します。


) VMware Update Manager(VUM)を使用している場合、この手順では、ホストがスイッチに追加されると、Cisco Nexus 1000V ソフトウェアが自動的に VEM にインストールされます。


はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

アップストリーム スイッチの対応するインターフェイスを、システム アップリンク ポート プロファイルで設定している同じ VLAN を許可するように設定しておく必要があります。

この手順の例では、トラフィック フローが次のように設定される。

 

トラフィック
VMNIC

コントロール VLAN

システムアップリンク VMNIC

パケット VLAN

システムアップリンク VMNIC

VM データ

VM-uplink ポート グループ

 


) システムアップリンク プロファイルを使用してデータ トラフィックを伝送する場合に、システムアップリンク プロファイルがすでに定義されているときは、vm-uplink プロファイルを別の vmnic に割り当てる必要はありません。


VUM を使用しない場合は、『 Cisco Nexus 1000V VEM Software Installation and Upgrade Guide, Release 4.2(1)SV1(4b) 』 の指示に従ってホストに VEM ソフトウェアがすでにインストールされている。

VUM を使用している場合、この手順では、VUM がトリガーされ、Cisco Nexus 1000V VEM パッケージがインストールされます。

VUM を使用している場合は、すでに VUM がロードされており、VMware の指示に従って vCenter Server 上にパッチ用データベースが作成されている。


注意 VEM ソフトウェアの自動インストールは、VUM でプロキシ サーバがイネーブルになっていると、失敗することがあります。これは VMware の制限によるものです。回避するには、ソフトウェアのインストール中にプロキシをディセーブルにします。

VMware Enterprise Plus ライセンスは、ホストを DVS に追加する前に、ホストにインストールされている必要があります。そうでない場合は、ホストが [Add Host to Distributed Virtual Switch] ダイアログボックスに表示されず、ホストを追加することができません。

VSM がすでに vCenter Server に接続されている。

複数のアップリンクを DVS に追加し、それらとのポート チャネルを形成する手順については、『 Cisco Nexus 1000V Interface Configuration Guide, Release 4.2(1)SV1(4a) 』を参照してください。

DRS をイネーブルにして VMware クラスタに Cisco Nexus 1000 をインストールする場合は、すべての ESX ホストを Cisco Nexus 1000 DVS に移行する必要があります。移行していないホストがある場合は、vSwitch に VLAN、物理アダプタ、またはその両方がないホストに VM がインストールされるか、そこに VM が移動する可能性があります。

手順の詳細


ステップ 1 vSphere Client で、[Inventory] > [Networking] をクリックします。

次のものが表示されます。

設定したスイッチ名を持つ DVS

作成したポート プロファイル

ステップ 2 次のいずれかを実行します。

DVS とポート プロファイルが存在する場合は、次のステップに進む。

そうでない場合は、『 Cisco Nexus 1000V Troubleshooting Guide, Release 4.2(1)SV1(4b) 』を参照する。

 

 

ステップ 3 スイッチ名を右クリックし、[Add Host] を選択します。

ホストを分散仮想スイッチに追加ウィザードが開きます。


) [Add Host to Distributed Virtual Switch] ダイアログボックスが空の場合は、ホストが VMware ESX 4.0 サーバ用の Enterprise Plus ライセンスを持っていることを確認します。


 

 


) VUM を使用している場合、VUM によって、Cisco Nexus 1000V ソフトウェアがここで DVS にロードされます。


ステップ 4 次のいずれかを実行します。

システムアップリンク プロファイルを使用してデータ トラフィックを伝送する場合に、システムアップリンク プロファイルがすでに定義されているときは、vm-uplink プロファイルを別の vmnic に割り当てる必要はありません。

そうでない場合は、VMware vSwitch に接続されていない次の vmnic(たとえば、vmnic1)のチェックボックスをクリックし、下向き矢印をクリックし、アップリンク ポート グループ [system-uplink]を選択します。

 

 

ステップ 5 VMware vSwitch に接続されていない次の vmnic(たとえば、vmnic2)を選択します。

vmnic はアップリンク ポート グループ [vm-uplink]にリンクされている必要があります。


) 複数のアップリンクを DVS に追加し、それらとのポート チャネルを形成する手順については、『Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.2(1)SV1(4a)』を参照してください。


ステップ 6 [Next] をクリックします。

ステップ 7 ポート グループの割り当てを確認し、[Finish] をクリックします。

ステップ 8 次のいずれかを実行します。

ホストが DVS に正常に追加された場合は、次の手順に進む。

操作に失敗した場合は、『 Cisco Nexus 1000V Troubleshooting Guide, Release 4.2(1)SV1(4b) 』を参照する。

ステップ 9 これで手順は完了です。
「CLI ソフトウェアの設定プロセス」に戻り、VSM の設定を続けます。