Cisco Nexus 1000V レイヤ 2 スイッチング コンフィギュレーション ガイド リリース 4.2(1)SV1(5.1)
vEthernet のネットワーク ロード バランシングの設定
vEthernet のネットワーク ロード バランシングの設定
発行日;2012/07/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

vEthernet のネットワーク ロード バランシングの設定

Microsoft ネットワーク ロード バランシングについて

ユニキャスト モード(デフォルト)で Microsoft ロード バランシングを実行するための vEth の設定

注意事項および制約事項

インターフェイス コンフィギュレーション モードでの Microsoft ネットワーク ロード バランシングの設定

ポート プロファイル コンフィギュレーション モードでの Microsoft ネットワーク ロード バランシングの設定

イーサネットの Microsoft ネットワーク ロード バランシングの機能履歴

Microsoft ネットワーク ロード バランシングについて

Microsoft NLB は Windows サーバ オペレーティング システムの一部として Microsoft 社から提供されるクラスタリング テクノロジーです。クラスタリングを使用すると、独立したサーバ グループを 1 つのシステムとして管理できるようになるため、アベイラビリティの向上、管理性の容易化、スケーラビリティの増大が可能になります。

Microsoft ネットワーク ロード バランシングについては、 次の URL を参照してください。

http://technet.microsoft.com/en-us/library/bb742455.aspx


) このマニュアル内で示されているサードパーティ Web サイトへのアクセスは、お客様に便宜を図ることのみを目的として提供されています。シスコおよびその関連会社は、サードパーティ Web サイトの動作の保証についていかなる責任も負いません。また、サードパーティ Web サイトを通じてアクセスしたソフトウェア プログラム等のダウンロード、パフォーマンス、品質、動作、サポートについても一切責任を負いません。さらに、サードパーティ Web サイトまたはそれらを通じてアクセスしたプログラム等により発生したいかなる損害、修理、修正、費用についても一切の責任を負いません。シスコのエンド ユーザ ライセンス契約書は、サードパーティ Web サイトおよびそれらの Web サイトを通じてアクセスされるソフトウェア プログラムの使用条件に適用されるものではありません。


ユニキャスト モード(デフォルト)で Microsoft ロード バランシングを実行するための vEth の設定

ここでは、次の内容について説明します。

「注意事項および制約事項」

「インターフェイス コンフィギュレーション モードでの Microsoft ネットワーク ロード バランシングの設定」

「ポート プロファイル コンフィギュレーション モードでの Microsoft ネットワーク ロード バランシングの設定」

注意事項および制約事項

PVLAN ポートでは、 no mac auto-static-learn config はサポートされません。

不明なユニキャスト フラッディングのブロック(UUFB)が設定されたポートでは、 no mac auto-static-learn config はサポートされません。

switchport port-security mac-address sticky が設定されたポートでは、 no mac auto-static-learn config はサポートされません。

インターフェイス コンフィギュレーション モードでの Microsoft ネットワーク ロード バランシングの設定

インターフェイス コンフィギュレーション モードで Microsoft ネットワーク ロード バランシングを設定できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。


) Windows 仮想マシン(VM)で Microsoft NLB を設定する前に、Cisco Nexus 1000V が設定されていることを確認します。


EXEC モードで CLI にログインしていること。

デフォルトの Microsoft ネットワーク ロード バランシング動作モードは、ユニキャストです。

Microsoft NLB により、クラスタ内の各サーバの MAC アドレスが Microsoft NLB の共通 MAC アドレスに置き換えられます。

手順の概要

1. configure termina l

2. show running-config interface veth number

3. int veth 1

4. [no] mac auto-static-learn

5. (任意) copy running-config startup-config

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

show running-config interface <veth number>

Example:

show running-config interface Vethernet1

no mac auto-static-learn が設定されているかどうかを確認できるように、vEth の設定を表示します。

ステップ 3

int veth 1

 

Example:

n1000v(config)# int veth 1

vEthernet モジュールでインターフェイス コンフィギュレーション モードを設定します。

ステップ 4

[no] mac auto-static-learn

 

Example:

n1000v(config-if)# no mac auto-static-learn

vEthernet モジュールで、auto-mac-learning を切り替えます。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、vEthernet で直接 Microsoft ネットワーク ロード バランシングを設定する例を示します。

n1000v(config)# int vethernet 1
n1000v(config-if)# no mac auto-static-learn
n1000v(config-if)#
 
n1000v(config-if)# show run int vethernet 1
 
!Command: show running-config interface Vethernet1
!Time: Tue Nov 15 19:01:36 2011
 
version 4.2(1)SV1(5.1)
 
interface Vethernet1
inherit port-profile vm59
description stc3, Network Adapter 2
no mac auto-static-learn
vmware dvport 34 dvswitch uuid "ea 5c 3b 50 cd 00 9f 55-41 a3 2d 61 84 9e 0e c4"
vmware vm mac 0050.56B3.0071
 

次に、vEthernet から直接 Microsoft ネットワーク ロード バランシング設定を削除する例を示します。

 
n1000v(config)# int vethernet 1
n1000v(config-if)# mac auto-static-learn
 
n1000v(config)# show run int vethernet 1
 
!Command: show running-config interface Vethernet1
!Time: Tue Nov 15 19:01:52 2011
 
version 4.2(1)SV1(5.1)
 
interface Vethernet1
inherit port-profile vm59
description stc3, Network Adapter 2
mac auto-static-learn
vmware dvport 34 dvswitch uuid "ea 5c 3b 50 cd 00 9f 55-41 a3 2d 61 84 9e 0e c4"
vmware vm mac 0050.56B3.0071
 
n1000v(config)#

 

ポート プロファイル コンフィギュレーション モードでの Microsoft ネットワーク ロード バランシングの設定

ポート プロファイル コンフィギュレーション モードで Microsoft ネットワーク ロード バランシングを設定できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。


) Windows 仮想マシン(VM)で Microsoft NLB を設定する前に、Cisco Nexus 1000V が設定されていることを確認します。


EXEC モードで CLI にログインしていること。

デフォルトの Microsoft ネットワーク ロード バランシング動作モードは、ユニキャストです。

Microsoft ネットワーク ロード バランシングにより、クラスタ内の各サーバの MAC アドレスが Microsoft NLB の共通 MAC アドレスに置き換えられます。

手順の概要

1. configure terminal

2. show running config port-profile <profile name>

3. port-profile type vethernet ms-nlb

4. [ no ] mac auto-static-learn

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

show running config port-profile <profile name>

Example:

n1000v(config)#show running config port-profile <profile name>

no mac auto-static-learn が設定されているかどうかを確認できるように、ポート プロファイルの設定を表示します。

ステップ 3

port profile type vethernet ms-nlb

 

Example:

n1000v(config)# port profile type vethernet ms-nlb

vEthernet モジュールでポート プロファイル コンフィギュレーション モードを設定します。

ステップ 4

[no] mac auto-static-learn

 

Example :

n1000v(config-if)# no mac auto-static-learn

vEthernet モジュールで、auto-mac-learning を切り替えます。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、ポート プロファイル モードで Microsoft ネットワーク ロード バランシングを設定する例を示します。

n1000v(config)# port-profile type vethernet ms-nlb
n1000v(config-port-prof)# vmware port-group
n1000v(config-port-prof)# switchport mode access
n1000v(config-port-prof)# switchport access vlan 59
n1000v(config-port-prof)# no mac auto-static-learn
n1000v(config-port-prof)# no shutdown
n1000v(config-port-prof)# state enabled
n1000v(config-port-prof)#
 
n1000v(config-port-prof)# show run port-profile ms-nlb
 
!Command: show running-config port-profile ms-nlb
!Time: Tue Nov 15 19:00:40 2011
 
version 4.2(1)SV1(5.1)
port-profile type vethernet ms-nlb
vmware port-group
switchport mode access
switchport access vlan 59
no mac auto-static-learn
no shutdown
state enabled
 

次に、ポート プロファイル モードで vEthernet の Microsoft ネットワーク ロード バランシング設定を削除する例を示します。

n1000v(config)# port-profile type vethernet ms-nlb
n1000v(config-port-prof)# mac auto-static-learn
 
n1000v(config-port-prof)# show run port-profile ms-nlb
 
!Command: show running-config port-profile ms-nlb
!Time: Tue Nov 15 19:01:05 2011
 
version 4.2(1)SV1(5.1)
port-profile type vethernet ms-nlb
vmware port-group
switchport mode access
switchport access vlan 59
mac auto-static-learn
no shutdown
state enabled
 

イーサネットの Microsoft ネットワーク ロード バランシングの機能履歴

ここでは、イーサネットのネットワーク ロード バランシングのリリース履歴を示します。

 

表 7-1 イーサネットのネットワーク ロード バランシングの機能履歴

機能名
リリース
機能情報

ネットワーク ロード バランシング

4.2(1)SV1(5.1)

この機能が導入されました。