Cisco Nexus 1000V システム管理コンフィギュレーション ガイド リリース 4.2(1)SV1(5.1)
ローカル SPAN および ERSPAN の設定
ローカル SPAN および ERSPAN の設定
発行日;2012/05/24 | 英語版ドキュメント(2012/04/18 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

ローカル SPAN および ERSPAN の設定

SPAN および ERSPAN について

SPAN ソース

SPAN 送信元の特性

SPAN 宛先

ローカル SPAN 宛先の特性

ERSPAN 宛先の特性

ローカル SPAN

カプセル化リモート SPAN

ネットワーク解析モジュール

SPAN セッション

SPAN 注意事項および制約事項

デフォルト設定

SPAN の設定

ローカル SPAN セッションの設定

ERSPAN ポート プロファイルの設定

ERSPAN セッションの設定

SPAN セッションのシャットダウン

SPAN セッションの再開

許可される ERSPAN フロー ID の設定

SPAN の設定確認

設定例

SPAN セッションの設定例

ERSPAN セッションの設定例

その他の関連資料

関連資料

標準

SPAN および ERSPAN 機能の履歴

ローカル SPAN および ERSPAN の設定

この章では、ローカルおよびカプセル化リモート(ER)スイッチド ポート アナライザ(SPAN)機能を設定して、トラフィックをモニタする方法を説明します。また、次の内容が含まれます。

「SPAN および ERSPAN について」

「SPAN 注意事項および制約事項」

「デフォルト設定」

「SPAN の設定」

「SPAN の設定確認」

「設定例」

「その他の関連資料」

「SPAN および ERSPAN 機能の履歴」

SPAN および ERSPAN について

スイッチド ポート アナライザ(SPAN)機能(ポート ミラーリングまたはポート モニタリングとも呼ばれます)では、Cisco SwitchProbe やその他のリモート モニタリング(RMON)プローブなどのネットワーク アナライザを使用して、ネットワーク トラフィックを分析できます。

SPAN では、1 つ以上のポートまたは 1 つ以上の VLAN 上のトラフィックをモニタして、ネットワーク アナライザが接続されている 1 つ以上の宛先ポートに、モニタされたトラフィックを送信できます。

ここでは、次の内容について説明します。

「SPAN ソース」

「SPAN 宛先」

「SPAN セッション」

SPAN ソース

トラフィックをモニタできるモニタ元インターフェイスのことを SPAN ソースと呼びます。これには、イーサネット、仮想イーサネット、ポートチャネル、ポート プロファイル、および VLAN が含まれます。VLAN が SPAN ソースとして指定されている場合は、VLAN 内でサポートされているすべてのインターフェイスが SPAN ソースになります。ポート プロファイルが SPAN 送信元として指定されている場合、ポート プロファイルを継承するすべてのポートが SPAN 送信元になります。トラフィックのモニタは、イーサネットおよび仮想イーサネットのソース インターフェイスの受信方向、送信方向、双方向のいずれでも行えます。

受信ソース(Rx):このソース ポートを介してスイッチに入ってくるトラフィックが、SPAN 宛先ポートにコピーされます。

送信ソース(Tx):このソース ポートを介してスイッチから出て行くトラフィックが、SPAN 宛先ポートにコピーされます。

SPAN 送信元の特性

ローカル SPAN 送信元には次の特性があります。

ポート タイプは、イーサネット、仮想イーサネット、ポート チャネル、ポート プロファイル、VLAN のいずれでもかまいません。

宛先ポートまたはポート プロファイルにはできません。

モニタするトラフィックの方向を、受信、送信、両方のいずれかに設定できます。

送信元ポートは同じ VLAN にあっても異なる VLAN にあってもかまいません。

VLAN の SPAN 送信元では、送信元 VLAN のすべてのアクティブ ポートが送信元ポートとして含まれます。

ローカル SPAN 送信元は、宛先ポートと同じホスト(VEM)上にある必要があります。

ポート プロファイル送信元の場合、ポート プロファイルに接続しているすべてのアクティブ インターフェイスが送信元ポートとして含まれます。

SPAN 宛先

SPAN 宛先とは、送信元ポートをモニタするインターフェイスを指します。ここでは、次の内容について説明します。

「ローカル SPAN 宛先の特性」

「ERSPAN 宛先の特性」

ローカル SPAN 宛先の特性

各ローカル SPAN セッションが、ソース ポートまたはソース VLAN から送られてくるトラフィックのコピーを受信する少なくとも 1 つの宛先ポート(モニタリング ポートとも呼ばれます)を持っていなければなりません。宛先ポートの特性は、次のとおりです。

物理または仮想イーサネット ポート、ポート チャネル、ポート プロファイルのいずれでもかまいません。

送信元ポートまたはポート プロファイルにはできません。

いずれかの SPAN セッションの送信元 VLAN または送信元ポート プロファイルに属する場合、送信元リストから除外され、モニタされません。

同じ VEM モジュールのすべてのモニタ対象送信元ポートの送受信トラフィックのコピーを受信します。宛先ポートがオーバーサブスクライブ型の場合、輻輳が発生する可能性があります。輻輳が発生すると、1 つまたは複数の送信元ポートでのトラフィック転送に影響を及ぼす可能性があります。

プライベート VLAN モードには設定できません。

宛先ポートは同じホスト(VEM)上の送信元のみモニタできます。図 9-1 ローカル SPAN を参照してください。

アクセス モードの宛先ポートは、すべての VLAN のモニタ対象トラフィックを受信します。

トランク モードの宛先ポートは、トランク設定で許可されている VLAN のモニタ対象トラフィックのみ受信します。

ERSPAN 宛先の特性

ERSPAN 宛先は、IP アドレスによって指定されます。

ERSPAN では、送信元 SPAN インターフェイスと宛先 SPAN インターフェイスは、IP ネットワークで相互接続された異なるデバイス上にある場合があります。ERSPAN トラフィックは GRE によってカプセル化されています。図 9-2 ERSPAN を参照してください。

ローカル SPAN

ローカル SPAN では、送信元インターフェイスと宛先インターフェイスは同じ VEM 上にあります。ネットワーク アナライザは、SPAN 宛先ポートに直接接続しています。SPAN 送信元は、ポート、VLAN インターフェイス、またはポート プロファイルのいずれかです。宛先は、ポートまたはポート プロファイルのいずれかです。

図 9-1では、ホスト A から送信されたトラフィックが、SPAN 送信元インターフェイスで受信されます。トラフィック(ACL、QoS など)は、通常どおり処理されます。その後、トラフィックが複製されます。元のパケットは、ホスト B に対して転送されます。複製されたパケットは、モニタが接続されている宛先 SPAN インターフェイスに送信されます。

ローカル SPAN は、1 つ以上の宛先ポートに複製できます。トラフィックをフィルタリングできるため、必要なトラフィックだけが宛先 SPAN インターフェイスを送信します。

ローカル SPAN は、BPDU を含む送信元インターフェイスで受信されるすべてのトラフィックをモニタできます。

図 9-1 ローカル SPAN

 

 

カプセル化リモート SPAN

カプセル化リモート(ER)SPAN は、IP ネットワーク全体の複数のネットワーク デバイスのトラフィックをモニタし、カプセル化エンベロープにあるトラフィックを宛先アナライザに送信します。これとは対照的に、ローカル SPAN は、IP ネットワーク経由でトラフィックを転送できません。ERSPAN を使用して、リモートでトラフィックをモニタできます。ERSPAN 送信元は、ポート、VLAN、またはポート プロファイルのいずれかです。

図 9-2では、ホスト A の入出力トラフィックが ERSPAN によってモニタされています。カプセル化された ERSPAN パケットは、ルーティングされたネットワーク経由で、ホスト A から宛先デバイスにルーティングされます。宛先デバイスではパケットのカプセルが解除されて、接続しているネットワーク アナライザに転送されます。宛先は送信元と同じ L2 ネットワークにすることもできます。

図 9-2 ERSPAN

 

 

ネットワーク解析モジュール

Cisco ネットワーク解析モジュール(NAM)を使用して ERSPAN データソースをモニタし、アプリケーション パフォーマンス、トラフィック、およびパケット ヘッダーを分析することもできます。

NAM を使用して Cisco Nexus 1000V ERSPAN データソースをモニタする手順については、『 Cisco Nexus 1010 Network Analysis Module Installation and Configuration Note, 5.1 』を参照してください。

SPAN セッション

VEM には最大 64 の SPAN セッション(ローカル SPAN と ERSPAN の合計)を作成できます。

管理者は、終端ボックス側でのトラフィックの ERSPAN ストリームを区別するために、カプセル化されたフレームの ERSPAN ヘッダーに追加される ERSPAN セッション ID を設定する必要があります。フロー ID 番号の範囲を設定することもできます。詳細については、「許可される ERSPAN フロー ID の設定」を参照してください。

トランク ポートが SPAN 送信元および宛先として設定されている場合、許可された中から宛先ポートに送信する VLAN をフィルタリングできます。送信元と宛先の両方を VLAN を許可するように設定する必要があります。

図 9-3 は、トラフィックが 3 つの VLAN から指定された 3 つの宛先ポートにコピーされる VLAN ベースの SPAN 設定の例を示しています。各宛先ポートで許可する VLAN を選択して、トラフィックの送信を制限できます。図 9-3 では、デバイスは各宛先ポートの 1 つの VLAN からパケットを送信します。この例の宛先は、許可 VLAN が設定されたトランクです。


) VLAN ベースの SPAN セッションでは、パケットが宛先で必要かどうかに関係なく、すべての送信元パケットがすべての宛先にコピーされます。VLAN トラフィック フィルタリングは、送信宛先ポートで実行されます。


図 9-3 VLAN ベースの SPAN の設定例

.

SPAN 注意事項および制約事項

SPAN に関する設定時の注意事項および制約事項は、次のとおりです。

最大 64 の SPAN セッション(ローカル SPAN と ERSPAN)を VSM で設定できます。

最大 32 の送信元 VLAN がセッションで許可されます。

最大 32 の宛先がローカル SPAN セッションで許可されます。

最大 128 の送信元インターフェイスがセッションで許可されます。


注意 過負荷の可能性
アップリンク ポートの過負荷を回避するには、ERSPAN の設定、特に送信元 VLAN の設定時には注意が必要です。

ポートは最大 4 つの SPAN セッションで設定できます。

1 つの SPAN セッションで使用される宛先ポートは、別の SPAN セッションの宛先ポートとしても使用できません。

ポートを送信元ポートと宛先ポートの両方として設定することはできません。

SPAN セッションでは、送信元ポートが受信したパケットは、そのポートで送信されるものではなくても複製される可能性があります。たとえば、次のような場合です。

フラッディングから発生するトラフィック

ブロードキャストおよびマルチキャスト トラフィック

送受信の両方が設定された同じ VLAN でスイッチされる VLAN SPAN セッションの場合、宛先ポートから 2 つのパケット(受信から 1 つ、送信から 1 つ)が転送されます。

デフォルト設定

表 9-1 に、SPAN のデフォルト設定を示します。

 

表 9-1 SPAN のデフォルト

パラメータ
デフォルト

State

SPAN セッションはシャット ステートで作成されます。

Description

ブランク

Traffic direction for source interface or port profile

両方

Traffic direction for source VLAN

受信(入力または RX)

SPAN の設定

この項では、SPAN を設定する方法を説明し、次の手順が含まれています。

「ローカル SPAN セッションの設定」

「ERSPAN ポート プロファイルの設定」

「ERSPAN セッションの設定」

「SPAN セッションのシャットダウン」

「SPAN セッションの再開」

「SPAN の設定確認」

ローカル SPAN セッションの設定

この手順を使用して、SPAN セッションを設定します。


) ERSPAN を設定している場合は、「ERSPAN セッションの設定」を参照してください。


はじめる前に

EXEC モードで CLI にログインしていること。

設定する SPAN セッションの数を確認します。

送信元および宛先ポートは、アクセスまたはトランク モードで設定しておきます。詳細については、『 Cisco Nexus 1000V Interface Configuration Guide, Release 4.2(1)SV1(5.1) 』を参照してください。

デフォルトでは、SPAN セッションはシャット ステートで作成されます。

既存の SPAN セッションを作成する場合は、追加の設定がセッションに追加されます。確実にセッションの以前の設定をクリアするには、まず、セッションを削除する必要があります(ステップ 2の no monitor session を参照)。

この手順では、SPAN セッションをモニタ コンフィギュレーション モードで作成してから、許可される VLAN をインターフェイス コンフィギュレーション モードで設定します。許可される VLAN の設定は省略可能です。

手順の概要

1. config t

2. no monitor session session-number

3. monitor session session-number

4. description description

5. source {interface {type} {id | range} | vlan {id | range} | port-profile { name} } [ rx | tx | both ]

6. (任意)ステップ 5を繰り返して、追加の SPAN 送信元を設定します。

7. (任意) filter vlan {number | range}

8. (任意)ステップ 7を繰り返して、フィルタリングするすべての送信元 VLAN を設定します。

9. destination {interface {type} {id } | port-profile { name} }

10. (任意)ステップ 9を繰り返して、すべての SPAN 宛先ポートを設定します。

11. no shut

12. (任意) exit

13. (任意)show monitor session session-number

14. (任意) show interface {type} {id} switchport

15. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

Example:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

no monitor session session-number

 

Example:

n1000v(config)# no monitor session 3

指定されたセッションをクリアします。

ステップ 3

monitor session session-number

 

Example:

n1000v(config)# monitor session 3

n1000v(config-monitor)#

任意のセッション番号でセッションを作成して、CLI モニタ コンフィギュレーション モードに切り替え、セッションを設定します。

ステップ 4

description description

 

Example:

n1000v(config-monitor)# description my_span_session_3

指定された SPAN セッションの場合は、説明を追加します。

description:最大 32 文字の英数字
デフォルト = ブランク(説明なし)

ステップ 5

source {interface {type} {id} |
vlan {id | range} |
port-profile { name} } [ rx | tx | both ]

 

Example 1:

n1000v(config-monitor)# source interface ethernet 2/1-3, ethernet 3/1 rx

 

Example 2:

n1000v(config-monitor)# source interface port-channel 2

 

Example 3:

n1000v(config-monitor)# source interface vethernet 12 both

 

Example 4:

n1000v(config-monitor)# source vlan 3, 6-8 tx

 

Example 5:

n1000v(config-monitor)# source port-profile my_port_profile

指定されたセッションの場合は、モニタするトラフィックの送信元と方向を設定します。

type:インターフェイス タイプ(イーサネットまたは vEthernet)を指定します。

ID:モニタする vEthernet 番号、イーサネット スロット/ポート、または VLAN ID を指定します。

range:モニタする VLAN の範囲を指定します。

name:既存のポート プロファイルの名前を指定します。このポート プロファイルは、「ERSPAN ポート プロファイルの設定」で定義されている IP ネットワークを介して ERSPAN パケットを伝送するために作成されているポート プロファイルとは異なります。

traffic direction:トラフィック モニタリングの方向を指定します。

受信(rx)(VLAN デフォルト)

送信(tx)

両方(デフォルト)

ステップ 6

(任意)ステップ 5を繰り返して、追加の SPAN 送信元を設定します。

ステップ 7

filter vlan {id | range}

 

Example:

n1000v(config-monitor)# filter vlan 3-5, 7

(任意)指定された SPAN セッションの場合、送信元 VLAN の中からフィルタを設定します。

ステップ 8

(任意)ステップ 7を繰り返して、フィルタリングするすべての送信元 VLAN を設定します。

ステップ 9

destination {interface {type} {id | range} | port-profile { name} }

 

Example:

n1000v(config-monitor)# destination interface ethernet 2/5, ethernet 3/7

指定された SPAN セッションの場合は、コピーされた送信元パケットの宛先を設定します。

type:インターフェイス タイプ(イーサネットまたは vEthernet)を指定します。

ID:モニタする vEthernet 番号、またはイーサネット スロット/ポートを指定します。

name:モニタするポート プロファイルの名前を指定します。

(注) SPAN 宛先ポートはアクセスまたはトランク ポートとして設定しておく必要があります。

ステップ 10

(任意)ステップ 9を繰り返して、すべての SPAN 宛先ポートを設定します。

ステップ 11

no shut

 
Example:
n1000v(config-monitor)# no shut

SPAN セッションをイネーブルにします。デフォルトでは、セッションはシャット ステートで作成されます。

ステップ 12

exit

 

Example:

n1000v(config-monitor)# exit

n1000v(config)#

(任意)モニタ コンフィギュレーション モードを終了して、CLI コンフィギュレーション モードに切り替えます。

ステップ 13

show monitor session session-number

 

Example:

n1000v(config-if)# show monitor session 3

(任意)設定済みのモニタ セッションを表示します。

ステップ 14

show interface {type} {id} switchport

 

Example:

n1000v(config-if)# show interface ethernet 2/5 switchport

(任意)許可 VLAN を含む、設定済みのポートを表示します。

ステップ 15

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

ERSPAN ポート プロファイルの設定

この手順を使用して、VSM 上のポート プロファイルを設定し、ERSPAN パケットを IP ネットワーク経由で、リモート宛先アナライザに転送します。

はじめる前に

EXEC モードで CLI にログインしていること。

vCenter Server のすべてのホストに対して、この設定を完了する必要があります。

このポート プロファイルに使用する名前を確認します。


) ポート プロファイル名は、VMKNIC を設定するために使用されます。VMKNIC は、ERSPAN カプセル化 IP パケットを送信するために各 ESX ホストで必要であり、ERSPAN 宛先 IP アドレスへの IP 接続が必要です。


このプロファイルをマッピングする VMware ポート グループ名を確認します。

新しい仮想アダプタを追加するための VMware マニュアルを手元に用意します。

ERSPAN 宛先に IP トラフィックを送信するシステム VLAN をすでに作成していること、およびこの設定で使用される VLAN ID を確認します。

システム ポート プロファイルの詳細については、『 Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.2(1)SV1(5.1) 』を参照してください。

ERSPAN に使用するポート プロファイルは、レイヤ 3 コントロール用に設定する必要があります。この手順には、この設定を行うステップも含まれています。

このレイヤ 3 コントロール ポート プロファイルに割り当て可能な VM カーネル NIC は、1 つのホストにつき 1 つだけです。

複数の VMware カーネル NIC が同じホストに割り当てられている場合は、最初に割り当てられたものが有効になります。2 番目はレイヤ 3 制御 VMware カーネル NIC とは見なされません。

2 つの VMware カーネル NIC が同じホストに割り当てられている場合に、2 番目に割り当てられたものを削除しても、最初に割り当てられたものが VEM によって使用されることはありません。代わりに、VMware カーネル NIC を両方とも削除してから 1 つだけをもう一度割り当てる必要があります。

ポート プロファイルは、アクセス ポート プロファイルであることが必要です。トランク ポート プロファイルであってはなりません。ここで説明する手順の中で、ポート プロファイルをアクセス ポート プロファイルとして設定します。

レイヤ 3 制御ポート プロファイルの作成方法の詳細については、「レイヤ 3 コントロール用のポート プロファイルの作成」を参照してください。

手順の概要

1. config t

2. port-profile name

3. capability l3control

4. vmware port-group name

5. switchport mode access

6. switchport access vlan id

7. no shutdown

8. system vlan id

9. state enabled

10. (任意) show port-profile name name

11. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

Example:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile port_profile_name

 

Example:

n1000v(config)# port-profile erspan_profile

n1000v(config-port-prof)#

ポート プロファイルを作成し、指定されたポート プロファイルの CLI グローバル コンフィギュレーション モードに切り替えます。実行コンフィギュレーションに、ポート プロファイルを保存します。

ポート プロファイル名は最大 80 文字で指定し、Cisco Nexus 1000V のポート プロファイルごとに一意である必要があります。

ステップ 3

capability l3control

 

Example:

n1000v(config-port-prof)# capability l3control

n1000v(config-port-prof)#

ポート プロファイルを設定して、ERSPAN トラフィックを転送し、実行コンフィギュレーションに保存します。

ステップ 4

vmware port-group name

 

Example:

n1000v(config-port-prof)#vmware port-group erspan

n1000v(config-port-prof)#

ポート プロファイルを VMware ポート グループとして指定し、このプロファイルがマッピングする VMware ポート グループ名を追加します。実行コンフィギュレーションに、設定を保存します。

ポート プロファイルは、同じ名前の VMware ポート グループにマッピングされます。vCenter Server 接続が確立すると、Cisco Nexus 1000V で作成されたポート グループは、vCenter Server の仮想スイッチに配信されます。

name:ポート グループ名。名前を指定しない場合は、ポート プロファイル名がポート グループ名となります。ポート プロファイルを異なるポート グループ名にマッピングする場合は、name オプションの後に別の名前を続けます。

ステップ 5

switchport mode access

 

Example:

n1000v(config-port-prof)# switchport mode access

n1000v(config-port-prof)#

インターフェイスがスイッチ アクセス ポート(デフォルト)であることを指定します。

ステップ 6

switchport access vlan id

 

Example 1:

n1000v(config-port-prof)# switchport access vlan 2

n1000v(config-port-prof)#

VLAN ID をこのポート プロファイルのアクセス ポートに割り当て、実行コンフィギュレーションに設定を保存します。

この VLAN が ERSPAN 宛先に IP トラフィックを送信するために使用されます。

ステップ 7

no shutdown

 

Example:

n1000v(config-port-prof)# no shutdown

n1000v(config-port-prof)#

実行コンフィギュレーションのインターフェイスをイネーブルにします。

ステップ 8

system vlan id

 

Example:

n1000v(config-port-prof)# system vlan 2

n1000v(config-port-prof)#

システム VLAN ID をポート プロファイルに関連付け、実行コンフィギュレーションに保存します。

アクセス ポートに割り当てられた VLAN ID と一致しなければなりません。一致しない場合は、次のエラー メッセージが表示されます。

ERROR: System vlan being set does not match the switchport access vlan 2

ステップ 9

state enabled

 

Example:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

実行コンフィギュレーションで、ポート プロファイルをイネーブルにします。

これで、このポート プロファイルは、ERSPAN 送信元を持つすべての ESX ホストの ERSPAN パケットを送信できます。

ステップ 10

show port-profile name port_profile_name

 

Example:

n1000v(config-port-prof)# show port-profile name erspan

port-profile erspan

description:

status: enabled

capability uplink: no

capability l3control: yes

system vlans: 2

port-group: access

max-ports: 32

inherit:

config attributes:

switchport access vlan 2

no shutdown

evaluated config attributes:

switchport access vlan 2

no shutdown

assigned interfaces:

 

n1000v(config-port-prof)#

(任意)指定されたポート プロファイルの設定を、実行コンフィギュレーションにあるとおりに表示します。

ステップ 11

copy running-config startup-config

 

Example:

n1000v(config-port-prof)# copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

ステップ 12

VMware のマニュアルを参照して、vSphere Client で、各 ESX ホストの VMKNIC を ERSPAN カプセル化パケットを送信するように設定します。必ず 新しい仮想アダプタ として、VMKNIC がこのポート プロファイルを参照するようにします。この VMKNIC は ERSPAN 宛先 IP アドレスに IP 接続できる必要があります。

ERSPAN セッションの設定

この手順を使用して、ERSPAN セッションを設定します。


) ローカル SPAN を設定している場合は、「ローカル SPAN セッションの設定」を参照してください。


はじめる前に

EXEC モードで CLI にログインしていること。

設定する SPAN セッションの数を確認します。

「ERSPAN ポート プロファイルの設定」を参照して、VSM の ERSPAN 対応ポート プロファイルを設定しておきます。

新しい仮想アダプタを追加するための VMware マニュアルを使用して、各 ESX ホスト上に必要な VMKNIC を設定しておきます。VMKNIC は ERSPAN カプセル化パケットを送信するために、ERSPAN 宛先 IP アドレスに IP 接続できる必要があります。

デフォルトでは、SPAN セッションはシャット ステートで作成されます。

既存の SPAN セッションを作成する場合は、追加の設定がセッションに追加されます。確実にセッションの以前の設定をクリアするには、まず、セッションを削除する必要があります(ステップ 2の no monitor session を参照)。

この手順には、ERSPAN 送信元コンフィギュレーション モード(config-erspan-source)での SPAN セッションの作成が含まれます。

手順の概要

1. config t

2. no monitor session session-number

3. monitor session session-number type erspan-source

4. description description

5. source {interface type { number | range } | vlan { number | range } | port-profile name }} [ rx | tx | both ]

6. (任意)ステップ 5を繰り返して、追加の ERSPAN 送信元を設定します。

7. (任意) filter vlan {number | range}

8. (任意)ステップ 7を繰り返して、フィルタリングするすべての送信元 VLAN を設定します。

9. destination ip ip_address

10. (任意) ip ttl ttl_value

11. (任意) ip prec ipp_value

12. (任意) ip dscp dscp_value

13. (任意) mtu mtu_value

14. (任意) header-type value

15. erspan-id flow_id

16. no shut

17. (任意) show monitor session session_id

18. (任意) exit

19. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

Example:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

no monitor session session-number

 

Example:

n1000v(config)# no monitor session 3

指定されたセッションをクリアします。

ステップ 3

monitor session session-number type erspan-source

 

Example:

n1000v(config)# monitor session 3 type erspan

n1000v(config-erspan-source)#

任意のセッション番号でセッションを作成し、CLI ERSPAN 送信元コンフィギュレーション モードに切り替えます。この設定は、実行コンフィギュレーションに保存されます。

ステップ 4

description description

Example:

n1000v(config-erspan-src)# description my_erspan_session_3

n1000v(config-erspan-src)#

指定された ERSPAN セッションの場合、説明を追加して、実行コンフィギュレーションに保存します。

description:最大 32 文字の英数字
デフォルト = ブランク(説明なし)

ステップ 5

source { interface type { number | range } | vlan { number | range } | port-profile name }} [ rx | tx | both ]

 

Example 1:

n1000v(config-erspan-src)# source interface ethernet 2/1-3, ethernet 3/1 rx

 

Example 2:

n1000v(config-erspan-src)# source interface port-channel 2

 

Example 3:

n1000v(config-erspan-src)# source interface vethernet 12 both

 

Example 4:

n1000v(config-erspan-src)# source vlan 3, 6-8 tx

 

Example 5:

n1000v(config-erspan-src)# source port-profile my_port_profile

指定されたセッションの場合、モニタする送信元とトラフィックの方向を設定し、実行コンフィギュレーションに保存します。

type:インターフェイス タイプ(イーサネット、ポートチャネル、仮想イーサネット)を指定します。

number:モニタするインターフェイス スロットおよびポートまたはポート範囲、VLAN 番号または VLAN 範囲を指定します。

name:既存のポート プロファイルの名前。

traffic direction:次の方向のいずれかになるように、トラフィック モニタを指定します。

受信(rx)(VLAN デフォルト)

送信(tx)

両方(インターフェイスおよびポート プロファイルのデフォルト値)

ステップ 6

(任意)ステップ 5を繰り返して、追加の ERSPAN 送信元を設定します。

ステップ 7

filter vlan { number | range }

 

Example:

n1000v(config-erspan-src)# filter vlan 3-5, 7

(任意)指定された ERSPAN セッションの場合、モニタする VLAN、VLAN リスト、VLAN 範囲のいずれかを設定して、実行コンフィギュレーションに保存します。

モニタ ポート上では、VLAN フィルタ リストと一致する VLAN からのトラフィックだけが宛先に複製されます。

ステップ 8

(任意)ステップ 7を繰り返して、フィルタリングするすべての送信元 VLAN を設定します。

ステップ 9

destination ip ip_address

 

Example:

n1000v(config-erspan-src)# destination ip 10.54.54.1

n1000v(config-erspan-src)#

このモニタ セッションでカプセル化されたトラフィックが送信されるホストの IP アドレスを設定し、実行コンフィギュレーションに保存します。

ステップ 10

ip ttl ttl_value

 

Example:

n1000v(config-erspan-src)# ip ttl 64

n1000v(config-erspan-src)#

(任意)このモニタ セッションでの ERSPAN パケットの IP 存続可能時間の値(1 ~ 255)を指定し、実行コンフィギュレーションに保存します。

デフォルトは 64 です。

ステップ 11

ip prec precedence_value

 

Example:

n1000v(config-erspan-src)# ip prec 1

n1000v(config-erspan-src)#

(任意)このモニタ セッションでの ERSPAN パケットの IP Precedence 値(0 ~ 7)を指定し、実行コンフィギュレーションに保存します。

デフォルト値は 0 です。

ステップ 12

ip dscp dscp_value

 

Example:

n1000v(config-erspan-src)# ip dscp 24

n1000v(config-erspan-src)#

(任意)このモニタ セッションでの ERSPAN パケットの IP DSCP 値(0 ~ 63)を指定し、実行コンフィギュレーションに保存します。

デフォルトは 0 です。

ステップ 13

mtu mtu_value

 

Example:

n1000v(config-erspan-src)# mtu 1000

n1000v(config-erspan-src)#

(任意)このモニタ セッションでの ERSPANed パケットの MTU サイズ(50~1500)を指定し、実行コンフィギュレーションに保存します。1500 の MTU サイズの制限には、ERSPAN によってモニタ対象パケットに追加される 50 バイトのオーバーヘッドが含まれます。このサイズより大きいパケットは切り捨てられます。

デフォルト値は 1500 です。

ステップ 14

header-type value

 

Example:

n1000v(config-erspan-src)# header-type 2

n1000v(config-erspan-src)#

(任意)このモニタ セッションの ERSPAN のカプセル化に使用される ERSPAN ヘッダー タイプ(2 または 3)を指定します。

2 = ERPSPANv2 ヘッダー タイプ(デフォルト)

3 = ERSPANv3 ヘッダー タイプ(NAM 設定で使用されます。他のタイプの宛先は、デフォルト v2 ヘッダーでのみ動作します)。

ステップ 15

erspan-id flow_id

 

Example:

n1000v(config-erspan-src)# erspan-id 51

ERSPAN ID(1 ~ 1023)をセッション設定に追加して、実行コンフィギュレーションに保存します。

セッション ERSPAN ID を、カプセル化されたフレームの ERSPAN ヘッダーに追加し、終端ボックスで使用して、さまざまなトラフィックの ERSPAN ストリームを識別できます。

ステップ 16

no shut

 
Example:
n1000v(config-erspan-src)# no shut

ERSPAN セッションをイネーブルにし、実行コンフィギュレーションに保存します。

デフォルトでは、セッションはシャット ステートで作成されます。

ステップ 17

show monitor session session_id

 

Example:
n1000v(config-erspan-src)# show monitor session 3

(任意)実行コンフィギュレーションにあるとおりに、ERSPAN セッション設定を表示します。

ステップ 18

copy running-config startup-config

 

Example:

n1000v(config-erspan-src)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

SPAN セッションのシャットダウン

この手順を使用して、SPAN セッションのパケットのコピーを中止します。1 つの送信元および宛先からのパケットのコピーを中止し、別の送信元および宛先で再開できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

シャットダウンする SPAN セッションを確認します。

グローバル コンフィギュレーション モードまたはモニタ コンフィギュレーション モードで、SPAN セッションをシャットダウンできます。

手順の概要

グローバル コンフィギュレーション モードから:

1. config t

2. monitor session {session-number | session-range | all } shut

3. show monitor

4. copy running-config startup-config

モニタ コンフィギュレーション モードから:

1. config t

2. monitor session {session-number | session-range | all } [type erspan-source]

3. shut

4. show monitor

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

Example:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

monitor session {session-number | session-range | all } shut

Example:

n1000v(config)# monitor session 3 shut

n1000v(config)#

 

Example:

n1000v(config)# monitor session 3

n1000v(config-monitor)# shut

グローバル コンフィギュレーション モードまたはモニタ コンフィギュレーション モードで、指定された SPAN モニタ セッションをシャットダウンします。

session-number:特定の SPAN セッション番号を指定します。

session range:SPAN セッションの範囲を指定します(許可されている範囲は 1 ~ 64)。

all:すべての SPAN モニタ セッションを指定します。

ステップ 3

show monitor

 

Example:

n1000v(config-monitor)# show monitor

(任意)SPAN セッションの状況を表示します。

ステップ 4

copy running-config startup-config

 

Example:

n1000v(config-monitor)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

 

SPAN セッションの再開

この手順を使用して、SPAN セッションのパケットのコピーを再開します。1 つの送信元および宛先からのパケットのコピーを中止し、別の送信元および宛先で再開できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

設定する SPAN セッションを確認します。

グローバル コンフィギュレーション モードまたはモニタ コンフィギュレーション モードで、SPAN セッションを再開できます。

手順の概要

グローバル コンフィギュレーション モードから:

1. config t

2. no monitor session {session-number | session-range | all } shut

3. show monitor

4. copy running-config startup-config

モニタ コンフィギュレーション モードから:

1. config t

2. monitor session {session-number | session-range | all } [type erspan-source]

3. no shut

4. show monitor

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

Example:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

[ no ] monitor session {session-number session-range | all } shut

 

Example:

n1000v(config)# no monitor session 3 shut

n1000v(config)#

 

Example:

n1000v(config)# monitor session 3

n1000v(config-monitor)# no shut

グローバル コンフィギュレーション モードまたはモニタ コンフィギュレーション モードで、指定された SPAN モニタ セッションを開始します。

session-number:特定の SPAN セッション番号を指定します。

session range:SPAN セッションの範囲を指定します(許可されている範囲は 1 ~ 64)。

all:すべての SPAN モニタ セッションを指定します。

ステップ 3

show monitor

 

Example:

n1000v(config-monitor)# show monitor

(任意)確認のために、すべての設定済み SPAN セッションのステータスを表示します。

ステップ 4

show monitor session session-id

 

Example:

n1000v(config-monitor)# show monitor session 3

(任意)確認のために、特定の SPAN セッションの詳細な設定およびステータスを表示します。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config-monitor)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

許可される ERSPAN フロー ID の設定

ここでは、ERSPAN セッションに割り当て可能なフロー ID の範囲を限定する手順を説明します。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

許容される ERSPAN フロー ID の範囲がわかっている必要があります。

使用可能な ERSPAN フロー ID は 1 ~ 1023 です。この手順を使用すると、使用可能な ID の範囲を制限できます。

手順の概要

1. config t

2. [no] limit-resource erspan-flow-id minimum min_val maximum max_val

3. show running monitor

4. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

Example:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

[no] limit-resource erspan-flow-id minimum min_val maximum max_val

 

Example:

n1000v(config)# limit-resource erspan-flow-id minimum 20 maximum 40

n1000v(config)#

 

Example:

n1000v(config)# no limit-resource erspan-flow-id

n1000v(config)#

 

割り当て可能な ERSPAN フロー ID の範囲を限定します。

有効な範囲 = 1~1023

デフォルト:

min_val = 1

max_val = 1023

このコマンドの no バージョンは設定値を削除し、デフォルト値に戻します。

ステップ 3

show running monitor

 

Example:

n1000v(config-monitor)# show monitor session 3

(任意)確認のために、デフォルトの limit-resource erspan-flow-id 値に対する変更を表示します。

ステップ 4

copy running-config startup-config

 

Example:

n1000v(config-monitor)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

SPAN の設定確認

SPAN 設定を確認するには、次のコマンドを使用します。

 

コマンド
目的

show monitor session { all | session-number | range session-range } [ brief ]

SPAN セッションの設定を表示します。

show monitor

イーサネット SPAN 情報を表示します。

module vem module-number execute vemcmd show span

VEM モジュールで設定された SPAN セッションを表示します。

show port-profile name port_profile_name

ポート プロファイルを表示します。

設定例

この項には、次の設定例が含まれています。

「SPAN セッションの設定例」

「ERSPAN セッションの設定例」

SPAN セッションの設定例

SPAN セッションを設定する手順は、次のとおりです。


ステップ 1 アクセス モードまたはトランク モードで宛先ポートを設定し、SPAN モニタリングをイネーブルにします。

n1000v# config t
n1000v(config)# interface ethernet 2/5
n1000v(config-if)# switchport
n1000v(config-if)# switchport mode trunk
n1000v(config-if)# no shut
n1000v(config-if)# exit
n1000v(config)#
 

ステップ 2 SPAN セッションを設定します。

n1000v(config)# no monitor session 1
n1000v(config)# monitor session 1
n1000v(config-monitor)# source interface ethernet 2/1-3
n1000v(config-monitor)# source interface port-channel 2
n1000v(config-monitor)# source port-profile my_profile_src
n1000v(config-monitor)# source vlan 3, 6-8 tx
n1000v(config-monitor)# filter vlan 3-5, 7
n1000v(config-monitor)# destination interface ethernet 2/5
n1000v(config-monitor)# destination port-profile my_profile_dst
n1000v(config-monitor)# no shut
n1000v(config-monitor)# exit
n1000v(config)# show monitor session 1
n1000v(config)# copy running-config startup-config
 
n1000v(config)# show monitor session 1
session 1
---------------
type : local
state : up
source intf :
rx : Eth2/1 Eth2/2 Eth2/3
tx : Eth2/1 Eth2/2 Eth2/3
both : Eth2/1 Eth2/2 Eth2/3
source VLANs :
rx :
tx : 3,6,7,8
both :
source port-profile :
rx : my_profile_src
tx : my_profile_src
both : my_profile_src
filter VLANs : 3,4,5,7
destination ports : Eth2/5
destination port-profile : my_profile_dst
 
n1000v# module vem 3 execute vemcmd show span
 
VEM SOURCE IP NOT CONFIGURED.
 
HW SSN ID ERSPAN ID HDR VER DST LTL/IP
1 local 49,51,52,55,56
 


 

ERSPAN セッションの設定例

次の例では、Cisco Nexus 1000V の送信元イーサネット インターフェイスおよび宛先 IP アドレスに対する ERSPAN セッションを作成する方法を示します。宛先 IP に到達するパケットは、ヘッダーの ID 999 で特定されます。

monitor session 2 type erspan-source
source interface ethernet 3/3
source port-profile my_profile_src
destination ip 10.54.54.1
erspan-id 999
mtu 1000
no shut
 
show monitor session 2
session 2
---------------
type : erspan-source
state : up
source intf :
rx : Eth3/3
tx : Eth3/3
both : Eth3/3
source VLANs :
rx :
tx :
both :
source port-profile :
rx : my_profile_src
tx : my_profile_src
both : my_profile_src
filter VLANs : filter not specified
destination IP : 10.54.54.1
ERSPAN ID : 999
ERSPAN TTL : 64
ERSPAN IP Prec. : 0
ERSPAN DSCP : 0
ERSPAN MTU : 1000
ERSPAN Header Type: 2
 
module vem 3 execute vemcmd show span
 
VEM SOURCE IP: 10.54.54.10
 
HW SSN ID ERSPAN ID HDR VER DST LTL/IP
1 local 49,51,52,55,56
2 999 2 10.54.54.1
 

その他の関連資料

SPAN の実装に関連する詳細情報については、次の項を参照してください。

「関連資料」

「標準」

関連資料

 

関連項目
参照先

ポート プロファイルの設定

Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.2(1)SV1(5.1)

インターフェイス コンフィギュレーション

Cisco Nexus 1000V Interface Configuration Guide, Release 4.2(1)SV1(5.1)

すべてのコマンド構文、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、例

Cisco Nexus 1000V Command Reference, Release 4.2(1)SV1(5.1)

標準

 

標準
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--

SPAN および ERSPAN 機能の履歴

ここでは、SPAN および ERSPAN 機能のリリース履歴を示します。

 

機能名
リリース
機能情報

ローカル SPAN および ERSPAN 送信元としてのポート プロファイル

4.2(1)SV1(4)

ローカル SPAN および ERSPAN モニタ トラフィックの送信元としてのポート プロファイルを指定できます。

ERSPAN データソースに対する NAM サポート

4.0(4)SV1(3)

NAM サポートが追加されました。

ERSPAN タイプ III ヘッダー

4.0(4)SV1(3)

ERSPAN タイプ III ヘッダー形式が追加されました。

SPAN および ERSPAN

4.0(4)SV1(1)

SPAN および ERSPAN が追加されました。