Cisco Nexus 1000V システム管理コンフィギュレーション ガイド リリース 4.2(1)SV1(5.1)
設定の管理
設定の管理
発行日;2012/05/24 | 英語版ドキュメント(2012/04/18 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

設定の管理

コンフィギュレーション管理について

スイッチ名の変更

Message of the Day の設定

設定の確認

ソフトウェアとハードウェアのバージョンの確認

実行コンフィギュレーションの確認

スタートアップ コンフィギュレーションと実行コンフィギュレーションの比較

インターフェイス コンフィギュレーションの確認

インターフェイス コンフィギュレーションの要約の確認

インターフェイス コンフィギュレーションの詳細の確認

全インターフェイスの要約の確認

全インターフェイスの実行コンフィギュレーションの確認

コンフィギュレーションの保存

コンフィギュレーションの削除

コンフィギュレーション管理機能の履歴

コンフィギュレーション管理について

Cisco Nexus 1000V では、スイッチ名の変更と Messages of the Day の設定や、コンフィギュレーション ファイルの表示、保存、および消去を管理者が実行できるようになっています。

スイッチ名の変更

スイッチ名またはプロンプトをデフォルト(switch#)から別のストリングに変更するには、ここに示す手順を実行します。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

コンフィギュレーション モードで CLI にログインします。

VSM が vCenter Server に接続されている場合は、この手順の中で、VSM による管理の対象の DVS も変更されます。DVS の名前を変更するときにエラーが発生した場合は、syslog が生成され、vCenter Server 上の DVS の名前は古い DVS 名のままとなります。

手順の詳細

 

コマンド
目的

ステップ 1

switchname

 

Example:

n1000v(config)# switchname metro

metro(config)# exit

metro#

スイッチ プロンプトを変更します。

Message of the Day の設定

ユーザがログインする際に端末上のログイン プロンプトの前に表示される Message of the Day(MOTD)のメッセージを設定するには、ここに示す手順を実行します。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

コンフィギュレーション モードで CLI にログインします。

バナー メッセージは、最大 40 行、行あたり最大 80 文字です。

デリミタを選ぶ際には、次のガイドラインに従ってください。

メッセージ ストリング中では デリミタ を使用しないでください。

" および % をデリミタとして使用しないでください。

Message of the Day の中では次のトークンを使用できます。

$(hostname) を使用すると、スイッチのホスト名が表示されます。

$(line) を使用すると、vty または tty のラインまたは名前が表示されます。

手順の詳細

 

コマンド
目的

ステップ 1

banner motd [ delimiting-character message delimiting-character ]

 

Example:
n1000v(config)# banner motd #April 16, 2008 Welcome to the svs#
n1000v(config)#

バナー Message of the Day を設定します。

最大 40 行

行あたり最大 80 文字

# などのデリミタで囲む

複数行にまたがることが可能

トークンを使用可能

ステップ 2

show banner motd

 

Example:
n1000v(config)# show banner motd
April 16, 2008 Welcome to the Switch

設定されているバナー メッセージを表示します。

設定の確認

スイッチのコンフィギュレーションを表示するには、ここで説明する方法を使用します。ここでは、次の内容について説明します。

「ソフトウェアとハードウェアのバージョンの確認」

「実行コンフィギュレーションの確認」

「スタートアップ コンフィギュレーションと実行コンフィギュレーションの比較」

「インターフェイス コンフィギュレーションの確認」

ソフトウェアとハードウェアのバージョンの確認

アップグレードの前後でバージョンを確認するためなど、システム上のソフトウェアとハードウェアのバージョンを表示するには、ここに示すコマンドを使用します。

はじめる前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

show version

 
Example:

n1000v# show version

現在スイッチで動作しているシステム ソフトウェアとハードウェアのバージョンを表示します。

 

Example:
n1000v# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2009, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained in this software are
owned by other third parties and used and distributed under
license. Certain components of this software are licensed under
the GNU General Public License (GPL) version 2.0 or the GNU
Lesser General Public License (LGPL) Version 2.1. A copy of each
such license is available at
http://www.opensource.org/licenses/gpl-2.0.php and
http://www.opensource.org/licenses/lgpl-2.1.php
 
Software
loader: version 1.2(2)
kickstart: version 4.0(4)SV1(1)
system: version 4.0(4)SV1(1)
kickstart image file is:
kickstart compile time: 4/2/2009 23:00:00
system image file is: bootflash:/svs.bin
system compile time: 4/2/2009 23:00:00 [04/23/2009 09:55:29]
 
 
Hardware
Cisco Nexus 1000V Chassis ("Virtual Supervisor Module")
Intel(R) Xeon(R) CPU with 1034780 kB of memory.
Processor Board ID T5056893321
 
Device name: n1000v
bootflash: 3897832 kB
 
Kernel uptime is 0 day(s), 0 hour(s), 2 minute(s), 55 second(s)
 
 
plugin
Core Plugin, Ethernet Plugin

実行コンフィギュレーションの確認

現在システムで動作しているコンフィギュレーションを表示するには、ここに示す方法を使用します。

はじめる前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

show running-config

 
Example:
n1000v# show running-config

現在スイッチで動作しているシステム ソフトウェアとハードウェアのバージョンを表示します。

Example:
n1000v# show running-config
version 4.0(4)SV1(1)
username admin password 5 $1$ouYE/pRM$/j4/2lg3RMd4PhE.1Z1S.0 role network-admin
telnet server enable
ip domain-lookup
ip host n1000v 172.23.232.141
kernel core target 0.0.0.0
kernel core limit 1
system default switchport
vem 3
host vmware id 89130a67-e66b-3e57-ad25-547750bcfc7e
snmp-server user admin network-admin auth md5 0xb64ad6879970f0e57600c443287a79f0 priv 0xb64ad6879970f0e57600c443287a79f0 localizedkey
snmp-server enable traps license
vrf context management
ip route 0.0.0.0/0 172.23.232.1
switchname n1000v
vlan 1,260-269
vdc n1000v id 1
limit-resource vlan minimum 16 maximum 513
limit-resource monitor-session minimum 0 maximum 64
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 256
limit-resource u4route-mem minimum 32 maximum 80
limit-resource u6route-mem minimum 16 maximum 48
port-profile Unused_Or_Quarantine_Uplink
description "Port-group created for Nexus1000V internal usage. Do not use."
capability uplink
vmware port-group
shutdown
state enabled
port-profile Unused_Or_Quarantine_Veth
description "Port-group created for Nexus1000V internal usage. Do not use."
vmware port-group
shutdown
state enabled
port-profile system-uplink
capability uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 260-261
no shutdown
system vlan 260-261
state enabled
port-profile vm-uplink
capability uplink
vmware port-group
switchport mode access
switchport access vlan 262
no shutdown
state enabled
port-profile data262
vmware port-group
switchport access vlan 262
no shutdown
state enabled
 
interface Ethernet3/2
inherit port-profile system-uplink
 
interface Ethernet3/3
inherit port-profile vm-uplink
 
interface mgmt0
ip address 172.23.232.141/24
 
interface control0
line vty
session-limit 32
boot kickstart bootflash:/kick.bin sup-1
boot system bootflash:/svs.bin sup-1
boot kickstart bootflash:/kick.bin sup-2
boot system bootflash:/svs.bin sup-2
svs-domain
domain id 141
control vlan 260
packet vlan 261
svs mode L2
svs connection vc
protocol vmware-vim
remote hostname 172.23.231.201
vmware dvs uuid "2c 6f 3d 50 62 f3 7f 4d-dc 00 70 e2 52 77 ca 15" datacenter-name HamiltonDC
connect
 
n1000v#
 

スタートアップ コンフィギュレーションと実行コンフィギュレーションの比較

スタートアップ コンフィギュレーションと実行コンフィギュレーションの違いを表示するには、ここに示す手順を実行します。

はじめる前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

show running-config diff

 
Example:
n1000v# show running-config diff

スイッチ上の現在のスタートアップ コンフィギュレーションと実行コンフィギュレーションの差違を表示します。

 

例 5-1 show running-config diff のコマンド出力

n1000v# show running-config diff
*** Startup-config
--- Running-config
***************
*** 1,7 ****
version 4.0(1)
- system mem-thresholds minor 0 severe 0 critical 0
vrf context management
ip route 0.0.0.0/0 10.78.1.1
switchname DCOS-112-S10
vlan 80,110-111,150,160,170
vdc DCOS-112-S10 id 1
--- 1,6 ----
***************
*** 116,131 ****
ip address 10.78.1.112/24
interface Vethernet49
inherit port-profile vlan160
- interface Vethernet65
- inherit port-profile vlan170
interface Vethernet50
inherit port-profile vlan160
interface Vethernet66
inherit port-profile vlan170
ip route 0.0.0.0/0 10.78.1.1
vlan 80-80, 110-110, 111-111, 150-150, 160-160, 170-170
--- 115,130 ----
ip address 10.78.1.112/24
interface Vethernet49
inherit port-profile vlan160
interface Vethernet50
inherit port-profile vlan160
+ interface Vethernet65
+ inherit port-profile vlan170
+
interface Vethernet66
inherit port-profile vlan170
ip route 0.0.0.0/0 10.78.1.1
vlan 80-80, 110-110, 111-111, 150-150, 160-160, 170-170
n1000v#

インターフェイス コンフィギュレーションの確認

ここでは、次の手順について説明します。

「インターフェイス コンフィギュレーションの要約の確認」

「インターフェイス コンフィギュレーションの詳細の確認」

「全インターフェイスの要約の確認」

「全インターフェイスの実行コンフィギュレーションの確認」

インターフェイスの表示の詳細については、『 Cisco Nexus 1000V Interface Configuration Guide, Release 4.2(1)SV1(5.1) 』を参照してください。

インターフェイス コンフィギュレーションの要約の確認

インターフェイス コンフィギュレーションの要約を表示するには、ここに示す手順を実行します。

はじめる前に

この手順を実行する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

show interface { type } { name } brief

指定したインターフェイス コンフィギュレーションに関する要約情報を表示します。

Example:
n1000v# show interface mgmt 0 brief
 
--------------------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
--------------------------------------------------------------------------------
mgmt0 -- up 10.78.1.63 1000 1500
n1000v#
 

インターフェイス コンフィギュレーションの詳細の確認

インターフェイス コンフィギュレーションの詳細を表示するには、ここに示す手順を実行します。

はじめる前に

ここに示すコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

show interface { type } { name }

指定したインターフェイス コンフィギュレーションに関する詳細を表示します。

Example:
n1000v# show interface mgmt 0
mgmt0 is up
Hardware: Ethernet, address: 0050.5689.3321 (bia 0050.5689.3321)
Internet Address is 172.23.232.141/24
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
full-duplex, 1000 Mb/s
Auto-Negotiation is turned on
4961 packets input, 511995 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun, 0 fifo
245 packets output, 35853 bytes
0 underrun, 0 output errors, 0 collisions
0 fifo, 0 carrier errors
 
n1000v#

全インターフェイスの要約の確認

システム上で設定されているすべてのインターフェイスの要約を表示するには、ここに示す手順を実行します。

はじめる前に

この手順を実行する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

show interface brief

システム上の全インターフェイス コンフィギュレーションの要約を表示します。

 

Example:
n1000v# show interface brief
 
--------------------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
--------------------------------------------------------------------------------
mgmt0 -- up 172.23.232.141 1000 1500
 
--------------------------------------------------------------------------------
Ethernet VLAN Type Mode Status Reason Speed Port
Interface Ch #
--------------------------------------------------------------------------------
Eth3/2 1 eth trunk up none 1000(D) --
Eth3/3 262 eth access up none 1000(D) --
--------------------------------------------------------------------------------
Interface VLAN Type Mode Status Reason MTU
--------------------------------------------------------------------------------
Veth81 630 virt access up none 1500
Veth82 630 virt access up none 1500
Veth224 631 virt access up none 1500
Veth225 1 virt access nonPcpt nonParticipating 1500
n1000v#
 

全インターフェイスの実行コンフィギュレーションの確認

システム上の全インターフェイスの実行コンフィギュレーションを表示するには、ここに示す手順を実行します。

はじめる前に

この手順を実行する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

コマンド show running-config interface の出力は、コマンド show interface の出力と異なります。

手順の詳細

 

コマンド
説明

ステップ 1

show running-config interface

システム上の全インターフェイスの実行コンフィギュレーションを表示します。

Example:
n1000v# show running-config interface
version 4.0(1)
 
interface Ethernet3/2
switchport
inherit port-profile sftrunk
 
interface Ethernet3/6
switchport
inherit port-profile vmuplink
 
interface Ethernet6/2
switchport
inherit port-profile alluplink
 
interface mgmt0
ip address 10.78.1.63/24
 
interface Vethernet81
inherit port-profile vm630
 
interface Vethernet82
inherit port-profile vm630
 
interface Vethernet224
inherit port-profile vm631
 
interface Vethernet225
 
n1000v#
 

コンフィギュレーションの保存

実行コンフィギュレーションをスタートアップ コンフィギュレーションに保存するには、ここに示す手順を実行します。これにより、コンフィギュレーション ファイルに変更内容が保存され、次回システムを起動したときに有効になります。

はじめる前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

copy running-config startup-config

新しいコンフィギュレーションを不揮発性ストレージに保存します。これにより、実行コンフィギュレーションとスタートアップ コンフィギュレーションが同じになります。

 

Example:
n1000v(config)# copy run start
[########################################] 100%
n1000v(config)#

コンフィギュレーションの削除

スタートアップ コンフィギュレーションを削除するには、ここに示す手順を実行します。

はじめる前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。


注意 write erase コマンドを実行すると、スタートアップ コンフィギュレーション全体(ローダ機能、ライセンス コンフィギュレーション、および証明書拡張ファイル コンフィギュレーションを除く)が削除されます。

CLI にログインしていること。

このコマンドでは次のパラメータが使用されます。

boot:ブート変数と mgmt0 IP コンフィギュレーションを削除します。

debug:デバッグ コンフィギュレーションを削除します。

手順の詳細

 

コマンド
説明

ステップ 1

write erase [boot | debug]

既存のスタートアップ コンフィギュレーションが完全に削除され、すべての設定が工場出荷時のデフォルトに戻ります。

実行コンフィギュレーションに影響はありません。

 

コンフィギュレーション管理機能の履歴

ここでは、コンフィギュレーション管理機能のリリース履歴を示します。

 

機能名
リリース
機能情報

コンフィギュレーション管理

4.0(4)SV1(1)

この機能が導入されました。