Cisco Nexus 1000V インターフェイス コンフィギュレーション ガイド リリース 4.2(1) SV1(5.1)
ポート チャネルの設定
ポート チャネルの設定
発行日;2012/05/24 | 英語版ドキュメント(2012/01/31 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

ポート チャネルの設定

ポート チャネルについて

ポート チャネル

互換性チェック

ポート チャネルを使ったロード バランシング

LACP

LACP の VEM 管理

ポート チャネル モード

LACP ID パラメータ

LACP マーカー レスポンダ

LACP がイネーブルのポート チャネルとスタティック ポート チャネルの相違点

vPC ホスト モード

サブグループの作成

静的ピン接続

MAC ピン接続

相対的な MAC ピン接続

VPC-HM に対するネットワーク ステート トラッキング

ハイ アベイラビリティ

ポート チャネルの前提条件

注意事項および制約事項

デフォルト設定

ポート チャネルの設定

ポート チャネルのポート プロファイルの作成

1 つのアップストリーム スイッチへの接続

複数のアップストリーム スイッチへの接続

インターフェイス サブグループの手動設定

vEthernet インターフェイスのサブグループへのピン接続

コントロールまたはパケット VLAN のサブグループへのピン接続

チャネル グループのポート プロファイルへの移行

ポート プロファイル内のポート プロファイル タイプの移行

vPC-HM に対するネットワーク ステート トラッキングの設定

インターフェイスでの静的ピン接続の設定

ポート プロファイルからのポート チャネル グループの削除

ポート チャネル インターフェイスのシャットダウンと再起動

ポート チャネル インターフェイスへの説明の追加

ポート チャネル インターフェイスへの速度とデュプレックスの設定

ポート チャネル ロード バランシングの設定

デフォルトのロード バランシング方式の復元

ポート チャネルの LACP の設定

LACP ポート チャネルの設定

LACP の VEM 管理の設定

ポート チャネルの確認

ポート チャネルのモニタリング

ポート チャネルの設定例

設定例:ポート チャネルの作成およびインターフェイスの追加

設定例:LACP ポート チャネルの作成

設定例:vPC-HM に対するネットワーク ステート トラッキングの設定

その他の関連資料

関連資料

標準

ポート チャネルの機能履歴

ポート チャネルについて

ポート チャネルは複数の物理インターフェイスの集合体で、論理インターフェイスを作成します。1 つのポート チャネルに最大 8 つの個別アクティブ リンクをバンドルして、帯域幅と冗長性を向上させることができます。これらの集約された各物理インターフェイス間でトラフィックのロード バランシングも行います。ポート チャネルの物理インターフェイスが少なくとも 1 つ動作していれば、そのポート チャネルは動作しています。

集約プロトコルが関連付けられていない場合でもスタティック ポート チャネルを使用して設定を簡略化できます。

ここでは、次の内容について説明します。

「ポート チャネル」

「互換性チェック」

「ポート チャネルを使ったロード バランシング」

「LACP」

「vPC ホスト モード」

「サブグループの作成」

「静的ピン接続」

「MAC ピン接続」

「VPC-HM に対するネットワーク ステート トラッキング」

ポート チャネル

ポート チャネルは、物理リンクをまとめて 1 つのチャネル グループに入れ、最大 8 つの物理リンクの帯域幅を集約した単一の論理リンクを作ります。ポート チャネルのメンバ ポートが故障すると、それまでに故障したリンクで伝送されたトラフィックはポート チャネルに残っている他のメンバ ポートに切り替えます。

最大 8 つのポートをスタティック ポート チャネルにバンドルできます。集約プロトコルは使用しません。


) デバイスのポート チャネルは Port Aggregation Protocol(PAgP)をサポートしません。


各ポートにはポート チャネルが 1 つだけあります。ポート チャネルのすべてのポートには互換性があり、同じ速度とデュプレックス モードを使用します(「互換性チェック」を参照)。集約プロトコルを使わずにスタティック ポート チャネルを実行する場合、物理リンクはすべて on チャネルモードです。

ポートチャネル インターフェイスを作成すると、ポート チャネルを直接作成できます。またはチャネル グループを作成して個別ポートをバンドルに集約させることができます。インターフェイスをチャネル グループに関連付けると、ポート チャネルがない場合は対応するポート チャネルが自動的に作成されます。この場合、ポート チャネルは最初のインターフェイスのレイヤ 2 設定を行います。最初にポート チャネルを作成することもできます。この場合は、Cisco Nexus 1000Vがポート チャネルと同じチャネル番号の空のチャネル グループを作成してデフォルト レイヤ 2 設定を行い、互換性も設定します(「互換性チェック」を参照)。


) 少なくともメンバ ポートの 1 つがアップしており、そのポートのチャネルが有効であれば、ポート チャネルはアップしています。メンバ ポートがすべてダウンしていれば、ポート チャネルはダウンしています。


互換性チェック

ポート チャネル グループにインターフェイスを追加すると、そのインターフェイスのポート チャネルへの参加が許可される前に、次の互換性チェックが行われます。

ネットワーク層

(リンク)速度性能

速度設定

デュプレックス性能

デュプレックス設定

ポート モード

アクセス VLAN

トランク Native VLAN

タグ付きまたはタグなし

許可 VLAN リスト

MTU サイズ

SPAN:SPAN の始点または宛先ポートは不可

ストーム制御

Cisco Nexus 1000V で実行される互換性チェックの全リストを表示するには、 show port-channel compatibility-parameters を使用します。

チャネル モード セットを on に設定したインターフェイスだけをスタティック ポート チャネルに追加できます。これらの属性は個別のメンバ ポートに設定できます。設定するメンバ ポートの属性に互換性がない場合、Cisco Nexus 1000V はこのポートをポート チャネルで一時停止させます。

または、次のパラメータが同じ場合、パラメータに互換性がないポートを強制的にポート チャネルに参加させることもできます。

(リンク)速度性能

速度設定

デュプレックス性能

デュプレックス設定

インターフェイスがポート チャネルに参加すると、一部のパラメータが削除され、ポート チャネルの値が次のように置き換わります。

帯域幅

遅延

UDP の拡張認証プロトコル

VRF

IP アドレス(v4 および v6)

MAC アドレス

STP

NAC

サービス ポリシー

Quality of Service(QoS)

アクセス コントロール リスト(ACL)

インターフェイスがポート チャネルに参加または脱退しても、次に示すインターフェイス パラメータは影響を受けません。

説明

CDP

MDIX

レート モード

Shutdown

SNMP トラップ


) ポート チャネルを削除すると、すべてのメンバ インターフェイスはポート チャネルから削除されたかのように設定されます。


ポート チャネルを使ったロード バランシング

Cisco Nexus 1000V は、フレームのアドレスを数値にハッシュしてチャネルのリンクを 1 つ選択することで、ポート チャネルのすべての動作インターフェイス間のトラフィックを負荷分散します。ポート チャネルはデフォルトでロード バランシングを備えています。ポート チャネル ロード バランシングでは、MAC アドレス、IP アドレス、またはレイヤ 4 ポート番号を使用してリンクを選択します。ポート チャネル ロードバランシングは、送信元または宛先アドレス、およびポートの両方またはいずれか一方を使用します。

ロード バランシング モードを設定して、デバイス全体または指定したモジュールに設定したすべてのポート チャネルに適用することができます。モジュールごとの設定は、デバイス全体のロード バランシング設定よりも優先されます。デバイス全体に 1 つのロード バランシング モードを、指定したモジュールに別のモードを、さらに別の指定したモジュールに別のモードを設定できます。ポート チャネルごとにロード バランシング方式を設定できません。

使用するロード バランシング アルゴリズムのタイプを設定できます。ロード バランシング アルゴリズムを指定し、フレームのフィールドを見て出力トラフィックに選択するメンバ ポートを決定します。


) デフォルトのロード バランシング方式では、送信元 MAC アドレスを使用します。


次のいずれかの方式を設定して、ポート チャネル全体を負荷分散できます。

宛先 MAC アドレス

送信元 MAC アドレス

送信元および宛先 MAC アドレス

宛先 IP アドレスおよび VLAN

送信元 IP アドレスおよび VLAN

送信元および宛先 IP アドレスおよび VLAN

宛先 Transmission Control Protocol(TCP)/User Datagram Protocol(UDP)ポート番号

送信元 TCP/UDP ポート番号

送信元および宛先 TCP/UDP ポート番号

宛先 IP アドレスおよび TCP/UDP ポート番号

送信元 IP アドレスおよび TCP/UDP ポート番号

送信元および宛先 IP アドレスおよび TCP/UDP ポート番号

宛先 IP アドレス、TCP/UDP ポート番号、および VLAN

送信元 IP アドレス、TCP/UDP ポート番号、および VLAN

送信元および宛先 IP アドレス、TCP/UDP ポート番号、および VLAN

宛先 IP アドレス

送信元 IP アドレス

送信元および宛先 IP アドレス

VLAN のみ

送信元仮想ポート ID

送信元 IP アドレス ロード バランシングを設定する場合、送信元 MAC アドレスを使用してトラフィックをロード バランシングします。宛先 MAC アドレス ロード バランシング方式を設定する場合、宛先 MAC アドレスを使用してトラフィックをロード バランシングします。

ポート チャネルを使用するロード バランシング方式は、マルチキャスト トラフィックには適用されません。設定方式にかかわらず、マルチキャスト トラフィックは、次の方式を使用してポート チャネルをロード バランシングします。

レイヤ 4 情報を持つマルチキャスト トラフィック:送信元 IP アドレス、送信元ポート、宛先 IP アドレス、および宛先ポート

レイヤ 4 情報を持たないマルチキャスト トラフィック:発信元 IP アドレスおよび宛先 IP アドレス

非 IP マルチキャスト トラフィック:発信元 MAC アドレスおよび宛先 MAC アドレス

ポート チャネル ロード バランシングを設定するには、「ポート チャネル ロード バランシングの設定」を参照してください。

LACP

Link Aggregation Control Protocol(LACP)では、最大 16 のインターフェイスを 1 つのポート チャネルに設定できます。最大 8 つのインターフェイスをアクティブにすることができ、最大 8 つのインターフェイスをスタンバイ状態に入れることができます。図 5-1 に、個別リンクを LACP ポート チャネルおよびチャネル グループに組み込み、個別リンクとして機能させる方法を示します。


) ポート チャネルを削除すると、関連するチャネル グループが自動的に削除されます。すべてのメンバ インターフェイスはオリジナルの設定に戻ります。


ここでは、次の内容について説明します。

「LACP の VEM 管理」

「ポート チャネル モード」

「LACP ID パラメータ」

「LACP マーカー レスポンダ」

「LACP がイネーブルのポート チャネルとスタティック ポート チャネルの相違点」

図 5-1 個別リンクをポート チャネルに組み込む

 

LACP の VEM 管理

LACP プロトコルの動作を VSM から VEM にオフロードできます。これにより、VEM が VSM から切断されているときに(ヘッドレス モードと呼ばれます)、VSM によって LACP がアップストリーム スイッチとネゴシエートできない状況が防止されます。LACP の VEM 管理によって、ヘッドレス VEM のリブート後に、ポート チャネルを再確立できるようになります。

ポート チャネル モード

ポート チャネルの個別インターフェイスは、チャネル モードで設定します。スタティック ポート チャネルを集約プロトコルを使用せずに実行すると、チャネル モードは常に on に設定されます。

各チャネルの LACP をイネーブルにするには、各インターフェイスのチャネル モードに active または passive を設定します。チャネル グループにリンクを追加すると、LACP チャネル グループの個別リンクにいずれかのチャネル モードを設定できます。

表 5-1 で、各チャネル モードについて説明します。

 

表 5-1 ポート チャネルの個別リンクのチャネル モード

チャネル モード
説明

passive

LACP モード。ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した LACP パケットには応答しますが、LACP ネゴシエーションは開始しません。

active

LACP モード。ポートをアクティブ ネゴシエーション ステートにします。ポートは LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

on

すべてのスタティック ポート チャネル(LACP を実行していない)がこのモードです。LACP をイネーブルにする前にチャネル モードをアクティブまたはパッシブにしようとすると、デバイス表示はエラー メッセージを表示します。

チャネルで LACP をイネーブルにするには、そのチャネルのインターフェイスでチャネル モードを active または passive に設定します。LACP は、on 状態のインターフェイスとネゴシエートする場合、LACP パケットを受信しないため、そのインターフェイスと個別のリンクを形成します。つまり、LACP チャネル グループには参加しません。

デフォルト ポート チャネル モードは on です。

LACP は、パッシブおよびアクティブ モードの両方でポート間をネゴシエートして、ポート速度やトランキング ステートなどを基準にしてポート チャネルを形成できるかどうかを決定します。パッシブ モードは、リモート システムやパートナーが LACP をサポートするかどうか不明の場合に役に立ちます。

次の例のようにモードに互換性がある場合、ポートの LACP モードが異なれば、ポートは LACP ポート チャネルを形成できます。

active モードのポートは、 active モードの別のポートとともにポート チャネルを正しく形成できます。

active モードのポートは、 passive モードの別のポートとともにポート チャネルを形成できます。

passive モードのポートは、どちらのポートもネゴシエーションを開始しないため、 passive モードの別のポートとともにポート チャネルを形成できません。

on モードのポートは LACP を実行しておらず、 active または passive モードの別のポートとともにポート チャネルを形成できません。

LACP ID パラメータ

ここでは、LACP パラメータについて次の内容を説明します。

「LACP システム プライオリティ」

「LCAP ポート プライオリティ」

「LACP 管理キー」

LACP システム プライオリティ

LACP を実行するどのシステムにも LACP システム プライオリティ値があります。このパラメータのデフォルト値である 32768 をそのまま使用するか、1 ~ 65535 の範囲で値を設定できます。LACP はシステム プライオリティに MAC アドレスを使用してシステム ID を形成します。また、他のデバイスとのネゴシエーション中にもシステム プライオリティを使用します。システム プライオリティ値が大きいほど、プライオリティは低くなります。


LACP のシステム ID は、LACP システム プライオリティ値と MAC アドレスを組み合わせたものです。


LCAP ポート プライオリティ

LACP を使用するように設定されたポートにはそれぞれ LACP ポート プライオリティがあります。デフォルト値である 32768 をそのまま使用するか、1 ~ 65535 の範囲で値を設定できます。LACP はポート プライオリティとポート番号を使用してポート ID を形成します。

また、互換性のあるポートのうち一部を束ねることができない場合に、どのポートをスタンバイ モードにし、どのポートをアクティブ モードにするかを決定するのに、ポート プライオリティを使用します。LACP では、ポート プライオリティ値が大きいほど、プライオリティは低くなります。指定ポートが、より低い LACP プライオリティを持ち、ホット スタンバイ リンクではなくアクティブ リンクとして選択される可能性が最も高くなるように、ポート プライオリティを設定できます。

LACP 管理キー

LACP は、LACP を使用するように設定されたポートごとに、チャネルグループ番号と同じ管理キー値を自動的に設定します。管理キーは、他のポートと集約されるポートの機能を定義します。他のポートと集約されるポート機能は、次の要因によって決まります。

ポートの物理特性。データ レートやデュプレックス性能などです。

ユーザが作成した設定に関する制限事項

LACP マーカー レスポンダ

ポート チャネルを使用すればデータ トラフィックを動的に再配布できます。この再配布により、リンクが削除または追加されたり、ロード バランシング スキームが変更されることもあります。トラフィック フローの途中でトラフィックが再配布されると、フレームの秩序が乱れる可能性があります。

LACP は Marker Protocol を使って、再配布によってフレームが重複したり順番が入れ替わらないようにします。Marker Protocol は、所定のトラフィック フローのすべてのフレームがリモート エンドで正しく受信すると検出します。LACP はポート チャネル リンクごとに Marker PDUS を送信します。リモート システムは、Marker PDU よりも先にこのリンクで受信されたすべてのフレームを受信すると、Marker PDU に応答します。リモート システムは次に Marker Responder を送信します。ポート チャネルのすべてのメンバ リンクの Marker Responder を受信したローカル システムは、トラフィック フローのフレームを正しい順序で再配分します。ソフトウェアは Marker Responder だけをサポートします。

LACP がイネーブルのポート チャネルとスタティック ポート チャネルの相違点

表 5-2 に、LACP がイネーブルのポート チャネルとスタティック ポート チャネルの主な相違点を示します。

 

表 5-2 LACP がイネーブルのポート チャネルとスタティック ポート チャネル

構成
LACP がイネーブルのポート チャネル
スタティック ポート チャネル

適用されるプロトコル

グローバルにイネーブル

N/A

リンクのチャネル モード

次のいずれか。

Active

Passive

On だけ

チャネルを構成する最大リンク数

16

8

vPC ホスト モード

vPC-HM は、クラスタ化されていない複数のアップストリーム スイッチに接続するときにポート チャネルを作成するための方法です。Cisco Nexus 1000V では、ポート チャネルは、それぞれが 1 つのアップストリーム物理スイッチへの 1 つ以上のアップリンクを表すサブグループまたは論理的な小さなポート チャネルに分けられます。

同じ物理スイッチに接続するリンクは、アップストリーム スイッチからの Cisco Discovery Protocol パケットから収集された情報を使用して、自動的に同じサブグループにバンドルされます。また、インターフェイスに特定のサブグループを手動で割り当てることもできます。詳細については、次の手順を参照してください。

「vEthernet インターフェイスのサブグループへのピン接続」(ポート プロファイル上で設定される)

「インターフェイスでの静的ピン接続の設定」(インターフェイス上で設定される)

vPC-HM を使用した場合、VEM 上の各 vEthernet インターフェイスは、ラウンドロビン方式で 2 つのサブグループのうちの 1 つにマッピングされます。vEthernet インターフェイスからのすべてのトラフィックは、割り当てられたサブグループが使用不可でない限り、そのサブグループを使用します。使用不可の場合、vEthernet インターフェイスは残りのサブグループにフェールオーバーします。元のサブグループが再び使用可能になると、トラフィックはそのサブグループに戻されます。その後、各 vEthernet インターフェイスからのトラフィックが、設定されたハッシュ アルゴリズムに基づいて分散されます。

同じサブグループに複数のアップリンクが接続されている場合は、アップストリーム スイッチを、リンクがまとめてバンドルされたポート チャネル内に設定する必要があります。また、そのポート チャネルも channel-group auto mode on で設定する必要があります(アクティブおよびパッシブ モードは LACP を使用します)。

アップストリーム スイッチがポート チャネルをサポートしていない場合は、MAC ピン接続を使用して、各イーサネット ポート メンバを特定のポート チャネル サブグループに割り当てることができます。詳細については、「MAC ピン接続」を参照してください。


) VEM に接続するアップストリーム スイッチ ポートで vPC が設定されている場合は、Cisco Nexus 1000V で vPC-HM を設定しないでください。この場合は、接続を中断するか、またはディセーブルにすることができます。


図 5-2 に、メンバ ポート 1 と 2 をサブグループ ID 0 に、メンバ ポート 3 と 4 をサブグループ ID 1 に割り当てることによる、vPC-HM を使用したトラフィック分離を示します。

図 5-2 vPC-HM によるポート チャネルから複数のアップストリーム スイッチへの接続

 

 

vPC-HM でポート プロファイルを設定するには、「複数のアップストリーム スイッチへの接続」を参照してください。

サブグループの作成

アップストリーム スイッチ上で Cisco Discovery Protocol(CDP)がイネーブルになっている場合、サブグループは、Cisco Discovery Protocol パケットから収集された情報を使用して自動的に作成されます。それ以外の場合は、「インターフェイス サブグループの手動設定」を使用する必要があります。

静的ピン接続

静的ピン接続を使用すると、VEM の背後にある仮想ポートをチャネル内の特定のサブグループにピン接続できます。サブグループ間でのラウンド ロビン方式のダイナミック割り当てを許可する代わりに、スタティック vEthernet インターフェイス、コントロール VLAN、またはパケット VLAN を特定のポート チャネル サブグループに割り当てる(またはピン接続する)ことができます。静的ピン接続では、トラフィックは、指定したサブグループ内のメンバ ポートを通してのみ転送されます。

ネットワークと通信するサブグループを指定するには、次の手順を使用できます。

「vEthernet インターフェイスのサブグループへのピン接続」

「コントロールまたはパケット VLAN のサブグループへのピン接続」

また、「インターフェイスでの静的ピン接続の設定」を使用して、インターフェイス コンフィギュレーション モードで vEthernet インターフェイスをサブグループにピン接続することもできます。

MAC ピン接続

ポート チャネルをサポートしていない複数のアップストリーム スイッチに接続する場合は、MAC ピン接続が推奨設定です。MAC ピン接続では、アップリンクがサーバからスタンドアロン リンクに分割され、MAC アドレスがこれらのリンクにラウンドロビン方式でピン接続されます。これにより、仮想マシンの MAC アドレスが複数のアップストリーム スイッチ インターフェイス上で認識されることがなくなります。そのため、VEM をアップストリーム スイッチに接続するためのアップストリーム設定は必要ありません。

MAC ピン接続では、どのプロトコルにも依存せずにアップストリーム スイッチを区別できるため、その設定はアップストリームのハードウェアや設計には関係しません。

障害が発生した場合、Cisco Nexus 1000V はまず、VEM の MAC アドレスが別のリンク上で学習されるようになることを示す Gratuitous ARP パケットをアップストリーム スイッチに送信します。また、1 秒未満のフェールオーバー時間も可能になります。

図 5-3 に、MAC ピン接続を使用して特定のポート チャネル サブグループに割り当てられた各メンバ ポートを示します。

図 5-3 MAC ピン接続によるポート チャネルから複数のアップストリーム スイッチへの接続

 

相対的な MAC ピン接続

この機能では、ポート チャネルがイーサネット メンバ ポートのサブグループ ID としてポート番号(vmnic 番号)を使用している、MAC ピン接続の既存のアルゴリズムが変更されます。

新しいアルゴリズムでは、ゼロベースの論理的なサブグループ ID がイーサネット メンバ ポートに割り当てられます。ポート番号(vmnic 番号)が最も小さいメンバ ポートにサブグループ ID 0 が割り当てられます。

図 5-4 に、相対的な MAC ピン接続を使用して特定のポート チャネル サブグループに割り当てられた各メンバ ポートを示します。

図 5-4 相対的な MAC ピン接続を使用した複数のアップストリーム スイッチへのポート チャネルの接続

 

VPC-HM に対するネットワーク ステート トラッキング

VPC-HM に対するネットワーク ステート トラッキングは、他の検出方法では失敗したリンク障害を識別し、vPC-HM チャネル サブグループ間のレイヤ 2 接続を確認します。ネットワーク設定に関する問題の検出を目的にしているわけではありません。

ネットワーク ステート トラッキングでは、パケットをトラッキング VLAN にブロードキャストするために、各サブグループ内の 1 つのアップリンク インターフェイスを選択します。トラッキング VLAN は通常、トランク ポートのための最も小さい転送 VLAN であり、混合アクセス ポートのためのプライマリ VLAN です。各サブグループ上のネットワークから戻されたパケットは、連続して欠落したブロードキャストの数としてトラッキングされます。サブグループの欠落ブロードキャストがしきい値を超えると、そのポート チャネルはスプリット モードにあると見なされます。スプリット モードにあるインターフェイスは非アクティブとしてマークされ、トラフィックはアクティブ インターフェイスにピン接続されます。

ポート チャネルがスプリット モードになった時期や回復した時期はシステム メッセージによって示され、インターフェイスがアクティブまたは非アクティブとしてマークされます。

詳細については、「vPC-HM に対するネットワーク ステート トラッキングの設定」を参照してください。

ハイ アベイラビリティ

ポート チャネルは、複数のポートのトラフィックをロード バランシングすることでハイ アベイラビリティを実現します。物理ポートが故障した場合、ポート チャネルのメンバがアクティブであればポート チャネルは引き続き動作します。

ポート チャネルは、ステートフル再起動とステートレス再起動をサポートします。ステートフル再起動はスーパーバイザ切り替え時に発生します。切り替え後、Cisco Nexus 1000Vは実行時の設定を適用します。

ポート チャネルの前提条件

ポート チャネリングには次の前提条件があります。

EXEC モードで Cisco Nexus 1000V にログインしている。

シングル ポート チャネルのすべてのポートが、互換性の要件を満たしていること。互換性の要件の詳細については、「互換性チェック」を参照してください。

物理ポートが 2 つの異なるスイッチに接続されている場合でも、仮想の vPC-HM を使用してポート チャネルを設定できる。

注意事項および制約事項

ポート チャネリングには次の注意事項と制約事項があります。

ポート チャネル内のすべてのポートは同じ Cisco Nexus 1000V モジュール内にある必要があり、Cisco Nexus 1000V モジュール間でポート チャネルを設定できません。

ポート チャネルが互換性の要件を満たして、かつ次の条件のときだけ、複数のアップストリームでポート チャネルを形成することができます。

ホストからのアップリンクが同じアップストリーム スイッチに接続されている。

ホストからの複数のアップストリーム スイッチに接続されているアップリンクが vPC-HM で設定されている。

デバイスに複数のポート チャネルを設定できます。

ポート チャネルを設定した場合、ポート チャネル インターフェイスに適用した設定はポートチャネル メンバ ポートに影響を与えます。メンバ ポートに適用した設定は、設定を適用したメンバ ポートにだけ影響します。

ポート チャネルにポートを追加する前に、ポート セキュリティ情報をそのポートから削除しておく必要があります。同様に、チャネル グループのメンバであるポートにポート セキュリティ情報を追加できません。

ポート チャネル グループに属するポートを PVLAN ポートとして設定できます。

変更した設定をポート チャネルに適用すると、そのポート チャネルのメンバ インターフェイスにもそれぞれ変更が適用されます。

チャネル メンバ ポートを発信元または宛先 SPAN ポートにできません。

リンクを介して inband/AIPC も伝送される場合に LACP をサポートするには、ESX ホストに接続されるポートで次のコマンドを設定する必要があります。

spanning-tree portfast trunk

spanning-tree bpdufilter enable


) 制御トラフィック用に独立した専用の NIC がある場合、これらの設定は不要です。


LACP チャネルを介して inband/AIPC も伝送される場合、2 つのスイッチを接続するリンクが 2 つ以上必要です。

LACP を設定し、アップストリーム スイッチが LACP の一時停止機能を使用している場合は、この機能がディセーブルになっていることを確認してください。詳細については、次に示すようなアップストリーム スイッチのマニュアルを参照してください。

『Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 5.x』

ポート チャネルをサポートしていない 1 つまたは複数のアップストリーム スイッチに接続する場合は、MAC ピン接続が推奨される設定です。MAC ピン接続では、アップリンクがサーバからスタンドアロン リンクに分割され、MAC アドレスがこれらのリンクにラウンドロビン方式でピン接続されます。欠点は、LACP によって提供されるロード シェアリング パフォーマンスを利用できない点です。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

サーバ管理者は、ポート チャネルを使用せずに、1 つの VLAN に複数のアップリンクを割り当てることはできません。1 つ以上の VLAN を共有するポート チャネルまたはポート プロファイルを使用せずに、同じホスト上の複数のアップリンクをプロファイルに割り当てることはサポートされていません。


注意 Cisco Nexus 1000V 上で vPC-HM を設定したときに、その VEM に接続されているアップストリーム スイッチのポート上で vPC も設定されていると、接続の中断が発生する場合があります。

セットアップ ルーチンを使用して、Cisco Nexus 1000V ソフトウェアがすでに設定されている必要があります。詳細については、『 Cisco Nexus 1000V Getting Started Guide, Release 4.2(1)SV1(5.1) 』を参照してください。

Cisco Nexus 1000V は vCenter Server に接続する必要があります。

EXEC モードで CLI にログインしていること。

ポート チャネルを作成すると、関連するチャネル グループが自動的に作成されます。

ポート チャネルに LACP サポートが必要な場合は、そのポート チャネルを設定する前に LACP 機能をイネーブルにしておく必要があります。

ネットワーク ステート トラッキングは、Flex-10 ファブリックからの 1 つの物理リンクが VMkernel には 4 つの Flex-10 NIC(物理 NIC)として認識される HP Virtual Connect でのみサポートされます。詳細については、「VPC-HM に対するネットワーク ステート トラッキング」を参照してください。

デフォルト設定

次の表に、ポート チャネルのデフォルト設定を示します。

 

パラメータ
デフォルト

ポート プロファイル タイプ

vEthernet

ポート プロファイルの管理ステート

すべてのポートがディセーブル

ポート チャネル

管理アップ

LACP

ディセーブル

(注) 以前のリリースから Release 4.2(1)SV1(5.1) にアップグレードしている場合は、LACP はデフォルトでイネーブルになっています。

レイヤ 2 インターフェイスのロード バランシング方式

送信元および宛先 MAC アドレス

モジュールごとのロード バランシング

ディセーブル

チャネル モード

on

LACP オフロード

(LACP 管理から VEM へのオフロード)

イネーブル

(注) 以前のリリースから Release 4.2(1)SV1(5.1) にアップグレードしている場合は、LACP オフロードはデフォルトでディセーブルになっています。

ネットワーク ステート トラッキング:

ブロードキャストの間隔

5 秒

スプリット ネットワーク モードのアクション

再ピン接続

欠落数の最大しきい値

5 秒

ステート

ディセーブル

ポート チャネルの設定

ここでは、次の内容について説明します。

「ポート チャネルのポート プロファイルの作成」

「インターフェイス サブグループの手動設定」

「チャネル グループのポート プロファイルへの移行」

「ポート プロファイル内のポート プロファイル タイプの移行」

「vPC-HM に対するネットワーク ステート トラッキングの設定」

「インターフェイスでの静的ピン接続の設定」

「ポート プロファイルからのポート チャネル グループの削除」

「ポート チャネル インターフェイスのシャットダウンと再起動」

「ポート チャネル インターフェイスへの説明の追加」

「ポート チャネル インターフェイスへの速度とデュプレックスの設定」

「ポート チャネル ロード バランシングの設定」

「デフォルトのロード バランシング方式の復元」

「ポート チャネルの LACP の設定」


) Cisco Nexus 1000V のコマンドは Cisco IOS のコマンドと異なる場合があることに注意してください。


ポート チャネルのポート プロファイルの作成

この項の手順を使用すると、ポート プロファイル内にポート チャネルを定義し、必要に応じて、インターフェイスまたは VLAN サブグループを設定およびピン接続できます。

「1 つのアップストリーム スイッチへの接続」

「複数のアップストリーム スイッチへの接続」

「インターフェイス サブグループの手動設定」

「vEthernet インターフェイスのサブグループへのピン接続」

「コントロールまたはパケット VLAN のサブグループへのピン接続」

1 つのアップストリーム スイッチへの接続

各ポートが同じアップストリーム スイッチに接続されているポート チャネルを設定できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

ポートが複数のアップストリーム スイッチに接続される場合は、「複数のアップストリーム スイッチへの接続」を参照してください。

ポート プロファイルが最初のインターフェイスに割り当てられたときに、チャネル グループ番号が自動的に割り当てられています。

手順の概要

1. configure terminal

2. port-profile [ type { ethernet | vethernet }] name

3. channel-group auto [ mode { on | active | passive } [ sub-group { cdp | manual }] [ mac-pinning [relative]]

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

Example:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

名前付きポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定を後で変更することはできません。デフォルトは vEthernet タイプです。

ポート チャネルを設定するには、ポート プロファイルをイーサネット タイプとして指定します。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server では、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルを Ethernet タイプとして設定すると、VMware 仮想ポートの設定には使用できなくなります。

ステップ 3

channel-group auto [ mode { on | active | passive }] [mac-pinning [relative]]

 

Example:

n1000v(config-port-prof)# channel-group auto mode on

n1000v(config-port-prof)#

 

Example:

n1000v(config-port-prof)# channel-group auto mode on mac-pinning

n1000v(config-port-prof)#

 

Example:

n1000v(config-port-prof)# channel-group auto mode on mac-pinning relative

n1000v(config-port-prof)#

 

ポート プロファイルが最初のインターフェイスに割り当てられたときに一意のポート チャネルが作成され、自動的に割り当てられるポート チャネル グループを定義します。

同じモジュールに属する追加インターフェイスは、それぞれ同じポート チャネルに追加されます。VMware 環境では、各モジュールに対して異なるポート チャネルが作成されます。

mode: ポート チャネル モードを [on]、[active]、または [passive] に設定します([active] および [passive] は LACP を使用します)。

mac-pinning :アップストリーム スイッチがポート チャネルをサポートしていない場合、これは、イーサネット メンバ ポートごとに 1 つのサブグループを自動的に割り当てる必要があることを指定します。

relative :サブグループの番号が 0 から開始され、引き続きサブグループに連続した番号が付けられます。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

Example:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)確認のためにコンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config-port-prof)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、単一のアップストリーム スイッチに接続するポート チャネルを設定する例を示します。

Example:
n1000v# configure terminal
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# channel-group auto mode on
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
description: allaccess4
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on
evaluated config attributes:
channel-group auto mode on
assigned interfaces:
n1000v(config-port-prof)#

複数のアップストリーム スイッチへの接続

複数のアップストリーム スイッチに接続されるポート チャネルを作成できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

ポートを 1 つのアップストリーム スイッチに接続する場合は、「1 つのアップストリーム スイッチへの接続」を参照してください。

ポートを複数のアップストリーム スイッチに接続する場合は、仮想ポート チャネル ホスト モード(vPC-HM)にある VEM 内の物理 NIC で使用されるアップリンク ポート プロファイルを設定できます。

ポート チャネルをサポートしていない複数のアップストリーム スイッチに接続する場合は、MAC ピン接続が推奨設定です。この手順を使用して MAC ピン接続を設定できます。この機能の詳細については、「MAC ピン接続」を参照してください。

チャネル グループ モードが [on] に設定されている必要があります([active] および [passive] モードは LACP を使用します)。

アップストリーム スイッチで CDP が設定されているかどうかを確認する必要があります。

設定されている場合は、そのアップストリーム スイッチからの CDP パケットを使用して、トラフィックを個別に管理するためのアップストリーム スイッチごとのサブグループが自動的に作成されます。

設定されていない場合は、この手順を完了した後、個別のスイッチ上のトラフィック フローを管理するためのサブグループを手動で設定する必要があります。「インターフェイス サブグループの手動設定」を参照してください。


注意 CDP タイマーが 60 秒(デフォルト)に設定されている場合は、接続が最大 60 秒間中断される可能性があります。


注意 ポート チャネルを 2 つの異なるアップストリーム スイッチに接続するときに vPC-HM が設定されていない場合は、Cisco Nexus 1000V の背後にある VM が、ネットワークから不明なユニキャスト、マルチキャスト フラッド、およびブロードキャストの重複したパケットを受信します。

手順の概要

1. configure terminal

2. port-profile [ type { ethernet | vethernet }] name

3. channel-group auto mode on [ sub-group { cdp | manual }] [ mac-pinning [ relative ]]

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

Example:

n1000v(config)# port-profile uplinkProf

n1000v(config-port-prof)#

イーサネット タイプのポート プロファイル(デフォルト)を作成し、そのポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定を後で変更することはできません。デフォルトは vEthernet タイプです。

ポート チャネルを設定するには、ポート プロファイルをイーサネット タイプとして指定します。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server では、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルを Ethernet タイプとして設定すると、VMware 仮想ポートの設定には使用できなくなります。

ステップ 3

channel-group auto mode on [ sub-group { cdp | manual }] [ mac-pinning [ relative ]]

 
 
例:CDP がアップストリーム スイッチで設定されている場合

n1000v(config-port-prof)# channel-group auto mode on sub-group cdp

n1000v(config-port-prof)#

 

 

例:CDP がアップストリーム スイッチで設定されていない場合

n1000v(config-port-prof)# channel-group auto mode on manual

n1000v(config-port-prof)#

 

 

例:アップストリーム スイッチがポート チャネルをサポートしない場合

n1000v(config-port-prof)# channel-group auto mode on mac-pinning

n1000v(config-port-prof)#

 

 

例:相対的な MAC ピン接続

n1000v(config-port-prof)# channel-group auto mode on mac-pinning relative

n1000v(config-port-prof)#

 

 

一意の非対称ポート チャネル(vPC-HM とも呼ばれます)を作成し、ポート プロファイルが最初のインターフェイスに割り当てられたときに、そのポート チャネルを自動的に割り当てます。

同じモジュールに属する追加インターフェイスは、それぞれ同じポート チャネルに追加されます。VMware 環境では、各モジュールに対して異なるポート チャネルが作成されます。

また、次のオプションも定義されます。

mode: ポート チャネル モードを [on] に設定します([active] および [passive] は LACP を使用します)。

sub-group :このチャネル グループを非対称(複数のスイッチに接続されている)として識別します。

cdp :CDP 情報を使用してトラフィック フローを管理するためのサブグループを自動的に作成することを指定します。

manual :サブグループが手動で設定されることを指定します。このオプションは、アップストリーム スイッチで CDP が設定されていない場合に使用します。サブグループを設定するには、「インターフェイス サブグループの手動設定」を参照してください。

mac-pinning :イーサネット メンバ ポートがサブグループ(メンバ ポートあたり 1 つのサブグループ)に自動的に割り当てられることを指定します。このオプションは、アップストリーム スイッチがポート チャネルをサポートしていない場合に使用します。

relative :サブグループの番号が 0 から開始され、引き続きサブグループに連続した番号が付けられます。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

Example:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)確認のためにコンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config-port-prof)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、CDP をサポートしている複数のアップストリーム スイッチに接続するポート チャネルを作成する例を示します。

n1000v(config)# port-profile UpLinkProfile2
n1000v(config-port-prof)# channel-group auto mode on sub-group cdp
n1000v(config-port-prof)# show port-profile name UpLinkProfile2
port-profile UpLinkProfile2
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on sub-group cdp
evaluated config attributes:
channel-group auto mode on sub-group cdp
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 
 

次に、CDP をサポートしていない複数のアップストリーム スイッチに接続するポート チャネルを作成する例を示します。

n1000v(config)# port-profile UpLinkProfile3

n1000v(config-port-prof)# channel-group auto mode on sub-group manual

n1000v(config-port-prof)# exit

n1000v(config)# interface ethernet3/2-3

n1000v(config-if)# sub-group-id 0

n1000v(config-port-prof)# show port-profile name
n1000v(config-port-prof)# show port-profile name UplinkProfile3
port-profile UplinkProfile3
description:
type: ethernet
status: enabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group: UplinkProfile3
max ports: -
inherit:
config attributes:
channel-group auto mode on sub-group manual
evaluated config attributes:
channel-group auto mode on sub-group manual
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 
 

次に、ポート チャネルをサポートしていない複数のアップストリーム スイッチに接続するポート チャネルを作成する例を示します。

n1000v(config)# port-profile UpLinkProfile1
n1000v(config-port-prof)# channel-group auto mode on mac-pinning
n1000v(config-port-prof)# show port-profile name UpLinkProfile1
port-profile UpLinkProfile1
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on mac-pinning
evaluated config attributes:
channel-group auto mode on mac-pinning
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 

インターフェイス サブグループの手動設定

複数のアップストリーム スイッチ上のトラフィック フローを管理するためのポート チャネル サブグループを手動で設定できます。CDP が設定されていない複数のアップストリーム スイッチに接続するポート チャネルに対しては、これを実行する必要があります。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

「複数のアップストリーム スイッチへの接続」を使用して、ポート チャネルに対するポート プロファイルを設定します。

アップストリーム スイッチへのトラフィックのためのインターフェイス範囲とサブグループ ID(0 ~ 31)を把握します。

手順の概要

1. configure terminal

2. interface ethernet range

3. sub-group-id number

4. CDP が設定されていないアップストリーム スイッチに接続されている各ポートについて、ステップ 2 と 3 を繰り返します。

5. show interface ethernet range

6. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet range

 

Example:

n1000v(config)# interface ethernet3/2-3

n1000v(config-if)#

指定したインターフェイス範囲のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

sub-group id number

 

Example:

n1000v(config-if)# sub-group-id 0

n1000v(config-if)#

アップストリーム スイッチのトラフィックを管理するためのサブグループを手動で設定します。

指定できるサブグループ番号は 0 ~ 31 です。

ステップ 4

CDP が設定されていないアップストリーム スイッチに接続された各ポートについて、ステップ 2 およびステップ 3 を繰り返します。

ステップ 5

show interface ethernet range

 

Example:

n1000v(config-if)# show interface ethernet 3/2-3

(任意)確認のためにコンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、4 つの物理ポートがあるモジュール 3 のホストにポート チャネル サブグループを手動で設定する方法の例を示します。アップストリーム スイッチは CDP をサポートしません。イーサネット ポート 3/2 および 3/3 は 1 つのアップストリーム スイッチに接続し、イーサネット ポート 3/4 および 3/5 は別のアップストリーム スイッチに接続します。

n1000v# conf t
n1000v(config)# int eth3/2
n1000v(config-if)# sub-group-id 0
n1000v(config-if)# int eth3/3
n1000v(config-if)# sub-group-id 0
n1000v(config-if)# int eth3/4
n1000v(config-if)# sub-group-id 1
n1000v(config-if)# int eth3/5
n1000v(config-if)# sub-group-id 1
n1000v(config-if)# show running-config interface
. . .
interface Ethernet3/2
inherit port-profile system-uplink-pvlan
sub-group-id 0
interface Ethernet3/3
inherit port-profile system-uplink-pvlan
sub-group-id 0
interface Ethernet3/4
inherit port-profile system-uplink-pvlan
sub-group-id 1
interface Ethernet3/5
inherit port-profile system-uplink-pvlan
sub-group-id 1

vEthernet インターフェイスのサブグループへのピン接続

ポート プロファイル コンフィギュレーションで vEthernet インターフェイスを特定のポート チャネル サブグループにピン接続することができます。


) また、インターフェイス コンフィギュレーションでサブグループを vEthernet インターフェイスにピン接続することもできます。詳細については、「インターフェイスでの静的ピン接続の設定」を参照してください。


はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

vEthernet インターフェイスのサブグループ ID(0 ~ 31)がわかっていること。

手順の概要

1. configure terminal

2. port-profile type vethernet name

3. pinning id subgroup_id [ backup subgroup_id1 ... subgroup_id7 ]

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile type vethernet name

 

Example:

n1000v(config)# port-profile type vethernet PortProfile1

n1000v(config-port-prof)#

指定したプロファイルのポート プロファイル コンフィギュレーション モードを開始します。

ステップ 3

pinning id subgroup_id [ backup subgroup_id1...subgroup_id7 ]

 

Example:

n1000v(config-port-prof)# pinning id 3 backup 4

指定したポート プロファイルについて、vEthernet インターフェイスをポート チャネル サブグループ(0 ~ 31)に割り当て(またはピン接続)します。

backup :オプションで、プライマリ サブグループが使用できない場合に使用される、ピン接続のためのバックアップ サブグループの順序付けられたリストを指定します。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

Example:

n1000v(config-port-prof)# show port-profile PortProfile1

(任意)確認のためにコンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config-port-prof)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、vEthernet ポート プロファイルを作成し、それをポート チャネル サブグループ 3 にピン接続する例を示します。

n1000v# configure terminal
n1000v(config)# port-profile type vethernet PortProfile1
n1000v(config-port-prof)# pinning id 3
n1000v(config-port-prof)# show port-profile name PortProfile1
port-profile PortProfile1
description:
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
pinning id 3
evaluated config attributes:
pinning id 3
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 

 

次に、vEthernet ポート プロファイルを作成し、それをポート チャネル サブグループ 3 とバックアップ サブグループ 4 および 6 にピン接続する例を示します。

n1000v# configure terminal
n1000v(config)# port-profile type vethernet PortProfile1
n1000v(config-port-prof)# pinning id 3 backup 4 6
n1000v(config-port-prof)# show port-profile name PortProfile1
port-profile PortProfile1
description:
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
pinning id 3 backup 4 6
evaluated config attributes:
pinning id 3
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 

コントロールまたはパケット VLAN のサブグループへのピン接続

コントロールまたはパケット VLAN を特定のサブグループにピン接続することができます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

既存のポート プロファイルはシステム ポート プロファイルである必要があります。

ポート プロファイルはイーサネット タイプである必要があります。

コントロールまたはパケット VLAN をピン接続する場合は、その VLAN がすでにポート プロファイル内に存在する必要があります。

コントロール VLAN をピン接続する場合は、そのコントロール VLAN がすでに、ポート プロファイル内のいずれかのシステム VLAN 内に存在する必要があります。

手順の概要

1. configure terminal

2. port-profile name

3. pinning { control-vlan | packet-vlan } subgroup_id

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile name

 

Example:

n1000v(config)# port-profile SystemProfile1

n1000v(config-port-prof)#

名前付きポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。

ステップ 3

pinning { control-vlan | packet-vlan } subgroup_id

 

Example:

n1000v(config-port-prof)# pinning control-vlan 3

n1000v(config-port-prof)#

コントロール VLAN またはパケット VLAN をポート チャネル サブグループ(0 ~ 31)に割り当て(またはピン接続)します。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

Example:

n1000v(config-port-prof)# show port-profile SystemProfile1

(任意)確認のためにコンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config-port-prof)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、コントロール VLAN で静的ピン接続を設定する例を示します。

n1000v# configure terminal
n1000v(config)# port-profile SystemProfile1
n1000v(config-port-prof)# pinning control-vlan 3
n1000v(config-port-prof)# show port-profile SystemProfile1
port-profile SystemProfile1
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: 3
pinning packet-vlan: -
system vlans: 1
port-group: SystemProfile1
max ports: -
inherit:
config attributes:
switchport mode trunk
switchport trunk allowed vlan 1-5
no shutdown
evaluated config attributes:
switchport mode trunk
switchport trunk allowed vlan 1-5
no shutdown
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 
 

次に、パケット VLAN で静的ピン接続を設定する例を示します。

n1000v# configure terminal
n1000v(config)# port-profile SystemProfile1
n1000v(config-port-prof)# pinning packet-vlan 0
n1000v(config-port-prof)# show port-profile name SystemProfile1
port-profile SystemProfile1
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: 0
system vlans: 1
port-group:
max ports: -
inherit:
config attributes:
switchport mode access
switchport access vlan 1
switchport trunk native vlan 1
no shutdown
evaluated config attributes:
switchport mode access
switchport access vlan 1
switchport trunk native vlan 1
no shutdown
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config

 

チャネル グループのポート プロファイルへの移行

チャネル グループをポート プロファイルに移行できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

ホスト サーバ上の vCenter サーバにログインしていること。


ステップ 1 ホストをメンテナンス モードにします。

ステップ 2 次のいずれかを実行します。

分散リソース スケジューリング(DRS)がイネーブルになっている場合は、必ず仮想マシンが他のホストに移行されるまで待ちます。

それ以外の場合は、仮想マシンを手動で移行します。

ステップ 3 すべての仮想マシンが正常に移行されたら、Cisco Nexus 1000V の CLI から、次に示す必要なパラメータを使用して、このホスト上のアップリンク ポートのためのイーサネット タイプの新しいポート プロファイルを作成します。

次のいずれかのコマンドを実行します。

channel-group auto mode active/passive

channel-group auto mode on mac-pinning

既存のポート チャネルでの CLI によるオーバーライド。

ステップ 4 アップリンク スイッチからポート チャネルの設定を削除します。

ステップ 5 ホスト上の vCenter から、ポートを新しいポート プロファイルに移行します。

ステップ 6 ポートが新しいポート チャネルに正常にバンドルされたことを確認します。


) 新しいポート チャネルには新しいポート チャネル ID が割り当てられています。


ステップ 7 古いポート プロファイルからすべてのポートが移行されたら、Cisco Nexus 1000V の CLI から次のコマンドを使用して、メンバが含まれていないポート チャネルを削除します。

no interface port-channel id

ステップ 8 ホストのメンテナンス モードを終了します。

ステップ 9 仮想マシンを移行してこのホストに戻します。

ステップ 10 Cisco Nexus 1000V から次のコマンドを使用して、実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーすることで、リブートや再起動を行っても維持されるように永続的に保存します。

copy running-config startup-config

ステップ 11 アップストリーム スイッチ内にポート チャネル タイプを作成します。詳細については、「ポート チャネルのポート プロファイルの作成」を参照してください。


 

ポート プロファイル内のポート プロファイル タイプの移行

ポート プロファイル内のポート プロファイル タイプを移行するには、既存のポート チャネルを削除した後、ポート チャネルを再作成します。これらのステップでは、この章の他の項に記載されている手順を使用します。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。


ステップ 1 ホストをメンテナンス モードにします。

ステップ 2 次のいずれかを実行します。

分散リソース スケジューリング(DRS)がイネーブルになっている場合は、必ず仮想マシンが他のホストに移行されるまで待ちます。

それ以外の場合は、仮想マシンを手動で移行します。

ステップ 3 すべての仮想マシンが正常に移行されたら、Cisco Nexus 1000V の CLI から、次に示す必要なパラメータを使用して、このホスト上のアップリンク ポートのためのイーサネット タイプの新しいポート プロファイルを作成します。

次のいずれかのコマンドを実行します。

channel-group auto mode active/passive

channel-group auto mode on mac-pinning

既存のポート チャネルでの CLI によるオーバーライド。

ステップ 4 アップストリーム スイッチ内の移行するポート チャネルを削除します。詳細については、「ポート プロファイルからのポート チャネル グループの削除」を参照してください。

ステップ 5 アップストリーム スイッチ内のポート チャネルを削除します。

ステップ 6 Nexus 1000V イーサネット インターフェイスでサブグループ ID を手動で設定します。詳細については、「インターフェイス サブグループの手動設定」を参照してください。


) このステップは、ポート チャネルを手動モードで使用する場合に使用します。


ステップ 7 Nexus 1000v ポート プロファイル内のポート チャネル タイプを変更します。詳細については、「チャネル グループのポート プロファイルへの移行」を参照してください。

ステップ 8 Nexus 1000v ポート プロファイル内のポート チャネル タイプを変更します。詳細については、「1 つのアップストリーム スイッチへの接続」を参照してください。

ステップ 9 ホストのメンテナンス モードを終了します。

ステップ 10 仮想マシンを移行してこのホストに戻します。

ステップ 11 Cisco Nexus 1000V から次のコマンドを使用して、実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーすることで、リブートや再起動を行っても維持されるように永続的に保存します。

copy running-config startup-config

ステップ 12 アップストリーム スイッチ内に、必要なポート チャネル タイプを作成します。詳細については、「ポート チャネルのポート プロファイルの作成」を参照してください。


 

vPC-HM に対するネットワーク ステート トラッキングの設定

ネットワーク ステート トラッキングを設定して、vPC-HM 用に設定されたポート チャネル上のリンク障害を正確に特定することができます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

イネーブルになっていると、ネットワーク ステート トラッキングは、vPC-HM ポート プロファイルが設定されているすべての VEM 上で使用されます。

再ピン接続(デフォルト)を指定しているときに、スプリット ネットワークが検出された場合は、イーサネット インターフェイスが非アクティブ化されるとともに、再びアクティブ化されたイーサネット インターフェイスを含むすべてのインターフェイス間に vEth が再配布されます。以前のピン接続された状態への復元は保証されません。

ネットワーク ステート トラッキングの詳細については、「VPC-HM に対するネットワーク ステート トラッキング」を参照してください。

手順の概要

1. configure terminal

2. track network-state enable

3. (任意)track network-state interval seconds

4. (任意)track network-state split action [repin | log-only]

5. (任意)track network-state threshold miss-count count

6. show network-state tracking config

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

track network-state enable

 

Example:

n1000v(config)# track network-state enable

n1000v(config)#

vPC-HM ポート チャネル内のすべてのインターフェイス上のネットワーク ステート トラッキングをイネーブルにします。

ステップ 3

track network-state interval seconds

 

Example:

n1000v(config)# track network-state interval 8

n1000v(config)#

(任意)トラッキング ブロードキャストが送信される時間間隔(1 ~ 10 秒)と、トラッキング パケットの間隔を指定します。ブロードキャスト間のデフォルトの間隔は 5 秒です。

ステップ 4

track network-state split action [repin | log-only]

 

Example:

n1000v(config)# track network-state split action repin

n1000v(config)#

(任意)スプリット ネットワークが検出された場合に実行されるアクションを指定します。

repin:トラフィックを別のアップリンクにピン接続します (デフォルト)。

no repin:vEth を現在の場所に置いておきます。

ステップ 5

track network-state threshold miss-count count

 

Example:

n1000v(config)# track network-state threshold miss-count 7

n1000v(config)#

(任意)スプリット ネットワークが宣言されるまでに連続して欠落してもかまわないブロードキャストの最大数(3 ~ 7)を指定します。欠落ブロードキャストのデフォルトの数は 5 です。

ステップ 6

show network-state tracking config

 

Example:

n1000v(config)# show network-state tracking config

Tracking mode : disabled

Tracking Interval : 8 sec

Miss count threshold : 7 pkts

Split-network action : repin

n1000v(config)#

 

(任意)確認のために、ネットワーク ステート トラッキングの設定を表示します。

ステップ 7

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、各ブロードキャストの送信間隔が 8 秒、スプリット ネットワークが検出された場合はトラフィックを別のアップリンクに再ピン接続、およびスプリット ネットワークが宣言されるまでの欠落ブロードキャストの最大数が 7 という条件でネットワーク ステート トラッキングを設定する例を示します。

configure terminal
track network-state enable
track network-state interval 8
track network-state split action repin
track network-state threshold miss-count 7
show network-state tracking config

Tracking mode : enabled

Tracking Interval : 8 sec

Miss count threshold : 7 pkts

Split-network action : repin

n1000v(config)#

 

インターフェイスでの静的ピン接続の設定

vEthernet インターフェイス上で静的ピン接続を設定できます。


) また、ポート プロファイル コンフィギュレーションでサブグループを vEthernet インターフェイスにピン接続することもできます。詳細については、「vEthernet インターフェイスのサブグループへのピン接続」を参照してください。


はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

手順の概要

1. configure terminal

2. interface vethernet interface-number

3. pinning id subgroup_id [ backup subgroup_id1 ... subgroup_id7 ]

4. show running-config interface vethernet interface-number

5. module vem module_number execute vemcmd show pinning

6. module vem module_number execute vemcmd show static pinning config

7. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vethernet interface-number

 

Example:

n1000v(config)# interface vethernet 1

n1000v(config-if)#

指定したインターフェイス(1 ~ 1048575)のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

pinning id subgroup_id [ backup subgroup_id1...subgroup_id7 ]

 

Example:

n1000v(config-if)# pinning id 0 backup 1 2

vEthernet インターフェイスを特定のポート チャネル サブグループ(0 ~ 31)に割り当てます(ピン接続します)。

backup :オプションで、プライマリ サブグループが使用できない場合に使用される、ピン接続のためのバックアップ サブグループの順序付けられたリストを指定します。

ステップ 4

show running-config interface vethernet interface-number

 

Example:

n1000v(config-if)# show running-config interface vethernet 1

(任意)指定したインターフェイスのピン接続設定を表示します。

ステップ 5

module vem module_number execute vemcmd show pinning

 

Example:

n1000v(config-if)# module vem 3 execute vemcmd show pinning

(任意)指定した VEM のピン接続設定を表示します。

ステップ 6

module vem module_number execute vemcmd show static pinning config

 

Example:

n1000v(config-if) module vem 3 execute vemcmd show static pinning config

(任意)VSM で設定されているピン接続のサブグループを表示します。

ステップ 7

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、サブグループ ID 0 を vEthernet インターフェイス 1 にピン接続する例を示します。

n1000v(config)# configure terminal
n1000v(config)# interface vethernet 1
n1000v(config-if)# pinning id 0
n1000v(config-if)# show running-config interface vethernet 1
version 4.0(4)SV1(2)
 
interface Vethernet3
service-policy type qos input policy1
pinning id 0
 

n1000v(config-if)# exit

n1000v(config)# exit
n1000v# module vem 3 execute vemcmd show pinning
LTL IfIndex PC_LTL VSM_SGID VEM_SGID Eff_SGID
48 1b040000 304 0 0 0
 

次に、ピン接続のためのバックアップ サブグループを設定した後の出力の例を示します。

n1000v(config-if)# module vem 4 execute vemcmd show static pinning config
LTL IfIndex VSM_SGID Backup_SGID
48 1c0000a0 0, 1,2
50 1c000100 0, 1
 
n1000v(config-if)# copy running-config startup-config
 

ポート プロファイルからのポート チャネル グループの削除

ポート プロファイルからポート チャネル グループを削除できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

手順の概要

1. configure terminal

2. port-profile name

3. no channel-group auto

4. show

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile name

 

Example:

n1000v(config)# port-profile testProf

n1000v(config-port-prof)#

ポート チャネルを削除するポート プロファイルを指定します。

ステップ 3

no channel-group auto

 

Example:

n1000v(config-port-prof)# no channel-group auto

n1000v(config-port-prof)#

指定したポート プロファイル内のすべてのメンバ インターフェイスからチャネル グループの設定を削除します。

ステップ 4

show port-profile name

 

Example:

n1000v(config)# show port-profile testProf

確認のためにコンフィギュレーションを表示します。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

ポート チャネル インターフェイスのシャットダウンと再起動

ポート チャネル インターフェイスをシャットダウンして再起動できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

ポート チャネル インターフェイスをシャットダウンすると、トラフィックは通過しなくなり、インターフェイスは管理上ダウンします。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. shutdown | no shutdown

4. show interface port-channel channel-number

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

Example:

n1000v(config)# interface port-channel 2

n1000v(config-if)

指定したポート チャネル インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

shutdown

 

Example:

n1000v(config-if)# shutdown

インターフェイスをシャットダウンします。トラフィックは通過せず、インターフェイスは管理ダウン状態になります。デフォルトは no shutdown です。

no shutdown

 

Example:

n1000v(config-if)# no shutdown

インターフェイスをアップに戻します。インターフェイスは管理的にアップとなります。操作上の問題がなければ、トラフィックが通過します。デフォルトは no shutdown です。

ステップ 4

show interface port-channel channel-number

 

Example :

n1000v(config-if)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、ポート チャネル 2 のインターフェイスをアップする例を示します。

n1000v# configure terminal
n1000v(config)# interface port-channel 2
n1000v(config-if)# no shutdown

ポート チャネル インターフェイスへの説明の追加

ポート チャネル インターフェイスに説明を追加できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. description string

4. show interface port-channel channel-number

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

Example:

n1000v(config)# interface port-channel 2

n1000v(config-if)

指定されたポート チャネル インターフェイスをインターフェイス コンフィギュレーション モードにします。

channel number に指定できる範囲は 1 ~ 4096 です。ポート チャネルがない場合は、このチャネル グループに関連付けられたポート チャネルが自動的に作成されます。

ステップ 3

description string

 

Example:

n1000v(config-if)# description engineering

説明をポート チャネル インターフェイスに追加します。

string には、英数字で最大 80 文字の説明を指定できます。

(注) スペースを含む説明を引用符で囲む必要はありません。

ステップ 4

show interface port-channel channel-number

 

Example :

n1000v(config-if)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、ポート チャネル 2 に説明を追加する例を示します。

n1000v# configure terminal
n1000v(config)# interface port-channel 2
n1000v(config-if)# description engineering

ポート チャネル インターフェイスへの速度とデュプレックスの設定

ポート チャネル インターフェイスに速度とデュプレックスを設定できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. speed { 10 | 100 | 1000 | auto }

4. duplex { auto | full | half }

5. show interface port-channel channel-number

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

Example:

n1000v(config)# interface port-channel 2

n1000v(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

指定できるチャネル番号は 1 ~ 4096 です。

ステップ 3

speed { 10 | 100 | 1000 | auto }

 

Example:

n1000v(config-if)# speed auto

ポート チャネル インターフェイスの速度を設定します。デフォルトの自動ネゴシエーションは auto です。

ステップ 4

duplex { auto | full | half }

 

Example:

n1000v(config-if)# speed auto

ポート チャネル インターフェイスのデュプレックス モードを設定します。デフォルトの自動ネゴシエーションは auto です。

ステップ 5

show interface port-channel channel-number

 

Example :

n1000v(config-if)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 6

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、ポート チャネル 2 を 100 Mbps に設定する例を示します。

n1000v# configure terminal
n1000v(config)# interface port channel 2
n1000v(config-if)# speed 100

ポート チャネル ロード バランシングの設定

ポート チャネル ロード バランシングを設定できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

ポート チャネル ロード バランシングは、デバイス全体または 1 つのモジュールに対して設定できます。

モジュールベースのロード バランシングは、デバイスベースのロード バランシングに優先します。

デフォルト ロード バランシング方式は、送信元 MAC アドレスです。

ポート チャネル ロード バランシングの詳細については、「ポート チャネルを使ったロード バランシング」を参照してください。

手順の概要

1. configure terminal

2. port-channel load-balance ethernet { dest-ip-port | dest-ip-port-vlan | destination-ip-vlan | destination-mac | destination-port | source-dest-ip-port | source-dest-ip-port-vlan | source-dest-ip-vlan | source-dest-mac | source-dest-port | source-ip-port | source-ip-port-vlan | source-ip-vlan | source-mac | source-port | source-virtual-port-id | vlan-only } [ module module_number ]

3. show port-channel load-balance

4. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-channel load-balance ethernet { dest-ip-port | dest-ip-port-vlan | destination-ip-vlan | destination-mac | destination-port | source-dest-ip-port | source-dest-ip-port-vlan | source-dest-ip-vlan | source-dest-mac | source-dest-port | source-ip-port | source-ip-port-vlan | source-ip-vlan | source-mac | source-port | source-virtual-port-id | vlan-only }

 

Example:

n1000v(config)# port-channel load-balance ethernet source-destination-mac

デバイスまたはモジュールのロード バランス方式を設定します。指定可能なアルゴリズムはデバイスによって異なります。

デフォルトのロード バランシング方式では、送信元 MAC アドレスを使用します。

ステップ 3

show port-channel load-balance

 

Example :

n1000v(config)# show port-channel load-balance

(任意)ポート チャネル ロード バランシング方式を表示します。

ステップ 4

copy running-config startup-config

 

Example:

n1000v(config)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

次に、モジュール 5 のポート チャネルに対して、送信元 IP ロード バランシング方式を設定する例を示します。

n1000v# configure terminal
n1000v(config)# port-channel load-balance ethernet source-ip module 5

デフォルトのロード バランシング方式の復元

デフォルトのロード バランシング方式を復元できます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

手順の概要

1. configure terminal

2. no port-channel load-balance ethernet

3. show port-channel load-balance

4. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no port-channel load-balance ethernet

 

Example:

n1000v(config)# no port-channel load-balance ethernet

デフォルトのロード バランシング方式(送信元 MAC アドレス)に戻します。

ステップ 3

show port-channel load-balance

 

Example :

n1000v(config)# show port-channel load-balance

(任意)ポート チャネル ロード バランシング方式を表示します。

ステップ 4

copy running-config startup-config

 

Example:

n1000v(config)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

ポート チャネルの LACP の設定

ここでは、次の手順について説明します。

「LACP ポート チャネルの設定」

「LACP の VEM 管理の設定」

LACP ポート チャネルの設定

LACP に対する次の要件を設定できます。

ポート チャネルの LACP サポートをイネーブルにします。

個々のポート チャネル リンクを設定して、LACP での動作が許可されるようにします。

LACP のシステム アップリンク ポート プロファイルを設定します。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

デフォルト ポート チャネル モードは on です。

LACP を設定する前に、LACP 機能のサポートがイネーブルになっている必要があります。この手順には、LACP 機能をイネーブルにするためのステップが含まれています。

関連する集約プロトコルを使用せずにポート チャネルを設定すると、リンク両端のすべてのインターフェイスは on チャネル モードを維持します。

LACP ポート チャネル内の個々のリンクの LACP モードは、そのリンクが LACP での動作を許可されていることを示します。

トランク ポートのネイティブ VLAN が定義されています。データには使用されない可能性がありますが、ネイティブ VLAN は LACP ネゴシエーションに使用されます。トラフィックがトランク ポートのネイティブ VLAN に転送されるようにしたい場合は、そのネイティブ VLAN が許可 VLAN リストおよびシステム VLAN リストに含まれている必要があります。

この手順には、VLAN をポート チャネルの許可 VLAN リストとシステム VLAN リストに追加するためのステップが含まれています。

手順の概要

1. configure terminal

2. feature lacp

3. port-profile [ type { ethernet | vethernet }] name

4. vmware port-group [ pg_name ]

5. switchport mode { access | private-vlan { host | promiscuous } | trunk }

6. switchport trunk allowed vlan vlan-id-list

7. channel-group auto [ mode { on | active | passive }] mac-pinning

8. system vlan vlan-id-list

9. state enabled

10. show port-channel summary

11. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature lacp

 

Example:

n1000v(config)# feature lacp

n1000v(config)#

ポート チャネルの LACP サポートをイネーブルにします。

ステップ 3

port-profile [ type { ethernet | vethernet }] name
 
Example:
n1000v(config-if)# port-profile type ethernet system-uplink
n1000v(config-port-prof)#

 

名前付きポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定を後で変更することはできません。デフォルトは vEthernet タイプです。

ポート チャネルを設定するには、ポート プロファイルをイーサネット タイプとして指定します。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server では、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルを Ethernet タイプとして設定すると、VMware 仮想ポートの設定には使用できなくなります。

ステップ 4

vmware port-group [ pg_name ]

 

Example:

n1000v(config-port-prof)# vmware port-group lacp

n1000v(config-port-prof)#

ポート プロファイルを VMware ポート グループとして指定します。

ここで名前を指定しない限り、ポート プロファイルは、同じ名前の VMware ポート グループにマッピングされます。VSM を vCenter サーバに接続すると、ポート グループは、その vCenter サーバ上の仮想スイッチに配信されます。

ステップ 5

switchport mode { access | private-vlan { host | promiscuous } | trunk }

 

Example:

n1000v(config-port-prof)# switchport mode trunk

n1000v(config-port-prof)#

 

インターフェイスの使用方法を指定します。

指定できるポート モードは次のとおりです。

access

private-vlan

host

promiscuous

trunk

トランク ポートは、ネイティブ VLAN に対しては非タグ付きパケットを伝送し、他のすべての VLAN に対してはカプセル化されたタグ付きパケットを伝送します。

ステップ 6

switchport trunk allowed vlan vlan-id-list

 

Example:

n1000v(config-port-prof)# switchport trunk allowed vlan 1-100

n1000v(config-port-prof)#

ポート プロファイルをトランキングとして指定し、そのポート プロファイルへの VLAN アクセスを次のように定義します。

allowed-vlans :ポート上で許可される VLAN ID を定義します。

add :ポート上で許可される VLAN ID のリストに追加する VLAN ID を一覧表示します。

except :ポート上で許可されない VLAN ID を一覧表示します。

remove :ポートからアクセスを削除する VLAN ID を一覧表示します。

all :同時に例外も指定されない限り、すべての VLAN ID がポート上で許可されることを示します。

none :どの VLAN ID もポート上で許可されないことを示します。

許可される VLAN を設定しない場合は、デフォルトの VLAN 1 が許可される VLAN として使用されます。

トラフィックがトランク ポートのネイティブ VLAN に転送されるようにしたい場合は、そのネイティブ VLAN が許可 VLAN リストに含まれている必要があります。

ステップ 7

channel-group auto [ mode { on | active | passive }] mac-pinning

 

Example:

n1000v(config-port-prof)# channel-group auto mode active

n1000v(config-port-prof)#

 

ポート プロファイルが最初のインターフェイスに割り当てられたときに一意のポート チャネルが作成され、自動的に割り当てられるポート チャネル グループを定義します。

同じモジュールに属する追加インターフェイスは、それぞれ同じポート チャネルに追加されます。VMware 環境では、各モジュールに対して異なるポート チャネルが作成されます。

mode: ポート チャネル モードを [on]、[active]、または [passive] に設定します([active] および [passive] は LACP を使用します)。

mac-pinning :アップストリーム スイッチがポート チャネルをサポートしていない場合、これは、イーサネット メンバ ポートごとに 1 つのサブグループを自動的に割り当てる必要があることを指定します。

ステップ 8

system vlan vlan-id-list

 

Example:

n1000v(config-port-prof)# system vlan 1,10,20

n1000v(config-port-prof)#

このポート プロファイルにシステム VLAN を追加します。

トラフィックがトランク ポートのネイティブ VLAN に転送されるようにしたい場合は、そのネイティブ VLAN がシステム VLAN リストに含まれている必要があります。

ステップ 9

state enabled

 

Example:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

ポート プロファイルをイネーブルにし、その設定を割り当てられたポートに適用します。ポート プロファイルが VMware ポート グループである場合、そのポート グループは vCenter サーバ上の vSwitch 内に作成されます。

ステップ 10

show port-channel summary

 

Example:

n1000v(config-if)# show port-channel summary

(任意)ポート チャネルの概要を表示します。

ステップ 11

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

設定例

次に、LACP をイネーブルにしたインターフェイスをチャネル グループ 5 内のイーサネット インターフェイス 1/4 のアクティブ ポート チャネル モードに設定した後、LACP ポート プロファイルを設定する例を示します。

configure terminal
feature lacp
interface ethernet 1/4
channel-group 5 mode active
port-profile type ethernet system-uplink
vmware port-group lacp
switchport mode trunk
switchport trunk allowed vlan 1-100
channel-group auto mode active
system vlan 1,10,20
state enabled
show port-channel summary
copy running-config startup-config

 

LACP の VEM 管理の設定

この手順を使用すると、LACP の管理を VSM から VEM にオフロードできます。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

EXEC モードで CLI にログインしていること。

LACP の管理を VSM から VEM にオフロードした後、そのオフロードを有効にする前に、実行コンフィギュレーションをスタートアップ コンフィギュレーション内に保持して VSM をリロードすること。この手順には、これを実行するためのステップが含まれています。

LACP 管理の VEM へのオフロードが、VSM 上でデフォルトでイネーブルになっていること。


) 以前のリリースからアップグレードした場合は、LACP 管理の VEM へのオフロードはデフォルトでディセーブルになっています。


この機能は、[no] lacp offload コマンドを使用してイネーブルまたはディセーブルにできます。

手順の概要

1. configure terminal

2. [no] lacp offload

3. copy running-config startup-config

4. show lacp offload status

5. reload

6. show lacp offload status

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

n1000v# configure terminal

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

lacp offload

 

Example:

n1000v(config)# lacp offload

Please do a "copy running startup" to ensure the new setting takes effect on next reboot
LACP Offload Status can be verified using "show lacp offload status"
Change in LACP Offload Status takes effect only on the next VSM Reboot
This can potentially cause modules with LACP uplinks to flap

 

n1000v(config)#

 

(任意)LACP 管理を VSM から VEM にオフロードします。

LACP オフロードをイネーブルにする場合は、リロードが必要なことを知らせるメッセージが表示されます。

LACP 管理の VEM へのオフロードは、デフォルトでイネーブルになっています。

(注) 以前のリリースからアップグレードした場合は、LACP 管理の VEM へのオフロードはデフォルトでディセーブルになっています。

ステップ 3

copy running-config startup-config

 

Example:

n1000v(config-if)# copy running-config startup-config

[###############################] 100%

n1000v(config-if)#

(任意)リブート後に永続的な実行コンフィギュレーションを保存し、スタートアップ コンフィギュレーションにコピーして再起動します。

ステップ 4

show lacp offload status

 

Example:

n1000v(config)# show lacp offload status

Current Status : Disabled

Running Config Status : Enabled

Saved Config Status : Enabled

n1000v (config)#

(任意)確認のために、LACP オフロードのステータスを表示します。

(注) 現在のステータスは、リロードされるまでイネーブルに変更されません。

ステップ 5

reload

 

Example:

n1000v (config)# reload
This command will reboot the system. (y/n)? [n] y
2010 Sep 3 11:33:35 n1000v %PLATFORM-2-PFM_SYSTEM_RESET: Manual system restart from Command Line Interface

 

プライマリとセカンダリの両方の VSM をリブートします。

ステップ 6

show lacp offload status

 

Example:

n1000v# show lacp offload status

Current Status : Enabled

Running Config Status : Enabled

Saved Config Status : Enabled

n1000v (config)#

(任意)システム リロードの後、確認のために LACP オフロードのステータスを表示します。

(注) 現在のステータスがイネーブルとして表示されるはずです。

ポート チャネルの確認

次のコマンドを使用すると、ポート チャネルの設定を表示できます。

コマンド出力の詳細については、『 Cisco Nexus 1000V Command Reference, Release 4.2(1)SV1(5.1) 』を参照してください。

コマンド
目的

show feature

LACP などの使用可能な機能と、それらの機能がイネーブルかどうかを表示します。

show interface port-channel channel-number

ポート チャネル インターフェイスのステータスを表示します。

show lacp port-channel [interface port-channel channel-number]

LACP ポート チャネルに関する情報を表示します。

show lacp interface ethernet slot/port

特定の LACP インターフェイスに関する情報を表示します。

show lacp offload status

LACP 管理が VEM にオフロードされているかどうかを表示します。

Enabled:LACP は VEM によって管理されています。

Disabled:LACP は VSM によって管理されています。

show network-state tracking config

確認のために、ネットワーク ステート トラッキングの設定を表示します。

show network - state tracking { module modID | interface channelID }

モジュールまたはインターフェイスのネットワーク ステート トラッキングのステータスを表示します。

show port-channel compatibility-parameters

ポート チャネルに追加するためにメンバ ポート間で同じにするパラメータを表示します。

show port-channel database [ interface port-channel channel-number]

1 つ以上のポート チャネル インターフェイスの集約状態を表示します。

show port-channel load-balance

ポート チャネルで使用するロード バランシングのタイプを表示します。

show port-channel summary

ポート チャネル インターフェイスの概要を表示します。

show port-channel traffic

ポート チャネルのトラフィック統計情報を表示します。

show port-channel usage

使用済みおよび未使用のチャネル番号の範囲を表示します。

show running-config interface ethernet port/slot

指定したイーサネット インターフェイスの実行コンフィギュレーションに関する情報を表示します。

show running-config interface port-channel channel-number

ポート チャネルの実行コンフィギュレーション情報を表示します。

show running-config interface vethernet interface-number

指定した vEthernet インターフェイスの実行コンフィギュレーションに関する情報を表示します。

ポート チャネルのモニタリング

次のコマンドを使用すると、ポート チャネル インターフェイスの設定をモニタできます。

 

コマンド
目的

clear counters interface port-channel channel-number

カウンタをクリアします。

show interface counters [module module ]

入力および出力オクテット ユニキャスト パケット、マルチキャスト パケット、ブロードキャスト パケットを表示します。

show interface counters detailed [all]

入力パケット、バイト、マルチキャストおよび出力パケット、バイトを表示します。

show interface counters errors [module module ]

エラー パケットの数を表示します。

show lacp counters [interface port-channel channel-number]

LACP の統計情報を表示します。

ポート チャネルの設定例

ここでは、次の例について説明します。

「設定例:ポート チャネルの作成およびインターフェイスの追加」

「設定例:LACP ポート チャネルの作成」

「設定例:vPC-HM に対するネットワーク ステート トラッキングの設定」

設定例:ポート チャネルの作成およびインターフェイスの追加

次に、ポート チャネルを作成し、そのポート チャネルに 2 つのレイヤ 2 インターフェイスを追加する例を示します。

configure terminal
interface port-channel 5
interface ethernet 1/4
switchport
channel-group 5 mode active
interface ethernet 1/7
switchport
channel-group 5 mode

設定例:LACP ポート チャネルの作成

次に、LACP をイネーブルにしたインターフェイスをチャネル グループ 5 内のイーサネット インターフェイス 1/4 のアクティブ ポート チャネル モードに設定した後、ポート チャネルの LACP ポート プロファイルを設定する例を示します。

configure terminal
feature lacp
interface ethernet 1/4
channel-group 5 mode active
port-profile type ethernet system-uplink
vmware port-group lacp
switchport mode trunk
switchport trunk allowed vlan 1-100
channel-group auto mode active
system vlan 1,10,20
state enabled
show port-channel summary
copy running-config startup-config

設定例:vPC-HM に対するネットワーク ステート トラッキングの設定

次に、ブロードキャストの送信間隔が 8 秒、スプリット ネットワークが宣言されるまでの欠落ブロードキャストの最大数が 7、およびスプリット ネットワークが検出された場合はトラフィックを別のアップリンクに再ピン接続という条件でネットワーク ステート トラッキングを設定する例を示します。

configure terminal
track network-state enable
track network-state interval 8
track network-state split action repin
track network-state threshold miss-count 7
show network-state tracking config

Tracking mode : enabled

Tracking Interval : 8 sec

Miss count threshold : 7 pkts

Split-network action : repin

n1000v(config)#
 

その他の関連資料

ポート チャネルの実装に関する追加情報については、次の項を参照してください。

「関連資料」

「標準」

関連資料

 

関連項目
参照先

Cisco Nexus 1000V のすべてのコマンドのコマンド構文、コマンド モード、コマンド履歴、デフォルト値、使用上の注意、および例

Cisco Nexus 1000V Command Reference, Release 4.2(1)SV1(5.1)

レイヤ 2 インターフェイスの設定

「レイヤ 2 インターフェイスの設定」

システム管理

『Cisco Nexus 1000V System Management Configuration Guide, Release 4.2(1)SV1(5.1)

リリース ノート

『Cisco Nexus 1000V Release Notes, Release 4.2(1)SV1(5.1)

ポート プロファイル

『Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.2(1)SV1(5.1)

標準

 

標準
タイトル

IEEE 802.3ad

リンク集約

ポート チャネルの機能履歴

ここでは、ポート チャネルの機能履歴を示します。

 

機能名
リリース
機能情報

バックアップ サブグループ

4.2(1)SV1(4a)

プライマリ サブグループをピン接続する場合は、最大 7 つのバックアップ サブグループを割り当てることができます。

ポート チャネルの相対的な番号付け

4.2(1)SV1(4a)

サブグループの番号が 0 から開始され、vmnic 番号には固定されません。

ポート チャネル vPC-HM

4.2(1)SV1(4)

複数のアップストリーム スイッチに接続する場合、インターフェイスの sub-group cdp コマンドがポート チャネル vPC-HM の設定から削除されています。

vPC-HM ポート チャネルに対するネットワーク ステート トラッキング

4.2(1)SV1(4)

vPC-HM 用に設定されたポート チャネル上のリンク障害を正確に特定します。

LACP の VEM 管理

4.2(1)SV1(4)

LACP の管理を VSM から VEM にオフロードします。

LACP ポート チャネル機能のイネーブル化

4.2(1)SV1(4)

LACP ポート チャネルのサポートをイネーブルにするための feature lacp コマンドが追加されました。以前は、LACP が自動的にイネーブルになっていました。

vPC ホスト モード

4.0(4)SV1(2)

サブグループの手動作成をサポートします。

静的ピン接続

4.0(4)SV1(2)

特定のポート チャネル サブグループへの vEthernet インターフェイスの割り当て(ピン接続)をサポートします。

ポート チャネル

4.0(4)SV1(1)

この機能が導入されました。