Cisco Nexus 1000V System Management コン フィギュレーション ガイド リリース 4.0(4)SV1(3)
サーバ接続の管理
サーバ接続の管理
発行日;2012/02/02 | 英語版ドキュメント(2011/04/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

サーバ接続の管理

サーバ接続について

vCenter Server への接続

vCenter Server からの切断

vCenter Server からの DVS の削除

ホスト マッピングの設定

ホスト マッピングについて

モジュールからのホスト マッピングの削除

新しいホストへのマッピング

ホスト マッピングの表示

接続の確認

ドメインの確認

コンフィギュレーションの確認

モジュール情報の確認

サーバ接続機能の履歴

サーバ接続の管理

この章では、接続を確立してサーバに接続する方法、サーバから切断する方法、およびサーバ接続を表示する方法について説明します。

この章では、次の内容について説明します。

「サーバ接続について」

「vCenter Server への接続」

「vCenter Server からの切断」

「ホスト マッピングの設定」

「接続の確認」

「ドメインの確認」

「コンフィギュレーションの確認」

サーバ接続について

vCenter Server または ESX サーバに接続するには、初めに接続を Cisco Nexus 1000V の中で定義する必要があります。この定義には、次の項目が含まれます。

接続名

使用するプロトコル

サーバの IP アドレス

サーバの DNS 名

データセンター名

vCenter Server との通信はすべて、TLS プロトコルによってセキュリティが維持されます。

vCenter Server への接続

この手順を使用して、接続を設定して、vCenter Server または ESX サーバに接続します。

始める前に

EXEC モードで CLI にログインします。

データセンター名がわかっている必要があります。

vCenter Server 管理ステーションをインストールして実行します。

vCenter Server の IP アドレスまたはホスト名がわかっている必要があります。

ESX サーバをインストールして実行します。

管理ポートを設定します。

Cisco Nexus 1000V から vCenter Server にアクセスできるようにします。

Cisco Nexus 1000V アプライアンスをインストールします。

ホスト名を使用して接続を設定している場合は、DNS はすでに設定済みです。

拡張ファイルが vCenter Server に登録済みであることが必要です。この拡張ファイルには、VSM 用の拡張キーとパブリック証明書が格納されています。これらは、vCenter Server が VSM から受信した要求の真正性を検証するために使用されます。拡張ファイルの追加および登録の手順については、『 Cisco Nexus 1000V Software Installation Guide, Release 4.0(4)SV1(3) 』を参照してください。

手順の概要

1. config t

2. svs connection name

3. protocol vmware-vim

4. remote {ip address address A.B.C.D | hostname name}

5. vmware dvs datacenter-name name

6. connect

手順の詳細

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

svs connection name

 

例:

n1000v (config#) svs connection VC

n1000v(config-svs-conn#)

Cisco Nexus 1000V と特定の ESX サーバまたは vCenter Server 間にこの接続を追加するための、接続コンフィギュレーション モードに切り替えます。名前を使用して、複数接続情報をコンフィギュレーションに格納できます。

ステップ 3

protocol vmware-vim [http]

 

例:

n1000v(config-svs-conn#) protocol vmware-vim

n1000v(config-svs-conn#)

この接続が VIM プロトコルを使用するように指定します。このコマンドはローカルに格納されます。

http:VIM プロトコルが HTTP で実行されるように指定します。デフォルトでは HTTP over SSL(HTTPS)を使用します。

次のいずれかを実行します。

IP アドレスを設定している場合は、ステップ 4 に進んでください。

ホスト名を設定している場合は、ステップ 5 に進んでください。

ステップ 4

remote ip address ipaddress

 

例:

n1000v(config-svs-conn#) remote ip address 192.168.0.1

n1000v(config-svs-conn#)

 

ステップ 6 に進んでください。

この接続で使用する ESX サーバまたは vCenter Server の IP アドレスを指定します。このコマンドはローカルに格納されます。

ステップ 5

remote hostname hostname

 

例:

n1000v(config-svs-conn#) remote hostname vcMain

n1000v(config-svs-conn#)

この接続で使用する ESX サーバまたは vCenter Server の DNS 名を指定します。このコマンドはローカルに格納されます。

(注) DNS はすでに設定されています。

ステップ 6

vmware dvs datacenter-name name

 

例:

n1000v(config-svs-conn#) vmware dvs datacenter-name Hamilton-DC

n1000v(config-svs-conn#)

Cisco Nexus 1000V が Distributed Virtual Switch(DVS; 分散仮想スイッチ)として作成される vCenter Server のデータセンター名を指定します。接続前または接続後に、このコマンドを使用できます。データセンター名はローカルに格納されます。

ステップ 7

connect

 

例:

n1000v(config-svs-conn#) connect

 

接続を開始します。この接続のユーザ名とパスワードが設定されていない場合は、ユーザ名とパスワード入力プロンプトが表示されます。

デフォルトは no connect です。一度にアクティブにできる接続は 1 つだけです。以前に定義した接続が確立している場合は、no connect を入力して以前の接続を終了するまでは、エラー メッセージが表示され、コマンドは拒否されます。

例:

n1000v# config t

n1000v (config)# svs connection VC

n1000v(config-svs-conn#) protocol vmware-vim

n1000v(config-svs-conn#) remote ip address 192.168.0.1

n1000v(config-svs-conn#) vmware dvs datacenter-name Hamilton-DC

n1000v(config-svs-conn#) connect
 
 
n1000v# show svs connections
connection VC:
ip address: 192.168.0.1
protocol: vmware-vim https
certificate: default
datacenter name: Hamilton-DC
DVS uuid: ac 36 07 50 42 88 e9 ab-03 fe 4f dd d1 30 cc 5c
config status: Enabled
operational status: Connected
n1000v#
 
 

vCenter Server からの切断

この手順を使用して、vCenter Server 設定の修正後などに vCenter Server から切断します。

始める前に

EXEC モードでCisco Nexus 1000V にログインします。

「vCenter Server への接続」を参照して、Cisco Nexus 1000V 接続を設定します。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

svs connection name

 

例:

n1000v (config#) svs connection vcWest

n1000v(config-svs-conn)#

vCenter Server に接続するために、CLI グローバル コンフィギュレーション サブモードに切り替えます。

ステップ 3

no connect

 

例:

n1000v(config-svs-conn)# no connect
n1000v(config-svs-conn)#

接続を終了します。

vCenter Server からの DVS の削除

この手順を使用して、vCenter Server から DVS を削除します。

始める前に

EXEC モードで CLI にログインします。

「vCenter Server への接続」を参照して、接続を設定します。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

Server Administrator をCisco Nexus 1000V に接続しているすべてのホストの VI クライアントから削除しておきます。詳細については、VMware のマニュアルを参照してください。

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

svs connection name

 

例:

n1000v(config#) svs connection vcWest

n1000v(config-svs-conn)#

vCenter Server に接続するために、CLI グローバル コンフィギュレーション サブモードに切り替えます。

ステップ 3

no vmware dvs

 

例:

n1000v(config-svs-conn)# no vmware dvs

n1000v(config-svs-conn)#

指定された接続に関連付けられている DVS を vCenter Server から削除します。

ホスト マッピングの設定

ここでは、次の内容について説明します。

「ホスト マッピングについて」

「モジュールからのホスト マッピングの削除」

「新しいホストへのマッピング」

「ホスト マッピングの表示」

ホスト マッピングについて

VSM によって新しい VEM が検出されると、空きモジュール番号が自動的にその VEM に割り当てられ、このモジュール番号がホスト サーバの UUID にマッピングされます。このマッピングによって、同じホスト サーバには同じモジュール番号が割り当てられるようになります。

モジュールからのホスト マッピングの削除

ここでは、モジュールからホスト サーバへのマッピングを削除する手順を説明します。

始める前に

EXEC モードで CLI にログインしている必要があります。

ホストはすでに vCenter 上の Cisco Nexus 1000V DVS から削除されている必要があります。

手順の概要

1. config t

2. no vem module-number

3. show module vem mapping

4. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

no vem module-number

 

例:

n1000v(config)# no vem 4

n1000v(config)# no vem 3

cannot modify slot 3: host module is inserted

n1000v((config)#

指定されたモジュールをソフトウェアから削除します。

(注) モジュールがまだスロット内に存在している場合は、この例で示すように、コマンドは拒否されます。

ステップ 3

show module vem mapping

(任意)モジュールからホスト サーバへのマッピングを表示します。

例:

n1000v(config)# show module vem mapping

Mod Status UUID License Status

--- ----------- ------------------------------------ --------------

3 powered-up 93312881-309e-11db-afa1-0015170f51a8 licensed

n1000v(config)#

ステップ 4

copy running-config startup-config

 

例:

n1000v(config-vem-slot)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

新しいホストへのマッピング

ここでは、モジュール番号を別のホスト サーバ UUID にマッピングする手順を説明します。

始める前に

EXEC モードで CLI にログインしている必要があります。

ホストはすでに vCenter 上の Cisco Nexus 1000V DVS から「モジュールからのホスト マッピングの削除」を使用して削除されている必要があります。


) 最初に既存のホスト サーバ マッピングを削除しなかった場合は、新しいホスト サーバに別のモジュール番号が割り当てられます。


手順の概要

1. config t

2. vem module number

3. host vmware id server-bios-uuid

4. show module vem mapping

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

vem module number

 

例:

n1000v(config)# vem 3

n1000v((config-vem-slot)#

CLI VEM スロット コンフィギュレーション モードを開始します。

ステップ 3

host vmware id server-bios-uuid

 

例:

n1000v(config-vem-slot)# host vmware id 6dd6c3e3-7379-11db-abcd-000bab086eb6

n1000v(config-vem-slot)#

指定したモジュールに別のホスト サーバ UUID を割り当てます。

ステップ 4

show module vem mapping

(任意)モジュールからホスト サーバへのマッピングを表示します。

例:

n1000v(config-vem-slot)# show module vem mapping

Mod Status UUID License Status

--- ----------- ------------------------------------ --------------

3 powered-up 93312881-309e-11db-afa1-0015170f51a8 licensed

4 absent 6dd6c3e3-7379-11db-abcd-000bab086eb6 licensed

 

n1000v(config-vem-slot)#

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-vem-slot)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

ホスト マッピングの表示

ここでは、モジュールからホスト サーバへのマッピングを表示する手順を説明します。この手順は、EXEC モードで実行します。


ステップ 1 show module vem mapping

例:

n1000v(config)# show module vem mapping

Mod Status UUID License Status

--- ----------- ------------------------------------ --------------

3 powered-up 93312881-309e-11db-afa1-0015170f51a8 licensed

n1000v(config)#


 

接続の確認

ここでは、接続を表示して確認する手順を説明します。

始める前に

任意のコマンド モードで CLI にログインします。

「vCenter Server への接続」を参照して、接続を設定します。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

手順の詳細

 

コマンド
説明

ステップ 1

show svs connections [name]

 

例:

n1000v# show svs connections vc
Connection vc:
IP address: 172.28.15.206
Protocol: vmware-vim https
vmware dvs datacenter-name: HamiltonDC
ConfigStatus: Enabled
OperStatus: Connected
n1000v#

現在のCisco Nexus 1000V への接続を表示します。

(注) ネットワーク接続の問題により、vCenter Server への接続がシャットダウンされる場合があります。ネットワーク接続が復元しても、Cisco Nexus 1000V では自動的に接続は復元されません。この場合、次のコマンド シーケンスを使用して、手動で接続を復元する必要があります。

no connect
connect

 

ドメインの確認

ここでは、設定済みのドメインを表示して確認する手順を説明します。

始める前に

任意のコマンド モードで CLI にログインします。

「ドメインの作成」を参照して、ドメインを設定します。

手順の詳細

 

コマンド
説明

ステップ 1

show svs domain

 

例:

n1000v# show svs domain
SVS domain config:
Domain id: 98
Control vlan: 70
Packet vlan: 71
Sync state: -
 
n1000v#

Cisco Nexus 1000V で設定されたドメインを表示します。

 

 

コンフィギュレーションの確認

ここでは、実行コンフィギュレーションを表示して確認する手順を説明します。

始める前に

任意のコマンド モードで CLI にログインします。

「vCenter Server への接続」を参照して、Cisco Nexus 1000V 接続を設定します。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

手順の詳細

 

コマンド
説明

ステップ 1

show running-config

現在の設定を表示します。

Cisco Nexus 1000V が vCenter Server または ESX サーバに接続していない場合は、接続関連情報だけが出力されます。

例:

n1000v(config-acl)# show running-config
version 4.0(4)SV1(1)
feature port-security
username adminbackup password 5 $1$Oip/C5Ci$oOdx7oJSlBCFpNRmQK4na. role network-operator
username admin password 5 $1$N1mX5tLD$daXpuxlAPcIHoz53PBhy6/ role network-admin
telnet server enable
ssh key rsa 1024 force
kernel core target 0.0.0.0
kernel core limit 1
system default switchport
ip access-list my66
10 permit ip 1.1.1.1/32 1.1.1.2/32
snmp-server user admin network-admin auth md5 0x90f3798f3e894496a11ec42ce2efec9c priv 0x90f3798f3e894496a11ec42ce2efec9c localizedkey
snmp-server enable traps entity fru
snmp-server enable traps license
vrf context management
ip route 0.0.0.0/0 172.28.15.1
switchname srini-cp
vlan 40-43,45-48
vdc srini-cp id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 32
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 32 maximum 256
limit-resource u6route-mem minimum 16 maximum 256
 
interface Ethernet6/2
inherit port-profile uplinkportprofile1
 
interface Ethernet6/3
inherit port-profile uplinkportprofile2
 
interface Ethernet6/4
inherit port-profile uplinportprofile3
 
interface Ethernet7/2
inherit port-profile uplinkportprofile1
 
interface mgmt0
ip address 172.28.15.163/24
 
interface Vethernet1
inherit port-profile vm100
 
interface Vethernet2
inherit port-profile vm100
 
interface Vethernet3
inherit port-profile vm100
 
interface Vethernet4
inherit port-profile vm100
 
interface Vethernet5
 
interface Vethernet6
boot kickstart bootflash:/svs-kickstart-mzg.4.0.1a.S1.0.82.bin sup-1
boot system bootflash:/svs-mzg.4.0.1a.S1.0.82.bin sup-1
boot system bootflash:/isan.bin sup-1
boot kickstart bootflash:/svs-kickstart-mzg.4.0.1a.S1.0.82.bin sup-2
boot system bootflash:/svs-mzg.4.0.1a.S1.0.82.bin sup-2
boot system bootflash:/isan.bin sup-2
ip route 0.0.0.0/0 172.28.15.1
port-profile uplinkportprofile1
capability uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 1,40-43
no shutdown
system vlan 1,40-43
state enabled
port-profile vm100
vmware port-group
switchport mode access
switchport access vlan 43
ip port access-group my100 out
ip port access-group my66 in
no shutdown
state enabled
port-profile uplinkportprofile2
capability uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 45-46
no shutdown
state enabled
port-profile uplinportprofile3
capability uplink
vmware port-group
switchport trunk allowed vlan 47-48
state enabled
port-profile uplinkportprofile3
no shutdown
svs-domain
domain id 163
control vlan 41
packet vlan 42
svs connection VCR5
protocol vmware-vim
remote ip address 172.28.30.83
vmware dvs datacenter-name cisco-DC
connect
n1000v(config-acl)#

モジュール情報の確認

ここでは、モジュール情報を表示して確認する手順を説明します。この情報には、Cisco Nexus 1000V からの DVS のビューも含まれます。

始める前に

任意のコマンド モードで CLI にログインします。

「vCenter Server への接続」を参照して、Cisco Nexus 1000V 接続を設定します。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

Server Administrator で、Cisco Nexus 1000V を実行しているホストを、vCenter Server の DVS に追加しておきます。

手順の概要

1. show module

2. show server-info

3. show interface brief

4. show interface virtual

手順の詳細

 

コマンド
説明

ステップ 1

show module

 
例:
n1000v# show module

モジュール情報を表示します。

ステップ 2

show server_info

 
例:
n1000v# show server_info

サーバ情報を表示します。

ステップ 3

show interface brief

 
例:
n1000v# show interface brief

インターフェイス情報を表示します。vCenter Server へのアップリンクも表示されます。

ステップ 4

show interface virtual

 
例:
n1000v# show interface virtual

仮想インターフェイス情報を表示します。

 

n1000v# show module
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ------------------ ------------
1 1 Virtual Supervisor Module Nexus1000V active *
2 48 Virtual Ethernet Module ok
3 48 Virtual Ethernet Module ok
 
Mod Sw Hw World-Wide-Name(s) (WWN)
--- -------------- ------ --------------------------------------------------
1 4.0(0)S1(0.82) 0.0 --
2 NA 0.0 --
3 NA 0.0 --
 
Mod MAC-Address(es) Serial-Num
--- -------------------------------------- ----------
1 00-19-07-6c-5a-a8 to 00-19-07-6c-62-a8 NA
2 02-00-0c-00-02-00 to 02-00-0c-00-02-80 NA
3 02-00-0c-00-03-00 to 02-00-0c-00-03-80 NA
 
Mod Server-IP Server-UUID Server-Name
--- --------------- ------------------------------------ --------------------
1 172.18.217.180 esx-1
2 172.18.117.44 487701ee-6e87-c9e8-fb62-001a64d20a20 esx-2
3 172.18.217.3 4876efdd-b563-9873-8b39-001a64644a24 esx-3
 
* this terminal session
 
 
n1000v# show server_info
 
Mod Status UUID
--- ----------- ----
2 powered-up 34303734-3239-5347-4838-323130344654
3 absent 371e5916-8505-3833-a02b-74a4122fc476
4 powered-up 4880a7a7-7b51-dd96-5561-001e4f3a22f9
5 absent 48840e85-e6f9-e298-85fc-001e4f3a2326
6 powered-up eb084ba6-3b35-3031-a6fe-255506d10cd0
n1000v#
 
 
n1000v# show interface brief
 
--------------------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
--------------------------------------------------------------------------------
mgmt0 -- up 172.28.15.211 1000 1500
 
--------------------------------------------------------------------------------
Ethernet VLAN Type Mode Status Reason Speed Port
Interface Ch #
--------------------------------------------------------------------------------
Eth2/2 1 eth trunk up none a-1000(D) --
 
--------------------------------------------------------------------------------
Interface VLAN Type Mode Status Reason MTU
--------------------------------------------------------------------------------
 
 
n1000v# show interface virtual
 
--------------------------------------------------------------------------------
Port Adapter Owner Mod Host
--------------------------------------------------------------------------------
Veth49 R-VM-1 2 mcs-srvr35
 

サーバ接続機能の履歴

ここでは、サーバ接続機能のリリース履歴を示します。

 

機能名
リリース
機能情報

サーバ接続

4.0(4)SV1(1)

この機能が追加されました。