Cisco Nexus 1000V インターフェイス コンフィギュ レーション ガイド リリース 4.0(4)SV1(3)
ポート チャネルの設定
ポート チャネルの設定
発行日;2012/02/04 | 英語版ドキュメント(2011/10/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

ポート チャネルの設定

ポート チャネルについて

ポート チャネル

互換性チェック

ポート チャネルを使ったロード バランシング

LACP

ポート チャネル モード

LACP ID パラメータ

LACP Marker Responder

LACP がイネーブルのポート チャネルとスタティック ポート チャネルの相違点

vPC ホスト モード

CDP または手動方式によるサブグループの作成

静的ピン接続によるインターフェイスの割り当て

ハイ アベイラビリティ

ポート チャネルの前提条件

注意事項および制約事項

デフォルト設定

ポート チャネルの設定

1 つのアップストリーム スイッチに接続するポート チャネルの設定

複数のアップストリーム スイッチに接続するポート チャネルの設定

サブグループの手動での設定

静的ピン接続の設定

ポート チャネルおよびグループの削除

レイヤ 2 ポートをチャネル グループに追加

チャネル グループからのポートの削除

ポート チャネル インターフェイスのシャットダウンと再起動

ポート チャネルの説明の設定

LACP ポート チャネル ポート モードの設定

ポート チャネル インターフェイスへの速度とデュプレックスの設定

フロー制御の設定

ポート チャネル ロード バランシングの設定

デフォルトのロード バランシング方式の復元

ポート チャネル設定の確認

ポート チャネル設定のモニタリング

ポート チャネルの設定例

その他の関連資料

関連資料

標準規格

ポート チャネルの機能履歴

ポート チャネルについて

ポート チャネルは複数の物理インターフェイスの集合体で、論理インターフェイスを作成します。1 つのポート チャネルに最大 8 つの個別アクティブ リンクをバンドルして、帯域幅と冗長性を向上させることができます。ポート チャネルは、これらの物理インターフェイスのトラフィックの負荷分散も行います。ポート チャネルの物理インターフェイスが少なくとも 1 つ動作していれば、そのポート チャネルは動作しています。

集約プロトコルが関連付けられていない場合でもスタティック ポート チャネルを使用して設定を簡略化できます。

ここでは、次の内容について説明します。

「ポート チャネル」

「互換性チェック」

「ポート チャネルを使ったロード バランシング」

「LACP」

「vPC ホスト モード」

ポート チャネル

ポート チャネルは物理リンクをチャネル グループにバンドルして単一の論理リンクを作成し、最大 8 つの物理リンクからなる集約帯域幅を実現します。ポート チャネルのメンバ ポートが故障すると、それまでに故障したリンクで伝送されたトラフィックはポート チャネルに残っている他のメンバ ポートに切り替えます。

最大 8 つのポートをスタティック ポート チャネルにバンドルできます。集約プロトコルは使用しません。


) デバイスのポート チャネルは Port Aggregation Protocol(PAgP)をサポートしません。


各ポートにはポート チャネルが 1 つだけあります。ポート チャネルのすべてのポートには互換性があり、同じ速度とデュプレックス モードを使用します(「互換性チェック」を参照)。集約プロトコルを使わずにスタティック ポート チャネルを実行する場合、物理リンクはすべて on チャネル モードです。

ポート チャネル インターフェイスを作成すると、ポート チャネルを直接作成できます。またはチャネル グループを作成して個別ポートをバンドルに集約させることができます。インターフェイスをチャネル グループに関連付けると、ポート チャネルがない場合は対応するポート チャネルが自動的に作成されます。この場合、ポート チャネルは最初のインターフェイスのレイヤ 2 設定を行います。最初にポート チャネルを作成することもできます。この場合は、Cisco Nexus 1000Vがポート チャネルと同じチャネル番号の空のチャネル グループを作成してデフォルト レイヤ 2 設定を行い、互換性も設定します(「互換性チェック」を参照)。


) 少なくともメンバ ポートの 1 つがアップしており、そのポートのチャネルが有効であれば、ポート チャネルはアップしています。メンバ ポートがすべてダウンしていれば、ポート チャネルはダウンしています。


互換性チェック

ポート チャネル グループにインターフェイスを追加すると、そのインターフェイスのポート チャネルへの参加が許可される前に、次の互換性チェックが行われます。

ネットワーク レイヤ

(リンク)速度性能

速度設定

デュプレックス性能

デュプレックス設定

ポート モード

アクセス VLAN

トランク ネイティブ VLAN

タグ付きまたは非タグ付き

許容 VLAN リスト

MTU サイズ

SPAN:SPAN の始点または宛先ポートは不可

ストーム制御

フロー制御性能

フロー制御設定

Cisco Nexus 1000V で実行される互換性チェックの全リストを表示するには、 show port-channel compatibility-parameters を使用します。

チャネル モード セットを on に設定したインターフェイスだけをスタティック ポート チャネルに追加できます。これらのアトリビュートは個別のメンバ ポートに設定できます。設定するメンバ ポートのアトリビュートに互換性がない場合、Cisco Nexus 1000Vはこのポートをポート チャネルで一時停止させます。

または、次のパラメータが同じ場合、パラメータに互換性がないポートを強制的にポート チャネルに参加させることもできます。

(リンク)速度性能

速度設定

デュプレックス性能

デュプレックス設定

フロー制御性能

フロー制御設定

インターフェイスがポート チャネルに参加すると、一部のパラメータが削除され、ポート チャネルの値が次のように置き換わります。

帯域幅

遅延

UDP の拡張認証プロトコル

VRF

IP アドレス(v4 および v6)

MAC アドレス

STP

NAC

サービス ポリシー

Quality of Service(QoS; サービス品質)

Access Control List(ACL; アクセス コントロール リスト)

インターフェイスがポート チャネルに参加または脱退しても、次に示すインターフェイス パラメータは影響を受けません。

説明

CDP

MDIX

レート モード

シャットダウン

SNMP トラップ


) ポート チャネルを削除すると、すべてのメンバ インターフェイスはポート チャネルから削除されたかのように設定されます。


ポート チャネルを使ったロード バランシング

Cisco Nexus 1000Vは、フレームのアドレスを数値にハッシュしてチャネルのリンクを 1 つ選択することで、ポート チャネルのすべての動作インターフェイス間のトラフィックを負荷分散します。ポート チャネルはデフォルトでロード バランシングを備えています。ポート チャネル ロード バランシングでは、MAC アドレス、IP アドレス、またはレイヤ 4 ポート番号を使用してリンクを選択します。ポート チャネル ロード バランシングは、送信元または宛先アドレス、およびポートの両方またはいずれか一方を使用します。

ロード バランシング モードを設定して、デバイス全体または指定したモジュールに設定したすべてのポート チャネルに適用することができます。モジュールごとの設定は、デバイス全体のロード バランシング設定よりも優先されます。デバイス全体に 1 つのロード バランシング モードを、指定したモジュールに別のモードを、さらに別の指定したモジュールに別のモードを設定できます。ポート チャネルごとにロード バランシング方式を設定できません。

使用するロード バランシング アルゴリズムのタイプを設定できます。ロード バランシング アルゴリズムを指定し、フレームのフィールドを見て出力トラフィックに選択するメンバ ポートを決定します。


) デフォルトのロード バランシング方式では、送信元 MAC アドレスを使用します。


次のいずれかの方式を設定して、ポート チャネル全体を負荷分散できます。

宛先 MAC アドレス

送信元 MAC アドレス

送信元および宛先 MAC アドレス

宛先 IP アドレスおよび VLAN

送信元 IP アドレスおよび VLAN

送信元および宛先 IP アドレスおよび VLAN

宛先 TCP/UDP ポート番号

送信元 TCP/UDP ポート番号

送信元および宛先 TCP/UDP ポート番号

宛先 IP アドレスおよび TCP/UDP ポート番号

送信元 IP アドレスおよび TCP/UDP ポート番号

送信元および宛先 IP アドレスおよび TCP/UDP ポート番号

宛先 IP アドレス、TCP/UDP ポート番号、および VLAN

送信元 IP アドレス、TCP/UDP ポート番号、および VLAN

送信元および宛先 IP アドレス、TCP/UDP ポート番号、および VLAN

宛先 IP アドレス

送信元 IP アドレス

送信元および宛先 IP アドレス

VLAN のみ

送信元仮想ポート ID

送信元 IP アドレス ロード バランシングを設定する場合、送信元 MAC アドレスを使用してトラフィックを負荷分散します。宛先 MAC アドレス ロード バランシング方式を設定する場合、宛先 MAC アドレスを使用してトラフィックを負荷分散します。

ポート チャネルを使用するロード バランシング方式は、マルチキャスト トラフィックには適用されません。設定方式にかかわらず、マルチキャスト トラフィックは、次の方式を使用してポート チャネルを負荷分散します。

レイヤ 4 情報を持つマルチキャスト トラフィック:送信元 IP アドレス、送信元ポート、宛先 IP アドレス、および宛先ポート

レイヤ 4 情報を持たないマルチキャスト トラフィック:発信元 IP アドレスおよび宛先 IP アドレス

非 IP マルチキャスト トラフィック:発信元 MAC アドレスおよび宛先 MAC アドレス

ポート チャネル ロード バランシングを設定するには、「ポート チャネル ロード バランシングの設定」を参照してください。

LACP

Link Aggregation Control Protocol(LACP)では、最大 16 のインターフェイスを 1 つのポート チャネルに設定できます。最大 8 つのインターフェイスをアクティブに、最大 8 つのインターフェイスをスタンバイ ステートにできます。図 5-1 に、個別リンクを LACP ポート チャネルおよびチャネル グループに組み込み、個別リンクとして機能させる方法を示します。

Cisco Nexus 1000V では、LACP はデフォルトでグローバルにイネーブルです。


) ポート チャネルを削除すると、関連するチャネル グループが自動的に削除されます。すべてのメンバ インターフェイスはオリジナルの設定に戻ります。


ここでは、次の内容について説明します。

「ポート チャネル モード」

「LACP ID パラメータ」

「LACP Marker Responder」

「LACP がイネーブルのポート チャネルとスタティック ポート チャネルの相違点」

図 5-1 個別リンクをポート チャネルに組み込む

 

ポート チャネル モード

ポート チャネルの個別インターフェイスは、チャネル モードで設定します。スタティック ポート チャネルを集約プロトコルを使用せずに実行すると、チャネル モードは常に on に設定されます。

各チャネルの LACP をイネーブルにするには、各インターフェイスのチャネル モードに active または passive を設定します。チャネル グループにリンクを追加すると、LACP チャネル グループの個別リンクにいずれかのチャネル モードを設定できます。

表 5-1 に、チャネル モードの説明を記します。

 

表 5-1 ポート チャネルの個別リンクのチャネル モード

チャネル モード
説明

passive

LACP モード。ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した LACP パケットには応答しますが、LACP ネゴシエーションは開始しません。

active

LACP モード。ポートをアクティブ ネゴシエーション ステートにします。ポートは LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

on

すべてのスタティック ポート チャネル(LACP を実行していない)がこのモードです。LACP をイネーブルにする前にチャネル モードをアクティブまたはパッシブにしようとすると、エラー メッセージが表示されます。

各チャネルの LACP をイネーブルにするには、そのチャネルのインターフェイスのチャネル モードを active または passive に設定します。on ステートの LACP がインターフェイスとネゴシエートしても LACP パケットは受信せず、そのインターフェイスとの個別リンクになります。LACP チャネル グループには参加しません。

デフォルト ポート チャネル モードは on です。

LACP は、passive および active モードの両方でポート間をネゴシエートして、ポート速度やトランキング ステートなどを基準にしてポート チャネルを形成できるかどうかを決定します。passive モードは、リモート システムやパートナーが LACP をサポートするかどうか不明の場合に役に立ちます。

次の例のように、ポートの LACP モードが異なっている場合でも、それらのモードに互換性があれば、ポートは LACP ポート チャネルを形成できます。

active モードのポートは、 active モードの別のポートとともにポート チャネルを正しく形成できます。

active モードのポートは、 passive モードの別のポートとともにポート チャネルを形成できます。

passive モードのポートは、どちらのポートもネゴシエーションを開始しないため、 passive モードの別のポートとともにポート チャネルを形成できません。

on モードのポートは LACP を実行しておらず、 active または passive モードの別のポートとともにポート チャネルを形成できません。

LACP ID パラメータ

ここでは、LACP パラメータについて次の内容を説明します。

「LACP システム プライオリティ」

「LCAP ポート プライオリティ」

「LACP 管理キー」

LACP システム プライオリティ

LACP を実行するどのシステムにも LACP システム プライオリティ値があります。このパラメータのデフォルトの値である 32768 を適用することも、1 ~ 65535 の値を設定することもできます。LACP はシステム プライオリティに MAC アドレスを使用してシステム ID を形成します。また、他のデバイスとのネゴシエーション中にもシステム プライオリティを使用します。システム プライオリティの値が大きいとプライオリティは低くなります。


LACP のシステム ID は、LACP システム プライオリティ値と MAC アドレスを組み合わせたものです。


LCAP ポート プライオリティ

LACP を使用するように設定されたポートにはそれぞれ LACP ポート プライオリティがあります。LACP ポート プライオリティに、デフォルト値である 32768 を適用することも、1 ~ 65535 の値を設定することもできます。LACP はポート番号とともにポート プライオリティを使用して、ポート ID を形成します。

互換性のあるすべてのポートを集約できない制限がある場合、LACP はポート プライオリティを使用して、スタンバイ モードにする必要があるポートを決定し、アクティブ モードにすべきポートを指定します。ポート プライオリティの値が大きいと LACP のプライオリティは低くなります。ポート プライオリティを設定して指定したポートの LACP プライオリティを低くして、ホットスタンバイ リンクではなくアクティブ リンクとして選択されるようにすることができます。

LACP 管理キー

LACP は、LACP を使用するように設定されたポートごとに、チャネルグループ番号と同じ管理キー値を自動的に設定します。管理キーは、他のポートと集約されるポートの機能を定義します。他のポートと集約されるポート機能は、次の要因によって決まります。

ポートの物理特性。データ レートやデュプレックス性能などです。

ユーザが作成した設定に関する制限事項

LACP Marker Responder

ポート チャネルを使用すればデータ トラフィックを動的に再配布できます。この再配布により、リンクが削除または追加されたり、ロード バランシング スキームが変更されることもあります。トラフィック フローの途中でトラフィックが再配布されると、フレームの秩序が乱れる可能性があります。

LACP は Marker Protocol を使って、再配布によってフレームが重複したり順番が入れ替わらないようにします。Marker Protocol は、所定のトラフィック フローのすべてのフレームがリモート エンドで正しく受信されていることを検出します。LACP は ポート チャネル リンクごとに Marker PDU を送信します。リモート システムは、Marker PDU よりも先にこのリンクで受信されたすべてのフレームを受信すると、Marker PDU に応答します。リモート システムは次に Marker Responder を送信します。ポート チャネルのすべてのメンバ リンクの Marker Responder を受信したローカル システムは、トラフィック フローのフレームを正しい順序で再配分します。ソフトウェアは Marker Responder だけをサポートします。

LACP がイネーブルのポート チャネルとスタティック ポート チャネルの相違点

表 5-2 に、LACP がイネーブルのポート チャネルとスタティック ポート チャネルの主な相違点を示します。

 

表 5-2 LACP がイネーブルのポート チャネルとスタティック ポート チャネル

設定
LACP がイネーブルのポート チャネル
スタティック ポート チャネル

プロトコルを適用

グローバルにイネーブル

適用不可

リンクのチャネル モード

次のいずれかです。

Active

Passive

On だけ

チャネルの最大リンク数

16

8

vPC ホスト モード

Virtual Port Channel In Host Mode(vPC-HM)により、ポート チャネルのメンバ ポートを複数のアップストリーム スイッチに接続できます。vPC-HM では、トラフィックを分離するために、ポートをサブグループ(0 ~ 31)にグループ化します。

図 5-2 では、vPC-HM を使用してトラフィックを分離するために、メンバ ポート 1 および 2 をサブグループ ID 0 に割り当て、メンバ ポート 3 および 4 をサブグループ ID 1 に割り当てています。

図 5-2 vPC-HM による複数のアップストリーム スイッチへのポート チャネルの接続

 

 

vPC-HM でインターフェイスを設定するには、「複数のアップストリーム スイッチに接続するポート チャネルの設定」を参照してください。

vPC-HM は、ポート プロファイルで設定することもできます。詳細については、『 Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3) を参照してください。

サブグループの作成方法と、インターフェイスの割り当て方法については、「CDP または手動方式によるサブグループの作成」および 「静的ピン接続によるインターフェイスの割り当て」を参照してください。

CDP または手動方式によるサブグループの作成

アップストリーム スイッチで Cisco Discovery Protocol(CDP; シスコ検出プロトコル)がイネーブルになっている場合、CDP 情報を使用してサブグループを自動的に作成できます。アップストリーム スイッチで CDP がイネーブルになっていない場合、サブグループ ID をイーサネット インターフェイスに割り当てて、サブグループを手動で作成する必要があります。

この設定は、ポート チャネル設定の一部として行うことができます。詳細については、「複数のアップストリーム スイッチに接続するポート チャネルの設定」を参照してください。

静的ピン接続によるインターフェイスの割り当て

静的ピン接続を使用すると、vPC-HM の特定のサブグループに vEthernet インターフェイスを割り当てる(ピン接続する)ことができます。この割り当てにより、vEthernet インターフェイスからのトラフィックを、サブグループ内のメンバ ポート経由に限り転送することが可能となります。この機能では、ポート チャネルのポート メンバに対して、サブグループ ID を手動で設定していることが前提となります。

特定のポート チャネル サブグループに vEthernet インターフェイスをピン接続するには、「静的ピン接続の設定」を参照してください。

ポート プロファイル コンフィギュレーション モードで vEthernet インターフェイスをサブグループにピン接続することもできます。詳細については、『 Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3) を参照してください。

ハイ アベイラビリティ

ポート チャネルは、複数のポートのトラフィックを負荷分散することでハイ アベイラビリティを実現します。物理ポートが故障した場合、ポート チャネルのメンバがアクティブであればポート チャネルは引き続き動作します。

ポート チャネルは、ステートフル再起動とステートレス再起動をサポートします。ステートフル再起動はスーパーバイザ切り替え時に発生します。切り替え後、Cisco Nexus 1000Vは実行時の設定を適用します。

ポート チャネルの前提条件

ポート チャネリングには次の前提条件があります。

EXEC モードで Cisco Nexus 1000V にログインしている。

シングル ポート チャネルのすべてのポートが、互換性の要件を満たしていること。互換性の要件の詳細については、「互換性チェック」を参照してください。

物理ポートが 2 つの異なるスイッチに接続されている場合でも、仮想の vPC-HM を使用してポート チャネルを設定できる。

注意事項および制約事項

ポート チャネリングには次の注意事項と制約事項があります。

モジュール間のポート チャネルはサポートされていません。

ポート チャネルが互換性の要件を満たして、かつ次の条件のときだけ、複数のアップストリームでポート チャネルを形成することができます。

ホストからのアップリンクが同じアップストリーム スイッチに接続されている。

ホストからの複数のアップストリーム スイッチに接続されているアップリンクが vPC-HM で設定されている。

ポート チャネルはポート プロファイルを使用して設定できます。詳細については、『 Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3) を参照してください。

最大 256 のポート チャネルを設定できます。

デバイスに複数のポート チャネルを設定できます。

ポート チャネルを設定した場合、ポート チャネル インターフェイスに適用した設定はポート チャネル メンバ ポートに影響を与えます。メンバ ポートに適用した設定は、設定を適用したメンバ ポートにだけ影響します。

ポート チャネルにポートを追加する前に、ポート セキュリティ情報をそのポートから削除しておく必要があります。同様に、チャネル グループのメンバであるポートにポート セキュリティ情報を追加できません。

ポート チャネル グループに属するポートを PVLAN ポートとして設定できます。

ポート チャネル内のすべてのポートは同じ Cisco Nexus 1000V モジュール内にある必要があり、Cisco Nexus 1000V モジュール間でポート チャネルを設定できません。

変更した設定をポート チャネルに適用すると、そのポート チャネルのメンバ インターフェイスにもそれぞれ変更が適用されます。

チャネル メンバ ポートを発信元または宛先 SPAN ポートにできません。

リンクを介して inband/AIPC も伝送される場合に LACP をサポートするには、ESX ホストに接続されるポートで次のコマンドを設定する必要があります。

spanning-tree portfast trunk

spanning-tree bpdufilter enable


) 制御トラフィック用に独立した専用の NIC がある場合、これらの設定は不要です。


LACP チャネルを介して inband/AIPC も伝送される場合、2 つのスイッチを接続するリンクが 2 つ以上必要です。

デフォルト設定

次の表に、ポート チャネルのデフォルト設定を示します。

 

パラメータ
デフォルト

ポート チャネル

管理アップ

LACP

イネーブル

レイヤ 2 インターフェイスのロード バランシング方式

送信元および宛先 MAC アドレス

モジュールごとのロード バランシング

ディセーブル

チャネル モード

on

ポート チャネルの設定

ここでは、次の内容について説明します。

「1 つのアップストリーム スイッチに接続するポート チャネルの設定」

「複数のアップストリーム スイッチに接続するポート チャネルの設定」

「静的ピン接続の設定」

「ポート チャネルおよびグループの削除」

「レイヤ 2 ポートをチャネル グループに追加」

「チャネル グループからのポートの削除」

「ポート チャネル インターフェイスのシャットダウンと再起動」

「ポート チャネルの説明の設定」

「LACP ポート チャネル ポート モードの設定」

「ポート チャネル インターフェイスへの速度とデュプレックスの設定」

「フロー制御の設定」

「ポート チャネル ロード バランシングの設定」

「デフォルトのロード バランシング方式の復元」


) Cisco Nexus 1000V のコマンドは Cisco IOS のコマンドと異なる場合があることに注意してください。


1 つのアップストリーム スイッチに接続するポート チャネルの設定

この手順を使用すると、メンバ ポートが 1 つのアップストリーム スイッチに接続するポート チャネルを設定できます。


) メンバ ポートが複数のアップストリーム スイッチに接続するポート チャネルを設定するには、「複数のアップストリーム スイッチに接続するポート チャネルの設定」を参照してください。


始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

ポート チャネルを作成すると、関連するチャネル グループが自動的に作成されます。

手順の概要

1. config t

2. interface port-channel channel-number

3. show port-channel summary

4. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

n1000v(config)# interface port-channel 1

n1000v(config-if)#

指定したポート チャネルのインターフェイス コンフィギュレーション モードを開始します。

channel-number に指定できる範囲は 1 ~ 4096 です。チャネル グループがまだ存在しない場合は、すべてのメンバ ポートが同じアップストリーム スイッチに接続するポート チャネル グループとして自動的に作成されます。

ステップ 3

show port-channel summary

 

:

n1000v(config-if)# show port-channel summary

(任意)ポート チャネル設定を表示します。

ステップ 4

copy running-config startup-config

 

例:

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、ポート チャネルを作成する例を示します。

n1000v# config t
n1000v(config)# interface port-channel 1
 

複数のアップストリーム スイッチに接続するポート チャネルの設定

この手順を使用すると、Virtual Port Channel Host Mode(vPC-HM)でポート チャネルを設定できます。

メンバ ポートが 1 つのアップストリーム スイッチに接続するポート チャネルを設定するには、「1 つのアップストリーム スイッチに接続するポート チャネルの設定」を参照してください。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

vPC-HM では、ポート チャネルのメンバ ポートが複数のアップストリーム スイッチに接続し、トラフィックを個別のサブグループで管理する必要があります。

ポート チャネルを作成すると、関連するチャネル グループが自動的に作成されます。

vPC-HM は、 on モードで設定されたポート チャネルに限りサポートされます。vPC-HM は、 active モードおよび passive モードを使用する LACP チャネルに対してはサポートされません。

アップストリーム スイッチで CDP が設定されているかどうかを確認する必要があります。設定されている場合、CDP によってアップストリーム スイッチごとにサブグループが作成され、トラフィックが個別に管理されます。CDP が設定されていない場合は、サブグループを手動で設定して、個別のスイッチ上のトラフィック フローを管理する必要があります。

CDP をデフォルトの CDP タイマー(60 秒)で使用している場合、サービス中とサービス停止中とを連続してアドバタイズするリンクは、サービスに戻るまでに最大で 60 秒かかることがあります。

いずれかのサブグループに複数のメンバ ポートがある場合、アップストリーム スイッチの各サブグループのメンバ ポートに対して、ポート チャネルを設定する必要があります。

ポート チャネルが複数のアップストリーム スイッチに接続するときに vPC-HM が設定されていない場合、Cisco Nexus 1000V の後ろに位置する VM は、不明なユニキャスト フラッド、マルチキャスト フラッド、およびブロードキャストについて、ネットワークから重複したパケットを受信します。

この手順で使用する sub-group コマンドは、ポート チャネル インターフェイスによって継承されるポート プロファイルで指定されたサブグループ設定よりも優先されます。

ポート プロファイルで vPC-HM を設定することもできます。詳細については、『 Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3) を参照してください。

手順の概要

1. config t

2. interface port-channel channel-number

3. 次のいずれかの手順を実行します。

sub-group cdp を入力し、ステップ 8 に進みます。

sub-group manual を入力し、次のステップに進みます。

4. exit

5 . interface ethernet range

6 . sub-group-id number

7. CDP が設定されていないアップストリーム スイッチに接続された各ポート メンバについて、ステップ 5 および 6 を繰り返します。

8 . show port-channel summary

9. show running-config interface ethernet range

10. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

n1000v(config)# interface port-channel 12

n1000v(config-if)#

指定したポート チャネル(1 ~ 4096)のインターフェイス コンフィギュレーション モードを開始します。

チャネル グループがまだ存在しない場合は、すべてのメンバ ポートが同じアップストリーム スイッチに接続するポート チャネル グループとして自動的に作成されます。

ステップ 3

sub-group { cdp | manual }

 

例:

n1000v(config-if)# sub-group cdp

 

例:

n1000v(config-if)# sub-group manual

 

ポート チャネルがホスト モードであることを指定し、トラフィック フローが CDP で管理されるか、手動で作成されたサブグループで管理されるかを指定します。アップストリーム スイッチ上で CDP が設定されていない場合、サブグループを手動で設定する必要があります。

(注) これらのコマンドによる設定は、ポート チャネル インターフェイスによって継承されるポート プロファイルで指定されたサブグループ設定よりも優先されます。

ステップ 4

show port-channel summary

 

:

n1000v(config-if)# show port-channel summary

(任意)ポート チャネル設定を表示します。

ステップ 5

show running-config interface ethernet range

 

例:

n1000v(config-if)# show running-config interface ethernet 3/2-3

(任意)サブグループ ID 設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

サブグループの手動での設定

この手順を使用すると、複数のアップストリーム スイッチ上でトラフィック フローを管理するためのポート チャネル サブグループを手動で設定できます。CDP が設定されていない複数のアップストリーム スイッチに接続するポート チャネルに対しては、これを実行する必要があります。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

「複数のアップストリーム スイッチに接続するポート チャネルの設定」の手順を使用して、ポート チャネルに対するポート プロファイルを設定します。

アップストリーム スイッチへのトラフィックのためのインターフェイス範囲とサブグループ ID(0 ~ 31)を把握します。

手順の概要

1. config t

2. interface ethernet range

3. sub-group-id number

4. CDP が設定されていないアップストリーム スイッチに接続された各ポート について、ステップ 25 およびステップ 3 を繰り返します。

5. show interface ethernet range

6. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet range

 

例:

n1000v(config)# interface ethernet3/2-3

n1000v(config-if)#

指定したインターフェイス範囲のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

sub-group id number

 

例:

n1000v(config-if)# sub-group-id 0

n1000v(config-if)#

アップストリーム スイッチに対するトラフィックを管理するため、手動でサブグループ(0 ~ 31)を設定します。

ステップ 4

CDP が設定されていないアップストリーム スイッチに接続された各ポート について、ステップ 2 およびステップ 3 を繰り返します。

ステップ 5

show interface ethernet range

 

例:

n1000v(config-if)# show interface ethernet 3/2-3

(任意)確認のためにコンフィギュレーションを表示します。

ステップ 6

copy running-config startup-config

 

例:

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、4 つの物理ポートがあるモジュール 3 のホストにポート チャネル サブグループを手動で設定する方法の例を示します。アップストリーム スイッチは CDP をサポートしません。イーサネット ポート 3/2 および 3/3 は 1 つのアップストリーム スイッチに接続し、イーサネット ポート 3/4 および 3/5 は別のアップストリーム スイッチに接続します。

n1000v# conf t
n1000v(config)# int eth3/2
n1000v(config-if)# sub-group-id 0
n1000v(config-if)# int eth3/3
n1000v(config-if)# sub-group-id 0
n1000v(config-if)# int eth3/4
n1000v(config-if)# sub-group-id 1
n1000v(config-if)# int eth3/5
n1000v(config-if)# sub-group-id 1
n1000v(config-if)# show running-config interface
. . .
interface Ethernet3/2
inherit port-profile system-uplink-pvlan
sub-group-id 0
interface Ethernet3/3
inherit port-profile system-uplink-pvlan
sub-group-id 0
interface Ethernet3/4
inherit port-profile system-uplink-pvlan
sub-group-id 1
interface Ethernet3/5
inherit port-profile system-uplink-pvlan
sub-group-id 1

静的ピン接続の設定

この手順を使用すると、vEthernet インターフェイスで静的ピン接続を設定できます。


) 静的ピン接続はポート プロファイルで設定することもできます。詳細については、『Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3)を参照してください。


始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

手順の概要

1. config t

2. interface vethernet interface-number

3. pinning id sub-group_id

4. show running-config interface vethernet interface-number

5. module vem module_number execute vemcmd show pinning

6. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vethernet interface-number

 

例:

n1000v(config)# interface vethernet 1

n1000v(config-if)#

指定したインターフェイス(1 ~ 1048575)のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

pinning id sub-group_id

 

例:

n1000v(config-if)# pinning id 0

vEthernet インターフェイスを特定のポート チャネル サブグループ(0 ~ 31)に割り当てます(ピン接続します)。

ステップ 4

show running-config interface vethernet interface-number

 

例:

n1000v(config-if)# show running-config interface vethernet 1

(任意)指定したインターフェイスのピン接続設定を表示します。

ステップ 5

module vem module_number execute vemcmd show pinning

 

例:

n1000v(config-if)# module vem 3 execute vemcmd show pinning

(任意)指定した VEM のピン接続設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

 

次に、サブグループ ID 0 を vEthernet インターフェイス 1 にピン接続する例を示します。

n1000v(config)# config t
n1000v(config)# interface vethernet 1
n1000v(config-if)# pinning id 0
n1000v(config-if)# show running-config interface vethernet 1
version 4.0(4)SV1(2)
 
interface Vethernet3
service-policy type qos input policy1
pinning id 0
 

n1000v(config-if)# exit

n1000v(config)# exit
n1000v# module vem 3 execute vemcmd show pinning
LTL IfIndex PC_LTL VSM_SGID VEM_SGID Eff_SGID
48 1b040000 304 0 0 0
 
n1000v(config-if)# copy running-config startup-config
 
 

ポート チャネルおよびグループの削除

この手順を使用すると、ポート チャネルを削除して関連するチャネル グループを削除することができます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

ポート チャネルを削除したときのインターフェイス設定の変化の詳細については、「互換性チェック」を参照してください。

手順の概要

1. config t

2. no channel-group channel-number

3. no interface port-channel channel-number

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no channel-group channel-number

 

例:

n1000v(config)# no channel-group port-channel 1

 

インターフェイスからチャネル グループ設定を削除します。

ステップ 3

no interface port-channel channel-number

 

例:

n1000v(config)# no interface port-channel 1

ポート チャネルを削除し、関連するチャネル グループを削除します。

レイヤ 2 ポートをチャネル グループに追加

この手順を使用すると、レイヤ 2 ポートをチャネル グループに追加することができます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

すべてのレイヤ 2 メンバ ポートは、全二重モードで同じ速度で実行されている必要があります。

ポート チャネルがない場合は、チャネル グループを作成するとポート チャネルが自動的に作成されます。


) 特定のインターフェイスを特定のポート チャネルに追加できない場合、エラー メッセージにより互換性の問題が示されます。


手順の概要

1. config t

2. interface ethernet slot/port

3. switchport mode trunk

4. switchport trunk { allowed vlan vlan-id | native vlan-id }

5. channel-group channel- number [ mode { on | active | passive }]

6. show interface type slot/port

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

例:

n1000v(config)# interface ethernet 1/4

n1000v(config-if)

指定インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport mode trunk

 

例:

n1000v(config-if)# switchport mode trunk

(任意)インターフェイスをトランク ポートとして設定します。

ステップ 4

switchport trunk { allowed vlan vlan-id | native vlan-id }

 

例:

n1000v(config-if)# switchport trunk native 3

(任意)トランク ポートに必要なパラメータを設定します。

ステップ 5

channel-group channel-number [ mode { on | active | passive }]

:

n1000v(config-if)# channel-group 5

チャネル グループのポートを変更し、モードを設定します。

channel number channel-number の範囲は 1 ~ 4096 です。ポート チャネルがない場合は、このチャネル グループに関連付けられたポート チャネルが自動的に作成されます。

mode :すべてのスタティック ポート チャネル インターフェイスは on モードに設定されます。

ステップ 6

show interface type slot/port

 

:

n1000v(config-if)# show interface port channel 5

(任意)インターフェイスの内容を表示します。

ステップ 7

copy running-config startup-config

 

例:

n1000v(config)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

 

次に、イーサネット インターフェイス 1/4 をチャネル グループ 5 に追加する例を示します。

n1000v# config t
n1000v(config)# interface ethernet 1/4
n1000v(config-if)# switchport
n1000v(config-if)# channel-group 5

チャネル グループからのポートの削除

この手順を使用すると、ポートをチャネル グループから削除し、ポートを元の設定に戻すことができます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

手順の概要

1. config t

2. no channel-group

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no channel-group

 

例:

n1000v(config)# no channel-group

ポートをチャネル グループから削除し、ポートを元の設定に戻します。

ポート チャネル インターフェイスのシャットダウンと再起動

この手順を使用すると、ポート チャネル インターフェイスをシャットダウンして再起動することができます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

ポート チャネル インターフェイスをシャットダウンすると、トラフィックは通過しなくなり、インターフェイスは管理上ダウンします。

手順の概要

1. config t

2. interface port-channel channel-number

3. shutdown | no shutdown

4. show interface port-channel channel-number

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

n1000v(config)# interface port-channel 2

n1000v(config-if)

指定したポート チャネル インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

shutdown

 

例:

n1000v(config-if)# shutdown

インターフェイスをシャットダウンします。トラフィックは通過せず、インターフェイスは管理ダウン状態になります。デフォルトは no shutdown です。

no shutdown

 

例:

n1000v(config-if)# no shutdown

インターフェイスをアップに戻します。インターフェイスは管理的にアップとなります。操作上の問題がなければ、トラフィックが通過します。デフォルトは no shutdown です。

ステップ 4

show interface port-channel channel-number

 

:

n1000v(config-if)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、ポート チャネル 2 のインターフェイスをアップする例を示します。

n1000v# config t
n1000v(config)# interface port-channel 2
n1000v(config-if)# no shutdown

ポート チャネルの説明の設定

この手順を使用すると、ポート チャネルの説明を設定することができます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

手順の概要

1. config t

2. interface port-channel channel-number

3. description string

4. show interface port-channel channel-number

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

n1000v(config)# interface port-channel 2

n1000v(config-if)

指定されたポート チャネル インターフェイスをインターフェイス コンフィギュレーション モードにします。

channel number に指定できる範囲は 1 ~ 4096 です。ポート チャネルがない場合は、このチャネル グループに関連付けられたポート チャネルが自動的に作成されます。

ステップ 3

description string

 

例:

n1000v(config-if)# description engineering

説明をポート チャネル インターフェイスに追加します。

string には、英数字で最大 80 文字の説明を指定できます。

(注) スペースを含む説明を引用符で囲む必要はありません。

ステップ 4

show interface port-channel channel-number

 

:

n1000v(config-if)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、ポート チャネル 2 に説明を追加する例を示します。

n1000v# config t
n1000v(config)# interface port-channel 2
n1000v(config-if)# description engineering

LACP ポート チャネル ポート モードの設定

この手順を使用すると、LACP ポート チャネルのリンクごとに LACP モードを設定できます。この設定は、リンクが LACP で許容されるかどうかを示します。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

デフォルト ポート チャネル モードは on です。

関連する集約プロトコルを使用せずにポート チャネルを設定すると、リンク両端のすべてのインターフェイスは on チャネル モードを維持します。

手順の概要

1. config t

2. interface interface

3. channel-group number mode { active | on | passive }

4. show port-channel summary

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface

 

 

 

:

n1000v(config)# interface ethernet 1/4

n1000v(config-if)#

設定しているインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

イーサネット ポートの場合、 ethernet slot/port を使用します。 slot はモジュールのスロット番号、 port はポート番号です。

vEthernet ポートの場合、 vethernet interface-number を使用します。 interface-number は 1 ~ 1048575 の番号です。

ステップ 3

channel-group number mode { active | on | passive }

 

例:

n1000v(config-if)# channel-group 5 mode active

 

指定したリンクのポート モードを active または passive に設定します。

関連する集約プロトコルを使用せずにポート チャネルを実行する場合、ポート チャネル モードは常に on です。

デフォルト ポート チャネル モードは on です。

ステップ 4

show port-channel summary

 

例:

n1000v(config-if)# show port-channel summary

(任意)ポート チャネルの概要を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、LACP をイネーブルにしたインターフェイスを、チャネル グループ 5 のイーサネット インターフェイス 1/4 のアクティブ ポート チャネル モードに設定する例を示します。

n1000v# config t
n1000v (config)# interface ethernet 1/4
n1000v(config-if)# channel-group 5 mode active
 

ポート チャネル インターフェイスへの速度とデュプレックスの設定

次の手順を使用すると、ポート チャネル インターフェイスの速度設定とデュプレックス設定を行うことができます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

手順の概要

1. config t

2. interface port-channel channel-number

3. speed { 10 | 100 | 1000 | auto }

4. duplex { auto | full | half }

5. show interface port-channel channel-number

6. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

n1000v(config)# interface port-channel 2

n1000v(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

speed { 10 | 100 | 1000 | auto }

 

例:

n1000v(config-if)# speed auto

ポート チャネル インターフェイスの速度を設定します。デフォルトの自動ネゴシエーションは auto です。

ステップ 4

duplex { auto | full | half }

 

例:

n1000v(config-if)# speed auto

ポート チャネル インターフェイスのデュプレックス モードを設定します。デフォルトの自動ネゴシエーションは auto です。

ステップ 5

show interface port-channel channel-number

 

:

n1000v(config-if)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、ポート チャネル 2 を 100 Mbps に設定する例を示します。

n1000v# config t
n1000v(config)# interface port channel 2
n1000v(config-if)# speed 100

フロー制御の設定

この手順を使用すると、1 Gbps 以上の速度のポート チャネル インターフェイスで、フロー制御ポーズ パケットの送受信を設定できます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

1 Gbps よりも低速なポート チャネル インターフェイスでは、ポーズ フレームを受信する機能だけを設定できます。ポーズ パケットの送信については設定できません。


) フロー制御を正しく動作させるには、リンクの両端でフロー制御設定が一致している必要があります。


手順の概要

1. config t

2. interface port-channel channel-number

3. flowcontrol { receive | send } { desired | off | on }

4. show interface port-channel channel-number

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

例:

n1000v(config)# interface port-channel 2

n1000v(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

flowcontrol { receive | send } { desired | off | on }

 

例:

n1000v(config-if)# flowcontrol send desired

フロー制御パラメータを設定して、ポート チャネル インターフェイスのポーズ パケットを送信および受信します。デフォルトは、ディセーブルです。

ステップ 4

show interface port-channel channel-number

 

:

n1000v(config-if)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、ポート チャネル グループ 2 のポート チャネル インターフェイスで、ポーズ パケットを送受信するように設定する例を示します。

n1000v# config t
n1000v(config)# interface port channel 2
n1000v(config-if)# flowcontrol receive on
n1000v(config-if)# flowcontrol send on

ポート チャネル ロード バランシングの設定

この手順を使用すると、ポート チャネル ロード バランシングを設定できます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

ポート チャネル ロード バランシングは、デバイス全体または 1 つのモジュールに対して設定できます。

モジュールベースのロード バランシングは、デバイスベースのロード バランシングに優先します。

デフォルト ロード バランシング方式は、送信元 MAC アドレスです。

ポート チャネル ロード バランシングの詳細については、「ポート チャネルを使ったロード バランシング」を参照してください。

手順の概要

1. config t

2. port-channel load-balance ethernet { dest-ip-port | dest-ip-port-vlan | destination-ip-vlan | destination-mac | destination-port | source-dest-ip-port | source-dest-ip-port-vlan | source-dest-ip-vlan | source-dest-mac | source-dest-port | source-ip-port | source-ip-port-vlan | source-ip-vlan | source-mac | source-port | source-virtual-port-id | vlan-only }

3. show port-channel load-balance

4. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-channel load-balance ethernet { dest-ip-port | dest-ip-port-vlan | destination-ip-vlan | destination-mac | destination-port | source-dest-ip-port | source-dest-ip-port-vlan | source-dest-ip-vlan | source-dest-mac | source-dest-port | source-ip-port | source-ip-port-vlan | source-ip-vlan | source-mac | source-port | source-virtual-port-id | vlan-only }

 

例:

n1000v(config)# port-channel load-balance ethernet source-destination-mac

デバイスまたはモジュールのロード バランシング方式を設定します。有効範囲はデバイスによって異なります。

デフォルトのロード バランシング方式では、送信元 MAC アドレスを使用します。

ステップ 3

show port-channel load-balance

 

:

n1000v(config)# show port-channel load-balance

(任意)ポート チャネル ロード バランシング方式を表示します。

ステップ 4

copy running-config startup-config

 

例:

n1000v(config)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、モジュール 5 のポート チャネルに対して、送信元 IP ロード バランシング方式を設定する例を示します。

n1000v# config t
n1000v(config)# port-channel load-balance ethernet source-ip module 5

デフォルトのロード バランシング方式の復元

この手順を使用すると、デフォルトのロード バランシング方式に戻すことができます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

EXEC モードで CLI にログインします。

手順の概要

1. config t

2. no port-channel load-balance ethernet

3. show port-channel load-balance

4. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no port-channel load-balance ethernet

 

例:

n1000v(config)# no port-channel load-balance ethernet

デフォルトのロード バランシング方式(送信元 MAC アドレス)に戻します。

ステップ 3

show port-channel load-balance

 

:

n1000v(config)# show port-channel load-balance

(任意)ポート チャネル ロード バランシング方式を表示します。

ステップ 4

copy running-config startup-config

 

例:

n1000v(config)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

 

ポート チャネル設定の確認

ポート チャネル設定を表示するには、次の作業を実行します。

 

コマンド
目的

show interface port-channel channel-number

ポート チャネル インターフェイスのステータスを表示します。

show port-channel compatibility-parameters

ポート チャネルに追加するためにメンバ ポート間で同じにするパラメータを表示します。

show port-channel database [ interface port-channel channel-number]

1 つ以上のポート チャネル インターフェイスの集約状態を表示します。

show port-channel load-balance

ポート チャネルで使用するロード バランシングのタイプを表示します。

show port-channel summary

ポート チャネル インターフェイスの概要を表示します。

show port-channel traffic

ポート チャネルのトラフィック統計情報を表示します。

show port-channel usage

使用チャネル数および未使用チャネル数の範囲を表示します。

show running-config interface ethernet port/slot

指定したイーサネット インターフェイスの実行コンフィギュレーションに関する情報を表示します。

show running-config interface port-channel channel-number

ポート チャネルの実行コンフィギュレーション情報を表示します。

show running-config interface vethernet interface-number

指定した vEthernet インターフェイスの実行コンフィギュレーションに関する情報を表示します。

コマンド出力の詳細については、『 Cisco Nexus 1000V Command Reference, Release 4.0(4)SV1(3) を参照してください。

ポート チャネル設定のモニタリング

ポート チャネル インターフェイスの設定情報を表示できます。

 

コマンド
目的

clear counters interface port-channel channel-number

カウンタをクリアします。

show interface counters [module module ]

入力および出力オクテット ユニキャスト パケット、マルチキャスト パケット、ブロードキャスト パケットを表示します。

show interface counters detailed [all]

入力パケット、バイト、マルチキャストおよび出力パケット、バイトを表示します。

show interface counters errors [module module ]

エラー パケットの数を表示します。

ポート チャネルの設定例

次に、ポート チャネルを作成し、そのポート チャネルに 2 つのレイヤ 2 インターフェイスを追加する例を示します。

n1000v# config t
n1000v(config)# interface port-channel 5
n1000v(config-if)# interface ethernet 1/4
n1000v(config-if)# switchport
n1000v(config-if)# channel-group 5 mode active
n1000v(config-if)# interface ethernet 1/7
n1000v(config-if)# switchport
n1000v(config-if)# channel-group 5 mode
 

その他の関連資料

ポート チャネルの実装に関する追加情報については、次のセクションを参照してください。

「関連資料」

「標準規格」

関連資料

関連項目
マニュアル タイトル

レイヤ 2 インターフェイスの設定

「レイヤ 2 インターフェイスの設定」

システム管理

Cisco Nexus 1000V System Management Configuration Guide, Release 4.0(4)SV1(3)

リリース ノート

Cisco Nexus 1000V Release Notes, Release 4.0(4)SV1(3)

標準規格

標準規格
タイトル

IEEE 802.3ad

--

ポート チャネルの機能履歴

ここでは、ポート チャネルの機能履歴を示します。

 

機能名
リリース
機能情報

ポート プロファイル

4.0

この機能が導入されました。

vPC ホスト モード

4.0(4)SV1(2)

サブグループの手動作成をサポートします。

静的ピン接続

4.0(4)SV1(2)

特定のポート チャネル サブグループへの vEthernet インターフェイスの割り当て(ピン接続)をサポートします。