Cisco Nexus 1000V インターフェイス コンフィギュ レーション ガイド リリース 4.0(4)SV1(3)
仮想イーサネット インターフェイスの設定
仮想イーサネット インターフェイスの設定
発行日;2012/02/04 | 英語版ドキュメント(2011/10/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

仮想イーサネット インターフェイスの設定

vEthernet インターフェイスについて

注意事項および制約事項

デフォルト設定

vEthernet インターフェイスの設定

vEthernet アクセス インターフェイスの設定

vEthernet インターフェイス上でのプライベート VLAN の設定

vEthernet インターフェイスのイネーブル化またはディセーブル化

vEthernet インターフェイス設定の確認

vEthernet インターフェイスの設定例

その他の関連資料

関連資料

標準規格

vEthernet インターフェイス パラメータの機能履歴

仮想イーサネット インターフェイスの設定

この章では、Virtual Ethernet(vEthernet または vEth; 仮想イーサネット)インターフェイスを設定する手順について説明します。

ここでは、次の内容について説明します。

「vEthernet インターフェイスについて」

「注意事項および制約事項」

「デフォルト設定」

「vEthernet インターフェイスの設定」

「vEthernet インターフェイス設定の確認」

「vEthernet インターフェイスの設定例」

「その他の関連資料」

「vEthernet インターフェイス パラメータの機能履歴」

vEthernet インターフェイスについて

Virtual Ethernet インターフェイスは、論理インターフェイスです。各 vEthernet インターフェイスは、仮想ポートに接続されたスイッチ インターフェイスに対応します。次のインターフェイス タイプがあります。

VM(VM NIC に接続されたインターフェイス)

サービス コンソール

vmkernel

vEthernet インターフェイスは、分散型仮想スイッチ上で使用されている仮想ポートを表す Cisco Nexus 1000V で作成されます。

注意事項および制約事項

vEthernet インターフェイスの設定には次の注意事項と制限があります。

MTU は vEthernet インターフェイスに設定できません。

デフォルト設定

次の表に、デバイスのアクセスおよびトランク ポート モード パラメータのデフォルト設定を示します。

 

パラメータ
デフォルト

スイッチポート モード

アクセス

許容 VLAN

1 ~ 4094

アクセス VLAN ID

VLAN1

ネイティブ VLAN ID

VLAN1

ネイティブ VLAN ID タギング

ディセーブル

管理ステート

閉じる

vEthernet インターフェイスの設定

ここでは、次の内容について説明します。

「vEthernet アクセス インターフェイスの設定」

「vEthernet インターフェイス上でのプライベート VLAN の設定」

「vEthernet インターフェイスのイネーブル化またはディセーブル化」

vEthernet アクセス インターフェイスの設定

この手順を使用すると、vEthernet インターフェイスをアクセス インターフェイスとして設定できます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

CLI に EXEC モードでログインします。

vEthernet インターフェイスに説明を追加していない場合、次のいずれかの説明が接続時に追加されます。説明を追加してから、 no description コマンドを使用して説明を削除した場合、次のいずれかの説明がインターフェイスに追加されます。

VM の場合:VM-Name、Network Adapter number

VMK の場合:VMware VMkerne、vmk number

VSWIF の場合:VMware Service Console、vswif number

手順の概要

1. config t

2. interface vethernet interface-number

3. description string

4. switchport access vlan vlan-id

5. switchport mode access

6. show interface interface-number

7. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vethernet interface-number

 

例:

n1000v(config)# interface vethernet 100

n1000v(config-if)#

指定した vEthernet インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

interface-number に指定できる範囲は 1 ~ 1048575 です。

ステップ 3

description string

 

例:

n1000v(config-if)# description accessvlan

実行コンフィギュレーションにインターフェイスの説明を追加します。

string には、英数字で最大 80 文字の説明を指定できます。

(注) スペースを含む説明を引用符で囲む必要はありません。

ステップ 4

switchport access vlan vlanid

 

例:

n1000v(config-if)# switchport access vlan 5

vEthernet インターフェイスをアクセス インターフェイスとして設定し、実行コンフィギュレーション内の VLAN ID を指定します。

vlanid に指定できる範囲は 1 ~ 4094 です。

ステップ 5

switchport mode access

 

例:

n1000v(config-if)# switchport mode access

n1000v(config-if)#

実行コンフィギュレーションでアクセス インターフェイスとして使用する vEthernet インターフェイスを設定します。

ステップ 6

show interface interface-number

 

例:

n1000v(config-if)# show interface vethernet1

(任意)インターフェイスのステータスと内容を表示します。

interface-number に指定できる範囲は 1 ~ 1048575 です。

ステップ 7

copy running-config startup-config

 

例:

n1000v(config)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

vEthernet インターフェイス上でのプライベート VLAN の設定

この手順を使用すると、vEthernet インターフェイスに Private VLAN(PVLAN; プライベート VLAN)を設定できます。

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

CLI に EXEC モードでログインします。

手順の概要

1. config t

2. interface vethernet interface-number

3. description string

4. switchport access vlan vlan-id

5. switchport mode private-vlan host

6. switchport private-vlan host-association primary-vlan-id

7. show interface

8. copy running-config startup-config

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vethernet interface-number

 

例:

n1000v(config)# interface vethernet 1

n1000v(config-if)#

指定した vEthernet インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

interface-number に指定できる範囲は 1 ~ 1048575 です。

ステップ 3

description string

 

例:

n1000v(config-if)# description isp_pvlan1

実行コンフィギュレーションにインターフェイスの説明を追加します。

string には、英数字で最大 80 文字の説明を指定できます。

(注) スペースを含む説明を引用符で囲む必要はありません。

ステップ 4

switchport access vlan vlan-id

 

例:

n1000v(config-if)# switchport access vlan 5

vEthernet インターフェイスをアクセス インターフェイスとして設定し、実行コンフィギュレーション内の VLAN ID を指定します。

vlan-id に指定できる範囲は 1 ~ 4094 です。

ステップ 5

switchport mode private-vlan host

 

例:

n1000v(config-if)# switchport mode private-vlan host

実行コンフィギュレーションに、PVLAN ホストの vEthernet インターフェイスを設定します。

ステップ 6

switchport private-vlan host-association primary-vlanid

 

例:

n1000v(config-if)# switchport private-vlan host-association 5

 

実行コンフィギュレーション内の特定のプライマリ VLAN ID に関連付けられているホストの vEthernet インターフェイスを設定します。

primary-vlanid に指定できる範囲は 1 ~ 4094 です。

ステップ 7

show interface

 

例:

n1000v# show interface

(任意)インターフェイスのステータスと内容を表示します。

ステップ 8

copy running-config startup-config

 

例:

n1000v(config)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、vEthernet インターフェイスをプライベート VLAN で使用するように設定する例を示します。

n1000v# config t
n1000v(config)# interface vethernet 1
n1000v(config-if)# description isp_pvlan1
n1000v(config-if)# switchport access vlan 5
n1000v(config-if)# switchport mode private-vlan host
n1000v(config-if)# switchport private-vlan host-association 5

n1000v(config-if)# show interface vethernet 1

Vethernet1 is up

Port description is gentoo, Network Adapter 1
Hardware is Virtual, address is 0050.5687.3bac
Owner is VM "gentoo", adapter is Network Adapter 1
Active on module 4
VMware DVS port 1
Port-Profile is vm
Port mode is access
5 minute input rate 1 bytes/second, 0 packets/second
5 minute output rate 94 bytes/second, 1 packets/second
Rx
655 Input Packets 594 Unicast Packets
0 Multicast Packets 61 Broadcast Packets
114988 Bytes
Tx
98875 Output Packets 1759 Unicast Packets
80410 Multicast Packets 16706 Broadcast Packets 0 Flood Packets
6368452 Bytes
0 Input Packet Drops 0 Output Packet Drops
 

vEthernet インターフェイスのイネーブル化またはディセーブル化

この手順を使用すると、vEtherenet インターフェイスをイネーブルまたはディセーブルにすることができます。

手順の概要

1. config t

2. interface vethernet interface-number

3. [no] shutdown

4. show interface

5. copy running-config startup-config

始める前に

この手順を開始する前に、次の点を確認するか、または実行しておく必要があります。

CLI に EXEC モードでログインします。

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vethernet interface-number

 

例:

n1000v(config)# interface vethernet 100

n1000v(config-if)#

 

指定した vEthernet インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

interface-number に指定できる範囲は 1 ~ 1048575 です。

ステップ 3

[no] shutdown

 

例:

n1000v(config-if)# no shutdown

n1000v(config-if)#

実行コンフィギュレーション内の vEthernet インターフェイスをイネーブルまたはディセーブルにします。

shutdown:vEthernet インターフェイスをディセーブルにします。

no shutdown:vEthernet インターフェイスをイネーブルにします。

ステップ 4

show interface

 

例:

n1000v# show interface

(任意)インターフェイスのステータスと内容を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動を行ってもこの設定が維持されるように永続的に保存します。

次に、vEthernet インターフェイスをイネーブルにする例を示します。

n1000v# config t
n1000v(config)# interface vethernet 100
n1000v(config)# no shutdown
n1000v(config-if)# show interface veth100 status
 
--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
Veth100 -- up 1 auto auto --
n1000v(config-if)#

 

vEthernet インターフェイス設定の確認

vEthernet インターフェイス設定を表示するには、次の作業を実行します

 

コマンド
目的

show interface vethernet interface-number [ brief | counters [ detailed [ all ] | errors ] | description | mac-address | status [ down | err-disabled | inactive | module num | up ] | switchport ]

vEthernet インターフェイス設定を表示します。

show interface [ vethernet interface-number]

インターフェイスの全設定を表示します。

show interface [ vethernet interface-number] brief

簡略化したインターフェイス設定を表示します。

show interface [ vethernet interface-number] counters

インターフェイス着信カウンタおよびインターフェイス受信カウンタを表示します。

show interface [ vethernet interface-number] counters detailed [ all ]

すべてのカウンタの詳細情報を表示します。

(注) [all] が指定されてない場合は、非ゼロ カウンタだけが表示されます。

show interface [ vethernet interface-number] counters errors

インターフェイス エラー カウンタを表示します。

show interface [ vethernet interface-number] description

インターフェイスの説明を表示します。

show interface [ vethernet interface-number] mac-address

インターフェイス MAC アドレスを表示します。

(注) vEth インターフェイスの場合、これは、接続されたデバイスの MAC アドレスを表示します。

show interface [ vethernet interface-number] status [ down | err-disabled | inactive | module num | up ]

インターフェイス ライン ステータスを表示します。

show interface [ vethernet interface-number] switchport

インターフェイス スイッチポートの内容を表示します。

show interface virtual [ vm [ vm_name ] | vmk | vswif ] [ module mod_no ]

仮想インターフェイスだけを表示します。

show interface virtual port-mapping [ vm [ name ] | vmk | vswif | description ] [ module num ]

vEth と VMware DVPort 間のマッピングを表示します。

次に、vEthernet 1 を表示する例を示します。

n1000v# show interface veth1
Vethernet1 is up
Port description is gentoo1, Network Adapter 1
Hardware is Virtual, address is 0050.56bd.42f6
Owner is VM "gentoo1", adapter is Network Adapter 1
Active on module 33
VMware DVS port 100
Port-Profile is vlan48
Port mode is access
Rx
491242 Input Packets 491180 Unicast Packets
7 Multicast Packets 55 Broadcast Packets
29488527 Bytes
Tx
504958 Output Packets 491181 Unicast Packets
1 Multicast Packets 13776 Broadcast Packets 941 Flood Packets
714925076 Bytes
11 Input Packet Drops 0 Output Packet Drops
n1000v#
 
 

次に、すべての vEthernet インターフェイスの情報を表示する例を示します。

n1000v# show interface virtual
 
--------------------------------------------------------------------------------
Port Adapter Owner Mod Host
--------------------------------------------------------------------------------
Veth1 Vm1-kl61 2
Veth2 VM1-kl65 5
Veth3 VM2-kl61 2
Veth1 Net Adapter 1 austen-gentoo1 33 austen-strider.austen.
Veth2 Net Adapter 2 austen-gentoo1 33 austen-strider.austen.
n1000v#
 
 

次に、すべての vEthernet インターフェイスの説明を表示する例を示します。

n1000v# show interface virtual description
 
--------------------------------------------------------------------------------
Interface Description
--------------------------------------------------------------------------------
Veth1 gentoo1, Network Adapter 1
Veth2 gentoo1, Network Adapter 2
Veth3 VMware VMkernel, vmk1
Veth4 VMware Service Console, vswif1
 
 

次に、すべての vEthernet インターフェイスのカウンタを表示する例を示します。

n1000v# show interface counters
 
--------------------------------------------------------------------------------
Port InOctets InUcastPkts InMcastPkts InBcastPkts
--------------------------------------------------------------------------------
mgmt0 42754 -- 0 --
Eth2/2 41423421 112708 125997 180167
Eth5/2 39686276 119152 93284 180100
Eth5/6 4216279 9530 31268 40
Veth1 0 0 0 0
Veth2 0 0 0 0
Veth3 0 0 0 0
Veth4 0 0 0 0
Veth5 0 0 0 0
Veth6 0 0 0 0
Veth7 0 0 0 0
Veth100 0 0 0 0
 
--------------------------------------------------------------------------------
Port OutOctets OutUcastPkts OutMcastPkts OutBcastPkts
--------------------------------------------------------------------------------
mgmt0 3358 -- -- --
Eth2/2 23964739 116150 516 52768
Eth5/2 26419473 111598 571 52420
Eth5/6 1042930 9548 536 14
Veth1 393589 0 6150 0
Veth2 393600 0 6150 0
Veth3 393600 0 6150 0
Veth4 0 0 0 0
Veth5 0 0 0 0
Veth6 0 0 0 0
Veth7 0 0 0 0
Veth100 0 0 0 0
 
n1000v#
 
 

次に、すべての vEthernet インターフェイスの仮想ポート マッピングを表示する例を示します。

n1000v# show interface virtual port-mapping
 
--------------------------------------------------------------------------------
Port Hypervisor Port Status Reason
--------------------------------------------------------------------------------
Veth1 DVPort100 up none
Veth2 DVPort160 up none
 
 

次に、すべての vEthernet インターフェイスの実行コンフィギュレーション情報を表示する例を示します。

n1000v# show running-config interface veth1
version 4.0(4)SV1(1)
 
interface Vethernet1
inherit port-profile vlan48
description gentoo1, Network Adapter 1

vEthernet インターフェイスの設定例

次に、vEthernet アクセス インターフェイスを設定し、このインターフェイスにアクセス VLAN を割り当てる例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 2/30
n1000v(config-if)# switchport
n1000v(config-if)# switchport mode access
n1000v(config-if)# switchport access vlan 5
n1000v(config-if)#
 

次に、レイヤ 2 トランク インターフェイスを設定してネイティブ VLAN および許容 VLAN を割り当て、デバイスにトランク インターフェイスのネイティブ VLAN トラフィックのタグを設定する例を示します。

n1000v# configure terminal
n1000v(config)# interface vethernet 2/35
n1000v(config-if)# switchport
n1000v(config-if)# switchport mode trunk
n1000v(config-if)# switchport trunk native vlan 10
n1000v(config-if)# switchport trunk allowed vlan 5, 10
n1000v(config-if)#
 

その他の関連資料

アクセスおよびトランク ポート モードの実装に関する追加情報については、次のセクションを参照してください。

「関連資料」

「標準規格」

関連資料

関連項目
マニュアル タイトル

ポート プロファイル

Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3)

VLAN およびプライベート VLAN

Cisco Nexus 1000V Layer 2 Switching Configuration Guide, Release 4.0(4)SV1(3)

システム管理

Cisco Nexus 1000V System Management Configuration Guide, Release 4.0(4)SV1(3)

リリース ノート

Cisco Nexus 1000V Release Notes, Release 4.0(4)SV1(3)

標準規格

標準規格
タイトル

この機能でサポートされる新規または改訂された標準規格はありません。また、この機能による既存の標準規格サポートの変更はありません。

--

vEthernet インターフェイス パラメータの機能履歴

ここでは、vEthernet インターフェイス パラメータの機能履歴を示します。

 

機能名
リリース
機能情報

vEthernet インターフェイス パラメータ

4.0

この機能が導入されました。