Cisco Nexus 1000V スタートアップ ガイド リリー ス 4.0(4)SV1(3)
CLI を使用したソフトウェアの設定
CLI を使用したソフトウェアの設定
発行日;2012/01/31 | 英語版ドキュメント(2011/04/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

CLI を使用したソフトウェアの設定

CLI ソフトウェアの設定プロセス

CLI を使用した VSM 仮想マシンの設定

VSM 接続の確認

vCenter Server 上での Cisco Nexus 1000V プラグインの作成

vCenter Server への接続

VSM と VEM 間の通信用のシステム ポート プロファイル設定

設定例:クリティカルなポートのシステム プロファイル

VM トラフィックのアップリンク ポート プロファイル設定

設定例:VM トラフィックのアップリンク プロファイル

VM トラフィックのデータ ポート プロファイル設定

設定例:VM トラフィックのデータ プロファイル

ESX 4.0 ホストの DVS への追加

CLI を使用したソフトウェアの設定

この章では、CLI を ESX 4.0 または ESXi 4.0 VMware サーバにインストールした後で、CLI を使用して Cisco Nexus 1000V ソフトウェアを設定する方法について説明します。


) Cisco Nexus 1000V ソフトウェアを ESX 4.0 または ESXi 4.0 VMware サーバにインストールする方法については、『Cisco Nexus 1000V Software Installation Guide, Release 4.0(4)SV1(3)を参照してください。


CLI ソフトウェアの設定プロセス

ここでは、このプロセスをガイドします。各手順の完了後に、この項に戻り、必要な手順がすべて正しい順に完了したことを確認してください。


ステップ 1 「CLI を使用した VSM 仮想マシンの設定」を使用して、VSM 仮想マシンを設定します。

ステップ 2 次のいずれかの手順を実行します。

レイヤ 3 コントロールを設定している場合は、『 Cisco Nexus 1000V System Management Configuration Guide, Release 4.0(4)SV1(3) の「Domain Configuration」を参照してから、次の手順に進みます。

レイヤ 3 コントロールを設定していない場合は、次の手順に進みます。

ステップ 3 「VSM 接続の確認」に従って VSM 接続を確認します。

ステップ 4 Cisco Nexus 1000V ライセンスを追加します。


) ソフトウェアでは、16 CPU ソケットに 60 日間のライセンスが提供されます。永久ライセンスが VSM にインストールされていない場合だけ、これらのライセンスが使用されます。このソフトウェアをインストールすると、60 日間の評価期間が開始します。


ライセンスを購入した場合は、『 Cisco Nexus 1000V License Configuration Guide, Release 4.0(4)SV1(3) を参照してください。

ステップ 5 「vCenter Server 上での Cisco Nexus 1000V プラグインの作成」に従って Cisco Nexus 1000V プラグインを作成します。

ステップ 6 「vCenter Server への接続」に従って vCenter Server に接続します。

ステップ 7 「VLAN の作成」に従って必要な VLAN を作成します。

ステップ 8 次の手順に従って、使用するポート プロファイルを作成します。

「VSM と VEM 間の通信用のシステム ポート プロファイル設定」

「VM トラフィックのアップリンク ポート プロファイル設定」

「VM トラフィックのデータ ポート プロファイル設定」

ステップ 9 「ESX 4.0 ホストの DVS への追加」に従ってホストを DVS に追加します。

ステップ 10 このプロセスが完了しました。「ソフトウェアの設定プロセス」に戻ります。


 

CLI を使用した VSM 仮想マシンの設定

次の手順に従って、CLI を使用して VSM 管理アクセスの設定と保存を行うことができます。

始める前に

この手順を開始する前に、次の事柄を理解または実行しておく必要があります。

次の Cisco Nexus 1000V ドメイン情報を用意している必要があります。

コントロール VLAN ID

パケット VLAN ID

ドメイン ID

コントロール、パケット、管理には同じ VLAN を使用し、この VLAN 上にデータ トラフィックは流さないことを推奨します。柔軟性を高めるため、個別の VLAN を使用できます。

手順の詳細


ステップ 1 仮想マシン(VM)の電源を入れ、[Install Cisco Nexus 1000V and bring up the new image] を選択します。

次の画面が表示されます。

 

 

 


) VM の電源投入が完了するまで、最大 5 分かかることがあります。


ステップ 2 プロンプトが表示されたら、管理者用のパスワードを入力して確認します。

例:

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":

ステップ 3 プロンプトが表示されたら、ドメイン ID を入力します。

例:

Enter the domain id<1-4095>: 152

ステップ 4 プロンプトが表示されたら、ハイ アベイラビリティ(HA)ロールを入力します。

ロールを指定しない場合は、スタンドアロン ロールがデフォルトで割り当てられます。

例:standalone または primary

Enter HA role[standalone/primary/secondary]: primary

 

[#########################################] 100%

 
---- Basic System Configuration Dialog ----
 
This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.
 
*Note: setup is mainly used for configuring the system initially,
when no configuration is present. So setup always assumes system
defaults and not the current system configuration values.
 
Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.
 
Would you like to enter the basic configuration dialog (yes/no):
 
 
 
例: Secondary
Enter HA role[standalone/primary/secondary]: secondary
 
 
Setting HA role to secondary will cause a system reboot. Are you sure (yes/no) ? :
 

ステップ 5 次のいずれかの手順を実行します。

プライマリおよびアクティブ VSM を設定する場合は、ステップ 8へ進みます。

セカンダリおよびスタンバイ VSM を設定する場合は、次の手順に進みます。

ステップ 6 CD-ROM の ISO イメージからセカンダリ VSM をインストールする場合は、仮想 CD-ROM をここでアンマウントし、VSM が CD から起動しないようにします。

VSM VM がハード ドライブより先に CD-ROM から起動するように設定している場合は、このステップが必要です。

ステップ 7 セカンダリおよびスタンバイ VSM を設定しているときに、VSM の再起動が要求された場合は、yes と入力します。

セカンダリ VSM VM が再起動し、スタンバイ モードになります。

セカンダリ VSM のパスワードは、アクティブおよびプライマリ VSM のパスワードと同期化されます。

アクティブおよびプライマリ VSM の設定はここで自動的にスタンバイと同期化されます。

例:secondary

Setting HA role to secondary will cause a system reboot. Are you sure (yes/no) ? : y

 

[########################################] 100%

 

HA mode set to secondary. Rebooting now...

 

セカンダリ VSM を設定する手順が完了しました。「CLI ソフトウェアの設定プロセス」に戻り、設定を続けます。

ステップ 8 基本設定ダイアログを開始するかどうかを尋ねるプロンプトが表示されたら、yes と入力します。

例:

Would you like to enter the basic configuration dialog (yes/no): yes

 

ステップ 9 別のログイン アカウントを作成するかどうかを尋ねるプロンプトが表示されたら、 no と入力します。

例:

Create another login account (yes/no) [n]: no
 

ステップ 10 読み取り専用 Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)コミュニティ ストリングを設定するかどうかを尋ねるプロンプトが表示されたら、 no と入力します。

例:

Configure read-only SNMP community string (yes/no) [n]: no
 

ステップ 11 読み取りと書き込み用 SNMP コミュニティ ストリングを設定するかどうかを尋ねるプロンプトが表示されたら、 no と入力します。

例:
Configure read-write SNMP community string (yes/no) [n]: no
 

ステップ 12 スイッチ名を入力します。

例:
Enter the switch name: n1000v
 

ステップ 13 帯域外管理を設定するかどうかを尋ねるプロンプトが表示されたら、 yes と入力して、mgmt0 IPv4 アドレスとサブネット マスクを入力します。

例:
Continue with Out-of-band (mgmt0) management configuration? [yes/no] [y]: yes
Mgmt0 IPv4 address:
172.28.15.152
Mgmt0 IPv4 netmask: 255.255.255.0
 

ステップ 14 デフォルト ゲートウェイを設定するかどうかを尋ねるプロンプトが表示されたら、 no と入力します。

例:
Configure the default-gateway: (yes/no) [y]: no

ステップ 15 高度な IP オプションを設定するかどうかを尋ねるプロンプトが表示されたら、 no と入力します。

例:
Configure Advanced IP options (yes/no)? [n]: no
 

ステップ 16 Telnet サービスをイネーブルにするかどうかを尋ねるプロンプトが表示されたら、 yes と入力します。

例:
Enable the telnet service? (yes/no) [y]: yes
 

ステップ 17 Secure Shell(SSH; セキュア シェル)サービスをイネーブルにするかどうかを尋ねるプロンプトが表示されたら、 yes と入力して、キーのタイプとキービット数を入力します。
詳細については、『 Cisco Nexus 1000V Security Configuration Guide, Release 4.0(4)SV1(3) を参照してください。

例:
Enable the ssh service? (yes/no) [y]: yes
Type of ssh key you would like to generate (dsa/rsa) : rsa
Number of key bits <768-2048> : 1024
 

ステップ 18 Network Time Protocol(NTP; ネットワーク タイム プロトコル)サーバを設定するかどうかを尋ねるプロンプトが表示されたら、 no と入力します。

例:
Configure NTP server? (yes/no) [n]: no
 

ステップ 19 Virtual Ethernet Module(VEM)機能レベルを設定するかどうかを尋ねるプロンプトが表示されたら、 yes と入力して、0 または 1 を入力します

例:
Configure vem feature level? (yes/no) [n]: yes
Current vem feature level is set to 4.0.(4)SV1(1)
You can change the feature level to:
1 4.0(4)SV1(2)
Enter an index from the list above <1-1> or 0 if you don't want to change:
 

ステップ 20 Cisco Nexus 1000V ドメイン パラメータを設定するかどうかを尋ねるプロンプトが表示されたら、 yes と入力して、パラメータを入力します。

例:
Configure n1000v domain parameters (yes/no) [y]: yes
Enter control vlan <1-3967, 4048-4093>: 260
Enter packet vlan <1-3967, 4048-4093>: 260
 
The system now summarizes the complete configuration and asks if you want to edit it.
 
例:
The following configuration will be applied:
Switchname n1000v
interface Mgmt0
ip address 172.28.15.152 255.255.255.0
no shutdown
telnet server enable
ssh key rsa 1024 force
ssh server enable
svs-domain
control vlan 260
packet vlan 260
domain id 152
 

ステップ 21 次のいずれかの手順を実行します。

設定を変更しない場合は、 no と入力して、次の手順に進みます。

設定を変更する場合は、 yes と入力して、ステップ 9 に戻り、各コマンドを再び実行します。

例:
Would you like to edit the configuration? (yes/no) [n]:no
 

ステップ 22 この設定を使用および保存するかどうかを尋ねるプロンプトが表示されたら、 yes と入力します。


注意 ここで設定を保存しておかないと、次回のスイッチ起動時に設定が更新されません。新しい設定を保存するには、yes と入力します。これによって、キックスタート イメージとシステム イメージも自動的に設定されます。

例:
Use this configuration and save it? (yes/no) [y]: yes
[########################################] 100%
 

新しい設定が不揮発性メモリに保存されると、設定の実行コピーとスタートアップ コピーが一致します。


) EXEC モードで setup コマンドを使用して、ステップ 8 からステップ 22 で完了した設定を、セットアップ ルーチンに従っていつでも更新できます。セットアップが開始されたら、Enter キーを押してコマンドをスキップします。Ctrl+C キーを押して残りのコマンドをスキップします。


ステップ 23 この手順が完了しました。
「CLI ソフトウェアの設定プロセス」に戻ります。


 

VSM 接続の確認

次の手順に従って、アクティブ VSM への IP 接続を確認できます。

始める前に

この手順を開始する前に、次の事柄を理解または実行しておく必要があります。

EXEC モードでアクティブ VSM にログインしている必要があります。

手順の詳細


ステップ 1 アクティブ VSM への IP 接続を確認します。

ping ip_address

例:

n1000v# ping 172.28.15.1
PING 172.28.15.1 (172.28.15.1): 56 data bytes
Request 0 timed out
64 bytes from 172.28.15.1: icmp_seq=1 ttl=63 time=0.799 ms
64 bytes from 172.28.15.1: icmp_seq=2 ttl=63 time=0.597 ms
64 bytes from 172.28.15.1: icmp_seq=3 ttl=63 time=0.711 ms
64 bytes from 172.28.15.1: icmp_seq=4 ttl=63 time=0.67 ms
--- 172.28.15.1 ping statistics ---
5 packets transmitted, 4 packets received, 20.00% packet loss
round-trip min/avg/max = 0.597/0.694/0.799 ms
 

VSM への接続がここで確認され、SSH による安全な接続が使用できます。

ステップ 2 この手順が完了しました。
「CLI ソフトウェアの設定プロセス」に戻ります。


 

vCenter Server 上での Cisco Nexus 1000V プラグインの作成

次の注意事項と VMware マニュアルに従って、vCenter Server に Cisco Nexus 1000V プラグイン(拡張機能)をインストールして登録します。

始める前に

この手順を開始する前に、次の事柄を理解または実行しておく必要があります。

VSM ホームページ(アクティブ VSM の IP アドレスにブラウザをポイントします)から次のファイルのコピーをすでにダウンロードしている必要があります。

cisco_nexus1000v_extension.xml

古いまたは破損したバージョンの cisco_nexus1000v_extension.xml ファイルを使用すると、エラー メッセージが表示されることがあります。


) このファイルに使用されていないキャッシュ コピーのダウンロードを防ぐため、ブラウザ ウィンドウを必ず最初に更新してください。


アクティブ VSM の IP アドレスを知っている必要があります。

接続するすべての VSM 用のプラグインを vCenter Server に追加する必要があります。

デュアル スーパーバイザを使用している場合は、両方のスーパーバイザが同じプラグインを使用します。


) すでに登録されているプラグインを登録しようとすると、「The specified parameter was not correct」というエラーが表示されます。『Cisco Nexus 1000V Troubleshooting Guide, Release 4.0(4)SV1(3)を参照してください。


手順の詳細


ステップ 1 vSphere Client クライアントを開始します。

[local host - VMware Infrastructure Client] ダイアログボックスが開きます。

ステップ 2 [Plug-Ins] メニューから [Manage Plug-Ins] を選択します。

[Plug-In Manager] ダイアログボックスが開きます。

ステップ 3 ダイアログボックスのスペースを右クリックし、ポップアップ メニューから [New Plug-In] を選択します。

[Register Plug-In] ダイアログボックスが開きます。

ステップ 4 [Browse] をクリックし、VSM ホームページからダウンロードした cisco_nexus1000v_extension.xml ファイルを選択します。

ステップ 5 [Register Plug-In] をクリックします。


) すでに登録されているプラグインを登録しようとすると、「The specified parameter was not correct」というエラーが表示されます。『Cisco Nexus 1000V Troubleshooting Guide, Release 4.0(4)SV1(3)を参照してください。


 

ステップ 6 [Security Warning] ダイアログボックスで、[Ignore] をクリックし、証明書の使用を継続します。

ステップ 7 [Register Plug-in] ダイアログボックスで、[OK] をクリックします。

プラグインの作成と登録が行われます。

ステップ 8 拡張機能が [Plug-in Manager] ウィンドウに表示されていることを確認します。

ステップ 9 ウィンドウを閉じます。

ステップ 10 この手順が完了しました。
「CLI ソフトウェアの設定プロセス」に戻ります。


 

vCenter Server への接続

次の手順に従って、VSM と vCenter Server 間の接続を設定し、再起動やリブートを行ってもこの設定が維持されるように永続メモリに保存できます。

始める前に

この手順を開始する前に、次の事柄を理解または実行しておく必要があります。

EXEC モードでスタンドアロンまたはアクティブ VSM にログインしている必要があります。

Cisco Nexus 1000V の拡張機能は、vCenter Server のプラグインとしてすでに登録されている必要があります。

大文字と小文字が区別されたデータセンター名を知っている必要があります。

データセンターは vCenter Server 上にすでに存在している必要があります。

vCenter Server の IP アドレスを知っている必要があります。

手順の要約

1. config t

2. svs connection connection_name

3. vmware dvs datacenter-name dc_name

4. protocol vmware-vim

5. remote ip address ip_address

6. connect

7. show svs connections

8. copy running-config startup-config

手順の詳細

 

 
コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

svs connection name

 

例:

n1000v (config#) svs connection VC

n1000v(config-svs-conn#)

Cisco Nexus 1000V と vCenter Server 間の接続を追加するための接続コンフィギュレーション モードを開始します。名前を使用すると、複数の接続情報を設定に保存できます。

ステップ 3

protocol vmware-vim [http]

 

例:

n1000v(config-svs-conn#) protocol vmware-vim

n1000v(config-svs-conn#)

この接続が VIM プロトコルを使用することを指定します。このコマンドはローカルに保存されます。

http:VIM プロトコルが HTTP で実行されることを指定します。デフォルトでは、HTTP over SSL(HTTPS)を使用します。

ステップ 4

remote ip address ipaddress

 

例:

n1000v(config-svs-conn#) remote ip address 172.28.15.150

n1000v(config-svs-conn#)

 

この接続用の ESX サーバまたは vCenter Server の IP アドレスを指定します。このコマンドはローカルに保存されます。

ステップ 5

vmware dvs datacenter-name name

 

例:

n1000v(config-svs-conn#) vmware dvs datacenter-name Hamilton-DC

n1000v(config-svs-conn#)

vCenter Server 内のデータセンター名を特定します。Cisco Nexus 1000V は vCenter Server で分散仮想スイッチ(DVS)として作成されます。このコマンドは接続の前後で使用できます。データセンター名はローカルに保存されます。

ステップ 6

connect

 

例:

n1000v(config-svs-conn#) connect

 

接続を開始します。

(注) 初回の接続には最大 10 秒かかることがあります。

この接続にユーザ名とパスワードが設定されていない場合は、ユーザ名とパスワードの入力を要求するプロンプトが表示されます。

アクティブな接続は一度に 1 つだけ可能です。定義済みの接続が有効な場合は、 no connect コマンドを使用して定義済みの接続を閉じるまでエラー メッセージが表示され、コマンドが拒否されます。

を参照してください。

ステップ 7

show svs connections [name]

 

例:

n1000v(config-svs-conn#) show svs connections vc
connection VC:
hostname: 172.28.15.150
protocol: vmware-vim https
certificate: default
datacenter name: HamiltonDC
DVS uuid: 6d fd 37 50 37 45 05 64-b9 a4 90 4e 66 eb 8c f5
config status: Enabled
operational status: Connected
 
n1000v(config-svs-conn#)

確認のため、Cisco Nexus 1000V への現在の接続を表示します。

Cisco Nexus 1000V DVS は vCenter Server 上に作成され、vSphere Client の [Inventory] > [Networking] に表示されます。

(注) vCenter Server への接続がなんらかの理由でシャットダウンした場合、Cisco Nexus 1000V は接続を自動的に復元しません。この場合は、次のコマンド シーケンスを使用して接続を手動で復元する必要があります。

no connect
connect

ステップ 8

copy running-config startup-config

 

例:

n1000v(config-svs-conn#) copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

vCenter Server への接続が確立され、接続が実行コンフィギュレーションからスタートアップ コンフィギュレーションにコピーされます。この接続はリブート、再起動後もスタートアップ コンフィギュレーションに永続的に保存されます。

 


注意 この設定をスタートアップ コンフィギュレーションにコピーしない場合、VSM を再起動すると、この接続コンフィギュレーションは廃棄されます。

ステップ 9

この手順が完了しました。

「CLI ソフトウェアの設定プロセス」に戻ります。

VSM と VEM 間の通信用のシステム ポート プロファイル設定

次の手順に従って、システム VLAN でアップリンク ポート プロファイルを定義し、VSM と VEM 間の通信を確立できます。

始める前に

この手順を開始する前に、次の事柄を理解または実行しておく必要があります。

「VLAN の作成」に従って、使用する VLAN を追加している必要があります。

EXEC モードでスタンドアロンまたはアクティブ VSM にログインしている必要があります。

セカンダリ VSM でシステム ポート プロファイルを設定する必要はありません。この設定がプライマリ VSM で完了すると、設定は自動的にセカンダリ VSM と同期化されます。

ファイルで使用したコマンドを保存したり、bootflash にコピーしたり、スクリプトとして実行したりできます。スクリプト使用の詳細については、「コマンド スクリプトの使用方法」を参照してください。

この手順で定義されたシステム VLAN は、VSM と VEM 間の通信リンクを確立します。

システム ポート プロファイルのトランク設定で定義された VLAN は、接続された物理スイッチポートのトランク設定でも定義する必要があります。

この手順で指定したポート プロファイル名はユーザが選択したものです。

コントロール、パケット、管理には同じ VLAN を使用し、この VLAN 上にデータ トラフィックは流さないことを推奨します。柔軟性を高めるため、個別の VLAN を使用できます。

この例では、単一のシステム VLAN 260 がコントロールおよびパケット トラフィックの両方に使用されます。個別の VLAN を使用できます。

ポート モード(アクセス モードまたは トランク モード)、許可 VLAN、シャットダウン状態は、システム VLAN よりも前に定義されます。

許可 VLAN のリストは、システム VLAN のリストのスーパーセット(またはシステム VLAN のリストと同じ)である必要があります。

システム VLAN とシステム ポート プロファイルの詳細については、次を参照してください。

「システム ポート プロファイルとシステム VLAN」

Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3)


注意 ポート プロファイルの設定が再起動またはリブート後も維持されるように、ポート プロファイルを Cisco Nexus 1000V スタートアップ コンフィギュレーションに保存する必要があります。そうしないと、VSM を再起動すると、ポート グループは vCenter Server に継続して存在しますが、VSM には存在しなくなります。

手順の要約

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. description profiledescription

4. switchport mode trunk

5. switchport trunk allowed vlan vlan_IDs

6. no shutdown

7. system vlan vlan_ID_list

8. vmware port-group [ portgroup_name ]

9. state enabled

10. show port-profile [ brief | expand-interface | usage ] [ name profile-name ]

11. copy running-config startup-config

手順の詳細

 

 
コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile type ethernet system-uplink

n1000v(config-port-prof)#

名前付きポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。ポート プロファイルがない場合は、次の特性を使用して作成されます。

name :ポート プロファイル名は、最大 80 文字で、Cisco Nexus 1000V 上のポート プロファイルごとに一意である必要があります。

type :(任意)ポート プロファイル タイプはイーサネットまたは vEthernet です。設定が完了すると、タイプは変更できません。デフォルトは vEthernet タイプです。

ポート プロファイル タイプをイーサネットとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できます。vCenter Server では、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルを Ethernet タイプとして定義した場合、ポート プロファイルを使用して VMware 仮想ポートを設定できません。

ステップ 3

description profiledescription

 

例:

n1000v(config-port-prof)# description “System profile for critical ports”

n1000v(config-port-prof)#

ポート プロファイルに説明を追加します。この説明は自動的に vCenter Server にプッシュされます。

profile description:最大 80 文字の ASCII 文字。

(注) 説明にスペースが含まれる場合は、説明の前後に引用符を使用する必要があります。

ステップ 4

switchport mode trunk

 

例:

n1000v(config-port-prof)# switchport mode trunk

n1000v(config-port-prof)#

新しいポート プロファイルがトランク ポートとして使用されることを指定します。

ステップ 5

switchport trunk allowed vlan vlan_IDs

 

例:

n1000v(config-port-prof)# switchport trunk allowed vlan 260

 

新しいポート プロファイルのトランク ポートで許可された VLAN を指定します。

ステップ 6

no shutdown

 

例:

n1000v(config-port-prof)# no shutdown

n1000v(config-port-prof)#

新しいポート プロファイルのすべてのポートを管理上のイネーブル状態にします。

ステップ 7

system vlan vlan_ID_list

 

例:

n1000v(config-port-prof)# system vlan 260

n1000v(config-port-prof)#

system vlan をこの新しいポート プロファイルに追加します。system vlan は、VSM が VEM と通信を確立する前に、物理ポートまたは vEthernet ポートの設定とアップに使用されます。

(注) 個別のコントロールおよびパケット VLAN を定義した場合、別のシステム VLAN を追加します。

ステップ 8

vmware port-group [ portgroup_name ]

 

例:

n1000v(config-port-prof)# vmware port-group system-uplink

n1000v(config-port-prof)#

 

ポート プロファイルを同じ名前の VMware ポート グループとして指定します。

ポート プロファイルは同じ名前の VMware ポート グループにマッピングされます。vCenter Server 接続が確立されると、このポート グループは vCenter Server 上の仮想スイッチに分散されます。

ステップ 9

state enabled

 

例:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

新しいシステム ポート プロファイルをイネーブルにします。

新しいシステム ポート プロファイルの設定は割り当てられたポートに適用されます。VMware ポート グループは vCenter Server 上の vSwitch で作成されます。

ここで、Distributed Virtual Port Group が vSphere Client の [Inventory] > [Networking] > [DataCenter] タブにある [VSM Name] の下に表示されます。

ステップ 10

show port-profile name profile-name

 

例:

n1000v(config-port-prof)# show port-profile name system-uplink

port-profile system-uplink

description: "System profile for critical ports"

type: ethernet

status: enabled

capability l3control: no

pinning control-vlan: -

pinning packet-vlan: -

system vlans: 260

port-group: system-uplink

max ports: -

inherit:

config attributes:

switchport mode trunk

switchport trunk allowed vlan 260

no shutdown

evaluated config attributes:

switchport mode trunk

switchport trunk allowed vlan 260

no shutdown

assigned interfaces:

n1000v(config-port-prof)#

(任意)システムアップリンク ポート プロファイル コンフィギュレーションを表示します。

ステップ 11

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動後も維持されるように永続的に保存します。


注意 この設定をスタートアップ コンフィギュレーションにコピーしない場合、VSM を再起動すると、このポート グループは vCenter Server に継続して存在しますが、VSM には存在しなくなります。

ステップ 12

この手順が完了しました。

「CLI ソフトウェアの設定プロセス」に戻ります。

設定例:クリティカルなポートのシステム プロファイル

config t
port-profile type ethernet system-uplink
description "System profile for critical ports"
switchport mode trunk
switchport trunk allowed vlan 260
no shutdown
system vlan 260
vmware port group system-uplink
state enabled

VM トラフィックのアップリンク ポート プロファイル設定

次の手順に従って、物理インターフェイスが VM トラフィックの伝送に使用するアップリンク ポート プロファイルを定義します。

始める前に

この手順を開始する前に、次の事柄を理解または実行しておく必要があります。

「VLAN の作成」に従って、使用する VLAN を追加している必要があります。

EXEC モードでスタンドアロンまたはアクティブ VSM にログインしている必要があります。

セカンダリ VSM でシステム ポート プロファイルを設定する必要はありません。この設定が完了すると、プライマリ VSM は自動的にセカンダリ VSM と同期化されます。

ファイルで使用したコマンドを保存したり、bootflash にコピーしたり、スクリプトとして実行したりできます。スクリプト使用の詳細については、『 Cisco Nexus 1000V スタートアップ ガイド リリース 4.0(4)SV1(3) 』を参照してください。

この手順で指定したポート プロファイル名はユーザが選択したものです。

システムアップリンク ポート プロファイルを使用してデータ トラフィックを伝送する場合は、データ VLAN をシステムアップリンク ポート プロファイルに追加し、アップストリーム スイッチ上で対応する変更を加えます。

ポート プロファイルの詳細については、『 Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3) を参照してください。

手順の要約

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. description profiledescription

4. switchport mode access

5. switchport access vlan vlan_ID

6. vmware port-group [ portgroup_name ]

7. no shutdown

8. state enabled

9. show port-profile [ brief | expand-interface | usage ] [ name profile-name ]

10. copy running-config startup-config

手順の詳細

 

 
コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile type ethernet name

 

例:

n1000v(config)# port-profile type ethernet vm-uplink

n1000v(config-port-prof)#

指定したポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。

type :イーサネット タイプまたは vEthernet タイプとしてポート プロファイルを定義します。設定が完了すると、この設定は変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルを vEthernet タイプとして定義すると、ポートがアップリンク ポートとして使用できます。vCenter Server では、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルを Ethernet タイプとして定義した場合、ポート プロファイルを使用して VMware 仮想ポートを設定できません。

name :ポート プロファイル名は、最大 80 文字で、Cisco Nexus 1000V 上のポート プロファイルごとに一意である必要があります。

ステップ 3

description profiledescription

 

例:

n1000v(config-port-prof)# description “Uplink profile for VM Traffic”

n1000v(config-port-prof)#

ポート プロファイルに説明を追加します。この説明は自動的に vCenter Server にプッシュされます。

profile description:最大 80 文字の ASCII 文字。

(注) 説明にスペースが含まれる場合は、説明の前後に引用符を使用する必要があります。

ステップ 4

switchport mode access

 

例:

n1000v(config-port-prof)# switchport mode access

n1000v(config-port-prof)#

新しいポート プロファイルがアクセス ポートとして使用されることを指定します。

ステップ 5

switchport access vlan vlan_ID

 

例:

n1000v(config-port-prof)# switchport access vlan 260

新しいポート プロファイルのアクセス VLAN を指定します。

 

ステップ 6

no shutdown

 

例:

n1000v(config-port-prof)# no shutdown

n1000v(config-port-prof)#

新しいポート プロファイルのすべてのポートを管理上のイネーブル状態にします。

ステップ 7

vmware port-group [ portgroup_name ]

 

例:

n1000v(config-port-prof)# vmware port-group vm-uplink

n1000v(config-port-prof)#

ポート プロファイルを同じ名前の VMware ポート グループとして指定します。

ポート プロファイルは VMware ポート グループにマッピングされます。vCenter Server 接続が確立されると、このポート グループは vCenter Server 上の仮想スイッチに分散されます。

ステップ 8

state enabled

 

例:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

VM トラフィックの新しいアップリンク ポート プロファイルをイネーブルにします。

新しいアップリンク ポート プロファイルの設定は割り当てられたポートに適用されます。VMware ポート グループは vCenter Server 上の vSwitch で作成されます。

ここで、Distributed Virtual Port Group が vSphere Client の [Inventory] > [Networking] > [DataCenter] タブにある [VSM Name] の下に表示されます。

ステップ 9

show port-profile name profile-name

 

例:

n1000v(config-port-prof)# show port-profile name vm-uplink

port-profile vm-uplink

description: "Uplink profile for VM traffic

type: ethernet

status: enabled

capability l3control: no

pinning control-vlan: -

pinning packet-vlan: -

system vlans: none

port-group: vm-uplink

max ports: -

inherit:

config attributes:

switchport mode access

switchport access vlan 260

no shutdown

evaluated config attributes:

switchport mode access

switchport access vlan 260

no shutdown

assigned interfaces:

n1000v(config-port-prof)#

(任意)vm-uplink ポート プロファイル コンフィギュレーションを表示します。

ステップ 10

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動後も維持されるように永続的に保存します。


注意 この設定をスタートアップ コンフィギュレーションにコピーしない場合、VSM を再起動すると、このポート グループは vCenter Server に継続して存在しますが、VSM には存在しなくなります。

ステップ 11

この手順が完了しました。

「CLI ソフトウェアの設定プロセス」に戻ります。

設定例:VM トラフィックのアップリンク プロファイル

config t
port-profile type ethernet vm-uplink
description "Uplink profile for VM traffic
switchport mode access
switchport access vlan 260
no shutdown
vmware port-group vm-uplink
state enabled

VM トラフィックのデータ ポート プロファイル設定

次の手順に従って、データ ポート プロファイルを定義します。データ ポート プロファイルは、VM にネットワーク アダプタとして提供され、ゲスト VM とのトラフィック伝送を行います。

始める前に

この手順を開始する前に、次の事柄を理解または実行しておく必要があります。

「VLAN の作成」に従って、使用する VLAN を追加している必要があります。

コントロール、パケット、管理には同じ VLAN を使用し、この VLAN 上にデータ トラフィックは流さないことを推奨します。柔軟性を高めるため、個別の VLAN を設定できます。

EXEC モードでスタンドアロンまたはアクティブ VSM にログインしている必要があります。

セカンダリ VSM でデータ ポート プロファイルを設定する必要はありません。この設定がプライマリ VSM で完了すると、設定は自動的にセカンダリ VSM と同期化されます。

ファイルで使用したコマンドを保存したり、bootflash にコピーしたり、スクリプトとして実行したりできます。スクリプト使用の詳細については、『 Cisco Nexus 1000V スタートアップ ガイド リリース 4.0(4)SV1(3) 』を参照してください。

この手順で指定したポート プロファイル名はユーザが選択したものです。

ポート プロファイルの詳細については、『 Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3) を参照してください。

手順の要約

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. description profiledescription

4. switchport mode access

5. switchport access vlan vlan_ID

6. vmware port-group [ portgroup_name ]

7. no shutdown

8. state enabled

9. show port-profile [ brief | expand-interface | usage ] [ name profile-name ]

10. copy running-config startup-config

手順の詳細

 

 
コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile type ethernet data20

n1000v(config-port-prof)#

名前付きポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。ポート プロファイルがない場合は、次の特性を使用して作成されます。

name :ポート プロファイル名は、最大 80 文字で、Cisco Nexus 1000V 上のポート プロファイルごとに一意である必要があります。

type :(任意)ポート プロファイル タイプはイーサネットまたは vEthernet です。設定が完了すると、タイプは変更できません。デフォルトは vEthernet タイプです。

ポート プロファイル タイプをイーサネットとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できます。vCenter Server では、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルを Ethernet タイプとして定義した場合、ポート プロファイルを使用して VMware 仮想ポートを設定できません。

ステップ 3

description profiledescription

 

例:

n1000v(config-port-prof)# description “Data profile for VM Traffic”

n1000v(config-port-prof)#

ポート プロファイルに ASCII 文字で 80 文字までの説明を追加します。この説明は自動的に vCenter Server にプッシュされます。

ステップ 4

switchport mode access

 

例:

n1000v(config-port-prof)# switchport mode access

n1000v(config-port-prof)#

 

新しいポート プロファイルがアクセス ポートとして使用されることを指定します。

ステップ 5

switchport access vlan vlan_ID

 

例:

n1000v(config-port-prof)# switchport access vlan 20

新しいポート プロファイルのアクセス VLAN を指定します。

 

ステップ 6

no shutdown

 

例:

n1000v(config-port-prof)# no shutdown

n1000v(config-port-prof)#

新しいポート プロファイルのすべてのポートを管理上のイネーブル状態にします。

ステップ 7

vmware port-group [ portgroup_name ]

 

例:

n1000v(config-port-prof)# vmware port-group data20

n1000v(config-port-prof)#

ポート プロファイルを VMware ポート グループとして指定します。

ポート プロファイルは VMware ポート グループにマッピングされます。vCenter Server 接続が確立されると、このポート グループは vCenter Server 上の仮想スイッチに分散されます。

ステップ 8

state enabled

 

例:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

VM トラフィックの新しいデータ ポート プロファイルをイネーブルにします。

新しいデータ ポート プロファイルの設定は割り当てられたポートに適用されます。VMware ポート グループは vCenter Server 上の vSwitch で作成されます。

ここで、Distributed Virtual Port Group が vSphere Client の [Inventory] > [Networking] > [DataCenter] タブにある [VSM Name] の下に表示されます。

ステップ 9

show port-profile name profile-name

 

例:

n1000v(config-port-prof)# show port-profile name data260

port-profile data20

description: "Data profile for VM traffic"

type: ethernet

status: enabled

capability l3control: no

pinning control-vlan: -

pinning packet-vlan: -

system vlans: none

port-group: data20

max ports: -

inherit:

config attributes:

switchport mode access

switchport access vlan 20

no shutdown

evaluated config attributes:

switchport mode access

switchport access vlan 20

no shutdown

assigned interfaces:

n1000v(config-port-prof)#

(任意)VM トラフィックの物理 NIC にバインドされるポート プロファイル コンフィギュレーションを表示します。

ステップ 10

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートや再起動後も維持されるように永続的に保存します。


注意 この設定をスタートアップ コンフィギュレーションにコピーしない場合、VSM を再起動すると、このポート グループは vCenter Server に継続して存在しますが、VSM には存在しなくなります。

ステップ 11

この手順が完了しました。

「CLI ソフトウェアの設定プロセス」に戻ります。

設定例:VM トラフィックのデータ プロファイル

config t
port-profile type ethernet data20
description "Data profile for VM traffic"
switchport mode access
switchport access vlan 20
no shutdown
vmware port-group data20
state enabled

ESX 4.0 ホストの DVS への追加

次の手順と VMware マニュアルに従って、ホストを DVS に追加します。


) VMware Update Manager(VUM)を使用している場合、この手順では、ホストがスイッチに追加されると、Cisco Nexus 1000V ソフトウェアが自動的に VEM にインストールされます。


始める前に

この手順を開始する前に、次の事柄を理解または実行しておく必要があります。

アップストリーム スイッチ上の対応するインターフェイスがすでに設定されていて、システムアップリンク ポート プロファイルで設定したのと同じ VLAN を許可する必要があります。

この手順の例では、トラフィック フローは次のように設定されます。

 

トラフィック
VMNIC

コントロール VLAN

システムアップリンク VMNIC

パケット VLAN

システムアップリンク VMNIC

VM データ

VM-uplink ポート グループ

 


) システムアップリンク プロファイルを使用してデータ トラフィックを伝送する場合に、システムアップリンク プロファイルがすでに定義されているときは、vm-uplink プロファイルを別の vmnic に割り当てる必要はありません。


VUM を使用していない場合、『 Cisco Nexus 1000V Virtual Ethernet Module Software Installation Guide, Release 4.0(4)SV1(3) に従って、VEM ソフトウェアをホストにすでにインストールしている必要があります。

VUM を使用している場合、この手順では、VUM がトリガーされ、Cisco Nexus 1000V VEM パッケージがインストールされます。

VUM を使用している場合、VMware マニュアルに従って、VUM をロードし、vCenter Server 上にパッチのデータベースをすでに作成している必要があります。


注意 VEM ソフトウェアの自動インストールは、VUM でプロキシ サーバがイネーブルになっていると、失敗することがあります。これは VMware の制限によるものです。回避するには、ソフトウェアのインストール中にプロキシをディセーブルにします。

VMware Enterprise Plus ライセンスは、ホストを DVS に追加する前に、ホストにインストールされている必要があります。そうでない場合は、ホストが [Add Host to Distributed Virtual Switch] ダイアログボックスに表示されず、ホストを追加することができません。

VSM は vCenter Server にすでに接続されている必要があります。

複数のアップリンクを DVS に追加し、これらのアップリンクを使用してポート チャネルを作成するには、『 Cisco Nexus 1000V Interface Configuration Guide, Release 4.0(4)SV1(3) 』を参照してください。

手順の詳細


ステップ 1 vSphere Client で、[Inventory] > [Networking] をクリックします。

作成した次のものが表示されます。

設定したスイッチ名を持つ DVS

作成したポート プロファイル

ステップ 2 次のいずれかの手順を実行します。

DVS とポート プロファイルが表示される場合は、次の手順に進みます。

そうでない場合は、『 Cisco Nexus 1000V Troubleshooting Guide, Release 4.0(4)SV1(3) を参照してください。

 

 

ステップ 3 スイッチ名を右クリックし、[Add Host] を選択します。

[Add Host to Distributed Virtual Switch] ウィザードが開きます。


) [Add Host to Distributed Virtual Switch] ダイアログボックスが空の場合は、ホストが VMware ESX 4.0 サーバ用の Enterprise Plus ライセンスを持っていることを確認します。


 

 


) VUM を使用している場合、VUM によって、Cisco Nexus 1000V ソフトウェアがここで DVS にロードされます。


ステップ 4 次のいずれかの手順を実行します。

システムアップリンク プロファイルを使用してデータ トラフィックを伝送する場合に、システムアップリンク プロファイルがすでに定義されているときは、vm-uplink プロファイルを別の vmnic に割り当てる必要はありません。

そうでない場合は、VMware vSwitch に接続されていない次の vmnic(たとえば、vmnic1)のチェックボックスをクリックし、下向き矢印をクリックし、アップリンク ポート グループ [system-uplink] を選択します。

 

 

ステップ 5 VMware vSwitch に接続されていない次の vmnic(たとえば、vmnic2)を選択します。

vmnic はアップリンク ポート グループ [vm-uplink] にリンクされている必要があります。


) 複数のアップリンクを DVS に追加し、これらのアップリンクを使用してポート チャネルを作成するには、『Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0(4)SV1(3)を参照してください。


ステップ 6 [Next] をクリックします。

ステップ 7 ポート グループの割り当てを確認し、[Finish] をクリックします。

ステップ 8 次のいずれかの手順を実行します。

ホストが DVS に正常に追加されている場合は、次の手順に進みます。

操作に失敗する場合は、『 Cisco Nexus 1000V Troubleshooting Guide, Release 4.0(4)SV1(3) を参照してください。

ステップ 9 この手順が完了しました。
「CLI ソフトウェアの設定プロセス」に戻ります。