Cisco Nexus 1000V ポート プロファイル コンフィギュレーション ガイド リリース 4.0(4)SV1(2)
ポート プロファイルの設定
ポート プロファイルの設定
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

ポート プロファイルの設定

ポート プロファイルの概要

注意事項および制限事項

ポート プロファイルの設定

ポート プロファイルの作成

ポート プロファイル設定の継承

VMware オプションの設定

ポート管理の設定

ポート プロファイルからのポート管理ポリシーのクリア

システム ポート プロファイルの設定

ポート チャネルの設定

単一のアップストリーム スイッチに接続するポート チャネルの設定

複数のアップストリーム スイッチに接続するポート チャネルの設定

静的ピン接続の設定

vEthernet インターフェイスでの静的ピン接続の設定

コントロールまたはパケット VLAN での静的ピン接続の設定

ポート プロファイルへの VLAN の割り当て

プライベート VLAN としてのポート プロファイルの設定

MAC または IP ACL の設定

NetFlow フロー モニタの設定

ポート プロファイルのイネーブル化

ポート プロファイルの削除

継承されるポリシーの削除

ポート プロファイルの確認

ポート プロファイルの機能履歴

ポート プロファイルの設定

この章では、システム ポート プロファイルを含むポート プロファイルの設定方法について説明します。

この章で説明する内容は、次のとおりです。

「ポート プロファイルの概要」

「注意事項および制限事項」

「ポート プロファイルの設定」

「ポート プロファイルの確認」

「ポート プロファイルの機能履歴」

ポート プロファイルの概要

ポート プロファイルは、複数のインターフェイスに対して再利用可能なポリシーを定義することによって、インターフェイス設定を簡略化します。ポート プロファイルの詳細については、「概要」を参照してください。

注意事項および制限事項

ポート プロファイルやポート プロファイル機能を設定するときには、次の注意事項および制限事項に従ってください。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

アップストリーム スイッチで vPC がイネーブルになっている場合は、Cisco Nexus 1000V で Virtual Port Channel Host Mode(vPC-HM; 仮想ポート チャネル ホスト モード)を設定しないでください。vPC-HM が Cisco Nexus 1000V で設定されていて、vPC がアップストリーム スイッチで設定されている場合は、接続が中断されるか、ディセーブルになる可能性があります。vPC-HM の詳細については、「vPC ホスト モード」を参照してください。

Nexus 1000V ソフトウェアは最初に設定する必要があります。詳細については、『 Cisco Nexus 1000V Getting Started Guide, Release 4.0(4)SV1(2) 』を参照してください。

Nexus 1000V は vCenter Server に接続する必要があります。

ポート プロファイルの設定

ここでは、次の内容について説明します。

「ポート プロファイルの作成」

「ポート プロファイル設定の継承」

「VMware オプションの設定」

「ポート管理の設定」

「ポート プロファイルからのポート管理ポリシーのクリア」

「システム ポート プロファイルの設定」

「ポート チャネルの設定」

「静的ピン接続の設定」

「ポート プロファイルへの VLAN の割り当て」

「プライベート VLAN としてのポート プロファイルの設定」

「MAC または IP ACL の設定」

「NetFlow フロー モニタの設定」

「ポート プロファイルのイネーブル化」

ポート プロファイルの作成

新しいポート プロファイルを作成できます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

システム設定でポートを初期化する必要があるかどうかを知っています。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

このポート プロファイルに必要な特性を確認しました。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. (任意) description profiledescription

4. show port-profil e [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile type ethernet AllAccess1

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(Physical Network Interface Card(PNIC; 物理ネットワーク インターフェイス カード))に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

description profiledescription

 

例:

n1000v(config-port-prof)# description all_access

n1000v(config-port-prof)#

(任意)新しいポート プロファイルに説明を追加します。この説明は、自動的に vCenter Server にプッシュされます。

profiledescription 引数には最大 80 の ASCII 文字を使用でき、スペースを含めることもできます。

(注) スペースを含む説明には引用符を使用する必要はありません。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name ]

 

例:

n1000v(config-port-prof)# show port-profile name AllAccess1

(任意)指定したポート プロファイルに関する情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

 

次に、新しいポート プロファイルを作成する例を示します。

n1000v(config)# port-profile type ethernet AllAccess1
n1000v(config-port-prof)# description all_access
n1000v(config-port-prof)# show port-profile name AllAccess1
port-profile AllAccess1
description: all_access
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: -
inherit:
config attributes:
evaluated config attributes:
assigned interfaces:
n1000v(config-port-prof)#

ポート プロファイル設定の継承

ポート プロファイルは、既存のポート プロファイル設定からポリシーを継承することができます。この手順では、継承されるポート プロファイルの設定を取得し、別のプロファイルのデフォルト設定として使用します。

継承するポート プロファイルを確認するには、Cisco Nexus 1000V の現在のプロファイルを調べ(「ポート プロファイルのイネーブル化」を参照)、ニーズに最適な特性を持つポート プロファイルを探します。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

表 1-3 を理解しています。ここには、継承できる特性と継承できない特性が示されています。

ポリシーが継承される既存のポート プロファイルの名前を知っています。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。ポート プロファイルのタイプを別のポート プロファイルから継承できません。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. inherit port-profile name

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name ]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile type vethernet AllAccess2

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

inherit port-profile name

 

例:

n1000v(config-port-prof)# inherit port-profile AllAccess1

n1000v(config-port-prof)#

継承される設定をデフォルトの設定として新しいポート プロファイルに追加します。継承される設定は、ポート プロファイル タイプを除き、いずれも CLI を使用して変更できます。

引数は次のとおりです。

name :ポリシーが継承されるポート プロファイルの名前を指定します。ポート プロファイルには最大 80 文字の名前を設定できます。ポート プロファイル名は、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name ]

 
:
n1000v(config-port-prof)# show port-profile AllAccess2

(任意)指定したポート プロファイルに関する情報を表示します。

現在のポート プロファイルによって継承されるポート プロファイルを表示するには、 show port-profile name profile-name コマンドを使用します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、別のポート プロファイルのポート プロファイル設定を継承する例を示します。

n1000v# config t
n1000v(config)# port-profile AllAccess2
n1000v(config-port-prof)# inherit port-profile AllAccess1
n1000v(config-port-prof)# show port-profile name AllAccess2
port-profile AllAccess2
description:
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit: port-profile AllAccess1
config attributes:
evaluated config attributes:
assigned interfaces:

n1000v(config-port-prof)#

 

VMware オプションの設定

ポート プロファイルを VMware ポート プロファイルとして指定できます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

VMware ポート グループにポート プロファイルと同じ名前を設定するか、または VMware ポート グループに別の名前を指定するかを知っています。

vmware max-ports コマンドは、非アップリンク プロファイルだけに使用できます。

ポート プロファイルに割り当てられるポートの最大数を制限するかどうかを知っています (その場合、その最大数を知っています)。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. vmware port-group [ pg_name ]

4. vmware max-ports number

5. show port-profile [ brief | expand-interface | usage ] [name profile-name ]

6. copy running-config startup-config

手順の詳細

 

コマンド
説明/結果

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

vmware port-group [ pg_name ]

 

例:

n1000v(config-port-prof)# vmware port-group n1000v(config-port-prof)#

 

ポート プロファイルを VMware ポート グループとして指定します。

ポート プロファイルは、同じ名前の VMware ポート グループにマップされます。vCenter Server への接続が確立されると、Cisco Nexus 1000V で作成されたポート グループは、vCenter Server 上の仮想スイッチに配布されます。

引数は次のとおりです。

pg-name :ポート グループの名前を指定します。名前を指定しない場合、ポート グループ名はポート プロファイル名と同じになります。

ステップ 4

vmware max-ports num

 

例:

n1000v(config-port-prof)# vmware max-ports 5

n1000v(config-port-prof)#

 

非アップリンク ポート プロファイルに割り当てられるポートの最大数を指定します。

指定したポートの最大数に達すると、ポートを割り当てられなくなります。

デフォルトは 32 ポートです。

ステップ 5

show port-profile [ brief | expand-interface | usage ] [name profile-name ]

 

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルに関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、ポート プロファイルを VMware ポート プロファイルとして指定する例を示します。

例:
n1000v# config t
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# vmware port-group
n1000v(config-port-prof)# vmware max-ports 5
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
description: allaccess4
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: 8
pinning packet-vlan: 8
system vlans: none
port-group: AccessProf
max ports: 5
inherit:
config attributes:
evaluated config attributes:
assigned interfaces:n1000v(config-port-prof)#

ポート管理の設定

アクセス モードまたはトランク モード、プロファイル内の各ポートの管理ステートなどのポート管理を設定できます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

ポート プロファイルをアクセス ポートとして設定するか、トランク ポートとして設定するかを知っています。

アクセス ポートは、非タグ付きの 1 つだけの VLAN のパケットを伝送します。インターフェイスが伝送する VLAN トラフィックを指定します。これがアクセス VLAN になります。アクセス ポートの VLAN を指定しない場合、そのインターフェイスはデフォルト VLAN のトラフィックだけを伝送します。デフォルト VLAN は VLAN1 です。

トランク ポートは、ネイティブ VLAN に対しては非タグ付きパケットを伝送し、他のすべての VLAN に対してはカプセル化されたタグ付きパケットを伝送します。

ポート プロファイルに割り当てられるポートの最大数を制限するかどうかを知っています (その場合、その最大数を知っています)。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. switchport mode { access | trunk }

4. no shutdown

5. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

6. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

switchport mode { access | trunk }

 

例:

n1000v(config-port-prof)# switchport mode access

n1000v(config-port-prof)#

インターフェイスをスイッチ アクセス ポート(デフォルト)またはトランク ポートとして指定します。

ステップ 4

no shutdown

 

例:

n1000v(config-port-prof)# no shutdown

n1000v(config-port-prof)#

管理上の目的でプロファイル内のすべてのポートをイネーブルにします。

ステップ 5

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルに関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、ポート プロファイルにスイッチ アクセス ポートを設定する例と、ポートをイネーブルにする例を示します。

例:
n1000v# config t
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# switchport mode access
n1000v(config-port-prof)# no shutdown
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
description: allaccess4
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: 8
pinning packet-vlan: 8
system vlans: none
port-group: AccessProf
max ports: 5
inherit:
config attributes:
switchport mode access
no shutdown
evaluated config attributes:
switchport mode access
no shutdown
assigned interfaces:
n1000v(config-port-prof)#
 

ポート プロファイルからのポート管理ポリシーのクリア

shutdown または switchport mode コンフィギュレーションのいずれかをポート プロファイルから削除し、デフォルトの状態に変更できます。shutdown コンフィギュレーションを削除すると、ポート プロファイル ポートの状態が shutdown に変更されます。switchport mode コンフィギュレーションを削除すると、ポート プロファイル ポートがスイッチ アクセス ポートに変換されます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

アトリビュートのコンフィギュレーションを削除すると、そのアトリビュートは、show コマンド出力に表示されなくなります。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. default { shutdown | switchport mode }

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

default { shutdown | switchport mode }

 

例:

n1000v(config-port-prof)# default switchport mode

n1000v(config-port-prof)#

shutdown アトリビュートまたは switchport mode アトリビュートのいずれかのコンフィギュレーションをポート プロファイルから 削除します。

キーワードは次のとおりです。

shutdown:ポート プロファイル ポートを shutdown ステートに戻します。

switchport mode:ポート プロファイル ポートをスイッチ アクセス ポートに戻します。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルに関する情報を表示します。アトリビュートのコンフィギュレーションを削除すると、そのアトリビュートは、 show コマンド出力に表示されません。

次に、ポート プロファイルの管理ステートをデフォルト設定(全ポートがディセーブルの状態)に戻す例を示します。

n1000v# config t
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# default shutdown
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
description: allaccess4
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: 8
pinning packet-vlan: 8
system vlans: none
port-group: AccessProf
max ports: 5
inherit:
config attributes:
switchport mode access
evaluated config attributes:
switchport mode access
assigned interfaces:
n1000v(config-port-prof)#
 

システム ポート プロファイルの設定

クリティカル ポートに対してシステム ポート プロファイルを設定できます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

次の設定が済んでいます。

ポートの admin ステータスは active(no shutdown) です。

ポート モードは access または trunk です。

システム VLAN として使用する VLAN が存在しています。

VLAN はアクセス VLAN またはトランク対応 VLAN として設定されています。

システム ポート プロファイルの詳細については、「システム ポート プロファイルの概要」を参照してください。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. description profiledescription

4. system vlan vlan-id-list

5. show port-profil e [ brief | expand-interface | usage ] [ name profile-name]

6. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

description profiledescription

 

例:

n1000v(config-port-prof)# description “System profile for critical ports”

n1000v(config-port-prof)#

ポート プロファイルに説明を追加します。この説明は、自動的に vCenter Server にプッシュされます。

profiledescription 引数には最大 80 文字の ASCII 文字を使用できます。

(注) スペースを含む説明には引用符を使用する必要はありません。

ステップ 4

system vlan vlan-id-list

 

例:

n1000v(config-port-prof)# system vlan 114,115

n1000v(config-port-prof)#

このポート プロファイルにシステム VLAN を追加します。システム VLAN は、Virtual Supervisor Module(VSM; 仮想スーパーバイザ モジュール)と システム VLAN を使用し、VSMが Virtual Ethernet Module(VEM; 仮想イーサネット モジュール)との通信を確立するよりも前に物理ポートまたは vEthernet ポートを設定し、起動します。

ステップ 5

show port-profil e [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルに関する情報を表示します。アトリビュートのコンフィギュレーションを削除すると、そのアトリビュートは、 show コマンド出力に表示されません。

次に、システム ポート プロファイルを作成する例を示します。

n1000v# config t
n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)# description "System profile for critical ports"

n1000v(config-port-prof)# system vlan 1
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
description:
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: 1
port-group:
max ports: 32
inherit: port-profile xyz
config attributes:
switchport mode access
switchport access vlan 1
switchport trunk allowed vlan 1-10
channel-group auto mode on sub-group cdp
no shutdown
evaluated config attributes:
switchport mode access
switchport access vlan 1
switchport trunk allowed vlan 1-10
channel-group auto mode on sub-group cdp
no shutdown
assigned interfaces:
 

ポート チャネルの設定

単一または複数のアップストリーム スイッチに接続するポート チャネルを設定することができます。

ここでは、次の内容について説明します。

「単一のアップストリーム スイッチに接続するポート チャネルの設定」

「複数のアップストリーム スイッチに接続するポート チャネルの設定」

単一のアップストリーム スイッチに接続するポート チャネルの設定

すべてのポートが同一のアップストリーム スイッチに接続されている場合は、ポート プロファイルにポート チャネルを設定できます。

ポートが複数のアップストリーム スイッチに接続されている場合に、ポート プロファイルにポート チャネルを設定するには、「複数のアップストリーム スイッチに接続するポート チャネルの設定」を参照してください。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

ポート プロファイルが最初のインターフェイスに割り当てられたときに、チャネル グループ番号が自動的に割り当てられています。

ポート チャネルを設定する際に、アップストリーム スイッチがポート チャネルをサポートしていない場合は、MAC ピン接続を使用すると、各イーサネット ポート メンバーを特定のポート チャネル サブグループに割り当てられるようになります。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

アップストリーム スイッチで vPC がイネーブルになっている場合は、Cisco Nexus 1000V で vPC-HM を設定しないでください。vPC-HM が Cisco Nexus 1000V で設定されていて、vPC がアップストリーム スイッチで設定されている場合は、接続の問題が発生する可能性があります。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. 次のいずれかを実行します。

アップストリーム スイッチがポート チャネルをサポートしている場合は、 channel-group auto [ mode {on | active | passive}] を入力します。

アップストリーム スイッチがポート チャネルをサポートしていない場合は、 channel-group auto [ mode {on | active | passive}] mac-pinning を入力します。

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

次のいずれかを実行します。

アップストリーム スイッチがポート チャネルをサポートしている場合は、 channel-group auto [ mode { on | active | passive }] を入力します。

アップストリーム スイッチがポート チャネルをサポートしていない場合は、 channel-group auto [ mode { on | active | passive }] mac-pinning を入力します。

 

例:

n1000v(config-port-prof)# channel-group auto mode on

n1000v(config-port-prof)#

ポート チャネル グループを定義します。

キーワードは次のとおりです。

auto:ポート プロファイルが最初のインターフェイスに割り当てられたときに、一意のポート チャネルが 1 つ作成され、自動的に割り当てられることを指定します。同じモジュールに属する追加インターフェイスは、それぞれ同じポート チャネルに追加されます。VMware 環境では、各モジュールに対して異なるポート チャネルが作成されます。

mode: on、active、または passive を指定します(active および passive は LACP を使用します)。

mac-pinning :イーサネット メンバー ポートがサブグループ(メンバー ポートあたり 1 つのサブグループ)に自動的に割り当てられることを指定します。このオプションは、アップストリーム スイッチがポート チャネルをサポートしていない場合に使用します。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルに関する情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、単一のアップストリーム スイッチに接続するポート チャネルを設定する例を示します。

例:
n1000v# config t
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# channel-group auto mode on
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
description: allaccess4
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on
evaluated config attributes:
channel-group auto mode on
assigned interfaces:
n1000v(config-port-prof)#

複数のアップストリーム スイッチに接続するポート チャネルの設定

ポート チャネル内のポートが複数のアップストリーム スイッチに接続する場合は、vPC-HM 内の VEM の物理 Network Interface Card(NIC; ネットワーク インターフェイス カード)が使用するアップリンク ポート プロファイルを設定できます。

ポートが単一のアップストリーム スイッチに接続されている場合に、ポート プロファイルにポート チャネルを設定するには、「ポート チャネルの設定」を参照してください。

インターフェイスで vPC-HM を設定することもできます。詳細については、『 Cisco Nexus 1000V Interface Configuration Guide, Release 4.0(4)SV1(2) 』を参照してください。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

ポート チャネルの作成時には、関連付けられたチャネル グループが自動的に作成されます。

チャネル グループ モードは on に設定する必要があります。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

Cisco Discovery Protocol(CDP; シスコ検出プロトコル)がアップストリーム スイッチで設定されているかどうかを確認する必要があります。設定されている場合は、CDP によって、各アップストリーム スイッチがトラフィックを個別に管理するためのサブグループが作成されます。設定されていない場合は、個別のスイッチ上のトラフィック フローを管理するためのサブグループを手動で設定する必要があります。

CDP をデフォルトの CDP タイマー(60 秒)で使用している場合は、稼動中をアドバタイズした直後に停止をアドバタイズしたリンクが稼動状態に戻るまでに、最大 60 秒かかります。

ポート チャネルを設定する際に、アップストリーム スイッチがポート チャネルをサポートしていない場合は、MAC ピン接続を使用すると、各イーサネット ポート メンバーを特定のポート チャネル サブグループに接続できるようになります。

ポート チャネルが 2 つの異なるアップストリーム スイッチに接続する際に、vPC-HM が設定されていない場合は、不明なユニキャスト、マルチキャスト フラッド、およびブロードキャストについて、Cisco Nexus 1000V の背後にある VM がネットワークから重複するパケットを受信します。

アップストリーム スイッチで vPC がイネーブルになっている場合は、Cisco Nexus 1000V で vPC-HM を設定しないでください。vPC-HM が Cisco Nexus 1000V で設定されていて、vPC がアップストリーム スイッチで設定されている場合は、接続の問題が発生する可能性があります。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. 次のいずれかを実行します。

アップストリーム スイッチがポート チャネルをサポートしていない場合は、 channel-group auto mode on mac-pinning を入力して、ステップ 8. に進みます。

CDP がアップストリーム スイッチで設定されている場合は、 channel-group auto mode on sub-group cdp を入力して、ステップ 8. に進みます。

CDP がアップストリーム スイッチで設定されていない場合は、 channel-group auto mode on sub-group manual を入力して、次の手順に進みます。

4. exit

5. interface ethernet range

6. sub-group-id number

7. CDP 用に設定されていないアップストリーム スイッチに接続されているポート メンバーごとに、ステップ 5 および 6 を繰り返します。

8. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

9. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile uplinkProf

n1000v(config-port-prof)#

イーサネット タイプのポート プロファイル(デフォルト)を作成し、グローバル コンフィギュレーション モードを開始します。

イーサネット タイプのポート プロファイルは物理ポートに使用できます。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

(注) ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

ポート プロファイルには最大 80 文字の名前を設定できます。ポート プロファイル名は、Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

次のいずれかを実行します。

アップストリーム スイッチがポート チャネルをサポートしていない場合は、 channel-group auto mode on mac-pinning を入力して、ステップ 8 に進みます。

CDP がアップストリーム スイッチで設定されている場合は、 channel-group auto mode on sub-group cdp を入力して、 ステップ 8 に進みます。

CDP がアップストリーム スイッチで設定されていない場合は、 channel-group auto mode on sub-group manual を入力して、次の手順に進みます。

 
 
例:

n1000v(config-port-prof)# channel-group auto mode on sub-group cdp

n1000v(config-port-prof)#

非対称ポート チャネル(vPC-HM とも呼ばれる)を定義します。

キーワードは次のとおりです。

auto:ポート プロファイルが最初のインターフェイスに割り当てられたときに、一意のポート チャネルが 1 つ作成され、自動的に割り当てられることを指定します。同じモジュールに属する追加インターフェイスは、それぞれ同じポート チャネルに追加されます。VMware 環境では、各モジュールに対して異なるポート チャネルが作成されます。

mode: vPC-HM の場合はチャネル モードが on になることを指定します (active および passive モードは LACP を使用し、vPC-HM ではサポートされません)。

sub-group :このチャネル グループを非対称として識別します。

cdp :CDP 情報を使用してトラフィック フローを管理するためのサブグループを自動的に作成することを指定します。

manual :サブグループが手動で設定されることを指定します。このオプションは、アップストリーム スイッチで CDP が設定されていない場合に使用します。

mac-pinning :イーサネット メンバー ポートがサブグループ(メンバー ポートあたり 1 つのサブグループ)に自動的に割り当てられることを指定します。このオプションは、アップストリーム スイッチがポート チャネルをサポートしていない場合に使用します。

ステップ 4

exit

 

例:

n1000v(config-port-prof)# exit

n1000v(config)#

ポート チャネルのポート プロファイル コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 5

interface ethernet range

 

例:

n1000v(config)# interface ethernet3/2-3

n1000v(config-if)#

指定したインターフェイス範囲でインターフェイス コンフィギュレーション モードを開始します。

ステップ 6

sub-group id number

 

例:

n1000v(config-if)# sub-group-id 0

n1000v(config-if)#

指定したポート チャネル メンバーを vPC-HM として設定して、指定したサブグループがいずれかのアップストリーム スイッチのトラフィックを管理できるようにします。

サブグループの許容範囲は 0 ~ 31 です。

ステップ 7

CDP 用に設定されていないアップストリーム スイッチに接続するポート メンバーごとに、ステップ 5 および ステップ 6 を繰り返します。

--

ステップ 8

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルに関する情報を表示します。

ステップ 9

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、CDP をサポートしている複数のアップストリーム スイッチに接続するポート チャネルを作成する例を示します。

n1000v(config)# port-profile UpLinkProfile2
n1000v(config-port-prof)# channel-group auto mode on sub-group cdp
n1000v(config-port-prof)# show port-profile name UpLinkProfile2
port-profile UpLinkProfile2
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on sub-group cdp
evaluated config attributes:
channel-group auto mode on sub-group cdp
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 
 

次に、CDP をサポートしていない複数のアップストリーム スイッチに接続するポート チャネルを作成する例を示します。

n1000v(config)# port-profile UpLinkProfile3

n1000v(config-port-prof)# channel-group auto mode on sub-group manual

n1000v(config-port-prof)# exit

n1000v(config)# interface ethernet3/2-3

n1000v(config-if)# sub-group-id 0

n1000v(config-port-prof)# show port-profile name
n1000v(config-port-prof)# show port-profile name UplinkProfile3
port-profile UplinkProfile3
description:
type: ethernet
status: enabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group: UplinkProfile3
max ports: -
inherit:
config attributes:
channel-group auto mode on sub-group manual
evaluated config attributes:
channel-group auto mode on sub-group manual
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 
 

次に、ポート チャネルをサポートしていない複数のアップストリーム スイッチに接続するポート チャネルを作成する例を示します。

n1000v(config)# port-profile UpLinkProfile1
n1000v(config-port-prof)# channel-group auto mode on mac-pinning
n1000v(config-port-prof)# show port-profile name UpLinkProfile1
port-profile UpLinkProfile1
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on mac-pinning
evaluated config attributes:
channel-group auto mode on mac-pinning
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 

静的ピン接続の設定

vEthernet インターフェイスや、コントロール VLAN またはパケット VLAN で静的ピン接続を設定できます。

ここでは、次の内容について説明します。

「vEthernet インターフェイスでの静的ピン接続の設定」

「コントロールまたはパケット VLAN での静的ピン接続の設定」

vEthernet インターフェイスでの静的ピン接続の設定

ポート プロファイルで、vEthernet インターフェイスで静的ピン接続を設定できます。


) また、特定の vEthernet インターフェイスで静的ピン接続を設定することも可能です。詳細については、『Cisco Nexus 1000V Interface Configuration Guide, Release 4.0(4)SV1(2)』を参照してください。


始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

手順の概要

1. config t

2. port-profile type vethernet name

3. pinning id sub-group_id

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile type vethernet name

 

例:

n1000v(config)# port-profile type vethernet PortProfile1

n1000v(config-port-prof)#

ポート プロファイル コンフィギュレーション モードを開始し、vEthernet タイプのポート プロファイルを作成します(まだ作成されていない場合)。

ポート プロファイルには最大 80 文字の名前を設定できます。ポート プロファイル名は、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

pinning id sub-group_id

 

例:

n1000v(config-port-prof)# pinning id 3

vEthernet インターフェイスを特定のポート チャネル サブグループ(0 ~ 32)に割り当て(またはピン接続)します。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile PortProfile1

(任意)指定したポート プロファイルに関する情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、vEthernet ポート プロファイルを作成し、それをサブグループ 3 にピン接続する例を示します。

n1000v# config t
n1000v(config)# port-profile type vethernet PortProfile1
n1000v(config-port-prof)# pinning id 3
n1000v(config-port-prof)# show port-profile name PortProfile1
port-profile PortProfile1
description:
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
pinning id 3
evaluated config attributes:
pinning id 3
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 

コントロールまたはパケット VLAN での静的ピン接続の設定

コントロール VLAN またはパケット VLAN で静的ピン接続を設定できます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

コントロール VLAN またはパケット VLAN で静的ピン接続を設定するには、イーサネット タイプのシステム ポート プロファイルが必要です。詳細については、「システム ポート プロファイルの設定」を参照してください。

コントロール VLAN で静的ピン接続を設定する場合は、コントロール VLAN がポート プロファイルのシステム VLAN の 1 つとして指定されていることを確認します。

パケット VLAN で静的ピン接続を設定する場合は、パケット VLAN がポート プロファイルのパケット VLAN の 1 つとして指定されていることを確認します。

手順の概要

1. config t

2. port-profile name

3. pinning { control-vlan | packet-vlan } sub-group_id

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile name

 

例:

n1000v(config)# port-profile SystemProfile1

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、システム ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

pinning { control-vlan | packet-vlan } sub-group_id

 

例:

n1000v(config-port-prof)# pinning control-vlan 3

n1000v(config-port-prof)#

コントロール VLAN またはパケット VLAN を特定のポート チャネル サブグループ(0 ~ 32)に割り当て(またはピン接続)します。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile SystemProfile1

(任意)指定したポート プロファイルに関する情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、コントロール VLAN で静的ピン接続を設定する例を示します。

n1000v# config t
n1000v(config)# port-profile SystemProfile1
n1000v(config-port-prof)# pinning control-vlan 3
n1000v(config-port-prof)# show port-profile SystemProfile1
port-profile SystemProfile1
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: 3
pinning packet-vlan: -
system vlans: 1
port-group: SystemProfile1
max ports: -
inherit:
config attributes:
switchport mode trunk
switchport trunk allowed vlan 1-5
no shutdown
evaluated config attributes:
switchport mode trunk
switchport trunk allowed vlan 1-5
no shutdown
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config
 
 

次に、パケット VLAN で静的ピン接続を設定する例を示します。

n1000v# config t
n1000v(config)# port-profile SystemProfile1
n1000v(config-port-prof)# pinning packet-vlan 0
n1000v(config-port-prof)# show port-profile name SystemProfile1
port-profile SystemProfile1
description:
type: ethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: 0
system vlans: 1
port-group:
max ports: -
inherit:
config attributes:
switchport mode access
switchport access vlan 1
switchport trunk native vlan 1
no shutdown
evaluated config attributes:
switchport mode access
switchport access vlan 1
switchport trunk native vlan 1
no shutdown
assigned interfaces:
n1000v(config-port-prof)# copy running-config startup-config

ポート プロファイルへの VLAN の割り当て

VLAN をポート プロファイルに割り当てることができます。


) このスイッチ ポートをデフォルトの VLAN 1 に割り当てる場合、これはデフォルトの設定なので、操作は必要ありません。


始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

トランク ポートまたはアクセス ポートにポート プロファイルが必要かどうかを知っています。

このポート プロファイルに必要な VLAN コンフィギュレーションを知っています。

VLAN を割り当てる前に、スイッチ上で VLAN を作成済みです。

割り当てる VLAN の VLAN ID を知っています。

VLAN1 は、デフォルト VLAN です。この VLAN の作成、変更、または削除はできません。

サポートされている VLAN 範囲を知っています。Cisco Nexus 1000V は IEEE 802.1Q 標準に準拠して、4094 のVLAN をサポートします。これらの VLAN は、用途の異なる範囲で構成されています。 表 2-1 に使用可能な VLAN 範囲を示します。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

 

表 2-1 VLAN 範囲

VLAN 番号
範囲
用途

1

標準

Cisco デフォルト値。この VLAN は使用できますが、変更または削除はできません。

2 ~ 1005

標準

これらの VLAN は、作成、使用、変更、および削除できます。

1006 ~ 4094

拡張

これらの VLAN は、作成、命名、および使用できます。次のパラメータは変更できません。

ステートは常にアクティブ

VLAN は常にイネーブル

これらの VLAN はシャットダウンできません。

3968 ~ 4047 および 4094

内部割り当て済み

これら 80 の VLAN および VLAN 4094 は、内部デバイスが使用するために割り当てられます。内部用途で予約されているブロック内の VLAN は、いずれも作成、削除、または変更できません。

 

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. 次のいずれかを実行します。

(任意) switchport access vlan vlan-id-access

(任意) switchport trunk allowed vlan {allowed-vlans | add add-vlans | except except-vlans | remove remove-vlans | all | none}

4. switchport trunk native vlan vlan-id

5. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

6. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

次のいずれかを実行します。

VLAN ID をこのポート プロファイルのアクセス ポートに割り当てるには、 switchport access vlan vlan-id-access を入力します。

トランク ポート上で使用可能な VLAN ID を指定するには、 switchport trunk allowed vlan { allowed-vlans | add add-vlans | except except-vlans | remove remove-vlans | all | none } を入力します。

 

例:

n1000v(config-port-prof)# switchport trunk allowed vlan all

switchport access vlan コマンドは、ポート プロファイルのトランク ポート上で使用可能な VLAN を指定します。 vlan-id-access 引数は、アクセス VLAN の ID を指定します。

switchport trunk native vlan コマンドは、インターフェイスがトランキング モードのときに、トランキングのネイティブ特性を設定します。キーワードおよび引数は次のとおりです。

allowed-vlans :使用可能な VLAN の VLAN ID(1 ~ 3967 および 4048 ~ 4093)を指定します。

add :ポート プロファイルに割り当てられた VLAN ID の現行リストに、 add-vlans 引数で定義された VLAN ID を追加する場合に指定します。

except except-vlans 引数で定義された VLAN ID を除くすべての VLAN ID をポート プロファイルに追加する場合に指定します。

remove remove-vlans 引数で定義された VLAN ID をポート プロファイルから削除する場合に指定します。

all :すべての VLAN ID を使用可能な VLAN として指定します。

none :使用可能な VLAN がないことを指定します。

ステップ 4

switchport trunk native vlan vlan-id

 

例:

n1000v(config-port-prof)# switchport trunk native vlan 3

インターフェイスがトランキング モードのときに、トランキングのネイティブ特性を設定します。

ステップ 5

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile AccessProf

(任意)ポート プロファイルに関する情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、VLAN をポート プロファイルに割り当て、ポート プロファイルのネイティブ VLAN 設定する例を示します。

例:
n1000v# config t
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# switchport trunk allowed vlan all
n1000v(config-port-prof)# switchport trunk native vlan 3
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
description: allaccess4
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
switchport trunk native vlan 3
switchport trunk allowed vlan all
channel-group auto mode on
evaluated config attributes:
switchport trunk native vlan 3
switchport trunk allowed vlan all
channel-group auto mode on
assigned interfaces:n1000v(config-port-prof)#
 

プライベート VLAN としてのポート プロファイルの設定

プライベート VLAN(PVLAN)として使用するポート プロファイルを設定することができます。

プライベート VLAN の詳細については、『 Cisco Nexus 1000V Layer 2 Switching Configuration Guide, Release 4.0(4)SV1(2) 』を参照してください。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

プライベート VLAN ペアのプライマリ VLAN およびセカンダリ VLAN の両方の VLAN ID を知っています。

このプライベート VLAN がその設定を継承するかどうかを知っています。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. switchport mode private-vlan { host | promiscuous }

4. switchport private-vlan host-association primary-vlan secondary-vlans

5. switchport private-vlan mapping primary_vlan [add | remove] secondary_vlans

6. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

7. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

switchport mode private-vlan { host | promiscuous }

 

例:

n1000v(config-port-prof)# switchport mode private-vlan promiscuous

n1000v(config-port-prof)#

 

プライベート VLAN として使用するポート プロファイルを指定します。

キーワードは次のとおりです。

promiscuous:プライマリ VLAN に属し、レイヤ 3 ゲートウェイと通信する無差別ポートを指定します。無差別ポートは、セカンダリ VLAN に関連付けられているインターフェイスを含む、PVLAN ドメイン内の任意のインターフェイスと通信できます。

host:PVLAN ペアのセカンダリ VLAN に属するホスト ポートを次のいずれかとして指定します。

コミュニティ PVLAN のホスト ポート

隔離 PVLAN のホスト ポート

ステップ 4

switchport private-vlan host-association primary-vlan secondary-vlans

 

例:

n1000v(config-port-prof)# switchport private-vlan host-association 3 300 301 302

n1000v(config-port-prof)#

プライマリ PVLAN ID およびセカンダリ PVLAN ID をポート プロファイルに割り当て、この関係を実行コンフィギュレーションに保存します。

primary-vlan :プライマリ VLAN ID を指定します。

s econdary-vlans :セカンダリ VLAN ID を指定します。複数の VLAN ID を指定できます。

ステップ 5

switchport private-vlan mapping primary_vlan
[add | remove] secondary_vlans

 

例:

n1000v(config-port-prof)# switchport private-vlan mapping primary_vlan add 3 300 301 302

n1000v(config-port-prof)#

ポート プロファイルの PVLAN をマップし、実行コンフィギュレーションに保存します。

ステップ 6

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルに関する情報を表示します。

ステップ 7

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

MAC または IP ACL の設定

ポート プロファイルに対して MAC または IP Access Control List(ACL; アクセス コントロール リスト)を設定できます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

このポート プロファイルに対して設定する IP または MAC アクセス コントロールリストの名前を知っています。

アクセス リストのパケット フローの方向を知っています。

ACL の詳細については、『 Cisco Nexus 1000V Security Configuration Guide, Release 4.0(4)SV1(2) 』を参照してください。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. 次のいずれかを実行します。

mac port access-group name { in | out }

ip port access-group name { in | out }

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

次のいずれかを実行します。

MAC ACL を追加するには、 mac port access-group name { in | out } を入力します。

IP ACL を追加するには、 ip port access-group name { in | out } を入力します。

 

例:

n1000v(config-port-prof)# mac port access-group allaccess4 out

 

例:

n1000v(config-port-prof)# ip port access-group allaccess4 in

mac port access-port group コマンドは、MAC ACL をポート プロファイルに追加します。

ip port access-group コマンドは、IP ACL をポート プロファイルに追加します。

キーワードおよび引数は次のとおりです(どちらのコマンドも同じです)。

acl_name :このポート プロファイルに追加する ACL の名前を指定します。

in :着信トラフィックを指定します。

out :発信トラフィックを指定します。

ステップ 4

show port-profile name profile-name

 

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルの設定を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、ポート プロファイルに MAC または IP ACL を設定する例を示します。

n1000v# config t
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# mac port access-group allaccess4 out

n1000v(config-port-prof)# ip port access-group allaccess4 in

n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
description: allaccess4 out
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
ip port access-group allaccess4 in
mac port access-group allaccess4 out
evaluated config attributes:
ip port access-group allaccess4 in
mac port access-group allaccess4 out
assigned interfaces:n1000v(config-port-prof)#
 

NetFlow フロー モニタの設定

ポート プロファイルに NetFlow フロー モニタを設定できます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

NetFlow の詳細については、『 Cisco Nexus 1000V System Management Configuration Guide, Release 4.0(4)SV1(2) 』を参照してください。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. ip flow monitor name {input | output}

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

ip flow monitor name { input | output }

 

例:

n1000v(config-port-prof)# ip flow monitor allaccess4 output

n1000v(config-port-prof)#

フロー モニタをポート プロファイルに適用します。

キーワードおよび引数は次のとおりです。

name :フロー モニタの名前を追加します。

input:着信トラフィックにフロー モニタを適用します。

output:発信トラフィックにフロー モニタを適用します。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルに関する情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、ポート プロファイルに NetFlow フロー モニタを設定する例を示します。

n1000v# config t
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# ip flow monitor allacces4 output
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
ip flow monitor allaccess4 output
evaluated config attributes:
ip flow monitor allaccess4 output
assigned interfaces:n1000v(config-port-prof)#

ポート プロファイルのイネーブル化

ポート プロファイルをイネーブルにできます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

ポート プロファイルを作成したあとで、そのプロファイルのタイプ(イーサネットまたは vEthernet)を変更できません。

手順の概要

1. config t

2. port-profile [ type { ethernet | vethernet }] name

3. state enabled

4. show port-profile [ brief | expand-interface | usage ] [ name profile-name]

5. copy running-config startup-config

手順の詳細

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile [ type { ethernet | vethernet }] name

 

例:

n1000v(config)# port-profile AccessProf

n1000v(config-port-prof)#

グローバル コンフィギュレーション モードを開始して、ポート プロファイルを定義します。

キーワードおよび引数は次のとおりです。

type :(任意)ポート プロファイルのタイプをイーサネットまたは vEthernet として指定します。この設定は、あとで変更できません。デフォルトは vEthernet タイプです。

ポート プロファイルをイーサネット タイプとして定義すると、ポート プロファイルを物理(イーサネット)ポートに使用できるようになります。vCenter Server で、対応するポート グループを選択し、物理ポート(PNIC)に割り当てることができます。

(注) ポート プロファイルがイーサネット タイプとして設定される場合、VMware 仮想ポートの設定には使用できません。

name :ポート プロファイル名を指定します。名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。

ステップ 3

state enabled

 

例:

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

ポート プロファイルをイネーブルにします。

ポート プロファイルの設定が、割り当てられるポートに適用されます。ポート プロファイルが VMware ポート グループを指定する場合、ポート グループは vCenter Server 上の vSwitch に作成されます。

ステップ 4

show port-profile [ brief | expand-interface | usage ] [ name profile-name]

 

例:

n1000v(config-port-prof)# show port-profile name AccessProf

(任意)ポート プロファイルに関する情報を表示します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、ポート プロファイルをイネーブルにする例を示します。

n1000v# config t
n1000v(config)# port-profile AccessProf
n1000v(config-port-prof)# state enabled
n1000v(config-port-prof)# show port-profile name AccessProf
port-profile AccessProf
description: allaccess4
status: enabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on
evaluated config attributes:
channel-group auto mode on
assigned interfaces:
n1000v(config-port-prof)#n1000v(config-port-prof)#

ポート プロファイルの削除

ポート プロファイルを削除できます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

EXEC モードで CLI にログインしています。

ポート プロファイルが別のポート プロファイルによって継承される場合は、このポート プロファイルを削除する前に、別のポート プロファイルから継承を削除する必要があります。継承を先に削除しないと、この手順は失敗します。「継承されるポリシーの削除」 を参照してください。

VMware ポート グループにマップされているポート プロファイルを削除する場合、vCenter Server 内で関連付けられているポートグループと設定も削除されます。

手順の概要

1. config t

2. (任意)show port-profile usage name profile_name

3. no port-profile profile_name

4. show port-profile name profile_name

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

show port-profile usage name profile_name

 

例:

n1000v(config)# show port-profile usage name AccessProf

(任意)アクティブ インターフェイスがこのポート プロファイルを使用しているかどうかを確認します。

(注) ポート プロファイルに関連付けられているアクティブ インターフェイスが存在する場合は、ポート プロファイルを削除できません。

ステップ 3

no port-profile profile_name

 

例:

n1000v(config)# no port-profile AccessProf
n1000v(config)#

ポート プロファイル設定および動作設定を削除します。

ステップ 4

show port-profile name profile_name

 

例:

n1000v(config)# show port-profile name AccessProf
ERROR: port-profile AccessProf does not exist
n1000v(config)#

(任意)ポート プロファイルが存在しないことを確認します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

次に、ポート プロファイルを削除する例を示します。

n1000v# config t

n1000v(config)# show port-profile usage name AccessProf

--------------------------------------------------------------------------------

Port Profile Port Adapter Owner

--------------------------------------------------------------------------------

n1000v(config)# no port-profile AccessProf
n1000v(config)# show port-profile name AccessProf
ERROR: port-profile AccessProf does not exist
n1000v(config)# copy running-config startup-config
 

継承されるポリシーの削除

ポート プロファイルから継承されるポリシーを削除できます。

始める前に

この手順を始める前に、次のことを認識または実行する必要があります。

コンフィギュレーション モードで CLI にログインしています。

手順の概要

1. config t

2. (任意)show port-profile usage name profile_name

3. no port-profile inherit

4. show port-profile name profile_name

5. copy running-config startup-config

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

例:

n1000v# config t

n1000v(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile name

 

例:

(config)# port-profile Access4
(config-port-prof)#

指定したポート プロファイルに対して、グローバル コンフィギュレーション モードを開始します。

ステップ 3

no port-profile inherit

 

例:

(config-port-prof)# no port-profile map

継承されるポリシーを削除します。

継承されるポリシーに依存せずに明示的に設定されたポート プロファイル タイプと任意の設定を除き、ポート プロファイルの設定はデフォルトに戻ります。

ステップ 4

show port-profile name profile_name

 

例:

n1000v(config)# show port-profile name AccessProf

(任意)ポート プロファイルが存在しないことを確認します。

ステップ 5

copy running-config startup-config

 

例:

n1000v(config-port-prof)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

ポート プロファイルの確認

ポート プロファイルの設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show port-profile [ brief | expand-interface | usage ] [ name profile-name ]

ポート プロファイルの設定を表示します。

show running-config interface { ethernet slot/port | mgmt 0 | vethernet number }

インターフェイスの割り当てを含む、ポート プロファイルの設定を表示します。

これらのコマンド出力のフィールドの詳細については、『 Cisco Nexus 1000V Command Reference, Release 4.0(4)SV1(2) 』を参照してください。

次に、すべてのポート プロファイルに関する情報を表示する例を示します。

n1000v# show port-profile
port-profile UpLinkProfile1
description:
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on mac-pinning
evaluated config attributes:
channel-group auto mode on mac-pinning
assigned interfaces:
port-profile UpLinkProfile2
description:
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on sub-group cdp
evaluated config attributes:
channel-group auto mode on sub-group cdp
assigned interfaces:
port-profile UpLinkProfile3
description:
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on sub-group manual
evaluated config attributes:
channel-group auto mode on sub-group manual
assigned interfaces:n1000v#
 
 

次に、特定のポート プロファイルに関する情報を表示する例を示します。

n1000v# show port-profile name UpLinkProfile3
port-profile UpLinkProfile3
description:
type: vethernet
status: disabled
capability l3control: no
pinning control-vlan: -
pinning packet-vlan: -
system vlans: none
port-group:
max ports: 32
inherit:
config attributes:
channel-group auto mode on sub-group manual
evaluated config attributes:
channel-group auto mode on sub-group manual
assigned interfaces:
n1000v#
 
 

次に、すべてのポート プロファイルに関するサマリー情報を表示する例を示します。

n1000v# show port-profile brief
 
--------------------------------------------------------------------------------
Port Profile Remote Conf Eval Child Child
Profile State Mgmt Items Items Intfs Profs
--------------------------------------------------------------------------------
UplinkProfile1 enabled vmware 3 3 1 0
UplinkProfile2 enabled vmware 3 3 2 0
Ubuntu-Profile enabled vmware 3 3 1 0
n1000v#
 
 

次に、すべてのポート プロファイルに関する使用状況情報を表示する例を示します。

n1000v# show port-profile usage
 
--------------------------------------------------------------------------------
Port Profile Port Adapter Owner
--------------------------------------------------------------------------------
UplinkProfile1 Eth2/2 vmnic1 mcs-srvr26
UplinkProfile2 Eth2/3 vmnic2 mcs-srvr26
Eth2/4 vmnic3 mcs-srvr26
Ubuntu-Profile Veth439 ubuntu-2
n1000v#
 

次に、特定のポート プロファイルに関する拡張インターフェイス情報を表示する例を示します。

n1000v# show port-profile expand-interface name UplinkProfile1
 
port-profile UplinkProfile1
Ethernet2/2
switchport mode trunk
switchport trunk allowed vlan 110-119
no shutdown
n1000v#
 

次に、すべてのポート プロファイルに関する拡張インターフェイス情報を表示する例を示します。

n1000v# show port-profile expand-interface
 
port-profile UplinkProfile1
Ethernet2/2
switchport mode trunk
switchport trunk allowed vlan 110-119
no shutdown
 
port-profile UplinkProfile2
Ethernet2/3
switchport mode trunk
switchport trunk allowed vlan 117
no shutdown
Ethernet2/4
switchport mode trunk
switchport trunk allowed vlan 117
no shutdown
 
port-profile Ubuntu-Profile
Vethernet439
switchport mode access
switchport access vlan 118
no shutdown
n1000v#
 
 

次に、すべてのポート プロファイルの実行コンフィギュレーションを表示する例を示します。

n1000v# show running-config port-profile
port-profile type ethernet UplinkProfile1
description "Profile for critical system ports"
vmware port-group
switchport mode access
switchport access vlan 113
switchport trunk native vlan 113
channel-group auto mode on
no shutdown
port-profile type vethernet UplinkProfile2
vmware port-group
vmware max-ports 5
switchport mode trunk
switchport trunk native vlan 112
channel-group auto mode on sub-group cdp
no shutdown
n1000v#

 

ポート プロファイルの機能履歴

ここでは、ポート プロファイルの機能履歴を示します。

 

機能名
リリース
機能情報

ポート プロファイル

4.0(4)SV1(1)

この機能が追加されました。

vPC ホスト モード

4.0(4)SV1(2)

次のサポートが追加されました。

サブグループの手動作成

MAC ピン接続による、ポート チャネルをサポートしないアップストリーム スイッチへの接続

MAC ピン接続

4.0(4)SV1(2)

MAC-pinning コマンドを使用して、ポート チャネルをサポートしないアップストリーム スイッチに接続できるようになりました。

静的ピン接続

4.0(4)SV1(2)

vEthernet インターフェイス、コントロール VLAN、またはパケット VLAN から特定のポート チャネル サブグループに接続(またはピン接続)できるようになりました。

ポート プロファイル タイプ

4.0(4)SV1(2)

ポート プロファイルがイーサネットまたは vEthernet タイプ として設定されるようになりました。デフォルトでは、ポート プロファイルは vEthernet タイプとして作成されます。

[ no ] capability uplink コマンド

4.0(4)SV1(2)

capability uplink コマンドが port-profile [ type { ethernet | vethernet }] name コマンドに置き換えられました。ポート プロファイルにアップリンク機能を設定するには、ポート プロファイルをイーサネット タイプとして設定します。

no capability uplink コマンドは削除されました。

show running-config コマンド

4.0(4)SV1(2)

このコマンドの出力は、次のように変更されました。

ポート プロファイル タイプ(イーサネットまたは vEthernet)を示します。

任意で、すべてのポート プロファイルまたは特定のポート プロファイルの実行コンフィギュレーションを表示できます。

show port-profile name コマンド

4.0(4)SV1(2)

このコマンドの出力は、ポート プロファイル タイプ、ピン接続、およびチャネルグループ設定を示すようになりました。アップリンクとして使用されるポート プロファイルはイーサネット タイプとして設定されるようになったため、アップリンク機能はこのコマンドの出力から削除されました。