Cisco Nexus 1000V System Management コン フィギュレーション ガイド リリース 4.0
ローカル SPAN および ER SPAN の設定
ローカル SPAN および ER SPAN の設定
発行日;2012/01/31 | 英語版ドキュメント(2010/01/11 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

ローカル SPAN および ER SPAN の設定

SPAN の概要

SPAN 送信元

送信元ポートの特徴

SPAN 宛先

ローカル SPAN 宛先ポートの特徴

ER SPAN 宛先ポートの特徴

ローカル SPAN

カプセル化リモート SPAN

SPAN セッション

SPAN 注意事項および制約事項

SPAN の設定

ローカル SPAN セッションの設定

ERSPAN ポート プロファイルの設定

ERSPAN セッションの設定

SPAN セッションのシャットダウン

SPAN セッションの再開

SPAN の設定確認

設定例

SPAN セッションの設定例

ERSPAN セッションの設定例

その他の関連資料

関連資料

標準規格

ローカル SPAN および ER SPAN の設定

この章では、ローカルおよび ER イーサネット Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)機能を設定して、トラフィックを監視する方法を説明します。また、次の内容が含まれます。

「SPAN の概要」

「SPAN 注意事項および制約事項」

「SPAN の設定」

「SPAN の設定確認」

「設定例」

「その他の関連資料」

SPAN の概要

スイッチド ポート アナライザ(SPAN)機能(ポート ミラーリングまたはポート モニタリングとも呼ばれます)では、Cisco SwitchProbe やその他の Remote Monitoring(RMON; リモート モニタリング)プローブなどのネットワーク アナライザを使用して、ネットワーク トラフィックを分析できます。

SPAN では、1 つ以上のポートまたは 1 つ以上の VLAN 上のトラフィックを監視して、ネットワーク アナライザが接続されている 1 つ以上の宛先ポートに、監視されたトラフィックを送信できます。

ここでは、次の内容について説明します。

「SPAN 送信元」

「SPAN 宛先」

「SPAN セッション」

SPAN 送信元

トラフィックを監視できるインターフェイスは、SPAN 送信元と呼ばれます。SPAN 送信元には、イーサネット、仮想イーサネット、ポートチャネル、VLAN があります。VLAN が SPAN 送信元として指定されると、VLAN でサポートされているすべてのインターフェイスは、SPAN 送信元となります。トラフィックは、受信方向、送信方向で監視できます。また、イーサネットおよび仮想イーサネット送信元インターフェイスの場合は、双方向で監視できます。

受信ソース(Rx):この送信元ポート経由でスイッチに入るトラフィックは、SPAN 宛先ポートにコピーされます。

送信ソース(Tx):この送信元ポート経由でスイッチから出るトラフィックは、SPAN 宛先ポートにコピーされます。

送信元ポートの特徴

Cisco Nexus 1000V がサポートする送信元ポート数は無制限(最大数はスイッチで利用可能なポート数)です。サポートする送信元 VLAN 数も無制限です。

送信元ポートには次の特徴があります。

イーサネット、仮想イーサネット、ポートチャネル、VLAN のいずれかのポート タイプを使用できます。

宛先ポートとしての使用はできません。

トラフィックの方向(受信、送信、双方向)を監視するように設定できます。

送信元ポートは同じ VLAN にも異なる VLAN にも配置できます。

VLAN SPAN 送信元の場合、送信元 VLAN のすべてのアクティブなポートが送信元ポートとして含まれます。

ローカル SPAN 送信元は、宛先ポートと同じホスト(ラインカード)上になければなりません。

SPAN 宛先

SPAN 宛先とは、送信元ポートを監視するインターフェイスを指します。Cisco Nexus 1000V では、宛先は必ずポートになります。Cisco Nexus 1000V は、SPAN 宛先として、イーサネットおよび仮想イーサネット インターフェイスをサポートします。この項には次の内容が含まれます。

ローカル SPAN 宛先ポートの特徴

各ローカル SPAN セッションには、送信元ポートまたは VLAN からトラフィックのコピーを受信するために、1 つ以上の宛先ポート(モニタリング ポートとも呼ばれます)が必要です。宛先ポートには次の特徴があります。

物理または仮想イーサネット ポートまたはポート チャネルとして使用できます。

送信元ポートとしての使用はできません。

SPAN セッションの送信元 VLAN に属する場合、送信元リストから除外され、監視されません。

すべての監視された送信元ポートでの送受信トラフィックのコピーを受信します。宛先ポートがオーバーサブスクライブ状態になっている場合、輻輳する可能性があります。この輻輳は 1 つ以上の送信元ポートでのトラフィック転送に影響する可能性があります。

送信元ポートと同じホスト(ラインカード)上になければなりません。

ローカル SPAN では、送信元インターフェイスおよび宛先インターフェイスは、同じデバイス上になければなりません。
図 9-1およびローカル SPANを参照してください。

ER SPAN 宛先ポートの特徴

ERSPAN では、送信元 SPAN インターフェイスおよび宛先 SPAN インターフェイスは、IP ネットワークで相互接続した異なるデバイス上にある場合があります。ERSPAN トラフィックは GRE によってカプセル化されています。図 9-2およびERSPANを参照してください。

ローカル SPAN

ローカル SPAN では、送信元インターフェイスおよび宛先インターフェイスは、同じデバイス上になければなりません。ネットワーク アナライザは、SPAN 宛先ポートに直接接続しています。SPAN 送信元は、VLAN インターフェイスのポートとして使用できます。宛先は、通常はポートですが、VLAN としても使用できます。

図 9-1では、ホスト A から送信されたトラフィックが、SPAN 送信元インターフェイスで受信されます。トラフィック(ACL、QoS など)は、通常どおり処理されます。その後、トラフィックが複製されます。元のパケットは、ホスト B に対して転送されます。次に、複製されたパケットは、モニタが接続されている宛先 SPAN インターフェイスに送信されます。

ローカル SPAN は、1 つ以上の宛先ポートに複製できます。トラフィックをフィルタリングできるため、必要なトラフィックだけが宛先 SPAN インターフェイスを送信します。

ローカル SPAN は、BPDU を含む送信元インターフェイスで受信されるすべてのトラフィックを監視できます。

図 9-1 ローカル SPAN

 

 

カプセル化リモート SPAN

Encapsulated remote(ER; カプセル化リモート)SPAN は、IP ネットワーク全体の複数のネットワーク デバイスのトラフィックを監視し、カプセル化エンベロープにあるトラフィックを宛先アナライザに送信します。これとは対照的に、ローカル Local SPAN は、IP ネットワーク経由でトラフィックを転送できません。ERSPAN を使用して、リモートでトラフィックを監視できます。ERSPAN 送信元には、ポートまたは VLAN を設定できます。

図 9-2では、ホスト A の入出力トラフィックが ERSPAN によって監視されています。カプセル化された ERSPAN パケットは、ルーティングされたネットワーク経由で、ホスト A から宛先デバイスにルーティングされます。宛先デバイスでは、ERSPAN パケットのカプセルを解除して、接続しているネットワーク アナライザに転送します。宛先は送信元と同じ L2 ネットワークにすることもできます。

図 9-2 ERSPAN

 

 

SPAN セッション

最大合計 64 の SPAN セッション(ローカル SPAN と ER SPAN)をローカル デバイス上に作成できます。

 

SPAN セッションを作成すると、複数の VLAN 送信元を監視し、必要な VLAN だけを選択して、複数の宛先ポートに送信できます。たとえば、トランク ポートで SPAN を設定し、さまざまな宛先ポート上でのさまざまな VLAN からのトラフィックを監視できます。

図 9-3では、3 つの VLAN から 3 つの指定された宛先ポートにトラフィックをコピーする VLAN ベースの SPAN 設定を示しています。各宛先ポートで許可する VLAN を選択して、トラフィックの送信を制限できます。図 9-3 では、デバイスは各宛先ポートへ、1 つの VLAN からのパケットを送信します。


) VLAN ベースの SPAN セッションでは、パケットが宛先で必要かどうかに関係なく、すべての送信元パケットがすべての宛先にコピーされます。VLAN トラフィック フィルタリングは、送信宛先ポートで実行されます。


図 9-3 VLAN ベースの SPAN 設定

 

SPAN 注意事項および制約事項

SPAN に関する設定時の注意事項および制約事項は、次のとおりです。

最大 64 の SPAN セッション(ローカル SPAN と ERSPAN)を VSM で設定できます。

最大 32 の送信元 VLAN がセッションで許可されます。

最大 128 の送信元インターフェイスがセッションで許可されます。


注意 オーバーロードの可能性
アップリンク ポートのオーバーロードを回避するために、ERSPAN の設定時、特に送信元 VLAN 設定時には注意が必要です。

ポートは最大 4 つの SPAN セッションで設定できます。

1 つの SPAN セッションで使用される宛先ポートは、別の SPAN セッションの宛先ポートとしても使用できません。

1 つのポートを送信元ポートと宛先ポートの両方に設定できません。

SPAN セッションに複数の出力側送信元ポートが含まれている場合、これらのポートが受信するパケットは、そのポートで送信しない場合でも複製される可能性があります。送信元ポートでこの動作が生じる例の一部を示します。

フラッディングから生じたトラフィック

ブロードキャストおよびマルチキャスト トラフィック

送受信の両方が設定された同じ VLAN でスイッチされる VLAN SPAN セッションの場合、宛先ポートから 2 つのパケット(受信から 1 つ、送信から 1 つ)が転送されます。

SPAN の設定

この項では、SPAN を設定する方法を説明し、次の手順が含まれています。

「ローカル SPAN セッションの設定」

「ERSPAN ポート プロファイルの設定」

付録 9「ERSPAN セッションの設定」

「SPAN セッションのシャットダウン」

「SPAN セッションの再開」

「SPAN の設定確認」

ローカル SPAN セッションの設定

この手順を使用して、SPAN セッションを設定します。


) ERSPAN を設定している場合は、「ERSPAN セッションの設定」を参照してください。


始める前に

EXEC モードで CLI にログインします。

設定する SPAN セッションの数を確認します。

送信元および宛先ポートは、アクセスまたはトランク モードで設定しておきます。詳細については、『 Cisco Nexus 1000V Interface Configuration Guide, Release 4.0 』を参照してください。

宛先インターフェイスは、スイッチポート トランク モードで設定しておく必要があります。

デフォルトでは、SPAN セッションはシャット ステートで作成されます。

既存の SPAN セッションを作成する場合は、追加の設定がセッションに追加されます。確実にセッションの以前の設定をクリアするには、まず、セッションを削除する必要があります(ステップ 2の no monitor session を参照)。

この手順には、モニタ コンフィギュレーション モードでの SPAN セッションの作成と、インターフェイス コンフィギュレーション モードでの実行 VLAN の設定が含まれます。

手順の概要

1. config t

2. no monitor session session-number

3. monitor session session-number

4. description description

5. source {interface type | vlan} {number | range} [ rx | tx | both ]

6. (任意)ステップ 5を繰り返して、追加の SPAN 送信元を設定します。

7. (任意) filter vlan {number | range}

8. (任意)ステップ 7を繰り返して、フィルタリングするすべての送信元 VLAN を設定します。

9. destination interface type {number | range}

10. (任意)ステップ 9を繰り返して、すべての SPAN 宛先ポートを設定します。

11. no shut

12. (任意) exit

13. (任意) interface ethernet slot / port [- port ]

14. (任意) switchport trunk allowed vlan { vlan-range | add vlan-range | except vlan-range | remove vlan-range | all | none }

15. (任意)ステップ 13およびステップ 14を繰り返して、各宛先ポートで許可された VLAN を設定します。

16. (任意) show interface ethernet slot / port [- port ] trunk

17. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

no monitor session session-number

 

n1000v(config)# no monitor session 3

指定されたセッションをクリアします。

ステップ 3

monitor session session-number

 

n1000v(config)# monitor session 3

n1000v(config-monitor)#

任意のセッション番号でセッションを作成して、CLI モニタ コンフィギュレーション モードに切り替え、セッションを設定します。

ステップ 4

description description

 

n1000v(config-monitor)# description my_span_session_3

指定された SPAN セッションの場合は、説明を追加します。

description:最大 32 文字の英数字
デフォルト = ブランク(no description)

ステップ 5

source {interface type | vlan}
{number | range} [ rx | tx | both ]

 

n1000v(config-monitor)# source interface ethernet 2/1-3, ethernet 3/1 rx

 

n1000v(config-monitor)# source interface port-channel 2

 

n1000v(config-monitor)# source interface vethernet 12 both

 

n1000v(config-monitor)# source vlan 3, 6-8 tx

指定されたセッションの場合は、監視するトラフィックの送信元と方向を設定します。

type:インターフェイス タイプ(イーサネット、ポートチャネル、仮想イーサネット)を指定します。

number:監視するインターフェイス スロットおよびポートまたはポート範囲、VLAN 番号または VLAN 範囲を指定します。

traffic direction:次の方向のいずれかになるように、トラフィック 監視を指定します。

受信(rx)(VLAN デフォルト)

送信(tx)

双方向(インターフェイス デフォルト)

ステップ 6

(任意)ステップ 5を繰り返して、追加の SPAN 送信元を設定します。

ステップ 7

filter vlan {number | range}

 

n1000v(config-monitor)# filter vlan 3-5, 7

(任意)指定された SPAN セッションの場合、送信元 VLAN の中からフィルタを設定します。

ステップ 8

(任意)ステップ 7を繰り返して、フィルタリングするすべての送信元 VLAN を設定します。

ステップ 9

destination interface type
{number | range}

 

n1000v(config-monitor)# destination interface ethernet 2/5, ethernet 3/7

指定された SPAN セッションの場合、コピーされた送信元パケットの宛先として動作するポートを指定します。

type:インターフェイス タイプ(イーサネットまたは仮想イーサネット)を指定します。

number:監視するインターフェイス スロットおよびポートを指定します。

range:監視するインターフェイス範囲を指定します。

(注) SPAN 宛先ポートはアクセスまたはトランク ポートとして設定しておく必要があります。

ステップ 10

(任意)ステップ 9を繰り返して、すべての SPAN 宛先ポートを設定します。

ステップ 11

no shut

 
n1000v(config-monitor)# no shut

SPAN セッションをイネーブルにします。デフォルトでは、セッションはシャット ステートで作成されます。

ステップ 12

exit

 

n1000v(config-monitor)# exit

n1000v(config)#

(任意)モニタ コンフィギュレーション モードを終了して、CLI コンフィギュレーション モードに切り替えます。

ステップ 13

interface ethernet slot / port [- port ]

 

n1000v(config)# interface ethernet 2/5

n1000v(config-if)#

(任意)指定されたインターフェイスの CLI インターフェイス コンフィギュレーション モードに切り替えます。

ステップ 14

switchport trunk allowed vlan { vlan-range | add vlan-range | except vlan-range | remove vlan-range | all | none }

 

n1000v(config-if)# switchport trunk allowed vlan 3-5

(任意)指定されたインターフェイス用。インターフェイスで許可する VLAN の範囲を設定します。デフォルトでは、インターフェイス上ですべての VLAN が許可されます。

vlan-range:インターフェイスで許可する VLAN の範囲を指定します。

add vlan-range:インターフェイスで許可されている既存の VLAN を追加します。

except vlan-range:インターフェイスで許可されている VLAN から VLAN の範囲を除外します。

remove vlan-range:インターフェイスで許可されている VLAN から VLAN の範囲を削除します。

all:インターフェイスですべての VLAN を許可します。
これはデフォルトです。

none:インターフェイスで VLAN を許可しません。

ステップ 15

(任意)ステップ 13およびステップ 14を繰り返して、各宛先ポートで許可された VLAN を設定します。

ステップ 16

show interface ethernet slot / port [- port ] trunk

 

n1000v(config-if)# show interface ethernet 2/5 trunk

(任意)選択したスロットおよびポートまたはポート範囲に対応するインターフェイス トランキング設定を表示します。

ステップ 17

copy running-config startup-config

 

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

ERSPAN ポート プロファイルの設定

この手順を使用して、VSM 上のポート プロファイルを設定し、ERSPAN パケットを IP ネットワーク経由で、リモート宛先アナライザに 転送します。

始める前に

EXEC モードで CLI にログインします。

vCenter Server のすべてのホストに対して、この設定を完了する必要があります。

このポート プロファイルに使用する名前を確認します。


) ポート プロファイル名は、各 ESX ホストで必要な VMKNIC を設定するために使用されます。


このプロファイルをマッピングする VMware ポート グループ名を確認します。

新しい仮想アダプタを追加するための VMware マニュアルを手元に用意します。

この設定で使用するシステム VLAN の ID を確認します。

手順の概要

1. config t

1. port-profile port_profile_name

2. capability l3control

3. vmware port-group pg_name

4. switchport access vlan vlan_id

5. no shutdown

6. system vlan vlan_id

7. state enabled

8. (任意) show port-profile name port_profile_name

9. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-profile port_profile_name

 

n1000v(config)# port-profile erspan_profile

n1000v(config-port-prof)#

ポート プロファイルを作成し、指定されたポート プロファイルの CLI グローバル コンフィギュレーション モードに切り替えます。実行コンフィギュレーションに、ポート プロファイルを保存します。

port-profile name は、最大 80 文字で、Cisco Nexus 1000V の各ポート プロファイルで一意でなければなりません。

ステップ 3

capability l3control

 

n1000v(config-port-prof)# capability l3control

n1000v(config-port-prof)#

port-profile を設定して、ERSPAN トラフィックを転送し、実行コンフィギュレーションに保存します。

ステップ 4

vmware port-group pg_name

 

n1000v(config-port-prof)#vmware port-group erspan

n1000v(config-port-prof)#

ポート プロファイルを VMware ポート グループとして指定し、このプロファイルがマッピングする VMware ポート グループ名を追加します。実行コンフィギュレーションに、設定を保存します。

ポート プロファイルは、同じ名前の VMware ポート グループにマッピングされます。vCenter Server 接続が確立すると、Cisco Nexus 1000V で作成されたポート グループは、vCenter Server の仮想スイッチに配信されます。

pg-name:ポート グループ名。pg-name を指定しない場合、ポート グループ名は、ポート プロファイル名と同じになります。ポート プロファイルを異なるポート グループ名にマッピングする場合は、pg-name オプションのあとに別の名前を続けます。

ステップ 5

switchport access vlan vlan_id

 

 

n1000v(config-port-prof)# switchport access vlan 2

n1000v(config-port-prof)#

VLAN ID をこのポート プロファイルのアクセス ポートに割り当て、実行コンフィギュレーションに設定を保存します。

ステップ 6

no shutdown

 

n1000v(config-port-prof)# no shutdown

n1000v(config-port-prof)#

実行コンフィギュレーションのインターフェイスをイネーブルにします。

ステップ 7

system vlan vlan_id

 

n1000v(config-port-prof)# system vlan 2

n1000v(config-port-prof)#

システム VLAN ID をポート プロファイルに関連付け、実行コンフィギュレーションに保存します。

アクセス ポートに割り当てられた VLAN ID と一致しなければなりません。一致しない場合は、次のエラー メッセージが表示されます。

ERROR: System vlan being set does not match the switchport access vlan 2

ステップ 8

state enabled

 

n1000v(config-port-prof)# state enabled

n1000v(config-port-prof)#

実行コンフィギュレーションで、ポート プロファイルをイネーブルにします。

これで、このポート プロファイルは、ERSPAN 送信元を持つすべての ESX ホストの ERSPAN パケットを送信できます。

ステップ 9

show port-profile name port_profile_name

 

n1000v(config-port-prof)# show port-profile name erspan

port-profile erspan

description:

status: enabled

capability uplink: no

capability l3control: yes

system vlans: 2

port-group: access

max-ports: 32

inherit:

config attributes:

switchport access vlan 2

no shutdown

evaluated config attributes:

switchport access vlan 2

no shutdown

assigned interfaces:

 

n1000v(config-port-prof)#

(任意)指定されたポート プロファイルの設定を、実行コンフィギュレーションにあるとおりに表示します。

ステップ 10

copy running-config startup-config

 

n1000v(config-port-prof)# copy running-config startup-config

[########################################] 100%

n1000v(config-port-prof)#

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

ステップ 11

VMware のマニュアルを参照して、vSphere Client クライアントで、各 ESX ホストの VMKNIC を設定します。必ず 新しい仮想アダプタ として、VMKNIC がこのポート プロファイルを参照するようにします。

ERSPAN セッションの設定

この手順を使用して、ERSPAN セッションを設定します。


) ローカル SPAN を設定している場合は、「ローカル SPAN セッションの設定」を参照してください。


始める前に

EXEC モードで CLI にログインします。

設定する SPAN セッションの数を確認します。

「ERSPAN ポート プロファイルの設定」を参照して、VSM の ERSPAN 対応ポート プロファイルを設定しておきます。

新しい仮想アダプタを追加するための VMware マニュアルを使用して、各 ESX ホスト上に必要な VMKNIC を設定しておきます。

デフォルトでは、SPAN セッションはシャット ステートで作成されます。

既存の SPAN セッションを作成する場合は、追加の設定がセッションに追加されます。確実にセッションの以前の設定をクリアするには、まず、セッションを削除する必要があります(ステップ 2の no monitor session を参照)。

この手順には、ERSPAN 送信元コンフィギュレーション モードでの SPAN セッションの作成と、インターフェイス コンフィギュレーション モードでの実行 VLAN の設定が含まれます。

手順の概要

1. config t

2. no monitor session session-number

3. monitor session session-number type erspan-source

4. description description

5. source {interface type | vlan} {number | range} [ rx | tx | both ]

6. (任意)ステップ 5を繰り返して、追加の ERSPAN 送信元を設定します。

7. (任意) filter vlan {number | range}

8. (任意)ステップ 7を繰り返して、フィルタリングするすべての送信元 VLAN を設定します。

9. destination ip ip_address

10. ip ttl ttl_value

11. ip prec ipp_value

12. ip dscp dscp_value

13. mtu mtu_value

14. (任意)ステップ 9からステップ 13まで繰り返して、すべての ERSPAN 宛先を設定します。

15. (任意) erspan-id flow_id

16. no shut

17. (任意) show monitor session session_id

18. (任意) exit

19. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

no monitor session session-number

 

n1000v(config)# no monitor session 3

指定されたセッションをクリアします。

ステップ 3

monitor session session-number type erspan-source

 

n1000v(config)# monitor session 3 type erspan

n1000v(config-erspan-src)#

任意のセッション番号でセッションを作成し、CLI ERSPAN 送信元コンフィギュレーション モードに切り替えます。この設定は、実行コンフィギュレーションに保存されます。

ステップ 4

description description

 

n1000v(config-erspan-src)# description my_erspan_session_3

n1000v(config-erspan-src)#

指定された ERSPAN セッションの場合、説明を追加して、実行コンフィギュレーションに保存します。

description:最大 32 文字の英数字
デフォルト = ブランク(no description)

ステップ 5

source {interface type | vlan}
{number | range} [ rx | tx | both ]

 

n1000v(config-erspan-src)# source interface ethernet 2/1-3, ethernet 3/1 rx

 

n1000v(config-erspan-src)# source interface port-channel 2

 

n1000v(config-erspan-src)# source interface vethernet 12 both

 

n1000v(config-erspan-src)# source vlan 3, 6-8 tx

指定されたセッションの場合、監視する送信元とトラフィックの方向を設定し、実行コンフィギュレーションに保存します。

type:インターフェイス タイプ(イーサネット、ポートチャネル、仮想イーサネット)を指定します。

number:監視するインターフェイス スロットおよびポートまたはポート範囲、VLAN 番号または VLAN 範囲を指定します。

traffic direction:次の方向のいずれかになるように、トラフィック 監視を指定します。

受信(rx)(VLAN デフォルト)

送信(tx)

双方向(インターフェイス デフォルト)

ステップ 6

(任意)ステップ 5を繰り返して、追加の ERSPAN 送信元を設定します。

ステップ 7

filter vlan {number | range}

 

n1000v(config-erspan-src)# filter vlan 3-5, 7

(任意)指定された ERSPAN セッションの場合、監視する VLAN、VLAN リスト、VLAN 範囲のいずれかを設定して、実行コンフィギュレーションに保存します。

モニタ ポート上では、VLAN フィルタ リストと一致する VLAN からのトラフィックだけが宛先に複製されます。

ステップ 8

(任意)ステップ 7を繰り返して、フィルタリングするすべての送信元 VLAN を設定します。

ステップ 9

destination ip ip_address

 

n1000v(config-erspan-src)# destination interface ethernet 2/5, ethernet 3/7

n1000v(config-monitor-erspan-src)#

カプセル化されたトラフィックが送信されるホストの IP アドレスを設定し、実行コンフィギュレーションに保存します。

ステップ 10

ip ttl ttl_value

 

n1000v(config-monitor-erspan-src)# ip ttl 64

n1000v(config-monitor-erspan-src)#

(任意)ERSPAN のパケットに対し、1 ~ 255 の範囲で IP 有効期限値を指定し、実行コンフィギュレーションに保存します。

ステップ 11

ip prec precedence_value

 

n1000v(config-monitor-erspan-src)# ip prec 1

n1000v(config-monitor-erspan-src)#

 

(任意)ERSPAN のパケットに対し、0 ~ 7 の範囲で IP precedence 値を指定し、実行コンフィギュレーションに保存します。

ステップ 12

ip dscp dscp_value

 

n1000v(config-monitor-erspan-src)# ip dscp 24

n1000v(config-monitor-erspan-src)#

 

(任意)0 ~ 63 の範囲で IP DSCP 値を指定します。ERSPAN トラフィックのパケットの場合は、実行コンフィギュレーションに保存します。

ステップ 13

mtu mtu_value

 

n1000v(config-monitor-erspan-src)# mtu 1000

n1000v(config-monitor-erspan-src)#

(任意)ERSPAN トラフィックの MTU サイズを指定し、実行コンフィギュレーションに保存します。

ステップ 14

(任意)ステップ 9からステップ 13までを繰り返して、すべての SPAN 宛先ポートを設定します。

ステップ 15

erspan-id flow_id

 

n1000v(config-erspan-src)# erspan_id 51

 

ERSPAN ID(1 ~ 1023)をセッション設定に追加して、実行コンフィギュレーションに保存します。

セッション ERSPAN ID を、カプセル化されたフレームの ERSPAN ヘッダーに追加し、終端ボックスで使用して、さまざまな トラフィックの ERSPAN ストリームを識別できます。

ステップ 16

no shut

 
n1000v(config-erspan-src)# no shut

ERSPAN セッションをイネーブルにし、実行コンフィギュレーションに保存します。

デフォルトでは、セッションはシャット ステートで作成されます。

ステップ 17

show monitor session session_id

 
n1000v(config-erspan-src)# show monitor session 3

(任意)実行コンフィギュレーションにあるとおりに、ERSPAN セッション設定を表示します。

ステップ 18

exit

 

n1000v(config-erspan-src)# exit

n1000v(config)#

(任意)ERSPAN 送信元コンフィギュレーション モードを終了し、CLI コンフィギュレーション モードに戻ります。

ステップ 19

copy running-config startup-config

 

n1000v(config-if)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

 

SPAN セッションのシャットダウン

この手順を使用して、SPAN セッションのパケットのコピーを中止します。1 つの送信元および宛先からのパケットのコピーを中止し、別の送信元および宛先で再開できます。

始める前に

この手順を開始する前に、次の点を理解または実行しておく必要があります。

EXEC モードで CLI にログインします。

シャットダウンする SPAN セッションを確認します。

グローバル コンフィギュレーション モードまたはモニタ コンフィギュレーション モードで、SPAN セッションをシャットダウンできます。

手順の概要

グローバル コンフィギュレーション モードから:

1. config t

2. monitor session {session-number | session-range | all } shut

3. show monitor

4. copy running-config startup-config

モニタ コンフィギュレーション モードから:

1. config t

2. monitor session {session-number | session-range | all }

3. shut

4. show monitor

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

monitor session {session-number | session-range | all } shut

 

n1000v(config)# monitor session 3 shut

n1000v(config)#

 

n1000v(config)# monitor session 3

n1000v(config-monitor)# shut

グローバル コンフィギュレーション モードまたはモニタ コンフィギュレーション モードで、指定された SPAN モニタ セッションをシャットダウンします。

session-number:特定の SPAN セッション番号を指定します。

session range:SPAN セッションの範囲を指定します(許可されている範囲は 1 ~ 16)。

all:すべての SPAN モニタ セッションを指定します。

ステップ 3

show monitor

 

n1000v(config-monitor)# show monitor

(任意)SPAN セッションの状況を表示します。

ステップ 4

copy running-config startup-config

 

n1000v(config-monitor)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

 

SPAN セッションの再開

この手順を使用して、SPAN セッションのパケットのコピーを再開します。1 つの送信元および宛先からのパケットのコピーを中止し、別の送信元および宛先で再開できます。

始める前に

この手順を開始する前に、次の点を理解または実行しておく必要があります。

EXEC モードで CLI にログインします。

設定する SPAN セッションを確認します。

グローバル コンフィギュレーション モードまたはモニタ コンフィギュレーション モードで、SPAN セッションを再開できます。

手順の概要

グローバル コンフィギュレーション モードから:

1. config t

2. no monitor session {session-number | session-range | all } shut

3. show monitor

4. copy running-config startup-config

モニタ コンフィギュレーション モードから:

1. config t

2. monitor session {session-number | session-range | all }

3. no shut

4. show monitor

5. copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

config t

 

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

[no] monitor session {session-number session-range | all } shut

 

n1000v(config)# no monitor session 3 shut

n1000v(config)#

 

n1000v(config)# monitor session 3

n1000v(config-monitor)# no shut

 

グローバル コンフィギュレーション モードまたはモニタ コンフィギュレーション モードで、指定された SPAN モニタ セッションを開始します。

session-number:特定の SPAN セッション番号を指定します。

session range:SPAN セッションの範囲を指定します(許可されている範囲は 1 ~ 16)。

all:すべての SPAN モニタ セッションを指定します。

ステップ 3

show monitor

 

n1000v(config-monitor)# show monitor

(任意)SPAN セッションの状況を表示します。

ステップ 4

copy running-config startup-config

 

n1000v(config-monitor)# copy running-config startup-config

(任意)実行中のコンフィギュレーションをスタートアップ コンフィギュレーションにコピーし、リブートと再起動を行って、永久的に保存します。

SPAN の設定確認

SPAN 設定を表示するには、次のコマンドを使用します。

 

コマンド
目的

show monitor session { all | session-number | range session-range } [ brief ]

SPAN セッションの設定を表示します。

show monitor

イーサネット SPAN 情報を表示します。

module vem module-number execute vemcmd show span //

VEM モジュールで設定された SPAN セッションを表示します。

show port-profile name port_profile_name

ERSPAN で必要なレイヤ 3 対応ポート プロファイルを表示します。

設定例

この項には、次の設定例が含まれています。

「SPAN セッションの設定例」

「ERSPAN セッションの設定例」

SPAN セッションの設定例

SPAN セッションを設定する手順は、次のとおりです。


ステップ 1 アクセス モードまたはトランク モードで宛先ポートを設定し、SPAN モニタリングをイネーブルにします。

n1000v# config t
n1000v(config)# interface ethernet 2/5
n1000v(config-if)# switchport
n1000v(config-if)# switchport mode trunk
n1000v(config-if)# no shut
n1000v(config-if)# exit
n1000v(config)#
 

ステップ 2 SPAN セッションを設定します。

n1000v(config)# no monitor session 3
n1000v(config)# monitor session 3
n1000v(config-monitor)# source interface ethernet 2/1-3
n1000v(config-monitor)# source interface port-channel 2
n1000v(config-monitor)# source vlan 3, 6-8 tx
n1000v(config-monitor)# filter vlan 3-5, 7
n1000v(config-monitor)# destination interface ethernet 2/5
n1000v(config-monitor)# no shut
n1000v(config-monitor)# exit
n1000v(config)# show monitor session 3
n1000v(config)# copy running-config startup-config
 


 

ERSPAN セッションの設定例

次の例では、送信元イーサネット インターフェイスと宛先 IP アドレスに対して、双方向 ERSPAN セッションを作成する方法を示しています。宛先 IP に到達するパケットは、ヘッダーの ID 999 で特定されます。

n1000v(config)# monitor session 1 type erspan-source
n1000v(config-erspan-src)# source interface ethernet 3/3
n1000v(config-erspan-src)# destination ip 10.54.54.1
n1000v(config-erspan-src)# erspan-id 999
n1000v(config-erspan-src)# mtu 1000
n1000v(config-erspan-src)# no shut
 
n1000v(config)# show monitor session 1
session 1
---------------
type : erspan-source
state : up
source intf :
rx : Eth3/3
tx : Eth3/3
both : Eth3/3
source VLANs :
rx :
tx :
both :
filter VLANs : filter not specified
destination IP : 10.54.54.1
ERSPAN ID : 999
ERSPAN TTL : 64
ERSPAN IP Prec. : 0
ERSPAN DSCP : 0
ERSPAN MTU : 1000
 
n1000v# module vem 3 execute vemcmd show span
 
VEM SOURCE IP: 10.54.54.10
 
HW SSN ID DST LTL/IP ERSPAN ID
0 10.54.54.1 999
1 48 local
 

その他の関連資料

SPAN の実装に関する詳細情報については、次の項を参照してください。

「関連資料」

「標準規格」

関連資料

 

関連項目
マニュアル タイトル

ポート プロファイル設定

Cisco Nexus 1000V Port Profile Configuration Guide, Release 4.0

インターフェイス

Cisco Nexus 1000V Interface Configuration Guide, Release 4.0

SPAN コマンド

Cisco Nexus 1000V Command Reference, Release 4.0

標準規格

 

標準規格
タイトル

この機能でサポートされる新規または改訂された標準規格はありません。また、この機能による既存の標準規格サポートの変更はありません。

--