Cisco Nexus 1000V System Management コン フィギュレーション ガイド リリース 4.0
サーバ接続の管理
サーバ接続の管理
発行日;2012/01/31 | 英語版ドキュメント(2010/01/11 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

サーバ接続の管理

vCenter Server への接続

vCenter Server からの切断

vCenter Server からの DVS の削除

接続の表示

ドメインの表示

コンフィギュレーションの表示

モジュール情報の表示

サーバ接続の管理

この章では、接続を確立してサーバに接続する方法、サーバから切断する方法、およびサーバ接続を表示する方法について説明します。

この章では、次の内容について説明します。

「vCenter Server への接続」

「vCenter Server からの切断」

「接続の表示」

「ドメインの表示」

「コンフィギュレーションの表示」

vCenter Server への接続

この手順を使用して、接続を設定して、vCenter Server または ESX サーバに接続します。

始める前に

EXEC モードで CLI にログインします。

vCenter Server 管理ステーションをインストールして実行します。

ESX サーバをインストールして実行します。

管理ポートを設定します。

Cisco Nexus 1000V から vCenter Server にアクセスできるようにします。

Cisco Nexus 1000V アプライアンスをインストールします。

ホスト名を使用して接続を設定している場合は、DNS を設定しておきます。

手順の概要

1. config t

2. svs connection name

3. protocol vmware-vim

4. remote {ip address address| hostname name}

5. vmware dvs datacenter-name name

6. connect

手順の詳細

コマンド
説明

ステップ 1

config t

 

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

svs connection name

 

n1000v (config#) svs connection vcWest

n1000v(config-svs-conn#)

Cisco Nexus 1000V と特定の ESX サーバまたは vCenter Server 間にこの接続を追加するための、接続コンフィギュレーション モードに切り替えます。名前を使用して、複数接続情報をコンフィギュレーションに格納できます。

ステップ 3

protocol vmware-vim [http]

 

n1000v(config-svs-conn#) protocol vmware-vim

n1000v(config-svs-conn#)

この接続が VIM プロトコルを使用するように指定します。このコマンドはローカルに格納されます。

http:VIM プロトコルが HTTP で実行されるように指定します。デフォルトでは HTTP over SSL(HTTPS)を使用します。

ステップ 4

次のいずれかを実行します。

IP アドレスを設定している場合は、ステップ 5を参照してください。

ホスト名を設定している場合は、ステップ 6を参照してください。

ステップ 5

remote ip address ipaddress

 

n1000v(config-svs-conn#) remote ip address 10.86.194.225

n1000v(config-svs-conn#)

 

ステップ 7を参照してください。

この接続で使用する ESX サーバまたは vCenter Server の IP アドレスを指定します。このコマンドはローカルに格納されます。

ステップ 6

remote hostname hostname

 

n1000v(config-svs-conn#) remote hostname vcMain

n1000v(config-svs-conn#)

 

この接続で使用する ESX サーバまたは vCenter Server の DNS 名を指定します。このコマンドはローカルに格納されます。

(注) DNS はすでに設定されています。

ステップ 7

vmware dvs datacenter-name name

 

n1000v(config-svs-conn#) vmware dvs datacenter-name HamiltonDC

n1000v(config-svs-conn#)

Cisco Nexus 1000V が Distributed Virtual Switch(DVS; 分散仮想スイッチ)として作成される vCenter Server のデータセンター名を指定します。接続前または接続後に、このコマンドを使用できます。データセンター名はローカルに格納されます。

ステップ 8

connect

 

n1000v(config-svs-conn#) connect

 

接続を開始します。この接続のユーザ名とパスワードが設定されていない場合は、ユーザ名とパスワード入力プロンプトが表示されます。

デフォルトは no connect です。一度にアクティブにできる接続は 1 つだけです。以前に定義した接続が確立している場合は、no connect を入力して以前の接続を終了するまでは、エラー メッセージが表示され、コマンドは拒否されます。

vCenter Server からの切断

この手順を使用して、vCenter Server 設定の修正後などに vCenter Server から切断します。

始める前に

EXEC モードでCisco Nexus 1000V にログインします。

「vCenter Server への接続」を参照して、Cisco Nexus 1000V 接続を設定します。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

svs connection name

 

n1000v (config#) svs connection vcWest

n1000v(config-svs-conn)#

vCenter Server に接続するために、CLI グローバル コンフィギュレーション サブモードに切り替えます。

ステップ 3

no connect

 
n1000v(config-svs-conn)# no connect
n1000v(config-svs-conn)#

接続を終了します。

vCenter Server からの DVS の削除

この手順を使用して、vCenter Server から DVS を削除します。

始める前に

EXEC モードで CLI にログインします。

「vCenter Server への接続」を参照して、接続を設定します。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

Server Administrator をCisco Nexus 1000V に接続しているすべてのホストの VI クライアントから削除しておきます。詳細については、VMware のマニュアルを参照してください。

手順の詳細

 

コマンド
説明

ステップ 1

config t

 

n1000v# config t

n1000v(config)#

CLI グローバル コンフィギュレーション モードを開始します。

ステップ 2

svs connection name

 

n1000v(config#) svs connection vcWest

n1000v(config-svs-conn)#

vCenter Server に接続するために、CLI グローバル コンフィギュレーション サブモードに切り替えます。

ステップ 3

no vmware dvs

 

n1000v(config-svs-conn)# no vmware dvs

n1000v(config-svs-conn)#

指定された接続に関連付けられている DVS を vCenter Server から削除します。

接続の表示

この手順を使用して、接続を表示します。

始める前に

任意のコマンド モードで CLI にログインします。

「vCenter Server への接続」を参照して、接続設定を行います。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

手順の詳細

 

コマンド
説明

ステップ 1

show svs connections [name]

 

現在のCisco Nexus 1000V への接続を表示します。

(注) ネットワーク接続の問題により、vCenter Server への接続がシャットダウンされる場合があります。ネットワーク接続が復元しても、Cisco Nexus 1000V では自動的に接続は復元されません。この場合、次のコマンド シーケンスを使用して、手動で接続を復元する必要があります。

no connect
connect

 

 
n1000v# show svs connections vc
Connection vc:
IP address: 172.28.15.206
Protocol: vmware-vim https
vmware dvs datacenter-name: HamiltonDC
ConfigStatus: Enabled
OperStatus: Connected
n1000v#
 

ドメインの表示

この手順を使用して、設定されたドメインを表示します。

始める前に

任意のコマンド モードで CLI にログインします。

「ドメインの作成」を参照して、ドメインを設定します。

手順の詳細

 

コマンド
説明

ステップ 1

show svs-domain

 
n1000v# show svs-domain
 
n1000v (config)# show svs domain
SVS domain config:
Domain id: 98
Control vlan: 70
Packet vlan: 71
Sync state: -
 
n1000v#
 

Cisco Nexus 1000V で設定されたドメインを表示します。

 

 

コンフィギュレーションの表示

この手順を使用して、実行コンフィギュレーションを表示します。

始める前に

任意のコマンド モードで CLI にログインします。

「vCenter Server への接続」を参照して、Cisco Nexus 1000V 接続を設定します。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

手順の詳細

 

コマンド
説明

ステップ 1

show running-config

現在の設定を表示します。

Cisco Nexus 1000V が vCenter Server または ESX サーバに接続していない場合は、接続関連情報だけが出力されます。

 
n1000v(config-acl)# show running-config
version 4.0(1)
feature port-security
username adminbackup password 5 $1$Oip/C5Ci$oOdx7oJSlBCFpNRmQK4na. role network-operator
username admin password 5 $1$N1mX5tLD$daXpuxlAPcIHoz53PBhy6/ role network-admin
telnet server enable
ssh key rsa 1024 force
kernel core target 0.0.0.0
kernel core limit 1
system default switchport
ip access-list my66
10 permit ip 1.1.1.1/32 1.1.1.2/32
snmp-server user admin network-admin auth md5 0x90f3798f3e894496a11ec42ce2efec9c priv 0x90f3798f3e894496a11ec42ce2efec9c localizedkey
snmp-server enable traps entity fru
snmp-server enable traps license
vrf context management
ip route 0.0.0.0/0 172.28.15.1
switchname srini-cp
vlan 40-43,45-48
vdc srini-cp id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 32
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 32 maximum 256
limit-resource u6route-mem minimum 16 maximum 256
 
interface Ethernet6/2
inherit port-profile uplinkportprofile1
 
interface Ethernet6/3
inherit port-profile uplinkportprofile2
 
interface Ethernet6/4
inherit port-profile uplinportprofile3
 
interface Ethernet7/2
inherit port-profile uplinkportprofile1
 
interface mgmt0
ip address 172.28.15.163/24
 
interface Vethernet1
inherit port-profile vm100
 
interface Vethernet2
inherit port-profile vm100
 
interface Vethernet3
inherit port-profile vm100
 
interface Vethernet4
inherit port-profile vm100
 
interface Vethernet5
 
interface Vethernet6
boot kickstart bootflash:/svs-kickstart-mzg.4.0.1a.S1.0.82.bin sup-1
boot system bootflash:/svs-mzg.4.0.1a.S1.0.82.bin sup-1
boot system bootflash:/isan.bin sup-1
boot kickstart bootflash:/svs-kickstart-mzg.4.0.1a.S1.0.82.bin sup-2
boot system bootflash:/svs-mzg.4.0.1a.S1.0.82.bin sup-2
boot system bootflash:/isan.bin sup-2
ip route 0.0.0.0/0 172.28.15.1
port-profile uplinkportprofile1
capability uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 1,40-43
no shutdown
system vlan 1,40-43
state enabled
port-profile vm100
vmware port-group
switchport mode access
switchport access vlan 43
ip port access-group my100 out
ip port access-group my66 in
no shutdown
state enabled
port-profile uplinkportprofile2
capability uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 45-46
no shutdown
state enabled
port-profile uplinportprofile3
capability uplink
vmware port-group
switchport trunk allowed vlan 47-48
state enabled
port-profile uplinkportprofile3
no shutdown
svs-domain
domain id 163
control vlan 41
packet vlan 42
svs connection VCR5
protocol vmware-vim
remote ip address 172.28.30.83
vmware dvs datacenter-name cisco-DC
connect
n1000v(config-acl)#

モジュール情報の表示

この手順を使用して、Cisco Nexus 1000V から DVS のビューを含むモジュール情報を表示します。

始める前に

任意のコマンド モードで CLI にログインします。

「vCenter Server への接続」を参照して、Cisco Nexus 1000V 接続を設定します。

Cisco Nexus 1000V を vCenter Server または ESX に接続します。

Server Administrator で、Cisco Nexus 1000V を実行しているホストを、vCenter Server の DVS に追加しておきます。

手順の概要

1. show module

2. show server-info

3. show interface brief

4. show interface virtual

手順の詳細

 

コマンド
説明

ステップ 1

show module

 
n1000v# show module

モジュール情報を表示します。

ステップ 2

show server_info

 
n1000v# show server_info

サーバ情報を表示します。

ステップ 3

show interface brief

 
n1000v# show interface brief

vCenter Server へのアップリンクを含むインターフェイス情報を表示します。

ステップ 4

show interface virtual

 
n1000v# show interface virtual

仮想インターフェイス情報を表示します。

 
n1000v# show module
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ------------------ ------------
1 1 Virtual Supervisor Module Nexus1000V active *
2 48 Virtual Ethernet Module ok
3 48 Virtual Ethernet Module ok
 
Mod Sw Hw World-Wide-Name(s) (WWN)
--- -------------- ------ --------------------------------------------------
1 4.0(0)S1(0.82) 0.0 --
2 NA 0.0 --
3 NA 0.0 --
 
Mod MAC-Address(es) Serial-Num
--- -------------------------------------- ----------
1 00-19-07-6c-5a-a8 to 00-19-07-6c-62-a8 NA
2 02-00-0c-00-02-00 to 02-00-0c-00-02-80 NA
3 02-00-0c-00-03-00 to 02-00-0c-00-03-80 NA
 
Mod Server-IP Server-UUID Server-Name
--- --------------- ------------------------------------ --------------------
1 172.18.217.180 esx-1
2 172.18.117.44 487701ee-6e87-c9e8-fb62-001a64d20a20 esx-2
3 172.18.217.3 4876efdd-b563-9873-8b39-001a64644a24 esx-3
 
* this terminal session
 
n1000v# show server_info
 
Mod Status UUID
--- ----------- ----
2 powered-up 34303734-3239-5347-4838-323130344654
3 absent 371e5916-8505-3833-a02b-74a4122fc476
4 powered-up 4880a7a7-7b51-dd96-5561-001e4f3a22f9
5 absent 48840e85-e6f9-e298-85fc-001e4f3a2326
6 powered-up eb084ba6-3b35-3031-a6fe-255506d10cd0
n1000v#
 
n1000v# show interface brief
 
--------------------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
--------------------------------------------------------------------------------
mgmt0 -- up 172.28.15.211 1000 1500
 
--------------------------------------------------------------------------------
Ethernet VLAN Type Mode Status Reason Speed Port
Interface Ch #
--------------------------------------------------------------------------------
Eth2/2 1 eth trunk up none a-1000(D) --
 
--------------------------------------------------------------------------------
Interface VLAN Type Mode Status Reason MTU
--------------------------------------------------------------------------------
 
n1000v# show interface virtual
 
--------------------------------------------------------------------------------
Port Adapter Owner Mod Host
--------------------------------------------------------------------------------
Veth49 R-VM-1 2 mcs-srvr35