Cisco Nexus 1000V System Management コン フィギュレーション ガイド リリース 4.0
コンフィギュレーションの管理
コンフィギュレーションの管理
発行日;2012/01/31 | 英語版ドキュメント(2010/01/11 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

コンフィギュレーションの管理

スイッチ名の変更

Message of the Day の設定

コンフィギュレーションの表示

ソフトウェアとハードウェアのバージョンの表示

実行コンフィギュレーションの表示

スタートアップ コンフィギュレーションと実行コンフィギュレーションの比較

インターフェイス コンフィギュレーションの表示

インターフェイス コンフィギュレーションの要約の表示

インターフェイス コンフィギュレーションの詳細の表示

全インターフェイスの要約の表示

全インターフェイスの実行コンフィギュレーションの表示

コンフィギュレーションの保存

コンフィギュレーションの削除

スイッチ名の変更

スイッチ名またはプロンプトをデフォルト(switch#)から別のストリングに変更するには、ここに示す手順を実行します。

始める前に

この手順を開始する前に、次の点を理解または実行しておく必要があります。

コンフィギュレーション モードで CLI にログインします。

手順の詳細

 

コマンド
目的

ステップ 1

switchname

 

n1000v(config)# switchname metro

metro(config)# exit

metro#

スイッチ プロンプトを変更します。

Message of the Day の設定

ユーザがログインする際に端末上のログイン プロンプトの前に表示される Message of the Day(MOTD)のメッセージを設定するには、ここに示す手順を実行します。

始める前に

この手順を開始する前に、次の点を理解または実行しておく必要があります。

コンフィギュレーション モードで CLI にログインします。

バナー メッセージは、最大 40 行、行あたり最大 80 文字です。

デリミタを選ぶ際には、次のガイドラインに従ってください。

メッセージ ストリング中では デリミタ を使用しないでください。

" および % をデリミタとして使用しないでください。

Message of the Day の中では次のトークンを使用できます。

$(hostname) を使用すると、スイッチのホスト名が表示されます。

$(line) を使用すると、vty または tty のラインまたは名前が表示されます。

手順の詳細

 

コマンド
目的

ステップ 1

banner motd [ delimiting-character message delimiting-character ]

 
n1000v(config)# banner motd #April 16, 2008 Welcome to the svs#
n1000v(config)#

 

バナー Message of the Day を設定します。

最大 40 行

行あたり最大 80 文字

# などのデリミタで囲む

複数行にまたがることが可能

トークンを使用可能

ステップ 2

show banner motd

 
n1000v(config)# show banner motd
April 16, 2008 Welcome to the Switch

設定されているバナー メッセージを表示します。

コンフィギュレーションの表示

スイッチのコンフィギュレーションを表示するには、ここで説明する方法を使用します。ここでは、次の内容について説明します。

「ソフトウェアとハードウェアのバージョンの表示」

「実行コンフィギュレーションの表示」

「スタートアップ コンフィギュレーションと実行コンフィギュレーションの比較」

「インターフェイス コンフィギュレーションの表示」

ソフトウェアとハードウェアのバージョンの表示

アップグレードの前後でバージョンを確認するためなど、システム上のソフトウェアとハードウェアのバージョンを表示するには、ここに示すコマンドを使用します。

始める前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

システムで動作しているソフトウェアとハードウェアのバージョンを表示するには、次の手順を実行します。

 

コマンド
説明

ステップ 1

show version

 

n1000v# show version

現在スイッチで動作しているシステム ソフトウェアとハードウェアのバージョンを表示します。

 

 
n1000v(config-acl)# show ver
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2008, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained in this software are
owned by other third parties and used and distributed under
license. Certain components of this software are licensed under
the GNU General Public License (GPL) version 2.0 or the GNU
Lesser General Public License (LGPL) Version 2.1. A copy of each
such license is available at
http://www.opensource.org/licenses/gpl-2.0.php and
http://www.opensource.org/licenses/lgpl-2.1.php
 
Software
loader: version 1.2(2) [last: image booted through mgmt0]
kickstart: version 4.0(1) [build 4.0(1a)S1(0.122)]
system: version 4.0(1) [build 4.0(1a)S1(0.82)] [gdb]
kickstart image file is:
kickstart compile time: 10/19/2008 4:00:00
system image file is: bootflash:/isan.bin
system compile time: 9/2/2008 1:00:00 [10/24/2008 05:12:58]
 
 
Hardware
Cisco Nexus1000V ("Virtual Supervisor Module")
Intel(R) Xeon(R) CPU with 1034780 kB of memory.
Processor Board ID T5056807B1E
 
Device name: n1000v
bootflash: 0 kB
slot0: 0 kB (expansion flash)
 
Kernel uptime is 3 day(s), 15 hour(s), 21 minute(s), 53 second(s)
 
 
plugin
Core Plugin, Ethernet Plugin
 
n1000v#
 

実行コンフィギュレーションの表示

現在システムで動作しているコンフィギュレーションを表示するには、ここに示す方法を使用します。

始める前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

show running-config

 
n1000v# show running-config

現在スイッチで動作しているシステム ソフトウェアとハードウェアのバージョンを表示します。

 

 
n1000v(config-acl)# show running-config
version 4.0(1)
feature port-security
username adminbackup password 5 $1$Oip/C5Ci$oOdx7oJSlBCFpNRmQK4na. role network-operator
username admin password 5 $1$N1mX5tLD$daXpuxlAPcIHoz53PBhy6/ role network-admin
telnet server enable
ssh key rsa 1024 force
kernel core target 0.0.0.0
kernel core limit 1
system default switchport
ip access-list my66
10 permit ip 1.1.1.1/32 1.1.1.2/32
snmp-server user admin network-admin auth md5 0x90f3798f3e894496a11ec42ce2efec9c priv 0x90f3798f3e894496a11ec42ce2efec9c localizedkey
snmp-server enable traps entity fru
snmp-server enable traps license
vrf context management
ip route 0.0.0.0/0 172.28.15.1
switchname srini-cp
vlan 40-43,45-48
vdc srini-cp id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 32
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 32 maximum 256
limit-resource u6route-mem minimum 16 maximum 256
 
interface Ethernet6/2
inherit port-profile uplinkportprofile1
 
interface Ethernet6/3
inherit port-profile uplinkportprofile2
 
interface Ethernet6/4
inherit port-profile uplinportprofile3
 
interface Ethernet7/2
inherit port-profile uplinkportprofile1
 
interface mgmt0
ip address 172.28.15.163/24
 
interface Vethernet1
inherit port-profile vm100
 
interface Vethernet2
inherit port-profile vm100
 
interface Vethernet3
inherit port-profile vm100
 
interface Vethernet4
inherit port-profile vm100
 
interface Vethernet5
 
interface Vethernet6
boot kickstart bootflash:/svs-kickstart-mzg.4.0.1a.S1.0.82.bin sup-1
boot system bootflash:/svs-mzg.4.0.1a.S1.0.82.bin sup-1
boot system bootflash:/isan.bin sup-1
boot kickstart bootflash:/svs-kickstart-mzg.4.0.1a.S1.0.82.bin sup-2
boot system bootflash:/svs-mzg.4.0.1a.S1.0.82.bin sup-2
boot system bootflash:/isan.bin sup-2
ip route 0.0.0.0/0 172.28.15.1
port-profile uplinkportprofile1
capability uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 1,40-43
no shutdown
system vlan 1,40-43
state enabled
port-profile vm100
vmware port-group
switchport mode access
switchport access vlan 43
ip port access-group my100 out
ip port access-group my66 in
no shutdown
state enabled
port-profile uplinkportprofile2
capability uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 45-46
no shutdown
state enabled
port-profile uplinportprofile3
capability uplink
vmware port-group
switchport trunk allowed vlan 47-48
state enabled
port-profile uplinkportprofile3
no shutdown
svs-domain
domain id 163
control vlan 41
packet vlan 42
svs connection VCR5
protocol vmware-vim
remote ip address 172.28.30.83
vmware dvs datacenter-name cisco-DC
connect
 

スタートアップ コンフィギュレーションと実行コンフィギュレーションの比較

スタートアップ コンフィギュレーションと実行コンフィギュレーションの違いを表示するには、ここに示す手順を実行します。

始める前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

show running-config diff

 
n1000v# show running-config diff

現在のシステムのスタートアップ コンフィギュレーションと実行コンフィギュレーションの差違を表示します。

 

 

例 5-1 show running-config diff のコマンド出力

n1000v# show running-config diff
*** Startup-config
--- Running-config
***************
*** 1,7 ****
version 4.0(1)
- system mem-thresholds minor 0 severe 0 critical 0
vrf context management
ip route 0.0.0.0/0 10.78.1.1
switchname DCOS-112-S10
vlan 80,110-111,150,160,170
vdc DCOS-112-S10 id 1
--- 1,6 ----
***************
*** 116,131 ****
ip address 10.78.1.112/24
interface Vethernet49
inherit port-profile vlan160
- interface Vethernet65
- inherit port-profile vlan170
-
interface Vethernet50
inherit port-profile vlan160
interface Vethernet66
inherit port-profile vlan170
ip route 0.0.0.0/0 10.78.1.1
vlan 80-80, 110-110, 111-111, 150-150, 160-160, 170-170
--- 115,130 ----
ip address 10.78.1.112/24
interface Vethernet49
inherit port-profile vlan160
interface Vethernet50
inherit port-profile vlan160
+ interface Vethernet65
+ inherit port-profile vlan170
+
interface Vethernet66
inherit port-profile vlan170
ip route 0.0.0.0/0 10.78.1.1
vlan 80-80, 110-110, 111-111, 150-150, 160-160, 170-170
n1000v#

インターフェイス コンフィギュレーションの表示

ここでは、次の手順について説明します。

「インターフェイス コンフィギュレーションの要約の表示」

「インターフェイス コンフィギュレーションの詳細の表示」

「全インターフェイスの要約の表示」

「全インターフェイスの実行コンフィギュレーションの表示」

インターフェイスの表示の詳細については、『 Cisco Nexus 1000V Interface Configuration Guide, Release 4.0 』を参照してください。

インターフェイス コンフィギュレーションの要約の表示

インターフェイス コンフィギュレーションの要約を表示するには、ここに示す手順を実行します。

始める前に

この手順を実行する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

システム上のインターフェイス コンフィギュレーションの要約を表示するには、次の手順を実行します。

 

コマンド
説明

ステップ 1

show interface {type} {name} brief

指定したインターフェイス コンフィギュレーションに関する要約情報を表示します。

 
n1000v# show interface mgmt 0 brief
 
--------------------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
--------------------------------------------------------------------------------
mgmt0 -- up 10.78.1.63 1000 1500
n1000v#
 

インターフェイス コンフィギュレーションの詳細の表示

インターフェイス コンフィギュレーションの詳細を表示するには、ここに示す手順を実行します。

始める前に

ここに示すコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

システム上の特定のインターフェイス コンフィギュレーションの詳細を表示するには、次の手順を実行します。

 

コマンド
説明

ステップ 1

show interface {type} {name}

指定したインターフェイス コンフィギュレーションに関する詳細を表示します。

 

 
n1000v# show interface mgmt 0
mgmt0 is up
Hardware is GigabitEthernet, address is 0000.0000.0000 (bia 0050.5681.5578)
Internet Address is 10.78.1.63/24
MTU 1500 bytes, BW 0 Kbit, DLY 0 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
full-duplex, 1000 Mb/s
Beacon is turned off
Auto-Negotiation is turned on
Input flow-control is off, output flow-control is off
59914 packets input, 10411045 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun, 0 fifo
6317 packets output, 1390631 bytes
0 underrun, 0 output errors, 0 collisions
0 fifo, 0 carrier errors
 
n1000v#

全インターフェイスの要約の表示

システム上で設定されているすべてのインターフェイスの要約を表示するには、ここに示す手順を実行します。

始める前に

この手順を実行する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

show interface brief

システム上の全インターフェイス コンフィギュレーションの要約を表示します。

 
n1000v# show interface brief
 
--------------------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
--------------------------------------------------------------------------------
mgmt0 -- up 10.78.1.63 1000 1500
 
--------------------------------------------------------------------------------
Ethernet VLAN Type Mode Status Reason Speed Port
Interface Ch #
--------------------------------------------------------------------------------
Eth3/2 1 eth trunk up none a-1000(D) --
Eth3/6 150 eth trunk up none a-1000(D) --
Eth6/2 1 eth trunk up none a-1000(D) --
 
--------------------------------------------------------------------------------
Interface VLAN Type Mode Status Reason MTU
--------------------------------------------------------------------------------
Veth81 630 virt access up none 1500
Veth82 630 virt access up none 1500
Veth224 631 virt access up none 1500
Veth225 1 virt access nonPcpt nonParticipating 1500
n1000v#
 

全インターフェイスの実行コンフィギュレーションの表示

システム上の全インターフェイスの実行コンフィギュレーションを表示するには、ここに示す手順を実行します。

始める前に

この手順を実行する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

コマンド show running-config interface の出力は、コマンド show interface の出力と異なります。

手順の詳細

 

コマンド
説明

ステップ 1

show running-config interface

システム上の全インターフェイスの実行コンフィギュレーションを表示します。

 
n1000v# show running-config interface
version 4.0(1)
 
interface Ethernet3/2
switchport
inherit port-profile sftrunk
 
interface Ethernet3/6
switchport
inherit port-profile vmuplink
 
interface Ethernet6/2
switchport
inherit port-profile alluplink
 
interface mgmt0
ip address 10.78.1.63/24
 
interface Vethernet81
inherit port-profile vm630
 
interface Vethernet82
inherit port-profile vm630
 
interface Vethernet224
inherit port-profile vm631
 
interface Vethernet225
 
n1000v#
 

コンフィギュレーションの保存

実行コンフィギュレーションをスタートアップ コンフィギュレーションに保存するには、ここに示す手順を実行します。これにより、コンフィギュレーション ファイルに変更内容が保存され、次回システムを起動したときに有効になります。

始める前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。

任意のコマンド モードで CLI にログインします。

手順の詳細

 

コマンド
説明

ステップ 1

copy running-config startup-config

新しいコンフィギュレーションを不揮発性ストレージに保存します。これにより、実行コンフィギュレーションとスタートアップ コンフィギュレーションが同じになります。

 
n1000v(config)# copy run start
[########################################] 100%
n1000v(config)#

コンフィギュレーションの削除

スタートアップ コンフィギュレーションを削除するには、ここに示す手順を実行します。

始める前に

このコマンドを使用する前に、次の点を理解または実行しておく必要があります。


注意 write erase コマンドを実行すると、ローダ機能を除き、スタートアップ コンフィギュレーション全体が削除されます。

CLI にログインします。

このコマンドでは次のパラメータが使用されます。

boot:ブート変数と mgmt0 IP コンフィギュレーションを削除します。

debug:デバッグ コンフィギュレーションを削除します。

手順の詳細

 

コマンド
説明

ステップ 1

write erase [boot | debug]

既存のスタートアップ コンフィギュレーションが完全に削除され、すべての設定が工場出荷時のデフォルトに戻ります。

実行コンフィギュレーションは影響を受けません。